
Advantech Studio
Quick Start Manual



Advantech Studio
Quick Start Manual



Initial Setup
The WebOIT offers an easy setup feature: It takes three easy steps for your
initial setup before use. Take out the Advantech hardware device from it’s
package and follow the steps below for initial setup:

Step 1.Connect the power cord to the Advantech hardware device and plug
the other end of the cord into the power outlet.

Step 2.Turn the system power on for the first boot.

Step 3.Assign a static IP address to your WebLink/WebOIT and use Ad-
vantech Studio Development to design your application.

Please refer to the hardware specific User’s Manual for detailed information
about your Advantech hardware device. Advantech Studio Development
software and eAutomation Quick Start Guide are located on the Advantech
eAutomation CD along with the Advantech Studio Tutorial and other docu-
mentation.
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Copyright Information

Proprietary Notice

The manual and software contain confidential information that represents
trade secrets of Advantech and may not be copied or disclosed except as
provided in the license with Advantech. The information in this manual is
subject to change without notice and should not be construed as a commit-
ment by Advantech Co., Ltd. Advantech assumes no responsibility for any
errors that may be in this document.

©1997-2000, Advantech Co., LTD. All Rights Reserved. Version 1.0 - 10.2000

Trademarks

Advantech® is a registered trademark of Advantech, Co., Ltd.

All other brand or product names are trademarks or registered trademarks of
their respective holders. Published in Taiwan R.O.C.

Advantech Co., LTD.
FL.4, No.108-3, Ming-Chuan Rd.,
Shing Tien City, Taipei, Taiwan R.O.C.
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For more information on this and other Advantech products, please visit
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For technical support and service, please visit our support website at:
http://www.advantech.com/support
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Introduction
Advantech eAutomation products offer powerful solutions to meet the needs
of the industrial automation market. eAutomation family products offer Web-
enabled business-to-device connectivity, XML data format support for easy
integration with the enterprise, allow remote management and update of all
stations, Internet access to the real-time data, alarms, trends, reports and
recipies using just an Internet browser, email message notification.

Advantech WebLink is designed to provide enterprise connectivity with
your plant floor systems and remote locations. WebLink can be configured to
dial-up using a serial modem when network connection is not available. We-
bLink is an excellent solution for remote monitoring and legacy device con-
nectivity.

Advantech WebOIT is an all-in-one powerful and flexible solution for your
operator panel needs. WebOIT comes with the choice of Advantech Auto-
mation 6" or 10" Color Touch Panel with pre-installed Windows CE operating
system, integrated web server and Advantech Studio runtime HMI/SCADA
software.

On Advantech eAutomation CD you will find:

- Advantech Studio HMI/SCADA Software

- Advantech Studio Tutorial

- Advantech eAutomation Quick Start Guide

Advantech eAutomation Quick Start Guide is intended to assist an applica-
tion engineer with getting a custom application for Advantech eAutomation
family products up and running by providing a step-by-step example and
useful hints. For detailed information about Advantech Studio please use the
Advantech Studio Technical Reference and User’s Manual accessible from
the “Help” menu.

If you have not done so, please install Advantech Studio software on your
Windows NT/98/2000 development PC. Advantech Studio is provided on the
eAutomation CD along with this Quick Start Guide.
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Please assign a static IP address and modify network settings on your Ad-
vantech WebLink/WebOIT target device. While designing a custom applica-
tion always use the IP address assigned to your target device. </big>

Advantech WebLink and WebOIT are featuring an embedded web server
technology for easy access to the real-time data over the Internet. To provide
such functionality, it is important to have the address of the WebLink/We-
bOIT static. In other words, the IP address of the device must remain un-
changed. The user must obtain a static IP address and the network settings
from the network administrator prior to modifying settings on the Advantech
device. By default the Advantech WebLink/WebOIT is preconfigured to obtain
their IP address via DHCP. Please consult your network administrator if you
want to use an obtained IP address as the static IP address of the Advantech
device.

Please note: If you purchased Advantech WebLink, please use an external
monitor and keyboard to configure your device.

How to ...

... find out the IP address of the Advantech WebLink/WebOIT device?

Boot your Advantech WebLink/WebOIT device. Click on the “Start” button,
“Run...” and type “ipconfig” in the “Run” window. The “Ipconfig” window
will display the HostName and Host address, which is an IP address of your
device. Click “OK” to dismiss the window.

... modify an IP address?

Boot your Advantech WebLink or WebOIT CE device. Follow the steps
below:

- Click on the “Start” menu, “Settings”, “Control Panel”.

- Double click on the “Network” icon. In the “Network Configuration” win-
dow click on “Adapters” tab, click on “Properties” button.

- In the “Ethernet Card Settings” window check the “Specify an IP address”
and enter the appropriate settings for “IP addres”, “Subnet Mask”, “De-
fault Gateway”.

- Click on the “Name Servers” tab and enter the DNS settings.

- Click “OK” in the upper right corner of the window.
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- Click “OK” on the “Adapters” window.

- Click “OK” on the “Network Configuration” window.

- Click on the “Start” button, “Run...” and type “regsave” in the “Run”
window, click “OK” . Wait until the “regsave” will execute and “Run”
window is closed.

- Reboot your Advantech WebLink/WebOIT CE device.

Steps in volved in WebLink/W ebOIT setup pr ocess:
Step 1.Create a new project and design display on Windows NT develop-

ment PC

Step 2.Install and configure communication driver on Windows NT devel-
opment PC

Step 3.Test and debug application on Windows NT development PC

Step 4.Create HTML file

Step 5.Download and test application on Advantech WebLink/WebOIT panel

Step 6.Run Application
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Step 1.Create a new project and design display on Windows NT develop-
ment PC

Launch Advantech Studio from the Start menu as shown in Figure 1-1.

Figure 1-1

Go to the “File” menu, select “New” as shown in Figure 1-2.

Figure 1-2

In the “New” dialog box, select “Project” tab and fill out your application
name, select location, in the “Target Platform” field select “WebOIT for
WinCE” or “WebLink” target platform as shown in Figure 1-3. Click “OK” to
close the window.

Figure 1-3
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In the “Project Wizard” window check resolution 640x480, “Empty Applica-
tion” as shown in Figure 1-4 and click “OK”.

Figure 1-4

To modify project settings go to the “Project” menu and select “Settings” as
shown in Figure 1-5.

Figure 1-5

In the “Project Settings” window select “Web” tab and type an IP address
of the Data Server IP address, URL as shown in Figure 1-6 and click “OK”.
It is important to have URL format as shown:
http://ip_address/project_folder/web/

The Data Server IP address is an IP address of the computer that is connect-
ed to the PLC and where the actual tag values are coming from. It is possible
to separate Data Server from the Web Server and have the web pages reside
on another computer. Advantech WebLink/WebOIT use the embedded web
server technology so your Data Server and web server reside on the same
device and have the same IP address.
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Figure 1-6

To create a new display right-click on “Screens”, click “Insert” as shown in
Figure 1-7.

Figure 1-7

Empty display window will appear and your screen should look as shown in
Figure 1-8.

Figure 1-8
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Click on the “Ellipse” icon pointed by the arrow on the right vertical toolbar
shown in Figure 1.8 to create a light indicator as shown in Figure 1-9 . Right-
click on the circle to bring up its “Properties”.

Figure 1-9

Click on the “Color” icon pointed by the arrow on the right vertical toolbar
as shown in Figure 1-10

Figure 1-10

Now the “Object Properties” window looks as shown in Figure 1-11.

Figure 1-11
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Click on the RED color square and select DARK BLUE color as shown in
Figure 1-12.

Figure 1-12

Click on the GREEN square and select LIGHT BLUE color as shown in
Figure 1-13.

Figure 1-13

Fill out “Tag/Expression” field with tag name “BLUE” as shown in
Figure 1-14 and hit “Enter” key.

Figure 1-14
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Dialog box will appear as shown in Figure 1-15. Click “Yes”.

Figure 1-15

Fill out tag properties by modifying type to “Boolean” as shown in
Figure 1-16 and click “OK”.

Figure 1-16

Select “Ellipse” from the pull-down menu of the “Properties” window as
shown in Figure 1-17.

Figure 1-17
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Modify “Fill Color” to DARK BLUE as shown in Figure 1-18.

Figure 1-18

Now your display should look as shown in Figure 1-19. Close “Properties”
window.

Figure 1-19

To create a push-button click on the “Button” icon pointed by the arrow on
the right vertical toolbar as shown in Figure 1-20.

Figure 1-20
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Paste a push-button of desired size on display as shown in Figure 1-21

Figure 1-21

Assign caption “BLUE” to the button as shown in Figure 1-22.

Figure 1-22

Click on the “Command” icon pointed by the arrow on the right vertical
toolbar as shown in Figure 1-23.

Figure 1-23
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Type tag “HMI_BLUE” in the “Tag” field as shown in Figure 1-24. Click
“Yes” in the question dialog box.

Figure 1-24

Modify type of the tag to “Boolean” as shown in Figure 1-25

Figure 1-25

In the “Expression” field type “NOT HMI_BLUE” as shown in Figure 1-26.

Figure 1-26
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Repeat the procedure to create light indicators for GREEN, YELLOW and
RED tags starting from Figure 1-8.

Repeat procedure to create push-buttons for HMI_GREEN, HMI_YELLOW
and HMI_RED tags starting from Figure 1-20.

Your display should look as shown in Figure 1-27. Select All circles and click
on the “Evenly space vertically” icon pointed by the arrow on the right
vertical toolbar as shown in Figure 1-27. Select all the push-buttons and
click “Evenly space vertically”.

Figure 1-27

Select all the circles and click on the “Align Left” icon pointed by the arrow
on the right vertical toolbar as shown in Figure 1-28. Select all the push-
buttons and click “Align Left”.

Figure 1-28
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Go to the “File” menu, “Save As...” and save your display as “Main.scr” as
shown in Figure 1-29.

Figure 1-29
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Step 2. Install and configure communication
driver on Windo ws NT de velopment PC

In this example we used the Allen Bradley SLC5/05 preconfigured to commu-
nicate via the DF1 serial protocol with four digital inputs and four digital
outputs. For detailed information on driver configuration please refer to the
driver specific documentation located in the \Program Files\Advantech
Studio\Drv\ directory.

Click on the “Comm” tab in the project environment, right-click on “Drivers”
and select “Add/Remove Drivers” as shown in Figure 2-1.

Figure 2-1

Highlight ABKE Allen Bradley DF1 serial driver as shown in Figure 2-2 and
click “Select”.

Figure 2-2
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Your display should look as shown in Figure 2-3. Click “OK” to close the
window.

Figure 2-3

Right click on “ABKE” under “Drivers” and select “Settings” as shown in
as shown in Figure 2-4.

Figure 2-4

Fill out ABKE communication parameters as shown in Figure 2-5. Make sure
that these parameters matches with the PLC parameters.

Figure 2-5
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Right click on “ABKE” under “Drivers” and select “Insert” as shown in
Figure 2-6.

Figure 2-6

Fill out driver sheet as shown in Figure 2-7.

Figure 2-7

Insert and fill out another driver sheet as shown in Figure 2-8.

Figure 2-8

Save All.
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Step 3. Test and deb ug application on Windo ws
NT development PC

Connect Allen Bradley PLC via RS232 serial cable to your Windows NT
development PC COM1.

Go to the “Project” menu, select “Settings”, “Runtime Desktop” tab and
modify “Startup Screen” to “Main” as shown in Figure 3-1. Click “OK” to
close the window.

Figure 3-1

Go to the Project menu and select “Status” as shown in Figure 3-2.

Figure 3-2

Ensure that your “Project status” window has the following Execution Tasks
Startup Automatically Driver Runtime, TCP/IP Client Runtime, TCP/IP Serv-
er as shown in Figure 3-3 . Please modify if necessary by clicking on the
“Startup” button and changing to “Automatic”. Click “OK” to close the
window.
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Figure 3-3

Go to the “Project” menu and select “Run Application” as shown in
Figure 3-4.

Figure 3-4

Your screen should look as shown in Figure 3-5.

Figure 3-5
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After ensuring that your application functions correctly, go to the “Project”
menu and select “Stop Application” as shown in Figure 3-6.

Figure 3-6

Make appropriate changes if necessary.

Save All.
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Step 4. Create HTML file
To create HTML file, go to the “File” menu and select “Save As HTML” as
shown in Figure 4-1. Save your application as “Main.html”. If you have
multiple screens, save each screen as HTML with corresponding file name.

Figure 4-1

To test your HTML page, double click Main.html under “Web Pages” as
shown in Figure 4-2. Note: Before double clicking on the HTML file, make
sure that the application is running, and that the Program Settings are cor-
rectly configured to your development station (Data Server IP Address and
URL).

Figure 4-2
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Step 5. Download and test application on
Advantec h WebLink/W ebOIT panel

Boot the Advantech WebLink/WebOIT panel. CEWebServer and
Advantech communication utility CEServer.exe will start automatically.

Before starting the application download procedure, configure the
“Program Settings” (Data Server IP Address and URL) according with the
CE device characteristics. After that, go to the “Tools” menu and click on
“Verify Application”. On the Windows NT development PC go to the
“Project”, select “Execution Environment” as shown in Figure 5-1.

Figure 5-1

In the “Execution Environment” window fill out IP address of the target CE
device as shown in Figure 5-2 and click “Connect”.

Figure 5-2

Your “Execution Environment” window should look as shown in Figure 5-3
with status reporting “Connected to CEVIEW” .
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Figure 5-3

Select “Application” tab in the “Execution Environment” window as shown
in Figure 5-4 and click on “Send To Target”.

Figure 5-4

Your display should look as shown in Figure 5-5 while downloading applica-
tion to the target CE device.

Figure 5-5

When done, “Execution Environment” window should look as shown in
Figure 5-6 with status reporting “Application was updated with success”.
Connect Allen Bradley PLC via RS232 serial cable to the COM1 on the target
CE device. Click “Run” button in the “Execution Environment” window on
your Windows NT development PC to start application on the Advantech
WebLink/WebOIT panel.
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Figure 5-6

Status should change to “Application was started” is shown in Figure 5-7.

Figure 5-7

“Server”. Go to Tools, Verify application. Save all.

Should you still have difficulty please contact Advantech support.

Back to the top

Thank you

Advantech eAutomation Product Team
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Step 6. Run Application

On desktop PC:
Open Internet Explorer 5.0 and type URL http://216.68.246.112/WebAB/web/
Main.html as shown in Figure 6-1.

Warning!  To browse ActiveX controls, IE security must be set to LOW.

Figure 6-1

Basic troubleshooting hints:
1. Make sure that the application itself is functioning properly.

2. Stop application. Save all the screens as HTML pages (use the Save As
HTML under File menu ).

3. Open Project Settings, under the Web tab and check IP address of your
server, enter the URL as http://ip_address/project_folder/web/. The last
forward slash is important.

4. Under Tools menu, verify application.

5. Restart your application.

If your Internet Explorer 5.0 still can’t find the page then make sure you can
ping the IP address of the target device.

If you can get the page but only see a large grey rectangle your system
probably cannot install and register ISSymbol.ocx in your system32 file fold-
er. Go to command prompt, change directory to system32, and run
“regsvr32.exe ISSymbol.ocx” . System should report success.
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If you can see graphics but no tag values then you need to go to the tag
database in “Database” tab of the project, double click on Application tags,
Datasheet view and change the setting in the last column from “Local” to
“Server”. Go to Tools, Verify application. Save all.

Should you still have difficulty please contact Advantech support.

Thank you

Advantech eAutomation Product Team
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