Advantech.Adam

Advantech AdamApax .NET Class Library Help
Advantech.Adam Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | Adam2000 |
Public class | Adam2000Config |
Public class | Adam4000Config | The ADAM-4000 configuration class.
Public class | Adam5000Config | The ADAM-5000 configuration class.
Public class | AdamBase | ADAM ASCII base class library for ADAM series. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | AdamCom | ADAM serial communication class library for ADAM series.
Public class | AdamCOMConfig | The ADAM COM configuration class.
Public class | AdamControl | AdamControl is the ADAM controller class.
Public class | AdamEvent | Class AdamEvent for event trigger
Public class | AdamEventServerThread |
Public class | AdamGCL_IOMsg | Adam GCL IO message class
Public class | AdamInformation | The ADAM class to stroe all information about a module
Public class | AdamMacComparer | The class is used for comparing the MAC address for ADAM.
Public class | AdamP2P | Adam P2P class
Public class | AdamSocket | ADAM ethernet communication class library for ADAM series.
Public class | AdamStreamRec | Class AdamStreamRec for event trigger
Public class | AdamStreamRecList | Class AdamStreamRecList for event trigger.
Public class | AdamWirelessAP | ADAM-6000W AP class
Public class | Alarm |
Public class | AnalogInput | AnalogInput class for ADAM series.
Public class | AnalogOutput |
Public class | Apax5000Config | ApaxSlotInfo Class
Public class | Configuration | Configuration class for ADAM series running on ASCII command.
Public class | Counter |
Public class | DigitalInput | DigitalInput class for ADAM series.
Public class | DigitalOutput | DigitalOutput class for ADAM series.
Public class | GCL_IOMsg_Config | Peer to Peer Configuration Class
Public class | Modbus | MODBUS class library.
Public class | P2P_Config | Peer to Peer Configuration Class
Public class | PID |
Public class | SelfMarshalledStruct | This class implements base functionality for a bytearray-based structure

Delegates

 | Delegate | Description
Public delegate | GetDataCallback | Delegate to receive TreeView selected node changed events.
Public delegate | GetP2PDataCallback | Delegate to receive TreeView selected node changed events.

Enumerations

 | Enumeration | Description
Public enumeration | _AlarmReason | The alarm resason code used for APAX Controller.
Public enumeration | _CurrentDeviceState | The current device state used for APAX Controller.
Public enumeration | _DeviceType | The device type used for APAX Controller.
Public enumeration | _FunctionType | The function type code used for APAX Controller.
Public enumeration | _HardwareIOType | The hardware type used for APAX Controller.
Public enumeration | _SlaveGeneralRespCode | The slave gereral respond code used for APAX Controller.
Public enumeration | _SlotStatus | The slot status used for APAX Controller.
Public enumeration | Adam_AIAlarmMode | The AI alarm mode
Public enumeration | Adam_AiStatus_HighAddress | Adam AI Status At High Address
Public enumeration | Adam_AiStatus_LowAddress | Adam AI Status At Low Address
Public enumeration | Adam_AoStatus_HighAddress | Adam AO Status At High Address
Public enumeration | Adam_AoStatus_LowAddress | Adam AO Status At Low Address
Public enumeration | Adam_Baudrate | The baudrate for ADAM-4000, ADAM-5000
Public enumeration | Adam_Checksum | The checksum status.
Public enumeration | Adam_DIMode | DI mode
Public enumeration | Adam_DOMode | DI mode
Public enumeration | ADAM_EVENT | Adam event parameters
Public enumeration | Adam_EventType | The event monitoring type used in event trigger
Public enumeration | Adam_LocalAlarmType | The local alarm type for ADAM-5081
Public enumeration | Adam_Protocol | The protocol for ADAM
Public enumeration | Adam_SlewRate | Adam slew rate
Public enumeration | Adam_Temperature | The temperature setting
NestedPublic enumeration | Adam2000.CC2530DownloadMode | CC2530 download mode select
NestedPublic enumeration | Adam2000.ChannelStatus | Command Code enumeration
NestedPublic enumeration | Adam2000.CmdCode | Command Code enumeration
NestedPublic enumeration | Adam2000.MessageType | MessageType
NestedPublic enumeration | Adam2000.SerialPortCfg | Serial port configuration enumeration
Public enumeration | Adam2000_Integration | The integration code for ADAM-2000
Public enumeration | Adam2000Type | The ADAM 2000 module type
Public enumeration | Adam2kChannelType | Sensor module channel type
Public enumeration | Adam4000_ChannelStatus | The channel status for analog input.
Public enumeration | Adam4000_CounterAlarmMode | The counter alarm mode for ADAM-4000
Public enumeration | Adam4000_DataFormat | The data format for analog input.
Public enumeration | Adam4000_FreqGateTime | The frequency gate time for ADAM-4080, ADAM-4080D
Public enumeration | Adam4000_Integration | The integration code for ADAM-4000
Public enumeration | Adam4000Type | The ADAM 4000 module type
Public enumeration | Adam4011_InputRange | Adam-4011 input range code
Public enumeration | Adam4012_InputRange | Adam-4012 input range code
Public enumeration | Adam4013_InputRange | Adam-4013 input range code
Public enumeration | Adam4015_InputRange | Adam-4015 input range code
Public enumeration | Adam4015T_InputRange | Adam-4015T input range code
Public enumeration | Adam4016_InputRange | Adam-4016 input range code
Public enumeration | Adam4017_InputRange | Adam-4017 input range code
Public enumeration | Adam4017P_InputRange | Adam-4017P input range code
Public enumeration | Adam4018_InputRange | Adam-4018 input range code
Public enumeration | Adam4018M_InputRange | Adam-4018M input range code
Public enumeration | Adam4018P_InputRange | Adam-4018P input range code
Public enumeration | Adam4019_InputRange | Adam-4019 input range code
Public enumeration | Adam4019P_InputRange | Adam-4019P input range code
Public enumeration | Adam4021_OutputRange | Adam-4021 Output range
Public enumeration | Adam4022T_InputRange | Adam-4022T input range code
Public enumeration | Adam4022T_OutputRange | Adam-4022T Output range
Public enumeration | Adam4024_OutputRange | Adam-4024 Output range
Public enumeration | Adam4080_CounterMode | Adam4080 counter mode
Public enumeration | Adam4080_GateMode | Adam4080 gate mode
Public enumeration | Adam4080_InputSignalMode | Adam4080 input signal mode
Public enumeration | Adam4080_Level | Adam4080 level
Public enumeration | Adam4080D_LedSource | Adam4080D LED source
Public enumeration | Adam4100_BurnoutMap | The burnout mapping.
Public enumeration | Adam4100_HighSpeed | The high speed mode status.
Public enumeration | Adam4100_Integration | The integration code for ADAM-4100
Public enumeration | Adam4117_InputRange | Adam-4117 input range code
Public enumeration | Adam4118_InputRange | Adam-4118 input range code
Public enumeration | Adam5000_ChannelStatus | The channel status for analog input.
Public enumeration | Adam5000_CounterAlarmMode | The counter alarm mode for ADAM-5000
Public enumeration | Adam5000_DataFormat | The data format for analog input.
Public enumeration | Adam5000_Integration | The integration code for ADAM-5000
Public enumeration | Adam5000TCP_Integration | The integration code for ADAM-5000TCP
Public enumeration | Adam5000Type | The ADAM 5000 module type
Public enumeration | Adam5013_InputRange | Adam-5013 input range code
Public enumeration | Adam5017_InputRange | Adam-5017 input range code
Public enumeration | Adam5017H_InputRange | Adam-5017H input range code
Public enumeration | Adam5017P_InputRange | Adam-5017P input range code
Public enumeration | Adam5017S_InputRange | Adam-5017S (ODM) input range code
Public enumeration | Adam5017UH_BurnoutMap | The burnout mapping.
Public enumeration | Adam5017UH_InputRange | Adam-5017UH input range code
Public enumeration | Adam5018_InputRange | Adam-5018 input range code
Public enumeration | Adam5018P_InputRange | Adam-5018P input range code
Public enumeration | Adam5024_OutputRange | Adam-5024 Output range
Public enumeration | Adam5080_CounterMode | Adam5080 counter mode
Public enumeration | Adam5081_CounterMode | Adam5081 counter mode
Public enumeration | Adam6000_Integration | The integration code for ADAM-6000
Public enumeration | Adam6000_RangeFormat | The range format (data type) code for ADAM-6000
Public enumeration | Adam6000_SlewRate | Adam 6000 slew rate
Public enumeration | Adam6000Type | The ADAM 6000 module type
Public enumeration | Adam6015_InputRange | Adam-6015 input range code
Public enumeration | Adam6017_InputRange | Adam-6017 input range code
Public enumeration | Adam6018_InputRange | Adam-6018 input range code
Public enumeration | Adam6022_InputRange | Adam-6022 input range code
Public enumeration | Adam6022_OutputRange | Adam-6022 Output range
Public enumeration | Adam6024_InputRange | Adam-6024 input range code
Public enumeration | Adam6024_OutputRange | Adam-6024 Output range
Public enumeration | Adam6051_CounterMode | Adam6051 counter mode
Public enumeration | AdamInfoModuleStatus | Module status in Adam information Class
Public enumeration | AdamInfoType | The type for getting Adam information by UDP broadcast
Public enumeration | AdamType | The ADAM module type
Public enumeration | AdamUnknown_DataFormat | The data format for analog input.
Public enumeration | AdamUnknown_InputRange | Newly unknown Adam module input range code
Public enumeration | Apax_Integration | The integration code for APAX
Public enumeration | Apax5000_ChannelStatus | The channel status for analog input.
Public enumeration | Apax5000Type | The APAX 5000 module type
Public enumeration | Apax5080_CounterMode | Adam5081 counter mode
Public enumeration | ApaxUnknown_InputRange | Newly unknown Apax module input range code
Public enumeration | DeviceConnectionStatus | Device Connection Status
Public enumeration | DI_OperationMode | DI Operation Mode
Public enumeration | EVENT_STATUS | Event status
Public enumeration | EVENT_TYPE | Event type
Public enumeration | ModuleControlCmdType | The type for setting Module Control Command by UDP broadcast
Public enumeration | P2P_FunctionCode | P2P: function code
Public enumeration | P2P_InfoIdx | P2P: data format start index
Public enumeration | P2P_Mode | P2P mode: Basic or Advanced
Public enumeration | PID_Addr | The PID value address
Public enumeration | PID_Loop | The PID loop.

Syntax based on .NET Framework version 2.0.
Documentation version 8.2.8.0.

Send comments on this topic.

Copyright (C) Advantech 2015


_AlarmReason Enumeration

_AlarmReason Enumeration
See Also Example
[image]

The alarm resason code used for APAX Controller.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum _AlarmReason As Byte
C#
public enum _AlarmReason : byte
C++
public enum class _AlarmReason : char
J#
public enum _AlarmReason byte
JScript
public enum _AlarmReason :

Members

Member Name | Description
ConditionOccur | Alarm condition occur.
DataChanged | Data changed occur.
BurnOut | Burn-out occur
BatteryLow | Battery low.
HardwareAbnormal | Hardware abnormal.

See Also

Advantech.Adam Namespace


_CurrentDeviceState Enumeration

_CurrentDeviceState Enumeration
[image]

The current device state used for APAX Controller.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum _CurrentDeviceState As
C#
public enum _CurrentDeviceState : ushort
C++
public enum class _CurrentDeviceState : unsigned short
J#
public enum _CurrentDeviceState ushort
JScript
public enum _CurrentDeviceState :

Members

Member Name | Description
NoError | No error code
Busy | Busy code
SoftwareError | Software error code
HardwareError | Hardware error code

See Also

Advantech.Adam Namespace


_DeviceType Enumeration

_DeviceType Enumeration
[image]

The device type used for APAX Controller.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum _DeviceType As
C#
public enum _DeviceType : ushort
C++
public enum class _DeviceType : unsigned short
J#
public enum _DeviceType ushort
JScript
public enum _DeviceType :

Members

Member Name | Description
PlatForm | Platform device type.
DigitalInput | Digital input device type.
DigitalOutput | Digital output device type.
AnalogInput | Analog input device type.
AnalogOutput | Analog output device type.
HybridDevice | Hybrid device type.
Counter | Counter device type.
Motion | Motion device type.
Storage | Storage device type.
Display | Display device type.
PID | PID device type.
ComPort | COM port device type.
Ethernet | Ethernet device type.
PWM | PWM device type.
DSP | DSP type.
DownloadMode_PWM | Download mode PWM type.
DownloadMode_DIO | Download mode DIO type.
DownloadMode_AIO | Download mode AIO type.
DownloadMode_DSP | Download mode DSP type.
DownloadMode_Counter | Download mode counter type.

See Also

Advantech.Adam Namespace


_FunctionType Enumeration

_FunctionType Enumeration
[image]

The function type code used for APAX Controller.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum _FunctionType As Byte
C#
public enum _FunctionType : byte
C++
public enum class _FunctionType : char
J#
public enum _FunctionType byte
JScript
public enum _FunctionType :

Members

Member Name | Description
Non | Non.
BurnOut | Burn-out.
Filter | For DI:DI filter; AI:60Hz/50Hz.
SampleRate | Sampling rate.

See Also

Advantech.Adam Namespace


_HardwareIOType Enumeration

_HardwareIOType Enumeration
[image]

The hardware type used for APAX Controller.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum _HardwareIOType As Byte
C#
public enum _HardwareIOType : byte
C++
public enum class _HardwareIOType : char
J#
public enum _HardwareIOType byte
JScript
public enum _HardwareIOType :

Members

Member Name | Description
None | None defined
DI | Digital input
DO | Digital output
AI | Analog input
AO | Analog output
CNT | Counter
Motion | Motion
Relay | Relay
PWM | PWM
COM_Port | COM Port

See Also

Advantech.Adam Namespace


_SlaveGeneralRespCode Enumeration

_SlaveGeneralRespCode Enumeration
[image]

The slave gereral respond code used for APAX Controller.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum _SlaveGeneralRespCode As
C#
public enum _SlaveGeneralRespCode : ushort
C++
public enum class _SlaveGeneralRespCode : unsigned short
J#
public enum _SlaveGeneralRespCode ushort
JScript
public enum _SlaveGeneralRespCode :

Members

Member Name | Description
Reserved1 | Reserved1.
MasterWriteDataOK | Master write module data OK.
MasterNotExist | Module doesn't exist.
Reserved2 | Reserved2
MasterWriteDataFailed | Master write module data failed.

See Also

Advantech.Adam Namespace


_SlotStatus Enumeration

_SlotStatus Enumeration
[image]

The slot status used for APAX Controller.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum _SlotStatus As Byte
C#
public enum _SlotStatus : byte
C++
public enum class _SlotStatus : char
J#
public enum _SlotStatus byte
JScript
public enum _SlotStatus :

Members

Member Name | Description
Reserved | Reserved
SlotHasModule | Slot has module
SlotEmpty | Slot empty

See Also

Advantech.Adam Namespace


Adam_AIAlarmMode Enumeration

Adam_AIAlarmMode Enumeration
[image]

The AI alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_AIAlarmMode As Byte
C#
public enum Adam_AIAlarmMode : byte
C++
public enum class Adam_AIAlarmMode : char
J#
public enum Adam_AIAlarmMode byte
JScript
public enum Adam_AIAlarmMode :

Members

Member Name | Description
Disable | Disable, 'D'
Latch | Latch, 'L'
Momentary | Momentary, 'M'
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam_AiStatus_HighAddress Enumeration

Adam_AiStatus_HighAddress Enumeration
[image]

Adam AI Status At High Address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_AiStatus_HighAddress
C#
public enum Adam_AiStatus_HighAddress
C++
public enum class Adam_AiStatus_HighAddress
J#
public enum Adam_AiStatus_HighAddress
JScript
public enum Adam_AiStatus_HighAddress

Members

Member Name | Description
No_Fault_Detected | No fault detected
Di_Triggered_SafetyValue | Di triggered to Safety Value
Di_Triggered_StartupValue | Di triggered to Startup Value

See Also

Advantech.Adam Namespace


Adam_AiStatus_LowAddress Enumeration

Adam_AiStatus_LowAddress Enumeration
[image]

Adam AI Status At Low Address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_AiStatus_LowAddress
C#
public enum Adam_AiStatus_LowAddress
C++
public enum class Adam_AiStatus_LowAddress
J#
public enum Adam_AiStatus_LowAddress
JScript
public enum Adam_AiStatus_LowAddress

Members

Member Name | Description
No_Fault_Detected | No fault detected
FailToProvideAiValueUartTimeout | Fail to provide Ai value (UART timeout)
Over_Range | Over Range
Under_Range | Under Range
Open_Circuit_Burnout | Open Circuit (Burnout)
Zero_Span_CalibrationError | Zero / Span Calibration Error

See Also

Advantech.Adam Namespace


Adam_AoStatus_HighAddress Enumeration

Adam_AoStatus_HighAddress Enumeration
[image]

Adam AO Status At High Address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_AoStatus_HighAddress
C#
public enum Adam_AoStatus_HighAddress
C++
public enum class Adam_AoStatus_HighAddress
J#
public enum Adam_AoStatus_HighAddress
JScript
public enum Adam_AoStatus_HighAddress

Members

Member Name | Description
No_Fault_Detected | No fault detected
Di_Triggered_SafetyValue | Di triggered to Safety Value
Di_Triggered_StartupValue | Di triggered to Startup Value
Ao_Triggered_FailSafetyValue | Ao triggered to Fail Safety Value

See Also

Advantech.Adam Namespace


Adam_AoStatus_LowAddress Enumeration

Adam_AoStatus_LowAddress Enumeration
[image]

Adam AO Status At Low Address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_AoStatus_LowAddress
C#
public enum Adam_AoStatus_LowAddress
C++
public enum class Adam_AoStatus_LowAddress
J#
public enum Adam_AoStatus_LowAddress
JScript
public enum Adam_AoStatus_LowAddress

Members

Member Name | Description
No_Fault_Detected | No fault detected
FailToProvideAoValueUartTimeout | Fail to provide Ao value (UART timeout)
No_Output_Current_CurrentBroken | No Output Current (Current Broken)
Zero_Span_CalibrationError | Zero / Span Calibration Error

See Also

Advantech.Adam Namespace


Adam_Baudrate Enumeration

Adam_Baudrate Enumeration
[image]

The baudrate for ADAM-4000, ADAM-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_Baudrate As Byte
C#
public enum Adam_Baudrate : byte
C++
public enum class Adam_Baudrate : char
J#
public enum Adam_Baudrate byte
JScript
public enum Adam_Baudrate :

Members

Member Name | Description
Baud_1200 | Baudrate 1200
Baud_2400 | Baudrate 2400
Baud_4800 | Baudrate 4800
Baud_9600 | Baudrate 9600
Baud_19200 | Baudrate 19200
Baud_38400 | Baudrate 38400
Baud_57600 | Baudrate 57600
Baud_115200 | Baudrate 115200

See Also

Advantech.Adam Namespace


Adam_Checksum Enumeration

Adam_Checksum Enumeration
[image]

The checksum status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_Checksum As Byte
C#
public enum Adam_Checksum : byte
C++
public enum class Adam_Checksum : char
J#
public enum Adam_Checksum byte
JScript
public enum Adam_Checksum :

Members

Member Name | Description
Disable | Disabled
Enable | Enabled

See Also

Advantech.Adam Namespace


Adam_DIMode Enumeration

Adam_DIMode Enumeration
[image]

DI mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_DIMode As Byte
C#
public enum Adam_DIMode : byte
C++
public enum class Adam_DIMode : char
J#
public enum Adam_DIMode byte
JScript
public enum Adam_DIMode :

Members

Member Name | Description
Di | Normal DI mode
Counter | Counter mode
LowToHighLatch | Low to high latch mode
HighToLowLatch | High to low latch mode
Frequency | Frequency mode
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam_DOMode Enumeration

Adam_DOMode Enumeration
[image]

DI mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_DOMode As Byte
C#
public enum Adam_DOMode : byte
C++
public enum class Adam_DOMode : char
J#
public enum Adam_DOMode byte
JScript
public enum Adam_DOMode :

Members

Member Name | Description
Do | Normal DO mode
PulseOutput | Pulse output mode
LowToHighDelay | Low to high delay mode
HighToLowDelay | High to low delay mode
Unknown | Unknown

See Also

Advantech.Adam Namespace


ADAM_EVENT Enumeration

ADAM_EVENT Enumeration
[image]

Adam event parameters

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum ADAM_EVENT
C#
public enum ADAM_EVENT
C++
public enum class ADAM_EVENT
J#
public enum ADAM_EVENT
JScript
public enum ADAM_EVENT

Members

Member Name | Description
OUT_PORT | Out port
IN_PORT | In port
MAX_CMD | Maximum command
MAX_IP | Maximum IP
RECV_WAIT | Receive waiting time
QUIT_WAIT | Quit waiting time
MOD_WAIT | Mode waiting time
PATTERN_LEN | Pattern length
PATTERN_LEN32 | Pattern length 2
MAX_RETRY | Maximum retry times
MAX_RECV_BUFF_LEN | Maximum received buffer length
MAX_NUM | Maximum number
IsEvenTrigData_DataChange | IsEvenTrigData_DataChange
IsEvenTrigData | IsEvenTrigData

See Also

Advantech.Adam Namespace


Adam_EventType Enumeration

Adam_EventType Enumeration
[image]

The event monitoring type used in event trigger

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_EventType As Byte
C#
public enum Adam_EventType : byte
C++
public enum class Adam_EventType : char
J#
public enum Adam_EventType byte
JScript
public enum Adam_EventType :

Members

Member Name | Description
Dio_OffToOn | DIO Off to On event type
Dio_OnToOff | DIO On to Off event type
Alarm_OffToOn | ALARM Off to On event type
Alarm_OnToOff | ALARM On to Off event type
Unknown | Unknown event type

See Also

Advantech.Adam Namespace


Adam_LocalAlarmType Enumeration

Adam_LocalAlarmType Enumeration
[image]

The local alarm type for ADAM-5081

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_LocalAlarmType As Byte
C#
public enum Adam_LocalAlarmType : byte
C++
public enum class Adam_LocalAlarmType : char
J#
public enum Adam_LocalAlarmType byte
JScript
public enum Adam_LocalAlarmType :

Members

Member Name | Description
Low | Low alarm, 'L'
High | High alarm, 'H'
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam_Protocol Enumeration

Adam_Protocol Enumeration
[image]

The protocol for ADAM

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_Protocol As Byte
C#
public enum Adam_Protocol : byte
C++
public enum class Adam_Protocol : char
J#
public enum Adam_Protocol byte
JScript
public enum Adam_Protocol :

Members

Member Name | Description
Advantech | Advantech ASCII command
Modbus | Modbus command
BACnet | BACnet protocol, only for ADAM-4022T
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam_SlewRate Enumeration

Adam_SlewRate Enumeration
[image]

Adam slew rate

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_SlewRate As Byte
C#
public enum Adam_SlewRate : byte
C++
public enum class Adam_SlewRate : char
J#
public enum Adam_SlewRate byte
JScript
public enum Adam_SlewRate :

Members

Member Name | Description
Immediate | Immediate change
V_p0625_mA_p125 | 0.0625 V/sec, 0.125 mA/sec
V_p125_mA_p250 | 0.125 V/sec, 0.250 mA/sec
V_p250_mA_p5 | 0.250 V/sec, 0.500 mA/sec
V_p5_mA_1 | 0.500 V/sec, 1 mA/sec
V_1_mA_2 | 1 V/sec, 2 mA/sec
V_2_mA_4 | 2 V/sec, 4 mA/sec
V_4_mA_8 | 4 V/sec, 8 mA/sec
V_8_mA_16 | 8 V/sec, 16 mA/sec
V_16_mA_32 | 16 V/sec, 32 mA/sec
V_32_mA_64 | 32 V/sec, 64 mA/sec
V_64_mA_128 | 64 V/sec, 128 mA/sec
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam_Temperature Enumeration

Adam_Temperature Enumeration
[image]

The temperature setting

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam_Temperature As Byte
C#
public enum Adam_Temperature : byte
C++
public enum class Adam_Temperature : char
J#
public enum Adam_Temperature byte
JScript
public enum Adam_Temperature :

Members

Member Name | Description
Centigrade | 'C
Fahrenheit | 'F

See Also

Advantech.Adam Namespace


Adam2000 Class

Adam2000 Class
See Also Example Members
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Adam2000
Inherits AdamBase
C#
public class Adam2000 : AdamBase
C++
ref class Adam2000 : AdamBase
J#
public class Adam2000 extends AdamBase
JScript
public class Adam2000 extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.Adam2000

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Adam2000 Members
Advantech.Adam Namespace


Adam2000 Members

Adam2000 Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Adam2000.

Public Constructors

Name | Description
Adam2000 | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | ClearTableInfo | Clear end device table information.
 | ConvertToEngineerData | Convert raw data into engineering data.
Public method | CustomPacketToSend | **INTERNAL USE** DO NOT USE THIS FUNCTION The returning byte array o_byRecvData is the packet sent by the device you indicate. And the packet includes header defined in internal protocol and its' payload.
Public method | DeviceEcho | **INTERNAL USE** DO NOT USE THIS FUNCTION
Public method | DevicePing | **INTERNAL USE** DO NOT USE THIS FUNCTION The returning byte array is excluded 8 byte header defined in internal protocol.
Public method | GeneralQuery | Overloaded. Perform general query procedure to coordinator for corresponding function.
Public method | GetChannelStatus | To get channel status string.
Public method | GetCoordinator | For comport type coordinator, one function call for one coordinator.
Public method | GetFixInformation | Get the fix information of Zigbee devices. (SlaveID, 802.15.4 Channel, PadID...etc)
Public method | GetModuleIOConfig | Get module IO config.
Public method | GetVariationInformation | Overloaded. Get the variation information of Zigbee devices. (Mode status, LQI, battery status and Advantech status)
Public method | SetCalibrationBackToDefault | Set Calibration Parameters back to default value.
Public method | SetChannelRangeType | Set Channel range type of Zigbee devices.
Public method | SetCoordinator | Setting function for coordinator
Public method | SetDownload430Packet | Perform general query procedure for corresponding function.
Public method | SetDownloadPacket | Perform general query procedure for corresponding function.
Public method | SetFixInformation | Set the fix information of Zigbee devices. (SlaveID, 802.15.4 Channel, PadID...etc)
Public method | SetLedIndicator | Set LED to blink as a indicator.
Public method | SetSpanCalibration | Set Span Calibration of Zigbee devices.
Public method | SetZeroCalibration | Set Zero Calibration of Zigbee devices.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
Adam2000 | Overloaded.
Top

See Also

Adam2000 Class
Advantech.Adam Namespace


Adam2000 Constructor

Adam2000 Constructor

Overload List

 | Name | Description
Public method | Adam2000 (AdamCom) | The Adam 2000 constructor.
Public method | Adam2000 (AdamSocket) | The Adam 2000 constructor.

See Also

Adam2000 Class
Advantech.Adam Namespace


Adam2000 Constructor (AdamCom)

Adam2000 Constructor (AdamCom)
See Also Example
[image]

The Adam 2000 constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public Adam2000(
AdamCom i_com
)
C++
public:
Adam2000(
AdamCom i_com
) sealed
J#
public Adam2000(
AdamCom i_com
)
JScript
public function Adam2000(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object.

See Also

Adam2000 Class
Advantech.Adam Namespace
Adam2000 Constructor Overload List


Adam2000 Constructor (AdamSocket)

Adam2000 Constructor (AdamSocket)
See Also Example
[image]

The Adam 2000 constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public Adam2000(
AdamSocket i_socket
)
C++
public:
Adam2000(
AdamSocket i_socket
) sealed
J#
public Adam2000(
AdamSocket i_socket
)
JScript
public function Adam2000(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object.

See Also

Adam2000 Class
Advantech.Adam Namespace
Adam2000 Constructor Overload List


Methods

Adam2000 Methods
[image]

Public Methods

 | Name | Description
Public method | ClearTableInfo | Clear end device table information.
 | ConvertToEngineerData | Convert raw data into engineering data.
Public method | CustomPacketToSend | **INTERNAL USE** DO NOT USE THIS FUNCTION The returning byte array o_byRecvData is the packet sent by the device you indicate. And the packet includes header defined in internal protocol and its' payload.
Public method | DeviceEcho | **INTERNAL USE** DO NOT USE THIS FUNCTION
Public method | DevicePing | **INTERNAL USE** DO NOT USE THIS FUNCTION The returning byte array is excluded 8 byte header defined in internal protocol.
Public method | GeneralQuery | Overloaded. Perform general query procedure to coordinator for corresponding function.
Public method | GetChannelStatus | To get channel status string.
Public method | GetCoordinator | For comport type coordinator, one function call for one coordinator.
Public method | GetFixInformation | Get the fix information of Zigbee devices. (SlaveID, 802.15.4 Channel, PadID...etc)
Public method | GetModuleIOConfig | Get module IO config.
Public method | GetVariationInformation | Overloaded. Get the variation information of Zigbee devices. (Mode status, LQI, battery status and Advantech status)
Public method | SetCalibrationBackToDefault | Set Calibration Parameters back to default value.
Public method | SetChannelRangeType | Set Channel range type of Zigbee devices.
Public method | SetCoordinator | Setting function for coordinator
Public method | SetDownload430Packet | Perform general query procedure for corresponding function.
Public method | SetDownloadPacket | Perform general query procedure for corresponding function.
Public method | SetFixInformation | Set the fix information of Zigbee devices. (SlaveID, 802.15.4 Channel, PadID...etc)
Public method | SetLedIndicator | Set LED to blink as a indicator.
Public method | SetSpanCalibration | Set Span Calibration of Zigbee devices.
Public method | SetZeroCalibration | Set Zero Calibration of Zigbee devices.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

Adam2000 Class
Advantech.Adam Namespace


ClearTableInfo Method

Adam2000.ClearTableInfo Method
[image]

Clear end device table information.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ClearTableInfo( _
ByVal i_usShortAddr As UInt16 _
) As Boolean
C#
public bool ClearTableInfo(
ushort i_usShortAddr
)
C++
public:
bool ClearTableInfo(
unsigned short i_usShortAddr
) sealed
J#
public bool ClearTableInfo(
ushort i_usShortAddr
)
JScript
public function ClearTableInfo(
i_usShortAddr : UInt16
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


ConvertToEngineerData Method

Adam2000.ConvertToEngineerData Method
[image]

Convert raw data into engineering data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertToEngineerData( _
ByVal iChannelType As Integer, _
ByVal i_usRawData As UInt16 _
) As Double
C#
public static double ConvertToEngineerData(
int iChannelType,
ushort i_usRawData
)
C++
public:
static double ConvertToEngineerData(
int iChannelType,
unsigned short i_usRawData
)
J#
public static double ConvertToEngineerData(
int iChannelType,
ushort i_usRawData
)
JScript
public static function ConvertToEngineerData(
iChannelType : int,
i_usRawData : UInt16
) : double

Return Value

Return scaled value if success, otherwise, return 0.00.

See Also

Adam2000 Class
Advantech.Adam Namespace


CustomPacketToSend Method

Adam2000.CustomPacketToSend Method
[image]

**INTERNAL USE** DO NOT USE THIS FUNCTION The returning byte array o_byRecvData is the packet sent by the device you indicate. And the packet includes header defined in internal protocol and its' payload.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function CustomPacketToSend( _
ByVal i_usShortAddr As UInt16, _
ByVal i_usMsgType As UInt16, _
ByVal i_usPktVer As UInt16, _
ByVal i_usSeqNum As UInt16, _
ByVal i_byCustomData As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public bool CustomPacketToSend(
ushort i_usShortAddr,
ushort i_usMsgType,
ushort i_usPktVer,
ushort i_usSeqNum,
byte[] i_byCustomData,
out byte o_byRecvData
)
C++
public:
bool CustomPacketToSend(
unsigned short i_usShortAddr,
unsigned short i_usMsgType,
unsigned short i_usPktVer,
unsigned short i_usSeqNum,
array<char>^ i_byCustomData,
[OutAttribute] char% o_byRecvData
) sealed
J#
public bool CustomPacketToSend(
ushort i_usShortAddr,
ushort i_usMsgType,
ushort i_usPktVer,
ushort i_usSeqNum,
byte[] i_byCustomData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public function CustomPacketToSend(
i_usShortAddr : UInt16,
i_usMsgType : UInt16,
i_usPktVer : UInt16,
i_usSeqNum : UInt16,
i_byCustomData : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


DeviceEcho Method

Adam2000.DeviceEcho Method
[image]

**INTERNAL USE** DO NOT USE THIS FUNCTION

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DeviceEcho( _
ByVal i_usShortAddr As UInt16, _
ByVal i_byEchoData As Byte() _
) As Boolean
C#
public bool DeviceEcho(
ushort i_usShortAddr,
byte[] i_byEchoData
)
C++
public:
bool DeviceEcho(
unsigned short i_usShortAddr,
array<char>^ i_byEchoData
) sealed
J#
public bool DeviceEcho(
ushort i_usShortAddr,
byte[] i_byEchoData
)
JScript
public function DeviceEcho(
i_usShortAddr : UInt16,
i_byEchoData : Byte[]
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


DevicePing Method

Adam2000.DevicePing Method
[image]

**INTERNAL USE** DO NOT USE THIS FUNCTION The returning byte array is excluded 8 byte header defined in internal protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DevicePing( _
ByVal i_usShortAddr As UInt16, _
<OutAttribute> ByRef o_byPingData As Byte _
) As Boolean
C#
public bool DevicePing(
ushort i_usShortAddr,
out byte o_byPingData
)
C++
public:
bool DevicePing(
unsigned short i_usShortAddr,
[OutAttribute] char% o_byPingData
) sealed
J#
public bool DevicePing(
ushort i_usShortAddr,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPingData
)
JScript
public function DevicePing(
i_usShortAddr : UInt16,
OutAttribute o_byPingData : Byte
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


GeneralQuery Method

Adam2000.GeneralQuery Method

Perform general query procedure to coordinator for corresponding function.

Overload List

 | Name | Description
Public method | GeneralQuery (Adam2000.CmdCode) | Perform general query procedure to coordinator for corresponding function.
Public method | GeneralQuery (UInt16, Adam2000.CmdCode) | Perform general query procedure for corresponding function.

See Also

Adam2000 Class
Advantech.Adam Namespace


GeneralQuery Method (Adam2000.CmdCode)

Adam2000.GeneralQuery Method (Adam2000.CmdCode)
See Also Example
[image]

Perform general query procedure to coordinator for corresponding function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GeneralQuery( _
ByVal i_CmdCode As Adam2000.CmdCode _
) As Boolean
C#
public bool GeneralQuery(
Adam2000.CmdCode i_CmdCode
)
C++
public:
bool GeneralQuery(
Adam2000.CmdCode i_CmdCode
) sealed
J#
public bool GeneralQuery(
Adam2000.CmdCode i_CmdCode
)
JScript
public function GeneralQuery(
i_CmdCode : Adam2000.CmdCode
) : bool

Parameters

i_CmdCode
Command code. (Defined in CmdCode enumeration)

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace
Adam2000.GeneralQuery Overload List


GeneralQuery Method (UInt16, Adam2000.CmdCode)

Adam2000.GeneralQuery Method (UInt16, Adam2000.CmdCode)
See Also Example
[image]

Perform general query procedure for corresponding function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GeneralQuery( _
ByVal i_usShortAddr As UInt16, _
ByVal i_CmdCode As Adam2000.CmdCode _
) As Boolean
C#
public bool GeneralQuery(
ushort i_usShortAddr,
Adam2000.CmdCode i_CmdCode
)
C++
public:
bool GeneralQuery(
unsigned short i_usShortAddr,
Adam2000.CmdCode i_CmdCode
) sealed
J#
public bool GeneralQuery(
ushort i_usShortAddr,
Adam2000.CmdCode i_CmdCode
)
JScript
public function GeneralQuery(
i_usShortAddr : UInt16,
i_CmdCode : Adam2000.CmdCode
) : bool

Parameters

i_usShortAddr
The short address of Zigbee device. (0x0 for coordinator)
i_CmdCode
Command code. (Defined in CmdCode enumeration)

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace
Adam2000.GeneralQuery Overload List


GetChannelStatus Method

Adam2000.GetChannelStatus Method
[image]

To get channel status string.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelStatus( _
ByRef i_byChannelStatus As Byte, _
<OutAttribute> ByRef o_strChStatus As String _
) As Boolean
C#
public bool GetChannelStatus(
ref byte i_byChannelStatus,
out string o_strChStatus
)
C++
public:
bool GetChannelStatus(
char% i_byChannelStatus,
[OutAttribute] String% o_strChStatus
) sealed
J#
public bool GetChannelStatus(
byte i_byChannelStatus,
/** @attribute OutAttribute() */ /** @ref */ string o_strChStatus
)
JScript
public function GetChannelStatus(
i_byChannelStatus : Byte,
OutAttribute o_strChStatus : String
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


GetCoordinator Method

Adam2000.GetCoordinator Method
[image]

For comport type coordinator, one function call for one coordinator.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCoordinator( _
ByRef i_a2kCfg As Adam2000Config _
) As Boolean
C#
public bool GetCoordinator(
ref Adam2000Config i_a2kCfg
)
C++
public:
bool GetCoordinator(
Adam2000Config% i_a2kCfg
) sealed
J#
public bool GetCoordinator(
Adam2000Config i_a2kCfg
)
JScript
public function GetCoordinator(
i_a2kCfg : Adam2000Config
) : bool

Parameters

i_a2kCfg
Coordinator configuration data.

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


GetFixInformation Method

Adam2000.GetFixInformation Method
[image]

Get the fix information of Zigbee devices. (SlaveID, 802.15.4 Channel, PadID...etc)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFixInformation( _
ByVal i_usShortAddr As UInt16, _
ByRef i_a2kCfg As Adam2000Config _
) As Boolean
C#
public bool GetFixInformation(
ushort i_usShortAddr,
ref Adam2000Config i_a2kCfg
)
C++
public:
bool GetFixInformation(
unsigned short i_usShortAddr,
Adam2000Config% i_a2kCfg
) sealed
J#
public bool GetFixInformation(
ushort i_usShortAddr,
Adam2000Config i_a2kCfg
)
JScript
public function GetFixInformation(
i_usShortAddr : UInt16,
i_a2kCfg : Adam2000Config
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


GetModuleIOConfig Method

Adam2000.GetModuleIOConfig Method
[image]

Get module IO config.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleIOConfig( _
ByVal i_usShortAddr As UInt16, _
ByRef i_a2kCfg As Adam2000Config _
) As Boolean
C#
public bool GetModuleIOConfig(
ushort i_usShortAddr,
ref Adam2000Config i_a2kCfg
)
C++
public:
bool GetModuleIOConfig(
unsigned short i_usShortAddr,
Adam2000Config% i_a2kCfg
) sealed
J#
public bool GetModuleIOConfig(
ushort i_usShortAddr,
Adam2000Config i_a2kCfg
)
JScript
public function GetModuleIOConfig(
i_usShortAddr : UInt16,
i_a2kCfg : Adam2000Config
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


GetVariationInformation Method

Adam2000.GetVariationInformation Method

Get the variation information of Zigbee devices. (Mode status, LQI, battery status and Advantech status)

Overload List

 | Name | Description
Public method | GetVariationInformation (UInt16, Adam2000Config) | Get the variation information of Zigbee devices. (Mode status, LQI, battery status and Advantech status)
Public method | GetVariationInformation (UInt16, Adam2000Config, Byte, UInt16) | Get the variation information of Zigbee devices. (Mode status, LQI, battery status and Advantech status)

See Also

Adam2000 Class
Advantech.Adam Namespace


GetVariationInformation Method (UInt16, Adam2000Config)

Adam2000.GetVariationInformation Method (UInt16, Adam2000Config)
See Also Example
[image]

Get the variation information of Zigbee devices. (Mode status, LQI, battery status and Advantech status)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetVariationInformation( _
ByVal i_usShortAddr As UInt16, _
ByRef i_a2kCfg As Adam2000Config _
) As Boolean
C#
public bool GetVariationInformation(
ushort i_usShortAddr,
ref Adam2000Config i_a2kCfg
)
C++
public:
bool GetVariationInformation(
unsigned short i_usShortAddr,
Adam2000Config% i_a2kCfg
) sealed
J#
public bool GetVariationInformation(
ushort i_usShortAddr,
Adam2000Config i_a2kCfg
)
JScript
public function GetVariationInformation(
i_usShortAddr : UInt16,
i_a2kCfg : Adam2000Config
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace
Adam2000.GetVariationInformation Overload List


GetVariationInformation Method (UInt16, Adam2000Config, Byte, UInt16)

Adam2000.GetVariationInformation Method (UInt16, Adam2000Config, Byte, UInt16)
See Also Example
[image]

Get the variation information of Zigbee devices. (Mode status, LQI, battery status and Advantech status)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetVariationInformation( _
ByVal i_usShortAddr As UInt16, _
ByRef i_a2kCfg As Adam2000Config, _
<OutAttribute> ByRef o_byChannelStatus As Byte, _
<OutAttribute> ByRef o_wIOData As UInt16 _
) As Boolean
C#
public bool GetVariationInformation(
ushort i_usShortAddr,
ref Adam2000Config i_a2kCfg,
out byte o_byChannelStatus,
out ushort o_wIOData
)
C++
public:
bool GetVariationInformation(
unsigned short i_usShortAddr,
Adam2000Config% i_a2kCfg,
[OutAttribute] char% o_byChannelStatus,
[OutAttribute] unsigned short% o_wIOData
) sealed
J#
public bool GetVariationInformation(
ushort i_usShortAddr,
Adam2000Config i_a2kCfg,
/** @attribute OutAttribute() */ /** @ref */ byte o_byChannelStatus,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wIOData
)
JScript
public function GetVariationInformation(
i_usShortAddr : UInt16,
i_a2kCfg : Adam2000Config,
OutAttribute o_byChannelStatus : Byte,
OutAttribute o_wIOData : UInt16
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace
Adam2000.GetVariationInformation Overload List


SetCalibrationBackToDefault Method

Adam2000.SetCalibrationBackToDefault Method
[image]

Set Calibration Parameters back to default value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationBackToDefault( _
ByVal i_usShortAddr As UInt16, _
ByVal i_usChannel As UInt16 _
) As Boolean
C#
public bool SetCalibrationBackToDefault(
ushort i_usShortAddr,
ushort i_usChannel
)
C++
public:
bool SetCalibrationBackToDefault(
unsigned short i_usShortAddr,
unsigned short i_usChannel
) sealed
J#
public bool SetCalibrationBackToDefault(
ushort i_usShortAddr,
ushort i_usChannel
)
JScript
public function SetCalibrationBackToDefault(
i_usShortAddr : UInt16,
i_usChannel : UInt16
) : bool

Return Value

True, if Return ok.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetChannelRangeType Method

Adam2000.SetChannelRangeType Method
[image]

Set Channel range type of Zigbee devices.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelRangeType( _
ByVal i_usShortAddr As UInt16, _
ByRef i_a2kCfg As Adam2000Config _
) As Boolean
C#
public bool SetChannelRangeType(
ushort i_usShortAddr,
ref Adam2000Config i_a2kCfg
)
C++
public:
bool SetChannelRangeType(
unsigned short i_usShortAddr,
Adam2000Config% i_a2kCfg
) sealed
J#
public bool SetChannelRangeType(
ushort i_usShortAddr,
Adam2000Config i_a2kCfg
)
JScript
public function SetChannelRangeType(
i_usShortAddr : UInt16,
i_a2kCfg : Adam2000Config
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetCoordinator Method

Adam2000.SetCoordinator Method
[image]

Setting function for coordinator

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCoordinator( _
ByRef i_a2kCfg As Adam2000Config _
) As Boolean
C#
public bool SetCoordinator(
ref Adam2000Config i_a2kCfg
)
C++
public:
bool SetCoordinator(
Adam2000Config% i_a2kCfg
) sealed
J#
public bool SetCoordinator(
Adam2000Config i_a2kCfg
)
JScript
public function SetCoordinator(
i_a2kCfg : Adam2000Config
) : bool

Parameters

i_a2kCfg
Coordinator configuration data.

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetDownload430Packet Method

Adam2000.SetDownload430Packet Method
[image]

Perform general query procedure for corresponding function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDownload430Packet( _
ByVal i_usSeqNum As UInt16, _
ByVal i_byData As Byte() _
) As Boolean
C#
public bool SetDownload430Packet(
ushort i_usSeqNum,
byte[] i_byData
)
C++
public:
bool SetDownload430Packet(
unsigned short i_usSeqNum,
array<char>^ i_byData
) sealed
J#
public bool SetDownload430Packet(
ushort i_usSeqNum,
byte[] i_byData
)
JScript
public function SetDownload430Packet(
i_usSeqNum : UInt16,
i_byData : Byte[]
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetDownloadPacket Method

Adam2000.SetDownloadPacket Method
[image]

Perform general query procedure for corresponding function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDownloadPacket( _
ByVal i_usShortAddr As UInt16, _
ByVal i_usSeqNum As UInt16, _
ByVal i_byData As Byte() _
) As Boolean
C#
public bool SetDownloadPacket(
ushort i_usShortAddr,
ushort i_usSeqNum,
byte[] i_byData
)
C++
public:
bool SetDownloadPacket(
unsigned short i_usShortAddr,
unsigned short i_usSeqNum,
array<char>^ i_byData
) sealed
J#
public bool SetDownloadPacket(
ushort i_usShortAddr,
ushort i_usSeqNum,
byte[] i_byData
)
JScript
public function SetDownloadPacket(
i_usShortAddr : UInt16,
i_usSeqNum : UInt16,
i_byData : Byte[]
) : bool

Return Value

True, if success.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetFixInformation Method

Adam2000.SetFixInformation Method
[image]

Set the fix information of Zigbee devices. (SlaveID, 802.15.4 Channel, PadID...etc)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetFixInformation( _
ByVal i_usShortAddr As UInt16, _
ByRef i_a2kCfg As Adam2000Config _
) As Boolean
C#
public bool SetFixInformation(
ushort i_usShortAddr,
ref Adam2000Config i_a2kCfg
)
C++
public:
bool SetFixInformation(
unsigned short i_usShortAddr,
Adam2000Config% i_a2kCfg
) sealed
J#
public bool SetFixInformation(
ushort i_usShortAddr,
Adam2000Config i_a2kCfg
)
JScript
public function SetFixInformation(
i_usShortAddr : UInt16,
i_a2kCfg : Adam2000Config
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetLedIndicator Method

Adam2000.SetLedIndicator Method
[image]

Set LED to blink as a indicator.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLedIndicator( _
ByVal i_usShortAddr As UInt16, _
ByVal bAlwaysOn As Boolean, _
ByVal byTimes As Byte _
) As Boolean
C#
public bool SetLedIndicator(
ushort i_usShortAddr,
bool bAlwaysOn,
byte byTimes
)
C++
public:
bool SetLedIndicator(
unsigned short i_usShortAddr,
bool bAlwaysOn,
char byTimes
) sealed
J#
public bool SetLedIndicator(
ushort i_usShortAddr,
bool bAlwaysOn,
byte byTimes
)
JScript
public function SetLedIndicator(
i_usShortAddr : UInt16,
bAlwaysOn : bool,
byTimes : Byte
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetSpanCalibration Method

Adam2000.SetSpanCalibration Method
[image]

Set Span Calibration of Zigbee devices.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSpanCalibration( _
ByVal i_usShortAddr As UInt16, _
ByVal i_usChannel As UInt16 _
) As Boolean
C#
public bool SetSpanCalibration(
ushort i_usShortAddr,
ushort i_usChannel
)
C++
public:
bool SetSpanCalibration(
unsigned short i_usShortAddr,
unsigned short i_usChannel
) sealed
J#
public bool SetSpanCalibration(
ushort i_usShortAddr,
ushort i_usChannel
)
JScript
public function SetSpanCalibration(
i_usShortAddr : UInt16,
i_usChannel : UInt16
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


SetZeroCalibration Method

Adam2000.SetZeroCalibration Method
[image]

Set Zero Calibration of Zigbee devices.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetZeroCalibration( _
ByVal i_usShortAddr As UInt16, _
ByVal i_usChannel As UInt16 _
) As Boolean
C#
public bool SetZeroCalibration(
ushort i_usShortAddr,
ushort i_usChannel
)
C++
public:
bool SetZeroCalibration(
unsigned short i_usShortAddr,
unsigned short i_usChannel
) sealed
J#
public bool SetZeroCalibration(
ushort i_usShortAddr,
ushort i_usChannel
)
JScript
public function SetZeroCalibration(
i_usShortAddr : UInt16,
i_usChannel : UInt16
) : bool

Return Value

True, if exists.

See Also

Adam2000 Class
Advantech.Adam Namespace


Adam2000.CC2530DownloadMode Enumeration

Adam2000.CC2530DownloadMode Enumeration
[image]

CC2530 download mode select

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2000.CC2530DownloadMode
C#
public enum Adam2000.CC2530DownloadMode
C++
public enum class Adam2000.CC2530DownloadMode
J#
public enum Adam2000.CC2530DownloadMode
JScript
public enum Adam2000.CC2530DownloadMode

Members

Member Name | Description
Normal | Check Ack with certain interval
With_Ack | Check Ack per packet.
Without_Ack | Don't check Ack.

See Also

Advantech.Adam Namespace


Adam2000.ChannelStatus Enumeration

Adam2000.ChannelStatus Enumeration
[image]

Command Code enumeration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2000.ChannelStatus As Byte
C#
public enum Adam2000.ChannelStatus : byte
C++
public enum class Adam2000.ChannelStatus : char
J#
public enum Adam2000.ChannelStatus byte
JScript
public enum Adam2000.ChannelStatus :

Members

Member Name | Description
Good | This channel is bad.
Bad | This channel is good.
OverCurrent | This channel is over current.
UnderCurrent | This channel is under current.
BurnOut | This channel is burnout.
ZeroSpanCalibrationError | This channel is in zero/span calibration error.
NotReady | This channel is not ready.
Unknown | This channel is in unknown status.

See Also

Advantech.Adam Namespace


Adam2000.CmdCode Enumeration

Adam2000.CmdCode Enumeration
[image]

Command Code enumeration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2000.CmdCode As
C#
public enum Adam2000.CmdCode : ushort
C++
public enum class Adam2000.CmdCode : unsigned short
J#
public enum Adam2000.CmdCode ushort
JScript
public enum Adam2000.CmdCode :

Members

Member Name | Description
Reserved1 | Reserved
ResetModule | Reset module.
SetToCfgMode | Change end device to configuration mode.
SetToNormalMode | Change end device to normal mode.
StartToDownloadFw | Inform Zigbee devices starting downloading firmware.
StartToDownloadConfig | Inform Zigbee devices starting downloading config.
RegisterSuccess | Register Success.
RegisterFail | Register Fail
UL_ConfigSuccess | UL_ConfigSuccess
UL_ConfigFail | UL_ConfigFail
ActiveMsg_Success | ActiveMsg_Success
ActiveMsg_Fail | ActiveMsg_Fail
SwitchToDownload | Inform Zigbee devices switching to download.
FinishDownload | Finish Download
QE_TestMode | QE_TestMode
ActiveMsgDelay | ActiveMsgDelay
RxOn | Turn On EndDevice RxOn
RxOff | Turn On EndDevice RxOff
ParentRxOn | Parent_Rx_On
ParentRxOff | Parent_Rx_Off
NvReset | NV_RESET

See Also

Advantech.Adam Namespace


Adam2000.MessageType Enumeration

Adam2000.MessageType Enumeration
[image]

MessageType

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2000.MessageType As
C#
public enum Adam2000.MessageType : ushort
C++
public enum class Adam2000.MessageType : unsigned short
J#
public enum Adam2000.MessageType ushort
JScript
public enum Adam2000.MessageType :

Members

Member Name | Description
Register_Query |
Register_Resp |
Active_Query |
Active_Resp |
General_Query |
General_Resp |
FwPkg_DL |
ConfigPkg_DL |
ConfigPkg_Query |
ConfigPkg_UL |
General_Query_430 |
General_Resp_430 |
FwPkg_DL_430 |
ConfigPkg_DL_430 |
ConfigPkg_Query_430 |
ConfigPkg_UL_430 |
ConfigPkg_DL_Zigbee |
Internal_CC2530_Event |
Internal_MSP430_Event |
Table_Clear_430 |
Internal_Echo_Query |
Internal_Echo_Resp |
Internal_Ping_Query |
Internal_Ping_Resp |
SetChannelConfig_Query | Set channel range type.
SetChannelConfig_Resp | Set channel range type response.
ZeroCalibration_Query | Request Zero calibration
ZeroCalibration_Resp | Zero calibration response
SpanCalibration_Query | Request Span calibration.
SpanCalibration_Resp | Span calibration response.
SetLedIndicator_Query | Set LED to blink as a indicator.
SetCalibrationToDefault_Query | Set AI System Calibration Parameters to default value.

See Also

Advantech.Adam Namespace


Adam2000.SerialPortCfg Enumeration

Adam2000.SerialPortCfg Enumeration
[image]

Serial port configuration enumeration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2000.SerialPortCfg As Short
C#
public enum Adam2000.SerialPortCfg : short
C++
public enum class Adam2000.SerialPortCfg : short
J#
public enum Adam2000.SerialPortCfg short
JScript
public enum Adam2000.SerialPortCfg : short

Members

Member Name | Description
N81_1200 | 1200 Baud, no parity, 8 bits symbol, 1 stop bit
N81_2400 | 2400 Baud, no parity, 8 bits symbol, 1 stop bit
N81_4800 | 4800 Baud, no parity, 8 bits symbol, 1 stop bit
N81_9600 | 9600 Baud, no parity, 8 bits symbol, 1 stop bit
N81_19200 | 19200 Baud, no parity, 8 bits symbol, 1 stop bit
N81_38400 | 38400 Baud, no parity, 8 bits symbol, 1 stop bit
N81_115200 | 115200 Baud, no parity, 8 bits symbol, 1 stop bit

See Also

Advantech.Adam Namespace


Adam2000_Integration Enumeration

Adam2000_Integration Enumeration
[image]

The integration code for ADAM-2000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2000_Integration As
C#
public enum Adam2000_Integration : uint
C++
public enum class Adam2000_Integration : unsigned int
J#
public enum Adam2000_Integration uint
JScript
public enum Adam2000_Integration :

Members

Member Name | Description
Hz60_50ms | 60 Hz
Hz50_60ms | 50 Hz
Auto | Auto
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam2000Config Class

Adam2000Config Class
See Also Example Members
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Adam2000Config
Inherits SelfMarshalledStruct
C#
public class Adam2000Config : SelfMarshalledStruct
C++
ref class Adam2000Config : SelfMarshalledStruct
J#
public class Adam2000Config extends SelfMarshalledStruct
JScript
public class Adam2000Config extends SelfMarshalledStruct

Inheritance Hierarchy

System.Object
Advantech.Adam.SelfMarshalledStruct
Advantech.Adam.Adam2000Config

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Adam2000Config Members
Advantech.Adam Namespace


Adam2000Config Members

Adam2000Config Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Adam2000Config.

Public Constructors

Name | Description
Adam2000Config | Overloaded. Initializes a new instance of the Adam2000Config class.
Top

Public Fields

Name | Description
CONFIG_AREA_SIZE | Config area size(byte). This field is read-only.
CONFIGURATION_SIZE | Maximum support range number. This field is read-only.
MAX_AI_CHANNEL | Maximum support range number. This field is read-only.
MAX_CH_BYTE | Maximum channel number. This field is read-only.
MAX_CURRENT_RANGE_TYPE | Maximum current range type (per module). This field is read-only.
MAX_HwIoType | Maximum hardware io type number. This field is read-only.
MAX_SUPPORT_RANGE | Maximum support range number (per io type). This field is read-only.
MAX_TAG_BYTE | Maximum tag name space(byte). This field is read-only.
Top

Protected Fields

 | Name | Description
Family field | baseOffset | (inherited from SelfMarshalledStruct)
Family field | data | (inherited from SelfMarshalledStruct)
Top

Public Properties

 | Name | Description
Public property | bBurnoutEnableStatus | Burnout Enable Status
Public property | bTagName | Self-Defined description for this module (array size:10)
Public property | byChTotal | Total # of Channels
Public property | byConfigArea | Config area for this module (array size:28)
Public property | byFunType_0 | Function Type 0
Public property | byFunType_1 | Function Type 1
Public property | byFunType_2 | Function Type 2
Public property | byFunType_3 | Function Type 3
Public property | byFunType_4 | Function Type 4
Public property | byHwIoTotal_0 | No. of Hardware I/O Type 0 Channels
Public property | byHwIoTotal_1 | No. of Hardware I/O Type 1 Channels
Public property | byHwIoTotal_2 | No. of Hardware I/O Type 2 Channels
Public property | byHwIoTotal_3 | No. of Hardware I/O Type 3 Channels
Public property | byHwIoTotal_4 | No. of Hardware I/O Type 4 Channels
Public property | byHwIoType_0 | Hardware I/O Type 0 (i.e: Device type )
Public property | byHwIoType_0_Resolution | Resolution 0
Public property | byHwIoType_0_TotalRangeNumber | Total number of Supported I/O Range 0
Public property | byHwIoType_1 | Hardware I/O Type 1
Public property | byHwIoType_1_Resolution | Resolution 1
Public property | byHwIoType_1_TotalRangeNumber | Total number of Supported I/O Range 1
Public property | byHwIoType_2 | Hardware I/O Type 2
Public property | byHwIoType_2_Resolution | Resolution 2
Public property | byHwIoType_2_TotalRangeNumber | Total number of Supported I/O Range 2
Public property | byHwIoType_3 | Hardware I/O Type 3
Public property | byHwIoType_3_Resolution | Resolution 3
Public property | byHwIoType_3_TotalRangeNumber | Total number of Supported I/O Range 3
Public property | byHwIoType_4 | Hardware I/O Type 4
Public property | byHwIoType_4_Resolution | Resolution 4
Public property | byHwIoType_4_TotalRangeNumber | Total number of Supported I/O Range 4
Public property | byOperationMode | MSP430 transparent mode enable
Public property | DataArray | Data
Public property | dwActCycle | Active Cycle
Public property | dwAlarmMask | Alarm State Mask
Public property | dwChMask | Channel Enabled Mask
Public property | dwFunMask_0 | Enable Mask 0
Public property | dwFunMask_1 | Enable Mask 1
Public property | dwFunMask_2 | Enable Mask 2
Public property | dwFunMask_3 | Enable Mask 3
Public property | dwFunMask_4 | Enable Mask 4
Public property | dwFunParam_0 | Function parameter 0
Public property | dwFunParam_1 | Function parameter 1
Public property | dwFunParam_2 | Function parameter 2
Public property | dwFunParam_3 | Function parameter 3
Public property | dwFunParam_4 | Function parameter 4
Public property | dwModName | Module Name
Public property | Handle | Handle
Public property | HwIoTotal | No. of Hardware I/O Type 0-4 Channels
Public property | HwIoType | Hardware I/O Type 0-4
Public property | HwIoType_TotalRangeNumber | Total number of Supported I/O Range 0-4
 | Length | Adam2000 module information size
Public property | w430DevType | MSP430 firmware build version
Public property | w430FwVer | MSP430 firmware version
Public property | w430FwVerBuild | MSP430 firmware build version
Public property | wAdvStatus | Power source (Battery or external power)
Public property | wBetteryStatus | Battery status (Battery level)
Public property | wChRange | Current I/O Range Type (array size:32)
Public property | wChTotal | Total # of Channels
Public property | wDeadConnection | Dead Connection
Public property | wDevType | Device Type
Public property | wFwVerBld | Firmware Build Version
Public property | wFwVerNo | Firmware Version
Public property | wHwIoType_0_End | Hardware I/O Type 0 Data Reg. Address Range End
Public property | wHwIoType_0_Range | Supported I/O Range 0 (array size:36)
Public property | wHwIoType_0_Start | Hardware I/O Type 0 Data Reg. Address Range Start
Public property | wHwIoType_1_End | Hardware I/O Type 1 Data Reg. Address Range End
Public property | wHwIoType_1_Range | Supported I/O Range 1 (array size:36)
Public property | wHwIoType_1_Start | Hardware I/O Type 1 Data Reg. Address Range Start
Public property | wHwIoType_2_End | Hardware I/O Type 2 Data Reg. Address Range End
Public property | wHwIoType_2_Range | Supported I/O Range 2 (array size:36)
Public property | wHwIoType_2_Start | Hardware I/O Type 2 Data Reg. Address Range Start
Public property | wHwIoType_3_End | Hardware I/O Type 3 Data Reg. Address Range End
Public property | wHwIoType_3_Range | Supported I/O Range 3 (array size:36)
Public property | wHwIoType_3_Start | Hardware I/O Type 3 Data Reg. Address Range Start
Public property | wHwIoType_4_End | Hardware I/O Type 4 Data Reg. Address Range End
Public property | wHwIoType_4_Range | Supported I/O Range 4 (array size:36)
Public property | wHwIoType_4_Start | Hardware I/O Type 4 Data Reg. Address Range Start
Public property | wHwVer | Hardware Version
Public property | wLossConnection | Loss Connection
Public property | wLQI | Wireless signal intensity (LQI)
Public property | wMBSlaveID | Modbus Slave ID
Public property | wModuleStatus | Module current mode
Public property | wPanID | Pan ID
Public property | wParentShortAddr | Parent short address
Public property | wPowerConserve | Security
Public property | wSecurity | Security
Public property | wSerialPortConf | MSP430 serial port configuration
Public property | wShortAddr | Short address
Public property | wSupportFwVer | Supported Controller's Firmware Version
Public property | wTPTargetID | MSP430 transparent target ID
Public property | wTXPower | Transmit Power
Public property | wWirelessCh | 802.15.4 Wireless Channel
Top

Protected Properties

 | Name | Description
Family property | Data | (inherited from SelfMarshalledStruct)
Family property | Item | (inherited from SelfMarshalledStruct)
Top

Public Methods

 | Name | Description
Public method | GetExtBuf | Get Extension buffer value
Public method | GetModuleName | Get the module name string.
Public method | SetExtBuf | Set Extension buffer value
Top

Protected Methods

 | Name | Description
Family method | Get | (inherited from SelfMarshalledStruct)
Family method | GetByte | (inherited from SelfMarshalledStruct)
Family method | GetChar | (inherited from SelfMarshalledStruct)
Family method | GetInt16 | (inherited from SelfMarshalledStruct)
Family method | GetInt32 | (inherited from SelfMarshalledStruct)
Family method | GetIntPtr | (inherited from SelfMarshalledStruct)
Family method | GetSlice | (inherited from SelfMarshalledStruct)
Family method | GetStringAscii | (inherited from SelfMarshalledStruct)
Family method | GetStringUni | (inherited from SelfMarshalledStruct)
Family method | GetUInt16 | (inherited from SelfMarshalledStruct)
Family method | GetUInt32 | (inherited from SelfMarshalledStruct)
Family method | Set | (inherited from SelfMarshalledStruct)
Family method | SetByte | (inherited from SelfMarshalledStruct)
Family method | SetChar | (inherited from SelfMarshalledStruct)
Family method | SetInt16 | (inherited from SelfMarshalledStruct)
Family method | SetInt32 | (inherited from SelfMarshalledStruct)
Family method | SetIntPtr | (inherited from SelfMarshalledStruct)
Family method | SetStringUni | (inherited from SelfMarshalledStruct)
Family method | SetUInt16 | (inherited from SelfMarshalledStruct)
Family method | SetUInt32 | (inherited from SelfMarshalledStruct)
Top

Explicit Interface Implementations

Name | Description
Adam2000Config | Overloaded. Initializes a new instance of the Adam2000Config class.
Top

See Also

Adam2000Config Class
Advantech.Adam Namespace


Adam2000Config Constructor

Adam2000Config Constructor

Initializes a new instance of the Adam2000Config class.

Overload List

 | Name | Description
Public method | Adam2000Config | ApaxSlotInfo Constructor
Public method | Adam2000Config (Byte, Int32) | ApaxSlotInfo Constructor
Public method | Adam2000Config (IntPtr, Int32) | ApaxSlotInfo Constructor

See Also

Adam2000Config Class
Advantech.Adam Namespace


Adam2000Config Constructor ()

Adam2000Config Constructor ()
See Also Example
[image]

ApaxSlotInfo Constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Adam2000Config()
C++
public:
Adam2000Config() sealed
J#
public Adam2000Config()
JScript
public function Adam2000Config()

See Also

Adam2000Config Class
Advantech.Adam Namespace
Adam2000Config Constructor Overload List


Adam2000Config Constructor (Byte[], Int32)

Adam2000Config Constructor (Byte[], Int32)
See Also Example
[image]

ApaxSlotInfo Constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal data As Byte(), _
ByVal offset As Integer _
)
C#
public Adam2000Config(
byte[] data,
int offset
)
C++
public:
Adam2000Config(
array<char>^ data,
int offset
) sealed
J#
public Adam2000Config(
byte[] data,
int offset
)
JScript
public function Adam2000Config(
data : Byte[],
offset : int
)

Parameters

data
offset

See Also

Adam2000Config Class
Advantech.Adam Namespace
Adam2000Config Constructor Overload List


Adam2000Config Constructor (IntPtr, Int32)

Adam2000Config Constructor (IntPtr, Int32)
See Also Example
[image]

ApaxSlotInfo Constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal pData As IntPtr, _
ByVal offset As Integer _
)
C#
public Adam2000Config(
IntPtr pData,
int offset
)
C++
public:
Adam2000Config(
IntPtr pData,
int offset
) sealed
J#
public Adam2000Config(
IntPtr pData,
int offset
)
JScript
public function Adam2000Config(
pData : IntPtr,
offset : int
)

Parameters

pData
offset

See Also

Adam2000Config Class
Advantech.Adam Namespace
Adam2000Config Constructor Overload List


Fields

Adam2000Config Fields
[image]

Public Fields

Name | Description
CONFIG_AREA_SIZE | Config area size(byte). This field is read-only.
CONFIGURATION_SIZE | Maximum support range number. This field is read-only.
MAX_AI_CHANNEL | Maximum support range number. This field is read-only.
MAX_CH_BYTE | Maximum channel number. This field is read-only.
MAX_CURRENT_RANGE_TYPE | Maximum current range type (per module). This field is read-only.
MAX_HwIoType | Maximum hardware io type number. This field is read-only.
MAX_SUPPORT_RANGE | Maximum support range number (per io type). This field is read-only.
MAX_TAG_BYTE | Maximum tag name space(byte). This field is read-only.
Top

Protected Fields

 | Name | Description
Family field | baseOffset | (inherited from SelfMarshalledStruct)
Family field | data | (inherited from SelfMarshalledStruct)
Top

See Also

Adam2000Config Class
Advantech.Adam Namespace


CONFIG_AREA_SIZE Field

Adam2000Config.CONFIG_AREA_SIZE Field
[image]

Config area size(byte). This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CONFIG_AREA_SIZE As Integer
C#
public static readonly int CONFIG_AREA_SIZE;
C++
public:
static const int CONFIG_AREA_SIZE;
J#
public static final int CONFIG_AREA_SIZE
JScript
public static const var CONFIG_AREA_SIZE : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


CONFIGURATION_SIZE Field

Adam2000Config.CONFIGURATION_SIZE Field
[image]

Maximum support range number. This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CONFIGURATION_SIZE As Integer
C#
public static readonly int CONFIGURATION_SIZE;
C++
public:
static const int CONFIGURATION_SIZE;
J#
public static final int CONFIGURATION_SIZE
JScript
public static const var CONFIGURATION_SIZE : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


MAX_AI_CHANNEL Field

Adam2000Config.MAX_AI_CHANNEL Field
[image]

Maximum support range number. This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_AI_CHANNEL As Integer
C#
public static readonly int MAX_AI_CHANNEL;
C++
public:
static const int MAX_AI_CHANNEL;
J#
public static final int MAX_AI_CHANNEL
JScript
public static const var MAX_AI_CHANNEL : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


MAX_CH_BYTE Field

Adam2000Config.MAX_CH_BYTE Field
[image]

Maximum channel number. This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_CH_BYTE As Integer
C#
public static readonly int MAX_CH_BYTE;
C++
public:
static const int MAX_CH_BYTE;
J#
public static final int MAX_CH_BYTE
JScript
public static const var MAX_CH_BYTE : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


MAX_CURRENT_RANGE_TYPE Field

Adam2000Config.MAX_CURRENT_RANGE_TYPE Field
[image]

Maximum current range type (per module). This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_CURRENT_RANGE_TYPE As Integer
C#
public static readonly int MAX_CURRENT_RANGE_TYPE;
C++
public:
static const int MAX_CURRENT_RANGE_TYPE;
J#
public static final int MAX_CURRENT_RANGE_TYPE
JScript
public static const var MAX_CURRENT_RANGE_TYPE : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


MAX_HwIoType Field

Adam2000Config.MAX_HwIoType Field
[image]

Maximum hardware io type number. This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_HwIoType As Integer
C#
public static readonly int MAX_HwIoType;
C++
public:
static const int MAX_HwIoType;
J#
public static final int MAX_HwIoType
JScript
public static const var MAX_HwIoType : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


MAX_SUPPORT_RANGE Field

Adam2000Config.MAX_SUPPORT_RANGE Field
[image]

Maximum support range number (per io type). This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_SUPPORT_RANGE As Integer
C#
public static readonly int MAX_SUPPORT_RANGE;
C++
public:
static const int MAX_SUPPORT_RANGE;
J#
public static final int MAX_SUPPORT_RANGE
JScript
public static const var MAX_SUPPORT_RANGE : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


MAX_TAG_BYTE Field

Adam2000Config.MAX_TAG_BYTE Field
[image]

Maximum tag name space(byte). This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_TAG_BYTE As Integer
C#
public static readonly int MAX_TAG_BYTE;
C++
public:
static const int MAX_TAG_BYTE;
J#
public static final int MAX_TAG_BYTE
JScript
public static const var MAX_TAG_BYTE : int;

See Also

Adam2000Config Class
Advantech.Adam Namespace


Properties

Adam2000Config Properties
[image]

Public Properties

 | Name | Description
Public property | bBurnoutEnableStatus | Burnout Enable Status
Public property | bTagName | Self-Defined description for this module (array size:10)
Public property | byChTotal | Total # of Channels
Public property | byConfigArea | Config area for this module (array size:28)
Public property | byFunType_0 | Function Type 0
Public property | byFunType_1 | Function Type 1
Public property | byFunType_2 | Function Type 2
Public property | byFunType_3 | Function Type 3
Public property | byFunType_4 | Function Type 4
Public property | byHwIoTotal_0 | No. of Hardware I/O Type 0 Channels
Public property | byHwIoTotal_1 | No. of Hardware I/O Type 1 Channels
Public property | byHwIoTotal_2 | No. of Hardware I/O Type 2 Channels
Public property | byHwIoTotal_3 | No. of Hardware I/O Type 3 Channels
Public property | byHwIoTotal_4 | No. of Hardware I/O Type 4 Channels
Public property | byHwIoType_0 | Hardware I/O Type 0 (i.e: Device type )
Public property | byHwIoType_0_Resolution | Resolution 0
Public property | byHwIoType_0_TotalRangeNumber | Total number of Supported I/O Range 0
Public property | byHwIoType_1 | Hardware I/O Type 1
Public property | byHwIoType_1_Resolution | Resolution 1
Public property | byHwIoType_1_TotalRangeNumber | Total number of Supported I/O Range 1
Public property | byHwIoType_2 | Hardware I/O Type 2
Public property | byHwIoType_2_Resolution | Resolution 2
Public property | byHwIoType_2_TotalRangeNumber | Total number of Supported I/O Range 2
Public property | byHwIoType_3 | Hardware I/O Type 3
Public property | byHwIoType_3_Resolution | Resolution 3
Public property | byHwIoType_3_TotalRangeNumber | Total number of Supported I/O Range 3
Public property | byHwIoType_4 | Hardware I/O Type 4
Public property | byHwIoType_4_Resolution | Resolution 4
Public property | byHwIoType_4_TotalRangeNumber | Total number of Supported I/O Range 4
Public property | byOperationMode | MSP430 transparent mode enable
Public property | DataArray | Data
Public property | dwActCycle | Active Cycle
Public property | dwAlarmMask | Alarm State Mask
Public property | dwChMask | Channel Enabled Mask
Public property | dwFunMask_0 | Enable Mask 0
Public property | dwFunMask_1 | Enable Mask 1
Public property | dwFunMask_2 | Enable Mask 2
Public property | dwFunMask_3 | Enable Mask 3
Public property | dwFunMask_4 | Enable Mask 4
Public property | dwFunParam_0 | Function parameter 0
Public property | dwFunParam_1 | Function parameter 1
Public property | dwFunParam_2 | Function parameter 2
Public property | dwFunParam_3 | Function parameter 3
Public property | dwFunParam_4 | Function parameter 4
Public property | dwModName | Module Name
Public property | Handle | Handle
Public property | HwIoTotal | No. of Hardware I/O Type 0-4 Channels
Public property | HwIoType | Hardware I/O Type 0-4
Public property | HwIoType_TotalRangeNumber | Total number of Supported I/O Range 0-4
 | Length | Adam2000 module information size
Public property | w430DevType | MSP430 firmware build version
Public property | w430FwVer | MSP430 firmware version
Public property | w430FwVerBuild | MSP430 firmware build version
Public property | wAdvStatus | Power source (Battery or external power)
Public property | wBetteryStatus | Battery status (Battery level)
Public property | wChRange | Current I/O Range Type (array size:32)
Public property | wChTotal | Total # of Channels
Public property | wDeadConnection | Dead Connection
Public property | wDevType | Device Type
Public property | wFwVerBld | Firmware Build Version
Public property | wFwVerNo | Firmware Version
Public property | wHwIoType_0_End | Hardware I/O Type 0 Data Reg. Address Range End
Public property | wHwIoType_0_Range | Supported I/O Range 0 (array size:36)
Public property | wHwIoType_0_Start | Hardware I/O Type 0 Data Reg. Address Range Start
Public property | wHwIoType_1_End | Hardware I/O Type 1 Data Reg. Address Range End
Public property | wHwIoType_1_Range | Supported I/O Range 1 (array size:36)
Public property | wHwIoType_1_Start | Hardware I/O Type 1 Data Reg. Address Range Start
Public property | wHwIoType_2_End | Hardware I/O Type 2 Data Reg. Address Range End
Public property | wHwIoType_2_Range | Supported I/O Range 2 (array size:36)
Public property | wHwIoType_2_Start | Hardware I/O Type 2 Data Reg. Address Range Start
Public property | wHwIoType_3_End | Hardware I/O Type 3 Data Reg. Address Range End
Public property | wHwIoType_3_Range | Supported I/O Range 3 (array size:36)
Public property | wHwIoType_3_Start | Hardware I/O Type 3 Data Reg. Address Range Start
Public property | wHwIoType_4_End | Hardware I/O Type 4 Data Reg. Address Range End
Public property | wHwIoType_4_Range | Supported I/O Range 4 (array size:36)
Public property | wHwIoType_4_Start | Hardware I/O Type 4 Data Reg. Address Range Start
Public property | wHwVer | Hardware Version
Public property | wLossConnection | Loss Connection
Public property | wLQI | Wireless signal intensity (LQI)
Public property | wMBSlaveID | Modbus Slave ID
Public property | wModuleStatus | Module current mode
Public property | wPanID | Pan ID
Public property | wParentShortAddr | Parent short address
Public property | wPowerConserve | Security
Public property | wSecurity | Security
Public property | wSerialPortConf | MSP430 serial port configuration
Public property | wShortAddr | Short address
Public property | wSupportFwVer | Supported Controller's Firmware Version
Public property | wTPTargetID | MSP430 transparent target ID
Public property | wTXPower | Transmit Power
Public property | wWirelessCh | 802.15.4 Wireless Channel
Top

Protected Properties

 | Name | Description
Family property | Data | (inherited from SelfMarshalledStruct)
Family property | Item | (inherited from SelfMarshalledStruct)
Top

See Also

Adam2000Config Class
Advantech.Adam Namespace


bBurnoutEnableStatus Property

Adam2000Config.bBurnoutEnableStatus Property
[image]

Burnout Enable Status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property bBurnoutEnableStatus As Byte
C#
public byte bBurnoutEnableStatus { get; set; }
C++
public property byte bBurnoutEnableStatus sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_bBurnoutEnableStatus();

/** property */
public void set_bBurnoutEnableStatus(byte value);
JScript
public function get bBurnoutEnableStatus() : Byte

public function set bBurnoutEnableStatus(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


bTagName Property

Adam2000Config.bTagName Property
[image]

Self-Defined description for this module (array size:10)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property bTagName As Byte()
C#
public byte[] bTagName { get; set; }
C++
public property byte[] bTagName sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_bTagName();

/** property */
public void set_bTagName(byte[] value);
JScript
public function get bTagName() : Byte[]

public function set bTagName(value : Byte[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byChTotal Property

Adam2000Config.byChTotal Property
[image]

Total # of Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byChTotal As Byte
C#
public byte byChTotal { get; set; }
C++
public property byte byChTotal sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byChTotal();

/** property */
public void set_byChTotal(byte value);
JScript
public function get byChTotal() : Byte

public function set byChTotal(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byConfigArea Property

Adam2000Config.byConfigArea Property
[image]

Config area for this module (array size:28)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byConfigArea As Byte()
C#
public byte[] byConfigArea { get; set; }
C++
public property byte[] byConfigArea sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_byConfigArea();

/** property */
public void set_byConfigArea(byte[] value);
JScript
public function get byConfigArea() : Byte[]

public function set byConfigArea(value : Byte[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byFunType_0 Property

Adam2000Config.byFunType_0 Property
[image]

Function Type 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_0 As Byte
C#
public byte byFunType_0 { get; set; }
C++
public property byte byFunType_0 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_0();

/** property */
public void set_byFunType_0(byte value);
JScript
public function get byFunType_0() : Byte

public function set byFunType_0(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byFunType_1 Property

Adam2000Config.byFunType_1 Property
[image]

Function Type 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_1 As Byte
C#
public byte byFunType_1 { get; set; }
C++
public property byte byFunType_1 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_1();

/** property */
public void set_byFunType_1(byte value);
JScript
public function get byFunType_1() : Byte

public function set byFunType_1(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byFunType_2 Property

Adam2000Config.byFunType_2 Property
[image]

Function Type 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_2 As Byte
C#
public byte byFunType_2 { get; set; }
C++
public property byte byFunType_2 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_2();

/** property */
public void set_byFunType_2(byte value);
JScript
public function get byFunType_2() : Byte

public function set byFunType_2(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byFunType_3 Property

Adam2000Config.byFunType_3 Property
[image]

Function Type 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_3 As Byte
C#
public byte byFunType_3 { get; set; }
C++
public property byte byFunType_3 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_3();

/** property */
public void set_byFunType_3(byte value);
JScript
public function get byFunType_3() : Byte

public function set byFunType_3(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byFunType_4 Property

Adam2000Config.byFunType_4 Property
[image]

Function Type 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_4 As Byte
C#
public byte byFunType_4 { get; set; }
C++
public property byte byFunType_4 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_4();

/** property */
public void set_byFunType_4(byte value);
JScript
public function get byFunType_4() : Byte

public function set byFunType_4(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoTotal_0 Property

Adam2000Config.byHwIoTotal_0 Property
[image]

No. of Hardware I/O Type 0 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_0 As Byte
C#
public byte byHwIoTotal_0 { get; set; }
C++
public property byte byHwIoTotal_0 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_0();

/** property */
public void set_byHwIoTotal_0(byte value);
JScript
public function get byHwIoTotal_0() : Byte

public function set byHwIoTotal_0(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoTotal_1 Property

Adam2000Config.byHwIoTotal_1 Property
[image]

No. of Hardware I/O Type 1 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_1 As Byte
C#
public byte byHwIoTotal_1 { get; set; }
C++
public property byte byHwIoTotal_1 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_1();

/** property */
public void set_byHwIoTotal_1(byte value);
JScript
public function get byHwIoTotal_1() : Byte

public function set byHwIoTotal_1(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoTotal_2 Property

Adam2000Config.byHwIoTotal_2 Property
[image]

No. of Hardware I/O Type 2 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_2 As Byte
C#
public byte byHwIoTotal_2 { get; set; }
C++
public property byte byHwIoTotal_2 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_2();

/** property */
public void set_byHwIoTotal_2(byte value);
JScript
public function get byHwIoTotal_2() : Byte

public function set byHwIoTotal_2(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoTotal_3 Property

Adam2000Config.byHwIoTotal_3 Property
[image]

No. of Hardware I/O Type 3 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_3 As Byte
C#
public byte byHwIoTotal_3 { get; set; }
C++
public property byte byHwIoTotal_3 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_3();

/** property */
public void set_byHwIoTotal_3(byte value);
JScript
public function get byHwIoTotal_3() : Byte

public function set byHwIoTotal_3(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoTotal_4 Property

Adam2000Config.byHwIoTotal_4 Property
[image]

No. of Hardware I/O Type 4 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_4 As Byte
C#
public byte byHwIoTotal_4 { get; set; }
C++
public property byte byHwIoTotal_4 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_4();

/** property */
public void set_byHwIoTotal_4(byte value);
JScript
public function get byHwIoTotal_4() : Byte

public function set byHwIoTotal_4(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_0 Property

Adam2000Config.byHwIoType_0 Property
[image]

Hardware I/O Type 0 (i.e: Device type )

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_0 As Byte
C#
public byte byHwIoType_0 { get; set; }
C++
public property byte byHwIoType_0 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_0();

/** property */
public void set_byHwIoType_0(byte value);
JScript
public function get byHwIoType_0() : Byte

public function set byHwIoType_0(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_0_Resolution Property

Adam2000Config.byHwIoType_0_Resolution Property
[image]

Resolution 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_0_Resolution As Byte
C#
public byte byHwIoType_0_Resolution { get; set; }
C++
public property byte byHwIoType_0_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_0_Resolution();

/** property */
public void set_byHwIoType_0_Resolution(byte value);
JScript
public function get byHwIoType_0_Resolution() : Byte

public function set byHwIoType_0_Resolution(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_0_TotalRangeNumber Property

Adam2000Config.byHwIoType_0_TotalRangeNumber Property
[image]

Total number of Supported I/O Range 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_0_TotalRangeNumber As Byte
C#
public byte byHwIoType_0_TotalRangeNumber { get; set; }
C++
public property byte byHwIoType_0_TotalRangeNumber sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_0_TotalRangeNumber();

/** property */
public void set_byHwIoType_0_TotalRangeNumber(byte value);
JScript
public function get byHwIoType_0_TotalRangeNumber() : Byte

public function set byHwIoType_0_TotalRangeNumber(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_1 Property

Adam2000Config.byHwIoType_1 Property
[image]

Hardware I/O Type 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_1 As Byte
C#
public byte byHwIoType_1 { get; set; }
C++
public property byte byHwIoType_1 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_1();

/** property */
public void set_byHwIoType_1(byte value);
JScript
public function get byHwIoType_1() : Byte

public function set byHwIoType_1(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_1_Resolution Property

Adam2000Config.byHwIoType_1_Resolution Property
[image]

Resolution 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_1_Resolution As Byte
C#
public byte byHwIoType_1_Resolution { get; set; }
C++
public property byte byHwIoType_1_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_1_Resolution();

/** property */
public void set_byHwIoType_1_Resolution(byte value);
JScript
public function get byHwIoType_1_Resolution() : Byte

public function set byHwIoType_1_Resolution(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_1_TotalRangeNumber Property

Adam2000Config.byHwIoType_1_TotalRangeNumber Property
[image]

Total number of Supported I/O Range 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_1_TotalRangeNumber As Byte
C#
public byte byHwIoType_1_TotalRangeNumber { get; set; }
C++
public property byte byHwIoType_1_TotalRangeNumber sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_1_TotalRangeNumber();

/** property */
public void set_byHwIoType_1_TotalRangeNumber(byte value);
JScript
public function get byHwIoType_1_TotalRangeNumber() : Byte

public function set byHwIoType_1_TotalRangeNumber(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_2 Property

Adam2000Config.byHwIoType_2 Property
[image]

Hardware I/O Type 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_2 As Byte
C#
public byte byHwIoType_2 { get; set; }
C++
public property byte byHwIoType_2 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_2();

/** property */
public void set_byHwIoType_2(byte value);
JScript
public function get byHwIoType_2() : Byte

public function set byHwIoType_2(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_2_Resolution Property

Adam2000Config.byHwIoType_2_Resolution Property
[image]

Resolution 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_2_Resolution As Byte
C#
public byte byHwIoType_2_Resolution { get; set; }
C++
public property byte byHwIoType_2_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_2_Resolution();

/** property */
public void set_byHwIoType_2_Resolution(byte value);
JScript
public function get byHwIoType_2_Resolution() : Byte

public function set byHwIoType_2_Resolution(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_2_TotalRangeNumber Property

Adam2000Config.byHwIoType_2_TotalRangeNumber Property
[image]

Total number of Supported I/O Range 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_2_TotalRangeNumber As Byte
C#
public byte byHwIoType_2_TotalRangeNumber { get; set; }
C++
public property byte byHwIoType_2_TotalRangeNumber sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_2_TotalRangeNumber();

/** property */
public void set_byHwIoType_2_TotalRangeNumber(byte value);
JScript
public function get byHwIoType_2_TotalRangeNumber() : Byte

public function set byHwIoType_2_TotalRangeNumber(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_3 Property

Adam2000Config.byHwIoType_3 Property
[image]

Hardware I/O Type 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_3 As Byte
C#
public byte byHwIoType_3 { get; set; }
C++
public property byte byHwIoType_3 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_3();

/** property */
public void set_byHwIoType_3(byte value);
JScript
public function get byHwIoType_3() : Byte

public function set byHwIoType_3(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_3_Resolution Property

Adam2000Config.byHwIoType_3_Resolution Property
[image]

Resolution 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_3_Resolution As Byte
C#
public byte byHwIoType_3_Resolution { get; set; }
C++
public property byte byHwIoType_3_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_3_Resolution();

/** property */
public void set_byHwIoType_3_Resolution(byte value);
JScript
public function get byHwIoType_3_Resolution() : Byte

public function set byHwIoType_3_Resolution(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_3_TotalRangeNumber Property

Adam2000Config.byHwIoType_3_TotalRangeNumber Property
[image]

Total number of Supported I/O Range 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_3_TotalRangeNumber As Byte
C#
public byte byHwIoType_3_TotalRangeNumber { get; set; }
C++
public property byte byHwIoType_3_TotalRangeNumber sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_3_TotalRangeNumber();

/** property */
public void set_byHwIoType_3_TotalRangeNumber(byte value);
JScript
public function get byHwIoType_3_TotalRangeNumber() : Byte

public function set byHwIoType_3_TotalRangeNumber(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_4 Property

Adam2000Config.byHwIoType_4 Property
[image]

Hardware I/O Type 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_4 As Byte
C#
public byte byHwIoType_4 { get; set; }
C++
public property byte byHwIoType_4 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_4();

/** property */
public void set_byHwIoType_4(byte value);
JScript
public function get byHwIoType_4() : Byte

public function set byHwIoType_4(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_4_Resolution Property

Adam2000Config.byHwIoType_4_Resolution Property
[image]

Resolution 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_4_Resolution As Byte
C#
public byte byHwIoType_4_Resolution { get; set; }
C++
public property byte byHwIoType_4_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_4_Resolution();

/** property */
public void set_byHwIoType_4_Resolution(byte value);
JScript
public function get byHwIoType_4_Resolution() : Byte

public function set byHwIoType_4_Resolution(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byHwIoType_4_TotalRangeNumber Property

Adam2000Config.byHwIoType_4_TotalRangeNumber Property
[image]

Total number of Supported I/O Range 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_4_TotalRangeNumber As Byte
C#
public byte byHwIoType_4_TotalRangeNumber { get; set; }
C++
public property byte byHwIoType_4_TotalRangeNumber sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_4_TotalRangeNumber();

/** property */
public void set_byHwIoType_4_TotalRangeNumber(byte value);
JScript
public function get byHwIoType_4_TotalRangeNumber() : Byte

public function set byHwIoType_4_TotalRangeNumber(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


byOperationMode Property

Adam2000Config.byOperationMode Property
[image]

MSP430 transparent mode enable

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byOperationMode As Byte
C#
public byte byOperationMode { get; set; }
C++
public property byte byOperationMode sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byOperationMode();

/** property */
public void set_byOperationMode(byte value);
JScript
public function get byOperationMode() : Byte

public function set byOperationMode(value : Byte);

See Also

Adam2000Config Class
Advantech.Adam Namespace


DataArray Property

Adam2000Config.DataArray Property
[image]

Data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataArray As Byte()
C#
public byte[] DataArray { get; }
C++
public property byte[] DataArray sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_DataArray();
JScript
public function get DataArray() : Byte[]

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwActCycle Property

Adam2000Config.dwActCycle Property
[image]

Active Cycle

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwActCycle As UInt32
C#
public uint dwActCycle { get; set; }
C++
public property uint dwActCycle sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwActCycle();

/** property */
public void set_dwActCycle(uint value);
JScript
public function get dwActCycle() : UInt32

public function set dwActCycle(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwAlarmMask Property

Adam2000Config.dwAlarmMask Property
[image]

Alarm State Mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwAlarmMask As UInt32
C#
public uint dwAlarmMask { get; set; }
C++
public property uint dwAlarmMask sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwAlarmMask();

/** property */
public void set_dwAlarmMask(uint value);
JScript
public function get dwAlarmMask() : UInt32

public function set dwAlarmMask(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwChMask Property

Adam2000Config.dwChMask Property
[image]

Channel Enabled Mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwChMask As UInt32
C#
public uint dwChMask { get; set; }
C++
public property uint dwChMask sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwChMask();

/** property */
public void set_dwChMask(uint value);
JScript
public function get dwChMask() : UInt32

public function set dwChMask(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunMask_0 Property

Adam2000Config.dwFunMask_0 Property
[image]

Enable Mask 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_0 As UInt32
C#
public uint dwFunMask_0 { get; set; }
C++
public property uint dwFunMask_0 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_0();

/** property */
public void set_dwFunMask_0(uint value);
JScript
public function get dwFunMask_0() : UInt32

public function set dwFunMask_0(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunMask_1 Property

Adam2000Config.dwFunMask_1 Property
[image]

Enable Mask 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_1 As UInt32
C#
public uint dwFunMask_1 { get; set; }
C++
public property uint dwFunMask_1 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_1();

/** property */
public void set_dwFunMask_1(uint value);
JScript
public function get dwFunMask_1() : UInt32

public function set dwFunMask_1(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunMask_2 Property

Adam2000Config.dwFunMask_2 Property
[image]

Enable Mask 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_2 As UInt32
C#
public uint dwFunMask_2 { get; set; }
C++
public property uint dwFunMask_2 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_2();

/** property */
public void set_dwFunMask_2(uint value);
JScript
public function get dwFunMask_2() : UInt32

public function set dwFunMask_2(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunMask_3 Property

Adam2000Config.dwFunMask_3 Property
[image]

Enable Mask 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_3 As UInt32
C#
public uint dwFunMask_3 { get; set; }
C++
public property uint dwFunMask_3 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_3();

/** property */
public void set_dwFunMask_3(uint value);
JScript
public function get dwFunMask_3() : UInt32

public function set dwFunMask_3(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunMask_4 Property

Adam2000Config.dwFunMask_4 Property
[image]

Enable Mask 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_4 As UInt32
C#
public uint dwFunMask_4 { get; set; }
C++
public property uint dwFunMask_4 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_4();

/** property */
public void set_dwFunMask_4(uint value);
JScript
public function get dwFunMask_4() : UInt32

public function set dwFunMask_4(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunParam_0 Property

Adam2000Config.dwFunParam_0 Property
[image]

Function parameter 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_0 As UInt32
C#
public uint dwFunParam_0 { get; set; }
C++
public property uint dwFunParam_0 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_0();

/** property */
public void set_dwFunParam_0(uint value);
JScript
public function get dwFunParam_0() : UInt32

public function set dwFunParam_0(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunParam_1 Property

Adam2000Config.dwFunParam_1 Property
[image]

Function parameter 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_1 As UInt32
C#
public uint dwFunParam_1 { get; set; }
C++
public property uint dwFunParam_1 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_1();

/** property */
public void set_dwFunParam_1(uint value);
JScript
public function get dwFunParam_1() : UInt32

public function set dwFunParam_1(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunParam_2 Property

Adam2000Config.dwFunParam_2 Property
[image]

Function parameter 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_2 As UInt32
C#
public uint dwFunParam_2 { get; set; }
C++
public property uint dwFunParam_2 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_2();

/** property */
public void set_dwFunParam_2(uint value);
JScript
public function get dwFunParam_2() : UInt32

public function set dwFunParam_2(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunParam_3 Property

Adam2000Config.dwFunParam_3 Property
[image]

Function parameter 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_3 As UInt32
C#
public uint dwFunParam_3 { get; set; }
C++
public property uint dwFunParam_3 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_3();

/** property */
public void set_dwFunParam_3(uint value);
JScript
public function get dwFunParam_3() : UInt32

public function set dwFunParam_3(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwFunParam_4 Property

Adam2000Config.dwFunParam_4 Property
[image]

Function parameter 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_4 As UInt32
C#
public uint dwFunParam_4 { get; set; }
C++
public property uint dwFunParam_4 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_4();

/** property */
public void set_dwFunParam_4(uint value);
JScript
public function get dwFunParam_4() : UInt32

public function set dwFunParam_4(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


dwModName Property

Adam2000Config.dwModName Property
[image]

Module Name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwModName As UInt32
C#
public uint dwModName { get; set; }
C++
public property uint dwModName sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwModName();

/** property */
public void set_dwModName(uint value);
JScript
public function get dwModName() : UInt32

public function set dwModName(value : UInt32);

See Also

Adam2000Config Class
Advantech.Adam Namespace


Handle Property

Adam2000Config.Handle Property
[image]

Handle

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle { get; }
C++
public property IntPtr Handle sealed {
IntPtr get();
}
J#
/** property */
public IntPtr get_Handle();
JScript
public function get Handle() : IntPtr

See Also

Adam2000Config Class
Advantech.Adam Namespace


HwIoTotal Property

Adam2000Config.HwIoTotal Property
[image]

No. of Hardware I/O Type 0-4 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HwIoTotal As Byte()
C#
public byte[] HwIoTotal { get; }
C++
public property byte[] HwIoTotal sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_HwIoTotal();
JScript
public function get HwIoTotal() : Byte[]

See Also

Adam2000Config Class
Advantech.Adam Namespace


HwIoType Property

Adam2000Config.HwIoType Property
[image]

Hardware I/O Type 0-4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HwIoType As Byte()
C#
public byte[] HwIoType { get; }
C++
public property byte[] HwIoType sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_HwIoType();
JScript
public function get HwIoType() : Byte[]

See Also

Adam2000Config Class
Advantech.Adam Namespace


HwIoType_TotalRangeNumber Property

Adam2000Config.HwIoType_TotalRangeNumber Property
[image]

Total number of Supported I/O Range 0-4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HwIoType_TotalRangeNumber As Byte()
C#
public byte[] HwIoType_TotalRangeNumber { get; }
C++
public property byte[] HwIoType_TotalRangeNumber sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_HwIoType_TotalRangeNumber();
JScript
public function get HwIoType_TotalRangeNumber() : Byte[]

See Also

Adam2000Config Class
Advantech.Adam Namespace


Length Property

Adam2000Config.Length Property
[image]

Adam2000 module information size

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Length As Integer
C#
public static int Length { get; }
C++
public static property int Length {
int get();
}
J#
/** property */
public int get_Length();
JScript
public function get Length() : int

See Also

Adam2000Config Class
Advantech.Adam Namespace


w430DevType Property

Adam2000Config.w430DevType Property
[image]

MSP430 firmware build version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property w430DevType As UInt16
C#
public ushort w430DevType { get; set; }
C++
public property ushort w430DevType sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_w430DevType();

/** property */
public void set_w430DevType(ushort value);
JScript
public function get w430DevType() : UInt16

public function set w430DevType(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


w430FwVer Property

Adam2000Config.w430FwVer Property
[image]

MSP430 firmware version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property w430FwVer As UInt16
C#
public ushort w430FwVer { get; set; }
C++
public property ushort w430FwVer sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_w430FwVer();

/** property */
public void set_w430FwVer(ushort value);
JScript
public function get w430FwVer() : UInt16

public function set w430FwVer(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


w430FwVerBuild Property

Adam2000Config.w430FwVerBuild Property
[image]

MSP430 firmware build version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property w430FwVerBuild As UInt16
C#
public ushort w430FwVerBuild { get; set; }
C++
public property ushort w430FwVerBuild sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_w430FwVerBuild();

/** property */
public void set_w430FwVerBuild(ushort value);
JScript
public function get w430FwVerBuild() : UInt16

public function set w430FwVerBuild(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wAdvStatus Property

Adam2000Config.wAdvStatus Property
[image]

Power source (Battery or external power)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wAdvStatus As UInt16
C#
public ushort wAdvStatus { get; set; }
C++
public property ushort wAdvStatus sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wAdvStatus();

/** property */
public void set_wAdvStatus(ushort value);
JScript
public function get wAdvStatus() : UInt16

public function set wAdvStatus(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wBetteryStatus Property

Adam2000Config.wBetteryStatus Property
[image]

Battery status (Battery level)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wBetteryStatus As UInt16
C#
public ushort wBetteryStatus { get; set; }
C++
public property ushort wBetteryStatus sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wBetteryStatus();

/** property */
public void set_wBetteryStatus(ushort value);
JScript
public function get wBetteryStatus() : UInt16

public function set wBetteryStatus(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wChRange Property

Adam2000Config.wChRange Property
[image]

Current I/O Range Type (array size:32)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wChRange As UInt16()
C#
public ushort[] wChRange { get; set; }
C++
public property ushort[] wChRange sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wChRange();

/** property */
public void set_wChRange(ushort[] value);
JScript
public function get wChRange() : UInt16[]

public function set wChRange(value : UInt16[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wChTotal Property

Adam2000Config.wChTotal Property
[image]

Total # of Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wChTotal As UInt16
C#
public ushort wChTotal { get; set; }
C++
public property ushort wChTotal sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wChTotal();

/** property */
public void set_wChTotal(ushort value);
JScript
public function get wChTotal() : UInt16

public function set wChTotal(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wDeadConnection Property

Adam2000Config.wDeadConnection Property
[image]

Dead Connection

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wDeadConnection As UInt16
C#
public ushort wDeadConnection { get; set; }
C++
public property ushort wDeadConnection sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wDeadConnection();

/** property */
public void set_wDeadConnection(ushort value);
JScript
public function get wDeadConnection() : UInt16

public function set wDeadConnection(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wDevType Property

Adam2000Config.wDevType Property
[image]

Device Type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wDevType As UInt16
C#
public ushort wDevType { get; set; }
C++
public property ushort wDevType sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wDevType();

/** property */
public void set_wDevType(ushort value);
JScript
public function get wDevType() : UInt16

public function set wDevType(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wFwVerBld Property

Adam2000Config.wFwVerBld Property
[image]

Firmware Build Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wFwVerBld As UInt16
C#
public ushort wFwVerBld { get; set; }
C++
public property ushort wFwVerBld sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wFwVerBld();

/** property */
public void set_wFwVerBld(ushort value);
JScript
public function get wFwVerBld() : UInt16

public function set wFwVerBld(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wFwVerNo Property

Adam2000Config.wFwVerNo Property
[image]

Firmware Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wFwVerNo As UInt16
C#
public ushort wFwVerNo { get; set; }
C++
public property ushort wFwVerNo sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wFwVerNo();

/** property */
public void set_wFwVerNo(ushort value);
JScript
public function get wFwVerNo() : UInt16

public function set wFwVerNo(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_0_End Property

Adam2000Config.wHwIoType_0_End Property
[image]

Hardware I/O Type 0 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_End As UInt16
C#
public ushort wHwIoType_0_End { get; set; }
C++
public property ushort wHwIoType_0_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_0_End();

/** property */
public void set_wHwIoType_0_End(ushort value);
JScript
public function get wHwIoType_0_End() : UInt16

public function set wHwIoType_0_End(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_0_Range Property

Adam2000Config.wHwIoType_0_Range Property
[image]

Supported I/O Range 0 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_Range As UInt16()
C#
public ushort[] wHwIoType_0_Range { get; set; }
C++
public property ushort[] wHwIoType_0_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_0_Range();

/** property */
public void set_wHwIoType_0_Range(ushort[] value);
JScript
public function get wHwIoType_0_Range() : UInt16[]

public function set wHwIoType_0_Range(value : UInt16[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_0_Start Property

Adam2000Config.wHwIoType_0_Start Property
[image]

Hardware I/O Type 0 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_Start As UInt16
C#
public ushort wHwIoType_0_Start { get; set; }
C++
public property ushort wHwIoType_0_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_0_Start();

/** property */
public void set_wHwIoType_0_Start(ushort value);
JScript
public function get wHwIoType_0_Start() : UInt16

public function set wHwIoType_0_Start(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_1_End Property

Adam2000Config.wHwIoType_1_End Property
[image]

Hardware I/O Type 1 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_End As UInt16
C#
public ushort wHwIoType_1_End { get; set; }
C++
public property ushort wHwIoType_1_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_1_End();

/** property */
public void set_wHwIoType_1_End(ushort value);
JScript
public function get wHwIoType_1_End() : UInt16

public function set wHwIoType_1_End(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_1_Range Property

Adam2000Config.wHwIoType_1_Range Property
[image]

Supported I/O Range 1 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_Range As UInt16()
C#
public ushort[] wHwIoType_1_Range { get; set; }
C++
public property ushort[] wHwIoType_1_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_1_Range();

/** property */
public void set_wHwIoType_1_Range(ushort[] value);
JScript
public function get wHwIoType_1_Range() : UInt16[]

public function set wHwIoType_1_Range(value : UInt16[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_1_Start Property

Adam2000Config.wHwIoType_1_Start Property
[image]

Hardware I/O Type 1 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_Start As UInt16
C#
public ushort wHwIoType_1_Start { get; set; }
C++
public property ushort wHwIoType_1_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_1_Start();

/** property */
public void set_wHwIoType_1_Start(ushort value);
JScript
public function get wHwIoType_1_Start() : UInt16

public function set wHwIoType_1_Start(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_2_End Property

Adam2000Config.wHwIoType_2_End Property
[image]

Hardware I/O Type 2 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_End As UInt16
C#
public ushort wHwIoType_2_End { get; set; }
C++
public property ushort wHwIoType_2_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_2_End();

/** property */
public void set_wHwIoType_2_End(ushort value);
JScript
public function get wHwIoType_2_End() : UInt16

public function set wHwIoType_2_End(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_2_Range Property

Adam2000Config.wHwIoType_2_Range Property
[image]

Supported I/O Range 2 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_Range As UInt16()
C#
public ushort[] wHwIoType_2_Range { get; set; }
C++
public property ushort[] wHwIoType_2_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_2_Range();

/** property */
public void set_wHwIoType_2_Range(ushort[] value);
JScript
public function get wHwIoType_2_Range() : UInt16[]

public function set wHwIoType_2_Range(value : UInt16[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_2_Start Property

Adam2000Config.wHwIoType_2_Start Property
[image]

Hardware I/O Type 2 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_Start As UInt16
C#
public ushort wHwIoType_2_Start { get; set; }
C++
public property ushort wHwIoType_2_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_2_Start();

/** property */
public void set_wHwIoType_2_Start(ushort value);
JScript
public function get wHwIoType_2_Start() : UInt16

public function set wHwIoType_2_Start(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_3_End Property

Adam2000Config.wHwIoType_3_End Property
[image]

Hardware I/O Type 3 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_End As UInt16
C#
public ushort wHwIoType_3_End { get; set; }
C++
public property ushort wHwIoType_3_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_3_End();

/** property */
public void set_wHwIoType_3_End(ushort value);
JScript
public function get wHwIoType_3_End() : UInt16

public function set wHwIoType_3_End(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_3_Range Property

Adam2000Config.wHwIoType_3_Range Property
[image]

Supported I/O Range 3 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_Range As UInt16()
C#
public ushort[] wHwIoType_3_Range { get; set; }
C++
public property ushort[] wHwIoType_3_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_3_Range();

/** property */
public void set_wHwIoType_3_Range(ushort[] value);
JScript
public function get wHwIoType_3_Range() : UInt16[]

public function set wHwIoType_3_Range(value : UInt16[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_3_Start Property

Adam2000Config.wHwIoType_3_Start Property
[image]

Hardware I/O Type 3 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_Start As UInt16
C#
public ushort wHwIoType_3_Start { get; set; }
C++
public property ushort wHwIoType_3_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_3_Start();

/** property */
public void set_wHwIoType_3_Start(ushort value);
JScript
public function get wHwIoType_3_Start() : UInt16

public function set wHwIoType_3_Start(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_4_End Property

Adam2000Config.wHwIoType_4_End Property
[image]

Hardware I/O Type 4 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_End As UInt16
C#
public ushort wHwIoType_4_End { get; set; }
C++
public property ushort wHwIoType_4_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_4_End();

/** property */
public void set_wHwIoType_4_End(ushort value);
JScript
public function get wHwIoType_4_End() : UInt16

public function set wHwIoType_4_End(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_4_Range Property

Adam2000Config.wHwIoType_4_Range Property
[image]

Supported I/O Range 4 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_Range As UInt16()
C#
public ushort[] wHwIoType_4_Range { get; set; }
C++
public property ushort[] wHwIoType_4_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_4_Range();

/** property */
public void set_wHwIoType_4_Range(ushort[] value);
JScript
public function get wHwIoType_4_Range() : UInt16[]

public function set wHwIoType_4_Range(value : UInt16[]);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwIoType_4_Start Property

Adam2000Config.wHwIoType_4_Start Property
[image]

Hardware I/O Type 4 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_Start As UInt16
C#
public ushort wHwIoType_4_Start { get; set; }
C++
public property ushort wHwIoType_4_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_4_Start();

/** property */
public void set_wHwIoType_4_Start(ushort value);
JScript
public function get wHwIoType_4_Start() : UInt16

public function set wHwIoType_4_Start(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wHwVer Property

Adam2000Config.wHwVer Property
[image]

Hardware Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwVer As UInt16
C#
public ushort wHwVer { get; set; }
C++
public property ushort wHwVer sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwVer();

/** property */
public void set_wHwVer(ushort value);
JScript
public function get wHwVer() : UInt16

public function set wHwVer(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wLossConnection Property

Adam2000Config.wLossConnection Property
[image]

Loss Connection

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wLossConnection As UInt16
C#
public ushort wLossConnection { get; set; }
C++
public property ushort wLossConnection sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wLossConnection();

/** property */
public void set_wLossConnection(ushort value);
JScript
public function get wLossConnection() : UInt16

public function set wLossConnection(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wLQI Property

Adam2000Config.wLQI Property
[image]

Wireless signal intensity (LQI)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wLQI As UInt16
C#
public ushort wLQI { get; set; }
C++
public property ushort wLQI sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wLQI();

/** property */
public void set_wLQI(ushort value);
JScript
public function get wLQI() : UInt16

public function set wLQI(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wMBSlaveID Property

Adam2000Config.wMBSlaveID Property
[image]

Modbus Slave ID

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wMBSlaveID As UInt16
C#
public ushort wMBSlaveID { get; set; }
C++
public property ushort wMBSlaveID sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wMBSlaveID();

/** property */
public void set_wMBSlaveID(ushort value);
JScript
public function get wMBSlaveID() : UInt16

public function set wMBSlaveID(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wModuleStatus Property

Adam2000Config.wModuleStatus Property
[image]

Module current mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wModuleStatus As UInt16
C#
public ushort wModuleStatus { get; set; }
C++
public property ushort wModuleStatus sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wModuleStatus();

/** property */
public void set_wModuleStatus(ushort value);
JScript
public function get wModuleStatus() : UInt16

public function set wModuleStatus(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wPanID Property

Adam2000Config.wPanID Property
[image]

Pan ID

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wPanID As UInt16
C#
public ushort wPanID { get; set; }
C++
public property ushort wPanID sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wPanID();

/** property */
public void set_wPanID(ushort value);
JScript
public function get wPanID() : UInt16

public function set wPanID(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wParentShortAddr Property

Adam2000Config.wParentShortAddr Property
[image]

Parent short address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wParentShortAddr As UInt16
C#
public ushort wParentShortAddr { get; set; }
C++
public property ushort wParentShortAddr sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wParentShortAddr();

/** property */
public void set_wParentShortAddr(ushort value);
JScript
public function get wParentShortAddr() : UInt16

public function set wParentShortAddr(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wPowerConserve Property

Adam2000Config.wPowerConserve Property
[image]

Security

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wPowerConserve As UInt16
C#
public ushort wPowerConserve { get; set; }
C++
public property ushort wPowerConserve sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wPowerConserve();

/** property */
public void set_wPowerConserve(ushort value);
JScript
public function get wPowerConserve() : UInt16

public function set wPowerConserve(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wSecurity Property

Adam2000Config.wSecurity Property
[image]

Security

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wSecurity As UInt16
C#
public ushort wSecurity { get; set; }
C++
public property ushort wSecurity sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wSecurity();

/** property */
public void set_wSecurity(ushort value);
JScript
public function get wSecurity() : UInt16

public function set wSecurity(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wSerialPortConf Property

Adam2000Config.wSerialPortConf Property
[image]

MSP430 serial port configuration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wSerialPortConf As UInt16
C#
public ushort wSerialPortConf { get; set; }
C++
public property ushort wSerialPortConf sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wSerialPortConf();

/** property */
public void set_wSerialPortConf(ushort value);
JScript
public function get wSerialPortConf() : UInt16

public function set wSerialPortConf(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wShortAddr Property

Adam2000Config.wShortAddr Property
[image]

Short address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wShortAddr As UInt16
C#
public ushort wShortAddr { get; set; }
C++
public property ushort wShortAddr sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wShortAddr();

/** property */
public void set_wShortAddr(ushort value);
JScript
public function get wShortAddr() : UInt16

public function set wShortAddr(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wSupportFwVer Property

Adam2000Config.wSupportFwVer Property
[image]

Supported Controller's Firmware Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wSupportFwVer As UInt16
C#
public ushort wSupportFwVer { get; set; }
C++
public property ushort wSupportFwVer sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wSupportFwVer();

/** property */
public void set_wSupportFwVer(ushort value);
JScript
public function get wSupportFwVer() : UInt16

public function set wSupportFwVer(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wTPTargetID Property

Adam2000Config.wTPTargetID Property
[image]

MSP430 transparent target ID

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wTPTargetID As UInt16
C#
public ushort wTPTargetID { get; set; }
C++
public property ushort wTPTargetID sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wTPTargetID();

/** property */
public void set_wTPTargetID(ushort value);
JScript
public function get wTPTargetID() : UInt16

public function set wTPTargetID(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wTXPower Property

Adam2000Config.wTXPower Property
[image]

Transmit Power

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wTXPower As UInt16
C#
public ushort wTXPower { get; set; }
C++
public property ushort wTXPower sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wTXPower();

/** property */
public void set_wTXPower(ushort value);
JScript
public function get wTXPower() : UInt16

public function set wTXPower(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


wWirelessCh Property

Adam2000Config.wWirelessCh Property
[image]

802.15.4 Wireless Channel

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wWirelessCh As UInt16
C#
public ushort wWirelessCh { get; set; }
C++
public property ushort wWirelessCh sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wWirelessCh();

/** property */
public void set_wWirelessCh(ushort value);
JScript
public function get wWirelessCh() : UInt16

public function set wWirelessCh(value : UInt16);

See Also

Adam2000Config Class
Advantech.Adam Namespace


Methods

Adam2000Config Methods
[image]

Public Methods

 | Name | Description
Public method | GetExtBuf | Get Extension buffer value
Public method | GetModuleName | Get the module name string.
Public method | SetExtBuf | Set Extension buffer value
Top

Protected Methods

 | Name | Description
Family method | Get | (inherited from SelfMarshalledStruct)
Family method | GetByte | (inherited from SelfMarshalledStruct)
Family method | GetChar | (inherited from SelfMarshalledStruct)
Family method | GetInt16 | (inherited from SelfMarshalledStruct)
Family method | GetInt32 | (inherited from SelfMarshalledStruct)
Family method | GetIntPtr | (inherited from SelfMarshalledStruct)
Family method | GetSlice | (inherited from SelfMarshalledStruct)
Family method | GetStringAscii | (inherited from SelfMarshalledStruct)
Family method | GetStringUni | (inherited from SelfMarshalledStruct)
Family method | GetUInt16 | (inherited from SelfMarshalledStruct)
Family method | GetUInt32 | (inherited from SelfMarshalledStruct)
Family method | Set | (inherited from SelfMarshalledStruct)
Family method | SetByte | (inherited from SelfMarshalledStruct)
Family method | SetChar | (inherited from SelfMarshalledStruct)
Family method | SetInt16 | (inherited from SelfMarshalledStruct)
Family method | SetInt32 | (inherited from SelfMarshalledStruct)
Family method | SetIntPtr | (inherited from SelfMarshalledStruct)
Family method | SetStringUni | (inherited from SelfMarshalledStruct)
Family method | SetUInt16 | (inherited from SelfMarshalledStruct)
Family method | SetUInt32 | (inherited from SelfMarshalledStruct)
Top

See Also

Adam2000Config Class
Advantech.Adam Namespace


GetExtBuf Method

Adam2000Config.GetExtBuf Method
[image]

Get Extension buffer value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExtBuf( _
ByVal idx As Integer _
) As Byte
C#
public byte GetExtBuf(
int idx
)
C++
public:
char GetExtBuf(
int idx
) sealed
J#
public byte GetExtBuf(
int idx
)
JScript
public function GetExtBuf(
idx : int
) : Byte

Parameters

idx
Extension buffer index

See Also

Adam2000Config Class
Advantech.Adam Namespace


GetModuleName Method

Adam2000Config.GetModuleName Method
[image]

Get the module name string.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleName() As String
C#
public string GetModuleName()
C++
public:
String GetModuleName() sealed
J#
public string GetModuleName()
JScript
public function GetModuleName() : String

See Also

Adam2000Config Class
Advantech.Adam Namespace


SetExtBuf Method

Adam2000Config.SetExtBuf Method
[image]

Set Extension buffer value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetExtBuf( _
ByVal idx As Integer, _
ByVal i_byVal As Byte _
)
C#
public void SetExtBuf(
int idx,
byte i_byVal
)
C++
public:
void SetExtBuf(
int idx,
char i_byVal
) sealed
J#
public void SetExtBuf(
int idx,
byte i_byVal
)
JScript
public function SetExtBuf(
idx : int,
i_byVal : Byte
)

Parameters

idx
Extension buffer index
i_byVal

See Also

Adam2000Config Class
Advantech.Adam Namespace


Adam2000Type Enumeration

Adam2000Type Enumeration
[image]

The ADAM 2000 module type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2000Type As
C#
public enum Adam2000Type : uint
C++
public enum class Adam2000Type : unsigned int
J#
public enum Adam2000Type uint
JScript
public enum Adam2000Type :

Members

Member Name | Description
Non | Non module
Adam2011Z | ADAM-2011
Adam2012Z | ADAM-2012
Adam2015Z | ADAM-2015
Adam2017Z | ADAM-2017
Adam2017PZ | ADAM-2017P
Adam2018Z | ADAM-2018
Adam2031Z | ADAM-2031
Adam2051Z | ADAM-2051
Adam2051PZ | ADAM-2051P
Adam2060Z | ADAM-2060
Adam2510Z | ADAM-2510
Adam2520Z | ADAM-2520

See Also

Advantech.Adam Namespace


Adam2kChannelType Enumeration

Adam2kChannelType Enumeration
[image]

Sensor module channel type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam2kChannelType
C#
public enum Adam2kChannelType
C++
public enum class Adam2kChannelType
J#
public enum Adam2kChannelType
JScript
public enum Adam2kChannelType

Members

Member Name | Description
Temperature | Temperature channel
Humidity | Humidity channel

See Also

Advantech.Adam Namespace


Adam4000_ChannelStatus Enumeration

Adam4000_ChannelStatus Enumeration
[image]

The channel status for analog input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4000_ChannelStatus As Byte
C#
public enum Adam4000_ChannelStatus : byte
C++
public enum class Adam4000_ChannelStatus : char
J#
public enum Adam4000_ChannelStatus byte
JScript
public enum Adam4000_ChannelStatus :

Members

Member Name | Description
Normal | Normal
Over | Over range
Under | Under range
Burn | Burn out
Disable | Disabled

See Also

Advantech.Adam Namespace


Adam4000_CounterAlarmMode Enumeration

Adam4000_CounterAlarmMode Enumeration
[image]

The counter alarm mode for ADAM-4000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4000_CounterAlarmMode As Byte
C#
public enum Adam4000_CounterAlarmMode : byte
C++
public enum class Adam4000_CounterAlarmMode : char
J#
public enum Adam4000_CounterAlarmMode byte
JScript
public enum Adam4000_CounterAlarmMode :

Members

Member Name | Description
Disable | Disable, 'D'
Latch | Latch, 'L'
Momentary | Momentary, 'M'
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4000_DataFormat Enumeration

Adam4000_DataFormat Enumeration
[image]

The data format for analog input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4000_DataFormat As Byte
C#
public enum Adam4000_DataFormat : byte
C++
public enum class Adam4000_DataFormat : char
J#
public enum Adam4000_DataFormat byte
JScript
public enum Adam4000_DataFormat :

Members

Member Name | Description
EngineerUnit | Engineering unit
Percent | Percent pf FSR
TwosComplementHex | Two's complement hexdecimal
Ohms | Ohms (ADAM-4013)
Unknown | Unknown data format

See Also

Advantech.Adam Namespace


Adam4000_FreqGateTime Enumeration

Adam4000_FreqGateTime Enumeration
[image]

The frequency gate time for ADAM-4080, ADAM-4080D

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4000_FreqGateTime As Byte
C#
public enum Adam4000_FreqGateTime : byte
C++
public enum class Adam4000_FreqGateTime : char
J#
public enum Adam4000_FreqGateTime byte
JScript
public enum Adam4000_FreqGateTime :

Members

Member Name | Description
OneTenthSecond | Advantech ASCII command
OneSecond | Modbus command
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4000_Integration Enumeration

Adam4000_Integration Enumeration
[image]

The integration code for ADAM-4000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4000_Integration As Byte
C#
public enum Adam4000_Integration : byte
C++
public enum class Adam4000_Integration : char
J#
public enum Adam4000_Integration byte
JScript
public enum Adam4000_Integration :

Members

Member Name | Description
Hz60_50ms | 60 Hz
Hz50_60ms | 50 Hz
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4000Config Class

Adam4000Config Class
See Also Example Members
[image]

The ADAM-4000 configuration class.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Adam4000Config
C#
public class Adam4000Config
C++
ref class Adam4000Config
J#
public class Adam4000Config
JScript
public class Adam4000Config

Inheritance Hierarchy

System.Object
Advantech.Adam.Adam4000Config

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Adam4000Config Members
Advantech.Adam Namespace


Adam4000Config Members

Adam4000Config Members
See Also Example Constructors Properties
[image]

The ADAM-4000 configuration class.

The following tables list the members exposed by Adam4000Config.

Public Constructors

 | Name | Description
Public method | Adam4000Config | Adam4000Config constructor
Top

Public Properties

 | Name | Description
Public property | Address | The module setup address.
Public property | Baudrate | The baudrate.
Public property | Checksum | The checksum using.
Public property | Format | The data format.
Public property | FreqGateTime | The frequency gate time. (Only for ADAM-4080, ADAM-4080D)
Public property | HighSpeed4100 | The high speed using.
Public property | Integration | The integration time.
Public property | Integration4100 | The integration time.
Public property | Protocol | The protocol. (Except ADAM-4024)
Public property | Protocol4024 | The protocol for ADAM-4024. (Only for ADAM-4024)
Public property | Slewrate | The slew rate for ADAM-4021, ADAM-4024
Public property | Status | The status byte.
Public property | Temperature | The temperature
Public property | TypeCode | The input range code
Top

See Also

Adam4000Config Class
Advantech.Adam Namespace


Adam4000Config Constructor

Adam4000Config Constructor
[image]

Adam4000Config constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Adam4000Config()
C++
public:
Adam4000Config() sealed
J#
public Adam4000Config()
JScript
public function Adam4000Config()

See Also

Adam4000Config Class
Advantech.Adam Namespace


Properties

Adam4000Config Properties
[image]

Public Properties

 | Name | Description
Public property | Address | The module setup address.
Public property | Baudrate | The baudrate.
Public property | Checksum | The checksum using.
Public property | Format | The data format.
Public property | FreqGateTime | The frequency gate time. (Only for ADAM-4080, ADAM-4080D)
Public property | HighSpeed4100 | The high speed using.
Public property | Integration | The integration time.
Public property | Integration4100 | The integration time.
Public property | Protocol | The protocol. (Except ADAM-4024)
Public property | Protocol4024 | The protocol for ADAM-4024. (Only for ADAM-4024)
Public property | Slewrate | The slew rate for ADAM-4021, ADAM-4024
Public property | Status | The status byte.
Public property | Temperature | The temperature
Public property | TypeCode | The input range code
Top

See Also

Adam4000Config Class
Advantech.Adam Namespace


Address Property

Adam4000Config.Address Property
[image]

The module setup address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As Byte
C#
public byte Address { get; set; }
C++
public property byte Address sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Address();

/** property */
public void set_Address(byte value);
JScript
public function get Address() : Byte

public function set Address(value : Byte);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Baudrate Property

Adam4000Config.Baudrate Property
[image]

The baudrate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Baudrate As Byte
C#
public byte Baudrate { get; set; }
C++
public property byte Baudrate sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Baudrate();

/** property */
public void set_Baudrate(byte value);
JScript
public function get Baudrate() : Byte

public function set Baudrate(value : Byte);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Checksum Property

Adam4000Config.Checksum Property
[image]

The checksum using.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As Adam_Checksum
C#
public Adam_Checksum Checksum { get; set; }
C++
public property Adam_Checksum Checksum sealed {
Adam_Checksum get();
void set(Adam_Checksum value);
}
J#
/** property */
public Adam_Checksum get_Checksum();

/** property */
public void set_Checksum(Adam_Checksum value);
JScript
public function get Checksum() : Adam_Checksum

public function set Checksum(value : Adam_Checksum);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Format Property

Adam4000Config.Format Property
[image]

The data format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As Adam4000_DataFormat
C#
public Adam4000_DataFormat Format { get; set; }
C++
public property Adam4000_DataFormat Format sealed {
Adam4000_DataFormat get();
void set(Adam4000_DataFormat value);
}
J#
/** property */
public Adam4000_DataFormat get_Format();

/** property */
public void set_Format(Adam4000_DataFormat value);
JScript
public function get Format() : Adam4000_DataFormat

public function set Format(value : Adam4000_DataFormat);

See Also

Adam4000Config Class
Advantech.Adam Namespace


FreqGateTime Property

Adam4000Config.FreqGateTime Property
[image]

The frequency gate time. (Only for ADAM-4080, ADAM-4080D)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property FreqGateTime As Adam4000_FreqGateTime
C#
public Adam4000_FreqGateTime FreqGateTime { get; set; }
C++
public property Adam4000_FreqGateTime FreqGateTime sealed {
Adam4000_FreqGateTime get();
void set(Adam4000_FreqGateTime value);
}
J#
/** property */
public Adam4000_FreqGateTime get_FreqGateTime();

/** property */
public void set_FreqGateTime(Adam4000_FreqGateTime value);
JScript
public function get FreqGateTime() : Adam4000_FreqGateTime

public function set FreqGateTime(value : Adam4000_FreqGateTime);

See Also

Adam4000Config Class
Advantech.Adam Namespace


HighSpeed4100 Property

Adam4000Config.HighSpeed4100 Property
[image]

The high speed using.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property HighSpeed4100 As Adam4100_HighSpeed
C#
public Adam4100_HighSpeed HighSpeed4100 { get; set; }
C++
public property Adam4100_HighSpeed HighSpeed4100 sealed {
Adam4100_HighSpeed get();
void set(Adam4100_HighSpeed value);
}
J#
/** property */
public Adam4100_HighSpeed get_HighSpeed4100();

/** property */
public void set_HighSpeed4100(Adam4100_HighSpeed value);
JScript
public function get HighSpeed4100() : Adam4100_HighSpeed

public function set HighSpeed4100(value : Adam4100_HighSpeed);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Integration Property

Adam4000Config.Integration Property
[image]

The integration time.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Integration As Adam4000_Integration
C#
public Adam4000_Integration Integration { get; set; }
C++
public property Adam4000_Integration Integration sealed {
Adam4000_Integration get();
void set(Adam4000_Integration value);
}
J#
/** property */
public Adam4000_Integration get_Integration();

/** property */
public void set_Integration(Adam4000_Integration value);
JScript
public function get Integration() : Adam4000_Integration

public function set Integration(value : Adam4000_Integration);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Integration4100 Property

Adam4000Config.Integration4100 Property
[image]

The integration time.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Integration4100 As Adam4100_Integration
C#
public Adam4100_Integration Integration4100 { get; set; }
C++
public property Adam4100_Integration Integration4100 sealed {
Adam4100_Integration get();
void set(Adam4100_Integration value);
}
J#
/** property */
public Adam4100_Integration get_Integration4100();

/** property */
public void set_Integration4100(Adam4100_Integration value);
JScript
public function get Integration4100() : Adam4100_Integration

public function set Integration4100(value : Adam4100_Integration);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Protocol Property

Adam4000Config.Protocol Property
[image]

The protocol. (Except ADAM-4024)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Protocol As Adam_Protocol
C#
public Adam_Protocol Protocol { get; set; }
C++
public property Adam_Protocol Protocol sealed {
Adam_Protocol get();
void set(Adam_Protocol value);
}
J#
/** property */
public Adam_Protocol get_Protocol();

/** property */
public void set_Protocol(Adam_Protocol value);
JScript
public function get Protocol() : Adam_Protocol

public function set Protocol(value : Adam_Protocol);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Protocol4024 Property

Adam4000Config.Protocol4024 Property
[image]

The protocol for ADAM-4024. (Only for ADAM-4024)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Protocol4024 As Adam_Protocol
C#
public Adam_Protocol Protocol4024 { get; set; }
C++
public property Adam_Protocol Protocol4024 sealed {
Adam_Protocol get();
void set(Adam_Protocol value);
}
J#
/** property */
public Adam_Protocol get_Protocol4024();

/** property */
public void set_Protocol4024(Adam_Protocol value);
JScript
public function get Protocol4024() : Adam_Protocol

public function set Protocol4024(value : Adam_Protocol);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Slewrate Property

Adam4000Config.Slewrate Property
[image]

The slew rate for ADAM-4021, ADAM-4024

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Slewrate As Byte
C#
public byte Slewrate { get; set; }
C++
public property byte Slewrate sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Slewrate();

/** property */
public void set_Slewrate(byte value);
JScript
public function get Slewrate() : Byte

public function set Slewrate(value : Byte);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Status Property

Adam4000Config.Status Property
[image]

The status byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As Byte
C#
public byte Status { get; set; }
C++
public property byte Status sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Status();

/** property */
public void set_Status(byte value);
JScript
public function get Status() : Byte

public function set Status(value : Byte);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Temperature Property

Adam4000Config.Temperature Property
[image]

The temperature

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Temperature As Adam_Temperature
C#
public Adam_Temperature Temperature { get; set; }
C++
public property Adam_Temperature Temperature sealed {
Adam_Temperature get();
void set(Adam_Temperature value);
}
J#
/** property */
public Adam_Temperature get_Temperature();

/** property */
public void set_Temperature(Adam_Temperature value);
JScript
public function get Temperature() : Adam_Temperature

public function set Temperature(value : Adam_Temperature);

See Also

Adam4000Config Class
Advantech.Adam Namespace


TypeCode Property

Adam4000Config.TypeCode Property
[image]

The input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeCode As Byte
C#
public byte TypeCode { get; set; }
C++
public property byte TypeCode sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_TypeCode();

/** property */
public void set_TypeCode(byte value);
JScript
public function get TypeCode() : Byte

public function set TypeCode(value : Byte);

See Also

Adam4000Config Class
Advantech.Adam Namespace


Adam4000Type Enumeration

Adam4000Type Enumeration
[image]

The ADAM 4000 module type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4000Type
C#
public enum Adam4000Type
C++
public enum class Adam4000Type
J#
public enum Adam4000Type
JScript
public enum Adam4000Type

Members

Member Name | Description
Non | Non module
Adam4011 | ADAM-4011
Adam4011D | ADAM-4011D
Adam4012 | ADAM-4012
Adam4013 | ADAM-4013
Adam4015 | ADAM-4015
Adam4015T | ADAM-4015T
Adam4016 | ADAM-4016
Adam4017 | ADAM-4017
Adam4017P | ADAM-4017+
Adam4018 | ADAM-4018
Adam4018P | ADAM-4018+
Adam4018M | ADAM-4018M
Adam4019 | ADAM-4019
Adam4019P | ADAM-4019+
Adam4021 | ADAM-4021
Adam4022T | ADAM-4022T
Adam4024 | ADAM-4024
Adam4050 | ADAM-4050
Adam4051 | ADAM-4051
Adam4052 | ADAM-4052
Adam4053 | ADAM-4053
Adam4055 | ADAM-4055
Adam4056S | ADAM-4056S
Adam4056SO | ADAM-4056SO
Adam4060 | ADAM-4060
Adam4062 | ADAM-4062
Adam4064 | ADAM-4064
Adam4068 | ADAM-4068
Adam4069 | ADAM-4069
Adam4080 | ADAM-4080
Adam4080D | ADAM-4080D
Adam4117 | ADAM-4117
Adam4118 | ADAM-4118
Adam4150 | ADAM-4150
Adam4168 | ADAM-4168
Adam4521 | ADAM-4521

See Also

Advantech.Adam Namespace


Adam4011_InputRange Enumeration

Adam4011_InputRange Enumeration
[image]

Adam-4011 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4011_InputRange As Byte
C#
public enum Adam4011_InputRange : byte
C++
public enum class Adam4011_InputRange : char
J#
public enum Adam4011_InputRange byte
JScript
public enum Adam4011_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_Neg20To20 | +/- 20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4012_InputRange Enumeration

Adam4012_InputRange Enumeration
[image]

Adam-4012 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4012_InputRange As Byte
C#
public enum Adam4012_InputRange : byte
C++
public enum class Adam4012_InputRange : char
J#
public enum Adam4012_InputRange byte
JScript
public enum Adam4012_InputRange :

Members

Member Name | Description
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1 | +/- 1 V
mV_Neg500To500 | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_Neg20To20 | +/- 20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4013_InputRange Enumeration

Adam4013_InputRange Enumeration
[image]

Adam-4013 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4013_InputRange As Byte
C#
public enum Adam4013_InputRange : byte
C++
public enum class Adam4013_InputRange : char
J#
public enum Adam4013_InputRange byte
JScript
public enum Adam4013_InputRange :

Members

Member Name | Description
Pt385_Neg100To100 | Pt385 -100~100 'C
Pt385_0To100 | Pt385 0~100 'C
Pt385_0To200 | Pt385 0~200 'C
Pt385_0To600 | Pt385 0~600 'C
Pt392_Neg100To100 | Pt392 -100~100 'C
Pt392_0To100 | Pt392 0~100 'C
Pt392_0To200 | Pt392 0~200 'C
Pt392_0To600 | Pt392 0~600 'C
Ni518_Neg80To100 | Ni518 -80~100 'C
Ni518_0To100 | Ni518 0~100 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4015_InputRange Enumeration

Adam4015_InputRange Enumeration
[image]

Adam-4015 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4015_InputRange As Byte
C#
public enum Adam4015_InputRange : byte
C++
public enum class Adam4015_InputRange : char
J#
public enum Adam4015_InputRange byte
JScript
public enum Adam4015_InputRange :

Members

Member Name | Description
Pt385_Neg50To150 | Pt385 -50~150 'C
Pt385_0To100 | Pt385 0~100 'C
Pt385_0To200 | Pt385 0~200 'C
Pt385_0To400 | Pt385 0~400 'C
Pt385_Neg200To200 | Pt385 -200~200 'C
Pt392_Neg50To150 | Pt392 -50~150 'C
Pt392_0To100 | Pt392 0~100 'C
Pt392_0To200 | Pt392 0~200 'C
Pt392_0To400 | Pt392 0~400 'C
Pt392_Neg200To200 | Pt392 -200~200 'C
Pt1000_Neg40To160 | Pt1000 -40~160 'C
Balco500_Neg30To120 | Balco500 -30~120 'C
Ni518_Neg80To100 | Ni518 -80~100 'C
Ni518_0To100 | Ni518 0~100 'C
Ni508_0To100 | Ni508 0~100 'C
Ni508_Neg50To200 | Ni508 -50~200 'C
BA1_Neg200To600 | BA1 -200~600 'C
mV_Neg500To500 | +/- 500 mV
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4015T_InputRange Enumeration

Adam4015T_InputRange Enumeration
[image]

Adam-4015T input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4015T_InputRange As Byte
C#
public enum Adam4015T_InputRange : byte
C++
public enum class Adam4015T_InputRange : char
J#
public enum Adam4015T_InputRange byte
JScript
public enum Adam4015T_InputRange :

Members

Member Name | Description
Thermistor_3K_0To100 | Thermistor 3K 0~100 'C
Thermistor_10K_0To100 | Thermistor 10K 0~100 'C
Thermistor_10K_Neg50To100 | Thermistor 10K -50~100 'C For ODM: VAA.02
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4016_InputRange Enumeration

Adam4016_InputRange Enumeration
[image]

Adam-4016 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4016_InputRange As Byte
C#
public enum Adam4016_InputRange : byte
C++
public enum class Adam4016_InputRange : char
J#
public enum Adam4016_InputRange byte
JScript
public enum Adam4016_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
mA_Neg20To20 | +/- 20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4017_InputRange Enumeration

Adam4017_InputRange Enumeration
[image]

Adam-4017 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4017_InputRange As Byte
C#
public enum Adam4017_InputRange : byte
C++
public enum class Adam4017_InputRange : char
J#
public enum Adam4017_InputRange byte
JScript
public enum Adam4017_InputRange :

Members

Member Name | Description
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1 | +/- 1 V
mV_Neg500To500 | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_Neg20To20 | +/- 20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4017P_InputRange Enumeration

Adam4017P_InputRange Enumeration
[image]

Adam-4017P input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4017P_InputRange As Byte
C#
public enum Adam4017P_InputRange : byte
C++
public enum class Adam4017P_InputRange : char
J#
public enum Adam4017P_InputRange byte
JScript
public enum Adam4017P_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1 | +/- 1 V
mV_Neg500To500 | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_Neg20To20 | +/- 20 mA
mA_0To20_ODM | 0~20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4018_InputRange Enumeration

Adam4018_InputRange Enumeration
[image]

Adam-4018 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4018_InputRange As Byte
C#
public enum Adam4018_InputRange : byte
C++
public enum class Adam4018_InputRange : char
J#
public enum Adam4018_InputRange byte
JScript
public enum Adam4018_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_Neg20To20 | +/- 20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4018M_InputRange Enumeration

Adam4018M_InputRange Enumeration
[image]

Adam-4018M input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4018M_InputRange As Byte
C#
public enum Adam4018M_InputRange : byte
C++
public enum class Adam4018M_InputRange : char
J#
public enum Adam4018M_InputRange byte
JScript
public enum Adam4018M_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_Neg20To20 | +/- 20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4018P_InputRange Enumeration

Adam4018P_InputRange Enumeration
[image]

Adam-4018P input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4018P_InputRange As Byte
C#
public enum Adam4018P_InputRange : byte
C++
public enum class Adam4018P_InputRange : char
J#
public enum Adam4018P_InputRange byte
JScript
public enum Adam4018P_InputRange :

Members

Member Name | Description
mA_Neg20To20 | +/- 20 mA
mA_4To20 | 4~20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4019_InputRange Enumeration

Adam4019_InputRange Enumeration
[image]

Adam-4019 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4019_InputRange As Byte
C#
public enum Adam4019_InputRange : byte
C++
public enum class Adam4019_InputRange : char
J#
public enum Adam4019_InputRange byte
JScript
public enum Adam4019_InputRange :

Members

Member Name | Description
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
mA_Neg20To20 | +/- 20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4019P_InputRange Enumeration

Adam4019P_InputRange Enumeration
[image]

Adam-4019P input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4019P_InputRange As Byte
C#
public enum Adam4019P_InputRange : byte
C++
public enum class Adam4019P_InputRange : char
J#
public enum Adam4019P_InputRange byte
JScript
public enum Adam4019P_InputRange :

Members

Member Name | Description
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
mA_Neg20To20 | +/- 20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4021_OutputRange Enumeration

Adam4021_OutputRange Enumeration
[image]

Adam-4021 Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4021_OutputRange As Byte
C#
public enum Adam4021_OutputRange : byte
C++
public enum class Adam4021_OutputRange : char
J#
public enum Adam4021_OutputRange byte
JScript
public enum Adam4021_OutputRange :

Members

Member Name | Description
mA_0To20 | 0~20 mA
mA_4To20 | 4~20 mA
V_0To10 | 0~10 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4022T_InputRange Enumeration

Adam4022T_InputRange Enumeration
[image]

Adam-4022T input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4022T_InputRange As Byte
C#
public enum Adam4022T_InputRange : byte
C++
public enum class Adam4022T_InputRange : char
J#
public enum Adam4022T_InputRange byte
JScript
public enum Adam4022T_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_0To10 | 0~10 V
mA_0To20 | 0~20 mA
Pt385_Neg100To100 | Pt385 -100~100 'C
Pt385_0To100 | Pt385 0~100 'C
Pt385_0To200 | Pt385 0~200 'C
Pt385_0To600 | Pt385 0~600 'C
Pt392_Neg100To100 | Pt392 -100~100 'C
Pt392_0To100 | Pt392 0~100 'C
Pt392_0To200 | Pt392 0~200 'C
Pt392_0To600 | Pt392 0~600 'C
Pt1000_Neg40To160 | Pt1000 -40~160 'C
Thermistor_3K_0To100 | Thermistor 3K 0~100 'C
Thermistor_10K_0To100 | Thermistor 10K 0~100 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4022T_OutputRange Enumeration

Adam4022T_OutputRange Enumeration
[image]

Adam-4022T Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4022T_OutputRange As Byte
C#
public enum Adam4022T_OutputRange : byte
C++
public enum class Adam4022T_OutputRange : char
J#
public enum Adam4022T_OutputRange byte
JScript
public enum Adam4022T_OutputRange :

Members

Member Name | Description
mA_0To20 | 0~20 mA
mA_4To20 | 4~20 mA
V_0To10 | 0~10 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4024_OutputRange Enumeration

Adam4024_OutputRange Enumeration
[image]

Adam-4024 Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4024_OutputRange As Byte
C#
public enum Adam4024_OutputRange : byte
C++
public enum class Adam4024_OutputRange : char
J#
public enum Adam4024_OutputRange byte
JScript
public enum Adam4024_OutputRange :

Members

Member Name | Description
mA_0To20 | 0~20 mA
mA_4To20 | 4~20 mA
V_Neg10To10 | -10~10 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4080_CounterMode Enumeration

Adam4080_CounterMode Enumeration
[image]

Adam4080 counter mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4080_CounterMode As Byte
C#
public enum Adam4080_CounterMode : byte
C++
public enum class Adam4080_CounterMode : char
J#
public enum Adam4080_CounterMode byte
JScript
public enum Adam4080_CounterMode :

Members

Member Name | Description
Counter | Counter mode
Frequency | Frequency mode
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4080_GateMode Enumeration

Adam4080_GateMode Enumeration
[image]

Adam4080 gate mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4080_GateMode As Byte
C#
public enum Adam4080_GateMode : byte
C++
public enum class Adam4080_GateMode : char
J#
public enum Adam4080_GateMode byte
JScript
public enum Adam4080_GateMode :

Members

Member Name | Description
Low | Low mode
High | High mode
Disable | Disable
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4080_InputSignalMode Enumeration

Adam4080_InputSignalMode Enumeration
[image]

Adam4080 input signal mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4080_InputSignalMode As Byte
C#
public enum Adam4080_InputSignalMode : byte
C++
public enum class Adam4080_InputSignalMode : char
J#
public enum Adam4080_InputSignalMode byte
JScript
public enum Adam4080_InputSignalMode :

Members

Member Name | Description
NonIsolated | Non-isolated(TTL) input signal
PhotoIsolated | Photo-isolated input signal
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4080_Level Enumeration

Adam4080_Level Enumeration
[image]

Adam4080 level

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4080_Level As Byte
C#
public enum Adam4080_Level : byte
C++
public enum class Adam4080_Level : char
J#
public enum Adam4080_Level byte
JScript
public enum Adam4080_Level :

Members

Member Name | Description
Low | Low level
High | High level
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4080D_LedSource Enumeration

Adam4080D_LedSource Enumeration
[image]

Adam4080D LED source

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4080D_LedSource As Byte
C#
public enum Adam4080D_LedSource : byte
C++
public enum class Adam4080D_LedSource : char
J#
public enum Adam4080D_LedSource byte
JScript
public enum Adam4080D_LedSource :

Members

Member Name | Description
Channel0 | From channel 0
Channel1 | From channel 1
Host | From the host computer
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4100_BurnoutMap Enumeration

Adam4100_BurnoutMap Enumeration
[image]

The burnout mapping.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4100_BurnoutMap As Byte
C#
public enum Adam4100_BurnoutMap : byte
C++
public enum class Adam4100_BurnoutMap : char
J#
public enum Adam4100_BurnoutMap byte
JScript
public enum Adam4100_BurnoutMap :

Members

Member Name | Description
Lowest | Map to the lowest value when burnout detected
Highest | Map to the highest value when burnout detected

See Also

Advantech.Adam Namespace


Adam4100_HighSpeed Enumeration

Adam4100_HighSpeed Enumeration
[image]

The high speed mode status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4100_HighSpeed As Byte
C#
public enum Adam4100_HighSpeed : byte
C++
public enum class Adam4100_HighSpeed : char
J#
public enum Adam4100_HighSpeed byte
JScript
public enum Adam4100_HighSpeed :

Members

Member Name | Description
Disable | Disabled
Enable | Enabled

See Also

Advantech.Adam Namespace


Adam4100_Integration Enumeration

Adam4100_Integration Enumeration
[image]

The integration code for ADAM-4100

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4100_Integration As Byte
C#
public enum Adam4100_Integration : byte
C++
public enum class Adam4100_Integration : char
J#
public enum Adam4100_Integration byte
JScript
public enum Adam4100_Integration :

Members

Member Name | Description
Hz50_60 | 50/60 Hz
UserDefine | User define
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam4117_InputRange Enumeration

Adam4117_InputRange Enumeration
[image]

Adam-4117 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4117_InputRange As Byte
C#
public enum Adam4117_InputRange : byte
C++
public enum class Adam4117_InputRange : char
J#
public enum Adam4117_InputRange byte
JScript
public enum Adam4117_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1 | +/- 1 V
mV_Neg500To500 | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_Neg20To20 | +/- 20 mA
V_Neg15To15 | +/- 15 V
V_0To10 | 0~10 V
V_0To5 | 0~5 V
V_0To1 | 0~1 V
mV_0To500 | 0~500 mV
mV_0To150 | 0~150 mV
mA_0To20 | 0~20 mA
V_0To15 | 0~15 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam4118_InputRange Enumeration

Adam4118_InputRange Enumeration
[image]

Adam-4118 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam4118_InputRange As Byte
C#
public enum Adam4118_InputRange : byte
C++
public enum class Adam4118_InputRange : char
J#
public enum Adam4118_InputRange byte
JScript
public enum Adam4118_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_Neg20To20 | +/- 20 mA
mA_4To20 | 4~20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5000_ChannelStatus Enumeration

Adam5000_ChannelStatus Enumeration
[image]

The channel status for analog input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5000_ChannelStatus As Byte
C#
public enum Adam5000_ChannelStatus : byte
C++
public enum class Adam5000_ChannelStatus : char
J#
public enum Adam5000_ChannelStatus byte
JScript
public enum Adam5000_ChannelStatus :

Members

Member Name | Description
Normal | Normal
Over | Over range
Under | Under range
Burn | Burn out
Disable | Disabled

See Also

Advantech.Adam Namespace


Adam5000_CounterAlarmMode Enumeration

Adam5000_CounterAlarmMode Enumeration
[image]

The counter alarm mode for ADAM-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5000_CounterAlarmMode As Byte
C#
public enum Adam5000_CounterAlarmMode : byte
C++
public enum class Adam5000_CounterAlarmMode : char
J#
public enum Adam5000_CounterAlarmMode byte
JScript
public enum Adam5000_CounterAlarmMode :

Members

Member Name | Description
Disable | Disable, 'D'
Latch | Latch, 'L'
AutoClear | Auto Clear, 'A'
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam5000_DataFormat Enumeration

Adam5000_DataFormat Enumeration
[image]

The data format for analog input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5000_DataFormat As Byte
C#
public enum Adam5000_DataFormat : byte
C++
public enum class Adam5000_DataFormat : char
J#
public enum Adam5000_DataFormat byte
JScript
public enum Adam5000_DataFormat :

Members

Member Name | Description
EngineerUnit | Engineering unit
Percent | Percent pf FSR
TwosComplementHex | Two's complement hexdecimal
Ohms | Ohms (ADAM-5013)
Unknown | Unknown data format

See Also

Advantech.Adam Namespace


Adam5000_Integration Enumeration

Adam5000_Integration Enumeration
[image]

The integration code for ADAM-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5000_Integration As Byte
C#
public enum Adam5000_Integration : byte
C++
public enum class Adam5000_Integration : char
J#
public enum Adam5000_Integration byte
JScript
public enum Adam5000_Integration :

Members

Member Name | Description
Hz60_50ms | 60 Hz
Hz50_60ms | 50 Hz
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam5000Config Class

Adam5000Config Class
See Also Example Members
[image]

The ADAM-5000 configuration class.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Adam5000Config
C#
public class Adam5000Config
C++
ref class Adam5000Config
J#
public class Adam5000Config
JScript
public class Adam5000Config

Inheritance Hierarchy

System.Object
Advantech.Adam.Adam5000Config

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Adam5000Config Members
Advantech.Adam Namespace


Adam5000Config Members

Adam5000Config Members
See Also Example Constructors Properties
[image]

The ADAM-5000 configuration class.

The following tables list the members exposed by Adam5000Config.

Public Constructors

 | Name | Description
Public method | Adam5000Config | Adam5000Config constructor
Top

Public Properties

 | Name | Description
Public property | Baudrate | The baudrate.
Public property | Checksum | The checksum using.
Public property | Protocol | The protocol.
Public property | Status | The status byte.
Top

See Also

Adam5000Config Class
Advantech.Adam Namespace


Adam5000Config Constructor

Adam5000Config Constructor
[image]

Adam5000Config constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Adam5000Config()
C++
public:
Adam5000Config() sealed
J#
public Adam5000Config()
JScript
public function Adam5000Config()

See Also

Adam5000Config Class
Advantech.Adam Namespace


Properties

Adam5000Config Properties
[image]

Public Properties

 | Name | Description
Public property | Baudrate | The baudrate.
Public property | Checksum | The checksum using.
Public property | Protocol | The protocol.
Public property | Status | The status byte.
Top

See Also

Adam5000Config Class
Advantech.Adam Namespace


Baudrate Property

Adam5000Config.Baudrate Property
[image]

The baudrate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Baudrate As Byte
C#
public byte Baudrate { get; set; }
C++
public property byte Baudrate sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Baudrate();

/** property */
public void set_Baudrate(byte value);
JScript
public function get Baudrate() : Byte

public function set Baudrate(value : Byte);

See Also

Adam5000Config Class
Advantech.Adam Namespace


Checksum Property

Adam5000Config.Checksum Property
[image]

The checksum using.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As Adam_Checksum
C#
public Adam_Checksum Checksum { get; set; }
C++
public property Adam_Checksum Checksum sealed {
Adam_Checksum get();
void set(Adam_Checksum value);
}
J#
/** property */
public Adam_Checksum get_Checksum();

/** property */
public void set_Checksum(Adam_Checksum value);
JScript
public function get Checksum() : Adam_Checksum

public function set Checksum(value : Adam_Checksum);

See Also

Adam5000Config Class
Advantech.Adam Namespace


Protocol Property

Adam5000Config.Protocol Property
[image]

The protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Protocol As Adam_Protocol
C#
public Adam_Protocol Protocol { get; set; }
C++
public property Adam_Protocol Protocol sealed {
Adam_Protocol get();
void set(Adam_Protocol value);
}
J#
/** property */
public Adam_Protocol get_Protocol();

/** property */
public void set_Protocol(Adam_Protocol value);
JScript
public function get Protocol() : Adam_Protocol

public function set Protocol(value : Adam_Protocol);

See Also

Adam5000Config Class
Advantech.Adam Namespace


Status Property

Adam5000Config.Status Property
[image]

The status byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As Byte
C#
public byte Status { get; set; }
C++
public property byte Status sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Status();

/** property */
public void set_Status(byte value);
JScript
public function get Status() : Byte

public function set Status(value : Byte);

See Also

Adam5000Config Class
Advantech.Adam Namespace


Adam5000TCP_Integration Enumeration

Adam5000TCP_Integration Enumeration
[image]

The integration code for ADAM-5000TCP

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5000TCP_Integration As Byte
C#
public enum Adam5000TCP_Integration : byte
C++
public enum class Adam5000TCP_Integration : char
J#
public enum Adam5000TCP_Integration byte
JScript
public enum Adam5000TCP_Integration :

Members

Member Name | Description
Hz60_50ms | 60 Hz
Hz50_60ms | 50 Hz
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam5000Type Enumeration

Adam5000Type Enumeration
[image]

The ADAM 5000 module type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5000Type
C#
public enum Adam5000Type
C++
public enum class Adam5000Type
J#
public enum Adam5000Type
JScript
public enum Adam5000Type

Members

Member Name | Description
Non | Non module
Adam5000AI | New unknown ADAM-5000 AI module
Adam5000AO | New unknown ADAM-5000 AO module
Adam5000DI | New unknown ADAM-5000 DI module
Adam5000DO | New unknown ADAM-5000 DO module
Adam5000 | ADAM-5000
Adam5000E | ADAM-5000E
Adam5013 | ADAM-5013
Adam5017 | ADAM-5017
Adam5017H | ADAM-5017H
Adam5017UH | ADAM-5017UH
Adam5017P | ADAM-5017P
Adam5018 | ADAM-5018
Adam5018P | ADAM-5018+
Adam5024 | ADAM-5024
Adam5050 | ADAM-5050
Adam5051 | ADAM-5051
Adam5052 | ADAM-5052
Adam5055 | ADAM-5055
Adam5056 | ADAM-5056
Adam5060 | ADAM-5060
Adam5068 | ADAM-5068
Adam5069 | ADAM-5069
Adam5080 | ADAM-5080
Adam5081 | ADAM-5081

See Also

Advantech.Adam Namespace


Adam5013_InputRange Enumeration

Adam5013_InputRange Enumeration
[image]

Adam-5013 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5013_InputRange As Byte
C#
public enum Adam5013_InputRange : byte
C++
public enum class Adam5013_InputRange : char
J#
public enum Adam5013_InputRange byte
JScript
public enum Adam5013_InputRange :

Members

Member Name | Description
Pt385_Neg100To100 | Pt385 -100~100 'C
Pt385_0To100 | Pt385 0~100 'C
Pt385_0To200 | Pt385 0~200 'C
Pt385_0To600 | Pt385 0~600 'C
Pt3916_Neg100To100 | Pt3916 -100~100 'C
Pt3916_0To100 | Pt3916 0~100 'C
Pt3916_0To200 | Pt3916 0~200 'C
Pt3916_0To600 | Pt3916 0~600 'C
Ni672_Neg80To100 | Ni672 -80~100 'C
Ni618_0To100 | Ni618 0~100 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5017_InputRange Enumeration

Adam5017_InputRange Enumeration
[image]

Adam-5017 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5017_InputRange As Byte
C#
public enum Adam5017_InputRange : byte
C++
public enum class Adam5017_InputRange : char
J#
public enum Adam5017_InputRange byte
JScript
public enum Adam5017_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1 | +/- 1 V
mV_Neg500To500 | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_Neg20To20 | +/- 20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5017H_InputRange Enumeration

Adam5017H_InputRange Enumeration
[image]

Adam-5017H input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5017H_InputRange As Byte
C#
public enum Adam5017H_InputRange : byte
C++
public enum class Adam5017H_InputRange : char
J#
public enum Adam5017H_InputRange byte
JScript
public enum Adam5017H_InputRange :

Members

Member Name | Description
V_Neg10To10 | +/- 10 V
V_0To10 | 0~10 V
V_Neg5To5 | +/- 5 V
V_0To5 | 0~5 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
V_0To2AndHalf | 0~2.5 V
V_Neg1To1 | +/- 1 V
V_0To1 | 0~1 V
mV_Neg500To500 | +/- 500 mV
mV_0To500 | 0~500 mV
mA_4To20 | 4~20 mA
mA_0To20 | 0~20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5017P_InputRange Enumeration

Adam5017P_InputRange Enumeration
[image]

Adam-5017P input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5017P_InputRange As Byte
C#
public enum Adam5017P_InputRange : byte
C++
public enum class Adam5017P_InputRange : char
J#
public enum Adam5017P_InputRange byte
JScript
public enum Adam5017P_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1 | +/- 1 V
mV_Neg500To500 | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_Neg20To20 | +/- 20 mA
V_Neg15To15 | +/- 15 V
V_0To10 | 0~10 V
V_0To5 | 0~5 V
V_0To1 | 0~1 V
mV_0To500 | 0~500 mV
mV_0To500_Old | 0~500 mV, old define
mV_0To150 | 0~150 mV
mA_0To20 | 0~20 mA
V_0To15 | 0~15 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5017S_InputRange Enumeration

Adam5017S_InputRange Enumeration
[image]

Adam-5017S (ODM) input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5017S_InputRange As Byte
C#
public enum Adam5017S_InputRange : byte
C++
public enum class Adam5017S_InputRange : char
J#
public enum Adam5017S_InputRange byte
JScript
public enum Adam5017S_InputRange :

Members

Member Name | Description
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5017UH_BurnoutMap Enumeration

Adam5017UH_BurnoutMap Enumeration
[image]

The burnout mapping.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5017UH_BurnoutMap As Byte
C#
public enum Adam5017UH_BurnoutMap : byte
C++
public enum class Adam5017UH_BurnoutMap : char
J#
public enum Adam5017UH_BurnoutMap byte
JScript
public enum Adam5017UH_BurnoutMap :

Members

Member Name | Description
Lowest | Map to the lowest value when burnout detected
Highest | Map to the highest value when burnout detected

See Also

Advantech.Adam Namespace


Adam5017UH_InputRange Enumeration

Adam5017UH_InputRange Enumeration
[image]

Adam-5017UH input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5017UH_InputRange As Byte
C#
public enum Adam5017UH_InputRange : byte
C++
public enum class Adam5017UH_InputRange : char
J#
public enum Adam5017UH_InputRange byte
JScript
public enum Adam5017UH_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
mV_0To500 | 0~500 mV
mA_0To20 | 0~20 mA
V_0To10 | 0~10 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5018_InputRange Enumeration

Adam5018_InputRange Enumeration
[image]

Adam-5018 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5018_InputRange As Byte
C#
public enum Adam5018_InputRange : byte
C++
public enum class Adam5018_InputRange : char
J#
public enum Adam5018_InputRange byte
JScript
public enum Adam5018_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_Neg20To20 | +/- 20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5018P_InputRange Enumeration

Adam5018P_InputRange Enumeration
[image]

Adam-5018P input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5018P_InputRange As Byte
C#
public enum Adam5018P_InputRange : byte
C++
public enum class Adam5018P_InputRange : char
J#
public enum Adam5018P_InputRange byte
JScript
public enum Adam5018P_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_Neg20To20 | +/- 20 mA
mA_4To20 | 4~20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5024_OutputRange Enumeration

Adam5024_OutputRange Enumeration
[image]

Adam-5024 Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5024_OutputRange As Byte
C#
public enum Adam5024_OutputRange : byte
C++
public enum class Adam5024_OutputRange : char
J#
public enum Adam5024_OutputRange byte
JScript
public enum Adam5024_OutputRange :

Members

Member Name | Description
mA_0To20 | 0~20 mA
mA_4To20 | 4~20 mA
V_0To10 | 0~10 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam5080_CounterMode Enumeration

Adam5080_CounterMode Enumeration
[image]

Adam5080 counter mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5080_CounterMode As Byte
C#
public enum Adam5080_CounterMode : byte
C++
public enum class Adam5080_CounterMode : char
J#
public enum Adam5080_CounterMode byte
JScript
public enum Adam5080_CounterMode :

Members

Member Name | Description
Bi_Direction | Bi-directory mode
Up_Down | Up/Down mode
Frequency | Frequency mode
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam5081_CounterMode Enumeration

Adam5081_CounterMode Enumeration
[image]

Adam5081 counter mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam5081_CounterMode As Byte
C#
public enum Adam5081_CounterMode : byte
C++
public enum class Adam5081_CounterMode : char
J#
public enum Adam5081_CounterMode byte
JScript
public enum Adam5081_CounterMode :

Members

Member Name | Description
Bi_Direction | Bi-directory mode
Up_Down | Up/Down mode
Up | Up mode
Frequency | Frequency mode
AB1X | A/B-1X mode
AB2X | A/B-2X mode
AB4X | A/B-4X mode
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam6000_Integration Enumeration

Adam6000_Integration Enumeration
[image]

The integration code for ADAM-6000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6000_Integration As Byte
C#
public enum Adam6000_Integration : byte
C++
public enum class Adam6000_Integration : char
J#
public enum Adam6000_Integration byte
JScript
public enum Adam6000_Integration :

Members

Member Name | Description
Hz60_50ms | 60 Hz
Hz50_60ms | 50 Hz
HzHighSpeed | High Speed
HzAuto | Auto Hz
Unknown | Unknown

See Also

Advantech.Adam Namespace


Adam6000_RangeFormat Enumeration

Adam6000_RangeFormat Enumeration
[image]

The range format (data type) code for ADAM-6000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6000_RangeFormat As Byte
C#
public enum Adam6000_RangeFormat : byte
C++
public enum class Adam6000_RangeFormat : char
J#
public enum Adam6000_RangeFormat byte
JScript
public enum Adam6000_RangeFormat :

Members

Member Name | Description
Byte | Byte
Ushort | Ushort

See Also

Advantech.Adam Namespace


Adam6000_SlewRate Enumeration

Adam6000_SlewRate Enumeration
[image]

Adam 6000 slew rate

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6000_SlewRate As Byte
C#
public enum Adam6000_SlewRate : byte
C++
public enum class Adam6000_SlewRate : char
J#
public enum Adam6000_SlewRate byte
JScript
public enum Adam6000_SlewRate :

Members

Member Name | Description
Immediate | Immediate change
V_1_mA_1 | 1 V/sec;1 mA/sec
V_2_mA_2 | 2 V/sec;2 mA/sec
V_4_mA_4 | 4 V/sec;4 mA/sec
V_8_mA_8 | 8 V/sec;8 mA/sec
V_16_mA_16 | 16 V/sec;16 mA/sec
V_32_mA_32 | 32 V/sec;32 mA/sec
V_64_mA_64 | 64 V/sec;64 mA/sec

See Also

Advantech.Adam Namespace


Adam6000Type Enumeration

Adam6000Type Enumeration
[image]

The ADAM 6000 module type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6000Type
C#
public enum Adam6000Type
C++
public enum class Adam6000Type
J#
public enum Adam6000Type
JScript
public enum Adam6000Type

Members

Member Name | Description
Non | Non module
Adam6015 | ADAM-6015
Adam6017 | ADAM-6017
Adam6018 | ADAM-6018
Adam6022 | ADAM-6022
Adam6024 | ADAM-6024
Adam6050 | ADAM-6050
Adam6051 | ADAM-6051
Adam6052 | ADAM-6052
Adam6055 | ADAM-6055
Adam6060 | ADAM-6060
Adam6066 | ADAM-6066
Adam6117 | ADAM-6117
Adam6118 | ADAM-6118
Adam6122 | ADAM-6122
Adam6124 | ADAM-6124
Adam6150 | ADAM-6150
Adam6151 | ADAM-6151
Adam6156 | ADAM-6156
Adam6160 | ADAM-6160
Adam6166 | ADAM-6166
Adam6217 | ADAM-6217
Adam6218 | ADAM-6218
Adam6222 | ADAM-6222
Adam6224 | ADAM-6224
Adam6250 | ADAM-6250
Adam6251 | ADAM-6251
Adam6256 | ADAM-6256
Adam6260 | ADAM-6260
Adam6265AMAT | ADAM-6265-AMAT
Adam6266 | ADAM-6266
Adam6050W | ADAM-6050W
Adam6051W | ADAM-6051W
Adam6060W | ADAM-6060W

See Also

Advantech.Adam Namespace


Adam6015_InputRange Enumeration

Adam6015_InputRange Enumeration
[image]

Adam-6015 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6015_InputRange As Byte
C#
public enum Adam6015_InputRange : byte
C++
public enum class Adam6015_InputRange : char
J#
public enum Adam6015_InputRange byte
JScript
public enum Adam6015_InputRange :

Members

Member Name | Description
Pt385_Neg50To150 | Pt385 -50~150 'C
Pt385_0To100 | Pt385 0~100 'C
Pt385_0To200 | Pt385 0~200 'C
Pt385_0To400 | Pt385 0~400 'C
Pt385_Neg200To200 | Pt385 -200~200 'C
Pt392_Neg50To150 | Pt392 -50~150 'C
Pt392_0To100 | Pt392 0~100 'C
Pt392_0To200 | Pt392 0~200 'C
Pt392_0To400 | Pt392 0~400 'C
Pt392_Neg200To200 | Pt392 -200~200 'C
Pt1000_Neg40To160 | Pt1000 -40~160 'C
Balco500_Neg30To120 | Balco500 -30~120 'C
Ni518_Neg80To100 | Ni518 -80~100 'C
Ni518_0To100 | Ni518 0~100 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam6017_InputRange Enumeration

Adam6017_InputRange Enumeration
[image]

Adam-6017 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6017_InputRange As Byte
C#
public enum Adam6017_InputRange : byte
C++
public enum class Adam6017_InputRange : char
J#
public enum Adam6017_InputRange byte
JScript
public enum Adam6017_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1 | +/- 1 V
mV_Neg500To500 | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_0To20 | 0~20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam6018_InputRange Enumeration

Adam6018_InputRange Enumeration
[image]

Adam-6018 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6018_InputRange As Byte
C#
public enum Adam6018_InputRange : byte
C++
public enum class Adam6018_InputRange : char
J#
public enum Adam6018_InputRange byte
JScript
public enum Adam6018_InputRange :

Members

Member Name | Description
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam6022_InputRange Enumeration

Adam6022_InputRange Enumeration
[image]

Adam-6022 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6022_InputRange As Byte
C#
public enum Adam6022_InputRange : byte
C++
public enum class Adam6022_InputRange : char
J#
public enum Adam6022_InputRange byte
JScript
public enum Adam6022_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
mA_0To20 | 0~20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam6022_OutputRange Enumeration

Adam6022_OutputRange Enumeration
[image]

Adam-6022 Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6022_OutputRange As Byte
C#
public enum Adam6022_OutputRange : byte
C++
public enum class Adam6022_OutputRange : char
J#
public enum Adam6022_OutputRange byte
JScript
public enum Adam6022_OutputRange :

Members

Member Name | Description
mA_0To20 | 0~20 mA
mA_4To20 | 4~20 mA
V_0To10 | 0~10 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam6024_InputRange Enumeration

Adam6024_InputRange Enumeration
[image]

Adam-6024 input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6024_InputRange As Byte
C#
public enum Adam6024_InputRange : byte
C++
public enum class Adam6024_InputRange : char
J#
public enum Adam6024_InputRange byte
JScript
public enum Adam6024_InputRange :

Members

Member Name | Description
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
mA_0To20 | 0~20 mA
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam6024_OutputRange Enumeration

Adam6024_OutputRange Enumeration
[image]

Adam-6024 Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6024_OutputRange As Byte
C#
public enum Adam6024_OutputRange : byte
C++
public enum class Adam6024_OutputRange : char
J#
public enum Adam6024_OutputRange byte
JScript
public enum Adam6024_OutputRange :

Members

Member Name | Description
mA_0To20 | 0~20 mA
mA_4To20 | 4~20 mA
V_0To10 | 0~10 V
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Adam6051_CounterMode Enumeration

Adam6051_CounterMode Enumeration
[image]

Adam6051 counter mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Adam6051_CounterMode As Byte
C#
public enum Adam6051_CounterMode : byte
C++
public enum class Adam6051_CounterMode : char
J#
public enum Adam6051_CounterMode byte
JScript
public enum Adam6051_CounterMode :

Members

Member Name | Description
Counter | Counter mode
Frequency | Frequency mode
Unknown | Unknown

See Also

Advantech.Adam Namespace


AdamBase Class

AdamBase Class
See Also Example Members
[image]

ADAM ASCII base class library for ADAM series. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class AdamBase
C#
public abstract class AdamBase
C++
ref class AdamBase abstract
J#
public class AdamBase
JScript
public class AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamBase Members
Advantech.Adam Namespace


AdamBase Members

AdamBase Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

ADAM ASCII base class library for ADAM series. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by AdamBase.

Public Constructors

Name | Description
AdamBase | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type
Public property | Address | The slave address.
Public property | ApiLastError | The API last error code when API function return error code.
Public property | Handle | The controller driver handle.
Public property | LastError | The last error code when function return false.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command
Family method | GetProtocolType | Get socket protocol type
Top

Explicit Interface Implementations

Name | Description
AdamBase | Overloaded.
Top

See Also

AdamBase Class
Advantech.Adam Namespace


AdamBase Constructor

AdamBase Constructor

Overload List

 | Name | Description
Public method | AdamBase (AdamCom) | The AdamBase constructor
Public method | AdamBase (AdamControl) | The AdamBase constructor
Public method | AdamBase (AdamSocket) | The AdamBase constructor

See Also

AdamBase Class
Advantech.Adam Namespace


AdamBase Constructor (AdamCom)

AdamBase Constructor (AdamCom)
See Also Example
[image]

The AdamBase constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public AdamBase(
AdamCom i_com
)
C++
public:
AdamBase(
AdamCom i_com
) sealed
J#
public AdamBase(
AdamCom i_com
)
JScript
public function AdamBase(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object.

See Also

AdamBase Class
Advantech.Adam Namespace
AdamBase Constructor Overload List


AdamBase Constructor (AdamControl)

AdamBase Constructor (AdamControl)
See Also Example
[image]

The AdamBase constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public AdamBase(
AdamControl i_control
)
C++
public:
AdamBase(
AdamControl i_control
) sealed
J#
public AdamBase(
AdamControl i_control
)
JScript
public function AdamBase(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object.

See Also

AdamBase Class
Advantech.Adam Namespace
AdamBase Constructor Overload List


AdamBase Constructor (AdamSocket)

AdamBase Constructor (AdamSocket)
See Also Example
[image]

The AdamBase constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public AdamBase(
AdamSocket i_socket
)
C++
public:
AdamBase(
AdamSocket i_socket
) sealed
J#
public AdamBase(
AdamSocket i_socket
)
JScript
public function AdamBase(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object.

See Also

AdamBase Class
Advantech.Adam Namespace
AdamBase Constructor Overload List


Fields

AdamBase Fields
[image]

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules
Top

See Also

AdamBase Class
Advantech.Adam Namespace


m_numberFormatInfo Field

AdamBase.m_numberFormatInfo Field
[image]

The number format information for ADAM modules

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected m_numberFormatInfo As NumberFormatInfo
C#
protected NumberFormatInfo m_numberFormatInfo;
C++
protected:
NumberFormatInfo m_numberFormatInfo sealed ;
J#
protected NumberFormatInfo m_numberFormatInfo
JScript
protected m_numberFormatInfo : NumberFormatInfo;

See Also

AdamBase Class
Advantech.Adam Namespace


Properties

AdamBase Properties
[image]

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type
Public property | Address | The slave address.
Public property | ApiLastError | The API last error code when API function return error code.
Public property | Handle | The controller driver handle.
Public property | LastError | The last error code when function return false.
Top

See Also

AdamBase Class
Advantech.Adam Namespace


AdamSeriesType Property

AdamBase.AdamSeriesType Property
[image]

The Adam series type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property AdamSeriesType As AdamType
C#
public AdamType AdamSeriesType { get; set; }
C++
public property AdamType AdamSeriesType sealed {
AdamType get();
void set(AdamType value);
}
J#
/** property */
public AdamType get_AdamSeriesType();

/** property */
public void set_AdamSeriesType(AdamType value);
JScript
public function get AdamSeriesType() : AdamType

public function set AdamSeriesType(value : AdamType);

See Also

AdamBase Class
Advantech.Adam Namespace


Address Property

AdamBase.Address Property
[image]

The slave address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As Integer
C#
public int Address { get; set; }
C++
public property int Address sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Address();

/** property */
public void set_Address(int value);
JScript
public function get Address() : int

public function set Address(value : int);

See Also

AdamBase Class
Advantech.Adam Namespace


ApiLastError Property

AdamBase.ApiLastError Property
[image]

The API last error code when API function return error code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property ApiLastError As Integer
C#
public int ApiLastError { get; set; }
C++
public property int ApiLastError sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ApiLastError();

/** property */
public void set_ApiLastError(int value);
JScript
public function get ApiLastError() : int

public function set ApiLastError(value : int);

See Also

AdamBase Class
Advantech.Adam Namespace


Handle Property

AdamBase.Handle Property
[image]

The controller driver handle.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Handle As Integer
C#
public int Handle { get; set; }
C++
public property int Handle sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Handle();

/** property */
public void set_Handle(int value);
JScript
public function get Handle() : int

public function set Handle(value : int);

See Also

AdamBase Class
Advantech.Adam Namespace


LastError Property

AdamBase.LastError Property
[image]

The last error code when function return false.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property LastError As ErrorCode
C#
public ErrorCode LastError { get; set; }
C++
public property ErrorCode LastError sealed {
ErrorCode get();
void set(ErrorCode value);
}
J#
/** property */
public ErrorCode get_LastError();

/** property */
public void set_LastError(ErrorCode value);
JScript
public function get LastError() : ErrorCode

public function set LastError(value : ErrorCode);

See Also

AdamBase Class
Advantech.Adam Namespace


Methods

AdamBase Methods
[image]

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command
Family method | GetProtocolType | Get socket protocol type
Top

See Also

AdamBase Class
Advantech.Adam Namespace


ASCIISendRecv Method

AdamBase.ASCIISendRecv Method
[image]

Send and receive ADAM ASCII command

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function ASCIISendRecv( _
ByVal i_szSend As String, _
<OutAttribute> ByRef o_szRecv As String _
) As Boolean
C#
protected bool ASCIISendRecv(
string i_szSend,
out string o_szRecv
)
C++
protected:
bool ASCIISendRecv(
String i_szSend,
[OutAttribute] String% o_szRecv
) sealed
J#
protected bool ASCIISendRecv(
string i_szSend,
/** @attribute OutAttribute() */ /** @ref */ string o_szRecv
)
JScript
protected function ASCIISendRecv(
i_szSend : String,
OutAttribute o_szRecv : String
) : bool

Parameters

i_szSend
The ASCII command to send.
o_szRecv
The ASCII response received.

Return Value

True, if successed, otherwise false.

See Also

AdamBase Class
Advantech.Adam Namespace


GetProtocolType Method

AdamBase.GetProtocolType Method
[image]

Get socket protocol type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetProtocolType() As ProtocolType
C#
protected ProtocolType GetProtocolType()
C++
protected:
ProtocolType GetProtocolType() sealed
J#
protected ProtocolType GetProtocolType()
JScript
protected function GetProtocolType() : ProtocolType

Return Value

The socket protocol type

See Also

AdamBase Class
Advantech.Adam Namespace


AdamCom Class

AdamCom Class
See Also Example Members
[image]

ADAM serial communication class library for ADAM series.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamCom
Inherits ComPort
C#
public class AdamCom : ComPort
C++
ref class AdamCom : ComPort
J#
public class AdamCom extends ComPort
JScript
public class AdamCom extends ComPort

Inheritance Hierarchy

System.Object
Advantech.Common.ComPort
Advantech.Adam.AdamCom

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamCom Members
Advantech.Adam Namespace


AdamCom Members

AdamCom Members
See Also Example Constructors Properties Methods
[image]

ADAM serial communication class library for ADAM series.

The following tables list the members exposed by AdamCom.

Public Constructors

 | Name | Description
Public method | AdamCom | AdamCom constructor.
Top

Public Properties

 | Name | Description
Public property | Checksum | Get/Set Checksum status when module runs on ASCII protocol.
Public property | IsOpen | Get the COM port open status. (inherited from ComPort)
Public property | LastError | The last error code when function return false.
Top

Public Methods

 | Name | Description
Public method | Adam2000 | ADAM-2000 object
Public method | AdamTransaction | Send and receive ASCII command for ADAM modules
Public method | Alarm | ADAM-4000 ADAM-5000 Alarm object
Public method | AnalogInput | ADAM-4000 ADAM-5000 AnalogInput object
Public method | AnalogOutput | ADAM-4000 ADAM-5000 AnalogOutput object
Public method | CloseComPort | Close the COM port. (inherited from ComPort)
Public method | Configuration | ADAM-4000 ADAM-5000 Configuration object
Public method | Counter | ADAM-4000 ADAM-5000 Counter object
Public method | DigitalInput | ADAM-4000 ADAM-5000 DigitalInput object
Public method | DigitalOutput | ADAM-4000 ADAM-5000 DigitalOutput object
Public method | GetComPortEventMask | Get the COM port events monitored (inherited from ComPort)
Public method | GetComPortLastError | Get the last error when calling Win API. (inherited from ComPort)
Public method | GetComPortState | Read the device control settings to the class DCB structure. (inherited from ComPort)
Public method | GetComPortTimeout | Get the COM port timeout. (inherited from ComPort)
Public method | GetDspFwVersion | Get APAX-5073 DSP firmware version. Support: APAX-5073
Public method | GetPlatformFwVersion | Get APAX-5073 firmware version. Support: APAX-5073
Public method | GetPortNum | Get the port number for this object. (inherited from ComPort)
Public method | Modbus | ADAM-4000 Modbus object
Public method | OpenComPort | Open the COM port and get the COM port setting from system (inherited from ComPort)
Public method | Pid | ADAM-4000 PID object
Public method | Recv | Overloaded. Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024. (inherited from ComPort)
Public method | Send | Overloaded. Send binary data to this COM port. (inherited from ComPort)
Public method | SetComPortEventMask | Set the COM port events to be monitored (inherited from ComPort)
Public method | SetComPortState | Overloaded. Set the COM port state. (inherited from ComPort)
Public method | SetComPortTimeout | Update the COM port timeout. (inherited from ComPort)
Public method | SetPurge | Flush the I/O buffers. (inherited from ComPort)
Public method | WaitComPortEvent | Wait for an event to occur for the COM port. (inherited from ComPort)
Top

Protected Methods

 | Name | Description
Family method | AppendChecksum | Append the checksum to the command
Family method | ChecksumNumber | Calculate the checksum
Family method | VfyTrimChecksum | Verify and trimoff the checksum of the response
Top

See Also

AdamCom Class
Advantech.Adam Namespace


AdamCom Constructor

AdamCom Constructor
[image]

AdamCom constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_i32Port As Integer _
)
C#
public AdamCom(
int i_i32Port
)
C++
public:
AdamCom(
int i_i32Port
) sealed
J#
public AdamCom(
int i_i32Port
)
JScript
public function AdamCom(
i_i32Port : int
)

Parameters

i_i32Port
The port number which is ranged from 1 to 256

See Also

AdamCom Class
Advantech.Adam Namespace


Properties

AdamCom Properties
[image]

Public Properties

 | Name | Description
Public property | Checksum | Get/Set Checksum status when module runs on ASCII protocol.
Public property | IsOpen | Get the COM port open status. (inherited from ComPort)
Public property | LastError | The last error code when function return false.
Top

See Also

AdamCom Class
Advantech.Adam Namespace


Checksum Property

AdamCom.Checksum Property
[image]

Get/Set Checksum status when module runs on ASCII protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As Boolean
C#
public bool Checksum { get; set; }
C++
public property bool Checksum sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Checksum();

/** property */
public void set_Checksum(bool value);
JScript
public function get Checksum() : bool

public function set Checksum(value : bool);

See Also

AdamCom Class
Advantech.Adam Namespace


LastError Property

AdamCom.LastError Property
[image]

The last error code when function return false.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastError As ErrorCode
C#
public ErrorCode LastError { get; }
C++
public property ErrorCode LastError sealed {
ErrorCode get();
}
J#
/** property */
public ErrorCode get_LastError();
JScript
public function get LastError() : ErrorCode

See Also

AdamCom Class
Advantech.Adam Namespace


Methods

AdamCom Methods
[image]

Public Methods

 | Name | Description
Public method | Adam2000 | ADAM-2000 object
Public method | AdamTransaction | Send and receive ASCII command for ADAM modules
Public method | Alarm | ADAM-4000 ADAM-5000 Alarm object
Public method | AnalogInput | ADAM-4000 ADAM-5000 AnalogInput object
Public method | AnalogOutput | ADAM-4000 ADAM-5000 AnalogOutput object
Public method | CloseComPort | Close the COM port. (inherited from ComPort)
Public method | Configuration | ADAM-4000 ADAM-5000 Configuration object
Public method | Counter | ADAM-4000 ADAM-5000 Counter object
Public method | DigitalInput | ADAM-4000 ADAM-5000 DigitalInput object
Public method | DigitalOutput | ADAM-4000 ADAM-5000 DigitalOutput object
Public method | GetComPortEventMask | Get the COM port events monitored (inherited from ComPort)
Public method | GetComPortLastError | Get the last error when calling Win API. (inherited from ComPort)
Public method | GetComPortState | Read the device control settings to the class DCB structure. (inherited from ComPort)
Public method | GetComPortTimeout | Get the COM port timeout. (inherited from ComPort)
Public method | GetDspFwVersion | Get APAX-5073 DSP firmware version. Support: APAX-5073
Public method | GetPlatformFwVersion | Get APAX-5073 firmware version. Support: APAX-5073
Public method | GetPortNum | Get the port number for this object. (inherited from ComPort)
Public method | Modbus | ADAM-4000 Modbus object
Public method | OpenComPort | Open the COM port and get the COM port setting from system (inherited from ComPort)
Public method | Pid | ADAM-4000 PID object
Public method | Recv | Overloaded. Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024. (inherited from ComPort)
Public method | Send | Overloaded. Send binary data to this COM port. (inherited from ComPort)
Public method | SetComPortEventMask | Set the COM port events to be monitored (inherited from ComPort)
Public method | SetComPortState | Overloaded. Set the COM port state. (inherited from ComPort)
Public method | SetComPortTimeout | Update the COM port timeout. (inherited from ComPort)
Public method | SetPurge | Flush the I/O buffers. (inherited from ComPort)
Public method | WaitComPortEvent | Wait for an event to occur for the COM port. (inherited from ComPort)
Top

Protected Methods

 | Name | Description
Family method | AppendChecksum | Append the checksum to the command
Family method | ChecksumNumber | Calculate the checksum
Family method | VfyTrimChecksum | Verify and trimoff the checksum of the response
Top

See Also

AdamCom Class
Advantech.Adam Namespace


Adam2000 Method

AdamCom.Adam2000 Method
[image]

ADAM-2000 object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Adam2000( _
ByVal i_iID As Integer _
) As Adam2000
C#
public Adam2000 Adam2000(
int i_iID
)
C++
public:
Adam2000 Adam2000(
int i_iID
) sealed
J#
public Adam2000 Adam2000(
int i_iID
)
JScript
public function Adam2000(
i_iID : int
) : Adam2000

Parameters

i_iID
The module address which is ranged from 0 to 65535

Return Value

The Adam2000 object

See Also

AdamCom Class
Advantech.Adam Namespace


AdamTransaction Method

AdamCom.AdamTransaction Method
[image]

Send and receive ASCII command for ADAM modules

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AdamTransaction( _
ByVal i_szSend As String, _
<OutAttribute> ByRef o_szRecv As String _
) As Boolean
C#
public bool AdamTransaction(
string i_szSend,
out string o_szRecv
)
C++
public:
bool AdamTransaction(
String i_szSend,
[OutAttribute] String% o_szRecv
) sealed
J#
public bool AdamTransaction(
string i_szSend,
/** @attribute OutAttribute() */ /** @ref */ string o_szRecv
)
JScript
public function AdamTransaction(
i_szSend : String,
OutAttribute o_szRecv : String
) : bool

Parameters

i_szSend
The command string to send
o_szRecv
The responsed string received

Return Value

True if the transaction success.

See Also

AdamCom Class
Advantech.Adam Namespace


Alarm Method

AdamCom.Alarm Method
[image]

ADAM-4000 ADAM-5000 Alarm object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Alarm( _
ByVal i_iAddr As Integer _
) As Alarm
C#
public Alarm Alarm(
int i_iAddr
)
C++
public:
Alarm Alarm(
int i_iAddr
) sealed
J#
public Alarm Alarm(
int i_iAddr
)
JScript
public function Alarm(
i_iAddr : int
) : Alarm

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The Alarm object

See Also

AdamCom Class
Advantech.Adam Namespace


AnalogInput Method

AdamCom.AnalogInput Method
[image]

ADAM-4000 ADAM-5000 AnalogInput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogInput( _
ByVal i_iAddr As Integer _
) As AnalogInput
C#
public AnalogInput AnalogInput(
int i_iAddr
)
C++
public:
AnalogInput AnalogInput(
int i_iAddr
) sealed
J#
public AnalogInput AnalogInput(
int i_iAddr
)
JScript
public function AnalogInput(
i_iAddr : int
) : AnalogInput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

See Also

AdamCom Class
Advantech.Adam Namespace


AnalogOutput Method

AdamCom.AnalogOutput Method
[image]

ADAM-4000 ADAM-5000 AnalogOutput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogOutput( _
ByVal i_iAddr As Integer _
) As AnalogOutput
C#
public AnalogOutput AnalogOutput(
int i_iAddr
)
C++
public:
AnalogOutput AnalogOutput(
int i_iAddr
) sealed
J#
public AnalogOutput AnalogOutput(
int i_iAddr
)
JScript
public function AnalogOutput(
i_iAddr : int
) : AnalogOutput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The AnalogOutput object

See Also

AdamCom Class
Advantech.Adam Namespace


AppendChecksum Method

AdamCom.AppendChecksum Method
[image]

Append the checksum to the command

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub AppendChecksum( _
ByRef io_szData As String _
)
C#
protected void AppendChecksum(
ref string io_szData
)
C++
protected:
void AppendChecksum(
String% io_szData
) sealed
J#
protected void AppendChecksum(
string io_szData
)
JScript
protected function AppendChecksum(
io_szData : String
)

Parameters

io_szData
The string that is going to calculate and append the checksum

See Also

AdamCom Class
Advantech.Adam Namespace


ChecksumNumber Method

AdamCom.ChecksumNumber Method
[image]

Calculate the checksum

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function ChecksumNumber( _
ByVal i_szData As String _
) As UInt32
C#
protected uint ChecksumNumber(
string i_szData
)
C++
protected:
unsigned int ChecksumNumber(
String i_szData
) sealed
J#
protected uint ChecksumNumber(
string i_szData
)
JScript
protected function ChecksumNumber(
i_szData : String
) : UInt32

Parameters

i_szData
The string that is going to calculate the checksum

Return Value

The checksum of the string.

See Also

AdamCom Class
Advantech.Adam Namespace


Configuration Method

AdamCom.Configuration Method
[image]

ADAM-4000 ADAM-5000 Configuration object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Configuration( _
ByVal i_iAddr As Integer _
) As Configuration
C#
public Configuration Configuration(
int i_iAddr
)
C++
public:
Configuration Configuration(
int i_iAddr
) sealed
J#
public Configuration Configuration(
int i_iAddr
)
JScript
public function Configuration(
i_iAddr : int
) : Configuration

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

AdamConfig object

See Also

AdamCom Class
Advantech.Adam Namespace


Counter Method

AdamCom.Counter Method
[image]

ADAM-4000 ADAM-5000 Counter object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Counter( _
ByVal i_iAddr As Integer _
) As Counter
C#
public Counter Counter(
int i_iAddr
)
C++
public:
Counter Counter(
int i_iAddr
) sealed
J#
public Counter Counter(
int i_iAddr
)
JScript
public function Counter(
i_iAddr : int
) : Counter

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The Counter object

See Also

AdamCom Class
Advantech.Adam Namespace


DigitalInput Method

AdamCom.DigitalInput Method
[image]

ADAM-4000 ADAM-5000 DigitalInput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalInput( _
ByVal i_iAddr As Integer _
) As DigitalInput
C#
public DigitalInput DigitalInput(
int i_iAddr
)
C++
public:
DigitalInput DigitalInput(
int i_iAddr
) sealed
J#
public DigitalInput DigitalInput(
int i_iAddr
)
JScript
public function DigitalInput(
i_iAddr : int
) : DigitalInput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The DigitalInput object

See Also

AdamCom Class
Advantech.Adam Namespace


DigitalOutput Method

AdamCom.DigitalOutput Method
[image]

ADAM-4000 ADAM-5000 DigitalOutput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalOutput( _
ByVal i_iAddr As Integer _
) As DigitalOutput
C#
public DigitalOutput DigitalOutput(
int i_iAddr
)
C++
public:
DigitalOutput DigitalOutput(
int i_iAddr
) sealed
J#
public DigitalOutput DigitalOutput(
int i_iAddr
)
JScript
public function DigitalOutput(
i_iAddr : int
) : DigitalOutput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The DigitalOutput object

See Also

AdamCom Class
Advantech.Adam Namespace


GetDspFwVersion Method

AdamCom.GetDspFwVersion Method
[image]

Get APAX-5073 DSP firmware version. Support: APAX-5073

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDspFwVersion( _
ByVal i_iAddr As Integer, _
ByRef o_szDspFwVer As String _
) As Boolean
C#
public bool GetDspFwVersion(
int i_iAddr,
ref string o_szDspFwVer
)
C++
public:
bool GetDspFwVersion(
int i_iAddr,
String% o_szDspFwVer
) sealed
J#
public bool GetDspFwVersion(
int i_iAddr,
string o_szDspFwVer
)
JScript
public function GetDspFwVersion(
i_iAddr : int,
o_szDspFwVer : String
) : bool

Parameters

i_iAddr
The module slave address which is ranged from 0 to 255
o_szDspFwVer
DSP firmware version.

Return Value

Return true if success, otherwise return false.

See Also

AdamCom Class
Advantech.Adam Namespace


GetPlatformFwVersion Method

AdamCom.GetPlatformFwVersion Method
[image]

Get APAX-5073 firmware version. Support: APAX-5073

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPlatformFwVersion( _
ByVal i_iAddr As Integer, _
ByRef o_szFwVer As String _
) As Boolean
C#
public bool GetPlatformFwVersion(
int i_iAddr,
ref string o_szFwVer
)
C++
public:
bool GetPlatformFwVersion(
int i_iAddr,
String% o_szFwVer
) sealed
J#
public bool GetPlatformFwVersion(
int i_iAddr,
string o_szFwVer
)
JScript
public function GetPlatformFwVersion(
i_iAddr : int,
o_szFwVer : String
) : bool

Parameters

i_iAddr
The module slave address which is ranged from 0 to 255
o_szFwVer
The module firmware version.

Return Value

Return true if success, otherwise return false.

See Also

AdamCom Class
Advantech.Adam Namespace


Modbus Method

AdamCom.Modbus Method
[image]

ADAM-4000 Modbus object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Modbus( _
ByVal i_iAddr As Integer _
) As Modbus
C#
public Modbus Modbus(
int i_iAddr
)
C++
public:
Modbus Modbus(
int i_iAddr
) sealed
J#
public Modbus Modbus(
int i_iAddr
)
JScript
public function Modbus(
i_iAddr : int
) : Modbus

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The Modbus object

See Also

AdamCom Class
Advantech.Adam Namespace


Pid Method

AdamCom.Pid Method
[image]

ADAM-4000 PID object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Pid( _
ByVal i_iAddr As Integer _
) As PID
C#
public PID Pid(
int i_iAddr
)
C++
public:
PID Pid(
int i_iAddr
) sealed
J#
public PID Pid(
int i_iAddr
)
JScript
public function Pid(
i_iAddr : int
) : PID

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The PID object

See Also

AdamCom Class
Advantech.Adam Namespace


VfyTrimChecksum Method

AdamCom.VfyTrimChecksum Method
[image]

Verify and trimoff the checksum of the response

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function VfyTrimChecksum( _
ByRef io_szData As String _
) As Boolean
C#
protected bool VfyTrimChecksum(
ref string io_szData
)
C++
protected:
bool VfyTrimChecksum(
String% io_szData
) sealed
J#
protected bool VfyTrimChecksum(
string io_szData
)
JScript
protected function VfyTrimChecksum(
io_szData : String
) : bool

Parameters

io_szData
The string that is going to verify and trimoff the checksum

See Also

AdamCom Class
Advantech.Adam Namespace


AdamCOMConfig Class

AdamCOMConfig Class
See Also Example Members
[image]

The ADAM COM configuration class.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamCOMConfig
C#
public class AdamCOMConfig
C++
ref class AdamCOMConfig
J#
public class AdamCOMConfig
JScript
public class AdamCOMConfig

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamCOMConfig

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamCOMConfig Members
Advantech.Adam Namespace


AdamCOMConfig Members

AdamCOMConfig Members
See Also Example Constructors Properties
[image]

The ADAM COM configuration class.

The following tables list the members exposed by AdamCOMConfig.

Public Constructors

 | Name | Description
Public method | AdamCOMConfig | AdamCOMConfig constructor
Top

Public Properties

 | Name | Description
Public property | Databits | The Databits setting.
Public property | Parity | The Parity setting.
Public property | Status | The status byte.
Public property | Stopbits | The Stopbits setting.
Top

See Also

AdamCOMConfig Class
Advantech.Adam Namespace


AdamCOMConfig Constructor

AdamCOMConfig Constructor
[image]

AdamCOMConfig constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamCOMConfig()
C++
public:
AdamCOMConfig() sealed
J#
public AdamCOMConfig()
JScript
public function AdamCOMConfig()

See Also

AdamCOMConfig Class
Advantech.Adam Namespace


Properties

AdamCOMConfig Properties
[image]

Public Properties

 | Name | Description
Public property | Databits | The Databits setting.
Public property | Parity | The Parity setting.
Public property | Status | The status byte.
Public property | Stopbits | The Stopbits setting.
Top

See Also

AdamCOMConfig Class
Advantech.Adam Namespace


Databits Property

AdamCOMConfig.Databits Property
[image]

The Databits setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Databits As Databits
C#
public Databits Databits { get; set; }
C++
public property Databits Databits sealed {
Databits get();
void set(Databits value);
}
J#
/** property */
public Databits get_Databits();

/** property */
public void set_Databits(Databits value);
JScript
public function get Databits() : Databits

public function set Databits(value : Databits);

See Also

AdamCOMConfig Class
Advantech.Adam Namespace


Parity Property

AdamCOMConfig.Parity Property
[image]

The Parity setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Parity As Parity
C#
public Parity Parity { get; set; }
C++
public property Parity Parity sealed {
Parity get();
void set(Parity value);
}
J#
/** property */
public Parity get_Parity();

/** property */
public void set_Parity(Parity value);
JScript
public function get Parity() : Parity

public function set Parity(value : Parity);

See Also

AdamCOMConfig Class
Advantech.Adam Namespace


Status Property

AdamCOMConfig.Status Property
[image]

The status byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As Byte
C#
public byte Status { get; set; }
C++
public property byte Status sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Status();

/** property */
public void set_Status(byte value);
JScript
public function get Status() : Byte

public function set Status(value : Byte);

See Also

AdamCOMConfig Class
Advantech.Adam Namespace


Stopbits Property

AdamCOMConfig.Stopbits Property
[image]

The Stopbits setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Stopbits As Stopbits
C#
public Stopbits Stopbits { get; set; }
C++
public property Stopbits Stopbits sealed {
Stopbits get();
void set(Stopbits value);
}
J#
/** property */
public Stopbits get_Stopbits();

/** property */
public void set_Stopbits(Stopbits value);
JScript
public function get Stopbits() : Stopbits

public function set Stopbits(value : Stopbits);

See Also

AdamCOMConfig Class
Advantech.Adam Namespace


AdamControl Class

AdamControl Class
See Also Example Members
[image]

AdamControl is the ADAM controller class.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamControl
C#
public class AdamControl
C++
ref class AdamControl
J#
public class AdamControl
JScript
public class AdamControl

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamControl

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamControl Members
Advantech.Adam Namespace


AdamControl Members

AdamControl Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

AdamControl is the ADAM controller class.

The following tables list the members exposed by AdamControl.

Public Constructors

Name | Description
AdamControl | Overloaded. Initializes a new instance of the AdamControl class.
Top

Public Fields

Name | Description
APAX_MaxAIOCh |
APAX_MaxDIOCh |
APAX_MaxPCIDev |
APAX_MaxSlot |
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type
Public property | LastError | The last error code when function return false.
Top

Public Methods

 | Name | Description
Public method | Alarm | Controller Alarm object. Support: ADAM-5550
Public method | AnalogInput | Controller AnalogInput object. Support: ADAM-5550, APAX-5000
Public method | AnalogOutput | Controller AnalogOutput object. Support: ADAM-5550, APAX-5000
Public method | CloseDevice | Close the device driver.
Public method | Configuration | Controller Configuration object. Support: ADAM-5550, APAX-5000
Public method | Counter | Controller Counter object. Support: ADAM-5550
Public method | DigitalInput | Controller DigitalInput object. Support: ADAM-5550, APAX-5000
Public method | DigitalOutput | Controller DigitalOutput object. Support: ADAM-5550, APAX-5000
Public method | IOUpdateReady | Get IO update ready status.
Public method | NodeID | Get the node ID
Public method | OpenDevice | Open the device driver.
Top

Explicit Interface Implementations

Name | Description
AdamControl | Overloaded. Initializes a new instance of the AdamControl class.
Top

See Also

AdamControl Class
Advantech.Adam Namespace


AdamControl Constructor

AdamControl Constructor

Initializes a new instance of the AdamControl class.

Overload List

 | Name | Description
Public method | AdamControl | The constructor
Public method | AdamControl (AdamType) | The constructor

See Also

AdamControl Class
Advantech.Adam Namespace


AdamControl Constructor ()

AdamControl Constructor ()
See Also Example
[image]

The constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamControl()
C++
public:
AdamControl() sealed
J#
public AdamControl()
JScript
public function AdamControl()

See Also

AdamControl Class
Advantech.Adam Namespace
AdamControl Constructor Overload List


AdamControl Constructor (AdamType)

AdamControl Constructor (AdamType)
See Also Example
[image]

The constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_adamType As AdamType _
)
C#
public AdamControl(
AdamType i_adamType
)
C++
public:
AdamControl(
AdamType i_adamType
) sealed
J#
public AdamControl(
AdamType i_adamType
)
JScript
public function AdamControl(
i_adamType : AdamType
)

Parameters

i_adamType
AdamType

See Also

AdamControl Class
Advantech.Adam Namespace
AdamControl Constructor Overload List


Fields

AdamControl Fields
[image]

Public Fields

Name | Description
APAX_MaxAIOCh |
APAX_MaxDIOCh |
APAX_MaxPCIDev |
APAX_MaxSlot |
Top

See Also

AdamControl Class
Advantech.Adam Namespace


APAX_MaxAIOCh Field

AdamControl.APAX_MaxAIOCh Field
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared APAX_MaxAIOCh As Integer
C#
public static int APAX_MaxAIOCh;
C++
public:
static int APAX_MaxAIOCh;
J#
public static int APAX_MaxAIOCh
JScript
public static APAX_MaxAIOCh : int;

See Also

AdamControl Class
Advantech.Adam Namespace


APAX_MaxDIOCh Field

AdamControl.APAX_MaxDIOCh Field
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared APAX_MaxDIOCh As Integer
C#
public static int APAX_MaxDIOCh;
C++
public:
static int APAX_MaxDIOCh;
J#
public static int APAX_MaxDIOCh
JScript
public static APAX_MaxDIOCh : int;

See Also

AdamControl Class
Advantech.Adam Namespace


APAX_MaxPCIDev Field

AdamControl.APAX_MaxPCIDev Field
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared APAX_MaxPCIDev As Integer
C#
public static int APAX_MaxPCIDev;
C++
public:
static int APAX_MaxPCIDev;
J#
public static int APAX_MaxPCIDev
JScript
public static APAX_MaxPCIDev : int;

See Also

AdamControl Class
Advantech.Adam Namespace


APAX_MaxSlot Field

AdamControl.APAX_MaxSlot Field
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared APAX_MaxSlot As Integer
C#
public static int APAX_MaxSlot;
C++
public:
static int APAX_MaxSlot;
J#
public static int APAX_MaxSlot
JScript
public static APAX_MaxSlot : int;

See Also

AdamControl Class
Advantech.Adam Namespace


Properties

AdamControl Properties
[image]

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type
Public property | LastError | The last error code when function return false.
Top

See Also

AdamControl Class
Advantech.Adam Namespace


AdamSeriesType Property

AdamControl.AdamSeriesType Property
[image]

The Adam series type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property AdamSeriesType As AdamType
C#
public AdamType AdamSeriesType { get; set; }
C++
public property AdamType AdamSeriesType sealed {
AdamType get();
void set(AdamType value);
}
J#
/** property */
public AdamType get_AdamSeriesType();

/** property */
public void set_AdamSeriesType(AdamType value);
JScript
public function get AdamSeriesType() : AdamType

public function set AdamSeriesType(value : AdamType);

See Also

AdamControl Class
Advantech.Adam Namespace


LastError Property

AdamControl.LastError Property
[image]

The last error code when function return false.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastError As ErrorCode
C#
public ErrorCode LastError { get; }
C++
public property ErrorCode LastError sealed {
ErrorCode get();
}
J#
/** property */
public ErrorCode get_LastError();
JScript
public function get LastError() : ErrorCode

See Also

AdamControl Class
Advantech.Adam Namespace


Methods

AdamControl Methods
[image]

Public Methods

 | Name | Description
Public method | Alarm | Controller Alarm object. Support: ADAM-5550
Public method | AnalogInput | Controller AnalogInput object. Support: ADAM-5550, APAX-5000
Public method | AnalogOutput | Controller AnalogOutput object. Support: ADAM-5550, APAX-5000
Public method | CloseDevice | Close the device driver.
Public method | Configuration | Controller Configuration object. Support: ADAM-5550, APAX-5000
Public method | Counter | Controller Counter object. Support: ADAM-5550
Public method | DigitalInput | Controller DigitalInput object. Support: ADAM-5550, APAX-5000
Public method | DigitalOutput | Controller DigitalOutput object. Support: ADAM-5550, APAX-5000
Public method | IOUpdateReady | Get IO update ready status.
Public method | NodeID | Get the node ID
Public method | OpenDevice | Open the device driver.
Top

See Also

AdamControl Class
Advantech.Adam Namespace


Alarm Method

AdamControl.Alarm Method
[image]

Controller Alarm object. Support: ADAM-5550

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Alarm() As Alarm
C#
public Alarm Alarm()
C++
public:
Alarm Alarm() sealed
J#
public Alarm Alarm()
JScript
public function Alarm() : Alarm

See Also

AdamControl Class
Advantech.Adam Namespace


AnalogInput Method

AdamControl.AnalogInput Method
[image]

Controller AnalogInput object. Support: ADAM-5550, APAX-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogInput() As AnalogInput
C#
public AnalogInput AnalogInput()
C++
public:
AnalogInput AnalogInput() sealed
J#
public AnalogInput AnalogInput()
JScript
public function AnalogInput() : AnalogInput

Return Value

The AnalogInput object

See Also

AdamControl Class
Advantech.Adam Namespace


AnalogOutput Method

AdamControl.AnalogOutput Method
[image]

Controller AnalogOutput object. Support: ADAM-5550, APAX-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogOutput() As AnalogOutput
C#
public AnalogOutput AnalogOutput()
C++
public:
AnalogOutput AnalogOutput() sealed
J#
public AnalogOutput AnalogOutput()
JScript
public function AnalogOutput() : AnalogOutput

Return Value

The AnalogOutput object

See Also

AdamControl Class
Advantech.Adam Namespace


CloseDevice Method

AdamControl.CloseDevice Method
[image]

Close the device driver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function CloseDevice() As Boolean
C#
public bool CloseDevice()
C++
public:
bool CloseDevice() sealed
J#
public bool CloseDevice()
JScript
public function CloseDevice() : bool

Return Value

Return true if success, otherwise return false.

See Also

AdamControl Class
Advantech.Adam Namespace


Configuration Method

AdamControl.Configuration Method
[image]

Controller Configuration object. Support: ADAM-5550, APAX-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Configuration() As Configuration
C#
public Configuration Configuration()
C++
public:
Configuration Configuration() sealed
J#
public Configuration Configuration()
JScript
public function Configuration() : Configuration

Return Value

The Configuration object

See Also

AdamControl Class
Advantech.Adam Namespace


Counter Method

AdamControl.Counter Method
[image]

Controller Counter object. Support: ADAM-5550

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Counter() As Counter
C#
public Counter Counter()
C++
public:
Counter Counter() sealed
J#
public Counter Counter()
JScript
public function Counter() : Counter

See Also

AdamControl Class
Advantech.Adam Namespace


DigitalInput Method

AdamControl.DigitalInput Method
[image]

Controller DigitalInput object. Support: ADAM-5550, APAX-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalInput() As DigitalInput
C#
public DigitalInput DigitalInput()
C++
public:
DigitalInput DigitalInput() sealed
J#
public DigitalInput DigitalInput()
JScript
public function DigitalInput() : DigitalInput

Return Value

The DigitalInput object

See Also

AdamControl Class
Advantech.Adam Namespace


DigitalOutput Method

AdamControl.DigitalOutput Method
[image]

Controller DigitalOutput object. Support: ADAM-5550, APAX-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalOutput() As DigitalOutput
C#
public DigitalOutput DigitalOutput()
C++
public:
DigitalOutput DigitalOutput() sealed
J#
public DigitalOutput DigitalOutput()
JScript
public function DigitalOutput() : DigitalOutput

Return Value

The DigitalOutput object

See Also

AdamControl Class
Advantech.Adam Namespace


IOUpdateReady Method

AdamControl.IOUpdateReady Method
[image]

Get IO update ready status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function IOUpdateReady( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef bReady As Boolean _
) As Boolean
C#
public bool IOUpdateReady(
int i_iSlot,
out bool bReady
)
C++
public:
bool IOUpdateReady(
int i_iSlot,
[OutAttribute] bool% bReady
) sealed
J#
public bool IOUpdateReady(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool bReady
)
JScript
public function IOUpdateReady(
i_iSlot : int,
OutAttribute bReady : bool
) : bool

Parameters

i_iSlot
The slot index, based 0.
bReady
The IO update status.

Return Value

Return true if success, otherwise return false.

See Also

AdamControl Class
Advantech.Adam Namespace


NodeID Method

AdamControl.NodeID Method
[image]

Get the node ID

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function NodeID() As Integer
C#
public int NodeID()
C++
public:
int NodeID() sealed
J#
public int NodeID()
JScript
public function NodeID() : int

Return Value

If the result is -1, means get ID failed, otherwise, return the node ID.

See Also

AdamControl Class
Advantech.Adam Namespace


OpenDevice Method

AdamControl.OpenDevice Method
[image]

Open the device driver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenDevice() As Boolean
C#
public bool OpenDevice()
C++
public:
bool OpenDevice() sealed
J#
public bool OpenDevice()
JScript
public function OpenDevice() : bool

Return Value

Return true if success, otherwise return false.

See Also

AdamControl Class
Advantech.Adam Namespace


AdamEvent Class

AdamEvent Class
See Also Example Members
[image]

Class AdamEvent for event trigger

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamEvent
C#
public class AdamEvent
C++
ref class AdamEvent
J#
public class AdamEvent
JScript
public class AdamEvent

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamEvent

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamEvent Members
Advantech.Adam Namespace


AdamEvent Members

AdamEvent Members
See Also Example Constructors Fields
[image]

Class AdamEvent for event trigger

The following tables list the members exposed by AdamEvent.

Public Constructors

 | Name | Description
Public method | AdamEvent | Constructer
Top

Public Fields

 | Name | Description
Public field | m_byIP | IP
Public field | m_iChannel | Channel
Public field | m_iSlot | Slot
Public field | m_iStatus | Event status
Public field | m_iType | Event Type
Public field | m_lVal | Value
Public field | m_Time | Time
Top

See Also

AdamEvent Class
Advantech.Adam Namespace


AdamEvent Constructor

AdamEvent Constructor
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_byIP As Byte(), _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iType As Integer, _
ByVal i_iStatus As Integer, _
ByVal i_lVal As Long _
)
C#
public AdamEvent(
byte[] i_byIP,
int i_iSlot,
int i_iChannel,
int i_iType,
int i_iStatus,
long i_lVal
)
C++
public:
AdamEvent(
array<char>^ i_byIP,
int i_iSlot,
int i_iChannel,
int i_iType,
int i_iStatus,
__int64 i_lVal
) sealed
J#
public AdamEvent(
byte[] i_byIP,
int i_iSlot,
int i_iChannel,
int i_iType,
int i_iStatus,
long i_lVal
)
JScript
public function AdamEvent(
i_byIP : Byte[],
i_iSlot : int,
i_iChannel : int,
i_iType : int,
i_iStatus : int,
i_lVal : long
)

Parameters

i_byIP
i_iSlot
i_iChannel
i_iType
i_iStatus
i_lVal

See Also

AdamEvent Class
Advantech.Adam Namespace


Fields

AdamEvent Fields
[image]

Public Fields

 | Name | Description
Public field | m_byIP | IP
Public field | m_iChannel | Channel
Public field | m_iSlot | Slot
Public field | m_iStatus | Event status
Public field | m_iType | Event Type
Public field | m_lVal | Value
Public field | m_Time | Time
Top

See Also

AdamEvent Class
Advantech.Adam Namespace


m_byIP Field

AdamEvent.m_byIP Field
[image]

IP

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_byIP As Byte()
C#
public byte[] m_byIP;
C++
public:
array<char>^ m_byIP sealed ;
J#
public byte[] m_byIP
JScript
public m_byIP : Byte[];

See Also

AdamEvent Class
Advantech.Adam Namespace


m_iChannel Field

AdamEvent.m_iChannel Field
[image]

Channel

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_iChannel As Integer
C#
public int m_iChannel;
C++
public:
int m_iChannel sealed ;
J#
public int m_iChannel
JScript
public m_iChannel : int;

See Also

AdamEvent Class
Advantech.Adam Namespace


m_iSlot Field

AdamEvent.m_iSlot Field
[image]

Slot

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_iSlot As Integer
C#
public int m_iSlot;
C++
public:
int m_iSlot sealed ;
J#
public int m_iSlot
JScript
public m_iSlot : int;

See Also

AdamEvent Class
Advantech.Adam Namespace


m_iStatus Field

AdamEvent.m_iStatus Field
[image]

Event status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_iStatus As Integer
C#
public int m_iStatus;
C++
public:
int m_iStatus sealed ;
J#
public int m_iStatus
JScript
public m_iStatus : int;

See Also

AdamEvent Class
Advantech.Adam Namespace


m_iType Field

AdamEvent.m_iType Field
[image]

Event Type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_iType As Integer
C#
public int m_iType;
C++
public:
int m_iType sealed ;
J#
public int m_iType
JScript
public m_iType : int;

See Also

AdamEvent Class
Advantech.Adam Namespace


m_lVal Field

AdamEvent.m_lVal Field
[image]

Value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_lVal As Long
C#
public long m_lVal;
C++
public:
__int64 m_lVal sealed ;
J#
public long m_lVal
JScript
public m_lVal : long;

See Also

AdamEvent Class
Advantech.Adam Namespace


m_Time Field

AdamEvent.m_Time Field
[image]

Time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Time As Date
C#
public DateTime m_Time;
C++
public:
DateTime m_Time sealed ;
J#
public DateTime m_Time
JScript
public m_Time : DateTime;

See Also

AdamEvent Class
Advantech.Adam Namespace


AdamEventServerThread Class

AdamEventServerThread Class
See Also Example Members
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamEventServerThread
C#
public class AdamEventServerThread
C++
ref class AdamEventServerThread
J#
public class AdamEventServerThread
JScript
public class AdamEventServerThread

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamEventServerThread

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamEventServerThread Members
Advantech.Adam Namespace


AdamEventServerThread Members

AdamEventServerThread Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by AdamEventServerThread.

Public Constructors

 | Name | Description
Public method | AdamEventServerThread | Constructer
Top

Public Methods

 | Name | Description
Public method | StartThread | Overloaded. Start server thread (Default Port:8168)
Public method | StopThread | Stop server thread
Top

See Also

AdamEventServerThread Class
Advantech.Adam Namespace


AdamEventServerThread Constructor

AdamEventServerThread Constructor
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByRef recList As AdamStreamRecList, _
ByVal i_IP As String() _
)
C#
public AdamEventServerThread(
ref AdamStreamRecList recList,
string[] i_IP
)
C++
public:
AdamEventServerThread(
AdamStreamRecList% recList,
array<String>^ i_IP
) sealed
J#
public AdamEventServerThread(
AdamStreamRecList recList,
string[] i_IP
)
JScript
public function AdamEventServerThread(
recList : AdamStreamRecList,
i_IP : String[]
)

Parameters

recList
i_IP

See Also

AdamEventServerThread Class
Advantech.Adam Namespace


Methods

AdamEventServerThread Methods
[image]

Public Methods

 | Name | Description
Public method | StartThread | Overloaded. Start server thread (Default Port:8168)
Public method | StopThread | Stop server thread
Top

See Also

AdamEventServerThread Class
Advantech.Adam Namespace


StartThread Method

AdamEventServerThread.StartThread Method

Start server thread (Default Port:8168)

Overload List

 | Name | Description
Public method | StartThread | Start server thread (Default Port:8168)
Public method | StartThread (Int32) | Start server thread

See Also

AdamEventServerThread Class
Advantech.Adam Namespace


StartThread Method ()

AdamEventServerThread.StartThread Method ()
See Also Example
[image]

Start server thread (Default Port:8168)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub StartThread()
C#
public void StartThread()
C++
public:
void StartThread() sealed
J#
public void StartThread()
JScript
public function StartThread()

See Also

AdamEventServerThread Class
Advantech.Adam Namespace
AdamEventServerThread.StartThread Overload List


StartThread Method (Int32)

AdamEventServerThread.StartThread Method (Int32)
See Also Example
[image]

Start server thread

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub StartThread( _
ByVal i_iPort As Integer _
)
C#
public void StartThread(
int i_iPort
)
C++
public:
void StartThread(
int i_iPort
) sealed
J#
public void StartThread(
int i_iPort
)
JScript
public function StartThread(
i_iPort : int
)

Parameters

i_iPort
Receive port. (Default:8168)

See Also

AdamEventServerThread Class
Advantech.Adam Namespace
AdamEventServerThread.StartThread Overload List


StopThread Method

AdamEventServerThread.StopThread Method
[image]

Stop server thread

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function StopThread() As Boolean
C#
public bool StopThread()
C++
public:
bool StopThread() sealed
J#
public bool StopThread()
JScript
public function StopThread() : bool

See Also

AdamEventServerThread Class
Advantech.Adam Namespace


AdamGCL_IOMsg Class

AdamGCL_IOMsg Class
See Also Example Members
[image]

Adam GCL IO message class

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamGCL_IOMsg
C#
public class AdamGCL_IOMsg
C++
ref class AdamGCL_IOMsg
J#
public class AdamGCL_IOMsg
JScript
public class AdamGCL_IOMsg

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamGCL_IOMsg

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamGCL_IOMsg Members
Advantech.Adam Namespace


AdamGCL_IOMsg Members

AdamGCL_IOMsg Members
See Also Example Fields Properties Methods Events Explicit Inteface Implementations
[image]

Adam GCL IO message class

The following tables list the members exposed by AdamGCL_IOMsg.

Public Constructors

Name | Description
AdamGCL_IOMsg | Overloaded. Initializes a new instance of the AdamGCL_IOMsg class.
Top

Public Fields

Name | Description
GCL_IOMsg_Port | Peer to peer UDP server
Top

Public Properties

 | Name | Description
Public property | GCL_IOMsgData | Received GCL IO Message Data
Public property | IsServerStart | if server start
Top

Public Methods

 | Name | Description
Public method | GetData_AI | Get AI data from GCL IO message configuration
Public method | GetData_AO | Get AO data from GCL IO message configuration
Public method | GetData_Cnt | Get Counter data from GCL IO message configuration
Public method | GetData_DI | Get DI data from GCL IO message configuration
Public method | GetData_DO | Get DO data from GCL IO message configuration
Public method | GetLastInfo | Overloaded. Get GCL IO message configuration information
Public method | GetMessage | Get message from GCL IO message configuration
Public method | Start_Server | Overloaded. Start GCL IO Message UDP server
Public method | Stop_Server | Stop GCL IO Message UDP server
Top

Public Events

 | Name | Description
Public event | GetDataEvent | Raised when a subscrition is changed.
Top

Explicit Interface Implementations

Name | Description
AdamGCL_IOMsg | Overloaded. Initializes a new instance of the AdamGCL_IOMsg class.
Top

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


AdamGCL_IOMsg Constructor

AdamGCL_IOMsg Constructor

Initializes a new instance of the AdamGCL_IOMsg class.

Overload List

 | Name | Description
Public method | AdamGCL_IOMsg | Constructer
Public method | AdamGCL_IOMsg (Int32, Int32) | Constructer

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


AdamGCL_IOMsg Constructor ()

AdamGCL_IOMsg Constructor ()
See Also Example
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamGCL_IOMsg()
C++
public:
AdamGCL_IOMsg() sealed
J#
public AdamGCL_IOMsg()
JScript
public function AdamGCL_IOMsg()

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace
AdamGCL_IOMsg Constructor Overload List


AdamGCL_IOMsg Constructor (Int32, Int32)

AdamGCL_IOMsg Constructor (Int32, Int32)
See Also Example
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal iUDPSendTimeout As Integer, _
ByVal iUDPRecvTimeout As Integer _
)
C#
public AdamGCL_IOMsg(
int iUDPSendTimeout,
int iUDPRecvTimeout
)
C++
public:
AdamGCL_IOMsg(
int iUDPSendTimeout,
int iUDPRecvTimeout
) sealed
J#
public AdamGCL_IOMsg(
int iUDPSendTimeout,
int iUDPRecvTimeout
)
JScript
public function AdamGCL_IOMsg(
iUDPSendTimeout : int,
iUDPRecvTimeout : int
)

Parameters

iUDPSendTimeout
UDPSendTimeout
iUDPRecvTimeout
UDPRecvTimeout

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace
AdamGCL_IOMsg Constructor Overload List


Fields

AdamGCL_IOMsg Fields
[image]

Public Fields

Name | Description
GCL_IOMsg_Port | Peer to peer UDP server
Top

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GCL_IOMsg_Port Field

AdamGCL_IOMsg.GCL_IOMsg_Port Field
[image]

Peer to peer UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared GCL_IOMsg_Port As Integer
C#
public static int GCL_IOMsg_Port;
C++
public:
static int GCL_IOMsg_Port;
J#
public static int GCL_IOMsg_Port
JScript
public static GCL_IOMsg_Port : int;

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


Properties

AdamGCL_IOMsg Properties
[image]

Public Properties

 | Name | Description
Public property | GCL_IOMsgData | Received GCL IO Message Data
Public property | IsServerStart | if server start
Top

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GCL_IOMsgData Property

AdamGCL_IOMsg.GCL_IOMsgData Property
[image]

Received GCL IO Message Data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GCL_IOMsgData As Byte()
C#
public byte[] GCL_IOMsgData { get; }
C++
public property byte[] GCL_IOMsgData sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_GCL_IOMsgData();
JScript
public function get GCL_IOMsgData() : Byte[]

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


IsServerStart Property

AdamGCL_IOMsg.IsServerStart Property
[image]

if server start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsServerStart As Boolean
C#
public bool IsServerStart { get; }
C++
public property bool IsServerStart sealed {
bool get();
}
J#
/** property */
public bool get_IsServerStart();
JScript
public function get IsServerStart() : bool

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


Methods

AdamGCL_IOMsg Methods
[image]

Public Methods

 | Name | Description
Public method | GetData_AI | Get AI data from GCL IO message configuration
Public method | GetData_AO | Get AO data from GCL IO message configuration
Public method | GetData_Cnt | Get Counter data from GCL IO message configuration
Public method | GetData_DI | Get DI data from GCL IO message configuration
Public method | GetData_DO | Get DO data from GCL IO message configuration
Public method | GetLastInfo | Overloaded. Get GCL IO message configuration information
Public method | GetMessage | Get message from GCL IO message configuration
Public method | Start_Server | Overloaded. Start GCL IO Message UDP server
Public method | Stop_Server | Stop GCL IO Message UDP server
Top

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetData_AI Method

AdamGCL_IOMsg.GetData_AI Method
[image]

Get AI data from GCL IO message configuration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData_AI( _
ByVal config As GCL_IOMsg_Config, _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetData_AI(
GCL_IOMsg_Config config,
out byte o_byData
)
C++
public:
bool GetData_AI(
GCL_IOMsg_Config config,
[OutAttribute] char% o_byData
) sealed
J#
public bool GetData_AI(
GCL_IOMsg_Config config,
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetData_AI(
config : GCL_IOMsg_Config,
OutAttribute o_byData : Byte
) : bool

Parameters

config
GCL IO and message configuration
o_byData
AI data

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetData_AO Method

AdamGCL_IOMsg.GetData_AO Method
[image]

Get AO data from GCL IO message configuration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData_AO( _
ByVal config As GCL_IOMsg_Config, _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetData_AO(
GCL_IOMsg_Config config,
out byte o_byData
)
C++
public:
bool GetData_AO(
GCL_IOMsg_Config config,
[OutAttribute] char% o_byData
) sealed
J#
public bool GetData_AO(
GCL_IOMsg_Config config,
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetData_AO(
config : GCL_IOMsg_Config,
OutAttribute o_byData : Byte
) : bool

Parameters

config
GCL IO and message configuration
o_byData
AO data

Return Value

true, if succeed. Otherwise, return false.>

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetData_Cnt Method

AdamGCL_IOMsg.GetData_Cnt Method
[image]

Get Counter data from GCL IO message configuration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData_Cnt( _
ByVal config As GCL_IOMsg_Config, _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetData_Cnt(
GCL_IOMsg_Config config,
out byte o_byData
)
C++
public:
bool GetData_Cnt(
GCL_IOMsg_Config config,
[OutAttribute] char% o_byData
) sealed
J#
public bool GetData_Cnt(
GCL_IOMsg_Config config,
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetData_Cnt(
config : GCL_IOMsg_Config,
OutAttribute o_byData : Byte
) : bool

Parameters

config
GCL IO and message configuration
o_byData
Counter data

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetData_DI Method

AdamGCL_IOMsg.GetData_DI Method
[image]

Get DI data from GCL IO message configuration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData_DI( _
ByVal config As GCL_IOMsg_Config, _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetData_DI(
GCL_IOMsg_Config config,
out byte o_byData
)
C++
public:
bool GetData_DI(
GCL_IOMsg_Config config,
[OutAttribute] char% o_byData
) sealed
J#
public bool GetData_DI(
GCL_IOMsg_Config config,
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetData_DI(
config : GCL_IOMsg_Config,
OutAttribute o_byData : Byte
) : bool

Parameters

config
GCL IO and message configuration
o_byData
DI data

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetData_DO Method

AdamGCL_IOMsg.GetData_DO Method
[image]

Get DO data from GCL IO message configuration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetData_DO( _
ByVal config As GCL_IOMsg_Config, _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetData_DO(
GCL_IOMsg_Config config,
out byte o_byData
)
C++
public:
bool GetData_DO(
GCL_IOMsg_Config config,
[OutAttribute] char% o_byData
) sealed
J#
public bool GetData_DO(
GCL_IOMsg_Config config,
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetData_DO(
config : GCL_IOMsg_Config,
OutAttribute o_byData : Byte
) : bool

Parameters

config
GCL IO and message configuration
o_byData
DO data

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetLastInfo Method

AdamGCL_IOMsg.GetLastInfo Method

Get GCL IO message configuration information

Overload List

 | Name | Description
Public method | GetLastInfo (GCL_IOMsg_Config) | Get GCL IO message configuration information
Public method | GetLastInfo (GCL_IOMsg_Config, UInt32) | Get GCL IO message configuration information by comparing newer sequence number

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetLastInfo Method (GCL_IOMsg_Config)

AdamGCL_IOMsg.GetLastInfo Method (GCL_IOMsg_Config)
See Also Example
[image]

Get GCL IO message configuration information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLastInfo( _
<OutAttribute> ByRef gcl_IOMsg_Config As GCL_IOMsg_Config _
) As Boolean
C#
public bool GetLastInfo(
out GCL_IOMsg_Config gcl_IOMsg_Config
)
C++
public:
bool GetLastInfo(
[OutAttribute] GCL_IOMsg_Config% gcl_IOMsg_Config
) sealed
J#
public bool GetLastInfo(
/** @attribute OutAttribute() */ /** @ref */ GCL_IOMsg_Config gcl_IOMsg_Config
)
JScript
public function GetLastInfo(
OutAttribute gcl_IOMsg_Config : GCL_IOMsg_Config
) : bool

Parameters

gcl_IOMsg_Config
GCL IO and message configuration

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace
AdamGCL_IOMsg.GetLastInfo Overload List


GetLastInfo Method (GCL_IOMsg_Config, UInt32)

AdamGCL_IOMsg.GetLastInfo Method (GCL_IOMsg_Config, UInt32)
See Also Example
[image]

Get GCL IO message configuration information by comparing newer sequence number

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLastInfo( _
<OutAttribute> ByRef gcl_IOMsg_Config As GCL_IOMsg_Config, _
ByVal currentSeqNum As UInt32 _
) As Boolean
C#
public bool GetLastInfo(
out GCL_IOMsg_Config gcl_IOMsg_Config,
uint currentSeqNum
)
C++
public:
bool GetLastInfo(
[OutAttribute] GCL_IOMsg_Config% gcl_IOMsg_Config,
unsigned int currentSeqNum
) sealed
J#
public bool GetLastInfo(
/** @attribute OutAttribute() */ /** @ref */ GCL_IOMsg_Config gcl_IOMsg_Config,
uint currentSeqNum
)
JScript
public function GetLastInfo(
OutAttribute gcl_IOMsg_Config : GCL_IOMsg_Config,
currentSeqNum : UInt32
) : bool

Parameters

gcl_IOMsg_Config
GCL IO and message configuration
currentSeqNum
Compare package by sequence number

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace
AdamGCL_IOMsg.GetLastInfo Overload List


GetMessage Method

AdamGCL_IOMsg.GetMessage Method
[image]

Get message from GCL IO message configuration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMessage( _
ByVal config As GCL_IOMsg_Config, _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetMessage(
GCL_IOMsg_Config config,
out byte o_byData
)
C++
public:
bool GetMessage(
GCL_IOMsg_Config config,
[OutAttribute] char% o_byData
) sealed
J#
public bool GetMessage(
GCL_IOMsg_Config config,
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetMessage(
config : GCL_IOMsg_Config,
OutAttribute o_byData : Byte
) : bool

Parameters

config
GCL IO and message configuration
o_byData

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


Start_Server Method

AdamGCL_IOMsg.Start_Server Method

Start GCL IO Message UDP server

Overload List

 | Name | Description
Public method | Start_Server | Start GCL IO Message UDP server
Public method | Start_Server (Int32) | Start GCL IO Message UDP server

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


Start_Server Method ()

AdamGCL_IOMsg.Start_Server Method ()
See Also Example
[image]

Start GCL IO Message UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Start_Server() As Boolean
C#
public bool Start_Server()
C++
public:
bool Start_Server() sealed
J#
public bool Start_Server()
JScript
public function Start_Server() : bool

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace
AdamGCL_IOMsg.Start_Server Overload List


Start_Server Method (Int32)

AdamGCL_IOMsg.Start_Server Method (Int32)
See Also Example
[image]

Start GCL IO Message UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Start_Server( _
ByVal iPort As Integer _
) As Boolean
C#
public bool Start_Server(
int iPort
)
C++
public:
bool Start_Server(
int iPort
) sealed
J#
public bool Start_Server(
int iPort
)
JScript
public function Start_Server(
iPort : int
) : bool

Parameters

iPort
GCL IO Message port.(Default:1025)

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace
AdamGCL_IOMsg.Start_Server Overload List


Stop_Server Method

AdamGCL_IOMsg.Stop_Server Method
[image]

Stop GCL IO Message UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Stop_Server() As Boolean
C#
public bool Stop_Server()
C++
public:
bool Stop_Server() sealed
J#
public bool Stop_Server()
JScript
public function Stop_Server() : bool

Return Value

true, if succeed. Otherwise, return false.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


Events

AdamGCL_IOMsg Events
[image]

Public Events

 | Name | Description
Public event | GetDataEvent | Raised when a subscrition is changed.
Top

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


GetDataEvent Event

AdamGCL_IOMsg.GetDataEvent Event
[image]

Raised when a subscrition is changed.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Event GetDataEvent As GetDataCallback
C#
public event GetDataCallback GetDataEvent
C++
public:
virtual event GetDataCallback GetDataEvent {
void add(GetDataCallback value) sealed ;
void remove(GetDataCallback value) sealed ;
}
J#
/** event */
public final void add_GetDataEvent(GetDataCallback value);

/** event */
public final void remove_GetDataEvent(GetDataCallback value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

AdamGCL_IOMsg Class
Advantech.Adam Namespace


AdamInfoModuleStatus Enumeration

AdamInfoModuleStatus Enumeration
[image]

Module status in Adam information Class

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum AdamInfoModuleStatus
C#
public enum AdamInfoModuleStatus
C++
public enum class AdamInfoModuleStatus
J#
public enum AdamInfoModuleStatus
JScript
public enum AdamInfoModuleStatus

Members

Member Name | Description
RuntimeMode | Download(Bootloader) mode.
DownloadMode | Runtime mode.
NormalMode | Normal mode.
InitialMode | Initial mode.

See Also

Advantech.Adam Namespace


AdamInformation Class

AdamInformation Class
See Also Example Members
[image]

The ADAM class to stroe all information about a module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamInformation
C#
public class AdamInformation
C++
ref class AdamInformation
J#
public class AdamInformation
JScript
public class AdamInformation

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamInformation

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamInformation Members
Advantech.Adam Namespace


AdamInformation Members

AdamInformation Members
See Also Example Constructors Properties Methods
[image]

The ADAM class to stroe all information about a module

The following tables list the members exposed by AdamInformation.

Public Constructors

 | Name | Description
Public method | AdamInformation | AdamInformation constuctor
Top

Public Properties

 | Name | Description
Public property | BasicRate | The wireless basic rate.
Public property | Baudrate | The baudrate.
Public property | ClientIP | The Client IP address.
Public property | Databits | The databits.
Public property | Description | The description.
Public property | DeviceID | Get/set device ID.
Public property | DeviceName | The device name.
Public property | EthernetMode | The ethernet mode.
Public property | FlowControl | The flow control.
Public property | FrameTimeout | The frame timeout.
Public property | FwVer | Get/set device ID.
Public property | Gateway | The default gateway.
Public property | HardwareType | The hardware type.
Public property | HeaderReserved | The header reserved field.
Public property | HostIdle | The host idle status.
Public property | HostIdleTime | The host idle time.
Public property | InitSSID | The wireless initial SSID.
Public property | InitSSIDLength | The wireless initial SSID length.
Public property | IP | The IP address.
Public property | Mac | The MAC address.
Public property | ModuleControlCmdData | The module control command parameter data.
Public property | ModuleControlCmdLength | The module control command parameter byte length.
Public property | ModuleStatus | The Module Status.
Public property | NetConfigProtocol | The default gateway.
Public property | NewMac | The new MAC address.
Public property | Parity | The parity.
Public property | Password | The password.
Public property | PasswordCache | The password cached
Public property | PortNumber | The port number.
Public property | SSID | The wireless SSID.
Public property | SSIDLength | The wireless SSID length.
Public property | Stopbits | The stop bits.
Public property | Subnet | The subnet mask.
Public property | SupportWebHttp | The Web Http status.
Public property | WEP | The wireless WEP key.
Public property | WEPKey128 | The wireless 128 bits WEP key.
Public property | WEPKey64 | The wireless 64 bits WEP key 1.
Public property | WEPKey64_2 | The wireless 64 bits WEP key 2.
Public property | WEPKey64_3 | The wireless 64 bits WEP key 3.
Public property | WEPKey64_4 | The wireless 64 bits WEP key 4.
Public property | WEPKeyIndex | The wireless WEP key Index.
Public property | WirelessChannel | The wireless channel.
Public property | WirelessMode | The wireless mode.
Public property | WirelessModeFlag | The wireless mode flag.
Public property | WirelessRegion | The wireless region.
Public property | WirelessRegionFlag | The wireless region flag.
Top

Public Methods

 | Name | Description
Public method | CopyTo | Copy to another AdamInformation object.
Public method | Equals | Overridden. Redefine Equals for AdamInformation type.
Public method | GetHashCode | Overridden. Override GetHashCode() for consistency and usability in dictionaries..
Public method | SetBasicRate | Copy wireless basic rate from UDP packet to this object
Public method | SetBaudrate | Copy baudrate from UDP packet to this object
Public method | SetClientIP | Copy IP from IPEndPoint to this object
Public method | SetDatabits | Copy databits from UDP packet to this object
Public method | SetDescription | Copy device description from UDP packet to this object
Public method | SetDeviceID | Copy device ID from UDP packet to this object
Public method | SetDeviceName | Copy device name from UDP packet to this object
Public method | SetEthernetMode | Copy ethernet mode from UDP packet to this object
Public method | SetFlowControl | Copy flow control from UDP packet to this object
Public method | SetFrameTimeout | Copy frame timeout from UDP packet to this object
Public method | SetFwVer | Copy device ID from UDP packet to this object
Public method | SetGateway | Copy default gateway from UDP packet to this object
Public method | SetHardwareType | Copy hardware type from UDP packet to this object
Public method | SetHeaderReserved | Copy header reserve field from UDP packet to this object
Public method | SetHostIdle | Copy host idle enabled from UDP packet to this object
Public method | SetHostIdleTime | Copy host idle time from UDP packet to this object
Public method | SetInitSSID | Copy wireless initial SSID from UDP packet to this object
Public method | SetInitSSIDLength | Copy wireless initial SSID length from UDP packet to this object
Public method | SetIP | Copy IP from UDP packet to this object
Public method | SetMac | Copy MAC address from UDP packet to this object
Public method | SetModuleControlCmd | Set Module Control Command Parameter Value.
Public method | SetModuleStatus | Copy Module Status from UDP packet to this object
Public method | SetNetConfigProtocol | Copy default NetConfigProtocol from UDP packet to this object
Public method | SetParity | Copy parity from UDP packet to this object
Public method | SetPassword | Copy password from UDP packet to this object
Public method | SetPortNumber | Copy port number from UDP packet to this object
Public method | SetSSID | Copy wireless SSID from UDP packet to this object
Public method | SetSSIDLength | Copy wireless SSID length from UDP packet to this object
Public method | SetStopbits | Copy stopbits from UDP packet to this object
Public method | SetSubnet | Copy subnet mask from UDP packet to this object
Public method | SetWebHttp | Copy Web Http enabled from UDP packet to this object
Public method | SetWEP | Copy wireless WEP key from UDP packet to this object
Public method | SetWEPKey128 | Copy wireless 128 bits WEP key from UDP packet to this object
Public method | SetWEPKey64 | Copy wireless 64 bits WEP key 1 from UDP packet to this object
Public method | SetWEPKey64_2 | Copy wireless 64 bits WEP key 2 from UDP packet to this object
Public method | SetWEPKey64_3 | Copy wireless 64 bits WEP key 3 from UDP packet to this object
Public method | SetWEPKey64_4 | Copy wireless 64 bits WEP key 4 from UDP packet to this object
Public method | SetWEPKeyIndex | Copy wireless WEP key index from UDP packet to this object
Public method | SetWirelessChannel | Copy wireless channel from UDP packet to this object
Public method | SetWirelessMode | Copy wireless mode from UDP packet to this object
Public method | SetWirelessModeFlag | Copy wireless mode flag from UDP packet to this object
Public method | SetWirelessRegion | Copy wireless region from UDP packet to this object
Public method | SetWirelessRegionFlag | Copy wireless region flag from UDP packet to this object
Top

See Also

AdamInformation Class
Advantech.Adam Namespace


AdamInformation Constructor

AdamInformation Constructor
[image]

AdamInformation constuctor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamInformation()
C++
public:
AdamInformation() sealed
J#
public AdamInformation()
JScript
public function AdamInformation()

See Also

AdamInformation Class
Advantech.Adam Namespace


Properties

AdamInformation Properties
[image]

Public Properties

 | Name | Description
Public property | BasicRate | The wireless basic rate.
Public property | Baudrate | The baudrate.
Public property | ClientIP | The Client IP address.
Public property | Databits | The databits.
Public property | Description | The description.
Public property | DeviceID | Get/set device ID.
Public property | DeviceName | The device name.
Public property | EthernetMode | The ethernet mode.
Public property | FlowControl | The flow control.
Public property | FrameTimeout | The frame timeout.
Public property | FwVer | Get/set device ID.
Public property | Gateway | The default gateway.
Public property | HardwareType | The hardware type.
Public property | HeaderReserved | The header reserved field.
Public property | HostIdle | The host idle status.
Public property | HostIdleTime | The host idle time.
Public property | InitSSID | The wireless initial SSID.
Public property | InitSSIDLength | The wireless initial SSID length.
Public property | IP | The IP address.
Public property | Mac | The MAC address.
Public property | ModuleControlCmdData | The module control command parameter data.
Public property | ModuleControlCmdLength | The module control command parameter byte length.
Public property | ModuleStatus | The Module Status.
Public property | NetConfigProtocol | The default gateway.
Public property | NewMac | The new MAC address.
Public property | Parity | The parity.
Public property | Password | The password.
Public property | PasswordCache | The password cached
Public property | PortNumber | The port number.
Public property | SSID | The wireless SSID.
Public property | SSIDLength | The wireless SSID length.
Public property | Stopbits | The stop bits.
Public property | Subnet | The subnet mask.
Public property | SupportWebHttp | The Web Http status.
Public property | WEP | The wireless WEP key.
Public property | WEPKey128 | The wireless 128 bits WEP key.
Public property | WEPKey64 | The wireless 64 bits WEP key 1.
Public property | WEPKey64_2 | The wireless 64 bits WEP key 2.
Public property | WEPKey64_3 | The wireless 64 bits WEP key 3.
Public property | WEPKey64_4 | The wireless 64 bits WEP key 4.
Public property | WEPKeyIndex | The wireless WEP key Index.
Public property | WirelessChannel | The wireless channel.
Public property | WirelessMode | The wireless mode.
Public property | WirelessModeFlag | The wireless mode flag.
Public property | WirelessRegion | The wireless region.
Public property | WirelessRegionFlag | The wireless region flag.
Top

See Also

AdamInformation Class
Advantech.Adam Namespace


BasicRate Property

AdamInformation.BasicRate Property
[image]

The wireless basic rate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property BasicRate As Integer
C#
public int BasicRate { get; set; }
C++
public property int BasicRate sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_BasicRate();

/** property */
public void set_BasicRate(int value);
JScript
public function get BasicRate() : int

public function set BasicRate(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


Baudrate Property

AdamInformation.Baudrate Property
[image]

The baudrate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Baudrate As Integer
C#
public int Baudrate { get; set; }
C++
public property int Baudrate sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Baudrate();

/** property */
public void set_Baudrate(int value);
JScript
public function get Baudrate() : int

public function set Baudrate(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


ClientIP Property

AdamInformation.ClientIP Property
[image]

The Client IP address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientIP As Byte()
C#
public byte[] ClientIP { get; set; }
C++
public property byte[] ClientIP sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_ClientIP();

/** property */
public void set_ClientIP(byte[] value);
JScript
public function get ClientIP() : Byte[]

public function set ClientIP(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


Databits Property

AdamInformation.Databits Property
[image]

The databits.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Databits As Integer
C#
public int Databits { get; set; }
C++
public property int Databits sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Databits();

/** property */
public void set_Databits(int value);
JScript
public function get Databits() : int

public function set Databits(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


Description Property

AdamInformation.Description Property
[image]

The description.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

AdamInformation Class
Advantech.Adam Namespace


DeviceID Property

AdamInformation.DeviceID Property
[image]

Get/set device ID.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceID As Byte()
C#
public byte[] DeviceID { get; set; }
C++
public property byte[] DeviceID sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_DeviceID();

/** property */
public void set_DeviceID(byte[] value);
JScript
public function get DeviceID() : Byte[]

public function set DeviceID(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


DeviceName Property

AdamInformation.DeviceName Property
[image]

The device name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property DeviceName As String
C#
public string DeviceName { get; set; }
C++
public property string DeviceName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DeviceName();

/** property */
public void set_DeviceName(string value);
JScript
public function get DeviceName() : String

public function set DeviceName(value : String);

See Also

AdamInformation Class
Advantech.Adam Namespace


EthernetMode Property

AdamInformation.EthernetMode Property
[image]

The ethernet mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property EthernetMode As Integer
C#
public int EthernetMode { get; set; }
C++
public property int EthernetMode sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_EthernetMode();

/** property */
public void set_EthernetMode(int value);
JScript
public function get EthernetMode() : int

public function set EthernetMode(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


FlowControl Property

AdamInformation.FlowControl Property
[image]

The flow control.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property FlowControl As Integer
C#
public int FlowControl { get; set; }
C++
public property int FlowControl sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_FlowControl();

/** property */
public void set_FlowControl(int value);
JScript
public function get FlowControl() : int

public function set FlowControl(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


FrameTimeout Property

AdamInformation.FrameTimeout Property
[image]

The frame timeout.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property FrameTimeout As Integer
C#
public int FrameTimeout { get; set; }
C++
public property int FrameTimeout sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_FrameTimeout();

/** property */
public void set_FrameTimeout(int value);
JScript
public function get FrameTimeout() : int

public function set FrameTimeout(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


FwVer Property

AdamInformation.FwVer Property
[image]

Get/set device ID.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property FwVer As Byte()
C#
public byte[] FwVer { get; set; }
C++
public property byte[] FwVer sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_FwVer();

/** property */
public void set_FwVer(byte[] value);
JScript
public function get FwVer() : Byte[]

public function set FwVer(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


Gateway Property

AdamInformation.Gateway Property
[image]

The default gateway.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Gateway As Byte()
C#
public byte[] Gateway { get; set; }
C++
public property byte[] Gateway sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_Gateway();

/** property */
public void set_Gateway(byte[] value);
JScript
public function get Gateway() : Byte[]

public function set Gateway(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


HardwareType Property

AdamInformation.HardwareType Property
[image]

The hardware type.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property HardwareType As Byte()
C#
public byte[] HardwareType { get; set; }
C++
public property byte[] HardwareType sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_HardwareType();

/** property */
public void set_HardwareType(byte[] value);
JScript
public function get HardwareType() : Byte[]

public function set HardwareType(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


HeaderReserved Property

AdamInformation.HeaderReserved Property
[image]

The header reserved field.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property HeaderReserved As Byte()
C#
public byte[] HeaderReserved { get; set; }
C++
public property byte[] HeaderReserved sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_HeaderReserved();

/** property */
public void set_HeaderReserved(byte[] value);
JScript
public function get HeaderReserved() : Byte[]

public function set HeaderReserved(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


HostIdle Property

AdamInformation.HostIdle Property
[image]

The host idle status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property HostIdle As Boolean
C#
public bool HostIdle { get; set; }
C++
public property bool HostIdle sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_HostIdle();

/** property */
public void set_HostIdle(bool value);
JScript
public function get HostIdle() : bool

public function set HostIdle(value : bool);

See Also

AdamInformation Class
Advantech.Adam Namespace


HostIdleTime Property

AdamInformation.HostIdleTime Property
[image]

The host idle time.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property HostIdleTime As Integer
C#
public int HostIdleTime { get; set; }
C++
public property int HostIdleTime sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_HostIdleTime();

/** property */
public void set_HostIdleTime(int value);
JScript
public function get HostIdleTime() : int

public function set HostIdleTime(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


InitSSID Property

AdamInformation.InitSSID Property
[image]

The wireless initial SSID.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property InitSSID As String
C#
public string InitSSID { get; set; }
C++
public property string InitSSID sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_InitSSID();

/** property */
public void set_InitSSID(string value);
JScript
public function get InitSSID() : String

public function set InitSSID(value : String);

See Also

AdamInformation Class
Advantech.Adam Namespace


InitSSIDLength Property

AdamInformation.InitSSIDLength Property
[image]

The wireless initial SSID length.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property InitSSIDLength As Byte
C#
public byte InitSSIDLength { get; set; }
C++
public property byte InitSSIDLength sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_InitSSIDLength();

/** property */
public void set_InitSSIDLength(byte value);
JScript
public function get InitSSIDLength() : Byte

public function set InitSSIDLength(value : Byte);

See Also

AdamInformation Class
Advantech.Adam Namespace


IP Property

AdamInformation.IP Property
[image]

The IP address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property IP As Byte()
C#
public byte[] IP { get; set; }
C++
public property byte[] IP sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_IP();

/** property */
public void set_IP(byte[] value);
JScript
public function get IP() : Byte[]

public function set IP(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


Mac Property

AdamInformation.Mac Property
[image]

The MAC address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Mac As Byte()
C#
public byte[] Mac { get; set; }
C++
public property byte[] Mac sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_Mac();

/** property */
public void set_Mac(byte[] value);
JScript
public function get Mac() : Byte[]

public function set Mac(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


ModuleControlCmdData Property

AdamInformation.ModuleControlCmdData Property
[image]

The module control command parameter data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ModuleControlCmdData As Byte()
C#
public byte[] ModuleControlCmdData { get; }
C++
public property byte[] ModuleControlCmdData sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_ModuleControlCmdData();
JScript
public function get ModuleControlCmdData() : Byte[]

See Also

AdamInformation Class
Advantech.Adam Namespace


ModuleControlCmdLength Property

AdamInformation.ModuleControlCmdLength Property
[image]

The module control command parameter byte length.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ModuleControlCmdLength As Integer
C#
public int ModuleControlCmdLength { get; }
C++
public property int ModuleControlCmdLength sealed {
int get();
}
J#
/** property */
public int get_ModuleControlCmdLength();
JScript
public function get ModuleControlCmdLength() : int

See Also

AdamInformation Class
Advantech.Adam Namespace


ModuleStatus Property

AdamInformation.ModuleStatus Property
[image]

The Module Status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property ModuleStatus As Byte()
C#
public byte[] ModuleStatus { get; set; }
C++
public property byte[] ModuleStatus sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_ModuleStatus();

/** property */
public void set_ModuleStatus(byte[] value);
JScript
public function get ModuleStatus() : Byte[]

public function set ModuleStatus(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


NetConfigProtocol Property

AdamInformation.NetConfigProtocol Property
[image]

The default gateway.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property NetConfigProtocol As Byte()
C#
public byte[] NetConfigProtocol { get; set; }
C++
public property byte[] NetConfigProtocol sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_NetConfigProtocol();

/** property */
public void set_NetConfigProtocol(byte[] value);
JScript
public function get NetConfigProtocol() : Byte[]

public function set NetConfigProtocol(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


NewMac Property

AdamInformation.NewMac Property
[image]

The new MAC address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property NewMac As Byte()
C#
public byte[] NewMac { get; set; }
C++
public property byte[] NewMac sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_NewMac();

/** property */
public void set_NewMac(byte[] value);
JScript
public function get NewMac() : Byte[]

public function set NewMac(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


Parity Property

AdamInformation.Parity Property
[image]

The parity.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Parity As Integer
C#
public int Parity { get; set; }
C++
public property int Parity sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Parity();

/** property */
public void set_Parity(int value);
JScript
public function get Parity() : int

public function set Parity(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


Password Property

AdamInformation.Password Property
[image]

The password.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

See Also

AdamInformation Class
Advantech.Adam Namespace


PasswordCache Property

AdamInformation.PasswordCache Property
[image]

The password cached

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property PasswordCache As String
C#
public string PasswordCache { get; set; }
C++
public property string PasswordCache sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_PasswordCache();

/** property */
public void set_PasswordCache(string value);
JScript
public function get PasswordCache() : String

public function set PasswordCache(value : String);

See Also

AdamInformation Class
Advantech.Adam Namespace


PortNumber Property

AdamInformation.PortNumber Property
[image]

The port number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property PortNumber As Integer
C#
public int PortNumber { get; set; }
C++
public property int PortNumber sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_PortNumber();

/** property */
public void set_PortNumber(int value);
JScript
public function get PortNumber() : int

public function set PortNumber(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


SSID Property

AdamInformation.SSID Property
[image]

The wireless SSID.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property SSID As String
C#
public string SSID { get; set; }
C++
public property string SSID sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SSID();

/** property */
public void set_SSID(string value);
JScript
public function get SSID() : String

public function set SSID(value : String);

See Also

AdamInformation Class
Advantech.Adam Namespace


SSIDLength Property

AdamInformation.SSIDLength Property
[image]

The wireless SSID length.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property SSIDLength As Byte
C#
public byte SSIDLength { get; set; }
C++
public property byte SSIDLength sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_SSIDLength();

/** property */
public void set_SSIDLength(byte value);
JScript
public function get SSIDLength() : Byte

public function set SSIDLength(value : Byte);

See Also

AdamInformation Class
Advantech.Adam Namespace


Stopbits Property

AdamInformation.Stopbits Property
[image]

The stop bits.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Stopbits As Integer
C#
public int Stopbits { get; set; }
C++
public property int Stopbits sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Stopbits();

/** property */
public void set_Stopbits(int value);
JScript
public function get Stopbits() : int

public function set Stopbits(value : int);

See Also

AdamInformation Class
Advantech.Adam Namespace


Subnet Property

AdamInformation.Subnet Property
[image]

The subnet mask.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Subnet As Byte()
C#
public byte[] Subnet { get; set; }
C++
public property byte[] Subnet sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_Subnet();

/** property */
public void set_Subnet(byte[] value);
JScript
public function get Subnet() : Byte[]

public function set Subnet(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


SupportWebHttp Property

AdamInformation.SupportWebHttp Property
[image]

The Web Http status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportWebHttp As Boolean
C#
public bool SupportWebHttp { get; set; }
C++
public property bool SupportWebHttp sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportWebHttp();

/** property */
public void set_SupportWebHttp(bool value);
JScript
public function get SupportWebHttp() : bool

public function set SupportWebHttp(value : bool);

See Also

AdamInformation Class
Advantech.Adam Namespace


WEP Property

AdamInformation.WEP Property
[image]

The wireless WEP key.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WEP As Byte
C#
public byte WEP { get; set; }
C++
public property byte WEP sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_WEP();

/** property */
public void set_WEP(byte value);
JScript
public function get WEP() : Byte

public function set WEP(value : Byte);

See Also

AdamInformation Class
Advantech.Adam Namespace


WEPKey128 Property

AdamInformation.WEPKey128 Property
[image]

The wireless 128 bits WEP key.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WEPKey128 As Byte()
C#
public byte[] WEPKey128 { get; set; }
C++
public property byte[] WEPKey128 sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_WEPKey128();

/** property */
public void set_WEPKey128(byte[] value);
JScript
public function get WEPKey128() : Byte[]

public function set WEPKey128(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


WEPKey64 Property

AdamInformation.WEPKey64 Property
[image]

The wireless 64 bits WEP key 1.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WEPKey64 As Byte()
C#
public byte[] WEPKey64 { get; set; }
C++
public property byte[] WEPKey64 sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_WEPKey64();

/** property */
public void set_WEPKey64(byte[] value);
JScript
public function get WEPKey64() : Byte[]

public function set WEPKey64(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


WEPKey64_2 Property

AdamInformation.WEPKey64_2 Property
[image]

The wireless 64 bits WEP key 2.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WEPKey64_2 As Byte()
C#
public byte[] WEPKey64_2 { get; set; }
C++
public property byte[] WEPKey64_2 sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_WEPKey64_2();

/** property */
public void set_WEPKey64_2(byte[] value);
JScript
public function get WEPKey64_2() : Byte[]

public function set WEPKey64_2(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


WEPKey64_3 Property

AdamInformation.WEPKey64_3 Property
[image]

The wireless 64 bits WEP key 3.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WEPKey64_3 As Byte()
C#
public byte[] WEPKey64_3 { get; set; }
C++
public property byte[] WEPKey64_3 sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_WEPKey64_3();

/** property */
public void set_WEPKey64_3(byte[] value);
JScript
public function get WEPKey64_3() : Byte[]

public function set WEPKey64_3(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


WEPKey64_4 Property

AdamInformation.WEPKey64_4 Property
[image]

The wireless 64 bits WEP key 4.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WEPKey64_4 As Byte()
C#
public byte[] WEPKey64_4 { get; set; }
C++
public property byte[] WEPKey64_4 sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_WEPKey64_4();

/** property */
public void set_WEPKey64_4(byte[] value);
JScript
public function get WEPKey64_4() : Byte[]

public function set WEPKey64_4(value : Byte[]);

See Also

AdamInformation Class
Advantech.Adam Namespace


WEPKeyIndex Property

AdamInformation.WEPKeyIndex Property
[image]

The wireless WEP key Index.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WEPKeyIndex As Byte
C#
public byte WEPKeyIndex { get; set; }
C++
public property byte WEPKeyIndex sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_WEPKeyIndex();

/** property */
public void set_WEPKeyIndex(byte value);
JScript
public function get WEPKeyIndex() : Byte

public function set WEPKeyIndex(value : Byte);

See Also

AdamInformation Class
Advantech.Adam Namespace


WirelessChannel Property

AdamInformation.WirelessChannel Property
[image]

The wireless channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WirelessChannel As Byte
C#
public byte WirelessChannel { get; set; }
C++
public property byte WirelessChannel sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_WirelessChannel();

/** property */
public void set_WirelessChannel(byte value);
JScript
public function get WirelessChannel() : Byte

public function set WirelessChannel(value : Byte);

See Also

AdamInformation Class
Advantech.Adam Namespace


WirelessMode Property

AdamInformation.WirelessMode Property
[image]

The wireless mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WirelessMode As Byte
C#
public byte WirelessMode { get; set; }
C++
public property byte WirelessMode sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_WirelessMode();

/** property */
public void set_WirelessMode(byte value);
JScript
public function get WirelessMode() : Byte

public function set WirelessMode(value : Byte);

See Also

AdamInformation Class
Advantech.Adam Namespace


WirelessModeFlag Property

AdamInformation.WirelessModeFlag Property
[image]

The wireless mode flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WirelessModeFlag As Long
C#
public long WirelessModeFlag { get; set; }
C++
public property long WirelessModeFlag sealed {
__int64 get();
void set(__int64 value);
}
J#
/** property */
public long get_WirelessModeFlag();

/** property */
public void set_WirelessModeFlag(long value);
JScript
public function get WirelessModeFlag() : long

public function set WirelessModeFlag(value : long);

See Also

AdamInformation Class
Advantech.Adam Namespace


WirelessRegion Property

AdamInformation.WirelessRegion Property
[image]

The wireless region.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WirelessRegion As Long
C#
public long WirelessRegion { get; set; }
C++
public property long WirelessRegion sealed {
__int64 get();
void set(__int64 value);
}
J#
/** property */
public long get_WirelessRegion();

/** property */
public void set_WirelessRegion(long value);
JScript
public function get WirelessRegion() : long

public function set WirelessRegion(value : long);

See Also

AdamInformation Class
Advantech.Adam Namespace


WirelessRegionFlag Property

AdamInformation.WirelessRegionFlag Property
[image]

The wireless region flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WirelessRegionFlag As Long
C#
public long WirelessRegionFlag { get; set; }
C++
public property long WirelessRegionFlag sealed {
__int64 get();
void set(__int64 value);
}
J#
/** property */
public long get_WirelessRegionFlag();

/** property */
public void set_WirelessRegionFlag(long value);
JScript
public function get WirelessRegionFlag() : long

public function set WirelessRegionFlag(value : long);

See Also

AdamInformation Class
Advantech.Adam Namespace


Methods

AdamInformation Methods
[image]

Public Methods

 | Name | Description
Public method | CopyTo | Copy to another AdamInformation object.
Public method | Equals | Overridden. Redefine Equals for AdamInformation type.
Public method | GetHashCode | Overridden. Override GetHashCode() for consistency and usability in dictionaries..
Public method | SetBasicRate | Copy wireless basic rate from UDP packet to this object
Public method | SetBaudrate | Copy baudrate from UDP packet to this object
Public method | SetClientIP | Copy IP from IPEndPoint to this object
Public method | SetDatabits | Copy databits from UDP packet to this object
Public method | SetDescription | Copy device description from UDP packet to this object
Public method | SetDeviceID | Copy device ID from UDP packet to this object
Public method | SetDeviceName | Copy device name from UDP packet to this object
Public method | SetEthernetMode | Copy ethernet mode from UDP packet to this object
Public method | SetFlowControl | Copy flow control from UDP packet to this object
Public method | SetFrameTimeout | Copy frame timeout from UDP packet to this object
Public method | SetFwVer | Copy device ID from UDP packet to this object
Public method | SetGateway | Copy default gateway from UDP packet to this object
Public method | SetHardwareType | Copy hardware type from UDP packet to this object
Public method | SetHeaderReserved | Copy header reserve field from UDP packet to this object
Public method | SetHostIdle | Copy host idle enabled from UDP packet to this object
Public method | SetHostIdleTime | Copy host idle time from UDP packet to this object
Public method | SetInitSSID | Copy wireless initial SSID from UDP packet to this object
Public method | SetInitSSIDLength | Copy wireless initial SSID length from UDP packet to this object
Public method | SetIP | Copy IP from UDP packet to this object
Public method | SetMac | Copy MAC address from UDP packet to this object
Public method | SetModuleControlCmd | Set Module Control Command Parameter Value.
Public method | SetModuleStatus | Copy Module Status from UDP packet to this object
Public method | SetNetConfigProtocol | Copy default NetConfigProtocol from UDP packet to this object
Public method | SetParity | Copy parity from UDP packet to this object
Public method | SetPassword | Copy password from UDP packet to this object
Public method | SetPortNumber | Copy port number from UDP packet to this object
Public method | SetSSID | Copy wireless SSID from UDP packet to this object
Public method | SetSSIDLength | Copy wireless SSID length from UDP packet to this object
Public method | SetStopbits | Copy stopbits from UDP packet to this object
Public method | SetSubnet | Copy subnet mask from UDP packet to this object
Public method | SetWebHttp | Copy Web Http enabled from UDP packet to this object
Public method | SetWEP | Copy wireless WEP key from UDP packet to this object
Public method | SetWEPKey128 | Copy wireless 128 bits WEP key from UDP packet to this object
Public method | SetWEPKey64 | Copy wireless 64 bits WEP key 1 from UDP packet to this object
Public method | SetWEPKey64_2 | Copy wireless 64 bits WEP key 2 from UDP packet to this object
Public method | SetWEPKey64_3 | Copy wireless 64 bits WEP key 3 from UDP packet to this object
Public method | SetWEPKey64_4 | Copy wireless 64 bits WEP key 4 from UDP packet to this object
Public method | SetWEPKeyIndex | Copy wireless WEP key index from UDP packet to this object
Public method | SetWirelessChannel | Copy wireless channel from UDP packet to this object
Public method | SetWirelessMode | Copy wireless mode from UDP packet to this object
Public method | SetWirelessModeFlag | Copy wireless mode flag from UDP packet to this object
Public method | SetWirelessRegion | Copy wireless region from UDP packet to this object
Public method | SetWirelessRegionFlag | Copy wireless region flag from UDP packet to this object
Top

See Also

AdamInformation Class
Advantech.Adam Namespace


CopyTo Method

AdamInformation.CopyTo Method
[image]

Copy to another AdamInformation object.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByRef adamObj As AdamInformation _
)
C#
public void CopyTo(
ref AdamInformation adamObj
)
C++
public:
void CopyTo(
AdamInformation% adamObj
) sealed
J#
public void CopyTo(
AdamInformation adamObj
)
JScript
public function CopyTo(
adamObj : AdamInformation
)

Parameters

adamObj
The target AdamInformation object.

See Also

AdamInformation Class
Advantech.Adam Namespace


Equals Method

AdamInformation.Equals Method
[image]

Redefine Equals for AdamInformation type.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

See Also

AdamInformation Class
Advantech.Adam Namespace


GetHashCode Method

AdamInformation.GetHashCode Method
[image]

Override GetHashCode() for consistency and usability in dictionaries..

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

AdamInformation Class
Advantech.Adam Namespace


SetBasicRate Method

AdamInformation.SetBasicRate Method
[image]

Copy wireless basic rate from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetBasicRate( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetBasicRate(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetBasicRate(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetBasicRate(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetBasicRate(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetBaudrate Method

AdamInformation.SetBaudrate Method
[image]

Copy baudrate from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetBaudrate( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetBaudrate(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetBaudrate(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetBaudrate(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetBaudrate(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetClientIP Method

AdamInformation.SetClientIP Method
[image]

Copy IP from IPEndPoint to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetClientIP( _
ByVal i_byAddressBytes As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetClientIP(
byte[] i_byAddressBytes,
int i_iIndex
)
C++
public:
void SetClientIP(
array<char>^ i_byAddressBytes,
int i_iIndex
) sealed
J#
public void SetClientIP(
byte[] i_byAddressBytes,
int i_iIndex
)
JScript
public function SetClientIP(
i_byAddressBytes : Byte[],
i_iIndex : int
)

Parameters

i_byAddressBytes
The IP address bytes array.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetDatabits Method

AdamInformation.SetDatabits Method
[image]

Copy databits from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDatabits( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetDatabits(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetDatabits(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetDatabits(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetDatabits(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetDescription Method

AdamInformation.SetDescription Method
[image]

Copy device description from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDescription( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer, _
ByVal i_iLen As Integer _
)
C#
public void SetDescription(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
C++
public:
void SetDescription(
array<char>^ i_byBuffer,
int i_iIndex,
int i_iLen
) sealed
J#
public void SetDescription(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
JScript
public function SetDescription(
i_byBuffer : Byte[],
i_iIndex : int,
i_iLen : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.
i_iLen
The description length.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetDeviceID Method

AdamInformation.SetDeviceID Method
[image]

Copy device ID from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDeviceID( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetDeviceID(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetDeviceID(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetDeviceID(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetDeviceID(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetDeviceName Method

AdamInformation.SetDeviceName Method
[image]

Copy device name from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetDeviceName( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer, _
ByVal i_iLen As Integer _
)
C#
public void SetDeviceName(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
C++
public:
void SetDeviceName(
array<char>^ i_byBuffer,
int i_iIndex,
int i_iLen
) sealed
J#
public void SetDeviceName(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
JScript
public function SetDeviceName(
i_byBuffer : Byte[],
i_iIndex : int,
i_iLen : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.
i_iLen
The device name length.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetEthernetMode Method

AdamInformation.SetEthernetMode Method
[image]

Copy ethernet mode from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetEthernetMode( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetEthernetMode(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetEthernetMode(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetEthernetMode(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetEthernetMode(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetFlowControl Method

AdamInformation.SetFlowControl Method
[image]

Copy flow control from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetFlowControl( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetFlowControl(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetFlowControl(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetFlowControl(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetFlowControl(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetFrameTimeout Method

AdamInformation.SetFrameTimeout Method
[image]

Copy frame timeout from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetFrameTimeout( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetFrameTimeout(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetFrameTimeout(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetFrameTimeout(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetFrameTimeout(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetFwVer Method

AdamInformation.SetFwVer Method
[image]

Copy device ID from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetFwVer( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetFwVer(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetFwVer(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetFwVer(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetFwVer(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetGateway Method

AdamInformation.SetGateway Method
[image]

Copy default gateway from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetGateway( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetGateway(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetGateway(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetGateway(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetGateway(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetHardwareType Method

AdamInformation.SetHardwareType Method
[image]

Copy hardware type from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetHardwareType( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetHardwareType(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetHardwareType(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetHardwareType(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetHardwareType(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetHeaderReserved Method

AdamInformation.SetHeaderReserved Method
[image]

Copy header reserve field from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetHeaderReserved( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetHeaderReserved(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetHeaderReserved(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetHeaderReserved(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetHeaderReserved(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetHostIdle Method

AdamInformation.SetHostIdle Method
[image]

Copy host idle enabled from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetHostIdle( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetHostIdle(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetHostIdle(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetHostIdle(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetHostIdle(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetHostIdleTime Method

AdamInformation.SetHostIdleTime Method
[image]

Copy host idle time from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetHostIdleTime( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetHostIdleTime(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetHostIdleTime(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetHostIdleTime(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetHostIdleTime(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetInitSSID Method

AdamInformation.SetInitSSID Method
[image]

Copy wireless initial SSID from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetInitSSID( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer, _
ByVal i_iLen As Integer _
)
C#
public void SetInitSSID(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
C++
public:
void SetInitSSID(
array<char>^ i_byBuffer,
int i_iIndex,
int i_iLen
) sealed
J#
public void SetInitSSID(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
JScript
public function SetInitSSID(
i_byBuffer : Byte[],
i_iIndex : int,
i_iLen : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.
i_iLen
The SSID length.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetInitSSIDLength Method

AdamInformation.SetInitSSIDLength Method
[image]

Copy wireless initial SSID length from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetInitSSIDLength( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetInitSSIDLength(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetInitSSIDLength(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetInitSSIDLength(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetInitSSIDLength(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetIP Method

AdamInformation.SetIP Method
[image]

Copy IP from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetIP( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetIP(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetIP(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetIP(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetIP(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetMac Method

AdamInformation.SetMac Method
[image]

Copy MAC address from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetMac( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetMac(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetMac(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetMac(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetMac(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetModuleControlCmd Method

AdamInformation.SetModuleControlCmd Method
[image]

Set Module Control Command Parameter Value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetModuleControlCmd( _
ByVal i_byCmdData As Byte() _
)
C#
public void SetModuleControlCmd(
byte[] i_byCmdData
)
C++
public:
void SetModuleControlCmd(
array<char>^ i_byCmdData
) sealed
J#
public void SetModuleControlCmd(
byte[] i_byCmdData
)
JScript
public function SetModuleControlCmd(
i_byCmdData : Byte[]
)

Parameters

i_byCmdData
The command parameter data.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetModuleStatus Method

AdamInformation.SetModuleStatus Method
[image]

Copy Module Status from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetModuleStatus( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetModuleStatus(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetModuleStatus(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetModuleStatus(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetModuleStatus(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The status represented by byte size.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetNetConfigProtocol Method

AdamInformation.SetNetConfigProtocol Method
[image]

Copy default NetConfigProtocol from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetNetConfigProtocol( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetNetConfigProtocol(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetNetConfigProtocol(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetNetConfigProtocol(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetNetConfigProtocol(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetParity Method

AdamInformation.SetParity Method
[image]

Copy parity from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetParity( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetParity(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetParity(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetParity(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetParity(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetPassword Method

AdamInformation.SetPassword Method
[image]

Copy password from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetPassword( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetPassword(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetPassword(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetPassword(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetPassword(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetPortNumber Method

AdamInformation.SetPortNumber Method
[image]

Copy port number from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetPortNumber( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetPortNumber(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetPortNumber(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetPortNumber(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetPortNumber(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetSSID Method

AdamInformation.SetSSID Method
[image]

Copy wireless SSID from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSSID( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer, _
ByVal i_iLen As Integer _
)
C#
public void SetSSID(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
C++
public:
void SetSSID(
array<char>^ i_byBuffer,
int i_iIndex,
int i_iLen
) sealed
J#
public void SetSSID(
byte[] i_byBuffer,
int i_iIndex,
int i_iLen
)
JScript
public function SetSSID(
i_byBuffer : Byte[],
i_iIndex : int,
i_iLen : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.
i_iLen
The SSID length.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetSSIDLength Method

AdamInformation.SetSSIDLength Method
[image]

Copy wireless SSID length from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSSIDLength( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetSSIDLength(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetSSIDLength(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetSSIDLength(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetSSIDLength(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetStopbits Method

AdamInformation.SetStopbits Method
[image]

Copy stopbits from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetStopbits( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetStopbits(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetStopbits(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetStopbits(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetStopbits(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetSubnet Method

AdamInformation.SetSubnet Method
[image]

Copy subnet mask from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSubnet( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetSubnet(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetSubnet(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetSubnet(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetSubnet(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWebHttp Method

AdamInformation.SetWebHttp Method
[image]

Copy Web Http enabled from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWebHttp( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWebHttp(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWebHttp(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWebHttp(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWebHttp(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWEP Method

AdamInformation.SetWEP Method
[image]

Copy wireless WEP key from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWEP( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWEP(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWEP(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWEP(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWEP(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWEPKey128 Method

AdamInformation.SetWEPKey128 Method
[image]

Copy wireless 128 bits WEP key from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWEPKey128( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWEPKey128(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWEPKey128(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWEPKey128(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWEPKey128(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWEPKey64 Method

AdamInformation.SetWEPKey64 Method
[image]

Copy wireless 64 bits WEP key 1 from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWEPKey64( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWEPKey64(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWEPKey64(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWEPKey64(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWEPKey64(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWEPKey64_2 Method

AdamInformation.SetWEPKey64_2 Method
[image]

Copy wireless 64 bits WEP key 2 from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWEPKey64_2( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWEPKey64_2(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWEPKey64_2(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWEPKey64_2(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWEPKey64_2(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWEPKey64_3 Method

AdamInformation.SetWEPKey64_3 Method
[image]

Copy wireless 64 bits WEP key 3 from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWEPKey64_3( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWEPKey64_3(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWEPKey64_3(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWEPKey64_3(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWEPKey64_3(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWEPKey64_4 Method

AdamInformation.SetWEPKey64_4 Method
[image]

Copy wireless 64 bits WEP key 4 from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWEPKey64_4( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWEPKey64_4(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWEPKey64_4(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWEPKey64_4(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWEPKey64_4(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWEPKeyIndex Method

AdamInformation.SetWEPKeyIndex Method
[image]

Copy wireless WEP key index from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWEPKeyIndex( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWEPKeyIndex(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWEPKeyIndex(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWEPKeyIndex(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWEPKeyIndex(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWirelessChannel Method

AdamInformation.SetWirelessChannel Method
[image]

Copy wireless channel from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWirelessChannel( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWirelessChannel(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWirelessChannel(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWirelessChannel(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWirelessChannel(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWirelessMode Method

AdamInformation.SetWirelessMode Method
[image]

Copy wireless mode from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWirelessMode( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWirelessMode(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWirelessMode(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWirelessMode(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWirelessMode(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWirelessModeFlag Method

AdamInformation.SetWirelessModeFlag Method
[image]

Copy wireless mode flag from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWirelessModeFlag( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWirelessModeFlag(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWirelessModeFlag(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWirelessModeFlag(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWirelessModeFlag(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWirelessRegion Method

AdamInformation.SetWirelessRegion Method
[image]

Copy wireless region from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWirelessRegion( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWirelessRegion(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWirelessRegion(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWirelessRegion(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWirelessRegion(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


SetWirelessRegionFlag Method

AdamInformation.SetWirelessRegionFlag Method
[image]

Copy wireless region flag from UDP packet to this object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWirelessRegionFlag( _
ByVal i_byBuffer As Byte(), _
ByVal i_iIndex As Integer _
)
C#
public void SetWirelessRegionFlag(
byte[] i_byBuffer,
int i_iIndex
)
C++
public:
void SetWirelessRegionFlag(
array<char>^ i_byBuffer,
int i_iIndex
) sealed
J#
public void SetWirelessRegionFlag(
byte[] i_byBuffer,
int i_iIndex
)
JScript
public function SetWirelessRegionFlag(
i_byBuffer : Byte[],
i_iIndex : int
)

Parameters

i_byBuffer
The UDP packet buffer.
i_iIndex
The byte index.

See Also

AdamInformation Class
Advantech.Adam Namespace


AdamInfoType Enumeration

AdamInfoType Enumeration
[image]

The type for getting Adam information by UDP broadcast

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum AdamInfoType
C#
public enum AdamInfoType
C++
public enum class AdamInfoType
J#
public enum AdamInfoType
JScript
public enum AdamInfoType

Members

Member Name | Description
AdamDeviceInfo | Get device information.
AdamNetConfig | Get network configuration.
AdamPortConfig | Get ADAM-5000 port setting.
AdamDeviceConfig | Get device configuration.
AdamWirelessConfig | Get wireless configuration.
AdamReset | Reset ADAM command.
ApaxDeviceInfo | Get Apax device information.
ApaxNetConfig | Get Apax network configuration.
AdvantechDevice | Get eAutomation device information.

See Also

Advantech.Adam Namespace


AdamMacComparer Class

AdamMacComparer Class
See Also Example Members
[image]

The class is used for comparing the MAC address for ADAM.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamMacComparer
Implements IComparer
C#
public class AdamMacComparer : IComparer
C++
ref class AdamMacComparer : IComparer
J#
public class AdamMacComparer implements IComparer
JScript
public class AdamMacComparer extends IComparer

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamMacComparer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamMacComparer Members
Advantech.Adam Namespace


AdamMacComparer Members

AdamMacComparer Members
See Also Example Constructors
[image]

The class is used for comparing the MAC address for ADAM.

The following tables list the members exposed by AdamMacComparer.

Public Constructors

 | Name | Description
Public method | AdamMacComparer | Initializes a new instance of the AdamMacComparer class.
Top

See Also

AdamMacComparer Class
Advantech.Adam Namespace


AdamMacComparer Constructor

AdamMacComparer Constructor
[image]

Initializes a new instance of the AdamMacComparer class.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamMacComparer()
C++
public:
AdamMacComparer() sealed
J#
public AdamMacComparer()
JScript
public function AdamMacComparer()

See Also

AdamMacComparer Class
Advantech.Adam Namespace


AdamP2P Class

AdamP2P Class
See Also Example Members
[image]

Adam P2P class

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamP2P
C#
public class AdamP2P
C++
ref class AdamP2P
J#
public class AdamP2P
JScript
public class AdamP2P

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamP2P

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamP2P Members
Advantech.Adam Namespace


AdamP2P Members

AdamP2P Members
See Also Example Fields Properties Methods Events Explicit Inteface Implementations
[image]

Adam P2P class

The following tables list the members exposed by AdamP2P.

Public Constructors

Name | Description
AdamP2P | Overloaded. Initializes a new instance of the AdamP2P class.
Top

Public Fields

Name | Description
P2P_Port | Peer to peer UDP server
Top

Public Properties

 | Name | Description
Public property | P2P_Data | Receive P2P data
Public property | P2P_PackageNum | Package number
Top

Public Methods

 | Name | Description
Public method | GetLastP2PInfo | Get P2P configuration information
Public method | Start_P2P_Server | Overloaded. Start P2P UDP server
Public method | Stop_P2P_Server | Stop P2P UDP server
Top

Public Events

 | Name | Description
Public event | GetDataEvent | Raised when a subscrition is changed.
Top

Explicit Interface Implementations

Name | Description
AdamP2P | Overloaded. Initializes a new instance of the AdamP2P class.
Top

See Also

AdamP2P Class
Advantech.Adam Namespace


AdamP2P Constructor

AdamP2P Constructor

Initializes a new instance of the AdamP2P class.

Overload List

 | Name | Description
Public method | AdamP2P | Constructer
Public method | AdamP2P (Int32, Int32) | Constructer

See Also

AdamP2P Class
Advantech.Adam Namespace


AdamP2P Constructor ()

AdamP2P Constructor ()
See Also Example
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamP2P()
C++
public:
AdamP2P() sealed
J#
public AdamP2P()
JScript
public function AdamP2P()

See Also

AdamP2P Class
Advantech.Adam Namespace
AdamP2P Constructor Overload List


AdamP2P Constructor (Int32, Int32)

AdamP2P Constructor (Int32, Int32)
See Also Example
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal iUDPSendTimeout As Integer, _
ByVal iUDPRecvTimeout As Integer _
)
C#
public AdamP2P(
int iUDPSendTimeout,
int iUDPRecvTimeout
)
C++
public:
AdamP2P(
int iUDPSendTimeout,
int iUDPRecvTimeout
) sealed
J#
public AdamP2P(
int iUDPSendTimeout,
int iUDPRecvTimeout
)
JScript
public function AdamP2P(
iUDPSendTimeout : int,
iUDPRecvTimeout : int
)

Parameters

iUDPSendTimeout
UDPSendTimeout
iUDPRecvTimeout
UDPRecvTimeout

See Also

AdamP2P Class
Advantech.Adam Namespace
AdamP2P Constructor Overload List


Fields

AdamP2P Fields
[image]

Public Fields

Name | Description
P2P_Port | Peer to peer UDP server
Top

See Also

AdamP2P Class
Advantech.Adam Namespace


P2P_Port Field

AdamP2P.P2P_Port Field
[image]

Peer to peer UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared P2P_Port As Integer
C#
public static int P2P_Port;
C++
public:
static int P2P_Port;
J#
public static int P2P_Port
JScript
public static P2P_Port : int;

See Also

AdamP2P Class
Advantech.Adam Namespace


Properties

AdamP2P Properties
[image]

Public Properties

 | Name | Description
Public property | P2P_Data | Receive P2P data
Public property | P2P_PackageNum | Package number
Top

See Also

AdamP2P Class
Advantech.Adam Namespace


P2P_Data Property

AdamP2P.P2P_Data Property
[image]

Receive P2P data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property P2P_Data As Byte()
C#
public byte[] P2P_Data { get; }
C++
public property byte[] P2P_Data sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_P2P_Data();
JScript
public function get P2P_Data() : Byte[]

See Also

AdamP2P Class
Advantech.Adam Namespace


P2P_PackageNum Property

AdamP2P.P2P_PackageNum Property
[image]

Package number

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property P2P_PackageNum As Integer
C#
public int P2P_PackageNum { get; }
C++
public property int P2P_PackageNum sealed {
int get();
}
J#
/** property */
public int get_P2P_PackageNum();
JScript
public function get P2P_PackageNum() : int

See Also

AdamP2P Class
Advantech.Adam Namespace


Methods

AdamP2P Methods
[image]

Public Methods

 | Name | Description
Public method | GetLastP2PInfo | Get P2P configuration information
Public method | Start_P2P_Server | Overloaded. Start P2P UDP server
Public method | Stop_P2P_Server | Stop P2P UDP server
Top

See Also

AdamP2P Class
Advantech.Adam Namespace


GetLastP2PInfo Method

AdamP2P.GetLastP2PInfo Method
[image]

Get P2P configuration information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLastP2PInfo( _
<OutAttribute> ByRef p2p_Config As P2P_Config, _
ByRef remoteEP As EndPoint _
) As Boolean
C#
public bool GetLastP2PInfo(
out P2P_Config p2p_Config,
ref EndPoint remoteEP
)
C++
public:
bool GetLastP2PInfo(
[OutAttribute] P2P_Config% p2p_Config,
EndPoint% remoteEP
) sealed
J#
public bool GetLastP2PInfo(
/** @attribute OutAttribute() */ /** @ref */ P2P_Config p2p_Config,
EndPoint remoteEP
)
JScript
public function GetLastP2PInfo(
OutAttribute p2p_Config : P2P_Config,
remoteEP : EndPoint
) : bool

Parameters

p2p_Config
remoteEP

See Also

AdamP2P Class
Advantech.Adam Namespace


Start_P2P_Server Method

AdamP2P.Start_P2P_Server Method

Start P2P UDP server

Overload List

 | Name | Description
Public method | Start_P2P_Server | Start P2P UDP server
Public method | Start_P2P_Server (Int32) | Start P2P UDP server

See Also

AdamP2P Class
Advantech.Adam Namespace


Start_P2P_Server Method ()

AdamP2P.Start_P2P_Server Method ()
See Also Example
[image]

Start P2P UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Start_P2P_Server() As Boolean
C#
public bool Start_P2P_Server()
C++
public:
bool Start_P2P_Server() sealed
J#
public bool Start_P2P_Server()
JScript
public function Start_P2P_Server() : bool

See Also

AdamP2P Class
Advantech.Adam Namespace
AdamP2P.Start_P2P_Server Overload List


Start_P2P_Server Method (Int32)

AdamP2P.Start_P2P_Server Method (Int32)
See Also Example
[image]

Start P2P UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Start_P2P_Server( _
ByVal iPort As Integer _
) As Boolean
C#
public bool Start_P2P_Server(
int iPort
)
C++
public:
bool Start_P2P_Server(
int iPort
) sealed
J#
public bool Start_P2P_Server(
int iPort
)
JScript
public function Start_P2P_Server(
iPort : int
) : bool

Parameters

iPort
P2P listen port.(Default:1025)

See Also

AdamP2P Class
Advantech.Adam Namespace
AdamP2P.Start_P2P_Server Overload List


Stop_P2P_Server Method

AdamP2P.Stop_P2P_Server Method
[image]

Stop P2P UDP server

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Stop_P2P_Server() As Boolean
C#
public bool Stop_P2P_Server()
C++
public:
bool Stop_P2P_Server() sealed
J#
public bool Stop_P2P_Server()
JScript
public function Stop_P2P_Server() : bool

See Also

AdamP2P Class
Advantech.Adam Namespace


Events

AdamP2P Events
[image]

Public Events

 | Name | Description
Public event | GetDataEvent | Raised when a subscrition is changed.
Top

See Also

AdamP2P Class
Advantech.Adam Namespace


GetDataEvent Event

AdamP2P.GetDataEvent Event
[image]

Raised when a subscrition is changed.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Event GetDataEvent As GetP2PDataCallback
C#
public event GetP2PDataCallback GetDataEvent
C++
public:
virtual event GetP2PDataCallback GetDataEvent {
void add(GetP2PDataCallback value) sealed ;
void remove(GetP2PDataCallback value) sealed ;
}
J#
/** event */
public final void add_GetDataEvent(GetP2PDataCallback value);

/** event */
public final void remove_GetDataEvent(GetP2PDataCallback value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

AdamP2P Class
Advantech.Adam Namespace


AdamSocket Class

AdamSocket Class
See Also Example Members
[image]

ADAM ethernet communication class library for ADAM series.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamSocket
C#
public class AdamSocket
C++
ref class AdamSocket
J#
public class AdamSocket
JScript
public class AdamSocket

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamSocket

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamSocket Members
Advantech.Adam Namespace


AdamSocket Members

AdamSocket Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

ADAM ethernet communication class library for ADAM series.

The following tables list the members exposed by AdamSocket.

Public Constructors

Name | Description
AdamSocket | Overloaded. Initializes a new instance of the AdamSocket class.
Top

Public Properties

 | Name | Description
 | Adam5000Found | The flag indicates the ADAM-5000 was found or not.
Public property | AdamSeriesType | The Adam series type
Public property | Connected | Get the socket connected status.
Public property | LastError | The last error code when function return false.
 | WirelessFound | The flag indicates the ADAM-6000W was found or not.
Top

Public Methods

 | Name | Description
Public method | AdamTransaction | Send data to and received data from an ADAM module
Public method | Alarm | Overloaded. ADAM-5000TCP ADAM-6000 Alarm object
Public method | AnalogInput | Overloaded. ADAM-5000TCP ADAM-6000 AnalogInput object
Public method | AnalogOutput | Overloaded. ADAM-5000TCP ADAM-6000 AnalogOutput object
Public method | Configuration | Overloaded. ADAM-5000TCP ADAM-6000 Configuration object
Public method | Connect | Overloaded. Connect to an ADAM module
Public method | Counter | Overloaded. ADAM-5000TCP ADAM-6000 Counter object
Public method | DigitalInput | Overloaded. ADAM-5000TCP ADAM-6000 DigitalInput object
Public method | DigitalOutput | Overloaded. ADAM-5000TCP ADAM-6000 DigitalOutput object
Public method | Disconnect | Disconnect the socket
 | GetAdamDeviceList | Overloaded. Get the ADAM device list by using UDP broadcast.
 | GetAdvantechDeviceList | Get the Advantech device list by using UDP broadcast.
Public method | GetDSPFWVer | Get DSP version from APAX coupler. Support: APAX-5070
Public method | GetIP | Get the IP string
 | GetLocalNetwork | Get the local network card IP
Public method | GetModuleName | Get module name. Support: APAX-5070, APAX-5072
Public method | GetProtocolType | Get the socket protocol type
Public method | Modbus | Overloaded. ADAM-5000TCP ADAM-6000 Modbus object
Public method | Pid | Overloaded. ADAM-6000 PID object
Public method | Receive | Receive data from connected module. This function will receive as many data as the length of i_byData within receiving timeout. The actually received data length will be returned in the o_iLen.
Public method | RefreshIOInfo | Refresh IO module informations. Support: APAX-5070
Public method | Send | Send data to the connected module
 | SendModuleControlCmd | Overloaded. Send the module control command by using UDP broadcast.
 | SetAdamInformation | Overloaded. Set the ADAM device information by using UDP broadcast. Add APAX-5070 support.
Public method | SetSocketOpt | Set socket option
Public method | SetTimeout | Set the timeout constances for socket
Public method | SYS_CheckReady | Overloaded. Check if APAX coupler is ready or not. Support: APAX-5070
Top

Protected Methods

 | Name | Description
Family method | AdamTCPTransaction |
Family method | AdamUDPTransaction |
 | GetAdamInformation | Overloaded. protected static bool GetAdamInformation(AdamInfoType i_infoType, string i_szIP, int i_iTimeout, ref ArrayList adamList)
Top

Explicit Interface Implementations

Name | Description
AdamSocket | Overloaded. Initializes a new instance of the AdamSocket class.
Top

See Also

AdamSocket Class
Advantech.Adam Namespace


AdamSocket Constructor

AdamSocket Constructor

Initializes a new instance of the AdamSocket class.

Overload List

 | Name | Description
Public method | AdamSocket | The AdamSocket constructor
Public method | AdamSocket (AdamType) | The AdamSocket constructor

See Also

AdamSocket Class
Advantech.Adam Namespace


AdamSocket Constructor ()

AdamSocket Constructor ()
See Also Example
[image]

The AdamSocket constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamSocket()
C++
public:
AdamSocket() sealed
J#
public AdamSocket()
JScript
public function AdamSocket()

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket Constructor Overload List


AdamSocket Constructor (AdamType)

AdamSocket Constructor (AdamType)
See Also Example
[image]

The AdamSocket constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adamType As AdamType _
)
C#
public AdamSocket(
AdamType adamType
)
C++
public:
AdamSocket(
AdamType adamType
) sealed
J#
public AdamSocket(
AdamType adamType
)
JScript
public function AdamSocket(
adamType : AdamType
)

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket Constructor Overload List


Properties

AdamSocket Properties
[image]

Public Properties

 | Name | Description
 | Adam5000Found | The flag indicates the ADAM-5000 was found or not.
Public property | AdamSeriesType | The Adam series type
Public property | Connected | Get the socket connected status.
Public property | LastError | The last error code when function return false.
 | WirelessFound | The flag indicates the ADAM-6000W was found or not.
Top

See Also

AdamSocket Class
Advantech.Adam Namespace


Adam5000Found Property

AdamSocket.Adam5000Found Property
[image]

The flag indicates the ADAM-5000 was found or not.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Adam5000Found As Boolean
C#
public static bool Adam5000Found { get; }
C++
public static property bool Adam5000Found {
bool get();
}
J#
/** property */
public bool get_Adam5000Found();
JScript
public function get Adam5000Found() : bool

See Also

AdamSocket Class
Advantech.Adam Namespace


AdamSeriesType Property

AdamSocket.AdamSeriesType Property
[image]

The Adam series type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property AdamSeriesType As AdamType
C#
public AdamType AdamSeriesType { get; set; }
C++
public property AdamType AdamSeriesType sealed {
AdamType get();
void set(AdamType value);
}
J#
/** property */
public AdamType get_AdamSeriesType();

/** property */
public void set_AdamSeriesType(AdamType value);
JScript
public function get AdamSeriesType() : AdamType

public function set AdamSeriesType(value : AdamType);

See Also

AdamSocket Class
Advantech.Adam Namespace


Connected Property

AdamSocket.Connected Property
[image]

Get the socket connected status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Connected As Boolean
C#
public bool Connected { get; }
C++
public property bool Connected sealed {
bool get();
}
J#
/** property */
public bool get_Connected();
JScript
public function get Connected() : bool

See Also

AdamSocket Class
Advantech.Adam Namespace


LastError Property

AdamSocket.LastError Property
[image]

The last error code when function return false.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastError As ErrorCode
C#
public ErrorCode LastError { get; }
C++
public property ErrorCode LastError sealed {
ErrorCode get();
}
J#
/** property */
public ErrorCode get_LastError();
JScript
public function get LastError() : ErrorCode

See Also

AdamSocket Class
Advantech.Adam Namespace


WirelessFound Property

AdamSocket.WirelessFound Property
[image]

The flag indicates the ADAM-6000W was found or not.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WirelessFound As Boolean
C#
public static bool WirelessFound { get; }
C++
public static property bool WirelessFound {
bool get();
}
J#
/** property */
public bool get_WirelessFound();
JScript
public function get WirelessFound() : bool

See Also

AdamSocket Class
Advantech.Adam Namespace


Methods

AdamSocket Methods
[image]

Public Methods

 | Name | Description
Public method | AdamTransaction | Send data to and received data from an ADAM module
Public method | Alarm | Overloaded. ADAM-5000TCP ADAM-6000 Alarm object
Public method | AnalogInput | Overloaded. ADAM-5000TCP ADAM-6000 AnalogInput object
Public method | AnalogOutput | Overloaded. ADAM-5000TCP ADAM-6000 AnalogOutput object
Public method | Configuration | Overloaded. ADAM-5000TCP ADAM-6000 Configuration object
Public method | Connect | Overloaded. Connect to an ADAM module
Public method | Counter | Overloaded. ADAM-5000TCP ADAM-6000 Counter object
Public method | DigitalInput | Overloaded. ADAM-5000TCP ADAM-6000 DigitalInput object
Public method | DigitalOutput | Overloaded. ADAM-5000TCP ADAM-6000 DigitalOutput object
Public method | Disconnect | Disconnect the socket
 | GetAdamDeviceList | Overloaded. Get the ADAM device list by using UDP broadcast.
 | GetAdvantechDeviceList | Get the Advantech device list by using UDP broadcast.
Public method | GetDSPFWVer | Get DSP version from APAX coupler. Support: APAX-5070
Public method | GetIP | Get the IP string
 | GetLocalNetwork | Get the local network card IP
Public method | GetModuleName | Get module name. Support: APAX-5070, APAX-5072
Public method | GetProtocolType | Get the socket protocol type
Public method | Modbus | Overloaded. ADAM-5000TCP ADAM-6000 Modbus object
Public method | Pid | Overloaded. ADAM-6000 PID object
Public method | Receive | Receive data from connected module. This function will receive as many data as the length of i_byData within receiving timeout. The actually received data length will be returned in the o_iLen.
Public method | RefreshIOInfo | Refresh IO module informations. Support: APAX-5070
Public method | Send | Send data to the connected module
 | SendModuleControlCmd | Overloaded. Send the module control command by using UDP broadcast.
 | SetAdamInformation | Overloaded. Set the ADAM device information by using UDP broadcast. Add APAX-5070 support.
Public method | SetSocketOpt | Set socket option
Public method | SetTimeout | Set the timeout constances for socket
Public method | SYS_CheckReady | Overloaded. Check if APAX coupler is ready or not. Support: APAX-5070
Top

Protected Methods

 | Name | Description
Family method | AdamTCPTransaction |
Family method | AdamUDPTransaction |
 | GetAdamInformation | Overloaded. protected static bool GetAdamInformation(AdamInfoType i_infoType, string i_szIP, int i_iTimeout, ref ArrayList adamList)
Top

See Also

AdamSocket Class
Advantech.Adam Namespace


AdamTCPTransaction Method

AdamSocket.AdamTCPTransaction Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function AdamTCPTransaction( _
ByVal i_szSend As String, _
<OutAttribute> ByRef o_szRecv As String _
) As Boolean
C#
protected bool AdamTCPTransaction(
string i_szSend,
out string o_szRecv
)
C++
protected:
bool AdamTCPTransaction(
String i_szSend,
[OutAttribute] String% o_szRecv
) sealed
J#
protected bool AdamTCPTransaction(
string i_szSend,
/** @attribute OutAttribute() */ /** @ref */ string o_szRecv
)
JScript
protected function AdamTCPTransaction(
i_szSend : String,
OutAttribute o_szRecv : String
) : bool

Parameters

i_szSend
o_szRecv

See Also

AdamSocket Class
Advantech.Adam Namespace


AdamTransaction Method

AdamSocket.AdamTransaction Method
[image]

Send data to and received data from an ADAM module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AdamTransaction( _
ByVal i_szSend As String, _
<OutAttribute> ByRef o_szRecv As String _
) As Boolean
C#
public bool AdamTransaction(
string i_szSend,
out string o_szRecv
)
C++
public:
bool AdamTransaction(
String i_szSend,
[OutAttribute] String% o_szRecv
) sealed
J#
public bool AdamTransaction(
string i_szSend,
/** @attribute OutAttribute() */ /** @ref */ string o_szRecv
)
JScript
public function AdamTransaction(
i_szSend : String,
OutAttribute o_szRecv : String
) : bool

Parameters

i_szSend
The ASCII command to send.
o_szRecv
The ASCII response from ADAM module.

Return Value

True, if successed, otherwise false.

See Also

AdamSocket Class
Advantech.Adam Namespace


AdamUDPTransaction Method

AdamSocket.AdamUDPTransaction Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function AdamUDPTransaction( _
ByVal i_szSend As String, _
<OutAttribute> ByRef o_szRecv As String _
) As Boolean
C#
protected bool AdamUDPTransaction(
string i_szSend,
out string o_szRecv
)
C++
protected:
bool AdamUDPTransaction(
String i_szSend,
[OutAttribute] String% o_szRecv
) sealed
J#
protected bool AdamUDPTransaction(
string i_szSend,
/** @attribute OutAttribute() */ /** @ref */ string o_szRecv
)
JScript
protected function AdamUDPTransaction(
i_szSend : String,
OutAttribute o_szRecv : String
) : bool

Parameters

i_szSend
o_szRecv

See Also

AdamSocket Class
Advantech.Adam Namespace


Alarm Method

AdamSocket.Alarm Method

ADAM-5000TCP ADAM-6000 Alarm object

Overload List

 | Name | Description
Public method | Alarm | ADAM-5000TCP ADAM-6000 Alarm object
Public method | Alarm (Int32) | ADAM-5000TCP ADAM-6000 Alarm object

See Also

AdamSocket Class
Advantech.Adam Namespace


Alarm Method ()

AdamSocket.Alarm Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Alarm object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Alarm() As Alarm
C#
public Alarm Alarm()
C++
public:
Alarm Alarm() sealed
J#
public Alarm Alarm()
JScript
public function Alarm() : Alarm

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Alarm Overload List


Alarm Method (Int32)

AdamSocket.Alarm Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Alarm object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Alarm( _
ByVal i_iAddr As Integer _
) As Alarm
C#
public Alarm Alarm(
int i_iAddr
)
C++
public:
Alarm Alarm(
int i_iAddr
) sealed
J#
public Alarm Alarm(
int i_iAddr
)
JScript
public function Alarm(
i_iAddr : int
) : Alarm

Parameters

i_iAddr
The module address which is ranged from 0 to 255

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Alarm Overload List


AnalogInput Method

AdamSocket.AnalogInput Method

ADAM-5000TCP ADAM-6000 AnalogInput object

Overload List

 | Name | Description
Public method | AnalogInput | ADAM-5000TCP ADAM-6000 AnalogInput object
Public method | AnalogInput (Int32) | ADAM-5000TCP ADAM-6000 AnalogInput object

See Also

AdamSocket Class
Advantech.Adam Namespace


AnalogInput Method ()

AdamSocket.AnalogInput Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 AnalogInput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogInput() As AnalogInput
C#
public AnalogInput AnalogInput()
C++
public:
AnalogInput AnalogInput() sealed
J#
public AnalogInput AnalogInput()
JScript
public function AnalogInput() : AnalogInput

Return Value

The AnalogInput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.AnalogInput Overload List


AnalogInput Method (Int32)

AdamSocket.AnalogInput Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 AnalogInput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogInput( _
ByVal i_iAddr As Integer _
) As AnalogInput
C#
public AnalogInput AnalogInput(
int i_iAddr
)
C++
public:
AnalogInput AnalogInput(
int i_iAddr
) sealed
J#
public AnalogInput AnalogInput(
int i_iAddr
)
JScript
public function AnalogInput(
i_iAddr : int
) : AnalogInput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The AnalogInput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.AnalogInput Overload List


AnalogOutput Method

AdamSocket.AnalogOutput Method

ADAM-5000TCP ADAM-6000 AnalogOutput object

Overload List

 | Name | Description
Public method | AnalogOutput | ADAM-5000TCP ADAM-6000 AnalogOutput object
Public method | AnalogOutput (Int32) | ADAM-5000TCP ADAM-6000 AnalogOutput object

See Also

AdamSocket Class
Advantech.Adam Namespace


AnalogOutput Method ()

AdamSocket.AnalogOutput Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 AnalogOutput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogOutput() As AnalogOutput
C#
public AnalogOutput AnalogOutput()
C++
public:
AnalogOutput AnalogOutput() sealed
J#
public AnalogOutput AnalogOutput()
JScript
public function AnalogOutput() : AnalogOutput

Return Value

The AnalogOutput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.AnalogOutput Overload List


AnalogOutput Method (Int32)

AdamSocket.AnalogOutput Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 AnalogOutput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogOutput( _
ByVal i_iAddr As Integer _
) As AnalogOutput
C#
public AnalogOutput AnalogOutput(
int i_iAddr
)
C++
public:
AnalogOutput AnalogOutput(
int i_iAddr
) sealed
J#
public AnalogOutput AnalogOutput(
int i_iAddr
)
JScript
public function AnalogOutput(
i_iAddr : int
) : AnalogOutput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The AnalogOutput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.AnalogOutput Overload List


Configuration Method

AdamSocket.Configuration Method

ADAM-5000TCP ADAM-6000 Configuration object

Overload List

 | Name | Description
Public method | Configuration | ADAM-5000TCP ADAM-6000 Configuration object
Public method | Configuration (Int32) | ADAM-5000TCP ADAM-6000 Configuration object

See Also

AdamSocket Class
Advantech.Adam Namespace


Configuration Method ()

AdamSocket.Configuration Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Configuration object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Configuration() As Configuration
C#
public Configuration Configuration()
C++
public:
Configuration Configuration() sealed
J#
public Configuration Configuration()
JScript
public function Configuration() : Configuration

Return Value

The Configuration object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Configuration Overload List


Configuration Method (Int32)

AdamSocket.Configuration Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Configuration object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Configuration( _
ByVal i_iAddr As Integer _
) As Configuration
C#
public Configuration Configuration(
int i_iAddr
)
C++
public:
Configuration Configuration(
int i_iAddr
) sealed
J#
public Configuration Configuration(
int i_iAddr
)
JScript
public function Configuration(
i_iAddr : int
) : Configuration

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The Configuration object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Configuration Overload List


Connect Method

AdamSocket.Connect Method

Connect to an ADAM module

Overload List

 | Name | Description
Public method | Connect (AdamType, String, ProtocolType) | Connect to an ADAM module
Public method | Connect (String, ProtocolType, Int32) | Connect to a TCP/UDP module

See Also

AdamSocket Class
Advantech.Adam Namespace


Connect Method (AdamType, String, ProtocolType)

AdamSocket.Connect Method (AdamType, String, ProtocolType)
See Also Example
[image]

Connect to an ADAM module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Connect( _
ByVal i_type As AdamType, _
ByVal i_szIPAddr As String, _
ByVal protocolType As ProtocolType _
) As Boolean
C#
public bool Connect(
AdamType i_type,
string i_szIPAddr,
ProtocolType protocolType
)
C++
public:
bool Connect(
AdamType i_type,
String i_szIPAddr,
ProtocolType protocolType
) sealed
J#
public bool Connect(
AdamType i_type,
string i_szIPAddr,
ProtocolType protocolType
)
JScript
public function Connect(
i_type : AdamType,
i_szIPAddr : String,
protocolType : ProtocolType
) : bool

Parameters

i_type
Adam module type.
i_szIPAddr
The IP address.
protocolType
The protocol type.

Return Value

True, if successed, otherwise false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Connect Overload List


Connect Method (String, ProtocolType, Int32)

AdamSocket.Connect Method (String, ProtocolType, Int32)
See Also Example
[image]

Connect to a TCP/UDP module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Connect( _
ByVal i_szIPAddr As String, _
ByVal protocolType As ProtocolType, _
ByVal i_iPort As Integer _
) As Boolean
C#
public bool Connect(
string i_szIPAddr,
ProtocolType protocolType,
int i_iPort
)
C++
public:
bool Connect(
String i_szIPAddr,
ProtocolType protocolType,
int i_iPort
) sealed
J#
public bool Connect(
string i_szIPAddr,
ProtocolType protocolType,
int i_iPort
)
JScript
public function Connect(
i_szIPAddr : String,
protocolType : ProtocolType,
i_iPort : int
) : bool

Parameters

i_szIPAddr
The IP address.
protocolType
The protocol type.
i_iPort
The port number.

Return Value

True, if successed, otherwise false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Connect Overload List


Counter Method

AdamSocket.Counter Method

ADAM-5000TCP ADAM-6000 Counter object

Overload List

 | Name | Description
Public method | Counter | ADAM-5000TCP ADAM-6000 Counter object
Public method | Counter (Int32) | ADAM-5000TCP ADAM-6000 Counter object

See Also

AdamSocket Class
Advantech.Adam Namespace


Counter Method ()

AdamSocket.Counter Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Counter object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Counter() As Counter
C#
public Counter Counter()
C++
public:
Counter Counter() sealed
J#
public Counter Counter()
JScript
public function Counter() : Counter

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Counter Overload List


Counter Method (Int32)

AdamSocket.Counter Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Counter object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Counter( _
ByVal i_iAddr As Integer _
) As Counter
C#
public Counter Counter(
int i_iAddr
)
C++
public:
Counter Counter(
int i_iAddr
) sealed
J#
public Counter Counter(
int i_iAddr
)
JScript
public function Counter(
i_iAddr : int
) : Counter

Parameters

i_iAddr
The module address which is ranged from 0 to 255

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Counter Overload List


DigitalInput Method

AdamSocket.DigitalInput Method

ADAM-5000TCP ADAM-6000 DigitalInput object

Overload List

 | Name | Description
Public method | DigitalInput | ADAM-5000TCP ADAM-6000 DigitalInput object
Public method | DigitalInput (Int32) | ADAM-5000TCP ADAM-6000 DigitalInput object

See Also

AdamSocket Class
Advantech.Adam Namespace


DigitalInput Method ()

AdamSocket.DigitalInput Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 DigitalInput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalInput() As DigitalInput
C#
public DigitalInput DigitalInput()
C++
public:
DigitalInput DigitalInput() sealed
J#
public DigitalInput DigitalInput()
JScript
public function DigitalInput() : DigitalInput

Return Value

The DigitalInput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.DigitalInput Overload List


DigitalInput Method (Int32)

AdamSocket.DigitalInput Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 DigitalInput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalInput( _
ByVal i_iAddr As Integer _
) As DigitalInput
C#
public DigitalInput DigitalInput(
int i_iAddr
)
C++
public:
DigitalInput DigitalInput(
int i_iAddr
) sealed
J#
public DigitalInput DigitalInput(
int i_iAddr
)
JScript
public function DigitalInput(
i_iAddr : int
) : DigitalInput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The DigitalInput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.DigitalInput Overload List


DigitalOutput Method

AdamSocket.DigitalOutput Method

ADAM-5000TCP ADAM-6000 DigitalOutput object

Overload List

 | Name | Description
Public method | DigitalOutput | ADAM-5000TCP ADAM-6000 DigitalOutput object
Public method | DigitalOutput (Int32) | ADAM-5000TCP ADAM-6000 DigitalOutput object

See Also

AdamSocket Class
Advantech.Adam Namespace


DigitalOutput Method ()

AdamSocket.DigitalOutput Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 DigitalOutput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalOutput() As DigitalOutput
C#
public DigitalOutput DigitalOutput()
C++
public:
DigitalOutput DigitalOutput() sealed
J#
public DigitalOutput DigitalOutput()
JScript
public function DigitalOutput() : DigitalOutput

Return Value

The DigitalOutput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.DigitalOutput Overload List


DigitalOutput Method (Int32)

AdamSocket.DigitalOutput Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 DigitalOutput object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalOutput( _
ByVal i_iAddr As Integer _
) As DigitalOutput
C#
public DigitalOutput DigitalOutput(
int i_iAddr
)
C++
public:
DigitalOutput DigitalOutput(
int i_iAddr
) sealed
J#
public DigitalOutput DigitalOutput(
int i_iAddr
)
JScript
public function DigitalOutput(
i_iAddr : int
) : DigitalOutput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The DigitalOutput object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.DigitalOutput Overload List


Disconnect Method

AdamSocket.Disconnect Method
[image]

Disconnect the socket

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub Disconnect()
C#
public void Disconnect()
C++
public:
void Disconnect() sealed
J#
public void Disconnect()
JScript
public function Disconnect()

See Also

AdamSocket Class
Advantech.Adam Namespace


GetAdamDeviceList Method

AdamSocket.GetAdamDeviceList Method

Get the ADAM device list by using UDP broadcast.

Overload List

Name | Description
GetAdamDeviceList (Int32, ArrayList) | Get the ADAM device list by using UDP broadcast.
GetAdamDeviceList (Int32, String, ArrayList) | Get the ADAM device list by using UDP broadcast.
GetAdamDeviceList (String, Int32, ArrayList) | Get the ADAM device list by using indicated IP address.
GetAdamDeviceList (String, Int32, String, ArrayList) | Get the ADAM device list by using indicated IP address.

See Also

AdamSocket Class
Advantech.Adam Namespace


GetAdamDeviceList Method (Int32, ArrayList)

AdamSocket.GetAdamDeviceList Method (Int32, ArrayList)
See Also Example
[image]

Get the ADAM device list by using UDP broadcast.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdamDeviceList( _
ByVal i_iTimeout As Integer, _
<OutAttribute> ByRef o_lstAdam As ArrayList _
) As Boolean
C#
public static bool GetAdamDeviceList(
int i_iTimeout,
out ArrayList o_lstAdam
)
C++
public:
static bool GetAdamDeviceList(
int i_iTimeout,
[OutAttribute] ArrayList% o_lstAdam
)
J#
public static bool GetAdamDeviceList(
int i_iTimeout,
/** @attribute OutAttribute() */ /** @ref */ ArrayList o_lstAdam
)
JScript
public static function GetAdamDeviceList(
i_iTimeout : int,
OutAttribute o_lstAdam : ArrayList
) : bool

Parameters

i_iTimeout
The timeout for each information type.
o_lstAdam
The array list which holds the ADAM information.

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.GetAdamDeviceList Overload List


GetAdamDeviceList Method (Int32, String, ArrayList)

AdamSocket.GetAdamDeviceList Method (Int32, String, ArrayList)
See Also Example
[image]

Get the ADAM device list by using UDP broadcast.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdamDeviceList( _
ByVal i_iTimeout As Integer, _
ByVal i_szBindIP As String, _
<OutAttribute> ByRef o_lstAdam As ArrayList _
) As Boolean
C#
public static bool GetAdamDeviceList(
int i_iTimeout,
string i_szBindIP,
out ArrayList o_lstAdam
)
C++
public:
static bool GetAdamDeviceList(
int i_iTimeout,
String i_szBindIP,
[OutAttribute] ArrayList% o_lstAdam
)
J#
public static bool GetAdamDeviceList(
int i_iTimeout,
string i_szBindIP,
/** @attribute OutAttribute() */ /** @ref */ ArrayList o_lstAdam
)
JScript
public static function GetAdamDeviceList(
i_iTimeout : int,
i_szBindIP : String,
OutAttribute o_lstAdam : ArrayList
) : bool

Parameters

i_iTimeout
The timeout for each information type.
i_szBindIP
The source IP address. (Make sure the network setting is the same as Adam)
o_lstAdam
The array list which holds the ADAM information.

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.GetAdamDeviceList Overload List


GetAdamDeviceList Method (String, Int32, ArrayList)

AdamSocket.GetAdamDeviceList Method (String, Int32, ArrayList)
See Also Example
[image]

Get the ADAM device list by using indicated IP address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdamDeviceList( _
ByVal i_szIP As String, _
ByVal i_iTimeout As Integer, _
<OutAttribute> ByRef o_lstAdam As ArrayList _
) As Boolean
C#
public static bool GetAdamDeviceList(
string i_szIP,
int i_iTimeout,
out ArrayList o_lstAdam
)
C++
public:
static bool GetAdamDeviceList(
String i_szIP,
int i_iTimeout,
[OutAttribute] ArrayList% o_lstAdam
)
J#
public static bool GetAdamDeviceList(
string i_szIP,
int i_iTimeout,
/** @attribute OutAttribute() */ /** @ref */ ArrayList o_lstAdam
)
JScript
public static function GetAdamDeviceList(
i_szIP : String,
i_iTimeout : int,
OutAttribute o_lstAdam : ArrayList
) : bool

Parameters

i_szIP
The indicated IP
i_iTimeout
The timeout for each information type.
o_lstAdam
The array list which holds the ADAM information.

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.GetAdamDeviceList Overload List


GetAdamDeviceList Method (String, Int32, String, ArrayList)

AdamSocket.GetAdamDeviceList Method (String, Int32, String, ArrayList)
See Also Example
[image]

Get the ADAM device list by using indicated IP address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdamDeviceList( _
ByVal i_szIP As String, _
ByVal i_iTimeout As Integer, _
ByVal i_szBindIP As String, _
<OutAttribute> ByRef o_lstAdam As ArrayList _
) As Boolean
C#
public static bool GetAdamDeviceList(
string i_szIP,
int i_iTimeout,
string i_szBindIP,
out ArrayList o_lstAdam
)
C++
public:
static bool GetAdamDeviceList(
String i_szIP,
int i_iTimeout,
String i_szBindIP,
[OutAttribute] ArrayList% o_lstAdam
)
J#
public static bool GetAdamDeviceList(
string i_szIP,
int i_iTimeout,
string i_szBindIP,
/** @attribute OutAttribute() */ /** @ref */ ArrayList o_lstAdam
)
JScript
public static function GetAdamDeviceList(
i_szIP : String,
i_iTimeout : int,
i_szBindIP : String,
OutAttribute o_lstAdam : ArrayList
) : bool

Parameters

i_szIP
The indicated IP
i_iTimeout
The timeout for each information type.
i_szBindIP
The source IP address. (Make sure the network setting is the same as Adam)
o_lstAdam
The array list which holds the ADAM information.

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.GetAdamDeviceList Overload List


GetAdamInformation Method

AdamSocket.GetAdamInformation Method

protected static bool GetAdamInformation(AdamInfoType i_infoType, string i_szIP, int i_iTimeout, ref ArrayList adamList)

Overload List

Name | Description
GetAdamInformation (AdamInfoType, String, Int32, ArrayList) | protected static bool GetAdamInformation(AdamInfoType i_infoType, string i_szIP, int i_iTimeout, ref ArrayList adamList)
GetAdamInformation (AdamInfoType, String, Int32, String, ArrayList) | protected static bool GetAdamInformation(AdamInfoType i_infoType, string i_szIP, int i_iTimeout, string i_szBindIP, ref ArrayList adamList)

See Also

AdamSocket Class
Advantech.Adam Namespace


GetAdamInformation Method (AdamInfoType, String, Int32, ArrayList)

AdamSocket.GetAdamInformation Method (AdamInfoType, String, Int32, ArrayList)
See Also Example
[image]

protected static bool GetAdamInformation(AdamInfoType i_infoType, string i_szIP, int i_iTimeout, ref ArrayList adamList)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdamInformation( _
ByVal i_infoType As AdamInfoType, _
ByVal i_szIP As String, _
ByVal i_iTimeout As Integer, _
ByRef adamList As ArrayList _
) As Boolean
C#
protected static bool GetAdamInformation(
AdamInfoType i_infoType,
string i_szIP,
int i_iTimeout,
ref ArrayList adamList
)
C++
protected:
static bool GetAdamInformation(
AdamInfoType i_infoType,
String i_szIP,
int i_iTimeout,
ArrayList% adamList
)
J#
protected static bool GetAdamInformation(
AdamInfoType i_infoType,
string i_szIP,
int i_iTimeout,
ArrayList adamList
)
JScript
protected static function GetAdamInformation(
i_infoType : AdamInfoType,
i_szIP : String,
i_iTimeout : int,
adamList : ArrayList
) : bool

Parameters

i_infoType
i_szIP
i_iTimeout
adamList

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.GetAdamInformation Overload List


GetAdamInformation Method (AdamInfoType, String, Int32, String, ArrayList)

AdamSocket.GetAdamInformation Method (AdamInfoType, String, Int32, String, ArrayList)
See Also Example
[image]

protected static bool GetAdamInformation(AdamInfoType i_infoType, string i_szIP, int i_iTimeout, string i_szBindIP, ref ArrayList adamList)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdamInformation( _
ByVal i_infoType As AdamInfoType, _
ByVal i_szIP As String, _
ByVal i_iTimeout As Integer, _
ByVal i_szBindIP As String, _
ByRef adamList As ArrayList _
) As Boolean
C#
protected static bool GetAdamInformation(
AdamInfoType i_infoType,
string i_szIP,
int i_iTimeout,
string i_szBindIP,
ref ArrayList adamList
)
C++
protected:
static bool GetAdamInformation(
AdamInfoType i_infoType,
String i_szIP,
int i_iTimeout,
String i_szBindIP,
ArrayList% adamList
)
J#
protected static bool GetAdamInformation(
AdamInfoType i_infoType,
string i_szIP,
int i_iTimeout,
string i_szBindIP,
ArrayList adamList
)
JScript
protected static function GetAdamInformation(
i_infoType : AdamInfoType,
i_szIP : String,
i_iTimeout : int,
i_szBindIP : String,
adamList : ArrayList
) : bool

Parameters

i_infoType
i_szIP
i_iTimeout
i_szBindIP
adamList

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.GetAdamInformation Overload List


GetAdvantechDeviceList Method

AdamSocket.GetAdvantechDeviceList Method
[image]

Get the Advantech device list by using UDP broadcast.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdvantechDeviceList( _
ByVal i_iTimeout As Integer, _
<OutAttribute> ByRef o_lstAdam As ArrayList _
) As Boolean
C#
public static bool GetAdvantechDeviceList(
int i_iTimeout,
out ArrayList o_lstAdam
)
C++
public:
static bool GetAdvantechDeviceList(
int i_iTimeout,
[OutAttribute] ArrayList% o_lstAdam
)
J#
public static bool GetAdvantechDeviceList(
int i_iTimeout,
/** @attribute OutAttribute() */ /** @ref */ ArrayList o_lstAdam
)
JScript
public static function GetAdvantechDeviceList(
i_iTimeout : int,
OutAttribute o_lstAdam : ArrayList
) : bool

Parameters

i_iTimeout
The timeout for each information type.
o_lstAdam
The array list which holds the Advantech device information.

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace


GetDSPFWVer Method

AdamSocket.GetDSPFWVer Method
[image]

Get DSP version from APAX coupler. Support: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDSPFWVer( _
ByRef o_szDSPFWVer As String _
) As Boolean
C#
public bool GetDSPFWVer(
ref string o_szDSPFWVer
)
C++
public:
bool GetDSPFWVer(
String% o_szDSPFWVer
) sealed
J#
public bool GetDSPFWVer(
string o_szDSPFWVer
)
JScript
public function GetDSPFWVer(
o_szDSPFWVer : String
) : bool

Parameters

o_szDSPFWVer
The receive data from APAX coupler

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace


GetIP Method

AdamSocket.GetIP Method
[image]

Get the IP string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIP() As String
C#
public string GetIP()
C++
public:
String GetIP() sealed
J#
public string GetIP()
JScript
public function GetIP() : String

Return Value

The IP string

See Also

AdamSocket Class
Advantech.Adam Namespace


GetLocalNetwork Method

AdamSocket.GetLocalNetwork Method
[image]

Get the local network card IP

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetLocalNetwork( _
<OutAttribute> ByRef o_szLocalIP As String _
) As Boolean
C#
public static bool GetLocalNetwork(
out string o_szLocalIP
)
C++
public:
static bool GetLocalNetwork(
[OutAttribute] String% o_szLocalIP
)
J#
public static bool GetLocalNetwork(
/** @attribute OutAttribute() */ /** @ref */ string o_szLocalIP
)
JScript
public static function GetLocalNetwork(
OutAttribute o_szLocalIP : String
) : bool

Parameters

o_szLocalIP

See Also

AdamSocket Class
Advantech.Adam Namespace


GetModuleName Method

AdamSocket.GetModuleName Method
[image]

Get module name. Support: APAX-5070, APAX-5072

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleName( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_uiModuleName As UInt32 _
) As Boolean
C#
public bool GetModuleName(
int i_iSlot,
out uint o_uiModuleName
)
C++
public:
bool GetModuleName(
int i_iSlot,
[OutAttribute] unsigned int% o_uiModuleName
) sealed
J#
public bool GetModuleName(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiModuleName
)
JScript
public function GetModuleName(
i_iSlot : int,
OutAttribute o_uiModuleName : UInt32
) : bool

Parameters

i_iSlot
The unique ID of the module
o_uiModuleName
The module name

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace


GetProtocolType Method

AdamSocket.GetProtocolType Method
[image]

Get the socket protocol type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetProtocolType() As ProtocolType
C#
public ProtocolType GetProtocolType()
C++
public:
ProtocolType GetProtocolType() sealed
J#
public ProtocolType GetProtocolType()
JScript
public function GetProtocolType() : ProtocolType

Return Value

The socket protocol type

See Also

AdamSocket Class
Advantech.Adam Namespace


Modbus Method

AdamSocket.Modbus Method

ADAM-5000TCP ADAM-6000 Modbus object

Overload List

 | Name | Description
Public method | Modbus | ADAM-5000TCP ADAM-6000 Modbus object
Public method | Modbus (Int32) | ADAM-5000TCP ADAM-6000 Modbus object

See Also

AdamSocket Class
Advantech.Adam Namespace


Modbus Method ()

AdamSocket.Modbus Method ()
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Modbus object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Modbus() As Modbus
C#
public Modbus Modbus()
C++
public:
Modbus Modbus() sealed
J#
public Modbus Modbus()
JScript
public function Modbus() : Modbus

Return Value

The Modbus object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Modbus Overload List


Modbus Method (Int32)

AdamSocket.Modbus Method (Int32)
See Also Example
[image]

ADAM-5000TCP ADAM-6000 Modbus object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Modbus( _
ByVal i_iAddr As Integer _
) As Modbus
C#
public Modbus Modbus(
int i_iAddr
)
C++
public:
Modbus Modbus(
int i_iAddr
) sealed
J#
public Modbus Modbus(
int i_iAddr
)
JScript
public function Modbus(
i_iAddr : int
) : Modbus

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

The Modbus object

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Modbus Overload List


Pid Method

AdamSocket.Pid Method

ADAM-6000 PID object

Overload List

 | Name | Description
Public method | Pid | ADAM-6000 PID object
Public method | Pid (Int32) | ADAM-6000 PID object

See Also

AdamSocket Class
Advantech.Adam Namespace


Pid Method ()

AdamSocket.Pid Method ()
See Also Example
[image]

ADAM-6000 PID object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Pid() As PID
C#
public PID Pid()
C++
public:
PID Pid() sealed
J#
public PID Pid()
JScript
public function Pid() : PID

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Pid Overload List


Pid Method (Int32)

AdamSocket.Pid Method (Int32)
See Also Example
[image]

ADAM-6000 PID object

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Pid( _
ByVal i_iAddr As Integer _
) As PID
C#
public PID Pid(
int i_iAddr
)
C++
public:
PID Pid(
int i_iAddr
) sealed
J#
public PID Pid(
int i_iAddr
)
JScript
public function Pid(
i_iAddr : int
) : PID

Parameters

i_iAddr
The module address which is ranged from 0 to 255

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.Pid Overload List


Receive Method

AdamSocket.Receive Method
[image]

Receive data from connected module. This function will receive as many data as the length of i_byData within receiving timeout. The actually received data length will be returned in the o_iLen.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Receive( _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_iLen As Integer _
) As Boolean
C#
public bool Receive(
byte[] i_byData,
out int o_iLen
)
C++
public:
bool Receive(
array<char>^ i_byData,
[OutAttribute] int% o_iLen
) sealed
J#
public bool Receive(
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ int o_iLen
)
JScript
public function Receive(
i_byData : Byte[],
OutAttribute o_iLen : int
) : bool

Parameters

i_byData
The receiving buffer.
o_iLen
The received data length

Return Value

True, if successed, otherwise false.

See Also

AdamSocket Class
Advantech.Adam Namespace


RefreshIOInfo Method

AdamSocket.RefreshIOInfo Method
[image]

Refresh IO module informations. Support: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function RefreshIOInfo() As Boolean
C#
public bool RefreshIOInfo()
C++
public:
bool RefreshIOInfo() sealed
J#
public bool RefreshIOInfo()
JScript
public function RefreshIOInfo() : bool

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace


Send Method

AdamSocket.Send Method
[image]

Send data to the connected module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Send( _
ByVal i_byData As Byte(), _
ByVal i_iLen As Integer _
) As Boolean
C#
public bool Send(
byte[] i_byData,
int i_iLen
)
C++
public:
bool Send(
array<char>^ i_byData,
int i_iLen
) sealed
J#
public bool Send(
byte[] i_byData,
int i_iLen
)
JScript
public function Send(
i_byData : Byte[],
i_iLen : int
) : bool

Parameters

i_byData
The data bytes.
i_iLen
The length of the data.

Return Value

True, if successed, otherwise false.

See Also

AdamSocket Class
Advantech.Adam Namespace


SendModuleControlCmd Method

AdamSocket.SendModuleControlCmd Method

Send the module control command by using UDP broadcast.

Overload List

Name | Description
SendModuleControlCmd (ModuleControlCmdType, Int32, AdamInformation) | Send the module control command by using UDP broadcast.
SendModuleControlCmd (ModuleControlCmdType, Int32, AdamInformation, String) | Send the module control command by using UDP broadcast.

See Also

AdamSocket Class
Advantech.Adam Namespace


SendModuleControlCmd Method (ModuleControlCmdType, Int32, AdamInformation)

AdamSocket.SendModuleControlCmd Method (ModuleControlCmdType, Int32, AdamInformation)
See Also Example
[image]

Send the module control command by using UDP broadcast.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SendModuleControlCmd( _
ByVal i_cmdType As ModuleControlCmdType, _
ByVal i_iTimeout As Integer, _
ByVal i_adamObject As AdamInformation _
) As Boolean
C#
public static bool SendModuleControlCmd(
ModuleControlCmdType i_cmdType,
int i_iTimeout,
AdamInformation i_adamObject
)
C++
public:
static bool SendModuleControlCmd(
ModuleControlCmdType i_cmdType,
int i_iTimeout,
AdamInformation i_adamObject
)
J#
public static bool SendModuleControlCmd(
ModuleControlCmdType i_cmdType,
int i_iTimeout,
AdamInformation i_adamObject
)
JScript
public static function SendModuleControlCmd(
i_cmdType : ModuleControlCmdType,
i_iTimeout : int,
i_adamObject : AdamInformation
) : bool

Parameters

i_cmdType
The module control command type.
i_iTimeout
The timeout for setting ADAM information.
i_adamObject
The ADAM information object which must be get by calling GetAdamDeviceList.

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.SendModuleControlCmd Overload List


SendModuleControlCmd Method (ModuleControlCmdType, Int32, AdamInformation, String)

AdamSocket.SendModuleControlCmd Method (ModuleControlCmdType, Int32, AdamInformation, String)
See Also Example
[image]

Send the module control command by using UDP broadcast.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SendModuleControlCmd( _
ByVal i_cmdType As ModuleControlCmdType, _
ByVal i_iTimeout As Integer, _
ByVal i_adamObject As AdamInformation, _
ByVal i_szBindIP As String _
) As Boolean
C#
public static bool SendModuleControlCmd(
ModuleControlCmdType i_cmdType,
int i_iTimeout,
AdamInformation i_adamObject,
string i_szBindIP
)
C++
public:
static bool SendModuleControlCmd(
ModuleControlCmdType i_cmdType,
int i_iTimeout,
AdamInformation i_adamObject,
String i_szBindIP
)
J#
public static bool SendModuleControlCmd(
ModuleControlCmdType i_cmdType,
int i_iTimeout,
AdamInformation i_adamObject,
string i_szBindIP
)
JScript
public static function SendModuleControlCmd(
i_cmdType : ModuleControlCmdType,
i_iTimeout : int,
i_adamObject : AdamInformation,
i_szBindIP : String
) : bool

Parameters

i_cmdType
The module control command type.
i_iTimeout
The timeout for setting ADAM information.
i_adamObject
The ADAM information object which must be get by calling GetAdamDeviceList.
i_szBindIP
The source IP address. (Make sure the network setting is the same as Adam)

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.SendModuleControlCmd Overload List


SetAdamInformation Method

AdamSocket.SetAdamInformation Method

Set the ADAM device information by using UDP broadcast. Add APAX-5070 support.

Overload List

Name | Description
SetAdamInformation (AdamInfoType, Int32, AdamInformation) | Set the ADAM device information by using UDP broadcast. Add APAX-5070 support.
SetAdamInformation (AdamInfoType, Int32, AdamInformation, String) | Set the ADAM device information by using UDP broadcast. Add APAX-5070 support.

See Also

AdamSocket Class
Advantech.Adam Namespace


SetAdamInformation Method (AdamInfoType, Int32, AdamInformation)

AdamSocket.SetAdamInformation Method (AdamInfoType, Int32, AdamInformation)
See Also Example
[image]

Set the ADAM device information by using UDP broadcast. Add APAX-5070 support.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SetAdamInformation( _
ByVal i_infoType As AdamInfoType, _
ByVal i_iTimeout As Integer, _
ByVal i_adamObject As AdamInformation _
) As Boolean
C#
public static bool SetAdamInformation(
AdamInfoType i_infoType,
int i_iTimeout,
AdamInformation i_adamObject
)
C++
public:
static bool SetAdamInformation(
AdamInfoType i_infoType,
int i_iTimeout,
AdamInformation i_adamObject
)
J#
public static bool SetAdamInformation(
AdamInfoType i_infoType,
int i_iTimeout,
AdamInformation i_adamObject
)
JScript
public static function SetAdamInformation(
i_infoType : AdamInfoType,
i_iTimeout : int,
i_adamObject : AdamInformation
) : bool

Parameters

i_infoType
The ADAM information type.
i_iTimeout
The timeout for setting ADAM information.
i_adamObject
The ADAM information object which must be get by calling GetAdamDeviceList.

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.SetAdamInformation Overload List


SetAdamInformation Method (AdamInfoType, Int32, AdamInformation, String)

AdamSocket.SetAdamInformation Method (AdamInfoType, Int32, AdamInformation, String)
See Also Example
[image]

Set the ADAM device information by using UDP broadcast. Add APAX-5070 support.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SetAdamInformation( _
ByVal i_infoType As AdamInfoType, _
ByVal i_iTimeout As Integer, _
ByVal i_adamObject As AdamInformation, _
ByVal i_szBindIP As String _
) As Boolean
C#
public static bool SetAdamInformation(
AdamInfoType i_infoType,
int i_iTimeout,
AdamInformation i_adamObject,
string i_szBindIP
)
C++
public:
static bool SetAdamInformation(
AdamInfoType i_infoType,
int i_iTimeout,
AdamInformation i_adamObject,
String i_szBindIP
)
J#
public static bool SetAdamInformation(
AdamInfoType i_infoType,
int i_iTimeout,
AdamInformation i_adamObject,
string i_szBindIP
)
JScript
public static function SetAdamInformation(
i_infoType : AdamInfoType,
i_iTimeout : int,
i_adamObject : AdamInformation,
i_szBindIP : String
) : bool

Parameters

i_infoType
The ADAM information type.
i_iTimeout
The timeout for setting ADAM information.
i_adamObject
The ADAM information object which must be get by calling GetAdamDeviceList.
i_szBindIP
The source IP address. (Make sure the network setting is the same as Adam)

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.SetAdamInformation Overload List


SetSocketOpt Method

AdamSocket.SetSocketOpt Method
[image]

Set socket option

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSocketOpt( _
ByVal OptLevel As SocketOptionLevel, _
ByVal OptName As SocketOptionName, _
ByVal OptIdx As Integer _
)
C#
public void SetSocketOpt(
SocketOptionLevel OptLevel,
SocketOptionName OptName,
int OptIdx
)
C++
public:
void SetSocketOpt(
SocketOptionLevel OptLevel,
SocketOptionName OptName,
int OptIdx
) sealed
J#
public void SetSocketOpt(
SocketOptionLevel OptLevel,
SocketOptionName OptName,
int OptIdx
)
JScript
public function SetSocketOpt(
OptLevel : SocketOptionLevel,
OptName : SocketOptionName,
OptIdx : int
)

Parameters

OptLevel
The IP address.
OptName
The protocol type.
OptIdx
The port number.

Return Value

True, if successed, otherwise false.

See Also

AdamSocket Class
Advantech.Adam Namespace


SetTimeout Method

AdamSocket.SetTimeout Method
[image]

Set the timeout constances for socket

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetTimeout( _
ByVal i_iConnectTimeout As Integer, _
ByVal i_iSendTimeout As Integer, _
ByVal i_iRecvTimeout As Integer _
)
C#
public void SetTimeout(
int i_iConnectTimeout,
int i_iSendTimeout,
int i_iRecvTimeout
)
C++
public:
void SetTimeout(
int i_iConnectTimeout,
int i_iSendTimeout,
int i_iRecvTimeout
) sealed
J#
public void SetTimeout(
int i_iConnectTimeout,
int i_iSendTimeout,
int i_iRecvTimeout
)
JScript
public function SetTimeout(
i_iConnectTimeout : int,
i_iSendTimeout : int,
i_iRecvTimeout : int
)

Parameters

i_iConnectTimeout
The connection timeout.
i_iSendTimeout
The sending timeout
i_iRecvTimeout
The receiving timeout

See Also

AdamSocket Class
Advantech.Adam Namespace


SYS_CheckReady Method

AdamSocket.SYS_CheckReady Method

Check if APAX coupler is ready or not. Support: APAX-5070

Overload List

 | Name | Description
Public method | SYS_CheckReady (Int32) | Check if APAX coupler is ready or not. Support: APAX-5070
Public method | SYS_CheckReady (Int32, Byte) | Check if APAX coupler is ready or not. Support: APAX-5070

See Also

AdamSocket Class
Advantech.Adam Namespace


SYS_CheckReady Method (Int32)

AdamSocket.SYS_CheckReady Method (Int32)
See Also Example
[image]

Check if APAX coupler is ready or not. Support: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_CheckReady( _
ByVal i_uID As Integer _
) As Boolean
C#
public bool SYS_CheckReady(
int i_uID
)
C++
public:
bool SYS_CheckReady(
int i_uID
) sealed
J#
public bool SYS_CheckReady(
int i_uID
)
JScript
public function SYS_CheckReady(
i_uID : int
) : bool

Parameters

i_uID
The unique ID

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.SYS_CheckReady Overload List


SYS_CheckReady Method (Int32, Byte)

AdamSocket.SYS_CheckReady Method (Int32, Byte)
See Also Example
[image]

Check if APAX coupler is ready or not. Support: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_CheckReady( _
ByVal i_uID As Integer, _
<OutAttribute> ByRef byRecv As Byte _
) As Boolean
C#
public bool SYS_CheckReady(
int i_uID,
out byte byRecv
)
C++
public:
bool SYS_CheckReady(
int i_uID,
[OutAttribute] char% byRecv
) sealed
J#
public bool SYS_CheckReady(
int i_uID,
/** @attribute OutAttribute() */ /** @ref */ byte byRecv
)
JScript
public function SYS_CheckReady(
i_uID : int,
OutAttribute byRecv : Byte
) : bool

Parameters

i_uID
The unique ID
byRecv
The receive data from APAX coupler

Return Value

Return true if success, otherwise return false.

See Also

AdamSocket Class
Advantech.Adam Namespace
AdamSocket.SYS_CheckReady Overload List


AdamStreamRec Class

AdamStreamRec Class
See Also Example Members
[image]

Class AdamStreamRec for event trigger

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamStreamRec
C#
public class AdamStreamRec
C++
ref class AdamStreamRec
J#
public class AdamStreamRec
JScript
public class AdamStreamRec

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamStreamRec

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamStreamRec Members
Advantech.Adam Namespace


AdamStreamRec Members

AdamStreamRec Members
See Also Example Constructors Fields
[image]

Class AdamStreamRec for event trigger

The following tables list the members exposed by AdamStreamRec.

Public Constructors

 | Name | Description
Public method | AdamStreamRec | Constructer
Top

Public Fields

 | Name | Description
Public field | m_byIP | IP
Public field | m_Data | DataStream struct
Public field | m_Data_AIO | AIO data : 128 bytes (Fixed Modbus address)
Public field | m_Data_DIO | DIO data : 16 bytes
Public field | m_FcnCode | Function code : 1 bytes
Public field | m_Header | Header : 4 bytes
Public field | m_HiAlarm | Hi alarm data : 8 bytes
Public field | m_LoAlarm | Lo alarm data : 8 bytes
Public field | m_Mask_DIO_Off2On | DIO off to on mask : 16 bytes
Public field | m_Mask_DIO_On2Off | DIO on to off mask : 16 bytes
Public field | m_Mask_HiAlarm_Off2On | Hi alarm off to on mask : 8 bytes
Public field | m_Mask_HiAlarm_On2Off | Hi alarm on to off mask : 8 bytes
Public field | m_Mask_LoAlarm_Off2On | Lo alarm off to on mask : 8 bytes
Public field | m_Mask_LoAlarm_On2Off | Lo alarm on to off mask: 8 bytes
Public field | m_PackageNum | Package number : 1 bytes
Public field | m_Pre_Data_DIO | Pre DIO data : 16 bytes
Public field | m_Pre_HiAlarm | Pre Hi alarm data : 8 bytes
Public field | m_Pre_LoAlarm | Pre Lo alarm data : 8 bytes
Top

See Also

AdamStreamRec Class
Advantech.Adam Namespace


AdamStreamRec Constructor

AdamStreamRec Constructor
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_byRecv As Byte(), _
ByVal i_byIP As Byte(), _
ByVal i_bIsFlexibleModAddrFW As Boolean _
)
C#
public AdamStreamRec(
byte[] i_byRecv,
byte[] i_byIP,
bool i_bIsFlexibleModAddrFW
)
C++
public:
AdamStreamRec(
array<char>^ i_byRecv,
array<char>^ i_byIP,
bool i_bIsFlexibleModAddrFW
) sealed
J#
public AdamStreamRec(
byte[] i_byRecv,
byte[] i_byIP,
bool i_bIsFlexibleModAddrFW
)
JScript
public function AdamStreamRec(
i_byRecv : Byte[],
i_byIP : Byte[],
i_bIsFlexibleModAddrFW : bool
)

Parameters

i_byRecv
i_byIP
i_bIsFlexibleModAddrFW

See Also

AdamStreamRec Class
Advantech.Adam Namespace


Fields

AdamStreamRec Fields
[image]

Public Fields

 | Name | Description
Public field | m_byIP | IP
Public field | m_Data | DataStream struct
Public field | m_Data_AIO | AIO data : 128 bytes (Fixed Modbus address)
Public field | m_Data_DIO | DIO data : 16 bytes
Public field | m_FcnCode | Function code : 1 bytes
Public field | m_Header | Header : 4 bytes
Public field | m_HiAlarm | Hi alarm data : 8 bytes
Public field | m_LoAlarm | Lo alarm data : 8 bytes
Public field | m_Mask_DIO_Off2On | DIO off to on mask : 16 bytes
Public field | m_Mask_DIO_On2Off | DIO on to off mask : 16 bytes
Public field | m_Mask_HiAlarm_Off2On | Hi alarm off to on mask : 8 bytes
Public field | m_Mask_HiAlarm_On2Off | Hi alarm on to off mask : 8 bytes
Public field | m_Mask_LoAlarm_Off2On | Lo alarm off to on mask : 8 bytes
Public field | m_Mask_LoAlarm_On2Off | Lo alarm on to off mask: 8 bytes
Public field | m_PackageNum | Package number : 1 bytes
Public field | m_Pre_Data_DIO | Pre DIO data : 16 bytes
Public field | m_Pre_HiAlarm | Pre Hi alarm data : 8 bytes
Public field | m_Pre_LoAlarm | Pre Lo alarm data : 8 bytes
Top

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_byIP Field

AdamStreamRec.m_byIP Field
[image]

IP

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_byIP As Byte()
C#
public byte[] m_byIP;
C++
public:
array<char>^ m_byIP sealed ;
J#
public byte[] m_byIP
JScript
public m_byIP : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Data Field

AdamStreamRec.m_Data Field
[image]

DataStream struct

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Data As Byte()
C#
public byte[] m_Data;
C++
public:
array<char>^ m_Data sealed ;
J#
public byte[] m_Data
JScript
public m_Data : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Data_AIO Field

AdamStreamRec.m_Data_AIO Field
[image]

AIO data : 128 bytes (Fixed Modbus address)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Data_AIO As Byte()
C#
public byte[] m_Data_AIO;
C++
public:
array<char>^ m_Data_AIO sealed ;
J#
public byte[] m_Data_AIO
JScript
public m_Data_AIO : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Data_DIO Field

AdamStreamRec.m_Data_DIO Field
[image]

DIO data : 16 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Data_DIO As Byte()
C#
public byte[] m_Data_DIO;
C++
public:
array<char>^ m_Data_DIO sealed ;
J#
public byte[] m_Data_DIO
JScript
public m_Data_DIO : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_FcnCode Field

AdamStreamRec.m_FcnCode Field
[image]

Function code : 1 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_FcnCode As Byte
C#
public byte m_FcnCode;
C++
public:
char m_FcnCode sealed ;
J#
public byte m_FcnCode
JScript
public m_FcnCode : Byte;

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Header Field

AdamStreamRec.m_Header Field
[image]

Header : 4 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Header As Byte()
C#
public byte[] m_Header;
C++
public:
array<char>^ m_Header sealed ;
J#
public byte[] m_Header
JScript
public m_Header : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_HiAlarm Field

AdamStreamRec.m_HiAlarm Field
[image]

Hi alarm data : 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_HiAlarm As Byte()
C#
public byte[] m_HiAlarm;
C++
public:
array<char>^ m_HiAlarm sealed ;
J#
public byte[] m_HiAlarm
JScript
public m_HiAlarm : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_LoAlarm Field

AdamStreamRec.m_LoAlarm Field
[image]

Lo alarm data : 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_LoAlarm As Byte()
C#
public byte[] m_LoAlarm;
C++
public:
array<char>^ m_LoAlarm sealed ;
J#
public byte[] m_LoAlarm
JScript
public m_LoAlarm : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Mask_DIO_Off2On Field

AdamStreamRec.m_Mask_DIO_Off2On Field
[image]

DIO off to on mask : 16 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Mask_DIO_Off2On As Byte()
C#
public byte[] m_Mask_DIO_Off2On;
C++
public:
array<char>^ m_Mask_DIO_Off2On sealed ;
J#
public byte[] m_Mask_DIO_Off2On
JScript
public m_Mask_DIO_Off2On : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Mask_DIO_On2Off Field

AdamStreamRec.m_Mask_DIO_On2Off Field
[image]

DIO on to off mask : 16 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Mask_DIO_On2Off As Byte()
C#
public byte[] m_Mask_DIO_On2Off;
C++
public:
array<char>^ m_Mask_DIO_On2Off sealed ;
J#
public byte[] m_Mask_DIO_On2Off
JScript
public m_Mask_DIO_On2Off : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Mask_HiAlarm_Off2On Field

AdamStreamRec.m_Mask_HiAlarm_Off2On Field
[image]

Hi alarm off to on mask : 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Mask_HiAlarm_Off2On As Byte()
C#
public byte[] m_Mask_HiAlarm_Off2On;
C++
public:
array<char>^ m_Mask_HiAlarm_Off2On sealed ;
J#
public byte[] m_Mask_HiAlarm_Off2On
JScript
public m_Mask_HiAlarm_Off2On : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Mask_HiAlarm_On2Off Field

AdamStreamRec.m_Mask_HiAlarm_On2Off Field
[image]

Hi alarm on to off mask : 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Mask_HiAlarm_On2Off As Byte()
C#
public byte[] m_Mask_HiAlarm_On2Off;
C++
public:
array<char>^ m_Mask_HiAlarm_On2Off sealed ;
J#
public byte[] m_Mask_HiAlarm_On2Off
JScript
public m_Mask_HiAlarm_On2Off : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Mask_LoAlarm_Off2On Field

AdamStreamRec.m_Mask_LoAlarm_Off2On Field
[image]

Lo alarm off to on mask : 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Mask_LoAlarm_Off2On As Byte()
C#
public byte[] m_Mask_LoAlarm_Off2On;
C++
public:
array<char>^ m_Mask_LoAlarm_Off2On sealed ;
J#
public byte[] m_Mask_LoAlarm_Off2On
JScript
public m_Mask_LoAlarm_Off2On : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Mask_LoAlarm_On2Off Field

AdamStreamRec.m_Mask_LoAlarm_On2Off Field
[image]

Lo alarm on to off mask: 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Mask_LoAlarm_On2Off As Byte()
C#
public byte[] m_Mask_LoAlarm_On2Off;
C++
public:
array<char>^ m_Mask_LoAlarm_On2Off sealed ;
J#
public byte[] m_Mask_LoAlarm_On2Off
JScript
public m_Mask_LoAlarm_On2Off : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_PackageNum Field

AdamStreamRec.m_PackageNum Field
[image]

Package number : 1 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_PackageNum As Byte
C#
public byte m_PackageNum;
C++
public:
char m_PackageNum sealed ;
J#
public byte m_PackageNum
JScript
public m_PackageNum : Byte;

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Pre_Data_DIO Field

AdamStreamRec.m_Pre_Data_DIO Field
[image]

Pre DIO data : 16 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Pre_Data_DIO As Byte()
C#
public byte[] m_Pre_Data_DIO;
C++
public:
array<char>^ m_Pre_Data_DIO sealed ;
J#
public byte[] m_Pre_Data_DIO
JScript
public m_Pre_Data_DIO : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Pre_HiAlarm Field

AdamStreamRec.m_Pre_HiAlarm Field
[image]

Pre Hi alarm data : 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Pre_HiAlarm As Byte()
C#
public byte[] m_Pre_HiAlarm;
C++
public:
array<char>^ m_Pre_HiAlarm sealed ;
J#
public byte[] m_Pre_HiAlarm
JScript
public m_Pre_HiAlarm : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


m_Pre_LoAlarm Field

AdamStreamRec.m_Pre_LoAlarm Field
[image]

Pre Lo alarm data : 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public m_Pre_LoAlarm As Byte()
C#
public byte[] m_Pre_LoAlarm;
C++
public:
array<char>^ m_Pre_LoAlarm sealed ;
J#
public byte[] m_Pre_LoAlarm
JScript
public m_Pre_LoAlarm : Byte[];

See Also

AdamStreamRec Class
Advantech.Adam Namespace


AdamStreamRecList Class

AdamStreamRecList Class
See Also Example Members
[image]

Class AdamStreamRecList for event trigger.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamStreamRecList
C#
public class AdamStreamRecList
C++
ref class AdamStreamRecList
J#
public class AdamStreamRecList
JScript
public class AdamStreamRecList

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamStreamRecList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamStreamRecList Members
Advantech.Adam Namespace


AdamStreamRecList Members

AdamStreamRecList Members
See Also Example Constructors Methods
[image]

Class AdamStreamRecList for event trigger.

The following tables list the members exposed by AdamStreamRecList.

Public Constructors

 | Name | Description
Public method | AdamStreamRecList | Constructer
Top

Public Methods

 | Name | Description
Public method | ClearStreamRec | Clear received stream
Public method | GetLastStreamRec | Overloaded. Get the last received stream
Public method | PopEventRec | Pop received event
Public method | PushEventRec | Push received event
Public method | PushStreamRec | Push received stream
Top

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


AdamStreamRecList Constructor

AdamStreamRecList Constructor
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamStreamRecList()
C++
public:
AdamStreamRecList() sealed
J#
public AdamStreamRecList()
JScript
public function AdamStreamRecList()

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


Methods

AdamStreamRecList Methods
[image]

Public Methods

 | Name | Description
Public method | ClearStreamRec | Clear received stream
Public method | GetLastStreamRec | Overloaded. Get the last received stream
Public method | PopEventRec | Pop received event
Public method | PushEventRec | Push received event
Public method | PushStreamRec | Push received stream
Top

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


ClearStreamRec Method

AdamStreamRecList.ClearStreamRec Method
[image]

Clear received stream

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearStreamRec()
C#
public void ClearStreamRec()
C++
public:
void ClearStreamRec() sealed
J#
public void ClearStreamRec()
JScript
public function ClearStreamRec()

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


GetLastStreamRec Method

AdamStreamRecList.GetLastStreamRec Method

Get the last received stream

Overload List

 | Name | Description
Public method | GetLastStreamRec (Byte) | Get the last received stream
Public method | GetLastStreamRec (String, Byte) | Get the last received stream from target IP

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


GetLastStreamRec Method (Byte)

AdamStreamRecList.GetLastStreamRec Method (Byte)
See Also Example
[image]

Get the last received stream

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLastStreamRec( _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetLastStreamRec(
out byte o_byData
)
C++
public:
bool GetLastStreamRec(
[OutAttribute] char% o_byData
) sealed
J#
public bool GetLastStreamRec(
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetLastStreamRec(
OutAttribute o_byData : Byte
) : bool

Parameters

o_byData
The last data stream

See Also

AdamStreamRecList Class
Advantech.Adam Namespace
AdamStreamRecList.GetLastStreamRec Overload List


GetLastStreamRec Method (String, Byte)

AdamStreamRecList.GetLastStreamRec Method (String, Byte)
See Also Example
[image]

Get the last received stream from target IP

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLastStreamRec( _
ByVal i_strIP As String, _
<OutAttribute> ByRef o_byData As Byte _
) As Boolean
C#
public bool GetLastStreamRec(
string i_strIP,
out byte o_byData
)
C++
public:
bool GetLastStreamRec(
String i_strIP,
[OutAttribute] char% o_byData
) sealed
J#
public bool GetLastStreamRec(
string i_strIP,
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function GetLastStreamRec(
i_strIP : String,
OutAttribute o_byData : Byte
) : bool

Parameters

i_strIP
Target IP
o_byData
The last data stream from target IP

See Also

AdamStreamRecList Class
Advantech.Adam Namespace
AdamStreamRecList.GetLastStreamRec Overload List


PopEventRec Method

AdamStreamRecList.PopEventRec Method
[image]

Pop received event

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function PopEventRec( _
<OutAttribute> ByRef o_byIP As Byte, _
<OutAttribute> ByRef o_iSlot As Integer, _
<OutAttribute> ByRef o_iChannel As Integer, _
<OutAttribute> ByRef o_iType As Integer, _
<OutAttribute> ByRef o_iStatus As Integer, _
<OutAttribute> ByRef o_strTime As String, _
<OutAttribute> ByRef o_lVal As Long _
) As Boolean
C#
public bool PopEventRec(
out byte o_byIP,
out int o_iSlot,
out int o_iChannel,
out int o_iType,
out int o_iStatus,
out string o_strTime,
out long o_lVal
)
C++
public:
bool PopEventRec(
[OutAttribute] char% o_byIP,
[OutAttribute] int% o_iSlot,
[OutAttribute] int% o_iChannel,
[OutAttribute] int% o_iType,
[OutAttribute] int% o_iStatus,
[OutAttribute] String% o_strTime,
[OutAttribute] __int64% o_lVal
) sealed
J#
public bool PopEventRec(
/** @attribute OutAttribute() */ /** @ref */ byte o_byIP,
/** @attribute OutAttribute() */ /** @ref */ int o_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iType,
/** @attribute OutAttribute() */ /** @ref */ int o_iStatus,
/** @attribute OutAttribute() */ /** @ref */ string o_strTime,
/** @attribute OutAttribute() */ /** @ref */ long o_lVal
)
JScript
public function PopEventRec(
OutAttribute o_byIP : Byte,
OutAttribute o_iSlot : int,
OutAttribute o_iChannel : int,
OutAttribute o_iType : int,
OutAttribute o_iStatus : int,
OutAttribute o_strTime : String,
OutAttribute o_lVal : long
) : bool

Parameters

o_byIP
o_iSlot
o_iChannel
o_iType
o_iStatus
o_strTime
o_lVal

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


PushEventRec Method

AdamStreamRecList.PushEventRec Method
[image]

Push received event

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub PushEventRec( _
ByVal i_byIP As Byte(), _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iType As Integer, _
ByVal i_iStatus As Integer, _
ByVal i_lVal As Long _
)
C#
public void PushEventRec(
byte[] i_byIP,
int i_iSlot,
int i_iChannel,
int i_iType,
int i_iStatus,
long i_lVal
)
C++
public:
void PushEventRec(
array<char>^ i_byIP,
int i_iSlot,
int i_iChannel,
int i_iType,
int i_iStatus,
__int64 i_lVal
) sealed
J#
public void PushEventRec(
byte[] i_byIP,
int i_iSlot,
int i_iChannel,
int i_iType,
int i_iStatus,
long i_lVal
)
JScript
public function PushEventRec(
i_byIP : Byte[],
i_iSlot : int,
i_iChannel : int,
i_iType : int,
i_iStatus : int,
i_lVal : long
)

Parameters

i_byIP
i_iSlot
i_iChannel
i_iType
i_iStatus
i_lVal

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


PushStreamRec Method

AdamStreamRecList.PushStreamRec Method
[image]

Push received stream

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub PushStreamRec( _
ByVal i_ipAddress As IPAddress, _
ByVal i_byData As Byte(), _
ByVal i_recvLen As Integer _
)
C#
public void PushStreamRec(
IPAddress i_ipAddress,
byte[] i_byData,
int i_recvLen
)
C++
public:
void PushStreamRec(
IPAddress i_ipAddress,
array<char>^ i_byData,
int i_recvLen
) sealed
J#
public void PushStreamRec(
IPAddress i_ipAddress,
byte[] i_byData,
int i_recvLen
)
JScript
public function PushStreamRec(
i_ipAddress : IPAddress,
i_byData : Byte[],
i_recvLen : int
)

Parameters

i_ipAddress
i_byData
i_recvLen

See Also

AdamStreamRecList Class
Advantech.Adam Namespace


AdamType Enumeration

AdamType Enumeration
[image]

The ADAM module type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum AdamType
C#
public enum AdamType
C++
public enum class AdamType
J#
public enum AdamType
JScript
public enum AdamType

Members

Member Name | Description
Non | Non module
Adam2000 | ADAM-2000 module
Adam3600 | ADAM-3600 module
Adam4000 | ADAM-4000 module
Adam5000 | ADAM-5000 module
Adam5000Tcp | ADAM-5000TCP module
Adam5550 | ADAM-5550 module
Apax5000 | APAX-5000 module
Apax5070 | APAX-5070 module
Apax5071 | APAX-5071 module
Apax5072 | APAX-5072 module
Apax5073 | APAX-5073 module
Adam6000 | ADAM-6000 module
Adam6100 | ADAM-6100 module
Adam6200 | ADAM-6200 module
Wise4000L | WISE-4000 Wired Series module
Wise4000 | WISE-4000 Wireless Series module
Wise4000E | WISE-4000 Wireless and Developer Version Series module

See Also

Advantech.Adam Namespace


AdamUnknown_DataFormat Enumeration

AdamUnknown_DataFormat Enumeration
[image]

The data format for analog input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum AdamUnknown_DataFormat As Byte
C#
public enum AdamUnknown_DataFormat : byte
C++
public enum class AdamUnknown_DataFormat : char
J#
public enum AdamUnknown_DataFormat byte
JScript
public enum AdamUnknown_DataFormat :

Members

Member Name | Description
EngineerUnit | Engineering unit
Percent | Percent pf FSR
TwosComplementHex | Two's complement hexdecimal
Ohms | Ohms (ADAM-5013)
Unknown | Unknown data format

See Also

Advantech.Adam Namespace


AdamUnknown_InputRange Enumeration

AdamUnknown_InputRange Enumeration
[image]

Newly unknown Adam module input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum AdamUnknown_InputRange As Byte
C#
public enum AdamUnknown_InputRange : byte
C++
public enum class AdamUnknown_InputRange : char
J#
public enum AdamUnknown_InputRange byte
JScript
public enum AdamUnknown_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg500To500 | +/- 500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
mA_Neg20To20_Old | +/- 20 mA
mA_4To20 | 4~20 mA
V_Neg10To10 | +/- 10 V
V_Neg5To5 | +/- 5 V
V_Neg1To1_Old | +/- 1 V
mV_Neg500To500_Old | +/- 500 mV
mV_Neg150To150 | +/- 150 mV
mA_Neg20To20 | +/- 20 mA
Jtype_0To760C | T/C J type 0~760 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Stype_500To1750C | T/C S type 500~1750 'C
Btype_500To1800C | T/C B type 500~1800 'C
V_Neg15To15 | +/- 15 V
Pt392_Neg50To150 | Pt392 -50~150 'C
Pt385_Neg200To200 | Pt385 -200~200 'C
Pt385_0To400 | Pt385 0~400 'C
Pt385_Neg50To150 | Pt385 -50~150 'C
Pt385_Neg100To100 | Pt385 -100~100 'C
Pt385_0To100 | Pt385 0~100 'C
Pt385_0To200 | Pt385 0~200 'C
Pt385_0To600 | Pt385 0~600 'C
Pt392_Neg100To100 | Pt392 -100~100 'C
Pt392_0To100 | Pt392 0~100 'C
Pt392_0To200 | Pt392 0~200 'C
Pt392_0To600 | Pt392 0~600 'C
Pt392_0To400 | Pt392 0~400 'C
Pt392_Neg200To200 | Pt392 -200~200 'C
Pt1000_Neg40To160 | Pt1000 -40~160 'C
Balco500_Neg30To120 | Balco500 -30~120 'C
Ni518_Neg80To100 | Ni518 -80~100 'C
Ni518_0To100 | Ni518 0~100 'C
Thermistor_3K_0To100 | Thermistor 3K 0~100 'C
Thermistor_10K_0To100 | Thermistor 10K 0~100 'C
Ni508_0To100 | Ni508 0~100 'C
Ni508_Neg50To200 | Ni508 -50~200 'C
mV_0To500_Old | 0~500 mV
mA_0To20 | 0~20 mA
V_0To10 | 0~10 V
V_0To5 | 0~5 V
V_0To1 | 0~1 V
mV_0To500 | 0~500 mV
mV_0To150 | 0~150 mV
mA_0To20_Old | 0~20 mA
V_0To2AndHalf | 0~2.5 V
V_0To15 | 0~15 V
Thermistor_10K_Neg50To100 | Thermistor 10K -50~100 'C
Unknown | Unknown range

See Also

Advantech.Adam Namespace


AdamWirelessAP Class

AdamWirelessAP Class
See Also Example Members
[image]

ADAM-6000W AP class

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamWirelessAP
C#
public class AdamWirelessAP
C++
ref class AdamWirelessAP
J#
public class AdamWirelessAP
JScript
public class AdamWirelessAP

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamWirelessAP

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamWirelessAP Members
Advantech.Adam Namespace


AdamWirelessAP Members

AdamWirelessAP Members
See Also Example Constructors Properties
[image]

ADAM-6000W AP class

The following tables list the members exposed by AdamWirelessAP.

Public Constructors

 | Name | Description
Public method | AdamWirelessAP | The AdamWirelessAP constructor
Top

Public Properties

 | Name | Description
Public property | Channel | The channel.
Public property | MAC | The MAC address.
Public property | Mode | The mode.
Public property | SSID | The SSID.
Public property | Strength | The strength.
Public property | WepUsed | The WEP used.
Top

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


AdamWirelessAP Constructor

AdamWirelessAP Constructor
[image]

The AdamWirelessAP constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamWirelessAP()
C++
public:
AdamWirelessAP() sealed
J#
public AdamWirelessAP()
JScript
public function AdamWirelessAP()

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


Properties

AdamWirelessAP Properties
[image]

Public Properties

 | Name | Description
Public property | Channel | The channel.
Public property | MAC | The MAC address.
Public property | Mode | The mode.
Public property | SSID | The SSID.
Public property | Strength | The strength.
Public property | WepUsed | The WEP used.
Top

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


Channel Property

AdamWirelessAP.Channel Property
[image]

The channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Channel As Byte
C#
public byte Channel { get; set; }
C++
public property byte Channel sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Channel();

/** property */
public void set_Channel(byte value);
JScript
public function get Channel() : Byte

public function set Channel(value : Byte);

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


MAC Property

AdamWirelessAP.MAC Property
[image]

The MAC address.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property MAC As String
C#
public string MAC { get; set; }
C++
public property string MAC sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_MAC();

/** property */
public void set_MAC(string value);
JScript
public function get MAC() : String

public function set MAC(value : String);

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


Mode Property

AdamWirelessAP.Mode Property
[image]

The mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Mode As Byte
C#
public byte Mode { get; set; }
C++
public property byte Mode sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Mode();

/** property */
public void set_Mode(byte value);
JScript
public function get Mode() : Byte

public function set Mode(value : Byte);

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


SSID Property

AdamWirelessAP.SSID Property
[image]

The SSID.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property SSID As String
C#
public string SSID { get; set; }
C++
public property string SSID sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SSID();

/** property */
public void set_SSID(string value);
JScript
public function get SSID() : String

public function set SSID(value : String);

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


Strength Property

AdamWirelessAP.Strength Property
[image]

The strength.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property Strength As Byte
C#
public byte Strength { get; set; }
C++
public property byte Strength sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_Strength();

/** property */
public void set_Strength(byte value);
JScript
public function get Strength() : Byte

public function set Strength(value : Byte);

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


WepUsed Property

AdamWirelessAP.WepUsed Property
[image]

The WEP used.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property WepUsed As Boolean
C#
public bool WepUsed { get; set; }
C++
public property bool WepUsed sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_WepUsed();

/** property */
public void set_WepUsed(bool value);
JScript
public function get WepUsed() : bool

public function set WepUsed(value : bool);

See Also

AdamWirelessAP Class
Advantech.Adam Namespace


Alarm Class

Alarm Class
See Also Example Members
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Alarm
Inherits AdamBase
C#
public class Alarm : AdamBase
C++
ref class Alarm : AdamBase
J#
public class Alarm extends AdamBase
JScript
public class Alarm extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.Alarm

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Alarm Members
Advantech.Adam Namespace


Alarm Members

Alarm Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Alarm.

Public Constructors

Name | Description
Alarm | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | ClearAlarmFlags | Support module: APAX-5080. Clear the alarm flags.
Public method | GetAlarmDO | Support module: ADAM-5081. Get Alarm/DO values. The o_bValues will return the DO values.
Public method | GetAlarmFlags | Support module: APAX-5080. Get the alarm flags.
Public method | GetEnableAlarmDO | Support module: ADAM-4080. Get alarm enabled status and the alarm DO status.
Public method | GetHighLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Get counter high alarm limit
Public method | GetHighMapping | Overloaded. Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the high alarm maps to.
Public method | GetHighMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get analog input High Alarm mode
Public method | GetLimit | Overloaded. Support module: ADAM-4080. Get alarm limit for the specified counter channel.
Public method | GetLocalAlarmConfiguration | Overloaded. Support module: ADAM-5081 Get local alarm mode, type, mapping channel, and limit value.
Public method | GetLocalAlarmStatus | Support module: ADAM-5081 Get the local alarm status
Public method | GetLowLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Get counter low alarm limit
Public method | GetLowMapping | Overloaded. Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the low alarm maps to.
Public method | GetLowMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018. Get analog input low alarm mode
Public method | GetModeAlarmDO | Overloaded. Support module: ADAM-4080D. Get alarm mode and the alarm DO status.
 | GetModeCode | Overloaded. Support module: ADAM-4000. Get the alarm code
 | GetModeIndex | Overloaded. Support module: ADAM-4000. Get the alarm code index
 | GetModeName | Overloaded. Support module: ADAM-4000. Get the alarm mode name
 | GetModeTotal | Overloaded. Support module: ADAM-4000. Get the range total
Public method | GetStatus | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get the alarm status
Public method | SetAlarmDO | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080, ADAM-4080D. Set the alarm DO values.
Public method | SetEnable | Support module: ADAM-4080. Set alarm enabled for the specified counter channel.
Public method | SetExtDO | Support module: ADAM-4016. Set the extra DO values. The DO-2 and DO-3 on the module.
Public method | SetHighLatchClear | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the high latch alarm to be cleared
Public method | SetHighLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Set counter high alarm limit
Public method | SetHighMapping | Overloaded. Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the high alarm maps to.
Public method | SetHighMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input high alarm mode
Public method | SetLatchClear | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080D. Set the latch alarm to be cleared.
Public method | SetLimit | Overloaded. Support module: ADAM-4080. Set alarm limit for the specified counter channel.
Public method | SetLocalAlarmConfiguration | Overloaded. Support module: ADAM-5081 Set local alarm mode, type, mapping channel, and limit value.
Public method | SetLocalAlarmLatchClear | Support module: ADAM-5081 Set the local alarm status
Public method | SetLowLatchClear | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the low latch alarm to be cleared
Public method | SetLowLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Set counter low alarm limit
Public method | SetLowMapping | Overloaded. Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the low alarm maps to.
Public method | SetLowMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input low alarm mode
Public method | SetMode | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input alarm mode. After the mode is set, you have to wait 2 seconds to let it takes effect.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetLimit | Overloaded. Support module: ADAM-4080. Get alarm limit for the specified counter channel.
Family method | GetMapping | Get digital output slot and channel that the high alarm maps to.
Family method | GetMode | Overloaded.
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Family method | SetLatchClear | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080D. Set the latch alarm to be cleared.
Family method | SetLimit | Overloaded. Support module: ADAM-4080. Set alarm limit for the specified counter channel.
Family method | SetMapping |
Family method | SetMode | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input alarm mode. After the mode is set, you have to wait 2 seconds to let it takes effect.
Top

Explicit Interface Implementations

Name | Description
Alarm | Overloaded.
Top

See Also

Alarm Class
Advantech.Adam Namespace


Alarm Constructor

Alarm Constructor

Overload List

 | Name | Description
Public method | Alarm (AdamCom) | The Alarm constructor.
Public method | Alarm (AdamControl) | The Alarm constructor.
Public method | Alarm (AdamSocket) | The Alarm constructor.

See Also

Alarm Class
Advantech.Adam Namespace


Alarm Constructor (AdamCom)

Alarm Constructor (AdamCom)
See Also Example
[image]

The Alarm constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public Alarm(
AdamCom i_com
)
C++
public:
Alarm(
AdamCom i_com
) sealed
J#
public Alarm(
AdamCom i_com
)
JScript
public function Alarm(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm Constructor Overload List


Alarm Constructor (AdamControl)

Alarm Constructor (AdamControl)
See Also Example
[image]

The Alarm constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public Alarm(
AdamControl i_control
)
C++
public:
Alarm(
AdamControl i_control
) sealed
J#
public Alarm(
AdamControl i_control
)
JScript
public function Alarm(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object

See Also

Alarm Class
Advantech.Adam Namespace
Alarm Constructor Overload List


Alarm Constructor (AdamSocket)

Alarm Constructor (AdamSocket)
See Also Example
[image]

The Alarm constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public Alarm(
AdamSocket i_socket
)
C++
public:
Alarm(
AdamSocket i_socket
) sealed
J#
public Alarm(
AdamSocket i_socket
)
JScript
public function Alarm(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm Constructor Overload List


Methods

Alarm Methods
[image]

Public Methods

 | Name | Description
Public method | ClearAlarmFlags | Support module: APAX-5080. Clear the alarm flags.
Public method | GetAlarmDO | Support module: ADAM-5081. Get Alarm/DO values. The o_bValues will return the DO values.
Public method | GetAlarmFlags | Support module: APAX-5080. Get the alarm flags.
Public method | GetEnableAlarmDO | Support module: ADAM-4080. Get alarm enabled status and the alarm DO status.
Public method | GetHighLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Get counter high alarm limit
Public method | GetHighMapping | Overloaded. Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the high alarm maps to.
Public method | GetHighMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get analog input High Alarm mode
Public method | GetLimit | Overloaded. Support module: ADAM-4080. Get alarm limit for the specified counter channel.
Public method | GetLocalAlarmConfiguration | Overloaded. Support module: ADAM-5081 Get local alarm mode, type, mapping channel, and limit value.
Public method | GetLocalAlarmStatus | Support module: ADAM-5081 Get the local alarm status
Public method | GetLowLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Get counter low alarm limit
Public method | GetLowMapping | Overloaded. Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the low alarm maps to.
Public method | GetLowMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018. Get analog input low alarm mode
Public method | GetModeAlarmDO | Overloaded. Support module: ADAM-4080D. Get alarm mode and the alarm DO status.
 | GetModeCode | Overloaded. Support module: ADAM-4000. Get the alarm code
 | GetModeIndex | Overloaded. Support module: ADAM-4000. Get the alarm code index
 | GetModeName | Overloaded. Support module: ADAM-4000. Get the alarm mode name
 | GetModeTotal | Overloaded. Support module: ADAM-4000. Get the range total
Public method | GetStatus | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get the alarm status
Public method | SetAlarmDO | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080, ADAM-4080D. Set the alarm DO values.
Public method | SetEnable | Support module: ADAM-4080. Set alarm enabled for the specified counter channel.
Public method | SetExtDO | Support module: ADAM-4016. Set the extra DO values. The DO-2 and DO-3 on the module.
Public method | SetHighLatchClear | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the high latch alarm to be cleared
Public method | SetHighLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Set counter high alarm limit
Public method | SetHighMapping | Overloaded. Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the high alarm maps to.
Public method | SetHighMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input high alarm mode
Public method | SetLatchClear | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080D. Set the latch alarm to be cleared.
Public method | SetLimit | Overloaded. Support module: ADAM-4080. Set alarm limit for the specified counter channel.
Public method | SetLocalAlarmConfiguration | Overloaded. Support module: ADAM-5081 Set local alarm mode, type, mapping channel, and limit value.
Public method | SetLocalAlarmLatchClear | Support module: ADAM-5081 Set the local alarm status
Public method | SetLowLatchClear | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the low latch alarm to be cleared
Public method | SetLowLimit | Overloaded. Support module: ADAM-5080, ADAM-5081. Set counter low alarm limit
Public method | SetLowMapping | Overloaded. Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the low alarm maps to.
Public method | SetLowMode | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input low alarm mode
Public method | SetMode | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input alarm mode. After the mode is set, you have to wait 2 seconds to let it takes effect.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetLimit | Overloaded. Support module: ADAM-4080. Get alarm limit for the specified counter channel.
Family method | GetMapping | Get digital output slot and channel that the high alarm maps to.
Family method | GetMode | Overloaded.
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Family method | SetLatchClear | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080D. Set the latch alarm to be cleared.
Family method | SetLimit | Overloaded. Support module: ADAM-4080. Set alarm limit for the specified counter channel.
Family method | SetMapping |
Family method | SetMode | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input alarm mode. After the mode is set, you have to wait 2 seconds to let it takes effect.
Top

See Also

Alarm Class
Advantech.Adam Namespace


ClearAlarmFlags Method

Alarm.ClearAlarmFlags Method
[image]

Support module: APAX-5080. Clear the alarm flags.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ClearAlarmFlags( _
ByVal i_iSlot As Integer, _
ByVal i_uiChMask As UInt32 _
) As Boolean
C#
public bool ClearAlarmFlags(
int i_iSlot,
uint i_uiChMask
)
C++
public:
bool ClearAlarmFlags(
int i_iSlot,
unsigned int i_uiChMask
) sealed
J#
public bool ClearAlarmFlags(
int i_iSlot,
uint i_uiChMask
)
JScript
public function ClearAlarmFlags(
i_iSlot : int,
i_uiChMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_uiChMask
The channel mask.

Return Value

True if succeed, otherwise false.

See Also

Alarm Class
Advantech.Adam Namespace


GetAlarmDO Method

Alarm.GetAlarmDO Method
[image]

Support module: ADAM-5081. Get Alarm/DO values. The o_bValues will return the DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAlarmDO( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_bValues As Boolean _
) As Boolean
C#
public bool GetAlarmDO(
int i_iSlot,
out bool o_bValues
)
C++
public:
bool GetAlarmDO(
int i_iSlot,
[OutAttribute] bool% o_bValues
) sealed
J#
public bool GetAlarmDO(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool o_bValues
)
JScript
public function GetAlarmDO(
i_iSlot : int,
OutAttribute o_bValues : bool
) : bool

Parameters

i_iSlot
The slot index, base 0.
o_bValues
Array of DI/DO values.

Return Value

True if secceed, otherwise false.

See Also

Alarm Class
Advantech.Adam Namespace


GetAlarmFlags Method

Alarm.GetAlarmFlags Method
[image]

Support module: APAX-5080. Get the alarm flags.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAlarmFlags( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_uiAlarmFlags As UInt32 _
) As Boolean
C#
public bool GetAlarmFlags(
int i_iSlot,
out uint o_uiAlarmFlags
)
C++
public:
bool GetAlarmFlags(
int i_iSlot,
[OutAttribute] unsigned int% o_uiAlarmFlags
) sealed
J#
public bool GetAlarmFlags(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiAlarmFlags
)
JScript
public function GetAlarmFlags(
i_iSlot : int,
OutAttribute o_uiAlarmFlags : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_uiAlarmFlags
The channel mask.

Return Value

True if succeed, otherwise false.

See Also

Alarm Class
Advantech.Adam Namespace


GetEnableAlarmDO Method

Alarm.GetEnableAlarmDO Method
[image]

Support module: ADAM-4080. Get alarm enabled status and the alarm DO status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnableAlarmDO( _
<OutAttribute> ByRef o_bEnable As Boolean, _
<OutAttribute> ByRef o_bAlarmDO As Boolean _
) As Boolean
C#
public bool GetEnableAlarmDO(
out bool o_bEnable,
out bool o_bAlarmDO
)
C++
public:
bool GetEnableAlarmDO(
[OutAttribute] bool% o_bEnable,
[OutAttribute] bool% o_bAlarmDO
) sealed
J#
public bool GetEnableAlarmDO(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlarmDO
)
JScript
public function GetEnableAlarmDO(
OutAttribute o_bEnable : bool,
OutAttribute o_bAlarmDO : bool
) : bool

Parameters

o_bEnable
The array of alarm enabled status.
o_bAlarmDO
The array of DO values.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace


GetHighLimit Method

Alarm.GetHighLimit Method

Support module: ADAM-5080, ADAM-5081. Get counter high alarm limit

Overload List

 | Name | Description
Public method | GetHighLimit (Int32, Int32, Int64) | Support module: ADAM-5080, ADAM-5081. Get counter high alarm limit
Public method | GetHighLimit (Int32, Int32, Single) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input high alarm limit
Public method | GetHighLimit (Int32, Single) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get analog input high alarm limit
Public method | GetHighLimit (Int64) | Support module: ADAM-4080D. Get high alarm limit for counter-0.
Public method | GetHighLimit (Single) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get analog input high alarm limit

See Also

Alarm Class
Advantech.Adam Namespace


GetHighLimit Method (Int32, Int32, Int64)

Alarm.GetHighLimit Method (Int32, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get counter high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lLimit As Long _
) As Boolean
C#
public bool GetHighLimit(
int i_iSlot,
int i_iChannel,
out long o_lLimit
)
C++
public:
bool GetHighLimit(
int i_iSlot,
int i_iChannel,
[OutAttribute] __int64% o_lLimit
) sealed
J#
public bool GetHighLimit(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lLimit
)
JScript
public function GetHighLimit(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_lLimit : long
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_lLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighLimit Overload List


GetHighLimit Method (Int32, Int32, Single)

Alarm.GetHighLimit Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fLimit As Single _
) As Boolean
C#
public bool GetHighLimit(
int i_iSlot,
int i_iChannel,
out float o_fLimit
)
C++
public:
bool GetHighLimit(
int i_iSlot,
int i_iChannel,
[OutAttribute] float% o_fLimit
) sealed
J#
public bool GetHighLimit(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fLimit
)
JScript
public function GetHighLimit(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_fLimit : float
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighLimit Overload List


GetHighLimit Method (Int32, Single)

Alarm.GetHighLimit Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get analog input high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighLimit( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fLimit As Single _
) As Boolean
C#
public bool GetHighLimit(
int i_iChannel,
out float o_fLimit
)
C++
public:
bool GetHighLimit(
int i_iChannel,
[OutAttribute] float% o_fLimit
) sealed
J#
public bool GetHighLimit(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fLimit
)
JScript
public function GetHighLimit(
i_iChannel : int,
OutAttribute o_fLimit : float
) : bool

Parameters

i_iChannel
The channel index.
o_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighLimit Overload List


GetHighLimit Method (Int64)

Alarm.GetHighLimit Method (Int64)
See Also Example
[image]

Support module: ADAM-4080D. Get high alarm limit for counter-0.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighLimit( _
<OutAttribute> ByRef o_lValue As Long _
) As Boolean
C#
public bool GetHighLimit(
out long o_lValue
)
C++
public:
bool GetHighLimit(
[OutAttribute] __int64% o_lValue
) sealed
J#
public bool GetHighLimit(
/** @attribute OutAttribute() */ /** @ref */ long o_lValue
)
JScript
public function GetHighLimit(
OutAttribute o_lValue : long
) : bool

Parameters

o_lValue
The high alarm limit.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighLimit Overload List


GetHighLimit Method (Single)

Alarm.GetHighLimit Method (Single)
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get analog input high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighLimit( _
<OutAttribute> ByRef o_fLimit As Single _
) As Boolean
C#
public bool GetHighLimit(
out float o_fLimit
)
C++
public:
bool GetHighLimit(
[OutAttribute] float% o_fLimit
) sealed
J#
public bool GetHighLimit(
/** @attribute OutAttribute() */ /** @ref */ float o_fLimit
)
JScript
public function GetHighLimit(
OutAttribute o_fLimit : float
) : bool

Parameters

o_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighLimit Overload List


GetHighMapping Method

Alarm.GetHighMapping Method

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the high alarm maps to.

Overload List

 | Name | Description
Public method | GetHighMapping (Int32, Int32, Int32, Int32) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the high alarm maps to.
Public method | GetHighMapping (Int32, Int32) | Support module: ADAM-6017, ADAM-6018. Get digital output slot and channel that the high alarm maps to.

See Also

Alarm Class
Advantech.Adam Namespace


GetHighMapping Method (Int32, Int32, Int32, Int32)

Alarm.GetHighMapping Method (Int32, Int32, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the high alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighMapping( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iSlot As Integer, _
<OutAttribute> ByRef o_iChannel As Integer _
) As Boolean
C#
public bool GetHighMapping(
int i_iSlot,
int i_iChannel,
out int o_iSlot,
out int o_iChannel
)
C++
public:
bool GetHighMapping(
int i_iSlot,
int i_iChannel,
[OutAttribute] int% o_iSlot,
[OutAttribute] int% o_iChannel
) sealed
J#
public bool GetHighMapping(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannel
)
JScript
public function GetHighMapping(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_iSlot : int,
OutAttribute o_iChannel : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_iSlot
The mapped digital output slot. If there is no mapping, this value will be -1.
o_iChannel
The mapped digital output channel. If there is no mapping, this value will be -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighMapping Overload List


GetHighMapping Method (Int32, Int32)

Alarm.GetHighMapping Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-6017, ADAM-6018. Get digital output slot and channel that the high alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighMapping( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iChannel As Integer _
) As Boolean
C#
public bool GetHighMapping(
int i_iChannel,
out int o_iChannel
)
C++
public:
bool GetHighMapping(
int i_iChannel,
[OutAttribute] int% o_iChannel
) sealed
J#
public bool GetHighMapping(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannel
)
JScript
public function GetHighMapping(
i_iChannel : int,
OutAttribute o_iChannel : int
) : bool

Parameters

i_iChannel
The channel index.
o_iChannel
The mapped digital output channel. If there is no mapping, this value will be -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighMapping Overload List


GetHighMode Method

Alarm.GetHighMode Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get analog input High Alarm mode

Overload List

 | Name | Description
Public method | GetHighMode (Int32, Adam_AIAlarmMode) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get analog input High Alarm mode
Public method | GetHighMode (Int32, Int32, Adam_AIAlarmMode) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input High Alarm mode
Public method | GetHighMode (Int32, Int32, Adam5000_CounterAlarmMode) | Support module: ADAM-5080, ADAM-5081. Get counter high alarm mode

See Also

Alarm Class
Advantech.Adam Namespace


GetHighMode Method (Int32, Adam_AIAlarmMode)

Alarm.GetHighMode Method (Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get analog input High Alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighMode( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool GetHighMode(
int i_iChannel,
out Adam_AIAlarmMode o_mode
)
C++
public:
bool GetHighMode(
int i_iChannel,
[OutAttribute] Adam_AIAlarmMode% o_mode
) sealed
J#
public bool GetHighMode(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ Adam_AIAlarmMode o_mode
)
JScript
public function GetHighMode(
i_iChannel : int,
OutAttribute o_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iChannel
The channel index.
o_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighMode Overload List


GetHighMode Method (Int32, Int32, Adam_AIAlarmMode)

Alarm.GetHighMode Method (Int32, Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input High Alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool GetHighMode(
int i_iSlot,
int i_iChannel,
out Adam_AIAlarmMode o_mode
)
C++
public:
bool GetHighMode(
int i_iSlot,
int i_iChannel,
[OutAttribute] Adam_AIAlarmMode% o_mode
) sealed
J#
public bool GetHighMode(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ Adam_AIAlarmMode o_mode
)
JScript
public function GetHighMode(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighMode Overload List


GetHighMode Method (Int32, Int32, Adam5000_CounterAlarmMode)

Alarm.GetHighMode Method (Int32, Int32, Adam5000_CounterAlarmMode)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get counter high alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHighMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_mode As Adam5000_CounterAlarmMode _
) As Boolean
C#
public bool GetHighMode(
int i_iSlot,
int i_iChannel,
out Adam5000_CounterAlarmMode o_mode
)
C++
public:
bool GetHighMode(
int i_iSlot,
int i_iChannel,
[OutAttribute] Adam5000_CounterAlarmMode% o_mode
) sealed
J#
public bool GetHighMode(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ Adam5000_CounterAlarmMode o_mode
)
JScript
public function GetHighMode(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_mode : Adam5000_CounterAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetHighMode Overload List


GetLimit Method

Alarm.GetLimit Method

Support module: ADAM-4080. Get alarm limit for the specified counter channel.

Overload List

 | Name | Description
Family method | GetLimit (Int32, Int32, Int32, Int64) |
Family method | GetLimit (Int32, Int32, Int32, Single) |
Public method | GetLimit (Int32, Int64) | Support module: ADAM-4080. Get alarm limit for the specified counter channel.
Public method | GetLimit (Int32, Single, Single) | Support module: ADAM-4018M. Get analog input high and low alarm limit

See Also

Alarm Class
Advantech.Adam Namespace


GetLimit Method (Int32, Int32, Int32, Int64)

Alarm.GetLimit Method (Int32, Int32, Int32, Int64)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
<OutAttribute> ByRef o_lLimit As Long _
) As Boolean
C#
protected bool GetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
out long o_lLimit
)
C++
protected:
bool GetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
[OutAttribute] __int64% o_lLimit
) sealed
J#
protected bool GetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
/** @attribute OutAttribute() */ /** @ref */ long o_lLimit
)
JScript
protected function GetLimit(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
OutAttribute o_lLimit : long
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
o_lLimit

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLimit Overload List


GetLimit Method (Int32, Int32, Int32, Single)

Alarm.GetLimit Method (Int32, Int32, Int32, Single)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
<OutAttribute> ByRef o_fLimit As Single _
) As Boolean
C#
protected bool GetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
out float o_fLimit
)
C++
protected:
bool GetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
[OutAttribute] float% o_fLimit
) sealed
J#
protected bool GetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
/** @attribute OutAttribute() */ /** @ref */ float o_fLimit
)
JScript
protected function GetLimit(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
OutAttribute o_fLimit : float
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
o_fLimit

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLimit Overload List


GetLimit Method (Int32, Int64)

Alarm.GetLimit Method (Int32, Int64)
See Also Example
[image]

Support module: ADAM-4080. Get alarm limit for the specified counter channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLimit( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lValue As Long _
) As Boolean
C#
public bool GetLimit(
int i_iChannel,
out long o_lValue
)
C++
public:
bool GetLimit(
int i_iChannel,
[OutAttribute] __int64% o_lValue
) sealed
J#
public bool GetLimit(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lValue
)
JScript
public function GetLimit(
i_iChannel : int,
OutAttribute o_lValue : long
) : bool

Parameters

i_iChannel
The channel index. The range is between 0~1.
o_lValue
The alarm limit.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLimit Overload List


GetLimit Method (Int32, Single, Single)

Alarm.GetLimit Method (Int32, Single, Single)
See Also Example
[image]

Support module: ADAM-4018M. Get analog input high and low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLimit( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fHighLimit As Single, _
<OutAttribute> ByRef o_fLowLimit As Single _
) As Boolean
C#
public bool GetLimit(
int i_iChannel,
out float o_fHighLimit,
out float o_fLowLimit
)
C++
public:
bool GetLimit(
int i_iChannel,
[OutAttribute] float% o_fHighLimit,
[OutAttribute] float% o_fLowLimit
) sealed
J#
public bool GetLimit(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fHighLimit,
/** @attribute OutAttribute() */ /** @ref */ float o_fLowLimit
)
JScript
public function GetLimit(
i_iChannel : int,
OutAttribute o_fHighLimit : float,
OutAttribute o_fLowLimit : float
) : bool

Parameters

i_iChannel
The channel index. The range is between 0~7.
o_fHighLimit
The high alarm limit value.
o_fLowLimit
The low alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLimit Overload List


GetLocalAlarmConfiguration Method

Alarm.GetLocalAlarmConfiguration Method

Support module: ADAM-5081 Get local alarm mode, type, mapping channel, and limit value.

Overload List

 | Name | Description
Public method | GetLocalAlarmConfiguration (Int32, Int32, Adam5000_CounterAlarmMode, Adam_LocalAlarmType, Int32, Int64) | Support module: ADAM-5081 Get local alarm mode, type, mapping channel, and limit value.
Public method | GetLocalAlarmConfiguration (Int32, Int32, Boolean, Boolean, Byte, Int32, UInt32, Byte, UInt32) | Support module: APAX-5080 Get local alarm mode, type, mapping channel, and limit value.

See Also

Alarm Class
Advantech.Adam Namespace


GetLocalAlarmConfiguration Method (Int32, Int32, Adam5000_CounterAlarmMode, Adam_LocalAlarmType, Int32, Int64)

Alarm.GetLocalAlarmConfiguration Method (Int32, Int32, Adam5000_CounterAlarmMode, Adam_LocalAlarmType, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5081 Get local alarm mode, type, mapping channel, and limit value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLocalAlarmConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_mode As Adam5000_CounterAlarmMode, _
<OutAttribute> ByRef o_type As Adam_LocalAlarmType, _
<OutAttribute> ByRef o_iChannelMap As Integer, _
<OutAttribute> ByRef o_lLimVal As Long _
) As Boolean
C#
public bool GetLocalAlarmConfiguration(
int i_iSlot,
int i_iChannel,
out Adam5000_CounterAlarmMode o_mode,
out Adam_LocalAlarmType o_type,
out int o_iChannelMap,
out long o_lLimVal
)
C++
public:
bool GetLocalAlarmConfiguration(
int i_iSlot,
int i_iChannel,
[OutAttribute] Adam5000_CounterAlarmMode% o_mode,
[OutAttribute] Adam_LocalAlarmType% o_type,
[OutAttribute] int% o_iChannelMap,
[OutAttribute] __int64% o_lLimVal
) sealed
J#
public bool GetLocalAlarmConfiguration(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ Adam5000_CounterAlarmMode o_mode,
/** @attribute OutAttribute() */ /** @ref */ Adam_LocalAlarmType o_type,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannelMap,
/** @attribute OutAttribute() */ /** @ref */ long o_lLimVal
)
JScript
public function GetLocalAlarmConfiguration(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_mode : Adam5000_CounterAlarmMode,
OutAttribute o_type : Adam_LocalAlarmType,
OutAttribute o_iChannelMap : int,
OutAttribute o_lLimVal : long
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The local alarm channel index.
o_mode
The local alarm mode.
o_type
The local alarm type.
o_iChannelMap
The mapping channel index.
o_lLimVal
The local alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLocalAlarmConfiguration Overload List


GetLocalAlarmConfiguration Method (Int32, Int32, Boolean, Boolean, Byte, Int32, UInt32, Byte, UInt32)

Alarm.GetLocalAlarmConfiguration Method (Int32, Int32, Boolean, Boolean, Byte, Int32, UInt32, Byte, UInt32)
See Also Example
[image]

Support module: APAX-5080 Get local alarm mode, type, mapping channel, and limit value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLocalAlarmConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iAlarmIndex As Integer, _
<OutAttribute> ByRef o_bAlarmEnable As Boolean, _
<OutAttribute> ByRef o_bAutoReloadEn As Boolean, _
<OutAttribute> ByRef o_byAlarmType As Byte, _
<OutAttribute> ByRef o_iChannelMap As Integer, _
<OutAttribute> ByRef o_uiLimVal As UInt32, _
<OutAttribute> ByRef o_byDoType As Byte, _
<OutAttribute> ByRef o_uiDoPulseWidth As UInt32 _
) As Boolean
C#
public bool GetLocalAlarmConfiguration(
int i_iSlot,
int i_iAlarmIndex,
out bool o_bAlarmEnable,
out bool o_bAutoReloadEn,
out byte o_byAlarmType,
out int o_iChannelMap,
out uint o_uiLimVal,
out byte o_byDoType,
out uint o_uiDoPulseWidth
)
C++
public:
bool GetLocalAlarmConfiguration(
int i_iSlot,
int i_iAlarmIndex,
[OutAttribute] bool% o_bAlarmEnable,
[OutAttribute] bool% o_bAutoReloadEn,
[OutAttribute] char% o_byAlarmType,
[OutAttribute] int% o_iChannelMap,
[OutAttribute] unsigned int% o_uiLimVal,
[OutAttribute] char% o_byDoType,
[OutAttribute] unsigned int% o_uiDoPulseWidth
) sealed
J#
public bool GetLocalAlarmConfiguration(
int i_iSlot,
int i_iAlarmIndex,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlarmEnable,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAutoReloadEn,
/** @attribute OutAttribute() */ /** @ref */ byte o_byAlarmType,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannelMap,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiLimVal,
/** @attribute OutAttribute() */ /** @ref */ byte o_byDoType,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiDoPulseWidth
)
JScript
public function GetLocalAlarmConfiguration(
i_iSlot : int,
i_iAlarmIndex : int,
OutAttribute o_bAlarmEnable : bool,
OutAttribute o_bAutoReloadEn : bool,
OutAttribute o_byAlarmType : Byte,
OutAttribute o_iChannelMap : int,
OutAttribute o_uiLimVal : UInt32,
OutAttribute o_byDoType : Byte,
OutAttribute o_uiDoPulseWidth : UInt32
) : bool

Parameters

i_iSlot
The slot index.
i_iAlarmIndex
The local alarm index.
o_bAlarmEnable
The local alarm enalbe flag.
o_bAutoReloadEn
The alarm auto reload flag.
o_byAlarmType
The local alarm type.
o_iChannelMap
The mapping counter channel index.
o_uiLimVal
The local alarm limit value.
o_byDoType
The DO behavior type.
o_uiDoPulseWidth
The DO pulse width.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLocalAlarmConfiguration Overload List


GetLocalAlarmStatus Method

Alarm.GetLocalAlarmStatus Method
[image]

Support module: ADAM-5081 Get the local alarm status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLocalAlarmStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bStatus As Boolean _
) As Boolean
C#
public bool GetLocalAlarmStatus(
int i_iSlot,
int i_iChannel,
out bool o_bStatus
)
C++
public:
bool GetLocalAlarmStatus(
int i_iSlot,
int i_iChannel,
[OutAttribute] bool% o_bStatus
) sealed
J#
public bool GetLocalAlarmStatus(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bStatus
)
JScript
public function GetLocalAlarmStatus(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_bStatus : bool
) : bool

Parameters

i_iSlot
The local alarm slot index.
i_iChannel
The local alarm channel index.
o_bStatus
The local alarm status

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace


GetLowLimit Method

Alarm.GetLowLimit Method

Support module: ADAM-5080, ADAM-5081. Get counter low alarm limit

Overload List

 | Name | Description
Public method | GetLowLimit (Int32, Int32, Int64) | Support module: ADAM-5080, ADAM-5081. Get counter low alarm limit
Public method | GetLowLimit (Int32, Int32, Single) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input low alarm limit
Public method | GetLowLimit (Int32, Single) | Support module: ADAM-6015, ADAM-6017, ADAM-6018. Get analog input low alarm limit
Public method | GetLowLimit (Int64) | Support module: ADAM-4080D. Get low alarm limit for counter-0.
Public method | GetLowLimit (Single) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get analog input low alarm limit

See Also

Alarm Class
Advantech.Adam Namespace


GetLowLimit Method (Int32, Int32, Int64)

Alarm.GetLowLimit Method (Int32, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get counter low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lLimit As Long _
) As Boolean
C#
public bool GetLowLimit(
int i_iSlot,
int i_iChannel,
out long o_lLimit
)
C++
public:
bool GetLowLimit(
int i_iSlot,
int i_iChannel,
[OutAttribute] __int64% o_lLimit
) sealed
J#
public bool GetLowLimit(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lLimit
)
JScript
public function GetLowLimit(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_lLimit : long
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_lLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowLimit Overload List


GetLowLimit Method (Int32, Int32, Single)

Alarm.GetLowLimit Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fLimit As Single _
) As Boolean
C#
public bool GetLowLimit(
int i_iSlot,
int i_iChannel,
out float o_fLimit
)
C++
public:
bool GetLowLimit(
int i_iSlot,
int i_iChannel,
[OutAttribute] float% o_fLimit
) sealed
J#
public bool GetLowLimit(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fLimit
)
JScript
public function GetLowLimit(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_fLimit : float
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowLimit Overload List


GetLowLimit Method (Int32, Single)

Alarm.GetLowLimit Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018. Get analog input low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowLimit( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fLimit As Single _
) As Boolean
C#
public bool GetLowLimit(
int i_iChannel,
out float o_fLimit
)
C++
public:
bool GetLowLimit(
int i_iChannel,
[OutAttribute] float% o_fLimit
) sealed
J#
public bool GetLowLimit(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fLimit
)
JScript
public function GetLowLimit(
i_iChannel : int,
OutAttribute o_fLimit : float
) : bool

Parameters

i_iChannel
The channel index.
o_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowLimit Overload List


GetLowLimit Method (Int64)

Alarm.GetLowLimit Method (Int64)
See Also Example
[image]

Support module: ADAM-4080D. Get low alarm limit for counter-0.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowLimit( _
<OutAttribute> ByRef o_lValue As Long _
) As Boolean
C#
public bool GetLowLimit(
out long o_lValue
)
C++
public:
bool GetLowLimit(
[OutAttribute] __int64% o_lValue
) sealed
J#
public bool GetLowLimit(
/** @attribute OutAttribute() */ /** @ref */ long o_lValue
)
JScript
public function GetLowLimit(
OutAttribute o_lValue : long
) : bool

Parameters

o_lValue
The low alarm limit.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowLimit Overload List


GetLowLimit Method (Single)

Alarm.GetLowLimit Method (Single)
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get analog input low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowLimit( _
<OutAttribute> ByRef o_fLimit As Single _
) As Boolean
C#
public bool GetLowLimit(
out float o_fLimit
)
C++
public:
bool GetLowLimit(
[OutAttribute] float% o_fLimit
) sealed
J#
public bool GetLowLimit(
/** @attribute OutAttribute() */ /** @ref */ float o_fLimit
)
JScript
public function GetLowLimit(
OutAttribute o_fLimit : float
) : bool

Parameters

o_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowLimit Overload List


GetLowMapping Method

Alarm.GetLowMapping Method

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the low alarm maps to.

Overload List

 | Name | Description
Public method | GetLowMapping (Int32, Int32, Int32, Int32) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the low alarm maps to.
Public method | GetLowMapping (Int32, Int32) | Support module: ADAM-6017, ADAM-6018. Get digital output slot and channel that the low alarm maps to.

See Also

Alarm Class
Advantech.Adam Namespace


GetLowMapping Method (Int32, Int32, Int32, Int32)

Alarm.GetLowMapping Method (Int32, Int32, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get digital output slot and channel that the low alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowMapping( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iSlot As Integer, _
<OutAttribute> ByRef o_iChannel As Integer _
) As Boolean
C#
public bool GetLowMapping(
int i_iSlot,
int i_iChannel,
out int o_iSlot,
out int o_iChannel
)
C++
public:
bool GetLowMapping(
int i_iSlot,
int i_iChannel,
[OutAttribute] int% o_iSlot,
[OutAttribute] int% o_iChannel
) sealed
J#
public bool GetLowMapping(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannel
)
JScript
public function GetLowMapping(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_iSlot : int,
OutAttribute o_iChannel : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_iSlot
The mapped digital output slot. If there is no mapping, this value will be -1.
o_iChannel
The mapped digital output channel. If there is no mapping, this value will be -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowMapping Overload List


GetLowMapping Method (Int32, Int32)

Alarm.GetLowMapping Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-6017, ADAM-6018. Get digital output slot and channel that the low alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowMapping( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iChannel As Integer _
) As Boolean
C#
public bool GetLowMapping(
int i_iChannel,
out int o_iChannel
)
C++
public:
bool GetLowMapping(
int i_iChannel,
[OutAttribute] int% o_iChannel
) sealed
J#
public bool GetLowMapping(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannel
)
JScript
public function GetLowMapping(
i_iChannel : int,
OutAttribute o_iChannel : int
) : bool

Parameters

i_iChannel
The channel index.
o_iChannel
The mapped digital output channel. If there is no mapping, this value will be -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowMapping Overload List


GetLowMode Method

Alarm.GetLowMode Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018. Get analog input low alarm mode

Overload List

 | Name | Description
Public method | GetLowMode (Int32, Adam_AIAlarmMode) | Support module: ADAM-6015, ADAM-6017, ADAM-6018. Get analog input low alarm mode
Public method | GetLowMode (Int32, Int32, Adam_AIAlarmMode) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input low alarm mode
Public method | GetLowMode (Int32, Int32, Adam5000_CounterAlarmMode) | Support module: ADAM-5080, ADAM-5081. Get counter low alarm mode

See Also

Alarm Class
Advantech.Adam Namespace


GetLowMode Method (Int32, Adam_AIAlarmMode)

Alarm.GetLowMode Method (Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018. Get analog input low alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowMode( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool GetLowMode(
int i_iChannel,
out Adam_AIAlarmMode o_mode
)
C++
public:
bool GetLowMode(
int i_iChannel,
[OutAttribute] Adam_AIAlarmMode% o_mode
) sealed
J#
public bool GetLowMode(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ Adam_AIAlarmMode o_mode
)
JScript
public function GetLowMode(
i_iChannel : int,
OutAttribute o_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iChannel
The channel index.
o_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowMode Overload List


GetLowMode Method (Int32, Int32, Adam_AIAlarmMode)

Alarm.GetLowMode Method (Int32, Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Get analog input low alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool GetLowMode(
int i_iSlot,
int i_iChannel,
out Adam_AIAlarmMode o_mode
)
C++
public:
bool GetLowMode(
int i_iSlot,
int i_iChannel,
[OutAttribute] Adam_AIAlarmMode% o_mode
) sealed
J#
public bool GetLowMode(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ Adam_AIAlarmMode o_mode
)
JScript
public function GetLowMode(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowMode Overload List


GetLowMode Method (Int32, Int32, Adam5000_CounterAlarmMode)

Alarm.GetLowMode Method (Int32, Int32, Adam5000_CounterAlarmMode)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get counter low alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLowMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_mode As Adam5000_CounterAlarmMode _
) As Boolean
C#
public bool GetLowMode(
int i_iSlot,
int i_iChannel,
out Adam5000_CounterAlarmMode o_mode
)
C++
public:
bool GetLowMode(
int i_iSlot,
int i_iChannel,
[OutAttribute] Adam5000_CounterAlarmMode% o_mode
) sealed
J#
public bool GetLowMode(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ Adam5000_CounterAlarmMode o_mode
)
JScript
public function GetLowMode(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_mode : Adam5000_CounterAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetLowMode Overload List


GetMapping Method

Alarm.GetMapping Method
[image]

Get digital output slot and channel that the high alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetMapping( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
<OutAttribute> ByRef o_iSlot As Integer, _
<OutAttribute> ByRef o_iChannel As Integer _
) As Boolean
C#
protected bool GetMapping(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
out int o_iSlot,
out int o_iChannel
)
C++
protected:
bool GetMapping(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
[OutAttribute] int% o_iSlot,
[OutAttribute] int% o_iChannel
) sealed
J#
protected bool GetMapping(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
/** @attribute OutAttribute() */ /** @ref */ int o_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannel
)
JScript
protected function GetMapping(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
OutAttribute o_iSlot : int,
OutAttribute o_iChannel : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_iHighLow
0: Low, 1: High
o_iSlot
The mapped digital output slot. If there is no mapping, this value will be -1.
o_iChannel
The mapped digital output channel. If there is no mapping, this value will be -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace


GetMode Method

Alarm.GetMode Method

Overload List

 | Name | Description
Family method | GetMode (Int32, Int32, Int32, Adam_AIAlarmMode) |
Family method | GetMode (Int32, Int32, Int32, Adam5000_CounterAlarmMode) |

See Also

Alarm Class
Advantech.Adam Namespace


GetMode Method (Int32, Int32, Int32, Adam_AIAlarmMode)

Alarm.GetMode Method (Int32, Int32, Int32, Adam_AIAlarmMode)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
<OutAttribute> ByRef o_mode As Adam_AIAlarmMode _
) As Boolean
C#
protected bool GetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
out Adam_AIAlarmMode o_mode
)
C++
protected:
bool GetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
[OutAttribute] Adam_AIAlarmMode% o_mode
) sealed
J#
protected bool GetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
/** @attribute OutAttribute() */ /** @ref */ Adam_AIAlarmMode o_mode
)
JScript
protected function GetMode(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
OutAttribute o_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
0: low, 1: high
o_mode

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetMode Overload List


GetMode Method (Int32, Int32, Int32, Adam5000_CounterAlarmMode)

Alarm.GetMode Method (Int32, Int32, Int32, Adam5000_CounterAlarmMode)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
<OutAttribute> ByRef o_mode As Adam5000_CounterAlarmMode _
) As Boolean
C#
protected bool GetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
out Adam5000_CounterAlarmMode o_mode
)
C++
protected:
bool GetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
[OutAttribute] Adam5000_CounterAlarmMode% o_mode
) sealed
J#
protected bool GetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
/** @attribute OutAttribute() */ /** @ref */ Adam5000_CounterAlarmMode o_mode
)
JScript
protected function GetMode(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
OutAttribute o_mode : Adam5000_CounterAlarmMode
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
0: low, 1: high
o_mode

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetMode Overload List


GetModeAlarmDO Method

Alarm.GetModeAlarmDO Method

Support module: ADAM-4080D. Get alarm mode and the alarm DO status.

Overload List

 | Name | Description
Public method | GetModeAlarmDO (Adam4000_CounterAlarmMode, Boolean) | Support module: ADAM-4080D. Get alarm mode and the alarm DO status.
Public method | GetModeAlarmDO (Int32, Adam_AIAlarmMode, Boolean) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get analog input alarm mode and the alarm DO status.

See Also

Alarm Class
Advantech.Adam Namespace


GetModeAlarmDO Method (Adam4000_CounterAlarmMode, Boolean)

Alarm.GetModeAlarmDO Method (Adam4000_CounterAlarmMode, Boolean)
See Also Example
[image]

Support module: ADAM-4080D. Get alarm mode and the alarm DO status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModeAlarmDO( _
<OutAttribute> ByRef o_mode As Adam4000_CounterAlarmMode, _
<OutAttribute> ByRef o_bAlarmDO As Boolean _
) As Boolean
C#
public bool GetModeAlarmDO(
out Adam4000_CounterAlarmMode o_mode,
out bool o_bAlarmDO
)
C++
public:
bool GetModeAlarmDO(
[OutAttribute] Adam4000_CounterAlarmMode% o_mode,
[OutAttribute] bool% o_bAlarmDO
) sealed
J#
public bool GetModeAlarmDO(
/** @attribute OutAttribute() */ /** @ref */ Adam4000_CounterAlarmMode o_mode,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlarmDO
)
JScript
public function GetModeAlarmDO(
OutAttribute o_mode : Adam4000_CounterAlarmMode,
OutAttribute o_bAlarmDO : bool
) : bool

Parameters

o_mode
The alarm mode of counter-0. Only the counter-0 has alarm.
o_bAlarmDO
The array of DO values.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeAlarmDO Overload List


GetModeAlarmDO Method (Int32, Adam_AIAlarmMode, Boolean)

Alarm.GetModeAlarmDO Method (Int32, Adam_AIAlarmMode, Boolean)
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get analog input alarm mode and the alarm DO status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModeAlarmDO( _
ByVal i_iDOTotal As Integer, _
<OutAttribute> ByRef o_mode As Adam_AIAlarmMode, _
<OutAttribute> ByRef o_bAlarmDO As Boolean _
) As Boolean
C#
public bool GetModeAlarmDO(
int i_iDOTotal,
out Adam_AIAlarmMode o_mode,
out bool o_bAlarmDO
)
C++
public:
bool GetModeAlarmDO(
int i_iDOTotal,
[OutAttribute] Adam_AIAlarmMode% o_mode,
[OutAttribute] bool% o_bAlarmDO
) sealed
J#
public bool GetModeAlarmDO(
int i_iDOTotal,
/** @attribute OutAttribute() */ /** @ref */ Adam_AIAlarmMode o_mode,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlarmDO
)
JScript
public function GetModeAlarmDO(
i_iDOTotal : int,
OutAttribute o_mode : Adam_AIAlarmMode,
OutAttribute o_bAlarmDO : bool
) : bool

Parameters

i_iDOTotal
The total of the DO on the module. Must be 4 for ADAM-4016, and 2 for the others.
o_mode
The alarm mode.
o_bAlarmDO
The array of DO values.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeAlarmDO Overload List


GetModeCode Method

Alarm.GetModeCode Method

Support module: ADAM-4000. Get the alarm code

Overload List

Name | Description
GetModeCode (Adam4000Type, Int32) | Support module: ADAM-4000. Get the alarm code
GetModeCode (Adam5000Type, Int32) | Support module: ADAM-5000. Get the alarm code
GetModeCode (Adam6000Type, Int32) | Support module: ADAM-6000. Get the alarm code

See Also

Alarm Class
Advantech.Adam Namespace


GetModeCode Method (Adam4000Type, Int32)

Alarm.GetModeCode Method (Adam4000Type, Int32)
See Also Example
[image]

Support module: ADAM-4000. Get the alarm code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeCode( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetModeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
C++
public:
static char GetModeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
J#
public static byte GetModeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
JScript
public static function GetModeCode(
adam4000Type : Adam4000Type,
i_iIndex : int
) : Byte

Parameters

adam4000Type
ADAM-4000 type
i_iIndex
The alarm code index

Return Value

Return range code if success, otherwise, return 255

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeCode Overload List


GetModeCode Method (Adam5000Type, Int32)

Alarm.GetModeCode Method (Adam5000Type, Int32)
See Also Example
[image]

Support module: ADAM-5000. Get the alarm code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeCode( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetModeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
C++
public:
static char GetModeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
J#
public static byte GetModeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
JScript
public static function GetModeCode(
adam5000Type : Adam5000Type,
i_iIndex : int
) : Byte

Parameters

adam5000Type
ADAM-5000 type
i_iIndex
The alarm code index

Return Value

Return range code if success, otherwise, return 255

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeCode Overload List


GetModeCode Method (Adam6000Type, Int32)

Alarm.GetModeCode Method (Adam6000Type, Int32)
See Also Example
[image]

Support module: ADAM-6000. Get the alarm code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeCode( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetModeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
C++
public:
static char GetModeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
J#
public static byte GetModeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
JScript
public static function GetModeCode(
adam6000Type : Adam6000Type,
i_iIndex : int
) : Byte

Parameters

adam6000Type
ADAM-6000 type
i_iIndex
The alarm code index

Return Value

Return range code if success, otherwise, return 255

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeCode Overload List


GetModeIndex Method

Alarm.GetModeIndex Method

Support module: ADAM-4000. Get the alarm code index

Overload List

Name | Description
GetModeIndex (Adam4000Type, Byte) | Support module: ADAM-4000. Get the alarm code index
GetModeIndex (Adam5000Type, Byte) | Support module: ADAM-5000. Get the alarm code index
GetModeIndex (Adam6000Type, Byte) | Support module: ADAM-6000. Get the alarm code index

See Also

Alarm Class
Advantech.Adam Namespace


GetModeIndex Method (Adam4000Type, Byte)

Alarm.GetModeIndex Method (Adam4000Type, Byte)
See Also Example
[image]

Support module: ADAM-4000. Get the alarm code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeIndex( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byMode As Byte _
) As Integer
C#
public static int GetModeIndex(
Adam4000Type adam4000Type,
byte i_byMode
)
C++
public:
static int GetModeIndex(
Adam4000Type adam4000Type,
char i_byMode
)
J#
public static int GetModeIndex(
Adam4000Type adam4000Type,
byte i_byMode
)
JScript
public static function GetModeIndex(
adam4000Type : Adam4000Type,
i_byMode : Byte
) : int

Parameters

adam4000Type
ADAM-4000 type
i_byMode
The alarm code.

Return Value

Return range code index if success, otherwise, return -1

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeIndex Overload List


GetModeIndex Method (Adam5000Type, Byte)

Alarm.GetModeIndex Method (Adam5000Type, Byte)
See Also Example
[image]

Support module: ADAM-5000. Get the alarm code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeIndex( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byMode As Byte _
) As Integer
C#
public static int GetModeIndex(
Adam5000Type adam5000Type,
byte i_byMode
)
C++
public:
static int GetModeIndex(
Adam5000Type adam5000Type,
char i_byMode
)
J#
public static int GetModeIndex(
Adam5000Type adam5000Type,
byte i_byMode
)
JScript
public static function GetModeIndex(
adam5000Type : Adam5000Type,
i_byMode : Byte
) : int

Parameters

adam5000Type
ADAM-5000 type
i_byMode
The alarm code.

Return Value

Return range code index if success, otherwise, return -1

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeIndex Overload List


GetModeIndex Method (Adam6000Type, Byte)

Alarm.GetModeIndex Method (Adam6000Type, Byte)
See Also Example
[image]

Support module: ADAM-6000. Get the alarm code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeIndex( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byMode As Byte _
) As Integer
C#
public static int GetModeIndex(
Adam6000Type adam6000Type,
byte i_byMode
)
C++
public:
static int GetModeIndex(
Adam6000Type adam6000Type,
char i_byMode
)
J#
public static int GetModeIndex(
Adam6000Type adam6000Type,
byte i_byMode
)
JScript
public static function GetModeIndex(
adam6000Type : Adam6000Type,
i_byMode : Byte
) : int

Parameters

adam6000Type
ADAM-6000 type
i_byMode
The alarm code.

Return Value

Return range code index if success, otherwise, return -1

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeIndex Overload List


GetModeName Method

Alarm.GetModeName Method

Support module: ADAM-4000. Get the alarm mode name

Overload List

Name | Description
GetModeName (Adam4000Type, Byte) | Support module: ADAM-4000. Get the alarm mode name
GetModeName (Adam5000Type, Byte) | Support module: ADAM-5000. Get the alarm mode name
GetModeName (Adam6000Type, Byte) | Support module: ADAM-6000. Get the alarm mode name

See Also

Alarm Class
Advantech.Adam Namespace


GetModeName Method (Adam4000Type, Byte)

Alarm.GetModeName Method (Adam4000Type, Byte)
See Also Example
[image]

Support module: ADAM-4000. Get the alarm mode name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetModeName(
Adam4000Type adam4000Type,
byte i_byMode
)
C++
public:
static String GetModeName(
Adam4000Type adam4000Type,
char i_byMode
)
J#
public static string GetModeName(
Adam4000Type adam4000Type,
byte i_byMode
)
JScript
public static function GetModeName(
adam4000Type : Adam4000Type,
i_byMode : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byMode
The mode code.

Return Value

Return range code if success, otherwise, return empty string

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeName Overload List


GetModeName Method (Adam5000Type, Byte)

Alarm.GetModeName Method (Adam5000Type, Byte)
See Also Example
[image]

Support module: ADAM-5000. Get the alarm mode name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetModeName(
Adam5000Type adam5000Type,
byte i_byMode
)
C++
public:
static String GetModeName(
Adam5000Type adam5000Type,
char i_byMode
)
J#
public static string GetModeName(
Adam5000Type adam5000Type,
byte i_byMode
)
JScript
public static function GetModeName(
adam5000Type : Adam5000Type,
i_byMode : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byMode
The mode code.

Return Value

Return range code if success, otherwise, return empty string

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeName Overload List


GetModeName Method (Adam6000Type, Byte)

Alarm.GetModeName Method (Adam6000Type, Byte)
See Also Example
[image]

Support module: ADAM-6000. Get the alarm mode name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetModeName(
Adam6000Type adam6000Type,
byte i_byMode
)
C++
public:
static String GetModeName(
Adam6000Type adam6000Type,
char i_byMode
)
J#
public static string GetModeName(
Adam6000Type adam6000Type,
byte i_byMode
)
JScript
public static function GetModeName(
adam6000Type : Adam6000Type,
i_byMode : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byMode
The mode code.

Return Value

Return range code if success, otherwise, return empty string

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeName Overload List


GetModeTotal Method

Alarm.GetModeTotal Method

Support module: ADAM-4000. Get the range total

Overload List

Name | Description
GetModeTotal (Adam4000Type) | Support module: ADAM-4000. Get the range total
GetModeTotal (Adam5000Type) | Support module: ADAM-5000. Get the alarm mode total
GetModeTotal (Adam6000Type) | Support module: ADAM-6000. Get the range total

See Also

Alarm Class
Advantech.Adam Namespace


GetModeTotal Method (Adam4000Type)

Alarm.GetModeTotal Method (Adam4000Type)
See Also Example
[image]

Support module: ADAM-4000. Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetModeTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetModeTotal(
Adam4000Type adam4000Type
)
J#
public static int GetModeTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetModeTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return mode total if success, otherwise, return 0.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeTotal Overload List


GetModeTotal Method (Adam5000Type)

Alarm.GetModeTotal Method (Adam5000Type)
See Also Example
[image]

Support module: ADAM-5000. Get the alarm mode total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetModeTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetModeTotal(
Adam5000Type adam5000Type
)
J#
public static int GetModeTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetModeTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return mode total if success, otherwise, return 0.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeTotal Overload List


GetModeTotal Method (Adam6000Type)

Alarm.GetModeTotal Method (Adam6000Type)
See Also Example
[image]

Support module: ADAM-6000. Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetModeTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetModeTotal(
Adam6000Type adam6000Type
)
J#
public static int GetModeTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetModeTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return mode total if success, otherwise, return 0.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetModeTotal Overload List


GetStatus Method

Alarm.GetStatus Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get the alarm status

Overload List

 | Name | Description
Public method | GetStatus (Int32, Boolean, Boolean) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get the alarm status
Public method | GetStatus (Int32, Int32, Boolean, Boolean) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get the alarm status

See Also

Alarm Class
Advantech.Adam Namespace


GetStatus Method (Int32, Boolean, Boolean)

Alarm.GetStatus Method (Int32, Boolean, Boolean)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Get the alarm status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStatus( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bHigh As Boolean, _
<OutAttribute> ByRef o_bLow As Boolean _
) As Boolean
C#
public bool GetStatus(
int i_iChannel,
out bool o_bHigh,
out bool o_bLow
)
C++
public:
bool GetStatus(
int i_iChannel,
[OutAttribute] bool% o_bHigh,
[OutAttribute] bool% o_bLow
) sealed
J#
public bool GetStatus(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bHigh,
/** @attribute OutAttribute() */ /** @ref */ bool o_bLow
)
JScript
public function GetStatus(
i_iChannel : int,
OutAttribute o_bHigh : bool,
OutAttribute o_bLow : bool
) : bool

Parameters

i_iChannel
The channel index.
o_bHigh
The high alarm status
o_bLow
The low alarm status

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetStatus Overload List


GetStatus Method (Int32, Int32, Boolean, Boolean)

Alarm.GetStatus Method (Int32, Int32, Boolean, Boolean)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Get the alarm status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bHigh As Boolean, _
<OutAttribute> ByRef o_bLow As Boolean _
) As Boolean
C#
public bool GetStatus(
int i_iSlot,
int i_iChannel,
out bool o_bHigh,
out bool o_bLow
)
C++
public:
bool GetStatus(
int i_iSlot,
int i_iChannel,
[OutAttribute] bool% o_bHigh,
[OutAttribute] bool% o_bLow
) sealed
J#
public bool GetStatus(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bHigh,
/** @attribute OutAttribute() */ /** @ref */ bool o_bLow
)
JScript
public function GetStatus(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_bHigh : bool,
OutAttribute o_bLow : bool
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
o_bHigh
The high alarm status
o_bLow
The low alarm status

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.GetStatus Overload List


SetAlarmDO Method

Alarm.SetAlarmDO Method

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080, ADAM-4080D. Set the alarm DO values.

Overload List

 | Name | Description
Public method | SetAlarmDO (Boolean) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080, ADAM-4080D. Set the alarm DO values.
Public method | SetAlarmDO (Int32, Int32, Boolean) | Support module: ADAM-5081 Set Alarm DO value to a single channel.

See Also

Alarm Class
Advantech.Adam Namespace


SetAlarmDO Method (Boolean[])

Alarm.SetAlarmDO Method (Boolean[])
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080, ADAM-4080D. Set the alarm DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAlarmDO( _
ByVal i_bAlarmDO As Boolean() _
) As Boolean
C#
public bool SetAlarmDO(
bool[] i_bAlarmDO
)
C++
public:
bool SetAlarmDO(
array<bool>^ i_bAlarmDO
) sealed
J#
public bool SetAlarmDO(
bool[] i_bAlarmDO
)
JScript
public function SetAlarmDO(
i_bAlarmDO : bool[]
) : bool

Parameters

i_bAlarmDO
The array of DO values. The length of the array must be 2.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetAlarmDO Overload List


SetAlarmDO Method (Int32, Int32, Boolean)

Alarm.SetAlarmDO Method (Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5081 Set Alarm DO value to a single channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAlarmDO( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_bValue As Boolean _
) As Boolean
C#
public bool SetAlarmDO(
int i_iSlot,
int i_iChannel,
bool i_bValue
)
C++
public:
bool SetAlarmDO(
int i_iSlot,
int i_iChannel,
bool i_bValue
) sealed
J#
public bool SetAlarmDO(
int i_iSlot,
int i_iChannel,
bool i_bValue
)
JScript
public function SetAlarmDO(
i_iSlot : int,
i_iChannel : int,
i_bValue : bool
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannel
The channel index, base 0.
i_bValue
The DO value to set.

Return Value

True if secceed, otherwise false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetAlarmDO Overload List


SetEnable Method

Alarm.SetEnable Method
[image]

Support module: ADAM-4080. Set alarm enabled for the specified counter channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetEnable( _
ByVal i_iChannel As Integer, _
ByVal i_bEnable As Boolean _
) As Boolean
C#
public bool SetEnable(
int i_iChannel,
bool i_bEnable
)
C++
public:
bool SetEnable(
int i_iChannel,
bool i_bEnable
) sealed
J#
public bool SetEnable(
int i_iChannel,
bool i_bEnable
)
JScript
public function SetEnable(
i_iChannel : int,
i_bEnable : bool
) : bool

Parameters

i_iChannel
The channel index. The range is between 0~1.
i_bEnable
The alarm enabled/disabled.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace


SetExtDO Method

Alarm.SetExtDO Method
[image]

Support module: ADAM-4016. Set the extra DO values. The DO-2 and DO-3 on the module.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetExtDO( _
ByVal i_bAlarmDO As Boolean() _
) As Boolean
C#
public bool SetExtDO(
bool[] i_bAlarmDO
)
C++
public:
bool SetExtDO(
array<bool>^ i_bAlarmDO
) sealed
J#
public bool SetExtDO(
bool[] i_bAlarmDO
)
JScript
public function SetExtDO(
i_bAlarmDO : bool[]
) : bool

Parameters

i_bAlarmDO
The array of DO values. The length of the array must be 2.

See Also

Alarm Class
Advantech.Adam Namespace


SetHighLatchClear Method

Alarm.SetHighLatchClear Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the high latch alarm to be cleared

Overload List

 | Name | Description
Public method | SetHighLatchClear (Int32) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the high latch alarm to be cleared
Public method | SetHighLatchClear (Int32, Int32) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set the high latch alarm to be cleared

See Also

Alarm Class
Advantech.Adam Namespace


SetHighLatchClear Method (Int32)

Alarm.SetHighLatchClear Method (Int32)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the high latch alarm to be cleared

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighLatchClear( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetHighLatchClear(
int i_iChannel
)
C++
public:
bool SetHighLatchClear(
int i_iChannel
) sealed
J#
public bool SetHighLatchClear(
int i_iChannel
)
JScript
public function SetHighLatchClear(
i_iChannel : int
) : bool

Parameters

i_iChannel
The channel index.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighLatchClear Overload List


SetHighLatchClear Method (Int32, Int32)

Alarm.SetHighLatchClear Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set the high latch alarm to be cleared

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighLatchClear( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetHighLatchClear(
int i_iSlot,
int i_iChannel
)
C++
public:
bool SetHighLatchClear(
int i_iSlot,
int i_iChannel
) sealed
J#
public bool SetHighLatchClear(
int i_iSlot,
int i_iChannel
)
JScript
public function SetHighLatchClear(
i_iSlot : int,
i_iChannel : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighLatchClear Overload List


SetHighLimit Method

Alarm.SetHighLimit Method

Support module: ADAM-5080, ADAM-5081. Set counter high alarm limit

Overload List

 | Name | Description
Public method | SetHighLimit (Int32, Int32, Int64) | Support module: ADAM-5080, ADAM-5081. Set counter high alarm limit
Public method | SetHighLimit (Int32, Int32, Single) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input high alarm limit
Public method | SetHighLimit (Int32, Single) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input high alarm limit
Public method | SetHighLimit (Int64) | Support module: ADAM-4080D. Set high alarm limit for counter-0.
Public method | SetHighLimit (Single) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input high alarm limit

See Also

Alarm Class
Advantech.Adam Namespace


SetHighLimit Method (Int32, Int32, Int64)

Alarm.SetHighLimit Method (Int32, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Set counter high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_lLimit As Long _
) As Boolean
C#
public bool SetHighLimit(
int i_iSlot,
int i_iChannel,
long i_lLimit
)
C++
public:
bool SetHighLimit(
int i_iSlot,
int i_iChannel,
__int64 i_lLimit
) sealed
J#
public bool SetHighLimit(
int i_iSlot,
int i_iChannel,
long i_lLimit
)
JScript
public function SetHighLimit(
i_iSlot : int,
i_iChannel : int,
i_lLimit : long
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_lLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighLimit Overload List


SetHighLimit Method (Int32, Int32, Single)

Alarm.SetHighLimit Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_fLimit As Single _
) As Boolean
C#
public bool SetHighLimit(
int i_iSlot,
int i_iChannel,
float i_fLimit
)
C++
public:
bool SetHighLimit(
int i_iSlot,
int i_iChannel,
float i_fLimit
) sealed
J#
public bool SetHighLimit(
int i_iSlot,
int i_iChannel,
float i_fLimit
)
JScript
public function SetHighLimit(
i_iSlot : int,
i_iChannel : int,
i_fLimit : float
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighLimit Overload List


SetHighLimit Method (Int32, Single)

Alarm.SetHighLimit Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighLimit( _
ByVal i_iChannel As Integer, _
ByVal i_fLimit As Single _
) As Boolean
C#
public bool SetHighLimit(
int i_iChannel,
float i_fLimit
)
C++
public:
bool SetHighLimit(
int i_iChannel,
float i_fLimit
) sealed
J#
public bool SetHighLimit(
int i_iChannel,
float i_fLimit
)
JScript
public function SetHighLimit(
i_iChannel : int,
i_fLimit : float
) : bool

Parameters

i_iChannel
The channel index.
i_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighLimit Overload List


SetHighLimit Method (Int64)

Alarm.SetHighLimit Method (Int64)
See Also Example
[image]

Support module: ADAM-4080D. Set high alarm limit for counter-0.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighLimit( _
ByVal i_lValue As Long _
) As Boolean
C#
public bool SetHighLimit(
long i_lValue
)
C++
public:
bool SetHighLimit(
__int64 i_lValue
) sealed
J#
public bool SetHighLimit(
long i_lValue
)
JScript
public function SetHighLimit(
i_lValue : long
) : bool

Parameters

i_lValue
The high alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighLimit Overload List


SetHighLimit Method (Single)

Alarm.SetHighLimit Method (Single)
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input high alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighLimit( _
ByVal i_fLimit As Single _
) As Boolean
C#
public bool SetHighLimit(
float i_fLimit
)
C++
public:
bool SetHighLimit(
float i_fLimit
) sealed
J#
public bool SetHighLimit(
float i_fLimit
)
JScript
public function SetHighLimit(
i_fLimit : float
) : bool

Parameters

i_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighLimit Overload List


SetHighMapping Method

Alarm.SetHighMapping Method

Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the high alarm maps to.

Overload List

 | Name | Description
Public method | SetHighMapping (Int32, Int32) | Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the high alarm maps to.
Public method | SetHighMapping (Int32, Int32, Int32, Int32) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set digital output slot and channel that the high alarm maps to.

See Also

Alarm Class
Advantech.Adam Namespace


SetHighMapping Method (Int32, Int32)

Alarm.SetHighMapping Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the high alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighMapping( _
ByVal i_iChannel As Integer, _
ByVal i_iChMap As Integer _
) As Boolean
C#
public bool SetHighMapping(
int i_iChannel,
int i_iChMap
)
C++
public:
bool SetHighMapping(
int i_iChannel,
int i_iChMap
) sealed
J#
public bool SetHighMapping(
int i_iChannel,
int i_iChMap
)
JScript
public function SetHighMapping(
i_iChannel : int,
i_iChMap : int
) : bool

Parameters

i_iChannel
The channel index.
i_iChMap
The mapped digital output channel. If the mapping is going to be disable, set this value to -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighMapping Overload List


SetHighMapping Method (Int32, Int32, Int32, Int32)

Alarm.SetHighMapping Method (Int32, Int32, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set digital output slot and channel that the high alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighMapping( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iSlotMap As Integer, _
ByVal i_iChMap As Integer _
) As Boolean
C#
public bool SetHighMapping(
int i_iSlot,
int i_iChannel,
int i_iSlotMap,
int i_iChMap
)
C++
public:
bool SetHighMapping(
int i_iSlot,
int i_iChannel,
int i_iSlotMap,
int i_iChMap
) sealed
J#
public bool SetHighMapping(
int i_iSlot,
int i_iChannel,
int i_iSlotMap,
int i_iChMap
)
JScript
public function SetHighMapping(
i_iSlot : int,
i_iChannel : int,
i_iSlotMap : int,
i_iChMap : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_iSlotMap
The mapped digital output slot. If the mapping is going to be disable, set this value to -1.
i_iChMap
The mapped digital output channel. If the mapping is going to be disable, set this value to -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighMapping Overload List


SetHighMode Method

Alarm.SetHighMode Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input high alarm mode

Overload List

 | Name | Description
Public method | SetHighMode (Int32, Adam_AIAlarmMode) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input high alarm mode
Public method | SetHighMode (Int32, Int32, Adam_AIAlarmMode) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input high alarm mode
Public method | SetHighMode (Int32, Int32, Adam5000_CounterAlarmMode) | Support module: ADAM-5080, ADAM-5081. Set counter high alarm mode

See Also

Alarm Class
Advantech.Adam Namespace


SetHighMode Method (Int32, Adam_AIAlarmMode)

Alarm.SetHighMode Method (Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input high alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighMode( _
ByVal i_iChannel As Integer, _
ByVal i_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool SetHighMode(
int i_iChannel,
Adam_AIAlarmMode i_mode
)
C++
public:
bool SetHighMode(
int i_iChannel,
Adam_AIAlarmMode i_mode
) sealed
J#
public bool SetHighMode(
int i_iChannel,
Adam_AIAlarmMode i_mode
)
JScript
public function SetHighMode(
i_iChannel : int,
i_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iChannel
The channel index.
i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighMode Overload List


SetHighMode Method (Int32, Int32, Adam_AIAlarmMode)

Alarm.SetHighMode Method (Int32, Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input high alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool SetHighMode(
int i_iSlot,
int i_iChannel,
Adam_AIAlarmMode i_mode
)
C++
public:
bool SetHighMode(
int i_iSlot,
int i_iChannel,
Adam_AIAlarmMode i_mode
) sealed
J#
public bool SetHighMode(
int i_iSlot,
int i_iChannel,
Adam_AIAlarmMode i_mode
)
JScript
public function SetHighMode(
i_iSlot : int,
i_iChannel : int,
i_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighMode Overload List


SetHighMode Method (Int32, Int32, Adam5000_CounterAlarmMode)

Alarm.SetHighMode Method (Int32, Int32, Adam5000_CounterAlarmMode)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Set counter high alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetHighMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_mode As Adam5000_CounterAlarmMode _
) As Boolean
C#
public bool SetHighMode(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode
)
C++
public:
bool SetHighMode(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode
) sealed
J#
public bool SetHighMode(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode
)
JScript
public function SetHighMode(
i_iSlot : int,
i_iChannel : int,
i_mode : Adam5000_CounterAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetHighMode Overload List


SetLatchClear Method

Alarm.SetLatchClear Method

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080D. Set the latch alarm to be cleared.

Overload List

 | Name | Description
Public method | SetLatchClear | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080D. Set the latch alarm to be cleared.
Public method | SetLatchClear (Int32) | Support module: ADAM-4100. Set the latch alarm to be cleared
Family method | SetLatchClear (Int32, Int32, Int32) |

See Also

Alarm Class
Advantech.Adam Namespace


SetLatchClear Method ()

Alarm.SetLatchClear Method ()
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016, ADAM-4080D. Set the latch alarm to be cleared.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLatchClear() As Boolean
C#
public bool SetLatchClear()
C++
public:
bool SetLatchClear() sealed
J#
public bool SetLatchClear()
JScript
public function SetLatchClear() : bool

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLatchClear Overload List


SetLatchClear Method (Int32)

Alarm.SetLatchClear Method (Int32)
See Also Example
[image]

Support module: ADAM-4100. Set the latch alarm to be cleared

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLatchClear( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetLatchClear(
int i_iChannel
)
C++
public:
bool SetLatchClear(
int i_iChannel
) sealed
J#
public bool SetLatchClear(
int i_iChannel
)
JScript
public function SetLatchClear(
i_iChannel : int
) : bool

Parameters

i_iChannel
The channel index.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLatchClear Overload List


SetLatchClear Method (Int32, Int32, Int32)

Alarm.SetLatchClear Method (Int32, Int32, Int32)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function SetLatchClear( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer _
) As Boolean
C#
protected bool SetLatchClear(
int i_iSlot,
int i_iChannel,
int i_iHighLow
)
C++
protected:
bool SetLatchClear(
int i_iSlot,
int i_iChannel,
int i_iHighLow
) sealed
J#
protected bool SetLatchClear(
int i_iSlot,
int i_iChannel,
int i_iHighLow
)
JScript
protected function SetLatchClear(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLatchClear Overload List


SetLimit Method

Alarm.SetLimit Method

Support module: ADAM-4080. Set alarm limit for the specified counter channel.

Overload List

 | Name | Description
Family method | SetLimit (Int32, Int32, Int32, Int64) |
Family method | SetLimit (Int32, Int32, Int32, Single) |
Public method | SetLimit (Int32, Int64) | Support module: ADAM-4080. Set alarm limit for the specified counter channel.
Public method | SetLimit (Int32, Single, Single) | Support module: ADAM-4018M. Set analog input high and low alarm limit

See Also

Alarm Class
Advantech.Adam Namespace


SetLimit Method (Int32, Int32, Int32, Int64)

Alarm.SetLimit Method (Int32, Int32, Int32, Int64)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function SetLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
ByVal i_lLimit As Long _
) As Boolean
C#
protected bool SetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
long i_lLimit
)
C++
protected:
bool SetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
__int64 i_lLimit
) sealed
J#
protected bool SetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
long i_lLimit
)
JScript
protected function SetLimit(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
i_lLimit : long
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
i_lLimit

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLimit Overload List


SetLimit Method (Int32, Int32, Int32, Single)

Alarm.SetLimit Method (Int32, Int32, Int32, Single)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function SetLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
ByVal i_fLimit As Single _
) As Boolean
C#
protected bool SetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
float i_fLimit
)
C++
protected:
bool SetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
float i_fLimit
) sealed
J#
protected bool SetLimit(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
float i_fLimit
)
JScript
protected function SetLimit(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
i_fLimit : float
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
i_fLimit

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLimit Overload List


SetLimit Method (Int32, Int64)

Alarm.SetLimit Method (Int32, Int64)
See Also Example
[image]

Support module: ADAM-4080. Set alarm limit for the specified counter channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLimit( _
ByVal i_iChannel As Integer, _
ByVal i_lValue As Long _
) As Boolean
C#
public bool SetLimit(
int i_iChannel,
long i_lValue
)
C++
public:
bool SetLimit(
int i_iChannel,
__int64 i_lValue
) sealed
J#
public bool SetLimit(
int i_iChannel,
long i_lValue
)
JScript
public function SetLimit(
i_iChannel : int,
i_lValue : long
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1.
i_lValue
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLimit Overload List


SetLimit Method (Int32, Single, Single)

Alarm.SetLimit Method (Int32, Single, Single)
See Also Example
[image]

Support module: ADAM-4018M. Set analog input high and low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLimit( _
ByVal i_iChannel As Integer, _
ByVal i_fHighLimit As Single, _
ByVal i_fLowLimit As Single _
) As Boolean
C#
public bool SetLimit(
int i_iChannel,
float i_fHighLimit,
float i_fLowLimit
)
C++
public:
bool SetLimit(
int i_iChannel,
float i_fHighLimit,
float i_fLowLimit
) sealed
J#
public bool SetLimit(
int i_iChannel,
float i_fHighLimit,
float i_fLowLimit
)
JScript
public function SetLimit(
i_iChannel : int,
i_fHighLimit : float,
i_fLowLimit : float
) : bool

Parameters

i_iChannel
The channel index. The range is between 0~7.
i_fHighLimit
The high alarm limit value.
i_fLowLimit
The low alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLimit Overload List


SetLocalAlarmConfiguration Method

Alarm.SetLocalAlarmConfiguration Method

Support module: ADAM-5081 Set local alarm mode, type, mapping channel, and limit value.

Overload List

 | Name | Description
Public method | SetLocalAlarmConfiguration (Int32, Int32, Adam5000_CounterAlarmMode, Adam_LocalAlarmType, Int32, Int64) | Support module: ADAM-5081 Set local alarm mode, type, mapping channel, and limit value.
Public method | SetLocalAlarmConfiguration (Int32, Int32, Boolean, Boolean, Byte, Int32, UInt32, Byte, UInt32) | Support module: APAX-5080 Set local alarm mode, type, mapping channel, and limit value.

See Also

Alarm Class
Advantech.Adam Namespace


SetLocalAlarmConfiguration Method (Int32, Int32, Adam5000_CounterAlarmMode, Adam_LocalAlarmType, Int32, Int64)

Alarm.SetLocalAlarmConfiguration Method (Int32, Int32, Adam5000_CounterAlarmMode, Adam_LocalAlarmType, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5081 Set local alarm mode, type, mapping channel, and limit value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLocalAlarmConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_mode As Adam5000_CounterAlarmMode, _
ByVal i_type As Adam_LocalAlarmType, _
ByVal i_iChannelMap As Integer, _
ByVal i_lLimVal As Long _
) As Boolean
C#
public bool SetLocalAlarmConfiguration(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode,
Adam_LocalAlarmType i_type,
int i_iChannelMap,
long i_lLimVal
)
C++
public:
bool SetLocalAlarmConfiguration(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode,
Adam_LocalAlarmType i_type,
int i_iChannelMap,
__int64 i_lLimVal
) sealed
J#
public bool SetLocalAlarmConfiguration(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode,
Adam_LocalAlarmType i_type,
int i_iChannelMap,
long i_lLimVal
)
JScript
public function SetLocalAlarmConfiguration(
i_iSlot : int,
i_iChannel : int,
i_mode : Adam5000_CounterAlarmMode,
i_type : Adam_LocalAlarmType,
i_iChannelMap : int,
i_lLimVal : long
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The local alarm channel index.
i_mode
The local alarm mode.
i_type
The local alarm type.
i_iChannelMap
The mapping channel index.
i_lLimVal
The local alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLocalAlarmConfiguration Overload List


SetLocalAlarmConfiguration Method (Int32, Int32, Boolean, Boolean, Byte, Int32, UInt32, Byte, UInt32)

Alarm.SetLocalAlarmConfiguration Method (Int32, Int32, Boolean, Boolean, Byte, Int32, UInt32, Byte, UInt32)
See Also Example
[image]

Support module: APAX-5080 Set local alarm mode, type, mapping channel, and limit value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLocalAlarmConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iAlarmIndex As Integer, _
ByVal i_bAlarmEnable As Boolean, _
ByVal i_bAutoReloadEn As Boolean, _
ByVal i_byAlarmType As Byte, _
ByVal i_iChannelMap As Integer, _
ByVal i_uiLimVal As UInt32, _
ByVal i_byDoType As Byte, _
ByVal i_uiDoPulseWidth As UInt32 _
) As Boolean
C#
public bool SetLocalAlarmConfiguration(
int i_iSlot,
int i_iAlarmIndex,
bool i_bAlarmEnable,
bool i_bAutoReloadEn,
byte i_byAlarmType,
int i_iChannelMap,
uint i_uiLimVal,
byte i_byDoType,
uint i_uiDoPulseWidth
)
C++
public:
bool SetLocalAlarmConfiguration(
int i_iSlot,
int i_iAlarmIndex,
bool i_bAlarmEnable,
bool i_bAutoReloadEn,
char i_byAlarmType,
int i_iChannelMap,
unsigned int i_uiLimVal,
char i_byDoType,
unsigned int i_uiDoPulseWidth
) sealed
J#
public bool SetLocalAlarmConfiguration(
int i_iSlot,
int i_iAlarmIndex,
bool i_bAlarmEnable,
bool i_bAutoReloadEn,
byte i_byAlarmType,
int i_iChannelMap,
uint i_uiLimVal,
byte i_byDoType,
uint i_uiDoPulseWidth
)
JScript
public function SetLocalAlarmConfiguration(
i_iSlot : int,
i_iAlarmIndex : int,
i_bAlarmEnable : bool,
i_bAutoReloadEn : bool,
i_byAlarmType : Byte,
i_iChannelMap : int,
i_uiLimVal : UInt32,
i_byDoType : Byte,
i_uiDoPulseWidth : UInt32
) : bool

Parameters

i_iSlot
The slot index.
i_iAlarmIndex
The local alarm index.
i_bAlarmEnable
The local alarm enable flag.
i_bAutoReloadEn
The alarm auto reload flag.
i_byAlarmType
The local alarm type. High alarm:1, Low alarm:0
i_iChannelMap
The mapping channel index.
i_uiLimVal
The local alarm limit value.
i_byDoType
The DO behavior type.
i_uiDoPulseWidth
The DO pulse width.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLocalAlarmConfiguration Overload List


SetLocalAlarmLatchClear Method

Alarm.SetLocalAlarmLatchClear Method
[image]

Support module: ADAM-5081 Set the local alarm status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLocalAlarmLatchClear( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetLocalAlarmLatchClear(
int i_iSlot,
int i_iChannel
)
C++
public:
bool SetLocalAlarmLatchClear(
int i_iSlot,
int i_iChannel
) sealed
J#
public bool SetLocalAlarmLatchClear(
int i_iSlot,
int i_iChannel
)
JScript
public function SetLocalAlarmLatchClear(
i_iSlot : int,
i_iChannel : int
) : bool

Parameters

i_iSlot
The local alarm slot index.
i_iChannel
The local alarm channel index.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace


SetLowLatchClear Method

Alarm.SetLowLatchClear Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the low latch alarm to be cleared

Overload List

 | Name | Description
Public method | SetLowLatchClear (Int32) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the low latch alarm to be cleared
Public method | SetLowLatchClear (Int32, Int32) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set the low latch alarm to be cleared

See Also

Alarm Class
Advantech.Adam Namespace


SetLowLatchClear Method (Int32)

Alarm.SetLowLatchClear Method (Int32)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set the low latch alarm to be cleared

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowLatchClear( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetLowLatchClear(
int i_iChannel
)
C++
public:
bool SetLowLatchClear(
int i_iChannel
) sealed
J#
public bool SetLowLatchClear(
int i_iChannel
)
JScript
public function SetLowLatchClear(
i_iChannel : int
) : bool

Parameters

i_iChannel
The channel index.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowLatchClear Overload List


SetLowLatchClear Method (Int32, Int32)

Alarm.SetLowLatchClear Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set the low latch alarm to be cleared

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowLatchClear( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetLowLatchClear(
int i_iSlot,
int i_iChannel
)
C++
public:
bool SetLowLatchClear(
int i_iSlot,
int i_iChannel
) sealed
J#
public bool SetLowLatchClear(
int i_iSlot,
int i_iChannel
)
JScript
public function SetLowLatchClear(
i_iSlot : int,
i_iChannel : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowLatchClear Overload List


SetLowLimit Method

Alarm.SetLowLimit Method

Support module: ADAM-5080, ADAM-5081. Set counter low alarm limit

Overload List

 | Name | Description
Public method | SetLowLimit (Int32, Int32, Int64) | Support module: ADAM-5080, ADAM-5081. Set counter low alarm limit
Public method | SetLowLimit (Int32, Int32, Single) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input low alarm limit
Public method | SetLowLimit (Int32, Single) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input low alarm limit
Public method | SetLowLimit (Int64) | Support module: ADAM-4080D. Set low alarm limit for counter-0.
Public method | SetLowLimit (Single) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input low alarm limit

See Also

Alarm Class
Advantech.Adam Namespace


SetLowLimit Method (Int32, Int32, Int64)

Alarm.SetLowLimit Method (Int32, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Set counter low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_lLimit As Long _
) As Boolean
C#
public bool SetLowLimit(
int i_iSlot,
int i_iChannel,
long i_lLimit
)
C++
public:
bool SetLowLimit(
int i_iSlot,
int i_iChannel,
__int64 i_lLimit
) sealed
J#
public bool SetLowLimit(
int i_iSlot,
int i_iChannel,
long i_lLimit
)
JScript
public function SetLowLimit(
i_iSlot : int,
i_iChannel : int,
i_lLimit : long
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_lLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowLimit Overload List


SetLowLimit Method (Int32, Int32, Single)

Alarm.SetLowLimit Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowLimit( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_fLimit As Single _
) As Boolean
C#
public bool SetLowLimit(
int i_iSlot,
int i_iChannel,
float i_fLimit
)
C++
public:
bool SetLowLimit(
int i_iSlot,
int i_iChannel,
float i_fLimit
) sealed
J#
public bool SetLowLimit(
int i_iSlot,
int i_iChannel,
float i_fLimit
)
JScript
public function SetLowLimit(
i_iSlot : int,
i_iChannel : int,
i_fLimit : float
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowLimit Overload List


SetLowLimit Method (Int32, Single)

Alarm.SetLowLimit Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowLimit( _
ByVal i_iChannel As Integer, _
ByVal i_fLimit As Single _
) As Boolean
C#
public bool SetLowLimit(
int i_iChannel,
float i_fLimit
)
C++
public:
bool SetLowLimit(
int i_iChannel,
float i_fLimit
) sealed
J#
public bool SetLowLimit(
int i_iChannel,
float i_fLimit
)
JScript
public function SetLowLimit(
i_iChannel : int,
i_fLimit : float
) : bool

Parameters

i_iChannel
The channel index.
i_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowLimit Overload List


SetLowLimit Method (Int64)

Alarm.SetLowLimit Method (Int64)
See Also Example
[image]

Support module: ADAM-4080D. Set low alarm limit for counter-0.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowLimit( _
ByVal i_lValue As Long _
) As Boolean
C#
public bool SetLowLimit(
long i_lValue
)
C++
public:
bool SetLowLimit(
__int64 i_lValue
) sealed
J#
public bool SetLowLimit(
long i_lValue
)
JScript
public function SetLowLimit(
i_lValue : long
) : bool

Parameters

i_lValue
The low alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowLimit Overload List


SetLowLimit Method (Single)

Alarm.SetLowLimit Method (Single)
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input low alarm limit

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowLimit( _
ByVal i_fLimit As Single _
) As Boolean
C#
public bool SetLowLimit(
float i_fLimit
)
C++
public:
bool SetLowLimit(
float i_fLimit
) sealed
J#
public bool SetLowLimit(
float i_fLimit
)
JScript
public function SetLowLimit(
i_fLimit : float
) : bool

Parameters

i_fLimit
The alarm limit value.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowLimit Overload List


SetLowMapping Method

Alarm.SetLowMapping Method

Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the low alarm maps to.

Overload List

 | Name | Description
Public method | SetLowMapping (Int32, Int32) | Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the low alarm maps to.
Public method | SetLowMapping (Int32, Int32, Int32, Int32) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set digital output slot and channel that the low alarm maps to.

See Also

Alarm Class
Advantech.Adam Namespace


SetLowMapping Method (Int32, Int32)

Alarm.SetLowMapping Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-6017, ADAM-6018. Set digital output slot and channel that the low alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowMapping( _
ByVal i_iChannel As Integer, _
ByVal i_iChMap As Integer _
) As Boolean
C#
public bool SetLowMapping(
int i_iChannel,
int i_iChMap
)
C++
public:
bool SetLowMapping(
int i_iChannel,
int i_iChMap
) sealed
J#
public bool SetLowMapping(
int i_iChannel,
int i_iChMap
)
JScript
public function SetLowMapping(
i_iChannel : int,
i_iChMap : int
) : bool

Parameters

i_iChannel
The channel index.
i_iChMap
The mapped digital output channel. If the mapping is going to be disable, set this value as well as 'i_iSlotMap' to -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowMapping Overload List


SetLowMapping Method (Int32, Int32, Int32, Int32)

Alarm.SetLowMapping Method (Int32, Int32, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P, ADAM-5080, ADAM-5081. Set digital output slot and channel that the low alarm maps to.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowMapping( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iSlotMap As Integer, _
ByVal i_iChMap As Integer _
) As Boolean
C#
public bool SetLowMapping(
int i_iSlot,
int i_iChannel,
int i_iSlotMap,
int i_iChMap
)
C++
public:
bool SetLowMapping(
int i_iSlot,
int i_iChannel,
int i_iSlotMap,
int i_iChMap
) sealed
J#
public bool SetLowMapping(
int i_iSlot,
int i_iChannel,
int i_iSlotMap,
int i_iChMap
)
JScript
public function SetLowMapping(
i_iSlot : int,
i_iChannel : int,
i_iSlotMap : int,
i_iChMap : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_iSlotMap
The mapped digital output slot. If the mapping is going to be disable, set this value as well as 'i_iChMap' to -1.
i_iChMap
The mapped digital output channel. If the mapping is going to be disable, set this value as well as 'i_iSlotMap' to -1.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowMapping Overload List


SetLowMode Method

Alarm.SetLowMode Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input low alarm mode

Overload List

 | Name | Description
Public method | SetLowMode (Int32, Adam_AIAlarmMode) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input low alarm mode
Public method | SetLowMode (Int32, Int32, Adam_AIAlarmMode) | Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input low alarm mode
Public method | SetLowMode (Int32, Int32, Adam5000_CounterAlarmMode) | Support module: ADAM-5080, ADAM-5081. Set counter low alarm mode

See Also

Alarm Class
Advantech.Adam Namespace


SetLowMode Method (Int32, Adam_AIAlarmMode)

Alarm.SetLowMode Method (Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217. Set analog input low alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowMode( _
ByVal i_iChannel As Integer, _
ByVal i_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool SetLowMode(
int i_iChannel,
Adam_AIAlarmMode i_mode
)
C++
public:
bool SetLowMode(
int i_iChannel,
Adam_AIAlarmMode i_mode
) sealed
J#
public bool SetLowMode(
int i_iChannel,
Adam_AIAlarmMode i_mode
)
JScript
public function SetLowMode(
i_iChannel : int,
i_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iChannel
The channel index.
i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowMode Overload List


SetLowMode Method (Int32, Int32, Adam_AIAlarmMode)

Alarm.SetLowMode Method (Int32, Int32, Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018, ADAM-5018P. Set analog input low alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool SetLowMode(
int i_iSlot,
int i_iChannel,
Adam_AIAlarmMode i_mode
)
C++
public:
bool SetLowMode(
int i_iSlot,
int i_iChannel,
Adam_AIAlarmMode i_mode
) sealed
J#
public bool SetLowMode(
int i_iSlot,
int i_iChannel,
Adam_AIAlarmMode i_mode
)
JScript
public function SetLowMode(
i_iSlot : int,
i_iChannel : int,
i_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowMode Overload List


SetLowMode Method (Int32, Int32, Adam5000_CounterAlarmMode)

Alarm.SetLowMode Method (Int32, Int32, Adam5000_CounterAlarmMode)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Set counter low alarm mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLowMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_mode As Adam5000_CounterAlarmMode _
) As Boolean
C#
public bool SetLowMode(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode
)
C++
public:
bool SetLowMode(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode
) sealed
J#
public bool SetLowMode(
int i_iSlot,
int i_iChannel,
Adam5000_CounterAlarmMode i_mode
)
JScript
public function SetLowMode(
i_iSlot : int,
i_iChannel : int,
i_mode : Adam5000_CounterAlarmMode
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The channel index.
i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetLowMode Overload List


SetMapping Method

Alarm.SetMapping Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function SetMapping( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
ByVal i_iSlotMap As Integer, _
ByVal i_iChMap As Integer _
) As Boolean
C#
protected bool SetMapping(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
int i_iSlotMap,
int i_iChMap
)
C++
protected:
bool SetMapping(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
int i_iSlotMap,
int i_iChMap
) sealed
J#
protected bool SetMapping(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
int i_iSlotMap,
int i_iChMap
)
JScript
protected function SetMapping(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
i_iSlotMap : int,
i_iChMap : int
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
i_iSlotMap
i_iChMap

See Also

Alarm Class
Advantech.Adam Namespace


SetMode Method

Alarm.SetMode Method

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input alarm mode. After the mode is set, you have to wait 2 seconds to let it takes effect.

Overload List

 | Name | Description
Public method | SetMode (Adam_AIAlarmMode) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input alarm mode. After the mode is set, you have to wait 2 seconds to let it takes effect.
Public method | SetMode (Adam4000_CounterAlarmMode) | Support module: ADAM-4080D. Set counter alarm mode for counter-0. After the mode is set, you have to wait 2 seconds to let it takes effect.
Family method | SetMode (Int32, Int32, Int32, Adam_AIAlarmMode) |
Family method | SetMode (Int32, Int32, Int32, Adam5000_CounterAlarmMode) |

See Also

Alarm Class
Advantech.Adam Namespace


SetMode Method (Adam_AIAlarmMode)

Alarm.SetMode Method (Adam_AIAlarmMode)
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Set analog input alarm mode. After the mode is set, you have to wait 2 seconds to let it takes effect.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMode( _
ByVal i_mode As Adam_AIAlarmMode _
) As Boolean
C#
public bool SetMode(
Adam_AIAlarmMode i_mode
)
C++
public:
bool SetMode(
Adam_AIAlarmMode i_mode
) sealed
J#
public bool SetMode(
Adam_AIAlarmMode i_mode
)
JScript
public function SetMode(
i_mode : Adam_AIAlarmMode
) : bool

Parameters

i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetMode Overload List


SetMode Method (Adam4000_CounterAlarmMode)

Alarm.SetMode Method (Adam4000_CounterAlarmMode)
See Also Example
[image]

Support module: ADAM-4080D. Set counter alarm mode for counter-0. After the mode is set, you have to wait 2 seconds to let it takes effect.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMode( _
ByVal i_mode As Adam4000_CounterAlarmMode _
) As Boolean
C#
public bool SetMode(
Adam4000_CounterAlarmMode i_mode
)
C++
public:
bool SetMode(
Adam4000_CounterAlarmMode i_mode
) sealed
J#
public bool SetMode(
Adam4000_CounterAlarmMode i_mode
)
JScript
public function SetMode(
i_mode : Adam4000_CounterAlarmMode
) : bool

Parameters

i_mode
The alarm mode.

Return Value

Return true if success, otherwise return false.

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetMode Overload List


SetMode Method (Int32, Int32, Int32, Adam_AIAlarmMode)

Alarm.SetMode Method (Int32, Int32, Int32, Adam_AIAlarmMode)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function SetMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
ByVal i_mode As Adam_AIAlarmMode _
) As Boolean
C#
protected bool SetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
Adam_AIAlarmMode i_mode
)
C++
protected:
bool SetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
Adam_AIAlarmMode i_mode
) sealed
J#
protected bool SetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
Adam_AIAlarmMode i_mode
)
JScript
protected function SetMode(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
i_mode : Adam_AIAlarmMode
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
i_mode

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetMode Overload List


SetMode Method (Int32, Int32, Int32, Adam5000_CounterAlarmMode)

Alarm.SetMode Method (Int32, Int32, Int32, Adam5000_CounterAlarmMode)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function SetMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iHighLow As Integer, _
ByVal i_mode As Adam5000_CounterAlarmMode _
) As Boolean
C#
protected bool SetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
Adam5000_CounterAlarmMode i_mode
)
C++
protected:
bool SetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
Adam5000_CounterAlarmMode i_mode
) sealed
J#
protected bool SetMode(
int i_iSlot,
int i_iChannel,
int i_iHighLow,
Adam5000_CounterAlarmMode i_mode
)
JScript
protected function SetMode(
i_iSlot : int,
i_iChannel : int,
i_iHighLow : int,
i_mode : Adam5000_CounterAlarmMode
) : bool

Parameters

i_iSlot
i_iChannel
i_iHighLow
i_mode

See Also

Alarm Class
Advantech.Adam Namespace
Alarm.SetMode Overload List


AnalogInput Class

AnalogInput Class
See Also Example Members
[image]

AnalogInput class for ADAM series.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AnalogInput
Inherits AdamBase
C#
public class AnalogInput : AdamBase
C++
ref class AnalogInput : AdamBase
J#
public class AnalogInput extends AdamBase
JScript
public class AnalogInput extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.AnalogInput

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AnalogInput Members
Advantech.Adam Namespace


AnalogInput Members

AnalogInput Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

AnalogInput class for ADAM series.

The following tables list the members exposed by AnalogInput.

Public Constructors

Name | Description
AnalogInput | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
 | Get4100IntegrationName | Get integration name for ADAM-4100.
Public method | GetAutoFilterEnabled | Support module: ADAM-4100. Get Auto-filter channel enabled status and filter percentage index.
Public method | GetAutoFilterProgress | Support module: ADAM-4100. Get Auto-filter progress percentage.
Public method | GetAutoFilterSampleRate | Support module: ADAM-4100. Get Auto-filter sampling rate.
Public method | GetAverageChannelEnabled | Support module: ADAM-6000. Get channel enabled status for average
Public method | GetBiasValue | Support module: ADAM-4018P. Get bias value.
Public method | GetBurnoutDetect | Overloaded. Support module: ADAM-4100. Get burnout detect setting.
Public method | GetBurnoutFunEnable | Support module: APAX-5000. Get Burnout Function Enable Mask
Public method | GetBurnoutMap | Overloaded. Support module: ADAM-4100. Get burnout mapping.
Public method | GetBurnoutValue | Support module: APAX-5000. Get The Value While Burnout
Public method | GetCalibrationValues | Support module: ADAM-5017P, ADAM-5018P. Get analog input calibration value.
Public method | GetChannelDiagnostic | Support module: ADAM-4022T, ADAM-4019P Get channel diagnostic status.
Public method | GetChannelEnabled | Overloaded. Support module: ADAM-4100, ADAM-6000. Get channel enabled status
Public method | GetChannelStatus | Overloaded. Support module: APAX-5000. Get channel status.
 | GetChannelTotal | Overloaded. Get the channel total
Public method | GetChValOffset | Support module: APAX-5000. Get channel value offset.
Public method | GetCJCValue | Overloaded. Support module: ADAM-5000, ADAM-5000TCP. Get CJC calibration value
Public method | GetDataFormat | Support module: ADAM-5017H, ADAM-5017UH. Get module data format
 | GetDataFormatCode | Overloaded. Get the data format code.
 | GetDataFormatIndex | Overloaded. Get the data format index
 | GetDataFormatName | Overloaded. Get the data format name
 | GetDataFormatTotal | Overloaded. Get the data format total
 | GetFloatFormat | Overloaded. Get floating format
Public method | GetInputRange | Overloaded. Support module: ADAM-4000 (Channel Independent Configuration), ADAM-4100, ADAM-6000. Get module analog input range
Public method | GetIntegration | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Get module integration time
 | GetIntegrationCode | Get the integration code
 | GetIntegrationIndex | Get integration index
 | GetIntegrationName | Get integration name.
 | GetIntegrationTotal | Get integration total.
Public method | GetLeadWire | Support module: ADAM-4000. Get lead wire resistance value
Public method | GetMemConfig | Support module: ADAM-4018M. Get memory configuration.
Public method | GetMemEventRecordCount | Support module: ADAM-4018M. Get memory event record counts.
Public method | GetMemOperation | Support module: ADAM-4018M. Get memory operation.
Public method | GetMemRecordData | Support module: ADAM-4018M. Get memory data record.
Public method | GetMemStandardRecordCount | Support module: ADAM-4018M. Get memory standard record counts.
 | GetRangeCode | Overloaded. Get the range code
 | GetRangeCode2Byte | Overloaded. Get the range code
 | GetRangeHighLow | Overloaded. Get the range boundary
 | GetRangeIndex | Overloaded. Get the range code index
Public method | GetRangeIntegration | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000/TCP. Get module analog input range and integration time
Public method | GetRangeIntegrationDataFormat | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000. Get module analog input range, integration time and data format
 | GetRangeName | Overloaded. Get the range name
 | GetRangeTotal | Overloaded. Get the range total
Public method | GetSampleRate | Support module: APAX-5000. Get module analog input sample rate
 | GetScaledValue | Overloaded. Get the scaled value
 | GetScaledValueWithResolution | Get the scaled value with resolution for unknown APAX module
 | GetSpanCalibrationName | Overloaded. Get the span calibration apply string
 | GetUnitName | Overloaded. Get unit string
Public method | GetUnknownModuleDescription | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module description.
Public method | GetUnknownModuleInfo | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module information.
Public method | GetUnknownModuleName | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module name.
Public method | GetUnknownRangeSupport | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module range code.
Public method | GetValue | Overloaded. Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get specified channel value. The value returned is in engineering unit format.
Public method | GetValues | Overloaded. Support module: ADAM-5000 Get channel values when the data format is set to two's complement hexdecimal.
 | GetZeroCalibrationName | Overloaded. Get the zero calibration apply string
Public method | ODM17S_GetEnableChannelTotal | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S enable channel number.
Public method | ODM17S_GetFifoData | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S enable channel number.
Public method | ODM17S_GetMode | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S acquisition mode
Public method | ODM17S_GetRange | Support module: ADAM-5017S ODM on ADAM-5550. Get module analog input range.
Public method | ODM17S_GetSampleRate | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S sampling rate.
Public method | ODM17S_GetTrigTotal | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S trigger total number.
Public method | ODM17S_SetEnableChannelTotal | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S enable channel number.
Public method | ODM17S_SetMode | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S acquisition mode.
Public method | ODM17S_SetRange | Support module: ADAM-5017S ODM on ADAM-5550. Set module analog input range.
Public method | ODM17S_SetSampleRate | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S sampling rate.
Public method | ODM17S_SetStart | Support module: ADAM-5017S ODM on ADAM-5550. ODM ADAM-5017S start to get value.
Public method | ODM17S_SetStop | Support module: ADAM-5017S ODM on ADAM-5550. ODM ADAM-5017S stop getting value.
Public method | ODM17S_SetTrigTotal | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S trigger total number.
Public method | SetAutoCalibration | Support module: APAX-5000, APAX-5070(UDP:5222). Set analog input auto-calibration
Public method | SetAutoFilter | Support module: ADAM-4100. Set Auto-filter.
Public method | SetAutoFilterEnabled | Support module: ADAM-4100. Set Auto-filter channel enabled status and filter percentage index.
Public method | SetAverageChannelEnabled | Support module: ADAM-6000. Set channel enabled status for average
Public method | SetBiasValue | Support module: ADAM-4018P. Set bias value.
Public method | SetBurnoutDetect | Overloaded. Support module: ADAM-4100. Set burnout detect setting.
Public method | SetBurnoutFunEnable | Support module: APAX-5000. Set burnout function.
Public method | SetBurnoutMap | Overloaded. Support module: ADAM-4100. Set burnout mapping.
Public method | SetBurnoutValue | Support module: APAX-5000. Set The Value While Burnout.
Public method | SetChannelEnabled | Overloaded. Support module: ADAM-4100, ADAM-6000. Set channel enabled status
Public method | SetChannelNegCalibration | Support module: ADAM-4000. Set analog input Neg. calibration
Public method | SetChannelSpanCalibration | Support module: ADAM-4000. Set analog input Span calibration
Public method | SetChannelZeroCalibration | Support module: ADAM-4000. Set analog input Zero calibration
Public method | SetChValOffset | Support module: APAX-5000. Set channel value offset.
Public method | SetCjcInitValRecord | Support module: APAX-5000. CJC Initial Value Record.
Public method | SetCJCOffset | Overloaded. Support module: ADAM-5000, ADAM-5000TCP, APAX-5000. Set CJC offset calibration value
Public method | SetCJCValue | Support module: ADAM-6000. Set CJC calibration value
Public method | SetDataFormat | Support module: ADAM-5017H, ADAM-5017UH. Set module data format
Public method | SetInputRange | Overloaded. Support module: ADAM-4000 (Channel Independant Configuration), ADAM-4100, ADAM-6000. Set module analog input range
Public method | SetIntegration | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Set module integration time
Public method | SetLeadWire | Support module: ADAM-4000. Set lead wire resistance value
Public method | SetMemConfig | Support module: ADAM-4018M. Set memory configuration.
Public method | SetMemOperation | Support module: ADAM-4018M. Set memory operation.
Public method | SetRangeIntegration | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000/TCP. Set module analog input range and integration time
Public method | SetRangeIntegrationDataFormat | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000. Set module analog input range, integration time and data format
Public method | SetRanges | Support module: APAX-5000. Set module analog input ranges
Public method | SetSampleRate | Support module: APAX-5000. Set module analog input sample rate
Public method | SetSpanCalibration | Overloaded. Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Span calibration
Public method | SetThermoCalibration | Support module: APAX-5000. Set Thermal Couple Calibration.
Public method | SetZeroCalibration | Overloaded. Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Zero calibration
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetAdam4011RangeCode | Get the ADAM-4011 range code.
 | GetAdam4011RangeIndex | Get the ADAM-4011 range code index
 | GetAdam4011RangeName | Get the ADAM-4011 range name.
 | GetAdam4012RangeCode | Get the ADAM-4012 range code.
 | GetAdam4012RangeIndex | Get the ADAM-4012 range code index
 | GetAdam4012RangeName | Get the ADAM-4012 range name.
 | GetAdam4013RangeCode | Get the ADAM-4013 range code.
 | GetAdam4013RangeIndex | Get the ADAM-4013 range code index
 | GetAdam4013RangeName | Get the ADAM-4013 range name.
 | GetAdam4015RangeCode |
 | GetAdam4015RangeHighLow |
 | GetAdam4015RangeIndex |
 | GetAdam4015RangeName |
 | GetAdam4015ScaledValue |
 | GetAdam4015TRangeCode |
 | GetAdam4015TRangeHighLow |
 | GetAdam4015TRangeIndex |
 | GetAdam4015TRangeName |
 | GetAdam4015TScaledValue |
 | GetAdam4016RangeCode | Get the ADAM-4016 range code.
 | GetAdam4016RangeIndex | Get the ADAM-4016 range code index
 | GetAdam4016RangeName | Get the ADAM-4016 range name.
 | GetAdam4017PRangeCode |
 | GetAdam4017PRangeHighLow |
 | GetAdam4017PRangeIndex |
 | GetAdam4017PRangeName |
 | GetAdam4017PScaledValue |
 | GetAdam4017RangeCode | Get the ADAM-4017 range code.
 | GetAdam4017RangeIndex | Get the ADAM-4017 range code index
 | GetAdam4017RangeName | Get the ADAM-4017 range name.
 | GetAdam4018PRangeCode |
 | GetAdam4018PRangeHighLow |
 | GetAdam4018PRangeIndex |
 | GetAdam4018PRangeName |
 | GetAdam4018PScaledValue |
 | GetAdam4018RangeCode | Get the ADAM-4018 range code.
 | GetAdam4018RangeIndex | Get the ADAM-4018 range code index
 | GetAdam4018RangeName | Get the ADAM-4018 range name.
 | GetAdam4019PRangeCode | Get the ADAM-4019P range code.
 | GetAdam4019PRangeHighLow |
 | GetAdam4019PRangeIndex | Get the ADAM-4019P range code index
 | GetAdam4019PRangeName | Get the ADAM-4019P range name.
 | GetAdam4019PScaledValue |
 | GetAdam4019RangeCode | Get the ADAM-4019 range code.
 | GetAdam4019RangeIndex | Get the ADAM-4019 range code index
 | GetAdam4019RangeName | Get the ADAM-4019 range name.
 | GetAdam4022TRangeCode | Get the ADAM-4022T range code.
 | GetAdam4022TRangeHighLow |
 | GetAdam4022TRangeIndex | Get the ADAM-4022T range code index
 | GetAdam4022TRangeName | Get the ADAM-4022T range name.
 | GetAdam4022TScaledValue |
 | GetAdam4117RangeCode | Get the ADAM-4117 range code.
 | GetAdam4117RangeHighLow |
 | GetAdam4117RangeIndex | Get the ADAM-4117 range code index
 | GetAdam4117RangeName | Get the ADAM-4117 range name.
 | GetAdam4117ScaledValue |
 | GetAdam4118RangeCode | Get the ADAM-4118 range code.
 | GetAdam4118RangeHighLow |
 | GetAdam4118RangeIndex | Get the ADAM-4118 range code index
 | GetAdam4118RangeName | Get the ADAM-4118 range name.
 | GetAdam4118ScaledValue |
 | GetAdam5013RangeCode | Get the ADAM-5013 range code.
 | GetAdam5013RangeHighLow |
 | GetAdam5013RangeIndex | Get the ADAM-5013 range code index
 | GetAdam5013RangeName | Get the ADAM-5013 range name.
 | GetAdam5013ScaledValue |
 | GetAdam5017HRangeCode | Get the ADAM-5017H range code.
 | GetAdam5017HRangeHighLow |
 | GetAdam5017HRangeIndex | Get the ADAM-5017H range code index
 | GetAdam5017HRangeName | Get the ADAM-5017H range name.
 | GetAdam5017HScaledValue |
 | GetAdam5017PRangeCode | Get the ADAM-5017P range code.
 | GetAdam5017PRangeHighLow |
 | GetAdam5017PRangeIndex | Get the ADAM-5017P range code index
 | GetAdam5017PRangeName | Get the ADAM-5017P range name.
 | GetAdam5017PScaledValue |
 | GetAdam5017RangeCode | Get the ADAM-5017 range code.
 | GetAdam5017RangeHighLow |
 | GetAdam5017RangeIndex | Get the ADAM-5017 range code index
 | GetAdam5017RangeName | Get the ADAM-5017 range name.
 | GetAdam5017ScaledValue |
 | GetAdam5017SRangeCode | Get the ADAM-5017S range code.
 | GetAdam5017SRangeHighLow |
 | GetAdam5017SRangeIndex | Get the ADAM-5017S range code index
 | GetAdam5017SRangeName | Get the ADAM-5017S range name.
 | GetAdam5017SScaledValue |
 | GetAdam5017UHRangeCode | Get the ADAM-5017UH range code.
 | GetAdam5017UHRangeHighLow |
 | GetAdam5017UHRangeIndex | Get the ADAM-5017UH range code index
 | GetAdam5017UHRangeName | Get the ADAM-5017UH range name.
 | GetAdam5017UHScaledValue |
 | GetAdam5018PRangeCode | Get the ADAM-5018P range code.
 | GetAdam5018PRangeHighLow |
 | GetAdam5018PRangeIndex | Get the ADAM-5018P range code index
 | GetAdam5018PRangeName | Get the ADAM-5018P range name.
 | GetAdam5018PScaledValue |
 | GetAdam5018RangeCode | Get the ADAM-5018 range code.
 | GetAdam5018RangeHighLow |
 | GetAdam5018RangeIndex | Get the ADAM-5018 range code index
 | GetAdam5018RangeName | Get the ADAM-5018 range name.
 | GetAdam5018ScaledValue |
 | GetAdam6015RangeCode |
 | GetAdam6015RangeHighLow |
 | GetAdam6015RangeIndex |
 | GetAdam6015RangeName |
 | GetAdam6015ScaledValue |
 | GetAdam6017RangeCode |
 | GetAdam6017RangeCode2Byte |
 | GetAdam6017RangeHighLow |
 | GetAdam6017RangeIndex | Overloaded.
 | GetAdam6017RangeName |
 | GetAdam6017ScaledValue |
 | GetAdam6018RangeCode |
 | GetAdam6018RangeHighLow |
 | GetAdam6018RangeIndex |
 | GetAdam6018RangeName |
 | GetAdam6018ScaledValue |
 | GetAdam6022RangeCode |
 | GetAdam6022RangeHighLow |
 | GetAdam6022RangeIndex |
 | GetAdam6022RangeName |
 | GetAdam6022ScaledValue |
 | GetAdam6024RangeCode |
 | GetAdam6024RangeHighLow |
 | GetAdam6024RangeIndex |
 | GetAdam6024RangeName |
 | GetAdam6024ScaledValue |
 | GetAdam6217RangeCode2Byte |
 | GetAdam6217RangeIndex |
 | GetAdam6218RangeCode2Byte |
 | GetAdam6218RangeIndex |
 | GetAdam6224RangeCode2Byte |
 | GetAdam6224RangeIndex |
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
AnalogInput | Overloaded.
Top

See Also

AnalogInput Class
Advantech.Adam Namespace


AnalogInput Constructor

AnalogInput Constructor

Overload List

 | Name | Description
Public method | AnalogInput (AdamCom) | The AnalogInput constructor.
Public method | AnalogInput (AdamControl) | The AnalogInput constructor.
Public method | AnalogInput (AdamSocket) | The AnalogInput constructor.

See Also

AnalogInput Class
Advantech.Adam Namespace


AnalogInput Constructor (AdamCom)

AnalogInput Constructor (AdamCom)
See Also Example
[image]

The AnalogInput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public AnalogInput(
AdamCom i_com
)
C++
public:
AnalogInput(
AdamCom i_com
) sealed
J#
public AnalogInput(
AdamCom i_com
)
JScript
public function AnalogInput(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput Constructor Overload List


AnalogInput Constructor (AdamControl)

AnalogInput Constructor (AdamControl)
See Also Example
[image]

The AnalogInput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public AnalogInput(
AdamControl i_control
)
C++
public:
AnalogInput(
AdamControl i_control
) sealed
J#
public AnalogInput(
AdamControl i_control
)
JScript
public function AnalogInput(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput Constructor Overload List


AnalogInput Constructor (AdamSocket)

AnalogInput Constructor (AdamSocket)
See Also Example
[image]

The AnalogInput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public AnalogInput(
AdamSocket i_socket
)
C++
public:
AnalogInput(
AdamSocket i_socket
) sealed
J#
public AnalogInput(
AdamSocket i_socket
)
JScript
public function AnalogInput(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput Constructor Overload List


Methods

AnalogInput Methods
[image]

Public Methods

 | Name | Description
 | Get4100IntegrationName | Get integration name for ADAM-4100.
Public method | GetAutoFilterEnabled | Support module: ADAM-4100. Get Auto-filter channel enabled status and filter percentage index.
Public method | GetAutoFilterProgress | Support module: ADAM-4100. Get Auto-filter progress percentage.
Public method | GetAutoFilterSampleRate | Support module: ADAM-4100. Get Auto-filter sampling rate.
Public method | GetAverageChannelEnabled | Support module: ADAM-6000. Get channel enabled status for average
Public method | GetBiasValue | Support module: ADAM-4018P. Get bias value.
Public method | GetBurnoutDetect | Overloaded. Support module: ADAM-4100. Get burnout detect setting.
Public method | GetBurnoutFunEnable | Support module: APAX-5000. Get Burnout Function Enable Mask
Public method | GetBurnoutMap | Overloaded. Support module: ADAM-4100. Get burnout mapping.
Public method | GetBurnoutValue | Support module: APAX-5000. Get The Value While Burnout
Public method | GetCalibrationValues | Support module: ADAM-5017P, ADAM-5018P. Get analog input calibration value.
Public method | GetChannelDiagnostic | Support module: ADAM-4022T, ADAM-4019P Get channel diagnostic status.
Public method | GetChannelEnabled | Overloaded. Support module: ADAM-4100, ADAM-6000. Get channel enabled status
Public method | GetChannelStatus | Overloaded. Support module: APAX-5000. Get channel status.
 | GetChannelTotal | Overloaded. Get the channel total
Public method | GetChValOffset | Support module: APAX-5000. Get channel value offset.
Public method | GetCJCValue | Overloaded. Support module: ADAM-5000, ADAM-5000TCP. Get CJC calibration value
Public method | GetDataFormat | Support module: ADAM-5017H, ADAM-5017UH. Get module data format
 | GetDataFormatCode | Overloaded. Get the data format code.
 | GetDataFormatIndex | Overloaded. Get the data format index
 | GetDataFormatName | Overloaded. Get the data format name
 | GetDataFormatTotal | Overloaded. Get the data format total
 | GetFloatFormat | Overloaded. Get floating format
Public method | GetInputRange | Overloaded. Support module: ADAM-4000 (Channel Independent Configuration), ADAM-4100, ADAM-6000. Get module analog input range
Public method | GetIntegration | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Get module integration time
 | GetIntegrationCode | Get the integration code
 | GetIntegrationIndex | Get integration index
 | GetIntegrationName | Get integration name.
 | GetIntegrationTotal | Get integration total.
Public method | GetLeadWire | Support module: ADAM-4000. Get lead wire resistance value
Public method | GetMemConfig | Support module: ADAM-4018M. Get memory configuration.
Public method | GetMemEventRecordCount | Support module: ADAM-4018M. Get memory event record counts.
Public method | GetMemOperation | Support module: ADAM-4018M. Get memory operation.
Public method | GetMemRecordData | Support module: ADAM-4018M. Get memory data record.
Public method | GetMemStandardRecordCount | Support module: ADAM-4018M. Get memory standard record counts.
 | GetRangeCode | Overloaded. Get the range code
 | GetRangeCode2Byte | Overloaded. Get the range code
 | GetRangeHighLow | Overloaded. Get the range boundary
 | GetRangeIndex | Overloaded. Get the range code index
Public method | GetRangeIntegration | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000/TCP. Get module analog input range and integration time
Public method | GetRangeIntegrationDataFormat | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000. Get module analog input range, integration time and data format
 | GetRangeName | Overloaded. Get the range name
 | GetRangeTotal | Overloaded. Get the range total
Public method | GetSampleRate | Support module: APAX-5000. Get module analog input sample rate
 | GetScaledValue | Overloaded. Get the scaled value
 | GetScaledValueWithResolution | Get the scaled value with resolution for unknown APAX module
 | GetSpanCalibrationName | Overloaded. Get the span calibration apply string
 | GetUnitName | Overloaded. Get unit string
Public method | GetUnknownModuleDescription | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module description.
Public method | GetUnknownModuleInfo | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module information.
Public method | GetUnknownModuleName | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module name.
Public method | GetUnknownRangeSupport | Support module: ADAM-5000, ADAM-5000TCP. Get unknown module range code.
Public method | GetValue | Overloaded. Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get specified channel value. The value returned is in engineering unit format.
Public method | GetValues | Overloaded. Support module: ADAM-5000 Get channel values when the data format is set to two's complement hexdecimal.
 | GetZeroCalibrationName | Overloaded. Get the zero calibration apply string
Public method | ODM17S_GetEnableChannelTotal | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S enable channel number.
Public method | ODM17S_GetFifoData | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S enable channel number.
Public method | ODM17S_GetMode | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S acquisition mode
Public method | ODM17S_GetRange | Support module: ADAM-5017S ODM on ADAM-5550. Get module analog input range.
Public method | ODM17S_GetSampleRate | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S sampling rate.
Public method | ODM17S_GetTrigTotal | Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S trigger total number.
Public method | ODM17S_SetEnableChannelTotal | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S enable channel number.
Public method | ODM17S_SetMode | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S acquisition mode.
Public method | ODM17S_SetRange | Support module: ADAM-5017S ODM on ADAM-5550. Set module analog input range.
Public method | ODM17S_SetSampleRate | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S sampling rate.
Public method | ODM17S_SetStart | Support module: ADAM-5017S ODM on ADAM-5550. ODM ADAM-5017S start to get value.
Public method | ODM17S_SetStop | Support module: ADAM-5017S ODM on ADAM-5550. ODM ADAM-5017S stop getting value.
Public method | ODM17S_SetTrigTotal | Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S trigger total number.
Public method | SetAutoCalibration | Support module: APAX-5000, APAX-5070(UDP:5222). Set analog input auto-calibration
Public method | SetAutoFilter | Support module: ADAM-4100. Set Auto-filter.
Public method | SetAutoFilterEnabled | Support module: ADAM-4100. Set Auto-filter channel enabled status and filter percentage index.
Public method | SetAverageChannelEnabled | Support module: ADAM-6000. Set channel enabled status for average
Public method | SetBiasValue | Support module: ADAM-4018P. Set bias value.
Public method | SetBurnoutDetect | Overloaded. Support module: ADAM-4100. Set burnout detect setting.
Public method | SetBurnoutFunEnable | Support module: APAX-5000. Set burnout function.
Public method | SetBurnoutMap | Overloaded. Support module: ADAM-4100. Set burnout mapping.
Public method | SetBurnoutValue | Support module: APAX-5000. Set The Value While Burnout.
Public method | SetChannelEnabled | Overloaded. Support module: ADAM-4100, ADAM-6000. Set channel enabled status
Public method | SetChannelNegCalibration | Support module: ADAM-4000. Set analog input Neg. calibration
Public method | SetChannelSpanCalibration | Support module: ADAM-4000. Set analog input Span calibration
Public method | SetChannelZeroCalibration | Support module: ADAM-4000. Set analog input Zero calibration
Public method | SetChValOffset | Support module: APAX-5000. Set channel value offset.
Public method | SetCjcInitValRecord | Support module: APAX-5000. CJC Initial Value Record.
Public method | SetCJCOffset | Overloaded. Support module: ADAM-5000, ADAM-5000TCP, APAX-5000. Set CJC offset calibration value
Public method | SetCJCValue | Support module: ADAM-6000. Set CJC calibration value
Public method | SetDataFormat | Support module: ADAM-5017H, ADAM-5017UH. Set module data format
Public method | SetInputRange | Overloaded. Support module: ADAM-4000 (Channel Independant Configuration), ADAM-4100, ADAM-6000. Set module analog input range
Public method | SetIntegration | Overloaded. Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Set module integration time
Public method | SetLeadWire | Support module: ADAM-4000. Set lead wire resistance value
Public method | SetMemConfig | Support module: ADAM-4018M. Set memory configuration.
Public method | SetMemOperation | Support module: ADAM-4018M. Set memory operation.
Public method | SetRangeIntegration | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000/TCP. Set module analog input range and integration time
Public method | SetRangeIntegrationDataFormat | Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000. Set module analog input range, integration time and data format
Public method | SetRanges | Support module: APAX-5000. Set module analog input ranges
Public method | SetSampleRate | Support module: APAX-5000. Set module analog input sample rate
Public method | SetSpanCalibration | Overloaded. Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Span calibration
Public method | SetThermoCalibration | Support module: APAX-5000. Set Thermal Couple Calibration.
Public method | SetZeroCalibration | Overloaded. Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Zero calibration
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetAdam4011RangeCode | Get the ADAM-4011 range code.
 | GetAdam4011RangeIndex | Get the ADAM-4011 range code index
 | GetAdam4011RangeName | Get the ADAM-4011 range name.
 | GetAdam4012RangeCode | Get the ADAM-4012 range code.
 | GetAdam4012RangeIndex | Get the ADAM-4012 range code index
 | GetAdam4012RangeName | Get the ADAM-4012 range name.
 | GetAdam4013RangeCode | Get the ADAM-4013 range code.
 | GetAdam4013RangeIndex | Get the ADAM-4013 range code index
 | GetAdam4013RangeName | Get the ADAM-4013 range name.
 | GetAdam4015RangeCode |
 | GetAdam4015RangeHighLow |
 | GetAdam4015RangeIndex |
 | GetAdam4015RangeName |
 | GetAdam4015ScaledValue |
 | GetAdam4015TRangeCode |
 | GetAdam4015TRangeHighLow |
 | GetAdam4015TRangeIndex |
 | GetAdam4015TRangeName |
 | GetAdam4015TScaledValue |
 | GetAdam4016RangeCode | Get the ADAM-4016 range code.
 | GetAdam4016RangeIndex | Get the ADAM-4016 range code index
 | GetAdam4016RangeName | Get the ADAM-4016 range name.
 | GetAdam4017PRangeCode |
 | GetAdam4017PRangeHighLow |
 | GetAdam4017PRangeIndex |
 | GetAdam4017PRangeName |
 | GetAdam4017PScaledValue |
 | GetAdam4017RangeCode | Get the ADAM-4017 range code.
 | GetAdam4017RangeIndex | Get the ADAM-4017 range code index
 | GetAdam4017RangeName | Get the ADAM-4017 range name.
 | GetAdam4018PRangeCode |
 | GetAdam4018PRangeHighLow |
 | GetAdam4018PRangeIndex |
 | GetAdam4018PRangeName |
 | GetAdam4018PScaledValue |
 | GetAdam4018RangeCode | Get the ADAM-4018 range code.
 | GetAdam4018RangeIndex | Get the ADAM-4018 range code index
 | GetAdam4018RangeName | Get the ADAM-4018 range name.
 | GetAdam4019PRangeCode | Get the ADAM-4019P range code.
 | GetAdam4019PRangeHighLow |
 | GetAdam4019PRangeIndex | Get the ADAM-4019P range code index
 | GetAdam4019PRangeName | Get the ADAM-4019P range name.
 | GetAdam4019PScaledValue |
 | GetAdam4019RangeCode | Get the ADAM-4019 range code.
 | GetAdam4019RangeIndex | Get the ADAM-4019 range code index
 | GetAdam4019RangeName | Get the ADAM-4019 range name.
 | GetAdam4022TRangeCode | Get the ADAM-4022T range code.
 | GetAdam4022TRangeHighLow |
 | GetAdam4022TRangeIndex | Get the ADAM-4022T range code index
 | GetAdam4022TRangeName | Get the ADAM-4022T range name.
 | GetAdam4022TScaledValue |
 | GetAdam4117RangeCode | Get the ADAM-4117 range code.
 | GetAdam4117RangeHighLow |
 | GetAdam4117RangeIndex | Get the ADAM-4117 range code index
 | GetAdam4117RangeName | Get the ADAM-4117 range name.
 | GetAdam4117ScaledValue |
 | GetAdam4118RangeCode | Get the ADAM-4118 range code.
 | GetAdam4118RangeHighLow |
 | GetAdam4118RangeIndex | Get the ADAM-4118 range code index
 | GetAdam4118RangeName | Get the ADAM-4118 range name.
 | GetAdam4118ScaledValue |
 | GetAdam5013RangeCode | Get the ADAM-5013 range code.
 | GetAdam5013RangeHighLow |
 | GetAdam5013RangeIndex | Get the ADAM-5013 range code index
 | GetAdam5013RangeName | Get the ADAM-5013 range name.
 | GetAdam5013ScaledValue |
 | GetAdam5017HRangeCode | Get the ADAM-5017H range code.
 | GetAdam5017HRangeHighLow |
 | GetAdam5017HRangeIndex | Get the ADAM-5017H range code index
 | GetAdam5017HRangeName | Get the ADAM-5017H range name.
 | GetAdam5017HScaledValue |
 | GetAdam5017PRangeCode | Get the ADAM-5017P range code.
 | GetAdam5017PRangeHighLow |
 | GetAdam5017PRangeIndex | Get the ADAM-5017P range code index
 | GetAdam5017PRangeName | Get the ADAM-5017P range name.
 | GetAdam5017PScaledValue |
 | GetAdam5017RangeCode | Get the ADAM-5017 range code.
 | GetAdam5017RangeHighLow |
 | GetAdam5017RangeIndex | Get the ADAM-5017 range code index
 | GetAdam5017RangeName | Get the ADAM-5017 range name.
 | GetAdam5017ScaledValue |
 | GetAdam5017SRangeCode | Get the ADAM-5017S range code.
 | GetAdam5017SRangeHighLow |
 | GetAdam5017SRangeIndex | Get the ADAM-5017S range code index
 | GetAdam5017SRangeName | Get the ADAM-5017S range name.
 | GetAdam5017SScaledValue |
 | GetAdam5017UHRangeCode | Get the ADAM-5017UH range code.
 | GetAdam5017UHRangeHighLow |
 | GetAdam5017UHRangeIndex | Get the ADAM-5017UH range code index
 | GetAdam5017UHRangeName | Get the ADAM-5017UH range name.
 | GetAdam5017UHScaledValue |
 | GetAdam5018PRangeCode | Get the ADAM-5018P range code.
 | GetAdam5018PRangeHighLow |
 | GetAdam5018PRangeIndex | Get the ADAM-5018P range code index
 | GetAdam5018PRangeName | Get the ADAM-5018P range name.
 | GetAdam5018PScaledValue |
 | GetAdam5018RangeCode | Get the ADAM-5018 range code.
 | GetAdam5018RangeHighLow |
 | GetAdam5018RangeIndex | Get the ADAM-5018 range code index
 | GetAdam5018RangeName | Get the ADAM-5018 range name.
 | GetAdam5018ScaledValue |
 | GetAdam6015RangeCode |
 | GetAdam6015RangeHighLow |
 | GetAdam6015RangeIndex |
 | GetAdam6015RangeName |
 | GetAdam6015ScaledValue |
 | GetAdam6017RangeCode |
 | GetAdam6017RangeCode2Byte |
 | GetAdam6017RangeHighLow |
 | GetAdam6017RangeIndex | Overloaded.
 | GetAdam6017RangeName |
 | GetAdam6017ScaledValue |
 | GetAdam6018RangeCode |
 | GetAdam6018RangeHighLow |
 | GetAdam6018RangeIndex |
 | GetAdam6018RangeName |
 | GetAdam6018ScaledValue |
 | GetAdam6022RangeCode |
 | GetAdam6022RangeHighLow |
 | GetAdam6022RangeIndex |
 | GetAdam6022RangeName |
 | GetAdam6022ScaledValue |
 | GetAdam6024RangeCode |
 | GetAdam6024RangeHighLow |
 | GetAdam6024RangeIndex |
 | GetAdam6024RangeName |
 | GetAdam6024ScaledValue |
 | GetAdam6217RangeCode2Byte |
 | GetAdam6217RangeIndex |
 | GetAdam6218RangeCode2Byte |
 | GetAdam6218RangeIndex |
 | GetAdam6224RangeCode2Byte |
 | GetAdam6224RangeIndex |
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

AnalogInput Class
Advantech.Adam Namespace


Get4100IntegrationName Method

AnalogInput.Get4100IntegrationName Method
[image]

Get integration name for ADAM-4100.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get4100IntegrationName( _
ByVal i_byCode As Byte _
) As String
C#
public static string Get4100IntegrationName(
byte i_byCode
)
C++
public:
static String Get4100IntegrationName(
char i_byCode
)
J#
public static string Get4100IntegrationName(
byte i_byCode
)
JScript
public static function Get4100IntegrationName(
i_byCode : Byte
) : String

Parameters

i_byCode
The integration index.

Return Value

Return integration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4011RangeCode Method

AnalogInput.GetAdam4011RangeCode Method
[image]

Get the ADAM-4011 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4011RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4011RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4011RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4011RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4011RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~13.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4011RangeIndex Method

AnalogInput.GetAdam4011RangeIndex Method
[image]

Get the ADAM-4011 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4011RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4011RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4011RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4011RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4011RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4011RangeName Method

AnalogInput.GetAdam4011RangeName Method
[image]

Get the ADAM-4011 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4011RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4011RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4011RangeName(
char i_byRange
)
J#
protected static string GetAdam4011RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4011RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4012RangeCode Method

AnalogInput.GetAdam4012RangeCode Method
[image]

Get the ADAM-4012 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4012RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4012RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4012RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4012RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4012RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~5.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4012RangeIndex Method

AnalogInput.GetAdam4012RangeIndex Method
[image]

Get the ADAM-4012 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4012RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4012RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4012RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4012RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4012RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4012RangeName Method

AnalogInput.GetAdam4012RangeName Method
[image]

Get the ADAM-4012 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4012RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4012RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4012RangeName(
char i_byRange
)
J#
protected static string GetAdam4012RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4012RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4013RangeCode Method

AnalogInput.GetAdam4013RangeCode Method
[image]

Get the ADAM-4013 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4013RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4013RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4013RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4013RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4013RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~9.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4013RangeIndex Method

AnalogInput.GetAdam4013RangeIndex Method
[image]

Get the ADAM-4013 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4013RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4013RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4013RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4013RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4013RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4013RangeName Method

AnalogInput.GetAdam4013RangeName Method
[image]

Get the ADAM-4013 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4013RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4013RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4013RangeName(
char i_byRange
)
J#
protected static string GetAdam4013RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4013RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015RangeCode Method

AnalogInput.GetAdam4015RangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4015RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4015RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4015RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4015RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015RangeHighLow Method

AnalogInput.GetAdam4015RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4015RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4015RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4015RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4015RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4015RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015RangeIndex Method

AnalogInput.GetAdam4015RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4015RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4015RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4015RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4015RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015RangeName Method

AnalogInput.GetAdam4015RangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4015RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4015RangeName(
char i_byRange
)
J#
protected static string GetAdam4015RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4015RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015ScaledValue Method

AnalogInput.GetAdam4015ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4015ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4015ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4015ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4015ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015TRangeCode Method

AnalogInput.GetAdam4015TRangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015TRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4015TRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4015TRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4015TRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4015TRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015TRangeHighLow Method

AnalogInput.GetAdam4015TRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4015TRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4015TRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4015TRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4015TRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4015TRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015TRangeIndex Method

AnalogInput.GetAdam4015TRangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015TRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4015TRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4015TRangeIndex(
char i_byRange
)
J#
protected static int GetAdam4015TRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4015TRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015TRangeName Method

AnalogInput.GetAdam4015TRangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015TRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4015TRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4015TRangeName(
char i_byRange
)
J#
protected static string GetAdam4015TRangeName(
byte i_byRange
)
JScript
protected static function GetAdam4015TRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4015TScaledValue Method

AnalogInput.GetAdam4015TScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4015TScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4015TScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4015TScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4015TScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4015TScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4016RangeCode Method

AnalogInput.GetAdam4016RangeCode Method
[image]

Get the ADAM-4016 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4016RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4016RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4016RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4016RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4016RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~4.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4016RangeIndex Method

AnalogInput.GetAdam4016RangeIndex Method
[image]

Get the ADAM-4016 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4016RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4016RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4016RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4016RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4016RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4016RangeName Method

AnalogInput.GetAdam4016RangeName Method
[image]

Get the ADAM-4016 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4016RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4016RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4016RangeName(
char i_byRange
)
J#
protected static string GetAdam4016RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4016RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017PRangeCode Method

AnalogInput.GetAdam4017PRangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4017PRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4017PRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4017PRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4017PRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4017PRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017PRangeHighLow Method

AnalogInput.GetAdam4017PRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4017PRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4017PRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4017PRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4017PRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4017PRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017PRangeIndex Method

AnalogInput.GetAdam4017PRangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4017PRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4017PRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4017PRangeIndex(
char i_byRange
)
J#
protected static int GetAdam4017PRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4017PRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017PRangeName Method

AnalogInput.GetAdam4017PRangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4017PRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4017PRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4017PRangeName(
char i_byRange
)
J#
protected static string GetAdam4017PRangeName(
byte i_byRange
)
JScript
protected static function GetAdam4017PRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017PScaledValue Method

AnalogInput.GetAdam4017PScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4017PScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4017PScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4017PScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4017PScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4017PScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017RangeCode Method

AnalogInput.GetAdam4017RangeCode Method
[image]

Get the ADAM-4017 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4017RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4017RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4017RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4017RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4017RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~5.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017RangeIndex Method

AnalogInput.GetAdam4017RangeIndex Method
[image]

Get the ADAM-4017 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4017RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4017RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4017RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4017RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4017RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4017RangeName Method

AnalogInput.GetAdam4017RangeName Method
[image]

Get the ADAM-4017 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4017RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4017RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4017RangeName(
char i_byRange
)
J#
protected static string GetAdam4017RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4017RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018PRangeCode Method

AnalogInput.GetAdam4018PRangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4018PRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4018PRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4018PRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4018PRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4018PRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018PRangeHighLow Method

AnalogInput.GetAdam4018PRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4018PRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4018PRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4018PRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4018PRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4018PRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018PRangeIndex Method

AnalogInput.GetAdam4018PRangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4018PRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4018PRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4018PRangeIndex(
char i_byRange
)
J#
protected static int GetAdam4018PRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4018PRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018PRangeName Method

AnalogInput.GetAdam4018PRangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4018PRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4018PRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4018PRangeName(
char i_byRange
)
J#
protected static string GetAdam4018PRangeName(
byte i_byRange
)
JScript
protected static function GetAdam4018PRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018PScaledValue Method

AnalogInput.GetAdam4018PScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4018PScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4018PScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4018PScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4018PScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4018PScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018RangeCode Method

AnalogInput.GetAdam4018RangeCode Method
[image]

Get the ADAM-4018 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4018RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4018RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4018RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4018RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4018RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~13.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018RangeIndex Method

AnalogInput.GetAdam4018RangeIndex Method
[image]

Get the ADAM-4018 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4018RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4018RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4018RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4018RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4018RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4018RangeName Method

AnalogInput.GetAdam4018RangeName Method
[image]

Get the ADAM-4018 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4018RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4018RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4018RangeName(
char i_byRange
)
J#
protected static string GetAdam4018RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4018RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019PRangeCode Method

AnalogInput.GetAdam4019PRangeCode Method
[image]

Get the ADAM-4019P range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4019PRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4019PRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4019PRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4019PRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4019PRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~14.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019PRangeHighLow Method

AnalogInput.GetAdam4019PRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4019PRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4019PRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4019PRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4019PRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4019PRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019PRangeIndex Method

AnalogInput.GetAdam4019PRangeIndex Method
[image]

Get the ADAM-4019P range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4019PRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4019PRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4019PRangeIndex(
char i_byRange
)
J#
protected static int GetAdam4019PRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4019PRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019PRangeName Method

AnalogInput.GetAdam4019PRangeName Method
[image]

Get the ADAM-4019P range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4019PRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4019PRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4019PRangeName(
char i_byRange
)
J#
protected static string GetAdam4019PRangeName(
byte i_byRange
)
JScript
protected static function GetAdam4019PRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019PScaledValue Method

AnalogInput.GetAdam4019PScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4019PScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4019PScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4019PScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4019PScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4019PScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019RangeCode Method

AnalogInput.GetAdam4019RangeCode Method
[image]

Get the ADAM-4019 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4019RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4019RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4019RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4019RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4019RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~13.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019RangeIndex Method

AnalogInput.GetAdam4019RangeIndex Method
[image]

Get the ADAM-4019 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4019RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4019RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4019RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4019RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4019RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4019RangeName Method

AnalogInput.GetAdam4019RangeName Method
[image]

Get the ADAM-4019 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4019RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4019RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4019RangeName(
char i_byRange
)
J#
protected static string GetAdam4019RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4019RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4022TRangeCode Method

AnalogInput.GetAdam4022TRangeCode Method
[image]

Get the ADAM-4022T range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4022TRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4022TRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4022TRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4022TRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~13.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4022TRangeHighLow Method

AnalogInput.GetAdam4022TRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4022TRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4022TRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4022TRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4022TRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4022TRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4022TRangeIndex Method

AnalogInput.GetAdam4022TRangeIndex Method
[image]

Get the ADAM-4022T range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4022TRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4022TRangeIndex(
char i_byRange
)
J#
protected static int GetAdam4022TRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4022TRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4022TRangeName Method

AnalogInput.GetAdam4022TRangeName Method
[image]

Get the ADAM-4022T range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4022TRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4022TRangeName(
char i_byRange
)
J#
protected static string GetAdam4022TRangeName(
byte i_byRange
)
JScript
protected static function GetAdam4022TRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4022TScaledValue Method

AnalogInput.GetAdam4022TScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4022TScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4022TScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4022TScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4022TScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4117RangeCode Method

AnalogInput.GetAdam4117RangeCode Method
[image]

Get the ADAM-4117 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4117RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4117RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4117RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4117RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4117RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~14.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4117RangeHighLow Method

AnalogInput.GetAdam4117RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4117RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4117RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4117RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4117RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4117RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4117RangeIndex Method

AnalogInput.GetAdam4117RangeIndex Method
[image]

Get the ADAM-4117 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4117RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4117RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4117RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4117RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4117RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4117RangeName Method

AnalogInput.GetAdam4117RangeName Method
[image]

Get the ADAM-4117 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4117RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4117RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4117RangeName(
char i_byRange
)
J#
protected static string GetAdam4117RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4117RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4117ScaledValue Method

AnalogInput.GetAdam4117ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4117ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4117ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4117ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4117ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4117ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4118RangeCode Method

AnalogInput.GetAdam4118RangeCode Method
[image]

Get the ADAM-4118 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4118RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4118RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4118RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4118RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4118RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~14.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4118RangeHighLow Method

AnalogInput.GetAdam4118RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam4118RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam4118RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam4118RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam4118RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam4118RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4118RangeIndex Method

AnalogInput.GetAdam4118RangeIndex Method
[image]

Get the ADAM-4118 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4118RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4118RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4118RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4118RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4118RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4118RangeName Method

AnalogInput.GetAdam4118RangeName Method
[image]

Get the ADAM-4118 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4118RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4118RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4118RangeName(
char i_byRange
)
J#
protected static string GetAdam4118RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4118RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam4118ScaledValue Method

AnalogInput.GetAdam4118ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4118ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4118ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4118ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4118ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4118ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5013RangeCode Method

AnalogInput.GetAdam5013RangeCode Method
[image]

Get the ADAM-5013 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5013RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5013RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5013RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5013RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5013RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~9.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5013RangeHighLow Method

AnalogInput.GetAdam5013RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5013RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5013RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5013RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5013RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5013RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5013RangeIndex Method

AnalogInput.GetAdam5013RangeIndex Method
[image]

Get the ADAM-5013 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5013RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5013RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5013RangeIndex(
char i_byRange
)
J#
protected static int GetAdam5013RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5013RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5013RangeName Method

AnalogInput.GetAdam5013RangeName Method
[image]

Get the ADAM-5013 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5013RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5013RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5013RangeName(
char i_byRange
)
J#
protected static string GetAdam5013RangeName(
byte i_byRange
)
JScript
protected static function GetAdam5013RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5013ScaledValue Method

AnalogInput.GetAdam5013ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5013ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5013ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5013ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5013ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5013ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017HRangeCode Method

AnalogInput.GetAdam5017HRangeCode Method
[image]

Get the ADAM-5017H range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017HRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5017HRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5017HRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5017HRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5017HRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~11.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017HRangeHighLow Method

AnalogInput.GetAdam5017HRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5017HRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5017HRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5017HRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5017HRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5017HRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017HRangeIndex Method

AnalogInput.GetAdam5017HRangeIndex Method
[image]

Get the ADAM-5017H range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017HRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5017HRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5017HRangeIndex(
char i_byRange
)
J#
protected static int GetAdam5017HRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5017HRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017HRangeName Method

AnalogInput.GetAdam5017HRangeName Method
[image]

Get the ADAM-5017H range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017HRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5017HRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5017HRangeName(
char i_byRange
)
J#
protected static string GetAdam5017HRangeName(
byte i_byRange
)
JScript
protected static function GetAdam5017HRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017HScaledValue Method

AnalogInput.GetAdam5017HScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017HScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5017HScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5017HScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5017HScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5017HScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017PRangeCode Method

AnalogInput.GetAdam5017PRangeCode Method
[image]

Get the ADAM-5017P range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017PRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5017PRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5017PRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5017PRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5017PRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~14.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017PRangeHighLow Method

AnalogInput.GetAdam5017PRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5017PRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5017PRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5017PRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5017PRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5017PRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017PRangeIndex Method

AnalogInput.GetAdam5017PRangeIndex Method
[image]

Get the ADAM-5017P range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017PRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5017PRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5017PRangeIndex(
char i_byRange
)
J#
protected static int GetAdam5017PRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5017PRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017PRangeName Method

AnalogInput.GetAdam5017PRangeName Method
[image]

Get the ADAM-5017P range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017PRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5017PRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5017PRangeName(
char i_byRange
)
J#
protected static string GetAdam5017PRangeName(
byte i_byRange
)
JScript
protected static function GetAdam5017PRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017PScaledValue Method

AnalogInput.GetAdam5017PScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017PScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5017PScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5017PScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5017PScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5017PScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017RangeCode Method

AnalogInput.GetAdam5017RangeCode Method
[image]

Get the ADAM-5017 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5017RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5017RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5017RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5017RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~6.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017RangeHighLow Method

AnalogInput.GetAdam5017RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5017RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5017RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5017RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5017RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5017RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017RangeIndex Method

AnalogInput.GetAdam5017RangeIndex Method
[image]

Get the ADAM-5017 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5017RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5017RangeIndex(
char i_byRange
)
J#
protected static int GetAdam5017RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5017RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017RangeName Method

AnalogInput.GetAdam5017RangeName Method
[image]

Get the ADAM-5017 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5017RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5017RangeName(
char i_byRange
)
J#
protected static string GetAdam5017RangeName(
byte i_byRange
)
JScript
protected static function GetAdam5017RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017ScaledValue Method

AnalogInput.GetAdam5017ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5017ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5017ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5017ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5017ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017SRangeCode Method

AnalogInput.GetAdam5017SRangeCode Method
[image]

Get the ADAM-5017S range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017SRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5017SRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5017SRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5017SRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5017SRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017SRangeHighLow Method

AnalogInput.GetAdam5017SRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5017SRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5017SRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5017SRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5017SRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5017SRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017SRangeIndex Method

AnalogInput.GetAdam5017SRangeIndex Method
[image]

Get the ADAM-5017S range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017SRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5017SRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5017SRangeIndex(
char i_byRange
)
J#
protected static int GetAdam5017SRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5017SRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017SRangeName Method

AnalogInput.GetAdam5017SRangeName Method
[image]

Get the ADAM-5017S range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017SRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5017SRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5017SRangeName(
char i_byRange
)
J#
protected static string GetAdam5017SRangeName(
byte i_byRange
)
JScript
protected static function GetAdam5017SRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017SScaledValue Method

AnalogInput.GetAdam5017SScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017SScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5017SScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5017SScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5017SScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5017SScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017UHRangeCode Method

AnalogInput.GetAdam5017UHRangeCode Method
[image]

Get the ADAM-5017UH range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017UHRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5017UHRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5017UHRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5017UHRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5017UHRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~4.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017UHRangeHighLow Method

AnalogInput.GetAdam5017UHRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5017UHRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5017UHRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5017UHRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5017UHRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5017UHRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017UHRangeIndex Method

AnalogInput.GetAdam5017UHRangeIndex Method
[image]

Get the ADAM-5017UH range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017UHRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5017UHRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5017UHRangeIndex(
char i_byRange
)
J#
protected static int GetAdam5017UHRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5017UHRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017UHRangeName Method

AnalogInput.GetAdam5017UHRangeName Method
[image]

Get the ADAM-5017UH range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017UHRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5017UHRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5017UHRangeName(
char i_byRange
)
J#
protected static string GetAdam5017UHRangeName(
byte i_byRange
)
JScript
protected static function GetAdam5017UHRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5017UHScaledValue Method

AnalogInput.GetAdam5017UHScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5017UHScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5017UHScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5017UHScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5017UHScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5017UHScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018PRangeCode Method

AnalogInput.GetAdam5018PRangeCode Method
[image]

Get the ADAM-5018P range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018PRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5018PRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5018PRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5018PRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5018PRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~14.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018PRangeHighLow Method

AnalogInput.GetAdam5018PRangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5018PRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5018PRangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5018PRangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5018PRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5018PRangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018PRangeIndex Method

AnalogInput.GetAdam5018PRangeIndex Method
[image]

Get the ADAM-5018P range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018PRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5018PRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5018PRangeIndex(
char i_byRange
)
J#
protected static int GetAdam5018PRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5018PRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018PRangeName Method

AnalogInput.GetAdam5018PRangeName Method
[image]

Get the ADAM-5018P range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018PRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5018PRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5018PRangeName(
char i_byRange
)
J#
protected static string GetAdam5018PRangeName(
byte i_byRange
)
JScript
protected static function GetAdam5018PRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018PScaledValue Method

AnalogInput.GetAdam5018PScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018PScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5018PScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5018PScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5018PScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5018PScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018RangeCode Method

AnalogInput.GetAdam5018RangeCode Method
[image]

Get the ADAM-5018 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5018RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5018RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5018RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5018RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~13.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018RangeHighLow Method

AnalogInput.GetAdam5018RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5018RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5018RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5018RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5018RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5018RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018RangeIndex Method

AnalogInput.GetAdam5018RangeIndex Method
[image]

Get the ADAM-5018 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5018RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5018RangeIndex(
char i_byRange
)
J#
protected static int GetAdam5018RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5018RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018RangeName Method

AnalogInput.GetAdam5018RangeName Method
[image]

Get the ADAM-5018 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5018RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5018RangeName(
char i_byRange
)
J#
protected static string GetAdam5018RangeName(
byte i_byRange
)
JScript
protected static function GetAdam5018RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam5018ScaledValue Method

AnalogInput.GetAdam5018ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5018ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5018ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5018ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5018ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5018ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6015RangeCode Method

AnalogInput.GetAdam6015RangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6015RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6015RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam6015RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam6015RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam6015RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6015RangeHighLow Method

AnalogInput.GetAdam6015RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam6015RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam6015RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam6015RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam6015RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam6015RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6015RangeIndex Method

AnalogInput.GetAdam6015RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6015RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam6015RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam6015RangeIndex(
char i_byRange
)
J#
protected static int GetAdam6015RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam6015RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6015RangeName Method

AnalogInput.GetAdam6015RangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6015RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam6015RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam6015RangeName(
char i_byRange
)
J#
protected static string GetAdam6015RangeName(
byte i_byRange
)
JScript
protected static function GetAdam6015RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6015ScaledValue Method

AnalogInput.GetAdam6015ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6015ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam6015ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam6015ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam6015ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam6015ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6017RangeCode Method

AnalogInput.GetAdam6017RangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6017RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6017RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam6017RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam6017RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam6017RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6017RangeCode2Byte Method

AnalogInput.GetAdam6017RangeCode2Byte Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6017RangeCode2Byte( _
ByVal i_iIndex As Integer _
) As UInt16
C#
protected static ushort GetAdam6017RangeCode2Byte(
int i_iIndex
)
C++
protected:
static unsigned short GetAdam6017RangeCode2Byte(
int i_iIndex
)
J#
protected static ushort GetAdam6017RangeCode2Byte(
int i_iIndex
)
JScript
protected static function GetAdam6017RangeCode2Byte(
i_iIndex : int
) : UInt16

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6017RangeHighLow Method

AnalogInput.GetAdam6017RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam6017RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam6017RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam6017RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam6017RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam6017RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6017RangeIndex Method

AnalogInput.GetAdam6017RangeIndex Method

Overload List

Name | Description
GetAdam6017RangeIndex (Byte) |
GetAdam6017RangeIndex (UInt16) |

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6017RangeIndex Method (Byte)

AnalogInput.GetAdam6017RangeIndex Method (Byte)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6017RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam6017RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam6017RangeIndex(
char i_byRange
)
J#
protected static int GetAdam6017RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam6017RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetAdam6017RangeIndex Overload List


GetAdam6017RangeIndex Method (UInt16)

AnalogInput.GetAdam6017RangeIndex Method (UInt16)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6017RangeIndex( _
ByVal i_usRange As UInt16 _
) As Integer
C#
protected static int GetAdam6017RangeIndex(
ushort i_usRange
)
C++
protected:
static int GetAdam6017RangeIndex(
unsigned short i_usRange
)
J#
protected static int GetAdam6017RangeIndex(
ushort i_usRange
)
JScript
protected static function GetAdam6017RangeIndex(
i_usRange : UInt16
) : int

Parameters

i_usRange

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetAdam6017RangeIndex Overload List


GetAdam6017RangeName Method

AnalogInput.GetAdam6017RangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6017RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam6017RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam6017RangeName(
char i_byRange
)
J#
protected static string GetAdam6017RangeName(
byte i_byRange
)
JScript
protected static function GetAdam6017RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6017ScaledValue Method

AnalogInput.GetAdam6017ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6017ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam6017ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam6017ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam6017ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam6017ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6018RangeCode Method

AnalogInput.GetAdam6018RangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6018RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6018RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam6018RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam6018RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam6018RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6018RangeHighLow Method

AnalogInput.GetAdam6018RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam6018RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam6018RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam6018RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam6018RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam6018RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6018RangeIndex Method

AnalogInput.GetAdam6018RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6018RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam6018RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam6018RangeIndex(
char i_byRange
)
J#
protected static int GetAdam6018RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam6018RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6018RangeName Method

AnalogInput.GetAdam6018RangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6018RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam6018RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam6018RangeName(
char i_byRange
)
J#
protected static string GetAdam6018RangeName(
byte i_byRange
)
JScript
protected static function GetAdam6018RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6018ScaledValue Method

AnalogInput.GetAdam6018ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6018ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam6018ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam6018ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam6018ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam6018ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6022RangeCode Method

AnalogInput.GetAdam6022RangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6022RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam6022RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam6022RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam6022RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6022RangeHighLow Method

AnalogInput.GetAdam6022RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam6022RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam6022RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam6022RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam6022RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam6022RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6022RangeIndex Method

AnalogInput.GetAdam6022RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam6022RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam6022RangeIndex(
char i_byRange
)
J#
protected static int GetAdam6022RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam6022RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6022RangeName Method

AnalogInput.GetAdam6022RangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam6022RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam6022RangeName(
char i_byRange
)
J#
protected static string GetAdam6022RangeName(
byte i_byRange
)
JScript
protected static function GetAdam6022RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6022ScaledValue Method

AnalogInput.GetAdam6022ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam6022ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam6022ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam6022ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam6022ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6024RangeCode Method

AnalogInput.GetAdam6024RangeCode Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6024RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam6024RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam6024RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam6024RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6024RangeHighLow Method

AnalogInput.GetAdam6024RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam6024RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam6024RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam6024RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam6024RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam6024RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6024RangeIndex Method

AnalogInput.GetAdam6024RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam6024RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam6024RangeIndex(
char i_byRange
)
J#
protected static int GetAdam6024RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam6024RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6024RangeName Method

AnalogInput.GetAdam6024RangeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam6024RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam6024RangeName(
char i_byRange
)
J#
protected static string GetAdam6024RangeName(
byte i_byRange
)
JScript
protected static function GetAdam6024RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6024ScaledValue Method

AnalogInput.GetAdam6024ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam6024ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam6024ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam6024ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam6024ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6217RangeCode2Byte Method

AnalogInput.GetAdam6217RangeCode2Byte Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6217RangeCode2Byte( _
ByVal i_iIndex As Integer _
) As UInt16
C#
protected static ushort GetAdam6217RangeCode2Byte(
int i_iIndex
)
C++
protected:
static unsigned short GetAdam6217RangeCode2Byte(
int i_iIndex
)
J#
protected static ushort GetAdam6217RangeCode2Byte(
int i_iIndex
)
JScript
protected static function GetAdam6217RangeCode2Byte(
i_iIndex : int
) : UInt16

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6217RangeIndex Method

AnalogInput.GetAdam6217RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6217RangeIndex( _
ByVal i_usRange As UInt16 _
) As Integer
C#
protected static int GetAdam6217RangeIndex(
ushort i_usRange
)
C++
protected:
static int GetAdam6217RangeIndex(
unsigned short i_usRange
)
J#
protected static int GetAdam6217RangeIndex(
ushort i_usRange
)
JScript
protected static function GetAdam6217RangeIndex(
i_usRange : UInt16
) : int

Parameters

i_usRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6218RangeCode2Byte Method

AnalogInput.GetAdam6218RangeCode2Byte Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6218RangeCode2Byte( _
ByVal i_iIndex As Integer _
) As UInt16
C#
protected static ushort GetAdam6218RangeCode2Byte(
int i_iIndex
)
C++
protected:
static unsigned short GetAdam6218RangeCode2Byte(
int i_iIndex
)
J#
protected static ushort GetAdam6218RangeCode2Byte(
int i_iIndex
)
JScript
protected static function GetAdam6218RangeCode2Byte(
i_iIndex : int
) : UInt16

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6218RangeIndex Method

AnalogInput.GetAdam6218RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6218RangeIndex( _
ByVal i_usRange As UInt16 _
) As Integer
C#
protected static int GetAdam6218RangeIndex(
ushort i_usRange
)
C++
protected:
static int GetAdam6218RangeIndex(
unsigned short i_usRange
)
J#
protected static int GetAdam6218RangeIndex(
ushort i_usRange
)
JScript
protected static function GetAdam6218RangeIndex(
i_usRange : UInt16
) : int

Parameters

i_usRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6224RangeCode2Byte Method

AnalogInput.GetAdam6224RangeCode2Byte Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6224RangeCode2Byte( _
ByVal i_iIndex As Integer _
) As UInt16
C#
protected static ushort GetAdam6224RangeCode2Byte(
int i_iIndex
)
C++
protected:
static unsigned short GetAdam6224RangeCode2Byte(
int i_iIndex
)
J#
protected static ushort GetAdam6224RangeCode2Byte(
int i_iIndex
)
JScript
protected static function GetAdam6224RangeCode2Byte(
i_iIndex : int
) : UInt16

Parameters

i_iIndex

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAdam6224RangeIndex Method

AnalogInput.GetAdam6224RangeIndex Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6224RangeIndex( _
ByVal i_usRange As UInt16 _
) As Integer
C#
protected static int GetAdam6224RangeIndex(
ushort i_usRange
)
C++
protected:
static int GetAdam6224RangeIndex(
unsigned short i_usRange
)
J#
protected static int GetAdam6224RangeIndex(
ushort i_usRange
)
JScript
protected static function GetAdam6224RangeIndex(
i_usRange : UInt16
) : int

Parameters

i_usRange

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAutoFilterEnabled Method

AnalogInput.GetAutoFilterEnabled Method
[image]

Support module: ADAM-4100. Get Auto-filter channel enabled status and filter percentage index.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAutoFilterEnabled( _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean, _
<OutAttribute> ByRef o_iPercentIndex As Integer _
) As Boolean
C#
public bool GetAutoFilterEnabled(
int i_iChannelTotal,
out bool o_bEnabled,
out int o_iPercentIndex
)
C++
public:
bool GetAutoFilterEnabled(
int i_iChannelTotal,
[OutAttribute] bool% o_bEnabled,
[OutAttribute] int% o_iPercentIndex
) sealed
J#
public bool GetAutoFilterEnabled(
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled,
/** @attribute OutAttribute() */ /** @ref */ int o_iPercentIndex
)
JScript
public function GetAutoFilterEnabled(
i_iChannelTotal : int,
OutAttribute o_bEnabled : bool,
OutAttribute o_iPercentIndex : int
) : bool

Parameters

i_iChannelTotal
The total of the channels on the module.
o_bEnabled
Array of channel status.
o_iPercentIndex
The percentage index. 1 means 10%, ..., 9 means 90%.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAutoFilterProgress Method

AnalogInput.GetAutoFilterProgress Method
[image]

Support module: ADAM-4100. Get Auto-filter progress percentage.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAutoFilterProgress( _
<OutAttribute> ByRef o_iPercent As Integer _
) As Boolean
C#
public bool GetAutoFilterProgress(
out int o_iPercent
)
C++
public:
bool GetAutoFilterProgress(
[OutAttribute] int% o_iPercent
) sealed
J#
public bool GetAutoFilterProgress(
/** @attribute OutAttribute() */ /** @ref */ int o_iPercent
)
JScript
public function GetAutoFilterProgress(
OutAttribute o_iPercent : int
) : bool

Parameters

o_iPercent
The progress percentage.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAutoFilterSampleRate Method

AnalogInput.GetAutoFilterSampleRate Method
[image]

Support module: ADAM-4100. Get Auto-filter sampling rate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAutoFilterSampleRate( _
<OutAttribute> ByRef o_iRate As Integer _
) As Boolean
C#
public bool GetAutoFilterSampleRate(
out int o_iRate
)
C++
public:
bool GetAutoFilterSampleRate(
[OutAttribute] int% o_iRate
) sealed
J#
public bool GetAutoFilterSampleRate(
/** @attribute OutAttribute() */ /** @ref */ int o_iRate
)
JScript
public function GetAutoFilterSampleRate(
OutAttribute o_iRate : int
) : bool

Parameters

o_iRate
The sampling rate.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetAverageChannelEnabled Method

AnalogInput.GetAverageChannelEnabled Method
[image]

Support module: ADAM-6000. Get channel enabled status for average

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAverageChannelEnabled( _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetAverageChannelEnabled(
int i_iChannelTotal,
out bool o_bEnabled
)
C++
public:
bool GetAverageChannelEnabled(
int i_iChannelTotal,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetAverageChannelEnabled(
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetAverageChannelEnabled(
i_iChannelTotal : int,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_iChannelTotal
The total of the channels. The value is between 1~8
o_bEnabled
Array of channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetBiasValue Method

AnalogInput.GetBiasValue Method
[image]

Support module: ADAM-4018P. Get bias value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBiasValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fBiasValue As Single _
) As Boolean
C#
public bool GetBiasValue(
int i_iChannel,
out float o_fBiasValue
)
C++
public:
bool GetBiasValue(
int i_iChannel,
[OutAttribute] float% o_fBiasValue
) sealed
J#
public bool GetBiasValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fBiasValue
)
JScript
public function GetBiasValue(
i_iChannel : int,
OutAttribute o_fBiasValue : float
) : bool

Parameters

i_iChannel
Channel index. The value is between 0~7
o_fBiasValue
Bias value. The value is between -25.5~25.5

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetBurnoutDetect Method

AnalogInput.GetBurnoutDetect Method

Support module: ADAM-4100. Get burnout detect setting.

Overload List

 | Name | Description
Public method | GetBurnoutDetect (Boolean) | Support module: ADAM-4100. Get burnout detect setting.
Public method | GetBurnoutDetect (UInt16) | Support module: ADAM-6000. Get burnout detect setting.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetBurnoutDetect Method (Boolean)

AnalogInput.GetBurnoutDetect Method (Boolean)
See Also Example
[image]

Support module: ADAM-4100. Get burnout detect setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBurnoutDetect( _
<OutAttribute> ByRef o_burnout As Boolean _
) As Boolean
C#
public bool GetBurnoutDetect(
out bool o_burnout
)
C++
public:
bool GetBurnoutDetect(
[OutAttribute] bool% o_burnout
) sealed
J#
public bool GetBurnoutDetect(
/** @attribute OutAttribute() */ /** @ref */ bool o_burnout
)
JScript
public function GetBurnoutDetect(
OutAttribute o_burnout : bool
) : bool

Parameters

o_burnout
Indicate whether the burnout detect enabled.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetBurnoutDetect Overload List


GetBurnoutDetect Method (UInt16)

AnalogInput.GetBurnoutDetect Method (UInt16)
See Also Example
[image]

Support module: ADAM-6000. Get burnout detect setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBurnoutDetect( _
<OutAttribute> ByRef o_usBurnout As UInt16 _
) As Boolean
C#
public bool GetBurnoutDetect(
out ushort o_usBurnout
)
C++
public:
bool GetBurnoutDetect(
[OutAttribute] unsigned short% o_usBurnout
) sealed
J#
public bool GetBurnoutDetect(
/** @attribute OutAttribute() */ /** @ref */ ushort o_usBurnout
)
JScript
public function GetBurnoutDetect(
OutAttribute o_usBurnout : UInt16
) : bool

Parameters

o_usBurnout
ushort, ( FFFF: up scale, 0000: down scale).

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetBurnoutDetect Overload List


GetBurnoutFunEnable Method

AnalogInput.GetBurnoutFunEnable Method
[image]

Support module: APAX-5000. Get Burnout Function Enable Mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBurnoutFunEnable( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_dwEnableMask As UInt32 _
) As Boolean
C#
public bool GetBurnoutFunEnable(
int i_iSlot,
out uint o_dwEnableMask
)
C++
public:
bool GetBurnoutFunEnable(
int i_iSlot,
[OutAttribute] unsigned int% o_dwEnableMask
) sealed
J#
public bool GetBurnoutFunEnable(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwEnableMask
)
JScript
public function GetBurnoutFunEnable(
i_iSlot : int,
OutAttribute o_dwEnableMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_dwEnableMask
The burnout enable mask

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetBurnoutMap Method

AnalogInput.GetBurnoutMap Method

Support module: ADAM-4100. Get burnout mapping.

Overload List

 | Name | Description
Public method | GetBurnoutMap (Adam4100_BurnoutMap) | Support module: ADAM-4100. Get burnout mapping.
Public method | GetBurnoutMap (Int32, Adam5017UH_BurnoutMap) | Support module: ADAM-5017UH. Get burnout mapping.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetBurnoutMap Method (Adam4100_BurnoutMap)

AnalogInput.GetBurnoutMap Method (Adam4100_BurnoutMap)
See Also Example
[image]

Support module: ADAM-4100. Get burnout mapping.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBurnoutMap( _
<OutAttribute> ByRef o_burnout As Adam4100_BurnoutMap _
) As Boolean
C#
public bool GetBurnoutMap(
out Adam4100_BurnoutMap o_burnout
)
C++
public:
bool GetBurnoutMap(
[OutAttribute] Adam4100_BurnoutMap% o_burnout
) sealed
J#
public bool GetBurnoutMap(
/** @attribute OutAttribute() */ /** @ref */ Adam4100_BurnoutMap o_burnout
)
JScript
public function GetBurnoutMap(
OutAttribute o_burnout : Adam4100_BurnoutMap
) : bool

Parameters

o_burnout
Burnout mapping

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetBurnoutMap Overload List


GetBurnoutMap Method (Int32, Adam5017UH_BurnoutMap)

AnalogInput.GetBurnoutMap Method (Int32, Adam5017UH_BurnoutMap)
See Also Example
[image]

Support module: ADAM-5017UH. Get burnout mapping.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBurnoutMap( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_burnout As Adam5017UH_BurnoutMap _
) As Boolean
C#
public bool GetBurnoutMap(
int i_iSlot,
out Adam5017UH_BurnoutMap o_burnout
)
C++
public:
bool GetBurnoutMap(
int i_iSlot,
[OutAttribute] Adam5017UH_BurnoutMap% o_burnout
) sealed
J#
public bool GetBurnoutMap(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ Adam5017UH_BurnoutMap o_burnout
)
JScript
public function GetBurnoutMap(
i_iSlot : int,
OutAttribute o_burnout : Adam5017UH_BurnoutMap
) : bool

Parameters

i_iSlot
The slot index, base 0.
o_burnout
Burnout mapping

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetBurnoutMap Overload List


GetBurnoutValue Method

AnalogInput.GetBurnoutValue Method
[image]

Support module: APAX-5000. Get The Value While Burnout

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBurnoutValue( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_dwValue As UInt32 _
) As Boolean
C#
public bool GetBurnoutValue(
int i_iSlot,
out uint o_dwValue
)
C++
public:
bool GetBurnoutValue(
int i_iSlot,
[OutAttribute] unsigned int% o_dwValue
) sealed
J#
public bool GetBurnoutValue(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwValue
)
JScript
public function GetBurnoutValue(
i_iSlot : int,
OutAttribute o_dwValue : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_dwValue
The value while burnout

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetCalibrationValues Method

AnalogInput.GetCalibrationValues Method
[image]

Support module: ADAM-5017P, ADAM-5018P. Get analog input calibration value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCalibrationValues( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_szZero As String, _
<OutAttribute> ByRef o_szSpan As String _
) As Boolean
C#
public bool GetCalibrationValues(
int i_iSlot,
out string o_szZero,
out string o_szSpan
)
C++
public:
bool GetCalibrationValues(
int i_iSlot,
[OutAttribute] String% o_szZero,
[OutAttribute] String% o_szSpan
) sealed
J#
public bool GetCalibrationValues(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ string o_szZero,
/** @attribute OutAttribute() */ /** @ref */ string o_szSpan
)
JScript
public function GetCalibrationValues(
i_iSlot : int,
OutAttribute o_szZero : String,
OutAttribute o_szSpan : String
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_szZero
The zero calibration string.
o_szSpan
The span calibration string.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetChannelDiagnostic Method

AnalogInput.GetChannelDiagnostic Method
[image]

Support module: ADAM-4022T, ADAM-4019P Get channel diagnostic status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelDiagnostic( _
<OutAttribute> ByRef o_iStatus As Integer _
) As Boolean
C#
public bool GetChannelDiagnostic(
out int o_iStatus
)
C++
public:
bool GetChannelDiagnostic(
[OutAttribute] int% o_iStatus
) sealed
J#
public bool GetChannelDiagnostic(
/** @attribute OutAttribute() */ /** @ref */ int o_iStatus
)
JScript
public function GetChannelDiagnostic(
OutAttribute o_iStatus : int
) : bool

Parameters

o_iStatus
The status. For ADAM-4019P the array length is 8: 0 means normal; 1 means open wire. For ADAM-4022T the array length is 4: 0 means normal; 1 means over high; 2 means over low; 3 means ivalid calibration.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetChannelEnabled Method

AnalogInput.GetChannelEnabled Method

Support module: ADAM-4100, ADAM-6000. Get channel enabled status

Overload List

 | Name | Description
Public method | GetChannelEnabled (Int32, Boolean) | Support module: ADAM-4100, ADAM-6000. Get channel enabled status
Public method | GetChannelEnabled (Int32, Int32, Boolean) | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get channel enabled status

See Also

AnalogInput Class
Advantech.Adam Namespace


GetChannelEnabled Method (Int32, Boolean)

AnalogInput.GetChannelEnabled Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-4100, ADAM-6000. Get channel enabled status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelEnabled( _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetChannelEnabled(
int i_iChannelTotal,
out bool o_bEnabled
)
C++
public:
bool GetChannelEnabled(
int i_iChannelTotal,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetChannelEnabled(
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetChannelEnabled(
i_iChannelTotal : int,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_iChannelTotal
The total of the channels. The value is between 1~8
o_bEnabled
Array of channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetChannelEnabled Overload List


GetChannelEnabled Method (Int32, Int32, Boolean)

AnalogInput.GetChannelEnabled Method (Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get channel enabled status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelEnabled( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetChannelEnabled(
int i_iSlot,
int i_iChannelTotal,
out bool o_bEnabled
)
C++
public:
bool GetChannelEnabled(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetChannelEnabled(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetChannelEnabled(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannelTotal
The total of the channels. The value is between 1~8
o_bEnabled
Array of channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetChannelEnabled Overload List


GetChannelStatus Method

AnalogInput.GetChannelStatus Method

Support module: APAX-5000. Get channel status.

Overload List

 | Name | Description
Public method | GetChannelStatus (Int32, Int32, Apax5000_ChannelStatus) | Support module: APAX-5000. Get channel status.
Public method | GetChannelStatus (Int32, Int32, Byte) | Support module: APAX-5000. Get channel status.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetChannelStatus Method (Int32, Int32, Apax5000_ChannelStatus)

AnalogInput.GetChannelStatus Method (Int32, Int32, Apax5000_ChannelStatus)
See Also Example
[image]

Support module: APAX-5000. Get channel status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_Status As Apax5000_ChannelStatus _
) As Boolean
C#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
out Apax5000_ChannelStatus o_Status
)
C++
public:
bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] Apax5000_ChannelStatus% o_Status
) sealed
J#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ Apax5000_ChannelStatus o_Status
)
JScript
public function GetChannelStatus(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_Status : Apax5000_ChannelStatus
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The channel total. The value is between 1~31
o_Status
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetChannelStatus Overload List


GetChannelStatus Method (Int32, Int32, Byte)

AnalogInput.GetChannelStatus Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: APAX-5000. Get channel status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_byStatus As Byte _
) As Boolean
C#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
out byte o_byStatus
)
C++
public:
bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] char% o_byStatus
) sealed
J#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ byte o_byStatus
)
JScript
public function GetChannelStatus(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_byStatus : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The channel total. The value is between 1~31
o_byStatus
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetChannelStatus Overload List


GetChannelTotal Method

AnalogInput.GetChannelTotal Method

Get the channel total

Overload List

Name | Description
GetChannelTotal (Adam4000Type) | Get the channel total
GetChannelTotal (Adam5000Type) | Get the channel total
GetChannelTotal (Adam6000Type) | Get the channel total

See Also

AnalogInput Class
Advantech.Adam Namespace


GetChannelTotal Method (Adam4000Type)

AnalogInput.GetChannelTotal Method (Adam4000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetChannelTotal(
Adam4000Type adam4000Type
)
J#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetChannelTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetChannelTotal Overload List


GetChannelTotal Method (Adam5000Type)

AnalogInput.GetChannelTotal Method (Adam5000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetChannelTotal(
Adam5000Type adam5000Type
)
J#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetChannelTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetChannelTotal Overload List


GetChannelTotal Method (Adam6000Type)

AnalogInput.GetChannelTotal Method (Adam6000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelTotal(
Adam6000Type adam6000Type
)
J#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetChannelTotal Overload List


GetChValOffset Method

AnalogInput.GetChValOffset Method
[image]

Support module: APAX-5000. Get channel value offset.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChValOffset( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_uiChValOffset As UInt32 _
) As Boolean
C#
public bool GetChValOffset(
int i_iSlot,
int i_iChannel,
out uint o_uiChValOffset
)
C++
public:
bool GetChValOffset(
int i_iSlot,
int i_iChannel,
[OutAttribute] unsigned int% o_uiChValOffset
) sealed
J#
public bool GetChValOffset(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiChValOffset
)
JScript
public function GetChValOffset(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_uiChValOffset : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
Channel index.
o_uiChValOffset
The channel value offset.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetCJCValue Method

AnalogInput.GetCJCValue Method

Support module: ADAM-5000, ADAM-5000TCP. Get CJC calibration value

Overload List

 | Name | Description
Public method | GetCJCValue (Int32, Single) | Support module: ADAM-5000, ADAM-5000TCP. Get CJC calibration value
Public method | GetCJCValue (Int32, Single, Apax5000_ChannelStatus) | Support module: APAX-5000, APAX-5070. Get CJC calibration value
Public method | GetCJCValue (Single) | Support module: ADAM-4000, ADAM-4100, ADAM-6000. Get CJC calibration value

See Also

AnalogInput Class
Advantech.Adam Namespace


GetCJCValue Method (Int32, Single)

AnalogInput.GetCJCValue Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP. Get CJC calibration value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCJCValue( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_fCJCVal As Single _
) As Boolean
C#
public bool GetCJCValue(
int i_iSlot,
out float o_fCJCVal
)
C++
public:
bool GetCJCValue(
int i_iSlot,
[OutAttribute] float% o_fCJCVal
) sealed
J#
public bool GetCJCValue(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ float o_fCJCVal
)
JScript
public function GetCJCValue(
i_iSlot : int,
OutAttribute o_fCJCVal : float
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_fCJCVal
The CJC calibration value

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetCJCValue Overload List


GetCJCValue Method (Int32, Single, Apax5000_ChannelStatus)

AnalogInput.GetCJCValue Method (Int32, Single, Apax5000_ChannelStatus)
See Also Example
[image]

Support module: APAX-5000, APAX-5070. Get CJC calibration value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCJCValue( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_fCJCVal As Single, _
<OutAttribute> ByRef o_Status As Apax5000_ChannelStatus _
) As Boolean
C#
public bool GetCJCValue(
int i_iSlot,
out float o_fCJCVal,
out Apax5000_ChannelStatus o_Status
)
C++
public:
bool GetCJCValue(
int i_iSlot,
[OutAttribute] float% o_fCJCVal,
[OutAttribute] Apax5000_ChannelStatus% o_Status
) sealed
J#
public bool GetCJCValue(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ float o_fCJCVal,
/** @attribute OutAttribute() */ /** @ref */ Apax5000_ChannelStatus o_Status
)
JScript
public function GetCJCValue(
i_iSlot : int,
OutAttribute o_fCJCVal : float,
OutAttribute o_Status : Apax5000_ChannelStatus
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_fCJCVal
The CJC calibration value
o_Status
The CJC status

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetCJCValue Overload List


GetCJCValue Method (Single)

AnalogInput.GetCJCValue Method (Single)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100, ADAM-6000. Get CJC calibration value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCJCValue( _
<OutAttribute> ByRef o_fCJCVal As Single _
) As Boolean
C#
public bool GetCJCValue(
out float o_fCJCVal
)
C++
public:
bool GetCJCValue(
[OutAttribute] float% o_fCJCVal
) sealed
J#
public bool GetCJCValue(
/** @attribute OutAttribute() */ /** @ref */ float o_fCJCVal
)
JScript
public function GetCJCValue(
OutAttribute o_fCJCVal : float
) : bool

Parameters

o_fCJCVal
The CJC calibration value

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetCJCValue Overload List


GetDataFormat Method

AnalogInput.GetDataFormat Method
[image]

Support module: ADAM-5017H, ADAM-5017UH. Get module data format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataFormat( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byDataFormat As Byte _
) As Boolean
C#
public bool GetDataFormat(
int i_iSlot,
out byte o_byDataFormat
)
C++
public:
bool GetDataFormat(
int i_iSlot,
[OutAttribute] char% o_byDataFormat
) sealed
J#
public bool GetDataFormat(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byDataFormat
)
JScript
public function GetDataFormat(
i_iSlot : int,
OutAttribute o_byDataFormat : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_byDataFormat
The data format code.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetDataFormatCode Method

AnalogInput.GetDataFormatCode Method

Get the data format code.

Overload List

Name | Description
GetDataFormatCode (Adam4000Type, Int32) | Get the data format code.
GetDataFormatCode (Adam5000Type, Int32) | Get the data format code.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetDataFormatCode Method (Adam4000Type, Int32)

AnalogInput.GetDataFormatCode Method (Adam4000Type, Int32)
See Also Example
[image]

Get the data format code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatCode( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetDataFormatCode(
Adam4000Type adam4000Type,
int i_iIndex
)
C++
public:
static char GetDataFormatCode(
Adam4000Type adam4000Type,
int i_iIndex
)
J#
public static byte GetDataFormatCode(
Adam4000Type adam4000Type,
int i_iIndex
)
JScript
public static function GetDataFormatCode(
adam4000Type : Adam4000Type,
i_iIndex : int
) : Byte

Parameters

adam4000Type
ADAM-4000 type
i_iIndex
The data format index. The value is between 0~2.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatCode Overload List


GetDataFormatCode Method (Adam5000Type, Int32)

AnalogInput.GetDataFormatCode Method (Adam5000Type, Int32)
See Also Example
[image]

Get the data format code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatCode( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetDataFormatCode(
Adam5000Type adam5000Type,
int i_iIndex
)
C++
public:
static char GetDataFormatCode(
Adam5000Type adam5000Type,
int i_iIndex
)
J#
public static byte GetDataFormatCode(
Adam5000Type adam5000Type,
int i_iIndex
)
JScript
public static function GetDataFormatCode(
adam5000Type : Adam5000Type,
i_iIndex : int
) : Byte

Parameters

adam5000Type
ADAM-5000 type
i_iIndex
The data format index. The value is between 0~1.

Return Value

The range code.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatCode Overload List


GetDataFormatIndex Method

AnalogInput.GetDataFormatIndex Method

Get the data format index

Overload List

Name | Description
GetDataFormatIndex (Adam4000Type, Byte) | Get the data format index
GetDataFormatIndex (Adam5000Type, Byte) | Get the data format index

See Also

AnalogInput Class
Advantech.Adam Namespace


GetDataFormatIndex Method (Adam4000Type, Byte)

AnalogInput.GetDataFormatIndex Method (Adam4000Type, Byte)
See Also Example
[image]

Get the data format index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatIndex( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byDataFormat As Byte _
) As Integer
C#
public static int GetDataFormatIndex(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
C++
public:
static int GetDataFormatIndex(
Adam4000Type adam4000Type,
char i_byDataFormat
)
J#
public static int GetDataFormatIndex(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatIndex(
adam4000Type : Adam4000Type,
i_byDataFormat : Byte
) : int

Parameters

adam4000Type
ADAM-4000 type
i_byDataFormat
The data format code.

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatIndex Overload List


GetDataFormatIndex Method (Adam5000Type, Byte)

AnalogInput.GetDataFormatIndex Method (Adam5000Type, Byte)
See Also Example
[image]

Get the data format index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatIndex( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byDataFormat As Byte _
) As Integer
C#
public static int GetDataFormatIndex(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
C++
public:
static int GetDataFormatIndex(
Adam5000Type adam5000Type,
char i_byDataFormat
)
J#
public static int GetDataFormatIndex(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatIndex(
adam5000Type : Adam5000Type,
i_byDataFormat : Byte
) : int

Parameters

adam5000Type
ADAM-5000 type
i_byDataFormat
The data format code.

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatIndex Overload List


GetDataFormatName Method

AnalogInput.GetDataFormatName Method

Get the data format name

Overload List

Name | Description
GetDataFormatName (Adam4000Type, Byte) | Get the data format name
GetDataFormatName (Adam5000Type, Byte) | Get the data format name
GetDataFormatName (Byte) | Get the data format name for ADAM unknown module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetDataFormatName Method (Adam4000Type, Byte)

AnalogInput.GetDataFormatName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the data format name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byDataFormat As Byte _
) As String
C#
public static string GetDataFormatName(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
C++
public:
static String GetDataFormatName(
Adam4000Type adam4000Type,
char i_byDataFormat
)
J#
public static string GetDataFormatName(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatName(
adam4000Type : Adam4000Type,
i_byDataFormat : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byDataFormat
The data format code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatName Overload List


GetDataFormatName Method (Adam5000Type, Byte)

AnalogInput.GetDataFormatName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the data format name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byDataFormat As Byte _
) As String
C#
public static string GetDataFormatName(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
C++
public:
static String GetDataFormatName(
Adam5000Type adam5000Type,
char i_byDataFormat
)
J#
public static string GetDataFormatName(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatName(
adam5000Type : Adam5000Type,
i_byDataFormat : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byDataFormat
The data format code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatName Overload List


GetDataFormatName Method (Byte)

AnalogInput.GetDataFormatName Method (Byte)
See Also Example
[image]

Get the data format name for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatName( _
ByVal i_byDataFormat As Byte _
) As String
C#
public static string GetDataFormatName(
byte i_byDataFormat
)
C++
public:
static String GetDataFormatName(
char i_byDataFormat
)
J#
public static string GetDataFormatName(
byte i_byDataFormat
)
JScript
public static function GetDataFormatName(
i_byDataFormat : Byte
) : String

Parameters

i_byDataFormat
The data format code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatName Overload List


GetDataFormatTotal Method

AnalogInput.GetDataFormatTotal Method

Get the data format total

Overload List

Name | Description
GetDataFormatTotal (Adam4000Type) | Get the data format total
GetDataFormatTotal (Adam5000Type) | Get the data format total

See Also

AnalogInput Class
Advantech.Adam Namespace


GetDataFormatTotal Method (Adam4000Type)

AnalogInput.GetDataFormatTotal Method (Adam4000Type)
See Also Example
[image]

Get the data format total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetDataFormatTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetDataFormatTotal(
Adam4000Type adam4000Type
)
J#
public static int GetDataFormatTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetDataFormatTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatTotal Overload List


GetDataFormatTotal Method (Adam5000Type)

AnalogInput.GetDataFormatTotal Method (Adam5000Type)
See Also Example
[image]

Get the data format total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetDataFormatTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetDataFormatTotal(
Adam5000Type adam5000Type
)
J#
public static int GetDataFormatTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetDataFormatTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetDataFormatTotal Overload List


GetFloatFormat Method

AnalogInput.GetFloatFormat Method

Get floating format

Overload List

Name | Description
GetFloatFormat (Adam4000Type, Byte) | Get floating format
GetFloatFormat (Adam5000Type, Byte) | Get floating format
GetFloatFormat (Adam6000Type, Byte) | Get floating format
GetFloatFormat (Adam6000Type, UInt16) | Get floating format
GetFloatFormat (Byte) | Get floating format for unknown ADAM module
GetFloatFormat (UInt16) | Get floating format for unknown APAX module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetFloatFormat Method (Adam4000Type, Byte)

AnalogInput.GetFloatFormat Method (Adam4000Type, Byte)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetFloatFormat(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetFloatFormat(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetFloatFormat(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The rnage code. (Use byte as the parameter)

Return Value

Return the float format string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetFloatFormat Overload List


GetFloatFormat Method (Adam5000Type, Byte)

AnalogInput.GetFloatFormat Method (Adam5000Type, Byte)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetFloatFormat(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetFloatFormat(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetFloatFormat(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The rnage code. (Use byte as the parameter)

Return Value

Return the float format string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetFloatFormat Overload List


GetFloatFormat Method (Adam6000Type, Byte)

AnalogInput.GetFloatFormat Method (Adam6000Type, Byte)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetFloatFormat(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetFloatFormat(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return the float format string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetFloatFormat Overload List


GetFloatFormat Method (Adam6000Type, UInt16)

AnalogInput.GetFloatFormat Method (Adam6000Type, UInt16)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetFloatFormat(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetFloatFormat(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return the float format string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetFloatFormat Overload List


GetFloatFormat Method (Byte)

AnalogInput.GetFloatFormat Method (Byte)
See Also Example
[image]

Get floating format for unknown ADAM module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
byte i_byRange
)
C++
public:
static String GetFloatFormat(
char i_byRange
)
J#
public static string GetFloatFormat(
byte i_byRange
)
JScript
public static function GetFloatFormat(
i_byRange : Byte
) : String

Parameters

i_byRange
The rnage code

Return Value

Return the float format string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetFloatFormat Overload List


GetFloatFormat Method (UInt16)

AnalogInput.GetFloatFormat Method (UInt16)
See Also Example
[image]

Get floating format for unknown APAX module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetFloatFormat(
ushort i_usRange
)
C++
public:
static String GetFloatFormat(
unsigned short i_usRange
)
J#
public static string GetFloatFormat(
ushort i_usRange
)
JScript
public static function GetFloatFormat(
i_usRange : UInt16
) : String

Parameters

i_usRange
The rnage code

Return Value

Return the float format string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetFloatFormat Overload List


GetInputRange Method

AnalogInput.GetInputRange Method

Support module: ADAM-4000 (Channel Independent Configuration), ADAM-4100, ADAM-6000. Get module analog input range

Overload List

 | Name | Description
Public method | GetInputRange (Int32, Byte) | Support module: ADAM-4000 (Channel Independent Configuration), ADAM-4100, ADAM-6000. Get module analog input range
Public method | GetInputRange (Int32, Int32, Byte) | Support module: ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018P. (Also support on ADAM-5550) Get module analog input range
Public method | GetInputRange (Int32, UInt16) | Support module: ADAM-6000. Get module analog input range

See Also

AnalogInput Class
Advantech.Adam Namespace


GetInputRange Method (Int32, Byte)

AnalogInput.GetInputRange Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4000 (Channel Independent Configuration), ADAM-4100, ADAM-6000. Get module analog input range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInputRange( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool GetInputRange(
int i_iChannel,
out byte o_byRange
)
C++
public:
bool GetInputRange(
int i_iChannel,
[OutAttribute] char% o_byRange
) sealed
J#
public bool GetInputRange(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function GetInputRange(
i_iChannel : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~7
o_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetInputRange Overload List


GetInputRange Method (Int32, Int32, Byte)

AnalogInput.GetInputRange Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018P. (Also support on ADAM-5550) Get module analog input range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInputRange( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool GetInputRange(
int i_iSlot,
int i_iChannel,
out byte o_byRange
)
C++
public:
bool GetInputRange(
int i_iSlot,
int i_iChannel,
[OutAttribute] char% o_byRange
) sealed
J#
public bool GetInputRange(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function GetInputRange(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetInputRange Overload List


GetInputRange Method (Int32, UInt16)

AnalogInput.GetInputRange Method (Int32, UInt16)
See Also Example
[image]

Support module: ADAM-6000. Get module analog input range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInputRange( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_usRange As UInt16 _
) As Boolean
C#
public bool GetInputRange(
int i_iChannel,
out ushort o_usRange
)
C++
public:
bool GetInputRange(
int i_iChannel,
[OutAttribute] unsigned short% o_usRange
) sealed
J#
public bool GetInputRange(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usRange
)
JScript
public function GetInputRange(
i_iChannel : int,
OutAttribute o_usRange : UInt16
) : bool

Parameters

i_iChannel
The channel index.
o_usRange
The input range code. (Use ushort as the parameter)

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetInputRange Overload List


GetIntegration Method

AnalogInput.GetIntegration Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Get module integration time

Overload List

 | Name | Description
Public method | GetIntegration (Byte) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Get module integration time
Public method | GetIntegration (Int32, Byte) | Support module: ADAM-5017H, ADAM-5017UH. Get module integration time

See Also

AnalogInput Class
Advantech.Adam Namespace


GetIntegration Method (Byte)

AnalogInput.GetIntegration Method (Byte)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Get module integration time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIntegration( _
<OutAttribute> ByRef o_byIntegration As Byte _
) As Boolean
C#
public bool GetIntegration(
out byte o_byIntegration
)
C++
public:
bool GetIntegration(
[OutAttribute] char% o_byIntegration
) sealed
J#
public bool GetIntegration(
/** @attribute OutAttribute() */ /** @ref */ byte o_byIntegration
)
JScript
public function GetIntegration(
OutAttribute o_byIntegration : Byte
) : bool

Parameters

o_byIntegration
The integration code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetIntegration Overload List


GetIntegration Method (Int32, Byte)

AnalogInput.GetIntegration Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-5017H, ADAM-5017UH. Get module integration time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIntegration( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byIntegration As Byte _
) As Boolean
C#
public bool GetIntegration(
int i_iSlot,
out byte o_byIntegration
)
C++
public:
bool GetIntegration(
int i_iSlot,
[OutAttribute] char% o_byIntegration
) sealed
J#
public bool GetIntegration(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byIntegration
)
JScript
public function GetIntegration(
i_iSlot : int,
OutAttribute o_byIntegration : Byte
) : bool

Parameters

i_iSlot
The slot index, base 0.
o_byIntegration
The integration code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetIntegration Overload List


GetIntegrationCode Method

AnalogInput.GetIntegrationCode Method
[image]

Get the integration code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetIntegrationCode( _
ByVal adamType As AdamType, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetIntegrationCode(
AdamType adamType,
int i_iIndex
)
C++
public:
static char GetIntegrationCode(
AdamType adamType,
int i_iIndex
)
J#
public static byte GetIntegrationCode(
AdamType adamType,
int i_iIndex
)
JScript
public static function GetIntegrationCode(
adamType : AdamType,
i_iIndex : int
) : Byte

Parameters

adamType
The ADAM type.
i_iIndex
The integration index. The value is between 0~1.

Return Value

Return integration code if success, otherwise, return 255.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetIntegrationIndex Method

AnalogInput.GetIntegrationIndex Method
[image]

Get integration index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetIntegrationIndex( _
ByVal adamType As AdamType, _
ByVal i_byCode As Byte _
) As Integer
C#
public static int GetIntegrationIndex(
AdamType adamType,
byte i_byCode
)
C++
public:
static int GetIntegrationIndex(
AdamType adamType,
char i_byCode
)
J#
public static int GetIntegrationIndex(
AdamType adamType,
byte i_byCode
)
JScript
public static function GetIntegrationIndex(
adamType : AdamType,
i_byCode : Byte
) : int

Parameters

adamType
The ADAM type.
i_byCode
The integration code

Return Value

Return integration index if success, otherwise, return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetIntegrationName Method

AnalogInput.GetIntegrationName Method
[image]

Get integration name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetIntegrationName( _
ByVal adamType As AdamType, _
ByVal i_byCode As Byte _
) As String
C#
public static string GetIntegrationName(
AdamType adamType,
byte i_byCode
)
C++
public:
static String GetIntegrationName(
AdamType adamType,
char i_byCode
)
J#
public static string GetIntegrationName(
AdamType adamType,
byte i_byCode
)
JScript
public static function GetIntegrationName(
adamType : AdamType,
i_byCode : Byte
) : String

Parameters

adamType
The ADAM type.
i_byCode
The integration index.

Return Value

Return integration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetIntegrationTotal Method

AnalogInput.GetIntegrationTotal Method
[image]

Get integration total.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetIntegrationTotal( _
ByVal adamType As AdamType _
) As Integer
C#
public static int GetIntegrationTotal(
AdamType adamType
)
C++
public:
static int GetIntegrationTotal(
AdamType adamType
)
J#
public static int GetIntegrationTotal(
AdamType adamType
)
JScript
public static function GetIntegrationTotal(
adamType : AdamType
) : int

Parameters

adamType
The ADAM type.

Return Value

Return integration total if success, otherwise, return -1.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetLeadWire Method

AnalogInput.GetLeadWire Method
[image]

Support module: ADAM-4000. Get lead wire resistance value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLeadWire( _
ByVal i_iType As Integer, _
<OutAttribute> ByRef o_fVal As Single _
) As Boolean
C#
public bool GetLeadWire(
int i_iType,
out float o_fVal
)
C++
public:
bool GetLeadWire(
int i_iType,
[OutAttribute] float% o_fVal
) sealed
J#
public bool GetLeadWire(
int i_iType,
/** @attribute OutAttribute() */ /** @ref */ float o_fVal
)
JScript
public function GetLeadWire(
i_iType : int,
OutAttribute o_fVal : float
) : bool

Parameters

i_iType
The thermistor type. 0 for 3k, others for 10k.
o_fVal
The lead wire resistance value

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetMemConfig Method

AnalogInput.GetMemConfig Method
[image]

Support module: ADAM-4018M. Get memory configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMemConfig( _
<OutAttribute> ByRef o_bEnabled As Boolean, _
<OutAttribute> ByRef o_bRecord As Boolean, _
<OutAttribute> ByRef o_byRecordMode As Byte, _
<OutAttribute> ByRef o_MemMode As Byte, _
<OutAttribute> ByRef o_iInterval As Integer _
) As Boolean
C#
public bool GetMemConfig(
out bool o_bEnabled,
out bool o_bRecord,
out byte o_byRecordMode,
out byte o_MemMode,
out int o_iInterval
)
C++
public:
bool GetMemConfig(
[OutAttribute] bool% o_bEnabled,
[OutAttribute] bool% o_bRecord,
[OutAttribute] char% o_byRecordMode,
[OutAttribute] char% o_MemMode,
[OutAttribute] int% o_iInterval
) sealed
J#
public bool GetMemConfig(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled,
/** @attribute OutAttribute() */ /** @ref */ bool o_bRecord,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecordMode,
/** @attribute OutAttribute() */ /** @ref */ byte o_MemMode,
/** @attribute OutAttribute() */ /** @ref */ int o_iInterval
)
JScript
public function GetMemConfig(
OutAttribute o_bEnabled : bool,
OutAttribute o_bRecord : bool,
OutAttribute o_byRecordMode : Byte,
OutAttribute o_MemMode : Byte,
OutAttribute o_iInterval : int
) : bool

Parameters

o_bEnabled
The storage enabled status for all channels. The length of the array is 8.
o_bRecord
The standalone recording status. Value 0 means recording disabled; Value 1 means recording enabled.
o_byRecordMode
The recording mode. Value 0 means standard mode; Value 1 means event mode. Value 2 means mixed mode.
o_MemMode
The memory buffer storage mode. Value 0 means linear buffer; Value 1 means cycle buffer.
o_iInterval
The recording interval in seconds. The range is between 2~65535.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetMemEventRecordCount Method

AnalogInput.GetMemEventRecordCount Method
[image]

Support module: ADAM-4018M. Get memory event record counts.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMemEventRecordCount( _
<OutAttribute> ByRef o_iCount As Integer _
) As Boolean
C#
public bool GetMemEventRecordCount(
out int o_iCount
)
C++
public:
bool GetMemEventRecordCount(
[OutAttribute] int% o_iCount
) sealed
J#
public bool GetMemEventRecordCount(
/** @attribute OutAttribute() */ /** @ref */ int o_iCount
)
JScript
public function GetMemEventRecordCount(
OutAttribute o_iCount : int
) : bool

Parameters

o_iCount
The record counts.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetMemOperation Method

AnalogInput.GetMemOperation Method
[image]

Support module: ADAM-4018M. Get memory operation.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMemOperation( _
<OutAttribute> ByRef o_bRecording As Boolean _
) As Boolean
C#
public bool GetMemOperation(
out bool o_bRecording
)
C++
public:
bool GetMemOperation(
[OutAttribute] bool% o_bRecording
) sealed
J#
public bool GetMemOperation(
/** @attribute OutAttribute() */ /** @ref */ bool o_bRecording
)
JScript
public function GetMemOperation(
OutAttribute o_bRecording : bool
) : bool

Parameters

o_bRecording
The recording operation status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetMemRecordData Method

AnalogInput.GetMemRecordData Method
[image]

Support module: ADAM-4018M. Get memory data record.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMemRecordData( _
ByVal i_iIndex As Integer, _
<OutAttribute> ByRef o_iChannel As Integer, _
<OutAttribute> ByRef o_fData As Single, _
<OutAttribute> ByRef o_lElapse As Long _
) As Boolean
C#
public bool GetMemRecordData(
int i_iIndex,
out int o_iChannel,
out float o_fData,
out long o_lElapse
)
C++
public:
bool GetMemRecordData(
int i_iIndex,
[OutAttribute] int% o_iChannel,
[OutAttribute] float% o_fData,
[OutAttribute] __int64% o_lElapse
) sealed
J#
public bool GetMemRecordData(
int i_iIndex,
/** @attribute OutAttribute() */ /** @ref */ int o_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fData,
/** @attribute OutAttribute() */ /** @ref */ long o_lElapse
)
JScript
public function GetMemRecordData(
i_iIndex : int,
OutAttribute o_iChannel : int,
OutAttribute o_fData : float,
OutAttribute o_lElapse : long
) : bool

Parameters

i_iIndex
The index of the record. For standard mode, the range is between 0~9999. For event mode, the range is between 0~4599. For mixed mode, the index 0~4999 is for standard data and index 5000~7299 is for event data.
o_iChannel
The channel index of the recorded data.
o_fData
The recorded data.
o_lElapse
The elapsed time for event data record since module started. For standard data, this value is 0.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetMemStandardRecordCount Method

AnalogInput.GetMemStandardRecordCount Method
[image]

Support module: ADAM-4018M. Get memory standard record counts.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMemStandardRecordCount( _
<OutAttribute> ByRef o_iCount As Integer _
) As Boolean
C#
public bool GetMemStandardRecordCount(
out int o_iCount
)
C++
public:
bool GetMemStandardRecordCount(
[OutAttribute] int% o_iCount
) sealed
J#
public bool GetMemStandardRecordCount(
/** @attribute OutAttribute() */ /** @ref */ int o_iCount
)
JScript
public function GetMemStandardRecordCount(
OutAttribute o_iCount : int
) : bool

Parameters

o_iCount
The record counts.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeCode Method

AnalogInput.GetRangeCode Method

Get the range code

Overload List

Name | Description
GetRangeCode (Adam4000Type, Int32) | Get the range code
GetRangeCode (Adam5000Type, Int32) | Get the range code
GetRangeCode (Adam6000Type, Int32) | Get the range code
GetRangeCode (String) | Get the range code by the range name for ADAM unknown module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeCode Method (Adam4000Type, Int32)

AnalogInput.GetRangeCode Method (Adam4000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetRangeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
C++
public:
static char GetRangeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
J#
public static byte GetRangeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
JScript
public static function GetRangeCode(
adam4000Type : Adam4000Type,
i_iIndex : int
) : Byte

Parameters

adam4000Type
ADAM-4000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeCode Overload List


GetRangeCode Method (Adam5000Type, Int32)

AnalogInput.GetRangeCode Method (Adam5000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetRangeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
C++
public:
static char GetRangeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
J#
public static byte GetRangeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
JScript
public static function GetRangeCode(
adam5000Type : Adam5000Type,
i_iIndex : int
) : Byte

Parameters

adam5000Type
ADAM-5000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeCode Overload List


GetRangeCode Method (Adam6000Type, Int32)

AnalogInput.GetRangeCode Method (Adam6000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetRangeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
C++
public:
static char GetRangeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
J#
public static byte GetRangeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
JScript
public static function GetRangeCode(
adam6000Type : Adam6000Type,
i_iIndex : int
) : Byte

Parameters

adam6000Type
ADAM-6000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeCode Overload List


GetRangeCode Method (String)

AnalogInput.GetRangeCode Method (String)
See Also Example
[image]

Get the range code by the range name for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal i_strName As String _
) As Byte
C#
public static byte GetRangeCode(
string i_strName
)
C++
public:
static char GetRangeCode(
String i_strName
)
J#
public static byte GetRangeCode(
string i_strName
)
JScript
public static function GetRangeCode(
i_strName : String
) : Byte

Parameters

i_strName
The range name.

Return Value

Return range code if success, otherwise, return 0x00.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeCode Overload List


GetRangeCode2Byte Method

AnalogInput.GetRangeCode2Byte Method

Get the range code

Overload List

Name | Description
GetRangeCode2Byte (Adam6000Type, Int32) | Get the range code
GetRangeCode2Byte (String) | Get the range code by the range name for APAX unknown module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeCode2Byte Method (Adam6000Type, Int32)

AnalogInput.GetRangeCode2Byte Method (Adam6000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode2Byte( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_iIndex As Integer _
) As UInt16
C#
public static ushort GetRangeCode2Byte(
Adam6000Type adam6000Type,
int i_iIndex
)
C++
public:
static unsigned short GetRangeCode2Byte(
Adam6000Type adam6000Type,
int i_iIndex
)
J#
public static ushort GetRangeCode2Byte(
Adam6000Type adam6000Type,
int i_iIndex
)
JScript
public static function GetRangeCode2Byte(
adam6000Type : Adam6000Type,
i_iIndex : int
) : UInt16

Parameters

adam6000Type
ADAM-6000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 65535

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeCode2Byte Overload List


GetRangeCode2Byte Method (String)

AnalogInput.GetRangeCode2Byte Method (String)
See Also Example
[image]

Get the range code by the range name for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode2Byte( _
ByVal i_strName As String _
) As UInt16
C#
public static ushort GetRangeCode2Byte(
string i_strName
)
C++
public:
static unsigned short GetRangeCode2Byte(
String i_strName
)
J#
public static ushort GetRangeCode2Byte(
string i_strName
)
JScript
public static function GetRangeCode2Byte(
i_strName : String
) : UInt16

Parameters

i_strName
The range name.

Return Value

Return range code if success, otherwise, return 0x00.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeCode2Byte Overload List


GetRangeHighLow Method

AnalogInput.GetRangeHighLow Method

Get the range boundary

Overload List

Name | Description
GetRangeHighLow (Adam4000Type, Byte, Single, Single) | Get the range boundary
GetRangeHighLow (Adam5000Type, Byte, Single, Single) | Get the range boundary
GetRangeHighLow (Adam6000Type, Byte, Single, Single) | Get the range boundary
GetRangeHighLow (Adam6000Type, UInt16, Single, Single) | Get the range boundary
GetRangeHighLow (Byte, Single, Single) | Get the range boundary for ADAM unknown module
GetRangeHighLow (UInt16, Single, Single) | Get the range boundary for APAX unknown module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeHighLow Method (Adam4000Type, Byte, Single, Single)

AnalogInput.GetRangeHighLow Method (Adam4000Type, Byte, Single, Single)
See Also Example
[image]

Get the range boundary

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
Adam4000Type adam4000Type,
byte i_byRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
Adam4000Type adam4000Type,
char i_byRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
Adam4000Type adam4000Type,
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
adam4000Type : Adam4000Type,
i_byRange : Byte,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeHighLow Overload List


GetRangeHighLow Method (Adam5000Type, Byte, Single, Single)

AnalogInput.GetRangeHighLow Method (Adam5000Type, Byte, Single, Single)
See Also Example
[image]

Get the range boundary

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
Adam5000Type adam5000Type,
byte i_byRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
Adam5000Type adam5000Type,
char i_byRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
Adam5000Type adam5000Type,
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
adam5000Type : Adam5000Type,
i_byRange : Byte,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeHighLow Overload List


GetRangeHighLow Method (Adam6000Type, Byte, Single, Single)

AnalogInput.GetRangeHighLow Method (Adam6000Type, Byte, Single, Single)
See Also Example
[image]

Get the range boundary

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
Adam6000Type adam6000Type,
byte i_byRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
Adam6000Type adam6000Type,
char i_byRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
Adam6000Type adam6000Type,
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
adam6000Type : Adam6000Type,
i_byRange : Byte,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeHighLow Overload List


GetRangeHighLow Method (Adam6000Type, UInt16, Single, Single)

AnalogInput.GetRangeHighLow Method (Adam6000Type, UInt16, Single, Single)
See Also Example
[image]

Get the range boundary

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
Adam6000Type adam6000Type,
ushort i_usRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
Adam6000Type adam6000Type,
unsigned short i_usRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
Adam6000Type adam6000Type,
ushort i_usRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
adam6000Type : Adam6000Type,
i_usRange : UInt16,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeHighLow Overload List


GetRangeHighLow Method (Byte, Single, Single)

AnalogInput.GetRangeHighLow Method (Byte, Single, Single)
See Also Example
[image]

Get the range boundary for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
byte i_byRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
char i_byRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
i_byRange : Byte,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

i_byRange
The range code.
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeHighLow Overload List


GetRangeHighLow Method (UInt16, Single, Single)

AnalogInput.GetRangeHighLow Method (UInt16, Single, Single)
See Also Example
[image]

Get the range boundary for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal i_usRange As UInt16, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
ushort i_usRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
unsigned short i_usRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
ushort i_usRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
i_usRange : UInt16,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

i_usRange
The range code.
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeHighLow Overload List


GetRangeIndex Method

AnalogInput.GetRangeIndex Method

Get the range code index

Overload List

Name | Description
GetRangeIndex (Adam4000Type, Byte) | Get the range code index
GetRangeIndex (Adam5000Type, Byte) | Get the range code index
GetRangeIndex (Adam6000Type, Byte) | Get the range code index
GetRangeIndex (Adam6000Type, UInt16) | Get the range code index

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeIndex Method (Adam4000Type, Byte)

AnalogInput.GetRangeIndex Method (Adam4000Type, Byte)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As Integer
C#
public static int GetRangeIndex(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static int GetRangeIndex(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static int GetRangeIndex(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetRangeIndex(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : int

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeIndex Overload List


GetRangeIndex Method (Adam5000Type, Byte)

AnalogInput.GetRangeIndex Method (Adam5000Type, Byte)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As Integer
C#
public static int GetRangeIndex(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static int GetRangeIndex(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static int GetRangeIndex(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetRangeIndex(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : int

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeIndex Overload List


GetRangeIndex Method (Adam6000Type, Byte)

AnalogInput.GetRangeIndex Method (Adam6000Type, Byte)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As Integer
C#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static int GetRangeIndex(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetRangeIndex(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : int

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeIndex Overload List


GetRangeIndex Method (Adam6000Type, UInt16)

AnalogInput.GetRangeIndex Method (Adam6000Type, UInt16)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As Integer
C#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static int GetRangeIndex(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetRangeIndex(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : int

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeIndex Overload List


GetRangeIntegration Method

AnalogInput.GetRangeIntegration Method
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000/TCP. Get module analog input range and integration time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRangeIntegration( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byRange As Byte, _
<OutAttribute> ByRef o_byIntegration As Byte _
) As Boolean
C#
public bool GetRangeIntegration(
int i_iSlot,
out byte o_byRange,
out byte o_byIntegration
)
C++
public:
bool GetRangeIntegration(
int i_iSlot,
[OutAttribute] char% o_byRange,
[OutAttribute] char% o_byIntegration
) sealed
J#
public bool GetRangeIntegration(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange,
/** @attribute OutAttribute() */ /** @ref */ byte o_byIntegration
)
JScript
public function GetRangeIntegration(
i_iSlot : int,
OutAttribute o_byRange : Byte,
OutAttribute o_byIntegration : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_byRange
The input range code
o_byIntegration
The integration code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeIntegrationDataFormat Method

AnalogInput.GetRangeIntegrationDataFormat Method
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000. Get module analog input range, integration time and data format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRangeIntegrationDataFormat( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byRange As Byte, _
<OutAttribute> ByRef o_byIntegration As Byte, _
<OutAttribute> ByRef o_byDataFormat As Byte _
) As Boolean
C#
public bool GetRangeIntegrationDataFormat(
int i_iSlot,
out byte o_byRange,
out byte o_byIntegration,
out byte o_byDataFormat
)
C++
public:
bool GetRangeIntegrationDataFormat(
int i_iSlot,
[OutAttribute] char% o_byRange,
[OutAttribute] char% o_byIntegration,
[OutAttribute] char% o_byDataFormat
) sealed
J#
public bool GetRangeIntegrationDataFormat(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange,
/** @attribute OutAttribute() */ /** @ref */ byte o_byIntegration,
/** @attribute OutAttribute() */ /** @ref */ byte o_byDataFormat
)
JScript
public function GetRangeIntegrationDataFormat(
i_iSlot : int,
OutAttribute o_byRange : Byte,
OutAttribute o_byIntegration : Byte,
OutAttribute o_byDataFormat : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_byRange
The input range code
o_byIntegration
The integration code
o_byDataFormat
The data format code.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeName Method

AnalogInput.GetRangeName Method

Get the range name

Overload List

Name | Description
GetRangeName (Adam4000Type, Byte) | Get the range name
GetRangeName (Adam5000Type, Byte) | Get the range name
GetRangeName (Adam6000Type, Byte) | Get the range name
GetRangeName (Adam6000Type, UInt16) | Get the range name
GetRangeName (Byte) | Get the range name for ADAM unknown module
GetRangeName (UInt16) | Get the range name for APAX unknown module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeName Method (Adam4000Type, Byte)

AnalogInput.GetRangeName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetRangeName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetRangeName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetRangeName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range name if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeName Overload List


GetRangeName Method (Adam5000Type, Byte)

AnalogInput.GetRangeName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetRangeName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetRangeName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetRangeName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range name if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeName Overload List


GetRangeName Method (Adam6000Type, Byte)

AnalogInput.GetRangeName Method (Adam6000Type, Byte)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetRangeName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetRangeName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetRangeName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range name if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeName Overload List


GetRangeName Method (Adam6000Type, UInt16)

AnalogInput.GetRangeName Method (Adam6000Type, UInt16)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetRangeName(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetRangeName(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetRangeName(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetRangeName(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return range name if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeName Overload List


GetRangeName Method (Byte)

AnalogInput.GetRangeName Method (Byte)
See Also Example
[image]

Get the range name for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
byte i_byRange
)
C++
public:
static String GetRangeName(
char i_byRange
)
J#
public static string GetRangeName(
byte i_byRange
)
JScript
public static function GetRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeName Overload List


GetRangeName Method (UInt16)

AnalogInput.GetRangeName Method (UInt16)
See Also Example
[image]

Get the range name for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetRangeName(
ushort i_usRange
)
C++
public:
static String GetRangeName(
unsigned short i_usRange
)
J#
public static string GetRangeName(
ushort i_usRange
)
JScript
public static function GetRangeName(
i_usRange : UInt16
) : String

Parameters

i_usRange
The range code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeName Overload List


GetRangeTotal Method

AnalogInput.GetRangeTotal Method

Get the range total

Overload List

Name | Description
GetRangeTotal (Adam4000Type) | Get the range total
GetRangeTotal (Adam5000Type) | Get the range total
GetRangeTotal (Adam6000Type) | Get the range total. This old GetRangeTotal(Adam6000Type adam6000Type) function is now deprecated in favour of the GetRangeTotal(Adam6000Type adam6000Type, Adam6000_RangeFormat adam6000RangeFormat) function.
GetRangeTotal (Adam6000Type, Adam6000_RangeFormat) | Get the range total

See Also

AnalogInput Class
Advantech.Adam Namespace


GetRangeTotal Method (Adam4000Type)

AnalogInput.GetRangeTotal Method (Adam4000Type)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetRangeTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetRangeTotal(
Adam4000Type adam4000Type
)
J#
public static int GetRangeTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetRangeTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeTotal Overload List


GetRangeTotal Method (Adam5000Type)

AnalogInput.GetRangeTotal Method (Adam5000Type)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetRangeTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetRangeTotal(
Adam5000Type adam5000Type
)
J#
public static int GetRangeTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetRangeTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeTotal Overload List


GetRangeTotal Method (Adam6000Type)

AnalogInput.GetRangeTotal Method (Adam6000Type)
See Also Example
[image]

Get the range total. This old GetRangeTotal(Adam6000Type adam6000Type) function is now deprecated in favour of the GetRangeTotal(Adam6000Type adam6000Type, Adam6000_RangeFormat adam6000RangeFormat) function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetRangeTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetRangeTotal(
Adam6000Type adam6000Type
)
J#
public static int GetRangeTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetRangeTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeTotal Overload List


GetRangeTotal Method (Adam6000Type, Adam6000_RangeFormat)

AnalogInput.GetRangeTotal Method (Adam6000Type, Adam6000_RangeFormat)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam6000Type As Adam6000Type, _
ByVal adam6000RangeFormat As Adam6000_RangeFormat _
) As Integer
C#
public static int GetRangeTotal(
Adam6000Type adam6000Type,
Adam6000_RangeFormat adam6000RangeFormat
)
C++
public:
static int GetRangeTotal(
Adam6000Type adam6000Type,
Adam6000_RangeFormat adam6000RangeFormat
)
J#
public static int GetRangeTotal(
Adam6000Type adam6000Type,
Adam6000_RangeFormat adam6000RangeFormat
)
JScript
public static function GetRangeTotal(
adam6000Type : Adam6000Type,
adam6000RangeFormat : Adam6000_RangeFormat
) : int

Parameters

adam6000Type
ADAM-6000 type
adam6000RangeFormat
ADAM-6000 range format

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetRangeTotal Overload List


GetSampleRate Method

AnalogInput.GetSampleRate Method
[image]

Support module: APAX-5000. Get module analog input sample rate

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSampleRate( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_dwRate As UInt32 _
) As Boolean
C#
public bool GetSampleRate(
int i_iSlot,
out uint o_dwRate
)
C++
public:
bool GetSampleRate(
int i_iSlot,
[OutAttribute] unsigned int% o_dwRate
) sealed
J#
public bool GetSampleRate(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwRate
)
JScript
public function GetSampleRate(
i_iSlot : int,
OutAttribute o_dwRate : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_dwRate
The analog input sample rate.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetScaledValue Method

AnalogInput.GetScaledValue Method

Get the scaled value

Overload List

Name | Description
GetScaledValue (Adam4000Type, Byte, Int32) | Get the scaled value
GetScaledValue (Adam5000Type, Byte, Int32) | Get the scaled value
GetScaledValue (Adam6000Type, Byte, Int32) | Get the scaled value
GetScaledValue (Adam6000Type, UInt16, UInt16) | Get the scaled value
GetScaledValue (Byte, Int32) | Get the scaled value for unknown ADAM module
GetScaledValue (UInt16, UInt16) | Get the scaled value for unknown APAX module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetScaledValue Method (Adam4000Type, Byte, Int32)

AnalogInput.GetScaledValue Method (Adam4000Type, Byte, Int32)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
Adam4000Type adam4000Type,
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
Adam4000Type adam4000Type,
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
Adam4000Type adam4000Type,
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
adam4000Type : Adam4000Type,
i_byRange : Byte,
i_iValue : int
) : float

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)
i_iValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetScaledValue Overload List


GetScaledValue Method (Adam5000Type, Byte, Int32)

AnalogInput.GetScaledValue Method (Adam5000Type, Byte, Int32)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
Adam5000Type adam5000Type,
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
Adam5000Type adam5000Type,
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
Adam5000Type adam5000Type,
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
adam5000Type : Adam5000Type,
i_byRange : Byte,
i_iValue : int
) : float

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)
i_iValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetScaledValue Overload List


GetScaledValue Method (Adam6000Type, Byte, Int32)

AnalogInput.GetScaledValue Method (Adam6000Type, Byte, Int32)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
Adam6000Type adam6000Type,
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
Adam6000Type adam6000Type,
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
Adam6000Type adam6000Type,
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
adam6000Type : Adam6000Type,
i_byRange : Byte,
i_iValue : int
) : float

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)
i_iValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetScaledValue Overload List


GetScaledValue Method (Adam6000Type, UInt16, UInt16)

AnalogInput.GetScaledValue Method (Adam6000Type, UInt16, UInt16)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16, _
ByVal i_usValue As UInt16 _
) As Single
C#
public static float GetScaledValue(
Adam6000Type adam6000Type,
ushort i_usRange,
ushort i_usValue
)
C++
public:
static float GetScaledValue(
Adam6000Type adam6000Type,
unsigned short i_usRange,
unsigned short i_usValue
)
J#
public static float GetScaledValue(
Adam6000Type adam6000Type,
ushort i_usRange,
ushort i_usValue
)
JScript
public static function GetScaledValue(
adam6000Type : Adam6000Type,
i_usRange : UInt16,
i_usValue : UInt16
) : float

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)
i_usValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetScaledValue Overload List


GetScaledValue Method (Byte, Int32)

AnalogInput.GetScaledValue Method (Byte, Int32)
See Also Example
[image]

Get the scaled value for unknown ADAM module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
The range code
i_iValue
The resolution of value is 16-bits.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetScaledValue Overload List


GetScaledValue Method (UInt16, UInt16)

AnalogInput.GetScaledValue Method (UInt16, UInt16)
See Also Example
[image]

Get the scaled value for unknown APAX module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal i_usRange As UInt16, _
ByVal i_usValue As UInt16 _
) As Single
C#
public static float GetScaledValue(
ushort i_usRange,
ushort i_usValue
)
C++
public:
static float GetScaledValue(
unsigned short i_usRange,
unsigned short i_usValue
)
J#
public static float GetScaledValue(
ushort i_usRange,
ushort i_usValue
)
JScript
public static function GetScaledValue(
i_usRange : UInt16,
i_usValue : UInt16
) : float

Parameters

i_usRange
The range code
i_usValue
The resolution of value is 16-bits.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetScaledValue Overload List


GetScaledValueWithResolution Method

AnalogInput.GetScaledValueWithResolution Method
[image]

Get the scaled value with resolution for unknown APAX module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValueWithResolution( _
ByVal i_usRange As UInt16, _
ByVal i_iValue As UInt16, _
ByVal i_byResolution As Byte _
) As Single
C#
public static float GetScaledValueWithResolution(
ushort i_usRange,
ushort i_iValue,
byte i_byResolution
)
C++
public:
static float GetScaledValueWithResolution(
unsigned short i_usRange,
unsigned short i_iValue,
char i_byResolution
)
J#
public static float GetScaledValueWithResolution(
ushort i_usRange,
ushort i_iValue,
byte i_byResolution
)
JScript
public static function GetScaledValueWithResolution(
i_usRange : UInt16,
i_iValue : UInt16,
i_byResolution : Byte
) : float

Parameters

i_usRange
The range code
i_iValue
The resolution of value is 16-bits.
i_byResolution
The resolution.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogInput Class
Advantech.Adam Namespace


GetSpanCalibrationName Method

AnalogInput.GetSpanCalibrationName Method

Get the span calibration apply string

Overload List

Name | Description
GetSpanCalibrationName (Adam2000Type, UInt16) | Get the span calibration apply string
GetSpanCalibrationName (Adam4000Type, Byte) | Get the span calibration apply string
GetSpanCalibrationName (Adam5000Type, Byte) | Get the span calibration apply string
GetSpanCalibrationName (Adam6000Type, Byte) | Get the span calibration apply string
GetSpanCalibrationName (Apax5000Type, UInt16) | Get the span calibration apply string
GetSpanCalibrationName (UInt32, UInt16) | Get the span calibration apply string

See Also

AnalogInput Class
Advantech.Adam Namespace


GetSpanCalibrationName Method (Adam2000Type, UInt16)

AnalogInput.GetSpanCalibrationName Method (Adam2000Type, UInt16)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam2000Type As Adam2000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetSpanCalibrationName(
Adam2000Type adam2000Type,
ushort i_usRange
)
C++
public:
static String GetSpanCalibrationName(
Adam2000Type adam2000Type,
unsigned short i_usRange
)
J#
public static string GetSpanCalibrationName(
Adam2000Type adam2000Type,
ushort i_usRange
)
JScript
public static function GetSpanCalibrationName(
adam2000Type : Adam2000Type,
i_usRange : UInt16
) : String

Parameters

adam2000Type
Adam-2000 type
i_usRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (Adam4000Type, Byte)

AnalogInput.GetSpanCalibrationName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetSpanCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetSpanCalibrationName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetSpanCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetSpanCalibrationName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (Adam5000Type, Byte)

AnalogInput.GetSpanCalibrationName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetSpanCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetSpanCalibrationName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetSpanCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetSpanCalibrationName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (Adam6000Type, Byte)

AnalogInput.GetSpanCalibrationName Method (Adam6000Type, Byte)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetSpanCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetSpanCalibrationName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetSpanCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetSpanCalibrationName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (Apax5000Type, UInt16)

AnalogInput.GetSpanCalibrationName Method (Apax5000Type, UInt16)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal apax5000Type As Apax5000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetSpanCalibrationName(
Apax5000Type apax5000Type,
ushort i_usRange
)
C++
public:
static String GetSpanCalibrationName(
Apax5000Type apax5000Type,
unsigned short i_usRange
)
J#
public static string GetSpanCalibrationName(
Apax5000Type apax5000Type,
ushort i_usRange
)
JScript
public static function GetSpanCalibrationName(
apax5000Type : Apax5000Type,
i_usRange : UInt16
) : String

Parameters

apax5000Type
APAX-5000 type
i_usRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (UInt32, UInt16)

AnalogInput.GetSpanCalibrationName Method (UInt32, UInt16)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal i_uiModuleName As UInt32, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetSpanCalibrationName(
uint i_uiModuleName,
ushort i_usRange
)
C++
public:
static String GetSpanCalibrationName(
unsigned int i_uiModuleName,
unsigned short i_usRange
)
J#
public static string GetSpanCalibrationName(
uint i_uiModuleName,
ushort i_usRange
)
JScript
public static function GetSpanCalibrationName(
i_uiModuleName : UInt32,
i_usRange : UInt16
) : String

Parameters

i_uiModuleName
APAX-5000 module name.
i_usRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetSpanCalibrationName Overload List


GetUnitName Method

AnalogInput.GetUnitName Method

Get unit string

Overload List

Name | Description
GetUnitName (Adam4000Type, Byte) | Get unit string
GetUnitName (Adam5000Type, Byte) | Get unit string
GetUnitName (Adam6000Type, Byte) | Get unit string
GetUnitName (Adam6000Type, UInt16) | Get unit string
GetUnitName (Byte) | Get unit string for ADAM unknown module
GetUnitName (UInt16) | Get unit string for APAX unknown module

See Also

AnalogInput Class
Advantech.Adam Namespace


GetUnitName Method (Adam4000Type, Byte)

AnalogInput.GetUnitName Method (Adam4000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetUnitName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetUnitName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetUnitName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetUnitName Overload List


GetUnitName Method (Adam5000Type, Byte)

AnalogInput.GetUnitName Method (Adam5000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetUnitName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetUnitName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetUnitName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetUnitName Overload List


GetUnitName Method (Adam6000Type, Byte)

AnalogInput.GetUnitName Method (Adam6000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetUnitName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetUnitName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetUnitName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetUnitName Overload List


GetUnitName Method (Adam6000Type, UInt16)

AnalogInput.GetUnitName Method (Adam6000Type, UInt16)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetUnitName(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetUnitName(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetUnitName(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetUnitName(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetUnitName Overload List


GetUnitName Method (Byte)

AnalogInput.GetUnitName Method (Byte)
See Also Example
[image]

Get unit string for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
byte i_byRange
)
C++
public:
static String GetUnitName(
char i_byRange
)
J#
public static string GetUnitName(
byte i_byRange
)
JScript
public static function GetUnitName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetUnitName Overload List


GetUnitName Method (UInt16)

AnalogInput.GetUnitName Method (UInt16)
See Also Example
[image]

Get unit string for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetUnitName(
ushort i_usRange
)
C++
public:
static String GetUnitName(
unsigned short i_usRange
)
J#
public static string GetUnitName(
ushort i_usRange
)
JScript
public static function GetUnitName(
i_usRange : UInt16
) : String

Parameters

i_usRange
The range code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetUnitName Overload List


GetUnknownModuleDescription Method

AnalogInput.GetUnknownModuleDescription Method
[image]

Support module: ADAM-5000, ADAM-5000TCP. Get unknown module description.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetUnknownModuleDescription( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_szDesc As String _
) As Boolean
C#
public bool GetUnknownModuleDescription(
int i_iSlot,
out string o_szDesc
)
C++
public:
bool GetUnknownModuleDescription(
int i_iSlot,
[OutAttribute] String% o_szDesc
) sealed
J#
public bool GetUnknownModuleDescription(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ string o_szDesc
)
JScript
public function GetUnknownModuleDescription(
i_iSlot : int,
OutAttribute o_szDesc : String
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_szDesc
The module description.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetUnknownModuleInfo Method

AnalogInput.GetUnknownModuleInfo Method
[image]

Support module: ADAM-5000, ADAM-5000TCP. Get unknown module information.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetUnknownModuleInfo( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iChTotal As Integer, _
<OutAttribute> ByRef o_byRanges As Byte, _
<OutAttribute> ByRef o_byMask As Byte, _
<OutAttribute> ByRef o_byConfig As Byte, _
<OutAttribute> ByRef o_szModuleID As String _
) As Boolean
C#
public bool GetUnknownModuleInfo(
int i_iSlot,
out int o_iChTotal,
out byte o_byRanges,
out byte o_byMask,
out byte o_byConfig,
out string o_szModuleID
)
C++
public:
bool GetUnknownModuleInfo(
int i_iSlot,
[OutAttribute] int% o_iChTotal,
[OutAttribute] char% o_byRanges,
[OutAttribute] char% o_byMask,
[OutAttribute] char% o_byConfig,
[OutAttribute] String% o_szModuleID
) sealed
J#
public bool GetUnknownModuleInfo(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iChTotal,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRanges,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMask,
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig,
/** @attribute OutAttribute() */ /** @ref */ string o_szModuleID
)
JScript
public function GetUnknownModuleInfo(
i_iSlot : int,
OutAttribute o_iChTotal : int,
OutAttribute o_byRanges : Byte,
OutAttribute o_byMask : Byte,
OutAttribute o_byConfig : Byte,
OutAttribute o_szModuleID : String
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_iChTotal
The channel total of the module.
o_byRanges
The ranges code for each channel.
o_byMask
The channel enabled mask.
o_byConfig
The module configuration.
o_szModuleID
The module ID.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetUnknownModuleName Method

AnalogInput.GetUnknownModuleName Method
[image]

Support module: ADAM-5000, ADAM-5000TCP. Get unknown module name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetUnknownModuleName( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_szName As String _
) As Boolean
C#
public bool GetUnknownModuleName(
int i_iSlot,
out string o_szName
)
C++
public:
bool GetUnknownModuleName(
int i_iSlot,
[OutAttribute] String% o_szName
) sealed
J#
public bool GetUnknownModuleName(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ string o_szName
)
JScript
public function GetUnknownModuleName(
i_iSlot : int,
OutAttribute o_szName : String
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_szName
The module name.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetUnknownRangeSupport Method

AnalogInput.GetUnknownRangeSupport Method
[image]

Support module: ADAM-5000, ADAM-5000TCP. Get unknown module range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetUnknownRangeSupport( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byRanges As Byte _
) As Boolean
C#
public bool GetUnknownRangeSupport(
int i_iSlot,
out byte o_byRanges
)
C++
public:
bool GetUnknownRangeSupport(
int i_iSlot,
[OutAttribute] char% o_byRanges
) sealed
J#
public bool GetUnknownRangeSupport(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRanges
)
JScript
public function GetUnknownRangeSupport(
i_iSlot : int,
OutAttribute o_byRanges : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_byRanges
The supported range codes.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetValue Method

AnalogInput.GetValue Method

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get specified channel value. The value returned is in engineering unit format.

Overload List

 | Name | Description
Public method | GetValue (Int32, Int32, Single) | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get specified channel value. The value returned is in engineering unit format.
Public method | GetValue (Int32, Int32, Single, Adam5000_ChannelStatus) | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get specified channel value. The value returned is in engineering unit format.
Public method | GetValue (Int32, Int32, UInt16) | Support module: APAX-5000. Get specified channel value. The value returned is in raw data.
Public method | GetValue (Int32, Int32) | Support module: ADAM-4000, ADAM-4100 Get channel values when the data format is set to two's complement hexdecimal.
Public method | GetValue (Int32, Single, Adam4000_ChannelStatus) | Support module: ADAM-4000, ADAM-4100 Get specified channel value when the data format is set to engineering unit, percent or ohms(ADAM-4015). If the module has only single channel, for example ADAM-4011, use GetValues instead of this method.

See Also

AnalogInput Class
Advantech.Adam Namespace


GetValue Method (Int32, Int32, Single)

AnalogInput.GetValue Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get specified channel value. The value returned is in engineering unit format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetValue(
int i_iSlot,
int i_iChannel,
out float o_fValue
)
C++
public:
bool GetValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_fValue : float
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_fValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValue Overload List


GetValue Method (Int32, Int32, Single, Adam5000_ChannelStatus)

AnalogInput.GetValue Method (Int32, Int32, Single, Adam5000_ChannelStatus)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get specified channel value. The value returned is in engineering unit format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single, _
<OutAttribute> ByRef o_status As Adam5000_ChannelStatus _
) As Boolean
C#
public bool GetValue(
int i_iSlot,
int i_iChannel,
out float o_fValue,
out Adam5000_ChannelStatus o_status
)
C++
public:
bool GetValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] float% o_fValue,
[OutAttribute] Adam5000_ChannelStatus% o_status
) sealed
J#
public bool GetValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue,
/** @attribute OutAttribute() */ /** @ref */ Adam5000_ChannelStatus o_status
)
JScript
public function GetValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_fValue : float,
OutAttribute o_status : Adam5000_ChannelStatus
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_fValue
The channel value.
o_status
The channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValue Overload List


GetValue Method (Int32, Int32, UInt16)

AnalogInput.GetValue Method (Int32, Int32, UInt16)
See Also Example
[image]

Support module: APAX-5000. Get specified channel value. The value returned is in raw data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_wValue As UInt16 _
) As Boolean
C#
public bool GetValue(
int i_iSlot,
int i_iChannel,
out ushort o_wValue
)
C++
public:
bool GetValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] unsigned short% o_wValue
) sealed
J#
public bool GetValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wValue
)
JScript
public function GetValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_wValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
The channel index. The value is between 0~31
o_wValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValue Overload List


GetValue Method (Int32, Int32)

AnalogInput.GetValue Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100 Get channel values when the data format is set to two's complement hexdecimal.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iValue As Integer _
) As Boolean
C#
public bool GetValue(
int i_iChannel,
out int o_iValue
)
C++
public:
bool GetValue(
int i_iChannel,
[OutAttribute] int% o_iValue
) sealed
J#
public bool GetValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iValue
)
JScript
public function GetValue(
i_iChannel : int,
OutAttribute o_iValue : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~7
o_iValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValue Overload List


GetValue Method (Int32, Single, Adam4000_ChannelStatus)

AnalogInput.GetValue Method (Int32, Single, Adam4000_ChannelStatus)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100 Get specified channel value when the data format is set to engineering unit, percent or ohms(ADAM-4015). If the module has only single channel, for example ADAM-4011, use GetValues instead of this method.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single, _
<OutAttribute> ByRef o_status As Adam4000_ChannelStatus _
) As Boolean
C#
public bool GetValue(
int i_iChannel,
out float o_fValue,
out Adam4000_ChannelStatus o_status
)
C++
public:
bool GetValue(
int i_iChannel,
[OutAttribute] float% o_fValue,
[OutAttribute] Adam4000_ChannelStatus% o_status
) sealed
J#
public bool GetValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue,
/** @attribute OutAttribute() */ /** @ref */ Adam4000_ChannelStatus o_status
)
JScript
public function GetValue(
i_iChannel : int,
OutAttribute o_fValue : float,
OutAttribute o_status : Adam4000_ChannelStatus
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~7
o_fValue
The channel value.
o_status
The channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValue Overload List


GetValues Method

AnalogInput.GetValues Method

Support module: ADAM-5000 Get channel values when the data format is set to two's complement hexdecimal.

Overload List

 | Name | Description
Public method | GetValues (Int32, Int32, Int32) | Support module: ADAM-5000 Get channel values when the data format is set to two's complement hexdecimal.
Public method | GetValues (Int32, Int32, Single) | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get channel values when the data format is set to engineering unit or ohms(ADAM-5013 on ADAM-5000).
Public method | GetValues (Int32, Int32, Single, Adam5000_ChannelStatus) | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get channel values when the data format is set to engineering unit or ohms(ADAM-5013 on ADAM-5000).
Public method | GetValues (Int32, Int32, UInt16) | Support module: APAX-5000. Get specified channel values. The value returned is in raw data.
Public method | GetValues (Int32, Int32) | Support module: ADAM-4000, ADAM-4100 Get channel values when the data format is set to two's complement hexdecimal.
Public method | GetValues (Int32, Single, Adam4000_ChannelStatus) | Support module: ADAM-4000, ADAM-4100 Get channel values when the data format is set to engineering unit, percent or ohms(ADAM-4013, ADAM-4015).

See Also

AnalogInput Class
Advantech.Adam Namespace


GetValues Method (Int32, Int32, Int32)

AnalogInput.GetValues Method (Int32, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5000 Get channel values when the data format is set to two's complement hexdecimal.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_iValues As Integer _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
out int o_iValues
)
C++
public:
bool GetValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] int% o_iValues
) sealed
J#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ int o_iValues
)
JScript
public function GetValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_iValues : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannelTotal
The total of the channels. The value is between 1~8
o_iValues
Array of channel values.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValues Overload List


GetValues Method (Int32, Int32, Single)

AnalogInput.GetValues Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get channel values when the data format is set to engineering unit or ohms(ADAM-5013 on ADAM-5000).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_fValues As Single _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
out float o_fValues
)
C++
public:
bool GetValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] float% o_fValues
) sealed
J#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ float o_fValues
)
JScript
public function GetValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_fValues : float
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannelTotal
The total of the channels. The value is between 1~8
o_fValues
Array of channel values.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValues Overload List


GetValues Method (Int32, Int32, Single, Adam5000_ChannelStatus)

AnalogInput.GetValues Method (Int32, Int32, Single, Adam5000_ChannelStatus)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get channel values when the data format is set to engineering unit or ohms(ADAM-5013 on ADAM-5000).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_fValues As Single, _
<OutAttribute> ByRef o_status As Adam5000_ChannelStatus _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
out float o_fValues,
out Adam5000_ChannelStatus o_status
)
C++
public:
bool GetValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] float% o_fValues,
[OutAttribute] Adam5000_ChannelStatus% o_status
) sealed
J#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ float o_fValues,
/** @attribute OutAttribute() */ /** @ref */ Adam5000_ChannelStatus o_status
)
JScript
public function GetValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_fValues : float,
OutAttribute o_status : Adam5000_ChannelStatus
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannelTotal
The total of the channels. The value is between 1~8
o_fValues
Array of channel values.
o_status
The channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValues Overload List


GetValues Method (Int32, Int32, UInt16)

AnalogInput.GetValues Method (Int32, Int32, UInt16)
See Also Example
[image]

Support module: APAX-5000. Get specified channel values. The value returned is in raw data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_wValue As UInt16 _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
out ushort o_wValue
)
C++
public:
bool GetValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] unsigned short% o_wValue
) sealed
J#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wValue
)
JScript
public function GetValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_wValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The channel total. The value is between 1~31
o_wValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValues Overload List


GetValues Method (Int32, Int32)

AnalogInput.GetValues Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100 Get channel values when the data format is set to two's complement hexdecimal.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_iValues As Integer _
) As Boolean
C#
public bool GetValues(
int i_iChannelTotal,
out int o_iValues
)
C++
public:
bool GetValues(
int i_iChannelTotal,
[OutAttribute] int% o_iValues
) sealed
J#
public bool GetValues(
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ int o_iValues
)
JScript
public function GetValues(
i_iChannelTotal : int,
OutAttribute o_iValues : int
) : bool

Parameters

i_iChannelTotal
The total of the channels. The value is between 1~8
o_iValues
Array of channel values.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValues Overload List


GetValues Method (Int32, Single, Adam4000_ChannelStatus)

AnalogInput.GetValues Method (Int32, Single, Adam4000_ChannelStatus)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100 Get channel values when the data format is set to engineering unit, percent or ohms(ADAM-4013, ADAM-4015).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_fValues As Single, _
<OutAttribute> ByRef o_status As Adam4000_ChannelStatus _
) As Boolean
C#
public bool GetValues(
int i_iChannelTotal,
out float o_fValues,
out Adam4000_ChannelStatus o_status
)
C++
public:
bool GetValues(
int i_iChannelTotal,
[OutAttribute] float% o_fValues,
[OutAttribute] Adam4000_ChannelStatus% o_status
) sealed
J#
public bool GetValues(
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ float o_fValues,
/** @attribute OutAttribute() */ /** @ref */ Adam4000_ChannelStatus o_status
)
JScript
public function GetValues(
i_iChannelTotal : int,
OutAttribute o_fValues : float,
OutAttribute o_status : Adam4000_ChannelStatus
) : bool

Parameters

i_iChannelTotal
The total of the channels on the module. The value is between 1~8
o_fValues
Array of channel values.
o_status
The channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetValues Overload List


GetZeroCalibrationName Method

AnalogInput.GetZeroCalibrationName Method

Get the zero calibration apply string

Overload List

Name | Description
GetZeroCalibrationName (Adam2000Type, UInt16) | Get the zero calibration apply string
GetZeroCalibrationName (Adam4000Type, Byte) | Get the zero calibration apply string
GetZeroCalibrationName (Adam5000Type, Byte) | Get the zero calibration apply string
GetZeroCalibrationName (Adam6000Type, Byte) | Get the zero calibration apply string
GetZeroCalibrationName (Adam6000Type, UInt16) | Get the zero calibration apply string
GetZeroCalibrationName (Apax5000Type, UInt16) | Get the zero calibration apply string
GetZeroCalibrationName (UInt32, UInt16) | Get the zero calibration apply string

See Also

AnalogInput Class
Advantech.Adam Namespace


GetZeroCalibrationName Method (Adam2000Type, UInt16)

AnalogInput.GetZeroCalibrationName Method (Adam2000Type, UInt16)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam2000Type As Adam2000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetZeroCalibrationName(
Adam2000Type adam2000Type,
ushort i_usRange
)
C++
public:
static String GetZeroCalibrationName(
Adam2000Type adam2000Type,
unsigned short i_usRange
)
J#
public static string GetZeroCalibrationName(
Adam2000Type adam2000Type,
ushort i_usRange
)
JScript
public static function GetZeroCalibrationName(
adam2000Type : Adam2000Type,
i_usRange : UInt16
) : String

Parameters

adam2000Type
Adam-2000 type
i_usRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Adam4000Type, Byte)

AnalogInput.GetZeroCalibrationName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetZeroCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetZeroCalibrationName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetZeroCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetZeroCalibrationName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Adam5000Type, Byte)

AnalogInput.GetZeroCalibrationName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetZeroCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetZeroCalibrationName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetZeroCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetZeroCalibrationName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Adam6000Type, Byte)

AnalogInput.GetZeroCalibrationName Method (Adam6000Type, Byte)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetZeroCalibrationName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetZeroCalibrationName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Adam6000Type, UInt16)

AnalogInput.GetZeroCalibrationName Method (Adam6000Type, UInt16)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetZeroCalibrationName(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetZeroCalibrationName(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
Adam-6000 type
i_usRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Apax5000Type, UInt16)

AnalogInput.GetZeroCalibrationName Method (Apax5000Type, UInt16)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal apax5000Type As Apax5000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetZeroCalibrationName(
Apax5000Type apax5000Type,
ushort i_usRange
)
C++
public:
static String GetZeroCalibrationName(
Apax5000Type apax5000Type,
unsigned short i_usRange
)
J#
public static string GetZeroCalibrationName(
Apax5000Type apax5000Type,
ushort i_usRange
)
JScript
public static function GetZeroCalibrationName(
apax5000Type : Apax5000Type,
i_usRange : UInt16
) : String

Parameters

apax5000Type
APAX-5000 type
i_usRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (UInt32, UInt16)

AnalogInput.GetZeroCalibrationName Method (UInt32, UInt16)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal i_uiModuleName As UInt32, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetZeroCalibrationName(
uint i_uiModuleName,
ushort i_usRange
)
C++
public:
static String GetZeroCalibrationName(
unsigned int i_uiModuleName,
unsigned short i_usRange
)
J#
public static string GetZeroCalibrationName(
uint i_uiModuleName,
ushort i_usRange
)
JScript
public static function GetZeroCalibrationName(
i_uiModuleName : UInt32,
i_usRange : UInt16
) : String

Parameters

i_uiModuleName
APAX-5000 module name.
i_usRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.GetZeroCalibrationName Overload List


ODM17S_GetEnableChannelTotal Method

AnalogInput.ODM17S_GetEnableChannelTotal Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S enable channel number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_GetEnableChannelTotal( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iEnableChannelTotal As Integer _
) As Boolean
C#
public bool ODM17S_GetEnableChannelTotal(
int i_iSlot,
out int o_iEnableChannelTotal
)
C++
public:
bool ODM17S_GetEnableChannelTotal(
int i_iSlot,
[OutAttribute] int% o_iEnableChannelTotal
) sealed
J#
public bool ODM17S_GetEnableChannelTotal(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iEnableChannelTotal
)
JScript
public function ODM17S_GetEnableChannelTotal(
i_iSlot : int,
OutAttribute o_iEnableChannelTotal : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_iEnableChannelTotal
The enable channel number.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_GetFifoData Method

AnalogInput.ODM17S_GetFifoData Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S enable channel number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_GetFifoData( _
ByVal i_iSlot As Integer, _
ByRef o_sValues As Short _
) As Boolean
C#
public bool ODM17S_GetFifoData(
int i_iSlot,
ref short o_sValues
)
C++
public:
bool ODM17S_GetFifoData(
int i_iSlot,
short% o_sValues
) sealed
J#
public bool ODM17S_GetFifoData(
int i_iSlot,
short o_sValues
)
JScript
public function ODM17S_GetFifoData(
i_iSlot : int,
o_sValues : short
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_sValues
The fifo data.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_GetMode Method

AnalogInput.ODM17S_GetMode Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S acquisition mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_GetMode( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byMode As Byte _
) As Boolean
C#
public bool ODM17S_GetMode(
int i_iSlot,
out byte o_byMode
)
C++
public:
bool ODM17S_GetMode(
int i_iSlot,
[OutAttribute] char% o_byMode
) sealed
J#
public bool ODM17S_GetMode(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode
)
JScript
public function ODM17S_GetMode(
i_iSlot : int,
OutAttribute o_byMode : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_byMode
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_GetRange Method

AnalogInput.ODM17S_GetRange Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Get module analog input range.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_GetRange( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool ODM17S_GetRange(
int i_iSlot,
out byte o_byRange
)
C++
public:
bool ODM17S_GetRange(
int i_iSlot,
[OutAttribute] char% o_byRange
) sealed
J#
public bool ODM17S_GetRange(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function ODM17S_GetRange(
i_iSlot : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_GetSampleRate Method

AnalogInput.ODM17S_GetSampleRate Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S sampling rate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_GetSampleRate( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iSampleRate As Integer _
) As Boolean
C#
public bool ODM17S_GetSampleRate(
int i_iSlot,
out int o_iSampleRate
)
C++
public:
bool ODM17S_GetSampleRate(
int i_iSlot,
[OutAttribute] int% o_iSampleRate
) sealed
J#
public bool ODM17S_GetSampleRate(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iSampleRate
)
JScript
public function ODM17S_GetSampleRate(
i_iSlot : int,
OutAttribute o_iSampleRate : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_iSampleRate
The sampling rate.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_GetTrigTotal Method

AnalogInput.ODM17S_GetTrigTotal Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Get ODM ADAM-5017S trigger total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_GetTrigTotal( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iTrigTotal As Integer _
) As Boolean
C#
public bool ODM17S_GetTrigTotal(
int i_iSlot,
out int o_iTrigTotal
)
C++
public:
bool ODM17S_GetTrigTotal(
int i_iSlot,
[OutAttribute] int% o_iTrigTotal
) sealed
J#
public bool ODM17S_GetTrigTotal(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iTrigTotal
)
JScript
public function ODM17S_GetTrigTotal(
i_iSlot : int,
OutAttribute o_iTrigTotal : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_iTrigTotal
The trigger total number.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_SetEnableChannelTotal Method

AnalogInput.ODM17S_SetEnableChannelTotal Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S enable channel number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_SetEnableChannelTotal( _
ByVal i_iSlot As Integer, _
ByVal i_iEnableChannelTotal As Integer _
) As Boolean
C#
public bool ODM17S_SetEnableChannelTotal(
int i_iSlot,
int i_iEnableChannelTotal
)
C++
public:
bool ODM17S_SetEnableChannelTotal(
int i_iSlot,
int i_iEnableChannelTotal
) sealed
J#
public bool ODM17S_SetEnableChannelTotal(
int i_iSlot,
int i_iEnableChannelTotal
)
JScript
public function ODM17S_SetEnableChannelTotal(
i_iSlot : int,
i_iEnableChannelTotal : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iEnableChannelTotal
The enable channel number.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_SetMode Method

AnalogInput.ODM17S_SetMode Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S acquisition mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_SetMode( _
ByVal i_iSlot As Integer, _
ByVal i_byMode As Byte _
) As Boolean
C#
public bool ODM17S_SetMode(
int i_iSlot,
byte i_byMode
)
C++
public:
bool ODM17S_SetMode(
int i_iSlot,
char i_byMode
) sealed
J#
public bool ODM17S_SetMode(
int i_iSlot,
byte i_byMode
)
JScript
public function ODM17S_SetMode(
i_iSlot : int,
i_byMode : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_byMode
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_SetRange Method

AnalogInput.ODM17S_SetRange Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Set module analog input range.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_SetRange( _
ByVal i_iSlot As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool ODM17S_SetRange(
int i_iSlot,
byte i_byRange
)
C++
public:
bool ODM17S_SetRange(
int i_iSlot,
char i_byRange
) sealed
J#
public bool ODM17S_SetRange(
int i_iSlot,
byte i_byRange
)
JScript
public function ODM17S_SetRange(
i_iSlot : int,
i_byRange : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_SetSampleRate Method

AnalogInput.ODM17S_SetSampleRate Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S sampling rate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_SetSampleRate( _
ByVal i_iSlot As Integer, _
ByVal i_iSampleRate As Integer _
) As Boolean
C#
public bool ODM17S_SetSampleRate(
int i_iSlot,
int i_iSampleRate
)
C++
public:
bool ODM17S_SetSampleRate(
int i_iSlot,
int i_iSampleRate
) sealed
J#
public bool ODM17S_SetSampleRate(
int i_iSlot,
int i_iSampleRate
)
JScript
public function ODM17S_SetSampleRate(
i_iSlot : int,
i_iSampleRate : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iSampleRate
The sampling rate.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_SetStart Method

AnalogInput.ODM17S_SetStart Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. ODM ADAM-5017S start to get value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_SetStart( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool ODM17S_SetStart(
int i_iSlot
)
C++
public:
bool ODM17S_SetStart(
int i_iSlot
) sealed
J#
public bool ODM17S_SetStart(
int i_iSlot
)
JScript
public function ODM17S_SetStart(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_SetStop Method

AnalogInput.ODM17S_SetStop Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. ODM ADAM-5017S stop getting value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_SetStop( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool ODM17S_SetStop(
int i_iSlot
)
C++
public:
bool ODM17S_SetStop(
int i_iSlot
) sealed
J#
public bool ODM17S_SetStop(
int i_iSlot
)
JScript
public function ODM17S_SetStop(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


ODM17S_SetTrigTotal Method

AnalogInput.ODM17S_SetTrigTotal Method
[image]

Support module: ADAM-5017S ODM on ADAM-5550. Set ODM ADAM-5017S trigger total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ODM17S_SetTrigTotal( _
ByVal i_iSlot As Integer, _
ByVal i_iTrigTotal As Integer _
) As Boolean
C#
public bool ODM17S_SetTrigTotal(
int i_iSlot,
int i_iTrigTotal
)
C++
public:
bool ODM17S_SetTrigTotal(
int i_iSlot,
int i_iTrigTotal
) sealed
J#
public bool ODM17S_SetTrigTotal(
int i_iSlot,
int i_iTrigTotal
)
JScript
public function ODM17S_SetTrigTotal(
i_iSlot : int,
i_iTrigTotal : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iTrigTotal
The trigger total number.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetAutoCalibration Method

AnalogInput.SetAutoCalibration Method
[image]

Support module: APAX-5000, APAX-5070(UDP:5222). Set analog input auto-calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAutoCalibration( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SetAutoCalibration(
int i_iSlot
)
C++
public:
bool SetAutoCalibration(
int i_iSlot
) sealed
J#
public bool SetAutoCalibration(
int i_iSlot
)
JScript
public function SetAutoCalibration(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetAutoFilter Method

AnalogInput.SetAutoFilter Method
[image]

Support module: ADAM-4100. Set Auto-filter.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAutoFilter() As Boolean
C#
public bool SetAutoFilter()
C++
public:
bool SetAutoFilter() sealed
J#
public bool SetAutoFilter()
JScript
public function SetAutoFilter() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetAutoFilterEnabled Method

AnalogInput.SetAutoFilterEnabled Method
[image]

Support module: ADAM-4100. Set Auto-filter channel enabled status and filter percentage index.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAutoFilterEnabled( _
ByVal i_bEnabled As Boolean(), _
ByVal i_iPercentIndex As Integer _
) As Boolean
C#
public bool SetAutoFilterEnabled(
bool[] i_bEnabled,
int i_iPercentIndex
)
C++
public:
bool SetAutoFilterEnabled(
array<bool>^ i_bEnabled,
int i_iPercentIndex
) sealed
J#
public bool SetAutoFilterEnabled(
bool[] i_bEnabled,
int i_iPercentIndex
)
JScript
public function SetAutoFilterEnabled(
i_bEnabled : bool[],
i_iPercentIndex : int
) : bool

Parameters

i_bEnabled
Array of channel status.
i_iPercentIndex
The percentage index. 1 means 10%, ..., 9 means 90%.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetAverageChannelEnabled Method

AnalogInput.SetAverageChannelEnabled Method
[image]

Support module: ADAM-6000. Set channel enabled status for average

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAverageChannelEnabled( _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetAverageChannelEnabled(
bool[] i_bEnabled
)
C++
public:
bool SetAverageChannelEnabled(
array<bool>^ i_bEnabled
) sealed
J#
public bool SetAverageChannelEnabled(
bool[] i_bEnabled
)
JScript
public function SetAverageChannelEnabled(
i_bEnabled : bool[]
) : bool

Parameters

i_bEnabled
Array of channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetBiasValue Method

AnalogInput.SetBiasValue Method
[image]

Support module: ADAM-4018P. Set bias value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetBiasValue( _
ByVal i_iChannel As Integer, _
ByVal i_fBiasValue As Single _
) As Boolean
C#
public bool SetBiasValue(
int i_iChannel,
float i_fBiasValue
)
C++
public:
bool SetBiasValue(
int i_iChannel,
float i_fBiasValue
) sealed
J#
public bool SetBiasValue(
int i_iChannel,
float i_fBiasValue
)
JScript
public function SetBiasValue(
i_iChannel : int,
i_fBiasValue : float
) : bool

Parameters

i_iChannel
Channel index. The value is between 0~7
i_fBiasValue
Bias value. The value is between -25.5~25.5

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetBurnoutDetect Method

AnalogInput.SetBurnoutDetect Method

Support module: ADAM-4100. Set burnout detect setting.

Overload List

 | Name | Description
Public method | SetBurnoutDetect (Boolean) | Support module: ADAM-4100. Set burnout detect setting.
Public method | SetBurnoutDetect (UInt16) | Support module: ADAM-6000. Get burnout detect setting.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetBurnoutDetect Method (Boolean)

AnalogInput.SetBurnoutDetect Method (Boolean)
See Also Example
[image]

Support module: ADAM-4100. Set burnout detect setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetBurnoutDetect( _
ByVal i_burnout As Boolean _
) As Boolean
C#
public bool SetBurnoutDetect(
bool i_burnout
)
C++
public:
bool SetBurnoutDetect(
bool i_burnout
) sealed
J#
public bool SetBurnoutDetect(
bool i_burnout
)
JScript
public function SetBurnoutDetect(
i_burnout : bool
) : bool

Parameters

i_burnout
Enable burnout detect enable

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetBurnoutDetect Overload List


SetBurnoutDetect Method (UInt16)

AnalogInput.SetBurnoutDetect Method (UInt16)
See Also Example
[image]

Support module: ADAM-6000. Get burnout detect setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetBurnoutDetect( _
ByVal i_usBurnout As UInt16 _
) As Boolean
C#
public bool SetBurnoutDetect(
ushort i_usBurnout
)
C++
public:
bool SetBurnoutDetect(
unsigned short i_usBurnout
) sealed
J#
public bool SetBurnoutDetect(
ushort i_usBurnout
)
JScript
public function SetBurnoutDetect(
i_usBurnout : UInt16
) : bool

Parameters

i_usBurnout
ushort, ( FFFF: up scale, 0000: down scale).

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetBurnoutDetect Overload List


SetBurnoutFunEnable Method

AnalogInput.SetBurnoutFunEnable Method
[image]

Support module: APAX-5000. Set burnout function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetBurnoutFunEnable( _
ByVal i_iSlot As Integer, _
ByVal i_uiEnableMask As UInt32 _
) As Boolean
C#
public bool SetBurnoutFunEnable(
int i_iSlot,
uint i_uiEnableMask
)
C++
public:
bool SetBurnoutFunEnable(
int i_iSlot,
unsigned int i_uiEnableMask
) sealed
J#
public bool SetBurnoutFunEnable(
int i_iSlot,
uint i_uiEnableMask
)
JScript
public function SetBurnoutFunEnable(
i_iSlot : int,
i_uiEnableMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_uiEnableMask
Enable burnout detect enable

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetBurnoutMap Method

AnalogInput.SetBurnoutMap Method

Support module: ADAM-4100. Set burnout mapping.

Overload List

 | Name | Description
Public method | SetBurnoutMap (Adam4100_BurnoutMap) | Support module: ADAM-4100. Set burnout mapping.
Public method | SetBurnoutMap (Int32, Adam5017UH_BurnoutMap) | Support module: ADAM-5017UH. Set burnout mapping.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetBurnoutMap Method (Adam4100_BurnoutMap)

AnalogInput.SetBurnoutMap Method (Adam4100_BurnoutMap)
See Also Example
[image]

Support module: ADAM-4100. Set burnout mapping.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetBurnoutMap( _
ByVal i_burnout As Adam4100_BurnoutMap _
) As Boolean
C#
public bool SetBurnoutMap(
Adam4100_BurnoutMap i_burnout
)
C++
public:
bool SetBurnoutMap(
Adam4100_BurnoutMap i_burnout
) sealed
J#
public bool SetBurnoutMap(
Adam4100_BurnoutMap i_burnout
)
JScript
public function SetBurnoutMap(
i_burnout : Adam4100_BurnoutMap
) : bool

Parameters

i_burnout
Burnout mapping

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetBurnoutMap Overload List


SetBurnoutMap Method (Int32, Adam5017UH_BurnoutMap)

AnalogInput.SetBurnoutMap Method (Int32, Adam5017UH_BurnoutMap)
See Also Example
[image]

Support module: ADAM-5017UH. Set burnout mapping.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetBurnoutMap( _
ByVal i_iSlot As Integer, _
ByVal i_burnout As Adam5017UH_BurnoutMap _
) As Boolean
C#
public bool SetBurnoutMap(
int i_iSlot,
Adam5017UH_BurnoutMap i_burnout
)
C++
public:
bool SetBurnoutMap(
int i_iSlot,
Adam5017UH_BurnoutMap i_burnout
) sealed
J#
public bool SetBurnoutMap(
int i_iSlot,
Adam5017UH_BurnoutMap i_burnout
)
JScript
public function SetBurnoutMap(
i_iSlot : int,
i_burnout : Adam5017UH_BurnoutMap
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_burnout
Burnout mapping

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetBurnoutMap Overload List


SetBurnoutValue Method

AnalogInput.SetBurnoutValue Method
[image]

Support module: APAX-5000. Set The Value While Burnout.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetBurnoutValue( _
ByVal i_iSlot As Integer, _
ByVal i_dwValue As UInt32 _
) As Boolean
C#
public bool SetBurnoutValue(
int i_iSlot,
uint i_dwValue
)
C++
public:
bool SetBurnoutValue(
int i_iSlot,
unsigned int i_dwValue
) sealed
J#
public bool SetBurnoutValue(
int i_iSlot,
uint i_dwValue
)
JScript
public function SetBurnoutValue(
i_iSlot : int,
i_dwValue : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_dwValue
The value while burnout

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetChannelEnabled Method

AnalogInput.SetChannelEnabled Method

Support module: ADAM-4100, ADAM-6000. Set channel enabled status

Overload List

 | Name | Description
Public method | SetChannelEnabled (Boolean) | Support module: ADAM-4100, ADAM-6000. Set channel enabled status
Public method | SetChannelEnabled (Int32, Boolean) | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550, APAX-5000. Set channel enabled status
Public method | SetChannelEnabled (Int32, UInt32) | Support module: APAX-5000. Set channel enabled status

See Also

AnalogInput Class
Advantech.Adam Namespace


SetChannelEnabled Method (Boolean[])

AnalogInput.SetChannelEnabled Method (Boolean[])
See Also Example
[image]

Support module: ADAM-4100, ADAM-6000. Set channel enabled status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelEnabled( _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetChannelEnabled(
bool[] i_bEnabled
)
C++
public:
bool SetChannelEnabled(
array<bool>^ i_bEnabled
) sealed
J#
public bool SetChannelEnabled(
bool[] i_bEnabled
)
JScript
public function SetChannelEnabled(
i_bEnabled : bool[]
) : bool

Parameters

i_bEnabled
Array of channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetChannelEnabled Overload List


SetChannelEnabled Method (Int32, Boolean[])

AnalogInput.SetChannelEnabled Method (Int32, Boolean[])
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550, APAX-5000. Set channel enabled status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelEnabled( _
ByVal i_iSlot As Integer, _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetChannelEnabled(
int i_iSlot,
bool[] i_bEnabled
)
C++
public:
bool SetChannelEnabled(
int i_iSlot,
array<bool>^ i_bEnabled
) sealed
J#
public bool SetChannelEnabled(
int i_iSlot,
bool[] i_bEnabled
)
JScript
public function SetChannelEnabled(
i_iSlot : int,
i_bEnabled : bool[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7 (APAX:0~15)
i_bEnabled
Array of channel status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetChannelEnabled Overload List


SetChannelEnabled Method (Int32, UInt32)

AnalogInput.SetChannelEnabled Method (Int32, UInt32)
See Also Example
[image]

Support module: APAX-5000. Set channel enabled status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelEnabled( _
ByVal i_iSlot As Integer, _
ByVal uiEnabledMask As UInt32 _
) As Boolean
C#
public bool SetChannelEnabled(
int i_iSlot,
uint uiEnabledMask
)
C++
public:
bool SetChannelEnabled(
int i_iSlot,
unsigned int uiEnabledMask
) sealed
J#
public bool SetChannelEnabled(
int i_iSlot,
uint uiEnabledMask
)
JScript
public function SetChannelEnabled(
i_iSlot : int,
uiEnabledMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
uiEnabledMask
The enable mask.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetChannelEnabled Overload List


SetChannelNegCalibration Method

AnalogInput.SetChannelNegCalibration Method
[image]

Support module: ADAM-4000. Set analog input Neg. calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelNegCalibration( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetChannelNegCalibration(
int i_iChannel
)
C++
public:
bool SetChannelNegCalibration(
int i_iChannel
) sealed
J#
public bool SetChannelNegCalibration(
int i_iChannel
)
JScript
public function SetChannelNegCalibration(
i_iChannel : int
) : bool

Parameters

i_iChannel
Channel index. The value is between 0~7

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetChannelSpanCalibration Method

AnalogInput.SetChannelSpanCalibration Method
[image]

Support module: ADAM-4000. Set analog input Span calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelSpanCalibration( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetChannelSpanCalibration(
int i_iChannel
)
C++
public:
bool SetChannelSpanCalibration(
int i_iChannel
) sealed
J#
public bool SetChannelSpanCalibration(
int i_iChannel
)
JScript
public function SetChannelSpanCalibration(
i_iChannel : int
) : bool

Parameters

i_iChannel
Channel index. The value is between 0~7

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetChannelZeroCalibration Method

AnalogInput.SetChannelZeroCalibration Method
[image]

Support module: ADAM-4000. Set analog input Zero calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelZeroCalibration( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetChannelZeroCalibration(
int i_iChannel
)
C++
public:
bool SetChannelZeroCalibration(
int i_iChannel
) sealed
J#
public bool SetChannelZeroCalibration(
int i_iChannel
)
JScript
public function SetChannelZeroCalibration(
i_iChannel : int
) : bool

Parameters

i_iChannel
Channel index. The value is between 0~7

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetChValOffset Method

AnalogInput.SetChValOffset Method
[image]

Support module: APAX-5000. Set channel value offset.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChValOffset( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_uiChValOffset As UInt32 _
) As Boolean
C#
public bool SetChValOffset(
int i_iSlot,
int i_iChannel,
uint i_uiChValOffset
)
C++
public:
bool SetChValOffset(
int i_iSlot,
int i_iChannel,
unsigned int i_uiChValOffset
) sealed
J#
public bool SetChValOffset(
int i_iSlot,
int i_iChannel,
uint i_uiChValOffset
)
JScript
public function SetChValOffset(
i_iSlot : int,
i_iChannel : int,
i_uiChValOffset : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
Channel index.
i_uiChValOffset
The channel value offset.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetCjcInitValRecord Method

AnalogInput.SetCjcInitValRecord Method
[image]

Support module: APAX-5000. CJC Initial Value Record.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCjcInitValRecord( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SetCjcInitValRecord(
int i_iSlot
)
C++
public:
bool SetCjcInitValRecord(
int i_iSlot
) sealed
J#
public bool SetCjcInitValRecord(
int i_iSlot
)
JScript
public function SetCjcInitValRecord(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetCJCOffset Method

AnalogInput.SetCJCOffset Method

Support module: ADAM-5000, ADAM-5000TCP, APAX-5000. Set CJC offset calibration value

Overload List

 | Name | Description
Public method | SetCJCOffset (Int32, Single) | Support module: ADAM-5000, ADAM-5000TCP, APAX-5000. Set CJC offset calibration value
Public method | SetCJCOffset (Single) | Support module: ADAM-4000, ADAM-4100. Set CJC offset calibration value

See Also

AnalogInput Class
Advantech.Adam Namespace


SetCJCOffset Method (Int32, Single)

AnalogInput.SetCJCOffset Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP, APAX-5000. Set CJC offset calibration value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCJCOffset( _
ByVal i_iSlot As Integer, _
ByVal i_fCJCOffset As Single _
) As Boolean
C#
public bool SetCJCOffset(
int i_iSlot,
float i_fCJCOffset
)
C++
public:
bool SetCJCOffset(
int i_iSlot,
float i_fCJCOffset
) sealed
J#
public bool SetCJCOffset(
int i_iSlot,
float i_fCJCOffset
)
JScript
public function SetCJCOffset(
i_iSlot : int,
i_fCJCOffset : float
) : bool

Parameters

i_iSlot
Slot index.
i_fCJCOffset
The CJC offset value

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetCJCOffset Overload List


SetCJCOffset Method (Single)

AnalogInput.SetCJCOffset Method (Single)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100. Set CJC offset calibration value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCJCOffset( _
ByVal i_fCJCOffset As Single _
) As Boolean
C#
public bool SetCJCOffset(
float i_fCJCOffset
)
C++
public:
bool SetCJCOffset(
float i_fCJCOffset
) sealed
J#
public bool SetCJCOffset(
float i_fCJCOffset
)
JScript
public function SetCJCOffset(
i_fCJCOffset : float
) : bool

Parameters

i_fCJCOffset
The CJC offset value

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetCJCOffset Overload List


SetCJCValue Method

AnalogInput.SetCJCValue Method
[image]

Support module: ADAM-6000. Set CJC calibration value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCJCValue( _
ByVal i_fCJCOffset As Single _
) As Boolean
C#
public bool SetCJCValue(
float i_fCJCOffset
)
C++
public:
bool SetCJCValue(
float i_fCJCOffset
) sealed
J#
public bool SetCJCValue(
float i_fCJCOffset
)
JScript
public function SetCJCValue(
i_fCJCOffset : float
) : bool

Parameters

i_fCJCOffset
The CJC offset value

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetDataFormat Method

AnalogInput.SetDataFormat Method
[image]

Support module: ADAM-5017H, ADAM-5017UH. Set module data format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDataFormat( _
ByVal i_iSlot As Integer, _
ByVal i_byDataFormat As Byte _
) As Boolean
C#
public bool SetDataFormat(
int i_iSlot,
byte i_byDataFormat
)
C++
public:
bool SetDataFormat(
int i_iSlot,
char i_byDataFormat
) sealed
J#
public bool SetDataFormat(
int i_iSlot,
byte i_byDataFormat
)
JScript
public function SetDataFormat(
i_iSlot : int,
i_byDataFormat : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_byDataFormat
The data format code.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetInputRange Method

AnalogInput.SetInputRange Method

Support module: ADAM-4000 (Channel Independant Configuration), ADAM-4100, ADAM-6000. Set module analog input range

Overload List

 | Name | Description
Public method | SetInputRange (Int32, Byte) | Support module: ADAM-4000 (Channel Independant Configuration), ADAM-4100, ADAM-6000. Set module analog input range
Public method | SetInputRange (Int32, Int32, Byte) | Support module: ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018P. (Also support on ADAM-5550) Set module analog input range
Public method | SetInputRange (Int32, UInt16) | Support module: ADAM-6000. Set module analog input range

See Also

AnalogInput Class
Advantech.Adam Namespace


SetInputRange Method (Int32, Byte)

AnalogInput.SetInputRange Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4000 (Channel Independant Configuration), ADAM-4100, ADAM-6000. Set module analog input range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetInputRange( _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool SetInputRange(
int i_iChannel,
byte i_byRange
)
C++
public:
bool SetInputRange(
int i_iChannel,
char i_byRange
) sealed
J#
public bool SetInputRange(
int i_iChannel,
byte i_byRange
)
JScript
public function SetInputRange(
i_iChannel : int,
i_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~7
i_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetInputRange Overload List


SetInputRange Method (Int32, Int32, Byte)

AnalogInput.SetInputRange Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5017H, ADAM-5017UH, ADAM-5017P, ADAM-5018P. (Also support on ADAM-5550) Set module analog input range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetInputRange( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool SetInputRange(
int i_iSlot,
int i_iChannel,
byte i_byRange
)
C++
public:
bool SetInputRange(
int i_iSlot,
int i_iChannel,
char i_byRange
) sealed
J#
public bool SetInputRange(
int i_iSlot,
int i_iChannel,
byte i_byRange
)
JScript
public function SetInputRange(
i_iSlot : int,
i_iChannel : int,
i_byRange : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetInputRange Overload List


SetInputRange Method (Int32, UInt16)

AnalogInput.SetInputRange Method (Int32, UInt16)
See Also Example
[image]

Support module: ADAM-6000. Set module analog input range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetInputRange( _
ByVal i_iChannel As Integer, _
ByVal i_usRange As UInt16 _
) As Boolean
C#
public bool SetInputRange(
int i_iChannel,
ushort i_usRange
)
C++
public:
bool SetInputRange(
int i_iChannel,
unsigned short i_usRange
) sealed
J#
public bool SetInputRange(
int i_iChannel,
ushort i_usRange
)
JScript
public function SetInputRange(
i_iChannel : int,
i_usRange : UInt16
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~7
i_usRange
The input range code. (Use ushort as the parameter)

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetInputRange Overload List


SetIntegration Method

AnalogInput.SetIntegration Method

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Set module integration time

Overload List

 | Name | Description
Public method | SetIntegration (Byte) | Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Set module integration time
Public method | SetIntegration (Int32, Byte) | Support module: ADAM-5017H, ADAM-5017UH. Set module integration time
Public method | SetIntegration (Int32, UInt32) | Support module: APAX-5000, APAX-5070. Set module integration time

See Also

AnalogInput Class
Advantech.Adam Namespace


SetIntegration Method (Byte)

AnalogInput.SetIntegration Method (Byte)
See Also Example
[image]

Support module: ADAM-6015, ADAM-6017, ADAM-6018, ADAM-6217, ADAM-6218. Set module integration time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIntegration( _
ByVal i_byIntegration As Byte _
) As Boolean
C#
public bool SetIntegration(
byte i_byIntegration
)
C++
public:
bool SetIntegration(
char i_byIntegration
) sealed
J#
public bool SetIntegration(
byte i_byIntegration
)
JScript
public function SetIntegration(
i_byIntegration : Byte
) : bool

Parameters

i_byIntegration
The integration code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetIntegration Overload List


SetIntegration Method (Int32, Byte)

AnalogInput.SetIntegration Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-5017H, ADAM-5017UH. Set module integration time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIntegration( _
ByVal i_iSlot As Integer, _
ByVal i_byIntegration As Byte _
) As Boolean
C#
public bool SetIntegration(
int i_iSlot,
byte i_byIntegration
)
C++
public:
bool SetIntegration(
int i_iSlot,
char i_byIntegration
) sealed
J#
public bool SetIntegration(
int i_iSlot,
byte i_byIntegration
)
JScript
public function SetIntegration(
i_iSlot : int,
i_byIntegration : Byte
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_byIntegration
The integration code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetIntegration Overload List


SetIntegration Method (Int32, UInt32)

AnalogInput.SetIntegration Method (Int32, UInt32)
See Also Example
[image]

Support module: APAX-5000, APAX-5070. Set module integration time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIntegration( _
ByVal i_iSlot As Integer, _
ByVal i_uiIntegration As UInt32 _
) As Boolean
C#
public bool SetIntegration(
int i_iSlot,
uint i_uiIntegration
)
C++
public:
bool SetIntegration(
int i_iSlot,
unsigned int i_uiIntegration
) sealed
J#
public bool SetIntegration(
int i_iSlot,
uint i_uiIntegration
)
JScript
public function SetIntegration(
i_iSlot : int,
i_uiIntegration : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15.
i_uiIntegration
The integration code. 0:60Hz, 1:50Hz

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetIntegration Overload List


SetLeadWire Method

AnalogInput.SetLeadWire Method
[image]

Support module: ADAM-4000. Set lead wire resistance value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLeadWire( _
ByVal i_iType As Integer, _
ByVal i_fVal As Single _
) As Boolean
C#
public bool SetLeadWire(
int i_iType,
float i_fVal
)
C++
public:
bool SetLeadWire(
int i_iType,
float i_fVal
) sealed
J#
public bool SetLeadWire(
int i_iType,
float i_fVal
)
JScript
public function SetLeadWire(
i_iType : int,
i_fVal : float
) : bool

Parameters

i_iType
The thermistor type. 0 for 3k, others for 10k.
i_fVal
The lead wire resistance value. The value must be between -655.35~655.35

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetMemConfig Method

AnalogInput.SetMemConfig Method
[image]

Support module: ADAM-4018M. Set memory configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMemConfig( _
ByVal i_bEnabled As Boolean(), _
ByVal i_bRecord As Boolean, _
ByVal i_byRecordMode As Byte, _
ByVal i_MemMode As Byte, _
ByVal i_iInterval As Integer _
) As Boolean
C#
public bool SetMemConfig(
bool[] i_bEnabled,
bool i_bRecord,
byte i_byRecordMode,
byte i_MemMode,
int i_iInterval
)
C++
public:
bool SetMemConfig(
array<bool>^ i_bEnabled,
bool i_bRecord,
char i_byRecordMode,
char i_MemMode,
int i_iInterval
) sealed
J#
public bool SetMemConfig(
bool[] i_bEnabled,
bool i_bRecord,
byte i_byRecordMode,
byte i_MemMode,
int i_iInterval
)
JScript
public function SetMemConfig(
i_bEnabled : bool[],
i_bRecord : bool,
i_byRecordMode : Byte,
i_MemMode : Byte,
i_iInterval : int
) : bool

Parameters

i_bEnabled
The storage enabled status for all channels. The length of the array is 8.
i_bRecord
The standalone recording status. Value 0 means recording disabled; Value 1 means recording enabled.
i_byRecordMode
The recording mode. Value 0 means standard mode; Value 1 means event mode. Value 2 means mixed mode.
i_MemMode
The memory buffer storage mode. Value 0 means linear buffer; Value 1 means cycle buffer.
i_iInterval
The recording interval in seconds. The range is between 2~65535.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetMemOperation Method

AnalogInput.SetMemOperation Method
[image]

Support module: ADAM-4018M. Set memory operation.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMemOperation( _
ByVal i_bRecording As Boolean _
) As Boolean
C#
public bool SetMemOperation(
bool i_bRecording
)
C++
public:
bool SetMemOperation(
bool i_bRecording
) sealed
J#
public bool SetMemOperation(
bool i_bRecording
)
JScript
public function SetMemOperation(
i_bRecording : bool
) : bool

Parameters

i_bRecording
The recording operation status.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetRangeIntegration Method

AnalogInput.SetRangeIntegration Method
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000/TCP. Set module analog input range and integration time

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRangeIntegration( _
ByVal i_iSlot As Integer, _
ByVal i_byRange As Byte, _
ByVal i_byIntegration As Byte _
) As Boolean
C#
public bool SetRangeIntegration(
int i_iSlot,
byte i_byRange,
byte i_byIntegration
)
C++
public:
bool SetRangeIntegration(
int i_iSlot,
char i_byRange,
char i_byIntegration
) sealed
J#
public bool SetRangeIntegration(
int i_iSlot,
byte i_byRange,
byte i_byIntegration
)
JScript
public function SetRangeIntegration(
i_iSlot : int,
i_byRange : Byte,
i_byIntegration : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_byRange
The input range code
i_byIntegration
The integration code

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetRangeIntegrationDataFormat Method

AnalogInput.SetRangeIntegrationDataFormat Method
[image]

Support module: ADAM-5013, ADAM-5017, ADAM-5018 on ADAM-5000. Set module analog input range, integration time and data format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRangeIntegrationDataFormat( _
ByVal i_iSlot As Integer, _
ByVal i_byRange As Byte, _
ByVal i_byIntegration As Byte, _
ByVal i_byDataFormat As Byte _
) As Boolean
C#
public bool SetRangeIntegrationDataFormat(
int i_iSlot,
byte i_byRange,
byte i_byIntegration,
byte i_byDataFormat
)
C++
public:
bool SetRangeIntegrationDataFormat(
int i_iSlot,
char i_byRange,
char i_byIntegration,
char i_byDataFormat
) sealed
J#
public bool SetRangeIntegrationDataFormat(
int i_iSlot,
byte i_byRange,
byte i_byIntegration,
byte i_byDataFormat
)
JScript
public function SetRangeIntegrationDataFormat(
i_iSlot : int,
i_byRange : Byte,
i_byIntegration : Byte,
i_byDataFormat : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_byRange
The input range code
i_byIntegration
The integration code
i_byDataFormat
The data format code.

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetRanges Method

AnalogInput.SetRanges Method
[image]

Support module: APAX-5000. Set module analog input ranges

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRanges( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
ByVal i_usRange As UInt16() _
) As Boolean
C#
public bool SetRanges(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usRange
)
C++
public:
bool SetRanges(
int i_iSlot,
int i_iChannelTotal,
array<unsigned short>^ i_usRange
) sealed
J#
public bool SetRanges(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usRange
)
JScript
public function SetRanges(
i_iSlot : int,
i_iChannelTotal : int,
i_usRange : UInt16[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The total of the channel on the module.
i_usRange
The analog input ranges.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetSampleRate Method

AnalogInput.SetSampleRate Method
[image]

Support module: APAX-5000. Set module analog input sample rate

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSampleRate( _
ByVal i_iSlot As Integer, _
ByVal i_dwRate As UInt32 _
) As Boolean
C#
public bool SetSampleRate(
int i_iSlot,
uint i_dwRate
)
C++
public:
bool SetSampleRate(
int i_iSlot,
unsigned int i_dwRate
) sealed
J#
public bool SetSampleRate(
int i_iSlot,
uint i_dwRate
)
JScript
public function SetSampleRate(
i_iSlot : int,
i_dwRate : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_dwRate
The analog input sample rate. For APAX-5017, only 1 Hz or 10 Hz can be accepted. For APAX-5017H, only 100 Hz or 1000 Hz can be accepted.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetSpanCalibration Method

AnalogInput.SetSpanCalibration Method

Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Span calibration

Overload List

 | Name | Description
Public method | SetSpanCalibration | Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Span calibration
Public method | SetSpanCalibration (Int32) | Support module: ADAM-5000, ADAM-5000TCP, APAX-5000 (Ch0), APAX-5070(UDP:5222). Set analog input Span calibration

See Also

AnalogInput Class
Advantech.Adam Namespace


SetSpanCalibration Method ()

AnalogInput.SetSpanCalibration Method ()
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Span calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSpanCalibration() As Boolean
C#
public bool SetSpanCalibration()
C++
public:
bool SetSpanCalibration() sealed
J#
public bool SetSpanCalibration()
JScript
public function SetSpanCalibration() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetSpanCalibration Overload List


SetSpanCalibration Method (Int32)

AnalogInput.SetSpanCalibration Method (Int32)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP, APAX-5000 (Ch0), APAX-5070(UDP:5222). Set analog input Span calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSpanCalibration( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SetSpanCalibration(
int i_iSlot
)
C++
public:
bool SetSpanCalibration(
int i_iSlot
) sealed
J#
public bool SetSpanCalibration(
int i_iSlot
)
JScript
public function SetSpanCalibration(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7 (APAX:0~15)

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetSpanCalibration Overload List


SetThermoCalibration Method

AnalogInput.SetThermoCalibration Method
[image]

Support module: APAX-5000. Set Thermal Couple Calibration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetThermoCalibration( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SetThermoCalibration(
int i_iSlot
)
C++
public:
bool SetThermoCalibration(
int i_iSlot
) sealed
J#
public bool SetThermoCalibration(
int i_iSlot
)
JScript
public function SetThermoCalibration(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace


SetZeroCalibration Method

AnalogInput.SetZeroCalibration Method

Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Zero calibration

Overload List

 | Name | Description
Public method | SetZeroCalibration | Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Zero calibration
Public method | SetZeroCalibration (Int32) | Support module: ADAM-5000, ADAM-5000TCP, APAX-5000, APAX-5070(UDP:5222). Set analog input Zero calibration

See Also

AnalogInput Class
Advantech.Adam Namespace


SetZeroCalibration Method ()

AnalogInput.SetZeroCalibration Method ()
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100, ADAM-6000. Set analog input Zero calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetZeroCalibration() As Boolean
C#
public bool SetZeroCalibration()
C++
public:
bool SetZeroCalibration() sealed
J#
public bool SetZeroCalibration()
JScript
public function SetZeroCalibration() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetZeroCalibration Overload List


SetZeroCalibration Method (Int32)

AnalogInput.SetZeroCalibration Method (Int32)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP, APAX-5000, APAX-5070(UDP:5222). Set analog input Zero calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetZeroCalibration( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SetZeroCalibration(
int i_iSlot
)
C++
public:
bool SetZeroCalibration(
int i_iSlot
) sealed
J#
public bool SetZeroCalibration(
int i_iSlot
)
JScript
public function SetZeroCalibration(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7 (APAX:0~15)

Return Value

True if succeed, otherwise false.

See Also

AnalogInput Class
Advantech.Adam Namespace
AnalogInput.SetZeroCalibration Overload List


AnalogOutput Class

AnalogOutput Class
See Also Example Members
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class AnalogOutput
Inherits AdamBase
C#
public class AnalogOutput : AdamBase
C++
ref class AnalogOutput : AdamBase
J#
public class AnalogOutput extends AdamBase
JScript
public class AnalogOutput extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.AnalogOutput

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AnalogOutput Members
Advantech.Adam Namespace


AnalogOutput Members

AnalogOutput Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by AnalogOutput.

Public Constructors

Name | Description
AnalogOutput | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | AO_BufValues | APAX API. Set AO buffer values.
 | Get6124SlewRateName | Get the slew rate name of ADAM-6124
 | Get6124SlewRateTotal | Get the slew rate total of ADAM-6124
Public method | GetAOBurnStatus | Support module: ADAM-6124.
 | GetChannelTotal | Overloaded. Get the channel total
Public method | GetConfiguration | Overloaded. Support module: ADAM-6022, ADAM-6024. Get module analog output range
Public method | GetCurrentValue | Overloaded. Support module: ADAM-4021. Get module last analog output value by different data format.
 | GetDataFormatCode | Get the data format code.
 | GetDataFormatIndex | Get the data format index
 | GetDataFormatName | Overloaded. Get the data format name
 | GetDataFormatTotal | Get the data format total
Public method | GetEmergencyDI | Support module: ADAM-4024. Get emergency DI status that is used for the AO.
Public method | GetEmergencyFlag | Support module: ADAM-4024. Get module emergency flag.
Public method | GetEmergencyValue | Support module: ADAM-4024. Get analog output Emergency value
Public method | GetExcitationValue | Support module: ADAM-4016. Get module excitation output value.
 | GetFloatFormat | Overloaded. Get floating format
Public method | GetOutputRange | Overloaded. Support module: ADAM-4024. Get module analog Output range
Public method | GetRange | Support module: ADAM-4022T. Get module analog Output range
 | GetRangeCode | Overloaded. Get the range code
 | GetRangeCode2Byte | Overloaded. Get the range code
 | GetRangeHighLow | Overloaded. Get the range boundary
 | GetRangeIndex | Overloaded. Get the range code index
 | GetRangeName | Overloaded. Get the range name
 | GetRangeTotal | Overloaded. Get the range total
Public method | GetSafetyFunctionStatus | Support module: ADAM-6200 series. Get safety function status (enable or disable) value.
Public method | GetSafetyTrigTime | Support module: ADAM-6100 series. Get module fail safety values(FSV) trig time value.
Public method | GetSafetyValues | Support module: APAX-5000. Get specified channel safety values. The value returned is in raw data.
 | GetScaledValue | Overloaded. Get the scaled value
 | GetScaledValueWithResolution | Get the scaled value for unknown APAX module
Public method | GetSlewRate | Overloaded. Support module: ADAM-6200. Get module Slew Rate
 | GetSlewRateCode | Overloaded. Get the slew rate code.
 | GetSlewRateIndex | Overloaded. Get the slew rate code index
 | GetSlewRateName | Overloaded. Get the slew rate name
 | GetSlewRateTotal | Overloaded. Get the slew rate total
 | GetSpanCalibrationName | Overloaded. Get the span calibration apply string
Public method | GetSpanCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Get analog output Span calibration raw data
Public method | GetStartupValue | Overloaded. Support module: ADAM-5024. Get analog output startup value
Public method | GetStartupValues | Support module: APAX-5028. Get analog output startup values
 | GetUnitName | Overloaded. Get unit string
Public method | GetValue | Support module: ADAM-4022T. Get module analog output value.
Public method | GetValues | Support module: APAX-5000. Get specified channel values. The value returned is in raw data.
 | GetZeroCalibrationName | Overloaded. Get the zero calibration apply string
Public method | GetZeroCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Get analog output Zero calibration raw data
Public method | Set20mACalibration | Overloaded. Support module: ADAM-4021. Set analog output Span calibration
Public method | Set4mACalibration | Overloaded. Support module: ADAM-4021. Set analog output Zero calibration
Public method | SetCalibrationCounts | Overloaded. Support module: ADAM-6200. Set the counts to adjust output value.
Public method | SetCalibrationMode | Support module: APAX_5000. Set analog output calibration mode
Public method | SetCalibrationRawOutput | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Output analog uses raw data.
Public method | SetCjcCompensationValue | Support module: ADAM-6118 Set module CJC compensation value.
Public method | SetConfiguration | Overloaded. Support module: ADAM-6022, ADAM-6024. Set module analog output range
Public method | SetCurrentToStartup | Overloaded. Support module: ADAM-4021. Set the present output value as startup value
Public method | SetCurrentValue | Overloaded. Support module: ADAM-4021. Set the current output value by different data format.
Public method | SetCurrentValueWithResolution | Support module: APAX-5000, APAX-5070. Set specified channel value. The value is float data.
Public method | SetEmergencyFlag | Support module: ADAM-4024. Set emergency flag.
Public method | SetEmergencyValue | Support module: ADAM-4024. Set the emergency value
Public method | SetExcitationCalibrationCounts | Support module: ADAM-4016. Set the counts to adjust output value. Each count is about 1.0 mV.
Public method | SetExcitationSpanCalibration | Support module: ADAM-4016. Set analog output Span calibration
Public method | SetExcitationToStartup | Support module: ADAM-4016. Set the present output value as startup value
Public method | SetExcitationValue | Support module: ADAM-4016. Set the excitation output value
Public method | SetExcitationZeroCalibration | Support module: ADAM-4016. Set analog output Zero calibration
Public method | SetOutputRange | Overloaded. Support module: ADAM-4024. Set module analog Output range
Public method | SetRange | Support module: ADAM-4022T. Set module analog Output range
Public method | SetRanges | Support module: APAX-5000. Set module analog output ranges
Public method | SetSafetyFunctionStatus | Support module: ADAM-6200 series. Set safety function status (enable or disable) value.
Public method | SetSafetyTrigTime | Support module: ADAM-6100 series. Set module fail safety values(FSV) trig time value.
Public method | SetSafetyValues | Support module: APAX-5000. Set module module safety values.
Public method | SetSlewRate | Overloaded. Support module: ADAM-6200. Set module Slew Rate
Public method | SetSpanCalibration | Overloaded. Support module: ADAM-5024. Set analog output Span calibration
Public method | SetSpanCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Set analog output Span calibration raw data
Public method | SetStartupValue | Overloaded. Support module: ADAM-6022, ADAM-6024. Set the analog output startup value
Public method | SetStartupValues | Support module: APAX-5028. Set analog output startup values
Public method | SetValue | Support module: ADAM-4022T. Set the output value
Public method | SetZeroCalibration | Overloaded. Support module: ADAM-5024. Set analog output Zero calibration
Public method | SetZeroCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Set analog output Zero calibration raw data
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetAdam4021RangeCode | Get the ADAM-4021 range code.
 | GetAdam4021RangeIndex | Get the ADAM-4021 range code index
 | GetAdam4021RangeName | Get the ADAM-4021 range name.
 | GetAdam4022TRangeCode | Get the ADAM-4022T range code.
 | GetAdam4022TRangeIndex | Get the ADAM-4022T range code index
 | GetAdam4022TRangeName | Get the ADAM-4022T range name.
 | GetAdam4022TScaledValue |
 | GetAdam4024RangeCode | Get the ADAM-4024 range code.
 | GetAdam4024RangeIndex | Get the ADAM-4024 range code index
 | GetAdam4024RangeName | Get the ADAM-4024 range name.
 | GetAdam4024ScaledValue |
 | GetAdam5024RangeCode | Get the ADAM-5024 range code.
 | GetAdam5024RangeHighLow |
 | GetAdam5024RangeIndex | Get the ADAM-5024 range code index
 | GetAdam5024RangeName | Get the ADAM-5024 range name.
 | GetAdam5024ScaledValue |
 | GetAdam6000SlewRateCode | Get the slew rate code of ADAM-6000.
 | GetAdam6000SlewRateIndex | Get the slew rate code index of ADAM-6000
 | GetAdam6000SlewRateName | Get the slew rate name of ADAM-6000
 | GetAdam6022RangeCode | Get the ADAM-6022 range code.
 | GetAdam6022RangeIndex | Get the ADAM-6022 range code index
 | GetAdam6022RangeName | Get the ADAM-6022 range name.
 | GetAdam6022ScaledValue |
 | GetAdam6024RangeCode | Get the ADAM-6024 range code.
 | GetAdam6024RangeIndex | Get the ADAM-6024 range code index
 | GetAdam6024RangeName | Get the ADAM-6024 range name.
 | GetAdam6024ScaledValue |
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
 | GetSlewRateCode | Overloaded. Get the slew rate code.
 | GetSlewRateIndex | Overloaded. Get the slew rate code index
 | GetSlewRateName | Overloaded. Get the slew rate name
 | GetSlewRateTotal | Overloaded. Get the slew rate total
Top

Explicit Interface Implementations

Name | Description
AnalogOutput | Overloaded.
Top

See Also

AnalogOutput Class
Advantech.Adam Namespace


AnalogOutput Constructor

AnalogOutput Constructor

Overload List

 | Name | Description
Public method | AnalogOutput (AdamCom) | The AnalogOutput constructor.
Public method | AnalogOutput (AdamControl) | The AnalogOutput constructor.
Public method | AnalogOutput (AdamSocket) | The AnalogOutput constructor.

See Also

AnalogOutput Class
Advantech.Adam Namespace


AnalogOutput Constructor (AdamCom)

AnalogOutput Constructor (AdamCom)
See Also Example
[image]

The AnalogOutput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public AnalogOutput(
AdamCom i_com
)
C++
public:
AnalogOutput(
AdamCom i_com
) sealed
J#
public AnalogOutput(
AdamCom i_com
)
JScript
public function AnalogOutput(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput Constructor Overload List


AnalogOutput Constructor (AdamControl)

AnalogOutput Constructor (AdamControl)
See Also Example
[image]

The AnalogOutput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public AnalogOutput(
AdamControl i_control
)
C++
public:
AnalogOutput(
AdamControl i_control
) sealed
J#
public AnalogOutput(
AdamControl i_control
)
JScript
public function AnalogOutput(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput Constructor Overload List


AnalogOutput Constructor (AdamSocket)

AnalogOutput Constructor (AdamSocket)
See Also Example
[image]

The AnalogOutput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public AnalogOutput(
AdamSocket i_socket
)
C++
public:
AnalogOutput(
AdamSocket i_socket
) sealed
J#
public AnalogOutput(
AdamSocket i_socket
)
JScript
public function AnalogOutput(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput Constructor Overload List


Methods

AnalogOutput Methods
[image]

Public Methods

 | Name | Description
Public method | AO_BufValues | APAX API. Set AO buffer values.
 | Get6124SlewRateName | Get the slew rate name of ADAM-6124
 | Get6124SlewRateTotal | Get the slew rate total of ADAM-6124
Public method | GetAOBurnStatus | Support module: ADAM-6124.
 | GetChannelTotal | Overloaded. Get the channel total
Public method | GetConfiguration | Overloaded. Support module: ADAM-6022, ADAM-6024. Get module analog output range
Public method | GetCurrentValue | Overloaded. Support module: ADAM-4021. Get module last analog output value by different data format.
 | GetDataFormatCode | Get the data format code.
 | GetDataFormatIndex | Get the data format index
 | GetDataFormatName | Overloaded. Get the data format name
 | GetDataFormatTotal | Get the data format total
Public method | GetEmergencyDI | Support module: ADAM-4024. Get emergency DI status that is used for the AO.
Public method | GetEmergencyFlag | Support module: ADAM-4024. Get module emergency flag.
Public method | GetEmergencyValue | Support module: ADAM-4024. Get analog output Emergency value
Public method | GetExcitationValue | Support module: ADAM-4016. Get module excitation output value.
 | GetFloatFormat | Overloaded. Get floating format
Public method | GetOutputRange | Overloaded. Support module: ADAM-4024. Get module analog Output range
Public method | GetRange | Support module: ADAM-4022T. Get module analog Output range
 | GetRangeCode | Overloaded. Get the range code
 | GetRangeCode2Byte | Overloaded. Get the range code
 | GetRangeHighLow | Overloaded. Get the range boundary
 | GetRangeIndex | Overloaded. Get the range code index
 | GetRangeName | Overloaded. Get the range name
 | GetRangeTotal | Overloaded. Get the range total
Public method | GetSafetyFunctionStatus | Support module: ADAM-6200 series. Get safety function status (enable or disable) value.
Public method | GetSafetyTrigTime | Support module: ADAM-6100 series. Get module fail safety values(FSV) trig time value.
Public method | GetSafetyValues | Support module: APAX-5000. Get specified channel safety values. The value returned is in raw data.
 | GetScaledValue | Overloaded. Get the scaled value
 | GetScaledValueWithResolution | Get the scaled value for unknown APAX module
Public method | GetSlewRate | Overloaded. Support module: ADAM-6200. Get module Slew Rate
 | GetSlewRateCode | Overloaded. Get the slew rate code.
 | GetSlewRateIndex | Overloaded. Get the slew rate code index
 | GetSlewRateName | Overloaded. Get the slew rate name
 | GetSlewRateTotal | Overloaded. Get the slew rate total
 | GetSpanCalibrationName | Overloaded. Get the span calibration apply string
Public method | GetSpanCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Get analog output Span calibration raw data
Public method | GetStartupValue | Overloaded. Support module: ADAM-5024. Get analog output startup value
Public method | GetStartupValues | Support module: APAX-5028. Get analog output startup values
 | GetUnitName | Overloaded. Get unit string
Public method | GetValue | Support module: ADAM-4022T. Get module analog output value.
Public method | GetValues | Support module: APAX-5000. Get specified channel values. The value returned is in raw data.
 | GetZeroCalibrationName | Overloaded. Get the zero calibration apply string
Public method | GetZeroCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Get analog output Zero calibration raw data
Public method | Set20mACalibration | Overloaded. Support module: ADAM-4021. Set analog output Span calibration
Public method | Set4mACalibration | Overloaded. Support module: ADAM-4021. Set analog output Zero calibration
Public method | SetCalibrationCounts | Overloaded. Support module: ADAM-6200. Set the counts to adjust output value.
Public method | SetCalibrationMode | Support module: APAX_5000. Set analog output calibration mode
Public method | SetCalibrationRawOutput | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Output analog uses raw data.
Public method | SetCjcCompensationValue | Support module: ADAM-6118 Set module CJC compensation value.
Public method | SetConfiguration | Overloaded. Support module: ADAM-6022, ADAM-6024. Set module analog output range
Public method | SetCurrentToStartup | Overloaded. Support module: ADAM-4021. Set the present output value as startup value
Public method | SetCurrentValue | Overloaded. Support module: ADAM-4021. Set the current output value by different data format.
Public method | SetCurrentValueWithResolution | Support module: APAX-5000, APAX-5070. Set specified channel value. The value is float data.
Public method | SetEmergencyFlag | Support module: ADAM-4024. Set emergency flag.
Public method | SetEmergencyValue | Support module: ADAM-4024. Set the emergency value
Public method | SetExcitationCalibrationCounts | Support module: ADAM-4016. Set the counts to adjust output value. Each count is about 1.0 mV.
Public method | SetExcitationSpanCalibration | Support module: ADAM-4016. Set analog output Span calibration
Public method | SetExcitationToStartup | Support module: ADAM-4016. Set the present output value as startup value
Public method | SetExcitationValue | Support module: ADAM-4016. Set the excitation output value
Public method | SetExcitationZeroCalibration | Support module: ADAM-4016. Set analog output Zero calibration
Public method | SetOutputRange | Overloaded. Support module: ADAM-4024. Set module analog Output range
Public method | SetRange | Support module: ADAM-4022T. Set module analog Output range
Public method | SetRanges | Support module: APAX-5000. Set module analog output ranges
Public method | SetSafetyFunctionStatus | Support module: ADAM-6200 series. Set safety function status (enable or disable) value.
Public method | SetSafetyTrigTime | Support module: ADAM-6100 series. Set module fail safety values(FSV) trig time value.
Public method | SetSafetyValues | Support module: APAX-5000. Set module module safety values.
Public method | SetSlewRate | Overloaded. Support module: ADAM-6200. Set module Slew Rate
Public method | SetSpanCalibration | Overloaded. Support module: ADAM-5024. Set analog output Span calibration
Public method | SetSpanCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Set analog output Span calibration raw data
Public method | SetStartupValue | Overloaded. Support module: ADAM-6022, ADAM-6024. Set the analog output startup value
Public method | SetStartupValues | Support module: APAX-5028. Set analog output startup values
Public method | SetValue | Support module: ADAM-4022T. Set the output value
Public method | SetZeroCalibration | Overloaded. Support module: ADAM-5024. Set analog output Zero calibration
Public method | SetZeroCalibrationRaw | Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Set analog output Zero calibration raw data
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetAdam4021RangeCode | Get the ADAM-4021 range code.
 | GetAdam4021RangeIndex | Get the ADAM-4021 range code index
 | GetAdam4021RangeName | Get the ADAM-4021 range name.
 | GetAdam4022TRangeCode | Get the ADAM-4022T range code.
 | GetAdam4022TRangeIndex | Get the ADAM-4022T range code index
 | GetAdam4022TRangeName | Get the ADAM-4022T range name.
 | GetAdam4022TScaledValue |
 | GetAdam4024RangeCode | Get the ADAM-4024 range code.
 | GetAdam4024RangeIndex | Get the ADAM-4024 range code index
 | GetAdam4024RangeName | Get the ADAM-4024 range name.
 | GetAdam4024ScaledValue |
 | GetAdam5024RangeCode | Get the ADAM-5024 range code.
 | GetAdam5024RangeHighLow |
 | GetAdam5024RangeIndex | Get the ADAM-5024 range code index
 | GetAdam5024RangeName | Get the ADAM-5024 range name.
 | GetAdam5024ScaledValue |
 | GetAdam6000SlewRateCode | Get the slew rate code of ADAM-6000.
 | GetAdam6000SlewRateIndex | Get the slew rate code index of ADAM-6000
 | GetAdam6000SlewRateName | Get the slew rate name of ADAM-6000
 | GetAdam6022RangeCode | Get the ADAM-6022 range code.
 | GetAdam6022RangeIndex | Get the ADAM-6022 range code index
 | GetAdam6022RangeName | Get the ADAM-6022 range name.
 | GetAdam6022ScaledValue |
 | GetAdam6024RangeCode | Get the ADAM-6024 range code.
 | GetAdam6024RangeIndex | Get the ADAM-6024 range code index
 | GetAdam6024RangeName | Get the ADAM-6024 range name.
 | GetAdam6024ScaledValue |
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
 | GetSlewRateCode | Overloaded. Get the slew rate code.
 | GetSlewRateIndex | Overloaded. Get the slew rate code index
 | GetSlewRateName | Overloaded. Get the slew rate name
 | GetSlewRateTotal | Overloaded. Get the slew rate total
Top

See Also

AnalogOutput Class
Advantech.Adam Namespace


AO_BufValues Method

AnalogOutput.AO_BufValues Method
[image]

APAX API. Set AO buffer values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AO_BufValues( _
ByVal i_iSlot As Integer, _
ByVal i_uiMask As UInt32, _
ByVal i_usValues As UInt16() _
) As Boolean
C#
public bool AO_BufValues(
int i_iSlot,
uint i_uiMask,
ushort[] i_usValues
)
C++
public:
bool AO_BufValues(
int i_iSlot,
unsigned int i_uiMask,
array<unsigned short>^ i_usValues
) sealed
J#
public bool AO_BufValues(
int i_iSlot,
uint i_uiMask,
ushort[] i_usValues
)
JScript
public function AO_BufValues(
i_iSlot : int,
i_uiMask : UInt32,
i_usValues : UInt16[]
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_uiMask
Channel mask.
i_usValues
The AO values to set. The length of the array must match the total of the channel on the module.

Return Value

Return true if success; otherwise, return false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


Get6124SlewRateName Method

AnalogOutput.Get6124SlewRateName Method
[image]

Get the slew rate name of ADAM-6124

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get6124SlewRateName( _
ByVal i_bySlew As Byte _
) As String
C#
public static string Get6124SlewRateName(
byte i_bySlew
)
C++
public:
static String Get6124SlewRateName(
char i_bySlew
)
J#
public static string Get6124SlewRateName(
byte i_bySlew
)
JScript
public static function Get6124SlewRateName(
i_bySlew : Byte
) : String

Parameters

i_bySlew
Adam_SlewRate.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace


Get6124SlewRateTotal Method

AnalogOutput.Get6124SlewRateTotal Method
[image]

Get the slew rate total of ADAM-6124

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get6124SlewRateTotal() As Integer
C#
public static int Get6124SlewRateTotal()
C++
public:
static int Get6124SlewRateTotal()
J#
public static int Get6124SlewRateTotal()
JScript
public static function Get6124SlewRateTotal() : int

Return Value

Return slew rate total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4021RangeCode Method

AnalogOutput.GetAdam4021RangeCode Method
[image]

Get the ADAM-4021 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4021RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4021RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4021RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4021RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4021RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~2.

Return Value

The range code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4021RangeIndex Method

AnalogOutput.GetAdam4021RangeIndex Method
[image]

Get the ADAM-4021 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4021RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4021RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4021RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4021RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4021RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4021RangeName Method

AnalogOutput.GetAdam4021RangeName Method
[image]

Get the ADAM-4021 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4021RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4021RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4021RangeName(
char i_byRange
)
J#
protected static string GetAdam4021RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4021RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4022TRangeCode Method

AnalogOutput.GetAdam4022TRangeCode Method
[image]

Get the ADAM-4022T range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TRangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4022TRangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4022TRangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4022TRangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4022TRangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~2.

Return Value

The range code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4022TRangeIndex Method

AnalogOutput.GetAdam4022TRangeIndex Method
[image]

Get the ADAM-4022T range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TRangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4022TRangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4022TRangeIndex(
char i_byRange
)
J#
protected static int GetAdam4022TRangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4022TRangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4022TRangeName Method

AnalogOutput.GetAdam4022TRangeName Method
[image]

Get the ADAM-4022T range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TRangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4022TRangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4022TRangeName(
char i_byRange
)
J#
protected static string GetAdam4022TRangeName(
byte i_byRange
)
JScript
protected static function GetAdam4022TRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4022TScaledValue Method

AnalogOutput.GetAdam4022TScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4022TScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4022TScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4022TScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4022TScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4022TScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4024RangeCode Method

AnalogOutput.GetAdam4024RangeCode Method
[image]

Get the ADAM-4024 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4024RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam4024RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam4024RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam4024RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam4024RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~2.

Return Value

The range code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4024RangeIndex Method

AnalogOutput.GetAdam4024RangeIndex Method
[image]

Get the ADAM-4024 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4024RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam4024RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam4024RangeIndex(
char i_byRange
)
J#
protected static int GetAdam4024RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam4024RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4024RangeName Method

AnalogOutput.GetAdam4024RangeName Method
[image]

Get the ADAM-4024 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4024RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam4024RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam4024RangeName(
char i_byRange
)
J#
protected static string GetAdam4024RangeName(
byte i_byRange
)
JScript
protected static function GetAdam4024RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam4024ScaledValue Method

AnalogOutput.GetAdam4024ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam4024ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam4024ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam4024ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam4024ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam4024ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam5024RangeCode Method

AnalogOutput.GetAdam5024RangeCode Method
[image]

Get the ADAM-5024 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5024RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam5024RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam5024RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam5024RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam5024RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~9.

Return Value

The range code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam5024RangeHighLow Method

AnalogOutput.GetAdam5024RangeHighLow Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub GetAdam5024RangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef fHigh As Single, _
<OutAttribute> ByRef fLow As Single _
)
C#
protected static void GetAdam5024RangeHighLow(
byte i_byRange,
out float fHigh,
out float fLow
)
C++
protected:
static void GetAdam5024RangeHighLow(
char i_byRange,
[OutAttribute] float% fHigh,
[OutAttribute] float% fLow
)
J#
protected static void GetAdam5024RangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float fHigh,
/** @attribute OutAttribute() */ /** @ref */ float fLow
)
JScript
protected static function GetAdam5024RangeHighLow(
i_byRange : Byte,
OutAttribute fHigh : float,
OutAttribute fLow : float
)

Parameters

i_byRange
fHigh
fLow

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam5024RangeIndex Method

AnalogOutput.GetAdam5024RangeIndex Method
[image]

Get the ADAM-5024 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5024RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam5024RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam5024RangeIndex(
char i_byRange
)
J#
protected static int GetAdam5024RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam5024RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam5024RangeName Method

AnalogOutput.GetAdam5024RangeName Method
[image]

Get the ADAM-5024 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5024RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam5024RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam5024RangeName(
char i_byRange
)
J#
protected static string GetAdam5024RangeName(
byte i_byRange
)
JScript
protected static function GetAdam5024RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam5024ScaledValue Method

AnalogOutput.GetAdam5024ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5024ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam5024ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam5024ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam5024ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam5024ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6000SlewRateCode Method

AnalogOutput.GetAdam6000SlewRateCode Method
[image]

Get the slew rate code of ADAM-6000.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6000SlewRateCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6000SlewRateCode(
int i_iIndex
)
C++
protected:
static char GetAdam6000SlewRateCode(
int i_iIndex
)
J#
protected static byte GetAdam6000SlewRateCode(
int i_iIndex
)
JScript
protected static function GetAdam6000SlewRateCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The slew rate code index.

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6000SlewRateIndex Method

AnalogOutput.GetAdam6000SlewRateIndex Method
[image]

Get the slew rate code index of ADAM-6000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6000SlewRateIndex( _
ByVal i_bySlew As Byte _
) As Integer
C#
protected static int GetAdam6000SlewRateIndex(
byte i_bySlew
)
C++
protected:
static int GetAdam6000SlewRateIndex(
char i_bySlew
)
J#
protected static int GetAdam6000SlewRateIndex(
byte i_bySlew
)
JScript
protected static function GetAdam6000SlewRateIndex(
i_bySlew : Byte
) : int

Parameters

i_bySlew
The slew rate code.

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6000SlewRateName Method

AnalogOutput.GetAdam6000SlewRateName Method
[image]

Get the slew rate name of ADAM-6000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6000SlewRateName( _
ByVal i_bySlew As Byte _
) As String
C#
protected static string GetAdam6000SlewRateName(
byte i_bySlew
)
C++
protected:
static String GetAdam6000SlewRateName(
char i_bySlew
)
J#
protected static string GetAdam6000SlewRateName(
byte i_bySlew
)
JScript
protected static function GetAdam6000SlewRateName(
i_bySlew : Byte
) : String

Parameters

i_bySlew
Adam_SlewRate code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6022RangeCode Method

AnalogOutput.GetAdam6022RangeCode Method
[image]

Get the ADAM-6022 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6022RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam6022RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam6022RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam6022RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~9.

Return Value

The range code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6022RangeIndex Method

AnalogOutput.GetAdam6022RangeIndex Method
[image]

Get the ADAM-6022 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam6022RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam6022RangeIndex(
char i_byRange
)
J#
protected static int GetAdam6022RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam6022RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6022RangeName Method

AnalogOutput.GetAdam6022RangeName Method
[image]

Get the ADAM-6022 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam6022RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam6022RangeName(
char i_byRange
)
J#
protected static string GetAdam6022RangeName(
byte i_byRange
)
JScript
protected static function GetAdam6022RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6022ScaledValue Method

AnalogOutput.GetAdam6022ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6022ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam6022ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam6022ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam6022ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam6022ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6024RangeCode Method

AnalogOutput.GetAdam6024RangeCode Method
[image]

Get the ADAM-6024 range code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024RangeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetAdam6024RangeCode(
int i_iIndex
)
C++
protected:
static char GetAdam6024RangeCode(
int i_iIndex
)
J#
protected static byte GetAdam6024RangeCode(
int i_iIndex
)
JScript
protected static function GetAdam6024RangeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The range code index. The value is between 0~9.

Return Value

The range code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6024RangeIndex Method

AnalogOutput.GetAdam6024RangeIndex Method
[image]

Get the ADAM-6024 range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024RangeIndex( _
ByVal i_byRange As Byte _
) As Integer
C#
protected static int GetAdam6024RangeIndex(
byte i_byRange
)
C++
protected:
static int GetAdam6024RangeIndex(
char i_byRange
)
J#
protected static int GetAdam6024RangeIndex(
byte i_byRange
)
JScript
protected static function GetAdam6024RangeIndex(
i_byRange : Byte
) : int

Parameters

i_byRange
The range code

Return Value

The range index, base-0. If the range is not defined, then return -1.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6024RangeName Method

AnalogOutput.GetAdam6024RangeName Method
[image]

Get the ADAM-6024 range name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024RangeName( _
ByVal i_byRange As Byte _
) As String
C#
protected static string GetAdam6024RangeName(
byte i_byRange
)
C++
protected:
static String GetAdam6024RangeName(
char i_byRange
)
J#
protected static string GetAdam6024RangeName(
byte i_byRange
)
JScript
protected static function GetAdam6024RangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

The range name.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAdam6024ScaledValue Method

AnalogOutput.GetAdam6024ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6024ScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
protected static float GetAdam6024ScaledValue(
byte i_byRange,
int i_iValue
)
C++
protected:
static float GetAdam6024ScaledValue(
char i_byRange,
int i_iValue
)
J#
protected static float GetAdam6024ScaledValue(
byte i_byRange,
int i_iValue
)
JScript
protected static function GetAdam6024ScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
i_iValue

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetAOBurnStatus Method

AnalogOutput.GetAOBurnStatus Method
[image]

Support module: ADAM-6124.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAOBurnStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_iAOBurnStatus As Integer _
) As Boolean
C#
public bool GetAOBurnStatus(
int i_iSlot,
int i_iChannelTotal,
out int o_iAOBurnStatus
)
C++
public:
bool GetAOBurnStatus(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] int% o_iAOBurnStatus
) sealed
J#
public bool GetAOBurnStatus(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ int o_iAOBurnStatus
)
JScript
public function GetAOBurnStatus(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_iAOBurnStatus : int
) : bool

Parameters

i_iSlot
Slot index.
i_iChannelTotal
The total of the channel on the module.
o_iAOBurnStatus
The AO channel status.

Return Value

True if secceed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetChannelTotal Method

AnalogOutput.GetChannelTotal Method

Get the channel total

Overload List

Name | Description
GetChannelTotal (Adam4000Type) | Get the channel total
GetChannelTotal (Adam5000Type) | Get the channel total
GetChannelTotal (Adam6000Type) | Get the channel total

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetChannelTotal Method (Adam4000Type)

AnalogOutput.GetChannelTotal Method (Adam4000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetChannelTotal(
Adam4000Type adam4000Type
)
J#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetChannelTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetChannelTotal Overload List


GetChannelTotal Method (Adam5000Type)

AnalogOutput.GetChannelTotal Method (Adam5000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetChannelTotal(
Adam5000Type adam5000Type
)
J#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetChannelTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetChannelTotal Overload List


GetChannelTotal Method (Adam6000Type)

AnalogOutput.GetChannelTotal Method (Adam6000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelTotal(
Adam6000Type adam6000Type
)
J#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetChannelTotal Overload List


GetConfiguration Method

AnalogOutput.GetConfiguration Method

Support module: ADAM-6022, ADAM-6024. Get module analog output range

Overload List

 | Name | Description
Public method | GetConfiguration (Int32, Byte) | Support module: ADAM-6022, ADAM-6024. Get module analog output range
Public method | GetConfiguration (Int32, Int32, Byte) | Support module: ADAM-5024 on ADAM-5000/TCP. Get module analog output range
Public method | GetConfiguration (Int32, Int32, Byte, Byte) | Support module: ADAM-5024 on ADAM-5000. Get module analog output range

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetConfiguration Method (Int32, Byte)

AnalogOutput.GetConfiguration Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-6022, ADAM-6024. Get module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConfiguration( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool GetConfiguration(
int i_iChannel,
out byte o_byRange
)
C++
public:
bool GetConfiguration(
int i_iChannel,
[OutAttribute] char% o_byRange
) sealed
J#
public bool GetConfiguration(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function GetConfiguration(
i_iChannel : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
o_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetConfiguration Overload List


GetConfiguration Method (Int32, Int32, Byte)

AnalogOutput.GetConfiguration Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5024 on ADAM-5000/TCP. Get module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool GetConfiguration(
int i_iSlot,
int i_iChannel,
out byte o_byRange
)
C++
public:
bool GetConfiguration(
int i_iSlot,
int i_iChannel,
[OutAttribute] char% o_byRange
) sealed
J#
public bool GetConfiguration(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function GetConfiguration(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetConfiguration Overload List


GetConfiguration Method (Int32, Int32, Byte, Byte)

AnalogOutput.GetConfiguration Method (Int32, Int32, Byte, Byte)
See Also Example
[image]

Support module: ADAM-5024 on ADAM-5000. Get module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte, _
<OutAttribute> ByRef o_bySlewrate As Byte _
) As Boolean
C#
public bool GetConfiguration(
int i_iSlot,
int i_iChannel,
out byte o_byRange,
out byte o_bySlewrate
)
C++
public:
bool GetConfiguration(
int i_iSlot,
int i_iChannel,
[OutAttribute] char% o_byRange,
[OutAttribute] char% o_bySlewrate
) sealed
J#
public bool GetConfiguration(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange,
/** @attribute OutAttribute() */ /** @ref */ byte o_bySlewrate
)
JScript
public function GetConfiguration(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_byRange : Byte,
OutAttribute o_bySlewrate : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_byRange
The input range code
o_bySlewrate
The slew rate code.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetConfiguration Overload List


GetCurrentValue Method

AnalogOutput.GetCurrentValue Method

Support module: ADAM-4021. Get module last analog output value by different data format.

Overload List

 | Name | Description
Public method | GetCurrentValue (Byte, Single) | Support module: ADAM-4021. Get module last analog output value by different data format.
Public method | GetCurrentValue (Int32, Int32, Single) | Support module: ADAM-5024 on ADAM-5000. (Also support on ADAM-5550) Get module last analog output value
Public method | GetCurrentValue (Int32, Int32, UInt16) | Support module: APAX-5000. Get specified channel value. The value returned is in raw data.
Public method | GetCurrentValue (Int32, Single) | Support module: ADAM-4024. Get module last analog output value by different data format.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetCurrentValue Method (Byte, Single)

AnalogOutput.GetCurrentValue Method (Byte, Single)
See Also Example
[image]

Support module: ADAM-4021. Get module last analog output value by different data format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCurrentValue( _
ByVal i_byFormat As Byte, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetCurrentValue(
byte i_byFormat,
out float o_fValue
)
C++
public:
bool GetCurrentValue(
char i_byFormat,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetCurrentValue(
byte i_byFormat,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetCurrentValue(
i_byFormat : Byte,
OutAttribute o_fValue : float
) : bool

Parameters

i_byFormat
The data format.
o_fValue
The last output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetCurrentValue Overload List


GetCurrentValue Method (Int32, Int32, Single)

AnalogOutput.GetCurrentValue Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5024 on ADAM-5000. (Also support on ADAM-5550) Get module last analog output value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCurrentValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetCurrentValue(
int i_iSlot,
int i_iChannel,
out float o_fValue
)
C++
public:
bool GetCurrentValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetCurrentValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetCurrentValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_fValue : float
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_fValue
The last output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetCurrentValue Overload List


GetCurrentValue Method (Int32, Int32, UInt16)

AnalogOutput.GetCurrentValue Method (Int32, Int32, UInt16)
See Also Example
[image]

Support module: APAX-5000. Get specified channel value. The value returned is in raw data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCurrentValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_wValue As UInt16 _
) As Boolean
C#
public bool GetCurrentValue(
int i_iSlot,
int i_iChannel,
out ushort o_wValue
)
C++
public:
bool GetCurrentValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] unsigned short% o_wValue
) sealed
J#
public bool GetCurrentValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wValue
)
JScript
public function GetCurrentValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_wValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
The channel index. The value is between 0~31
o_wValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetCurrentValue Overload List


GetCurrentValue Method (Int32, Single)

AnalogOutput.GetCurrentValue Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-4024. Get module last analog output value by different data format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCurrentValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetCurrentValue(
int i_iChannel,
out float o_fValue
)
C++
public:
bool GetCurrentValue(
int i_iChannel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetCurrentValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetCurrentValue(
i_iChannel : int,
OutAttribute o_fValue : float
) : bool

Parameters

i_iChannel
The channel index.
o_fValue
The last output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetCurrentValue Overload List


GetDataFormatCode Method

AnalogOutput.GetDataFormatCode Method
[image]

Get the data format code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatCode( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetDataFormatCode(
Adam4000Type adam4000Type,
int i_iIndex
)
C++
public:
static char GetDataFormatCode(
Adam4000Type adam4000Type,
int i_iIndex
)
J#
public static byte GetDataFormatCode(
Adam4000Type adam4000Type,
int i_iIndex
)
JScript
public static function GetDataFormatCode(
adam4000Type : Adam4000Type,
i_iIndex : int
) : Byte

Parameters

adam4000Type
ADAM-4000 type
i_iIndex
The data format index. The value is between 0~2.

Return Value

The range code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetDataFormatIndex Method

AnalogOutput.GetDataFormatIndex Method
[image]

Get the data format index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatIndex( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byDataFormat As Byte _
) As Integer
C#
public static int GetDataFormatIndex(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
C++
public:
static int GetDataFormatIndex(
Adam4000Type adam4000Type,
char i_byDataFormat
)
J#
public static int GetDataFormatIndex(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatIndex(
adam4000Type : Adam4000Type,
i_byDataFormat : Byte
) : int

Parameters

adam4000Type
ADAM-4000 type
i_byDataFormat
The data format code.

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetDataFormatName Method

AnalogOutput.GetDataFormatName Method

Get the data format name

Overload List

Name | Description
GetDataFormatName (Adam4000Type, Byte) | Get the data format name
GetDataFormatName (Byte) | Get the data format name for ADAM unknown module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetDataFormatName Method (Adam4000Type, Byte)

AnalogOutput.GetDataFormatName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the data format name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byDataFormat As Byte _
) As String
C#
public static string GetDataFormatName(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
C++
public:
static String GetDataFormatName(
Adam4000Type adam4000Type,
char i_byDataFormat
)
J#
public static string GetDataFormatName(
Adam4000Type adam4000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatName(
adam4000Type : Adam4000Type,
i_byDataFormat : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byDataFormat
The data format code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetDataFormatName Overload List


GetDataFormatName Method (Byte)

AnalogOutput.GetDataFormatName Method (Byte)
See Also Example
[image]

Get the data format name for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatName( _
ByVal i_byDataFormat As Byte _
) As String
C#
public static string GetDataFormatName(
byte i_byDataFormat
)
C++
public:
static String GetDataFormatName(
char i_byDataFormat
)
J#
public static string GetDataFormatName(
byte i_byDataFormat
)
JScript
public static function GetDataFormatName(
i_byDataFormat : Byte
) : String

Parameters

i_byDataFormat
The data format code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetDataFormatName Overload List


GetDataFormatTotal Method

AnalogOutput.GetDataFormatTotal Method
[image]

Get the data format total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetDataFormatTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetDataFormatTotal(
Adam4000Type adam4000Type
)
J#
public static int GetDataFormatTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetDataFormatTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetEmergencyDI Method

AnalogOutput.GetEmergencyDI Method
[image]

Support module: ADAM-4024. Get emergency DI status that is used for the AO.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEmergencyDI( _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bDI As Boolean _
) As Boolean
C#
public bool GetEmergencyDI(
int i_iChannelTotal,
out bool o_bDI
)
C++
public:
bool GetEmergencyDI(
int i_iChannelTotal,
[OutAttribute] bool% o_bDI
) sealed
J#
public bool GetEmergencyDI(
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDI
)
JScript
public function GetEmergencyDI(
i_iChannelTotal : int,
OutAttribute o_bDI : bool
) : bool

Parameters

i_iChannelTotal
The total of the DI channel on the module.
o_bDI
The emergency DI status.

Return Value

Return true if success, otherwise return false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetEmergencyFlag Method

AnalogOutput.GetEmergencyFlag Method
[image]

Support module: ADAM-4024. Get module emergency flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEmergencyFlag( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bFlag As Boolean _
) As Boolean
C#
public bool GetEmergencyFlag(
int i_iChannel,
out bool o_bFlag
)
C++
public:
bool GetEmergencyFlag(
int i_iChannel,
[OutAttribute] bool% o_bFlag
) sealed
J#
public bool GetEmergencyFlag(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bFlag
)
JScript
public function GetEmergencyFlag(
i_iChannel : int,
OutAttribute o_bFlag : bool
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3.
o_bFlag
The emergency flag. If the flag is true, the AO will output the emergency value when corresponded DI is On.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetEmergencyValue Method

AnalogOutput.GetEmergencyValue Method
[image]

Support module: ADAM-4024. Get analog output Emergency value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEmergencyValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetEmergencyValue(
int i_iChannel,
out float o_fValue
)
C++
public:
bool GetEmergencyValue(
int i_iChannel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetEmergencyValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetEmergencyValue(
i_iChannel : int,
OutAttribute o_fValue : float
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3
o_fValue
The emergency output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetExcitationValue Method

AnalogOutput.GetExcitationValue Method
[image]

Support module: ADAM-4016. Get module excitation output value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExcitationValue( _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetExcitationValue(
out float o_fValue
)
C++
public:
bool GetExcitationValue(
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetExcitationValue(
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetExcitationValue(
OutAttribute o_fValue : float
) : bool

Parameters

o_fValue
The last output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetFloatFormat Method

AnalogOutput.GetFloatFormat Method

Get floating format

Overload List

Name | Description
GetFloatFormat (Adam4000Type, Byte) | Get floating format
GetFloatFormat (Adam5000Type, Byte) | Get floating format
GetFloatFormat (Adam6000Type, Byte) | Get floating format
GetFloatFormat (Adam6000Type, UInt16) | Get floating format
GetFloatFormat (Byte) | Get floating format for unknown ADAM module
GetFloatFormat (UInt16) | Get floating format for unknown APAX module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetFloatFormat Method (Adam4000Type, Byte)

AnalogOutput.GetFloatFormat Method (Adam4000Type, Byte)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetFloatFormat(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetFloatFormat(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetFloatFormat(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return the float format string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetFloatFormat Overload List


GetFloatFormat Method (Adam5000Type, Byte)

AnalogOutput.GetFloatFormat Method (Adam5000Type, Byte)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetFloatFormat(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetFloatFormat(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetFloatFormat(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return the float format string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetFloatFormat Overload List


GetFloatFormat Method (Adam6000Type, Byte)

AnalogOutput.GetFloatFormat Method (Adam6000Type, Byte)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetFloatFormat(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetFloatFormat(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return the float format string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetFloatFormat Overload List


GetFloatFormat Method (Adam6000Type, UInt16)

AnalogOutput.GetFloatFormat Method (Adam6000Type, UInt16)
See Also Example
[image]

Get floating format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetFloatFormat(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetFloatFormat(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetFloatFormat(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return the float format string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetFloatFormat Overload List


GetFloatFormat Method (Byte)

AnalogOutput.GetFloatFormat Method (Byte)
See Also Example
[image]

Get floating format for unknown ADAM module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal i_byRange As Byte _
) As String
C#
public static string GetFloatFormat(
byte i_byRange
)
C++
public:
static String GetFloatFormat(
char i_byRange
)
J#
public static string GetFloatFormat(
byte i_byRange
)
JScript
public static function GetFloatFormat(
i_byRange : Byte
) : String

Parameters

i_byRange
The rnage code

Return Value

Return the float format string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetFloatFormat Overload List


GetFloatFormat Method (UInt16)

AnalogOutput.GetFloatFormat Method (UInt16)
See Also Example
[image]

Get floating format for unknown APAX module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFloatFormat( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetFloatFormat(
ushort i_usRange
)
C++
public:
static String GetFloatFormat(
unsigned short i_usRange
)
J#
public static string GetFloatFormat(
ushort i_usRange
)
JScript
public static function GetFloatFormat(
i_usRange : UInt16
) : String

Parameters

i_usRange
The rnage code

Return Value

Return the float format string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetFloatFormat Overload List


GetOutputRange Method

AnalogOutput.GetOutputRange Method

Support module: ADAM-4024. Get module analog Output range

Overload List

 | Name | Description
Public method | GetOutputRange (Int32, Byte) | Support module: ADAM-4024. Get module analog Output range
Public method | GetOutputRange (Int32, Int32, Byte) | Support module: ADAM-5024 on ADAM-5550. Get module analog Output range
Public method | GetOutputRange (Int32, UInt16) | Support module: ADAM-6200. Get module analog output range

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetOutputRange Method (Int32, Byte)

AnalogOutput.GetOutputRange Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4024. Get module analog Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOutputRange( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool GetOutputRange(
int i_iChannel,
out byte o_byRange
)
C++
public:
bool GetOutputRange(
int i_iChannel,
[OutAttribute] char% o_byRange
) sealed
J#
public bool GetOutputRange(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function GetOutputRange(
i_iChannel : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3
o_byRange
The Output range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetOutputRange Overload List


GetOutputRange Method (Int32, Int32, Byte)

AnalogOutput.GetOutputRange Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5024 on ADAM-5550. Get module analog Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOutputRange( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool GetOutputRange(
int i_iSlot,
int i_iChannel,
out byte o_byRange
)
C++
public:
bool GetOutputRange(
int i_iSlot,
int i_iChannel,
[OutAttribute] char% o_byRange
) sealed
J#
public bool GetOutputRange(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function GetOutputRange(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannel
The channel index. The value is between 0~3
o_byRange
The Output range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetOutputRange Overload List


GetOutputRange Method (Int32, UInt16)

AnalogOutput.GetOutputRange Method (Int32, UInt16)
See Also Example
[image]

Support module: ADAM-6200. Get module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOutputRange( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_usRange As UInt16 _
) As Boolean
C#
public bool GetOutputRange(
int i_iChannel,
out ushort o_usRange
)
C++
public:
bool GetOutputRange(
int i_iChannel,
[OutAttribute] unsigned short% o_usRange
) sealed
J#
public bool GetOutputRange(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usRange
)
JScript
public function GetOutputRange(
i_iChannel : int,
OutAttribute o_usRange : UInt16
) : bool

Parameters

i_iChannel
The channel index.
o_usRange
The output range code. (Use ushort as the parameter)

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetOutputRange Overload List


GetRange Method

AnalogOutput.GetRange Method
[image]

Support module: ADAM-4022T. Get module analog Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRange( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byRange As Byte _
) As Boolean
C#
public bool GetRange(
int i_iChannel,
out byte o_byRange
)
C++
public:
bool GetRange(
int i_iChannel,
[OutAttribute] char% o_byRange
) sealed
J#
public bool GetRange(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public function GetRange(
i_iChannel : int,
OutAttribute o_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1.
o_byRange
The Output range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetRangeCode Method

AnalogOutput.GetRangeCode Method

Get the range code

Overload List

Name | Description
GetRangeCode (Adam4000Type, Int32) | Get the range code
GetRangeCode (Adam5000Type, Int32) | Get the range code
GetRangeCode (Adam6000Type, Int32) | Get the range code
GetRangeCode (String) | Get the range code by the range name for ADAM unknown module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetRangeCode Method (Adam4000Type, Int32)

AnalogOutput.GetRangeCode Method (Adam4000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetRangeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
C++
public:
static char GetRangeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
J#
public static byte GetRangeCode(
Adam4000Type adam4000Type,
int i_iIndex
)
JScript
public static function GetRangeCode(
adam4000Type : Adam4000Type,
i_iIndex : int
) : Byte

Parameters

adam4000Type
ADAM-4000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeCode Overload List


GetRangeCode Method (Adam5000Type, Int32)

AnalogOutput.GetRangeCode Method (Adam5000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetRangeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
C++
public:
static char GetRangeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
J#
public static byte GetRangeCode(
Adam5000Type adam5000Type,
int i_iIndex
)
JScript
public static function GetRangeCode(
adam5000Type : Adam5000Type,
i_iIndex : int
) : Byte

Parameters

adam5000Type
ADAM-5000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeCode Overload List


GetRangeCode Method (Adam6000Type, Int32)

AnalogOutput.GetRangeCode Method (Adam6000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetRangeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
C++
public:
static char GetRangeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
J#
public static byte GetRangeCode(
Adam6000Type adam6000Type,
int i_iIndex
)
JScript
public static function GetRangeCode(
adam6000Type : Adam6000Type,
i_iIndex : int
) : Byte

Parameters

adam6000Type
ADAM-6000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeCode Overload List


GetRangeCode Method (String)

AnalogOutput.GetRangeCode Method (String)
See Also Example
[image]

Get the range code by the range name for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode( _
ByVal i_strName As String _
) As Byte
C#
public static byte GetRangeCode(
string i_strName
)
C++
public:
static char GetRangeCode(
String i_strName
)
J#
public static byte GetRangeCode(
string i_strName
)
JScript
public static function GetRangeCode(
i_strName : String
) : Byte

Parameters

i_strName
The range name.

Return Value

Return range code if success, otherwise, return 0x00.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeCode Overload List


GetRangeCode2Byte Method

AnalogOutput.GetRangeCode2Byte Method

Get the range code

Overload List

Name | Description
GetRangeCode2Byte (Adam6000Type, Int32) | Get the range code
GetRangeCode2Byte (String) | Get the range code by the range name for APAX unknown module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetRangeCode2Byte Method (Adam6000Type, Int32)

AnalogOutput.GetRangeCode2Byte Method (Adam6000Type, Int32)
See Also Example
[image]

Get the range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode2Byte( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_iIndex As Integer _
) As UInt16
C#
public static ushort GetRangeCode2Byte(
Adam6000Type adam6000Type,
int i_iIndex
)
C++
public:
static unsigned short GetRangeCode2Byte(
Adam6000Type adam6000Type,
int i_iIndex
)
J#
public static ushort GetRangeCode2Byte(
Adam6000Type adam6000Type,
int i_iIndex
)
JScript
public static function GetRangeCode2Byte(
adam6000Type : Adam6000Type,
i_iIndex : int
) : UInt16

Parameters

adam6000Type
ADAM-6000 type
i_iIndex
The range code index

Return Value

Return range code if success, otherwise, return 65535

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeCode2Byte Overload List


GetRangeCode2Byte Method (String)

AnalogOutput.GetRangeCode2Byte Method (String)
See Also Example
[image]

Get the range code by the range name for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode2Byte( _
ByVal i_strName As String _
) As UInt16
C#
public static ushort GetRangeCode2Byte(
string i_strName
)
C++
public:
static unsigned short GetRangeCode2Byte(
String i_strName
)
J#
public static ushort GetRangeCode2Byte(
string i_strName
)
JScript
public static function GetRangeCode2Byte(
i_strName : String
) : UInt16

Parameters

i_strName
The range name.

Return Value

Return range code if success, otherwise, return 0x00.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeCode2Byte Overload List


GetRangeHighLow Method

AnalogOutput.GetRangeHighLow Method

Get the range boundary

Overload List

Name | Description
GetRangeHighLow (Adam5000Type, Byte, Single, Single) | Get the range boundary
GetRangeHighLow (Adam6000Type, UInt16, Single, Single) | Get the range boundary
GetRangeHighLow (Byte, Single, Single) | Get the range boundary for ADAM unknown module
GetRangeHighLow (UInt16, Single, Single) | Get the range boundary for APAX unknown module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetRangeHighLow Method (Adam5000Type, Byte, Single, Single)

AnalogOutput.GetRangeHighLow Method (Adam5000Type, Byte, Single, Single)
See Also Example
[image]

Get the range boundary

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
Adam5000Type adam5000Type,
byte i_byRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
Adam5000Type adam5000Type,
char i_byRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
Adam5000Type adam5000Type,
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
adam5000Type : Adam5000Type,
i_byRange : Byte,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeHighLow Overload List


GetRangeHighLow Method (Adam6000Type, UInt16, Single, Single)

AnalogOutput.GetRangeHighLow Method (Adam6000Type, UInt16, Single, Single)
See Also Example
[image]

Get the range boundary

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
Adam6000Type adam6000Type,
ushort i_usRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
Adam6000Type adam6000Type,
unsigned short i_usRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
Adam6000Type adam6000Type,
ushort i_usRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
adam6000Type : Adam6000Type,
i_usRange : UInt16,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeHighLow Overload List


GetRangeHighLow Method (Byte, Single, Single)

AnalogOutput.GetRangeHighLow Method (Byte, Single, Single)
See Also Example
[image]

Get the range boundary for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal i_byRange As Byte, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
byte i_byRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
char i_byRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
byte i_byRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
i_byRange : Byte,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

i_byRange
The range code.
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeHighLow Overload List


GetRangeHighLow Method (UInt16, Single, Single)

AnalogOutput.GetRangeHighLow Method (UInt16, Single, Single)
See Also Example
[image]

Get the range boundary for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetRangeHighLow( _
ByVal i_usRange As UInt16, _
<OutAttribute> ByRef o_fHigh As Single, _
<OutAttribute> ByRef o_fLow As Single _
)
C#
public static void GetRangeHighLow(
ushort i_usRange,
out float o_fHigh,
out float o_fLow
)
C++
public:
static void GetRangeHighLow(
unsigned short i_usRange,
[OutAttribute] float% o_fHigh,
[OutAttribute] float% o_fLow
)
J#
public static void GetRangeHighLow(
ushort i_usRange,
/** @attribute OutAttribute() */ /** @ref */ float o_fHigh,
/** @attribute OutAttribute() */ /** @ref */ float o_fLow
)
JScript
public static function GetRangeHighLow(
i_usRange : UInt16,
OutAttribute o_fHigh : float,
OutAttribute o_fLow : float
)

Parameters

i_usRange
The range code.
o_fHigh
The highest value of the range.
o_fLow
The lowest value of the range.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeHighLow Overload List


GetRangeIndex Method

AnalogOutput.GetRangeIndex Method

Get the range code index

Overload List

Name | Description
GetRangeIndex (Adam4000Type, Byte) | Get the range code index
GetRangeIndex (Adam5000Type, Byte) | Get the range code index
GetRangeIndex (Adam6000Type, Byte) | Get the range code index
GetRangeIndex (Adam6000Type, UInt16) | Get the range code index

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetRangeIndex Method (Adam4000Type, Byte)

AnalogOutput.GetRangeIndex Method (Adam4000Type, Byte)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As Integer
C#
public static int GetRangeIndex(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static int GetRangeIndex(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static int GetRangeIndex(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetRangeIndex(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : int

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code index. (Use byte as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeIndex Overload List


GetRangeIndex Method (Adam5000Type, Byte)

AnalogOutput.GetRangeIndex Method (Adam5000Type, Byte)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As Integer
C#
public static int GetRangeIndex(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static int GetRangeIndex(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static int GetRangeIndex(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetRangeIndex(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : int

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code index. (Use byte as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeIndex Overload List


GetRangeIndex Method (Adam6000Type, Byte)

AnalogOutput.GetRangeIndex Method (Adam6000Type, Byte)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As Integer
C#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static int GetRangeIndex(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetRangeIndex(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : int

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code index. (Use byte as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeIndex Overload List


GetRangeIndex Method (Adam6000Type, UInt16)

AnalogOutput.GetRangeIndex Method (Adam6000Type, UInt16)
See Also Example
[image]

Get the range code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeIndex( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As Integer
C#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static int GetRangeIndex(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static int GetRangeIndex(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetRangeIndex(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : int

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code index. (Use ushort as the parameter)

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeIndex Overload List


GetRangeName Method

AnalogOutput.GetRangeName Method

Get the range name

Overload List

Name | Description
GetRangeName (Adam4000Type, Byte) | Get the range name
GetRangeName (Adam5000Type, Byte) | Get the range name
GetRangeName (Adam6000Type, Byte) | Get the range name
GetRangeName (Adam6000Type, UInt16) | Get the range name
GetRangeName (Byte) | Get the range name for ADAM unknown module
GetRangeName (UInt16) | Get the range name for APAX unknown module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetRangeName Method (Adam4000Type, Byte)

AnalogOutput.GetRangeName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetRangeName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetRangeName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetRangeName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeName Overload List


GetRangeName Method (Adam5000Type, Byte)

AnalogOutput.GetRangeName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetRangeName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetRangeName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetRangeName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeName Overload List


GetRangeName Method (Adam6000Type, Byte)

AnalogOutput.GetRangeName Method (Adam6000Type, Byte)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetRangeName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetRangeName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetRangeName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeName Overload List


GetRangeName Method (Adam6000Type, UInt16)

AnalogOutput.GetRangeName Method (Adam6000Type, UInt16)
See Also Example
[image]

Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetRangeName(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetRangeName(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetRangeName(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetRangeName(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeName Overload List


GetRangeName Method (Byte)

AnalogOutput.GetRangeName Method (Byte)
See Also Example
[image]

Get the range name for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal i_byRange As Byte _
) As String
C#
public static string GetRangeName(
byte i_byRange
)
C++
public:
static String GetRangeName(
char i_byRange
)
J#
public static string GetRangeName(
byte i_byRange
)
JScript
public static function GetRangeName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeName Overload List


GetRangeName Method (UInt16)

AnalogOutput.GetRangeName Method (UInt16)
See Also Example
[image]

Get the range name for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeName( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetRangeName(
ushort i_usRange
)
C++
public:
static String GetRangeName(
unsigned short i_usRange
)
J#
public static string GetRangeName(
ushort i_usRange
)
JScript
public static function GetRangeName(
i_usRange : UInt16
) : String

Parameters

i_usRange
The range code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeName Overload List


GetRangeTotal Method

AnalogOutput.GetRangeTotal Method

Get the range total

Overload List

Name | Description
GetRangeTotal (Adam4000Type) | Get the range total
GetRangeTotal (Adam5000Type) | Get the range total
GetRangeTotal (Adam6000Type) | Get the range total. This old GetRangeTotal(Adam6000Type adam6000Type) function is now deprecated in favour of the GetRangeTotal(Adam6000Type adam6000Type, Adam6000_RangeFormat adam6000RangeFormat) function.
GetRangeTotal (Adam6000Type, Adam6000_RangeFormat) | Get the range total

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetRangeTotal Method (Adam4000Type)

AnalogOutput.GetRangeTotal Method (Adam4000Type)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetRangeTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetRangeTotal(
Adam4000Type adam4000Type
)
J#
public static int GetRangeTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetRangeTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeTotal Overload List


GetRangeTotal Method (Adam5000Type)

AnalogOutput.GetRangeTotal Method (Adam5000Type)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetRangeTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetRangeTotal(
Adam5000Type adam5000Type
)
J#
public static int GetRangeTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetRangeTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeTotal Overload List


GetRangeTotal Method (Adam6000Type)

AnalogOutput.GetRangeTotal Method (Adam6000Type)
See Also Example
[image]

Get the range total. This old GetRangeTotal(Adam6000Type adam6000Type) function is now deprecated in favour of the GetRangeTotal(Adam6000Type adam6000Type, Adam6000_RangeFormat adam6000RangeFormat) function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetRangeTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetRangeTotal(
Adam6000Type adam6000Type
)
J#
public static int GetRangeTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetRangeTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeTotal Overload List


GetRangeTotal Method (Adam6000Type, Adam6000_RangeFormat)

AnalogOutput.GetRangeTotal Method (Adam6000Type, Adam6000_RangeFormat)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeTotal( _
ByVal adam6000Type As Adam6000Type, _
ByVal adam6000RangeFormat As Adam6000_RangeFormat _
) As Integer
C#
public static int GetRangeTotal(
Adam6000Type adam6000Type,
Adam6000_RangeFormat adam6000RangeFormat
)
C++
public:
static int GetRangeTotal(
Adam6000Type adam6000Type,
Adam6000_RangeFormat adam6000RangeFormat
)
J#
public static int GetRangeTotal(
Adam6000Type adam6000Type,
Adam6000_RangeFormat adam6000RangeFormat
)
JScript
public static function GetRangeTotal(
adam6000Type : Adam6000Type,
adam6000RangeFormat : Adam6000_RangeFormat
) : int

Parameters

adam6000Type
ADAM-6000 type
adam6000RangeFormat
ADAM-6000 range format

Return Value

Return range total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetRangeTotal Overload List


GetSafetyFunctionStatus Method

AnalogOutput.GetSafetyFunctionStatus Method
[image]

Support module: ADAM-6200 series. Get safety function status (enable or disable) value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSafetyFunctionStatus( _
<OutAttribute> ByRef o_bValue As Boolean _
) As Boolean
C#
public bool GetSafetyFunctionStatus(
out bool o_bValue
)
C++
public:
bool GetSafetyFunctionStatus(
[OutAttribute] bool% o_bValue
) sealed
J#
public bool GetSafetyFunctionStatus(
/** @attribute OutAttribute() */ /** @ref */ bool o_bValue
)
JScript
public function GetSafetyFunctionStatus(
OutAttribute o_bValue : bool
) : bool

Parameters

o_bValue
The safety function status value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSafetyTrigTime Method

AnalogOutput.GetSafetyTrigTime Method
[image]

Support module: ADAM-6100 series. Get module fail safety values(FSV) trig time value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSafetyTrigTime( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_usValue As UInt16 _
) As Boolean
C#
public bool GetSafetyTrigTime(
int i_iSlot,
out ushort o_usValue
)
C++
public:
bool GetSafetyTrigTime(
int i_iSlot,
[OutAttribute] unsigned short% o_usValue
) sealed
J#
public bool GetSafetyTrigTime(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usValue
)
JScript
public function GetSafetyTrigTime(
i_iSlot : int,
OutAttribute o_usValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_usValue
The trig time value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSafetyValues Method

AnalogOutput.GetSafetyValues Method
[image]

Support module: APAX-5000. Get specified channel safety values. The value returned is in raw data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSafetyValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_wValue As UInt16 _
) As Boolean
C#
public bool GetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
out ushort o_wValue
)
C++
public:
bool GetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] unsigned short% o_wValue
) sealed
J#
public bool GetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wValue
)
JScript
public function GetSafetyValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_wValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The channel total. The value is between 1~31
o_wValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetScaledValue Method

AnalogOutput.GetScaledValue Method

Get the scaled value

Overload List

Name | Description
GetScaledValue (Adam4000Type, Byte, Int32) | Get the scaled value
GetScaledValue (Adam5000Type, Byte, Int32) | Get the scaled value
GetScaledValue (Adam6000Type, Byte, Int32) | Get the scaled value
GetScaledValue (Adam6000Type, UInt16, UInt16) | Get the scaled value
GetScaledValue (Byte, Int32) | Get the scaled value for unknown ADAM module
GetScaledValue (UInt16, UInt16) | Get the scaled value for unknown APAX module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetScaledValue Method (Adam4000Type, Byte, Int32)

AnalogOutput.GetScaledValue Method (Adam4000Type, Byte, Int32)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
Adam4000Type adam4000Type,
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
Adam4000Type adam4000Type,
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
Adam4000Type adam4000Type,
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
adam4000Type : Adam4000Type,
i_byRange : Byte,
i_iValue : int
) : float

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)
i_iValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetScaledValue Overload List


GetScaledValue Method (Adam5000Type, Byte, Int32)

AnalogOutput.GetScaledValue Method (Adam5000Type, Byte, Int32)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
Adam5000Type adam5000Type,
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
Adam5000Type adam5000Type,
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
Adam5000Type adam5000Type,
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
adam5000Type : Adam5000Type,
i_byRange : Byte,
i_iValue : int
) : float

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)
i_iValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetScaledValue Overload List


GetScaledValue Method (Adam6000Type, Byte, Int32)

AnalogOutput.GetScaledValue Method (Adam6000Type, Byte, Int32)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
Adam6000Type adam6000Type,
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
Adam6000Type adam6000Type,
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
Adam6000Type adam6000Type,
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
adam6000Type : Adam6000Type,
i_byRange : Byte,
i_iValue : int
) : float

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)
i_iValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetScaledValue Overload List


GetScaledValue Method (Adam6000Type, UInt16, UInt16)

AnalogOutput.GetScaledValue Method (Adam6000Type, UInt16, UInt16)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16, _
ByVal i_usValue As UInt16 _
) As Single
C#
public static float GetScaledValue(
Adam6000Type adam6000Type,
ushort i_usRange,
ushort i_usValue
)
C++
public:
static float GetScaledValue(
Adam6000Type adam6000Type,
unsigned short i_usRange,
unsigned short i_usValue
)
J#
public static float GetScaledValue(
Adam6000Type adam6000Type,
ushort i_usRange,
ushort i_usValue
)
JScript
public static function GetScaledValue(
adam6000Type : Adam6000Type,
i_usRange : UInt16,
i_usValue : UInt16
) : float

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)
i_usValue
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetScaledValue Overload List


GetScaledValue Method (Byte, Int32)

AnalogOutput.GetScaledValue Method (Byte, Int32)
See Also Example
[image]

Get the scaled value for unknown ADAM module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal i_byRange As Byte, _
ByVal i_iValue As Integer _
) As Single
C#
public static float GetScaledValue(
byte i_byRange,
int i_iValue
)
C++
public:
static float GetScaledValue(
char i_byRange,
int i_iValue
)
J#
public static float GetScaledValue(
byte i_byRange,
int i_iValue
)
JScript
public static function GetScaledValue(
i_byRange : Byte,
i_iValue : int
) : float

Parameters

i_byRange
The range code
i_iValue
The resolution of value is 16-bits.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetScaledValue Overload List


GetScaledValue Method (UInt16, UInt16)

AnalogOutput.GetScaledValue Method (UInt16, UInt16)
See Also Example
[image]

Get the scaled value for unknown APAX module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal i_usRange As UInt16, _
ByVal i_usValue As UInt16 _
) As Single
C#
public static float GetScaledValue(
ushort i_usRange,
ushort i_usValue
)
C++
public:
static float GetScaledValue(
unsigned short i_usRange,
unsigned short i_usValue
)
J#
public static float GetScaledValue(
ushort i_usRange,
ushort i_usValue
)
JScript
public static function GetScaledValue(
i_usRange : UInt16,
i_usValue : UInt16
) : float

Parameters

i_usRange
The range code
i_usValue
The resolution of value is 16-bits.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetScaledValue Overload List


GetScaledValueWithResolution Method

AnalogOutput.GetScaledValueWithResolution Method
[image]

Get the scaled value for unknown APAX module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValueWithResolution( _
ByVal i_usRange As UInt16, _
ByVal i_iValue As UInt16, _
ByVal i_byResolution As Byte _
) As Single
C#
public static float GetScaledValueWithResolution(
ushort i_usRange,
ushort i_iValue,
byte i_byResolution
)
C++
public:
static float GetScaledValueWithResolution(
unsigned short i_usRange,
unsigned short i_iValue,
char i_byResolution
)
J#
public static float GetScaledValueWithResolution(
ushort i_usRange,
ushort i_iValue,
byte i_byResolution
)
JScript
public static function GetScaledValueWithResolution(
i_usRange : UInt16,
i_iValue : UInt16,
i_byResolution : Byte
) : float

Parameters

i_usRange
The range code
i_iValue
The resolution of value is 16-bits.
i_byResolution
The resolution.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSlewRate Method

AnalogOutput.GetSlewRate Method

Support module: ADAM-6200. Get module Slew Rate

Overload List

 | Name | Description
Public method | GetSlewRate (Int32, Byte) | Support module: ADAM-6200. Get module Slew Rate
Public method | GetSlewRate (Int32, Int32, Byte, Byte, Byte) | Support module: ADAM-6124. Get module module safety values.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSlewRate Method (Int32, Byte)

AnalogOutput.GetSlewRate Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-6200. Get module Slew Rate

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSlewRate( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bySlewRate As Byte _
) As Boolean
C#
public bool GetSlewRate(
int i_iChannel,
out byte o_bySlewRate
)
C++
public:
bool GetSlewRate(
int i_iChannel,
[OutAttribute] char% o_bySlewRate
) sealed
J#
public bool GetSlewRate(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_bySlewRate
)
JScript
public function GetSlewRate(
i_iChannel : int,
OutAttribute o_bySlewRate : Byte
) : bool

Parameters

i_iChannel
The channel index.
o_bySlewRate
The slew rate

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRate Overload List


GetSlewRate Method (Int32, Int32, Byte, Byte, Byte)

AnalogOutput.GetSlewRate Method (Int32, Int32, Byte, Byte, Byte)
See Also Example
[image]

Support module: ADAM-6124. Get module module safety values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSlewRate( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef i_bySlewRateIdx As Byte, _
<OutAttribute> ByRef i_byStep As Byte, _
<OutAttribute> ByRef i_byClock As Byte _
) As Boolean
C#
public bool GetSlewRate(
int i_iSlot,
int i_iChannel,
out byte i_bySlewRateIdx,
out byte i_byStep,
out byte i_byClock
)
C++
public:
bool GetSlewRate(
int i_iSlot,
int i_iChannel,
[OutAttribute] char% i_bySlewRateIdx,
[OutAttribute] char% i_byStep,
[OutAttribute] char% i_byClock
) sealed
J#
public bool GetSlewRate(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte i_bySlewRateIdx,
/** @attribute OutAttribute() */ /** @ref */ byte i_byStep,
/** @attribute OutAttribute() */ /** @ref */ byte i_byClock
)
JScript
public function GetSlewRate(
i_iSlot : int,
i_iChannel : int,
OutAttribute i_bySlewRateIdx : Byte,
OutAttribute i_byStep : Byte,
OutAttribute i_byClock : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
Channel index to config.
i_bySlewRateIdx
The slew rate index. (0xFF for user defined)
i_byStep
The slew rate setting: step size for user defined.
i_byClock
The slew rate setting: update clock for user defined.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRate Overload List


GetSlewRateCode Method

AnalogOutput.GetSlewRateCode Method

Get the slew rate code.

Overload List

Name | Description
GetSlewRateCode (Adam4000Type, Int32) | Get the slew rate code.
GetSlewRateCode (Adam5000Type, Int32) | Get the slew rate code.
GetSlewRateCode (Adam6000Type, Int32) | Get the slew rate code.
GetSlewRateCode (Int32) | Get the slew rate code.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSlewRateCode Method (Adam4000Type, Int32)

AnalogOutput.GetSlewRateCode Method (Adam4000Type, Int32)
See Also Example
[image]

Get the slew rate code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateCode( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetSlewRateCode(
Adam4000Type adam4000Type,
int i_iIndex
)
C++
public:
static char GetSlewRateCode(
Adam4000Type adam4000Type,
int i_iIndex
)
J#
public static byte GetSlewRateCode(
Adam4000Type adam4000Type,
int i_iIndex
)
JScript
public static function GetSlewRateCode(
adam4000Type : Adam4000Type,
i_iIndex : int
) : Byte

Parameters

adam4000Type
ADAM-4000 type
i_iIndex
The slew rate code index.

Return Value

Return slew rate code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateCode Overload List


GetSlewRateCode Method (Adam5000Type, Int32)

AnalogOutput.GetSlewRateCode Method (Adam5000Type, Int32)
See Also Example
[image]

Get the slew rate code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateCode( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetSlewRateCode(
Adam5000Type adam5000Type,
int i_iIndex
)
C++
public:
static char GetSlewRateCode(
Adam5000Type adam5000Type,
int i_iIndex
)
J#
public static byte GetSlewRateCode(
Adam5000Type adam5000Type,
int i_iIndex
)
JScript
public static function GetSlewRateCode(
adam5000Type : Adam5000Type,
i_iIndex : int
) : Byte

Parameters

adam5000Type
ADAM-5000 type
i_iIndex
The slew rate code index.

Return Value

Return slew rate code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateCode Overload List


GetSlewRateCode Method (Adam6000Type, Int32)

AnalogOutput.GetSlewRateCode Method (Adam6000Type, Int32)
See Also Example
[image]

Get the slew rate code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateCode( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetSlewRateCode(
Adam6000Type adam6000Type,
int i_iIndex
)
C++
public:
static char GetSlewRateCode(
Adam6000Type adam6000Type,
int i_iIndex
)
J#
public static byte GetSlewRateCode(
Adam6000Type adam6000Type,
int i_iIndex
)
JScript
public static function GetSlewRateCode(
adam6000Type : Adam6000Type,
i_iIndex : int
) : Byte

Parameters

adam6000Type
ADAM-6000 type
i_iIndex
The slew rate code index.

Return Value

Return slew rate code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateCode Overload List


GetSlewRateCode Method (Int32)

AnalogOutput.GetSlewRateCode Method (Int32)
See Also Example
[image]

Get the slew rate code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetSlewRateCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetSlewRateCode(
int i_iIndex
)
C++
protected:
static char GetSlewRateCode(
int i_iIndex
)
J#
protected static byte GetSlewRateCode(
int i_iIndex
)
JScript
protected static function GetSlewRateCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The slew rate code index.

Return Value

Return range code if success, otherwise, return 255

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateCode Overload List


GetSlewRateIndex Method

AnalogOutput.GetSlewRateIndex Method

Get the slew rate code index

Overload List

Name | Description
GetSlewRateIndex (Adam4000Type, Byte) | Get the slew rate code index
GetSlewRateIndex (Adam5000Type, Byte) | Get the slew rate code index
GetSlewRateIndex (Adam6000Type, Byte) | Get the slew rate code index
GetSlewRateIndex (Byte) | Get the slew rate code index

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSlewRateIndex Method (Adam4000Type, Byte)

AnalogOutput.GetSlewRateIndex Method (Adam4000Type, Byte)
See Also Example
[image]

Get the slew rate code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateIndex( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_bySlew As Byte _
) As Integer
C#
public static int GetSlewRateIndex(
Adam4000Type adam4000Type,
byte i_bySlew
)
C++
public:
static int GetSlewRateIndex(
Adam4000Type adam4000Type,
char i_bySlew
)
J#
public static int GetSlewRateIndex(
Adam4000Type adam4000Type,
byte i_bySlew
)
JScript
public static function GetSlewRateIndex(
adam4000Type : Adam4000Type,
i_bySlew : Byte
) : int

Parameters

adam4000Type
ADAM-4000 type
i_bySlew
The slew rate code index.

Return Value

Return slew rate index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateIndex Overload List


GetSlewRateIndex Method (Adam5000Type, Byte)

AnalogOutput.GetSlewRateIndex Method (Adam5000Type, Byte)
See Also Example
[image]

Get the slew rate code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateIndex( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_bySlew As Byte _
) As Integer
C#
public static int GetSlewRateIndex(
Adam5000Type adam5000Type,
byte i_bySlew
)
C++
public:
static int GetSlewRateIndex(
Adam5000Type adam5000Type,
char i_bySlew
)
J#
public static int GetSlewRateIndex(
Adam5000Type adam5000Type,
byte i_bySlew
)
JScript
public static function GetSlewRateIndex(
adam5000Type : Adam5000Type,
i_bySlew : Byte
) : int

Parameters

adam5000Type
ADAM-5000 type
i_bySlew
The slew rate code index.

Return Value

Return slew rate index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateIndex Overload List


GetSlewRateIndex Method (Adam6000Type, Byte)

AnalogOutput.GetSlewRateIndex Method (Adam6000Type, Byte)
See Also Example
[image]

Get the slew rate code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateIndex( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_bySlew As Byte _
) As Integer
C#
public static int GetSlewRateIndex(
Adam6000Type adam6000Type,
byte i_bySlew
)
C++
public:
static int GetSlewRateIndex(
Adam6000Type adam6000Type,
char i_bySlew
)
J#
public static int GetSlewRateIndex(
Adam6000Type adam6000Type,
byte i_bySlew
)
JScript
public static function GetSlewRateIndex(
adam6000Type : Adam6000Type,
i_bySlew : Byte
) : int

Parameters

adam6000Type
ADAM-6000 type
i_bySlew
The slew rate code index.

Return Value

Return slew rate index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateIndex Overload List


GetSlewRateIndex Method (Byte)

AnalogOutput.GetSlewRateIndex Method (Byte)
See Also Example
[image]

Get the slew rate code index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetSlewRateIndex( _
ByVal i_bySlew As Byte _
) As Integer
C#
protected static int GetSlewRateIndex(
byte i_bySlew
)
C++
protected:
static int GetSlewRateIndex(
char i_bySlew
)
J#
protected static int GetSlewRateIndex(
byte i_bySlew
)
JScript
protected static function GetSlewRateIndex(
i_bySlew : Byte
) : int

Parameters

i_bySlew
The slew rate code.

Return Value

Return range code index if success, otherwise, return -1

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateIndex Overload List


GetSlewRateName Method

AnalogOutput.GetSlewRateName Method

Get the slew rate name

Overload List

Name | Description
GetSlewRateName (Adam4000Type, Byte) | Get the slew rate name
GetSlewRateName (Adam5000Type, Byte) | Get the slew rate name
GetSlewRateName (Adam6000Type, Byte) | Get the slew rate name
GetSlewRateName (Byte) | Get the slew rate name

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSlewRateName Method (Adam4000Type, Byte)

AnalogOutput.GetSlewRateName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the slew rate name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_bySlew As Byte _
) As String
C#
public static string GetSlewRateName(
Adam4000Type adam4000Type,
byte i_bySlew
)
C++
public:
static String GetSlewRateName(
Adam4000Type adam4000Type,
char i_bySlew
)
J#
public static string GetSlewRateName(
Adam4000Type adam4000Type,
byte i_bySlew
)
JScript
public static function GetSlewRateName(
adam4000Type : Adam4000Type,
i_bySlew : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_bySlew
Adam_SlewRate.

Return Value

Return slew rate name if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateName Overload List


GetSlewRateName Method (Adam5000Type, Byte)

AnalogOutput.GetSlewRateName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the slew rate name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_bySlew As Byte _
) As String
C#
public static string GetSlewRateName(
Adam5000Type adam5000Type,
byte i_bySlew
)
C++
public:
static String GetSlewRateName(
Adam5000Type adam5000Type,
char i_bySlew
)
J#
public static string GetSlewRateName(
Adam5000Type adam5000Type,
byte i_bySlew
)
JScript
public static function GetSlewRateName(
adam5000Type : Adam5000Type,
i_bySlew : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_bySlew
Adam_SlewRate.

Return Value

Return slew rate name if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateName Overload List


GetSlewRateName Method (Adam6000Type, Byte)

AnalogOutput.GetSlewRateName Method (Adam6000Type, Byte)
See Also Example
[image]

Get the slew rate name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_bySlew As Byte _
) As String
C#
public static string GetSlewRateName(
Adam6000Type adam6000Type,
byte i_bySlew
)
C++
public:
static String GetSlewRateName(
Adam6000Type adam6000Type,
char i_bySlew
)
J#
public static string GetSlewRateName(
Adam6000Type adam6000Type,
byte i_bySlew
)
JScript
public static function GetSlewRateName(
adam6000Type : Adam6000Type,
i_bySlew : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_bySlew
Adam_SlewRate.

Return Value

Return slew rate name if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateName Overload List


GetSlewRateName Method (Byte)

AnalogOutput.GetSlewRateName Method (Byte)
See Also Example
[image]

Get the slew rate name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetSlewRateName( _
ByVal i_bySlew As Byte _
) As String
C#
protected static string GetSlewRateName(
byte i_bySlew
)
C++
protected:
static String GetSlewRateName(
char i_bySlew
)
J#
protected static string GetSlewRateName(
byte i_bySlew
)
JScript
protected static function GetSlewRateName(
i_bySlew : Byte
) : String

Parameters

i_bySlew
Adam_SlewRate code.

Return Value

Return range code name if success, otherwise, return empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateName Overload List


GetSlewRateTotal Method

AnalogOutput.GetSlewRateTotal Method

Get the slew rate total

Overload List

Name | Description
GetSlewRateTotal | Get the slew rate total
GetSlewRateTotal (Adam4000Type) | Get the slew rate total
GetSlewRateTotal (Adam5000Type) | Get the slew rate total
GetSlewRateTotal (Adam6000Type) | Get the slew rate total

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSlewRateTotal Method ()

AnalogOutput.GetSlewRateTotal Method ()
See Also Example
[image]

Get the slew rate total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetSlewRateTotal() As Integer
C#
protected static int GetSlewRateTotal()
C++
protected:
static int GetSlewRateTotal()
J#
protected static int GetSlewRateTotal()
JScript
protected static function GetSlewRateTotal() : int

Return Value

Return slew rate total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateTotal Overload List


GetSlewRateTotal Method (Adam4000Type)

AnalogOutput.GetSlewRateTotal Method (Adam4000Type)
See Also Example
[image]

Get the slew rate total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetSlewRateTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetSlewRateTotal(
Adam4000Type adam4000Type
)
J#
public static int GetSlewRateTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetSlewRateTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return slew rate total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateTotal Overload List


GetSlewRateTotal Method (Adam5000Type)

AnalogOutput.GetSlewRateTotal Method (Adam5000Type)
See Also Example
[image]

Get the slew rate total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetSlewRateTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetSlewRateTotal(
Adam5000Type adam5000Type
)
J#
public static int GetSlewRateTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetSlewRateTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return slew rate total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateTotal Overload List


GetSlewRateTotal Method (Adam6000Type)

AnalogOutput.GetSlewRateTotal Method (Adam6000Type)
See Also Example
[image]

Get the slew rate total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSlewRateTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetSlewRateTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetSlewRateTotal(
Adam6000Type adam6000Type
)
J#
public static int GetSlewRateTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetSlewRateTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return slew rate total if success, otherwise, return 0.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSlewRateTotal Overload List


GetSpanCalibrationName Method

AnalogOutput.GetSpanCalibrationName Method

Get the span calibration apply string

Overload List

Name | Description
GetSpanCalibrationName (Adam4000Type, Byte) | Get the span calibration apply string
GetSpanCalibrationName (Adam5000Type, Byte) | Get the span calibration apply string
GetSpanCalibrationName (Adam6000Type, Byte) | Get the span calibration apply string
GetSpanCalibrationName (Adam6000Type, UInt16) | Get the span calibration apply string

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetSpanCalibrationName Method (Adam4000Type, Byte)

AnalogOutput.GetSpanCalibrationName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetSpanCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetSpanCalibrationName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetSpanCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetSpanCalibrationName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (Adam5000Type, Byte)

AnalogOutput.GetSpanCalibrationName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetSpanCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetSpanCalibrationName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetSpanCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetSpanCalibrationName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (Adam6000Type, Byte)

AnalogOutput.GetSpanCalibrationName Method (Adam6000Type, Byte)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetSpanCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetSpanCalibrationName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetSpanCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetSpanCalibrationName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSpanCalibrationName Overload List


GetSpanCalibrationName Method (Adam6000Type, UInt16)

AnalogOutput.GetSpanCalibrationName Method (Adam6000Type, UInt16)
See Also Example
[image]

Get the span calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSpanCalibrationName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetSpanCalibrationName(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetSpanCalibrationName(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetSpanCalibrationName(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetSpanCalibrationName(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
Adam-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetSpanCalibrationName Overload List


GetSpanCalibrationRaw Method

AnalogOutput.GetSpanCalibrationRaw Method
[image]

Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Get analog output Span calibration raw data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSpanCalibrationRaw( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iRawData As Integer _
) As Boolean
C#
public bool GetSpanCalibrationRaw(
int i_iChannel,
out int o_iRawData
)
C++
public:
bool GetSpanCalibrationRaw(
int i_iChannel,
[OutAttribute] int% o_iRawData
) sealed
J#
public bool GetSpanCalibrationRaw(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iRawData
)
JScript
public function GetSpanCalibrationRaw(
i_iChannel : int,
OutAttribute o_iRawData : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
o_iRawData
The raw analog output data, range is from 0~4095

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetStartupValue Method

AnalogOutput.GetStartupValue Method

Support module: ADAM-5024. Get analog output startup value

Overload List

 | Name | Description
Public method | GetStartupValue (Int32, Int32, Single) | Support module: ADAM-5024. Get analog output startup value
Public method | GetStartupValue (Int32, Int32) | Support module: ADAM-6022, ADAM-6024. Get analog output startup value
Public method | GetStartupValue (Int32, Single) | Support module: ADAM-4024. Get analog output startup value

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetStartupValue Method (Int32, Int32, Single)

AnalogOutput.GetStartupValue Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5024. Get analog output startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStartupValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetStartupValue(
int i_iSlot,
int i_iChannel,
out float o_fValue
)
C++
public:
bool GetStartupValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetStartupValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetStartupValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_fValue : float
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_fValue
The startup output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetStartupValue Overload List


GetStartupValue Method (Int32, Int32)

AnalogOutput.GetStartupValue Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-6022, ADAM-6024. Get analog output startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStartupValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iValue As Integer _
) As Boolean
C#
public bool GetStartupValue(
int i_iChannel,
out int o_iValue
)
C++
public:
bool GetStartupValue(
int i_iChannel,
[OutAttribute] int% o_iValue
) sealed
J#
public bool GetStartupValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iValue
)
JScript
public function GetStartupValue(
i_iChannel : int,
OutAttribute o_iValue : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
o_iValue
The startup output value, ranged from 0x000(0) to 0xFFF(4095)

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetStartupValue Overload List


GetStartupValue Method (Int32, Single)

AnalogOutput.GetStartupValue Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-4024. Get analog output startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStartupValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetStartupValue(
int i_iChannel,
out float o_fValue
)
C++
public:
bool GetStartupValue(
int i_iChannel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetStartupValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetStartupValue(
i_iChannel : int,
OutAttribute o_fValue : float
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3
o_fValue
The startup output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetStartupValue Overload List


GetStartupValues Method

AnalogOutput.GetStartupValues Method
[image]

Support module: APAX-5028. Get analog output startup values

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStartupValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_usValues As UInt16 _
) As Boolean
C#
public bool GetStartupValues(
int i_iSlot,
int i_iChannelTotal,
out ushort o_usValues
)
C++
public:
bool GetStartupValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] unsigned short% o_usValues
) sealed
J#
public bool GetStartupValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usValues
)
JScript
public function GetStartupValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_usValues : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The total channel number. The maximum value is 32.
o_usValues
The startup output values.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetUnitName Method

AnalogOutput.GetUnitName Method

Get unit string

Overload List

Name | Description
GetUnitName (Adam4000Type, Byte) | Get unit string
GetUnitName (Adam5000Type, Byte) | Get unit string
GetUnitName (Adam6000Type, Byte) | Get unit string
GetUnitName (Adam6000Type, UInt16) | Get unit string
GetUnitName (Byte) | Get unit string for ADAM unknown module
GetUnitName (UInt16) | Get unit string for APAX unknown module

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetUnitName Method (Adam4000Type, Byte)

AnalogOutput.GetUnitName Method (Adam4000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetUnitName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetUnitName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetUnitName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetUnitName Overload List


GetUnitName Method (Adam5000Type, Byte)

AnalogOutput.GetUnitName Method (Adam5000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetUnitName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetUnitName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetUnitName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetUnitName Overload List


GetUnitName Method (Adam6000Type, Byte)

AnalogOutput.GetUnitName Method (Adam6000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetUnitName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetUnitName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetUnitName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetUnitName Overload List


GetUnitName Method (Adam6000Type, UInt16)

AnalogOutput.GetUnitName Method (Adam6000Type, UInt16)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetUnitName(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetUnitName(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetUnitName(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetUnitName(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
ADAM-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetUnitName Overload List


GetUnitName Method (Byte)

AnalogOutput.GetUnitName Method (Byte)
See Also Example
[image]

Get unit string for ADAM unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal i_byRange As Byte _
) As String
C#
public static string GetUnitName(
byte i_byRange
)
C++
public:
static String GetUnitName(
char i_byRange
)
J#
public static string GetUnitName(
byte i_byRange
)
JScript
public static function GetUnitName(
i_byRange : Byte
) : String

Parameters

i_byRange
The range code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetUnitName Overload List


GetUnitName Method (UInt16)

AnalogOutput.GetUnitName Method (UInt16)
See Also Example
[image]

Get unit string for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetUnitName(
ushort i_usRange
)
C++
public:
static String GetUnitName(
unsigned short i_usRange
)
J#
public static string GetUnitName(
ushort i_usRange
)
JScript
public static function GetUnitName(
i_usRange : UInt16
) : String

Parameters

i_usRange
The range code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetUnitName Overload List


GetValue Method

AnalogOutput.GetValue Method
[image]

Support module: ADAM-4022T. Get module analog output value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetValue(
int i_iChannel,
out float o_fValue
)
C++
public:
bool GetValue(
int i_iChannel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetValue(
i_iChannel : int,
OutAttribute o_fValue : float
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1.
o_fValue
The last output value

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetValues Method

AnalogOutput.GetValues Method
[image]

Support module: APAX-5000. Get specified channel values. The value returned is in raw data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_wValue As UInt16 _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
out ushort o_wValue
)
C++
public:
bool GetValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] unsigned short% o_wValue
) sealed
J#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wValue
)
JScript
public function GetValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_wValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The channel total. The value is between 1~31
o_wValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetZeroCalibrationName Method

AnalogOutput.GetZeroCalibrationName Method

Get the zero calibration apply string

Overload List

Name | Description
GetZeroCalibrationName (Adam4000Type, Byte) | Get the zero calibration apply string
GetZeroCalibrationName (Adam5000Type, Byte) | Get the zero calibration apply string
GetZeroCalibrationName (Adam6000Type, Byte) | Get the zero calibration apply string
GetZeroCalibrationName (Adam6000Type, UInt16) | Get the zero calibration apply string

See Also

AnalogOutput Class
Advantech.Adam Namespace


GetZeroCalibrationName Method (Adam4000Type, Byte)

AnalogOutput.GetZeroCalibrationName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetZeroCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
C++
public:
static String GetZeroCalibrationName(
Adam4000Type adam4000Type,
char i_byRange
)
J#
public static string GetZeroCalibrationName(
Adam4000Type adam4000Type,
byte i_byRange
)
JScript
public static function GetZeroCalibrationName(
adam4000Type : Adam4000Type,
i_byRange : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Adam5000Type, Byte)

AnalogOutput.GetZeroCalibrationName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetZeroCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
C++
public:
static String GetZeroCalibrationName(
Adam5000Type adam5000Type,
char i_byRange
)
J#
public static string GetZeroCalibrationName(
Adam5000Type adam5000Type,
byte i_byRange
)
JScript
public static function GetZeroCalibrationName(
adam5000Type : Adam5000Type,
i_byRange : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Adam6000Type, Byte)

AnalogOutput.GetZeroCalibrationName Method (Adam6000Type, Byte)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byRange As Byte _
) As String
C#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
C++
public:
static String GetZeroCalibrationName(
Adam6000Type adam6000Type,
char i_byRange
)
J#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
byte i_byRange
)
JScript
public static function GetZeroCalibrationName(
adam6000Type : Adam6000Type,
i_byRange : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byRange
The range code. (Use byte as the parameter)

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetZeroCalibrationName Overload List


GetZeroCalibrationName Method (Adam6000Type, UInt16)

AnalogOutput.GetZeroCalibrationName Method (Adam6000Type, UInt16)
See Also Example
[image]

Get the zero calibration apply string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetZeroCalibrationName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
ushort i_usRange
)
C++
public:
static String GetZeroCalibrationName(
Adam6000Type adam6000Type,
unsigned short i_usRange
)
J#
public static string GetZeroCalibrationName(
Adam6000Type adam6000Type,
ushort i_usRange
)
JScript
public static function GetZeroCalibrationName(
adam6000Type : Adam6000Type,
i_usRange : UInt16
) : String

Parameters

adam6000Type
Adam-6000 type
i_usRange
The range code. (Use ushort as the parameter)

Return Value

Return calibration string if success, otherwise, return an empty string.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.GetZeroCalibrationName Overload List


GetZeroCalibrationRaw Method

AnalogOutput.GetZeroCalibrationRaw Method
[image]

Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Get analog output Zero calibration raw data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetZeroCalibrationRaw( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_iRawData As Integer _
) As Boolean
C#
public bool GetZeroCalibrationRaw(
int i_iChannel,
out int o_iRawData
)
C++
public:
bool GetZeroCalibrationRaw(
int i_iChannel,
[OutAttribute] int% o_iRawData
) sealed
J#
public bool GetZeroCalibrationRaw(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ int o_iRawData
)
JScript
public function GetZeroCalibrationRaw(
i_iChannel : int,
OutAttribute o_iRawData : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
o_iRawData
The raw analog output data, range is from 0~4095

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


Set20mACalibration Method

AnalogOutput.Set20mACalibration Method

Support module: ADAM-4021. Set analog output Span calibration

Overload List

 | Name | Description
Public method | Set20mACalibration | Support module: ADAM-4021. Set analog output Span calibration
Public method | Set20mACalibration (Int32) | Support module: ADAM-4024. Set analog output 20 mA calibration

See Also

AnalogOutput Class
Advantech.Adam Namespace


Set20mACalibration Method ()

AnalogOutput.Set20mACalibration Method ()
See Also Example
[image]

Support module: ADAM-4021. Set analog output Span calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Set20mACalibration() As Boolean
C#
public bool Set20mACalibration()
C++
public:
bool Set20mACalibration() sealed
J#
public bool Set20mACalibration()
JScript
public function Set20mACalibration() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.Set20mACalibration Overload List


Set20mACalibration Method (Int32)

AnalogOutput.Set20mACalibration Method (Int32)
See Also Example
[image]

Support module: ADAM-4024. Set analog output 20 mA calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Set20mACalibration( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool Set20mACalibration(
int i_iChannel
)
C++
public:
bool Set20mACalibration(
int i_iChannel
) sealed
J#
public bool Set20mACalibration(
int i_iChannel
)
JScript
public function Set20mACalibration(
i_iChannel : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.Set20mACalibration Overload List


Set4mACalibration Method

AnalogOutput.Set4mACalibration Method

Support module: ADAM-4021. Set analog output Zero calibration

Overload List

 | Name | Description
Public method | Set4mACalibration | Support module: ADAM-4021. Set analog output Zero calibration
Public method | Set4mACalibration (Int32) | Support module: ADAM-4024. Set analog output 4 mA calibration

See Also

AnalogOutput Class
Advantech.Adam Namespace


Set4mACalibration Method ()

AnalogOutput.Set4mACalibration Method ()
See Also Example
[image]

Support module: ADAM-4021. Set analog output Zero calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Set4mACalibration() As Boolean
C#
public bool Set4mACalibration()
C++
public:
bool Set4mACalibration() sealed
J#
public bool Set4mACalibration()
JScript
public function Set4mACalibration() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.Set4mACalibration Overload List


Set4mACalibration Method (Int32)

AnalogOutput.Set4mACalibration Method (Int32)
See Also Example
[image]

Support module: ADAM-4024. Set analog output 4 mA calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Set4mACalibration( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool Set4mACalibration(
int i_iChannel
)
C++
public:
bool Set4mACalibration(
int i_iChannel
) sealed
J#
public bool Set4mACalibration(
int i_iChannel
)
JScript
public function Set4mACalibration(
i_iChannel : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.Set4mACalibration Overload List


SetCalibrationCounts Method

AnalogOutput.SetCalibrationCounts Method

Support module: ADAM-6200. Set the counts to adjust output value.

Overload List

 | Name | Description
Public method | SetCalibrationCounts (Byte, Int32, UInt16) | Support module: ADAM-6200. Set the counts to adjust output value.
Public method | SetCalibrationCounts (Int32) | Support module: ADAM-4021. Set the counts to adjust output value. Each count is about 1.5uA.
Public method | SetCalibrationCounts (Int32, Int32) | Support module: ADAM-4024. Set the counts to adjust output value.
Public method | SetCalibrationCounts (Int32, Int32, Int32) | Support module: ADAM-5024. Set the counts to adjust output value. Each count is about 1.5uA.
Public method | SetCalibrationCounts (Int32, Int32, UInt16) | Support module: APAX_5000. Set AO calibration count. Use Calibration steps: 1. SetCalibrationMode() 2. SetCalibrationCounts() 3. SetZeroCalibration() or SetSpanCalibration()

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetCalibrationCounts Method (Byte, Int32, UInt16)

AnalogOutput.SetCalibrationCounts Method (Byte, Int32, UInt16)
See Also Example
[image]

Support module: ADAM-6200. Set the counts to adjust output value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationCounts( _
ByVal i_byType As Byte, _
ByVal i_iChannel As Integer, _
ByVal i_usCount As UInt16 _
) As Boolean
C#
public bool SetCalibrationCounts(
byte i_byType,
int i_iChannel,
ushort i_usCount
)
C++
public:
bool SetCalibrationCounts(
char i_byType,
int i_iChannel,
unsigned short i_usCount
) sealed
J#
public bool SetCalibrationCounts(
byte i_byType,
int i_iChannel,
ushort i_usCount
)
JScript
public function SetCalibrationCounts(
i_byType : Byte,
i_iChannel : int,
i_usCount : UInt16
) : bool

Parameters

i_byType
0 : span, 1 : Zero.
i_iChannel
The channel index.
i_usCount
The counts to set.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCalibrationCounts Overload List


SetCalibrationCounts Method (Int32)

AnalogOutput.SetCalibrationCounts Method (Int32)
See Also Example
[image]

Support module: ADAM-4021. Set the counts to adjust output value. Each count is about 1.5uA.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationCounts( _
ByVal i_iCount As Integer _
) As Boolean
C#
public bool SetCalibrationCounts(
int i_iCount
)
C++
public:
bool SetCalibrationCounts(
int i_iCount
) sealed
J#
public bool SetCalibrationCounts(
int i_iCount
)
JScript
public function SetCalibrationCounts(
i_iCount : int
) : bool

Parameters

i_iCount
The counts to set. The range is from -95~95.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCalibrationCounts Overload List


SetCalibrationCounts Method (Int32, Int32)

AnalogOutput.SetCalibrationCounts Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-4024. Set the counts to adjust output value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationCounts( _
ByVal i_iChannel As Integer, _
ByVal i_iCount As Integer _
) As Boolean
C#
public bool SetCalibrationCounts(
int i_iChannel,
int i_iCount
)
C++
public:
bool SetCalibrationCounts(
int i_iChannel,
int i_iCount
) sealed
J#
public bool SetCalibrationCounts(
int i_iChannel,
int i_iCount
)
JScript
public function SetCalibrationCounts(
i_iChannel : int,
i_iCount : int
) : bool

Parameters

i_iChannel
The channel index.
i_iCount
The counts to set. The range is from -127~127.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCalibrationCounts Overload List


SetCalibrationCounts Method (Int32, Int32, Int32)

AnalogOutput.SetCalibrationCounts Method (Int32, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5024. Set the counts to adjust output value. Each count is about 1.5uA.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationCounts( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iCount As Integer _
) As Boolean
C#
public bool SetCalibrationCounts(
int i_iSlot,
int i_iChannel,
int i_iCount
)
C++
public:
bool SetCalibrationCounts(
int i_iSlot,
int i_iChannel,
int i_iCount
) sealed
J#
public bool SetCalibrationCounts(
int i_iSlot,
int i_iChannel,
int i_iCount
)
JScript
public function SetCalibrationCounts(
i_iSlot : int,
i_iChannel : int,
i_iCount : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_iCount
The counts to set. The range is from -95~95.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCalibrationCounts Overload List


SetCalibrationCounts Method (Int32, Int32, UInt16)

AnalogOutput.SetCalibrationCounts Method (Int32, Int32, UInt16)
See Also Example
[image]

Support module: APAX_5000. Set AO calibration count. Use Calibration steps: 1. SetCalibrationMode() 2. SetCalibrationCounts() 3. SetZeroCalibration() or SetSpanCalibration()

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationCounts( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal uiCount As UInt16 _
) As Boolean
C#
public bool SetCalibrationCounts(
int i_iSlot,
int i_iChannel,
ushort uiCount
)
C++
public:
bool SetCalibrationCounts(
int i_iSlot,
int i_iChannel,
unsigned short uiCount
) sealed
J#
public bool SetCalibrationCounts(
int i_iSlot,
int i_iChannel,
ushort uiCount
)
JScript
public function SetCalibrationCounts(
i_iSlot : int,
i_iChannel : int,
uiCount : UInt16
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannel
The channel index.
uiCount
AO calibration count value.

Return Value

True if secceed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCalibrationCounts Overload List


SetCalibrationMode Method

AnalogOutput.SetCalibrationMode Method
[image]

Support module: APAX_5000. Set analog output calibration mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationMode( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SetCalibrationMode(
int i_iSlot
)
C++
public:
bool SetCalibrationMode(
int i_iSlot
) sealed
J#
public bool SetCalibrationMode(
int i_iSlot
)
JScript
public function SetCalibrationMode(
i_iSlot : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetCalibrationRawOutput Method

AnalogOutput.SetCalibrationRawOutput Method
[image]

Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Output analog uses raw data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCalibrationRawOutput( _
ByVal i_iChannel As Integer, _
ByVal i_iRawData As Integer _
) As Boolean
C#
public bool SetCalibrationRawOutput(
int i_iChannel,
int i_iRawData
)
C++
public:
bool SetCalibrationRawOutput(
int i_iChannel,
int i_iRawData
) sealed
J#
public bool SetCalibrationRawOutput(
int i_iChannel,
int i_iRawData
)
JScript
public function SetCalibrationRawOutput(
i_iChannel : int,
i_iRawData : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
i_iRawData
The raw analog output data, range is from 0~4095

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetCjcCompensationValue Method

AnalogOutput.SetCjcCompensationValue Method
[image]

Support module: ADAM-6118 Set module CJC compensation value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCjcCompensationValue( _
ByVal i_iSlot As Integer, _
ByRef i_bValue As Byte _
) As Boolean
C#
public bool SetCjcCompensationValue(
int i_iSlot,
ref byte i_bValue
)
C++
public:
bool SetCjcCompensationValue(
int i_iSlot,
char% i_bValue
) sealed
J#
public bool SetCjcCompensationValue(
int i_iSlot,
byte i_bValue
)
JScript
public function SetCjcCompensationValue(
i_iSlot : int,
i_bValue : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_bValue
The offset value.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetConfiguration Method

AnalogOutput.SetConfiguration Method

Support module: ADAM-6022, ADAM-6024. Set module analog output range

Overload List

 | Name | Description
Public method | SetConfiguration (Int32, Byte) | Support module: ADAM-6022, ADAM-6024. Set module analog output range
Public method | SetConfiguration (Int32, Int32, Byte) | Support module: ADAM-5024 on ADAM-5000/TCP. Set module analog output range
Public method | SetConfiguration (Int32, Int32, Byte, Byte) | Support module: ADAM-5024 on ADAM-5000. Set module analog output range

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetConfiguration Method (Int32, Byte)

AnalogOutput.SetConfiguration Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-6022, ADAM-6024. Set module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetConfiguration( _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool SetConfiguration(
int i_iChannel,
byte i_byRange
)
C++
public:
bool SetConfiguration(
int i_iChannel,
char i_byRange
) sealed
J#
public bool SetConfiguration(
int i_iChannel,
byte i_byRange
)
JScript
public function SetConfiguration(
i_iChannel : int,
i_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
i_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetConfiguration Overload List


SetConfiguration Method (Int32, Int32, Byte)

AnalogOutput.SetConfiguration Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5024 on ADAM-5000/TCP. Set module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool SetConfiguration(
int i_iSlot,
int i_iChannel,
byte i_byRange
)
C++
public:
bool SetConfiguration(
int i_iSlot,
int i_iChannel,
char i_byRange
) sealed
J#
public bool SetConfiguration(
int i_iSlot,
int i_iChannel,
byte i_byRange
)
JScript
public function SetConfiguration(
i_iSlot : int,
i_iChannel : int,
i_byRange : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_byRange
The input range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetConfiguration Overload List


SetConfiguration Method (Int32, Int32, Byte, Byte)

AnalogOutput.SetConfiguration Method (Int32, Int32, Byte, Byte)
See Also Example
[image]

Support module: ADAM-5024 on ADAM-5000. Set module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte, _
ByVal i_bySlew As Byte _
) As Boolean
C#
public bool SetConfiguration(
int i_iSlot,
int i_iChannel,
byte i_byRange,
byte i_bySlew
)
C++
public:
bool SetConfiguration(
int i_iSlot,
int i_iChannel,
char i_byRange,
char i_bySlew
) sealed
J#
public bool SetConfiguration(
int i_iSlot,
int i_iChannel,
byte i_byRange,
byte i_bySlew
)
JScript
public function SetConfiguration(
i_iSlot : int,
i_iChannel : int,
i_byRange : Byte,
i_bySlew : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_byRange
The input range code
i_bySlew
The slew rate code.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetConfiguration Overload List


SetCurrentToStartup Method

AnalogOutput.SetCurrentToStartup Method

Support module: ADAM-4021. Set the present output value as startup value

Overload List

 | Name | Description
Public method | SetCurrentToStartup | Support module: ADAM-4021. Set the present output value as startup value
Public method | SetCurrentToStartup (Int32, Int32) | Support module: ADAM-5024. Set the current output value as startup value

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetCurrentToStartup Method ()

AnalogOutput.SetCurrentToStartup Method ()
See Also Example
[image]

Support module: ADAM-4021. Set the present output value as startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentToStartup() As Boolean
C#
public bool SetCurrentToStartup()
C++
public:
bool SetCurrentToStartup() sealed
J#
public bool SetCurrentToStartup()
JScript
public function SetCurrentToStartup() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCurrentToStartup Overload List


SetCurrentToStartup Method (Int32, Int32)

AnalogOutput.SetCurrentToStartup Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-5024. Set the current output value as startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentToStartup( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetCurrentToStartup(
int i_iSlot,
int i_iChannel
)
C++
public:
bool SetCurrentToStartup(
int i_iSlot,
int i_iChannel
) sealed
J#
public bool SetCurrentToStartup(
int i_iSlot,
int i_iChannel
)
JScript
public function SetCurrentToStartup(
i_iSlot : int,
i_iChannel : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCurrentToStartup Overload List


SetCurrentValue Method

AnalogOutput.SetCurrentValue Method

Support module: ADAM-4021. Set the current output value by different data format.

Overload List

 | Name | Description
Public method | SetCurrentValue (Byte, Single) | Support module: ADAM-4021. Set the current output value by different data format.
Public method | SetCurrentValue (Int32, Int32, Single) | Support module: ADAM-5024. (Also support on ADAM-5550) Set the current output value
Public method | SetCurrentValue (Int32, Int32, UInt16) | Support module: APAX-5000, APAX-5070. Set specified channel value. The value is raw data.
Public method | SetCurrentValue (Int32, Int32, UInt16, Single) | Support module: APAX-5000, APAX-5070. Set specified channel value. The value is float data.
Public method | SetCurrentValue (Int32, Single) | Support module: ADAM-4024. Set the current output value

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetCurrentValue Method (Byte, Single)

AnalogOutput.SetCurrentValue Method (Byte, Single)
See Also Example
[image]

Support module: ADAM-4021. Set the current output value by different data format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentValue( _
ByVal i_byFormat As Byte, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetCurrentValue(
byte i_byFormat,
float i_fValue
)
C++
public:
bool SetCurrentValue(
char i_byFormat,
float i_fValue
) sealed
J#
public bool SetCurrentValue(
byte i_byFormat,
float i_fValue
)
JScript
public function SetCurrentValue(
i_byFormat : Byte,
i_fValue : float
) : bool

Parameters

i_byFormat
The data format.
i_fValue
The value to output

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCurrentValue Overload List


SetCurrentValue Method (Int32, Int32, Single)

AnalogOutput.SetCurrentValue Method (Int32, Int32, Single)
See Also Example
[image]

Support module: ADAM-5024. (Also support on ADAM-5550) Set the current output value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
float i_fValue
)
C++
public:
bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
float i_fValue
) sealed
J#
public bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
float i_fValue
)
JScript
public function SetCurrentValue(
i_iSlot : int,
i_iChannel : int,
i_fValue : float
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_fValue
The value to output

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCurrentValue Overload List


SetCurrentValue Method (Int32, Int32, UInt16)

AnalogOutput.SetCurrentValue Method (Int32, Int32, UInt16)
See Also Example
[image]

Support module: APAX-5000, APAX-5070. Set specified channel value. The value is raw data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_wValue As UInt16 _
) As Boolean
C#
public bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
ushort i_wValue
)
C++
public:
bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
unsigned short i_wValue
) sealed
J#
public bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
ushort i_wValue
)
JScript
public function SetCurrentValue(
i_iSlot : int,
i_iChannel : int,
i_wValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
The channel index. The value is between 0~31
i_wValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCurrentValue Overload List


SetCurrentValue Method (Int32, Int32, UInt16, Single)

AnalogOutput.SetCurrentValue Method (Int32, Int32, UInt16, Single)
See Also Example
[image]

Support module: APAX-5000, APAX-5070. Set specified channel value. The value is float data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_wRange As UInt16, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
ushort i_wRange,
float i_fValue
)
C++
public:
bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
unsigned short i_wRange,
float i_fValue
) sealed
J#
public bool SetCurrentValue(
int i_iSlot,
int i_iChannel,
ushort i_wRange,
float i_fValue
)
JScript
public function SetCurrentValue(
i_iSlot : int,
i_iChannel : int,
i_wRange : UInt16,
i_fValue : float
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
The channel index. The value is between 0~31
i_wRange
The channel range code.
i_fValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCurrentValue Overload List


SetCurrentValue Method (Int32, Single)

AnalogOutput.SetCurrentValue Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-4024. Set the current output value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentValue( _
ByVal i_iChannel As Integer, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetCurrentValue(
int i_iChannel,
float i_fValue
)
C++
public:
bool SetCurrentValue(
int i_iChannel,
float i_fValue
) sealed
J#
public bool SetCurrentValue(
int i_iChannel,
float i_fValue
)
JScript
public function SetCurrentValue(
i_iChannel : int,
i_fValue : float
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~7
i_fValue
The value to output

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetCurrentValue Overload List


SetCurrentValueWithResolution Method

AnalogOutput.SetCurrentValueWithResolution Method
[image]

Support module: APAX-5000, APAX-5070. Set specified channel value. The value is float data.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCurrentValueWithResolution( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_wRange As UInt16, _
ByVal i_fValue As Single, _
ByVal i_byResolution As Byte _
) As Boolean
C#
public bool SetCurrentValueWithResolution(
int i_iSlot,
int i_iChannel,
ushort i_wRange,
float i_fValue,
byte i_byResolution
)
C++
public:
bool SetCurrentValueWithResolution(
int i_iSlot,
int i_iChannel,
unsigned short i_wRange,
float i_fValue,
char i_byResolution
) sealed
J#
public bool SetCurrentValueWithResolution(
int i_iSlot,
int i_iChannel,
ushort i_wRange,
float i_fValue,
byte i_byResolution
)
JScript
public function SetCurrentValueWithResolution(
i_iSlot : int,
i_iChannel : int,
i_wRange : UInt16,
i_fValue : float,
i_byResolution : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
The channel index. The value is between 0~31
i_wRange
The channel range code.
i_fValue
The channel value.
i_byResolution
The resolution.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetEmergencyFlag Method

AnalogOutput.SetEmergencyFlag Method
[image]

Support module: ADAM-4024. Set emergency flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetEmergencyFlag( _
ByVal i_iChannel As Integer, _
ByVal i_bFlag As Boolean _
) As Boolean
C#
public bool SetEmergencyFlag(
int i_iChannel,
bool i_bFlag
)
C++
public:
bool SetEmergencyFlag(
int i_iChannel,
bool i_bFlag
) sealed
J#
public bool SetEmergencyFlag(
int i_iChannel,
bool i_bFlag
)
JScript
public function SetEmergencyFlag(
i_iChannel : int,
i_bFlag : bool
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3
i_bFlag
The emergency flag. Set to true, then the AO will output the emergency value when corresponded DI is On.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetEmergencyValue Method

AnalogOutput.SetEmergencyValue Method
[image]

Support module: ADAM-4024. Set the emergency value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetEmergencyValue( _
ByVal i_iChannel As Integer, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetEmergencyValue(
int i_iChannel,
float i_fValue
)
C++
public:
bool SetEmergencyValue(
int i_iChannel,
float i_fValue
) sealed
J#
public bool SetEmergencyValue(
int i_iChannel,
float i_fValue
)
JScript
public function SetEmergencyValue(
i_iChannel : int,
i_fValue : float
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3.
i_fValue
The emergency output value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetExcitationCalibrationCounts Method

AnalogOutput.SetExcitationCalibrationCounts Method
[image]

Support module: ADAM-4016. Set the counts to adjust output value. Each count is about 1.0 mV.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetExcitationCalibrationCounts( _
ByVal i_iCount As Integer _
) As Boolean
C#
public bool SetExcitationCalibrationCounts(
int i_iCount
)
C++
public:
bool SetExcitationCalibrationCounts(
int i_iCount
) sealed
J#
public bool SetExcitationCalibrationCounts(
int i_iCount
)
JScript
public function SetExcitationCalibrationCounts(
i_iCount : int
) : bool

Parameters

i_iCount
The counts to set. The range is from -128~127.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetExcitationSpanCalibration Method

AnalogOutput.SetExcitationSpanCalibration Method
[image]

Support module: ADAM-4016. Set analog output Span calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetExcitationSpanCalibration() As Boolean
C#
public bool SetExcitationSpanCalibration()
C++
public:
bool SetExcitationSpanCalibration() sealed
J#
public bool SetExcitationSpanCalibration()
JScript
public function SetExcitationSpanCalibration() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetExcitationToStartup Method

AnalogOutput.SetExcitationToStartup Method
[image]

Support module: ADAM-4016. Set the present output value as startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetExcitationToStartup() As Boolean
C#
public bool SetExcitationToStartup()
C++
public:
bool SetExcitationToStartup() sealed
J#
public bool SetExcitationToStartup()
JScript
public function SetExcitationToStartup() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetExcitationValue Method

AnalogOutput.SetExcitationValue Method
[image]

Support module: ADAM-4016. Set the excitation output value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetExcitationValue( _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetExcitationValue(
float i_fValue
)
C++
public:
bool SetExcitationValue(
float i_fValue
) sealed
J#
public bool SetExcitationValue(
float i_fValue
)
JScript
public function SetExcitationValue(
i_fValue : float
) : bool

Parameters

i_fValue
The value to output. The value is form 0.0~10.0

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetExcitationZeroCalibration Method

AnalogOutput.SetExcitationZeroCalibration Method
[image]

Support module: ADAM-4016. Set analog output Zero calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetExcitationZeroCalibration() As Boolean
C#
public bool SetExcitationZeroCalibration()
C++
public:
bool SetExcitationZeroCalibration() sealed
J#
public bool SetExcitationZeroCalibration()
JScript
public function SetExcitationZeroCalibration() : bool

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetOutputRange Method

AnalogOutput.SetOutputRange Method

Support module: ADAM-4024. Set module analog Output range

Overload List

 | Name | Description
Public method | SetOutputRange (Int32, Byte) | Support module: ADAM-4024. Set module analog Output range
Public method | SetOutputRange (Int32, Int32, Byte) | Support module: ADAM-5024 on ADAM-5550. Set module analog Output range
Public method | SetOutputRange (Int32, UInt16) | Support module: ADAM-6200. Set module analog output range

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetOutputRange Method (Int32, Byte)

AnalogOutput.SetOutputRange Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4024. Set module analog Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetOutputRange( _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool SetOutputRange(
int i_iChannel,
byte i_byRange
)
C++
public:
bool SetOutputRange(
int i_iChannel,
char i_byRange
) sealed
J#
public bool SetOutputRange(
int i_iChannel,
byte i_byRange
)
JScript
public function SetOutputRange(
i_iChannel : int,
i_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3
i_byRange
The Output range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetOutputRange Overload List


SetOutputRange Method (Int32, Int32, Byte)

AnalogOutput.SetOutputRange Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5024 on ADAM-5550. Set module analog Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetOutputRange( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool SetOutputRange(
int i_iSlot,
int i_iChannel,
byte i_byRange
)
C++
public:
bool SetOutputRange(
int i_iSlot,
int i_iChannel,
char i_byRange
) sealed
J#
public bool SetOutputRange(
int i_iSlot,
int i_iChannel,
byte i_byRange
)
JScript
public function SetOutputRange(
i_iSlot : int,
i_iChannel : int,
i_byRange : Byte
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannel
The channel index. The value is between 0~3
i_byRange
The Output range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetOutputRange Overload List


SetOutputRange Method (Int32, UInt16)

AnalogOutput.SetOutputRange Method (Int32, UInt16)
See Also Example
[image]

Support module: ADAM-6200. Set module analog output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetOutputRange( _
ByVal i_iChannel As Integer, _
ByVal i_usRange As UInt16 _
) As Boolean
C#
public bool SetOutputRange(
int i_iChannel,
ushort i_usRange
)
C++
public:
bool SetOutputRange(
int i_iChannel,
unsigned short i_usRange
) sealed
J#
public bool SetOutputRange(
int i_iChannel,
ushort i_usRange
)
JScript
public function SetOutputRange(
i_iChannel : int,
i_usRange : UInt16
) : bool

Parameters

i_iChannel
The channel index.
i_usRange
The output range code (Use ushort as the parameter)

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetOutputRange Overload List


SetRange Method

AnalogOutput.SetRange Method
[image]

Support module: ADAM-4022T. Set module analog Output range

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRange( _
ByVal i_iChannel As Integer, _
ByVal i_byRange As Byte _
) As Boolean
C#
public bool SetRange(
int i_iChannel,
byte i_byRange
)
C++
public:
bool SetRange(
int i_iChannel,
char i_byRange
) sealed
J#
public bool SetRange(
int i_iChannel,
byte i_byRange
)
JScript
public function SetRange(
i_iChannel : int,
i_byRange : Byte
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
i_byRange
The Output range code

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetRanges Method

AnalogOutput.SetRanges Method
[image]

Support module: APAX-5000. Set module analog output ranges

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRanges( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
ByVal i_usRange As UInt16() _
) As Boolean
C#
public bool SetRanges(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usRange
)
C++
public:
bool SetRanges(
int i_iSlot,
int i_iChannelTotal,
array<unsigned short>^ i_usRange
) sealed
J#
public bool SetRanges(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usRange
)
JScript
public function SetRanges(
i_iSlot : int,
i_iChannelTotal : int,
i_usRange : UInt16[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The total of the channel on the module.
i_usRange
The analog output ranges.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetSafetyFunctionStatus Method

AnalogOutput.SetSafetyFunctionStatus Method
[image]

Support module: ADAM-6200 series. Set safety function status (enable or disable) value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSafetyFunctionStatus( _
ByVal i_bValue As Boolean _
) As Boolean
C#
public bool SetSafetyFunctionStatus(
bool i_bValue
)
C++
public:
bool SetSafetyFunctionStatus(
bool i_bValue
) sealed
J#
public bool SetSafetyFunctionStatus(
bool i_bValue
)
JScript
public function SetSafetyFunctionStatus(
i_bValue : bool
) : bool

Parameters

i_bValue
The safety function status value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetSafetyTrigTime Method

AnalogOutput.SetSafetyTrigTime Method
[image]

Support module: ADAM-6100 series. Set module fail safety values(FSV) trig time value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSafetyTrigTime( _
ByVal i_iSlot As Integer, _
ByVal i_usValue As UInt16 _
) As Boolean
C#
public bool SetSafetyTrigTime(
int i_iSlot,
ushort i_usValue
)
C++
public:
bool SetSafetyTrigTime(
int i_iSlot,
unsigned short i_usValue
) sealed
J#
public bool SetSafetyTrigTime(
int i_iSlot,
ushort i_usValue
)
JScript
public function SetSafetyTrigTime(
i_iSlot : int,
i_usValue : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_usValue
The trig time value.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetSafetyValues Method

AnalogOutput.SetSafetyValues Method
[image]

Support module: APAX-5000. Set module module safety values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSafetyValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
ByVal i_usValues As UInt16() _
) As Boolean
C#
public bool SetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usValues
)
C++
public:
bool SetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
array<unsigned short>^ i_usValues
) sealed
J#
public bool SetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usValues
)
JScript
public function SetSafetyValues(
i_iSlot : int,
i_iChannelTotal : int,
i_usValues : UInt16[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The total of the channel on the module.
i_usValues
The analog output ranges.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetSlewRate Method

AnalogOutput.SetSlewRate Method

Support module: ADAM-6200. Set module Slew Rate

Overload List

 | Name | Description
Public method | SetSlewRate (Int32, Byte) | Support module: ADAM-6200. Set module Slew Rate
Public method | SetSlewRate (Int32, Int32, Byte, Byte, Byte) | Support module: ADAM-6124. Set module module safety values.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetSlewRate Method (Int32, Byte)

AnalogOutput.SetSlewRate Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-6200. Set module Slew Rate

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSlewRate( _
ByVal i_iChannel As Integer, _
ByVal i_bySlewRate As Byte _
) As Boolean
C#
public bool SetSlewRate(
int i_iChannel,
byte i_bySlewRate
)
C++
public:
bool SetSlewRate(
int i_iChannel,
char i_bySlewRate
) sealed
J#
public bool SetSlewRate(
int i_iChannel,
byte i_bySlewRate
)
JScript
public function SetSlewRate(
i_iChannel : int,
i_bySlewRate : Byte
) : bool

Parameters

i_iChannel
The channel index.
i_bySlewRate
The slew rate

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetSlewRate Overload List


SetSlewRate Method (Int32, Int32, Byte, Byte, Byte)

AnalogOutput.SetSlewRate Method (Int32, Int32, Byte, Byte, Byte)
See Also Example
[image]

Support module: ADAM-6124. Set module module safety values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSlewRate( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_bySlewRateIdx As Byte, _
ByVal i_byStep As Byte, _
ByVal i_byClock As Byte _
) As Boolean
C#
public bool SetSlewRate(
int i_iSlot,
int i_iChannel,
byte i_bySlewRateIdx,
byte i_byStep,
byte i_byClock
)
C++
public:
bool SetSlewRate(
int i_iSlot,
int i_iChannel,
char i_bySlewRateIdx,
char i_byStep,
char i_byClock
) sealed
J#
public bool SetSlewRate(
int i_iSlot,
int i_iChannel,
byte i_bySlewRateIdx,
byte i_byStep,
byte i_byClock
)
JScript
public function SetSlewRate(
i_iSlot : int,
i_iChannel : int,
i_bySlewRateIdx : Byte,
i_byStep : Byte,
i_byClock : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
Channel index to config.
i_bySlewRateIdx
The slew rate index. (0xFF for user defined)
i_byStep
The slew rate setting: step size for user defined.
i_byClock
The slew rate setting: update clock for user defined.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetSlewRate Overload List


SetSpanCalibration Method

AnalogOutput.SetSpanCalibration Method

Support module: ADAM-5024. Set analog output Span calibration

Overload List

 | Name | Description
Public method | SetSpanCalibration (Int32, Int32) | Support module: ADAM-5024. Set analog output Span calibration
Public method | SetSpanCalibration (Int32, Int32, Int32) | Support module: APAX-5000. Set analog output Span calibration

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetSpanCalibration Method (Int32, Int32)

AnalogOutput.SetSpanCalibration Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-5024. Set analog output Span calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSpanCalibration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetSpanCalibration(
int i_iSlot,
int i_iChannel
)
C++
public:
bool SetSpanCalibration(
int i_iSlot,
int i_iChannel
) sealed
J#
public bool SetSpanCalibration(
int i_iSlot,
int i_iChannel
)
JScript
public function SetSpanCalibration(
i_iSlot : int,
i_iChannel : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetSpanCalibration Overload List


SetSpanCalibration Method (Int32, Int32, Int32)

AnalogOutput.SetSpanCalibration Method (Int32, Int32, Int32)
See Also Example
[image]

Support module: APAX-5000. Set analog output Span calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSpanCalibration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iType As Integer _
) As Boolean
C#
public bool SetSpanCalibration(
int i_iSlot,
int i_iChannel,
int i_iType
)
C++
public:
bool SetSpanCalibration(
int i_iSlot,
int i_iChannel,
int i_iType
) sealed
J#
public bool SetSpanCalibration(
int i_iSlot,
int i_iChannel,
int i_iType
)
JScript
public function SetSpanCalibration(
i_iSlot : int,
i_iChannel : int,
i_iType : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
The channel ID which is ranged from 0 to 31.
i_iType
The type value to be set. Currently, it is ingnored.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetSpanCalibration Overload List


SetSpanCalibrationRaw Method

AnalogOutput.SetSpanCalibrationRaw Method
[image]

Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Set analog output Span calibration raw data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSpanCalibrationRaw( _
ByVal i_iChannel As Integer, _
ByVal i_iRawData As Integer _
) As Boolean
C#
public bool SetSpanCalibrationRaw(
int i_iChannel,
int i_iRawData
)
C++
public:
bool SetSpanCalibrationRaw(
int i_iChannel,
int i_iRawData
) sealed
J#
public bool SetSpanCalibrationRaw(
int i_iChannel,
int i_iRawData
)
JScript
public function SetSpanCalibrationRaw(
i_iChannel : int,
i_iRawData : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
i_iRawData
The raw analog output data, range is from 0~4095

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetStartupValue Method

AnalogOutput.SetStartupValue Method

Support module: ADAM-6022, ADAM-6024. Set the analog output startup value

Overload List

 | Name | Description
Public method | SetStartupValue (Int32, Int32) | Support module: ADAM-6022, ADAM-6024. Set the analog output startup value
Public method | SetStartupValue (Int32, Single) | Support module: ADAM-4024. Set the startup value

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetStartupValue Method (Int32, Int32)

AnalogOutput.SetStartupValue Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-6022, ADAM-6024. Set the analog output startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStartupValue( _
ByVal i_iChannel As Integer, _
ByVal i_iValue As Integer _
) As Boolean
C#
public bool SetStartupValue(
int i_iChannel,
int i_iValue
)
C++
public:
bool SetStartupValue(
int i_iChannel,
int i_iValue
) sealed
J#
public bool SetStartupValue(
int i_iChannel,
int i_iValue
)
JScript
public function SetStartupValue(
i_iChannel : int,
i_iValue : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
i_iValue
The startup output value, ranged from 0x000(0) to 0xFFF(4095)

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetStartupValue Overload List


SetStartupValue Method (Int32, Single)

AnalogOutput.SetStartupValue Method (Int32, Single)
See Also Example
[image]

Support module: ADAM-4024. Set the startup value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStartupValue( _
ByVal i_iChannel As Integer, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetStartupValue(
int i_iChannel,
float i_fValue
)
C++
public:
bool SetStartupValue(
int i_iChannel,
float i_fValue
) sealed
J#
public bool SetStartupValue(
int i_iChannel,
float i_fValue
)
JScript
public function SetStartupValue(
i_iChannel : int,
i_fValue : float
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~3.
i_fValue
The startup output value.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetStartupValue Overload List


SetStartupValues Method

AnalogOutput.SetStartupValues Method
[image]

Support module: APAX-5028. Set analog output startup values

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStartupValues( _
ByVal i_iSlot As Integer, _
ByVal i_usValues As UInt16() _
) As Boolean
C#
public bool SetStartupValues(
int i_iSlot,
ushort[] i_usValues
)
C++
public:
bool SetStartupValues(
int i_iSlot,
array<unsigned short>^ i_usValues
) sealed
J#
public bool SetStartupValues(
int i_iSlot,
ushort[] i_usValues
)
JScript
public function SetStartupValues(
i_iSlot : int,
i_usValues : UInt16[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_usValues
The startup output values.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetValue Method

AnalogOutput.SetValue Method
[image]

Support module: ADAM-4022T. Set the output value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetValue( _
ByVal i_iChannel As Integer, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetValue(
int i_iChannel,
float i_fValue
)
C++
public:
bool SetValue(
int i_iChannel,
float i_fValue
) sealed
J#
public bool SetValue(
int i_iChannel,
float i_fValue
)
JScript
public function SetValue(
i_iChannel : int,
i_fValue : float
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1.
i_fValue
The value to output

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetZeroCalibration Method

AnalogOutput.SetZeroCalibration Method

Support module: ADAM-5024. Set analog output Zero calibration

Overload List

 | Name | Description
Public method | SetZeroCalibration (Int32, Int32) | Support module: ADAM-5024. Set analog output Zero calibration
Public method | SetZeroCalibration (Int32, Int32, Int32) | Support module: APAX-5000. Set analog output Zero calibration

See Also

AnalogOutput Class
Advantech.Adam Namespace


SetZeroCalibration Method (Int32, Int32)

AnalogOutput.SetZeroCalibration Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-5024. Set analog output Zero calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetZeroCalibration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetZeroCalibration(
int i_iSlot,
int i_iChannel
)
C++
public:
bool SetZeroCalibration(
int i_iSlot,
int i_iChannel
) sealed
J#
public bool SetZeroCalibration(
int i_iSlot,
int i_iChannel
)
JScript
public function SetZeroCalibration(
i_iSlot : int,
i_iChannel : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetZeroCalibration Overload List


SetZeroCalibration Method (Int32, Int32, Int32)

AnalogOutput.SetZeroCalibration Method (Int32, Int32, Int32)
See Also Example
[image]

Support module: APAX-5000. Set analog output Zero calibration

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetZeroCalibration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_iType As Integer _
) As Boolean
C#
public bool SetZeroCalibration(
int i_iSlot,
int i_iChannel,
int i_iType
)
C++
public:
bool SetZeroCalibration(
int i_iSlot,
int i_iChannel,
int i_iType
) sealed
J#
public bool SetZeroCalibration(
int i_iSlot,
int i_iChannel,
int i_iType
)
JScript
public function SetZeroCalibration(
i_iSlot : int,
i_iChannel : int,
i_iType : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15.
i_iChannel
The channel ID which is ranged from 0 to 31.
i_iType
The type value to be set. Currently, it is ingnored in APAX.

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace
AnalogOutput.SetZeroCalibration Overload List


SetZeroCalibrationRaw Method

AnalogOutput.SetZeroCalibrationRaw Method
[image]

Support module: ADAM-4022T, ADAM-6022, ADAM-6024. Set analog output Zero calibration raw data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetZeroCalibrationRaw( _
ByVal i_iChannel As Integer, _
ByVal i_iRawData As Integer _
) As Boolean
C#
public bool SetZeroCalibrationRaw(
int i_iChannel,
int i_iRawData
)
C++
public:
bool SetZeroCalibrationRaw(
int i_iChannel,
int i_iRawData
) sealed
J#
public bool SetZeroCalibrationRaw(
int i_iChannel,
int i_iRawData
)
JScript
public function SetZeroCalibrationRaw(
i_iChannel : int,
i_iRawData : int
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
i_iRawData
The raw analog output data, range is from 0~4095

Return Value

True if succeed, otherwise false.

See Also

AnalogOutput Class
Advantech.Adam Namespace


Apax_Integration Enumeration

Apax_Integration Enumeration
[image]

The integration code for APAX

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Apax_Integration As
C#
public enum Apax_Integration : uint
C++
public enum class Apax_Integration : unsigned int
J#
public enum Apax_Integration uint
JScript
public enum Apax_Integration :

Members

Member Name | Description
Hz60_50ms | 60 Hz
Hz50_60ms | 50 Hz
Auto | Auto
Unknown | Unknown

See Also

Advantech.Adam Namespace


Apax5000_ChannelStatus Enumeration

Apax5000_ChannelStatus Enumeration
[image]

The channel status for analog input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Apax5000_ChannelStatus As Byte
C#
public enum Apax5000_ChannelStatus : byte
C++
public enum class Apax5000_ChannelStatus : char
J#
public enum Apax5000_ChannelStatus byte
JScript
public enum Apax5000_ChannelStatus :

Members

Member Name | Description
Bad | Bad
Good | Good
OverCurrent | Over current
UnderCurrent | Under Current
BurnOut | Burn out
OpenLoop | Open loop
NotReady | Not Ready
Short | Short
Overflow | Overflow
Underflow | Underflow
OverflowAndUnderflow | Overflow and Underflow
ChannelTempSensorError | Channel Temperature Sensor Error
ChannelTempSensorInitError | Channel Temperature Sensor Initial Error
CJCInitialError | CJC Initial Error
CJCTempError | CJC Temperature Error
ZeroSpanCalibrationError | ZeroSpan Calibration Error
FactoryCalibrationError | Factory Calibration Error
Unknown | Unknown

See Also

Advantech.Adam Namespace


Apax5000Config Class

Apax5000Config Class
See Also Example Members
[image]

ApaxSlotInfo Class

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Apax5000Config
Inherits SelfMarshalledStruct
C#
public class Apax5000Config : SelfMarshalledStruct
C++
ref class Apax5000Config : SelfMarshalledStruct
J#
public class Apax5000Config extends SelfMarshalledStruct
JScript
public class Apax5000Config extends SelfMarshalledStruct

Inheritance Hierarchy

System.Object
Advantech.Adam.SelfMarshalledStruct
Advantech.Adam.Apax5000Config

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Apax5000Config Members
Advantech.Adam Namespace


Apax5000Config Members

Apax5000Config Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

ApaxSlotInfo Class

The following tables list the members exposed by Apax5000Config.

Public Constructors

Name | Description
Apax5000Config | Overloaded. Initializes a new instance of the Apax5000Config class.
Top

Public Fields

Name | Description
MAX_CH | Maximum channel number. This field is read-only.
MAX_HwIoType | Maximum hardware io type number. This field is read-only.
MAX_SUPPORT_RANGE | Maximum support range number. This field is read-only.
Top

Protected Fields

 | Name | Description
Family field | baseOffset | (inherited from SelfMarshalledStruct)
Family field | data | (inherited from SelfMarshalledStruct)
Top

Public Properties

 | Name | Description
Public property | byChTotal | Total # of Channels
Public property | byCOS | Change of State
Public property | byEthSpeed | EthSpeed
Public property | byExtUsed | Extension used
Public property | byFunType_0 | Function Type 0
Public property | byFunType_1 | Function Type 1
Public property | byFunType_2 | Function Type 2
Public property | byFunType_3 | Function Type 3
Public property | byFunType_4 | Function Type 4
Public property | byFwVerBld | Firmware Build Version
Public property | byHwIoTotal_0 | No. of Hardware I/O Type 0 Channels
Public property | byHwIoTotal_1 | No. of Hardware I/O Type 1 Channels
Public property | byHwIoTotal_2 | No. of Hardware I/O Type 2 Channels
Public property | byHwIoTotal_3 | No. of Hardware I/O Type 3 Channels
Public property | byHwIoTotal_4 | No. of Hardware I/O Type 4 Channels
Public property | byHwIoType_0 | Hardware I/O Type 0
Public property | byHwIoType_1 | Hardware I/O Type 1
Public property | byHwIoType_2 | Hardware I/O Type 2
Public property | byHwIoType_3 | Hardware I/O Type 3
Public property | byHwIoType_4 | Hardware I/O Type 4
Public property | byIpAddr | IP Address
Public property | byMacAddr | MAC address
Public property | byMaxLoadShare | Maximum Loading Shared
Public property | bySizeOfReg | Size of Register
Public property | byUID | Unique ID
Public property | DataArray | Data
Public property | dwActPeriod | ActiveMsg Period
Public property | dwAlarmMask | Alarm State Mask
Public property | dwChMask | Channel Enabled Mask
Public property | dwFunMask_0 | Enable Mask 0
Public property | dwFunMask_1 | Enable Mask 1
Public property | dwFunMask_2 | Enable Mask 2
Public property | dwFunMask_3 | Enable Mask 3
Public property | dwFunMask_4 | Enable Mask 4
Public property | dwFunParam_0 | Function parameter 0
Public property | dwFunParam_1 | Function parameter 1
Public property | dwFunParam_2 | Function parameter 2
Public property | dwFunParam_3 | Function parameter 3
Public property | dwFunParam_4 | Function parameter 4
Public property | dwModName | Module Name
Public property | Handle | Handle
Public property | HwIoTotal | No. of Hardware I/O Type 0-4 Channels
Public property | HwIoType | Hardware I/O Type 0-4
Public property | HwIoType_TotalRange | Total # of Supported I/O Range 0-4
 | Length | ApaxSlotInfo size length
Public property | wChRange | Current I/O Type (array size:32)
Public property | wDevType | Device Type
Public property | wExtLength | Extension Bytes
Public property | wFwVerNo | Firmware Version
Public property | wHwIoType_0_End | Hardware I/O Type 0 Data Reg. Address Range End
Public property | wHwIoType_0_Range | Supported I/O Range 0 (array size:36)
Public property | wHwIoType_0_Resolution | Resolution 0
Public property | wHwIoType_0_Start | Hardware I/O Type 0 Data Reg. Address Range Start
Public property | wHwIoType_0_TotalRange | Total # of Supported I/O Range 0
Public property | wHwIoType_1_End | Hardware I/O Type 1 Data Reg. Address Range End
Public property | wHwIoType_1_Range | Supported I/O Range 1 (array size:36)
Public property | wHwIoType_1_Resolution | Resolution 1
Public property | wHwIoType_1_Start | Hardware I/O Type 1 Data Reg. Address Range Start
Public property | wHwIoType_1_TotalRange | Total # of Supported I/O Range 1
Public property | wHwIoType_2_End | Hardware I/O Type 2 Data Reg. Address Range End
Public property | wHwIoType_2_Range | Supported I/O Range 2 (array size:36)
Public property | wHwIoType_2_Resolution | Resolution 2
Public property | wHwIoType_2_Start | Hardware I/O Type 2 Data Reg. Address Range Start
Public property | wHwIoType_2_TotalRange | Total # of Supported I/O Range 2
Public property | wHwIoType_3_End | Hardware I/O Type 3 Data Reg. Address Range End
Public property | wHwIoType_3_Range | Supported I/O Range 3 (array size:36)
Public property | wHwIoType_3_Resolution | Resolution 3
Public property | wHwIoType_3_Start | Hardware I/O Type 3 Data Reg. Address Range Start
Public property | wHwIoType_3_TotalRange | Total # of Supported I/O Range 3
Public property | wHwIoType_4_End | Hardware I/O Type 4 Data Reg. Address Range End
Public property | wHwIoType_4_Range | Supported I/O Range 4 (array size:36)
Public property | wHwIoType_4_Resolution | Resolution 4
Public property | wHwIoType_4_Start | Hardware I/O Type 4 Data Reg. Address Range Start
Public property | wHwIoType_4_TotalRange | Total # of Supported I/O Range 4
Public property | wHwVer | Hardware Version
Public property | wMsgType | Message Type
Public property | wPktVer | Packet Version
Public property | wProtoVer | Protocol Version
Public property | wSeqNo | Sequence Number
Public property | wSupportFwVer | Supported Controller's Firmware Version
Top

Protected Properties

 | Name | Description
Family property | Data | (inherited from SelfMarshalledStruct)
Family property | Item | (inherited from SelfMarshalledStruct)
Top

Public Methods

 | Name | Description
Public method | GetExtBuf | Get Extension buffer value
Public method | GetModuleName | Get the module name string.
Public method | SetExtBuf | Set Extension buffer value
Top

Protected Methods

 | Name | Description
Family method | Get | (inherited from SelfMarshalledStruct)
Family method | GetByte | (inherited from SelfMarshalledStruct)
Family method | GetChar | (inherited from SelfMarshalledStruct)
Family method | GetInt16 | (inherited from SelfMarshalledStruct)
Family method | GetInt32 | (inherited from SelfMarshalledStruct)
Family method | GetIntPtr | (inherited from SelfMarshalledStruct)
Family method | GetSlice | (inherited from SelfMarshalledStruct)
Family method | GetStringAscii | (inherited from SelfMarshalledStruct)
Family method | GetStringUni | (inherited from SelfMarshalledStruct)
Family method | GetUInt16 | (inherited from SelfMarshalledStruct)
Family method | GetUInt32 | (inherited from SelfMarshalledStruct)
Family method | Set | (inherited from SelfMarshalledStruct)
Family method | SetByte | (inherited from SelfMarshalledStruct)
Family method | SetChar | (inherited from SelfMarshalledStruct)
Family method | SetInt16 | (inherited from SelfMarshalledStruct)
Family method | SetInt32 | (inherited from SelfMarshalledStruct)
Family method | SetIntPtr | (inherited from SelfMarshalledStruct)
Family method | SetStringUni | (inherited from SelfMarshalledStruct)
Family method | SetUInt16 | (inherited from SelfMarshalledStruct)
Family method | SetUInt32 | (inherited from SelfMarshalledStruct)
Top

Explicit Interface Implementations

Name | Description
Apax5000Config | Overloaded. Initializes a new instance of the Apax5000Config class.
Top

See Also

Apax5000Config Class
Advantech.Adam Namespace


Apax5000Config Constructor

Apax5000Config Constructor

Initializes a new instance of the Apax5000Config class.

Overload List

 | Name | Description
Public method | Apax5000Config | ApaxSlotInfo Constructor
Public method | Apax5000Config (Byte, Int32) | ApaxSlotInfo Constructor
Public method | Apax5000Config (IntPtr, Int32) | ApaxSlotInfo Constructor

See Also

Apax5000Config Class
Advantech.Adam Namespace


Apax5000Config Constructor ()

Apax5000Config Constructor ()
See Also Example
[image]

ApaxSlotInfo Constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Apax5000Config()
C++
public:
Apax5000Config() sealed
J#
public Apax5000Config()
JScript
public function Apax5000Config()

See Also

Apax5000Config Class
Advantech.Adam Namespace
Apax5000Config Constructor Overload List


Apax5000Config Constructor (Byte[], Int32)

Apax5000Config Constructor (Byte[], Int32)
See Also Example
[image]

ApaxSlotInfo Constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal data As Byte(), _
ByVal offset As Integer _
)
C#
public Apax5000Config(
byte[] data,
int offset
)
C++
public:
Apax5000Config(
array<char>^ data,
int offset
) sealed
J#
public Apax5000Config(
byte[] data,
int offset
)
JScript
public function Apax5000Config(
data : Byte[],
offset : int
)

Parameters

data
offset

See Also

Apax5000Config Class
Advantech.Adam Namespace
Apax5000Config Constructor Overload List


Apax5000Config Constructor (IntPtr, Int32)

Apax5000Config Constructor (IntPtr, Int32)
See Also Example
[image]

ApaxSlotInfo Constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal pData As IntPtr, _
ByVal offset As Integer _
)
C#
public Apax5000Config(
IntPtr pData,
int offset
)
C++
public:
Apax5000Config(
IntPtr pData,
int offset
) sealed
J#
public Apax5000Config(
IntPtr pData,
int offset
)
JScript
public function Apax5000Config(
pData : IntPtr,
offset : int
)

Parameters

pData
offset

See Also

Apax5000Config Class
Advantech.Adam Namespace
Apax5000Config Constructor Overload List


Fields

Apax5000Config Fields
[image]

Public Fields

Name | Description
MAX_CH | Maximum channel number. This field is read-only.
MAX_HwIoType | Maximum hardware io type number. This field is read-only.
MAX_SUPPORT_RANGE | Maximum support range number. This field is read-only.
Top

Protected Fields

 | Name | Description
Family field | baseOffset | (inherited from SelfMarshalledStruct)
Family field | data | (inherited from SelfMarshalledStruct)
Top

See Also

Apax5000Config Class
Advantech.Adam Namespace


MAX_CH Field

Apax5000Config.MAX_CH Field
[image]

Maximum channel number. This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_CH As Integer
C#
public static readonly int MAX_CH;
C++
public:
static const int MAX_CH;
J#
public static final int MAX_CH
JScript
public static const var MAX_CH : int;

See Also

Apax5000Config Class
Advantech.Adam Namespace


MAX_HwIoType Field

Apax5000Config.MAX_HwIoType Field
[image]

Maximum hardware io type number. This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_HwIoType As Integer
C#
public static readonly int MAX_HwIoType;
C++
public:
static const int MAX_HwIoType;
J#
public static final int MAX_HwIoType
JScript
public static const var MAX_HwIoType : int;

See Also

Apax5000Config Class
Advantech.Adam Namespace


MAX_SUPPORT_RANGE Field

Apax5000Config.MAX_SUPPORT_RANGE Field
[image]

Maximum support range number. This field is read-only.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_SUPPORT_RANGE As Integer
C#
public static readonly int MAX_SUPPORT_RANGE;
C++
public:
static const int MAX_SUPPORT_RANGE;
J#
public static final int MAX_SUPPORT_RANGE
JScript
public static const var MAX_SUPPORT_RANGE : int;

See Also

Apax5000Config Class
Advantech.Adam Namespace


Properties

Apax5000Config Properties
[image]

Public Properties

 | Name | Description
Public property | byChTotal | Total # of Channels
Public property | byCOS | Change of State
Public property | byEthSpeed | EthSpeed
Public property | byExtUsed | Extension used
Public property | byFunType_0 | Function Type 0
Public property | byFunType_1 | Function Type 1
Public property | byFunType_2 | Function Type 2
Public property | byFunType_3 | Function Type 3
Public property | byFunType_4 | Function Type 4
Public property | byFwVerBld | Firmware Build Version
Public property | byHwIoTotal_0 | No. of Hardware I/O Type 0 Channels
Public property | byHwIoTotal_1 | No. of Hardware I/O Type 1 Channels
Public property | byHwIoTotal_2 | No. of Hardware I/O Type 2 Channels
Public property | byHwIoTotal_3 | No. of Hardware I/O Type 3 Channels
Public property | byHwIoTotal_4 | No. of Hardware I/O Type 4 Channels
Public property | byHwIoType_0 | Hardware I/O Type 0
Public property | byHwIoType_1 | Hardware I/O Type 1
Public property | byHwIoType_2 | Hardware I/O Type 2
Public property | byHwIoType_3 | Hardware I/O Type 3
Public property | byHwIoType_4 | Hardware I/O Type 4
Public property | byIpAddr | IP Address
Public property | byMacAddr | MAC address
Public property | byMaxLoadShare | Maximum Loading Shared
Public property | bySizeOfReg | Size of Register
Public property | byUID | Unique ID
Public property | DataArray | Data
Public property | dwActPeriod | ActiveMsg Period
Public property | dwAlarmMask | Alarm State Mask
Public property | dwChMask | Channel Enabled Mask
Public property | dwFunMask_0 | Enable Mask 0
Public property | dwFunMask_1 | Enable Mask 1
Public property | dwFunMask_2 | Enable Mask 2
Public property | dwFunMask_3 | Enable Mask 3
Public property | dwFunMask_4 | Enable Mask 4
Public property | dwFunParam_0 | Function parameter 0
Public property | dwFunParam_1 | Function parameter 1
Public property | dwFunParam_2 | Function parameter 2
Public property | dwFunParam_3 | Function parameter 3
Public property | dwFunParam_4 | Function parameter 4
Public property | dwModName | Module Name
Public property | Handle | Handle
Public property | HwIoTotal | No. of Hardware I/O Type 0-4 Channels
Public property | HwIoType | Hardware I/O Type 0-4
Public property | HwIoType_TotalRange | Total # of Supported I/O Range 0-4
 | Length | ApaxSlotInfo size length
Public property | wChRange | Current I/O Type (array size:32)
Public property | wDevType | Device Type
Public property | wExtLength | Extension Bytes
Public property | wFwVerNo | Firmware Version
Public property | wHwIoType_0_End | Hardware I/O Type 0 Data Reg. Address Range End
Public property | wHwIoType_0_Range | Supported I/O Range 0 (array size:36)
Public property | wHwIoType_0_Resolution | Resolution 0
Public property | wHwIoType_0_Start | Hardware I/O Type 0 Data Reg. Address Range Start
Public property | wHwIoType_0_TotalRange | Total # of Supported I/O Range 0
Public property | wHwIoType_1_End | Hardware I/O Type 1 Data Reg. Address Range End
Public property | wHwIoType_1_Range | Supported I/O Range 1 (array size:36)
Public property | wHwIoType_1_Resolution | Resolution 1
Public property | wHwIoType_1_Start | Hardware I/O Type 1 Data Reg. Address Range Start
Public property | wHwIoType_1_TotalRange | Total # of Supported I/O Range 1
Public property | wHwIoType_2_End | Hardware I/O Type 2 Data Reg. Address Range End
Public property | wHwIoType_2_Range | Supported I/O Range 2 (array size:36)
Public property | wHwIoType_2_Resolution | Resolution 2
Public property | wHwIoType_2_Start | Hardware I/O Type 2 Data Reg. Address Range Start
Public property | wHwIoType_2_TotalRange | Total # of Supported I/O Range 2
Public property | wHwIoType_3_End | Hardware I/O Type 3 Data Reg. Address Range End
Public property | wHwIoType_3_Range | Supported I/O Range 3 (array size:36)
Public property | wHwIoType_3_Resolution | Resolution 3
Public property | wHwIoType_3_Start | Hardware I/O Type 3 Data Reg. Address Range Start
Public property | wHwIoType_3_TotalRange | Total # of Supported I/O Range 3
Public property | wHwIoType_4_End | Hardware I/O Type 4 Data Reg. Address Range End
Public property | wHwIoType_4_Range | Supported I/O Range 4 (array size:36)
Public property | wHwIoType_4_Resolution | Resolution 4
Public property | wHwIoType_4_Start | Hardware I/O Type 4 Data Reg. Address Range Start
Public property | wHwIoType_4_TotalRange | Total # of Supported I/O Range 4
Public property | wHwVer | Hardware Version
Public property | wMsgType | Message Type
Public property | wPktVer | Packet Version
Public property | wProtoVer | Protocol Version
Public property | wSeqNo | Sequence Number
Public property | wSupportFwVer | Supported Controller's Firmware Version
Top

Protected Properties

 | Name | Description
Family property | Data | (inherited from SelfMarshalledStruct)
Family property | Item | (inherited from SelfMarshalledStruct)
Top

See Also

Apax5000Config Class
Advantech.Adam Namespace


byChTotal Property

Apax5000Config.byChTotal Property
[image]

Total # of Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byChTotal As Byte
C#
public byte byChTotal { get; set; }
C++
public property byte byChTotal sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byChTotal();

/** property */
public void set_byChTotal(byte value);
JScript
public function get byChTotal() : Byte

public function set byChTotal(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byCOS Property

Apax5000Config.byCOS Property
[image]

Change of State

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byCOS As Byte
C#
public byte byCOS { get; set; }
C++
public property byte byCOS sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byCOS();

/** property */
public void set_byCOS(byte value);
JScript
public function get byCOS() : Byte

public function set byCOS(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byEthSpeed Property

Apax5000Config.byEthSpeed Property
[image]

EthSpeed

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byEthSpeed As Byte
C#
public byte byEthSpeed { get; set; }
C++
public property byte byEthSpeed sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byEthSpeed();

/** property */
public void set_byEthSpeed(byte value);
JScript
public function get byEthSpeed() : Byte

public function set byEthSpeed(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byExtUsed Property

Apax5000Config.byExtUsed Property
[image]

Extension used

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byExtUsed As Byte
C#
public byte byExtUsed { get; set; }
C++
public property byte byExtUsed sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byExtUsed();

/** property */
public void set_byExtUsed(byte value);
JScript
public function get byExtUsed() : Byte

public function set byExtUsed(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byFunType_0 Property

Apax5000Config.byFunType_0 Property
[image]

Function Type 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_0 As Byte
C#
public byte byFunType_0 { get; set; }
C++
public property byte byFunType_0 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_0();

/** property */
public void set_byFunType_0(byte value);
JScript
public function get byFunType_0() : Byte

public function set byFunType_0(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byFunType_1 Property

Apax5000Config.byFunType_1 Property
[image]

Function Type 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_1 As Byte
C#
public byte byFunType_1 { get; set; }
C++
public property byte byFunType_1 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_1();

/** property */
public void set_byFunType_1(byte value);
JScript
public function get byFunType_1() : Byte

public function set byFunType_1(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byFunType_2 Property

Apax5000Config.byFunType_2 Property
[image]

Function Type 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_2 As Byte
C#
public byte byFunType_2 { get; set; }
C++
public property byte byFunType_2 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_2();

/** property */
public void set_byFunType_2(byte value);
JScript
public function get byFunType_2() : Byte

public function set byFunType_2(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byFunType_3 Property

Apax5000Config.byFunType_3 Property
[image]

Function Type 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_3 As Byte
C#
public byte byFunType_3 { get; set; }
C++
public property byte byFunType_3 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_3();

/** property */
public void set_byFunType_3(byte value);
JScript
public function get byFunType_3() : Byte

public function set byFunType_3(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byFunType_4 Property

Apax5000Config.byFunType_4 Property
[image]

Function Type 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFunType_4 As Byte
C#
public byte byFunType_4 { get; set; }
C++
public property byte byFunType_4 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFunType_4();

/** property */
public void set_byFunType_4(byte value);
JScript
public function get byFunType_4() : Byte

public function set byFunType_4(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byFwVerBld Property

Apax5000Config.byFwVerBld Property
[image]

Firmware Build Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byFwVerBld As Byte
C#
public byte byFwVerBld { get; set; }
C++
public property byte byFwVerBld sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byFwVerBld();

/** property */
public void set_byFwVerBld(byte value);
JScript
public function get byFwVerBld() : Byte

public function set byFwVerBld(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoTotal_0 Property

Apax5000Config.byHwIoTotal_0 Property
[image]

No. of Hardware I/O Type 0 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_0 As Byte
C#
public byte byHwIoTotal_0 { get; set; }
C++
public property byte byHwIoTotal_0 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_0();

/** property */
public void set_byHwIoTotal_0(byte value);
JScript
public function get byHwIoTotal_0() : Byte

public function set byHwIoTotal_0(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoTotal_1 Property

Apax5000Config.byHwIoTotal_1 Property
[image]

No. of Hardware I/O Type 1 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_1 As Byte
C#
public byte byHwIoTotal_1 { get; set; }
C++
public property byte byHwIoTotal_1 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_1();

/** property */
public void set_byHwIoTotal_1(byte value);
JScript
public function get byHwIoTotal_1() : Byte

public function set byHwIoTotal_1(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoTotal_2 Property

Apax5000Config.byHwIoTotal_2 Property
[image]

No. of Hardware I/O Type 2 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_2 As Byte
C#
public byte byHwIoTotal_2 { get; set; }
C++
public property byte byHwIoTotal_2 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_2();

/** property */
public void set_byHwIoTotal_2(byte value);
JScript
public function get byHwIoTotal_2() : Byte

public function set byHwIoTotal_2(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoTotal_3 Property

Apax5000Config.byHwIoTotal_3 Property
[image]

No. of Hardware I/O Type 3 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_3 As Byte
C#
public byte byHwIoTotal_3 { get; set; }
C++
public property byte byHwIoTotal_3 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_3();

/** property */
public void set_byHwIoTotal_3(byte value);
JScript
public function get byHwIoTotal_3() : Byte

public function set byHwIoTotal_3(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoTotal_4 Property

Apax5000Config.byHwIoTotal_4 Property
[image]

No. of Hardware I/O Type 4 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoTotal_4 As Byte
C#
public byte byHwIoTotal_4 { get; set; }
C++
public property byte byHwIoTotal_4 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoTotal_4();

/** property */
public void set_byHwIoTotal_4(byte value);
JScript
public function get byHwIoTotal_4() : Byte

public function set byHwIoTotal_4(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoType_0 Property

Apax5000Config.byHwIoType_0 Property
[image]

Hardware I/O Type 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_0 As Byte
C#
public byte byHwIoType_0 { get; set; }
C++
public property byte byHwIoType_0 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_0();

/** property */
public void set_byHwIoType_0(byte value);
JScript
public function get byHwIoType_0() : Byte

public function set byHwIoType_0(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoType_1 Property

Apax5000Config.byHwIoType_1 Property
[image]

Hardware I/O Type 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_1 As Byte
C#
public byte byHwIoType_1 { get; set; }
C++
public property byte byHwIoType_1 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_1();

/** property */
public void set_byHwIoType_1(byte value);
JScript
public function get byHwIoType_1() : Byte

public function set byHwIoType_1(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoType_2 Property

Apax5000Config.byHwIoType_2 Property
[image]

Hardware I/O Type 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_2 As Byte
C#
public byte byHwIoType_2 { get; set; }
C++
public property byte byHwIoType_2 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_2();

/** property */
public void set_byHwIoType_2(byte value);
JScript
public function get byHwIoType_2() : Byte

public function set byHwIoType_2(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoType_3 Property

Apax5000Config.byHwIoType_3 Property
[image]

Hardware I/O Type 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_3 As Byte
C#
public byte byHwIoType_3 { get; set; }
C++
public property byte byHwIoType_3 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_3();

/** property */
public void set_byHwIoType_3(byte value);
JScript
public function get byHwIoType_3() : Byte

public function set byHwIoType_3(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byHwIoType_4 Property

Apax5000Config.byHwIoType_4 Property
[image]

Hardware I/O Type 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byHwIoType_4 As Byte
C#
public byte byHwIoType_4 { get; set; }
C++
public property byte byHwIoType_4 sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byHwIoType_4();

/** property */
public void set_byHwIoType_4(byte value);
JScript
public function get byHwIoType_4() : Byte

public function set byHwIoType_4(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byIpAddr Property

Apax5000Config.byIpAddr Property
[image]

IP Address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byIpAddr As Byte()
C#
public byte[] byIpAddr { get; set; }
C++
public property byte[] byIpAddr sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_byIpAddr();

/** property */
public void set_byIpAddr(byte[] value);
JScript
public function get byIpAddr() : Byte[]

public function set byIpAddr(value : Byte[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byMacAddr Property

Apax5000Config.byMacAddr Property
[image]

MAC address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byMacAddr As Byte()
C#
public byte[] byMacAddr { get; set; }
C++
public property byte[] byMacAddr sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_byMacAddr();

/** property */
public void set_byMacAddr(byte[] value);
JScript
public function get byMacAddr() : Byte[]

public function set byMacAddr(value : Byte[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byMaxLoadShare Property

Apax5000Config.byMaxLoadShare Property
[image]

Maximum Loading Shared

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byMaxLoadShare As Byte
C#
public byte byMaxLoadShare { get; set; }
C++
public property byte byMaxLoadShare sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byMaxLoadShare();

/** property */
public void set_byMaxLoadShare(byte value);
JScript
public function get byMaxLoadShare() : Byte

public function set byMaxLoadShare(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


bySizeOfReg Property

Apax5000Config.bySizeOfReg Property
[image]

Size of Register

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property bySizeOfReg As Byte
C#
public byte bySizeOfReg { get; set; }
C++
public property byte bySizeOfReg sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_bySizeOfReg();

/** property */
public void set_bySizeOfReg(byte value);
JScript
public function get bySizeOfReg() : Byte

public function set bySizeOfReg(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


byUID Property

Apax5000Config.byUID Property
[image]

Unique ID

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property byUID As Byte
C#
public byte byUID { get; set; }
C++
public property byte byUID sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_byUID();

/** property */
public void set_byUID(byte value);
JScript
public function get byUID() : Byte

public function set byUID(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


DataArray Property

Apax5000Config.DataArray Property
[image]

Data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataArray As Byte()
C#
public byte[] DataArray { get; }
C++
public property byte[] DataArray sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_DataArray();
JScript
public function get DataArray() : Byte[]

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwActPeriod Property

Apax5000Config.dwActPeriod Property
[image]

ActiveMsg Period

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwActPeriod As UInt32
C#
public uint dwActPeriod { get; set; }
C++
public property uint dwActPeriod sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwActPeriod();

/** property */
public void set_dwActPeriod(uint value);
JScript
public function get dwActPeriod() : UInt32

public function set dwActPeriod(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwAlarmMask Property

Apax5000Config.dwAlarmMask Property
[image]

Alarm State Mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwAlarmMask As UInt32
C#
public uint dwAlarmMask { get; set; }
C++
public property uint dwAlarmMask sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwAlarmMask();

/** property */
public void set_dwAlarmMask(uint value);
JScript
public function get dwAlarmMask() : UInt32

public function set dwAlarmMask(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwChMask Property

Apax5000Config.dwChMask Property
[image]

Channel Enabled Mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwChMask As UInt32
C#
public uint dwChMask { get; set; }
C++
public property uint dwChMask sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwChMask();

/** property */
public void set_dwChMask(uint value);
JScript
public function get dwChMask() : UInt32

public function set dwChMask(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunMask_0 Property

Apax5000Config.dwFunMask_0 Property
[image]

Enable Mask 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_0 As UInt32
C#
public uint dwFunMask_0 { get; set; }
C++
public property uint dwFunMask_0 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_0();

/** property */
public void set_dwFunMask_0(uint value);
JScript
public function get dwFunMask_0() : UInt32

public function set dwFunMask_0(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunMask_1 Property

Apax5000Config.dwFunMask_1 Property
[image]

Enable Mask 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_1 As UInt32
C#
public uint dwFunMask_1 { get; set; }
C++
public property uint dwFunMask_1 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_1();

/** property */
public void set_dwFunMask_1(uint value);
JScript
public function get dwFunMask_1() : UInt32

public function set dwFunMask_1(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunMask_2 Property

Apax5000Config.dwFunMask_2 Property
[image]

Enable Mask 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_2 As UInt32
C#
public uint dwFunMask_2 { get; set; }
C++
public property uint dwFunMask_2 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_2();

/** property */
public void set_dwFunMask_2(uint value);
JScript
public function get dwFunMask_2() : UInt32

public function set dwFunMask_2(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunMask_3 Property

Apax5000Config.dwFunMask_3 Property
[image]

Enable Mask 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_3 As UInt32
C#
public uint dwFunMask_3 { get; set; }
C++
public property uint dwFunMask_3 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_3();

/** property */
public void set_dwFunMask_3(uint value);
JScript
public function get dwFunMask_3() : UInt32

public function set dwFunMask_3(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunMask_4 Property

Apax5000Config.dwFunMask_4 Property
[image]

Enable Mask 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunMask_4 As UInt32
C#
public uint dwFunMask_4 { get; set; }
C++
public property uint dwFunMask_4 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunMask_4();

/** property */
public void set_dwFunMask_4(uint value);
JScript
public function get dwFunMask_4() : UInt32

public function set dwFunMask_4(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunParam_0 Property

Apax5000Config.dwFunParam_0 Property
[image]

Function parameter 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_0 As UInt32
C#
public uint dwFunParam_0 { get; set; }
C++
public property uint dwFunParam_0 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_0();

/** property */
public void set_dwFunParam_0(uint value);
JScript
public function get dwFunParam_0() : UInt32

public function set dwFunParam_0(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunParam_1 Property

Apax5000Config.dwFunParam_1 Property
[image]

Function parameter 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_1 As UInt32
C#
public uint dwFunParam_1 { get; set; }
C++
public property uint dwFunParam_1 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_1();

/** property */
public void set_dwFunParam_1(uint value);
JScript
public function get dwFunParam_1() : UInt32

public function set dwFunParam_1(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunParam_2 Property

Apax5000Config.dwFunParam_2 Property
[image]

Function parameter 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_2 As UInt32
C#
public uint dwFunParam_2 { get; set; }
C++
public property uint dwFunParam_2 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_2();

/** property */
public void set_dwFunParam_2(uint value);
JScript
public function get dwFunParam_2() : UInt32

public function set dwFunParam_2(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunParam_3 Property

Apax5000Config.dwFunParam_3 Property
[image]

Function parameter 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_3 As UInt32
C#
public uint dwFunParam_3 { get; set; }
C++
public property uint dwFunParam_3 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_3();

/** property */
public void set_dwFunParam_3(uint value);
JScript
public function get dwFunParam_3() : UInt32

public function set dwFunParam_3(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwFunParam_4 Property

Apax5000Config.dwFunParam_4 Property
[image]

Function parameter 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwFunParam_4 As UInt32
C#
public uint dwFunParam_4 { get; set; }
C++
public property uint dwFunParam_4 sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwFunParam_4();

/** property */
public void set_dwFunParam_4(uint value);
JScript
public function get dwFunParam_4() : UInt32

public function set dwFunParam_4(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


dwModName Property

Apax5000Config.dwModName Property
[image]

Module Name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property dwModName As UInt32
C#
public uint dwModName { get; set; }
C++
public property uint dwModName sealed {
unsigned int get();
void set(unsigned int value);
}
J#
/** property */
public uint get_dwModName();

/** property */
public void set_dwModName(uint value);
JScript
public function get dwModName() : UInt32

public function set dwModName(value : UInt32);

See Also

Apax5000Config Class
Advantech.Adam Namespace


Handle Property

Apax5000Config.Handle Property
[image]

Handle

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As IntPtr
C#
public IntPtr Handle { get; }
C++
public property IntPtr Handle sealed {
IntPtr get();
}
J#
/** property */
public IntPtr get_Handle();
JScript
public function get Handle() : IntPtr

See Also

Apax5000Config Class
Advantech.Adam Namespace


HwIoTotal Property

Apax5000Config.HwIoTotal Property
[image]

No. of Hardware I/O Type 0-4 Channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HwIoTotal As Byte()
C#
public byte[] HwIoTotal { get; }
C++
public property byte[] HwIoTotal sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_HwIoTotal();
JScript
public function get HwIoTotal() : Byte[]

See Also

Apax5000Config Class
Advantech.Adam Namespace


HwIoType Property

Apax5000Config.HwIoType Property
[image]

Hardware I/O Type 0-4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HwIoType As Byte()
C#
public byte[] HwIoType { get; }
C++
public property byte[] HwIoType sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_HwIoType();
JScript
public function get HwIoType() : Byte[]

See Also

Apax5000Config Class
Advantech.Adam Namespace


HwIoType_TotalRange Property

Apax5000Config.HwIoType_TotalRange Property
[image]

Total # of Supported I/O Range 0-4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HwIoType_TotalRange As Byte()
C#
public byte[] HwIoType_TotalRange { get; }
C++
public property byte[] HwIoType_TotalRange sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_HwIoType_TotalRange();
JScript
public function get HwIoType_TotalRange() : Byte[]

See Also

Apax5000Config Class
Advantech.Adam Namespace


Length Property

Apax5000Config.Length Property
[image]

ApaxSlotInfo size length

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Length As Integer
C#
public static int Length { get; }
C++
public static property int Length {
int get();
}
J#
/** property */
public int get_Length();
JScript
public function get Length() : int

See Also

Apax5000Config Class
Advantech.Adam Namespace


wChRange Property

Apax5000Config.wChRange Property
[image]

Current I/O Type (array size:32)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wChRange As UInt16()
C#
public ushort[] wChRange { get; set; }
C++
public property ushort[] wChRange sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wChRange();

/** property */
public void set_wChRange(ushort[] value);
JScript
public function get wChRange() : UInt16[]

public function set wChRange(value : UInt16[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wDevType Property

Apax5000Config.wDevType Property
[image]

Device Type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wDevType As UInt16
C#
public ushort wDevType { get; set; }
C++
public property ushort wDevType sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wDevType();

/** property */
public void set_wDevType(ushort value);
JScript
public function get wDevType() : UInt16

public function set wDevType(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wExtLength Property

Apax5000Config.wExtLength Property
[image]

Extension Bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wExtLength As UInt16
C#
public ushort wExtLength { get; set; }
C++
public property ushort wExtLength sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wExtLength();

/** property */
public void set_wExtLength(ushort value);
JScript
public function get wExtLength() : UInt16

public function set wExtLength(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wFwVerNo Property

Apax5000Config.wFwVerNo Property
[image]

Firmware Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wFwVerNo As UInt16
C#
public ushort wFwVerNo { get; set; }
C++
public property ushort wFwVerNo sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wFwVerNo();

/** property */
public void set_wFwVerNo(ushort value);
JScript
public function get wFwVerNo() : UInt16

public function set wFwVerNo(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_0_End Property

Apax5000Config.wHwIoType_0_End Property
[image]

Hardware I/O Type 0 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_End As UInt16
C#
public ushort wHwIoType_0_End { get; set; }
C++
public property ushort wHwIoType_0_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_0_End();

/** property */
public void set_wHwIoType_0_End(ushort value);
JScript
public function get wHwIoType_0_End() : UInt16

public function set wHwIoType_0_End(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_0_Range Property

Apax5000Config.wHwIoType_0_Range Property
[image]

Supported I/O Range 0 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_Range As UInt16()
C#
public ushort[] wHwIoType_0_Range { get; set; }
C++
public property ushort[] wHwIoType_0_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_0_Range();

/** property */
public void set_wHwIoType_0_Range(ushort[] value);
JScript
public function get wHwIoType_0_Range() : UInt16[]

public function set wHwIoType_0_Range(value : UInt16[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_0_Resolution Property

Apax5000Config.wHwIoType_0_Resolution Property
[image]

Resolution 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_Resolution As Byte
C#
public byte wHwIoType_0_Resolution { get; set; }
C++
public property byte wHwIoType_0_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_0_Resolution();

/** property */
public void set_wHwIoType_0_Resolution(byte value);
JScript
public function get wHwIoType_0_Resolution() : Byte

public function set wHwIoType_0_Resolution(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_0_Start Property

Apax5000Config.wHwIoType_0_Start Property
[image]

Hardware I/O Type 0 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_Start As UInt16
C#
public ushort wHwIoType_0_Start { get; set; }
C++
public property ushort wHwIoType_0_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_0_Start();

/** property */
public void set_wHwIoType_0_Start(ushort value);
JScript
public function get wHwIoType_0_Start() : UInt16

public function set wHwIoType_0_Start(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_0_TotalRange Property

Apax5000Config.wHwIoType_0_TotalRange Property
[image]

Total # of Supported I/O Range 0

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_0_TotalRange As Byte
C#
public byte wHwIoType_0_TotalRange { get; set; }
C++
public property byte wHwIoType_0_TotalRange sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_0_TotalRange();

/** property */
public void set_wHwIoType_0_TotalRange(byte value);
JScript
public function get wHwIoType_0_TotalRange() : Byte

public function set wHwIoType_0_TotalRange(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_1_End Property

Apax5000Config.wHwIoType_1_End Property
[image]

Hardware I/O Type 1 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_End As UInt16
C#
public ushort wHwIoType_1_End { get; set; }
C++
public property ushort wHwIoType_1_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_1_End();

/** property */
public void set_wHwIoType_1_End(ushort value);
JScript
public function get wHwIoType_1_End() : UInt16

public function set wHwIoType_1_End(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_1_Range Property

Apax5000Config.wHwIoType_1_Range Property
[image]

Supported I/O Range 1 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_Range As UInt16()
C#
public ushort[] wHwIoType_1_Range { get; set; }
C++
public property ushort[] wHwIoType_1_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_1_Range();

/** property */
public void set_wHwIoType_1_Range(ushort[] value);
JScript
public function get wHwIoType_1_Range() : UInt16[]

public function set wHwIoType_1_Range(value : UInt16[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_1_Resolution Property

Apax5000Config.wHwIoType_1_Resolution Property
[image]

Resolution 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_Resolution As Byte
C#
public byte wHwIoType_1_Resolution { get; set; }
C++
public property byte wHwIoType_1_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_1_Resolution();

/** property */
public void set_wHwIoType_1_Resolution(byte value);
JScript
public function get wHwIoType_1_Resolution() : Byte

public function set wHwIoType_1_Resolution(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_1_Start Property

Apax5000Config.wHwIoType_1_Start Property
[image]

Hardware I/O Type 1 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_Start As UInt16
C#
public ushort wHwIoType_1_Start { get; set; }
C++
public property ushort wHwIoType_1_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_1_Start();

/** property */
public void set_wHwIoType_1_Start(ushort value);
JScript
public function get wHwIoType_1_Start() : UInt16

public function set wHwIoType_1_Start(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_1_TotalRange Property

Apax5000Config.wHwIoType_1_TotalRange Property
[image]

Total # of Supported I/O Range 1

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_1_TotalRange As Byte
C#
public byte wHwIoType_1_TotalRange { get; set; }
C++
public property byte wHwIoType_1_TotalRange sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_1_TotalRange();

/** property */
public void set_wHwIoType_1_TotalRange(byte value);
JScript
public function get wHwIoType_1_TotalRange() : Byte

public function set wHwIoType_1_TotalRange(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_2_End Property

Apax5000Config.wHwIoType_2_End Property
[image]

Hardware I/O Type 2 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_End As UInt16
C#
public ushort wHwIoType_2_End { get; set; }
C++
public property ushort wHwIoType_2_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_2_End();

/** property */
public void set_wHwIoType_2_End(ushort value);
JScript
public function get wHwIoType_2_End() : UInt16

public function set wHwIoType_2_End(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_2_Range Property

Apax5000Config.wHwIoType_2_Range Property
[image]

Supported I/O Range 2 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_Range As UInt16()
C#
public ushort[] wHwIoType_2_Range { get; set; }
C++
public property ushort[] wHwIoType_2_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_2_Range();

/** property */
public void set_wHwIoType_2_Range(ushort[] value);
JScript
public function get wHwIoType_2_Range() : UInt16[]

public function set wHwIoType_2_Range(value : UInt16[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_2_Resolution Property

Apax5000Config.wHwIoType_2_Resolution Property
[image]

Resolution 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_Resolution As Byte
C#
public byte wHwIoType_2_Resolution { get; set; }
C++
public property byte wHwIoType_2_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_2_Resolution();

/** property */
public void set_wHwIoType_2_Resolution(byte value);
JScript
public function get wHwIoType_2_Resolution() : Byte

public function set wHwIoType_2_Resolution(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_2_Start Property

Apax5000Config.wHwIoType_2_Start Property
[image]

Hardware I/O Type 2 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_Start As UInt16
C#
public ushort wHwIoType_2_Start { get; set; }
C++
public property ushort wHwIoType_2_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_2_Start();

/** property */
public void set_wHwIoType_2_Start(ushort value);
JScript
public function get wHwIoType_2_Start() : UInt16

public function set wHwIoType_2_Start(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_2_TotalRange Property

Apax5000Config.wHwIoType_2_TotalRange Property
[image]

Total # of Supported I/O Range 2

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_2_TotalRange As Byte
C#
public byte wHwIoType_2_TotalRange { get; set; }
C++
public property byte wHwIoType_2_TotalRange sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_2_TotalRange();

/** property */
public void set_wHwIoType_2_TotalRange(byte value);
JScript
public function get wHwIoType_2_TotalRange() : Byte

public function set wHwIoType_2_TotalRange(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_3_End Property

Apax5000Config.wHwIoType_3_End Property
[image]

Hardware I/O Type 3 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_End As UInt16
C#
public ushort wHwIoType_3_End { get; set; }
C++
public property ushort wHwIoType_3_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_3_End();

/** property */
public void set_wHwIoType_3_End(ushort value);
JScript
public function get wHwIoType_3_End() : UInt16

public function set wHwIoType_3_End(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_3_Range Property

Apax5000Config.wHwIoType_3_Range Property
[image]

Supported I/O Range 3 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_Range As UInt16()
C#
public ushort[] wHwIoType_3_Range { get; set; }
C++
public property ushort[] wHwIoType_3_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_3_Range();

/** property */
public void set_wHwIoType_3_Range(ushort[] value);
JScript
public function get wHwIoType_3_Range() : UInt16[]

public function set wHwIoType_3_Range(value : UInt16[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_3_Resolution Property

Apax5000Config.wHwIoType_3_Resolution Property
[image]

Resolution 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_Resolution As Byte
C#
public byte wHwIoType_3_Resolution { get; set; }
C++
public property byte wHwIoType_3_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_3_Resolution();

/** property */
public void set_wHwIoType_3_Resolution(byte value);
JScript
public function get wHwIoType_3_Resolution() : Byte

public function set wHwIoType_3_Resolution(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_3_Start Property

Apax5000Config.wHwIoType_3_Start Property
[image]

Hardware I/O Type 3 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_Start As UInt16
C#
public ushort wHwIoType_3_Start { get; set; }
C++
public property ushort wHwIoType_3_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_3_Start();

/** property */
public void set_wHwIoType_3_Start(ushort value);
JScript
public function get wHwIoType_3_Start() : UInt16

public function set wHwIoType_3_Start(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_3_TotalRange Property

Apax5000Config.wHwIoType_3_TotalRange Property
[image]

Total # of Supported I/O Range 3

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_3_TotalRange As Byte
C#
public byte wHwIoType_3_TotalRange { get; set; }
C++
public property byte wHwIoType_3_TotalRange sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_3_TotalRange();

/** property */
public void set_wHwIoType_3_TotalRange(byte value);
JScript
public function get wHwIoType_3_TotalRange() : Byte

public function set wHwIoType_3_TotalRange(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_4_End Property

Apax5000Config.wHwIoType_4_End Property
[image]

Hardware I/O Type 4 Data Reg. Address Range End

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_End As UInt16
C#
public ushort wHwIoType_4_End { get; set; }
C++
public property ushort wHwIoType_4_End sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_4_End();

/** property */
public void set_wHwIoType_4_End(ushort value);
JScript
public function get wHwIoType_4_End() : UInt16

public function set wHwIoType_4_End(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_4_Range Property

Apax5000Config.wHwIoType_4_Range Property
[image]

Supported I/O Range 4 (array size:36)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_Range As UInt16()
C#
public ushort[] wHwIoType_4_Range { get; set; }
C++
public property ushort[] wHwIoType_4_Range sealed {
array<unsigned short>^ get();
void set(array<unsigned short>^ value);
}
J#
/** property */
public ushort[] get_wHwIoType_4_Range();

/** property */
public void set_wHwIoType_4_Range(ushort[] value);
JScript
public function get wHwIoType_4_Range() : UInt16[]

public function set wHwIoType_4_Range(value : UInt16[]);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_4_Resolution Property

Apax5000Config.wHwIoType_4_Resolution Property
[image]

Resolution 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_Resolution As Byte
C#
public byte wHwIoType_4_Resolution { get; set; }
C++
public property byte wHwIoType_4_Resolution sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_4_Resolution();

/** property */
public void set_wHwIoType_4_Resolution(byte value);
JScript
public function get wHwIoType_4_Resolution() : Byte

public function set wHwIoType_4_Resolution(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_4_Start Property

Apax5000Config.wHwIoType_4_Start Property
[image]

Hardware I/O Type 4 Data Reg. Address Range Start

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_Start As UInt16
C#
public ushort wHwIoType_4_Start { get; set; }
C++
public property ushort wHwIoType_4_Start sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwIoType_4_Start();

/** property */
public void set_wHwIoType_4_Start(ushort value);
JScript
public function get wHwIoType_4_Start() : UInt16

public function set wHwIoType_4_Start(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwIoType_4_TotalRange Property

Apax5000Config.wHwIoType_4_TotalRange Property
[image]

Total # of Supported I/O Range 4

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwIoType_4_TotalRange As Byte
C#
public byte wHwIoType_4_TotalRange { get; set; }
C++
public property byte wHwIoType_4_TotalRange sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_wHwIoType_4_TotalRange();

/** property */
public void set_wHwIoType_4_TotalRange(byte value);
JScript
public function get wHwIoType_4_TotalRange() : Byte

public function set wHwIoType_4_TotalRange(value : Byte);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wHwVer Property

Apax5000Config.wHwVer Property
[image]

Hardware Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wHwVer As UInt16
C#
public ushort wHwVer { get; set; }
C++
public property ushort wHwVer sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wHwVer();

/** property */
public void set_wHwVer(ushort value);
JScript
public function get wHwVer() : UInt16

public function set wHwVer(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wMsgType Property

Apax5000Config.wMsgType Property
[image]

Message Type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wMsgType As UInt16
C#
public ushort wMsgType { get; set; }
C++
public property ushort wMsgType sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wMsgType();

/** property */
public void set_wMsgType(ushort value);
JScript
public function get wMsgType() : UInt16

public function set wMsgType(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wPktVer Property

Apax5000Config.wPktVer Property
[image]

Packet Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wPktVer As UInt16
C#
public ushort wPktVer { get; set; }
C++
public property ushort wPktVer sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wPktVer();

/** property */
public void set_wPktVer(ushort value);
JScript
public function get wPktVer() : UInt16

public function set wPktVer(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wProtoVer Property

Apax5000Config.wProtoVer Property
[image]

Protocol Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wProtoVer As UInt16
C#
public ushort wProtoVer { get; set; }
C++
public property ushort wProtoVer sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wProtoVer();

/** property */
public void set_wProtoVer(ushort value);
JScript
public function get wProtoVer() : UInt16

public function set wProtoVer(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wSeqNo Property

Apax5000Config.wSeqNo Property
[image]

Sequence Number

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wSeqNo As UInt16
C#
public ushort wSeqNo { get; set; }
C++
public property ushort wSeqNo sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wSeqNo();

/** property */
public void set_wSeqNo(ushort value);
JScript
public function get wSeqNo() : UInt16

public function set wSeqNo(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


wSupportFwVer Property

Apax5000Config.wSupportFwVer Property
[image]

Supported Controller's Firmware Version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Property wSupportFwVer As UInt16
C#
public ushort wSupportFwVer { get; set; }
C++
public property ushort wSupportFwVer sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_wSupportFwVer();

/** property */
public void set_wSupportFwVer(ushort value);
JScript
public function get wSupportFwVer() : UInt16

public function set wSupportFwVer(value : UInt16);

See Also

Apax5000Config Class
Advantech.Adam Namespace


Methods

Apax5000Config Methods
[image]

Public Methods

 | Name | Description
Public method | GetExtBuf | Get Extension buffer value
Public method | GetModuleName | Get the module name string.
Public method | SetExtBuf | Set Extension buffer value
Top

Protected Methods

 | Name | Description
Family method | Get | (inherited from SelfMarshalledStruct)
Family method | GetByte | (inherited from SelfMarshalledStruct)
Family method | GetChar | (inherited from SelfMarshalledStruct)
Family method | GetInt16 | (inherited from SelfMarshalledStruct)
Family method | GetInt32 | (inherited from SelfMarshalledStruct)
Family method | GetIntPtr | (inherited from SelfMarshalledStruct)
Family method | GetSlice | (inherited from SelfMarshalledStruct)
Family method | GetStringAscii | (inherited from SelfMarshalledStruct)
Family method | GetStringUni | (inherited from SelfMarshalledStruct)
Family method | GetUInt16 | (inherited from SelfMarshalledStruct)
Family method | GetUInt32 | (inherited from SelfMarshalledStruct)
Family method | Set | (inherited from SelfMarshalledStruct)
Family method | SetByte | (inherited from SelfMarshalledStruct)
Family method | SetChar | (inherited from SelfMarshalledStruct)
Family method | SetInt16 | (inherited from SelfMarshalledStruct)
Family method | SetInt32 | (inherited from SelfMarshalledStruct)
Family method | SetIntPtr | (inherited from SelfMarshalledStruct)
Family method | SetStringUni | (inherited from SelfMarshalledStruct)
Family method | SetUInt16 | (inherited from SelfMarshalledStruct)
Family method | SetUInt32 | (inherited from SelfMarshalledStruct)
Top

See Also

Apax5000Config Class
Advantech.Adam Namespace


GetExtBuf Method

Apax5000Config.GetExtBuf Method
[image]

Get Extension buffer value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExtBuf( _
ByVal idx As Integer _
) As Byte
C#
public byte GetExtBuf(
int idx
)
C++
public:
char GetExtBuf(
int idx
) sealed
J#
public byte GetExtBuf(
int idx
)
JScript
public function GetExtBuf(
idx : int
) : Byte

Parameters

idx
Extension buffer index

See Also

Apax5000Config Class
Advantech.Adam Namespace


GetModuleName Method

Apax5000Config.GetModuleName Method
[image]

Get the module name string.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleName() As String
C#
public string GetModuleName()
C++
public:
String GetModuleName() sealed
J#
public string GetModuleName()
JScript
public function GetModuleName() : String

See Also

Apax5000Config Class
Advantech.Adam Namespace


SetExtBuf Method

Apax5000Config.SetExtBuf Method
[image]

Set Extension buffer value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetExtBuf( _
ByVal idx As Integer, _
ByVal i_byVal As Byte _
)
C#
public void SetExtBuf(
int idx,
byte i_byVal
)
C++
public:
void SetExtBuf(
int idx,
char i_byVal
) sealed
J#
public void SetExtBuf(
int idx,
byte i_byVal
)
JScript
public function SetExtBuf(
idx : int,
i_byVal : Byte
)

Parameters

idx
Extension buffer index
i_byVal

See Also

Apax5000Config Class
Advantech.Adam Namespace


Apax5000Type Enumeration

Apax5000Type Enumeration
[image]

The APAX 5000 module type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Apax5000Type As
C#
public enum Apax5000Type : uint
C++
public enum class Apax5000Type : unsigned int
J#
public enum Apax5000Type uint
JScript
public enum Apax5000Type :

Members

Member Name | Description
Non | Non module
Apax5000 | APAX-5000
Apax5570 | APAX-5570
Apax5520 | APAX-5520
Apax5070 | APAX-5070
Apax5013 | APAX-5013
Apax5017 | APAX-5017
Apax5017H | APAX-5017H
Apax5017PE | APAX-5017PE
Apax5017PG | APAX-5017PG
Apax5018 | APAX-5018
Apax5028 | APAX-5028
Apax5040 | APAX-5040
Apax5040PE | APAX-5040PE
Apax5045 | APAX-5045
Apax5046 | APAX-5046
Apax5046SO | APAX-5046SO
Apax5060 | APAX-5060
Apax5060PE | APAX-5060PE
Apax5080 | APAX-5080
Apax5082 | APAX-5082
Apax5090 | APAX-5090
Apax5090P | APAX-5090P
Apax5095P | APAX-5095P
Apax5202P | APAX-5202P

See Also

Advantech.Adam Namespace


Apax5080_CounterMode Enumeration

Apax5080_CounterMode Enumeration
[image]

Adam5081 counter mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum Apax5080_CounterMode As
C#
public enum Apax5080_CounterMode : ushort
C++
public enum class Apax5080_CounterMode : unsigned short
J#
public enum Apax5080_CounterMode ushort
JScript
public enum Apax5080_CounterMode :

Members

Member Name | Description
Bi_Direction | Bi-directory mode
Up_Down | Up/Down mode
Up | Up mode
Frequency | Frequency mode
AB1X | A/B-1X mode
AB2X | A/B-2X mode
AB4X | A/B-4X mode
Unknown | Unknown

See Also

Advantech.Adam Namespace


ApaxUnknown_InputRange Enumeration

ApaxUnknown_InputRange Enumeration
[image]

Newly unknown Apax module input range code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum ApaxUnknown_InputRange As
C#
public enum ApaxUnknown_InputRange : ushort
C++
public enum class ApaxUnknown_InputRange : unsigned short
J#
public enum ApaxUnknown_InputRange ushort
JScript
public enum ApaxUnknown_InputRange :

Members

Member Name | Description
mV_Neg15To15 | +/- 15 mV
mV_Neg50To50 | +/- 50 mV
mV_Neg100To100 | +/- 100 mV
mV_Neg150To150 | +/- 150 mV
mV_Neg500To500 | +/- 500 mV
mV_0To150 | 0~150 mV
mV_0To500 | 0~500 mV
V_Neg1To1 | +/- 1 V
V_Neg2AndHalfTo2AndHalf | +/- 2.5 V
V_Neg5To5 | +/- 5 V
V_Neg10To10 | +/- 10 V
V_Neg15To15 | +/- 15 V
V_0To1 | 0~1 V
V_0To2AndHalf | 0~2.5 V
V_0To5 | 0~5 V
V_0To10 | 0~10 V
V_0To15 | 0~15 V
mA_4To20 | 4~20 mA
mA_Neg20To20 | +/- 20 mA
mA_0To20 | 0~20 mA
Bi_Direction | Bi-direction counter mode
Up_Down | Up/Down counter mode
Up | Up counter mode
HighFrequency | High Frequency counter mode
AB1X | A/B-1X counter mode
AB2X | A/B-2X counter mode
AB4X | A/B-4X counter mode
LowFrequency | Low Frequency counter mode
WaveWidth | Wave width counter mode
Pt100_3851_Neg200To850 | Pt100(3851) -200~850 'C
Pt100_3851_Neg120To130 | Pt100(3851) -120~130 'C
Pt100_3851_Neg200To200 | Pt100(3851) -200~200 'C
Pt100_3851_Neg100To100 | Pt100(3851) -100~100 'C
Pt100_3851_Neg50To150 | Pt100(3851) -50~150 'C
Pt100_3851_0To100 | Pt100(3851) 0~100 'C
Pt100_3851_0To200 | Pt100(3851) 0~200 'C
Pt100_3851_0To400 | Pt100(3851) 0~400 'C
Pt100_3851_0To600 | Pt100(3851) 0~600 'C
Pt200_3851_Neg200To850 | Pt200(3851) -200~850 'C
Pt200_3851_Neg120To130 | Pt200(3851) -120~130 'C
Pt500_3851_Neg200To850 | Pt500(3851) -200~850 'C
Pt500_3851_Neg120To130 | Pt500(3851) -120~130 'C
Pt1000_3851_Neg200To850 | Pt1000(3851) -200~850 'C
Pt1000_3851_Neg120To130 | Pt1000(3851) -120~130 'C
Pt1000_3851_Neg40To160 | Pt1000(3851) -40~160 'C
Pt100_3916_Neg200To850 | Pt100(3916) -200~850 'C
Pt100_3916_Neg120To130 | Pt100(3916) -120~130 'C
Pt100_3916_Neg200To200 | Pt100(3916) -200~200 'C
Pt100_3916_Neg100To100 | Pt100(3916) -100~100 'C
Pt100_3916_Neg50To150 | Pt100(3916) -50~150 'C
Pt100_3916_0To100 | Pt100(3916) 0~100 'C
Pt100_3916_0To200 | Pt100(3916) 0~200 'C
Pt100_3916_0To400 | Pt100(3916) 0~400 'C
Pt100_3916_0To600 | Pt100(3916) 0~600 'C
Pt200_3916_Neg200To850 | Pt200(3916) -200~850 'C
Pt200_3916_Neg120To130 | Pt200(3916) -120~130 'C
Pt500_3916_Neg200To850 | Pt500(3916) -200~850 'C
Pt500_3916_Neg120To130 | Pt500(3916) -120~130 'C
Pt1000_3916_Neg200To850 | Pt1000(3916) -200~850 'C
Pt1000_3916_Neg120To130 | Pt1000(3916) -120~130 'C
Pt1000_3916_Neg40To160 | Pt1000(3916) -40~160 'C
Balco500_Neg30To120 | Balco500 -30~120 'C
Ni518_Neg80To100 | Ni518 -80~100 'C
Ni518_0To100 | Ni518 0~100 'C
Ni508_0To100 | Ni508 0~100 'C
Ni508_Neg50To200 | Ni508 -50~200 'C
Thermistor_3K_0To100 | Thermistor 3K 0~100 'C
Thermistor_10K_0To100 | Thermistor 10K 0~100 'C
Thermistor_10K_Neg50To100 | Thermistor 10K -50~100 'C
Jtype_0To760C | T/C J type 0~760 'C
Jtype_Neg210To1200C | T/C J type -200~1200 'C
Ktype_0To1370C | T/C K type 0~1370 'C
Ktype_Neg270To1372C | T/C K type -270~1372 'C
Ktype_Neg230To1372C | T/C K type -230~1372 'C
Ttype_Neg100To400C | T/C T type -100~400 'C
Ttype_Neg270To400C | T/C T type -270~400 'C
Ttype_Neg230To400C | T/C T type -230~400 'C
Etype_0To1000C | T/C E type 0~1000 'C
Etype_Neg270To1000C | T/C E type -270~1000 'C
Etype_Neg230To1000C | T/C E type -230~1000 'C
Rtype_500To1750C | T/C R type 500~1750 'C
Rtype_0To1768C | T/C R type 0~1768 'C
Rtype_0To1750C | T/C R type 0~1750 'C
Rtype_Neg50To1768C | T/C R type -50~1768 'C
Stype_500To1750C | T/C S type 500~1750 'C
Stype_0To1768C | T/C S type 0~1768 'C
Stype_Neg50To1768C | T/C S type -50~1768 'C
Btype_500To1800C | T/C B type 500~1800 'C
Btype_200To1820C | T/C B type 200~1820 'C
Btype_0To1820C | T/C B type 0~1820 'C
Ntype_Neg270To1300C | T/C N type -270~1300 'C
TemperatureSensor_Type0 | TemperatureSensor Type 0
HumiditySensor_Type0 | HumiditySensor Type 0
LightSensor_Type0 | LightSensor Type 0
CO2Sensor_Type0 | CO2Sensor Type 0
Unknown | Unknown range

See Also

Advantech.Adam Namespace


Configuration Class

Configuration Class
See Also Example Members
[image]

Configuration class for ADAM series running on ASCII command.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Configuration
Inherits AdamBase
C#
public class Configuration : AdamBase
C++
ref class Configuration : AdamBase
J#
public class Configuration extends AdamBase
JScript
public class Configuration extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.Configuration

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Configuration Members
Advantech.Adam Namespace


Configuration Members

Configuration Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

Configuration class for ADAM series running on ASCII command.

The following tables list the members exposed by Configuration.

Public Constructors

Name | Description
Configuration | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | ChangePassword | Support module: ADAM-5000TCP, ADAM-6000 Change the password. This command only supports TCP connection, DO NOT USE UDP!
Public method | ClearAlarmLatch | Clear Alarm Latch. Support module: APAX-5070
Public method | FinishModbusAddressConfig | Support module: ADAM-5000 Finish MODBUS address configuration.
Public method | GetAccessControl_Config | Support module: ADAM-6000/W AI/DIO module Get IO access control security configuration.
Public method | GetAIOFirmwareVer | Support module: ADAM-6200 Get the ADAM mdoule AIO firmware version.
Public method | GetAlarmInfoSetting | Get Alarm enable mask. Support module: APAX-5070
Public method | GetAlarmLatchStatus | Get Alarm Latch Status. Support module: APAX-5070
 | GetBaudrateCode | Get the baudrate code.
 | GetBaudrateIndex | Get the baudrate index
 | GetBaudrateName | Get the baudrate name
 | GetBaudrateTotal | Get the baudrate total
Public method | GetCommunicationSafety | Support module: ADAM-4024 Get communication safety timeout in seconds
Public method | GetDataStreamingInterval | Support module: ADAM-5000TCP, ADAM-6000, APAX-5070 Get the interval for data streaming sending
Public method | GetDataStreamingIP | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Get the IP address that set for data streaming receiver.
Public method | GetDataStreamingMask | Overloaded. Support module: APAX-5070 Get the enabled mask for data streaming receiver.
Public method | GetDatastreamPort | Get datastream port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05), ADAM-5000 (V1.427)
Public method | GetEventTriggerMask | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Get the event trigger mask for all channels
Public method | GetEventTriggerPort | Get eventtrigger port setting. Support: ADAM-5000
Public method | GetFirmwareVer | Support module: ADAM-4000, ADAM-4100, ADAM-5000, ADAM-5000TCP, ADAM-6000 Get the ADAM mdoule firmware version.
Public method | GetFpgaVersion | Support module: APAX-5000, APAX-5070 Get FPGA version.
Public method | GetGCL_AuxFlagStatus | Support module: ADAM-6000 DIO module Get GCL Auxiliary Flag Status
Public method | GetModbusAddressConfig | Support module: ADAM-5000 Get MODBUS address configuration.
Public method | GetModbusAddressMode | Support module: ADAM-5000, APAX-5070 Get MODBUS address mode
Public method | GetModuleCOMConfig | Overloaded. Support module: ADAM-4100, ADAM-5000 Get module COM configuration.
Public method | GetModuleCOMTcpPortMapping | Support module: APAX-5090 Get module COM (COM1~COM4) TCP port mapping values.
Public method | GetModuleConfig | Overloaded. Support module: ADAM-4000 Get module configuration.
Public method | GetModuleCurrentChMsk | Support module: APAX-5070 Get APAX-5000 module current channel enabled mask.
Public method | GetModuleCurrentRange | Support module: APAX-5070 Get APAX-5000 module current range.
Public method | GetModuleFunPara | Support module: APAX-5070 Get module function parameters.
Public method | GetModuleGroupSetting | Support module: APAX-5070 Get module group setting.
Public method | GetModuleName | Support module: ADAM-4000, ADAM-4100, ADAM-5000, ADAM-5000TCP, ADAM-6000 Get the ADAM mdoule name.
Public method | GetModuleTotalRange | Support module: APAX-5070 Get APAX-5000 module supported total range.
Public method | GetModuleVersion | Support Platform: ADAM-5000TCP after V1.424 Get the ADAM IO mdoule name. Support IO module: ADAM-5081.
Public method | GetNetworkDiagEnable | Get the network diagnostic enable flag. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | GetP2P_Config | Overloaded. Support module: ADAM-6000/W Digital Input/Output module Get Peer to Peer configuration.
Public method | GetP2pGclPort | Get P2P/GCL port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | GetP2PValueStatus | Overloaded. Get P2P mapping value status. Support module: ADAM-6017 (after V4.05)
Public method | GetSlotInfo | Overloaded. Support module: ADAM-5000, ADAM-5000TCP, ADAM-5550 Get the slot information
Public method | GetSlotName | Support module: APAX-5000 Get the slot information
 | GetSupportDeviceNames | Overloaded. Get ADAM-4000/5000/6000 support device names
Public method | GetThermocoupleMode | Support module: ADAM-4100 Get Thermocouple mode.
Public method | GetWDTMask | Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout mask.
Public method | GetWDTTimeout | Overloaded. Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout value in seconds
Public method | GetWirelessAPInfo | Support module: ADAM-6000W Get AP information by index.
Public method | GetWirelessAPTotal | Support module: ADAM-6000W Get wireless AP total.
Public method | IsValidPassword | Support module: ADAM-5000TCP, ADAM-6000 Validate the password. This command only supports TCP connection, DO NOT USE UDP!
Public method | OUT_FlushBufValues | APAX API. Set the slot buffer mask flags.
Public method | OUT_GetSafetyEnable | APAX API. Support module: APAX-5000, APAX-5070 Get safety enable flag.
Public method | OUT_SetSafetyEnable | APAX API. Support module: APAX-5000, APAX-5070 Set safety enable flag.
 | ParseVersion | Parsing the version string
Public method | ResetPassword | Support module: ADAM-6000 Reset the password to "00000000" This command only supports TCP connection, DO NOT USE UDP!
Public method | SetAccessControl_Config | Support module: ADAM-6000/W AI/DIO module Set IO access control security configuration.
Public method | SetAlarmInfoSetting | Set Alarm enable mask. Support module: APAX-5070
Public method | SetCommunicationSafety | Support module: ADAM-4024 Set communication safety timeout in seconds
Public method | SetDataStreamingInterval | Support module: ADAM-5000TCP, ADAM-6000 Set the interval for data streaming sending
Public method | SetDataStreamingIP | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Set the data streaming receiver's IP
Public method | SetDataStreamingMask | Overloaded. Support module: APAX-5070 Set the enabled mask for data streaming receiver.
Public method | SetDatastreamPort | Set datastream port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05), ADAM-5000 (V1.427), APAX-5070
Public method | SetEventTriggerMask | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Set the event trigger mask for all channels
Public method | SetEventTriggerPort | Set event trigger port setting. Support: ADAM-5000 (V1.427)
Public method | SetGCL_AuxFlagStatus | Overloaded. Support module: ADAM-6000 DIO module Set GCL Auxiliary Flag Status
Public method | SetModbusAddressConfig | Support module: ADAM-5000 Set MODBUS address configuration.
Public method | SetModuleCOMConfig | Overloaded. Support module: ADAM-4100, ADAM-5000 Set module COM configuration.
Public method | SetModuleCOMTcpPortMapping | Support module: APAX-5090 Set module COM (COM1~COM4) TCP port mapping values.
Public method | SetModuleConfig | Overloaded. Support module: ADAM-4000 Set module configuration.
Public method | SetModuleGroupSetting | Support module: APAX-5070 Set module group setting.
Public method | SetModuleLocated | Support module: ADAM-4100 Set module located LED.
Public method | SetNetworkDiagEnable | Set the network diagnostic enable flag. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | SetP2P_Config | Overloaded. Support module: ADAM-6000/W Digital Input/Output module Set Peer to Peer configuration.
Public method | SetP2pGclPort | Set P2P/GCL port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | SetP2PValueStatus | Overloaded. Set P2P mapping value status. Support module: ADAM-6017 (after V4.05)
Public method | SetThermocoupleMode | Support module: ADAM-4100 Set Thermocouple mode.
Public method | SetWDTMask | Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout mask.
Public method | SetWDTTimeout | Overloaded. Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout value in seconds
Public method | SYS_GetAllSlotErrorFlag | APAX API. Support module: APAX-5000 Get all slot error flags.
Public method | SYS_GetAppAStatus | APAX API. Backup System: Get the application A status.
Public method | SYS_GetAppBStatus | APAX API. Backup System: Get the application B status.
Public method | SYS_GetArmFirmwareVersion | Support module: ADAM-5550 Get the ARM firmware version
Public method | SYS_GetCPLDVersion | Support module: ADAM-5550 Get the CPLD version
Public method | SYS_GetDspChannelFlag | Overloaded. APAX API. Get dsp channel flag.
Public method | SYS_GetGlobalActive | APAX API. Backup System: Get the global machine ID.
Public method | SYS_GetGlobalMachineID | APAX API. Backup System: Get the global machine ID.
Public method | SYS_GetGlobalStatus | APAX API. Backup System: Get the global status.
Public method | SYS_GetHeartbeatRun | APAX API. Backup System: Set the heartbeat run mode.
Public method | SYS_GetRawData | Support module: APAX-5000 Get the raw data of DPM.
Public method | SYS_GetVersion | APAX API. Get the driver version.
Public method | SYS_SetAppAHeartbeat | APAX API. Backup System: Set the application A heartbeat.
Public method | SYS_SetAppBHeartbeat | APAX API. Backup System: Set the application B heartbeat.
Public method | SYS_SetCmdWriteRead | APAX API. Internal used. DO NOT call this function in your program.
Public method | SYS_SetCommLock | APAX API. Internal used. DO NOT call this function in your program.
Public method | SYS_SetDownloadMode | APAX API. Support module: APAX-5000, APAX-5070 Set download mode. (Internal use)
Public method | SYS_SetDownloadPacket | APAX API. Support module: APAX-5000 Set download data packet. (Internal use)
Public method | SYS_SetDownloadStart | APAX API. Support module: APAX-5000 Set download start flag. (Internal use)
Public method | SYS_SetDspChannelFlag | Overloaded. APAX API. Set dsp channel flag.
Public method | SYS_SetGlobalHeartbeat | APAX API. Backup System: Set the global heartbeat.
Public method | SYS_SetHeartbeatRun | APAX API. Backup System: Set the heartbeat run mode.
Public method | SYS_SetInnerTimeout | APAX API. Set the inner timeout.
Public method | SYS_SetLocateModule | APAX API. Set module locate function.
Public method | TOOL_SetCmdWrite5Read10 | APAX API. Internal used. DO NOT call this function in your program.
Public method | TOOL_SetCmdWriteReadRet | APAX API. Internal used. DO NOT call this function in your program.
Public method | VerifyAccessControl | Support module: ADAM-6000/W AI/DIO module Verify if this IP/MAC is valid security IP/MAC.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
Configuration | Overloaded.
Top

See Also

Configuration Class
Advantech.Adam Namespace


Configuration Constructor

Configuration Constructor

Overload List

 | Name | Description
Public method | Configuration (AdamCom) | The Configuration constructor
Public method | Configuration (AdamControl) | The Configuration constructor
Public method | Configuration (AdamSocket) | The Configuration constructor

See Also

Configuration Class
Advantech.Adam Namespace


Configuration Constructor (AdamCom)

Configuration Constructor (AdamCom)
See Also Example
[image]

The Configuration constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public Configuration(
AdamCom i_com
)
C++
public:
Configuration(
AdamCom i_com
) sealed
J#
public Configuration(
AdamCom i_com
)
JScript
public function Configuration(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object

See Also

Configuration Class
Advantech.Adam Namespace
Configuration Constructor Overload List


Configuration Constructor (AdamControl)

Configuration Constructor (AdamControl)
See Also Example
[image]

The Configuration constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public Configuration(
AdamControl i_control
)
C++
public:
Configuration(
AdamControl i_control
) sealed
J#
public Configuration(
AdamControl i_control
)
JScript
public function Configuration(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object

See Also

Configuration Class
Advantech.Adam Namespace
Configuration Constructor Overload List


Configuration Constructor (AdamSocket)

Configuration Constructor (AdamSocket)
See Also Example
[image]

The Configuration constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public Configuration(
AdamSocket i_socket
)
C++
public:
Configuration(
AdamSocket i_socket
) sealed
J#
public Configuration(
AdamSocket i_socket
)
JScript
public function Configuration(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object

See Also

Configuration Class
Advantech.Adam Namespace
Configuration Constructor Overload List


Methods

Configuration Methods
[image]

Public Methods

 | Name | Description
Public method | ChangePassword | Support module: ADAM-5000TCP, ADAM-6000 Change the password. This command only supports TCP connection, DO NOT USE UDP!
Public method | ClearAlarmLatch | Clear Alarm Latch. Support module: APAX-5070
Public method | FinishModbusAddressConfig | Support module: ADAM-5000 Finish MODBUS address configuration.
Public method | GetAccessControl_Config | Support module: ADAM-6000/W AI/DIO module Get IO access control security configuration.
Public method | GetAIOFirmwareVer | Support module: ADAM-6200 Get the ADAM mdoule AIO firmware version.
Public method | GetAlarmInfoSetting | Get Alarm enable mask. Support module: APAX-5070
Public method | GetAlarmLatchStatus | Get Alarm Latch Status. Support module: APAX-5070
 | GetBaudrateCode | Get the baudrate code.
 | GetBaudrateIndex | Get the baudrate index
 | GetBaudrateName | Get the baudrate name
 | GetBaudrateTotal | Get the baudrate total
Public method | GetCommunicationSafety | Support module: ADAM-4024 Get communication safety timeout in seconds
Public method | GetDataStreamingInterval | Support module: ADAM-5000TCP, ADAM-6000, APAX-5070 Get the interval for data streaming sending
Public method | GetDataStreamingIP | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Get the IP address that set for data streaming receiver.
Public method | GetDataStreamingMask | Overloaded. Support module: APAX-5070 Get the enabled mask for data streaming receiver.
Public method | GetDatastreamPort | Get datastream port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05), ADAM-5000 (V1.427)
Public method | GetEventTriggerMask | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Get the event trigger mask for all channels
Public method | GetEventTriggerPort | Get eventtrigger port setting. Support: ADAM-5000
Public method | GetFirmwareVer | Support module: ADAM-4000, ADAM-4100, ADAM-5000, ADAM-5000TCP, ADAM-6000 Get the ADAM mdoule firmware version.
Public method | GetFpgaVersion | Support module: APAX-5000, APAX-5070 Get FPGA version.
Public method | GetGCL_AuxFlagStatus | Support module: ADAM-6000 DIO module Get GCL Auxiliary Flag Status
Public method | GetModbusAddressConfig | Support module: ADAM-5000 Get MODBUS address configuration.
Public method | GetModbusAddressMode | Support module: ADAM-5000, APAX-5070 Get MODBUS address mode
Public method | GetModuleCOMConfig | Overloaded. Support module: ADAM-4100, ADAM-5000 Get module COM configuration.
Public method | GetModuleCOMTcpPortMapping | Support module: APAX-5090 Get module COM (COM1~COM4) TCP port mapping values.
Public method | GetModuleConfig | Overloaded. Support module: ADAM-4000 Get module configuration.
Public method | GetModuleCurrentChMsk | Support module: APAX-5070 Get APAX-5000 module current channel enabled mask.
Public method | GetModuleCurrentRange | Support module: APAX-5070 Get APAX-5000 module current range.
Public method | GetModuleFunPara | Support module: APAX-5070 Get module function parameters.
Public method | GetModuleGroupSetting | Support module: APAX-5070 Get module group setting.
Public method | GetModuleName | Support module: ADAM-4000, ADAM-4100, ADAM-5000, ADAM-5000TCP, ADAM-6000 Get the ADAM mdoule name.
Public method | GetModuleTotalRange | Support module: APAX-5070 Get APAX-5000 module supported total range.
Public method | GetModuleVersion | Support Platform: ADAM-5000TCP after V1.424 Get the ADAM IO mdoule name. Support IO module: ADAM-5081.
Public method | GetNetworkDiagEnable | Get the network diagnostic enable flag. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | GetP2P_Config | Overloaded. Support module: ADAM-6000/W Digital Input/Output module Get Peer to Peer configuration.
Public method | GetP2pGclPort | Get P2P/GCL port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | GetP2PValueStatus | Overloaded. Get P2P mapping value status. Support module: ADAM-6017 (after V4.05)
Public method | GetSlotInfo | Overloaded. Support module: ADAM-5000, ADAM-5000TCP, ADAM-5550 Get the slot information
Public method | GetSlotName | Support module: APAX-5000 Get the slot information
 | GetSupportDeviceNames | Overloaded. Get ADAM-4000/5000/6000 support device names
Public method | GetThermocoupleMode | Support module: ADAM-4100 Get Thermocouple mode.
Public method | GetWDTMask | Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout mask.
Public method | GetWDTTimeout | Overloaded. Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout value in seconds
Public method | GetWirelessAPInfo | Support module: ADAM-6000W Get AP information by index.
Public method | GetWirelessAPTotal | Support module: ADAM-6000W Get wireless AP total.
Public method | IsValidPassword | Support module: ADAM-5000TCP, ADAM-6000 Validate the password. This command only supports TCP connection, DO NOT USE UDP!
Public method | OUT_FlushBufValues | APAX API. Set the slot buffer mask flags.
Public method | OUT_GetSafetyEnable | APAX API. Support module: APAX-5000, APAX-5070 Get safety enable flag.
Public method | OUT_SetSafetyEnable | APAX API. Support module: APAX-5000, APAX-5070 Set safety enable flag.
 | ParseVersion | Parsing the version string
Public method | ResetPassword | Support module: ADAM-6000 Reset the password to "00000000" This command only supports TCP connection, DO NOT USE UDP!
Public method | SetAccessControl_Config | Support module: ADAM-6000/W AI/DIO module Set IO access control security configuration.
Public method | SetAlarmInfoSetting | Set Alarm enable mask. Support module: APAX-5070
Public method | SetCommunicationSafety | Support module: ADAM-4024 Set communication safety timeout in seconds
Public method | SetDataStreamingInterval | Support module: ADAM-5000TCP, ADAM-6000 Set the interval for data streaming sending
Public method | SetDataStreamingIP | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Set the data streaming receiver's IP
Public method | SetDataStreamingMask | Overloaded. Support module: APAX-5070 Set the enabled mask for data streaming receiver.
Public method | SetDatastreamPort | Set datastream port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05), ADAM-5000 (V1.427), APAX-5070
Public method | SetEventTriggerMask | Overloaded. Support module: ADAM-5000TCP, ADAM-6000 Set the event trigger mask for all channels
Public method | SetEventTriggerPort | Set event trigger port setting. Support: ADAM-5000 (V1.427)
Public method | SetGCL_AuxFlagStatus | Overloaded. Support module: ADAM-6000 DIO module Set GCL Auxiliary Flag Status
Public method | SetModbusAddressConfig | Support module: ADAM-5000 Set MODBUS address configuration.
Public method | SetModuleCOMConfig | Overloaded. Support module: ADAM-4100, ADAM-5000 Set module COM configuration.
Public method | SetModuleCOMTcpPortMapping | Support module: APAX-5090 Set module COM (COM1~COM4) TCP port mapping values.
Public method | SetModuleConfig | Overloaded. Support module: ADAM-4000 Set module configuration.
Public method | SetModuleGroupSetting | Support module: APAX-5070 Set module group setting.
Public method | SetModuleLocated | Support module: ADAM-4100 Set module located LED.
Public method | SetNetworkDiagEnable | Set the network diagnostic enable flag. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | SetP2P_Config | Overloaded. Support module: ADAM-6000/W Digital Input/Output module Set Peer to Peer configuration.
Public method | SetP2pGclPort | Set P2P/GCL port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)
Public method | SetP2PValueStatus | Overloaded. Set P2P mapping value status. Support module: ADAM-6017 (after V4.05)
Public method | SetThermocoupleMode | Support module: ADAM-4100 Set Thermocouple mode.
Public method | SetWDTMask | Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout mask.
Public method | SetWDTTimeout | Overloaded. Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout value in seconds
Public method | SYS_GetAllSlotErrorFlag | APAX API. Support module: APAX-5000 Get all slot error flags.
Public method | SYS_GetAppAStatus | APAX API. Backup System: Get the application A status.
Public method | SYS_GetAppBStatus | APAX API. Backup System: Get the application B status.
Public method | SYS_GetArmFirmwareVersion | Support module: ADAM-5550 Get the ARM firmware version
Public method | SYS_GetCPLDVersion | Support module: ADAM-5550 Get the CPLD version
Public method | SYS_GetDspChannelFlag | Overloaded. APAX API. Get dsp channel flag.
Public method | SYS_GetGlobalActive | APAX API. Backup System: Get the global machine ID.
Public method | SYS_GetGlobalMachineID | APAX API. Backup System: Get the global machine ID.
Public method | SYS_GetGlobalStatus | APAX API. Backup System: Get the global status.
Public method | SYS_GetHeartbeatRun | APAX API. Backup System: Set the heartbeat run mode.
Public method | SYS_GetRawData | Support module: APAX-5000 Get the raw data of DPM.
Public method | SYS_GetVersion | APAX API. Get the driver version.
Public method | SYS_SetAppAHeartbeat | APAX API. Backup System: Set the application A heartbeat.
Public method | SYS_SetAppBHeartbeat | APAX API. Backup System: Set the application B heartbeat.
Public method | SYS_SetCmdWriteRead | APAX API. Internal used. DO NOT call this function in your program.
Public method | SYS_SetCommLock | APAX API. Internal used. DO NOT call this function in your program.
Public method | SYS_SetDownloadMode | APAX API. Support module: APAX-5000, APAX-5070 Set download mode. (Internal use)
Public method | SYS_SetDownloadPacket | APAX API. Support module: APAX-5000 Set download data packet. (Internal use)
Public method | SYS_SetDownloadStart | APAX API. Support module: APAX-5000 Set download start flag. (Internal use)
Public method | SYS_SetDspChannelFlag | Overloaded. APAX API. Set dsp channel flag.
Public method | SYS_SetGlobalHeartbeat | APAX API. Backup System: Set the global heartbeat.
Public method | SYS_SetHeartbeatRun | APAX API. Backup System: Set the heartbeat run mode.
Public method | SYS_SetInnerTimeout | APAX API. Set the inner timeout.
Public method | SYS_SetLocateModule | APAX API. Set module locate function.
Public method | TOOL_SetCmdWrite5Read10 | APAX API. Internal used. DO NOT call this function in your program.
Public method | TOOL_SetCmdWriteReadRet | APAX API. Internal used. DO NOT call this function in your program.
Public method | VerifyAccessControl | Support module: ADAM-6000/W AI/DIO module Verify if this IP/MAC is valid security IP/MAC.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

Configuration Class
Advantech.Adam Namespace


ChangePassword Method

Configuration.ChangePassword Method
[image]

Support module: ADAM-5000TCP, ADAM-6000 Change the password. This command only supports TCP connection, DO NOT USE UDP!

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ChangePassword( _
ByVal i_szOldPassword As String, _
ByVal i_szNewPassword As String _
) As Boolean
C#
public bool ChangePassword(
string i_szOldPassword,
string i_szNewPassword
)
C++
public:
bool ChangePassword(
String i_szOldPassword,
String i_szNewPassword
) sealed
J#
public bool ChangePassword(
string i_szOldPassword,
string i_szNewPassword
)
JScript
public function ChangePassword(
i_szOldPassword : String,
i_szNewPassword : String
) : bool

Parameters

i_szOldPassword
The old password.
i_szNewPassword
The new password

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


ClearAlarmLatch Method

Configuration.ClearAlarmLatch Method
[image]

Clear Alarm Latch. Support module: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ClearAlarmLatch( _
ByVal i_bClearMask As Boolean() _
) As Boolean
C#
public bool ClearAlarmLatch(
bool[] i_bClearMask
)
C++
public:
bool ClearAlarmLatch(
array<bool>^ i_bClearMask
) sealed
J#
public bool ClearAlarmLatch(
bool[] i_bClearMask
)
JScript
public function ClearAlarmLatch(
i_bClearMask : bool[]
) : bool

Parameters

i_bClearMask
Alarm clear latch mask.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


FinishModbusAddressConfig Method

Configuration.FinishModbusAddressConfig Method
[image]

Support module: ADAM-5000 Finish MODBUS address configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function FinishModbusAddressConfig() As Boolean
C#
public bool FinishModbusAddressConfig()
C++
public:
bool FinishModbusAddressConfig() sealed
J#
public bool FinishModbusAddressConfig()
JScript
public function FinishModbusAddressConfig() : bool

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetAccessControl_Config Method

Configuration.GetAccessControl_Config Method
[image]

Support module: ADAM-6000/W AI/DIO module Get IO access control security configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAccessControl_Config( _
ByVal i_iIndex As Integer, _
<OutAttribute> ByRef o_bState As Boolean, _
<OutAttribute> ByRef o_iMode As Integer, _
<OutAttribute> ByRef o_byIP_MAC As Byte _
) As Boolean
C#
public bool GetAccessControl_Config(
int i_iIndex,
out bool o_bState,
out int o_iMode,
out byte o_byIP_MAC
)
C++
public:
bool GetAccessControl_Config(
int i_iIndex,
[OutAttribute] bool% o_bState,
[OutAttribute] int% o_iMode,
[OutAttribute] char% o_byIP_MAC
) sealed
J#
public bool GetAccessControl_Config(
int i_iIndex,
/** @attribute OutAttribute() */ /** @ref */ bool o_bState,
/** @attribute OutAttribute() */ /** @ref */ int o_iMode,
/** @attribute OutAttribute() */ /** @ref */ byte o_byIP_MAC
)
JScript
public function GetAccessControl_Config(
i_iIndex : int,
OutAttribute o_bState : bool,
OutAttribute o_iMode : int,
OutAttribute o_byIP_MAC : Byte
) : bool

Parameters

i_iIndex
Client index.
o_bState
Enable/Disable state.
o_iMode
IP(0) or MAC(1) mode
o_byIP_MAC
IP array(4) or MAC array(6)

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetAIOFirmwareVer Method

Configuration.GetAIOFirmwareVer Method
[image]

Support module: ADAM-6200 Get the ADAM mdoule AIO firmware version.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAIOFirmwareVer( _
<OutAttribute> ByRef o_szVer As String _
) As Boolean
C#
public bool GetAIOFirmwareVer(
out string o_szVer
)
C++
public:
bool GetAIOFirmwareVer(
[OutAttribute] String% o_szVer
) sealed
J#
public bool GetAIOFirmwareVer(
/** @attribute OutAttribute() */ /** @ref */ string o_szVer
)
JScript
public function GetAIOFirmwareVer(
OutAttribute o_szVer : String
) : bool

Parameters

o_szVer
The AIO firmware version.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetAlarmInfoSetting Method

Configuration.GetAlarmInfoSetting Method
[image]

Get Alarm enable mask. Support module: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAlarmInfoSetting( _
<OutAttribute> ByRef o_bEnable As Boolean, _
<OutAttribute> ByRef o_bType As Boolean, _
<OutAttribute> ByRef o_iMappingSlot As Integer, _
<OutAttribute> ByRef o_iMappingCh As Integer, _
<OutAttribute> ByRef o_iLimitValue As Integer, _
<OutAttribute> ByRef o_iBehaviorSlot As Integer, _
<OutAttribute> ByRef o_iBehaviorCh As Integer, _
<OutAttribute> ByRef o_iBehaviorOutputValue As Integer _
) As Boolean
C#
public bool GetAlarmInfoSetting(
out bool o_bEnable,
out bool o_bType,
out int o_iMappingSlot,
out int o_iMappingCh,
out int o_iLimitValue,
out int o_iBehaviorSlot,
out int o_iBehaviorCh,
out int o_iBehaviorOutputValue
)
C++
public:
bool GetAlarmInfoSetting(
[OutAttribute] bool% o_bEnable,
[OutAttribute] bool% o_bType,
[OutAttribute] int% o_iMappingSlot,
[OutAttribute] int% o_iMappingCh,
[OutAttribute] int% o_iLimitValue,
[OutAttribute] int% o_iBehaviorSlot,
[OutAttribute] int% o_iBehaviorCh,
[OutAttribute] int% o_iBehaviorOutputValue
) sealed
J#
public bool GetAlarmInfoSetting(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable,
/** @attribute OutAttribute() */ /** @ref */ bool o_bType,
/** @attribute OutAttribute() */ /** @ref */ int o_iMappingSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iMappingCh,
/** @attribute OutAttribute() */ /** @ref */ int o_iLimitValue,
/** @attribute OutAttribute() */ /** @ref */ int o_iBehaviorSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iBehaviorCh,
/** @attribute OutAttribute() */ /** @ref */ int o_iBehaviorOutputValue
)
JScript
public function GetAlarmInfoSetting(
OutAttribute o_bEnable : bool,
OutAttribute o_bType : bool,
OutAttribute o_iMappingSlot : int,
OutAttribute o_iMappingCh : int,
OutAttribute o_iLimitValue : int,
OutAttribute o_iBehaviorSlot : int,
OutAttribute o_iBehaviorCh : int,
OutAttribute o_iBehaviorOutputValue : int
) : bool

Parameters

o_bEnable
Alarm enable mask.
o_bType
Alarm type mask.
o_iMappingSlot
Alarm mapping slot.
o_iMappingCh
Alarm mapping channel.
o_iLimitValue
Alarm mapping limit value.
o_iBehaviorSlot
Alarm behavior target slot.
o_iBehaviorCh
Alarm behavior target ch.
o_iBehaviorOutputValue
Alarm behavior target output value.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetAlarmLatchStatus Method

Configuration.GetAlarmLatchStatus Method
[image]

Get Alarm Latch Status. Support module: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAlarmLatchStatus( _
<OutAttribute> ByRef o_bAlarmMask As Boolean _
) As Boolean
C#
public bool GetAlarmLatchStatus(
out bool o_bAlarmMask
)
C++
public:
bool GetAlarmLatchStatus(
[OutAttribute] bool% o_bAlarmMask
) sealed
J#
public bool GetAlarmLatchStatus(
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlarmMask
)
JScript
public function GetAlarmLatchStatus(
OutAttribute o_bAlarmMask : bool
) : bool

Parameters

o_bAlarmMask
Alarm latch status mask.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetBaudrateCode Method

Configuration.GetBaudrateCode Method
[image]

Get the baudrate code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBaudrateCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetBaudrateCode(
int i_iIndex
)
C++
public:
static char GetBaudrateCode(
int i_iIndex
)
J#
public static byte GetBaudrateCode(
int i_iIndex
)
JScript
public static function GetBaudrateCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The baudrate index. The value is between 0~7.

Return Value

The range code.

See Also

Configuration Class
Advantech.Adam Namespace


GetBaudrateIndex Method

Configuration.GetBaudrateIndex Method
[image]

Get the baudrate index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBaudrateIndex( _
ByVal i_byBaudrate As Byte _
) As Integer
C#
public static int GetBaudrateIndex(
byte i_byBaudrate
)
C++
public:
static int GetBaudrateIndex(
char i_byBaudrate
)
J#
public static int GetBaudrateIndex(
byte i_byBaudrate
)
JScript
public static function GetBaudrateIndex(
i_byBaudrate : Byte
) : int

Parameters

i_byBaudrate
The baudrate code.

Return Value

Return range code index if success, otherwise, return -1

See Also

Configuration Class
Advantech.Adam Namespace


GetBaudrateName Method

Configuration.GetBaudrateName Method
[image]

Get the baudrate name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBaudrateName( _
ByVal i_byBaudrate As Byte _
) As String
C#
public static string GetBaudrateName(
byte i_byBaudrate
)
C++
public:
static String GetBaudrateName(
char i_byBaudrate
)
J#
public static string GetBaudrateName(
byte i_byBaudrate
)
JScript
public static function GetBaudrateName(
i_byBaudrate : Byte
) : String

Parameters

i_byBaudrate
The baudrate code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

Configuration Class
Advantech.Adam Namespace


GetBaudrateTotal Method

Configuration.GetBaudrateTotal Method
[image]

Get the baudrate total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBaudrateTotal() As Integer
C#
public static int GetBaudrateTotal()
C++
public:
static int GetBaudrateTotal()
J#
public static int GetBaudrateTotal()
JScript
public static function GetBaudrateTotal() : int

Return Value

Return range total if success, otherwise, return 0.

See Also

Configuration Class
Advantech.Adam Namespace


GetCommunicationSafety Method

Configuration.GetCommunicationSafety Method
[image]

Support module: ADAM-4024 Get communication safety timeout in seconds

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCommunicationSafety( _
<OutAttribute> ByRef o_fTimeout As Single _
) As Boolean
C#
public bool GetCommunicationSafety(
out float o_fTimeout
)
C++
public:
bool GetCommunicationSafety(
[OutAttribute] float% o_fTimeout
) sealed
J#
public bool GetCommunicationSafety(
/** @attribute OutAttribute() */ /** @ref */ float o_fTimeout
)
JScript
public function GetCommunicationSafety(
OutAttribute o_fTimeout : float
) : bool

Parameters

o_fTimeout
The cycle time in seconds. The range is from 0.0~6553.5

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetDataStreamingInterval Method

Configuration.GetDataStreamingInterval Method
[image]

Support module: ADAM-5000TCP, ADAM-6000, APAX-5070 Get the interval for data streaming sending

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataStreamingInterval( _
<OutAttribute> ByRef o_iInterval As Integer _
) As Boolean
C#
public bool GetDataStreamingInterval(
out int o_iInterval
)
C++
public:
bool GetDataStreamingInterval(
[OutAttribute] int% o_iInterval
) sealed
J#
public bool GetDataStreamingInterval(
/** @attribute OutAttribute() */ /** @ref */ int o_iInterval
)
JScript
public function GetDataStreamingInterval(
OutAttribute o_iInterval : int
) : bool

Parameters

o_iInterval
The interval in millisecond

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetDataStreamingIP Method

Configuration.GetDataStreamingIP Method

Support module: ADAM-5000TCP, ADAM-6000 Get the IP address that set for data streaming receiver.

Overload List

 | Name | Description
Public method | GetDataStreamingIP (Int32, String) | Support module: ADAM-5000TCP, ADAM-6000 Get the IP address that set for data streaming receiver.
Public method | GetDataStreamingIP (String) | Support module: APAX-5070 Get the IP address that set for data streaming receiver.

See Also

Configuration Class
Advantech.Adam Namespace


GetDataStreamingIP Method (Int32, String)

Configuration.GetDataStreamingIP Method (Int32, String)
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Get the IP address that set for data streaming receiver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataStreamingIP( _
ByVal i_iIndex As Integer, _
<OutAttribute> ByRef o_szIP As String _
) As Boolean
C#
public bool GetDataStreamingIP(
int i_iIndex,
out string o_szIP
)
C++
public:
bool GetDataStreamingIP(
int i_iIndex,
[OutAttribute] String% o_szIP
) sealed
J#
public bool GetDataStreamingIP(
int i_iIndex,
/** @attribute OutAttribute() */ /** @ref */ string o_szIP
)
JScript
public function GetDataStreamingIP(
i_iIndex : int,
OutAttribute o_szIP : String
) : bool

Parameters

i_iIndex
The receiver index, range from 0 to 7
o_szIP
The IP address of the receiver

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetDataStreamingIP Overload List


GetDataStreamingIP Method (String)

Configuration.GetDataStreamingIP Method (String)
See Also Example
[image]

Support module: APAX-5070 Get the IP address that set for data streaming receiver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataStreamingIP( _
<OutAttribute> ByRef o_szIP As String _
) As Boolean
C#
public bool GetDataStreamingIP(
out string o_szIP
)
C++
public:
bool GetDataStreamingIP(
[OutAttribute] String% o_szIP
) sealed
J#
public bool GetDataStreamingIP(
/** @attribute OutAttribute() */ /** @ref */ string o_szIP
)
JScript
public function GetDataStreamingIP(
OutAttribute o_szIP : String
) : bool

Parameters

o_szIP
The IP address of the receiver

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetDataStreamingIP Overload List


GetDataStreamingMask Method

Configuration.GetDataStreamingMask Method

Support module: APAX-5070 Get the enabled mask for data streaming receiver.

Overload List

 | Name | Description
Public method | GetDataStreamingMask (Boolean) | Support module: APAX-5070 Get the enabled mask for data streaming receiver.
Public method | GetDataStreamingMask (Int32, Boolean) | Support module: ADAM-5000TCP, ADAM-6000 Get the enabled mask for data streaming receiver.

See Also

Configuration Class
Advantech.Adam Namespace


GetDataStreamingMask Method (Boolean)

Configuration.GetDataStreamingMask Method (Boolean)
See Also Example
[image]

Support module: APAX-5070 Get the enabled mask for data streaming receiver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataStreamingMask( _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetDataStreamingMask(
out bool o_bEnabled
)
C++
public:
bool GetDataStreamingMask(
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetDataStreamingMask(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetDataStreamingMask(
OutAttribute o_bEnabled : bool
) : bool

Parameters

o_bEnabled
The enabled mask

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetDataStreamingMask Overload List


GetDataStreamingMask Method (Int32, Boolean)

Configuration.GetDataStreamingMask Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Get the enabled mask for data streaming receiver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDataStreamingMask( _
ByVal i_iIndex As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetDataStreamingMask(
int i_iIndex,
out bool o_bEnabled
)
C++
public:
bool GetDataStreamingMask(
int i_iIndex,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetDataStreamingMask(
int i_iIndex,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetDataStreamingMask(
i_iIndex : int,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_iIndex
The receiver index, range from 0 to 7
o_bEnabled
The enabled mask

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetDataStreamingMask Overload List


GetDatastreamPort Method

Configuration.GetDatastreamPort Method
[image]

Get datastream port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05), ADAM-5000 (V1.427)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDatastreamPort( _
<OutAttribute> ByRef o_iPort As Integer _
) As Boolean
C#
public bool GetDatastreamPort(
out int o_iPort
)
C++
public:
bool GetDatastreamPort(
[OutAttribute] int% o_iPort
) sealed
J#
public bool GetDatastreamPort(
/** @attribute OutAttribute() */ /** @ref */ int o_iPort
)
JScript
public function GetDatastreamPort(
OutAttribute o_iPort : int
) : bool

Parameters

o_iPort
The datastream port

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetEventTriggerMask Method

Configuration.GetEventTriggerMask Method

Support module: ADAM-5000TCP, ADAM-6000 Get the event trigger mask for all channels

Overload List

 | Name | Description
Public method | GetEventTriggerMask (Adam_EventType, Boolean) | Support module: ADAM-5000TCP, ADAM-6000 Get the event trigger mask for all channels
Public method | GetEventTriggerMask (Adam_EventType, String) | Support module: ADAM-5000TCP, ADAM-6000 Get the event trigger mask for all channels

See Also

Configuration Class
Advantech.Adam Namespace


GetEventTriggerMask Method (Adam_EventType, Boolean)

Configuration.GetEventTriggerMask Method (Adam_EventType, Boolean)
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Get the event trigger mask for all channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEventTriggerMask( _
ByVal i_Type As Adam_EventType, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetEventTriggerMask(
Adam_EventType i_Type,
out bool o_bEnabled
)
C++
public:
bool GetEventTriggerMask(
Adam_EventType i_Type,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetEventTriggerMask(
Adam_EventType i_Type,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetEventTriggerMask(
i_Type : Adam_EventType,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_Type
The event type
o_bEnabled
The event mask. For ADAM-5000TCP, 16 channels are used for each slot, 8 slots for an ADAM-5000TCP.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetEventTriggerMask Overload List


GetEventTriggerMask Method (Adam_EventType, String)

Configuration.GetEventTriggerMask Method (Adam_EventType, String)
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Get the event trigger mask for all channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEventTriggerMask( _
ByVal i_Type As Adam_EventType, _
<OutAttribute> ByRef o_szMask As String _
) As Boolean
C#
public bool GetEventTriggerMask(
Adam_EventType i_Type,
out string o_szMask
)
C++
public:
bool GetEventTriggerMask(
Adam_EventType i_Type,
[OutAttribute] String% o_szMask
) sealed
J#
public bool GetEventTriggerMask(
Adam_EventType i_Type,
/** @attribute OutAttribute() */ /** @ref */ string o_szMask
)
JScript
public function GetEventTriggerMask(
i_Type : Adam_EventType,
OutAttribute o_szMask : String
) : bool

Parameters

i_Type
The event type
o_szMask
The event mask string For ADAM-5000TCP, 4 HEX characters are used for each slots, 8 slots for an ADAM-5000TCP.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetEventTriggerMask Overload List


GetEventTriggerPort Method

Configuration.GetEventTriggerPort Method
[image]

Get eventtrigger port setting. Support: ADAM-5000

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEventTriggerPort( _
<OutAttribute> ByRef o_iPort As Integer _
) As Boolean
C#
public bool GetEventTriggerPort(
out int o_iPort
)
C++
public:
bool GetEventTriggerPort(
[OutAttribute] int% o_iPort
) sealed
J#
public bool GetEventTriggerPort(
/** @attribute OutAttribute() */ /** @ref */ int o_iPort
)
JScript
public function GetEventTriggerPort(
OutAttribute o_iPort : int
) : bool

Parameters

o_iPort
The datastream port

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetFirmwareVer Method

Configuration.GetFirmwareVer Method
[image]

Support module: ADAM-4000, ADAM-4100, ADAM-5000, ADAM-5000TCP, ADAM-6000 Get the ADAM mdoule firmware version.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFirmwareVer( _
<OutAttribute> ByRef o_szVer As String _
) As Boolean
C#
public bool GetFirmwareVer(
out string o_szVer
)
C++
public:
bool GetFirmwareVer(
[OutAttribute] String% o_szVer
) sealed
J#
public bool GetFirmwareVer(
/** @attribute OutAttribute() */ /** @ref */ string o_szVer
)
JScript
public function GetFirmwareVer(
OutAttribute o_szVer : String
) : bool

Parameters

o_szVer
The firmware version.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetFpgaVersion Method

Configuration.GetFpgaVersion Method
[image]

Support module: APAX-5000, APAX-5070 Get FPGA version.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFpgaVersion( _
<OutAttribute> ByRef o_dwVer As UInt32 _
) As Boolean
C#
public bool GetFpgaVersion(
out uint o_dwVer
)
C++
public:
bool GetFpgaVersion(
[OutAttribute] unsigned int% o_dwVer
) sealed
J#
public bool GetFpgaVersion(
/** @attribute OutAttribute() */ /** @ref */ uint o_dwVer
)
JScript
public function GetFpgaVersion(
OutAttribute o_dwVer : UInt32
) : bool

Parameters

o_dwVer
The FPGA version

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


GetGCL_AuxFlagStatus Method

Configuration.GetGCL_AuxFlagStatus Method
[image]

Support module: ADAM-6000 DIO module Get GCL Auxiliary Flag Status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetGCL_AuxFlagStatus( _
<OutAttribute> ByRef o_bStatus As Boolean _
) As Boolean
C#
public bool GetGCL_AuxFlagStatus(
out bool o_bStatus
)
C++
public:
bool GetGCL_AuxFlagStatus(
[OutAttribute] bool% o_bStatus
) sealed
J#
public bool GetGCL_AuxFlagStatus(
/** @attribute OutAttribute() */ /** @ref */ bool o_bStatus
)
JScript
public function GetGCL_AuxFlagStatus(
OutAttribute o_bStatus : bool
) : bool

Parameters

o_bStatus
GCL Auxiliary Flag Status (Valid:0~15)

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetModbusAddressConfig Method

Configuration.GetModbusAddressConfig Method
[image]

Support module: ADAM-5000 Get MODBUS address configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModbusAddressConfig( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iStartAddr As Integer, _
<OutAttribute> ByRef o_iLengthIndex As Integer _
) As Boolean
C#
public bool GetModbusAddressConfig(
int i_iSlot,
out int o_iStartAddr,
out int o_iLengthIndex
)
C++
public:
bool GetModbusAddressConfig(
int i_iSlot,
[OutAttribute] int% o_iStartAddr,
[OutAttribute] int% o_iLengthIndex
) sealed
J#
public bool GetModbusAddressConfig(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iStartAddr,
/** @attribute OutAttribute() */ /** @ref */ int o_iLengthIndex
)
JScript
public function GetModbusAddressConfig(
i_iSlot : int,
OutAttribute o_iStartAddr : int,
OutAttribute o_iLengthIndex : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_iStartAddr
The MODBUS starting address.
o_iLengthIndex
The length index. 0: length is 0 1: length is 1 2: length is 2 3: length is 4 4: length is 8 5: length is 16 6: length is 32 7: length is 64

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetModbusAddressMode Method

Configuration.GetModbusAddressMode Method
[image]

Support module: ADAM-5000, APAX-5070 Get MODBUS address mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModbusAddressMode( _
<OutAttribute> ByRef o_bFixed As Boolean _
) As Boolean
C#
public bool GetModbusAddressMode(
out bool o_bFixed
)
C++
public:
bool GetModbusAddressMode(
[OutAttribute] bool% o_bFixed
) sealed
J#
public bool GetModbusAddressMode(
/** @attribute OutAttribute() */ /** @ref */ bool o_bFixed
)
JScript
public function GetModbusAddressMode(
OutAttribute o_bFixed : bool
) : bool

Parameters

o_bFixed
True if the MODBUS address is fixed, otherwise, return false.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleCOMConfig Method

Configuration.GetModuleCOMConfig Method

Support module: ADAM-4100, ADAM-5000 Get module COM configuration.

Overload List

 | Name | Description
Public method | GetModuleCOMConfig (AdamCOMConfig) | Support module: ADAM-4100, ADAM-5000 Get module COM configuration.
Public method | GetModuleCOMConfig (Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Support module: APAX-5090 Get module COM configuration.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleCOMConfig Method (AdamCOMConfig)

Configuration.GetModuleCOMConfig Method (AdamCOMConfig)
See Also Example
[image]

Support module: ADAM-4100, ADAM-5000 Get module COM configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleCOMConfig( _
<OutAttribute> ByRef o_objCon As AdamCOMConfig _
) As Boolean
C#
public bool GetModuleCOMConfig(
out AdamCOMConfig o_objCon
)
C++
public:
bool GetModuleCOMConfig(
[OutAttribute] AdamCOMConfig% o_objCon
) sealed
J#
public bool GetModuleCOMConfig(
/** @attribute OutAttribute() */ /** @ref */ AdamCOMConfig o_objCon
)
JScript
public function GetModuleCOMConfig(
OutAttribute o_objCon : AdamCOMConfig
) : bool

Parameters

o_objCon
The AdamCOMConfig object.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetModuleCOMConfig Overload List


GetModuleCOMConfig Method (Int32, Int32, Int32, Int32, Int32, Int32, Int32)

Configuration.GetModuleCOMConfig Method (Int32, Int32, Int32, Int32, Int32, Int32, Int32)
See Also Example
[image]

Support module: APAX-5090 Get module COM configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleCOMConfig( _
ByVal i_iSlot As Integer, _
ByVal i_iCom As Integer, _
<OutAttribute> ByRef o_iBaudRate As Integer, _
<OutAttribute> ByRef o_iDataBit As Integer, _
<OutAttribute> ByRef o_iStopBit As Integer, _
<OutAttribute> ByRef o_iParity As Integer, _
<OutAttribute> ByRef o_iFlowControl As Integer _
) As Boolean
C#
public bool GetModuleCOMConfig(
int i_iSlot,
int i_iCom,
out int o_iBaudRate,
out int o_iDataBit,
out int o_iStopBit,
out int o_iParity,
out int o_iFlowControl
)
C++
public:
bool GetModuleCOMConfig(
int i_iSlot,
int i_iCom,
[OutAttribute] int% o_iBaudRate,
[OutAttribute] int% o_iDataBit,
[OutAttribute] int% o_iStopBit,
[OutAttribute] int% o_iParity,
[OutAttribute] int% o_iFlowControl
) sealed
J#
public bool GetModuleCOMConfig(
int i_iSlot,
int i_iCom,
/** @attribute OutAttribute() */ /** @ref */ int o_iBaudRate,
/** @attribute OutAttribute() */ /** @ref */ int o_iDataBit,
/** @attribute OutAttribute() */ /** @ref */ int o_iStopBit,
/** @attribute OutAttribute() */ /** @ref */ int o_iParity,
/** @attribute OutAttribute() */ /** @ref */ int o_iFlowControl
)
JScript
public function GetModuleCOMConfig(
i_iSlot : int,
i_iCom : int,
OutAttribute o_iBaudRate : int,
OutAttribute o_iDataBit : int,
OutAttribute o_iStopBit : int,
OutAttribute o_iParity : int,
OutAttribute o_iFlowControl : int
) : bool

Parameters

i_iSlot
Slot index. (switch id : 0~15)
i_iCom
Com index. (com port id : 1~4)
o_iBaudRate
Baudrate index. (Baudrate value index : 0~9)
o_iDataBit
Data Bit index. (Data Bit value index : 0~1)
o_iStopBit
Stop Bit index. (Stop Bit value index : 0~3)
o_iParity
Parity index. (Parity value index : 0~4)
o_iFlowControl
Flow Control index. (Flow Control value index : 0~3)

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetModuleCOMConfig Overload List


GetModuleCOMTcpPortMapping Method

Configuration.GetModuleCOMTcpPortMapping Method
[image]

Support module: APAX-5090 Get module COM (COM1~COM4) TCP port mapping values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleCOMTcpPortMapping( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iTcpPortValues As Integer _
) As Boolean
C#
public bool GetModuleCOMTcpPortMapping(
int i_iSlot,
out int o_iTcpPortValues
)
C++
public:
bool GetModuleCOMTcpPortMapping(
int i_iSlot,
[OutAttribute] int% o_iTcpPortValues
) sealed
J#
public bool GetModuleCOMTcpPortMapping(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iTcpPortValues
)
JScript
public function GetModuleCOMTcpPortMapping(
i_iSlot : int,
OutAttribute o_iTcpPortValues : int
) : bool

Parameters

i_iSlot
Slot index. (switch id : 0~15)
o_iTcpPortValues
Tcp port mapping values (COM1~COM4)

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleConfig Method

Configuration.GetModuleConfig Method

Support module: ADAM-4000 Get module configuration.

Overload List

 | Name | Description
Public method | GetModuleConfig (Adam4000Config) | Support module: ADAM-4000 Get module configuration.
Public method | GetModuleConfig (Adam5000Config) | Support module: ADAM-5000 Get module configuration.
Public method | GetModuleConfig (Int32, Apax5000Config) | Support module: APAX-5000 Get APAX-5000 module configuration.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleConfig Method (Adam4000Config)

Configuration.GetModuleConfig Method (Adam4000Config)
See Also Example
[image]

Support module: ADAM-4000 Get module configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleConfig( _
<OutAttribute> ByRef o_objCon As Adam4000Config _
) As Boolean
C#
public bool GetModuleConfig(
out Adam4000Config o_objCon
)
C++
public:
bool GetModuleConfig(
[OutAttribute] Adam4000Config% o_objCon
) sealed
J#
public bool GetModuleConfig(
/** @attribute OutAttribute() */ /** @ref */ Adam4000Config o_objCon
)
JScript
public function GetModuleConfig(
OutAttribute o_objCon : Adam4000Config
) : bool

Parameters

o_objCon
The Adam4000Config object.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetModuleConfig Overload List


GetModuleConfig Method (Adam5000Config)

Configuration.GetModuleConfig Method (Adam5000Config)
See Also Example
[image]

Support module: ADAM-5000 Get module configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleConfig( _
<OutAttribute> ByRef o_objCon As Adam5000Config _
) As Boolean
C#
public bool GetModuleConfig(
out Adam5000Config o_objCon
)
C++
public:
bool GetModuleConfig(
[OutAttribute] Adam5000Config% o_objCon
) sealed
J#
public bool GetModuleConfig(
/** @attribute OutAttribute() */ /** @ref */ Adam5000Config o_objCon
)
JScript
public function GetModuleConfig(
OutAttribute o_objCon : Adam5000Config
) : bool

Parameters

o_objCon
The Adam5000Config object.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetModuleConfig Overload List


GetModuleConfig Method (Int32, Apax5000Config)

Configuration.GetModuleConfig Method (Int32, Apax5000Config)
See Also Example
[image]

Support module: APAX-5000 Get APAX-5000 module configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleConfig( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef apaxConfig As Apax5000Config _
) As Boolean
C#
public bool GetModuleConfig(
int i_iSlot,
out Apax5000Config apaxConfig
)
C++
public:
bool GetModuleConfig(
int i_iSlot,
[OutAttribute] Apax5000Config% apaxConfig
) sealed
J#
public bool GetModuleConfig(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ Apax5000Config apaxConfig
)
JScript
public function GetModuleConfig(
i_iSlot : int,
OutAttribute apaxConfig : Apax5000Config
) : bool

Parameters

i_iSlot
Slot index. (module:0~31, dsp platform:0xD2~0xD4)
apaxConfig
APAX-5000 module configuration

Return Value

True if succeed, otherwise error code.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetModuleConfig Overload List


GetModuleCurrentChMsk Method

Configuration.GetModuleCurrentChMsk Method
[image]

Support module: APAX-5070 Get APAX-5000 module current channel enabled mask.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleCurrentChMsk( _
ByVal i_iSlot As Integer, _
ByVal apaxConfig As Apax5000Config _
) As Boolean
C#
public bool GetModuleCurrentChMsk(
int i_iSlot,
Apax5000Config apaxConfig
)
C++
public:
bool GetModuleCurrentChMsk(
int i_iSlot,
Apax5000Config apaxConfig
) sealed
J#
public bool GetModuleCurrentChMsk(
int i_iSlot,
Apax5000Config apaxConfig
)
JScript
public function GetModuleCurrentChMsk(
i_iSlot : int,
apaxConfig : Apax5000Config
) : bool

Parameters

i_iSlot
Slot index. (module:0~15, dsp platform:0xD2~0xD4)
apaxConfig
APAX-5000 module configuration

Return Value

0 if succeed, otherwise error code.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleCurrentRange Method

Configuration.GetModuleCurrentRange Method
[image]

Support module: APAX-5070 Get APAX-5000 module current range.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleCurrentRange( _
ByVal i_iSlot As Integer, _
ByVal apaxConfig As Apax5000Config _
) As Boolean
C#
public bool GetModuleCurrentRange(
int i_iSlot,
Apax5000Config apaxConfig
)
C++
public:
bool GetModuleCurrentRange(
int i_iSlot,
Apax5000Config apaxConfig
) sealed
J#
public bool GetModuleCurrentRange(
int i_iSlot,
Apax5000Config apaxConfig
)
JScript
public function GetModuleCurrentRange(
i_iSlot : int,
apaxConfig : Apax5000Config
) : bool

Parameters

i_iSlot
Slot index. (module:0~31, dsp platform:0xD2~0xD4)
apaxConfig
APAX-5000 module configuration

Return Value

0 if succeed, otherwise error code.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleFunPara Method

Configuration.GetModuleFunPara Method
[image]

Support module: APAX-5070 Get module function parameters.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleFunPara( _
ByVal i_iSlot As Integer, _
ByVal o_aConf As Apax5000Config _
) As Boolean
C#
public bool GetModuleFunPara(
int i_iSlot,
Apax5000Config o_aConf
)
C++
public:
bool GetModuleFunPara(
int i_iSlot,
Apax5000Config o_aConf
) sealed
J#
public bool GetModuleFunPara(
int i_iSlot,
Apax5000Config o_aConf
)
JScript
public function GetModuleFunPara(
i_iSlot : int,
o_aConf : Apax5000Config
) : bool

Parameters

i_iSlot
The slot index.
o_aConf
The configuration data.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleGroupSetting Method

Configuration.GetModuleGroupSetting Method
[image]

Support module: APAX-5070 Get module group setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleGroupSetting( _
<OutAttribute> ByRef o_bTurnOn As Boolean _
) As Boolean
C#
public bool GetModuleGroupSetting(
out bool o_bTurnOn
)
C++
public:
bool GetModuleGroupSetting(
[OutAttribute] bool% o_bTurnOn
) sealed
J#
public bool GetModuleGroupSetting(
/** @attribute OutAttribute() */ /** @ref */ bool o_bTurnOn
)
JScript
public function GetModuleGroupSetting(
OutAttribute o_bTurnOn : bool
) : bool

Parameters

o_bTurnOn
Indicate whether the module group setting enabled.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleName Method

Configuration.GetModuleName Method
[image]

Support module: ADAM-4000, ADAM-4100, ADAM-5000, ADAM-5000TCP, ADAM-6000 Get the ADAM mdoule name.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleName( _
<OutAttribute> ByRef o_szName As String _
) As Boolean
C#
public bool GetModuleName(
out string o_szName
)
C++
public:
bool GetModuleName(
[OutAttribute] String% o_szName
) sealed
J#
public bool GetModuleName(
/** @attribute OutAttribute() */ /** @ref */ string o_szName
)
JScript
public function GetModuleName(
OutAttribute o_szName : String
) : bool

Parameters

o_szName
The module name

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleTotalRange Method

Configuration.GetModuleTotalRange Method
[image]

Support module: APAX-5070 Get APAX-5000 module supported total range.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleTotalRange( _
ByVal i_iSlot As Integer, _
ByVal apaxConfig As Apax5000Config, _
ByVal typeIndex As Integer _
) As Boolean
C#
public bool GetModuleTotalRange(
int i_iSlot,
Apax5000Config apaxConfig,
int typeIndex
)
C++
public:
bool GetModuleTotalRange(
int i_iSlot,
Apax5000Config apaxConfig,
int typeIndex
) sealed
J#
public bool GetModuleTotalRange(
int i_iSlot,
Apax5000Config apaxConfig,
int typeIndex
)
JScript
public function GetModuleTotalRange(
i_iSlot : int,
apaxConfig : Apax5000Config,
typeIndex : int
) : bool

Parameters

i_iSlot
Slot index. (module:0~31, dsp platform:0xD2~0xD4)
apaxConfig
APAX-5000 module configuration
typeIndex
Type index. (from 0 ~ 4)

Return Value

0 if succeed, otherwise error code.

See Also

Configuration Class
Advantech.Adam Namespace


GetModuleVersion Method

Configuration.GetModuleVersion Method
[image]

Support Platform: ADAM-5000TCP after V1.424 Get the ADAM IO mdoule name. Support IO module: ADAM-5081.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModuleVersion( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iMajor As Integer, _
<OutAttribute> ByRef o_iMinor As Integer, _
<OutAttribute> ByRef o_iBuild As Integer, _
<OutAttribute> ByRef o_iReserved As Integer _
) As Boolean
C#
public bool GetModuleVersion(
int i_iSlot,
out int o_iMajor,
out int o_iMinor,
out int o_iBuild,
out int o_iReserved
)
C++
public:
bool GetModuleVersion(
int i_iSlot,
[OutAttribute] int% o_iMajor,
[OutAttribute] int% o_iMinor,
[OutAttribute] int% o_iBuild,
[OutAttribute] int% o_iReserved
) sealed
J#
public bool GetModuleVersion(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iMajor,
/** @attribute OutAttribute() */ /** @ref */ int o_iMinor,
/** @attribute OutAttribute() */ /** @ref */ int o_iBuild,
/** @attribute OutAttribute() */ /** @ref */ int o_iReserved
)
JScript
public function GetModuleVersion(
i_iSlot : int,
OutAttribute o_iMajor : int,
OutAttribute o_iMinor : int,
OutAttribute o_iBuild : int,
OutAttribute o_iReserved : int
) : bool

Parameters

i_iSlot
Slot index.
o_iMajor
Major version.
o_iMinor
Minor version.
o_iBuild
Build version.
o_iReserved
Reserved version

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetNetworkDiagEnable Method

Configuration.GetNetworkDiagEnable Method
[image]

Get the network diagnostic enable flag. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNetworkDiagEnable( _
<OutAttribute> ByRef o_bEnable As Boolean _
) As Boolean
C#
public bool GetNetworkDiagEnable(
out bool o_bEnable
)
C++
public:
bool GetNetworkDiagEnable(
[OutAttribute] bool% o_bEnable
) sealed
J#
public bool GetNetworkDiagEnable(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable
)
JScript
public function GetNetworkDiagEnable(
OutAttribute o_bEnable : bool
) : bool

Parameters

o_bEnable
The network diagnostic enable flag.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetP2P_Config Method

Configuration.GetP2P_Config Method

Support module: ADAM-6000/W Digital Input/Output module Get Peer to Peer configuration.

Overload List

 | Name | Description
Public method | GetP2P_Config (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean) | Support module: ADAM-6000/W Digital Input/Output module Get Peer to Peer configuration.
Public method | GetP2P_Config (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean, Int32) | Support module: ADAM-6000 Analog Input module Get Peer to Peer configuration.

See Also

Configuration Class
Advantech.Adam Namespace


GetP2P_Config Method (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean)

Configuration.GetP2P_Config Method (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean)
See Also Example
[image]

Support module: ADAM-6000/W Digital Input/Output module Get Peer to Peer configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetP2P_Config( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bState As Boolean, _
<OutAttribute> ByRef o_iPeriodTime As Integer, _
<OutAttribute> ByRef o_byIP As Byte, _
<OutAttribute> ByRef o_iModbusAddr As Integer, _
<OutAttribute> ByRef o_byModuleID As Byte, _
<OutAttribute> ByRef o_bMask As Boolean _
) As Boolean
C#
public bool GetP2P_Config(
int i_iChannel,
out bool o_bState,
out int o_iPeriodTime,
out byte o_byIP,
out int o_iModbusAddr,
out byte o_byModuleID,
out bool o_bMask
)
C++
public:
bool GetP2P_Config(
int i_iChannel,
[OutAttribute] bool% o_bState,
[OutAttribute] int% o_iPeriodTime,
[OutAttribute] char% o_byIP,
[OutAttribute] int% o_iModbusAddr,
[OutAttribute] char% o_byModuleID,
[OutAttribute] bool% o_bMask
) sealed
J#
public bool GetP2P_Config(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bState,
/** @attribute OutAttribute() */ /** @ref */ int o_iPeriodTime,
/** @attribute OutAttribute() */ /** @ref */ byte o_byIP,
/** @attribute OutAttribute() */ /** @ref */ int o_iModbusAddr,
/** @attribute OutAttribute() */ /** @ref */ byte o_byModuleID,
/** @attribute OutAttribute() */ /** @ref */ bool o_bMask
)
JScript
public function GetP2P_Config(
i_iChannel : int,
OutAttribute o_bState : bool,
OutAttribute o_iPeriodTime : int,
OutAttribute o_byIP : Byte,
OutAttribute o_iModbusAddr : int,
OutAttribute o_byModuleID : Byte,
OutAttribute o_bMask : bool
) : bool

Parameters

i_iChannel
Channel index.
o_bState
Change of state.
o_iPeriodTime
Period time. The value is between 0~4095.
o_byIP
Map to IP.
o_iModbusAddr
Map to modbus address.
o_byModuleID
Map to module ID.
o_bMask
Basic mode mask.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetP2P_Config Overload List


GetP2P_Config Method (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean, Int32)

Configuration.GetP2P_Config Method (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean, Int32)
See Also Example
[image]

Support module: ADAM-6000 Analog Input module Get Peer to Peer configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetP2P_Config( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bState As Boolean, _
<OutAttribute> ByRef o_iPeriodTime As Integer, _
<OutAttribute> ByRef o_byIP As Byte, _
<OutAttribute> ByRef o_iModbusAddr As Integer, _
<OutAttribute> ByRef o_byModuleID As Byte, _
<OutAttribute> ByRef o_bMask As Boolean, _
<OutAttribute> ByRef o_iDeviationRate As Integer _
) As Boolean
C#
public bool GetP2P_Config(
int i_iChannel,
out bool o_bState,
out int o_iPeriodTime,
out byte o_byIP,
out int o_iModbusAddr,
out byte o_byModuleID,
out bool o_bMask,
out int o_iDeviationRate
)
C++
public:
bool GetP2P_Config(
int i_iChannel,
[OutAttribute] bool% o_bState,
[OutAttribute] int% o_iPeriodTime,
[OutAttribute] char% o_byIP,
[OutAttribute] int% o_iModbusAddr,
[OutAttribute] char% o_byModuleID,
[OutAttribute] bool% o_bMask,
[OutAttribute] int% o_iDeviationRate
) sealed
J#
public bool GetP2P_Config(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bState,
/** @attribute OutAttribute() */ /** @ref */ int o_iPeriodTime,
/** @attribute OutAttribute() */ /** @ref */ byte o_byIP,
/** @attribute OutAttribute() */ /** @ref */ int o_iModbusAddr,
/** @attribute OutAttribute() */ /** @ref */ byte o_byModuleID,
/** @attribute OutAttribute() */ /** @ref */ bool o_bMask,
/** @attribute OutAttribute() */ /** @ref */ int o_iDeviationRate
)
JScript
public function GetP2P_Config(
i_iChannel : int,
OutAttribute o_bState : bool,
OutAttribute o_iPeriodTime : int,
OutAttribute o_byIP : Byte,
OutAttribute o_iModbusAddr : int,
OutAttribute o_byModuleID : Byte,
OutAttribute o_bMask : bool,
OutAttribute o_iDeviationRate : int
) : bool

Parameters

i_iChannel
Channel index.
o_bState
Change of state.
o_iPeriodTime
Period time. The value is between 0~4095.
o_byIP
Map to IP.
o_iModbusAddr
Map to modbus address.
o_byModuleID
Map to module ID.
o_bMask
Basic mode mask.
o_iDeviationRate
Deviation Rate.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetP2P_Config Overload List


GetP2pGclPort Method

Configuration.GetP2pGclPort Method
[image]

Get P2P/GCL port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetP2pGclPort( _
<OutAttribute> ByRef o_iPort As Integer _
) As Boolean
C#
public bool GetP2pGclPort(
out int o_iPort
)
C++
public:
bool GetP2pGclPort(
[OutAttribute] int% o_iPort
) sealed
J#
public bool GetP2pGclPort(
/** @attribute OutAttribute() */ /** @ref */ int o_iPort
)
JScript
public function GetP2pGclPort(
OutAttribute o_iPort : int
) : bool

Parameters

o_iPort
The P2P/GCL port.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetP2PValueStatus Method

Configuration.GetP2PValueStatus Method

Get P2P mapping value status. Support module: ADAM-6017 (after V4.05)

Overload List

 | Name | Description
Public method | GetP2PValueStatus (Boolean) | Get P2P mapping value status. Support module: ADAM-6017 (after V4.05)
Public method | GetP2PValueStatus (Byte) | Get P2P mapping value status. Support module: ADAM-6217

See Also

Configuration Class
Advantech.Adam Namespace


GetP2PValueStatus Method (Boolean)

Configuration.GetP2PValueStatus Method (Boolean)
See Also Example
[image]

Get P2P mapping value status. Support module: ADAM-6017 (after V4.05)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetP2PValueStatus( _
<OutAttribute> ByRef o_bEnable As Boolean _
) As Boolean
C#
public bool GetP2PValueStatus(
out bool o_bEnable
)
C++
public:
bool GetP2PValueStatus(
[OutAttribute] bool% o_bEnable
) sealed
J#
public bool GetP2PValueStatus(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable
)
JScript
public function GetP2PValueStatus(
OutAttribute o_bEnable : bool
) : bool

Parameters

o_bEnable
Enable only upper half value valid flag.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetP2PValueStatus Overload List


GetP2PValueStatus Method (Byte)

Configuration.GetP2PValueStatus Method (Byte)
See Also Example
[image]

Get P2P mapping value status. Support module: ADAM-6217

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetP2PValueStatus( _
<OutAttribute> ByRef o_byStatus As Byte _
) As Boolean
C#
public bool GetP2PValueStatus(
out byte o_byStatus
)
C++
public:
bool GetP2PValueStatus(
[OutAttribute] char% o_byStatus
) sealed
J#
public bool GetP2PValueStatus(
/** @attribute OutAttribute() */ /** @ref */ byte o_byStatus
)
JScript
public function GetP2PValueStatus(
OutAttribute o_byStatus : Byte
) : bool

Parameters

o_byStatus
Get Enable only upper half value valid flag Setting Information.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetP2PValueStatus Overload List


GetSlotInfo Method

Configuration.GetSlotInfo Method

Support module: ADAM-5000, ADAM-5000TCP, ADAM-5550 Get the slot information

Overload List

 | Name | Description
Public method | GetSlotInfo (Adam5000Type) | Support module: ADAM-5000, ADAM-5000TCP, ADAM-5550 Get the slot information
Public method | GetSlotInfo (String) | Support module: ADAM-5000, ADAM-5000TCP, ADAM-5550, APAX-5000 Get the slot information

See Also

Configuration Class
Advantech.Adam Namespace


GetSlotInfo Method (Adam5000Type)

Configuration.GetSlotInfo Method (Adam5000Type)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP, ADAM-5550 Get the slot information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSlotInfo( _
<OutAttribute> ByRef o_aSlotInfo As Adam5000Type _
) As Boolean
C#
public bool GetSlotInfo(
out Adam5000Type o_aSlotInfo
)
C++
public:
bool GetSlotInfo(
[OutAttribute] Adam5000Type% o_aSlotInfo
) sealed
J#
public bool GetSlotInfo(
/** @attribute OutAttribute() */ /** @ref */ Adam5000Type o_aSlotInfo
)
JScript
public function GetSlotInfo(
OutAttribute o_aSlotInfo : Adam5000Type
) : bool

Parameters

o_aSlotInfo
Array of slot information.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetSlotInfo Overload List


GetSlotInfo Method (String)

Configuration.GetSlotInfo Method (String)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP, ADAM-5550, APAX-5000 Get the slot information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSlotInfo( _
<OutAttribute> ByRef o_szSlotInfo As String _
) As Boolean
C#
public bool GetSlotInfo(
out string o_szSlotInfo
)
C++
public:
bool GetSlotInfo(
[OutAttribute] String% o_szSlotInfo
) sealed
J#
public bool GetSlotInfo(
/** @attribute OutAttribute() */ /** @ref */ string o_szSlotInfo
)
JScript
public function GetSlotInfo(
OutAttribute o_szSlotInfo : String
) : bool

Parameters

o_szSlotInfo
Array of slot information.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetSlotInfo Overload List


GetSlotName Method

Configuration.GetSlotName Method
[image]

Support module: APAX-5000 Get the slot information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSlotName( _
ByVal i_iSlot As UInt16, _
<OutAttribute> ByRef o_szSlotInfo As String _
) As Boolean
C#
public bool GetSlotName(
ushort i_iSlot,
out string o_szSlotInfo
)
C++
public:
bool GetSlotName(
unsigned short i_iSlot,
[OutAttribute] String% o_szSlotInfo
) sealed
J#
public bool GetSlotName(
ushort i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ string o_szSlotInfo
)
JScript
public function GetSlotName(
i_iSlot : UInt16,
OutAttribute o_szSlotInfo : String
) : bool

Parameters

i_iSlot
Slot index.
o_szSlotInfo
The module name.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetSupportDeviceNames Method

Configuration.GetSupportDeviceNames Method

Get ADAM-4000/5000/6000 support device names

Overload List

Name | Description
GetSupportDeviceNames (Type, String, String) | Get ADAM-4000/5000/6000 support device names
GetSupportDeviceNames (Type, String) | Get ADAM-4000/5000/6000 support device names

See Also

Configuration Class
Advantech.Adam Namespace


GetSupportDeviceNames Method (Type, String, String)

Configuration.GetSupportDeviceNames Method (Type, String, String)
See Also Example
[image]

Get ADAM-4000/5000/6000 support device names

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetSupportDeviceNames( _
ByVal i_Type As Type, _
ByVal i_strTitle As String, _
<OutAttribute> ByRef o_strNames As String _
)
C#
public static void GetSupportDeviceNames(
Type i_Type,
string i_strTitle,
out string o_strNames
)
C++
public:
static void GetSupportDeviceNames(
Type i_Type,
String i_strTitle,
[OutAttribute] String% o_strNames
)
J#
public static void GetSupportDeviceNames(
Type i_Type,
string i_strTitle,
/** @attribute OutAttribute() */ /** @ref */ string o_strNames
)
JScript
public static function GetSupportDeviceNames(
i_Type : Type,
i_strTitle : String,
OutAttribute o_strNames : String
)

Parameters

i_Type
Adam4000Type/Adam5000Type/Adam6000Type
i_strTitle
Device title
o_strNames
Output name strings

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetSupportDeviceNames Overload List


GetSupportDeviceNames Method (Type, String)

Configuration.GetSupportDeviceNames Method (Type, String)
See Also Example
[image]

Get ADAM-4000/5000/6000 support device names

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GetSupportDeviceNames( _
ByVal i_Type As Type, _
<OutAttribute> ByRef o_strNames As String _
)
C#
public static void GetSupportDeviceNames(
Type i_Type,
out string o_strNames
)
C++
public:
static void GetSupportDeviceNames(
Type i_Type,
[OutAttribute] String% o_strNames
)
J#
public static void GetSupportDeviceNames(
Type i_Type,
/** @attribute OutAttribute() */ /** @ref */ string o_strNames
)
JScript
public static function GetSupportDeviceNames(
i_Type : Type,
OutAttribute o_strNames : String
)

Parameters

i_Type
Adam4000Type/Adam5000Type/Adam6000Type
o_strNames
Output name strings

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetSupportDeviceNames Overload List


GetThermocoupleMode Method

Configuration.GetThermocoupleMode Method
[image]

Support module: ADAM-4100 Get Thermocouple mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetThermocoupleMode( _
<OutAttribute> ByRef o_iMode As Integer _
) As Boolean
C#
public bool GetThermocoupleMode(
out int o_iMode
)
C++
public:
bool GetThermocoupleMode(
[OutAttribute] int% o_iMode
) sealed
J#
public bool GetThermocoupleMode(
/** @attribute OutAttribute() */ /** @ref */ int o_iMode
)
JScript
public function GetThermocoupleMode(
OutAttribute o_iMode : int
) : bool

Parameters

o_iMode
The thermocouple mode

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetWDTMask Method

Configuration.GetWDTMask Method
[image]

Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout mask.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDTMask( _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetWDTMask(
out bool o_bEnabled
)
C++
public:
bool GetWDTMask(
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetWDTMask(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetWDTMask(
OutAttribute o_bEnabled : bool
) : bool

Parameters

o_bEnabled
The array of boolean values indicate the WDT mask for each slot

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetWDTTimeout Method

Configuration.GetWDTTimeout Method

Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout value in seconds

Overload List

 | Name | Description
Public method | GetWDTTimeout (Int32) | Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout value in seconds
Public method | GetWDTTimeout (Single) | Support module: ADAM-4000, ADAM-4100 Get WDT cycle time in seconds

See Also

Configuration Class
Advantech.Adam Namespace


GetWDTTimeout Method (Int32)

Configuration.GetWDTTimeout Method (Int32)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP Get WDT timeout value in seconds

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDTTimeout( _
<OutAttribute> ByRef o_iWDTTimeout As Integer _
) As Boolean
C#
public bool GetWDTTimeout(
out int o_iWDTTimeout
)
C++
public:
bool GetWDTTimeout(
[OutAttribute] int% o_iWDTTimeout
) sealed
J#
public bool GetWDTTimeout(
/** @attribute OutAttribute() */ /** @ref */ int o_iWDTTimeout
)
JScript
public function GetWDTTimeout(
OutAttribute o_iWDTTimeout : int
) : bool

Parameters

o_iWDTTimeout
The timeout value in seconds

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetWDTTimeout Overload List


GetWDTTimeout Method (Single)

Configuration.GetWDTTimeout Method (Single)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100 Get WDT cycle time in seconds

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDTTimeout( _
<OutAttribute> ByRef o_fWDTTimeout As Single _
) As Boolean
C#
public bool GetWDTTimeout(
out float o_fWDTTimeout
)
C++
public:
bool GetWDTTimeout(
[OutAttribute] float% o_fWDTTimeout
) sealed
J#
public bool GetWDTTimeout(
/** @attribute OutAttribute() */ /** @ref */ float o_fWDTTimeout
)
JScript
public function GetWDTTimeout(
OutAttribute o_fWDTTimeout : float
) : bool

Parameters

o_fWDTTimeout
The cycle time in seconds

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.GetWDTTimeout Overload List


GetWirelessAPInfo Method

Configuration.GetWirelessAPInfo Method
[image]

Support module: ADAM-6000W Get AP information by index.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWirelessAPInfo( _
ByVal i_iIndex As Integer, _
<OutAttribute> ByRef o_objAP As AdamWirelessAP _
) As Boolean
C#
public bool GetWirelessAPInfo(
int i_iIndex,
out AdamWirelessAP o_objAP
)
C++
public:
bool GetWirelessAPInfo(
int i_iIndex,
[OutAttribute] AdamWirelessAP% o_objAP
) sealed
J#
public bool GetWirelessAPInfo(
int i_iIndex,
/** @attribute OutAttribute() */ /** @ref */ AdamWirelessAP o_objAP
)
JScript
public function GetWirelessAPInfo(
i_iIndex : int,
OutAttribute o_objAP : AdamWirelessAP
) : bool

Parameters

i_iIndex
The index of the AP.
o_objAP
The AP object.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


GetWirelessAPTotal Method

Configuration.GetWirelessAPTotal Method
[image]

Support module: ADAM-6000W Get wireless AP total.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWirelessAPTotal( _
<OutAttribute> ByRef o_iTotal As Integer _
) As Boolean
C#
public bool GetWirelessAPTotal(
out int o_iTotal
)
C++
public:
bool GetWirelessAPTotal(
[OutAttribute] int% o_iTotal
) sealed
J#
public bool GetWirelessAPTotal(
/** @attribute OutAttribute() */ /** @ref */ int o_iTotal
)
JScript
public function GetWirelessAPTotal(
OutAttribute o_iTotal : int
) : bool

Parameters

o_iTotal
The total number of AP.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


IsValidPassword Method

Configuration.IsValidPassword Method
[image]

Support module: ADAM-5000TCP, ADAM-6000 Validate the password. This command only supports TCP connection, DO NOT USE UDP!

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function IsValidPassword( _
ByVal i_szPassword As String _
) As Boolean
C#
public bool IsValidPassword(
string i_szPassword
)
C++
public:
bool IsValidPassword(
String i_szPassword
) sealed
J#
public bool IsValidPassword(
string i_szPassword
)
JScript
public function IsValidPassword(
i_szPassword : String
) : bool

Parameters

i_szPassword
The password string, maximum length is 8.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


OUT_FlushBufValues Method

Configuration.OUT_FlushBufValues Method
[image]

APAX API. Set the slot buffer mask flags.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function OUT_FlushBufValues( _
ByVal i_dwFlag As UInt32 _
) As Boolean
C#
public bool OUT_FlushBufValues(
uint i_dwFlag
)
C++
public:
bool OUT_FlushBufValues(
unsigned int i_dwFlag
) sealed
J#
public bool OUT_FlushBufValues(
uint i_dwFlag
)
JScript
public function OUT_FlushBufValues(
i_dwFlag : UInt32
) : bool

Parameters

i_dwFlag
The slot buffer mask flags.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


OUT_GetSafetyEnable Method

Configuration.OUT_GetSafetyEnable Method
[image]

APAX API. Support module: APAX-5000, APAX-5070 Get safety enable flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function OUT_GetSafetyEnable( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_bEnable As Boolean _
) As Boolean
C#
public bool OUT_GetSafetyEnable(
int i_iSlot,
out bool o_bEnable
)
C++
public:
bool OUT_GetSafetyEnable(
int i_iSlot,
[OutAttribute] bool% o_bEnable
) sealed
J#
public bool OUT_GetSafetyEnable(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable
)
JScript
public function OUT_GetSafetyEnable(
i_iSlot : int,
OutAttribute o_bEnable : bool
) : bool

Parameters

i_iSlot
The slot number. (module:0~15, dsp platform:0xD2~0xD4)
o_bEnable
The enable flag.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


OUT_SetSafetyEnable Method

Configuration.OUT_SetSafetyEnable Method
[image]

APAX API. Support module: APAX-5000, APAX-5070 Set safety enable flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function OUT_SetSafetyEnable( _
ByVal i_iSlot As Integer, _
ByVal i_bEnable As Boolean _
) As Boolean
C#
public bool OUT_SetSafetyEnable(
int i_iSlot,
bool i_bEnable
)
C++
public:
bool OUT_SetSafetyEnable(
int i_iSlot,
bool i_bEnable
) sealed
J#
public bool OUT_SetSafetyEnable(
int i_iSlot,
bool i_bEnable
)
JScript
public function OUT_SetSafetyEnable(
i_iSlot : int,
i_bEnable : bool
) : bool

Parameters

i_iSlot
The slot number. (module:0~15, dsp platform:0xD2~0xD4)
i_bEnable
The enable flag.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


ParseVersion Method

Configuration.ParseVersion Method
[image]

Parsing the version string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ParseVersion( _
ByRef i_szVer As String, _
<OutAttribute> ByRef o_szPrefix As String, _
<OutAttribute> ByRef o_fMainVer As Single, _
<OutAttribute> ByRef o_iBuildNum As Integer _
)
C#
public static void ParseVersion(
ref string i_szVer,
out string o_szPrefix,
out float o_fMainVer,
out int o_iBuildNum
)
C++
public:
static void ParseVersion(
String% i_szVer,
[OutAttribute] String% o_szPrefix,
[OutAttribute] float% o_fMainVer,
[OutAttribute] int% o_iBuildNum
)
J#
public static void ParseVersion(
string i_szVer,
/** @attribute OutAttribute() */ /** @ref */ string o_szPrefix,
/** @attribute OutAttribute() */ /** @ref */ float o_fMainVer,
/** @attribute OutAttribute() */ /** @ref */ int o_iBuildNum
)
JScript
public static function ParseVersion(
i_szVer : String,
OutAttribute o_szPrefix : String,
OutAttribute o_fMainVer : float,
OutAttribute o_iBuildNum : int
)

Parameters

i_szVer
The version string read from module
o_szPrefix
The prefix character
o_fMainVer
The main version number
o_iBuildNum
The build number

See Also

Configuration Class
Advantech.Adam Namespace


ResetPassword Method

Configuration.ResetPassword Method
[image]

Support module: ADAM-6000 Reset the password to "00000000" This command only supports TCP connection, DO NOT USE UDP!

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ResetPassword() As Boolean
C#
public bool ResetPassword()
C++
public:
bool ResetPassword() sealed
J#
public bool ResetPassword()
JScript
public function ResetPassword() : bool

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetAccessControl_Config Method

Configuration.SetAccessControl_Config Method
[image]

Support module: ADAM-6000/W AI/DIO module Set IO access control security configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAccessControl_Config( _
ByVal i_iIndex As Integer, _
ByVal i_bState As Boolean, _
ByVal i_iMode As Integer, _
ByVal i_byIP_MAC As Byte() _
) As Boolean
C#
public bool SetAccessControl_Config(
int i_iIndex,
bool i_bState,
int i_iMode,
byte[] i_byIP_MAC
)
C++
public:
bool SetAccessControl_Config(
int i_iIndex,
bool i_bState,
int i_iMode,
array<char>^ i_byIP_MAC
) sealed
J#
public bool SetAccessControl_Config(
int i_iIndex,
bool i_bState,
int i_iMode,
byte[] i_byIP_MAC
)
JScript
public function SetAccessControl_Config(
i_iIndex : int,
i_bState : bool,
i_iMode : int,
i_byIP_MAC : Byte[]
) : bool

Parameters

i_iIndex
Client index.
i_bState
Enable/Disable state.
i_iMode
IP(0) or MAC(1) mode
i_byIP_MAC
IP array(4) or MAC array(6)

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetAlarmInfoSetting Method

Configuration.SetAlarmInfoSetting Method
[image]

Set Alarm enable mask. Support module: APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAlarmInfoSetting( _
ByVal i_bEnable As Boolean(), _
ByVal i_bType As Boolean(), _
ByVal i_iMappingSlot As Integer(), _
ByVal i_iMappingCh As Integer(), _
ByVal i_iLimitValue As Integer(), _
ByVal i_iBehaviorSlot As Integer(), _
ByVal i_iBehaviorCh As Integer(), _
ByVal i_iBehaviorOutputValue As Integer() _
) As Boolean
C#
public bool SetAlarmInfoSetting(
bool[] i_bEnable,
bool[] i_bType,
int[] i_iMappingSlot,
int[] i_iMappingCh,
int[] i_iLimitValue,
int[] i_iBehaviorSlot,
int[] i_iBehaviorCh,
int[] i_iBehaviorOutputValue
)
C++
public:
bool SetAlarmInfoSetting(
array<bool>^ i_bEnable,
array<bool>^ i_bType,
array<int>^ i_iMappingSlot,
array<int>^ i_iMappingCh,
array<int>^ i_iLimitValue,
array<int>^ i_iBehaviorSlot,
array<int>^ i_iBehaviorCh,
array<int>^ i_iBehaviorOutputValue
) sealed
J#
public bool SetAlarmInfoSetting(
bool[] i_bEnable,
bool[] i_bType,
int[] i_iMappingSlot,
int[] i_iMappingCh,
int[] i_iLimitValue,
int[] i_iBehaviorSlot,
int[] i_iBehaviorCh,
int[] i_iBehaviorOutputValue
)
JScript
public function SetAlarmInfoSetting(
i_bEnable : bool[],
i_bType : bool[],
i_iMappingSlot : int[],
i_iMappingCh : int[],
i_iLimitValue : int[],
i_iBehaviorSlot : int[],
i_iBehaviorCh : int[],
i_iBehaviorOutputValue : int[]
) : bool

Parameters

i_bEnable
Alarm enable mask.
i_bType
Alarm type mask.
i_iMappingSlot
Alarm mapping slot.
i_iMappingCh
Alarm mapping channel.
i_iLimitValue
Alarm mapping limit value.
i_iBehaviorSlot
Alarm behavior target slot.
i_iBehaviorCh
Alarm behavior target ch.
i_iBehaviorOutputValue
Alarm behavior target output value.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetCommunicationSafety Method

Configuration.SetCommunicationSafety Method
[image]

Support module: ADAM-4024 Set communication safety timeout in seconds

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCommunicationSafety( _
ByVal o_fTimeout As Single _
) As Boolean
C#
public bool SetCommunicationSafety(
float o_fTimeout
)
C++
public:
bool SetCommunicationSafety(
float o_fTimeout
) sealed
J#
public bool SetCommunicationSafety(
float o_fTimeout
)
JScript
public function SetCommunicationSafety(
o_fTimeout : float
) : bool

Parameters

o_fTimeout
The cycle time in seconds, the range is from 0.0~6553.5.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetDataStreamingInterval Method

Configuration.SetDataStreamingInterval Method
[image]

Support module: ADAM-5000TCP, ADAM-6000 Set the interval for data streaming sending

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDataStreamingInterval( _
ByVal i_iInterval As Integer _
) As Boolean
C#
public bool SetDataStreamingInterval(
int i_iInterval
)
C++
public:
bool SetDataStreamingInterval(
int i_iInterval
) sealed
J#
public bool SetDataStreamingInterval(
int i_iInterval
)
JScript
public function SetDataStreamingInterval(
i_iInterval : int
) : bool

Parameters

i_iInterval
The interval in millisecond

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetDataStreamingIP Method

Configuration.SetDataStreamingIP Method

Support module: ADAM-5000TCP, ADAM-6000 Set the data streaming receiver's IP

Overload List

 | Name | Description
Public method | SetDataStreamingIP (Int32, String) | Support module: ADAM-5000TCP, ADAM-6000 Set the data streaming receiver's IP
Public method | SetDataStreamingIP (String) | Support module: APAX-5070 Set the data streaming receiver's IP

See Also

Configuration Class
Advantech.Adam Namespace


SetDataStreamingIP Method (Int32, String)

Configuration.SetDataStreamingIP Method (Int32, String)
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Set the data streaming receiver's IP

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDataStreamingIP( _
ByVal i_iIndex As Integer, _
ByVal i_szIP As String _
) As Boolean
C#
public bool SetDataStreamingIP(
int i_iIndex,
string i_szIP
)
C++
public:
bool SetDataStreamingIP(
int i_iIndex,
String i_szIP
) sealed
J#
public bool SetDataStreamingIP(
int i_iIndex,
string i_szIP
)
JScript
public function SetDataStreamingIP(
i_iIndex : int,
i_szIP : String
) : bool

Parameters

i_iIndex
The receiver index, range from 0 to 7
i_szIP
The IP address of the receiver

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetDataStreamingIP Overload List


SetDataStreamingIP Method (String[])

Configuration.SetDataStreamingIP Method (String[])
See Also Example
[image]

Support module: APAX-5070 Set the data streaming receiver's IP

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDataStreamingIP( _
ByVal i_szIP As String() _
) As Boolean
C#
public bool SetDataStreamingIP(
string[] i_szIP
)
C++
public:
bool SetDataStreamingIP(
array<String>^ i_szIP
) sealed
J#
public bool SetDataStreamingIP(
string[] i_szIP
)
JScript
public function SetDataStreamingIP(
i_szIP : String[]
) : bool

Parameters

i_szIP
The IP address of the receiver

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetDataStreamingIP Overload List


SetDataStreamingMask Method

Configuration.SetDataStreamingMask Method

Support module: APAX-5070 Set the enabled mask for data streaming receiver.

Overload List

 | Name | Description
Public method | SetDataStreamingMask (Boolean) | Support module: APAX-5070 Set the enabled mask for data streaming receiver.
Public method | SetDataStreamingMask (Int32, Boolean) | Support module: ADAM-5000TCP, ADAM-6000 Set the enabled mask for data streaming receiver.

See Also

Configuration Class
Advantech.Adam Namespace


SetDataStreamingMask Method (Boolean[])

Configuration.SetDataStreamingMask Method (Boolean[])
See Also Example
[image]

Support module: APAX-5070 Set the enabled mask for data streaming receiver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDataStreamingMask( _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetDataStreamingMask(
bool[] i_bEnabled
)
C++
public:
bool SetDataStreamingMask(
array<bool>^ i_bEnabled
) sealed
J#
public bool SetDataStreamingMask(
bool[] i_bEnabled
)
JScript
public function SetDataStreamingMask(
i_bEnabled : bool[]
) : bool

Parameters

i_bEnabled
The enabled masks

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetDataStreamingMask Overload List


SetDataStreamingMask Method (Int32, Boolean)

Configuration.SetDataStreamingMask Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Set the enabled mask for data streaming receiver.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDataStreamingMask( _
ByVal i_iIndex As Integer, _
ByVal i_bEnabled As Boolean _
) As Boolean
C#
public bool SetDataStreamingMask(
int i_iIndex,
bool i_bEnabled
)
C++
public:
bool SetDataStreamingMask(
int i_iIndex,
bool i_bEnabled
) sealed
J#
public bool SetDataStreamingMask(
int i_iIndex,
bool i_bEnabled
)
JScript
public function SetDataStreamingMask(
i_iIndex : int,
i_bEnabled : bool
) : bool

Parameters

i_iIndex
The receiver index, range from 0 to 7
i_bEnabled
The enabled mask

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetDataStreamingMask Overload List


SetDatastreamPort Method

Configuration.SetDatastreamPort Method
[image]

Set datastream port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05), ADAM-5000 (V1.427), APAX-5070

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDatastreamPort( _
ByVal i_iPort As Integer _
) As Boolean
C#
public bool SetDatastreamPort(
int i_iPort
)
C++
public:
bool SetDatastreamPort(
int i_iPort
) sealed
J#
public bool SetDatastreamPort(
int i_iPort
)
JScript
public function SetDatastreamPort(
i_iPort : int
) : bool

Parameters

i_iPort
The P2P/GCL port

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetEventTriggerMask Method

Configuration.SetEventTriggerMask Method

Support module: ADAM-5000TCP, ADAM-6000 Set the event trigger mask for all channels

Overload List

 | Name | Description
Public method | SetEventTriggerMask (Adam_EventType, Boolean) | Support module: ADAM-5000TCP, ADAM-6000 Set the event trigger mask for all channels
Public method | SetEventTriggerMask (Adam_EventType, String) | Support module: ADAM-5000TCP, ADAM-6000 Set the event trigger mask for all channels

See Also

Configuration Class
Advantech.Adam Namespace


SetEventTriggerMask Method (Adam_EventType, Boolean[])

Configuration.SetEventTriggerMask Method (Adam_EventType, Boolean[])
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Set the event trigger mask for all channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetEventTriggerMask( _
ByVal i_Type As Adam_EventType, _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetEventTriggerMask(
Adam_EventType i_Type,
bool[] i_bEnabled
)
C++
public:
bool SetEventTriggerMask(
Adam_EventType i_Type,
array<bool>^ i_bEnabled
) sealed
J#
public bool SetEventTriggerMask(
Adam_EventType i_Type,
bool[] i_bEnabled
)
JScript
public function SetEventTriggerMask(
i_Type : Adam_EventType,
i_bEnabled : bool[]
) : bool

Parameters

i_Type
The event type
i_bEnabled
The event mask For ADAM-5000TCP, 16 channels are used for each slot, 8 slots for an ADAM-5000TCP.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetEventTriggerMask Overload List


SetEventTriggerMask Method (Adam_EventType, String)

Configuration.SetEventTriggerMask Method (Adam_EventType, String)
See Also Example
[image]

Support module: ADAM-5000TCP, ADAM-6000 Set the event trigger mask for all channels

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetEventTriggerMask( _
ByVal i_Type As Adam_EventType, _
ByVal i_szMask As String _
) As Boolean
C#
public bool SetEventTriggerMask(
Adam_EventType i_Type,
string i_szMask
)
C++
public:
bool SetEventTriggerMask(
Adam_EventType i_Type,
String i_szMask
) sealed
J#
public bool SetEventTriggerMask(
Adam_EventType i_Type,
string i_szMask
)
JScript
public function SetEventTriggerMask(
i_Type : Adam_EventType,
i_szMask : String
) : bool

Parameters

i_Type
The event type
i_szMask
The event mask string For ADAM-5000TCP, 4 HEX characters are used for each slots, 8 slots for an ADAM-5000TCP.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetEventTriggerMask Overload List


SetEventTriggerPort Method

Configuration.SetEventTriggerPort Method
[image]

Set event trigger port setting. Support: ADAM-5000 (V1.427)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetEventTriggerPort( _
ByVal i_iPort As Integer _
) As Boolean
C#
public bool SetEventTriggerPort(
int i_iPort
)
C++
public:
bool SetEventTriggerPort(
int i_iPort
) sealed
J#
public bool SetEventTriggerPort(
int i_iPort
)
JScript
public function SetEventTriggerPort(
i_iPort : int
) : bool

Parameters

i_iPort
The P2P/GCL port

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetGCL_AuxFlagStatus Method

Configuration.SetGCL_AuxFlagStatus Method

Support module: ADAM-6000 DIO module Set GCL Auxiliary Flag Status

Overload List

 | Name | Description
Public method | SetGCL_AuxFlagStatus (Boolean) | Support module: ADAM-6000 DIO module Set GCL Auxiliary Flag Status
Public method | SetGCL_AuxFlagStatus (Int32, Boolean) | Support module: ADAM-6000 DIO module Set GCL Auxiliary Flag Status

See Also

Configuration Class
Advantech.Adam Namespace


SetGCL_AuxFlagStatus Method (Boolean[])

Configuration.SetGCL_AuxFlagStatus Method (Boolean[])
See Also Example
[image]

Support module: ADAM-6000 DIO module Set GCL Auxiliary Flag Status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetGCL_AuxFlagStatus( _
ByVal i_bStatus As Boolean() _
) As Boolean
C#
public bool SetGCL_AuxFlagStatus(
bool[] i_bStatus
)
C++
public:
bool SetGCL_AuxFlagStatus(
array<bool>^ i_bStatus
) sealed
J#
public bool SetGCL_AuxFlagStatus(
bool[] i_bStatus
)
JScript
public function SetGCL_AuxFlagStatus(
i_bStatus : bool[]
) : bool

Parameters

i_bStatus
GCL Auxiliary Flag Status

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetGCL_AuxFlagStatus Overload List


SetGCL_AuxFlagStatus Method (Int32, Boolean)

Configuration.SetGCL_AuxFlagStatus Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-6000 DIO module Set GCL Auxiliary Flag Status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetGCL_AuxFlagStatus( _
ByVal i_iIndex As Integer, _
ByVal i_bStatus As Boolean _
) As Boolean
C#
public bool SetGCL_AuxFlagStatus(
int i_iIndex,
bool i_bStatus
)
C++
public:
bool SetGCL_AuxFlagStatus(
int i_iIndex,
bool i_bStatus
) sealed
J#
public bool SetGCL_AuxFlagStatus(
int i_iIndex,
bool i_bStatus
)
JScript
public function SetGCL_AuxFlagStatus(
i_iIndex : int,
i_bStatus : bool
) : bool

Parameters

i_iIndex
The index of GCL Auxiliary Flag Status
i_bStatus
GCL Auxiliary Flag Status

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetGCL_AuxFlagStatus Overload List


SetModbusAddressConfig Method

Configuration.SetModbusAddressConfig Method
[image]

Support module: ADAM-5000 Set MODBUS address configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModbusAddressConfig( _
ByVal i_iSlot As Integer, _
ByVal i_iStartAddr As Integer, _
ByVal i_iLengthIndex As Integer _
) As Boolean
C#
public bool SetModbusAddressConfig(
int i_iSlot,
int i_iStartAddr,
int i_iLengthIndex
)
C++
public:
bool SetModbusAddressConfig(
int i_iSlot,
int i_iStartAddr,
int i_iLengthIndex
) sealed
J#
public bool SetModbusAddressConfig(
int i_iSlot,
int i_iStartAddr,
int i_iLengthIndex
)
JScript
public function SetModbusAddressConfig(
i_iSlot : int,
i_iStartAddr : int,
i_iLengthIndex : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iStartAddr
The MODBUS starting address.
i_iLengthIndex
The length index. 0: length is 0 1: length is 1 2: length is 2 3: length is 4 4: length is 8 5: length is 16 6: length is 32 7: length is 64

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetModuleCOMConfig Method

Configuration.SetModuleCOMConfig Method

Support module: ADAM-4100, ADAM-5000 Set module COM configuration.

Overload List

 | Name | Description
Public method | SetModuleCOMConfig (AdamCOMConfig) | Support module: ADAM-4100, ADAM-5000 Set module COM configuration.
Public method | SetModuleCOMConfig (Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Support module: APAX-5090 Set module COM configuration.

See Also

Configuration Class
Advantech.Adam Namespace


SetModuleCOMConfig Method (AdamCOMConfig)

Configuration.SetModuleCOMConfig Method (AdamCOMConfig)
See Also Example
[image]

Support module: ADAM-4100, ADAM-5000 Set module COM configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModuleCOMConfig( _
ByVal o_objCon As AdamCOMConfig _
) As Boolean
C#
public bool SetModuleCOMConfig(
AdamCOMConfig o_objCon
)
C++
public:
bool SetModuleCOMConfig(
AdamCOMConfig o_objCon
) sealed
J#
public bool SetModuleCOMConfig(
AdamCOMConfig o_objCon
)
JScript
public function SetModuleCOMConfig(
o_objCon : AdamCOMConfig
) : bool

Parameters

o_objCon
The AdamCOMConfig object.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetModuleCOMConfig Overload List


SetModuleCOMConfig Method (Int32, Int32, Int32, Int32, Int32, Int32, Int32)

Configuration.SetModuleCOMConfig Method (Int32, Int32, Int32, Int32, Int32, Int32, Int32)
See Also Example
[image]

Support module: APAX-5090 Set module COM configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModuleCOMConfig( _
ByVal i_iSlot As Integer, _
ByVal i_iCom As Integer, _
ByVal i_iBaudRate As Integer, _
ByVal i_iDataBit As Integer, _
ByVal i_iStopBit As Integer, _
ByVal i_iParity As Integer, _
ByVal i_iFlowControl As Integer _
) As Boolean
C#
public bool SetModuleCOMConfig(
int i_iSlot,
int i_iCom,
int i_iBaudRate,
int i_iDataBit,
int i_iStopBit,
int i_iParity,
int i_iFlowControl
)
C++
public:
bool SetModuleCOMConfig(
int i_iSlot,
int i_iCom,
int i_iBaudRate,
int i_iDataBit,
int i_iStopBit,
int i_iParity,
int i_iFlowControl
) sealed
J#
public bool SetModuleCOMConfig(
int i_iSlot,
int i_iCom,
int i_iBaudRate,
int i_iDataBit,
int i_iStopBit,
int i_iParity,
int i_iFlowControl
)
JScript
public function SetModuleCOMConfig(
i_iSlot : int,
i_iCom : int,
i_iBaudRate : int,
i_iDataBit : int,
i_iStopBit : int,
i_iParity : int,
i_iFlowControl : int
) : bool

Parameters

i_iSlot
Slot index. (switch id : 0~15)
i_iCom
Com index. (com port id : 1~4)
i_iBaudRate
Baudrate index. (Baudrate value index : 0~9)
i_iDataBit
Data Bit index. (Data Bit value index : 0~1)
i_iStopBit
Stop Bit index. (Stop Bit value index : 0~3)
i_iParity
Parity index. (Parity value index : 0~4)
i_iFlowControl
Flow Control index. (Flow Control value index : 0~3)

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetModuleCOMConfig Overload List


SetModuleCOMTcpPortMapping Method

Configuration.SetModuleCOMTcpPortMapping Method
[image]

Support module: APAX-5090 Set module COM (COM1~COM4) TCP port mapping values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModuleCOMTcpPortMapping( _
ByVal i_iSlot As Integer, _
ByVal i_iTcpPortValues As Integer() _
) As Boolean
C#
public bool SetModuleCOMTcpPortMapping(
int i_iSlot,
int[] i_iTcpPortValues
)
C++
public:
bool SetModuleCOMTcpPortMapping(
int i_iSlot,
array<int>^ i_iTcpPortValues
) sealed
J#
public bool SetModuleCOMTcpPortMapping(
int i_iSlot,
int[] i_iTcpPortValues
)
JScript
public function SetModuleCOMTcpPortMapping(
i_iSlot : int,
i_iTcpPortValues : int[]
) : bool

Parameters

i_iSlot
Slot index. (switch id : 0~15)
i_iTcpPortValues
Tcp port mapping values (COM1~COM4)

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetModuleConfig Method

Configuration.SetModuleConfig Method

Support module: ADAM-4000 Set module configuration.

Overload List

 | Name | Description
Public method | SetModuleConfig (Adam4000Config) | Support module: ADAM-4000 Set module configuration.
Public method | SetModuleConfig (Adam5000Config) | Support module: ADAM-5000 Set module configuration.

See Also

Configuration Class
Advantech.Adam Namespace


SetModuleConfig Method (Adam4000Config)

Configuration.SetModuleConfig Method (Adam4000Config)
See Also Example
[image]

Support module: ADAM-4000 Set module configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModuleConfig( _
ByVal o_objCon As Adam4000Config _
) As Boolean
C#
public bool SetModuleConfig(
Adam4000Config o_objCon
)
C++
public:
bool SetModuleConfig(
Adam4000Config o_objCon
) sealed
J#
public bool SetModuleConfig(
Adam4000Config o_objCon
)
JScript
public function SetModuleConfig(
o_objCon : Adam4000Config
) : bool

Parameters

o_objCon
The Adam4000Config object.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetModuleConfig Overload List


SetModuleConfig Method (Adam5000Config)

Configuration.SetModuleConfig Method (Adam5000Config)
See Also Example
[image]

Support module: ADAM-5000 Set module configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModuleConfig( _
ByVal o_objCon As Adam5000Config _
) As Boolean
C#
public bool SetModuleConfig(
Adam5000Config o_objCon
)
C++
public:
bool SetModuleConfig(
Adam5000Config o_objCon
) sealed
J#
public bool SetModuleConfig(
Adam5000Config o_objCon
)
JScript
public function SetModuleConfig(
o_objCon : Adam5000Config
) : bool

Parameters

o_objCon
The Adam5000Config object.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetModuleConfig Overload List


SetModuleGroupSetting Method

Configuration.SetModuleGroupSetting Method
[image]

Support module: APAX-5070 Set module group setting.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModuleGroupSetting( _
ByVal i_bTurnOn As Boolean _
) As Boolean
C#
public bool SetModuleGroupSetting(
bool i_bTurnOn
)
C++
public:
bool SetModuleGroupSetting(
bool i_bTurnOn
) sealed
J#
public bool SetModuleGroupSetting(
bool i_bTurnOn
)
JScript
public function SetModuleGroupSetting(
i_bTurnOn : bool
) : bool

Parameters

i_bTurnOn
Enable burnout detect enable.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetModuleLocated Method

Configuration.SetModuleLocated Method
[image]

Support module: ADAM-4100 Set module located LED.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModuleLocated( _
ByVal i_bTurnOn As Boolean _
) As Boolean
C#
public bool SetModuleLocated(
bool i_bTurnOn
)
C++
public:
bool SetModuleLocated(
bool i_bTurnOn
) sealed
J#
public bool SetModuleLocated(
bool i_bTurnOn
)
JScript
public function SetModuleLocated(
i_bTurnOn : bool
) : bool

Parameters

i_bTurnOn
Turn ON the LED.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetNetworkDiagEnable Method

Configuration.SetNetworkDiagEnable Method
[image]

Set the network diagnostic enable flag. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetNetworkDiagEnable( _
ByVal i_bEnable As Boolean _
) As Boolean
C#
public bool SetNetworkDiagEnable(
bool i_bEnable
)
C++
public:
bool SetNetworkDiagEnable(
bool i_bEnable
) sealed
J#
public bool SetNetworkDiagEnable(
bool i_bEnable
)
JScript
public function SetNetworkDiagEnable(
i_bEnable : bool
) : bool

Parameters

i_bEnable
The network diagnostic enable flag.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetP2P_Config Method

Configuration.SetP2P_Config Method

Support module: ADAM-6000/W Digital Input/Output module Set Peer to Peer configuration.

Overload List

 | Name | Description
Public method | SetP2P_Config (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean) | Support module: ADAM-6000/W Digital Input/Output module Set Peer to Peer configuration.
Public method | SetP2P_Config (Int32, Boolean, Int32, Byte, Int32, Byte, Boolean, Int32) | Support module: ADAM-6000 Analog Input module Set Peer to Peer configuration.

See Also

Configuration Class
Advantech.Adam Namespace


SetP2P_Config Method (Int32, Boolean, Int32, Byte[], Int32, Byte, Boolean[])

Configuration.SetP2P_Config Method (Int32, Boolean, Int32, Byte[], Int32, Byte, Boolean[])
See Also Example
[image]

Support module: ADAM-6000/W Digital Input/Output module Set Peer to Peer configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetP2P_Config( _
ByVal i_iChannel As Integer, _
ByVal i_bState As Boolean, _
ByVal i_iPeriodTime As Integer, _
ByVal i_byIP As Byte(), _
ByVal i_iModbusAddr As Integer, _
ByVal i_byModuleID As Byte, _
ByVal i_bMask As Boolean() _
) As Boolean
C#
public bool SetP2P_Config(
int i_iChannel,
bool i_bState,
int i_iPeriodTime,
byte[] i_byIP,
int i_iModbusAddr,
byte i_byModuleID,
bool[] i_bMask
)
C++
public:
bool SetP2P_Config(
int i_iChannel,
bool i_bState,
int i_iPeriodTime,
array<char>^ i_byIP,
int i_iModbusAddr,
char i_byModuleID,
array<bool>^ i_bMask
) sealed
J#
public bool SetP2P_Config(
int i_iChannel,
bool i_bState,
int i_iPeriodTime,
byte[] i_byIP,
int i_iModbusAddr,
byte i_byModuleID,
bool[] i_bMask
)
JScript
public function SetP2P_Config(
i_iChannel : int,
i_bState : bool,
i_iPeriodTime : int,
i_byIP : Byte[],
i_iModbusAddr : int,
i_byModuleID : Byte,
i_bMask : bool[]
) : bool

Parameters

i_iChannel
Channel index.
i_bState
Change of state.
i_iPeriodTime
Period time. The value is between 0~4095.
i_byIP
Map to IP.
i_iModbusAddr
Map to modbus address.
i_byModuleID
Map to module ID.
i_bMask
Basic mode mask.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetP2P_Config Overload List


SetP2P_Config Method (Int32, Boolean, Int32, Byte[], Int32, Byte, Boolean[], Int32)

Configuration.SetP2P_Config Method (Int32, Boolean, Int32, Byte[], Int32, Byte, Boolean[], Int32)
See Also Example
[image]

Support module: ADAM-6000 Analog Input module Set Peer to Peer configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetP2P_Config( _
ByVal i_iChannel As Integer, _
ByVal i_bState As Boolean, _
ByVal i_iPeriodTime As Integer, _
ByVal i_byIP As Byte(), _
ByVal i_iModbusAddr As Integer, _
ByVal i_byModuleID As Byte, _
ByVal i_bMask As Boolean(), _
ByVal i_iDeviationRate As Integer _
) As Boolean
C#
public bool SetP2P_Config(
int i_iChannel,
bool i_bState,
int i_iPeriodTime,
byte[] i_byIP,
int i_iModbusAddr,
byte i_byModuleID,
bool[] i_bMask,
int i_iDeviationRate
)
C++
public:
bool SetP2P_Config(
int i_iChannel,
bool i_bState,
int i_iPeriodTime,
array<char>^ i_byIP,
int i_iModbusAddr,
char i_byModuleID,
array<bool>^ i_bMask,
int i_iDeviationRate
) sealed
J#
public bool SetP2P_Config(
int i_iChannel,
bool i_bState,
int i_iPeriodTime,
byte[] i_byIP,
int i_iModbusAddr,
byte i_byModuleID,
bool[] i_bMask,
int i_iDeviationRate
)
JScript
public function SetP2P_Config(
i_iChannel : int,
i_bState : bool,
i_iPeriodTime : int,
i_byIP : Byte[],
i_iModbusAddr : int,
i_byModuleID : Byte,
i_bMask : bool[],
i_iDeviationRate : int
) : bool

Parameters

i_iChannel
Channel index.
i_bState
Change of state.
i_iPeriodTime
Period time. The value is between 0~4095.
i_byIP
Map to IP.
i_iModbusAddr
Map to modbus address.
i_byModuleID
Map to module ID.
i_bMask
Basic mode mask.
i_iDeviationRate
Deviation Rate.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetP2P_Config Overload List


SetP2pGclPort Method

Configuration.SetP2pGclPort Method
[image]

Set P2P/GCL port setting. Support: ADAM-6000 (DIO:V4.10/AI:V4.05)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetP2pGclPort( _
ByVal i_iPort As Integer _
) As Boolean
C#
public bool SetP2pGclPort(
int i_iPort
)
C++
public:
bool SetP2pGclPort(
int i_iPort
) sealed
J#
public bool SetP2pGclPort(
int i_iPort
)
JScript
public function SetP2pGclPort(
i_iPort : int
) : bool

Parameters

i_iPort
The P2P/GCL port.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetP2PValueStatus Method

Configuration.SetP2PValueStatus Method

Set P2P mapping value status. Support module: ADAM-6017 (after V4.05)

Overload List

 | Name | Description
Public method | SetP2PValueStatus (Boolean) | Set P2P mapping value status. Support module: ADAM-6017 (after V4.05)
Public method | SetP2PValueStatus (Byte) | Set P2P mapping value status. Support module: ADAM-6217

See Also

Configuration Class
Advantech.Adam Namespace


SetP2PValueStatus Method (Boolean)

Configuration.SetP2PValueStatus Method (Boolean)
See Also Example
[image]

Set P2P mapping value status. Support module: ADAM-6017 (after V4.05)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetP2PValueStatus( _
ByVal i_bEnable As Boolean _
) As Boolean
C#
public bool SetP2PValueStatus(
bool i_bEnable
)
C++
public:
bool SetP2PValueStatus(
bool i_bEnable
) sealed
J#
public bool SetP2PValueStatus(
bool i_bEnable
)
JScript
public function SetP2PValueStatus(
i_bEnable : bool
) : bool

Parameters

i_bEnable
Enable only upper half value valid flag.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetP2PValueStatus Overload List


SetP2PValueStatus Method (Byte)

Configuration.SetP2PValueStatus Method (Byte)
See Also Example
[image]

Set P2P mapping value status. Support module: ADAM-6217

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetP2PValueStatus( _
ByVal i_byStatus As Byte _
) As Boolean
C#
public bool SetP2PValueStatus(
byte i_byStatus
)
C++
public:
bool SetP2PValueStatus(
char i_byStatus
) sealed
J#
public bool SetP2PValueStatus(
byte i_byStatus
)
JScript
public function SetP2PValueStatus(
i_byStatus : Byte
) : bool

Parameters

i_byStatus
Setting Enable only upper half value valid flag Information.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetP2PValueStatus Overload List


SetThermocoupleMode Method

Configuration.SetThermocoupleMode Method
[image]

Support module: ADAM-4100 Set Thermocouple mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetThermocoupleMode( _
ByVal i_iMode As Integer _
) As Boolean
C#
public bool SetThermocoupleMode(
int i_iMode
)
C++
public:
bool SetThermocoupleMode(
int i_iMode
) sealed
J#
public bool SetThermocoupleMode(
int i_iMode
)
JScript
public function SetThermocoupleMode(
i_iMode : int
) : bool

Parameters

i_iMode
The thermocouple mode.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetWDTMask Method

Configuration.SetWDTMask Method
[image]

Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout mask.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetWDTMask( _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetWDTMask(
bool[] i_bEnabled
)
C++
public:
bool SetWDTMask(
array<bool>^ i_bEnabled
) sealed
J#
public bool SetWDTMask(
bool[] i_bEnabled
)
JScript
public function SetWDTMask(
i_bEnabled : bool[]
) : bool

Parameters

i_bEnabled
The array of boolean values indicate the WDT mask for each slot

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SetWDTTimeout Method

Configuration.SetWDTTimeout Method

Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout value in seconds

Overload List

 | Name | Description
Public method | SetWDTTimeout (Int32) | Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout value in seconds
Public method | SetWDTTimeout (Single) | Support module: ADAM-4000, ADAM-4100 Set WDT cycle time in seconds

See Also

Configuration Class
Advantech.Adam Namespace


SetWDTTimeout Method (Int32)

Configuration.SetWDTTimeout Method (Int32)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP Set WDT timeout value in seconds

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetWDTTimeout( _
ByVal i_iWDTTimeout As Integer _
) As Boolean
C#
public bool SetWDTTimeout(
int i_iWDTTimeout
)
C++
public:
bool SetWDTTimeout(
int i_iWDTTimeout
) sealed
J#
public bool SetWDTTimeout(
int i_iWDTTimeout
)
JScript
public function SetWDTTimeout(
i_iWDTTimeout : int
) : bool

Parameters

i_iWDTTimeout
The timeout value in seconds

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetWDTTimeout Overload List


SetWDTTimeout Method (Single)

Configuration.SetWDTTimeout Method (Single)
See Also Example
[image]

Support module: ADAM-4000, ADAM-4100 Set WDT cycle time in seconds

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetWDTTimeout( _
ByVal i_fWDTTimeout As Single _
) As Boolean
C#
public bool SetWDTTimeout(
float i_fWDTTimeout
)
C++
public:
bool SetWDTTimeout(
float i_fWDTTimeout
) sealed
J#
public bool SetWDTTimeout(
float i_fWDTTimeout
)
JScript
public function SetWDTTimeout(
i_fWDTTimeout : float
) : bool

Parameters

i_fWDTTimeout
The cycle time in seconds, the range is from 0 to 999.9.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SetWDTTimeout Overload List


SYS_GetAllSlotErrorFlag Method

Configuration.SYS_GetAllSlotErrorFlag Method
[image]

APAX API. Support module: APAX-5000 Get all slot error flags.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetAllSlotErrorFlag( _
<OutAttribute> ByRef o_bFlag As Boolean _
) As Boolean
C#
public bool SYS_GetAllSlotErrorFlag(
out bool o_bFlag
)
C++
public:
bool SYS_GetAllSlotErrorFlag(
[OutAttribute] bool% o_bFlag
) sealed
J#
public bool SYS_GetAllSlotErrorFlag(
/** @attribute OutAttribute() */ /** @ref */ bool o_bFlag
)
JScript
public function SYS_GetAllSlotErrorFlag(
OutAttribute o_bFlag : bool
) : bool

Parameters

o_bFlag
The slot error flags. (size:16)

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetAppAStatus Method

Configuration.SYS_GetAppAStatus Method
[image]

APAX API. Backup System: Get the application A status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetAppAStatus( _
<OutAttribute> ByRef o_bAlive As Boolean _
) As Boolean
C#
public bool SYS_GetAppAStatus(
out bool o_bAlive
)
C++
public:
bool SYS_GetAppAStatus(
[OutAttribute] bool% o_bAlive
) sealed
J#
public bool SYS_GetAppAStatus(
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlive
)
JScript
public function SYS_GetAppAStatus(
OutAttribute o_bAlive : bool
) : bool

Parameters

o_bAlive
The application A status.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetAppBStatus Method

Configuration.SYS_GetAppBStatus Method
[image]

APAX API. Backup System: Get the application B status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetAppBStatus( _
<OutAttribute> ByRef o_bAlive As Boolean _
) As Boolean
C#
public bool SYS_GetAppBStatus(
out bool o_bAlive
)
C++
public:
bool SYS_GetAppBStatus(
[OutAttribute] bool% o_bAlive
) sealed
J#
public bool SYS_GetAppBStatus(
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlive
)
JScript
public function SYS_GetAppBStatus(
OutAttribute o_bAlive : bool
) : bool

Parameters

o_bAlive
The application B status.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetArmFirmwareVersion Method

Configuration.SYS_GetArmFirmwareVersion Method
[image]

Support module: ADAM-5550 Get the ARM firmware version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetArmFirmwareVersion( _
<OutAttribute> ByRef o_fVer As Single _
) As Boolean
C#
public bool SYS_GetArmFirmwareVersion(
out float o_fVer
)
C++
public:
bool SYS_GetArmFirmwareVersion(
[OutAttribute] float% o_fVer
) sealed
J#
public bool SYS_GetArmFirmwareVersion(
/** @attribute OutAttribute() */ /** @ref */ float o_fVer
)
JScript
public function SYS_GetArmFirmwareVersion(
OutAttribute o_fVer : float
) : bool

Parameters

o_fVer
The ARM firmware version.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetCPLDVersion Method

Configuration.SYS_GetCPLDVersion Method
[image]

Support module: ADAM-5550 Get the CPLD version

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetCPLDVersion( _
<OutAttribute> ByRef o_usCPLD As UInt16 _
) As Boolean
C#
public bool SYS_GetCPLDVersion(
out ushort o_usCPLD
)
C++
public:
bool SYS_GetCPLDVersion(
[OutAttribute] unsigned short% o_usCPLD
) sealed
J#
public bool SYS_GetCPLDVersion(
/** @attribute OutAttribute() */ /** @ref */ ushort o_usCPLD
)
JScript
public function SYS_GetCPLDVersion(
OutAttribute o_usCPLD : UInt16
) : bool

Parameters

o_usCPLD
The CPLD version.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetDspChannelFlag Method

Configuration.SYS_GetDspChannelFlag Method

APAX API. Get dsp channel flag.

Overload List

 | Name | Description
Public method | SYS_GetDspChannelFlag (Boolean) | APAX API. Get dsp channel flag.
Public method | SYS_GetDspChannelFlag (UInt16) | APAX API. Get dsp channel flag.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetDspChannelFlag Method (Boolean)

Configuration.SYS_GetDspChannelFlag Method (Boolean)
See Also Example
[image]

APAX API. Get dsp channel flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetDspChannelFlag( _
<OutAttribute> ByRef o_bTurnOn As Boolean _
) As Boolean
C#
public bool SYS_GetDspChannelFlag(
out bool o_bTurnOn
)
C++
public:
bool SYS_GetDspChannelFlag(
[OutAttribute] bool% o_bTurnOn
) sealed
J#
public bool SYS_GetDspChannelFlag(
/** @attribute OutAttribute() */ /** @ref */ bool o_bTurnOn
)
JScript
public function SYS_GetDspChannelFlag(
OutAttribute o_bTurnOn : bool
) : bool

Parameters

o_bTurnOn
The dsp channel flag.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SYS_GetDspChannelFlag Overload List


SYS_GetDspChannelFlag Method (UInt16)

Configuration.SYS_GetDspChannelFlag Method (UInt16)
See Also Example
[image]

APAX API. Get dsp channel flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetDspChannelFlag( _
<OutAttribute> ByRef o_wFlag As UInt16 _
) As Boolean
C#
public bool SYS_GetDspChannelFlag(
out ushort o_wFlag
)
C++
public:
bool SYS_GetDspChannelFlag(
[OutAttribute] unsigned short% o_wFlag
) sealed
J#
public bool SYS_GetDspChannelFlag(
/** @attribute OutAttribute() */ /** @ref */ ushort o_wFlag
)
JScript
public function SYS_GetDspChannelFlag(
OutAttribute o_wFlag : UInt16
) : bool

Parameters

o_wFlag
The dsp channel flag. (Turn on:0x55aa ; turn off:others)

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SYS_GetDspChannelFlag Overload List


SYS_GetGlobalActive Method

Configuration.SYS_GetGlobalActive Method
[image]

APAX API. Backup System: Get the global machine ID.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetGlobalActive( _
<OutAttribute> ByRef o_wActive As UInt16 _
) As Boolean
C#
public bool SYS_GetGlobalActive(
out ushort o_wActive
)
C++
public:
bool SYS_GetGlobalActive(
[OutAttribute] unsigned short% o_wActive
) sealed
J#
public bool SYS_GetGlobalActive(
/** @attribute OutAttribute() */ /** @ref */ ushort o_wActive
)
JScript
public function SYS_GetGlobalActive(
OutAttribute o_wActive : UInt16
) : bool

Parameters

o_wActive
The global machine ID.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetGlobalMachineID Method

Configuration.SYS_GetGlobalMachineID Method
[image]

APAX API. Backup System: Get the global machine ID.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetGlobalMachineID( _
<OutAttribute> ByRef o_wID As UInt16 _
) As Boolean
C#
public bool SYS_GetGlobalMachineID(
out ushort o_wID
)
C++
public:
bool SYS_GetGlobalMachineID(
[OutAttribute] unsigned short% o_wID
) sealed
J#
public bool SYS_GetGlobalMachineID(
/** @attribute OutAttribute() */ /** @ref */ ushort o_wID
)
JScript
public function SYS_GetGlobalMachineID(
OutAttribute o_wID : UInt16
) : bool

Parameters

o_wID
The global machine ID.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetGlobalStatus Method

Configuration.SYS_GetGlobalStatus Method
[image]

APAX API. Backup System: Get the global status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetGlobalStatus( _
<OutAttribute> ByRef o_wStatus As UInt16 _
) As Boolean
C#
public bool SYS_GetGlobalStatus(
out ushort o_wStatus
)
C++
public:
bool SYS_GetGlobalStatus(
[OutAttribute] unsigned short% o_wStatus
) sealed
J#
public bool SYS_GetGlobalStatus(
/** @attribute OutAttribute() */ /** @ref */ ushort o_wStatus
)
JScript
public function SYS_GetGlobalStatus(
OutAttribute o_wStatus : UInt16
) : bool

Parameters

o_wStatus
The global status.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetHeartbeatRun Method

Configuration.SYS_GetHeartbeatRun Method
[image]

APAX API. Backup System: Set the heartbeat run mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetHeartbeatRun( _
<OutAttribute> ByRef o_bRun As Boolean _
) As Boolean
C#
public bool SYS_GetHeartbeatRun(
out bool o_bRun
)
C++
public:
bool SYS_GetHeartbeatRun(
[OutAttribute] bool% o_bRun
) sealed
J#
public bool SYS_GetHeartbeatRun(
/** @attribute OutAttribute() */ /** @ref */ bool o_bRun
)
JScript
public function SYS_GetHeartbeatRun(
OutAttribute o_bRun : bool
) : bool

Parameters

o_bRun
The heartbeat run mode.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetRawData Method

Configuration.SYS_GetRawData Method
[image]

Support module: APAX-5000 Get the raw data of DPM.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetRawData( _
ByVal i_dwStart As UInt32, _
ByVal i_dwLength As UInt32, _
<OutAttribute> ByRef o_dwRawData As Byte _
) As Boolean
C#
public bool SYS_GetRawData(
uint i_dwStart,
uint i_dwLength,
out byte o_dwRawData
)
C++
public:
bool SYS_GetRawData(
unsigned int i_dwStart,
unsigned int i_dwLength,
[OutAttribute] char% o_dwRawData
) sealed
J#
public bool SYS_GetRawData(
uint i_dwStart,
uint i_dwLength,
/** @attribute OutAttribute() */ /** @ref */ byte o_dwRawData
)
JScript
public function SYS_GetRawData(
i_dwStart : UInt32,
i_dwLength : UInt32,
OutAttribute o_dwRawData : Byte
) : bool

Parameters

i_dwStart
The start address of DPM
i_dwLength
The data length
o_dwRawData
The raw data of DPM

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_GetVersion Method

Configuration.SYS_GetVersion Method
[image]

APAX API. Get the driver version.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_GetVersion( _
<OutAttribute> ByRef o_dwVersion As UInt32 _
) As Boolean
C#
public bool SYS_GetVersion(
out uint o_dwVersion
)
C++
public:
bool SYS_GetVersion(
[OutAttribute] unsigned int% o_dwVersion
) sealed
J#
public bool SYS_GetVersion(
/** @attribute OutAttribute() */ /** @ref */ uint o_dwVersion
)
JScript
public function SYS_GetVersion(
OutAttribute o_dwVersion : UInt32
) : bool

Parameters

o_dwVersion
The driver version.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetAppAHeartbeat Method

Configuration.SYS_SetAppAHeartbeat Method
[image]

APAX API. Backup System: Set the application A heartbeat.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetAppAHeartbeat() As Boolean
C#
public bool SYS_SetAppAHeartbeat()
C++
public:
bool SYS_SetAppAHeartbeat() sealed
J#
public bool SYS_SetAppAHeartbeat()
JScript
public function SYS_SetAppAHeartbeat() : bool

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetAppBHeartbeat Method

Configuration.SYS_SetAppBHeartbeat Method
[image]

APAX API. Backup System: Set the application B heartbeat.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetAppBHeartbeat() As Boolean
C#
public bool SYS_SetAppBHeartbeat()
C++
public:
bool SYS_SetAppBHeartbeat() sealed
J#
public bool SYS_SetAppBHeartbeat()
JScript
public function SYS_SetAppBHeartbeat() : bool

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetCmdWriteRead Method

Configuration.SYS_SetCmdWriteRead Method
[image]

APAX API. Internal used. DO NOT call this function in your program.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetCmdWriteRead( _
ByVal i_usSlot As Integer, _
ByVal i_wMsgType As UInt16, _
ByVal i_uiPara1 As UInt32, _
ByVal i_uiPara2 As UInt32, _
ByVal i_uiPara3 As UInt32, _
ByVal i_uiPara4 As UInt32, _
ByVal i_uiPara5 As UInt32 _
) As Boolean
C#
public bool SYS_SetCmdWriteRead(
int i_usSlot,
ushort i_wMsgType,
uint i_uiPara1,
uint i_uiPara2,
uint i_uiPara3,
uint i_uiPara4,
uint i_uiPara5
)
C++
public:
bool SYS_SetCmdWriteRead(
int i_usSlot,
unsigned short i_wMsgType,
unsigned int i_uiPara1,
unsigned int i_uiPara2,
unsigned int i_uiPara3,
unsigned int i_uiPara4,
unsigned int i_uiPara5
) sealed
J#
public bool SYS_SetCmdWriteRead(
int i_usSlot,
ushort i_wMsgType,
uint i_uiPara1,
uint i_uiPara2,
uint i_uiPara3,
uint i_uiPara4,
uint i_uiPara5
)
JScript
public function SYS_SetCmdWriteRead(
i_usSlot : int,
i_wMsgType : UInt16,
i_uiPara1 : UInt32,
i_uiPara2 : UInt32,
i_uiPara3 : UInt32,
i_uiPara4 : UInt32,
i_uiPara5 : UInt32
) : bool

Parameters

i_usSlot
The slot number, based 0.
i_wMsgType
The message type.
i_uiPara1
The parameter 1.
i_uiPara2
The parameter 2.
i_uiPara3
The parameter 3.
i_uiPara4
The parameter 4.
i_uiPara5
The parameter 5.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetCommLock Method

Configuration.SYS_SetCommLock Method
[image]

APAX API. Internal used. DO NOT call this function in your program.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetCommLock( _
ByVal i_wLock As UInt16 _
) As Boolean
C#
public bool SYS_SetCommLock(
ushort i_wLock
)
C++
public:
bool SYS_SetCommLock(
unsigned short i_wLock
) sealed
J#
public bool SYS_SetCommLock(
ushort i_wLock
)
JScript
public function SYS_SetCommLock(
i_wLock : UInt16
) : bool

Parameters

i_wLock
The lock status.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetDownloadMode Method

Configuration.SYS_SetDownloadMode Method
[image]

APAX API. Support module: APAX-5000, APAX-5070 Set download mode. (Internal use)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetDownloadMode( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SYS_SetDownloadMode(
int i_iSlot
)
C++
public:
bool SYS_SetDownloadMode(
int i_iSlot
) sealed
J#
public bool SYS_SetDownloadMode(
int i_iSlot
)
JScript
public function SYS_SetDownloadMode(
i_iSlot : int
) : bool

Parameters

i_iSlot
The slot number. (module:0~15, dsp platform:0xD2~0xD4)

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetDownloadPacket Method

Configuration.SYS_SetDownloadPacket Method
[image]

APAX API. Support module: APAX-5000 Set download data packet. (Internal use)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetDownloadPacket( _
ByVal i_iSlot As Integer, _
ByVal i_wSequence As Integer, _
ByVal i_byData As Byte() _
) As Boolean
C#
public bool SYS_SetDownloadPacket(
int i_iSlot,
int i_wSequence,
byte[] i_byData
)
C++
public:
bool SYS_SetDownloadPacket(
int i_iSlot,
int i_wSequence,
array<char>^ i_byData
) sealed
J#
public bool SYS_SetDownloadPacket(
int i_iSlot,
int i_wSequence,
byte[] i_byData
)
JScript
public function SYS_SetDownloadPacket(
i_iSlot : int,
i_wSequence : int,
i_byData : Byte[]
) : bool

Parameters

i_iSlot
The slot number. (module:0~15, dsp platform:0xD2~0xD4)
i_wSequence
The sequence number of the packet.
i_byData
The data of the packet.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetDownloadStart Method

Configuration.SYS_SetDownloadStart Method
[image]

APAX API. Support module: APAX-5000 Set download start flag. (Internal use)

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetDownloadStart( _
ByVal i_iSlot As Integer _
) As Boolean
C#
public bool SYS_SetDownloadStart(
int i_iSlot
)
C++
public:
bool SYS_SetDownloadStart(
int i_iSlot
) sealed
J#
public bool SYS_SetDownloadStart(
int i_iSlot
)
JScript
public function SYS_SetDownloadStart(
i_iSlot : int
) : bool

Parameters

i_iSlot
The slot number. (module:0~15, dsp platform:0xD2~0xD4)

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetDspChannelFlag Method

Configuration.SYS_SetDspChannelFlag Method

APAX API. Set dsp channel flag.

Overload List

 | Name | Description
Public method | SYS_SetDspChannelFlag (Boolean) | APAX API. Set dsp channel flag.
Public method | SYS_SetDspChannelFlag (UInt16) | APAX API. Set dsp channel flag.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetDspChannelFlag Method (Boolean)

Configuration.SYS_SetDspChannelFlag Method (Boolean)
See Also Example
[image]

APAX API. Set dsp channel flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetDspChannelFlag( _
ByVal i_bTurnOn As Boolean _
) As Boolean
C#
public bool SYS_SetDspChannelFlag(
bool i_bTurnOn
)
C++
public:
bool SYS_SetDspChannelFlag(
bool i_bTurnOn
) sealed
J#
public bool SYS_SetDspChannelFlag(
bool i_bTurnOn
)
JScript
public function SYS_SetDspChannelFlag(
i_bTurnOn : bool
) : bool

Parameters

i_bTurnOn
The dsp channel flag.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SYS_SetDspChannelFlag Overload List


SYS_SetDspChannelFlag Method (UInt16)

Configuration.SYS_SetDspChannelFlag Method (UInt16)
See Also Example
[image]

APAX API. Set dsp channel flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetDspChannelFlag( _
ByVal i_wFlag As UInt16 _
) As Boolean
C#
public bool SYS_SetDspChannelFlag(
ushort i_wFlag
)
C++
public:
bool SYS_SetDspChannelFlag(
unsigned short i_wFlag
) sealed
J#
public bool SYS_SetDspChannelFlag(
ushort i_wFlag
)
JScript
public function SYS_SetDspChannelFlag(
i_wFlag : UInt16
) : bool

Parameters

i_wFlag
The dsp channel flag. (Turn on:0x55aa ; turn off:others)

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace
Configuration.SYS_SetDspChannelFlag Overload List


SYS_SetGlobalHeartbeat Method

Configuration.SYS_SetGlobalHeartbeat Method
[image]

APAX API. Backup System: Set the global heartbeat.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetGlobalHeartbeat() As Boolean
C#
public bool SYS_SetGlobalHeartbeat()
C++
public:
bool SYS_SetGlobalHeartbeat() sealed
J#
public bool SYS_SetGlobalHeartbeat()
JScript
public function SYS_SetGlobalHeartbeat() : bool

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetHeartbeatRun Method

Configuration.SYS_SetHeartbeatRun Method
[image]

APAX API. Backup System: Set the heartbeat run mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetHeartbeatRun( _
ByVal i_bRun As Boolean _
) As Boolean
C#
public bool SYS_SetHeartbeatRun(
bool i_bRun
)
C++
public:
bool SYS_SetHeartbeatRun(
bool i_bRun
) sealed
J#
public bool SYS_SetHeartbeatRun(
bool i_bRun
)
JScript
public function SYS_SetHeartbeatRun(
i_bRun : bool
) : bool

Parameters

i_bRun
The heartbeat run mode.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetInnerTimeout Method

Configuration.SYS_SetInnerTimeout Method
[image]

APAX API. Set the inner timeout.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetInnerTimeout( _
ByVal i_wTimeout As UInt16 _
) As Boolean
C#
public bool SYS_SetInnerTimeout(
ushort i_wTimeout
)
C++
public:
bool SYS_SetInnerTimeout(
unsigned short i_wTimeout
) sealed
J#
public bool SYS_SetInnerTimeout(
ushort i_wTimeout
)
JScript
public function SYS_SetInnerTimeout(
i_wTimeout : UInt16
) : bool

Parameters

i_wTimeout
The inner timeout.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


SYS_SetLocateModule Method

Configuration.SYS_SetLocateModule Method
[image]

APAX API. Set module locate function.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SYS_SetLocateModule( _
ByVal i_iSlot As Integer, _
ByVal i_wTimes As UInt16 _
) As Boolean
C#
public bool SYS_SetLocateModule(
int i_iSlot,
ushort i_wTimes
)
C++
public:
bool SYS_SetLocateModule(
int i_iSlot,
unsigned short i_wTimes
) sealed
J#
public bool SYS_SetLocateModule(
int i_iSlot,
ushort i_wTimes
)
JScript
public function SYS_SetLocateModule(
i_iSlot : int,
i_wTimes : UInt16
) : bool

Parameters

i_iSlot
The slot number. (module:0~15, dsp platform:0xD2~0xD4)
i_wTimes
The LED flash times.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


TOOL_SetCmdWrite5Read10 Method

Configuration.TOOL_SetCmdWrite5Read10 Method
[image]

APAX API. Internal used. DO NOT call this function in your program.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function TOOL_SetCmdWrite5Read10( _
ByVal i_iSlot As Integer, _
ByVal i_wMsgType As UInt16, _
ByVal i_dwParam0To4 As UInt32(), _
<OutAttribute> ByRef o_dwParam0To9 As UInt32 _
) As Boolean
C#
public bool TOOL_SetCmdWrite5Read10(
int i_iSlot,
ushort i_wMsgType,
uint[] i_dwParam0To4,
out uint o_dwParam0To9
)
C++
public:
bool TOOL_SetCmdWrite5Read10(
int i_iSlot,
unsigned short i_wMsgType,
array<unsigned int>^ i_dwParam0To4,
[OutAttribute] unsigned int% o_dwParam0To9
) sealed
J#
public bool TOOL_SetCmdWrite5Read10(
int i_iSlot,
ushort i_wMsgType,
uint[] i_dwParam0To4,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwParam0To9
)
JScript
public function TOOL_SetCmdWrite5Read10(
i_iSlot : int,
i_wMsgType : UInt16,
i_dwParam0To4 : UInt32[],
OutAttribute o_dwParam0To9 : UInt32
) : bool

Parameters

i_iSlot
The slot number, based 0.
i_wMsgType
The message type.
i_dwParam0To4
The parameter input.
o_dwParam0To9
The parameter output.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


TOOL_SetCmdWriteReadRet Method

Configuration.TOOL_SetCmdWriteReadRet Method
[image]

APAX API. Internal used. DO NOT call this function in your program.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function TOOL_SetCmdWriteReadRet( _
ByVal i_iSlot As Integer, _
ByVal i_wMsgType As UInt16, _
ByVal i_dwParam0To4 As UInt32() _
) As Boolean
C#
public bool TOOL_SetCmdWriteReadRet(
int i_iSlot,
ushort i_wMsgType,
uint[] i_dwParam0To4
)
C++
public:
bool TOOL_SetCmdWriteReadRet(
int i_iSlot,
unsigned short i_wMsgType,
array<unsigned int>^ i_dwParam0To4
) sealed
J#
public bool TOOL_SetCmdWriteReadRet(
int i_iSlot,
ushort i_wMsgType,
uint[] i_dwParam0To4
)
JScript
public function TOOL_SetCmdWriteReadRet(
i_iSlot : int,
i_wMsgType : UInt16,
i_dwParam0To4 : UInt32[]
) : bool

Parameters

i_iSlot
The slot number, based 0.
i_wMsgType
The message type.
i_dwParam0To4
The parameter input.

Return Value

Return true if success; otherwise, return false.

See Also

Configuration Class
Advantech.Adam Namespace


VerifyAccessControl Method

Configuration.VerifyAccessControl Method
[image]

Support module: ADAM-6000/W AI/DIO module Verify if this IP/MAC is valid security IP/MAC.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function VerifyAccessControl( _
<OutAttribute> ByRef o_bValid As Boolean _
) As Boolean
C#
public bool VerifyAccessControl(
out bool o_bValid
)
C++
public:
bool VerifyAccessControl(
[OutAttribute] bool% o_bValid
) sealed
J#
public bool VerifyAccessControl(
/** @attribute OutAttribute() */ /** @ref */ bool o_bValid
)
JScript
public function VerifyAccessControl(
OutAttribute o_bValid : bool
) : bool

Parameters

o_bValid
True if valid, otherwise false.

Return Value

True if succeed, otherwise false.

See Also

Configuration Class
Advantech.Adam Namespace


Counter Class

Counter Class
See Also Example Members
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Counter
Inherits AdamBase
C#
public class Counter : AdamBase
C++
ref class Counter : AdamBase
J#
public class Counter extends AdamBase
JScript
public class Counter extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.Counter

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Counter Members
Advantech.Adam Namespace


Counter Members

Counter Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Counter.

Public Constructors

Name | Description
Counter | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | ClearOverflows | Support module: APAX-5080. Clear the counter overflowflag.
 | FormIOConfig | Support module: ADAM-6000. Form the DI configuration byte.
Public method | GetChannelConfig | Support module: APAX-5082. Get the PWM channel configuration of the indicated slot.
Public method | GetChannelEnabled | Support module: APAX-5080/APAX-5082. Get the counter/PWM status (Start or stop).
 | GetChannelStart | Support module: ADAM-6051. Get the counter channel start index from IO config array.
Public method | GetChannelStatus | Overloaded. Support module: APAX-5000. Get channel status.
 | GetChannelTotal | Overloaded. Get the channel total
Public method | GetCntTypeConfiguration | Support module: APAX-5080 Get counter counting type configuration.
 | GetDataFormatCode | Get the data format code.
 | GetDataFormatIndex | Get the data format index
 | GetDataFormatName | Get the data format name
 | GetDataFormatTotal | Get the data format total
Public method | GetDigitalFilter | Overloaded. Support module: ADAM-4080, ADAM-4080D. Get Digital filter status.
Public method | GetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100. Get digital filter minimum signal width.
 | GetFormat | Overloaded. Get value format
Public method | GetFreqAcqTime | Support module: ADAM-5081. Get frequency acquisition time value.
Public method | GetGateMode | Support module: ADAM-4080, ADAM-4080D. Get the gate mode.
Public method | GetGateTriggerStatus | Support module: APAX-5080 Get gate mode, type, mapping gate.
Public method | GetInputSignalMode | Support module: ADAM-4080, ADAM-4080D Get the input signal mode.
Public method | GetIOConfig | Overloaded. Support module: ADAM-6000. Get DIO configuration.
Public method | GetLEDSource | Support module: ADAM-4080D Get the LED source.
Public method | GetLocalGateConfiguration | Support module: APAX-5080 Get gate mode, type, mapping gate.
Public method | GetMaxValue | Support module: ADAM-4080, ADAM-4080D. Get the counter/frequency maximum value.
Public method | GetMinInputSignalWidth | Support module: ADAM-4080, ADAM-4080D. Get the minimum input signal width.
Public method | GetMode | Overloaded. Support module: ADAM-5080 on ADAM-5000/TCP. Get module counter mode.
Public method | GetModeFormat | Support module: ADAM-5080 on ADAM-5000. Get module counter mode and data format.
 | GetModeName | Overloaded. Get the counter mode name
 | GetModeTotal | Overloaded. Get the range total
Public method | GetOverflowFlag | Overloaded. Support module: ADAM-5080, ADAM-5081. Get overflow flag
 | GetRangeCode2Byte | Get the range code by the range name for APAX unknown module
 | GetScaledValue | Overloaded. Get the scaled value
Public method | GetStartupValue | Overloaded. Support module: ADAM-5080, ADAM-5081. Get the counter startup value.
Public method | GetStartupValues | Support module: APAX-5080. Get counter startup values
Public method | GetStatus | Overloaded. Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Get the counter status.
Public method | GetTriggerLevel | Support module: ADAM-4080D. Get the trigger level for non-isolated input.
 | GetUnitName | Overloaded. Get unit string
Public method | GetValue | Overloaded. Support module: ADAM-5080 Get specified channel value. The value returned is in engineering unit format.
Public method | GetValues | Overloaded. Support module: ADAM-5080 Get channel values
 | ParseIOConfig | Support module: ADAM-6051. Parse the counter configuration byte.
Public method | SetChannelConfig | Support module: APAX-5082. Set the PWM channel configuration of the indicated slot.
Public method | SetChannelEnabled | Support module: APAX-5080/APAX-5082. Set the counter/PWM status (Start or stop).
Public method | SetClear | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Clear the event counter value.
Public method | SetCntTypeConfiguration | Support module: APAX-5080 Set counter counting type configuration.
Public method | SetDigitalFilter | Overloaded. Support module: ADAM-5080, ADAM-5081. Set Digital filter value.
Public method | SetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100. Set digital filter minimum signal width.
Public method | SetFreqAcqTime | Overloaded. Support module: ADAM-5081. Set frequency acquisition time value.
Public method | SetGateMode | Support module: ADAM-4080, ADAM-4080D. Set the gate mode.
Public method | SetInputSignalMode | Support module: ADAM-4080, ADAM-4080D Set the input signal mode.
Public method | SetIOConfig | Overloaded. Support module: ADAM-6000. Set DIO configuration.
Public method | SetLEDSource | Support module: ADAM-4080D Set the LED source.
Public method | SetLEDText | Support module: ADAM-4080D Set the LED text
Public method | SetLocalGateConfiguration | Support module: APAX-5080 Set gate mode, type, mapping gate.
Public method | SetMaxValue | Support module: ADAM-4080, ADAM-4080D. Set the counter/frequency maximum value.
Public method | SetMinInputSignalWidth | Support module: ADAM-4080, ADAM-4080D. Set the minimum input signal width.
Public method | SetMode | Overloaded. Support module: ADAM-5080 on ADAM-5000/TCP. Set module counter mode.
Public method | SetModeFormat | Support module: ADAM-5080 on ADAM-5000. Set module counter mode.
Public method | SetModes | Support module: APAX-5080. Set module counter modes
Public method | SetStartupValue | Overloaded. Support module: ADAM-5080, ADAM-5081. Set counter startup value.
Public method | SetStartupValues | Support module: APAX-5080. Set analog output startup values
Public method | SetStatus | Overloaded. Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Set the counter status.
Public method | SetToStartup | Overloaded. Support module: ADAM-5080, ADAM-5081. Force the counter value to startup value.
Public method | SetTriggerLevel | Support module: ADAM-4080D. Set the trigger level for non-isolated input.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetAdam5080ModeName |
 | GetAdam5080ScaledValue |
 | GetAdam5081ModeName |
 | GetAdam5081ScaledValue |
 | GetAdam6051ModeName |
 | GetAdam6051ScaledValue |
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
Counter | Overloaded.
Top

See Also

Counter Class
Advantech.Adam Namespace


Counter Constructor

Counter Constructor

Overload List

 | Name | Description
Public method | Counter (AdamCom) | The Counter constructor.
Public method | Counter (AdamControl) | The Counter constructor.
Public method | Counter (AdamSocket) | The Counter constructor.

See Also

Counter Class
Advantech.Adam Namespace


Counter Constructor (AdamCom)

Counter Constructor (AdamCom)
See Also Example
[image]

The Counter constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public Counter(
AdamCom i_com
)
C++
public:
Counter(
AdamCom i_com
) sealed
J#
public Counter(
AdamCom i_com
)
JScript
public function Counter(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object

See Also

Counter Class
Advantech.Adam Namespace
Counter Constructor Overload List


Counter Constructor (AdamControl)

Counter Constructor (AdamControl)
See Also Example
[image]

The Counter constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public Counter(
AdamControl i_control
)
C++
public:
Counter(
AdamControl i_control
) sealed
J#
public Counter(
AdamControl i_control
)
JScript
public function Counter(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object

See Also

Counter Class
Advantech.Adam Namespace
Counter Constructor Overload List


Counter Constructor (AdamSocket)

Counter Constructor (AdamSocket)
See Also Example
[image]

The Counter constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public Counter(
AdamSocket i_socket
)
C++
public:
Counter(
AdamSocket i_socket
) sealed
J#
public Counter(
AdamSocket i_socket
)
JScript
public function Counter(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object

See Also

Counter Class
Advantech.Adam Namespace
Counter Constructor Overload List


Methods

Counter Methods
[image]

Public Methods

 | Name | Description
Public method | ClearOverflows | Support module: APAX-5080. Clear the counter overflowflag.
 | FormIOConfig | Support module: ADAM-6000. Form the DI configuration byte.
Public method | GetChannelConfig | Support module: APAX-5082. Get the PWM channel configuration of the indicated slot.
Public method | GetChannelEnabled | Support module: APAX-5080/APAX-5082. Get the counter/PWM status (Start or stop).
 | GetChannelStart | Support module: ADAM-6051. Get the counter channel start index from IO config array.
Public method | GetChannelStatus | Overloaded. Support module: APAX-5000. Get channel status.
 | GetChannelTotal | Overloaded. Get the channel total
Public method | GetCntTypeConfiguration | Support module: APAX-5080 Get counter counting type configuration.
 | GetDataFormatCode | Get the data format code.
 | GetDataFormatIndex | Get the data format index
 | GetDataFormatName | Get the data format name
 | GetDataFormatTotal | Get the data format total
Public method | GetDigitalFilter | Overloaded. Support module: ADAM-4080, ADAM-4080D. Get Digital filter status.
Public method | GetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100. Get digital filter minimum signal width.
 | GetFormat | Overloaded. Get value format
Public method | GetFreqAcqTime | Support module: ADAM-5081. Get frequency acquisition time value.
Public method | GetGateMode | Support module: ADAM-4080, ADAM-4080D. Get the gate mode.
Public method | GetGateTriggerStatus | Support module: APAX-5080 Get gate mode, type, mapping gate.
Public method | GetInputSignalMode | Support module: ADAM-4080, ADAM-4080D Get the input signal mode.
Public method | GetIOConfig | Overloaded. Support module: ADAM-6000. Get DIO configuration.
Public method | GetLEDSource | Support module: ADAM-4080D Get the LED source.
Public method | GetLocalGateConfiguration | Support module: APAX-5080 Get gate mode, type, mapping gate.
Public method | GetMaxValue | Support module: ADAM-4080, ADAM-4080D. Get the counter/frequency maximum value.
Public method | GetMinInputSignalWidth | Support module: ADAM-4080, ADAM-4080D. Get the minimum input signal width.
Public method | GetMode | Overloaded. Support module: ADAM-5080 on ADAM-5000/TCP. Get module counter mode.
Public method | GetModeFormat | Support module: ADAM-5080 on ADAM-5000. Get module counter mode and data format.
 | GetModeName | Overloaded. Get the counter mode name
 | GetModeTotal | Overloaded. Get the range total
Public method | GetOverflowFlag | Overloaded. Support module: ADAM-5080, ADAM-5081. Get overflow flag
 | GetRangeCode2Byte | Get the range code by the range name for APAX unknown module
 | GetScaledValue | Overloaded. Get the scaled value
Public method | GetStartupValue | Overloaded. Support module: ADAM-5080, ADAM-5081. Get the counter startup value.
Public method | GetStartupValues | Support module: APAX-5080. Get counter startup values
Public method | GetStatus | Overloaded. Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Get the counter status.
Public method | GetTriggerLevel | Support module: ADAM-4080D. Get the trigger level for non-isolated input.
 | GetUnitName | Overloaded. Get unit string
Public method | GetValue | Overloaded. Support module: ADAM-5080 Get specified channel value. The value returned is in engineering unit format.
Public method | GetValues | Overloaded. Support module: ADAM-5080 Get channel values
 | ParseIOConfig | Support module: ADAM-6051. Parse the counter configuration byte.
Public method | SetChannelConfig | Support module: APAX-5082. Set the PWM channel configuration of the indicated slot.
Public method | SetChannelEnabled | Support module: APAX-5080/APAX-5082. Set the counter/PWM status (Start or stop).
Public method | SetClear | Overloaded. Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Clear the event counter value.
Public method | SetCntTypeConfiguration | Support module: APAX-5080 Set counter counting type configuration.
Public method | SetDigitalFilter | Overloaded. Support module: ADAM-5080, ADAM-5081. Set Digital filter value.
Public method | SetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100. Set digital filter minimum signal width.
Public method | SetFreqAcqTime | Overloaded. Support module: ADAM-5081. Set frequency acquisition time value.
Public method | SetGateMode | Support module: ADAM-4080, ADAM-4080D. Set the gate mode.
Public method | SetInputSignalMode | Support module: ADAM-4080, ADAM-4080D Set the input signal mode.
Public method | SetIOConfig | Overloaded. Support module: ADAM-6000. Set DIO configuration.
Public method | SetLEDSource | Support module: ADAM-4080D Set the LED source.
Public method | SetLEDText | Support module: ADAM-4080D Set the LED text
Public method | SetLocalGateConfiguration | Support module: APAX-5080 Set gate mode, type, mapping gate.
Public method | SetMaxValue | Support module: ADAM-4080, ADAM-4080D. Set the counter/frequency maximum value.
Public method | SetMinInputSignalWidth | Support module: ADAM-4080, ADAM-4080D. Set the minimum input signal width.
Public method | SetMode | Overloaded. Support module: ADAM-5080 on ADAM-5000/TCP. Set module counter mode.
Public method | SetModeFormat | Support module: ADAM-5080 on ADAM-5000. Set module counter mode.
Public method | SetModes | Support module: APAX-5080. Set module counter modes
Public method | SetStartupValue | Overloaded. Support module: ADAM-5080, ADAM-5081. Set counter startup value.
Public method | SetStartupValues | Support module: APAX-5080. Set analog output startup values
Public method | SetStatus | Overloaded. Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Set the counter status.
Public method | SetToStartup | Overloaded. Support module: ADAM-5080, ADAM-5081. Force the counter value to startup value.
Public method | SetTriggerLevel | Support module: ADAM-4080D. Set the trigger level for non-isolated input.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetAdam5080ModeName |
 | GetAdam5080ScaledValue |
 | GetAdam5081ModeName |
 | GetAdam5081ScaledValue |
 | GetAdam6051ModeName |
 | GetAdam6051ScaledValue |
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

Counter Class
Advantech.Adam Namespace


ClearOverflows Method

Counter.ClearOverflows Method
[image]

Support module: APAX-5080. Clear the counter overflowflag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ClearOverflows( _
ByVal i_iSlot As Integer, _
ByVal i_uiChMask As UInt32 _
) As Boolean
C#
public bool ClearOverflows(
int i_iSlot,
uint i_uiChMask
)
C++
public:
bool ClearOverflows(
int i_iSlot,
unsigned int i_uiChMask
) sealed
J#
public bool ClearOverflows(
int i_iSlot,
uint i_uiChMask
)
JScript
public function ClearOverflows(
i_iSlot : int,
i_uiChMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_uiChMask
The channel mask.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


FormIOConfig Method

Counter.FormIOConfig Method
[image]

Support module: ADAM-6000. Form the DI configuration byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FormIOConfig( _
ByVal i_byMode As Byte, _
ByVal i_bRecordLastCount As Boolean, _
ByVal i_bDigitalFilter As Boolean, _
ByVal i_bInvert As Boolean, _
<OutAttribute> ByRef o_byConfig As Byte _
)
C#
public static void FormIOConfig(
byte i_byMode,
bool i_bRecordLastCount,
bool i_bDigitalFilter,
bool i_bInvert,
out byte o_byConfig
)
C++
public:
static void FormIOConfig(
char i_byMode,
bool i_bRecordLastCount,
bool i_bDigitalFilter,
bool i_bInvert,
[OutAttribute] char% o_byConfig
)
J#
public static void FormIOConfig(
byte i_byMode,
bool i_bRecordLastCount,
bool i_bDigitalFilter,
bool i_bInvert,
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public static function FormIOConfig(
i_byMode : Byte,
i_bRecordLastCount : bool,
i_bDigitalFilter : bool,
i_bInvert : bool,
OutAttribute o_byConfig : Byte
)

Parameters

i_byMode
The DI mode.
i_bRecordLastCount
The record last count status.
i_bDigitalFilter
The digital filter enable status.
i_bInvert
The invert enable status.
o_byConfig
The configuration byte.

See Also

Counter Class
Advantech.Adam Namespace


GetAdam5080ModeName Method

Counter.GetAdam5080ModeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5080ModeName( _
ByVal i_byMode As Byte _
) As String
C#
protected static string GetAdam5080ModeName(
byte i_byMode
)
C++
protected:
static String GetAdam5080ModeName(
char i_byMode
)
J#
protected static string GetAdam5080ModeName(
byte i_byMode
)
JScript
protected static function GetAdam5080ModeName(
i_byMode : Byte
) : String

Parameters

i_byMode

See Also

Counter Class
Advantech.Adam Namespace


GetAdam5080ScaledValue Method

Counter.GetAdam5080ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5080ScaledValue( _
ByVal i_byMode As Byte, _
ByVal i_iHigh As Integer, _
ByVal i_iLow As Integer _
) As Double
C#
protected static double GetAdam5080ScaledValue(
byte i_byMode,
int i_iHigh,
int i_iLow
)
C++
protected:
static double GetAdam5080ScaledValue(
char i_byMode,
int i_iHigh,
int i_iLow
)
J#
protected static double GetAdam5080ScaledValue(
byte i_byMode,
int i_iHigh,
int i_iLow
)
JScript
protected static function GetAdam5080ScaledValue(
i_byMode : Byte,
i_iHigh : int,
i_iLow : int
) : double

Parameters

i_byMode
i_iHigh
i_iLow

See Also

Counter Class
Advantech.Adam Namespace


GetAdam5081ModeName Method

Counter.GetAdam5081ModeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5081ModeName( _
ByVal i_byMode As Byte _
) As String
C#
protected static string GetAdam5081ModeName(
byte i_byMode
)
C++
protected:
static String GetAdam5081ModeName(
char i_byMode
)
J#
protected static string GetAdam5081ModeName(
byte i_byMode
)
JScript
protected static function GetAdam5081ModeName(
i_byMode : Byte
) : String

Parameters

i_byMode

See Also

Counter Class
Advantech.Adam Namespace


GetAdam5081ScaledValue Method

Counter.GetAdam5081ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam5081ScaledValue( _
ByVal i_byMode As Byte, _
ByVal i_iHigh As Integer, _
ByVal i_iLow As Integer _
) As Double
C#
protected static double GetAdam5081ScaledValue(
byte i_byMode,
int i_iHigh,
int i_iLow
)
C++
protected:
static double GetAdam5081ScaledValue(
char i_byMode,
int i_iHigh,
int i_iLow
)
J#
protected static double GetAdam5081ScaledValue(
byte i_byMode,
int i_iHigh,
int i_iLow
)
JScript
protected static function GetAdam5081ScaledValue(
i_byMode : Byte,
i_iHigh : int,
i_iLow : int
) : double

Parameters

i_byMode
i_iHigh
i_iLow

See Also

Counter Class
Advantech.Adam Namespace


GetAdam6051ModeName Method

Counter.GetAdam6051ModeName Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6051ModeName( _
ByVal i_byMode As Byte _
) As String
C#
protected static string GetAdam6051ModeName(
byte i_byMode
)
C++
protected:
static String GetAdam6051ModeName(
char i_byMode
)
J#
protected static string GetAdam6051ModeName(
byte i_byMode
)
JScript
protected static function GetAdam6051ModeName(
i_byMode : Byte
) : String

Parameters

i_byMode

See Also

Counter Class
Advantech.Adam Namespace


GetAdam6051ScaledValue Method

Counter.GetAdam6051ScaledValue Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetAdam6051ScaledValue( _
ByVal i_byMode As Byte, _
ByVal i_iHigh As Integer, _
ByVal i_iLow As Integer _
) As Double
C#
protected static double GetAdam6051ScaledValue(
byte i_byMode,
int i_iHigh,
int i_iLow
)
C++
protected:
static double GetAdam6051ScaledValue(
char i_byMode,
int i_iHigh,
int i_iLow
)
J#
protected static double GetAdam6051ScaledValue(
byte i_byMode,
int i_iHigh,
int i_iLow
)
JScript
protected static function GetAdam6051ScaledValue(
i_byMode : Byte,
i_iHigh : int,
i_iLow : int
) : double

Parameters

i_byMode
i_iHigh
i_iLow

See Also

Counter Class
Advantech.Adam Namespace


GetChannelConfig Method

Counter.GetChannelConfig Method
[image]

Support module: APAX-5082. Get the PWM channel configuration of the indicated slot.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelConfig( _
ByVal i_iSlot As Integer, _
ByVal i_usChIdx As UInt16, _
<OutAttribute> ByRef o_uiFrequency As UInt32, _
<OutAttribute> ByRef o_fDutyCycle As Single _
) As Boolean
C#
public bool GetChannelConfig(
int i_iSlot,
ushort i_usChIdx,
out uint o_uiFrequency,
out float o_fDutyCycle
)
C++
public:
bool GetChannelConfig(
int i_iSlot,
unsigned short i_usChIdx,
[OutAttribute] unsigned int% o_uiFrequency,
[OutAttribute] float% o_fDutyCycle
) sealed
J#
public bool GetChannelConfig(
int i_iSlot,
ushort i_usChIdx,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiFrequency,
/** @attribute OutAttribute() */ /** @ref */ float o_fDutyCycle
)
JScript
public function GetChannelConfig(
i_iSlot : int,
i_usChIdx : UInt16,
OutAttribute o_uiFrequency : UInt32,
OutAttribute o_fDutyCycle : float
) : bool

Parameters

i_iSlot
Slot index.
i_usChIdx
The channel index, The value is between 0~7.
o_uiFrequency
The frequency of the channel. [1 ~ 500K Hz]
o_fDutyCycle
The duty cycle of the channel. [0 ~ 100 %]

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetChannelEnabled Method

Counter.GetChannelEnabled Method
[image]

Support module: APAX-5080/APAX-5082. Get the counter/PWM status (Start or stop).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelEnabled( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_usChMask As UInt32 _
) As Boolean
C#
public bool GetChannelEnabled(
int i_iSlot,
out uint o_usChMask
)
C++
public:
bool GetChannelEnabled(
int i_iSlot,
[OutAttribute] unsigned int% o_usChMask
) sealed
J#
public bool GetChannelEnabled(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_usChMask
)
JScript
public function GetChannelEnabled(
i_iSlot : int,
OutAttribute o_usChMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_usChMask
The channel mask.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetChannelStart Method

Counter.GetChannelStart Method
[image]

Support module: ADAM-6051. Get the counter channel start index from IO config array.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelStart( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelStart(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelStart(
Adam6000Type adam6000Type
)
J#
public static int GetChannelStart(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelStart(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
The adam6000Type.

Return Value

The counter channel start index.

See Also

Counter Class
Advantech.Adam Namespace


GetChannelStatus Method

Counter.GetChannelStatus Method

Support module: APAX-5000. Get channel status.

Overload List

 | Name | Description
Public method | GetChannelStatus (Int32, Int32, Apax5000_ChannelStatus) | Support module: APAX-5000. Get channel status.
Public method | GetChannelStatus (Int32, Int32, Byte) | Support module: APAX-5000. Get channel status.

See Also

Counter Class
Advantech.Adam Namespace


GetChannelStatus Method (Int32, Int32, Apax5000_ChannelStatus)

Counter.GetChannelStatus Method (Int32, Int32, Apax5000_ChannelStatus)
See Also Example
[image]

Support module: APAX-5000. Get channel status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_Status As Apax5000_ChannelStatus _
) As Boolean
C#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
out Apax5000_ChannelStatus o_Status
)
C++
public:
bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] Apax5000_ChannelStatus% o_Status
) sealed
J#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ Apax5000_ChannelStatus o_Status
)
JScript
public function GetChannelStatus(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_Status : Apax5000_ChannelStatus
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The channel total. The value is between 1~31
o_Status
The channel value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetChannelStatus Overload List


GetChannelStatus Method (Int32, Int32, Byte)

Counter.GetChannelStatus Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: APAX-5000. Get channel status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetChannelStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_byStatus As Byte _
) As Boolean
C#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
out byte o_byStatus
)
C++
public:
bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] char% o_byStatus
) sealed
J#
public bool GetChannelStatus(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ byte o_byStatus
)
JScript
public function GetChannelStatus(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_byStatus : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The channel total. The value is between 1~31
o_byStatus
The channel value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetChannelStatus Overload List


GetChannelTotal Method

Counter.GetChannelTotal Method

Get the channel total

Overload List

Name | Description
GetChannelTotal (Adam4000Type) | Get the channel total
GetChannelTotal (Adam5000Type) | Get the channel total
GetChannelTotal (Adam6000Type) | Support module: ADAM-6051. Get the channel total

See Also

Counter Class
Advantech.Adam Namespace


GetChannelTotal Method (Adam4000Type)

Counter.GetChannelTotal Method (Adam4000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetChannelTotal(
Adam4000Type adam4000Type
)
J#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetChannelTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetChannelTotal Overload List


GetChannelTotal Method (Adam5000Type)

Counter.GetChannelTotal Method (Adam5000Type)
See Also Example
[image]

Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetChannelTotal(
Adam5000Type adam5000Type
)
J#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetChannelTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetChannelTotal Overload List


GetChannelTotal Method (Adam6000Type)

Counter.GetChannelTotal Method (Adam6000Type)
See Also Example
[image]

Support module: ADAM-6051. Get the channel total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelTotal(
Adam6000Type adam6000Type
)
J#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return channel total if success, otherwise, return 0.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetChannelTotal Overload List


GetCntTypeConfiguration Method

Counter.GetCntTypeConfiguration Method
[image]

Support module: APAX-5080 Get counter counting type configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCntTypeConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bRepeat As Boolean, _
<OutAttribute> ByRef o_bReload As Boolean _
) As Boolean
C#
public bool GetCntTypeConfiguration(
int i_iSlot,
int i_iChannel,
out bool o_bRepeat,
out bool o_bReload
)
C++
public:
bool GetCntTypeConfiguration(
int i_iSlot,
int i_iChannel,
[OutAttribute] bool% o_bRepeat,
[OutAttribute] bool% o_bReload
) sealed
J#
public bool GetCntTypeConfiguration(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bRepeat,
/** @attribute OutAttribute() */ /** @ref */ bool o_bReload
)
JScript
public function GetCntTypeConfiguration(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_bRepeat : bool,
OutAttribute o_bReload : bool
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The counter channel index.
o_bRepeat
Count mode, false:Count once;true:Count repetitively.
o_bReload
Reload mode, true:reload to startup value ;false:reload to 0 or 0xFFFFFFFF.

Return Value

Return true if success, otherwise return false.

See Also

Counter Class
Advantech.Adam Namespace


GetDataFormatCode Method

Counter.GetDataFormatCode Method
[image]

Get the data format code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatCode( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iIndex As Integer _
) As Byte
C#
public static byte GetDataFormatCode(
Adam5000Type adam5000Type,
int i_iIndex
)
C++
public:
static char GetDataFormatCode(
Adam5000Type adam5000Type,
int i_iIndex
)
J#
public static byte GetDataFormatCode(
Adam5000Type adam5000Type,
int i_iIndex
)
JScript
public static function GetDataFormatCode(
adam5000Type : Adam5000Type,
i_iIndex : int
) : Byte

Parameters

adam5000Type
ADAM-5000 type
i_iIndex
The data format index. The value is between 0~1.

Return Value

The range code.

See Also

Counter Class
Advantech.Adam Namespace


GetDataFormatIndex Method

Counter.GetDataFormatIndex Method
[image]

Get the data format index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatIndex( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byDataFormat As Byte _
) As Integer
C#
public static int GetDataFormatIndex(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
C++
public:
static int GetDataFormatIndex(
Adam5000Type adam5000Type,
char i_byDataFormat
)
J#
public static int GetDataFormatIndex(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatIndex(
adam5000Type : Adam5000Type,
i_byDataFormat : Byte
) : int

Parameters

adam5000Type
ADAM-5000 type
i_byDataFormat
The data format code.

Return Value

Return range code index if success, otherwise, return -1

See Also

Counter Class
Advantech.Adam Namespace


GetDataFormatName Method

Counter.GetDataFormatName Method
[image]

Get the data format name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byDataFormat As Byte _
) As String
C#
public static string GetDataFormatName(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
C++
public:
static String GetDataFormatName(
Adam5000Type adam5000Type,
char i_byDataFormat
)
J#
public static string GetDataFormatName(
Adam5000Type adam5000Type,
byte i_byDataFormat
)
JScript
public static function GetDataFormatName(
adam5000Type : Adam5000Type,
i_byDataFormat : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byDataFormat
The data format code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

Counter Class
Advantech.Adam Namespace


GetDataFormatTotal Method

Counter.GetDataFormatTotal Method
[image]

Get the data format total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataFormatTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetDataFormatTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetDataFormatTotal(
Adam5000Type adam5000Type
)
J#
public static int GetDataFormatTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetDataFormatTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return range total if success, otherwise, return 0.

See Also

Counter Class
Advantech.Adam Namespace


GetDigitalFilter Method

Counter.GetDigitalFilter Method

Support module: ADAM-4080, ADAM-4080D. Get Digital filter status.

Overload List

 | Name | Description
Public method | GetDigitalFilter (Boolean) | Support module: ADAM-4080, ADAM-4080D. Get Digital filter status.
Public method | GetDigitalFilter (Int32, Int32) | Support module: ADAM-5080, ADAM-5081, APAX-5080. Get Digital filter value.

See Also

Counter Class
Advantech.Adam Namespace


GetDigitalFilter Method (Boolean)

Counter.GetDigitalFilter Method (Boolean)
See Also Example
[image]

Support module: ADAM-4080, ADAM-4080D. Get Digital filter status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilter( _
<OutAttribute> ByRef o_bFilter As Boolean _
) As Boolean
C#
public bool GetDigitalFilter(
out bool o_bFilter
)
C++
public:
bool GetDigitalFilter(
[OutAttribute] bool% o_bFilter
) sealed
J#
public bool GetDigitalFilter(
/** @attribute OutAttribute() */ /** @ref */ bool o_bFilter
)
JScript
public function GetDigitalFilter(
OutAttribute o_bFilter : bool
) : bool

Parameters

o_bFilter
The digital filter status. True means filter is enabled.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetDigitalFilter Overload List


GetDigitalFilter Method (Int32, Int32)

Counter.GetDigitalFilter Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081, APAX-5080. Get Digital filter value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilter( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iFilter As Integer _
) As Boolean
C#
public bool GetDigitalFilter(
int i_iSlot,
out int o_iFilter
)
C++
public:
bool GetDigitalFilter(
int i_iSlot,
[OutAttribute] int% o_iFilter
) sealed
J#
public bool GetDigitalFilter(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iFilter
)
JScript
public function GetDigitalFilter(
i_iSlot : int,
OutAttribute o_iFilter : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7(ADAM). The value is between 0~15(APAX)
o_iFilter
The digital filter value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetDigitalFilter Overload List


GetDigitalFilterMiniSignalWidth Method

Counter.GetDigitalFilterMiniSignalWidth Method

Support module: ADAM-4100. Get digital filter minimum signal width.

Overload List

 | Name | Description
Public method | GetDigitalFilterMiniSignalWidth (Int32, Int64, Int64) | Support module: ADAM-4100. Get digital filter minimum signal width.
Public method | GetDigitalFilterMiniSignalWidth (Int64, Int64) | Support module: ADAM-6000. Get digital filter minimum signal width.

See Also

Counter Class
Advantech.Adam Namespace


GetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)

Counter.GetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)
See Also Example
[image]

Support module: ADAM-4100. Get digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilterMiniSignalWidth( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lHigh As Long, _
<OutAttribute> ByRef o_lLow As Long _
) As Boolean
C#
public bool GetDigitalFilterMiniSignalWidth(
int i_iChannel,
out long o_lHigh,
out long o_lLow
)
C++
public:
bool GetDigitalFilterMiniSignalWidth(
int i_iChannel,
[OutAttribute] __int64% o_lHigh,
[OutAttribute] __int64% o_lLow
) sealed
J#
public bool GetDigitalFilterMiniSignalWidth(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lHigh,
/** @attribute OutAttribute() */ /** @ref */ long o_lLow
)
JScript
public function GetDigitalFilterMiniSignalWidth(
i_iChannel : int,
OutAttribute o_lHigh : long,
OutAttribute o_lLow : long
) : bool

Parameters

i_iChannel
Channel number
o_lHigh
The minimum high signal width.
o_lLow
The minimum low signal width.

Return Value

True if secceed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetDigitalFilterMiniSignalWidth Overload List


GetDigitalFilterMiniSignalWidth Method (Int64, Int64)

Counter.GetDigitalFilterMiniSignalWidth Method (Int64, Int64)
See Also Example
[image]

Support module: ADAM-6000. Get digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilterMiniSignalWidth( _
<OutAttribute> ByRef o_lHigh As Long, _
<OutAttribute> ByRef o_lLow As Long _
) As Boolean
C#
public bool GetDigitalFilterMiniSignalWidth(
out long o_lHigh,
out long o_lLow
)
C++
public:
bool GetDigitalFilterMiniSignalWidth(
[OutAttribute] __int64% o_lHigh,
[OutAttribute] __int64% o_lLow
) sealed
J#
public bool GetDigitalFilterMiniSignalWidth(
/** @attribute OutAttribute() */ /** @ref */ long o_lHigh,
/** @attribute OutAttribute() */ /** @ref */ long o_lLow
)
JScript
public function GetDigitalFilterMiniSignalWidth(
OutAttribute o_lHigh : long,
OutAttribute o_lLow : long
) : bool

Parameters

o_lHigh
The minimum high signal width.
o_lLow
The minimum low signal width.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetDigitalFilterMiniSignalWidth Overload List


GetFormat Method

Counter.GetFormat Method

Get value format

Overload List

Name | Description
GetFormat (Adam4000Type, Byte) | Get value format
GetFormat (Adam5000Type, Byte) | Get value format
GetFormat (Adam6000Type, Byte) | Support module: ADAM-6051. Get value format

See Also

Counter Class
Advantech.Adam Namespace


GetFormat Method (Adam4000Type, Byte)

Counter.GetFormat Method (Adam4000Type, Byte)
See Also Example
[image]

Get value format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFormat( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetFormat(
Adam4000Type adam4000Type,
byte i_byMode
)
C++
public:
static String GetFormat(
Adam4000Type adam4000Type,
char i_byMode
)
J#
public static string GetFormat(
Adam4000Type adam4000Type,
byte i_byMode
)
JScript
public static function GetFormat(
adam4000Type : Adam4000Type,
i_byMode : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byMode
The range code

Return Value

Return the format string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetFormat Overload List


GetFormat Method (Adam5000Type, Byte)

Counter.GetFormat Method (Adam5000Type, Byte)
See Also Example
[image]

Get value format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFormat( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetFormat(
Adam5000Type adam5000Type,
byte i_byMode
)
C++
public:
static String GetFormat(
Adam5000Type adam5000Type,
char i_byMode
)
J#
public static string GetFormat(
Adam5000Type adam5000Type,
byte i_byMode
)
JScript
public static function GetFormat(
adam5000Type : Adam5000Type,
i_byMode : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byMode
The range code

Return Value

Return the format string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetFormat Overload List


GetFormat Method (Adam6000Type, Byte)

Counter.GetFormat Method (Adam6000Type, Byte)
See Also Example
[image]

Support module: ADAM-6051. Get value format

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFormat( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetFormat(
Adam6000Type adam6000Type,
byte i_byMode
)
C++
public:
static String GetFormat(
Adam6000Type adam6000Type,
char i_byMode
)
J#
public static string GetFormat(
Adam6000Type adam6000Type,
byte i_byMode
)
JScript
public static function GetFormat(
adam6000Type : Adam6000Type,
i_byMode : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byMode
The range code

Return Value

Return the format string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetFormat Overload List


GetFreqAcqTime Method

Counter.GetFreqAcqTime Method
[image]

Support module: ADAM-5081. Get frequency acquisition time value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFreqAcqTime( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iFreqAcqTime As Integer _
) As Boolean
C#
public bool GetFreqAcqTime(
int i_iSlot,
out int o_iFreqAcqTime
)
C++
public:
bool GetFreqAcqTime(
int i_iSlot,
[OutAttribute] int% o_iFreqAcqTime
) sealed
J#
public bool GetFreqAcqTime(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int o_iFreqAcqTime
)
JScript
public function GetFreqAcqTime(
i_iSlot : int,
OutAttribute o_iFreqAcqTime : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_iFreqAcqTime
The frequency acquisition time value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetGateMode Method

Counter.GetGateMode Method
[image]

Support module: ADAM-4080, ADAM-4080D. Get the gate mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetGateMode( _
<OutAttribute> ByRef o_byMode As Byte _
) As Boolean
C#
public bool GetGateMode(
out byte o_byMode
)
C++
public:
bool GetGateMode(
[OutAttribute] char% o_byMode
) sealed
J#
public bool GetGateMode(
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode
)
JScript
public function GetGateMode(
OutAttribute o_byMode : Byte
) : bool

Parameters

o_byMode
The gate mode.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetGateTriggerStatus Method

Counter.GetGateTriggerStatus Method
[image]

Support module: APAX-5080 Get gate mode, type, mapping gate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetGateTriggerStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bStatus As Boolean _
) As Boolean
C#
public bool GetGateTriggerStatus(
int i_iSlot,
int i_iChannel,
out bool o_bStatus
)
C++
public:
bool GetGateTriggerStatus(
int i_iSlot,
int i_iChannel,
[OutAttribute] bool% o_bStatus
) sealed
J#
public bool GetGateTriggerStatus(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bStatus
)
JScript
public function GetGateTriggerStatus(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_bStatus : bool
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The counter channel index.
o_bStatus
The gate status.

Return Value

Return true if success, otherwise return false.

See Also

Counter Class
Advantech.Adam Namespace


GetInputSignalMode Method

Counter.GetInputSignalMode Method
[image]

Support module: ADAM-4080, ADAM-4080D Get the input signal mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInputSignalMode( _
<OutAttribute> ByRef o_byMode As Byte _
) As Boolean
C#
public bool GetInputSignalMode(
out byte o_byMode
)
C++
public:
bool GetInputSignalMode(
[OutAttribute] char% o_byMode
) sealed
J#
public bool GetInputSignalMode(
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode
)
JScript
public function GetInputSignalMode(
OutAttribute o_byMode : Byte
) : bool

Parameters

o_byMode
The input signal mode.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetIOConfig Method

Counter.GetIOConfig Method

Support module: ADAM-6000. Get DIO configuration.

Overload List

 | Name | Description
Public method | GetIOConfig (Byte) | Support module: ADAM-6000. Get DIO configuration.
Public method | GetIOConfig (Int32, Byte) | Support module: ADAM-4100 Get DI configuration.

See Also

Counter Class
Advantech.Adam Namespace


GetIOConfig Method (Byte)

Counter.GetIOConfig Method (Byte)
See Also Example
[image]

Support module: ADAM-6000. Get DIO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIOConfig( _
<OutAttribute> ByRef o_byConfig As Byte _
) As Boolean
C#
public bool GetIOConfig(
out byte o_byConfig
)
C++
public:
bool GetIOConfig(
[OutAttribute] char% o_byConfig
) sealed
J#
public bool GetIOConfig(
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public function GetIOConfig(
OutAttribute o_byConfig : Byte
) : bool

Parameters

o_byConfig
The configuration for all DIO channel.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetIOConfig Overload List


GetIOConfig Method (Int32, Byte)

Counter.GetIOConfig Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4100 Get DI configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIOConfig( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byConfig As Byte _
) As Boolean
C#
public bool GetIOConfig(
int i_iChannel,
out byte o_byConfig
)
C++
public:
bool GetIOConfig(
int i_iChannel,
[OutAttribute] char% o_byConfig
) sealed
J#
public bool GetIOConfig(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public function GetIOConfig(
i_iChannel : int,
OutAttribute o_byConfig : Byte
) : bool

Parameters

i_iChannel
Channel number
o_byConfig
The configuration for indicated DI channel.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetIOConfig Overload List


GetLEDSource Method

Counter.GetLEDSource Method
[image]

Support module: ADAM-4080D Get the LED source.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLEDSource( _
<OutAttribute> ByRef o_bySource As Byte _
) As Boolean
C#
public bool GetLEDSource(
out byte o_bySource
)
C++
public:
bool GetLEDSource(
[OutAttribute] char% o_bySource
) sealed
J#
public bool GetLEDSource(
/** @attribute OutAttribute() */ /** @ref */ byte o_bySource
)
JScript
public function GetLEDSource(
OutAttribute o_bySource : Byte
) : bool

Parameters

o_bySource
The LED source.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetLocalGateConfiguration Method

Counter.GetLocalGateConfiguration Method
[image]

Support module: APAX-5080 Get gate mode, type, mapping gate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLocalGateConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bEnable As Boolean, _
<OutAttribute> ByRef o_byTriggerMode As Byte, _
<OutAttribute> ByRef o_byGateActiveType As Byte, _
<OutAttribute> ByRef o_iGateMap As Integer _
) As Boolean
C#
public bool GetLocalGateConfiguration(
int i_iSlot,
int i_iChannel,
out bool o_bEnable,
out byte o_byTriggerMode,
out byte o_byGateActiveType,
out int o_iGateMap
)
C++
public:
bool GetLocalGateConfiguration(
int i_iSlot,
int i_iChannel,
[OutAttribute] bool% o_bEnable,
[OutAttribute] char% o_byTriggerMode,
[OutAttribute] char% o_byGateActiveType,
[OutAttribute] int% o_iGateMap
) sealed
J#
public bool GetLocalGateConfiguration(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable,
/** @attribute OutAttribute() */ /** @ref */ byte o_byTriggerMode,
/** @attribute OutAttribute() */ /** @ref */ byte o_byGateActiveType,
/** @attribute OutAttribute() */ /** @ref */ int o_iGateMap
)
JScript
public function GetLocalGateConfiguration(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_bEnable : bool,
OutAttribute o_byTriggerMode : Byte,
OutAttribute o_byGateActiveType : Byte,
OutAttribute o_iGateMap : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The counter channel index.
o_bEnable
The gate enalbe flag.
o_byTriggerMode
The gate trigger mode.
o_byGateActiveType
Gating Polarity Selection.
o_iGateMap
The mapping gate index.

Return Value

Return true if success, otherwise return false.

See Also

Counter Class
Advantech.Adam Namespace


GetMaxValue Method

Counter.GetMaxValue Method
[image]

Support module: ADAM-4080, ADAM-4080D. Get the counter/frequency maximum value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMaxValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lValue As Long _
) As Boolean
C#
public bool GetMaxValue(
int i_iChannel,
out long o_lValue
)
C++
public:
bool GetMaxValue(
int i_iChannel,
[OutAttribute] __int64% o_lValue
) sealed
J#
public bool GetMaxValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lValue
)
JScript
public function GetMaxValue(
i_iChannel : int,
OutAttribute o_lValue : long
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1.
o_lValue
The counter/frequency value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetMinInputSignalWidth Method

Counter.GetMinInputSignalWidth Method
[image]

Support module: ADAM-4080, ADAM-4080D. Get the minimum input signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMinInputSignalWidth( _
ByVal i_byLevel As Byte, _
<OutAttribute> ByRef o_iValue As Integer _
) As Boolean
C#
public bool GetMinInputSignalWidth(
byte i_byLevel,
out int o_iValue
)
C++
public:
bool GetMinInputSignalWidth(
char i_byLevel,
[OutAttribute] int% o_iValue
) sealed
J#
public bool GetMinInputSignalWidth(
byte i_byLevel,
/** @attribute OutAttribute() */ /** @ref */ int o_iValue
)
JScript
public function GetMinInputSignalWidth(
i_byLevel : Byte,
OutAttribute o_iValue : int
) : bool

Parameters

i_byLevel
The level. The value 0 means low. Otherwise means high.
o_iValue
The minimum input signal width. The unit is micro-second.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetMode Method

Counter.GetMode Method

Support module: ADAM-5080 on ADAM-5000/TCP. Get module counter mode.

Overload List

 | Name | Description
Public method | GetMode (Int32, Byte) | Support module: ADAM-5080 on ADAM-5000/TCP. Get module counter mode.
Public method | GetMode (Int32, Int32, Byte) | Support module: ADAM-5081. Get module counter mode.

See Also

Counter Class
Advantech.Adam Namespace


GetMode Method (Int32, Byte)

Counter.GetMode Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-5080 on ADAM-5000/TCP. Get module counter mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMode( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byMode As Byte _
) As Boolean
C#
public bool GetMode(
int i_iSlot,
out byte o_byMode
)
C++
public:
bool GetMode(
int i_iSlot,
[OutAttribute] char% o_byMode
) sealed
J#
public bool GetMode(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode
)
JScript
public function GetMode(
i_iSlot : int,
OutAttribute o_byMode : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_byMode
The counter mode code.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetMode Overload List


GetMode Method (Int32, Int32, Byte)

Counter.GetMode Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5081. Get module counter mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byMode As Byte _
) As Boolean
C#
public bool GetMode(
int i_iSlot,
int i_iChannel,
out byte o_byMode
)
C++
public:
bool GetMode(
int i_iSlot,
int i_iChannel,
[OutAttribute] char% o_byMode
) sealed
J#
public bool GetMode(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode
)
JScript
public function GetMode(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_byMode : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_byMode
The counter mode code.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetMode Overload List


GetModeFormat Method

Counter.GetModeFormat Method
[image]

Support module: ADAM-5080 on ADAM-5000. Get module counter mode and data format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetModeFormat( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_byMode As Byte, _
<OutAttribute> ByRef o_byFormat As Byte _
) As Boolean
C#
public bool GetModeFormat(
int i_iSlot,
out byte o_byMode,
out byte o_byFormat
)
C++
public:
bool GetModeFormat(
int i_iSlot,
[OutAttribute] char% o_byMode,
[OutAttribute] char% o_byFormat
) sealed
J#
public bool GetModeFormat(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode,
/** @attribute OutAttribute() */ /** @ref */ byte o_byFormat
)
JScript
public function GetModeFormat(
i_iSlot : int,
OutAttribute o_byMode : Byte,
OutAttribute o_byFormat : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_byMode
The counter mode code.
o_byFormat
The data format code.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetModeName Method

Counter.GetModeName Method

Get the counter mode name

Overload List

Name | Description
GetModeName (Adam4000Type, Byte) | Get the counter mode name
GetModeName (Adam5000Type, Byte) | Get the counter mode name
GetModeName (Adam6000Type, Byte) | Support module: ADAM-6051. Get the range name
GetModeName (UInt16) | Get the mode name for APAX unknown module

See Also

Counter Class
Advantech.Adam Namespace


GetModeName Method (Adam4000Type, Byte)

Counter.GetModeName Method (Adam4000Type, Byte)
See Also Example
[image]

Get the counter mode name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetModeName(
Adam4000Type adam4000Type,
byte i_byMode
)
C++
public:
static String GetModeName(
Adam4000Type adam4000Type,
char i_byMode
)
J#
public static string GetModeName(
Adam4000Type adam4000Type,
byte i_byMode
)
JScript
public static function GetModeName(
adam4000Type : Adam4000Type,
i_byMode : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byMode
The mode code.

Return Value

Return counter mode string if success, otherwise, return empty string

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetModeName Overload List


GetModeName Method (Adam5000Type, Byte)

Counter.GetModeName Method (Adam5000Type, Byte)
See Also Example
[image]

Get the counter mode name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetModeName(
Adam5000Type adam5000Type,
byte i_byMode
)
C++
public:
static String GetModeName(
Adam5000Type adam5000Type,
char i_byMode
)
J#
public static string GetModeName(
Adam5000Type adam5000Type,
byte i_byMode
)
JScript
public static function GetModeName(
adam5000Type : Adam5000Type,
i_byMode : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byMode
The mode code.

Return Value

Return counter mode string if success, otherwise, return empty string

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetModeName Overload List


GetModeName Method (Adam6000Type, Byte)

Counter.GetModeName Method (Adam6000Type, Byte)
See Also Example
[image]

Support module: ADAM-6051. Get the range name

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetModeName(
Adam6000Type adam6000Type,
byte i_byMode
)
C++
public:
static String GetModeName(
Adam6000Type adam6000Type,
char i_byMode
)
J#
public static string GetModeName(
Adam6000Type adam6000Type,
byte i_byMode
)
JScript
public static function GetModeName(
adam6000Type : Adam6000Type,
i_byMode : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byMode
The mode code.

Return Value

Return range code if success, otherwise, return empty string

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetModeName Overload List


GetModeName Method (UInt16)

Counter.GetModeName Method (UInt16)
See Also Example
[image]

Get the mode name for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeName( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetModeName(
ushort i_usRange
)
C++
public:
static String GetModeName(
unsigned short i_usRange
)
J#
public static string GetModeName(
ushort i_usRange
)
JScript
public static function GetModeName(
i_usRange : UInt16
) : String

Parameters

i_usRange
The range code.

Return Value

Return range code if success, otherwise, return empty string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetModeName Overload List


GetModeTotal Method

Counter.GetModeTotal Method

Get the range total

Overload List

Name | Description
GetModeTotal (Adam4000Type) | Get the range total
GetModeTotal (Adam5000Type) | Get the range total
GetModeTotal (Adam6000Type) | Support module: ADAM-6051. Get the range total

See Also

Counter Class
Advantech.Adam Namespace


GetModeTotal Method (Adam4000Type)

Counter.GetModeTotal Method (Adam4000Type)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetModeTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetModeTotal(
Adam4000Type adam4000Type
)
J#
public static int GetModeTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetModeTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
ADAM-4000 type

Return Value

Return mode total if success, otherwise, return 0.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetModeTotal Overload List


GetModeTotal Method (Adam5000Type)

Counter.GetModeTotal Method (Adam5000Type)
See Also Example
[image]

Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetModeTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetModeTotal(
Adam5000Type adam5000Type
)
J#
public static int GetModeTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetModeTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
ADAM-5000 type

Return Value

Return mode total if success, otherwise, return 0.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetModeTotal Overload List


GetModeTotal Method (Adam6000Type)

Counter.GetModeTotal Method (Adam6000Type)
See Also Example
[image]

Support module: ADAM-6051. Get the range total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetModeTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetModeTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetModeTotal(
Adam6000Type adam6000Type
)
J#
public static int GetModeTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetModeTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
ADAM-6000 type

Return Value

Return mode total if success, otherwise, return 0.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetModeTotal Overload List


GetOverflowFlag Method

Counter.GetOverflowFlag Method

Support module: ADAM-5080, ADAM-5081. Get overflow flag

Overload List

 | Name | Description
Public method | GetOverflowFlag (Adam5000Type, Int32, Boolean) | Support module: ADAM-5080, ADAM-5081. Get overflow flag
Public method | GetOverflowFlag (Adam5000Type, Int32, Int32, Boolean) | Support module: ADAM-5080, ADAM-5081. Get overflow flag
Public method | GetOverflowFlag (Int32, Boolean) | Support module: ADAM-4080, ADAM-4080D. Get overflow flag

See Also

Counter Class
Advantech.Adam Namespace


GetOverflowFlag Method (Adam5000Type, Int32, Boolean)

Counter.GetOverflowFlag Method (Adam5000Type, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get overflow flag

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOverflowFlag( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_bOver As Boolean _
) As Boolean
C#
public bool GetOverflowFlag(
Adam5000Type adam5000Type,
int i_iSlot,
out bool o_bOver
)
C++
public:
bool GetOverflowFlag(
Adam5000Type adam5000Type,
int i_iSlot,
[OutAttribute] bool% o_bOver
) sealed
J#
public bool GetOverflowFlag(
Adam5000Type adam5000Type,
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool o_bOver
)
JScript
public function GetOverflowFlag(
adam5000Type : Adam5000Type,
i_iSlot : int,
OutAttribute o_bOver : bool
) : bool

Parameters

adam5000Type
i_iSlot
Slot index. The value is between 0~7
o_bOver
The overflow flag. True means overflow occurs.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetOverflowFlag Overload List


GetOverflowFlag Method (Adam5000Type, Int32, Int32, Boolean)

Counter.GetOverflowFlag Method (Adam5000Type, Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get overflow flag

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOverflowFlag( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bOver As Boolean _
) As Boolean
C#
public bool GetOverflowFlag(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iChannelTotal,
out bool o_bOver
)
C++
public:
bool GetOverflowFlag(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] bool% o_bOver
) sealed
J#
public bool GetOverflowFlag(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bOver
)
JScript
public function GetOverflowFlag(
adam5000Type : Adam5000Type,
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_bOver : bool
) : bool

Parameters

adam5000Type
i_iSlot
Slot index. The value is between 0~7
i_iChannelTotal
The total of the channel on the module.
o_bOver
The overflow flag. True means overflow occurs.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetOverflowFlag Overload List


GetOverflowFlag Method (Int32, Boolean)

Counter.GetOverflowFlag Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-4080, ADAM-4080D. Get overflow flag

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOverflowFlag( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bOver As Boolean _
) As Boolean
C#
public bool GetOverflowFlag(
int i_iChannel,
out bool o_bOver
)
C++
public:
bool GetOverflowFlag(
int i_iChannel,
[OutAttribute] bool% o_bOver
) sealed
J#
public bool GetOverflowFlag(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bOver
)
JScript
public function GetOverflowFlag(
i_iChannel : int,
OutAttribute o_bOver : bool
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
o_bOver
The overflow flag. True means overflow occurs.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetOverflowFlag Overload List


GetRangeCode2Byte Method

Counter.GetRangeCode2Byte Method
[image]

Get the range code by the range name for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRangeCode2Byte( _
ByVal i_strName As String _
) As UInt16
C#
public static ushort GetRangeCode2Byte(
string i_strName
)
C++
public:
static unsigned short GetRangeCode2Byte(
String i_strName
)
J#
public static ushort GetRangeCode2Byte(
string i_strName
)
JScript
public static function GetRangeCode2Byte(
i_strName : String
) : UInt16

Parameters

i_strName
The range name.

Return Value

Return range code if success, otherwise, return 0x00.

See Also

Counter Class
Advantech.Adam Namespace


GetScaledValue Method

Counter.GetScaledValue Method

Get the scaled value

Overload List

Name | Description
GetScaledValue (Adam5000Type, Byte, Int32, Int32) | Get the scaled value
GetScaledValue (Adam6000Type, Byte, Int32, Int32) | Support module: ADAM-6051. Get the scaled value

See Also

Counter Class
Advantech.Adam Namespace


GetScaledValue Method (Adam5000Type, Byte, Int32, Int32)

Counter.GetScaledValue Method (Adam5000Type, Byte, Int32, Int32)
See Also Example
[image]

Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byMode As Byte, _
ByVal i_iHigh As Integer, _
ByVal i_iLow As Integer _
) As Double
C#
public static double GetScaledValue(
Adam5000Type adam5000Type,
byte i_byMode,
int i_iHigh,
int i_iLow
)
C++
public:
static double GetScaledValue(
Adam5000Type adam5000Type,
char i_byMode,
int i_iHigh,
int i_iLow
)
J#
public static double GetScaledValue(
Adam5000Type adam5000Type,
byte i_byMode,
int i_iHigh,
int i_iLow
)
JScript
public static function GetScaledValue(
adam5000Type : Adam5000Type,
i_byMode : Byte,
i_iHigh : int,
i_iLow : int
) : double

Parameters

adam5000Type
ADAM-5000 type
i_byMode
The mode code
i_iHigh
The value that is read by Modbus.
i_iLow
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetScaledValue Overload List


GetScaledValue Method (Adam6000Type, Byte, Int32, Int32)

Counter.GetScaledValue Method (Adam6000Type, Byte, Int32, Int32)
See Also Example
[image]

Support module: ADAM-6051. Get the scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetScaledValue( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byMode As Byte, _
ByVal i_iHigh As Integer, _
ByVal i_iLow As Integer _
) As Double
C#
public static double GetScaledValue(
Adam6000Type adam6000Type,
byte i_byMode,
int i_iHigh,
int i_iLow
)
C++
public:
static double GetScaledValue(
Adam6000Type adam6000Type,
char i_byMode,
int i_iHigh,
int i_iLow
)
J#
public static double GetScaledValue(
Adam6000Type adam6000Type,
byte i_byMode,
int i_iHigh,
int i_iLow
)
JScript
public static function GetScaledValue(
adam6000Type : Adam6000Type,
i_byMode : Byte,
i_iHigh : int,
i_iLow : int
) : double

Parameters

adam6000Type
ADAM-6000 type
i_byMode
The mode code
i_iHigh
The value that is read by Modbus.
i_iLow
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetScaledValue Overload List


GetStartupValue Method

Counter.GetStartupValue Method

Support module: ADAM-5080, ADAM-5081. Get the counter startup value.

Overload List

 | Name | Description
Public method | GetStartupValue (Int32, Int32, Int64) | Support module: ADAM-5080, ADAM-5081. Get the counter startup value.
Public method | GetStartupValue (Int32, Int64) | Support module: ADAM-4080. Get the counter startup value.

See Also

Counter Class
Advantech.Adam Namespace


GetStartupValue Method (Int32, Int32, Int64)

Counter.GetStartupValue Method (Int32, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get the counter startup value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStartupValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lStartup As Long _
) As Boolean
C#
public bool GetStartupValue(
int i_iSlot,
int i_iChannel,
out long o_lStartup
)
C++
public:
bool GetStartupValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] __int64% o_lStartup
) sealed
J#
public bool GetStartupValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lStartup
)
JScript
public function GetStartupValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_lStartup : long
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_lStartup
The startup value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetStartupValue Overload List


GetStartupValue Method (Int32, Int64)

Counter.GetStartupValue Method (Int32, Int64)
See Also Example
[image]

Support module: ADAM-4080. Get the counter startup value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStartupValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lStartup As Long _
) As Boolean
C#
public bool GetStartupValue(
int i_iChannel,
out long o_lStartup
)
C++
public:
bool GetStartupValue(
int i_iChannel,
[OutAttribute] __int64% o_lStartup
) sealed
J#
public bool GetStartupValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lStartup
)
JScript
public function GetStartupValue(
i_iChannel : int,
OutAttribute o_lStartup : long
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
o_lStartup
The startup value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetStartupValue Overload List


GetStartupValues Method

Counter.GetStartupValues Method
[image]

Support module: APAX-5080. Get counter startup values

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStartupValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_uiValues As UInt32 _
) As Boolean
C#
public bool GetStartupValues(
int i_iSlot,
int i_iChannelTotal,
out uint o_uiValues
)
C++
public:
bool GetStartupValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] unsigned int% o_uiValues
) sealed
J#
public bool GetStartupValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiValues
)
JScript
public function GetStartupValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_uiValues : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The Channel number. The value is between 1~8
o_uiValues
The counter startup values.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetStatus Method

Counter.GetStatus Method

Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Get the counter status.

Overload List

 | Name | Description
Public method | GetStatus (Int32, Boolean) | Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Get the counter status.
Public method | GetStatus (Int32, Int32, Boolean) | Support module: ADAM-5080, ADAM-5081. Get the counter status.

See Also

Counter Class
Advantech.Adam Namespace


GetStatus Method (Int32, Boolean)

Counter.GetStatus Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Get the counter status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStatus( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bCounting As Boolean _
) As Boolean
C#
public bool GetStatus(
int i_iChannel,
out bool o_bCounting
)
C++
public:
bool GetStatus(
int i_iChannel,
[OutAttribute] bool% o_bCounting
) sealed
J#
public bool GetStatus(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bCounting
)
JScript
public function GetStatus(
i_iChannel : int,
OutAttribute o_bCounting : bool
) : bool

Parameters

i_iChannel
The channel index.
o_bCounting
The counter status. True if the counter is counting. Otherwise false.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetStatus Overload List


GetStatus Method (Int32, Int32, Boolean)

Counter.GetStatus Method (Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Get the counter status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bCounting As Boolean _
) As Boolean
C#
public bool GetStatus(
int i_iSlot,
int i_iChannel,
out bool o_bCounting
)
C++
public:
bool GetStatus(
int i_iSlot,
int i_iChannel,
[OutAttribute] bool% o_bCounting
) sealed
J#
public bool GetStatus(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bCounting
)
JScript
public function GetStatus(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_bCounting : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
o_bCounting
The counter status. True if the counter is counting. Otherwise false.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetStatus Overload List


GetTriggerLevel Method

Counter.GetTriggerLevel Method
[image]

Support module: ADAM-4080D. Get the trigger level for non-isolated input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTriggerLevel( _
ByVal i_byLevel As Byte, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool GetTriggerLevel(
byte i_byLevel,
out float o_fValue
)
C++
public:
bool GetTriggerLevel(
char i_byLevel,
[OutAttribute] float% o_fValue
) sealed
J#
public bool GetTriggerLevel(
byte i_byLevel,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function GetTriggerLevel(
i_byLevel : Byte,
OutAttribute o_fValue : float
) : bool

Parameters

i_byLevel
The level. The value 0 means low. Otherwise means high.
o_fValue
The trigger level. The range is between 0.1~5.0 voltage.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


GetUnitName Method

Counter.GetUnitName Method

Get unit string

Overload List

Name | Description
GetUnitName (Adam4000Type, Byte) | Get unit string
GetUnitName (Adam5000Type, Byte) | Get unit string
GetUnitName (Adam6000Type, Byte) | Support module: ADAM-6051. Get unit string
GetUnitName (UInt16) | Get unit string for APAX unknown module

See Also

Counter Class
Advantech.Adam Namespace


GetUnitName Method (Adam4000Type, Byte)

Counter.GetUnitName Method (Adam4000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam4000Type As Adam4000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetUnitName(
Adam4000Type adam4000Type,
byte i_byMode
)
C++
public:
static String GetUnitName(
Adam4000Type adam4000Type,
char i_byMode
)
J#
public static string GetUnitName(
Adam4000Type adam4000Type,
byte i_byMode
)
JScript
public static function GetUnitName(
adam4000Type : Adam4000Type,
i_byMode : Byte
) : String

Parameters

adam4000Type
ADAM-4000 type
i_byMode
The mode code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetUnitName Overload List


GetUnitName Method (Adam5000Type, Byte)

Counter.GetUnitName Method (Adam5000Type, Byte)
See Also Example
[image]

Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetUnitName(
Adam5000Type adam5000Type,
byte i_byMode
)
C++
public:
static String GetUnitName(
Adam5000Type adam5000Type,
char i_byMode
)
J#
public static string GetUnitName(
Adam5000Type adam5000Type,
byte i_byMode
)
JScript
public static function GetUnitName(
adam5000Type : Adam5000Type,
i_byMode : Byte
) : String

Parameters

adam5000Type
ADAM-5000 type
i_byMode
The mode code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetUnitName Overload List


GetUnitName Method (Adam6000Type, Byte)

Counter.GetUnitName Method (Adam6000Type, Byte)
See Also Example
[image]

Support module: ADAM-6051. Get unit string

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal adam6000Type As Adam6000Type, _
ByVal i_byMode As Byte _
) As String
C#
public static string GetUnitName(
Adam6000Type adam6000Type,
byte i_byMode
)
C++
public:
static String GetUnitName(
Adam6000Type adam6000Type,
char i_byMode
)
J#
public static string GetUnitName(
Adam6000Type adam6000Type,
byte i_byMode
)
JScript
public static function GetUnitName(
adam6000Type : Adam6000Type,
i_byMode : Byte
) : String

Parameters

adam6000Type
ADAM-6000 type
i_byMode
The mode code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetUnitName Overload List


GetUnitName Method (UInt16)

Counter.GetUnitName Method (UInt16)
See Also Example
[image]

Get unit string for APAX unknown module

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetUnitName( _
ByVal i_usRange As UInt16 _
) As String
C#
public static string GetUnitName(
ushort i_usRange
)
C++
public:
static String GetUnitName(
unsigned short i_usRange
)
J#
public static string GetUnitName(
ushort i_usRange
)
JScript
public static function GetUnitName(
i_usRange : UInt16
) : String

Parameters

i_usRange
The range code

Return Value

Return unit string if success, otherwise, return an empty string.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetUnitName Overload List


GetValue Method

Counter.GetValue Method

Support module: ADAM-5080 Get specified channel value. The value returned is in engineering unit format.

Overload List

 | Name | Description
Public method | GetValue (Int32, Int32, Byte, Double) | Support module: ADAM-5080 Get specified channel value. The value returned is in engineering unit format.
Public method | GetValue (Int32, Int32, Byte, Int64) | Support module: ADAM-5081 Get specified channel value. The value returned is in engineering unit format.
Public method | GetValue (Int32, Int32, UInt32) | Support module: APAX-5080 Get channel value
Public method | GetValue (Int32, Int64) | Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Get the counter/frequency value
Public method | GetValue (Int64) | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get event counter value.

See Also

Counter Class
Advantech.Adam Namespace


GetValue Method (Int32, Int32, Byte, Double)

Counter.GetValue Method (Int32, Int32, Byte, Double)
See Also Example
[image]

Support module: ADAM-5080 Get specified channel value. The value returned is in engineering unit format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_byMode As Byte, _
<OutAttribute> ByRef o_dValue As Double _
) As Boolean
C#
public bool GetValue(
int i_iSlot,
int i_iChannel,
byte i_byMode,
out double o_dValue
)
C++
public:
bool GetValue(
int i_iSlot,
int i_iChannel,
char i_byMode,
[OutAttribute] double% o_dValue
) sealed
J#
public bool GetValue(
int i_iSlot,
int i_iChannel,
byte i_byMode,
/** @attribute OutAttribute() */ /** @ref */ double o_dValue
)
JScript
public function GetValue(
i_iSlot : int,
i_iChannel : int,
i_byMode : Byte,
OutAttribute o_dValue : double
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~3
i_byMode
The counter mode.
o_dValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValue Overload List


GetValue Method (Int32, Int32, Byte, Int64)

Counter.GetValue Method (Int32, Int32, Byte, Int64)
See Also Example
[image]

Support module: ADAM-5081 Get specified channel value. The value returned is in engineering unit format.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_byMode As Byte, _
<OutAttribute> ByRef o_lValue As Long _
) As Boolean
C#
public bool GetValue(
int i_iSlot,
int i_iChannel,
byte i_byMode,
out long o_lValue
)
C++
public:
bool GetValue(
int i_iSlot,
int i_iChannel,
char i_byMode,
[OutAttribute] __int64% o_lValue
) sealed
J#
public bool GetValue(
int i_iSlot,
int i_iChannel,
byte i_byMode,
/** @attribute OutAttribute() */ /** @ref */ long o_lValue
)
JScript
public function GetValue(
i_iSlot : int,
i_iChannel : int,
i_byMode : Byte,
OutAttribute o_lValue : long
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~3
i_byMode
The counter mode.
o_lValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValue Overload List


GetValue Method (Int32, Int32, UInt32)

Counter.GetValue Method (Int32, Int32, UInt32)
See Also Example
[image]

Support module: APAX-5080 Get channel value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_uiValue As UInt32 _
) As Boolean
C#
public bool GetValue(
int i_iSlot,
int i_iChannel,
out uint o_uiValue
)
C++
public:
bool GetValue(
int i_iSlot,
int i_iChannel,
[OutAttribute] unsigned int% o_uiValue
) sealed
J#
public bool GetValue(
int i_iSlot,
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiValue
)
JScript
public function GetValue(
i_iSlot : int,
i_iChannel : int,
OutAttribute o_uiValue : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannel
The channel index.
o_uiValue
The channel value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValue Overload List


GetValue Method (Int32, Int64)

Counter.GetValue Method (Int32, Int64)
See Also Example
[image]

Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Get the counter/frequency value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lValue As Long _
) As Boolean
C#
public bool GetValue(
int i_iChannel,
out long o_lValue
)
C++
public:
bool GetValue(
int i_iChannel,
[OutAttribute] __int64% o_lValue
) sealed
J#
public bool GetValue(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lValue
)
JScript
public function GetValue(
i_iChannel : int,
OutAttribute o_lValue : long
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1.
o_lValue
The counter/frequency value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValue Overload List


GetValue Method (Int64)

Counter.GetValue Method (Int64)
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Get event counter value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
<OutAttribute> ByRef o_lValue As Long _
) As Boolean
C#
public bool GetValue(
out long o_lValue
)
C++
public:
bool GetValue(
[OutAttribute] __int64% o_lValue
) sealed
J#
public bool GetValue(
/** @attribute OutAttribute() */ /** @ref */ long o_lValue
)
JScript
public function GetValue(
OutAttribute o_lValue : long
) : bool

Parameters

o_lValue
The counter value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValue Overload List


GetValues Method

Counter.GetValues Method

Support module: ADAM-5080 Get channel values

Overload List

 | Name | Description
Public method | GetValues (Int32, Byte, Double) | Support module: ADAM-5080 Get channel values
Public method | GetValues (Int32, Byte, Int64) | Support module: ADAM-5081 Get channel values
Public method | GetValues (Int32, UInt32) | Support module: APAX-5080 Get channel values

See Also

Counter Class
Advantech.Adam Namespace


GetValues Method (Int32, Byte, Double)

Counter.GetValues Method (Int32, Byte, Double)
See Also Example
[image]

Support module: ADAM-5080 Get channel values

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_byMode As Byte, _
<OutAttribute> ByRef o_dValues As Double _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
byte i_byMode,
out double o_dValues
)
C++
public:
bool GetValues(
int i_iSlot,
char i_byMode,
[OutAttribute] double% o_dValues
) sealed
J#
public bool GetValues(
int i_iSlot,
byte i_byMode,
/** @attribute OutAttribute() */ /** @ref */ double o_dValues
)
JScript
public function GetValues(
i_iSlot : int,
i_byMode : Byte,
OutAttribute o_dValues : double
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_byMode
The counter mode.
o_dValues
Array of channel values.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValues Overload List


GetValues Method (Int32, Byte, Int64)

Counter.GetValues Method (Int32, Byte, Int64)
See Also Example
[image]

Support module: ADAM-5081 Get channel values

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_byMode As Byte, _
<OutAttribute> ByRef o_lValues As Long _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
byte i_byMode,
out long o_lValues
)
C++
public:
bool GetValues(
int i_iSlot,
char i_byMode,
[OutAttribute] __int64% o_lValues
) sealed
J#
public bool GetValues(
int i_iSlot,
byte i_byMode,
/** @attribute OutAttribute() */ /** @ref */ long o_lValues
)
JScript
public function GetValues(
i_iSlot : int,
i_byMode : Byte,
OutAttribute o_lValues : long
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_byMode
The counter mode.
o_lValues
Array of channel values.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValues Overload List


GetValues Method (Int32, UInt32)

Counter.GetValues Method (Int32, UInt32)
See Also Example
[image]

Support module: APAX-5080 Get channel values

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_uiValues As UInt32 _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
out uint o_uiValues
)
C++
public:
bool GetValues(
int i_iSlot,
[OutAttribute] unsigned int% o_uiValues
) sealed
J#
public bool GetValues(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiValues
)
JScript
public function GetValues(
i_iSlot : int,
OutAttribute o_uiValues : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
o_uiValues
Array of channel values.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.GetValues Overload List


ParseIOConfig Method

Counter.ParseIOConfig Method
[image]

Support module: ADAM-6051. Parse the counter configuration byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ParseIOConfig( _
ByVal i_byConfig As Byte, _
<OutAttribute> ByRef o_byMode As Byte, _
<OutAttribute> ByRef o_bRecordLastCount As Boolean, _
<OutAttribute> ByRef o_bDigitalFilter As Boolean, _
<OutAttribute> ByRef o_bInvert As Boolean _
)
C#
public static void ParseIOConfig(
byte i_byConfig,
out byte o_byMode,
out bool o_bRecordLastCount,
out bool o_bDigitalFilter,
out bool o_bInvert
)
C++
public:
static void ParseIOConfig(
char i_byConfig,
[OutAttribute] char% o_byMode,
[OutAttribute] bool% o_bRecordLastCount,
[OutAttribute] bool% o_bDigitalFilter,
[OutAttribute] bool% o_bInvert
)
J#
public static void ParseIOConfig(
byte i_byConfig,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode,
/** @attribute OutAttribute() */ /** @ref */ bool o_bRecordLastCount,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDigitalFilter,
/** @attribute OutAttribute() */ /** @ref */ bool o_bInvert
)
JScript
public static function ParseIOConfig(
i_byConfig : Byte,
OutAttribute o_byMode : Byte,
OutAttribute o_bRecordLastCount : bool,
OutAttribute o_bDigitalFilter : bool,
OutAttribute o_bInvert : bool
)

Parameters

i_byConfig
The configuration byte.
o_byMode
The counter mode.
o_bRecordLastCount
The record last count status.
o_bDigitalFilter
The digital filter enable status.
o_bInvert
The invert enable status.

See Also

Counter Class
Advantech.Adam Namespace


SetChannelConfig Method

Counter.SetChannelConfig Method
[image]

Support module: APAX-5082. Set the PWM channel configuration of the indicated slot.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelConfig( _
ByVal i_iSlot As Integer, _
ByVal i_usChIdx As UInt16, _
ByVal i_uiFrequency As UInt32, _
ByVal i_fDutyCycle As Single _
) As Boolean
C#
public bool SetChannelConfig(
int i_iSlot,
ushort i_usChIdx,
uint i_uiFrequency,
float i_fDutyCycle
)
C++
public:
bool SetChannelConfig(
int i_iSlot,
unsigned short i_usChIdx,
unsigned int i_uiFrequency,
float i_fDutyCycle
) sealed
J#
public bool SetChannelConfig(
int i_iSlot,
ushort i_usChIdx,
uint i_uiFrequency,
float i_fDutyCycle
)
JScript
public function SetChannelConfig(
i_iSlot : int,
i_usChIdx : UInt16,
i_uiFrequency : UInt32,
i_fDutyCycle : float
) : bool

Parameters

i_iSlot
Slot index.
i_usChIdx
The channel index, The value is between 0~7.
i_uiFrequency
The frequency of the channel. [1 ~ 500K Hz]
i_fDutyCycle
The duty cycle of the channel. [0 ~ 100 %]

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetChannelEnabled Method

Counter.SetChannelEnabled Method
[image]

Support module: APAX-5080/APAX-5082. Set the counter/PWM status (Start or stop).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetChannelEnabled( _
ByVal i_iSlot As Integer, _
ByVal i_usChMask As UInt32 _
) As Boolean
C#
public bool SetChannelEnabled(
int i_iSlot,
uint i_usChMask
)
C++
public:
bool SetChannelEnabled(
int i_iSlot,
unsigned int i_usChMask
) sealed
J#
public bool SetChannelEnabled(
int i_iSlot,
uint i_usChMask
)
JScript
public function SetChannelEnabled(
i_iSlot : int,
i_usChMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_usChMask
The channel mask.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetClear Method

Counter.SetClear Method

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Clear the event counter value.

Overload List

 | Name | Description
Public method | SetClear | Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Clear the event counter value.
Public method | SetClear (Int32) | Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Clear the counter value.

See Also

Counter Class
Advantech.Adam Namespace


SetClear Method ()

Counter.SetClear Method ()
See Also Example
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012, ADAM-4016. Clear the event counter value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetClear() As Boolean
C#
public bool SetClear()
C++
public:
bool SetClear() sealed
J#
public bool SetClear()
JScript
public function SetClear() : bool

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetClear Overload List


SetClear Method (Int32)

Counter.SetClear Method (Int32)
See Also Example
[image]

Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Clear the counter value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetClear( _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetClear(
int i_iChannel
)
C++
public:
bool SetClear(
int i_iChannel
) sealed
J#
public bool SetClear(
int i_iChannel
)
JScript
public function SetClear(
i_iChannel : int
) : bool

Parameters

i_iChannel
The channel index.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetClear Overload List


SetCntTypeConfiguration Method

Counter.SetCntTypeConfiguration Method
[image]

Support module: APAX-5080 Set counter counting type configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetCntTypeConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_bRepeat As Boolean, _
ByVal i_bReload As Boolean _
) As Boolean
C#
public bool SetCntTypeConfiguration(
int i_iSlot,
int i_iChannel,
bool i_bRepeat,
bool i_bReload
)
C++
public:
bool SetCntTypeConfiguration(
int i_iSlot,
int i_iChannel,
bool i_bRepeat,
bool i_bReload
) sealed
J#
public bool SetCntTypeConfiguration(
int i_iSlot,
int i_iChannel,
bool i_bRepeat,
bool i_bReload
)
JScript
public function SetCntTypeConfiguration(
i_iSlot : int,
i_iChannel : int,
i_bRepeat : bool,
i_bReload : bool
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The counter channel index.
i_bRepeat
Count mode, false:Count once;true:Count repetitively.
i_bReload
Reload mode, true:reload to startup value ;false:reload to 0 or 0xFFFFFFFF.

Return Value

Return true if success, otherwise return false.

See Also

Counter Class
Advantech.Adam Namespace


SetDigitalFilter Method

Counter.SetDigitalFilter Method

Support module: ADAM-5080, ADAM-5081. Set Digital filter value.

Overload List

 | Name | Description
Public method | SetDigitalFilter (Adam5000Type, Int32, Int32) | Support module: ADAM-5080, ADAM-5081. Set Digital filter value.
Public method | SetDigitalFilter (Boolean) | Support module: ADAM-4080, ADAM-4080D. Set Digital filter value.
Public method | SetDigitalFilter (Int32, Int32) | Support module: APAX-5080. Set Digital filter value.

See Also

Counter Class
Advantech.Adam Namespace


SetDigitalFilter Method (Adam5000Type, Int32, Int32)

Counter.SetDigitalFilter Method (Adam5000Type, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Set Digital filter value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilter( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iSlot As Integer, _
ByVal i_iFilter As Integer _
) As Boolean
C#
public bool SetDigitalFilter(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iFilter
)
C++
public:
bool SetDigitalFilter(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iFilter
) sealed
J#
public bool SetDigitalFilter(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iFilter
)
JScript
public function SetDigitalFilter(
adam5000Type : Adam5000Type,
i_iSlot : int,
i_iFilter : int
) : bool

Parameters

adam5000Type
i_iSlot
Slot index. The value is between 0~7
i_iFilter
The digital filter value. The value is from 8~65000.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetDigitalFilter Overload List


SetDigitalFilter Method (Boolean)

Counter.SetDigitalFilter Method (Boolean)
See Also Example
[image]

Support module: ADAM-4080, ADAM-4080D. Set Digital filter value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilter( _
ByVal i_bFilter As Boolean _
) As Boolean
C#
public bool SetDigitalFilter(
bool i_bFilter
)
C++
public:
bool SetDigitalFilter(
bool i_bFilter
) sealed
J#
public bool SetDigitalFilter(
bool i_bFilter
)
JScript
public function SetDigitalFilter(
i_bFilter : bool
) : bool

Parameters

i_bFilter
The digital filter status. True means filter is enabled.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetDigitalFilter Overload List


SetDigitalFilter Method (Int32, Int32)

Counter.SetDigitalFilter Method (Int32, Int32)
See Also Example
[image]

Support module: APAX-5080. Set Digital filter value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilter( _
ByVal i_iSlot As Integer, _
ByVal i_iFilter As Integer _
) As Boolean
C#
public bool SetDigitalFilter(
int i_iSlot,
int i_iFilter
)
C++
public:
bool SetDigitalFilter(
int i_iSlot,
int i_iFilter
) sealed
J#
public bool SetDigitalFilter(
int i_iSlot,
int i_iFilter
)
JScript
public function SetDigitalFilter(
i_iSlot : int,
i_iFilter : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~16
i_iFilter
The digital filter value. The value is from 1~400000.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetDigitalFilter Overload List


SetDigitalFilterMiniSignalWidth Method

Counter.SetDigitalFilterMiniSignalWidth Method

Support module: ADAM-4100. Set digital filter minimum signal width.

Overload List

 | Name | Description
Public method | SetDigitalFilterMiniSignalWidth (Int32, Int64, Int64) | Support module: ADAM-4100. Set digital filter minimum signal width.
Public method | SetDigitalFilterMiniSignalWidth (Int64, Int64) | Support module: ADAM-6000. Set digital filter minimum signal width.

See Also

Counter Class
Advantech.Adam Namespace


SetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)

Counter.SetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)
See Also Example
[image]

Support module: ADAM-4100. Set digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilterMiniSignalWidth( _
ByVal i_iChannel As Integer, _
ByVal i_lHigh As Long, _
ByVal i_lLow As Long _
) As Boolean
C#
public bool SetDigitalFilterMiniSignalWidth(
int i_iChannel,
long i_lHigh,
long i_lLow
)
C++
public:
bool SetDigitalFilterMiniSignalWidth(
int i_iChannel,
__int64 i_lHigh,
__int64 i_lLow
) sealed
J#
public bool SetDigitalFilterMiniSignalWidth(
int i_iChannel,
long i_lHigh,
long i_lLow
)
JScript
public function SetDigitalFilterMiniSignalWidth(
i_iChannel : int,
i_lHigh : long,
i_lLow : long
) : bool

Parameters

i_iChannel
Channel number
i_lHigh
The minimum high signal width.
i_lLow
The minimum low signal width.

Return Value

True if secceed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetDigitalFilterMiniSignalWidth Overload List


SetDigitalFilterMiniSignalWidth Method (Int64[], Int64[])

Counter.SetDigitalFilterMiniSignalWidth Method (Int64[], Int64[])
See Also Example
[image]

Support module: ADAM-6000. Set digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilterMiniSignalWidth( _
ByVal i_lHigh As Long(), _
ByVal i_lLow As Long() _
) As Boolean
C#
public bool SetDigitalFilterMiniSignalWidth(
long[] i_lHigh,
long[] i_lLow
)
C++
public:
bool SetDigitalFilterMiniSignalWidth(
array<__int64>^ i_lHigh,
array<__int64>^ i_lLow
) sealed
J#
public bool SetDigitalFilterMiniSignalWidth(
long[] i_lHigh,
long[] i_lLow
)
JScript
public function SetDigitalFilterMiniSignalWidth(
i_lHigh : long[],
i_lLow : long[]
) : bool

Parameters

i_lHigh
The minimum high signal width.
i_lLow
The minimum low signal width.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetDigitalFilterMiniSignalWidth Overload List


SetFreqAcqTime Method

Counter.SetFreqAcqTime Method

Support module: ADAM-5081. Set frequency acquisition time value.

Overload List

 | Name | Description
Public method | SetFreqAcqTime (Adam5000Type, Int32, Int32) | Support module: ADAM-5081. Set frequency acquisition time value.
Public method | SetFreqAcqTime (Int32, Int32) | Support module: APAX-5080. Set frequency acquisition time value.

See Also

Counter Class
Advantech.Adam Namespace


SetFreqAcqTime Method (Adam5000Type, Int32, Int32)

Counter.SetFreqAcqTime Method (Adam5000Type, Int32, Int32)
See Also Example
[image]

Support module: ADAM-5081. Set frequency acquisition time value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetFreqAcqTime( _
ByVal adam5000Type As Adam5000Type, _
ByVal i_iSlot As Integer, _
ByVal i_iFreqAcqTime As Integer _
) As Boolean
C#
public bool SetFreqAcqTime(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iFreqAcqTime
)
C++
public:
bool SetFreqAcqTime(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iFreqAcqTime
) sealed
J#
public bool SetFreqAcqTime(
Adam5000Type adam5000Type,
int i_iSlot,
int i_iFreqAcqTime
)
JScript
public function SetFreqAcqTime(
adam5000Type : Adam5000Type,
i_iSlot : int,
i_iFreqAcqTime : int
) : bool

Parameters

adam5000Type
i_iSlot
Slot index. The value is between 0~7
i_iFreqAcqTime
The frequency acquisition time value. The value is from 1~1000 ms.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetFreqAcqTime Overload List


SetFreqAcqTime Method (Int32, Int32)

Counter.SetFreqAcqTime Method (Int32, Int32)
See Also Example
[image]

Support module: APAX-5080. Set frequency acquisition time value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetFreqAcqTime( _
ByVal i_iSlot As Integer, _
ByVal i_iFreqAcqTime As Integer _
) As Boolean
C#
public bool SetFreqAcqTime(
int i_iSlot,
int i_iFreqAcqTime
)
C++
public:
bool SetFreqAcqTime(
int i_iSlot,
int i_iFreqAcqTime
) sealed
J#
public bool SetFreqAcqTime(
int i_iSlot,
int i_iFreqAcqTime
)
JScript
public function SetFreqAcqTime(
i_iSlot : int,
i_iFreqAcqTime : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iFreqAcqTime
The frequency acquisition time value. The value is from 1~10000 ms.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetFreqAcqTime Overload List


SetGateMode Method

Counter.SetGateMode Method
[image]

Support module: ADAM-4080, ADAM-4080D. Set the gate mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetGateMode( _
ByVal i_byMode As Byte _
) As Boolean
C#
public bool SetGateMode(
byte i_byMode
)
C++
public:
bool SetGateMode(
char i_byMode
) sealed
J#
public bool SetGateMode(
byte i_byMode
)
JScript
public function SetGateMode(
i_byMode : Byte
) : bool

Parameters

i_byMode
The gate mode.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetInputSignalMode Method

Counter.SetInputSignalMode Method
[image]

Support module: ADAM-4080, ADAM-4080D Set the input signal mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetInputSignalMode( _
ByVal i_byMode As Byte _
) As Boolean
C#
public bool SetInputSignalMode(
byte i_byMode
)
C++
public:
bool SetInputSignalMode(
char i_byMode
) sealed
J#
public bool SetInputSignalMode(
byte i_byMode
)
JScript
public function SetInputSignalMode(
i_byMode : Byte
) : bool

Parameters

i_byMode
The input signal mode.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetIOConfig Method

Counter.SetIOConfig Method

Support module: ADAM-6000. Set DIO configuration.

Overload List

 | Name | Description
Public method | SetIOConfig (Byte) | Support module: ADAM-6000. Set DIO configuration.
Public method | SetIOConfig (Int32, Byte) | Support module: ADAM-4100. Set DI configuration.

See Also

Counter Class
Advantech.Adam Namespace


SetIOConfig Method (Byte[])

Counter.SetIOConfig Method (Byte[])
See Also Example
[image]

Support module: ADAM-6000. Set DIO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIOConfig( _
ByVal i_byConfig As Byte() _
) As Boolean
C#
public bool SetIOConfig(
byte[] i_byConfig
)
C++
public:
bool SetIOConfig(
array<char>^ i_byConfig
) sealed
J#
public bool SetIOConfig(
byte[] i_byConfig
)
JScript
public function SetIOConfig(
i_byConfig : Byte[]
) : bool

Parameters

i_byConfig
The configuration for all DIO channel.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetIOConfig Overload List


SetIOConfig Method (Int32, Byte)

Counter.SetIOConfig Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4100. Set DI configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIOConfig( _
ByVal i_iChannel As Integer, _
ByVal i_byConfig As Byte _
) As Boolean
C#
public bool SetIOConfig(
int i_iChannel,
byte i_byConfig
)
C++
public:
bool SetIOConfig(
int i_iChannel,
char i_byConfig
) sealed
J#
public bool SetIOConfig(
int i_iChannel,
byte i_byConfig
)
JScript
public function SetIOConfig(
i_iChannel : int,
i_byConfig : Byte
) : bool

Parameters

i_iChannel
Channel number
i_byConfig
The configuration for indicated DI channel.

Return Value

True if secceed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetIOConfig Overload List


SetLEDSource Method

Counter.SetLEDSource Method
[image]

Support module: ADAM-4080D Set the LED source.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLEDSource( _
ByVal i_bySource As Byte _
) As Boolean
C#
public bool SetLEDSource(
byte i_bySource
)
C++
public:
bool SetLEDSource(
char i_bySource
) sealed
J#
public bool SetLEDSource(
byte i_bySource
)
JScript
public function SetLEDSource(
i_bySource : Byte
) : bool

Parameters

i_bySource
The LED source.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetLEDText Method

Counter.SetLEDText Method
[image]

Support module: ADAM-4080D Set the LED text

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLEDText( _
ByVal i_szText As String _
) As Boolean
C#
public bool SetLEDText(
string i_szText
)
C++
public:
bool SetLEDText(
String i_szText
) sealed
J#
public bool SetLEDText(
string i_szText
)
JScript
public function SetLEDText(
i_szText : String
) : bool

Parameters

i_szText
The text to be shown. The length of the text must be six. The string must be numric or dot characters.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetLocalGateConfiguration Method

Counter.SetLocalGateConfiguration Method
[image]

Support module: APAX-5080 Set gate mode, type, mapping gate.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetLocalGateConfiguration( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_bEnable As Boolean, _
ByVal i_byTriggerMode As Byte, _
ByVal i_byGateActiveType As Byte, _
ByVal i_iGateMap As Integer _
) As Boolean
C#
public bool SetLocalGateConfiguration(
int i_iSlot,
int i_iChannel,
bool i_bEnable,
byte i_byTriggerMode,
byte i_byGateActiveType,
int i_iGateMap
)
C++
public:
bool SetLocalGateConfiguration(
int i_iSlot,
int i_iChannel,
bool i_bEnable,
char i_byTriggerMode,
char i_byGateActiveType,
int i_iGateMap
) sealed
J#
public bool SetLocalGateConfiguration(
int i_iSlot,
int i_iChannel,
bool i_bEnable,
byte i_byTriggerMode,
byte i_byGateActiveType,
int i_iGateMap
)
JScript
public function SetLocalGateConfiguration(
i_iSlot : int,
i_iChannel : int,
i_bEnable : bool,
i_byTriggerMode : Byte,
i_byGateActiveType : Byte,
i_iGateMap : int
) : bool

Parameters

i_iSlot
The slot index.
i_iChannel
The counter channel index.
i_bEnable
The gate enable flag.
i_byTriggerMode
The gate trigger mode.
i_byGateActiveType
The gate active type.
i_iGateMap
The mapping gate index.

Return Value

Return true if success, otherwise return false.

See Also

Counter Class
Advantech.Adam Namespace


SetMaxValue Method

Counter.SetMaxValue Method
[image]

Support module: ADAM-4080, ADAM-4080D. Set the counter/frequency maximum value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMaxValue( _
ByVal i_iChannel As Integer, _
ByVal i_lValue As Long _
) As Boolean
C#
public bool SetMaxValue(
int i_iChannel,
long i_lValue
)
C++
public:
bool SetMaxValue(
int i_iChannel,
__int64 i_lValue
) sealed
J#
public bool SetMaxValue(
int i_iChannel,
long i_lValue
)
JScript
public function SetMaxValue(
i_iChannel : int,
i_lValue : long
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1.
i_lValue
The counter/frequency value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetMinInputSignalWidth Method

Counter.SetMinInputSignalWidth Method
[image]

Support module: ADAM-4080, ADAM-4080D. Set the minimum input signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMinInputSignalWidth( _
ByVal i_byLevel As Byte, _
ByVal i_iValue As Integer _
) As Boolean
C#
public bool SetMinInputSignalWidth(
byte i_byLevel,
int i_iValue
)
C++
public:
bool SetMinInputSignalWidth(
char i_byLevel,
int i_iValue
) sealed
J#
public bool SetMinInputSignalWidth(
byte i_byLevel,
int i_iValue
)
JScript
public function SetMinInputSignalWidth(
i_byLevel : Byte,
i_iValue : int
) : bool

Parameters

i_byLevel
The level. The value 0 means low. Otherwise means high.
i_iValue
The minimum input signal width. The unit is micro-second. The range is between 2~65535.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetMode Method

Counter.SetMode Method

Support module: ADAM-5080 on ADAM-5000/TCP. Set module counter mode.

Overload List

 | Name | Description
Public method | SetMode (Int32, Byte) | Support module: ADAM-5080 on ADAM-5000/TCP. Set module counter mode.
Public method | SetMode (Int32, Int32, Byte) | Support module: ADAM-5081. Set module counter mode.

See Also

Counter Class
Advantech.Adam Namespace


SetMode Method (Int32, Byte)

Counter.SetMode Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-5080 on ADAM-5000/TCP. Set module counter mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMode( _
ByVal i_iSlot As Integer, _
ByVal i_byMode As Byte _
) As Boolean
C#
public bool SetMode(
int i_iSlot,
byte i_byMode
)
C++
public:
bool SetMode(
int i_iSlot,
char i_byMode
) sealed
J#
public bool SetMode(
int i_iSlot,
byte i_byMode
)
JScript
public function SetMode(
i_iSlot : int,
i_byMode : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_byMode
The counter mode code.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetMode Overload List


SetMode Method (Int32, Int32, Byte)

Counter.SetMode Method (Int32, Int32, Byte)
See Also Example
[image]

Support module: ADAM-5081. Set module counter mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMode( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_byMode As Byte _
) As Boolean
C#
public bool SetMode(
int i_iSlot,
int i_iChannel,
byte i_byMode
)
C++
public:
bool SetMode(
int i_iSlot,
int i_iChannel,
char i_byMode
) sealed
J#
public bool SetMode(
int i_iSlot,
int i_iChannel,
byte i_byMode
)
JScript
public function SetMode(
i_iSlot : int,
i_iChannel : int,
i_byMode : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_byMode
The counter mode code.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetMode Overload List


SetModeFormat Method

Counter.SetModeFormat Method
[image]

Support module: ADAM-5080 on ADAM-5000. Set module counter mode.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModeFormat( _
ByVal i_iSlot As Integer, _
ByVal i_byMode As Byte, _
ByVal i_byFormat As Byte _
) As Boolean
C#
public bool SetModeFormat(
int i_iSlot,
byte i_byMode,
byte i_byFormat
)
C++
public:
bool SetModeFormat(
int i_iSlot,
char i_byMode,
char i_byFormat
) sealed
J#
public bool SetModeFormat(
int i_iSlot,
byte i_byMode,
byte i_byFormat
)
JScript
public function SetModeFormat(
i_iSlot : int,
i_byMode : Byte,
i_byFormat : Byte
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_byMode
The counter mode code.
i_byFormat
The data format code.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetModes Method

Counter.SetModes Method
[image]

Support module: APAX-5080. Set module counter modes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetModes( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
ByVal i_usModes As UInt16() _
) As Boolean
C#
public bool SetModes(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usModes
)
C++
public:
bool SetModes(
int i_iSlot,
int i_iChannelTotal,
array<unsigned short>^ i_usModes
) sealed
J#
public bool SetModes(
int i_iSlot,
int i_iChannelTotal,
ushort[] i_usModes
)
JScript
public function SetModes(
i_iSlot : int,
i_iChannelTotal : int,
i_usModes : UInt16[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_iChannelTotal
The total of the channel on the module.
i_usModes
The counter modes. (Up, down, bipolar)

See Also

Counter Class
Advantech.Adam Namespace


SetStartupValue Method

Counter.SetStartupValue Method

Support module: ADAM-5080, ADAM-5081. Set counter startup value.

Overload List

 | Name | Description
Public method | SetStartupValue (Int32, Int32, Int64) | Support module: ADAM-5080, ADAM-5081. Set counter startup value.
Public method | SetStartupValue (Int32, Int64) | Support module: ADAM-4080. Set counter startup value.

See Also

Counter Class
Advantech.Adam Namespace


SetStartupValue Method (Int32, Int32, Int64)

Counter.SetStartupValue Method (Int32, Int32, Int64)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Set counter startup value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStartupValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_lStartup As Long _
) As Boolean
C#
public bool SetStartupValue(
int i_iSlot,
int i_iChannel,
long i_lStartup
)
C++
public:
bool SetStartupValue(
int i_iSlot,
int i_iChannel,
__int64 i_lStartup
) sealed
J#
public bool SetStartupValue(
int i_iSlot,
int i_iChannel,
long i_lStartup
)
JScript
public function SetStartupValue(
i_iSlot : int,
i_iChannel : int,
i_lStartup : long
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_lStartup
The startup value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetStartupValue Overload List


SetStartupValue Method (Int32, Int64)

Counter.SetStartupValue Method (Int32, Int64)
See Also Example
[image]

Support module: ADAM-4080. Set counter startup value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStartupValue( _
ByVal i_iChannel As Integer, _
ByVal i_lStartup As Long _
) As Boolean
C#
public bool SetStartupValue(
int i_iChannel,
long i_lStartup
)
C++
public:
bool SetStartupValue(
int i_iChannel,
__int64 i_lStartup
) sealed
J#
public bool SetStartupValue(
int i_iChannel,
long i_lStartup
)
JScript
public function SetStartupValue(
i_iChannel : int,
i_lStartup : long
) : bool

Parameters

i_iChannel
The channel index. The value is between 0~1
i_lStartup
The startup value.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetStartupValue Overload List


SetStartupValues Method

Counter.SetStartupValues Method
[image]

Support module: APAX-5080. Set analog output startup values

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStartupValues( _
ByVal i_iSlot As Integer, _
ByVal i_uiValues As UInt32() _
) As Boolean
C#
public bool SetStartupValues(
int i_iSlot,
uint[] i_uiValues
)
C++
public:
bool SetStartupValues(
int i_iSlot,
array<unsigned int>^ i_uiValues
) sealed
J#
public bool SetStartupValues(
int i_iSlot,
uint[] i_uiValues
)
JScript
public function SetStartupValues(
i_iSlot : int,
i_uiValues : UInt32[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_uiValues
The counter startup values.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


SetStatus Method

Counter.SetStatus Method

Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Set the counter status.

Overload List

 | Name | Description
Public method | SetStatus (Int32, Boolean) | Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Set the counter status.
Public method | SetStatus (Int32, Int32, Boolean) | Support module: ADAM-5080, ADAM-5081. Set the counter status.

See Also

Counter Class
Advantech.Adam Namespace


SetStatus Method (Int32, Boolean)

Counter.SetStatus Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-4100, ADAM-4080, ADAM-4080D. Set the counter status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStatus( _
ByVal i_iChannel As Integer, _
ByVal i_bCounting As Boolean _
) As Boolean
C#
public bool SetStatus(
int i_iChannel,
bool i_bCounting
)
C++
public:
bool SetStatus(
int i_iChannel,
bool i_bCounting
) sealed
J#
public bool SetStatus(
int i_iChannel,
bool i_bCounting
)
JScript
public function SetStatus(
i_iChannel : int,
i_bCounting : bool
) : bool

Parameters

i_iChannel
The channel index.
i_bCounting
The counter status. True if the counter starts counting. Otherwise false.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetStatus Overload List


SetStatus Method (Int32, Int32, Boolean)

Counter.SetStatus Method (Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Set the counter status.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_bCounting As Boolean _
) As Boolean
C#
public bool SetStatus(
int i_iSlot,
int i_iChannel,
bool i_bCounting
)
C++
public:
bool SetStatus(
int i_iSlot,
int i_iChannel,
bool i_bCounting
) sealed
J#
public bool SetStatus(
int i_iSlot,
int i_iChannel,
bool i_bCounting
)
JScript
public function SetStatus(
i_iSlot : int,
i_iChannel : int,
i_bCounting : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7
i_bCounting
The counter status. True if the counter is counting. Otherwise false.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetStatus Overload List


SetToStartup Method

Counter.SetToStartup Method

Support module: ADAM-5080, ADAM-5081. Force the counter value to startup value.

Overload List

 | Name | Description
Public method | SetToStartup (Int32, Int32) | Support module: ADAM-5080, ADAM-5081. Force the counter value to startup value.
Public method | SetToStartup (Int32, UInt32) | Support module: APAX-5080. Force the counter value to startup value.

See Also

Counter Class
Advantech.Adam Namespace


SetToStartup Method (Int32, Int32)

Counter.SetToStartup Method (Int32, Int32)
See Also Example
[image]

Support module: ADAM-5080, ADAM-5081. Force the counter value to startup value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetToStartup( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer _
) As Boolean
C#
public bool SetToStartup(
int i_iSlot,
int i_iChannel
)
C++
public:
bool SetToStartup(
int i_iSlot,
int i_iChannel
) sealed
J#
public bool SetToStartup(
int i_iSlot,
int i_iChannel
)
JScript
public function SetToStartup(
i_iSlot : int,
i_iChannel : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannel
The channel index. The value is between 0~7

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetToStartup Overload List


SetToStartup Method (Int32, UInt32)

Counter.SetToStartup Method (Int32, UInt32)
See Also Example
[image]

Support module: APAX-5080. Force the counter value to startup value.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetToStartup( _
ByVal i_iSlot As Integer, _
ByVal i_uiChMask As UInt32 _
) As Boolean
C#
public bool SetToStartup(
int i_iSlot,
uint i_uiChMask
)
C++
public:
bool SetToStartup(
int i_iSlot,
unsigned int i_uiChMask
) sealed
J#
public bool SetToStartup(
int i_iSlot,
uint i_uiChMask
)
JScript
public function SetToStartup(
i_iSlot : int,
i_uiChMask : UInt32
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~15
i_uiChMask
The channel mask.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace
Counter.SetToStartup Overload List


SetTriggerLevel Method

Counter.SetTriggerLevel Method
[image]

Support module: ADAM-4080D. Set the trigger level for non-isolated input.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetTriggerLevel( _
ByVal i_byLevel As Byte, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool SetTriggerLevel(
byte i_byLevel,
float i_fValue
)
C++
public:
bool SetTriggerLevel(
char i_byLevel,
float i_fValue
) sealed
J#
public bool SetTriggerLevel(
byte i_byLevel,
float i_fValue
)
JScript
public function SetTriggerLevel(
i_byLevel : Byte,
i_fValue : float
) : bool

Parameters

i_byLevel
The level. The value 0 means low. Otherwise means high.
i_fValue
The trigger level. The range is between 0.1~5.0 voltage.

Return Value

True if succeed, otherwise false.

See Also

Counter Class
Advantech.Adam Namespace


DeviceConnectionStatus Enumeration

DeviceConnectionStatus Enumeration
[image]

Device Connection Status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum DeviceConnectionStatus
C#
public enum DeviceConnectionStatus
C++
public enum class DeviceConnectionStatus
J#
public enum DeviceConnectionStatus
JScript
public enum DeviceConnectionStatus

Members

Member Name | Description
Connected | Connected
ConnectionFailed | ConnectionFailed
Disconnection | Disconnection
Connecting | Connecting

See Also

Advantech.Adam Namespace


DI_OperationMode Enumeration

DI_OperationMode Enumeration
[image]

DI Operation Mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum DI_OperationMode As Byte
C#
public enum DI_OperationMode : byte
C++
public enum class DI_OperationMode : char
J#
public enum DI_OperationMode byte
JScript
public enum DI_OperationMode :

Members

Member Name | Description
Normal | Normal mode
True_Triggers_To_Startup_Value | True Triggers To Startup Value
False_Triggers_To_Startup_Value | False Triggers To StartupValue
True_Triggers_To_Safety_Value | True Triggers to Safety Value
False_Triggers_To_Safety_Value | False Triggers to Safety Value
Unknown | Unknown

See Also

Advantech.Adam Namespace


DigitalInput Class

DigitalInput Class
See Also Example Members
[image]

DigitalInput class for ADAM series.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class DigitalInput
Inherits AdamBase
C#
public class DigitalInput : AdamBase
C++
ref class DigitalInput : AdamBase
J#
public class DigitalInput extends AdamBase
JScript
public class DigitalInput extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.DigitalInput

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DigitalInput Members
Advantech.Adam Namespace


DigitalInput Members

DigitalInput Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

DigitalInput class for ADAM series.

The following tables list the members exposed by DigitalInput.

Public Constructors

Name | Description
DigitalInput | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
 | FormIOConfig | Support module: ADAM-4100, ADAM-6000. Form the DI configuration byte.
Public method | Get6124DIStatus | Support module: ADAM-6124.
Public method | GetAOGateTriggerMode | Support module: ADAM-6124.
 | GetChannelStart | Support module: ADAM-6000. Get the DI channel start index from IO config array.
 | GetChannelTotal | Overloaded. Support module: ADAM-4000. Get DI channel total number.
 | GetCounterScaledValue | Support module: ADAM-6000. Get the counter scaled value
Public method | GetDIChannelConfigInfo | Support module: ADAM-6200. Get the DI channel configuration information
Public method | GetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100, ADAM-6200. Get digital filter minimum signal width.
 | GetDIOperationModeName | Get the DI Operation Mode Name for DI Operation Mode
 | GetFrequencyScaledValue | Support module: ADAM-6000. Get the frequency scaled value
Public method | GetInvertMask | Overloaded. Support module: ADAM-4051. Get invert enabled mask
Public method | GetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.
Public method | GetUniversalStatus | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get universal status
Public method | GetValue | Support module: ADAM-4011, ADAM-4011D, ADAM-4012. Get DI status that is used for the event counter.
Public method | GetValues | Overloaded. Support module: ADAM-4024. Get DI values.
 | ParseIOConfig | Support module: ADAM-4100, ADAM-6000. Parse the DI configuration byte.
Public method | SetAOGateTriggerMode | Support module: ADAM-6124.
Public method | SetDIChannelConfigInfo | Support module: ADAM-6200. Set the DI channel configuration information
Public method | SetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100, ADAM-6200. Set digital filter minimum signal width.
Public method | SetInvertMask | Overloaded. Support module: ADAM-4051. Set invert enabled mask
Public method | SetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetDIOperationModeCode | Get the DI operation mode code.
 | GetDIOperationModeIndex | Get the DI operation mode code index.
 | GetDIOperationModeTotal | Get the DI operation mode total
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
DigitalInput | Overloaded.
Top

See Also

DigitalInput Class
Advantech.Adam Namespace


DigitalInput Constructor

DigitalInput Constructor

Overload List

 | Name | Description
Public method | DigitalInput (AdamCom) | The DigitalInput constructor.
Public method | DigitalInput (AdamControl) | The DigitalInput constructor.
Public method | DigitalInput (AdamSocket) | The DigitalInput constructor.

See Also

DigitalInput Class
Advantech.Adam Namespace


DigitalInput Constructor (AdamCom)

DigitalInput Constructor (AdamCom)
See Also Example
[image]

The DigitalInput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public DigitalInput(
AdamCom i_com
)
C++
public:
DigitalInput(
AdamCom i_com
) sealed
J#
public DigitalInput(
AdamCom i_com
)
JScript
public function DigitalInput(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput Constructor Overload List


DigitalInput Constructor (AdamControl)

DigitalInput Constructor (AdamControl)
See Also Example
[image]

The DigitalInput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public DigitalInput(
AdamControl i_control
)
C++
public:
DigitalInput(
AdamControl i_control
) sealed
J#
public DigitalInput(
AdamControl i_control
)
JScript
public function DigitalInput(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput Constructor Overload List


DigitalInput Constructor (AdamSocket)

DigitalInput Constructor (AdamSocket)
See Also Example
[image]

The DigitalInput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public DigitalInput(
AdamSocket i_socket
)
C++
public:
DigitalInput(
AdamSocket i_socket
) sealed
J#
public DigitalInput(
AdamSocket i_socket
)
JScript
public function DigitalInput(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput Constructor Overload List


Methods

DigitalInput Methods
[image]

Public Methods

 | Name | Description
 | FormIOConfig | Support module: ADAM-4100, ADAM-6000. Form the DI configuration byte.
Public method | Get6124DIStatus | Support module: ADAM-6124.
Public method | GetAOGateTriggerMode | Support module: ADAM-6124.
 | GetChannelStart | Support module: ADAM-6000. Get the DI channel start index from IO config array.
 | GetChannelTotal | Overloaded. Support module: ADAM-4000. Get DI channel total number.
 | GetCounterScaledValue | Support module: ADAM-6000. Get the counter scaled value
Public method | GetDIChannelConfigInfo | Support module: ADAM-6200. Get the DI channel configuration information
Public method | GetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100, ADAM-6200. Get digital filter minimum signal width.
 | GetDIOperationModeName | Get the DI Operation Mode Name for DI Operation Mode
 | GetFrequencyScaledValue | Support module: ADAM-6000. Get the frequency scaled value
Public method | GetInvertMask | Overloaded. Support module: ADAM-4051. Get invert enabled mask
Public method | GetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.
Public method | GetUniversalStatus | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get universal status
Public method | GetValue | Support module: ADAM-4011, ADAM-4011D, ADAM-4012. Get DI status that is used for the event counter.
Public method | GetValues | Overloaded. Support module: ADAM-4024. Get DI values.
 | ParseIOConfig | Support module: ADAM-4100, ADAM-6000. Parse the DI configuration byte.
Public method | SetAOGateTriggerMode | Support module: ADAM-6124.
Public method | SetDIChannelConfigInfo | Support module: ADAM-6200. Set the DI channel configuration information
Public method | SetDigitalFilterMiniSignalWidth | Overloaded. Support module: ADAM-4100, ADAM-6200. Set digital filter minimum signal width.
Public method | SetInvertMask | Overloaded. Support module: ADAM-4051. Set invert enabled mask
Public method | SetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
 | GetDIOperationModeCode | Get the DI operation mode code.
 | GetDIOperationModeIndex | Get the DI operation mode code index.
 | GetDIOperationModeTotal | Get the DI operation mode total
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

DigitalInput Class
Advantech.Adam Namespace


FormIOConfig Method

DigitalInput.FormIOConfig Method
[image]

Support module: ADAM-4100, ADAM-6000. Form the DI configuration byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FormIOConfig( _
ByVal i_byMode As Byte, _
ByVal i_bRecordLastCount As Boolean, _
ByVal i_bDigitalFilter As Boolean, _
ByVal i_bInvert As Boolean, _
<OutAttribute> ByRef o_byConfig As Byte _
)
C#
public static void FormIOConfig(
byte i_byMode,
bool i_bRecordLastCount,
bool i_bDigitalFilter,
bool i_bInvert,
out byte o_byConfig
)
C++
public:
static void FormIOConfig(
char i_byMode,
bool i_bRecordLastCount,
bool i_bDigitalFilter,
bool i_bInvert,
[OutAttribute] char% o_byConfig
)
J#
public static void FormIOConfig(
byte i_byMode,
bool i_bRecordLastCount,
bool i_bDigitalFilter,
bool i_bInvert,
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public static function FormIOConfig(
i_byMode : Byte,
i_bRecordLastCount : bool,
i_bDigitalFilter : bool,
i_bInvert : bool,
OutAttribute o_byConfig : Byte
)

Parameters

i_byMode
The DI mode.
i_bRecordLastCount
The record last count status.
i_bDigitalFilter
The digital filter enable status.
i_bInvert
The invert enable status.
o_byConfig
The configuration byte.

See Also

DigitalInput Class
Advantech.Adam Namespace


Get6124DIStatus Method

DigitalInput.Get6124DIStatus Method
[image]

Support module: ADAM-6124.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function Get6124DIStatus( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_iDIStatus As Integer _
) As Boolean
C#
public bool Get6124DIStatus(
int i_iSlot,
int i_iChannelTotal,
out int o_iDIStatus
)
C++
public:
bool Get6124DIStatus(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] int% o_iDIStatus
) sealed
J#
public bool Get6124DIStatus(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ int o_iDIStatus
)
JScript
public function Get6124DIStatus(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_iDIStatus : int
) : bool

Parameters

i_iSlot
Slot index.
i_iChannelTotal
The total of the channel on the module.
o_iDIStatus
The DI status.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetAOGateTriggerMode Method

DigitalInput.GetAOGateTriggerMode Method
[image]

Support module: ADAM-6124.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAOGateTriggerMode( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef i_iTriggerMode As Integer _
) As Boolean
C#
public bool GetAOGateTriggerMode(
int i_iSlot,
out int i_iTriggerMode
)
C++
public:
bool GetAOGateTriggerMode(
int i_iSlot,
[OutAttribute] int% i_iTriggerMode
) sealed
J#
public bool GetAOGateTriggerMode(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ int i_iTriggerMode
)
JScript
public function GetAOGateTriggerMode(
i_iSlot : int,
OutAttribute i_iTriggerMode : int
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7.
i_iTriggerMode
The AO gate trigger mode.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetChannelStart Method

DigitalInput.GetChannelStart Method
[image]

Support module: ADAM-6000. Get the DI channel start index from IO config array.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelStart( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelStart(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelStart(
Adam6000Type adam6000Type
)
J#
public static int GetChannelStart(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelStart(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
The adam6000Type.

Return Value

The DI channel start index.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetChannelTotal Method

DigitalInput.GetChannelTotal Method

Support module: ADAM-4000. Get DI channel total number.

Overload List

Name | Description
GetChannelTotal (Adam4000Type) | Support module: ADAM-4000. Get DI channel total number.
GetChannelTotal (Adam5000Type) | Support module: ADAM-5000, ADAM-5000/TCP. Get DI channel total number.
GetChannelTotal (Adam6000Type) | Support module: ADAM-6000. Get DI channel total number.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetChannelTotal Method (Adam4000Type)

DigitalInput.GetChannelTotal Method (Adam4000Type)
See Also Example
[image]

Support module: ADAM-4000. Get DI channel total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetChannelTotal(
Adam4000Type adam4000Type
)
J#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetChannelTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
The Adam4000Type.

Return Value

The DI total channel number.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetChannelTotal Overload List


GetChannelTotal Method (Adam5000Type)

DigitalInput.GetChannelTotal Method (Adam5000Type)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP. Get DI channel total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetChannelTotal(
Adam5000Type adam5000Type
)
J#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetChannelTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
The Adam5000Type.

Return Value

The DI total channel number.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetChannelTotal Overload List


GetChannelTotal Method (Adam6000Type)

DigitalInput.GetChannelTotal Method (Adam6000Type)
See Also Example
[image]

Support module: ADAM-6000. Get DI channel total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelTotal(
Adam6000Type adam6000Type
)
J#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
The Adam6000Type.

Return Value

The DI total channel number.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetChannelTotal Overload List


GetCounterScaledValue Method

DigitalInput.GetCounterScaledValue Method
[image]

Support module: ADAM-6000. Get the counter scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCounterScaledValue( _
ByVal i_iHigh As Integer, _
ByVal i_iLow As Integer _
) As Double
C#
public static double GetCounterScaledValue(
int i_iHigh,
int i_iLow
)
C++
public:
static double GetCounterScaledValue(
int i_iHigh,
int i_iLow
)
J#
public static double GetCounterScaledValue(
int i_iHigh,
int i_iLow
)
JScript
public static function GetCounterScaledValue(
i_iHigh : int,
i_iLow : int
) : double

Parameters

i_iHigh
The value that is read by Modbus.
i_iLow
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

DigitalInput Class
Advantech.Adam Namespace


GetDIChannelConfigInfo Method

DigitalInput.GetDIChannelConfigInfo Method
[image]

Support module: ADAM-6200. Get the DI channel configuration information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDIChannelConfigInfo( _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_byDiConfigArray As Byte _
) As Boolean
C#
public bool GetDIChannelConfigInfo(
int i_iChannelTotal,
out byte o_byDiConfigArray
)
C++
public:
bool GetDIChannelConfigInfo(
int i_iChannelTotal,
[OutAttribute] char% o_byDiConfigArray
) sealed
J#
public bool GetDIChannelConfigInfo(
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ byte o_byDiConfigArray
)
JScript
public function GetDIChannelConfigInfo(
i_iChannelTotal : int,
OutAttribute o_byDiConfigArray : Byte
) : bool

Parameters

i_iChannelTotal
The total of the DI channel on the module.
o_byDiConfigArray
The total of DI channel configuration information.

Return Value

True if succeed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetDigitalFilterMiniSignalWidth Method

DigitalInput.GetDigitalFilterMiniSignalWidth Method

Support module: ADAM-4100, ADAM-6200. Get digital filter minimum signal width.

Overload List

 | Name | Description
Public method | GetDigitalFilterMiniSignalWidth (Int32, Int64, Int64) | Support module: ADAM-4100, ADAM-6200. Get digital filter minimum signal width.
Public method | GetDigitalFilterMiniSignalWidth (Int32, UInt16, UInt16) | Support module: ADAM-5000, ADAM-5000/TCP. Get digital filter minimum signal width.
Public method | GetDigitalFilterMiniSignalWidth (Int32, UInt32, Boolean) | Support module: APAX-5000, APAX-5070. Get digital filter minimum signal width.
Public method | GetDigitalFilterMiniSignalWidth (Int64, Int64) | Support module: ADAM-6050, ADAM-6051, ADAM-6052, ADAM-6055, ADAM-6060, ADAM-6066. Get digital filter minimum signal width.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)

DigitalInput.GetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)
See Also Example
[image]

Support module: ADAM-4100, ADAM-6200. Get digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilterMiniSignalWidth( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lHigh As Long, _
<OutAttribute> ByRef o_lLow As Long _
) As Boolean
C#
public bool GetDigitalFilterMiniSignalWidth(
int i_iChannel,
out long o_lHigh,
out long o_lLow
)
C++
public:
bool GetDigitalFilterMiniSignalWidth(
int i_iChannel,
[OutAttribute] __int64% o_lHigh,
[OutAttribute] __int64% o_lLow
) sealed
J#
public bool GetDigitalFilterMiniSignalWidth(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lHigh,
/** @attribute OutAttribute() */ /** @ref */ long o_lLow
)
JScript
public function GetDigitalFilterMiniSignalWidth(
i_iChannel : int,
OutAttribute o_lHigh : long,
OutAttribute o_lLow : long
) : bool

Parameters

i_iChannel
Channel number
o_lHigh
The minimum high signal width.
o_lLow
The minimum low signal width.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetDigitalFilterMiniSignalWidth Overload List


GetDigitalFilterMiniSignalWidth Method (Int32, UInt16, UInt16)

DigitalInput.GetDigitalFilterMiniSignalWidth Method (Int32, UInt16, UInt16)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP. Get digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilterMiniSignalWidth( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iHigh As UInt16, _
<OutAttribute> ByRef o_iLow As UInt16 _
) As Boolean
C#
public bool GetDigitalFilterMiniSignalWidth(
int i_iSlot,
out ushort o_iHigh,
out ushort o_iLow
)
C++
public:
bool GetDigitalFilterMiniSignalWidth(
int i_iSlot,
[OutAttribute] unsigned short% o_iHigh,
[OutAttribute] unsigned short% o_iLow
) sealed
J#
public bool GetDigitalFilterMiniSignalWidth(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_iHigh,
/** @attribute OutAttribute() */ /** @ref */ ushort o_iLow
)
JScript
public function GetDigitalFilterMiniSignalWidth(
i_iSlot : int,
OutAttribute o_iHigh : UInt16,
OutAttribute o_iLow : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7.
o_iHigh
The minimum high signal width.
o_iLow
The minimum low signal width.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetDigitalFilterMiniSignalWidth Overload List


GetDigitalFilterMiniSignalWidth Method (Int32, UInt32, Boolean)

DigitalInput.GetDigitalFilterMiniSignalWidth Method (Int32, UInt32, Boolean)
See Also Example
[image]

Support module: APAX-5000, APAX-5070. Get digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilterMiniSignalWidth( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_iWidth As UInt32, _
<OutAttribute> ByRef o_bEnable As Boolean _
) As Boolean
C#
public bool GetDigitalFilterMiniSignalWidth(
int i_iSlot,
out uint o_iWidth,
out bool o_bEnable
)
C++
public:
bool GetDigitalFilterMiniSignalWidth(
int i_iSlot,
[OutAttribute] unsigned int% o_iWidth,
[OutAttribute] bool% o_bEnable
) sealed
J#
public bool GetDigitalFilterMiniSignalWidth(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_iWidth,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable
)
JScript
public function GetDigitalFilterMiniSignalWidth(
i_iSlot : int,
OutAttribute o_iWidth : UInt32,
OutAttribute o_bEnable : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7.
o_iWidth
The minimum high signal width. The value is between 10~1280. (0.1ms/unit)
o_bEnable
True if enable; false if disable.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetDigitalFilterMiniSignalWidth Overload List


GetDigitalFilterMiniSignalWidth Method (Int64, Int64)

DigitalInput.GetDigitalFilterMiniSignalWidth Method (Int64, Int64)
See Also Example
[image]

Support module: ADAM-6050, ADAM-6051, ADAM-6052, ADAM-6055, ADAM-6060, ADAM-6066. Get digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDigitalFilterMiniSignalWidth( _
<OutAttribute> ByRef o_lHigh As Long, _
<OutAttribute> ByRef o_lLow As Long _
) As Boolean
C#
public bool GetDigitalFilterMiniSignalWidth(
out long o_lHigh,
out long o_lLow
)
C++
public:
bool GetDigitalFilterMiniSignalWidth(
[OutAttribute] __int64% o_lHigh,
[OutAttribute] __int64% o_lLow
) sealed
J#
public bool GetDigitalFilterMiniSignalWidth(
/** @attribute OutAttribute() */ /** @ref */ long o_lHigh,
/** @attribute OutAttribute() */ /** @ref */ long o_lLow
)
JScript
public function GetDigitalFilterMiniSignalWidth(
OutAttribute o_lHigh : long,
OutAttribute o_lLow : long
) : bool

Parameters

o_lHigh
The minimum high signal width.
o_lLow
The minimum low signal width.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetDigitalFilterMiniSignalWidth Overload List


GetDIOperationModeCode Method

DigitalInput.GetDIOperationModeCode Method
[image]

Get the DI operation mode code.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetDIOperationModeCode( _
ByVal i_iIndex As Integer _
) As Byte
C#
protected static byte GetDIOperationModeCode(
int i_iIndex
)
C++
protected:
static char GetDIOperationModeCode(
int i_iIndex
)
J#
protected static byte GetDIOperationModeCode(
int i_iIndex
)
JScript
protected static function GetDIOperationModeCode(
i_iIndex : int
) : Byte

Parameters

i_iIndex
The DI operation mode code index.

Return Value

Return range code if success, otherwise, return 255

See Also

DigitalInput Class
Advantech.Adam Namespace


GetDIOperationModeIndex Method

DigitalInput.GetDIOperationModeIndex Method
[image]

Get the DI operation mode code index.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetDIOperationModeIndex( _
ByVal i_byMode As Byte _
) As Integer
C#
protected static int GetDIOperationModeIndex(
byte i_byMode
)
C++
protected:
static int GetDIOperationModeIndex(
char i_byMode
)
J#
protected static int GetDIOperationModeIndex(
byte i_byMode
)
JScript
protected static function GetDIOperationModeIndex(
i_byMode : Byte
) : int

Parameters

i_byMode
The DI operation mode code index.

Return Value

Return range code index if success, otherwise, return -1

See Also

DigitalInput Class
Advantech.Adam Namespace


GetDIOperationModeName Method

DigitalInput.GetDIOperationModeName Method
[image]

Get the DI Operation Mode Name for DI Operation Mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDIOperationModeName( _
ByVal i_byMode As Byte _
) As String
C#
public static string GetDIOperationModeName(
byte i_byMode
)
C++
public:
static String GetDIOperationModeName(
char i_byMode
)
J#
public static string GetDIOperationModeName(
byte i_byMode
)
JScript
public static function GetDIOperationModeName(
i_byMode : Byte
) : String

Parameters

i_byMode
The DI Operation Mode code.

Return Value

Return operation mode string if success, otherwise, return empty string.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetDIOperationModeTotal Method

DigitalInput.GetDIOperationModeTotal Method
[image]

Get the DI operation mode total

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetDIOperationModeTotal() As Integer
C#
protected static int GetDIOperationModeTotal()
C++
protected:
static int GetDIOperationModeTotal()
J#
protected static int GetDIOperationModeTotal()
JScript
protected static function GetDIOperationModeTotal() : int

Return Value

Return DI operation mode total if success, otherwise, return 0.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetFrequencyScaledValue Method

DigitalInput.GetFrequencyScaledValue Method
[image]

Support module: ADAM-6000. Get the frequency scaled value

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFrequencyScaledValue( _
ByVal i_iHigh As Integer, _
ByVal i_iLow As Integer _
) As Double
C#
public static double GetFrequencyScaledValue(
int i_iHigh,
int i_iLow
)
C++
public:
static double GetFrequencyScaledValue(
int i_iHigh,
int i_iLow
)
J#
public static double GetFrequencyScaledValue(
int i_iHigh,
int i_iLow
)
JScript
public static function GetFrequencyScaledValue(
i_iHigh : int,
i_iLow : int
) : double

Parameters

i_iHigh
The value that is read by Modbus.
i_iLow
The value that is read by Modbus.

Return Value

Return scaled value if success, otherwise, return 0.0

See Also

DigitalInput Class
Advantech.Adam Namespace


GetInvertMask Method

DigitalInput.GetInvertMask Method

Support module: ADAM-4051. Get invert enabled mask

Overload List

 | Name | Description
Public method | GetInvertMask (Boolean) | Support module: ADAM-4051. Get invert enabled mask
Public method | GetInvertMask (Int32, Boolean) | Support module: ADAM-5000/TCP, ADAM-5000(after V3.26). Get invert enabled mask

See Also

DigitalInput Class
Advantech.Adam Namespace


GetInvertMask Method (Boolean)

DigitalInput.GetInvertMask Method (Boolean)
See Also Example
[image]

Support module: ADAM-4051. Get invert enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInvertMask( _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetInvertMask(
out bool o_bEnabled
)
C++
public:
bool GetInvertMask(
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetInvertMask(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetInvertMask(
OutAttribute o_bEnabled : bool
) : bool

Parameters

o_bEnabled
The invert mask. The channel is invert enabled if element is true. Otherwise, the invert is disabled. This array is fix to 16 elements, if the channel total of the module is less 16, the rest of the elements will be set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetInvertMask Overload List


GetInvertMask Method (Int32, Boolean)

DigitalInput.GetInvertMask Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000/TCP, ADAM-5000(after V3.26). Get invert enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetInvertMask( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetInvertMask(
int i_iSlot,
out bool o_bEnabled
)
C++
public:
bool GetInvertMask(
int i_iSlot,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetInvertMask(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetInvertMask(
i_iSlot : int,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_bEnabled
The invert mask. The channel is invert enabled if element is true. Otherwise, the invert is disabled. This array is fix to 16 elements, if the channel total of the module is less 16, the rest of the elements will be set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetInvertMask Overload List


GetIOConfig Method

DigitalInput.GetIOConfig Method

Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.

Overload List

 | Name | Description
Public method | GetIOConfig (Byte) | Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.
Public method | GetIOConfig (Int32, Byte) | Support module: ADAM-4100 Get DI configuration.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetIOConfig Method (Byte)

DigitalInput.GetIOConfig Method (Byte)
See Also Example
[image]

Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIOConfig( _
<OutAttribute> ByRef o_byConfig As Byte _
) As Boolean
C#
public bool GetIOConfig(
out byte o_byConfig
)
C++
public:
bool GetIOConfig(
[OutAttribute] char% o_byConfig
) sealed
J#
public bool GetIOConfig(
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public function GetIOConfig(
OutAttribute o_byConfig : Byte
) : bool

Parameters

o_byConfig
The configuration for all DIO channel.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetIOConfig Overload List


GetIOConfig Method (Int32, Byte)

DigitalInput.GetIOConfig Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4100 Get DI configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIOConfig( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byConfig As Byte _
) As Boolean
C#
public bool GetIOConfig(
int i_iChannel,
out byte o_byConfig
)
C++
public:
bool GetIOConfig(
int i_iChannel,
[OutAttribute] char% o_byConfig
) sealed
J#
public bool GetIOConfig(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public function GetIOConfig(
i_iChannel : int,
OutAttribute o_byConfig : Byte
) : bool

Parameters

i_iChannel
Channel number
o_byConfig
The configuration for indicated DI channel.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetIOConfig Overload List


GetUniversalStatus Method

DigitalInput.GetUniversalStatus Method
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get universal status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetUniversalStatus( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_bIsDI As Boolean _
) As Boolean
C#
public bool GetUniversalStatus(
int i_iSlot,
out bool o_bIsDI
)
C++
public:
bool GetUniversalStatus(
int i_iSlot,
[OutAttribute] bool% o_bIsDI
) sealed
J#
public bool GetUniversalStatus(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool o_bIsDI
)
JScript
public function GetUniversalStatus(
i_iSlot : int,
OutAttribute o_bIsDI : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_bIsDI
The universal status. The channel is DI if element is true. Otherwise, channel is DO

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetValue Method

DigitalInput.GetValue Method
[image]

Support module: ADAM-4011, ADAM-4011D, ADAM-4012. Get DI status that is used for the event counter.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
<OutAttribute> ByRef o_bDI As Boolean _
) As Boolean
C#
public bool GetValue(
out bool o_bDI
)
C++
public:
bool GetValue(
[OutAttribute] bool% o_bDI
) sealed
J#
public bool GetValue(
/** @attribute OutAttribute() */ /** @ref */ bool o_bDI
)
JScript
public function GetValue(
OutAttribute o_bDI : bool
) : bool

Parameters

o_bDI
The DI status.

Return Value

Return true if success, otherwise return false.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetValues Method

DigitalInput.GetValues Method

Support module: ADAM-4024. Get DI values.

Overload List

 | Name | Description
Public method | GetValues (Boolean) | Support module: ADAM-4024. Get DI values.
Public method | GetValues (Boolean, Boolean) | Support module: ADAM-4022T. Get DI/DO values.
Public method | GetValues (Int32, Int32, Boolean) | Support module: ADAM-5000, ADAM-5000/TCP, APAX_5000, ADAM-5550, APAX-5070. Get DI/DO values. If the module has both DI and DO, you must set the i_iChannelTotal to the DI total plus the DO total. The o_bValues will return DI values and then the DO values.
Public method | GetValues (Int32, Int32, Boolean, Boolean) | Support module: ADAM-4000 and ADAM-4100 pure DIO module. Get DI/DO values.

See Also

DigitalInput Class
Advantech.Adam Namespace


GetValues Method (Boolean)

DigitalInput.GetValues Method (Boolean)
See Also Example
[image]

Support module: ADAM-4024. Get DI values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
<OutAttribute> ByRef o_bDI As Boolean _
) As Boolean
C#
public bool GetValues(
out bool o_bDI
)
C++
public:
bool GetValues(
[OutAttribute] bool% o_bDI
) sealed
J#
public bool GetValues(
/** @attribute OutAttribute() */ /** @ref */ bool o_bDI
)
JScript
public function GetValues(
OutAttribute o_bDI : bool
) : bool

Parameters

o_bDI
Array of DI values.

Return Value

Return true if success, otherwise return false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetValues Overload List


GetValues Method (Boolean, Boolean)

DigitalInput.GetValues Method (Boolean, Boolean)
See Also Example
[image]

Support module: ADAM-4022T. Get DI/DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
<OutAttribute> ByRef o_bDI As Boolean, _
<OutAttribute> ByRef o_bDO As Boolean _
) As Boolean
C#
public bool GetValues(
out bool o_bDI,
out bool o_bDO
)
C++
public:
bool GetValues(
[OutAttribute] bool% o_bDI,
[OutAttribute] bool% o_bDO
) sealed
J#
public bool GetValues(
/** @attribute OutAttribute() */ /** @ref */ bool o_bDI,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDO
)
JScript
public function GetValues(
OutAttribute o_bDI : bool,
OutAttribute o_bDO : bool
) : bool

Parameters

o_bDI
Array of DI values.
o_bDO
Array of DO values.

Return Value

Return true if success, otherwise return false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetValues Overload List


GetValues Method (Int32, Int32, Boolean)

DigitalInput.GetValues Method (Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, APAX_5000, ADAM-5550, APAX-5070. Get DI/DO values. If the module has both DI and DO, you must set the i_iChannelTotal to the DI total plus the DO total. The o_bValues will return DI values and then the DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bValues As Boolean _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
out bool o_bValues
)
C++
public:
bool GetValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] bool% o_bValues
) sealed
J#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bValues
)
JScript
public function GetValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_bValues : bool
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannelTotal
The total of the channel on the module.
o_bValues
Array of DI/DO values.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetValues Overload List


GetValues Method (Int32, Int32, Boolean, Boolean)

DigitalInput.GetValues Method (Int32, Int32, Boolean, Boolean)
See Also Example
[image]

Support module: ADAM-4000 and ADAM-4100 pure DIO module. Get DI/DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iDITotal As Integer, _
ByVal i_iDOTotal As Integer, _
<OutAttribute> ByRef o_bDI As Boolean, _
<OutAttribute> ByRef o_bDO As Boolean _
) As Boolean
C#
public bool GetValues(
int i_iDITotal,
int i_iDOTotal,
out bool o_bDI,
out bool o_bDO
)
C++
public:
bool GetValues(
int i_iDITotal,
int i_iDOTotal,
[OutAttribute] bool% o_bDI,
[OutAttribute] bool% o_bDO
) sealed
J#
public bool GetValues(
int i_iDITotal,
int i_iDOTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDI,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDO
)
JScript
public function GetValues(
i_iDITotal : int,
i_iDOTotal : int,
OutAttribute o_bDI : bool,
OutAttribute o_bDO : bool
) : bool

Parameters

i_iDITotal
The total of the DI channel on the module.
i_iDOTotal
The total of the DO channel on the module.
o_bDI
Array of DI values. If the DI total is zero, this value will be null.
o_bDO
Array of DO values. If the DO total is zero, this value will be null.

Return Value

Return true if success, otherwise return false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.GetValues Overload List


ParseIOConfig Method

DigitalInput.ParseIOConfig Method
[image]

Support module: ADAM-4100, ADAM-6000. Parse the DI configuration byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ParseIOConfig( _
ByVal i_byConfig As Byte, _
<OutAttribute> ByRef o_byMode As Byte, _
<OutAttribute> ByRef o_bRecordLastCount As Boolean, _
<OutAttribute> ByRef o_bDigitalFilter As Boolean, _
<OutAttribute> ByRef o_bInvert As Boolean _
)
C#
public static void ParseIOConfig(
byte i_byConfig,
out byte o_byMode,
out bool o_bRecordLastCount,
out bool o_bDigitalFilter,
out bool o_bInvert
)
C++
public:
static void ParseIOConfig(
char i_byConfig,
[OutAttribute] char% o_byMode,
[OutAttribute] bool% o_bRecordLastCount,
[OutAttribute] bool% o_bDigitalFilter,
[OutAttribute] bool% o_bInvert
)
J#
public static void ParseIOConfig(
byte i_byConfig,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode,
/** @attribute OutAttribute() */ /** @ref */ bool o_bRecordLastCount,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDigitalFilter,
/** @attribute OutAttribute() */ /** @ref */ bool o_bInvert
)
JScript
public static function ParseIOConfig(
i_byConfig : Byte,
OutAttribute o_byMode : Byte,
OutAttribute o_bRecordLastCount : bool,
OutAttribute o_bDigitalFilter : bool,
OutAttribute o_bInvert : bool
)

Parameters

i_byConfig
The configuration byte.
o_byMode
The DI mode.
o_bRecordLastCount
The record last count status.
o_bDigitalFilter
The digital filter enable status.
o_bInvert
The invert enable status.

See Also

DigitalInput Class
Advantech.Adam Namespace


SetAOGateTriggerMode Method

DigitalInput.SetAOGateTriggerMode Method
[image]

Support module: ADAM-6124.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetAOGateTriggerMode( _
ByVal i_iSlot As Integer, _
ByVal i_iTriggerMode As Integer() _
) As Boolean
C#
public bool SetAOGateTriggerMode(
int i_iSlot,
int[] i_iTriggerMode
)
C++
public:
bool SetAOGateTriggerMode(
int i_iSlot,
array<int>^ i_iTriggerMode
) sealed
J#
public bool SetAOGateTriggerMode(
int i_iSlot,
int[] i_iTriggerMode
)
JScript
public function SetAOGateTriggerMode(
i_iSlot : int,
i_iTriggerMode : int[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7.
i_iTriggerMode
The AO gate trigger mode.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace


SetDIChannelConfigInfo Method

DigitalInput.SetDIChannelConfigInfo Method
[image]

Support module: ADAM-6200. Set the DI channel configuration information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDIChannelConfigInfo( _
ByVal i_byDiConfigArray As Byte() _
) As Boolean
C#
public bool SetDIChannelConfigInfo(
byte[] i_byDiConfigArray
)
C++
public:
bool SetDIChannelConfigInfo(
array<char>^ i_byDiConfigArray
) sealed
J#
public bool SetDIChannelConfigInfo(
byte[] i_byDiConfigArray
)
JScript
public function SetDIChannelConfigInfo(
i_byDiConfigArray : Byte[]
) : bool

Parameters

i_byDiConfigArray
The total of DI channel configuration information.

Return Value

True if succeed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace


SetDigitalFilterMiniSignalWidth Method

DigitalInput.SetDigitalFilterMiniSignalWidth Method

Support module: ADAM-4100, ADAM-6200. Set digital filter minimum signal width.

Overload List

 | Name | Description
Public method | SetDigitalFilterMiniSignalWidth (Int32, Int64, Int64) | Support module: ADAM-4100, ADAM-6200. Set digital filter minimum signal width.
Public method | SetDigitalFilterMiniSignalWidth (Int32, UInt16, UInt16) | Support module: ADAM-5000, ADAM-5000/TCP. Set digital filter minimum signal width.
Public method | SetDigitalFilterMiniSignalWidth (Int32, UInt32, Boolean) | Support module: APAX-5000. Set digital filter minimum signal width.
Public method | SetDigitalFilterMiniSignalWidth (Int64, Int64) | Support module: ADAM-6050, ADAM-6051, ADAM-6052, ADAM-6055, ADAM-6060, ADAM-6066. Set digital filter minimum signal width.

See Also

DigitalInput Class
Advantech.Adam Namespace


SetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)

DigitalInput.SetDigitalFilterMiniSignalWidth Method (Int32, Int64, Int64)
See Also Example
[image]

Support module: ADAM-4100, ADAM-6200. Set digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilterMiniSignalWidth( _
ByVal i_iChannel As Integer, _
ByVal i_lHigh As Long, _
ByVal i_lLow As Long _
) As Boolean
C#
public bool SetDigitalFilterMiniSignalWidth(
int i_iChannel,
long i_lHigh,
long i_lLow
)
C++
public:
bool SetDigitalFilterMiniSignalWidth(
int i_iChannel,
__int64 i_lHigh,
__int64 i_lLow
) sealed
J#
public bool SetDigitalFilterMiniSignalWidth(
int i_iChannel,
long i_lHigh,
long i_lLow
)
JScript
public function SetDigitalFilterMiniSignalWidth(
i_iChannel : int,
i_lHigh : long,
i_lLow : long
) : bool

Parameters

i_iChannel
Channel number
i_lHigh
The minimum high signal width.
i_lLow
The minimum low signal width.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetDigitalFilterMiniSignalWidth Overload List


SetDigitalFilterMiniSignalWidth Method (Int32, UInt16, UInt16)

DigitalInput.SetDigitalFilterMiniSignalWidth Method (Int32, UInt16, UInt16)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP. Set digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilterMiniSignalWidth( _
ByVal i_iSlot As Integer, _
ByVal i_iHigh As UInt16, _
ByVal i_iLow As UInt16 _
) As Boolean
C#
public bool SetDigitalFilterMiniSignalWidth(
int i_iSlot,
ushort i_iHigh,
ushort i_iLow
)
C++
public:
bool SetDigitalFilterMiniSignalWidth(
int i_iSlot,
unsigned short i_iHigh,
unsigned short i_iLow
) sealed
J#
public bool SetDigitalFilterMiniSignalWidth(
int i_iSlot,
ushort i_iHigh,
ushort i_iLow
)
JScript
public function SetDigitalFilterMiniSignalWidth(
i_iSlot : int,
i_iHigh : UInt16,
i_iLow : UInt16
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7.
i_iHigh
The minimum high signal width. The value is between 0~65535.
i_iLow
The minimum low signal width. The value is between 0~65535.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetDigitalFilterMiniSignalWidth Overload List


SetDigitalFilterMiniSignalWidth Method (Int32, UInt32, Boolean)

DigitalInput.SetDigitalFilterMiniSignalWidth Method (Int32, UInt32, Boolean)
See Also Example
[image]

Support module: APAX-5000. Set digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilterMiniSignalWidth( _
ByVal i_iSlot As Integer, _
ByVal i_iWidth As UInt32, _
ByVal i_bEnable As Boolean _
) As Boolean
C#
public bool SetDigitalFilterMiniSignalWidth(
int i_iSlot,
uint i_iWidth,
bool i_bEnable
)
C++
public:
bool SetDigitalFilterMiniSignalWidth(
int i_iSlot,
unsigned int i_iWidth,
bool i_bEnable
) sealed
J#
public bool SetDigitalFilterMiniSignalWidth(
int i_iSlot,
uint i_iWidth,
bool i_bEnable
)
JScript
public function SetDigitalFilterMiniSignalWidth(
i_iSlot : int,
i_iWidth : UInt32,
i_bEnable : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7.
i_iWidth
The minimum high signal width. The value is between 10~1280. (0.1ms/unit)
i_bEnable
True if enable; false if disable.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetDigitalFilterMiniSignalWidth Overload List


SetDigitalFilterMiniSignalWidth Method (Int64[], Int64[])

DigitalInput.SetDigitalFilterMiniSignalWidth Method (Int64[], Int64[])
See Also Example
[image]

Support module: ADAM-6050, ADAM-6051, ADAM-6052, ADAM-6055, ADAM-6060, ADAM-6066. Set digital filter minimum signal width.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetDigitalFilterMiniSignalWidth( _
ByVal i_lHigh As Long(), _
ByVal i_lLow As Long() _
) As Boolean
C#
public bool SetDigitalFilterMiniSignalWidth(
long[] i_lHigh,
long[] i_lLow
)
C++
public:
bool SetDigitalFilterMiniSignalWidth(
array<__int64>^ i_lHigh,
array<__int64>^ i_lLow
) sealed
J#
public bool SetDigitalFilterMiniSignalWidth(
long[] i_lHigh,
long[] i_lLow
)
JScript
public function SetDigitalFilterMiniSignalWidth(
i_lHigh : long[],
i_lLow : long[]
) : bool

Parameters

i_lHigh
The minimum high signal width.
i_lLow
The minimum low signal width.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetDigitalFilterMiniSignalWidth Overload List


SetInvertMask Method

DigitalInput.SetInvertMask Method

Support module: ADAM-4051. Set invert enabled mask

Overload List

 | Name | Description
Public method | SetInvertMask (Boolean) | Support module: ADAM-4051. Set invert enabled mask
Public method | SetInvertMask (Int32, Boolean) | Support module: ADAM-5000/TCP, ADAM-5000(after V3.26). Set invert enabled mask

See Also

DigitalInput Class
Advantech.Adam Namespace


SetInvertMask Method (Boolean[])

DigitalInput.SetInvertMask Method (Boolean[])
See Also Example
[image]

Support module: ADAM-4051. Set invert enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetInvertMask( _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetInvertMask(
bool[] i_bEnabled
)
C++
public:
bool SetInvertMask(
array<bool>^ i_bEnabled
) sealed
J#
public bool SetInvertMask(
bool[] i_bEnabled
)
JScript
public function SetInvertMask(
i_bEnabled : bool[]
) : bool

Parameters

i_bEnabled
The invert mask. Set an element to true to enabled the invert. Otherwise, set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetInvertMask Overload List


SetInvertMask Method (Int32, Boolean[])

DigitalInput.SetInvertMask Method (Int32, Boolean[])
See Also Example
[image]

Support module: ADAM-5000/TCP, ADAM-5000(after V3.26). Set invert enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetInvertMask( _
ByVal i_iSlot As Integer, _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetInvertMask(
int i_iSlot,
bool[] i_bEnabled
)
C++
public:
bool SetInvertMask(
int i_iSlot,
array<bool>^ i_bEnabled
) sealed
J#
public bool SetInvertMask(
int i_iSlot,
bool[] i_bEnabled
)
JScript
public function SetInvertMask(
i_iSlot : int,
i_bEnabled : bool[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_bEnabled
The invert mask. Set an element to true to enabled the invert. Otherwise, set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetInvertMask Overload List


SetIOConfig Method

DigitalInput.SetIOConfig Method

Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.

Overload List

 | Name | Description
Public method | SetIOConfig (Byte) | Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.
Public method | SetIOConfig (Int32, Byte) | Support module: ADAM-4100. Set DI configuration.

See Also

DigitalInput Class
Advantech.Adam Namespace


SetIOConfig Method (Byte[])

DigitalInput.SetIOConfig Method (Byte[])
See Also Example
[image]

Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIOConfig( _
ByVal i_byConfig As Byte() _
) As Boolean
C#
public bool SetIOConfig(
byte[] i_byConfig
)
C++
public:
bool SetIOConfig(
array<char>^ i_byConfig
) sealed
J#
public bool SetIOConfig(
byte[] i_byConfig
)
JScript
public function SetIOConfig(
i_byConfig : Byte[]
) : bool

Parameters

i_byConfig
The configuration for all DIO channel.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetIOConfig Overload List


SetIOConfig Method (Int32, Byte)

DigitalInput.SetIOConfig Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4100. Set DI configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIOConfig( _
ByVal i_iChannel As Integer, _
ByVal i_byConfig As Byte _
) As Boolean
C#
public bool SetIOConfig(
int i_iChannel,
byte i_byConfig
)
C++
public:
bool SetIOConfig(
int i_iChannel,
char i_byConfig
) sealed
J#
public bool SetIOConfig(
int i_iChannel,
byte i_byConfig
)
JScript
public function SetIOConfig(
i_iChannel : int,
i_byConfig : Byte
) : bool

Parameters

i_iChannel
Channel number
i_byConfig
The configuration for indicated DI channel.

Return Value

True if secceed, otherwise false.

See Also

DigitalInput Class
Advantech.Adam Namespace
DigitalInput.SetIOConfig Overload List


DigitalOutput Class

DigitalOutput Class
See Also Example Members
[image]

DigitalOutput class for ADAM series.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class DigitalOutput
Inherits AdamBase
C#
public class DigitalOutput : AdamBase
C++
ref class DigitalOutput : AdamBase
J#
public class DigitalOutput extends AdamBase
JScript
public class DigitalOutput extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.DigitalOutput

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DigitalOutput Members
Advantech.Adam Namespace


DigitalOutput Members

DigitalOutput Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

DigitalOutput class for ADAM series.

The following tables list the members exposed by DigitalOutput.

Public Constructors

Name | Description
DigitalOutput | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | DO_BufValues | APAX API. Set DO buffer values.
 | FormIOConfig | Support module: ADAM-6000. Form the DO configuration byte.
Public method | GetAlarmMappingMask | Support module: ADAM-5000, ADAM-5000TCP. Get the alarm mapping mask.
 | GetChannelStart | Overloaded. Support module: ADAM-4100. Get the DO channel start index from IO config array.
 | GetChannelTotal | Overloaded. Support module: ADAM-4000. Get DO channel total number.
Public method | GetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.
Public method | GetPulseOutputCount | Support module: ADAM-4100. Get pulse output mode and counts.
Public method | GetPulseOutputWidthAndDelayTime | Overloaded. Support module: ADAM-4100. Get pulse output width and delay time.
Public method | GetSafetyValues | Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000, APAX-5070. Get DI/DO values. If the module has both DI and DO, you must set the i_iChannelTotal to the DI total plus the DO total. The o_bValues will return DI values and then the DO values.
Public method | GetUniversalStatus | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get universal status
Public method | GetValues | Overloaded. Support module: ADAM-4022T. Get DI/DO values.
Public method | GetWDT | Support module: ADAM-6200. Get WDT enabled status
Public method | GetWDTFlag | Support module: ADAM-4100. Get WDT safety enabled flag.
Public method | GetWDTInfo | Support module: ADAM-4000 and ADAM-4100. Get WDT information.
Public method | GetWDTMask | Overloaded. Support module: ADAM-6000. Get WDT enabled mask
 | ParseIOConfig | Support module: ADAM-6000. Parse the DO configuration byte.
Public method | SetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.
Public method | SetPulseOutputCount | Support module: ADAM-4100. Get pulse output mode and counts.
Public method | SetPulseOutputWidthAndDelayTime | Overloaded. Support module: ADAM-4100. Set pulse output width and delay time.
Public method | SetSafetyValues | Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000. Set DO value to all channels.
Public method | SetSValue | Support module: For ADAM-4056S, ADAM-4056SO only. Set DO value to a single channel.
Public method | SetValue | Overloaded. Support module: ADAM-4000 and ADAM-4100. (But not for ADAM-4056S, ADAM-4056SO) Set DO value to a single channel.
Public method | SetValues | Overloaded. Support module: ADAM-4000 and ADAM-4100. Set DO value to all channels.
Public method | SetWDT | Support module: ADAM-6200. Set WDT enabled status
Public method | SetWDTInfo | Support module: ADAM-4000 and ADAM-4100. Set WDT information.
Public method | SetWDTMask | Overloaded. Support module: ADAM-6000. Set WDT enabled mask
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
DigitalOutput | Overloaded.
Top

See Also

DigitalOutput Class
Advantech.Adam Namespace


DigitalOutput Constructor

DigitalOutput Constructor

Overload List

 | Name | Description
Public method | DigitalOutput (AdamCom) | The DigitalOutput constructor.
Public method | DigitalOutput (AdamControl) | The DigitalOutput constructor.
Public method | DigitalOutput (AdamSocket) | The DigitalOutput constructor.

See Also

DigitalOutput Class
Advantech.Adam Namespace


DigitalOutput Constructor (AdamCom)

DigitalOutput Constructor (AdamCom)
See Also Example
[image]

The DigitalOutput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public DigitalOutput(
AdamCom i_com
)
C++
public:
DigitalOutput(
AdamCom i_com
) sealed
J#
public DigitalOutput(
AdamCom i_com
)
JScript
public function DigitalOutput(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput Constructor Overload List


DigitalOutput Constructor (AdamControl)

DigitalOutput Constructor (AdamControl)
See Also Example
[image]

The DigitalOutput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_control As AdamControl _
)
C#
public DigitalOutput(
AdamControl i_control
)
C++
public:
DigitalOutput(
AdamControl i_control
) sealed
J#
public DigitalOutput(
AdamControl i_control
)
JScript
public function DigitalOutput(
i_control : AdamControl
)

Parameters

i_control
The AdamControl object

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput Constructor Overload List


DigitalOutput Constructor (AdamSocket)

DigitalOutput Constructor (AdamSocket)
See Also Example
[image]

The DigitalOutput constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public DigitalOutput(
AdamSocket i_socket
)
C++
public:
DigitalOutput(
AdamSocket i_socket
) sealed
J#
public DigitalOutput(
AdamSocket i_socket
)
JScript
public function DigitalOutput(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput Constructor Overload List


Methods

DigitalOutput Methods
[image]

Public Methods

 | Name | Description
Public method | DO_BufValues | APAX API. Set DO buffer values.
 | FormIOConfig | Support module: ADAM-6000. Form the DO configuration byte.
Public method | GetAlarmMappingMask | Support module: ADAM-5000, ADAM-5000TCP. Get the alarm mapping mask.
 | GetChannelStart | Overloaded. Support module: ADAM-4100. Get the DO channel start index from IO config array.
 | GetChannelTotal | Overloaded. Support module: ADAM-4000. Get DO channel total number.
Public method | GetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.
Public method | GetPulseOutputCount | Support module: ADAM-4100. Get pulse output mode and counts.
Public method | GetPulseOutputWidthAndDelayTime | Overloaded. Support module: ADAM-4100. Get pulse output width and delay time.
Public method | GetSafetyValues | Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000, APAX-5070. Get DI/DO values. If the module has both DI and DO, you must set the i_iChannelTotal to the DI total plus the DO total. The o_bValues will return DI values and then the DO values.
Public method | GetUniversalStatus | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get universal status
Public method | GetValues | Overloaded. Support module: ADAM-4022T. Get DI/DO values.
Public method | GetWDT | Support module: ADAM-6200. Get WDT enabled status
Public method | GetWDTFlag | Support module: ADAM-4100. Get WDT safety enabled flag.
Public method | GetWDTInfo | Support module: ADAM-4000 and ADAM-4100. Get WDT information.
Public method | GetWDTMask | Overloaded. Support module: ADAM-6000. Get WDT enabled mask
 | ParseIOConfig | Support module: ADAM-6000. Parse the DO configuration byte.
Public method | SetIOConfig | Overloaded. Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.
Public method | SetPulseOutputCount | Support module: ADAM-4100. Get pulse output mode and counts.
Public method | SetPulseOutputWidthAndDelayTime | Overloaded. Support module: ADAM-4100. Set pulse output width and delay time.
Public method | SetSafetyValues | Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000. Set DO value to all channels.
Public method | SetSValue | Support module: For ADAM-4056S, ADAM-4056SO only. Set DO value to a single channel.
Public method | SetValue | Overloaded. Support module: ADAM-4000 and ADAM-4100. (But not for ADAM-4056S, ADAM-4056SO) Set DO value to a single channel.
Public method | SetValues | Overloaded. Support module: ADAM-4000 and ADAM-4100. Set DO value to all channels.
Public method | SetWDT | Support module: ADAM-6200. Set WDT enabled status
Public method | SetWDTInfo | Support module: ADAM-4000 and ADAM-4100. Set WDT information.
Public method | SetWDTMask | Overloaded. Support module: ADAM-6000. Set WDT enabled mask
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

DigitalOutput Class
Advantech.Adam Namespace


DO_BufValues Method

DigitalOutput.DO_BufValues Method
[image]

APAX API. Set DO buffer values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function DO_BufValues( _
ByVal i_iSlot As Integer, _
ByVal i_bValues As Boolean() _
) As Boolean
C#
public bool DO_BufValues(
int i_iSlot,
bool[] i_bValues
)
C++
public:
bool DO_BufValues(
int i_iSlot,
array<bool>^ i_bValues
) sealed
J#
public bool DO_BufValues(
int i_iSlot,
bool[] i_bValues
)
JScript
public function DO_BufValues(
i_iSlot : int,
i_bValues : bool[]
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_bValues
The DO values to set. The length of the array must match the total of the channel on the module.

Return Value

Return true if success; otherwise, return false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


FormIOConfig Method

DigitalOutput.FormIOConfig Method
[image]

Support module: ADAM-6000. Form the DO configuration byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FormIOConfig( _
ByVal i_byMode As Byte, _
<OutAttribute> ByRef o_byConfig As Byte _
)
C#
public static void FormIOConfig(
byte i_byMode,
out byte o_byConfig
)
C++
public:
static void FormIOConfig(
char i_byMode,
[OutAttribute] char% o_byConfig
)
J#
public static void FormIOConfig(
byte i_byMode,
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public static function FormIOConfig(
i_byMode : Byte,
OutAttribute o_byConfig : Byte
)

Parameters

i_byMode
The DO mode.
o_byConfig
The configuration byte.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetAlarmMappingMask Method

DigitalOutput.GetAlarmMappingMask Method
[image]

Support module: ADAM-5000, ADAM-5000TCP. Get the alarm mapping mask.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAlarmMappingMask( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetAlarmMappingMask(
int i_iSlot,
int i_iChannelTotal,
out bool o_bEnabled
)
C++
public:
bool GetAlarmMappingMask(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetAlarmMappingMask(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetAlarmMappingMask(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_iChannelTotal
The total of the channel on the module.
o_bEnabled
The mappng mask. The channel is mapped by alarm if element is true. Otherwise, channel is not mapped.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetChannelStart Method

DigitalOutput.GetChannelStart Method

Support module: ADAM-4100. Get the DO channel start index from IO config array.

Overload List

Name | Description
GetChannelStart (Adam4000Type) | Support module: ADAM-4100. Get the DO channel start index from IO config array.
GetChannelStart (Adam6000Type) | Support module: ADAM-6000. Get the DO channel start index from IO config array.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetChannelStart Method (Adam4000Type)

DigitalOutput.GetChannelStart Method (Adam4000Type)
See Also Example
[image]

Support module: ADAM-4100. Get the DO channel start index from IO config array.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelStart( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetChannelStart(
Adam4000Type adam4000Type
)
C++
public:
static int GetChannelStart(
Adam4000Type adam4000Type
)
J#
public static int GetChannelStart(
Adam4000Type adam4000Type
)
JScript
public static function GetChannelStart(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
The adam4000Type.

Return Value

The DO channel start index.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetChannelStart Overload List


GetChannelStart Method (Adam6000Type)

DigitalOutput.GetChannelStart Method (Adam6000Type)
See Also Example
[image]

Support module: ADAM-6000. Get the DO channel start index from IO config array.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelStart( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelStart(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelStart(
Adam6000Type adam6000Type
)
J#
public static int GetChannelStart(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelStart(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
The adam6000Type.

Return Value

The DO channel start index.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetChannelStart Overload List


GetChannelTotal Method

DigitalOutput.GetChannelTotal Method

Support module: ADAM-4000. Get DO channel total number.

Overload List

Name | Description
GetChannelTotal (Adam4000Type) | Support module: ADAM-4000. Get DO channel total number.
GetChannelTotal (Adam5000Type) | Support module: ADAM-5000, ADAM-5000/TCP. Get DO channel total number.
GetChannelTotal (Adam6000Type) | Support module: ADAM-6000. Get DO channel total number.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetChannelTotal Method (Adam4000Type)

DigitalOutput.GetChannelTotal Method (Adam4000Type)
See Also Example
[image]

Support module: ADAM-4000. Get DO channel total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam4000Type As Adam4000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
C++
public:
static int GetChannelTotal(
Adam4000Type adam4000Type
)
J#
public static int GetChannelTotal(
Adam4000Type adam4000Type
)
JScript
public static function GetChannelTotal(
adam4000Type : Adam4000Type
) : int

Parameters

adam4000Type
The Adam4000Type.

Return Value

The DO total channel number.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetChannelTotal Overload List


GetChannelTotal Method (Adam5000Type)

DigitalOutput.GetChannelTotal Method (Adam5000Type)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP. Get DO channel total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam5000Type As Adam5000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
C++
public:
static int GetChannelTotal(
Adam5000Type adam5000Type
)
J#
public static int GetChannelTotal(
Adam5000Type adam5000Type
)
JScript
public static function GetChannelTotal(
adam5000Type : Adam5000Type
) : int

Parameters

adam5000Type
The Adam5000Type.

Return Value

The DO total channel number.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetChannelTotal Overload List


GetChannelTotal Method (Adam6000Type)

DigitalOutput.GetChannelTotal Method (Adam6000Type)
See Also Example
[image]

Support module: ADAM-6000. Get DO channel total number.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetChannelTotal( _
ByVal adam6000Type As Adam6000Type _
) As Integer
C#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
C++
public:
static int GetChannelTotal(
Adam6000Type adam6000Type
)
J#
public static int GetChannelTotal(
Adam6000Type adam6000Type
)
JScript
public static function GetChannelTotal(
adam6000Type : Adam6000Type
) : int

Parameters

adam6000Type
The Adam6000Type.

Return Value

The DO total channel number.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetChannelTotal Overload List


GetIOConfig Method

DigitalOutput.GetIOConfig Method

Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.

Overload List

 | Name | Description
Public method | GetIOConfig (Byte) | Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.
Public method | GetIOConfig (Int32, Byte) | Support module: ADAM-4100 Get DO configuration.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetIOConfig Method (Byte)

DigitalOutput.GetIOConfig Method (Byte)
See Also Example
[image]

Support module: ADAM-4100 and ADAM-6000. Get DIO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIOConfig( _
<OutAttribute> ByRef o_byConfig As Byte _
) As Boolean
C#
public bool GetIOConfig(
out byte o_byConfig
)
C++
public:
bool GetIOConfig(
[OutAttribute] char% o_byConfig
) sealed
J#
public bool GetIOConfig(
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public function GetIOConfig(
OutAttribute o_byConfig : Byte
) : bool

Parameters

o_byConfig
The configuration for all DIO channel.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetIOConfig Overload List


GetIOConfig Method (Int32, Byte)

DigitalOutput.GetIOConfig Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4100 Get DO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIOConfig( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_byConfig As Byte _
) As Boolean
C#
public bool GetIOConfig(
int i_iChannel,
out byte o_byConfig
)
C++
public:
bool GetIOConfig(
int i_iChannel,
[OutAttribute] char% o_byConfig
) sealed
J#
public bool GetIOConfig(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byConfig
)
JScript
public function GetIOConfig(
i_iChannel : int,
OutAttribute o_byConfig : Byte
) : bool

Parameters

i_iChannel
Channel number
o_byConfig
The configuration for indicated DO channel.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetIOConfig Overload List


GetPulseOutputCount Method

DigitalOutput.GetPulseOutputCount Method
[image]

Support module: ADAM-4100. Get pulse output mode and counts.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPulseOutputCount( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_bContinue As Boolean, _
<OutAttribute> ByRef o_lPulseCount As Long _
) As Boolean
C#
public bool GetPulseOutputCount(
int i_iChannel,
out bool o_bContinue,
out long o_lPulseCount
)
C++
public:
bool GetPulseOutputCount(
int i_iChannel,
[OutAttribute] bool% o_bContinue,
[OutAttribute] __int64% o_lPulseCount
) sealed
J#
public bool GetPulseOutputCount(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bContinue,
/** @attribute OutAttribute() */ /** @ref */ long o_lPulseCount
)
JScript
public function GetPulseOutputCount(
i_iChannel : int,
OutAttribute o_bContinue : bool,
OutAttribute o_lPulseCount : long
) : bool

Parameters

i_iChannel
Channel number
o_bContinue
The pulse output continue mode.
o_lPulseCount
The pulse output count.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetPulseOutputWidthAndDelayTime Method

DigitalOutput.GetPulseOutputWidthAndDelayTime Method

Support module: ADAM-4100. Get pulse output width and delay time.

Overload List

 | Name | Description
Public method | GetPulseOutputWidthAndDelayTime (Int32, Int64, Int64, Int64, Int64) | Support module: ADAM-4100. Get pulse output width and delay time.
Public method | GetPulseOutputWidthAndDelayTime (Int64, Int64, Int64, Int64) | Support module: ADAM-6000. Get pulse output width and delay time.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetPulseOutputWidthAndDelayTime Method (Int32, Int64, Int64, Int64, Int64)

DigitalOutput.GetPulseOutputWidthAndDelayTime Method (Int32, Int64, Int64, Int64, Int64)
See Also Example
[image]

Support module: ADAM-4100. Get pulse output width and delay time.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPulseOutputWidthAndDelayTime( _
ByVal i_iChannel As Integer, _
<OutAttribute> ByRef o_lPulseHighWidth As Long, _
<OutAttribute> ByRef o_lPulseLowWidth As Long, _
<OutAttribute> ByRef o_lHighToLowDelay As Long, _
<OutAttribute> ByRef o_lLowToHighDelay As Long _
) As Boolean
C#
public bool GetPulseOutputWidthAndDelayTime(
int i_iChannel,
out long o_lPulseHighWidth,
out long o_lPulseLowWidth,
out long o_lHighToLowDelay,
out long o_lLowToHighDelay
)
C++
public:
bool GetPulseOutputWidthAndDelayTime(
int i_iChannel,
[OutAttribute] __int64% o_lPulseHighWidth,
[OutAttribute] __int64% o_lPulseLowWidth,
[OutAttribute] __int64% o_lHighToLowDelay,
[OutAttribute] __int64% o_lLowToHighDelay
) sealed
J#
public bool GetPulseOutputWidthAndDelayTime(
int i_iChannel,
/** @attribute OutAttribute() */ /** @ref */ long o_lPulseHighWidth,
/** @attribute OutAttribute() */ /** @ref */ long o_lPulseLowWidth,
/** @attribute OutAttribute() */ /** @ref */ long o_lHighToLowDelay,
/** @attribute OutAttribute() */ /** @ref */ long o_lLowToHighDelay
)
JScript
public function GetPulseOutputWidthAndDelayTime(
i_iChannel : int,
OutAttribute o_lPulseHighWidth : long,
OutAttribute o_lPulseLowWidth : long,
OutAttribute o_lHighToLowDelay : long,
OutAttribute o_lLowToHighDelay : long
) : bool

Parameters

i_iChannel
Channel number
o_lPulseHighWidth
The pulse high signal width.
o_lPulseLowWidth
The pulse low signal width.
o_lHighToLowDelay
The high to low delat time.
o_lLowToHighDelay
The low to high delay time.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetPulseOutputWidthAndDelayTime Overload List


GetPulseOutputWidthAndDelayTime Method (Int64, Int64, Int64, Int64)

DigitalOutput.GetPulseOutputWidthAndDelayTime Method (Int64, Int64, Int64, Int64)
See Also Example
[image]

Support module: ADAM-6000. Get pulse output width and delay time.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPulseOutputWidthAndDelayTime( _
<OutAttribute> ByRef o_lPulseHighWidth As Long, _
<OutAttribute> ByRef o_lPulseLowWidth As Long, _
<OutAttribute> ByRef o_lHighToLowDelay As Long, _
<OutAttribute> ByRef o_lLowToHighDelay As Long _
) As Boolean
C#
public bool GetPulseOutputWidthAndDelayTime(
out long o_lPulseHighWidth,
out long o_lPulseLowWidth,
out long o_lHighToLowDelay,
out long o_lLowToHighDelay
)
C++
public:
bool GetPulseOutputWidthAndDelayTime(
[OutAttribute] __int64% o_lPulseHighWidth,
[OutAttribute] __int64% o_lPulseLowWidth,
[OutAttribute] __int64% o_lHighToLowDelay,
[OutAttribute] __int64% o_lLowToHighDelay
) sealed
J#
public bool GetPulseOutputWidthAndDelayTime(
/** @attribute OutAttribute() */ /** @ref */ long o_lPulseHighWidth,
/** @attribute OutAttribute() */ /** @ref */ long o_lPulseLowWidth,
/** @attribute OutAttribute() */ /** @ref */ long o_lHighToLowDelay,
/** @attribute OutAttribute() */ /** @ref */ long o_lLowToHighDelay
)
JScript
public function GetPulseOutputWidthAndDelayTime(
OutAttribute o_lPulseHighWidth : long,
OutAttribute o_lPulseLowWidth : long,
OutAttribute o_lHighToLowDelay : long,
OutAttribute o_lLowToHighDelay : long
) : bool

Parameters

o_lPulseHighWidth
The pulse high signal width.
o_lPulseLowWidth
The pulse low signal width.
o_lHighToLowDelay
The high to low delat time.
o_lLowToHighDelay
The low to high delay time.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetPulseOutputWidthAndDelayTime Overload List


GetSafetyValues Method

DigitalOutput.GetSafetyValues Method
[image]

Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000, APAX-5070. Get DI/DO values. If the module has both DI and DO, you must set the i_iChannelTotal to the DI total plus the DO total. The o_bValues will return DI values and then the DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSafetyValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bValues As Boolean _
) As Boolean
C#
public bool GetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
out bool o_bValues
)
C++
public:
bool GetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] bool% o_bValues
) sealed
J#
public bool GetSafetyValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bValues
)
JScript
public function GetSafetyValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_bValues : bool
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannelTotal
The total of the channel on the module.
o_bValues
Array of DI/DO values.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetUniversalStatus Method

DigitalOutput.GetUniversalStatus Method
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550. Get universal status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetUniversalStatus( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_bIsDI As Boolean _
) As Boolean
C#
public bool GetUniversalStatus(
int i_iSlot,
out bool o_bIsDI
)
C++
public:
bool GetUniversalStatus(
int i_iSlot,
[OutAttribute] bool% o_bIsDI
) sealed
J#
public bool GetUniversalStatus(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool o_bIsDI
)
JScript
public function GetUniversalStatus(
i_iSlot : int,
OutAttribute o_bIsDI : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_bIsDI
The universal status. The channel is DI if element is true. Otherwise, channel is DO

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetValues Method

DigitalOutput.GetValues Method

Support module: ADAM-4022T. Get DI/DO values.

Overload List

 | Name | Description
Public method | GetValues (Boolean, Boolean) | Support module: ADAM-4022T. Get DI/DO values.
Public method | GetValues (Int32, Int32, Boolean) | Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000, ADAM-5550, APAX-5070. Get DI/DO values. If the module has both DI and DO, you must set the i_iChannelTotal to the DI total plus the DO total. The o_bValues will return DI values and then the DO values.
Public method | GetValues (Int32, Int32, Boolean, Boolean) | Support module: ADAM-4000 and ADAM-4100 pure DIO module. Get DI/DO values.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetValues Method (Boolean, Boolean)

DigitalOutput.GetValues Method (Boolean, Boolean)
See Also Example
[image]

Support module: ADAM-4022T. Get DI/DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
<OutAttribute> ByRef o_bDI As Boolean, _
<OutAttribute> ByRef o_bDO As Boolean _
) As Boolean
C#
public bool GetValues(
out bool o_bDI,
out bool o_bDO
)
C++
public:
bool GetValues(
[OutAttribute] bool% o_bDI,
[OutAttribute] bool% o_bDO
) sealed
J#
public bool GetValues(
/** @attribute OutAttribute() */ /** @ref */ bool o_bDI,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDO
)
JScript
public function GetValues(
OutAttribute o_bDI : bool,
OutAttribute o_bDO : bool
) : bool

Parameters

o_bDI
Array of DI values.
o_bDO
Array of DO values.

Return Value

Return true if success, otherwise return false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetValues Overload List


GetValues Method (Int32, Int32, Boolean)

DigitalOutput.GetValues Method (Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000, ADAM-5550, APAX-5070. Get DI/DO values. If the module has both DI and DO, you must set the i_iChannelTotal to the DI total plus the DO total. The o_bValues will return DI values and then the DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iSlot As Integer, _
ByVal i_iChannelTotal As Integer, _
<OutAttribute> ByRef o_bValues As Boolean _
) As Boolean
C#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
out bool o_bValues
)
C++
public:
bool GetValues(
int i_iSlot,
int i_iChannelTotal,
[OutAttribute] bool% o_bValues
) sealed
J#
public bool GetValues(
int i_iSlot,
int i_iChannelTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bValues
)
JScript
public function GetValues(
i_iSlot : int,
i_iChannelTotal : int,
OutAttribute o_bValues : bool
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannelTotal
The total of the channel on the module.
o_bValues
Array of DI/DO values.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetValues Overload List


GetValues Method (Int32, Int32, Boolean, Boolean)

DigitalOutput.GetValues Method (Int32, Int32, Boolean, Boolean)
See Also Example
[image]

Support module: ADAM-4000 and ADAM-4100 pure DIO module. Get DI/DO values.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
ByVal i_iDITotal As Integer, _
ByVal i_iDOTotal As Integer, _
<OutAttribute> ByRef o_bDI As Boolean, _
<OutAttribute> ByRef o_bDO As Boolean _
) As Boolean
C#
public bool GetValues(
int i_iDITotal,
int i_iDOTotal,
out bool o_bDI,
out bool o_bDO
)
C++
public:
bool GetValues(
int i_iDITotal,
int i_iDOTotal,
[OutAttribute] bool% o_bDI,
[OutAttribute] bool% o_bDO
) sealed
J#
public bool GetValues(
int i_iDITotal,
int i_iDOTotal,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDI,
/** @attribute OutAttribute() */ /** @ref */ bool o_bDO
)
JScript
public function GetValues(
i_iDITotal : int,
i_iDOTotal : int,
OutAttribute o_bDI : bool,
OutAttribute o_bDO : bool
) : bool

Parameters

i_iDITotal
The total of the DI channel on the module.
i_iDOTotal
The total of the DO channel on the module.
o_bDI
Array of DI values. If the DI total is zero, this value will be null.
o_bDO
Array of DO values. If the DO total is zero, this value will be null.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetValues Overload List


GetWDT Method

DigitalOutput.GetWDT Method
[image]

Support module: ADAM-6200. Get WDT enabled status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDT( _
<OutAttribute> ByRef o_bCommFSV As Boolean, _
<OutAttribute> ByRef o_bPtoPFSV As Boolean _
) As Boolean
C#
public bool GetWDT(
out bool o_bCommFSV,
out bool o_bPtoPFSV
)
C++
public:
bool GetWDT(
[OutAttribute] bool% o_bCommFSV,
[OutAttribute] bool% o_bPtoPFSV
) sealed
J#
public bool GetWDT(
/** @attribute OutAttribute() */ /** @ref */ bool o_bCommFSV,
/** @attribute OutAttribute() */ /** @ref */ bool o_bPtoPFSV
)
JScript
public function GetWDT(
OutAttribute o_bCommFSV : bool,
OutAttribute o_bPtoPFSV : bool
) : bool

Parameters

o_bCommFSV
The communication WDT.
o_bPtoPFSV
The P2P WDT.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetWDTFlag Method

DigitalOutput.GetWDTFlag Method
[image]

Support module: ADAM-4100. Get WDT safety enabled flag.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDTFlag( _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetWDTFlag(
out bool o_bEnabled
)
C++
public:
bool GetWDTFlag(
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetWDTFlag(
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetWDTFlag(
OutAttribute o_bEnabled : bool
) : bool

Parameters

o_bEnabled
The WDT safety enabled flag.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetWDTInfo Method

DigitalOutput.GetWDTInfo Method
[image]

Support module: ADAM-4000 and ADAM-4100. Get WDT information.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDTInfo( _
<OutAttribute> ByRef o_fTimeout As Single, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetWDTInfo(
out float o_fTimeout,
out bool o_bEnabled
)
C++
public:
bool GetWDTInfo(
[OutAttribute] float% o_fTimeout,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetWDTInfo(
/** @attribute OutAttribute() */ /** @ref */ float o_fTimeout,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetWDTInfo(
OutAttribute o_fTimeout : float,
OutAttribute o_bEnabled : bool
) : bool

Parameters

o_fTimeout
The timeout value. If no communication within the timeout, those channels that are set with WDT enabled will set to ON.
o_bEnabled
The channel WDT mask. The channel is WDT enabled if element is true. Otherwise, the WDT is disabled. This array is fixed to 16 elements, if the channel total of the module is less 16, the rest of the elements will be set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetWDTMask Method

DigitalOutput.GetWDTMask Method

Support module: ADAM-6000. Get WDT enabled mask

Overload List

 | Name | Description
Public method | GetWDTMask (Boolean, Boolean, Boolean) | Support module: ADAM-6000. Get WDT enabled mask
Public method | GetWDTMask (Int32, Boolean) | Support module: ADAM-5000, ADAM-5000TCP. Get WDT enabled mask

See Also

DigitalOutput Class
Advantech.Adam Namespace


GetWDTMask Method (Boolean, Boolean, Boolean)

DigitalOutput.GetWDTMask Method (Boolean, Boolean, Boolean)
See Also Example
[image]

Support module: ADAM-6000. Get WDT enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDTMask( _
<OutAttribute> ByRef o_bCommFSV As Boolean, _
<OutAttribute> ByRef o_bPtoPFSV As Boolean, _
<OutAttribute> ByRef o_bMask As Boolean _
) As Boolean
C#
public bool GetWDTMask(
out bool o_bCommFSV,
out bool o_bPtoPFSV,
out bool o_bMask
)
C++
public:
bool GetWDTMask(
[OutAttribute] bool% o_bCommFSV,
[OutAttribute] bool% o_bPtoPFSV,
[OutAttribute] bool% o_bMask
) sealed
J#
public bool GetWDTMask(
/** @attribute OutAttribute() */ /** @ref */ bool o_bCommFSV,
/** @attribute OutAttribute() */ /** @ref */ bool o_bPtoPFSV,
/** @attribute OutAttribute() */ /** @ref */ bool o_bMask
)
JScript
public function GetWDTMask(
OutAttribute o_bCommFSV : bool,
OutAttribute o_bPtoPFSV : bool,
OutAttribute o_bMask : bool
) : bool

Parameters

o_bCommFSV
The communication WDT.
o_bPtoPFSV
The P2P WDT.
o_bMask
The WDT mask. The channel is WDT enabled if element is true. Otherwise, the WDT is disabled. This array is fixed to 8 elements, if the channel total of the module is less 8, the rest of the elements will be set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetWDTMask Overload List


GetWDTMask Method (Int32, Boolean)

DigitalOutput.GetWDTMask Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP. Get WDT enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWDTMask( _
ByVal i_iSlot As Integer, _
<OutAttribute> ByRef o_bEnabled As Boolean _
) As Boolean
C#
public bool GetWDTMask(
int i_iSlot,
out bool o_bEnabled
)
C++
public:
bool GetWDTMask(
int i_iSlot,
[OutAttribute] bool% o_bEnabled
) sealed
J#
public bool GetWDTMask(
int i_iSlot,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnabled
)
JScript
public function GetWDTMask(
i_iSlot : int,
OutAttribute o_bEnabled : bool
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
o_bEnabled
The WDT mask. The channel is WDT enabled if element is true. Otherwise, the WDT is disabled. This array is fixed to 16 elements, if the channel total of the module is less 16, the rest of the elements will be set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.GetWDTMask Overload List


ParseIOConfig Method

DigitalOutput.ParseIOConfig Method
[image]

Support module: ADAM-6000. Parse the DO configuration byte.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ParseIOConfig( _
ByVal i_byConfig As Byte, _
<OutAttribute> ByRef o_byMode As Byte _
)
C#
public static void ParseIOConfig(
byte i_byConfig,
out byte o_byMode
)
C++
public:
static void ParseIOConfig(
char i_byConfig,
[OutAttribute] char% o_byMode
)
J#
public static void ParseIOConfig(
byte i_byConfig,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMode
)
JScript
public static function ParseIOConfig(
i_byConfig : Byte,
OutAttribute o_byMode : Byte
)

Parameters

i_byConfig
The configuration byte.
o_byMode
The DO mode.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetIOConfig Method

DigitalOutput.SetIOConfig Method

Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.

Overload List

 | Name | Description
Public method | SetIOConfig (Byte) | Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.
Public method | SetIOConfig (Int32, Byte) | Support module: ADAM-4100. Set DO configuration.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetIOConfig Method (Byte[])

DigitalOutput.SetIOConfig Method (Byte[])
See Also Example
[image]

Support module: ADAM-4100 and ADAM-6000. Set DIO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIOConfig( _
ByVal i_byConfig As Byte() _
) As Boolean
C#
public bool SetIOConfig(
byte[] i_byConfig
)
C++
public:
bool SetIOConfig(
array<char>^ i_byConfig
) sealed
J#
public bool SetIOConfig(
byte[] i_byConfig
)
JScript
public function SetIOConfig(
i_byConfig : Byte[]
) : bool

Parameters

i_byConfig
The configuration for all DIO channel.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetIOConfig Overload List


SetIOConfig Method (Int32, Byte)

DigitalOutput.SetIOConfig Method (Int32, Byte)
See Also Example
[image]

Support module: ADAM-4100. Set DO configuration.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetIOConfig( _
ByVal i_iChannel As Integer, _
ByVal i_byConfig As Byte _
) As Boolean
C#
public bool SetIOConfig(
int i_iChannel,
byte i_byConfig
)
C++
public:
bool SetIOConfig(
int i_iChannel,
char i_byConfig
) sealed
J#
public bool SetIOConfig(
int i_iChannel,
byte i_byConfig
)
JScript
public function SetIOConfig(
i_iChannel : int,
i_byConfig : Byte
) : bool

Parameters

i_iChannel
Channel number
i_byConfig
The configuration for indicated DO channel.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetIOConfig Overload List


SetPulseOutputCount Method

DigitalOutput.SetPulseOutputCount Method
[image]

Support module: ADAM-4100. Get pulse output mode and counts.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetPulseOutputCount( _
ByVal i_iChannel As Integer, _
ByVal i_bContinue As Boolean, _
ByVal i_lPulseCount As Long _
) As Boolean
C#
public bool SetPulseOutputCount(
int i_iChannel,
bool i_bContinue,
long i_lPulseCount
)
C++
public:
bool SetPulseOutputCount(
int i_iChannel,
bool i_bContinue,
__int64 i_lPulseCount
) sealed
J#
public bool SetPulseOutputCount(
int i_iChannel,
bool i_bContinue,
long i_lPulseCount
)
JScript
public function SetPulseOutputCount(
i_iChannel : int,
i_bContinue : bool,
i_lPulseCount : long
) : bool

Parameters

i_iChannel
Channel number
i_bContinue
The pulse output continue mode.
i_lPulseCount
The pulse output count.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetPulseOutputWidthAndDelayTime Method

DigitalOutput.SetPulseOutputWidthAndDelayTime Method

Support module: ADAM-4100. Set pulse output width and delay time.

Overload List

 | Name | Description
Public method | SetPulseOutputWidthAndDelayTime (Int32, Int64, Int64, Int64, Int64) | Support module: ADAM-4100. Set pulse output width and delay time.
Public method | SetPulseOutputWidthAndDelayTime (Int64, Int64, Int64, Int64) | Support module: ADAM-6000. Set pulse output width and delay time.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetPulseOutputWidthAndDelayTime Method (Int32, Int64, Int64, Int64, Int64)

DigitalOutput.SetPulseOutputWidthAndDelayTime Method (Int32, Int64, Int64, Int64, Int64)
See Also Example
[image]

Support module: ADAM-4100. Set pulse output width and delay time.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetPulseOutputWidthAndDelayTime( _
ByVal i_iChannel As Integer, _
ByVal i_lPulseHighWidth As Long, _
ByVal i_lPulseLowWidth As Long, _
ByVal i_lHighToLowDelay As Long, _
ByVal i_lLowToHighDelay As Long _
) As Boolean
C#
public bool SetPulseOutputWidthAndDelayTime(
int i_iChannel,
long i_lPulseHighWidth,
long i_lPulseLowWidth,
long i_lHighToLowDelay,
long i_lLowToHighDelay
)
C++
public:
bool SetPulseOutputWidthAndDelayTime(
int i_iChannel,
__int64 i_lPulseHighWidth,
__int64 i_lPulseLowWidth,
__int64 i_lHighToLowDelay,
__int64 i_lLowToHighDelay
) sealed
J#
public bool SetPulseOutputWidthAndDelayTime(
int i_iChannel,
long i_lPulseHighWidth,
long i_lPulseLowWidth,
long i_lHighToLowDelay,
long i_lLowToHighDelay
)
JScript
public function SetPulseOutputWidthAndDelayTime(
i_iChannel : int,
i_lPulseHighWidth : long,
i_lPulseLowWidth : long,
i_lHighToLowDelay : long,
i_lLowToHighDelay : long
) : bool

Parameters

i_iChannel
Channel number
i_lPulseHighWidth
The pulse high signal width.
i_lPulseLowWidth
The pulse low signal width.
i_lHighToLowDelay
The high to low delat time.
i_lLowToHighDelay
The low to high delay time.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetPulseOutputWidthAndDelayTime Overload List


SetPulseOutputWidthAndDelayTime Method (Int64[], Int64[], Int64[], Int64[])

DigitalOutput.SetPulseOutputWidthAndDelayTime Method (Int64[], Int64[], Int64[], Int64[])
See Also Example
[image]

Support module: ADAM-6000. Set pulse output width and delay time.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetPulseOutputWidthAndDelayTime( _
ByVal i_lPulseHighWidth As Long(), _
ByVal i_lPulseLowWidth As Long(), _
ByVal i_lHighToLowDelay As Long(), _
ByVal i_lLowToHighDelay As Long() _
) As Boolean
C#
public bool SetPulseOutputWidthAndDelayTime(
long[] i_lPulseHighWidth,
long[] i_lPulseLowWidth,
long[] i_lHighToLowDelay,
long[] i_lLowToHighDelay
)
C++
public:
bool SetPulseOutputWidthAndDelayTime(
array<__int64>^ i_lPulseHighWidth,
array<__int64>^ i_lPulseLowWidth,
array<__int64>^ i_lHighToLowDelay,
array<__int64>^ i_lLowToHighDelay
) sealed
J#
public bool SetPulseOutputWidthAndDelayTime(
long[] i_lPulseHighWidth,
long[] i_lPulseLowWidth,
long[] i_lHighToLowDelay,
long[] i_lLowToHighDelay
)
JScript
public function SetPulseOutputWidthAndDelayTime(
i_lPulseHighWidth : long[],
i_lPulseLowWidth : long[],
i_lHighToLowDelay : long[],
i_lLowToHighDelay : long[]
) : bool

Parameters

i_lPulseHighWidth
The pulse high signal width.
i_lPulseLowWidth
The pulse low signal width.
i_lHighToLowDelay
The high to low delat time.
i_lLowToHighDelay
The low to high delay time.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetPulseOutputWidthAndDelayTime Overload List


SetSafetyValues Method

DigitalOutput.SetSafetyValues Method
[image]

Support module: ADAM-5000, ADAM-5000/TCP, APAX-5000. Set DO value to all channels.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSafetyValues( _
ByVal i_iSlot As Integer, _
ByVal i_bValues As Boolean() _
) As Boolean
C#
public bool SetSafetyValues(
int i_iSlot,
bool[] i_bValues
)
C++
public:
bool SetSafetyValues(
int i_iSlot,
array<bool>^ i_bValues
) sealed
J#
public bool SetSafetyValues(
int i_iSlot,
bool[] i_bValues
)
JScript
public function SetSafetyValues(
i_iSlot : int,
i_bValues : bool[]
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_bValues
The DO safety values to set. The length of the array must match the total of the channel on the module.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetSValue Method

DigitalOutput.SetSValue Method
[image]

Support module: For ADAM-4056S, ADAM-4056SO only. Set DO value to a single channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetSValue( _
ByVal i_iChannel As Integer, _
ByVal i_bValue As Boolean _
) As Boolean
C#
public bool SetSValue(
int i_iChannel,
bool i_bValue
)
C++
public:
bool SetSValue(
int i_iChannel,
bool i_bValue
) sealed
J#
public bool SetSValue(
int i_iChannel,
bool i_bValue
)
JScript
public function SetSValue(
i_iChannel : int,
i_bValue : bool
) : bool

Parameters

i_iChannel
The channel index, base 0.
i_bValue
The DO value to set.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetValue Method

DigitalOutput.SetValue Method

Support module: ADAM-4000 and ADAM-4100. (But not for ADAM-4056S, ADAM-4056SO) Set DO value to a single channel.

Overload List

 | Name | Description
Public method | SetValue (Int32, Boolean) | Support module: ADAM-4000 and ADAM-4100. (But not for ADAM-4056S, ADAM-4056SO) Set DO value to a single channel.
Public method | SetValue (Int32, Int32, Boolean) | Support module: ADAM-5000, ADAM-5000/TCP, APAX_5000, ADAM-5550, APAX-5070. Set DO value to a single channel.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetValue Method (Int32, Boolean)

DigitalOutput.SetValue Method (Int32, Boolean)
See Also Example
[image]

Support module: ADAM-4000 and ADAM-4100. (But not for ADAM-4056S, ADAM-4056SO) Set DO value to a single channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetValue( _
ByVal i_iChannel As Integer, _
ByVal i_bValue As Boolean _
) As Boolean
C#
public bool SetValue(
int i_iChannel,
bool i_bValue
)
C++
public:
bool SetValue(
int i_iChannel,
bool i_bValue
) sealed
J#
public bool SetValue(
int i_iChannel,
bool i_bValue
)
JScript
public function SetValue(
i_iChannel : int,
i_bValue : bool
) : bool

Parameters

i_iChannel
The channel index, base 0.
i_bValue
The DO value to set.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetValue Overload List


SetValue Method (Int32, Int32, Boolean)

DigitalOutput.SetValue Method (Int32, Int32, Boolean)
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, APAX_5000, ADAM-5550, APAX-5070. Set DO value to a single channel.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetValue( _
ByVal i_iSlot As Integer, _
ByVal i_iChannel As Integer, _
ByVal i_bValue As Boolean _
) As Boolean
C#
public bool SetValue(
int i_iSlot,
int i_iChannel,
bool i_bValue
)
C++
public:
bool SetValue(
int i_iSlot,
int i_iChannel,
bool i_bValue
) sealed
J#
public bool SetValue(
int i_iSlot,
int i_iChannel,
bool i_bValue
)
JScript
public function SetValue(
i_iSlot : int,
i_iChannel : int,
i_bValue : bool
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_iChannel
The channel index, base 0.
i_bValue
The DO value to set.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetValue Overload List


SetValues Method

DigitalOutput.SetValues Method

Support module: ADAM-4000 and ADAM-4100. Set DO value to all channels.

Overload List

 | Name | Description
Public method | SetValues (Boolean) | Support module: ADAM-4000 and ADAM-4100. Set DO value to all channels.
Public method | SetValues (Int32, Boolean) | Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550, APAX-5000. Set DO value to all channels.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetValues Method (Boolean[])

DigitalOutput.SetValues Method (Boolean[])
See Also Example
[image]

Support module: ADAM-4000 and ADAM-4100. Set DO value to all channels.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetValues( _
ByVal i_bValues As Boolean() _
) As Boolean
C#
public bool SetValues(
bool[] i_bValues
)
C++
public:
bool SetValues(
array<bool>^ i_bValues
) sealed
J#
public bool SetValues(
bool[] i_bValues
)
JScript
public function SetValues(
i_bValues : bool[]
) : bool

Parameters

i_bValues
The DO values to set. The length of the array must match the total of the channel on the module.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetValues Overload List


SetValues Method (Int32, Boolean[])

DigitalOutput.SetValues Method (Int32, Boolean[])
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000/TCP, ADAM-5550, APAX-5000. Set DO value to all channels.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetValues( _
ByVal i_iSlot As Integer, _
ByVal i_bValues As Boolean() _
) As Boolean
C#
public bool SetValues(
int i_iSlot,
bool[] i_bValues
)
C++
public:
bool SetValues(
int i_iSlot,
array<bool>^ i_bValues
) sealed
J#
public bool SetValues(
int i_iSlot,
bool[] i_bValues
)
JScript
public function SetValues(
i_iSlot : int,
i_bValues : bool[]
) : bool

Parameters

i_iSlot
The slot index, base 0.
i_bValues
The DO values to set. The length of the array must match the total of the channel on the module.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetValues Overload List


SetWDT Method

DigitalOutput.SetWDT Method
[image]

Support module: ADAM-6200. Set WDT enabled status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetWDT( _
ByVal i_bCommFSV As Boolean, _
ByVal i_bPtoPFSV As Boolean _
) As Boolean
C#
public bool SetWDT(
bool i_bCommFSV,
bool i_bPtoPFSV
)
C++
public:
bool SetWDT(
bool i_bCommFSV,
bool i_bPtoPFSV
) sealed
J#
public bool SetWDT(
bool i_bCommFSV,
bool i_bPtoPFSV
)
JScript
public function SetWDT(
i_bCommFSV : bool,
i_bPtoPFSV : bool
) : bool

Parameters

i_bCommFSV
The communication WDT.
i_bPtoPFSV
The P2P WDT.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetWDTInfo Method

DigitalOutput.SetWDTInfo Method
[image]

Support module: ADAM-4000 and ADAM-4100. Set WDT information.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetWDTInfo( _
ByVal i_fTimeout As Single, _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetWDTInfo(
float i_fTimeout,
bool[] i_bEnabled
)
C++
public:
bool SetWDTInfo(
float i_fTimeout,
array<bool>^ i_bEnabled
) sealed
J#
public bool SetWDTInfo(
float i_fTimeout,
bool[] i_bEnabled
)
JScript
public function SetWDTInfo(
i_fTimeout : float,
i_bEnabled : bool[]
) : bool

Parameters

i_fTimeout
The timeout value. If no communication within the timeout, those channels that are set with WDT enabled will set to ON.
i_bEnabled
The WDT mask. Set an element to true to enabled the WDT. Otherwise, set to false. The total of the array must be the same as the total of DO channel on the module.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetWDTMask Method

DigitalOutput.SetWDTMask Method

Support module: ADAM-6000. Set WDT enabled mask

Overload List

 | Name | Description
Public method | SetWDTMask (Boolean, Boolean, Boolean) | Support module: ADAM-6000. Set WDT enabled mask
Public method | SetWDTMask (Int32, Boolean) | Support module: ADAM-5000, ADAM-5000TCP. Set WDT enabled mask

See Also

DigitalOutput Class
Advantech.Adam Namespace


SetWDTMask Method (Boolean, Boolean, Boolean[])

DigitalOutput.SetWDTMask Method (Boolean, Boolean, Boolean[])
See Also Example
[image]

Support module: ADAM-6000. Set WDT enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetWDTMask( _
ByVal i_bCommFSV As Boolean, _
ByVal i_bPtoPFSV As Boolean, _
ByVal i_bMask As Boolean() _
) As Boolean
C#
public bool SetWDTMask(
bool i_bCommFSV,
bool i_bPtoPFSV,
bool[] i_bMask
)
C++
public:
bool SetWDTMask(
bool i_bCommFSV,
bool i_bPtoPFSV,
array<bool>^ i_bMask
) sealed
J#
public bool SetWDTMask(
bool i_bCommFSV,
bool i_bPtoPFSV,
bool[] i_bMask
)
JScript
public function SetWDTMask(
i_bCommFSV : bool,
i_bPtoPFSV : bool,
i_bMask : bool[]
) : bool

Parameters

i_bCommFSV
The communication WDT.
i_bPtoPFSV
The P2P WDT.
i_bMask
The WDT mask. Set an element to true to enabled the WDT. Otherwise, set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetWDTMask Overload List


SetWDTMask Method (Int32, Boolean[])

DigitalOutput.SetWDTMask Method (Int32, Boolean[])
See Also Example
[image]

Support module: ADAM-5000, ADAM-5000TCP. Set WDT enabled mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function SetWDTMask( _
ByVal i_iSlot As Integer, _
ByVal i_bEnabled As Boolean() _
) As Boolean
C#
public bool SetWDTMask(
int i_iSlot,
bool[] i_bEnabled
)
C++
public:
bool SetWDTMask(
int i_iSlot,
array<bool>^ i_bEnabled
) sealed
J#
public bool SetWDTMask(
int i_iSlot,
bool[] i_bEnabled
)
JScript
public function SetWDTMask(
i_iSlot : int,
i_bEnabled : bool[]
) : bool

Parameters

i_iSlot
Slot index. The value is between 0~7
i_bEnabled
The WDT mask. Set an element to true to enabled the WDT. Otherwise, set to false.

Return Value

True if secceed, otherwise false.

See Also

DigitalOutput Class
Advantech.Adam Namespace
DigitalOutput.SetWDTMask Overload List


EVENT_STATUS Enumeration

EVENT_STATUS Enumeration
[image]

Event status

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum EVENT_STATUS
C#
public enum EVENT_STATUS
C++
public enum class EVENT_STATUS
J#
public enum EVENT_STATUS
JScript
public enum EVENT_STATUS

Members

Member Name | Description
NO_CHANGE | No change
ON_TO_OFF | On to off
OFF_TO_ON | Off to On
LOST | Lost

See Also

Advantech.Adam Namespace


EVENT_TYPE Enumeration

EVENT_TYPE Enumeration
[image]

Event type

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum EVENT_TYPE
C#
public enum EVENT_TYPE
C++
public enum class EVENT_TYPE
J#
public enum EVENT_TYPE
JScript
public enum EVENT_TYPE

Members

Member Name | Description
DIO | DIO
AIO | AIO
HIALARM | Hi alarm
LOALARM | Lo alarm
CONNECT | Connect

See Also

Advantech.Adam Namespace


GCL_IOMsg_Config Class

GCL_IOMsg_Config Class
See Also Example Members
[image]

Peer to Peer Configuration Class

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class GCL_IOMsg_Config
C#
public class GCL_IOMsg_Config
C++
ref class GCL_IOMsg_Config
J#
public class GCL_IOMsg_Config
JScript
public class GCL_IOMsg_Config

Inheritance Hierarchy

System.Object
Advantech.Adam.GCL_IOMsg_Config

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GCL_IOMsg_Config Members
Advantech.Adam Namespace


GCL_IOMsg_Config Members

GCL_IOMsg_Config Members
See Also Example Constructors Fields
[image]

Peer to Peer Configuration Class

The following tables list the members exposed by GCL_IOMsg_Config.

Public Constructors

 | Name | Description
Public method | GCL_IOMsg_Config | Constructer
Top

Public Fields

 | Name | Description
Public field | Data | All GCL IOMsg data package
Public field | Header | Header (GCLMSG) :Order 0~5, 6 bytes
Public field | IP | IP : Order 22~25, 4 bytes
Public field | ModuleLine | Module Line : Order 30, 1 byte
Public field | ModuleName | Module Name : Order 31~33, 3 bytes
Public field | NumBitsAI | The number of bits per AI Data : Order 35, 1 byte
Public field | NumBitsAO | The number of bits per AO Data : Order 39, 1 byte
Public field | NumBitsCnt | The number of bits per Counter Data : Order 51, 1 byte
Public field | NumBitsDI | The number of bits per DI Data : Order 43, 1 byte
Public field | NumBitsDO | The number of bits per DO Data : Order 47, 1 byte
Public field | OperationVal | Operation Value : Order 10~13, 4 bytes
Public field | Order1stAI | The byte order of the 1st byte of AI Data : Order 36~37, 2 bytes
Public field | Order1stAO | The byte order of the 1st byte of AO Data : Order 40~41, 2 bytes
Public field | Order1stCnt | The byte order of the 1st byte of Counter Data : Order 52~53, 2 bytes
Public field | Order1stDI | The byte order of the 1st byte of DI Data : Order 44~45, 2 bytes
Public field | Order1stDO | The byte order of the 1st byte of DO Data : Order 48~49, 2 bytes
Public field | Order1stMsg | The byte order of the 1st byte of Message : Order 62~63, 2 bytes
Public field | OutputIndex | Output Index : Order 8~9, 2 bytes
Public field | ReservedBytes1 | Reserved bytes 1: Order 14~21, 8 bytes
Public field | ReservedBytes2 | Reserved bytes 2: Order 54~61, 8 bytes
Public field | RuleIndex | Rule Index : Order 6~7, 2 bytes
Public field | SeqNum | Sequence Number : Order 26~29, 4 bytes
Public field | TotalAI | Total Number of AI Channels : Order 34, 1 byte
Public field | TotalAO | Total Number of AO Channels : Order 38, 1 byte
Public field | TotalBytesMsg | Total bytes of message : Order 64, 1 bytes
Public field | TotalCnt | Total Number of Counter Channels : Order 50, 1 byte
Public field | TotalDI | Total Number of DI Channels : Order 42, 1 byte
Public field | TotalDO | Total Number of DO Channels : Order 46, 1 byte
Top

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


GCL_IOMsg_Config Constructor

GCL_IOMsg_Config Constructor
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GCL_IOMsg_Config()
C++
public:
GCL_IOMsg_Config() sealed
J#
public GCL_IOMsg_Config()
JScript
public function GCL_IOMsg_Config()

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Fields

GCL_IOMsg_Config Fields
[image]

Public Fields

 | Name | Description
Public field | Data | All GCL IOMsg data package
Public field | Header | Header (GCLMSG) :Order 0~5, 6 bytes
Public field | IP | IP : Order 22~25, 4 bytes
Public field | ModuleLine | Module Line : Order 30, 1 byte
Public field | ModuleName | Module Name : Order 31~33, 3 bytes
Public field | NumBitsAI | The number of bits per AI Data : Order 35, 1 byte
Public field | NumBitsAO | The number of bits per AO Data : Order 39, 1 byte
Public field | NumBitsCnt | The number of bits per Counter Data : Order 51, 1 byte
Public field | NumBitsDI | The number of bits per DI Data : Order 43, 1 byte
Public field | NumBitsDO | The number of bits per DO Data : Order 47, 1 byte
Public field | OperationVal | Operation Value : Order 10~13, 4 bytes
Public field | Order1stAI | The byte order of the 1st byte of AI Data : Order 36~37, 2 bytes
Public field | Order1stAO | The byte order of the 1st byte of AO Data : Order 40~41, 2 bytes
Public field | Order1stCnt | The byte order of the 1st byte of Counter Data : Order 52~53, 2 bytes
Public field | Order1stDI | The byte order of the 1st byte of DI Data : Order 44~45, 2 bytes
Public field | Order1stDO | The byte order of the 1st byte of DO Data : Order 48~49, 2 bytes
Public field | Order1stMsg | The byte order of the 1st byte of Message : Order 62~63, 2 bytes
Public field | OutputIndex | Output Index : Order 8~9, 2 bytes
Public field | ReservedBytes1 | Reserved bytes 1: Order 14~21, 8 bytes
Public field | ReservedBytes2 | Reserved bytes 2: Order 54~61, 8 bytes
Public field | RuleIndex | Rule Index : Order 6~7, 2 bytes
Public field | SeqNum | Sequence Number : Order 26~29, 4 bytes
Public field | TotalAI | Total Number of AI Channels : Order 34, 1 byte
Public field | TotalAO | Total Number of AO Channels : Order 38, 1 byte
Public field | TotalBytesMsg | Total bytes of message : Order 64, 1 bytes
Public field | TotalCnt | Total Number of Counter Channels : Order 50, 1 byte
Public field | TotalDI | Total Number of DI Channels : Order 42, 1 byte
Public field | TotalDO | Total Number of DO Channels : Order 46, 1 byte
Top

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Data Field

GCL_IOMsg_Config.Data Field
[image]

All GCL IOMsg data package

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Header Field

GCL_IOMsg_Config.Header Field
[image]

Header (GCLMSG) :Order 0~5, 6 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Header As Byte()
C#
public byte[] Header;
C++
public:
array<char>^ Header sealed ;
J#
public byte[] Header
JScript
public Header : Byte[];

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


IP Field

GCL_IOMsg_Config.IP Field
[image]

IP : Order 22~25, 4 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public IP As Byte()
C#
public byte[] IP;
C++
public:
array<char>^ IP sealed ;
J#
public byte[] IP
JScript
public IP : Byte[];

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


ModuleLine Field

GCL_IOMsg_Config.ModuleLine Field
[image]

Module Line : Order 30, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ModuleLine As Byte
C#
public byte ModuleLine;
C++
public:
char ModuleLine sealed ;
J#
public byte ModuleLine
JScript
public ModuleLine : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


ModuleName Field

GCL_IOMsg_Config.ModuleName Field
[image]

Module Name : Order 31~33, 3 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ModuleName As Byte()
C#
public byte[] ModuleName;
C++
public:
array<char>^ ModuleName sealed ;
J#
public byte[] ModuleName
JScript
public ModuleName : Byte[];

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


NumBitsAI Field

GCL_IOMsg_Config.NumBitsAI Field
[image]

The number of bits per AI Data : Order 35, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public NumBitsAI As Byte
C#
public byte NumBitsAI;
C++
public:
char NumBitsAI sealed ;
J#
public byte NumBitsAI
JScript
public NumBitsAI : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


NumBitsAO Field

GCL_IOMsg_Config.NumBitsAO Field
[image]

The number of bits per AO Data : Order 39, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public NumBitsAO As Byte
C#
public byte NumBitsAO;
C++
public:
char NumBitsAO sealed ;
J#
public byte NumBitsAO
JScript
public NumBitsAO : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


NumBitsCnt Field

GCL_IOMsg_Config.NumBitsCnt Field
[image]

The number of bits per Counter Data : Order 51, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public NumBitsCnt As Byte
C#
public byte NumBitsCnt;
C++
public:
char NumBitsCnt sealed ;
J#
public byte NumBitsCnt
JScript
public NumBitsCnt : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


NumBitsDI Field

GCL_IOMsg_Config.NumBitsDI Field
[image]

The number of bits per DI Data : Order 43, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public NumBitsDI As Byte
C#
public byte NumBitsDI;
C++
public:
char NumBitsDI sealed ;
J#
public byte NumBitsDI
JScript
public NumBitsDI : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


NumBitsDO Field

GCL_IOMsg_Config.NumBitsDO Field
[image]

The number of bits per DO Data : Order 47, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public NumBitsDO As Byte
C#
public byte NumBitsDO;
C++
public:
char NumBitsDO sealed ;
J#
public byte NumBitsDO
JScript
public NumBitsDO : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


OperationVal Field

GCL_IOMsg_Config.OperationVal Field
[image]

Operation Value : Order 10~13, 4 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public OperationVal As UInt32
C#
public uint OperationVal;
C++
public:
unsigned int OperationVal sealed ;
J#
public uint OperationVal
JScript
public OperationVal : UInt32;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Order1stAI Field

GCL_IOMsg_Config.Order1stAI Field
[image]

The byte order of the 1st byte of AI Data : Order 36~37, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Order1stAI As UInt16
C#
public ushort Order1stAI;
C++
public:
unsigned short Order1stAI sealed ;
J#
public ushort Order1stAI
JScript
public Order1stAI : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Order1stAO Field

GCL_IOMsg_Config.Order1stAO Field
[image]

The byte order of the 1st byte of AO Data : Order 40~41, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Order1stAO As UInt16
C#
public ushort Order1stAO;
C++
public:
unsigned short Order1stAO sealed ;
J#
public ushort Order1stAO
JScript
public Order1stAO : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Order1stCnt Field

GCL_IOMsg_Config.Order1stCnt Field
[image]

The byte order of the 1st byte of Counter Data : Order 52~53, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Order1stCnt As UInt16
C#
public ushort Order1stCnt;
C++
public:
unsigned short Order1stCnt sealed ;
J#
public ushort Order1stCnt
JScript
public Order1stCnt : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Order1stDI Field

GCL_IOMsg_Config.Order1stDI Field
[image]

The byte order of the 1st byte of DI Data : Order 44~45, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Order1stDI As UInt16
C#
public ushort Order1stDI;
C++
public:
unsigned short Order1stDI sealed ;
J#
public ushort Order1stDI
JScript
public Order1stDI : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Order1stDO Field

GCL_IOMsg_Config.Order1stDO Field
[image]

The byte order of the 1st byte of DO Data : Order 48~49, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Order1stDO As UInt16
C#
public ushort Order1stDO;
C++
public:
unsigned short Order1stDO sealed ;
J#
public ushort Order1stDO
JScript
public Order1stDO : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


Order1stMsg Field

GCL_IOMsg_Config.Order1stMsg Field
[image]

The byte order of the 1st byte of Message : Order 62~63, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Order1stMsg As UInt16
C#
public ushort Order1stMsg;
C++
public:
unsigned short Order1stMsg sealed ;
J#
public ushort Order1stMsg
JScript
public Order1stMsg : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


OutputIndex Field

GCL_IOMsg_Config.OutputIndex Field
[image]

Output Index : Order 8~9, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public OutputIndex As UInt16
C#
public ushort OutputIndex;
C++
public:
unsigned short OutputIndex sealed ;
J#
public ushort OutputIndex
JScript
public OutputIndex : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


ReservedBytes1 Field

GCL_IOMsg_Config.ReservedBytes1 Field
[image]

Reserved bytes 1: Order 14~21, 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReservedBytes1 As Byte()
C#
public byte[] ReservedBytes1;
C++
public:
array<char>^ ReservedBytes1 sealed ;
J#
public byte[] ReservedBytes1
JScript
public ReservedBytes1 : Byte[];

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


ReservedBytes2 Field

GCL_IOMsg_Config.ReservedBytes2 Field
[image]

Reserved bytes 2: Order 54~61, 8 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ReservedBytes2 As Byte()
C#
public byte[] ReservedBytes2;
C++
public:
array<char>^ ReservedBytes2 sealed ;
J#
public byte[] ReservedBytes2
JScript
public ReservedBytes2 : Byte[];

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


RuleIndex Field

GCL_IOMsg_Config.RuleIndex Field
[image]

Rule Index : Order 6~7, 2 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public RuleIndex As UInt16
C#
public ushort RuleIndex;
C++
public:
unsigned short RuleIndex sealed ;
J#
public ushort RuleIndex
JScript
public RuleIndex : UInt16;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


SeqNum Field

GCL_IOMsg_Config.SeqNum Field
[image]

Sequence Number : Order 26~29, 4 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public SeqNum As UInt32
C#
public uint SeqNum;
C++
public:
unsigned int SeqNum sealed ;
J#
public uint SeqNum
JScript
public SeqNum : UInt32;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


TotalAI Field

GCL_IOMsg_Config.TotalAI Field
[image]

Total Number of AI Channels : Order 34, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public TotalAI As Byte
C#
public byte TotalAI;
C++
public:
char TotalAI sealed ;
J#
public byte TotalAI
JScript
public TotalAI : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


TotalAO Field

GCL_IOMsg_Config.TotalAO Field
[image]

Total Number of AO Channels : Order 38, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public TotalAO As Byte
C#
public byte TotalAO;
C++
public:
char TotalAO sealed ;
J#
public byte TotalAO
JScript
public TotalAO : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


TotalBytesMsg Field

GCL_IOMsg_Config.TotalBytesMsg Field
[image]

Total bytes of message : Order 64, 1 bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public TotalBytesMsg As Byte
C#
public byte TotalBytesMsg;
C++
public:
char TotalBytesMsg sealed ;
J#
public byte TotalBytesMsg
JScript
public TotalBytesMsg : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


TotalCnt Field

GCL_IOMsg_Config.TotalCnt Field
[image]

Total Number of Counter Channels : Order 50, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public TotalCnt As Byte
C#
public byte TotalCnt;
C++
public:
char TotalCnt sealed ;
J#
public byte TotalCnt
JScript
public TotalCnt : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


TotalDI Field

GCL_IOMsg_Config.TotalDI Field
[image]

Total Number of DI Channels : Order 42, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public TotalDI As Byte
C#
public byte TotalDI;
C++
public:
char TotalDI sealed ;
J#
public byte TotalDI
JScript
public TotalDI : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


TotalDO Field

GCL_IOMsg_Config.TotalDO Field
[image]

Total Number of DO Channels : Order 46, 1 byte

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public TotalDO As Byte
C#
public byte TotalDO;
C++
public:
char TotalDO sealed ;
J#
public byte TotalDO
JScript
public TotalDO : Byte;

See Also

GCL_IOMsg_Config Class
Advantech.Adam Namespace


GetDataCallback Delegate

GetDataCallback Delegate
[image]

Delegate to receive TreeView selected node changed events.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub GetDataCallback( _
ByVal config As GCL_IOMsg_Config _
)
C#
public delegate void GetDataCallback(
GCL_IOMsg_Config config
)
C++
public delegate void GetDataCallback(
GCL_IOMsg_Config config
)
J#
/** delegate */
public delegate void GetDataCallback(
GCL_IOMsg_Config config
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Adam Namespace


GetP2PDataCallback Delegate

GetP2PDataCallback Delegate
[image]

Delegate to receive TreeView selected node changed events.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub GetP2PDataCallback( _
ByVal config As P2P_Config _
)
C#
public delegate void GetP2PDataCallback(
P2P_Config config
)
C++
public delegate void GetP2PDataCallback(
P2P_Config config
)
J#
/** delegate */
public delegate void GetP2PDataCallback(
P2P_Config config
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Adam Namespace


Modbus Class

Modbus Class
See Also Example Members
[image]

MODBUS class library.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class Modbus
Inherits AdamBase
C#
public class Modbus : AdamBase
C++
ref class Modbus : AdamBase
J#
public class Modbus extends AdamBase
JScript
public class Modbus extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.Modbus

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Modbus Members
Advantech.Adam Namespace


Modbus Members

Modbus Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

MODBUS class library.

The following tables list the members exposed by Modbus.

Public Constructors

Name | Description
Modbus | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | ForceMultiCoils | Overloaded. Modbus function(0F) Force multi coils Forces each coil (0X reference) in a sequence of coils to either ON or OFF.
Public method | ForceSingleCoil | Overloaded. Modbus function(05) Force single coil Forces a single coil (0X reference) to either ON or OFF.
Public method | PresetMultiRegs | Overloaded. Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).
Public method | PresetSingleReg | Modbus function(06) Preset single register Presets a value into a single holding register (4X reference).
Public method | ReadAdvantechRegs | Overloaded. Modbus function(20) Read Advantech registers Reads the binary contents of Advantech registers (20X references) in the slave.
Public method | ReadCoilStatus | Overloaded. Modbus function(01) Read coil status Reads the ON/OFF status of discrete outputs (0X references, coils) in the slave.
Public method | ReadCustomizeRegs | Overloaded. Modbus function Read customize registers Reads the binary contents of customize registers in the slave.
Public method | ReadHoldingRegs | Overloaded. Modbus function(03) Read holding registers Reads the floating contents of holding registers (4X references) in the slave.
Public method | ReadInputRegs | Overloaded. Modbus function(04) Read input registers Reads the binary contents of input registers (3X references) in the slave.
Public method | ReadInputStatus | Overloaded. Modbus function(02) Read input status Reads the ON/OFF status of discrete inputs (1X references) in the slave.
Public method | WriteAdvantechRegs | Overloaded. Modbus function(21) Write Advantech registers Writes the binary contents of Advantech registers (21X references) in the slave.
Public method | WriteCustomizeRegs | Overloaded. Modbus function Write customize registers Writes the binary contents of customize registers in the slave.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
Modbus | Overloaded.
Top

See Also

Modbus Class
Advantech.Adam Namespace


Modbus Constructor

Modbus Constructor

Overload List

 | Name | Description
Public method | Modbus (AdamCom) | The Modbus-RTU constructor
Public method | Modbus (AdamSocket) | The Modbus-TCP constructor

See Also

Modbus Class
Advantech.Adam Namespace


Modbus Constructor (AdamCom)

Modbus Constructor (AdamCom)
See Also Example
[image]

The Modbus-RTU constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public Modbus(
AdamCom i_com
)
C++
public:
Modbus(
AdamCom i_com
) sealed
J#
public Modbus(
AdamCom i_com
)
JScript
public function Modbus(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus Constructor Overload List


Modbus Constructor (AdamSocket)

Modbus Constructor (AdamSocket)
See Also Example
[image]

The Modbus-TCP constructor

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public Modbus(
AdamSocket i_socket
)
C++
public:
Modbus(
AdamSocket i_socket
) sealed
J#
public Modbus(
AdamSocket i_socket
)
JScript
public function Modbus(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object

See Also

Modbus Class
Advantech.Adam Namespace
Modbus Constructor Overload List


Methods

Modbus Methods
[image]

Public Methods

 | Name | Description
Public method | ForceMultiCoils | Overloaded. Modbus function(0F) Force multi coils Forces each coil (0X reference) in a sequence of coils to either ON or OFF.
Public method | ForceSingleCoil | Overloaded. Modbus function(05) Force single coil Forces a single coil (0X reference) to either ON or OFF.
Public method | PresetMultiRegs | Overloaded. Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).
Public method | PresetSingleReg | Modbus function(06) Preset single register Presets a value into a single holding register (4X reference).
Public method | ReadAdvantechRegs | Overloaded. Modbus function(20) Read Advantech registers Reads the binary contents of Advantech registers (20X references) in the slave.
Public method | ReadCoilStatus | Overloaded. Modbus function(01) Read coil status Reads the ON/OFF status of discrete outputs (0X references, coils) in the slave.
Public method | ReadCustomizeRegs | Overloaded. Modbus function Read customize registers Reads the binary contents of customize registers in the slave.
Public method | ReadHoldingRegs | Overloaded. Modbus function(03) Read holding registers Reads the floating contents of holding registers (4X references) in the slave.
Public method | ReadInputRegs | Overloaded. Modbus function(04) Read input registers Reads the binary contents of input registers (3X references) in the slave.
Public method | ReadInputStatus | Overloaded. Modbus function(02) Read input status Reads the ON/OFF status of discrete inputs (1X references) in the slave.
Public method | WriteAdvantechRegs | Overloaded. Modbus function(21) Write Advantech registers Writes the binary contents of Advantech registers (21X references) in the slave.
Public method | WriteCustomizeRegs | Overloaded. Modbus function Write customize registers Writes the binary contents of customize registers in the slave.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

Modbus Class
Advantech.Adam Namespace


ForceMultiCoils Method

Modbus.ForceMultiCoils Method

Modbus function(0F) Force multi coils Forces each coil (0X reference) in a sequence of coils to either ON or OFF.

Overload List

 | Name | Description
Public method | ForceMultiCoils (Int32, Boolean) | Modbus function(0F) Force multi coils Forces each coil (0X reference) in a sequence of coils to either ON or OFF.
Public method | ForceMultiCoils (Int32, Int32, Int32, Byte) | Modbus function(0F) Force multiple coils Forces each coil (0X reference) in a sequence of coils to either ON or OFF.

See Also

Modbus Class
Advantech.Adam Namespace


ForceMultiCoils Method (Int32, Boolean[])

Modbus.ForceMultiCoils Method (Int32, Boolean[])
See Also Example
[image]

Modbus function(0F) Force multi coils Forces each coil (0X reference) in a sequence of coils to either ON or OFF.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ForceMultiCoils( _
ByVal i_iStartCoil As Integer, _
ByVal i_bData As Boolean() _
) As Boolean
C#
public bool ForceMultiCoils(
int i_iStartCoil,
bool[] i_bData
)
C++
public:
bool ForceMultiCoils(
int i_iStartCoil,
array<bool>^ i_bData
) sealed
J#
public bool ForceMultiCoils(
int i_iStartCoil,
bool[] i_bData
)
JScript
public function ForceMultiCoils(
i_iStartCoil : int,
i_bData : bool[]
) : bool

Parameters

i_iStartCoil
The starting coil addres (The base is 1).
i_bData
The boolean data for setting coils.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ForceMultiCoils Overload List


ForceMultiCoils Method (Int32, Int32, Int32, Byte[])

Modbus.ForceMultiCoils Method (Int32, Int32, Int32, Byte[])
See Also Example
[image]

Modbus function(0F) Force multiple coils Forces each coil (0X reference) in a sequence of coils to either ON or OFF.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ForceMultiCoils( _
ByVal i_iStartCoil As Integer, _
ByVal i_iTotalPoint As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte() _
) As Boolean
C#
public bool ForceMultiCoils(
int i_iStartCoil,
int i_iTotalPoint,
int i_iTotalByte,
byte[] i_byData
)
C++
public:
bool ForceMultiCoils(
int i_iStartCoil,
int i_iTotalPoint,
int i_iTotalByte,
array<char>^ i_byData
) sealed
J#
public bool ForceMultiCoils(
int i_iStartCoil,
int i_iTotalPoint,
int i_iTotalByte,
byte[] i_byData
)
JScript
public function ForceMultiCoils(
i_iStartCoil : int,
i_iTotalPoint : int,
i_iTotalByte : int,
i_byData : Byte[]
) : bool

Parameters

i_iStartCoil
The starting coil addres (The base is 1).
i_iTotalPoint
The total of coil for setting.
i_iTotalByte
The total of byte for setting.
i_byData
The raw byte data for setting coils.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ForceMultiCoils Overload List


ForceSingleCoil Method

Modbus.ForceSingleCoil Method

Modbus function(05) Force single coil Forces a single coil (0X reference) to either ON or OFF.

Overload List

 | Name | Description
Public method | ForceSingleCoil (Int32, Boolean) | Modbus function(05) Force single coil Forces a single coil (0X reference) to either ON or OFF.
Public method | ForceSingleCoil (Int32, Int32) | Modbus function(05) Force single coil Forces a single coil (0X reference) to either ON or OFF.

See Also

Modbus Class
Advantech.Adam Namespace


ForceSingleCoil Method (Int32, Boolean)

Modbus.ForceSingleCoil Method (Int32, Boolean)
See Also Example
[image]

Modbus function(05) Force single coil Forces a single coil (0X reference) to either ON or OFF.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ForceSingleCoil( _
ByVal i_iCoilIndex As Integer, _
ByVal i_bData As Boolean _
) As Boolean
C#
public bool ForceSingleCoil(
int i_iCoilIndex,
bool i_bData
)
C++
public:
bool ForceSingleCoil(
int i_iCoilIndex,
bool i_bData
) sealed
J#
public bool ForceSingleCoil(
int i_iCoilIndex,
bool i_bData
)
JScript
public function ForceSingleCoil(
i_iCoilIndex : int,
i_bData : bool
) : bool

Parameters

i_iCoilIndex
The coil address(The base is 1).
i_bData
The coil data, false is OFF, true is ON

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ForceSingleCoil Overload List


ForceSingleCoil Method (Int32, Int32)

Modbus.ForceSingleCoil Method (Int32, Int32)
See Also Example
[image]

Modbus function(05) Force single coil Forces a single coil (0X reference) to either ON or OFF.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ForceSingleCoil( _
ByVal i_iCoilIndex As Integer, _
ByVal i_iData As Integer _
) As Boolean
C#
public bool ForceSingleCoil(
int i_iCoilIndex,
int i_iData
)
C++
public:
bool ForceSingleCoil(
int i_iCoilIndex,
int i_iData
) sealed
J#
public bool ForceSingleCoil(
int i_iCoilIndex,
int i_iData
)
JScript
public function ForceSingleCoil(
i_iCoilIndex : int,
i_iData : int
) : bool

Parameters

i_iCoilIndex
The coil address(The base is 1).
i_iData
The coil data, 0 is OFF, other is ON

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ForceSingleCoil Overload List


PresetMultiRegs Method

Modbus.PresetMultiRegs Method

Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).

Overload List

 | Name | Description
Public method | PresetMultiRegs (Int32, Int32, Int32, Byte) | Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).
Public method | PresetMultiRegs (Int32, Int32) | Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).
Public method | PresetMultiRegs (Int32, Single, Boolean) | Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).
Public method | PresetMultiRegs (Int32, UInt32) | Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).

See Also

Modbus Class
Advantech.Adam Namespace


PresetMultiRegs Method (Int32, Int32, Int32, Byte[])

Modbus.PresetMultiRegs Method (Int32, Int32, Int32, Byte[])
See Also Example
[image]

Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function PresetMultiRegs( _
ByVal i_iStartReg As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte() _
) As Boolean
C#
public bool PresetMultiRegs(
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData
)
C++
public:
bool PresetMultiRegs(
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData
) sealed
J#
public bool PresetMultiRegs(
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData
)
JScript
public function PresetMultiRegs(
i_iStartReg : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[]
) : bool

Parameters

i_iStartReg
The starting register addres (The base is 1).
i_iTotalReg
The total of register for setting.
i_iTotalByte
The total of byte for setting.
i_byData
The byte data for setting registers.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.PresetMultiRegs Overload List


PresetMultiRegs Method (Int32, Int32[])

Modbus.PresetMultiRegs Method (Int32, Int32[])
See Also Example
[image]

Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function PresetMultiRegs( _
ByVal i_iStartReg As Integer, _
ByVal i_iData As Integer() _
) As Boolean
C#
public bool PresetMultiRegs(
int i_iStartReg,
int[] i_iData
)
C++
public:
bool PresetMultiRegs(
int i_iStartReg,
array<int>^ i_iData
) sealed
J#
public bool PresetMultiRegs(
int i_iStartReg,
int[] i_iData
)
JScript
public function PresetMultiRegs(
i_iStartReg : int,
i_iData : int[]
) : bool

Parameters

i_iStartReg
The starting register addres (The base is 1).
i_iData
The array of data for setting registers. The value is from 0~65535.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.PresetMultiRegs Overload List


PresetMultiRegs Method (Int32, Single[], Boolean)

Modbus.PresetMultiRegs Method (Int32, Single[], Boolean)
See Also Example
[image]

Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function PresetMultiRegs( _
ByVal i_iStartReg As Integer, _
ByVal i_fData As Single(), _
ByVal i_bSwap As Boolean _
) As Boolean
C#
public bool PresetMultiRegs(
int i_iStartReg,
float[] i_fData,
bool i_bSwap
)
C++
public:
bool PresetMultiRegs(
int i_iStartReg,
array<float>^ i_fData,
bool i_bSwap
) sealed
J#
public bool PresetMultiRegs(
int i_iStartReg,
float[] i_fData,
bool i_bSwap
)
JScript
public function PresetMultiRegs(
i_iStartReg : int,
i_fData : float[],
i_bSwap : bool
) : bool

Parameters

i_iStartReg
The starting register addres (The base is 1).
i_fData
The array of data for setting registers.
i_bSwap
Swap high word with low word.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.PresetMultiRegs Overload List


PresetMultiRegs Method (Int32, UInt32[])

Modbus.PresetMultiRegs Method (Int32, UInt32[])
See Also Example
[image]

Modbus function(10) Preset Multi-regs Presets values into a sequence of holding registers (4X references).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function PresetMultiRegs( _
ByVal i_iStartReg As Integer, _
ByVal i_uiData As UInt32() _
) As Boolean
C#
public bool PresetMultiRegs(
int i_iStartReg,
uint[] i_uiData
)
C++
public:
bool PresetMultiRegs(
int i_iStartReg,
array<unsigned int>^ i_uiData
) sealed
J#
public bool PresetMultiRegs(
int i_iStartReg,
uint[] i_uiData
)
JScript
public function PresetMultiRegs(
i_iStartReg : int,
i_uiData : UInt32[]
) : bool

Parameters

i_iStartReg
The starting register addres (The base is 1).
i_uiData
The array of data for setting registers. The value is from 0~4294967295.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.PresetMultiRegs Overload List


PresetSingleReg Method

Modbus.PresetSingleReg Method
[image]

Modbus function(06) Preset single register Presets a value into a single holding register (4X reference).

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function PresetSingleReg( _
ByVal i_iRegIndex As Integer, _
ByVal i_iData As Integer _
) As Boolean
C#
public bool PresetSingleReg(
int i_iRegIndex,
int i_iData
)
C++
public:
bool PresetSingleReg(
int i_iRegIndex,
int i_iData
) sealed
J#
public bool PresetSingleReg(
int i_iRegIndex,
int i_iData
)
JScript
public function PresetSingleReg(
i_iRegIndex : int,
i_iData : int
) : bool

Parameters

i_iRegIndex
The register address(The base is 1).
i_iData
The register data. The value is from 0~65535.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace


ReadAdvantechRegs Method

Modbus.ReadAdvantechRegs Method

Modbus function(20) Read Advantech registers Reads the binary contents of Advantech registers (20X references) in the slave.

Overload List

 | Name | Description
Public method | ReadAdvantechRegs (Int32, Int32, Byte) | Modbus function(20) Read Advantech registers Reads the binary contents of Advantech registers (20X references) in the slave.
Public method | ReadAdvantechRegs (Int32, Int32, Int32) | Modbus function(20) Read Advantech registers Reads the integer contents of Advantech registers (20X references) in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


ReadAdvantechRegs Method (Int32, Int32, Byte)

Modbus.ReadAdvantechRegs Method (Int32, Int32, Byte)
See Also Example
[image]

Modbus function(20) Read Advantech registers Reads the binary contents of Advantech registers (20X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadAdvantechRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byteData As Byte _
) As Boolean
C#
public bool ReadAdvantechRegs(
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byteData
)
C++
public:
bool ReadAdvantechRegs(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byteData
) sealed
J#
public bool ReadAdvantechRegs(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byteData
)
JScript
public function ReadAdvantechRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byteData : Byte
) : bool

Parameters

i_iStartIndex
The starting register addres (The base is 1).
i_iTotalPoint
The number of register for reading.
o_byteData
The raw byte data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadAdvantechRegs Overload List


ReadAdvantechRegs Method (Int32, Int32, Int32)

Modbus.ReadAdvantechRegs Method (Int32, Int32, Int32)
See Also Example
[image]

Modbus function(20) Read Advantech registers Reads the integer contents of Advantech registers (20X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadAdvantechRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_iData As Integer _
) As Boolean
C#
public bool ReadAdvantechRegs(
int i_iStartIndex,
int i_iTotalPoint,
out int o_iData
)
C++
public:
bool ReadAdvantechRegs(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] int% o_iData
) sealed
J#
public bool ReadAdvantechRegs(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ int o_iData
)
JScript
public function ReadAdvantechRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_iData : int
) : bool

Parameters

i_iStartIndex
The starting register addres (The base is 1).
i_iTotalPoint
The number of register for reading.
o_iData
The data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadAdvantechRegs Overload List


ReadCoilStatus Method

Modbus.ReadCoilStatus Method

Modbus function(01) Read coil status Reads the ON/OFF status of discrete outputs (0X references, coils) in the slave.

Overload List

 | Name | Description
Public method | ReadCoilStatus (Int32, Int32, Boolean) | Modbus function(01) Read coil status Reads the ON/OFF status of discrete outputs (0X references, coils) in the slave.
Public method | ReadCoilStatus (Int32, Int32, Byte) | Modbus function(01) Read coil status Reads the ON/OFF status of discrete outputs (0X references, coils) in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


ReadCoilStatus Method (Int32, Int32, Boolean)

Modbus.ReadCoilStatus Method (Int32, Int32, Boolean)
See Also Example
[image]

Modbus function(01) Read coil status Reads the ON/OFF status of discrete outputs (0X references, coils) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadCoilStatus( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_bCoil As Boolean _
) As Boolean
C#
public bool ReadCoilStatus(
int i_iStartIndex,
int i_iTotalPoint,
out bool o_bCoil
)
C++
public:
bool ReadCoilStatus(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] bool% o_bCoil
) sealed
J#
public bool ReadCoilStatus(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ bool o_bCoil
)
JScript
public function ReadCoilStatus(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_bCoil : bool
) : bool

Parameters

i_iStartIndex
The starting coil addres (The base is 1).
i_iTotalPoint
The number of coil for reading.
o_bCoil
The parsed boolean of coil received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadCoilStatus Overload List


ReadCoilStatus Method (Int32, Int32, Byte)

Modbus.ReadCoilStatus Method (Int32, Int32, Byte)
See Also Example
[image]

Modbus function(01) Read coil status Reads the ON/OFF status of discrete outputs (0X references, coils) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadCoilStatus( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byteCoil As Byte _
) As Boolean
C#
public bool ReadCoilStatus(
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byteCoil
)
C++
public:
bool ReadCoilStatus(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byteCoil
) sealed
J#
public bool ReadCoilStatus(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byteCoil
)
JScript
public function ReadCoilStatus(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byteCoil : Byte
) : bool

Parameters

i_iStartIndex
The starting coil addres (The base is 1).
i_iTotalPoint
The number of coil for reading.
o_byteCoil
The raw byte data of coil received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadCoilStatus Overload List


ReadCustomizeRegs Method

Modbus.ReadCustomizeRegs Method

Modbus function Read customize registers Reads the binary contents of customize registers in the slave.

Overload List

 | Name | Description
Public method | ReadCustomizeRegs (Int32, Int32, Int32, Byte) | Modbus function Read customize registers Reads the binary contents of customize registers in the slave.
Public method | ReadCustomizeRegs (Int32, Int32, Int32, Int32) | Modbus function Read customize registers Reads the integer contents of customize registers in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


ReadCustomizeRegs Method (Int32, Int32, Int32, Byte)

Modbus.ReadCustomizeRegs Method (Int32, Int32, Int32, Byte)
See Also Example
[image]

Modbus function Read customize registers Reads the binary contents of customize registers in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byteData As Byte _
) As Boolean
C#
public bool ReadCustomizeRegs(
int i_iCommand,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byteData
)
C++
public:
bool ReadCustomizeRegs(
int i_iCommand,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byteData
) sealed
J#
public bool ReadCustomizeRegs(
int i_iCommand,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byteData
)
JScript
public function ReadCustomizeRegs(
i_iCommand : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byteData : Byte
) : bool

Parameters

i_iCommand
Customize command need to send.
i_iStartIndex
The starting register address (The base is 1).
i_iTotalPoint
The number of register for reading.
o_byteData
The raw byte data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadCustomizeRegs Overload List


ReadCustomizeRegs Method (Int32, Int32, Int32, Int32)

Modbus.ReadCustomizeRegs Method (Int32, Int32, Int32, Int32)
See Also Example
[image]

Modbus function Read customize registers Reads the integer contents of customize registers in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_iData As Integer _
) As Boolean
C#
public bool ReadCustomizeRegs(
int i_iCommand,
int i_iStartIndex,
int i_iTotalPoint,
out int o_iData
)
C++
public:
bool ReadCustomizeRegs(
int i_iCommand,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] int% o_iData
) sealed
J#
public bool ReadCustomizeRegs(
int i_iCommand,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ int o_iData
)
JScript
public function ReadCustomizeRegs(
i_iCommand : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_iData : int
) : bool

Parameters

i_iCommand
Customize command.
i_iStartIndex
The starting register addres (The base is 1).
i_iTotalPoint
The number of register for reading.
o_iData
The data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadCustomizeRegs Overload List


ReadHoldingRegs Method

Modbus.ReadHoldingRegs Method

Modbus function(03) Read holding registers Reads the floating contents of holding registers (4X references) in the slave.

Overload List

 | Name | Description
Public method | ReadHoldingRegs (Int32, Int32, Boolean, Single) | Modbus function(03) Read holding registers Reads the floating contents of holding registers (4X references) in the slave.
Public method | ReadHoldingRegs (Int32, Int32, Byte) | Modbus function(03) Read holding registers Reads the binary contents of holding registers (4X references) in the slave.
Public method | ReadHoldingRegs (Int32, Int32, Int32) | Modbus function(03) Read holding registers Reads the integer contents of holding registers (4X references) in the slave.
Public method | ReadHoldingRegs (Int32, Int32, UInt32) | Modbus function(03) Read holding registers Reads the integer contents of holding registers (4X references) in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


ReadHoldingRegs Method (Int32, Int32, Boolean, Single)

Modbus.ReadHoldingRegs Method (Int32, Int32, Boolean, Single)
See Also Example
[image]

Modbus function(03) Read holding registers Reads the floating contents of holding registers (4X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadHoldingRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
ByVal i_bSwap As Boolean, _
<OutAttribute> ByRef o_fData As Single _
) As Boolean
C#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
bool i_bSwap,
out float o_fData
)
C++
public:
bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
bool i_bSwap,
[OutAttribute] float% o_fData
) sealed
J#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
bool i_bSwap,
/** @attribute OutAttribute() */ /** @ref */ float o_fData
)
JScript
public function ReadHoldingRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
i_bSwap : bool,
OutAttribute o_fData : float
) : bool

Parameters

i_iStartIndex
The starting register addres (The base is 1).
i_iTotalPoint
The number of register for reading.
i_bSwap
Swap high word with low word.
o_fData
The floating data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadHoldingRegs Overload List


ReadHoldingRegs Method (Int32, Int32, Byte)

Modbus.ReadHoldingRegs Method (Int32, Int32, Byte)
See Also Example
[image]

Modbus function(03) Read holding registers Reads the binary contents of holding registers (4X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadHoldingRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byteData As Byte _
) As Boolean
C#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byteData
)
C++
public:
bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byteData
) sealed
J#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byteData
)
JScript
public function ReadHoldingRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byteData : Byte
) : bool

Parameters

i_iStartIndex
The starting register address (The base is 1).
i_iTotalPoint
The number of register for reading.
o_byteData
The raw byte data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadHoldingRegs Overload List


ReadHoldingRegs Method (Int32, Int32, Int32)

Modbus.ReadHoldingRegs Method (Int32, Int32, Int32)
See Also Example
[image]

Modbus function(03) Read holding registers Reads the integer contents of holding registers (4X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadHoldingRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_iData As Integer _
) As Boolean
C#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
out int o_iData
)
C++
public:
bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] int% o_iData
) sealed
J#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ int o_iData
)
JScript
public function ReadHoldingRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_iData : int
) : bool

Parameters

i_iStartIndex
The starting register addres (The base is 1).
i_iTotalPoint
The number of register for reading.
o_iData
The data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadHoldingRegs Overload List


ReadHoldingRegs Method (Int32, Int32, UInt32)

Modbus.ReadHoldingRegs Method (Int32, Int32, UInt32)
See Also Example
[image]

Modbus function(03) Read holding registers Reads the integer contents of holding registers (4X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadHoldingRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_uiData As UInt32 _
) As Boolean
C#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
out uint o_uiData
)
C++
public:
bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] unsigned int% o_uiData
) sealed
J#
public bool ReadHoldingRegs(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ uint o_uiData
)
JScript
public function ReadHoldingRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_uiData : UInt32
) : bool

Parameters

i_iStartIndex
The starting register address (The base is 1).
i_iTotalPoint
The number of register for reading.
o_uiData
The UINT32 data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadHoldingRegs Overload List


ReadInputRegs Method

Modbus.ReadInputRegs Method

Modbus function(04) Read input registers Reads the binary contents of input registers (3X references) in the slave.

Overload List

 | Name | Description
Public method | ReadInputRegs (Int32, Int32, Byte) | Modbus function(04) Read input registers Reads the binary contents of input registers (3X references) in the slave.
Public method | ReadInputRegs (Int32, Int32, Int32) | Modbus function(04) Read input registers Reads the integer contents of input registers (3X references) in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


ReadInputRegs Method (Int32, Int32, Byte)

Modbus.ReadInputRegs Method (Int32, Int32, Byte)
See Also Example
[image]

Modbus function(04) Read input registers Reads the binary contents of input registers (3X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInputRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byteData As Byte _
) As Boolean
C#
public bool ReadInputRegs(
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byteData
)
C++
public:
bool ReadInputRegs(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byteData
) sealed
J#
public bool ReadInputRegs(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byteData
)
JScript
public function ReadInputRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byteData : Byte
) : bool

Parameters

i_iStartIndex
The starting register address (The base is 1).
i_iTotalPoint
The number of register for reading.
o_byteData
The raw byte data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadInputRegs Overload List


ReadInputRegs Method (Int32, Int32, Int32)

Modbus.ReadInputRegs Method (Int32, Int32, Int32)
See Also Example
[image]

Modbus function(04) Read input registers Reads the integer contents of input registers (3X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInputRegs( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_iData As Integer _
) As Boolean
C#
public bool ReadInputRegs(
int i_iStartIndex,
int i_iTotalPoint,
out int o_iData
)
C++
public:
bool ReadInputRegs(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] int% o_iData
) sealed
J#
public bool ReadInputRegs(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ int o_iData
)
JScript
public function ReadInputRegs(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_iData : int
) : bool

Parameters

i_iStartIndex
The starting register addres (The base is 1).
i_iTotalPoint
The number of register for reading.
o_iData
The data of register received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadInputRegs Overload List


ReadInputStatus Method

Modbus.ReadInputStatus Method

Modbus function(02) Read input status Reads the ON/OFF status of discrete inputs (1X references) in the slave.

Overload List

 | Name | Description
Public method | ReadInputStatus (Int32, Int32, Boolean) | Modbus function(02) Read input status Reads the ON/OFF status of discrete inputs (1X references) in the slave.
Public method | ReadInputStatus (Int32, Int32, Byte) | Modbus function(02) Read input status Reads the ON/OFF status of discrete inputs (1X references) in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


ReadInputStatus Method (Int32, Int32, Boolean)

Modbus.ReadInputStatus Method (Int32, Int32, Boolean)
See Also Example
[image]

Modbus function(02) Read input status Reads the ON/OFF status of discrete inputs (1X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInputStatus( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_bInputStatus As Boolean _
) As Boolean
C#
public bool ReadInputStatus(
int i_iStartIndex,
int i_iTotalPoint,
out bool o_bInputStatus
)
C++
public:
bool ReadInputStatus(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] bool% o_bInputStatus
) sealed
J#
public bool ReadInputStatus(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ bool o_bInputStatus
)
JScript
public function ReadInputStatus(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_bInputStatus : bool
) : bool

Parameters

i_iStartIndex
The starting coil addres (The base is 1).
i_iTotalPoint
The number of coil for reading.
o_bInputStatus
The parsed boolean of input status received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadInputStatus Overload List


ReadInputStatus Method (Int32, Int32, Byte)

Modbus.ReadInputStatus Method (Int32, Int32, Byte)
See Also Example
[image]

Modbus function(02) Read input status Reads the ON/OFF status of discrete inputs (1X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInputStatus( _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byteInputStatus As Byte _
) As Boolean
C#
public bool ReadInputStatus(
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byteInputStatus
)
C++
public:
bool ReadInputStatus(
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byteInputStatus
) sealed
J#
public bool ReadInputStatus(
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byteInputStatus
)
JScript
public function ReadInputStatus(
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byteInputStatus : Byte
) : bool

Parameters

i_iStartIndex
The starting coil addres (The base is 1).
i_iTotalPoint
The number of coil for reading.
o_byteInputStatus
The raw byte data of input status received.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.ReadInputStatus Overload List


WriteAdvantechRegs Method

Modbus.WriteAdvantechRegs Method

Modbus function(21) Write Advantech registers Writes the binary contents of Advantech registers (21X references) in the slave.

Overload List

 | Name | Description
Public method | WriteAdvantechRegs (Int32, Int32, Int32, Byte) | Modbus function(21) Write Advantech registers Writes the binary contents of Advantech registers (21X references) in the slave.
Public method | WriteAdvantechRegs (Int32, Int32) | Modbus function(21) Write Advantech registers Writes the integer contents of Advantech registers (21X references) in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


WriteAdvantechRegs Method (Int32, Int32, Int32, Byte[])

Modbus.WriteAdvantechRegs Method (Int32, Int32, Int32, Byte[])
See Also Example
[image]

Modbus function(21) Write Advantech registers Writes the binary contents of Advantech registers (21X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function WriteAdvantechRegs( _
ByVal i_iStartAddr As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte() _
) As Boolean
C#
public bool WriteAdvantechRegs(
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData
)
C++
public:
bool WriteAdvantechRegs(
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData
) sealed
J#
public bool WriteAdvantechRegs(
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData
)
JScript
public function WriteAdvantechRegs(
i_iStartAddr : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[]
) : bool

Parameters

i_iStartAddr
The starting register address (The base is 1).
i_iTotalReg
The total of register for setting.
i_iTotalByte
The total of byte for setting.
i_byData
The byte data for setting registers.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.WriteAdvantechRegs Overload List


WriteAdvantechRegs Method (Int32, Int32[])

Modbus.WriteAdvantechRegs Method (Int32, Int32[])
See Also Example
[image]

Modbus function(21) Write Advantech registers Writes the integer contents of Advantech registers (21X references) in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function WriteAdvantechRegs( _
ByVal i_iStartAddr As Integer, _
ByVal i_iData As Integer() _
) As Boolean
C#
public bool WriteAdvantechRegs(
int i_iStartAddr,
int[] i_iData
)
C++
public:
bool WriteAdvantechRegs(
int i_iStartAddr,
array<int>^ i_iData
) sealed
J#
public bool WriteAdvantechRegs(
int i_iStartAddr,
int[] i_iData
)
JScript
public function WriteAdvantechRegs(
i_iStartAddr : int,
i_iData : int[]
) : bool

Parameters

i_iStartAddr
The starting register address (The base is 1).
i_iData
The array of data for setting registers. The value is from 0~65535.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.WriteAdvantechRegs Overload List


WriteCustomizeRegs Method

Modbus.WriteCustomizeRegs Method

Modbus function Write customize registers Writes the binary contents of customize registers in the slave.

Overload List

 | Name | Description
Public method | WriteCustomizeRegs (Int32, Int32, Int32, Int32, Byte) | Modbus function Write customize registers Writes the binary contents of customize registers in the slave.
Public method | WriteCustomizeRegs (Int32, Int32, Int32) | Modbus function Write customize registers Writes the integer contents of customize registers in the slave.

See Also

Modbus Class
Advantech.Adam Namespace


WriteCustomizeRegs Method (Int32, Int32, Int32, Int32, Byte[])

Modbus.WriteCustomizeRegs Method (Int32, Int32, Int32, Int32, Byte[])
See Also Example
[image]

Modbus function Write customize registers Writes the binary contents of customize registers in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function WriteCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iStartAddr As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte() _
) As Boolean
C#
public bool WriteCustomizeRegs(
int i_iCommand,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData
)
C++
public:
bool WriteCustomizeRegs(
int i_iCommand,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData
) sealed
J#
public bool WriteCustomizeRegs(
int i_iCommand,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData
)
JScript
public function WriteCustomizeRegs(
i_iCommand : int,
i_iStartAddr : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[]
) : bool

Parameters

i_iCommand
Customize command.
i_iStartAddr
The starting register addres (The base is 1).
i_iTotalReg
The total of register for setting.
i_iTotalByte
The total of byte for setting.
i_byData
The byte data for setting registers.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.WriteCustomizeRegs Overload List


WriteCustomizeRegs Method (Int32, Int32, Int32[])

Modbus.WriteCustomizeRegs Method (Int32, Int32, Int32[])
See Also Example
[image]

Modbus function Write customize registers Writes the integer contents of customize registers in the slave.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function WriteCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iStartAddr As Integer, _
ByVal i_iData As Integer() _
) As Boolean
C#
public bool WriteCustomizeRegs(
int i_iCommand,
int i_iStartAddr,
int[] i_iData
)
C++
public:
bool WriteCustomizeRegs(
int i_iCommand,
int i_iStartAddr,
array<int>^ i_iData
) sealed
J#
public bool WriteCustomizeRegs(
int i_iCommand,
int i_iStartAddr,
int[] i_iData
)
JScript
public function WriteCustomizeRegs(
i_iCommand : int,
i_iStartAddr : int,
i_iData : int[]
) : bool

Parameters

i_iCommand
Customize command
i_iStartAddr
The starting register addres (The base is 1).
i_iData
The array of data for setting registers. The value is from 0~65535.

Return Value

True, if successed, otherwise false.

See Also

Modbus Class
Advantech.Adam Namespace
Modbus.WriteCustomizeRegs Overload List


ModuleControlCmdType Enumeration

ModuleControlCmdType Enumeration
[image]

The type for setting Module Control Command by UDP broadcast

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum ModuleControlCmdType
C#
public enum ModuleControlCmdType
C++
public enum class ModuleControlCmdType
J#
public enum ModuleControlCmdType
JScript
public enum ModuleControlCmdType

Members

Member Name | Description
LocateModule | Locate Module
ResetPassword | Reset Password

See Also

Advantech.Adam Namespace


P2P_Config Class

P2P_Config Class
See Also Example Members
[image]

Peer to Peer Configuration Class

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class P2P_Config
C#
public class P2P_Config
C++
ref class P2P_Config
J#
public class P2P_Config
JScript
public class P2P_Config

Inheritance Hierarchy

System.Object
Advantech.Adam.P2P_Config

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

P2P_Config Members
Advantech.Adam Namespace


P2P_Config Members

P2P_Config Members
See Also Example Constructors Fields
[image]

Peer to Peer Configuration Class

The following tables list the members exposed by P2P_Config.

Public Constructors

 | Name | Description
Public method | P2P_Config | Constructer
Top

Public Fields

 | Name | Description
Public field | ByteCnt | Byte count
Public field | ChannelMask | Channel Mask
Public field | COS_Flag | Peer to peer change of state (C.O.S) flag
Public field | Data | Peer to peer IO data
Public field | FunCode | Peer to Peer function code
Public field | NoChannels | No. of Channel
Public field | NoFollowBytes | No. of followed bytes
Public field | P2PMode | P2P mode
Public field | PackageNum | PackageNum
Public field | SlaveAddr | Slave address
Public field | SourceIP | Source IPEndPoint address information
Public field | TargetStrAddr | Target start address
Top

See Also

P2P_Config Class
Advantech.Adam Namespace


P2P_Config Constructor

P2P_Config Constructor
[image]

Constructer

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public P2P_Config()
C++
public:
P2P_Config() sealed
J#
public P2P_Config()
JScript
public function P2P_Config()

See Also

P2P_Config Class
Advantech.Adam Namespace


Fields

P2P_Config Fields
[image]

Public Fields

 | Name | Description
Public field | ByteCnt | Byte count
Public field | ChannelMask | Channel Mask
Public field | COS_Flag | Peer to peer change of state (C.O.S) flag
Public field | Data | Peer to peer IO data
Public field | FunCode | Peer to Peer function code
Public field | NoChannels | No. of Channel
Public field | NoFollowBytes | No. of followed bytes
Public field | P2PMode | P2P mode
Public field | PackageNum | PackageNum
Public field | SlaveAddr | Slave address
Public field | SourceIP | Source IPEndPoint address information
Public field | TargetStrAddr | Target start address
Top

See Also

P2P_Config Class
Advantech.Adam Namespace


ByteCnt Field

P2P_Config.ByteCnt Field
[image]

Byte count

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ByteCnt As Byte
C#
public byte ByteCnt;
C++
public:
char ByteCnt sealed ;
J#
public byte ByteCnt
JScript
public ByteCnt : Byte;

See Also

P2P_Config Class
Advantech.Adam Namespace


ChannelMask Field

P2P_Config.ChannelMask Field
[image]

Channel Mask

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public ChannelMask As UInt32
C#
public uint ChannelMask;
C++
public:
unsigned int ChannelMask sealed ;
J#
public uint ChannelMask
JScript
public ChannelMask : UInt32;

See Also

P2P_Config Class
Advantech.Adam Namespace


COS_Flag Field

P2P_Config.COS_Flag Field
[image]

Peer to peer change of state (C.O.S) flag

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public COS_Flag As Byte()
C#
public byte[] COS_Flag;
C++
public:
array<char>^ COS_Flag sealed ;
J#
public byte[] COS_Flag
JScript
public COS_Flag : Byte[];

See Also

P2P_Config Class
Advantech.Adam Namespace


Data Field

P2P_Config.Data Field
[image]

Peer to peer IO data

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Data As Byte()
C#
public byte[] Data;
C++
public:
array<char>^ Data sealed ;
J#
public byte[] Data
JScript
public Data : Byte[];

See Also

P2P_Config Class
Advantech.Adam Namespace


FunCode Field

P2P_Config.FunCode Field
[image]

Peer to Peer function code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public FunCode As Byte
C#
public byte FunCode;
C++
public:
char FunCode sealed ;
J#
public byte FunCode
JScript
public FunCode : Byte;

See Also

P2P_Config Class
Advantech.Adam Namespace


NoChannels Field

P2P_Config.NoChannels Field
[image]

No. of Channel

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public NoChannels As Integer
C#
public int NoChannels;
C++
public:
int NoChannels sealed ;
J#
public int NoChannels
JScript
public NoChannels : int;

See Also

P2P_Config Class
Advantech.Adam Namespace


NoFollowBytes Field

P2P_Config.NoFollowBytes Field
[image]

No. of followed bytes

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public NoFollowBytes As Byte
C#
public byte NoFollowBytes;
C++
public:
char NoFollowBytes sealed ;
J#
public byte NoFollowBytes
JScript
public NoFollowBytes : Byte;

See Also

P2P_Config Class
Advantech.Adam Namespace


P2PMode Field

P2P_Config.P2PMode Field
[image]

P2P mode

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public P2PMode As Byte
C#
public byte P2PMode;
C++
public:
char P2PMode sealed ;
J#
public byte P2PMode
JScript
public P2PMode : Byte;

See Also

P2P_Config Class
Advantech.Adam Namespace


PackageNum Field

P2P_Config.PackageNum Field
[image]

PackageNum

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public PackageNum As Integer
C#
public int PackageNum;
C++
public:
int PackageNum sealed ;
J#
public int PackageNum
JScript
public PackageNum : int;

See Also

P2P_Config Class
Advantech.Adam Namespace


SlaveAddr Field

P2P_Config.SlaveAddr Field
[image]

Slave address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public SlaveAddr As Byte
C#
public byte SlaveAddr;
C++
public:
char SlaveAddr sealed ;
J#
public byte SlaveAddr
JScript
public SlaveAddr : Byte;

See Also

P2P_Config Class
Advantech.Adam Namespace


SourceIP Field

P2P_Config.SourceIP Field
[image]

Source IPEndPoint address information

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public SourceIP As IPEndPoint
C#
public IPEndPoint SourceIP;
C++
public:
IPEndPoint SourceIP sealed ;
J#
public IPEndPoint SourceIP
JScript
public SourceIP : IPEndPoint;

See Also

P2P_Config Class
Advantech.Adam Namespace


TargetStrAddr Field

P2P_Config.TargetStrAddr Field
[image]

Target start address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public TargetStrAddr As Integer
C#
public int TargetStrAddr;
C++
public:
int TargetStrAddr sealed ;
J#
public int TargetStrAddr
JScript
public TargetStrAddr : int;

See Also

P2P_Config Class
Advantech.Adam Namespace


P2P_FunctionCode Enumeration

P2P_FunctionCode Enumeration
[image]

P2P: function code

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum P2P_FunctionCode As Byte
C#
public enum P2P_FunctionCode : byte
C++
public enum class P2P_FunctionCode : char
J#
public enum P2P_FunctionCode byte
JScript
public enum P2P_FunctionCode :

Members

Member Name | Description
DIO_ADV_MODE | For advanced DIO
DIO_BASIC_MODE | For basic DIO
AIO_MODE | For AIO

See Also

Advantech.Adam Namespace


P2P_InfoIdx Enumeration

P2P_InfoIdx Enumeration
[image]

P2P: data format start index

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum P2P_InfoIdx As Byte
C#
public enum P2P_InfoIdx : byte
C++
public enum class P2P_InfoIdx : char
J#
public enum P2P_InfoIdx byte
JScript
public enum P2P_InfoIdx :

Members

Member Name | Description
Header0 | Header0: #
Header1 | Header1: 1
Header2 | Header2: R
Header3 | Header3: R
Header4 | Header4: d
Header5 | Header5: F
Header6 | Header6: F
Header7 | Header7: F
Header8 | Header8: F
ChMask3 | Channel mask : Ch31~24
ChMask2 | Channel mask : Ch23~16
ChMask1 | Channel mask : Ch15~08
ChMask0 | Channel mask : Ch07~00
NoFollowBytes | No. of followed bytes
SlaveAddr | Slave address
FunCode | Peer to Peer Function code
TStrAddrH | Target start address (High byte)
TStrAddrL | Target start address (Low byte)
NoChH | No. of Channel (High byte)
NoChL | No. of Channel (Low byte)
ByteCnt | Byte count
IODataStart | Data start index
IODataStart_DIO_ADV_MODE | Data start index for "DIO_ADV_MODE"

See Also

Advantech.Adam Namespace


P2P_Mode Enumeration

P2P_Mode Enumeration
[image]

P2P mode: Basic or Advanced

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum P2P_Mode As Byte
C#
public enum P2P_Mode : byte
C++
public enum class P2P_Mode : char
J#
public enum P2P_Mode byte
JScript
public enum P2P_Mode :

Members

Member Name | Description
Basic | Basic
Advanced | Advanced

See Also

Advantech.Adam Namespace


PID Class

PID Class
See Also Example Members
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Class PID
Inherits AdamBase
C#
public class PID : AdamBase
C++
ref class PID : AdamBase
J#
public class PID extends AdamBase
JScript
public class PID extends AdamBase

Inheritance Hierarchy

System.Object
Advantech.Adam.AdamBase
Advantech.Adam.PID

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PID Members
Advantech.Adam Namespace


PID Members

PID Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by PID.

Public Constructors

Name | Description
PID | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | m_numberFormatInfo | The number format information for ADAM modules (inherited from AdamBase)
Top

Public Properties

 | Name | Description
Public property | AdamSeriesType | The Adam series type (inherited from AdamBase)
Public property | Address | The slave address. (inherited from AdamBase)
Public property | ApiLastError | The API last error code when API function return error code. (inherited from AdamBase)
Public property | Handle | The controller driver handle. (inherited from AdamBase)
Public property | LastError | The last error code when function return false. (inherited from AdamBase)
Top

Public Methods

 | Name | Description
Public method | AsciiBufferToModule | Support module: ADAM-4022T, ADAM-6022. Force to update the PID values of a loop from the buffer to the module by Advantech ASCII protocol.
Public method | AsciiGetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by Advantech ASCII protocol.
Public method | AsciiRefreshBuffer | Support module: ADAM-4022T, ADAM-6022. Force to read the PID values of a loop into the object buffer by Advantech ASCII protocol.
Public method | AsciiSetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by Advantech ASCII protocol.
Public method | GetBufferFloat | Support module: ADAM-4022T, ADAM-6022. Get PID float value from buffer.
Public method | GetBufferInt | Support module: ADAM-4022T, ADAM-6022. Get PID integer value from buffer.
Public method | ModbusBufferToModule | Support module: ADAM-4022T, ADAM-6022. Force to update the PID values of a loop from the buffer to the module by MODBUS protocol.
Public method | ModbusGetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by MODBUS protocol.
Public method | ModbusRefreshBuffer | Support module: ADAM-4022T, ADAM-6022. Force to read the PID values of a loop into the object buffer by MODBUS protocol.
Public method | ModbusSetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by MODBUS protocol.
Public method | SetBufferFloat | Support module: ADAM-4022T, ADAM-6022. Set PID float value to buffer.
Public method | SetBufferInt | Support module: ADAM-4022T, ADAM-6022. Set PID integer value to buffer.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

Explicit Interface Implementations

Name | Description
PID | Overloaded.
Top

See Also

PID Class
Advantech.Adam Namespace


PID Constructor

PID Constructor

Overload List

 | Name | Description
Public method | PID (AdamCom) | The PID constructor.
Public method | PID (AdamSocket) | The PID constructor.

See Also

PID Class
Advantech.Adam Namespace


PID Constructor (AdamCom)

PID Constructor (AdamCom)
See Also Example
[image]

The PID constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_com As AdamCom _
)
C#
public PID(
AdamCom i_com
)
C++
public:
PID(
AdamCom i_com
) sealed
J#
public PID(
AdamCom i_com
)
JScript
public function PID(
i_com : AdamCom
)

Parameters

i_com
The AdamCom object

See Also

PID Class
Advantech.Adam Namespace
PID Constructor Overload List


PID Constructor (AdamSocket)

PID Constructor (AdamSocket)
See Also Example
[image]

The PID constructor.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_socket As AdamSocket _
)
C#
public PID(
AdamSocket i_socket
)
C++
public:
PID(
AdamSocket i_socket
) sealed
J#
public PID(
AdamSocket i_socket
)
JScript
public function PID(
i_socket : AdamSocket
)

Parameters

i_socket
The AdamSocket object

See Also

PID Class
Advantech.Adam Namespace
PID Constructor Overload List


Methods

PID Methods
[image]

Public Methods

 | Name | Description
Public method | AsciiBufferToModule | Support module: ADAM-4022T, ADAM-6022. Force to update the PID values of a loop from the buffer to the module by Advantech ASCII protocol.
Public method | AsciiGetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by Advantech ASCII protocol.
Public method | AsciiRefreshBuffer | Support module: ADAM-4022T, ADAM-6022. Force to read the PID values of a loop into the object buffer by Advantech ASCII protocol.
Public method | AsciiSetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by Advantech ASCII protocol.
Public method | GetBufferFloat | Support module: ADAM-4022T, ADAM-6022. Get PID float value from buffer.
Public method | GetBufferInt | Support module: ADAM-4022T, ADAM-6022. Get PID integer value from buffer.
Public method | ModbusBufferToModule | Support module: ADAM-4022T, ADAM-6022. Force to update the PID values of a loop from the buffer to the module by MODBUS protocol.
Public method | ModbusGetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by MODBUS protocol.
Public method | ModbusRefreshBuffer | Support module: ADAM-4022T, ADAM-6022. Force to read the PID values of a loop into the object buffer by MODBUS protocol.
Public method | ModbusSetValue | Overloaded. Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by MODBUS protocol.
Public method | SetBufferFloat | Support module: ADAM-4022T, ADAM-6022. Set PID float value to buffer.
Public method | SetBufferInt | Support module: ADAM-4022T, ADAM-6022. Set PID integer value to buffer.
Top

Protected Methods

 | Name | Description
Family method | ASCIISendRecv | Send and receive ADAM ASCII command (inherited from AdamBase)
Family method | GetProtocolType | Get socket protocol type (inherited from AdamBase)
Top

See Also

PID Class
Advantech.Adam Namespace


AsciiBufferToModule Method

PID.AsciiBufferToModule Method
[image]

Support module: ADAM-4022T, ADAM-6022. Force to update the PID values of a loop from the buffer to the module by Advantech ASCII protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AsciiBufferToModule( _
ByVal i_loop As PID_Loop _
) As Boolean
C#
public bool AsciiBufferToModule(
PID_Loop i_loop
)
C++
public:
bool AsciiBufferToModule(
PID_Loop i_loop
) sealed
J#
public bool AsciiBufferToModule(
PID_Loop i_loop
)
JScript
public function AsciiBufferToModule(
i_loop : PID_Loop
) : bool

Parameters

i_loop
The PID loop index.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace


AsciiGetValue Method

PID.AsciiGetValue Method

Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by Advantech ASCII protocol.

Overload List

 | Name | Description
Public method | AsciiGetValue (PID_Loop, PID_Addr, Int32) | Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by Advantech ASCII protocol.
Public method | AsciiGetValue (PID_Loop, PID_Addr, Single) | Support module: ADAM-4022T, ADAM-6022. Get the PID float value from the module by Advantech ASCII protocol.

See Also

PID Class
Advantech.Adam Namespace


AsciiGetValue Method (PID_Loop, PID_Addr, Int32)

PID.AsciiGetValue Method (PID_Loop, PID_Addr, Int32)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by Advantech ASCII protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AsciiGetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
<OutAttribute> ByRef o_iValue As Integer _
) As Boolean
C#
public bool AsciiGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
out int o_iValue
)
C++
public:
bool AsciiGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
[OutAttribute] int% o_iValue
) sealed
J#
public bool AsciiGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
/** @attribute OutAttribute() */ /** @ref */ int o_iValue
)
JScript
public function AsciiGetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
OutAttribute o_iValue : int
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
o_iValue
The PID integer value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.AsciiGetValue Overload List


AsciiGetValue Method (PID_Loop, PID_Addr, Single)

PID.AsciiGetValue Method (PID_Loop, PID_Addr, Single)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Get the PID float value from the module by Advantech ASCII protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AsciiGetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool AsciiGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
out float o_fValue
)
C++
public:
bool AsciiGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
[OutAttribute] float% o_fValue
) sealed
J#
public bool AsciiGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function AsciiGetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
OutAttribute o_fValue : float
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
o_fValue
The PID float value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.AsciiGetValue Overload List


AsciiRefreshBuffer Method

PID.AsciiRefreshBuffer Method
[image]

Support module: ADAM-4022T, ADAM-6022. Force to read the PID values of a loop into the object buffer by Advantech ASCII protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AsciiRefreshBuffer( _
ByVal i_loop As PID_Loop _
) As Boolean
C#
public bool AsciiRefreshBuffer(
PID_Loop i_loop
)
C++
public:
bool AsciiRefreshBuffer(
PID_Loop i_loop
) sealed
J#
public bool AsciiRefreshBuffer(
PID_Loop i_loop
)
JScript
public function AsciiRefreshBuffer(
i_loop : PID_Loop
) : bool

Parameters

i_loop
The PID loop index.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace


AsciiSetValue Method

PID.AsciiSetValue Method

Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by Advantech ASCII protocol.

Overload List

 | Name | Description
Public method | AsciiSetValue (PID_Loop, PID_Addr, Int32) | Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by Advantech ASCII protocol.
Public method | AsciiSetValue (PID_Loop, PID_Addr, Single) | Support module: ADAM-4022T, ADAM-6022. Set the PID float value to the module by Advantech ASCII protocol.

See Also

PID Class
Advantech.Adam Namespace


AsciiSetValue Method (PID_Loop, PID_Addr, Int32)

PID.AsciiSetValue Method (PID_Loop, PID_Addr, Int32)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by Advantech ASCII protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AsciiSetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
ByVal i_iValue As Integer _
) As Boolean
C#
public bool AsciiSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
)
C++
public:
bool AsciiSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
) sealed
J#
public bool AsciiSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
)
JScript
public function AsciiSetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
i_iValue : int
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
i_iValue
The PID integer value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.AsciiSetValue Overload List


AsciiSetValue Method (PID_Loop, PID_Addr, Single)

PID.AsciiSetValue Method (PID_Loop, PID_Addr, Single)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Set the PID float value to the module by Advantech ASCII protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function AsciiSetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool AsciiSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
)
C++
public:
bool AsciiSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
) sealed
J#
public bool AsciiSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
)
JScript
public function AsciiSetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
i_fValue : float
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
i_fValue
The PID float value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.AsciiSetValue Overload List


GetBufferFloat Method

PID.GetBufferFloat Method
[image]

Support module: ADAM-4022T, ADAM-6022. Get PID float value from buffer.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBufferFloat( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr _
) As Single
C#
public float GetBufferFloat(
PID_Loop i_loop,
PID_Addr i_addr
)
C++
public:
float GetBufferFloat(
PID_Loop i_loop,
PID_Addr i_addr
) sealed
J#
public float GetBufferFloat(
PID_Loop i_loop,
PID_Addr i_addr
)
JScript
public function GetBufferFloat(
i_loop : PID_Loop,
i_addr : PID_Addr
) : float

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.

Return Value

Return The PID float value.

See Also

PID Class
Advantech.Adam Namespace


GetBufferInt Method

PID.GetBufferInt Method
[image]

Support module: ADAM-4022T, ADAM-6022. Get PID integer value from buffer.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBufferInt( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr _
) As Integer
C#
public int GetBufferInt(
PID_Loop i_loop,
PID_Addr i_addr
)
C++
public:
int GetBufferInt(
PID_Loop i_loop,
PID_Addr i_addr
) sealed
J#
public int GetBufferInt(
PID_Loop i_loop,
PID_Addr i_addr
)
JScript
public function GetBufferInt(
i_loop : PID_Loop,
i_addr : PID_Addr
) : int

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.

Return Value

Return The PID integer value.

See Also

PID Class
Advantech.Adam Namespace


ModbusBufferToModule Method

PID.ModbusBufferToModule Method
[image]

Support module: ADAM-4022T, ADAM-6022. Force to update the PID values of a loop from the buffer to the module by MODBUS protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ModbusBufferToModule( _
ByVal i_loop As PID_Loop _
) As Boolean
C#
public bool ModbusBufferToModule(
PID_Loop i_loop
)
C++
public:
bool ModbusBufferToModule(
PID_Loop i_loop
) sealed
J#
public bool ModbusBufferToModule(
PID_Loop i_loop
)
JScript
public function ModbusBufferToModule(
i_loop : PID_Loop
) : bool

Parameters

i_loop
The PID loop index.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace


ModbusGetValue Method

PID.ModbusGetValue Method

Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by MODBUS protocol.

Overload List

 | Name | Description
Public method | ModbusGetValue (PID_Loop, PID_Addr, Int32) | Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by MODBUS protocol.
Public method | ModbusGetValue (PID_Loop, PID_Addr, Single) | Support module: ADAM-4022T, ADAM-6022. Get the PID float value from the module by MODBUS protocol.

See Also

PID Class
Advantech.Adam Namespace


ModbusGetValue Method (PID_Loop, PID_Addr, Int32)

PID.ModbusGetValue Method (PID_Loop, PID_Addr, Int32)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Get the PID integer value from the module by MODBUS protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ModbusGetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
<OutAttribute> ByRef o_iValue As Integer _
) As Boolean
C#
public bool ModbusGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
out int o_iValue
)
C++
public:
bool ModbusGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
[OutAttribute] int% o_iValue
) sealed
J#
public bool ModbusGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
/** @attribute OutAttribute() */ /** @ref */ int o_iValue
)
JScript
public function ModbusGetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
OutAttribute o_iValue : int
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
o_iValue
The PID integer value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.ModbusGetValue Overload List


ModbusGetValue Method (PID_Loop, PID_Addr, Single)

PID.ModbusGetValue Method (PID_Loop, PID_Addr, Single)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Get the PID float value from the module by MODBUS protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ModbusGetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
<OutAttribute> ByRef o_fValue As Single _
) As Boolean
C#
public bool ModbusGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
out float o_fValue
)
C++
public:
bool ModbusGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
[OutAttribute] float% o_fValue
) sealed
J#
public bool ModbusGetValue(
PID_Loop i_loop,
PID_Addr i_addr,
/** @attribute OutAttribute() */ /** @ref */ float o_fValue
)
JScript
public function ModbusGetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
OutAttribute o_fValue : float
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
o_fValue
The PID float value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.ModbusGetValue Overload List


ModbusRefreshBuffer Method

PID.ModbusRefreshBuffer Method
[image]

Support module: ADAM-4022T, ADAM-6022. Force to read the PID values of a loop into the object buffer by MODBUS protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ModbusRefreshBuffer( _
ByVal i_loop As PID_Loop _
) As Boolean
C#
public bool ModbusRefreshBuffer(
PID_Loop i_loop
)
C++
public:
bool ModbusRefreshBuffer(
PID_Loop i_loop
) sealed
J#
public bool ModbusRefreshBuffer(
PID_Loop i_loop
)
JScript
public function ModbusRefreshBuffer(
i_loop : PID_Loop
) : bool

Parameters

i_loop
The PID loop index.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace


ModbusSetValue Method

PID.ModbusSetValue Method

Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by MODBUS protocol.

Overload List

 | Name | Description
Public method | ModbusSetValue (PID_Loop, PID_Addr, Int32) | Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by MODBUS protocol.
Public method | ModbusSetValue (PID_Loop, PID_Addr, Single) | Support module: ADAM-4022T, ADAM-6022. Set the PID float value to the module by MODBUS protocol.

See Also

PID Class
Advantech.Adam Namespace


ModbusSetValue Method (PID_Loop, PID_Addr, Int32)

PID.ModbusSetValue Method (PID_Loop, PID_Addr, Int32)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Set the PID integer value to the module by MODBUS protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ModbusSetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
ByVal i_iValue As Integer _
) As Boolean
C#
public bool ModbusSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
)
C++
public:
bool ModbusSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
) sealed
J#
public bool ModbusSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
)
JScript
public function ModbusSetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
i_iValue : int
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
i_iValue
The PID integer value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.ModbusSetValue Overload List


ModbusSetValue Method (PID_Loop, PID_Addr, Single)

PID.ModbusSetValue Method (PID_Loop, PID_Addr, Single)
See Also Example
[image]

Support module: ADAM-4022T, ADAM-6022. Set the PID float value to the module by MODBUS protocol.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Function ModbusSetValue( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
ByVal i_fValue As Single _
) As Boolean
C#
public bool ModbusSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
)
C++
public:
bool ModbusSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
) sealed
J#
public bool ModbusSetValue(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
)
JScript
public function ModbusSetValue(
i_loop : PID_Loop,
i_addr : PID_Addr,
i_fValue : float
) : bool

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
i_fValue
The PID float value.

Return Value

Return true if success, otherwise return false.

See Also

PID Class
Advantech.Adam Namespace
PID.ModbusSetValue Overload List


SetBufferFloat Method

PID.SetBufferFloat Method
[image]

Support module: ADAM-4022T, ADAM-6022. Set PID float value to buffer.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetBufferFloat( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
ByVal i_fValue As Single _
)
C#
public void SetBufferFloat(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
)
C++
public:
void SetBufferFloat(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
) sealed
J#
public void SetBufferFloat(
PID_Loop i_loop,
PID_Addr i_addr,
float i_fValue
)
JScript
public function SetBufferFloat(
i_loop : PID_Loop,
i_addr : PID_Addr,
i_fValue : float
)

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
i_fValue
The PID float value.

Return Value

Return The PID integer value.

See Also

PID Class
Advantech.Adam Namespace


SetBufferInt Method

PID.SetBufferInt Method
[image]

Support module: ADAM-4022T, ADAM-6022. Set PID integer value to buffer.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetBufferInt( _
ByVal i_loop As PID_Loop, _
ByVal i_addr As PID_Addr, _
ByVal i_iValue As Integer _
)
C#
public void SetBufferInt(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
)
C++
public:
void SetBufferInt(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
) sealed
J#
public void SetBufferInt(
PID_Loop i_loop,
PID_Addr i_addr,
int i_iValue
)
JScript
public function SetBufferInt(
i_loop : PID_Loop,
i_addr : PID_Addr,
i_iValue : int
)

Parameters

i_loop
The PID loop index.
i_addr
The PID value address.
i_iValue
The PID integer value.

Return Value

Return The PID integer value.

See Also

PID Class
Advantech.Adam Namespace


PID_Addr Enumeration

PID_Addr Enumeration
[image]

The PID value address

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum PID_Addr As Byte
C#
public enum PID_Addr : byte
C++
public enum class PID_Addr : char
J#
public enum PID_Addr byte
JScript
public enum PID_Addr :

Members

Member Name | Description
ControlMode | PID control mode. (R/W, int)
PidMode | PID calculation mode. (R/W, int)
PvMode | PV mode (which PV to be used). (R/W, int)
Pv1BareData | first PV raw data. (R, float)
Pv2BareData | second PV bare data. (R, float)
MvBareData | MV bare data. (R, float)
DiStatus | DI current status. (R, int)
DoStatus | DO current status. (R, int)
Sv1 | SV for first PV. (R/W, float)
Sv2 | SV for second PV. (R/W, float)
Pv1RangeHigh | The scaled high bound of the first PV. (R/W, float)
Pv1RangeLow | The scaled low bound of the first PV. (R/W, float)
Pv2RangeHigh | The scaled high bound of the Second PV. (R/W, float)
Pv2RangeLow | The scaled low bound of the Second PV. (R/W, float)
MvRangeHigh | The scaled high bound of the MV. (R/W, float)
MvRangeLow | The scaled low bound of the MV. (R/W, float)
Pv1EngData | The engineering data for the first PV. (R, float)
Pv2EngData | The engineering data for the second PV. (R, float)
MvEngData | The engineering data for the MV. (R/W, float)
PvEngData | The engineering data of the current using PV. (R, float)
SvEngData | The engineering data of the current using MV. (R, float)
Pv1Filter | The filter value for the first PV. (R/W, float)
Pv2Filter | The filter value for the second PV. (R/W, float)
Pv1RangeCode | The range code for the first PV. (R, int)
Pv2RangeCode | The range code for the second PV. (R, int)
MvRangeCode | The range code for the MV. (R, int)
Pv1KP | The KP value for the first PV. (R/W, float)
Pv1KI | The KI value for the first PV. (R/W, float)
Pv1KD | The KD value for the first PV. (R/W, float)
Pv2KP | The KP value for the second PV. (R/W, float)
Pv2KI | The KI value for the second PV. (R/W, float)
Pv2KD | The KD value for the second PV. (R/W, float)
KP | The KP value for current using PV. (R, float)
KI | The KI value for current using PV. (R, float)
KD | The KD value for current using PV. (R, float)
Pv1CountdownInterval | The calculation count down interval for the first PV. (R/W, int)
Pv2CountdownInterval | The calculation count down interval for the second PV. (R/W, int)
CountdownInterval | The current using calculation count down interval. (R, int)
CurrentCountdown | The current using calculation count down value. (R, int)
LastControlMode | The last control mode. (R, int)
CurrentNsec | The current NSEC value. (R, int)
LastNsec | The last NSEC value. (R, int)
PowerupMode | The power up mode. (R/W, int)
MvInitValue | The MV value when power up. (R/W, float)
LastDiState | The last DI status. (R, int)
LastDoState | The last DO value. (R, int)
Pv1AlarmHH | The high-high alarm for the first PV. (R/W, float)
Pv1AlarmH | The high alarm for the first PV. (R/W, float)
Pv1AlarmLL | The low-low alarm for the first PV. (R/W, float)
Pv1AlarmL | The low alarm for the first PV. (R/W, float)
Pv1AlarmDeadband | The alarm deadband for the first PV. (R/W, float)
Pv1AlarmStatus | The alarm status for the first PV. (R, int)
Pv2AlarmHH | The high-high alarm for the Second PV. (R/W, float)
Pv2AlarmH | The high alarm for the Second PV. (R/W, float)
Pv2AlarmLL | The low-low alarm for the Second PV. (R/W, float)
Pv2AlarmL | The low alarm for the Second PV. (R/W, float)
Pv2AlarmDeadband | The alarm deadband for the second PV. (R/W, float)
Pv2AlarmStatus | The alarm status for the second PV. (R, int)
MvHighLimit | The high limit for MV. (R/W, float)
MvLowLimit | The low limit for MV. (R/W, float)
MvAlarmStatus | The MV alarm status, which triggered when MV exceed high or low limit. (R, int)
MvEmergencyValue | Emergency stop MV value. (R/W, float)
Pv1OpenWireFlag | The open-wire flag for the first PV. (R, int)
Pv2OpenWireFlag | The open-wire flag for the second PV. (R, int)
PidDirectReverse | The PID direct/reverse mode. (R/W, int)
Sv1HighLimit | The high limit for the first SV. (R/W, float)
Sv1LowLimit | The low limit for the first SV. (R/W, float)
Sv2HighLimit | The high limit for the second SV. (R/W, float)
Sv2LowLimit | The low limit for the second SV. (R/W, float)
AlarmMask | The DO alarm output mask. (R/W, int)

See Also

Advantech.Adam Namespace


PID_Loop Enumeration

PID_Loop Enumeration
[image]

The PID loop.

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Public Enum PID_Loop As Byte
C#
public enum PID_Loop : byte
C++
public enum class PID_Loop : char
J#
public enum PID_Loop byte
JScript
public enum PID_Loop :

Members

Member Name | Description
Loop0 | PID Loop-0
Loop1 | PID Loop-1

See Also

Advantech.Adam Namespace


SelfMarshalledStruct Class

SelfMarshalledStruct Class
See Also Example Members
[image]

This class implements base functionality for a bytearray-based structure

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class SelfMarshalledStruct
C#
[DefaultMemberAttribute("Item")]
public class SelfMarshalledStruct
C++
[DefaultMemberAttribute(L"Item")]
ref class SelfMarshalledStruct
J#
/** @attribute DefaultMemberAttribute("Item") */
public class SelfMarshalledStruct
JScript
public
DefaultMemberAttribute("Item")
class SelfMarshalledStruct

Inheritance Hierarchy

System.Object
Advantech.Adam.SelfMarshalledStruct
Advantech.Adam.Adam2000Config
Advantech.Adam.Apax5000Config

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SelfMarshalledStruct Members
Advantech.Adam Namespace


SelfMarshalledStruct Members

SelfMarshalledStruct Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

This class implements base functionality for a bytearray-based structure

The following tables list the members exposed by SelfMarshalledStruct.

Protected Constructors

Name | Description
SelfMarshalledStruct | Overloaded.
Top

Protected Fields

 | Name | Description
Family field | baseOffset |
Family field | data |
Top

Protected Properties

 | Name | Description
Family property | Data |
Family property | Item |
Top

Protected Methods

 | Name | Description
Family method | Get |
Family method | GetByte |
Family method | GetChar |
Family method | GetInt16 |
Family method | GetInt32 |
Family method | GetIntPtr |
Family method | GetSlice |
Family method | GetStringAscii |
Family method | GetStringUni |
Family method | GetUInt16 |
Family method | GetUInt32 |
Family method | Set |
Family method | SetByte |
Family method | SetChar |
Family method | SetInt16 |
Family method | SetInt32 |
Family method | SetIntPtr |
Family method | SetStringUni |
Family method | SetUInt16 |
Family method | SetUInt32 |
Top

Explicit Interface Implementations

Name | Description
SelfMarshalledStruct | Overloaded.
Top

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SelfMarshalledStruct Constructor

SelfMarshalledStruct Constructor

Overload List

 | Name | Description
Family method | SelfMarshalledStruct (Byte, Int32) |
Family method | SelfMarshalledStruct (Int32) |

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SelfMarshalledStruct Constructor (Byte[], Int32)

SelfMarshalledStruct Constructor (Byte[], Int32)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal data As Byte(), _
ByVal offset As Integer _
)
C#
protected SelfMarshalledStruct(
byte[] data,
int offset
)
C++
protected:
SelfMarshalledStruct(
array<char>^ data,
int offset
) sealed
J#
protected SelfMarshalledStruct(
byte[] data,
int offset
)
JScript
protected function SelfMarshalledStruct(
data : Byte[],
offset : int
)

Parameters

data
offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace
SelfMarshalledStruct Constructor Overload List


SelfMarshalledStruct Constructor (Int32)

SelfMarshalledStruct Constructor (Int32)
See Also Example
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal size As Integer _
)
C#
protected SelfMarshalledStruct(
int size
)
C++
protected:
SelfMarshalledStruct(
int size
) sealed
J#
protected SelfMarshalledStruct(
int size
)
JScript
protected function SelfMarshalledStruct(
size : int
)

Parameters

size

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace
SelfMarshalledStruct Constructor Overload List


Fields

SelfMarshalledStruct Fields
[image]

Protected Fields

 | Name | Description
Family field | baseOffset |
Family field | data |
Top

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


baseOffset Field

SelfMarshalledStruct.baseOffset Field
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected baseOffset As Integer
C#
protected int baseOffset;
C++
protected:
int baseOffset sealed ;
J#
protected int baseOffset
JScript
protected baseOffset : int;

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


data Field

SelfMarshalledStruct.data Field
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected data As Byte()
C#
protected byte[] data;
C++
protected:
array<char>^ data sealed ;
J#
protected byte[] data
JScript
protected data : Byte[];

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


Properties

SelfMarshalledStruct Properties
[image]

Protected Properties

 | Name | Description
Family property | Data |
Family property | Item |
Top

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


Data Property

SelfMarshalledStruct.Data Property
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Data As Byte()
C#
protected byte[] Data { get; }
C++
protected property byte[] Data sealed {
array<char>^ get();
}
J#
/** property */
protected byte[] get_Data();
JScript
protected function get Data() : Byte[]

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


Item Property

SelfMarshalledStruct.Item Property
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Default Property Item( _
ByVal offset As Integer _
) As Byte
C#
protected byte this[
int offset
] { get; set; }
C++
protected property byte default[int offset] sealed {
char get(int offset);
void set(int offset, char value);
}
J#
/** property */
protected byte get_Item(int offset);

/** property */
protected void set_Item(int offset, byte value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


Methods

SelfMarshalledStruct Methods
[image]

Protected Methods

 | Name | Description
Family method | Get |
Family method | GetByte |
Family method | GetChar |
Family method | GetInt16 |
Family method | GetInt32 |
Family method | GetIntPtr |
Family method | GetSlice |
Family method | GetStringAscii |
Family method | GetStringUni |
Family method | GetUInt16 |
Family method | GetUInt32 |
Family method | Set |
Family method | SetByte |
Family method | SetChar |
Family method | SetInt16 |
Family method | SetInt32 |
Family method | SetIntPtr |
Family method | SetStringUni |
Family method | SetUInt16 |
Family method | SetUInt32 |
Top

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


Get Method

SelfMarshalledStruct.Get Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function Get( _
ByVal t As Type, _
ByVal offset As Integer _
) As Object
C#
protected object Get(
Type t,
int offset
)
C++
protected:
Object Get(
Type t,
int offset
) sealed
J#
protected object Get(
Type t,
int offset
)
JScript
protected function Get(
t : Type,
offset : int
) : Object

Parameters

t
offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetByte Method

SelfMarshalledStruct.GetByte Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetByte( _
ByVal offset As Integer _
) As Byte
C#
protected byte GetByte(
int offset
)
C++
protected:
char GetByte(
int offset
) sealed
J#
protected byte GetByte(
int offset
)
JScript
protected function GetByte(
offset : int
) : Byte

Parameters

offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetChar Method

SelfMarshalledStruct.GetChar Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetChar( _
ByVal offset As Integer _
) As Char
C#
protected char GetChar(
int offset
)
C++
protected:
wchar_t GetChar(
int offset
) sealed
J#
protected char GetChar(
int offset
)
JScript
protected function GetChar(
offset : int
) : char

Parameters

offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetInt16 Method

SelfMarshalledStruct.GetInt16 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetInt16( _
ByVal offset As Integer _
) As Short
C#
protected short GetInt16(
int offset
)
C++
protected:
short GetInt16(
int offset
) sealed
J#
protected short GetInt16(
int offset
)
JScript
protected function GetInt16(
offset : int
) : short

Parameters

offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetInt32 Method

SelfMarshalledStruct.GetInt32 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetInt32( _
ByVal offset As Integer _
) As Integer
C#
protected int GetInt32(
int offset
)
C++
protected:
int GetInt32(
int offset
) sealed
J#
protected int GetInt32(
int offset
)
JScript
protected function GetInt32(
offset : int
) : int

Parameters

offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetIntPtr Method

SelfMarshalledStruct.GetIntPtr Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetIntPtr( _
ByVal offset As Integer _
) As IntPtr
C#
protected IntPtr GetIntPtr(
int offset
)
C++
protected:
IntPtr GetIntPtr(
int offset
) sealed
J#
protected IntPtr GetIntPtr(
int offset
)
JScript
protected function GetIntPtr(
offset : int
) : IntPtr

Parameters

offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetSlice Method

SelfMarshalledStruct.GetSlice Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetSlice( _
ByVal offset As Integer, _
ByVal len As Integer _
) As Byte()
C#
protected byte[] GetSlice(
int offset,
int len
)
C++
protected:
array<char>^ GetSlice(
int offset,
int len
) sealed
J#
protected byte[] GetSlice(
int offset,
int len
)
JScript
protected function GetSlice(
offset : int,
len : int
) : Byte[]

Parameters

offset
len

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetStringAscii Method

SelfMarshalledStruct.GetStringAscii Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetStringAscii( _
ByVal offset As Integer, _
ByVal len As Integer _
) As String
C#
protected string GetStringAscii(
int offset,
int len
)
C++
protected:
String GetStringAscii(
int offset,
int len
) sealed
J#
protected string GetStringAscii(
int offset,
int len
)
JScript
protected function GetStringAscii(
offset : int,
len : int
) : String

Parameters

offset
len

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetStringUni Method

SelfMarshalledStruct.GetStringUni Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetStringUni( _
ByVal offset As Integer, _
ByVal len As Integer _
) As String
C#
protected string GetStringUni(
int offset,
int len
)
C++
protected:
String GetStringUni(
int offset,
int len
) sealed
J#
protected string GetStringUni(
int offset,
int len
)
JScript
protected function GetStringUni(
offset : int,
len : int
) : String

Parameters

offset
len

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetUInt16 Method

SelfMarshalledStruct.GetUInt16 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetUInt16( _
ByVal offset As Integer _
) As UInt16
C#
protected ushort GetUInt16(
int offset
)
C++
protected:
unsigned short GetUInt16(
int offset
) sealed
J#
protected ushort GetUInt16(
int offset
)
JScript
protected function GetUInt16(
offset : int
) : UInt16

Parameters

offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


GetUInt32 Method

SelfMarshalledStruct.GetUInt32 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetUInt32( _
ByVal offset As Integer _
) As UInt32
C#
protected uint GetUInt32(
int offset
)
C++
protected:
unsigned int GetUInt32(
int offset
) sealed
J#
protected uint GetUInt32(
int offset
)
JScript
protected function GetUInt32(
offset : int
) : UInt32

Parameters

offset

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


Set Method

SelfMarshalledStruct.Set Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub Set( _
ByVal t As Type, _
ByVal offset As Integer, _
ByVal Val As Object _
)
C#
protected void Set(
Type t,
int offset,
object Val
)
C++
protected:
void Set(
Type t,
int offset,
Object Val
) sealed
J#
protected void Set(
Type t,
int offset,
object Val
)
JScript
protected function Set(
t : Type,
offset : int,
Val : Object
)

Parameters

t
offset
Val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetByte Method

SelfMarshalledStruct.SetByte Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetByte( _
ByVal offset As Integer, _
ByVal val As Byte _
)
C#
protected void SetByte(
int offset,
byte val
)
C++
protected:
void SetByte(
int offset,
char val
) sealed
J#
protected void SetByte(
int offset,
byte val
)
JScript
protected function SetByte(
offset : int,
val : Byte
)

Parameters

offset
val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetChar Method

SelfMarshalledStruct.SetChar Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetChar( _
ByVal offset As Integer, _
ByVal val As Char _
)
C#
protected void SetChar(
int offset,
char val
)
C++
protected:
void SetChar(
int offset,
wchar_t val
) sealed
J#
protected void SetChar(
int offset,
char val
)
JScript
protected function SetChar(
offset : int,
val : char
)

Parameters

offset
val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetInt16 Method

SelfMarshalledStruct.SetInt16 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetInt16( _
ByVal offset As Integer, _
ByVal val As Short _
)
C#
protected void SetInt16(
int offset,
short val
)
C++
protected:
void SetInt16(
int offset,
short val
) sealed
J#
protected void SetInt16(
int offset,
short val
)
JScript
protected function SetInt16(
offset : int,
val : short
)

Parameters

offset
val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetInt32 Method

SelfMarshalledStruct.SetInt32 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetInt32( _
ByVal offset As Integer, _
ByVal val As Integer _
)
C#
protected void SetInt32(
int offset,
int val
)
C++
protected:
void SetInt32(
int offset,
int val
) sealed
J#
protected void SetInt32(
int offset,
int val
)
JScript
protected function SetInt32(
offset : int,
val : int
)

Parameters

offset
val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetIntPtr Method

SelfMarshalledStruct.SetIntPtr Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetIntPtr( _
ByVal offset As Integer, _
ByVal val As IntPtr _
)
C#
protected void SetIntPtr(
int offset,
IntPtr val
)
C++
protected:
void SetIntPtr(
int offset,
IntPtr val
) sealed
J#
protected void SetIntPtr(
int offset,
IntPtr val
)
JScript
protected function SetIntPtr(
offset : int,
val : IntPtr
)

Parameters

offset
val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetStringUni Method

SelfMarshalledStruct.SetStringUni Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetStringUni( _
ByVal str As String, _
ByVal offset As Integer, _
ByVal len As Integer _
)
C#
protected void SetStringUni(
string str,
int offset,
int len
)
C++
protected:
void SetStringUni(
String str,
int offset,
int len
) sealed
J#
protected void SetStringUni(
string str,
int offset,
int len
)
JScript
protected function SetStringUni(
str : String,
offset : int,
len : int
)

Parameters

str
offset
len

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetUInt16 Method

SelfMarshalledStruct.SetUInt16 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetUInt16( _
ByVal offset As Integer, _
ByVal val As UInt16 _
)
C#
protected void SetUInt16(
int offset,
ushort val
)
C++
protected:
void SetUInt16(
int offset,
unsigned short val
) sealed
J#
protected void SetUInt16(
int offset,
ushort val
)
JScript
protected function SetUInt16(
offset : int,
val : UInt16
)

Parameters

offset
val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


SetUInt32 Method

SelfMarshalledStruct.SetUInt32 Method
[image]

Namespace: Advantech.Adam
Assembly: Advantech.Adam (in Advantech.Adam.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SetUInt32( _
ByVal offset As Integer, _
ByVal val As UInt32 _
)
C#
protected void SetUInt32(
int offset,
uint val
)
C++
protected:
void SetUInt32(
int offset,
unsigned int val
) sealed
J#
protected void SetUInt32(
int offset,
uint val
)
JScript
protected function SetUInt32(
offset : int,
val : UInt32
)

Parameters

offset
val

See Also

SelfMarshalledStruct Class
Advantech.Adam Namespace


Advantech.Common

Advantech.Common Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AdsdioAPI |
Public class | ApaxAPI |
Public class | ComPort | Serial communications base interface class library for Windows CE. This class is provided by Advantech.
Public class | ICMP_ECHO_REPLY |
Public class | ModbusServerAPI |
Public class | Ping |
Public class | SocketStream |
Public class | Tool | Some tool functions for translating or calculating.
Public class | UDPSocketClient |
Public class | UDPSocketServer |

Structures

 | Structure | Description
NestedFamily structure | ComPort.COMMTIMEOUTS | The COMMTIMEOUTS structure is used in the SetCommTimeouts and GetCommTimeouts functions to set and query the time-out parameters for a communications device. The parameters determine the behavior of ReadFile, WriteFile, ReadFileEx, and WriteFileEx operations on the device.

Delegates

 | Delegate | Description
NestedPublic delegate | ModbusServerAPI.EventHandler_OnCoilChangedEvent | The prototype of call back function when the coil changed event occurred.
NestedPublic delegate | ModbusServerAPI.EventHandler_OnHoldRegChangedEvent | The prototype of the call back function when the holding register changed event occurred.
NestedPublic delegate | ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent | The prototype of the call back function when a remote client connects to the server event occurred.
NestedPublic delegate | ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent | The prototype of the call back function when a remote client disconnects from the server event occurred.

Enumerations

 | Enumeration | Description
Public enumeration | Baudrate | Baud rate settings. Supported Rates: 110, 300, 600, 1200, 2400, 4800, 9600 14400, 19200, 38400, 56000, 57600, 115200, 128000, 256000
Public enumeration | Databits | Data bits setting.
Public enumeration | DcbFlagFields | The DCB flag structure
Public enumeration | ErrorCode | The Advantech error code
Public enumeration | Event | Event settings
Public enumeration | FlagSetting | Flag settings. Supported : Off, On.
Public enumeration | FlowControl | FlowControl settings. Supported type: Hardware, Xon/Xoff, None.
Public enumeration | Parity | Parity settings
Public enumeration | Purge | Purge settings
Public enumeration | Stopbits | Stop bit settings


AdsdioAPI Class

AdsdioAPI Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class AdsdioAPI
C#
public class AdsdioAPI
C++
ref class AdsdioAPI
J#
public class AdsdioAPI
JScript
public class AdsdioAPI

Inheritance Hierarchy

System.Object
Advantech.Common.AdsdioAPI

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdsdioAPI Members
Advantech.Common Namespace


AdsdioAPI Members

AdsdioAPI Members
See Also Example Constructors Fields Methods
[image]

The following tables list the members exposed by AdsdioAPI.

Public Constructors

 | Name | Description
Public method | AdsdioAPI | Adsdio constructor
Top

Public Fields

Name | Description
Acq_Stop_Err |
DevErrorCode |
ERR_ApiException |
ERR_CHANNEL_INVALID |
ERR_HANDLE_INVALID |
ERR_SLOT_INVALID |
ERR_SUCCESS |
FIFO_DataFail_Err |
FIFO_Full_Err |
FIFO_NotReady_Err |
FreqMeasurementFailed |
InitInterruptFailed |
InvalidFunction |
InvalidModule |
InvalidParam |
MapAddressFailed |
MemoryAllocateFailed |
Top

Public Methods

Name | Description
ADAMDrvClose | Adam controller driver close.
ADAMDrvOpen | Adam Controller driver open.
AI_GetChannelEnabled | Get the AI channels enabled status.
AI_GetChannelTotal | Get AI channel total number.
AI_GetInputRange | Get the AI input range.
AI_GetValue | Get AI value.
AI_GetValues | Get AI values.
AI_SetChannelEnabled | Enable/Disable AI channels.
AI_SetInputRange | Set the AI input range.
AO_GetChannelTotal | Get the AO channel total number.
AO_GetOutputRange | Get the AO output range.
AO_GetValue | Get AO value.
AO_GetValues | Get AO values.
AO_SetOutputRange | Set the AO output range.
AO_SetValue | Set AO value.
AO_SetValues | Set the AO values.
CNT_ClearAlarmFlag | Clear counter alarm flag
CNT_ClearOverflow | Clear counter overflow flag
CNT_ClearValue | Clear Counter value
CNT_GetAlarmEnable | Get Counter alarm enable flag
CNT_GetAlarmFlag | Get Counter alarm flag
CNT_GetAlarmLimit | Get Counter alarm limit value
CNT_GetAlarmMap | Get Counter alarm mapping
CNT_GetAlarmType | Get Counter alarm type
CNT_GetDoValue | Get Counter DO value
CNT_GetDoValues | Get Counter DO values
CNT_GetFilter | Get Counter filter
CNT_GetFreqAcqTime | Get Counter filter
CNT_GetOverflow | Get Counter overflow flag
CNT_GetRange | Get Counter range
CNT_GetStartup | Get Counter startup value
CNT_GetState | Get Counter state
CNT_GetValue | Get Counter value
CNT_SetAlarmEnable | Set Counter alarm enable flag
CNT_SetAlarmLimit | Set Counter alarm limit value
CNT_SetAlarmMap | Set Counter alarm mapping
CNT_SetAlarmType | Set Counter alarm type
CNT_SetDoValue | Set Counter DO value
CNT_SetDoValues | Set Counter DO values
CNT_SetFilter | Set Counter filter
CNT_SetFreqAcqTime | Set Counter filter
CNT_SetRange | Set Counter range
CNT_SetStartup | Set Counter startup value
CNT_SetState | Set Counter state
DEBUG_GetRegValue | (Internal use)
DEBUG_SetRegValue | (Internal use)
DI_GetChannelTotal | Get DI channel total number.
DI_GetValue | Get DI value.
DI_GetValues | Get DI values.
DIO_GetUniversalStatus | Get universal status
DO_GetChannelTotal | Get DO channel total number.
DO_SetValue | Set DO value.
DO_SetValues | Set DO values.
ODM17S_GetEnableChannelTotal | Get ODM ADAM-5017S enable channel number.
ODM17S_GetFifoData | Get ODM ADAM-5017S fifo data.
ODM17S_GetMode | Get ODM ADAM-5017S acquisition mode
ODM17S_GetRange | Get ODM ADAM-5017S range
ODM17S_GetSampleRate | Get ODM ADAM-5017S sampling rate.
ODM17S_GetTrigTotal | Get ODM ADAM-5017S trigger total number.
ODM17S_SetEnableChannelTotal | Set ODM ADAM-5017S enable channel number.
ODM17S_SetMode | Set ODM ADAM-5017S acquisition mode
ODM17S_SetRange | Set ODM ADAM-5017S range
ODM17S_SetSampleRate | Set ODM ADAM-5017S sampling rate.
ODM17S_SetStart | ODM ADAM-5017S start to get value.
ODM17S_SetStop | ODM ADAM-5017S stop getting value.
ODM17S_SetTrigTotal | Set ODM ADAM-5017S trigger total number.
SYS_GetADAM5550ARMFWVer | Get the firmware version.
SYS_GetCPLDVer | Get the CPLD version.
SYS_GetKwMbData | Get Kw Modbus Data
SYS_GetModuleID | Get the module ID.
SYS_GetModuleID_EX | Get the module ID and order.
SYS_GetModuleName | Get AI module name
SYS_GetNodeID | Get node ID number.
SYS_SetKwMbData | Set Kw Modbus Data
SYS_WaitForADAM5550IOUpdate | Check the internal update status.
Top

See Also

AdsdioAPI Class
Advantech.Common Namespace


AdsdioAPI Constructor

AdsdioAPI Constructor
[image]

Adsdio constructor

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdsdioAPI()
C++
public:
AdsdioAPI() sealed
J#
public AdsdioAPI()
JScript
public function AdsdioAPI()

See Also

AdsdioAPI Class
Advantech.Common Namespace


Fields

AdsdioAPI Fields
[image]

Public Fields

Name | Description
Acq_Stop_Err |
DevErrorCode |
ERR_ApiException |
ERR_CHANNEL_INVALID |
ERR_HANDLE_INVALID |
ERR_SLOT_INVALID |
ERR_SUCCESS |
FIFO_DataFail_Err |
FIFO_Full_Err |
FIFO_NotReady_Err |
FreqMeasurementFailed |
InitInterruptFailed |
InvalidFunction |
InvalidModule |
InvalidParam |
MapAddressFailed |
MemoryAllocateFailed |
Top

See Also

AdsdioAPI Class
Advantech.Common Namespace


Acq_Stop_Err Field

AdsdioAPI.Acq_Stop_Err Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Acq_Stop_Err As Integer
C#
public static readonly int Acq_Stop_Err;
C++
public:
static const int Acq_Stop_Err;
J#
public static final int Acq_Stop_Err
JScript
public static const var Acq_Stop_Err : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


DevErrorCode Field

AdsdioAPI.DevErrorCode Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DevErrorCode As Integer
C#
public static readonly int DevErrorCode;
C++
public:
static const int DevErrorCode;
J#
public static final int DevErrorCode
JScript
public static const var DevErrorCode : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


ERR_ApiException Field

AdsdioAPI.ERR_ApiException Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_ApiException As Integer
C#
public static readonly int ERR_ApiException;
C++
public:
static const int ERR_ApiException;
J#
public static final int ERR_ApiException
JScript
public static const var ERR_ApiException : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


ERR_CHANNEL_INVALID Field

AdsdioAPI.ERR_CHANNEL_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_CHANNEL_INVALID As Integer
C#
public static readonly int ERR_CHANNEL_INVALID;
C++
public:
static const int ERR_CHANNEL_INVALID;
J#
public static final int ERR_CHANNEL_INVALID
JScript
public static const var ERR_CHANNEL_INVALID : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


ERR_HANDLE_INVALID Field

AdsdioAPI.ERR_HANDLE_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_HANDLE_INVALID As Integer
C#
public static readonly int ERR_HANDLE_INVALID;
C++
public:
static const int ERR_HANDLE_INVALID;
J#
public static final int ERR_HANDLE_INVALID
JScript
public static const var ERR_HANDLE_INVALID : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


ERR_SLOT_INVALID Field

AdsdioAPI.ERR_SLOT_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_SLOT_INVALID As Integer
C#
public static readonly int ERR_SLOT_INVALID;
C++
public:
static const int ERR_SLOT_INVALID;
J#
public static final int ERR_SLOT_INVALID
JScript
public static const var ERR_SLOT_INVALID : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


ERR_SUCCESS Field

AdsdioAPI.ERR_SUCCESS Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_SUCCESS As Integer
C#
public static readonly int ERR_SUCCESS;
C++
public:
static const int ERR_SUCCESS;
J#
public static final int ERR_SUCCESS
JScript
public static const var ERR_SUCCESS : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


FIFO_DataFail_Err Field

AdsdioAPI.FIFO_DataFail_Err Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FIFO_DataFail_Err As Integer
C#
public static readonly int FIFO_DataFail_Err;
C++
public:
static const int FIFO_DataFail_Err;
J#
public static final int FIFO_DataFail_Err
JScript
public static const var FIFO_DataFail_Err : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


FIFO_Full_Err Field

AdsdioAPI.FIFO_Full_Err Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FIFO_Full_Err As Integer
C#
public static readonly int FIFO_Full_Err;
C++
public:
static const int FIFO_Full_Err;
J#
public static final int FIFO_Full_Err
JScript
public static const var FIFO_Full_Err : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


FIFO_NotReady_Err Field

AdsdioAPI.FIFO_NotReady_Err Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FIFO_NotReady_Err As Integer
C#
public static readonly int FIFO_NotReady_Err;
C++
public:
static const int FIFO_NotReady_Err;
J#
public static final int FIFO_NotReady_Err
JScript
public static const var FIFO_NotReady_Err : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


FreqMeasurementFailed Field

AdsdioAPI.FreqMeasurementFailed Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FreqMeasurementFailed As Integer
C#
public static readonly int FreqMeasurementFailed;
C++
public:
static const int FreqMeasurementFailed;
J#
public static final int FreqMeasurementFailed
JScript
public static const var FreqMeasurementFailed : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


InitInterruptFailed Field

AdsdioAPI.InitInterruptFailed Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly InitInterruptFailed As Integer
C#
public static readonly int InitInterruptFailed;
C++
public:
static const int InitInterruptFailed;
J#
public static final int InitInterruptFailed
JScript
public static const var InitInterruptFailed : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


InvalidFunction Field

AdsdioAPI.InvalidFunction Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly InvalidFunction As Integer
C#
public static readonly int InvalidFunction;
C++
public:
static const int InvalidFunction;
J#
public static final int InvalidFunction
JScript
public static const var InvalidFunction : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


InvalidModule Field

AdsdioAPI.InvalidModule Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly InvalidModule As Integer
C#
public static readonly int InvalidModule;
C++
public:
static const int InvalidModule;
J#
public static final int InvalidModule
JScript
public static const var InvalidModule : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


InvalidParam Field

AdsdioAPI.InvalidParam Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly InvalidParam As Integer
C#
public static readonly int InvalidParam;
C++
public:
static const int InvalidParam;
J#
public static final int InvalidParam
JScript
public static const var InvalidParam : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


MapAddressFailed Field

AdsdioAPI.MapAddressFailed Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MapAddressFailed As Integer
C#
public static readonly int MapAddressFailed;
C++
public:
static const int MapAddressFailed;
J#
public static final int MapAddressFailed
JScript
public static const var MapAddressFailed : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


MemoryAllocateFailed Field

AdsdioAPI.MemoryAllocateFailed Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MemoryAllocateFailed As Integer
C#
public static readonly int MemoryAllocateFailed;
C++
public:
static const int MemoryAllocateFailed;
J#
public static final int MemoryAllocateFailed
JScript
public static const var MemoryAllocateFailed : int;

See Also

AdsdioAPI Class
Advantech.Common Namespace


Methods

AdsdioAPI Methods
[image]

Public Methods

Name | Description
ADAMDrvClose | Adam controller driver close.
ADAMDrvOpen | Adam Controller driver open.
AI_GetChannelEnabled | Get the AI channels enabled status.
AI_GetChannelTotal | Get AI channel total number.
AI_GetInputRange | Get the AI input range.
AI_GetValue | Get AI value.
AI_GetValues | Get AI values.
AI_SetChannelEnabled | Enable/Disable AI channels.
AI_SetInputRange | Set the AI input range.
AO_GetChannelTotal | Get the AO channel total number.
AO_GetOutputRange | Get the AO output range.
AO_GetValue | Get AO value.
AO_GetValues | Get AO values.
AO_SetOutputRange | Set the AO output range.
AO_SetValue | Set AO value.
AO_SetValues | Set the AO values.
CNT_ClearAlarmFlag | Clear counter alarm flag
CNT_ClearOverflow | Clear counter overflow flag
CNT_ClearValue | Clear Counter value
CNT_GetAlarmEnable | Get Counter alarm enable flag
CNT_GetAlarmFlag | Get Counter alarm flag
CNT_GetAlarmLimit | Get Counter alarm limit value
CNT_GetAlarmMap | Get Counter alarm mapping
CNT_GetAlarmType | Get Counter alarm type
CNT_GetDoValue | Get Counter DO value
CNT_GetDoValues | Get Counter DO values
CNT_GetFilter | Get Counter filter
CNT_GetFreqAcqTime | Get Counter filter
CNT_GetOverflow | Get Counter overflow flag
CNT_GetRange | Get Counter range
CNT_GetStartup | Get Counter startup value
CNT_GetState | Get Counter state
CNT_GetValue | Get Counter value
CNT_SetAlarmEnable | Set Counter alarm enable flag
CNT_SetAlarmLimit | Set Counter alarm limit value
CNT_SetAlarmMap | Set Counter alarm mapping
CNT_SetAlarmType | Set Counter alarm type
CNT_SetDoValue | Set Counter DO value
CNT_SetDoValues | Set Counter DO values
CNT_SetFilter | Set Counter filter
CNT_SetFreqAcqTime | Set Counter filter
CNT_SetRange | Set Counter range
CNT_SetStartup | Set Counter startup value
CNT_SetState | Set Counter state
DEBUG_GetRegValue | (Internal use)
DEBUG_SetRegValue | (Internal use)
DI_GetChannelTotal | Get DI channel total number.
DI_GetValue | Get DI value.
DI_GetValues | Get DI values.
DIO_GetUniversalStatus | Get universal status
DO_GetChannelTotal | Get DO channel total number.
DO_SetValue | Set DO value.
DO_SetValues | Set DO values.
ODM17S_GetEnableChannelTotal | Get ODM ADAM-5017S enable channel number.
ODM17S_GetFifoData | Get ODM ADAM-5017S fifo data.
ODM17S_GetMode | Get ODM ADAM-5017S acquisition mode
ODM17S_GetRange | Get ODM ADAM-5017S range
ODM17S_GetSampleRate | Get ODM ADAM-5017S sampling rate.
ODM17S_GetTrigTotal | Get ODM ADAM-5017S trigger total number.
ODM17S_SetEnableChannelTotal | Set ODM ADAM-5017S enable channel number.
ODM17S_SetMode | Set ODM ADAM-5017S acquisition mode
ODM17S_SetRange | Set ODM ADAM-5017S range
ODM17S_SetSampleRate | Set ODM ADAM-5017S sampling rate.
ODM17S_SetStart | ODM ADAM-5017S start to get value.
ODM17S_SetStop | ODM ADAM-5017S stop getting value.
ODM17S_SetTrigTotal | Set ODM ADAM-5017S trigger total number.
SYS_GetADAM5550ARMFWVer | Get the firmware version.
SYS_GetCPLDVer | Get the CPLD version.
SYS_GetKwMbData | Get Kw Modbus Data
SYS_GetModuleID | Get the module ID.
SYS_GetModuleID_EX | Get the module ID and order.
SYS_GetModuleName | Get AI module name
SYS_GetNodeID | Get node ID number.
SYS_SetKwMbData | Set Kw Modbus Data
SYS_WaitForADAM5550IOUpdate | Check the internal update status.
Top

See Also

AdsdioAPI Class
Advantech.Common Namespace


ADAMDrvClose Method

AdsdioAPI.ADAMDrvClose Method
[image]

Adam controller driver close.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ADAMDrvClose", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ADAMDrvClose( _
ByRef handle As Integer _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ADAMDrvClose", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ADAMDrvClose(
ref int handle
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ADAMDrvClose", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ADAMDrvClose(
int% handle
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ADAMDrvClose", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ADAMDrvClose(
int handle
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ADAMDrvClose", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ADAMDrvClose(
handle : int
) : int

Parameters

handle
The driver handle.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ADAMDrvOpen Method

AdsdioAPI.ADAMDrvOpen Method
[image]

Adam Controller driver open.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ADAMDrvOpen", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ADAMDrvOpen( _
ByRef handle As Integer _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ADAMDrvOpen", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ADAMDrvOpen(
ref int handle
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ADAMDrvOpen", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ADAMDrvOpen(
int% handle
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ADAMDrvOpen", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ADAMDrvOpen(
int handle
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ADAMDrvOpen", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ADAMDrvOpen(
handle : int
) : int

Parameters

handle
The driver handle.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AI_GetChannelEnabled Method

AdsdioAPI.AI_GetChannelEnabled Method
[image]

Get the AI channels enabled status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AI_GetChannelEnabled", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetChannelEnabled( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal i_bEnabled As Boolean() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetChannelEnabled", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetChannelEnabled(
int handle,
ushort i_usSlot,
bool[] i_bEnabled
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AI_GetChannelEnabled", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetChannelEnabled(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<bool>^ i_bEnabled
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetChannelEnabled", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetChannelEnabled(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ bool[] i_bEnabled
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetChannelEnabled", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetChannelEnabled(
handle : int,
i_usSlot : UInt16,
OutAttribute i_bEnabled : bool[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_bEnabled
The channel enabled status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AI_GetChannelTotal Method

AdsdioAPI.AI_GetChannelTotal Method
[image]

Get AI channel total number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AI_GetChannelTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetChannelTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_iChannels As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetChannelTotal(
int handle,
ushort i_usSlot,
out ushort o_iChannels
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AI_GetChannelTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetChannelTotal(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_iChannels
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetChannelTotal(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_iChannels
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetChannelTotal(
handle : int,
i_usSlot : UInt16,
OutAttribute o_iChannels : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_iChannels
The channel total number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AI_GetInputRange Method

AdsdioAPI.AI_GetInputRange Method
[image]

Get the AI input range.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AI_GetInputRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetInputRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_byRangeCode As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetInputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetInputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out byte o_byRangeCode
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AI_GetInputRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetInputRange(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] char% o_byRangeCode
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetInputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetInputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRangeCode
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetInputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetInputRange(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_byRangeCode : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_byRangeCode
The input range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AI_GetValue Method

AdsdioAPI.AI_GetValue Method
[image]

Get AI value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AI_GetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Single _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out float o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AI_GetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] float% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : float
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The AI value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AI_GetValues Method

AdsdioAPI.AI_GetValues Method
[image]

Get AI values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AI_GetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_fValue As Single() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetValues(
int handle,
ushort i_usSlot,
float[] o_fValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AI_GetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<float>^ o_fValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ float[] o_fValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_fValue : float[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_fValue
The AI values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AI_SetChannelEnabled Method

AdsdioAPI.AI_SetChannelEnabled Method
[image]

Enable/Disable AI channels.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AI_SetChannelEnabled", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetChannelEnabled( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_bEnabled As Boolean() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_SetChannelEnabled", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetChannelEnabled(
int handle,
ushort i_usSlot,
bool[] i_bEnabled
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AI_SetChannelEnabled", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetChannelEnabled(
int handle,
unsigned short i_usSlot,
array<bool>^ i_bEnabled
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_SetChannelEnabled", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetChannelEnabled(
int handle,
ushort i_usSlot,
bool[] i_bEnabled
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_SetChannelEnabled", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetChannelEnabled(
handle : int,
i_usSlot : UInt16,
i_bEnabled : bool[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_bEnabled
The channel enabled status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AI_SetInputRange Method

AdsdioAPI.AI_SetInputRange Method
[image]

Set the AI input range.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AI_SetInputRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetInputRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_byRangeCode As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_SetInputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetInputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_byRangeCode
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AI_SetInputRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetInputRange(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
char i_byRangeCode
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_SetInputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetInputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_byRangeCode
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AI_SetInputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetInputRange(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_byRangeCode : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_byRangeCode
The input range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AO_GetChannelTotal Method

AdsdioAPI.AO_GetChannelTotal Method
[image]

Get the AO channel total number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AO_GetChannelTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_GetChannelTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_iChannels As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_GetChannelTotal(
int handle,
ushort i_usSlot,
out ushort o_iChannels
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AO_GetChannelTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_GetChannelTotal(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_iChannels
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_GetChannelTotal(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_iChannels
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_GetChannelTotal(
handle : int,
i_usSlot : UInt16,
OutAttribute o_iChannels : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_iChannels
The channel total number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AO_GetOutputRange Method

AdsdioAPI.AO_GetOutputRange Method
[image]

Get the AO output range.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AO_GetOutputRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_GetOutputRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_byRange As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetOutputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_GetOutputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out byte o_byRange
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AO_GetOutputRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_GetOutputRange(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] char% o_byRange
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetOutputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_GetOutputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRange
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetOutputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_GetOutputRange(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_byRange : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_byRange
The output range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AO_GetValue Method

AdsdioAPI.AO_GetValue Method
[image]

Get AO value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AO_GetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_GetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Single _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out float o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AO_GetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_GetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] float% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ float o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_GetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : float
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The AO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AO_GetValues Method

AdsdioAPI.AO_GetValues Method
[image]

Get AO values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AO_GetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_GetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_fValue As Single() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_GetValues(
int handle,
ushort i_usSlot,
float[] o_fValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AO_GetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_GetValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<float>^ o_fValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_GetValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ float[] o_fValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_GetValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_fValue : float[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_fValue
The AO values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AO_SetOutputRange Method

AdsdioAPI.AO_SetOutputRange Method
[image]

Set the AO output range.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AO_SetOutputRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_SetOutputRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_byRange As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetOutputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_SetOutputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_byRange
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AO_SetOutputRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_SetOutputRange(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
char i_byRange
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetOutputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_SetOutputRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_byRange
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetOutputRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_SetOutputRange(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_byRange : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_byRange
The output range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AO_SetValue Method

AdsdioAPI.AO_SetValue Method
[image]

Set AO value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AO_SetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_SetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal o_sValue As Single _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
float o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AO_SetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_SetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
float o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
float o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_SetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
o_sValue : float
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The AO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


AO_SetValues Method

AdsdioAPI.AO_SetValues Method
[image]

Set the AO values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "AO_SetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_SetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal o_fValue As Single() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_SetValues(
int handle,
ushort i_usSlot,
float[] o_fValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"AO_SetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_SetValues(
int handle,
unsigned short i_usSlot,
array<float>^ o_fValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_SetValues(
int handle,
ushort i_usSlot,
float[] o_fValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "AO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_SetValues(
handle : int,
i_usSlot : UInt16,
o_fValue : float[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_fValue
The AO values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_ClearAlarmFlag Method

AdsdioAPI.CNT_ClearAlarmFlag Method
[image]

Clear counter alarm flag

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_ClearAlarmFlag", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_ClearAlarmFlag( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearAlarmFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_ClearAlarmFlag(
int handle,
ushort i_usSlot,
ushort i_usChannel
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_ClearAlarmFlag", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_ClearAlarmFlag(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearAlarmFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_ClearAlarmFlag(
int handle,
ushort i_usSlot,
ushort i_usChannel
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearAlarmFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_ClearAlarmFlag(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_ClearOverflow Method

AdsdioAPI.CNT_ClearOverflow Method
[image]

Clear counter overflow flag

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_ClearOverflow", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_ClearOverflow( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearOverflow", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_ClearOverflow(
int handle,
ushort i_usSlot,
ushort i_usChannel
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_ClearOverflow", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_ClearOverflow(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearOverflow", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_ClearOverflow(
int handle,
ushort i_usSlot,
ushort i_usChannel
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearOverflow", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_ClearOverflow(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_ClearValue Method

AdsdioAPI.CNT_ClearValue Method
[image]

Clear Counter value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_ClearValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_ClearValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_ClearValue(
int handle,
ushort i_usSlot,
ushort i_usChannel
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_ClearValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_ClearValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_ClearValue(
int handle,
ushort i_usSlot,
ushort i_usChannel
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_ClearValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_ClearValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetAlarmEnable Method

AdsdioAPI.CNT_GetAlarmEnable Method
[image]

Get Counter alarm enable flag

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetAlarmEnable", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetAlarmEnable( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetAlarmEnable(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetAlarmEnable", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetAlarmEnable(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetAlarmEnable(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetAlarmEnable(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter alarm enable flag.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetAlarmFlag Method

AdsdioAPI.CNT_GetAlarmFlag Method
[image]

Get Counter alarm flag

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetAlarmFlag", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetAlarmFlag( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetAlarmFlag(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetAlarmFlag", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetAlarmFlag(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetAlarmFlag(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetAlarmFlag(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter alarm flag.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetAlarmLimit Method

AdsdioAPI.CNT_GetAlarmLimit Method
[image]

Get Counter alarm limit value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetAlarmLimit", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetAlarmLimit( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmLimit", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetAlarmLimit(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out uint o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetAlarmLimit", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetAlarmLimit(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] unsigned int% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmLimit", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetAlarmLimit(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmLimit", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetAlarmLimit(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter alarm limit.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetAlarmMap Method

AdsdioAPI.CNT_GetAlarmMap Method
[image]

Get Counter alarm mapping

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetAlarmMap", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetAlarmMap( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmMap", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetAlarmMap(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out byte o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetAlarmMap", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetAlarmMap(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] char% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmMap", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetAlarmMap(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmMap", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetAlarmMap(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter alarm mapping.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetAlarmType Method

AdsdioAPI.CNT_GetAlarmType Method
[image]

Get Counter alarm type

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetAlarmType", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetAlarmType( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmType", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetAlarmType(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out byte o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetAlarmType", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetAlarmType(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] char% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmType", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetAlarmType(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetAlarmType", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetAlarmType(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter alarm type.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetDoValue Method

AdsdioAPI.CNT_GetDoValue Method
[image]

Get Counter DO value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetDoValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetDoValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetDoValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetDoValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetDoValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetDoValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetDoValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetDoValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetDoValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetDoValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter DO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetDoValues Method

AdsdioAPI.CNT_GetDoValues Method
[image]

Get Counter DO values

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetDoValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetDoValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetDoValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetDoValues(
int handle,
ushort i_usSlot,
out byte o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetDoValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetDoValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] char% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetDoValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetDoValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetDoValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetDoValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_sValue
The Counter DO values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetFilter Method

AdsdioAPI.CNT_GetFilter Method
[image]

Get Counter filter

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetFilter", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetFilter( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetFilter(
int handle,
ushort i_usSlot,
out uint o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetFilter", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetFilter(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetFilter(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetFilter(
handle : int,
i_usSlot : UInt16,
OutAttribute o_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_sValue
The Counter filter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetFreqAcqTime Method

AdsdioAPI.CNT_GetFreqAcqTime Method
[image]

Get Counter filter

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetFreqAcqTime", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetFreqAcqTime( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetFreqAcqTime(
int handle,
ushort i_usSlot,
out uint o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetFreqAcqTime", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetFreqAcqTime(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetFreqAcqTime(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetFreqAcqTime(
handle : int,
i_usSlot : UInt16,
OutAttribute o_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_sValue
The Counter filter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetOverflow Method

AdsdioAPI.CNT_GetOverflow Method
[image]

Get Counter overflow flag

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetOverflow", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetOverflow( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetOverflow", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetOverflow(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetOverflow", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetOverflow(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetOverflow", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetOverflow(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetOverflow", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetOverflow(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter overflow flag.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetRange Method

AdsdioAPI.CNT_GetRange Method
[image]

Get Counter range

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out byte o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetRange(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] char% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetRange(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetStartup Method

AdsdioAPI.CNT_GetStartup Method
[image]

Get Counter startup value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetStartup", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetStartup( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetStartup", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetStartup(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out uint o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetStartup", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetStartup(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] unsigned int% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetStartup", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetStartup(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetStartup", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetStartup(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter startup value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetState Method

AdsdioAPI.CNT_GetState Method
[image]

Get Counter state

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetState", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetState( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetState", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetState(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetState", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetState(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetState", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetState(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetState", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetState(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter state value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_GetValue Method

AdsdioAPI.CNT_GetValue Method
[image]

Get Counter value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_GetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out uint o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_GetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] unsigned int% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_sValue
The Counter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetAlarmEnable Method

AdsdioAPI.CNT_SetAlarmEnable Method
[image]

Set Counter alarm enable flag

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetAlarmEnable", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetAlarmEnable( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetAlarmEnable(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetAlarmEnable", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetAlarmEnable(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
bool i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetAlarmEnable(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetAlarmEnable(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter alarm enable flag.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetAlarmLimit Method

AdsdioAPI.CNT_SetAlarmLimit Method
[image]

Set Counter alarm limit value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetAlarmLimit", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetAlarmLimit( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmLimit", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetAlarmLimit(
int handle,
ushort i_usSlot,
ushort i_usChannel,
uint i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetAlarmLimit", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetAlarmLimit(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
unsigned int i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmLimit", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetAlarmLimit(
int handle,
ushort i_usSlot,
ushort i_usChannel,
uint i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmLimit", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetAlarmLimit(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter alarm limit value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetAlarmMap Method

AdsdioAPI.CNT_SetAlarmMap Method
[image]

Set Counter alarm mapping

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetAlarmMap", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetAlarmMap( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmMap", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetAlarmMap(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetAlarmMap", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetAlarmMap(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
char i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmMap", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetAlarmMap(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmMap", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetAlarmMap(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter alarm mapping.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetAlarmType Method

AdsdioAPI.CNT_SetAlarmType Method
[image]

Set Counter alarm type

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetAlarmType", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetAlarmType( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmType", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetAlarmType(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetAlarmType", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetAlarmType(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
char i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmType", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetAlarmType(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetAlarmType", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetAlarmType(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter alarm type.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetDoValue Method

AdsdioAPI.CNT_SetDoValue Method
[image]

Set Counter DO value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetDoValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetDoValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetDoValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetDoValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetDoValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetDoValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
bool i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetDoValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetDoValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetDoValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetDoValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter DO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetDoValues Method

AdsdioAPI.CNT_SetDoValues Method
[image]

Set Counter DO values

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetDoValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetDoValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetDoValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetDoValues(
int handle,
ushort i_usSlot,
byte i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetDoValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetDoValues(
int handle,
unsigned short i_usSlot,
char i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetDoValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetDoValues(
int handle,
ushort i_usSlot,
byte i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetDoValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetDoValues(
handle : int,
i_usSlot : UInt16,
i_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_sValue
The Counter DO values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetFilter Method

AdsdioAPI.CNT_SetFilter Method
[image]

Set Counter filter

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetFilter", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetFilter( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetFilter(
int handle,
ushort i_usSlot,
uint i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetFilter", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetFilter(
int handle,
unsigned short i_usSlot,
unsigned int i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetFilter(
int handle,
ushort i_usSlot,
uint i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetFilter(
handle : int,
i_usSlot : UInt16,
i_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_sValue
The Counter filter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetFreqAcqTime Method

AdsdioAPI.CNT_SetFreqAcqTime Method
[image]

Set Counter filter

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetFreqAcqTime", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetFreqAcqTime( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetFreqAcqTime(
int handle,
ushort i_usSlot,
uint i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetFreqAcqTime", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetFreqAcqTime(
int handle,
unsigned short i_usSlot,
unsigned int i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetFreqAcqTime(
int handle,
ushort i_usSlot,
uint i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetFreqAcqTime(
handle : int,
i_usSlot : UInt16,
i_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_sValue
The Counter filter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetRange Method

AdsdioAPI.CNT_SetRange Method
[image]

Set Counter range

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetRange(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
char i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetRange(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetRange(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetStartup Method

AdsdioAPI.CNT_SetStartup Method
[image]

Set Counter startup value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetStartup", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetStartup( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetStartup", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetStartup(
int handle,
ushort i_usSlot,
ushort i_usChannel,
uint i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetStartup", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetStartup(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
unsigned int i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetStartup", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetStartup(
int handle,
ushort i_usSlot,
ushort i_usChannel,
uint i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetStartup", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetStartup(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter startup value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


CNT_SetState Method

AdsdioAPI.CNT_SetState Method
[image]

Set Counter state

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "CNT_SetState", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetState( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_sValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetState", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetState(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"CNT_SetState", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetState(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
bool i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetState", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetState(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "CNT_SetState", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetState(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_sValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_sValue
The Counter state value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DEBUG_GetRegValue Method

AdsdioAPI.DEBUG_GetRegValue Method
[image]

(Internal use)

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DEBUG_GetRegValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DEBUG_GetRegValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_byValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DEBUG_GetRegValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DEBUG_GetRegValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out byte o_byValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DEBUG_GetRegValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DEBUG_GetRegValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] char% o_byValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DEBUG_GetRegValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DEBUG_GetRegValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ byte o_byValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DEBUG_GetRegValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DEBUG_GetRegValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_byValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_byValue
The register value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DEBUG_SetRegValue Method

AdsdioAPI.DEBUG_SetRegValue Method
[image]

(Internal use)

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DEBUG_SetRegValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DEBUG_SetRegValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_byValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DEBUG_SetRegValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DEBUG_SetRegValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_byValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DEBUG_SetRegValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DEBUG_SetRegValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
char i_byValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DEBUG_SetRegValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DEBUG_SetRegValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
byte i_byValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DEBUG_SetRegValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DEBUG_SetRegValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_byValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_byValue
The register value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DI_GetChannelTotal Method

AdsdioAPI.DI_GetChannelTotal Method
[image]

Get DI channel total number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DI_GetChannelTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DI_GetChannelTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_iChannels As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DI_GetChannelTotal(
int handle,
ushort i_usSlot,
out ushort o_iChannels
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DI_GetChannelTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DI_GetChannelTotal(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_iChannels
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DI_GetChannelTotal(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_iChannels
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DI_GetChannelTotal(
handle : int,
i_usSlot : UInt16,
OutAttribute o_iChannels : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_iChannels
The channel total number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DI_GetValue Method

AdsdioAPI.DI_GetValue Method
[image]

Get DI value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DI_GetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DI_GetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_bValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DI_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_bValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DI_GetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DI_GetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_bValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DI_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DI_GetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_bValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_bValue
The DI value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DI_GetValues Method

AdsdioAPI.DI_GetValues Method
[image]

Get DI values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DI_GetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DI_GetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DI_GetValues(
int handle,
ushort i_usSlot,
out uint o_dwValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DI_GetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DI_GetValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DI_GetValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DI_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DI_GetValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwValue
The DI value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DIO_GetUniversalStatus Method

AdsdioAPI.DIO_GetUniversalStatus Method
[image]

Get universal status

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DIO_GetUniversalStatus", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DIO_GetUniversalStatus( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwStatus As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DIO_GetUniversalStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DIO_GetUniversalStatus(
int handle,
ushort i_usSlot,
out ushort o_dwStatus
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DIO_GetUniversalStatus", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DIO_GetUniversalStatus(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_dwStatus
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DIO_GetUniversalStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DIO_GetUniversalStatus(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_dwStatus
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DIO_GetUniversalStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DIO_GetUniversalStatus(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwStatus : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwStatus
The universal status. The lowest bit indicates channel 0. The bit value equals to 1 means the channel is DI channel; otherwise is DO channel.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DO_GetChannelTotal Method

AdsdioAPI.DO_GetChannelTotal Method
[image]

Get DO channel total number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DO_GetChannelTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DO_GetChannelTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_iChannels As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DO_GetChannelTotal(
int handle,
ushort i_usSlot,
out ushort o_iChannels
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DO_GetChannelTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DO_GetChannelTotal(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_iChannels
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DO_GetChannelTotal(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_iChannels
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_GetChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DO_GetChannelTotal(
handle : int,
i_usSlot : UInt16,
OutAttribute o_iChannels : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_iChannels
The channel total number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DO_SetValue Method

AdsdioAPI.DO_SetValue Method
[image]

Set DO value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DO_SetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DO_SetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_bValue As Boolean _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DO_SetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DO_SetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
bool i_bValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DO_SetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_bValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_bValue
The DO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


DO_SetValues Method

AdsdioAPI.DO_SetValues Method
[image]

Set DO values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "DO_SetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DO_SetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DO_SetValues(
int handle,
ushort i_usSlot,
uint i_dwValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"DO_SetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DO_SetValues(
int handle,
unsigned short i_usSlot,
unsigned int i_dwValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DO_SetValues(
int handle,
ushort i_usSlot,
uint i_dwValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "DO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DO_SetValues(
handle : int,
i_usSlot : UInt16,
i_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwValue
The DO values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_GetEnableChannelTotal Method

AdsdioAPI.ODM17S_GetEnableChannelTotal Method
[image]

Get ODM ADAM-5017S enable channel number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_GetEnableChannelTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_GetEnableChannelTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_usValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetEnableChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_GetEnableChannelTotal(
int handle,
ushort i_usSlot,
out ushort o_usValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_GetEnableChannelTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_GetEnableChannelTotal(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_usValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetEnableChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_GetEnableChannelTotal(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetEnableChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_GetEnableChannelTotal(
handle : int,
i_usSlot : UInt16,
OutAttribute o_usValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_usValue
The enable channel number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_GetFifoData Method

AdsdioAPI.ODM17S_GetFifoData Method
[image]

Get ODM ADAM-5017S fifo data.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_GetFifoData", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_GetFifoData( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_usValue As UInt16() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetFifoData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_GetFifoData(
int handle,
ushort i_usSlot,
ushort[] o_usValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_GetFifoData", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_GetFifoData(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<unsigned short>^ o_usValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetFifoData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_GetFifoData(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ ushort[] o_usValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetFifoData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_GetFifoData(
handle : int,
i_usSlot : UInt16,
OutAttribute o_usValue : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_usValue
The fifo data.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_GetMode Method

AdsdioAPI.ODM17S_GetMode Method
[image]

Get ODM ADAM-5017S acquisition mode

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_GetMode", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_GetMode( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_GetMode(
int handle,
ushort i_usSlot,
out byte o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_GetMode", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_GetMode(
int handle,
unsigned short i_usSlot,
[OutAttribute] char% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_GetMode(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_GetMode(
handle : int,
i_usSlot : UInt16,
OutAttribute o_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_sValue
The acquisition mode. 1:cyclic mode, 0:non-cyclic mode

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_GetRange Method

AdsdioAPI.ODM17S_GetRange Method
[image]

Get ODM ADAM-5017S range

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_GetRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_GetRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_GetRange(
int handle,
ushort i_usSlot,
out byte o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_GetRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_GetRange(
int handle,
unsigned short i_usSlot,
[OutAttribute] char% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_GetRange(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ byte o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_GetRange(
handle : int,
i_usSlot : UInt16,
OutAttribute o_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_sValue
The input range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_GetSampleRate Method

AdsdioAPI.ODM17S_GetSampleRate Method
[image]

Get ODM ADAM-5017S sampling rate.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_GetSampleRate", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_GetSampleRate( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_usValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_GetSampleRate(
int handle,
ushort i_usSlot,
out ushort o_usValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_GetSampleRate", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_GetSampleRate(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_usValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_GetSampleRate(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_GetSampleRate(
handle : int,
i_usSlot : UInt16,
OutAttribute o_usValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_usValue
The sampling rate.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_GetTrigTotal Method

AdsdioAPI.ODM17S_GetTrigTotal Method
[image]

Get ODM ADAM-5017S trigger total number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_GetTrigTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_GetTrigTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_usValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetTrigTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_GetTrigTotal(
int handle,
ushort i_usSlot,
out ushort o_usValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_GetTrigTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_GetTrigTotal(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_usValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetTrigTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_GetTrigTotal(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_GetTrigTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_GetTrigTotal(
handle : int,
i_usSlot : UInt16,
OutAttribute o_usValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_usValue
The trigger total number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_SetEnableChannelTotal Method

AdsdioAPI.ODM17S_SetEnableChannelTotal Method
[image]

Set ODM ADAM-5017S enable channel number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_SetEnableChannelTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_SetEnableChannelTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetEnableChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_SetEnableChannelTotal(
int handle,
ushort i_usSlot,
ushort i_usValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_SetEnableChannelTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_SetEnableChannelTotal(
int handle,
unsigned short i_usSlot,
unsigned short i_usValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetEnableChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_SetEnableChannelTotal(
int handle,
ushort i_usSlot,
ushort i_usValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetEnableChannelTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_SetEnableChannelTotal(
handle : int,
i_usSlot : UInt16,
i_usValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usValue
The enable channel number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_SetMode Method

AdsdioAPI.ODM17S_SetMode Method
[image]

Set ODM ADAM-5017S acquisition mode

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_SetMode", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_SetMode( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_SetMode(
int handle,
ushort i_usSlot,
byte i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_SetMode", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_SetMode(
int handle,
unsigned short i_usSlot,
char i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_SetMode(
int handle,
ushort i_usSlot,
byte i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_SetMode(
handle : int,
i_usSlot : UInt16,
i_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_sValue
The acquisition mode. 1:cyclic mode, 0:non-cyclic mode

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_SetRange Method

AdsdioAPI.ODM17S_SetRange Method
[image]

Set ODM ADAM-5017S range

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_SetRange", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_SetRange( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_sValue As Byte _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_SetRange(
int handle,
ushort i_usSlot,
byte i_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_SetRange", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_SetRange(
int handle,
unsigned short i_usSlot,
char i_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_SetRange(
int handle,
ushort i_usSlot,
byte i_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetRange", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_SetRange(
handle : int,
i_usSlot : UInt16,
i_sValue : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_sValue
The input range.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_SetSampleRate Method

AdsdioAPI.ODM17S_SetSampleRate Method
[image]

Set ODM ADAM-5017S sampling rate.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_SetSampleRate", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_SetSampleRate( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_SetSampleRate(
int handle,
ushort i_usSlot,
ushort i_usValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_SetSampleRate", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_SetSampleRate(
int handle,
unsigned short i_usSlot,
unsigned short i_usValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_SetSampleRate(
int handle,
ushort i_usSlot,
ushort i_usValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_SetSampleRate(
handle : int,
i_usSlot : UInt16,
i_usValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usValue
The sampling rate.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_SetStart Method

AdsdioAPI.ODM17S_SetStart Method
[image]

ODM ADAM-5017S start to get value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_SetStart", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_SetStart( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetStart", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_SetStart(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_SetStart", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_SetStart(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetStart", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_SetStart(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetStart", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_SetStart(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_SetStop Method

AdsdioAPI.ODM17S_SetStop Method
[image]

ODM ADAM-5017S stop getting value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_SetStop", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_SetStop( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetStop", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_SetStop(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_SetStop", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_SetStop(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetStop", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_SetStop(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetStop", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_SetStop(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ODM17S_SetTrigTotal Method

AdsdioAPI.ODM17S_SetTrigTotal Method
[image]

Set ODM ADAM-5017S trigger total number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "ODM17S_SetTrigTotal", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ODM17S_SetTrigTotal( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetTrigTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ODM17S_SetTrigTotal(
int handle,
ushort i_usSlot,
ushort i_usValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"ODM17S_SetTrigTotal", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ODM17S_SetTrigTotal(
int handle,
unsigned short i_usSlot,
unsigned short i_usValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetTrigTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ODM17S_SetTrigTotal(
int handle,
ushort i_usSlot,
ushort i_usValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "ODM17S_SetTrigTotal", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ODM17S_SetTrigTotal(
handle : int,
i_usSlot : UInt16,
i_usValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usValue
The trigger total number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_GetADAM5550ARMFWVer Method

AdsdioAPI.SYS_GetADAM5550ARMFWVer Method
[image]

Get the firmware version.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_GetADAM5550ARMFWVer", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetADAM5550ARMFWVer( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_sValue As Single _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetADAM5550ARMFWVer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetADAM5550ARMFWVer(
int handle,
out float o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_GetADAM5550ARMFWVer", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetADAM5550ARMFWVer(
int handle,
[OutAttribute] float% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetADAM5550ARMFWVer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetADAM5550ARMFWVer(
int handle,
/** @attribute OutAttribute() */ /** @ref */ float o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetADAM5550ARMFWVer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetADAM5550ARMFWVer(
handle : int,
OutAttribute o_sValue : float
) : int

Parameters

handle
The driver handle.
o_sValue
The firmware version.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_GetCPLDVer Method

AdsdioAPI.SYS_GetCPLDVer Method
[image]

Get the CPLD version.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_GetCPLDVer", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetCPLDVer( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_sValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetCPLDVer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetCPLDVer(
int handle,
out ushort o_sValue
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_GetCPLDVer", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetCPLDVer(
int handle,
[OutAttribute] unsigned short% o_sValue
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetCPLDVer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetCPLDVer(
int handle,
/** @attribute OutAttribute() */ /** @ref */ ushort o_sValue
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetCPLDVer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetCPLDVer(
handle : int,
OutAttribute o_sValue : UInt16
) : int

Parameters

handle
The driver handle.
o_sValue
The CPLD version.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_GetKwMbData Method

AdsdioAPI.SYS_GetKwMbData Method
[image]

Get Kw Modbus Data

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_GetKwMbData", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetKwMbData( _
ByVal handle As Integer, _
ByVal i_dwStartAddr As UInt32, _
ByVal i_dwLength As UInt32, _
<OutAttribute> ByVal o_byValues As Byte() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
byte[] o_byValues
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_GetKwMbData", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetKwMbData(
int handle,
unsigned int i_dwStartAddr,
unsigned int i_dwLength,
[OutAttribute] array<char>^ o_byValues
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
/** @attribute OutAttribute() */ byte[] o_byValues
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetKwMbData(
handle : int,
i_dwStartAddr : UInt32,
i_dwLength : UInt32,
OutAttribute o_byValues : Byte[]
) : int

Parameters

handle
The driver handle.
i_dwStartAddr
The start address. 0~65535
i_dwLength
The length of modbus data.
o_byValues
The modbus data values

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_GetModuleID Method

AdsdioAPI.SYS_GetModuleID Method
[image]

Get the module ID.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_GetModuleID", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetModuleID( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_usModuleID As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetModuleID(
int handle,
ushort i_usSlot,
out ushort o_usModuleID
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_GetModuleID", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetModuleID(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_usModuleID
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetModuleID(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usModuleID
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetModuleID(
handle : int,
i_usSlot : UInt16,
OutAttribute o_usModuleID : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_usModuleID
The module ID number plugged in the slot.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_GetModuleID_EX Method

AdsdioAPI.SYS_GetModuleID_EX Method
[image]

Get the module ID and order.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_GetModuleID_EX", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetModuleID_EX( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_usModuleID As UInt16, _
<OutAttribute> ByRef o_usOrder As Integer _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleID_EX", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetModuleID_EX(
int handle,
ushort i_usSlot,
out ushort o_usModuleID,
out int o_usOrder
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_GetModuleID_EX", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetModuleID_EX(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned short% o_usModuleID,
[OutAttribute] int% o_usOrder
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleID_EX", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetModuleID_EX(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usModuleID,
/** @attribute OutAttribute() */ /** @ref */ int o_usOrder
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleID_EX", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetModuleID_EX(
handle : int,
i_usSlot : UInt16,
OutAttribute o_usModuleID : UInt16,
OutAttribute o_usOrder : int
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_usModuleID
The module ID number plugged in the slot.
o_usOrder
The module order.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_GetModuleName Method

AdsdioAPI.SYS_GetModuleName Method
[image]

Get AI module name

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_GetModuleName", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetModuleName( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_szName As Byte() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleName", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetModuleName(
int handle,
ushort i_usSlot,
byte[] o_szName
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_GetModuleName", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetModuleName(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<char>^ o_szName
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleName", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetModuleName(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ byte[] o_szName
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetModuleName", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetModuleName(
handle : int,
i_usSlot : UInt16,
OutAttribute o_szName : Byte[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_szName
The byte array of module name

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_GetNodeID Method

AdsdioAPI.SYS_GetNodeID Method
[image]

Get node ID number.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_GetNodeID", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetNodeID( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_usNodeID As UInt16 _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetNodeID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetNodeID(
int handle,
out ushort o_usNodeID
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_GetNodeID", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetNodeID(
int handle,
[OutAttribute] unsigned short% o_usNodeID
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetNodeID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetNodeID(
int handle,
/** @attribute OutAttribute() */ /** @ref */ ushort o_usNodeID
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_GetNodeID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetNodeID(
handle : int,
OutAttribute o_usNodeID : UInt16
) : int

Parameters

handle
The driver handle.
o_usNodeID
The node ID number.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_SetKwMbData Method

AdsdioAPI.SYS_SetKwMbData Method
[image]

Set Kw Modbus Data

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_SetKwMbData", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetKwMbData( _
ByVal handle As Integer, _
ByVal i_dwStartAddr As UInt32, _
ByVal i_dwLength As UInt32, _
ByVal i_byValues As Byte() _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_SetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
byte[] i_byValues
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_SetKwMbData", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetKwMbData(
int handle,
unsigned int i_dwStartAddr,
unsigned int i_dwLength,
array<char>^ i_byValues
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_SetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
byte[] i_byValues
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_SetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetKwMbData(
handle : int,
i_dwStartAddr : UInt32,
i_dwLength : UInt32,
i_byValues : Byte[]
) : int

Parameters

handle
The driver handle.
i_dwStartAddr
The start address. 0~65535
i_dwLength
The length of modbus data.
i_byValues
The modbus data values

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


SYS_WaitForADAM5550IOUpdate Method

AdsdioAPI.SYS_WaitForADAM5550IOUpdate Method
[image]

Check the internal update status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ads5550dio.dll", EntryPoint := "SYS_WaitForADAM5550IOUpdate", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_WaitForADAM5550IOUpdate( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_iflag As Short _
) As Integer
C#
[DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_WaitForADAM5550IOUpdate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_WaitForADAM5550IOUpdate(
int handle,
ushort i_usSlot,
out short o_iflag
)
C++
[DllImportAttribute(L"ads5550dio.dll", EntryPoint = L"SYS_WaitForADAM5550IOUpdate", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_WaitForADAM5550IOUpdate(
int handle,
unsigned short i_usSlot,
[OutAttribute] short% o_iflag
)
J#
/** @attribute DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_WaitForADAM5550IOUpdate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_WaitForADAM5550IOUpdate(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ short o_iflag
)
JScript
public static

DllImportAttribute("ads5550dio.dll", EntryPoint = "SYS_WaitForADAM5550IOUpdate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_WaitForADAM5550IOUpdate(
handle : int,
i_usSlot : UInt16,
OutAttribute o_iflag : short
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_iflag
1 means update ready, 0 means is not ready.

Return Value

Return 0 if success; otherwise, return error code.

See Also

AdsdioAPI Class
Advantech.Common Namespace


ApaxAPI Class

ApaxAPI Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class ApaxAPI
C#
public class ApaxAPI
C++
ref class ApaxAPI
J#
public class ApaxAPI
JScript
public class ApaxAPI

Inheritance Hierarchy

System.Object
Advantech.Common.ApaxAPI

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApaxAPI Members
Advantech.Common Namespace


ApaxAPI Members

ApaxAPI Members
See Also Example Constructors Fields Methods
[image]

The following tables list the members exposed by ApaxAPI.

Public Constructors

 | Name | Description
Public method | ApaxAPI | Initializes a new instance of the ApaxAPI class.
Top

Public Fields

Name | Description
DevErrorCode |
ERR_ACCESS_DENIED |
ERR_ACQSTOP_FAILED |
ERR_ApiException |
ERR_CHANNEL_INVALID |
ERR_COMMAND_FAILED |
ERR_CONFIG_FAILED |
ERR_DEVICE_NON |
ERR_DSPFLAG_INVALID |
ERR_FIFO_DATAFAILED |
ERR_FIFO_FULL |
ERR_FIFO_NOTREADY |
ERR_FREQMEASU_FAILED |
ERR_FUNC_INVALID |
ERR_HANDLE_INVALID |
ERR_INTERNAL_FAILED |
ERR_INTRINIT_FAILED |
ERR_LENGTH_INVALID |
ERR_MALLOC_FAILED |
ERR_MAPADDR_FAILED |
ERR_MODULE_INVALID |
ERR_PARAM_INVALID |
ERR_SLOT_INVALID |
ERR_SUCCESS |
ERR_TIMEOUT |
Top

Public Methods

Name | Description
ADAMDrvClose | Adam controller driver close.
ADAMDrvOpen | Adam Controller driver open.
AI_GetBurnoutFunEnable | Get AI Burnout Function Enable Status.
AI_GetBurnoutValue | Get AI Burnout Function Value.
AI_GetChValOffset | Get AI channel value offset.
AI_GetCjcValue | Get AI CJC value.
AI_GetSampleRate | Get AI sample rate.
AI_SetAutoCalibration | Set AI auto-calibration.
AI_SetBurnoutFunEnable | Set AI Burnout Function.
AI_SetBurnoutValue | Set AI Burnout Function Value.
AI_SetChannelMask | Set AI channel mask.
AI_SetChValOffset | Set AI channel value offset.
AI_SetCjcInitValRecord | Set AI CJC Initial Value Record.
AI_SetIntegrationTime | Set AI integration time.
AI_SetSampleRate | Set AI sample rate.
AI_SetThermoCalibration | Set AI Thermal Couple Calibration Procedure.
AIO_GetChannelStatus | Get AIO channel status.
AIO_GetValue | Get AIO value.
AIO_GetValues | Get AIO values.
AIO_SetRanges | Set AIO ranges.
AIO_SetSpanCalibration | Set AIO span calibration.
AIO_SetZeroCalibration | Set AIO zero calibration.
AO_BufValues | Set the AO buffer values.
AO_GetSaftyValues | Get AO safety setting values.
AO_GetStartupValues | Get AO startup value.
AO_SetCalibrationMode | Set AO calibration mode.
AO_SetSaftyValues | Set the AO values.
AO_SetStartupValues | Set AO startup value.
AO_SetValue | Set AO value.
CNT_ClearAlarmFlags | Clear counter alarm flags.
CNT_ClearOverflows | Clear counter overflow flags.
CNT_ClearValues | Clear counter value. Reset to startup value
CNT_GetAlarmConfig | Get counter alarm configuration.
CNT_GetAlarmFlags | Get counter alarm flags.
CNT_GetChannelMask | Get counter channel mask (Start or stop state).
CNT_GetChannelStatus | Get counter channel status.
CNT_GetCntTypeConfig | Get counter counting type configuration.
CNT_GetFilter | Get counter filter.
CNT_GetGateConfig | Get counter gate configuration.
CNT_GetStartupValues | Get counter startup values.
CNT_GetValue | Get Counter value
CNT_GetValues | Get Counter values
CNT_SetAlarmConfig | Set counter alarm configuration.
CNT_SetChannelMask | Set counter channel mask (Start or stop state).
CNT_SetCntTypeConfig | Set counter counting type configuration.
CNT_SetFilter | Set counter filter.
CNT_SetFreqAcqTime | Set counter frequency acquisition time.
CNT_SetGateConfig | Set Counter gate configuration.
CNT_SetRanges | Set counter ranges.
CNT_SetStartupValues | Set Counter startup values.
DI_GetFilters | Get the DI filter parameters.
DI_SetFilters | Set the DI filter parameters.
DIO_GetSaftyValues | Get DIO safety setting values.
DIO_GetValue | Get DIO value.
DIO_GetValues | Get DIO values.
DIO_SetSaftyValues | Set DIO safety setting values.
DO_BufValues | Set DO buffer values.
DO_SetValue | Set DO value.
DO_SetValues | Set DO values.
OUT_FlushBufValues | Set the slot buffer mask flags.
OUT_GetSaftyEnable | Get safety enable flag.
OUT_SetSaftyEnable | Set safety enable flag.
PWM_GetChannelMask | Get enabled PWM channel mask of the indicated slot.
PWM_GetConfig | Get the channel configuration of the indicated slot.
PWM_SetChannelMask | Set enabled PWM channel mask of the indicated slot.
PWM_SetConfig | Set the channel configuration of the indicated slot.
SYS_GetAllSlotErrorFlag | Get all slot error flags.
SYS_GetAppAStatus | Backup System: Get the application A status.
SYS_GetAppBStatus | Backup System: Get the application B status.
SYS_GetDspChannelFlag | Get dsp channel flag.
SYS_GetERRLED | Get the ERR LED status
SYS_GetFpgaVersion | Get FPGA version.
SYS_GetGlobalActive | Backup System: Get the global active.
SYS_GetGlobalMachineID | Backup System: Get the global machine ID.
SYS_GetGlobalStatus | Backup System: Get the global status.
SYS_GetHeartbeatRun | Backup System: Get the heartbeat run mode.
SYS_GetKwMbData | Get Kw Modbus Data
SYS_GetModuleID | Get the module ID.
SYS_GetModuleID_EX | Get the module ID.
SYS_GetRawData | Get the raw data of DPM.
SYS_GetRUNLED | Get the RUN LED status
SYS_GetSlotInfo | Get slot information.
SYS_GetVersion | Get the driver version.
SYS_SetActMsgPeriod | Set ack message period. (Internal use)
SYS_SetAppAHeartbeat | Backup System: Set the application A heartbeat.
SYS_SetAppBHeartbeat | Backup System: Set the application B heartbeat.
SYS_SetCmdWriteRead | Internal used. DO NOT call this function in your program.
SYS_SetCommLock | Internal used. DO NOT call this function in your program.
SYS_SetDownloadMode | Set download mode. (Internal use)
SYS_SetDownloadPacket | Set download data packet. (Internal use)
SYS_SetDownloadStart | Set download start flag. (Internal use)
SYS_SetDspChannelFlag | Set dsp channel flag.
SYS_SetERRLED | Set the ERR LED status
SYS_SetGlobalHeartbeat | Backup System: Set the global heartbeat.
SYS_SetHeartbeatRun | Backup System: Set the heartbeat run mode.
SYS_SetInnerTimeout | Set the inner timeout.
SYS_SetKwMbData | Set Kw Modbus Data
SYS_SetLocateModule | Set module locate function.
SYS_SetRUNLED | Set the RUN LED status
TOOL_SetCmdWrite5Read10 | Internal used. DO NOT call this function in your program.
TOOL_SetCmdWriteReadRet | Internal used. DO NOT call this function in your program.
Top

See Also

ApaxAPI Class
Advantech.Common Namespace


ApaxAPI Constructor

ApaxAPI Constructor
[image]

Initializes a new instance of the ApaxAPI class.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApaxAPI()
C++
public:
ApaxAPI() sealed
J#
public ApaxAPI()
JScript
public function ApaxAPI()

See Also

ApaxAPI Class
Advantech.Common Namespace


Fields

ApaxAPI Fields
[image]

Public Fields

Name | Description
DevErrorCode |
ERR_ACCESS_DENIED |
ERR_ACQSTOP_FAILED |
ERR_ApiException |
ERR_CHANNEL_INVALID |
ERR_COMMAND_FAILED |
ERR_CONFIG_FAILED |
ERR_DEVICE_NON |
ERR_DSPFLAG_INVALID |
ERR_FIFO_DATAFAILED |
ERR_FIFO_FULL |
ERR_FIFO_NOTREADY |
ERR_FREQMEASU_FAILED |
ERR_FUNC_INVALID |
ERR_HANDLE_INVALID |
ERR_INTERNAL_FAILED |
ERR_INTRINIT_FAILED |
ERR_LENGTH_INVALID |
ERR_MALLOC_FAILED |
ERR_MAPADDR_FAILED |
ERR_MODULE_INVALID |
ERR_PARAM_INVALID |
ERR_SLOT_INVALID |
ERR_SUCCESS |
ERR_TIMEOUT |
Top

See Also

ApaxAPI Class
Advantech.Common Namespace


DevErrorCode Field

ApaxAPI.DevErrorCode Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DevErrorCode As Integer
C#
public static readonly int DevErrorCode;
C++
public:
static const int DevErrorCode;
J#
public static final int DevErrorCode
JScript
public static const var DevErrorCode : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_ACCESS_DENIED Field

ApaxAPI.ERR_ACCESS_DENIED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_ACCESS_DENIED As Integer
C#
public static readonly int ERR_ACCESS_DENIED;
C++
public:
static const int ERR_ACCESS_DENIED;
J#
public static final int ERR_ACCESS_DENIED
JScript
public static const var ERR_ACCESS_DENIED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_ACQSTOP_FAILED Field

ApaxAPI.ERR_ACQSTOP_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_ACQSTOP_FAILED As Integer
C#
public static readonly int ERR_ACQSTOP_FAILED;
C++
public:
static const int ERR_ACQSTOP_FAILED;
J#
public static final int ERR_ACQSTOP_FAILED
JScript
public static const var ERR_ACQSTOP_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_ApiException Field

ApaxAPI.ERR_ApiException Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_ApiException As Integer
C#
public static readonly int ERR_ApiException;
C++
public:
static const int ERR_ApiException;
J#
public static final int ERR_ApiException
JScript
public static const var ERR_ApiException : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_CHANNEL_INVALID Field

ApaxAPI.ERR_CHANNEL_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_CHANNEL_INVALID As Integer
C#
public static readonly int ERR_CHANNEL_INVALID;
C++
public:
static const int ERR_CHANNEL_INVALID;
J#
public static final int ERR_CHANNEL_INVALID
JScript
public static const var ERR_CHANNEL_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_COMMAND_FAILED Field

ApaxAPI.ERR_COMMAND_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_COMMAND_FAILED As Integer
C#
public static readonly int ERR_COMMAND_FAILED;
C++
public:
static const int ERR_COMMAND_FAILED;
J#
public static final int ERR_COMMAND_FAILED
JScript
public static const var ERR_COMMAND_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_CONFIG_FAILED Field

ApaxAPI.ERR_CONFIG_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_CONFIG_FAILED As Integer
C#
public static readonly int ERR_CONFIG_FAILED;
C++
public:
static const int ERR_CONFIG_FAILED;
J#
public static final int ERR_CONFIG_FAILED
JScript
public static const var ERR_CONFIG_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_DEVICE_NON Field

ApaxAPI.ERR_DEVICE_NON Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_DEVICE_NON As Integer
C#
public static readonly int ERR_DEVICE_NON;
C++
public:
static const int ERR_DEVICE_NON;
J#
public static final int ERR_DEVICE_NON
JScript
public static const var ERR_DEVICE_NON : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_DSPFLAG_INVALID Field

ApaxAPI.ERR_DSPFLAG_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_DSPFLAG_INVALID As Integer
C#
public static readonly int ERR_DSPFLAG_INVALID;
C++
public:
static const int ERR_DSPFLAG_INVALID;
J#
public static final int ERR_DSPFLAG_INVALID
JScript
public static const var ERR_DSPFLAG_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_FIFO_DATAFAILED Field

ApaxAPI.ERR_FIFO_DATAFAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_FIFO_DATAFAILED As Integer
C#
public static readonly int ERR_FIFO_DATAFAILED;
C++
public:
static const int ERR_FIFO_DATAFAILED;
J#
public static final int ERR_FIFO_DATAFAILED
JScript
public static const var ERR_FIFO_DATAFAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_FIFO_FULL Field

ApaxAPI.ERR_FIFO_FULL Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_FIFO_FULL As Integer
C#
public static readonly int ERR_FIFO_FULL;
C++
public:
static const int ERR_FIFO_FULL;
J#
public static final int ERR_FIFO_FULL
JScript
public static const var ERR_FIFO_FULL : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_FIFO_NOTREADY Field

ApaxAPI.ERR_FIFO_NOTREADY Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_FIFO_NOTREADY As Integer
C#
public static readonly int ERR_FIFO_NOTREADY;
C++
public:
static const int ERR_FIFO_NOTREADY;
J#
public static final int ERR_FIFO_NOTREADY
JScript
public static const var ERR_FIFO_NOTREADY : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_FREQMEASU_FAILED Field

ApaxAPI.ERR_FREQMEASU_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_FREQMEASU_FAILED As Integer
C#
public static readonly int ERR_FREQMEASU_FAILED;
C++
public:
static const int ERR_FREQMEASU_FAILED;
J#
public static final int ERR_FREQMEASU_FAILED
JScript
public static const var ERR_FREQMEASU_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_FUNC_INVALID Field

ApaxAPI.ERR_FUNC_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_FUNC_INVALID As Integer
C#
public static readonly int ERR_FUNC_INVALID;
C++
public:
static const int ERR_FUNC_INVALID;
J#
public static final int ERR_FUNC_INVALID
JScript
public static const var ERR_FUNC_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_HANDLE_INVALID Field

ApaxAPI.ERR_HANDLE_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_HANDLE_INVALID As Integer
C#
public static readonly int ERR_HANDLE_INVALID;
C++
public:
static const int ERR_HANDLE_INVALID;
J#
public static final int ERR_HANDLE_INVALID
JScript
public static const var ERR_HANDLE_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_INTERNAL_FAILED Field

ApaxAPI.ERR_INTERNAL_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_INTERNAL_FAILED As Integer
C#
public static readonly int ERR_INTERNAL_FAILED;
C++
public:
static const int ERR_INTERNAL_FAILED;
J#
public static final int ERR_INTERNAL_FAILED
JScript
public static const var ERR_INTERNAL_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_INTRINIT_FAILED Field

ApaxAPI.ERR_INTRINIT_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_INTRINIT_FAILED As Integer
C#
public static readonly int ERR_INTRINIT_FAILED;
C++
public:
static const int ERR_INTRINIT_FAILED;
J#
public static final int ERR_INTRINIT_FAILED
JScript
public static const var ERR_INTRINIT_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_LENGTH_INVALID Field

ApaxAPI.ERR_LENGTH_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_LENGTH_INVALID As Integer
C#
public static readonly int ERR_LENGTH_INVALID;
C++
public:
static const int ERR_LENGTH_INVALID;
J#
public static final int ERR_LENGTH_INVALID
JScript
public static const var ERR_LENGTH_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_MALLOC_FAILED Field

ApaxAPI.ERR_MALLOC_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_MALLOC_FAILED As Integer
C#
public static readonly int ERR_MALLOC_FAILED;
C++
public:
static const int ERR_MALLOC_FAILED;
J#
public static final int ERR_MALLOC_FAILED
JScript
public static const var ERR_MALLOC_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_MAPADDR_FAILED Field

ApaxAPI.ERR_MAPADDR_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_MAPADDR_FAILED As Integer
C#
public static readonly int ERR_MAPADDR_FAILED;
C++
public:
static const int ERR_MAPADDR_FAILED;
J#
public static final int ERR_MAPADDR_FAILED
JScript
public static const var ERR_MAPADDR_FAILED : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_MODULE_INVALID Field

ApaxAPI.ERR_MODULE_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_MODULE_INVALID As Integer
C#
public static readonly int ERR_MODULE_INVALID;
C++
public:
static const int ERR_MODULE_INVALID;
J#
public static final int ERR_MODULE_INVALID
JScript
public static const var ERR_MODULE_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_PARAM_INVALID Field

ApaxAPI.ERR_PARAM_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_PARAM_INVALID As Integer
C#
public static readonly int ERR_PARAM_INVALID;
C++
public:
static const int ERR_PARAM_INVALID;
J#
public static final int ERR_PARAM_INVALID
JScript
public static const var ERR_PARAM_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_SLOT_INVALID Field

ApaxAPI.ERR_SLOT_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_SLOT_INVALID As Integer
C#
public static readonly int ERR_SLOT_INVALID;
C++
public:
static const int ERR_SLOT_INVALID;
J#
public static final int ERR_SLOT_INVALID
JScript
public static const var ERR_SLOT_INVALID : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_SUCCESS Field

ApaxAPI.ERR_SUCCESS Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_SUCCESS As Integer
C#
public static readonly int ERR_SUCCESS;
C++
public:
static const int ERR_SUCCESS;
J#
public static final int ERR_SUCCESS
JScript
public static const var ERR_SUCCESS : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


ERR_TIMEOUT Field

ApaxAPI.ERR_TIMEOUT Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ERR_TIMEOUT As Integer
C#
public static readonly int ERR_TIMEOUT;
C++
public:
static const int ERR_TIMEOUT;
J#
public static final int ERR_TIMEOUT
JScript
public static const var ERR_TIMEOUT : int;

See Also

ApaxAPI Class
Advantech.Common Namespace


Methods

ApaxAPI Methods
[image]

Public Methods

Name | Description
ADAMDrvClose | Adam controller driver close.
ADAMDrvOpen | Adam Controller driver open.
AI_GetBurnoutFunEnable | Get AI Burnout Function Enable Status.
AI_GetBurnoutValue | Get AI Burnout Function Value.
AI_GetChValOffset | Get AI channel value offset.
AI_GetCjcValue | Get AI CJC value.
AI_GetSampleRate | Get AI sample rate.
AI_SetAutoCalibration | Set AI auto-calibration.
AI_SetBurnoutFunEnable | Set AI Burnout Function.
AI_SetBurnoutValue | Set AI Burnout Function Value.
AI_SetChannelMask | Set AI channel mask.
AI_SetChValOffset | Set AI channel value offset.
AI_SetCjcInitValRecord | Set AI CJC Initial Value Record.
AI_SetIntegrationTime | Set AI integration time.
AI_SetSampleRate | Set AI sample rate.
AI_SetThermoCalibration | Set AI Thermal Couple Calibration Procedure.
AIO_GetChannelStatus | Get AIO channel status.
AIO_GetValue | Get AIO value.
AIO_GetValues | Get AIO values.
AIO_SetRanges | Set AIO ranges.
AIO_SetSpanCalibration | Set AIO span calibration.
AIO_SetZeroCalibration | Set AIO zero calibration.
AO_BufValues | Set the AO buffer values.
AO_GetSaftyValues | Get AO safety setting values.
AO_GetStartupValues | Get AO startup value.
AO_SetCalibrationMode | Set AO calibration mode.
AO_SetSaftyValues | Set the AO values.
AO_SetStartupValues | Set AO startup value.
AO_SetValue | Set AO value.
CNT_ClearAlarmFlags | Clear counter alarm flags.
CNT_ClearOverflows | Clear counter overflow flags.
CNT_ClearValues | Clear counter value. Reset to startup value
CNT_GetAlarmConfig | Get counter alarm configuration.
CNT_GetAlarmFlags | Get counter alarm flags.
CNT_GetChannelMask | Get counter channel mask (Start or stop state).
CNT_GetChannelStatus | Get counter channel status.
CNT_GetCntTypeConfig | Get counter counting type configuration.
CNT_GetFilter | Get counter filter.
CNT_GetGateConfig | Get counter gate configuration.
CNT_GetStartupValues | Get counter startup values.
CNT_GetValue | Get Counter value
CNT_GetValues | Get Counter values
CNT_SetAlarmConfig | Set counter alarm configuration.
CNT_SetChannelMask | Set counter channel mask (Start or stop state).
CNT_SetCntTypeConfig | Set counter counting type configuration.
CNT_SetFilter | Set counter filter.
CNT_SetFreqAcqTime | Set counter frequency acquisition time.
CNT_SetGateConfig | Set Counter gate configuration.
CNT_SetRanges | Set counter ranges.
CNT_SetStartupValues | Set Counter startup values.
DI_GetFilters | Get the DI filter parameters.
DI_SetFilters | Set the DI filter parameters.
DIO_GetSaftyValues | Get DIO safety setting values.
DIO_GetValue | Get DIO value.
DIO_GetValues | Get DIO values.
DIO_SetSaftyValues | Set DIO safety setting values.
DO_BufValues | Set DO buffer values.
DO_SetValue | Set DO value.
DO_SetValues | Set DO values.
OUT_FlushBufValues | Set the slot buffer mask flags.
OUT_GetSaftyEnable | Get safety enable flag.
OUT_SetSaftyEnable | Set safety enable flag.
PWM_GetChannelMask | Get enabled PWM channel mask of the indicated slot.
PWM_GetConfig | Get the channel configuration of the indicated slot.
PWM_SetChannelMask | Set enabled PWM channel mask of the indicated slot.
PWM_SetConfig | Set the channel configuration of the indicated slot.
SYS_GetAllSlotErrorFlag | Get all slot error flags.
SYS_GetAppAStatus | Backup System: Get the application A status.
SYS_GetAppBStatus | Backup System: Get the application B status.
SYS_GetDspChannelFlag | Get dsp channel flag.
SYS_GetERRLED | Get the ERR LED status
SYS_GetFpgaVersion | Get FPGA version.
SYS_GetGlobalActive | Backup System: Get the global active.
SYS_GetGlobalMachineID | Backup System: Get the global machine ID.
SYS_GetGlobalStatus | Backup System: Get the global status.
SYS_GetHeartbeatRun | Backup System: Get the heartbeat run mode.
SYS_GetKwMbData | Get Kw Modbus Data
SYS_GetModuleID | Get the module ID.
SYS_GetModuleID_EX | Get the module ID.
SYS_GetRawData | Get the raw data of DPM.
SYS_GetRUNLED | Get the RUN LED status
SYS_GetSlotInfo | Get slot information.
SYS_GetVersion | Get the driver version.
SYS_SetActMsgPeriod | Set ack message period. (Internal use)
SYS_SetAppAHeartbeat | Backup System: Set the application A heartbeat.
SYS_SetAppBHeartbeat | Backup System: Set the application B heartbeat.
SYS_SetCmdWriteRead | Internal used. DO NOT call this function in your program.
SYS_SetCommLock | Internal used. DO NOT call this function in your program.
SYS_SetDownloadMode | Set download mode. (Internal use)
SYS_SetDownloadPacket | Set download data packet. (Internal use)
SYS_SetDownloadStart | Set download start flag. (Internal use)
SYS_SetDspChannelFlag | Set dsp channel flag.
SYS_SetERRLED | Set the ERR LED status
SYS_SetGlobalHeartbeat | Backup System: Set the global heartbeat.
SYS_SetHeartbeatRun | Backup System: Set the heartbeat run mode.
SYS_SetInnerTimeout | Set the inner timeout.
SYS_SetKwMbData | Set Kw Modbus Data
SYS_SetLocateModule | Set module locate function.
SYS_SetRUNLED | Set the RUN LED status
TOOL_SetCmdWrite5Read10 | Internal used. DO NOT call this function in your program.
TOOL_SetCmdWriteReadRet | Internal used. DO NOT call this function in your program.
Top

See Also

ApaxAPI Class
Advantech.Common Namespace


ADAMDrvClose Method

ApaxAPI.ADAMDrvClose Method
[image]

Adam controller driver close.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "ADAMDrvClose", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ADAMDrvClose( _
ByRef handle As Integer _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "ADAMDrvClose", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ADAMDrvClose(
ref int handle
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"ADAMDrvClose", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ADAMDrvClose(
int% handle
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "ADAMDrvClose", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ADAMDrvClose(
int handle
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "ADAMDrvClose", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ADAMDrvClose(
handle : int
) : int

Parameters

handle
The driver handle.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


ADAMDrvOpen Method

ApaxAPI.ADAMDrvOpen Method
[image]

Adam Controller driver open.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "ADAMDrvOpen", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function ADAMDrvOpen( _
ByRef handle As Integer _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "ADAMDrvOpen", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int ADAMDrvOpen(
ref int handle
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"ADAMDrvOpen", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int ADAMDrvOpen(
int% handle
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "ADAMDrvOpen", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int ADAMDrvOpen(
int handle
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "ADAMDrvOpen", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function ADAMDrvOpen(
handle : int
) : int

Parameters

handle
The driver handle.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_GetBurnoutFunEnable Method

ApaxAPI.AI_GetBurnoutFunEnable Method
[image]

Get AI Burnout Function Enable Status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_GetBurnoutFunEnable", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetBurnoutFunEnable( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwEnableMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetBurnoutFunEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetBurnoutFunEnable(
int handle,
ushort i_usSlot,
out uint o_dwEnableMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_GetBurnoutFunEnable", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetBurnoutFunEnable(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwEnableMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetBurnoutFunEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetBurnoutFunEnable(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwEnableMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetBurnoutFunEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetBurnoutFunEnable(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwEnableMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwEnableMask
The Burnout Enable Status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_GetBurnoutValue Method

ApaxAPI.AI_GetBurnoutValue Method
[image]

Get AI Burnout Function Value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_GetBurnoutValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetBurnoutValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwVal As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetBurnoutValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetBurnoutValue(
int handle,
ushort i_usSlot,
out uint o_dwVal
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_GetBurnoutValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetBurnoutValue(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwVal
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetBurnoutValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetBurnoutValue(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwVal
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetBurnoutValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetBurnoutValue(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwVal : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwVal
The Burnout Function Value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_GetChValOffset Method

ApaxAPI.AI_GetChValOffset Method
[image]

Get AI channel value offset.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_GetChValOffset", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetChValOffset( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannel As UInt16, _
<OutAttribute> ByRef o_dwVal As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetChValOffset", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetChValOffset(
int handle,
ushort i_usSlot,
ushort i_wChannel,
out uint o_dwVal
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_GetChValOffset", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetChValOffset(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannel,
[OutAttribute] unsigned int% o_dwVal
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetChValOffset", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetChValOffset(
int handle,
ushort i_usSlot,
ushort i_wChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwVal
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetChValOffset", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetChValOffset(
handle : int,
i_usSlot : UInt16,
i_wChannel : UInt16,
OutAttribute o_dwVal : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannel
The channel ID which is ranged from 0 to 31.
o_dwVal
The channel value offset.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_GetCjcValue Method

ApaxAPI.AI_GetCjcValue Method
[image]

Get AI CJC value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_GetCjcValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetCjcValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwVal As UInt32, _
<OutAttribute> ByRef o_byStatus As Byte _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetCjcValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetCjcValue(
int handle,
ushort i_usSlot,
out uint o_dwVal,
out byte o_byStatus
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_GetCjcValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetCjcValue(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwVal,
[OutAttribute] char% o_byStatus
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetCjcValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetCjcValue(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwVal,
/** @attribute OutAttribute() */ /** @ref */ byte o_byStatus
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetCjcValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetCjcValue(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwVal : UInt32,
OutAttribute o_byStatus : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwVal
The CJC value.
o_byStatus
The CJC status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_GetSampleRate Method

ApaxAPI.AI_GetSampleRate Method
[image]

Get AI sample rate.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_GetSampleRate", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_GetSampleRate( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwRate As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_GetSampleRate(
int handle,
ushort i_usSlot,
out uint o_dwRate
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_GetSampleRate", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_GetSampleRate(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwRate
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_GetSampleRate(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwRate
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_GetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_GetSampleRate(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwRate : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwRate
The AI sample rate.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetAutoCalibration Method

ApaxAPI.AI_SetAutoCalibration Method
[image]

Set AI auto-calibration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetAutoCalibration", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetAutoCalibration( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetAutoCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetAutoCalibration(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetAutoCalibration", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetAutoCalibration(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetAutoCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetAutoCalibration(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetAutoCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetAutoCalibration(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetBurnoutFunEnable Method

ApaxAPI.AI_SetBurnoutFunEnable Method
[image]

Set AI Burnout Function.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetBurnoutFunEnable", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetBurnoutFunEnable( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwEnableMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetBurnoutFunEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetBurnoutFunEnable(
int handle,
ushort i_usSlot,
uint i_dwEnableMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetBurnoutFunEnable", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetBurnoutFunEnable(
int handle,
unsigned short i_usSlot,
unsigned int i_dwEnableMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetBurnoutFunEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetBurnoutFunEnable(
int handle,
ushort i_usSlot,
uint i_dwEnableMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetBurnoutFunEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetBurnoutFunEnable(
handle : int,
i_usSlot : UInt16,
i_dwEnableMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwEnableMask
The channel burnout function enable mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetBurnoutValue Method

ApaxAPI.AI_SetBurnoutValue Method
[image]

Set AI Burnout Function Value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetBurnoutValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetBurnoutValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetBurnoutValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetBurnoutValue(
int handle,
ushort i_usSlot,
uint i_dwValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetBurnoutValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetBurnoutValue(
int handle,
unsigned short i_usSlot,
unsigned int i_dwValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetBurnoutValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetBurnoutValue(
int handle,
ushort i_usSlot,
uint i_dwValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetBurnoutValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetBurnoutValue(
handle : int,
i_usSlot : UInt16,
i_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwValue
The channel burnout function enable mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetChannelMask Method

ApaxAPI.AI_SetChannelMask Method
[image]

Set AI channel mask.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetChannelMask", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetChannelMask( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetChannelMask(
int handle,
ushort i_usSlot,
uint i_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetChannelMask", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetChannelMask(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetChannelMask(
int handle,
ushort i_usSlot,
uint i_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetChannelMask(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwMask
The channel mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetChValOffset Method

ApaxAPI.AI_SetChValOffset Method
[image]

Set AI channel value offset.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetChValOffset", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetChValOffset( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannel As UInt16, _
ByVal i_dwVal As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetChValOffset", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetChValOffset(
int handle,
ushort i_usSlot,
ushort i_wChannel,
uint i_dwVal
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetChValOffset", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetChValOffset(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannel,
unsigned int i_dwVal
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetChValOffset", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetChValOffset(
int handle,
ushort i_usSlot,
ushort i_wChannel,
uint i_dwVal
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetChValOffset", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetChValOffset(
handle : int,
i_usSlot : UInt16,
i_wChannel : UInt16,
i_dwVal : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannel
The channel ID which is ranged from 0 to 31.
i_dwVal
The channel value offset.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetCjcInitValRecord Method

ApaxAPI.AI_SetCjcInitValRecord Method
[image]

Set AI CJC Initial Value Record.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetCjcInitValRecord", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetCjcInitValRecord( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetCjcInitValRecord", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetCjcInitValRecord(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetCjcInitValRecord", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetCjcInitValRecord(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetCjcInitValRecord", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetCjcInitValRecord(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetCjcInitValRecord", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetCjcInitValRecord(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetIntegrationTime Method

ApaxAPI.AI_SetIntegrationTime Method
[image]

Set AI integration time.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetIntegrationTime", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetIntegrationTime( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwIntegration As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetIntegrationTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetIntegrationTime(
int handle,
ushort i_usSlot,
uint i_dwIntegration
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetIntegrationTime", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetIntegrationTime(
int handle,
unsigned short i_usSlot,
unsigned int i_dwIntegration
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetIntegrationTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetIntegrationTime(
int handle,
ushort i_usSlot,
uint i_dwIntegration
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetIntegrationTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetIntegrationTime(
handle : int,
i_usSlot : UInt16,
i_dwIntegration : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwIntegration
The channel mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetSampleRate Method

ApaxAPI.AI_SetSampleRate Method
[image]

Set AI sample rate.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetSampleRate", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetSampleRate( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwRate As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetSampleRate(
int handle,
ushort i_usSlot,
uint i_dwRate
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetSampleRate", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetSampleRate(
int handle,
unsigned short i_usSlot,
unsigned int i_dwRate
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetSampleRate(
int handle,
ushort i_usSlot,
uint i_dwRate
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetSampleRate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetSampleRate(
handle : int,
i_usSlot : UInt16,
i_dwRate : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwRate
The AI sample rate.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AI_SetThermoCalibration Method

ApaxAPI.AI_SetThermoCalibration Method
[image]

Set AI Thermal Couple Calibration Procedure.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AI_SetThermoCalibration", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AI_SetThermoCalibration( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetThermoCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AI_SetThermoCalibration(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AI_SetThermoCalibration", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AI_SetThermoCalibration(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetThermoCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AI_SetThermoCalibration(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AI_SetThermoCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AI_SetThermoCalibration(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AIO_GetChannelStatus Method

ApaxAPI.AIO_GetChannelStatus Method
[image]

Get AIO channel status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AIO_GetChannelStatus", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AIO_GetChannelStatus( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_byValues As Byte() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetChannelStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AIO_GetChannelStatus(
int handle,
ushort i_usSlot,
byte[] o_byValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AIO_GetChannelStatus", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AIO_GetChannelStatus(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<char>^ o_byValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetChannelStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AIO_GetChannelStatus(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ byte[] o_byValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetChannelStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AIO_GetChannelStatus(
handle : int,
i_usSlot : UInt16,
OutAttribute o_byValues : Byte[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_byValues
The AIO channel status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AIO_GetValue Method

ApaxAPI.AIO_GetValue Method
[image]

Get AIO value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AIO_GetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AIO_GetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_wValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AIO_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out ushort o_wValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AIO_GetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AIO_GetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] unsigned short% o_wValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AIO_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AIO_GetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_wValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_wValue
The AIO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AIO_GetValues Method

ApaxAPI.AIO_GetValues Method
[image]

Get AIO values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AIO_GetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AIO_GetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_wValues As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AIO_GetValues(
int handle,
ushort i_usSlot,
ushort[] o_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AIO_GetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AIO_GetValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<unsigned short>^ o_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AIO_GetValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ ushort[] o_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AIO_GetValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_wValues : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_wValues
The AIO values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AIO_SetRanges Method

ApaxAPI.AIO_SetRanges Method
[image]

Set AIO ranges.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AIO_SetRanges", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AIO_SetRanges( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannelTotal As UInt16, _
ByVal i_wRanges As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetRanges", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AIO_SetRanges(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] i_wRanges
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AIO_SetRanges", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AIO_SetRanges(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannelTotal,
array<unsigned short>^ i_wRanges
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetRanges", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AIO_SetRanges(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] i_wRanges
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetRanges", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AIO_SetRanges(
handle : int,
i_usSlot : UInt16,
i_wChannelTotal : UInt16,
i_wRanges : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannelTotal
The channel number.
i_wRanges
The AIO ranges.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AIO_SetSpanCalibration Method

ApaxAPI.AIO_SetSpanCalibration Method
[image]

Set AIO span calibration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AIO_SetSpanCalibration", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AIO_SetSpanCalibration( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannel As UInt16, _
ByVal i_wType As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetSpanCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AIO_SetSpanCalibration(
int handle,
ushort i_usSlot,
ushort i_wChannel,
ushort i_wType
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AIO_SetSpanCalibration", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AIO_SetSpanCalibration(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannel,
unsigned short i_wType
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetSpanCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AIO_SetSpanCalibration(
int handle,
ushort i_usSlot,
ushort i_wChannel,
ushort i_wType
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetSpanCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AIO_SetSpanCalibration(
handle : int,
i_usSlot : UInt16,
i_wChannel : UInt16,
i_wType : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannel
The channel ID which is ranged from 0 to 31.
i_wType
The type value to be set. Currently, it is ignored.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AIO_SetZeroCalibration Method

ApaxAPI.AIO_SetZeroCalibration Method
[image]

Set AIO zero calibration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AIO_SetZeroCalibration", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AIO_SetZeroCalibration( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannel As UInt16, _
ByVal i_wType As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetZeroCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AIO_SetZeroCalibration(
int handle,
ushort i_usSlot,
ushort i_wChannel,
ushort i_wType
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AIO_SetZeroCalibration", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AIO_SetZeroCalibration(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannel,
unsigned short i_wType
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetZeroCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AIO_SetZeroCalibration(
int handle,
ushort i_usSlot,
ushort i_wChannel,
ushort i_wType
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AIO_SetZeroCalibration", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AIO_SetZeroCalibration(
handle : int,
i_usSlot : UInt16,
i_wChannel : UInt16,
i_wType : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannel
The channel ID which is ranged from 0 to 31.
i_wType
The type value to be set. Currently, it is ingnored.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AO_BufValues Method

ApaxAPI.AO_BufValues Method
[image]

Set the AO buffer values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AO_BufValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_BufValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32, _
ByVal i_wValues As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_BufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_BufValues(
int handle,
ushort i_usSlot,
uint i_dwMask,
ushort[] i_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AO_BufValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_BufValues(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask,
array<unsigned short>^ i_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_BufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_BufValues(
int handle,
ushort i_usSlot,
uint i_dwMask,
ushort[] i_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_BufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_BufValues(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32,
i_wValues : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwMask
Channel mask.
i_wValues
The AO buffer values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AO_GetSaftyValues Method

ApaxAPI.AO_GetSaftyValues Method
[image]

Get AO safety setting values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AO_GetSaftyValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_GetSaftyValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannelTotal As UInt16, _
<OutAttribute> ByVal o_wValues As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_GetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_GetSaftyValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] o_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AO_GetSaftyValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_GetSaftyValues(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannelTotal,
[OutAttribute] array<unsigned short>^ o_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_GetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_GetSaftyValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
/** @attribute OutAttribute() */ ushort[] o_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_GetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_GetSaftyValues(
handle : int,
i_usSlot : UInt16,
i_wChannelTotal : UInt16,
OutAttribute o_wValues : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannelTotal
The channel number.
o_wValues
The AIO safety setting values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AO_GetStartupValues Method

ApaxAPI.AO_GetStartupValues Method
[image]

Get AO startup value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AO_GetStartupValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_GetStartupValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannelTotal As UInt16, _
<OutAttribute> ByVal o_wValues As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_GetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_GetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] o_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AO_GetStartupValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_GetStartupValues(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannelTotal,
[OutAttribute] array<unsigned short>^ o_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_GetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_GetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
/** @attribute OutAttribute() */ ushort[] o_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_GetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_GetStartupValues(
handle : int,
i_usSlot : UInt16,
i_wChannelTotal : UInt16,
OutAttribute o_wValues : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannelTotal
The channel number.
o_wValues
The AO startup values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AO_SetCalibrationMode Method

ApaxAPI.AO_SetCalibrationMode Method
[image]

Set AO calibration mode.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AO_SetCalibrationMode", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_SetCalibrationMode( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetCalibrationMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_SetCalibrationMode(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AO_SetCalibrationMode", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_SetCalibrationMode(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetCalibrationMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_SetCalibrationMode(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetCalibrationMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_SetCalibrationMode(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AO_SetSaftyValues Method

ApaxAPI.AO_SetSaftyValues Method
[image]

Set the AO values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AO_SetSaftyValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_SetSaftyValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32, _
ByVal i_wValues As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_SetSaftyValues(
int handle,
ushort i_usSlot,
uint i_dwMask,
ushort[] i_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AO_SetSaftyValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_SetSaftyValues(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask,
array<unsigned short>^ i_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_SetSaftyValues(
int handle,
ushort i_usSlot,
uint i_dwMask,
ushort[] i_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_SetSaftyValues(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32,
i_wValues : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwMask
Channel mask.
i_wValues
The AO values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AO_SetStartupValues Method

ApaxAPI.AO_SetStartupValues Method
[image]

Set AO startup value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AO_SetStartupValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_SetStartupValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannelTotal As UInt16, _
ByVal i_wValues As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_SetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] i_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AO_SetStartupValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_SetStartupValues(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannelTotal,
array<unsigned short>^ i_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_SetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] i_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_SetStartupValues(
handle : int,
i_usSlot : UInt16,
i_wChannelTotal : UInt16,
i_wValues : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannelTotal
The channel number.
i_wValues
The AO startup values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


AO_SetValue Method

ApaxAPI.AO_SetValue Method
[image]

Set AO value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "AO_SetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function AO_SetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_wValue As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int AO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
ushort i_wValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"AO_SetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int AO_SetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
unsigned short i_wValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int AO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
ushort i_wValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "AO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function AO_SetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_wValue : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_wValue
The AO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_ClearAlarmFlags Method

ApaxAPI.CNT_ClearAlarmFlags Method
[image]

Clear counter alarm flags.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_ClearAlarmFlags", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_ClearAlarmFlags( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearAlarmFlags", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_ClearAlarmFlags(
int handle,
ushort i_usSlot,
uint i_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_ClearAlarmFlags", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_ClearAlarmFlags(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearAlarmFlags", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_ClearAlarmFlags(
int handle,
ushort i_usSlot,
uint i_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearAlarmFlags", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_ClearAlarmFlags(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwMask
The alarm channel mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_ClearOverflows Method

ApaxAPI.CNT_ClearOverflows Method
[image]

Clear counter overflow flags.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_ClearOverflows", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_ClearOverflows( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearOverflows", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_ClearOverflows(
int handle,
ushort i_usSlot,
uint i_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_ClearOverflows", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_ClearOverflows(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearOverflows", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_ClearOverflows(
int handle,
ushort i_usSlot,
uint i_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearOverflows", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_ClearOverflows(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwMask
The channel mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_ClearValues Method

ApaxAPI.CNT_ClearValues Method
[image]

Clear counter value. Reset to startup value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_ClearValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_ClearValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_ClearValues(
int handle,
ushort i_usSlot,
uint i_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_ClearValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_ClearValues(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_ClearValues(
int handle,
ushort i_usSlot,
uint i_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_ClearValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_ClearValues(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwMask
The channel mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetAlarmConfig Method

ApaxAPI.CNT_GetAlarmConfig Method
[image]

Get counter alarm configuration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetAlarmConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetAlarmConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usAlarmIndex As UInt16, _
<OutAttribute> ByRef o_bEnable As Boolean, _
<OutAttribute> ByRef o_bAutoReloadEn As Boolean, _
<OutAttribute> ByRef o_byType As Byte, _
<OutAttribute> ByRef o_byMappingCh As Byte, _
<OutAttribute> ByRef o_dwLimitValue As UInt32, _
<OutAttribute> ByRef o_byDoType As Byte, _
<OutAttribute> ByRef o_dwDoPulseWidth As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetAlarmConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetAlarmConfig(
int handle,
ushort i_usSlot,
ushort i_usAlarmIndex,
out bool o_bEnable,
out bool o_bAutoReloadEn,
out byte o_byType,
out byte o_byMappingCh,
out uint o_dwLimitValue,
out byte o_byDoType,
out uint o_dwDoPulseWidth
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetAlarmConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetAlarmConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usAlarmIndex,
[OutAttribute] bool% o_bEnable,
[OutAttribute] bool% o_bAutoReloadEn,
[OutAttribute] char% o_byType,
[OutAttribute] char% o_byMappingCh,
[OutAttribute] unsigned int% o_dwLimitValue,
[OutAttribute] char% o_byDoType,
[OutAttribute] unsigned int% o_dwDoPulseWidth
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetAlarmConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetAlarmConfig(
int handle,
ushort i_usSlot,
ushort i_usAlarmIndex,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAutoReloadEn,
/** @attribute OutAttribute() */ /** @ref */ byte o_byType,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMappingCh,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwLimitValue,
/** @attribute OutAttribute() */ /** @ref */ byte o_byDoType,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwDoPulseWidth
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetAlarmConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetAlarmConfig(
handle : int,
i_usSlot : UInt16,
i_usAlarmIndex : UInt16,
OutAttribute o_bEnable : bool,
OutAttribute o_bAutoReloadEn : bool,
OutAttribute o_byType : Byte,
OutAttribute o_byMappingCh : Byte,
OutAttribute o_dwLimitValue : UInt32,
OutAttribute o_byDoType : Byte,
OutAttribute o_dwDoPulseWidth : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usAlarmIndex
The alarm index, based 0.
o_bEnable
The alarm enable flag.
o_bAutoReloadEn
The alarm auto reload flag.
o_byType
The alarm type.
o_byMappingCh
The alarm counter mapping.
o_dwLimitValue
The alarm limit value.
o_byDoType
The DO behavior type.
o_dwDoPulseWidth
The DO pulse width.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetAlarmFlags Method

ApaxAPI.CNT_GetAlarmFlags Method
[image]

Get counter alarm flags.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetAlarmFlags", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetAlarmFlags( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef i_dwAlarmFlags As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetAlarmFlags", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetAlarmFlags(
int handle,
ushort i_usSlot,
out uint i_dwAlarmFlags
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetAlarmFlags", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetAlarmFlags(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% i_dwAlarmFlags
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetAlarmFlags", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetAlarmFlags(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint i_dwAlarmFlags
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetAlarmFlags", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetAlarmFlags(
handle : int,
i_usSlot : UInt16,
OutAttribute i_dwAlarmFlags : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwAlarmFlags
The alarm flags.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetChannelMask Method

ApaxAPI.CNT_GetChannelMask Method
[image]

Get counter channel mask (Start or stop state).

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetChannelMask", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetChannelMask( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetChannelMask(
int handle,
ushort i_usSlot,
out uint o_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetChannelMask", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetChannelMask(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetChannelMask(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetChannelMask(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwMask
The channel mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetChannelStatus Method

ApaxAPI.CNT_GetChannelStatus Method
[image]

Get counter channel status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetChannelStatus", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetChannelStatus( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_byValues As Byte() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetChannelStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetChannelStatus(
int handle,
ushort i_usSlot,
byte[] o_byValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetChannelStatus", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetChannelStatus(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<char>^ o_byValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetChannelStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetChannelStatus(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ byte[] o_byValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetChannelStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetChannelStatus(
handle : int,
i_usSlot : UInt16,
OutAttribute o_byValues : Byte[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_byValues
The counter channel status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetCntTypeConfig Method

ApaxAPI.CNT_GetCntTypeConfig Method
[image]

Get counter counting type configuration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetCntTypeConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetCntTypeConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_bRepeat As Boolean, _
<OutAttribute> ByRef o_bReload As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetCntTypeConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetCntTypeConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_bRepeat,
out bool o_bReload
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetCntTypeConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetCntTypeConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_bRepeat,
[OutAttribute] bool% o_bReload
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetCntTypeConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetCntTypeConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bRepeat,
/** @attribute OutAttribute() */ /** @ref */ bool o_bReload
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetCntTypeConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetCntTypeConfig(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_bRepeat : bool,
OutAttribute o_bReload : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel index, based 0.
o_bRepeat
Count mode, false:Count once;true:Count repetitively.
o_bReload
Reload mode, true:reload to startup value ;false:reload to 0(OV) or 0xFFFFFFFF(UD).

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetFilter Method

ApaxAPI.CNT_GetFilter Method
[image]

Get counter filter.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetFilter", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetFilter( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetFilter(
int handle,
ushort i_usSlot,
out uint o_dwValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetFilter", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetFilter(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetFilter(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetFilter(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwValue
The Counter filter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetGateConfig Method

ApaxAPI.CNT_GetGateConfig Method
[image]

Get counter gate configuration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetGateConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetGateConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_bEnable As Boolean, _
<OutAttribute> ByRef o_byTriggerMode As Byte, _
<OutAttribute> ByRef o_byGateActiveType As Byte, _
<OutAttribute> ByRef o_byMappingGate As Byte _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetGateConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetGateConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_bEnable,
out byte o_byTriggerMode,
out byte o_byGateActiveType,
out byte o_byMappingGate
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetGateConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetGateConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_bEnable,
[OutAttribute] char% o_byTriggerMode,
[OutAttribute] char% o_byGateActiveType,
[OutAttribute] char% o_byMappingGate
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetGateConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetGateConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bEnable,
/** @attribute OutAttribute() */ /** @ref */ byte o_byTriggerMode,
/** @attribute OutAttribute() */ /** @ref */ byte o_byGateActiveType,
/** @attribute OutAttribute() */ /** @ref */ byte o_byMappingGate
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetGateConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetGateConfig(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_bEnable : bool,
OutAttribute o_byTriggerMode : Byte,
OutAttribute o_byGateActiveType : Byte,
OutAttribute o_byMappingGate : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel index, based 0.
o_bEnable
The counter gate enable flag.
o_byTriggerMode
The counter gate trigger mode. (0:Non-trigger,1:trigger,2:Edge start)
o_byGateActiveType
The gate active type.
o_byMappingGate
The counter gate mapping.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetStartupValues Method

ApaxAPI.CNT_GetStartupValues Method
[image]

Get counter startup values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetStartupValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetStartupValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannelTotal As UInt16, _
<OutAttribute> ByVal o_wValues As UInt32() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
uint[] o_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetStartupValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetStartupValues(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannelTotal,
[OutAttribute] array<unsigned int>^ o_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
/** @attribute OutAttribute() */ uint[] o_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetStartupValues(
handle : int,
i_usSlot : UInt16,
i_wChannelTotal : UInt16,
OutAttribute o_wValues : UInt32[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannelTotal
The channel number.
o_wValues
The counter startup values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetValue Method

ApaxAPI.CNT_GetValue Method
[image]

Get Counter value

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out uint o_dwValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] unsigned int% o_dwValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_dwValue
The Counter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_GetValues Method

ApaxAPI.CNT_GetValues Method
[image]

Get Counter values

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_GetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_GetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_dwValues As UInt32() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_GetValues(
int handle,
ushort i_usSlot,
uint[] o_dwValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_GetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_GetValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<unsigned int>^ o_dwValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_GetValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ uint[] o_dwValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_GetValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwValues : UInt32[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwValues
The Counter values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetAlarmConfig Method

ApaxAPI.CNT_SetAlarmConfig Method
[image]

Set counter alarm configuration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetAlarmConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetAlarmConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usAlarmIndex As UInt16, _
ByVal i_bEnable As Boolean, _
ByVal i_bAutoReloadEn As Boolean, _
ByVal i_byType As Byte, _
ByVal i_byMappingCh As Byte, _
ByVal i_dwLimitValue As UInt32, _
ByVal i_byDoType As Byte, _
ByVal i_dwDoPulseWidth As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetAlarmConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetAlarmConfig(
int handle,
ushort i_usSlot,
ushort i_usAlarmIndex,
bool i_bEnable,
bool i_bAutoReloadEn,
byte i_byType,
byte i_byMappingCh,
uint i_dwLimitValue,
byte i_byDoType,
uint i_dwDoPulseWidth
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetAlarmConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetAlarmConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usAlarmIndex,
bool i_bEnable,
bool i_bAutoReloadEn,
char i_byType,
char i_byMappingCh,
unsigned int i_dwLimitValue,
char i_byDoType,
unsigned int i_dwDoPulseWidth
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetAlarmConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetAlarmConfig(
int handle,
ushort i_usSlot,
ushort i_usAlarmIndex,
bool i_bEnable,
bool i_bAutoReloadEn,
byte i_byType,
byte i_byMappingCh,
uint i_dwLimitValue,
byte i_byDoType,
uint i_dwDoPulseWidth
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetAlarmConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetAlarmConfig(
handle : int,
i_usSlot : UInt16,
i_usAlarmIndex : UInt16,
i_bEnable : bool,
i_bAutoReloadEn : bool,
i_byType : Byte,
i_byMappingCh : Byte,
i_dwLimitValue : UInt32,
i_byDoType : Byte,
i_dwDoPulseWidth : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usAlarmIndex
The alarm index, based 0.
i_bEnable
The alarm enable flag.
i_bAutoReloadEn
The alarm auto reload flag.
i_byType
The alarm type.
i_byMappingCh
The alarm counter mapping.
i_dwLimitValue
The alarm limit value.
i_byDoType
The DO behavior type.
i_dwDoPulseWidth
The DO pulse width.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetChannelMask Method

ApaxAPI.CNT_SetChannelMask Method
[image]

Set counter channel mask (Start or stop state).

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetChannelMask", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetChannelMask( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetChannelMask(
int handle,
ushort i_usSlot,
uint i_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetChannelMask", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetChannelMask(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetChannelMask(
int handle,
ushort i_usSlot,
uint i_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetChannelMask(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwMask
The channel mask.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetCntTypeConfig Method

ApaxAPI.CNT_SetCntTypeConfig Method
[image]

Set counter counting type configuration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetCntTypeConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetCntTypeConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_bRepeat As Boolean, _
ByVal i_bReload As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetCntTypeConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetCntTypeConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bRepeat,
bool i_bReload
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetCntTypeConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetCntTypeConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
bool i_bRepeat,
bool i_bReload
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetCntTypeConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetCntTypeConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bRepeat,
bool i_bReload
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetCntTypeConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetCntTypeConfig(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_bRepeat : bool,
i_bReload : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel index, based 0.
i_bRepeat
Count mode, false:Count once;true:Count repetitively.
i_bReload
Reload mode, true:reload to startup value ;false:reload to 0(OV) or 0xFFFFFFFF(UD).

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetFilter Method

ApaxAPI.CNT_SetFilter Method
[image]

Set counter filter.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetFilter", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetFilter( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetFilter(
int handle,
ushort i_usSlot,
uint i_dwValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetFilter", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetFilter(
int handle,
unsigned short i_usSlot,
unsigned int i_dwValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetFilter(
int handle,
ushort i_usSlot,
uint i_dwValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetFilter", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetFilter(
handle : int,
i_usSlot : UInt16,
i_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwValue
The Counter filter value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetFreqAcqTime Method

ApaxAPI.CNT_SetFreqAcqTime Method
[image]

Set counter frequency acquisition time.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetFreqAcqTime", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetFreqAcqTime( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetFreqAcqTime(
int handle,
ushort i_usSlot,
uint i_dwValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetFreqAcqTime", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetFreqAcqTime(
int handle,
unsigned short i_usSlot,
unsigned int i_dwValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetFreqAcqTime(
int handle,
ushort i_usSlot,
uint i_dwValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetFreqAcqTime", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetFreqAcqTime(
handle : int,
i_usSlot : UInt16,
i_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwValue
The counter frequency acquisition time value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetGateConfig Method

ApaxAPI.CNT_SetGateConfig Method
[image]

Set Counter gate configuration.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetGateConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetGateConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_bEnable As Boolean, _
ByVal i_byTriggerMode As Byte, _
ByVal i_byGateActiveType As Byte, _
ByVal i_byMappingGate As Byte _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetGateConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetGateConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bEnable,
byte i_byTriggerMode,
byte i_byGateActiveType,
byte i_byMappingGate
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetGateConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetGateConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
bool i_bEnable,
char i_byTriggerMode,
char i_byGateActiveType,
char i_byMappingGate
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetGateConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetGateConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bEnable,
byte i_byTriggerMode,
byte i_byGateActiveType,
byte i_byMappingGate
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetGateConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetGateConfig(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_bEnable : bool,
i_byTriggerMode : Byte,
i_byGateActiveType : Byte,
i_byMappingGate : Byte
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel index, based 0.
i_bEnable
The counter gate enable flag.
i_byTriggerMode
The counter gate trigger mode. (0:Non-trigger,1:trigger,2:Edge start)
i_byGateActiveType
The gate active type.
i_byMappingGate
The counter gate mapping.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetRanges Method

ApaxAPI.CNT_SetRanges Method
[image]

Set counter ranges.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetRanges", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetRanges( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannelTotal As UInt16, _
ByVal i_wRanges As UInt16() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetRanges", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetRanges(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] i_wRanges
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetRanges", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetRanges(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannelTotal,
array<unsigned short>^ i_wRanges
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetRanges", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetRanges(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
ushort[] i_wRanges
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetRanges", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetRanges(
handle : int,
i_usSlot : UInt16,
i_wChannelTotal : UInt16,
i_wRanges : UInt16[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannelTotal
The channel number.
i_wRanges
The Counter ranges.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


CNT_SetStartupValues Method

ApaxAPI.CNT_SetStartupValues Method
[image]

Set Counter startup values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "CNT_SetStartupValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function CNT_SetStartupValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wChannelTotal As UInt16, _
ByVal i_wValues As UInt32() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int CNT_SetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
uint[] i_wValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"CNT_SetStartupValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int CNT_SetStartupValues(
int handle,
unsigned short i_usSlot,
unsigned short i_wChannelTotal,
array<unsigned int>^ i_wValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int CNT_SetStartupValues(
int handle,
ushort i_usSlot,
ushort i_wChannelTotal,
uint[] i_wValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "CNT_SetStartupValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function CNT_SetStartupValues(
handle : int,
i_usSlot : UInt16,
i_wChannelTotal : UInt16,
i_wValues : UInt32[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wChannelTotal
The channel number.
i_wValues
The counter startup values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DI_GetFilters Method

ApaxAPI.DI_GetFilters Method
[image]

Get the DI filter parameters.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DI_GetFilters", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DI_GetFilters( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwHighMask As UInt32, _
<OutAttribute> ByRef o_dwLowMask As UInt32, _
<OutAttribute> ByRef o_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DI_GetFilters", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DI_GetFilters(
int handle,
ushort i_usSlot,
out uint o_dwHighMask,
out uint o_dwLowMask,
out uint o_dwValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DI_GetFilters", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DI_GetFilters(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwHighMask,
[OutAttribute] unsigned int% o_dwLowMask,
[OutAttribute] unsigned int% o_dwValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DI_GetFilters", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DI_GetFilters(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwHighMask,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwLowMask,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DI_GetFilters", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DI_GetFilters(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwHighMask : UInt32,
OutAttribute o_dwLowMask : UInt32,
OutAttribute o_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwHighMask
Channel high DWORD mask.
o_dwLowMask
Channel low DWORD mask.
o_dwValue
The DI filter parameters.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DI_SetFilters Method

ApaxAPI.DI_SetFilters Method
[image]

Set the DI filter parameters.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DI_SetFilters", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DI_SetFilters( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwHighMask As UInt32, _
ByVal i_dwLowMask As UInt32, _
ByVal i_dwValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DI_SetFilters", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DI_SetFilters(
int handle,
ushort i_usSlot,
uint i_dwHighMask,
uint i_dwLowMask,
uint i_dwValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DI_SetFilters", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DI_SetFilters(
int handle,
unsigned short i_usSlot,
unsigned int i_dwHighMask,
unsigned int i_dwLowMask,
unsigned int i_dwValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DI_SetFilters", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DI_SetFilters(
int handle,
ushort i_usSlot,
uint i_dwHighMask,
uint i_dwLowMask,
uint i_dwValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DI_SetFilters", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DI_SetFilters(
handle : int,
i_usSlot : UInt16,
i_dwHighMask : UInt32,
i_dwLowMask : UInt32,
i_dwValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwHighMask
Channel high DWORD mask.
i_dwLowMask
Channel low DWORD mask.
i_dwValue
The DI filter parameters.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DIO_GetSaftyValues Method

ApaxAPI.DIO_GetSaftyValues Method
[image]

Get DIO safety setting values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DIO_GetSaftyValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DIO_GetSaftyValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwHighValue As UInt32, _
<OutAttribute> ByRef o_dwLowValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DIO_GetSaftyValues(
int handle,
ushort i_usSlot,
out uint o_dwHighValue,
out uint o_dwLowValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DIO_GetSaftyValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DIO_GetSaftyValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwHighValue,
[OutAttribute] unsigned int% o_dwLowValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DIO_GetSaftyValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwHighValue,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwLowValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DIO_GetSaftyValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwHighValue : UInt32,
OutAttribute o_dwLowValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwHighValue
The DIO high DWORD safety setting value.
o_dwLowValue
The DIO low DWORD safety setting value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DIO_GetValue Method

ApaxAPI.DIO_GetValue Method
[image]

Get DIO value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DIO_GetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DIO_GetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_bValue As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DIO_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out bool o_bValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DIO_GetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DIO_GetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] bool% o_bValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DIO_GetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ bool o_bValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DIO_GetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_bValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
o_bValue
The DIO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DIO_GetValues Method

ApaxAPI.DIO_GetValues Method
[image]

Get DIO values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DIO_GetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DIO_GetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwHighValue As UInt32, _
<OutAttribute> ByRef o_dwLowValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DIO_GetValues(
int handle,
ushort i_usSlot,
out uint o_dwHighValue,
out uint o_dwLowValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DIO_GetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DIO_GetValues(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwHighValue,
[OutAttribute] unsigned int% o_dwLowValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DIO_GetValues(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwHighValue,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwLowValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_GetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DIO_GetValues(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwHighValue : UInt32,
OutAttribute o_dwLowValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwHighValue
The DIO high DWORD value.
o_dwLowValue
The DIO low DWORD value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DIO_SetSaftyValues Method

ApaxAPI.DIO_SetSaftyValues Method
[image]

Set DIO safety setting values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DIO_SetSaftyValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DIO_SetSaftyValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwHighValue As UInt32, _
ByVal i_dwLowValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_SetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DIO_SetSaftyValues(
int handle,
ushort i_usSlot,
uint i_dwHighValue,
uint i_dwLowValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DIO_SetSaftyValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DIO_SetSaftyValues(
int handle,
unsigned short i_usSlot,
unsigned int i_dwHighValue,
unsigned int i_dwLowValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_SetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DIO_SetSaftyValues(
int handle,
ushort i_usSlot,
uint i_dwHighValue,
uint i_dwLowValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DIO_SetSaftyValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DIO_SetSaftyValues(
handle : int,
i_usSlot : UInt16,
i_dwHighValue : UInt32,
i_dwLowValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwHighValue
The DIO high DWORD safety setting values.
i_dwLowValue
The DIO low DWORD safety setting values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DO_BufValues Method

ApaxAPI.DO_BufValues Method
[image]

Set DO buffer values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DO_BufValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DO_BufValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwHighValue As UInt32, _
ByVal i_dwLowValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_BufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DO_BufValues(
int handle,
ushort i_usSlot,
uint i_dwHighValue,
uint i_dwLowValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DO_BufValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DO_BufValues(
int handle,
unsigned short i_usSlot,
unsigned int i_dwHighValue,
unsigned int i_dwLowValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_BufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DO_BufValues(
int handle,
ushort i_usSlot,
uint i_dwHighValue,
uint i_dwLowValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_BufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DO_BufValues(
handle : int,
i_usSlot : UInt16,
i_dwHighValue : UInt32,
i_dwLowValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwHighValue
The DO high DWORD buffer values.
i_dwLowValue
The DO low DWORD buffer values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DO_SetValue Method

ApaxAPI.DO_SetValue Method
[image]

Set DO value.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DO_SetValue", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DO_SetValue( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_bValue As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DO_SetValue", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DO_SetValue(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
bool i_bValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DO_SetValue(
int handle,
ushort i_usSlot,
ushort i_usChannel,
bool i_bValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_SetValue", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DO_SetValue(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_bValue : bool
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_usChannel
The channel number, based 0.
i_bValue
The DO value.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


DO_SetValues Method

ApaxAPI.DO_SetValues Method
[image]

Set DO values.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "DO_SetValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function DO_SetValues( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwHighValue As UInt32, _
ByVal i_dwLowValue As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int DO_SetValues(
int handle,
ushort i_usSlot,
uint i_dwHighValue,
uint i_dwLowValue
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"DO_SetValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int DO_SetValues(
int handle,
unsigned short i_usSlot,
unsigned int i_dwHighValue,
unsigned int i_dwLowValue
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int DO_SetValues(
int handle,
ushort i_usSlot,
uint i_dwHighValue,
uint i_dwLowValue
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "DO_SetValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function DO_SetValues(
handle : int,
i_usSlot : UInt16,
i_dwHighValue : UInt32,
i_dwLowValue : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwHighValue
The DO high DWORD values.
i_dwLowValue
The DO low DWORD values.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


OUT_FlushBufValues Method

ApaxAPI.OUT_FlushBufValues Method
[image]

Set the slot buffer mask flags.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "OUT_FlushBufValues", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function OUT_FlushBufValues( _
ByVal handle As Integer, _
ByVal i_dwSlotMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_FlushBufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int OUT_FlushBufValues(
int handle,
uint i_dwSlotMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"OUT_FlushBufValues", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int OUT_FlushBufValues(
int handle,
unsigned int i_dwSlotMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_FlushBufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int OUT_FlushBufValues(
int handle,
uint i_dwSlotMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_FlushBufValues", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function OUT_FlushBufValues(
handle : int,
i_dwSlotMask : UInt32
) : int

Parameters

handle
The driver handle.
i_dwSlotMask
The slot buffer mask flag.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


OUT_GetSaftyEnable Method

ApaxAPI.OUT_GetSaftyEnable Method
[image]

Get safety enable flag.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "OUT_GetSaftyEnable", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function OUT_GetSaftyEnable( _
ByVal handle As Integer, _
ByVal i_wSlot As UInt16, _
<OutAttribute> ByRef i_bEnable As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_GetSaftyEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int OUT_GetSaftyEnable(
int handle,
ushort i_wSlot,
out bool i_bEnable
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"OUT_GetSaftyEnable", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int OUT_GetSaftyEnable(
int handle,
unsigned short i_wSlot,
[OutAttribute] bool% i_bEnable
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_GetSaftyEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int OUT_GetSaftyEnable(
int handle,
ushort i_wSlot,
/** @attribute OutAttribute() */ /** @ref */ bool i_bEnable
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_GetSaftyEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function OUT_GetSaftyEnable(
handle : int,
i_wSlot : UInt16,
OutAttribute i_bEnable : bool
) : int

Parameters

handle
The driver handle.
i_wSlot
The slot number, based 0.
i_bEnable
The safety enable flag.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


OUT_SetSaftyEnable Method

ApaxAPI.OUT_SetSaftyEnable Method
[image]

Set safety enable flag.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "OUT_SetSaftyEnable", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function OUT_SetSaftyEnable( _
ByVal handle As Integer, _
ByVal i_wSlot As UInt16, _
ByVal i_bEnable As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_SetSaftyEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int OUT_SetSaftyEnable(
int handle,
ushort i_wSlot,
bool i_bEnable
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"OUT_SetSaftyEnable", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int OUT_SetSaftyEnable(
int handle,
unsigned short i_wSlot,
bool i_bEnable
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_SetSaftyEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int OUT_SetSaftyEnable(
int handle,
ushort i_wSlot,
bool i_bEnable
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "OUT_SetSaftyEnable", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function OUT_SetSaftyEnable(
handle : int,
i_wSlot : UInt16,
i_bEnable : bool
) : int

Parameters

handle
The driver handle.
i_wSlot
The slot number, based 0.
i_bEnable
The safety enable flag.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


PWM_GetChannelMask Method

ApaxAPI.PWM_GetChannelMask Method
[image]

Get enabled PWM channel mask of the indicated slot.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "PWM_GetChannelMask", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function PWM_GetChannelMask( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_GetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int PWM_GetChannelMask(
int handle,
ushort i_usSlot,
out uint o_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"PWM_GetChannelMask", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int PWM_GetChannelMask(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_GetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int PWM_GetChannelMask(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_GetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function PWM_GetChannelMask(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
the slot ID which is ranged from 0 to 15.
o_dwMask
the enabled PWM channel mask. From LSB to MSB of the value indicate the channel-0 to channel-31 enabled mask. If the bit is 1, it means that the PWM channel start to output. Otherwise, stop output.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


PWM_GetConfig Method

ApaxAPI.PWM_GetConfig Method
[image]

Get the channel configuration of the indicated slot.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "PWM_GetConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function PWM_GetConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
<OutAttribute> ByRef o_dwFrequency As UInt32, _
<OutAttribute> ByRef o_fDutyCycle As Single _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_GetConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int PWM_GetConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
out uint o_dwFrequency,
out float o_fDutyCycle
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"PWM_GetConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int PWM_GetConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
[OutAttribute] unsigned int% o_dwFrequency,
[OutAttribute] float% o_fDutyCycle
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_GetConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int PWM_GetConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwFrequency,
/** @attribute OutAttribute() */ /** @ref */ float o_fDutyCycle
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_GetConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function PWM_GetConfig(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
OutAttribute o_dwFrequency : UInt32,
OutAttribute o_fDutyCycle : float
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot ID which is ranged from 0 to 15.
i_usChannel
The channel index, start from 0.
o_dwFrequency
A variable to hold the channel's frequency. [1 ~ 500K Hz]
o_fDutyCycle
A variable to hold the channel's duty cycle. [0 ~ 100 %]

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


PWM_SetChannelMask Method

ApaxAPI.PWM_SetChannelMask Method
[image]

Set enabled PWM channel mask of the indicated slot.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "PWM_SetChannelMask", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function PWM_SetChannelMask( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwMask As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int PWM_SetChannelMask(
int handle,
ushort i_usSlot,
uint i_dwMask
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"PWM_SetChannelMask", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int PWM_SetChannelMask(
int handle,
unsigned short i_usSlot,
unsigned int i_dwMask
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int PWM_SetChannelMask(
int handle,
ushort i_usSlot,
uint i_dwMask
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_SetChannelMask", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function PWM_SetChannelMask(
handle : int,
i_usSlot : UInt16,
i_dwMask : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
the slot ID which is ranged from 0 to 15.
i_dwMask
the enabled PWM channel mask to be set. From LSB to MSB of the value indicate the channel-0 to channel-31 enabled mask. If the bit is 1, it means that the PWM channel start to output. Otherwise, stop output.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


PWM_SetConfig Method

ApaxAPI.PWM_SetConfig Method
[image]

Set the channel configuration of the indicated slot.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "PWM_SetConfig", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function PWM_SetConfig( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_usChannel As UInt16, _
ByVal i_dwFrequency As UInt32, _
ByVal i_fDutyCycle As Single _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_SetConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int PWM_SetConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
uint i_dwFrequency,
float i_fDutyCycle
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"PWM_SetConfig", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int PWM_SetConfig(
int handle,
unsigned short i_usSlot,
unsigned short i_usChannel,
unsigned int i_dwFrequency,
float i_fDutyCycle
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_SetConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int PWM_SetConfig(
int handle,
ushort i_usSlot,
ushort i_usChannel,
uint i_dwFrequency,
float i_fDutyCycle
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "PWM_SetConfig", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function PWM_SetConfig(
handle : int,
i_usSlot : UInt16,
i_usChannel : UInt16,
i_dwFrequency : UInt32,
i_fDutyCycle : float
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot ID which is ranged from 0 to 15.
i_usChannel
The channel index, start from 0.
i_dwFrequency
The frequency of the channel. [1 ~ 500K Hz]
i_fDutyCycle
The duty cycle of the channel. [0 ~ 100 %]

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetAllSlotErrorFlag Method

ApaxAPI.SYS_GetAllSlotErrorFlag Method
[image]

Get all slot error flags.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetAllSlotErrorFlag", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetAllSlotErrorFlag( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_wError As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAllSlotErrorFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetAllSlotErrorFlag(
int handle,
out uint o_wError
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetAllSlotErrorFlag", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetAllSlotErrorFlag(
int handle,
[OutAttribute] unsigned int% o_wError
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAllSlotErrorFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetAllSlotErrorFlag(
int handle,
/** @attribute OutAttribute() */ /** @ref */ uint o_wError
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAllSlotErrorFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetAllSlotErrorFlag(
handle : int,
OutAttribute o_wError : UInt32
) : int

Parameters

handle
The driver handle.
o_wError
Slot error flags.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetAppAStatus Method

ApaxAPI.SYS_GetAppAStatus Method
[image]

Backup System: Get the application A status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetAppAStatus", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetAppAStatus( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_bAlive As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAppAStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetAppAStatus(
int handle,
out bool o_bAlive
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetAppAStatus", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetAppAStatus(
int handle,
[OutAttribute] bool% o_bAlive
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAppAStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetAppAStatus(
int handle,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlive
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAppAStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetAppAStatus(
handle : int,
OutAttribute o_bAlive : bool
) : int

Parameters

handle
The driver handle.
o_bAlive
The application A status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetAppBStatus Method

ApaxAPI.SYS_GetAppBStatus Method
[image]

Backup System: Get the application B status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetAppBStatus", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetAppBStatus( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_bAlive As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAppBStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetAppBStatus(
int handle,
out bool o_bAlive
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetAppBStatus", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetAppBStatus(
int handle,
[OutAttribute] bool% o_bAlive
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAppBStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetAppBStatus(
int handle,
/** @attribute OutAttribute() */ /** @ref */ bool o_bAlive
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetAppBStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetAppBStatus(
handle : int,
OutAttribute o_bAlive : bool
) : int

Parameters

handle
The driver handle.
o_bAlive
The application B status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetDspChannelFlag Method

ApaxAPI.SYS_GetDspChannelFlag Method
[image]

Get dsp channel flag.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetDspChannelFlag", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetDspChannelFlag( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_wFlag As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetDspChannelFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetDspChannelFlag(
int handle,
out ushort o_wFlag
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetDspChannelFlag", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetDspChannelFlag(
int handle,
[OutAttribute] unsigned short% o_wFlag
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetDspChannelFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetDspChannelFlag(
int handle,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wFlag
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetDspChannelFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetDspChannelFlag(
handle : int,
OutAttribute o_wFlag : UInt16
) : int

Parameters

handle
The driver handle.
o_wFlag
The set dsp channel flag. (Turn on:0x55aa ; turn off:others)

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetERRLED Method

ApaxAPI.SYS_GetERRLED Method
[image]

Get the ERR LED status

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetERRLED", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetERRLED( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_bERRLED As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetERRLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetERRLED(
int handle,
out bool o_bERRLED
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetERRLED", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetERRLED(
int handle,
[OutAttribute] bool% o_bERRLED
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetERRLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetERRLED(
int handle,
/** @attribute OutAttribute() */ /** @ref */ bool o_bERRLED
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetERRLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetERRLED(
handle : int,
OutAttribute o_bERRLED : bool
) : int

Parameters

handle
The driver handle.
o_bERRLED
The ERR LED status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetFpgaVersion Method

ApaxAPI.SYS_GetFpgaVersion Method
[image]

Get FPGA version.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetFpgaVersion", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetFpgaVersion( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_dwVer As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetFpgaVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetFpgaVersion(
int handle,
out uint o_dwVer
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetFpgaVersion", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetFpgaVersion(
int handle,
[OutAttribute] unsigned int% o_dwVer
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetFpgaVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetFpgaVersion(
int handle,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwVer
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetFpgaVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetFpgaVersion(
handle : int,
OutAttribute o_dwVer : UInt32
) : int

Parameters

handle
The driver handle.
o_dwVer
The set dsp channel flag. (Turn on:0x55aa ; turn off:others)

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetGlobalActive Method

ApaxAPI.SYS_GetGlobalActive Method
[image]

Backup System: Get the global active.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetGlobalActive", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetGlobalActive( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_wActive As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalActive", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetGlobalActive(
int handle,
out ushort o_wActive
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetGlobalActive", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetGlobalActive(
int handle,
[OutAttribute] unsigned short% o_wActive
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalActive", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetGlobalActive(
int handle,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wActive
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalActive", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetGlobalActive(
handle : int,
OutAttribute o_wActive : UInt16
) : int

Parameters

handle
The driver handle.
o_wActive
The global active.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetGlobalMachineID Method

ApaxAPI.SYS_GetGlobalMachineID Method
[image]

Backup System: Get the global machine ID.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetGlobalMachineID", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetGlobalMachineID( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_wID As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalMachineID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetGlobalMachineID(
int handle,
out ushort o_wID
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetGlobalMachineID", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetGlobalMachineID(
int handle,
[OutAttribute] unsigned short% o_wID
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalMachineID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetGlobalMachineID(
int handle,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wID
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalMachineID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetGlobalMachineID(
handle : int,
OutAttribute o_wID : UInt16
) : int

Parameters

handle
The driver handle.
o_wID
The global machine ID.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetGlobalStatus Method

ApaxAPI.SYS_GetGlobalStatus Method
[image]

Backup System: Get the global status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetGlobalStatus", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetGlobalStatus( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_wStatus As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetGlobalStatus(
int handle,
out ushort o_wStatus
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetGlobalStatus", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetGlobalStatus(
int handle,
[OutAttribute] unsigned short% o_wStatus
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetGlobalStatus(
int handle,
/** @attribute OutAttribute() */ /** @ref */ ushort o_wStatus
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetGlobalStatus", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetGlobalStatus(
handle : int,
OutAttribute o_wStatus : UInt16
) : int

Parameters

handle
The driver handle.
o_wStatus
The global status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetHeartbeatRun Method

ApaxAPI.SYS_GetHeartbeatRun Method
[image]

Backup System: Get the heartbeat run mode.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetHeartbeatRun", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetHeartbeatRun( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_bRun As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetHeartbeatRun", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetHeartbeatRun(
int handle,
out bool o_bRun
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetHeartbeatRun", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetHeartbeatRun(
int handle,
[OutAttribute] bool% o_bRun
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetHeartbeatRun", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetHeartbeatRun(
int handle,
/** @attribute OutAttribute() */ /** @ref */ bool o_bRun
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetHeartbeatRun", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetHeartbeatRun(
handle : int,
OutAttribute o_bRun : bool
) : int

Parameters

handle
The driver handle.
o_bRun
The heartbeat run mode.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetKwMbData Method

ApaxAPI.SYS_GetKwMbData Method
[image]

Get Kw Modbus Data

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetKwMbData", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetKwMbData( _
ByVal handle As Integer, _
ByVal i_dwStartAddr As UInt32, _
ByVal i_dwLength As UInt32, _
<OutAttribute> ByVal o_byValues As Byte() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
byte[] o_byValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetKwMbData", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetKwMbData(
int handle,
unsigned int i_dwStartAddr,
unsigned int i_dwLength,
[OutAttribute] array<char>^ o_byValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
/** @attribute OutAttribute() */ byte[] o_byValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetKwMbData(
handle : int,
i_dwStartAddr : UInt32,
i_dwLength : UInt32,
OutAttribute o_byValues : Byte[]
) : int

Parameters

handle
The driver handle.
i_dwStartAddr
The start address. 0~65535
i_dwLength
The length of modbus data.
o_byValues
The modbus data values

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetModuleID Method

ApaxAPI.SYS_GetModuleID Method
[image]

Get the module ID.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetModuleID", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetModuleID( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwModuleID As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetModuleID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetModuleID(
int handle,
ushort i_usSlot,
out uint o_dwModuleID
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetModuleID", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetModuleID(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwModuleID
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetModuleID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetModuleID(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwModuleID
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetModuleID", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetModuleID(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwModuleID : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwModuleID
The module ID number plugged in the slot.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetModuleID_EX Method

ApaxAPI.SYS_GetModuleID_EX Method
[image]

Get the module ID.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetModuleID_EX", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetModuleID_EX( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByRef o_dwModuleID As UInt32, _
<OutAttribute> ByRef o_usOrder As Integer _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetModuleID_EX", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetModuleID_EX(
int handle,
ushort i_usSlot,
out uint o_dwModuleID,
out int o_usOrder
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetModuleID_EX", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetModuleID_EX(
int handle,
unsigned short i_usSlot,
[OutAttribute] unsigned int% o_dwModuleID,
[OutAttribute] int% o_usOrder
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetModuleID_EX", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetModuleID_EX(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwModuleID,
/** @attribute OutAttribute() */ /** @ref */ int o_usOrder
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetModuleID_EX", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetModuleID_EX(
handle : int,
i_usSlot : UInt16,
OutAttribute o_dwModuleID : UInt32,
OutAttribute o_usOrder : int
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_dwModuleID
The module ID number plugged in the slot.
o_usOrder
The module order.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetRawData Method

ApaxAPI.SYS_GetRawData Method
[image]

Get the raw data of DPM.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetRawData", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetRawData( _
ByVal handle As Integer, _
ByVal i_dwStart As UInt32, _
ByVal i_dwLength As UInt32, _
<OutAttribute> ByVal o_dwRawData As Byte() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetRawData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetRawData(
int handle,
uint i_dwStart,
uint i_dwLength,
byte[] o_dwRawData
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetRawData", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetRawData(
int handle,
unsigned int i_dwStart,
unsigned int i_dwLength,
[OutAttribute] array<char>^ o_dwRawData
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetRawData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetRawData(
int handle,
uint i_dwStart,
uint i_dwLength,
/** @attribute OutAttribute() */ byte[] o_dwRawData
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetRawData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetRawData(
handle : int,
i_dwStart : UInt32,
i_dwLength : UInt32,
OutAttribute o_dwRawData : Byte[]
) : int

Parameters

handle
The driver handle.
i_dwStart
The start address of DPM
i_dwLength
The data length
o_dwRawData
The raw data of DPM

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetRUNLED Method

ApaxAPI.SYS_GetRUNLED Method
[image]

Get the RUN LED status

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetRUNLED", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetRUNLED( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_bRUNLED As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetRUNLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetRUNLED(
int handle,
out bool o_bRUNLED
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetRUNLED", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetRUNLED(
int handle,
[OutAttribute] bool% o_bRUNLED
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetRUNLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetRUNLED(
int handle,
/** @attribute OutAttribute() */ /** @ref */ bool o_bRUNLED
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetRUNLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetRUNLED(
handle : int,
OutAttribute o_bRUNLED : bool
) : int

Parameters

handle
The driver handle.
o_bRUNLED
The RUN LED status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetSlotInfo Method

ApaxAPI.SYS_GetSlotInfo Method
[image]

Get slot information.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetSlotInfo", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetSlotInfo( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
<OutAttribute> ByVal o_stSlotInfo As Byte() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetSlotInfo", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetSlotInfo(
int handle,
ushort i_usSlot,
byte[] o_stSlotInfo
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetSlotInfo", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetSlotInfo(
int handle,
unsigned short i_usSlot,
[OutAttribute] array<char>^ o_stSlotInfo
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetSlotInfo", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetSlotInfo(
int handle,
ushort i_usSlot,
/** @attribute OutAttribute() */ byte[] o_stSlotInfo
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetSlotInfo", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetSlotInfo(
handle : int,
i_usSlot : UInt16,
OutAttribute o_stSlotInfo : Byte[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
o_stSlotInfo

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_GetVersion Method

ApaxAPI.SYS_GetVersion Method
[image]

Get the driver version.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_GetVersion", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_GetVersion( _
ByVal handle As Integer, _
<OutAttribute> ByRef o_dwVersion As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_GetVersion(
int handle,
out uint o_dwVersion
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_GetVersion", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_GetVersion(
int handle,
[OutAttribute] unsigned int% o_dwVersion
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_GetVersion(
int handle,
/** @attribute OutAttribute() */ /** @ref */ uint o_dwVersion
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_GetVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_GetVersion(
handle : int,
OutAttribute o_dwVersion : UInt32
) : int

Parameters

handle
The driver handle.
o_dwVersion
The driver version.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetActMsgPeriod Method

ApaxAPI.SYS_SetActMsgPeriod Method
[image]

Set ack message period. (Internal use)

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetActMsgPeriod", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetActMsgPeriod( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_dwPeriod As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetActMsgPeriod", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetActMsgPeriod(
int handle,
ushort i_usSlot,
uint i_dwPeriod
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetActMsgPeriod", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetActMsgPeriod(
int handle,
unsigned short i_usSlot,
unsigned int i_dwPeriod
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetActMsgPeriod", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetActMsgPeriod(
int handle,
ushort i_usSlot,
uint i_dwPeriod
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetActMsgPeriod", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetActMsgPeriod(
handle : int,
i_usSlot : UInt16,
i_dwPeriod : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_dwPeriod
The ack message period.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetAppAHeartbeat Method

ApaxAPI.SYS_SetAppAHeartbeat Method
[image]

Backup System: Set the application A heartbeat.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetAppAHeartbeat", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetAppAHeartbeat( _
ByVal handle As Integer _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetAppAHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetAppAHeartbeat(
int handle
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetAppAHeartbeat", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetAppAHeartbeat(
int handle
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetAppAHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetAppAHeartbeat(
int handle
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetAppAHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetAppAHeartbeat(
handle : int
) : int

Parameters

handle
The driver handle.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetAppBHeartbeat Method

ApaxAPI.SYS_SetAppBHeartbeat Method
[image]

Backup System: Set the application B heartbeat.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetAppBHeartbeat", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetAppBHeartbeat( _
ByVal handle As Integer _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetAppBHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetAppBHeartbeat(
int handle
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetAppBHeartbeat", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetAppBHeartbeat(
int handle
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetAppBHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetAppBHeartbeat(
int handle
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetAppBHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetAppBHeartbeat(
handle : int
) : int

Parameters

handle
The driver handle.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetCmdWriteRead Method

ApaxAPI.SYS_SetCmdWriteRead Method
[image]

Internal used. DO NOT call this function in your program.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetCmdWriteRead", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetCmdWriteRead( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wMsgType As UInt16, _
ByVal i_dwPara1 As UInt32, _
ByVal i_dwPara2 As UInt32, _
ByVal i_dwPara3 As UInt32, _
ByVal i_dwPara4 As UInt32, _
ByVal i_dwPara5 As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetCmdWriteRead", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetCmdWriteRead(
int handle,
ushort i_usSlot,
ushort i_wMsgType,
uint i_dwPara1,
uint i_dwPara2,
uint i_dwPara3,
uint i_dwPara4,
uint i_dwPara5
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetCmdWriteRead", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetCmdWriteRead(
int handle,
unsigned short i_usSlot,
unsigned short i_wMsgType,
unsigned int i_dwPara1,
unsigned int i_dwPara2,
unsigned int i_dwPara3,
unsigned int i_dwPara4,
unsigned int i_dwPara5
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetCmdWriteRead", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetCmdWriteRead(
int handle,
ushort i_usSlot,
ushort i_wMsgType,
uint i_dwPara1,
uint i_dwPara2,
uint i_dwPara3,
uint i_dwPara4,
uint i_dwPara5
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetCmdWriteRead", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetCmdWriteRead(
handle : int,
i_usSlot : UInt16,
i_wMsgType : UInt16,
i_dwPara1 : UInt32,
i_dwPara2 : UInt32,
i_dwPara3 : UInt32,
i_dwPara4 : UInt32,
i_dwPara5 : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wMsgType
The message type.
i_dwPara1
The parameter 1.
i_dwPara2
The parameter 2.
i_dwPara3
The parameter 3.
i_dwPara4
The parameter 4.
i_dwPara5
The parameter 5.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetCommLock Method

ApaxAPI.SYS_SetCommLock Method
[image]

Internal used. DO NOT call this function in your program.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetCommLock", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetCommLock( _
ByVal handle As Integer, _
ByVal i_wLock As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetCommLock", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetCommLock(
int handle,
ushort i_wLock
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetCommLock", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetCommLock(
int handle,
unsigned short i_wLock
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetCommLock", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetCommLock(
int handle,
ushort i_wLock
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetCommLock", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetCommLock(
handle : int,
i_wLock : UInt16
) : int

Parameters

handle
The driver handle.
i_wLock
The lock status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetDownloadMode Method

ApaxAPI.SYS_SetDownloadMode Method
[image]

Set download mode. (Internal use)

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetDownloadMode", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetDownloadMode( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetDownloadMode(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetDownloadMode", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetDownloadMode(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetDownloadMode(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadMode", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetDownloadMode(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetDownloadPacket Method

ApaxAPI.SYS_SetDownloadPacket Method
[image]

Set download data packet. (Internal use)

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetDownloadPacket", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetDownloadPacket( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wSequence As UInt16, _
ByVal i_wDataLen As UInt16, _
ByVal i_byData As Byte() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadPacket", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetDownloadPacket(
int handle,
ushort i_usSlot,
ushort i_wSequence,
ushort i_wDataLen,
byte[] i_byData
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetDownloadPacket", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetDownloadPacket(
int handle,
unsigned short i_usSlot,
unsigned short i_wSequence,
unsigned short i_wDataLen,
array<char>^ i_byData
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadPacket", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetDownloadPacket(
int handle,
ushort i_usSlot,
ushort i_wSequence,
ushort i_wDataLen,
byte[] i_byData
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadPacket", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetDownloadPacket(
handle : int,
i_usSlot : UInt16,
i_wSequence : UInt16,
i_wDataLen : UInt16,
i_byData : Byte[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wSequence
The sequence number of the packet.
i_wDataLen
The data length of the packet.
i_byData
The data of the packet.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetDownloadStart Method

ApaxAPI.SYS_SetDownloadStart Method
[image]

Set download start flag. (Internal use)

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetDownloadStart", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetDownloadStart( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadStart", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetDownloadStart(
int handle,
ushort i_usSlot
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetDownloadStart", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetDownloadStart(
int handle,
unsigned short i_usSlot
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadStart", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetDownloadStart(
int handle,
ushort i_usSlot
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDownloadStart", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetDownloadStart(
handle : int,
i_usSlot : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetDspChannelFlag Method

ApaxAPI.SYS_SetDspChannelFlag Method
[image]

Set dsp channel flag.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetDspChannelFlag", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetDspChannelFlag( _
ByVal handle As Integer, _
ByVal i_wFlag As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDspChannelFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetDspChannelFlag(
int handle,
ushort i_wFlag
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetDspChannelFlag", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetDspChannelFlag(
int handle,
unsigned short i_wFlag
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDspChannelFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetDspChannelFlag(
int handle,
ushort i_wFlag
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetDspChannelFlag", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetDspChannelFlag(
handle : int,
i_wFlag : UInt16
) : int

Parameters

handle
The driver handle.
i_wFlag
The set dsp channel flag. (Turn on:0x55aa ; turn off:others)

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetERRLED Method

ApaxAPI.SYS_SetERRLED Method
[image]

Set the ERR LED status

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetERRLED", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetERRLED( _
ByVal handle As Integer, _
ByVal i_bERRLED As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetERRLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetERRLED(
int handle,
bool i_bERRLED
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetERRLED", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetERRLED(
int handle,
bool i_bERRLED
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetERRLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetERRLED(
int handle,
bool i_bERRLED
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetERRLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetERRLED(
handle : int,
i_bERRLED : bool
) : int

Parameters

handle
The driver handle.
i_bERRLED
The ERR LED status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetGlobalHeartbeat Method

ApaxAPI.SYS_SetGlobalHeartbeat Method
[image]

Backup System: Set the global heartbeat.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetGlobalHeartbeat", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetGlobalHeartbeat( _
ByVal handle As Integer _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetGlobalHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetGlobalHeartbeat(
int handle
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetGlobalHeartbeat", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetGlobalHeartbeat(
int handle
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetGlobalHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetGlobalHeartbeat(
int handle
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetGlobalHeartbeat", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetGlobalHeartbeat(
handle : int
) : int

Parameters

handle
The driver handle.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetHeartbeatRun Method

ApaxAPI.SYS_SetHeartbeatRun Method
[image]

Backup System: Set the heartbeat run mode.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetHeartbeatRun", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetHeartbeatRun( _
ByVal handle As Integer, _
ByVal i_bRun As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetHeartbeatRun", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetHeartbeatRun(
int handle,
bool i_bRun
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetHeartbeatRun", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetHeartbeatRun(
int handle,
bool i_bRun
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetHeartbeatRun", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetHeartbeatRun(
int handle,
bool i_bRun
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetHeartbeatRun", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetHeartbeatRun(
handle : int,
i_bRun : bool
) : int

Parameters

handle
The driver handle.
i_bRun
The heartbeat run mode.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetInnerTimeout Method

ApaxAPI.SYS_SetInnerTimeout Method
[image]

Set the inner timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetInnerTimeout", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetInnerTimeout( _
ByVal handle As Integer, _
ByVal i_wTimeout As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetInnerTimeout", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetInnerTimeout(
int handle,
ushort i_wTimeout
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetInnerTimeout", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetInnerTimeout(
int handle,
unsigned short i_wTimeout
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetInnerTimeout", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetInnerTimeout(
int handle,
ushort i_wTimeout
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetInnerTimeout", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetInnerTimeout(
handle : int,
i_wTimeout : UInt16
) : int

Parameters

handle
The driver handle.
i_wTimeout
The inner timeout.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetKwMbData Method

ApaxAPI.SYS_SetKwMbData Method
[image]

Set Kw Modbus Data

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetKwMbData", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetKwMbData( _
ByVal handle As Integer, _
ByVal i_dwStartAddr As UInt32, _
ByVal i_dwLength As UInt32, _
ByVal i_byValues As Byte() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
byte[] i_byValues
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetKwMbData", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetKwMbData(
int handle,
unsigned int i_dwStartAddr,
unsigned int i_dwLength,
array<char>^ i_byValues
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetKwMbData(
int handle,
uint i_dwStartAddr,
uint i_dwLength,
byte[] i_byValues
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetKwMbData", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetKwMbData(
handle : int,
i_dwStartAddr : UInt32,
i_dwLength : UInt32,
i_byValues : Byte[]
) : int

Parameters

handle
The driver handle.
i_dwStartAddr
The start address. 0~65535
i_dwLength
The length of modbus data.
i_byValues
The modbus data values

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetLocateModule Method

ApaxAPI.SYS_SetLocateModule Method
[image]

Set module locate function.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetLocateModule", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetLocateModule( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wTimes As UInt16 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetLocateModule", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetLocateModule(
int handle,
ushort i_usSlot,
ushort i_wTimes
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetLocateModule", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetLocateModule(
int handle,
unsigned short i_usSlot,
unsigned short i_wTimes
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetLocateModule", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetLocateModule(
int handle,
ushort i_usSlot,
ushort i_wTimes
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetLocateModule", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetLocateModule(
handle : int,
i_usSlot : UInt16,
i_wTimes : UInt16
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wTimes
The LED flash times, 0 for stop, 255 for continuous.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


SYS_SetRUNLED Method

ApaxAPI.SYS_SetRUNLED Method
[image]

Set the RUN LED status

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "SYS_SetRUNLED", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function SYS_SetRUNLED( _
ByVal handle As Integer, _
ByVal i_bRUNLED As Boolean _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetRUNLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int SYS_SetRUNLED(
int handle,
bool i_bRUNLED
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"SYS_SetRUNLED", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int SYS_SetRUNLED(
int handle,
bool i_bRUNLED
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetRUNLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int SYS_SetRUNLED(
int handle,
bool i_bRUNLED
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "SYS_SetRUNLED", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function SYS_SetRUNLED(
handle : int,
i_bRUNLED : bool
) : int

Parameters

handle
The driver handle.
i_bRUNLED
The RUN LED status.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


TOOL_SetCmdWrite5Read10 Method

ApaxAPI.TOOL_SetCmdWrite5Read10 Method
[image]

Internal used. DO NOT call this function in your program.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "TOOL_SetCmdWrite5Read10", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function TOOL_SetCmdWrite5Read10( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wMsgType As UInt16, _
ByVal i_dwParam0To4 As UInt32(), _
<OutAttribute> ByVal o_dwParam0To9 As UInt32() _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "TOOL_SetCmdWrite5Read10", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int TOOL_SetCmdWrite5Read10(
int handle,
ushort i_usSlot,
ushort i_wMsgType,
uint[] i_dwParam0To4,
uint[] o_dwParam0To9
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"TOOL_SetCmdWrite5Read10", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int TOOL_SetCmdWrite5Read10(
int handle,
unsigned short i_usSlot,
unsigned short i_wMsgType,
array<unsigned int>^ i_dwParam0To4,
[OutAttribute] array<unsigned int>^ o_dwParam0To9
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "TOOL_SetCmdWrite5Read10", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int TOOL_SetCmdWrite5Read10(
int handle,
ushort i_usSlot,
ushort i_wMsgType,
uint[] i_dwParam0To4,
/** @attribute OutAttribute() */ uint[] o_dwParam0To9
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "TOOL_SetCmdWrite5Read10", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function TOOL_SetCmdWrite5Read10(
handle : int,
i_usSlot : UInt16,
i_wMsgType : UInt16,
i_dwParam0To4 : UInt32[],
OutAttribute o_dwParam0To9 : UInt32[]
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wMsgType
The message type.
i_dwParam0To4
The parameter input.
o_dwParam0To9
The parameter output.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


TOOL_SetCmdWriteReadRet Method

ApaxAPI.TOOL_SetCmdWriteReadRet Method
[image]

Internal used. DO NOT call this function in your program.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSDIO.dll", EntryPoint := "TOOL_SetCmdWriteReadRet", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function TOOL_SetCmdWriteReadRet( _
ByVal handle As Integer, _
ByVal i_usSlot As UInt16, _
ByVal i_wMsgType As UInt16, _
ByVal i_dwParam0 As UInt32, _
ByVal i_dwParam1 As UInt32, _
ByVal i_dwParam2 As UInt32, _
ByVal i_dwParam3 As UInt32, _
ByVal i_dwParam4 As UInt32 _
) As Integer
C#
[DllImportAttribute("ADSDIO.dll", EntryPoint = "TOOL_SetCmdWriteReadRet", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int TOOL_SetCmdWriteReadRet(
int handle,
ushort i_usSlot,
ushort i_wMsgType,
uint i_dwParam0,
uint i_dwParam1,
uint i_dwParam2,
uint i_dwParam3,
uint i_dwParam4
)
C++
[DllImportAttribute(L"ADSDIO.dll", EntryPoint = L"TOOL_SetCmdWriteReadRet", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int TOOL_SetCmdWriteReadRet(
int handle,
unsigned short i_usSlot,
unsigned short i_wMsgType,
unsigned int i_dwParam0,
unsigned int i_dwParam1,
unsigned int i_dwParam2,
unsigned int i_dwParam3,
unsigned int i_dwParam4
)
J#
/** @attribute DllImportAttribute("ADSDIO.dll", EntryPoint = "TOOL_SetCmdWriteReadRet", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int TOOL_SetCmdWriteReadRet(
int handle,
ushort i_usSlot,
ushort i_wMsgType,
uint i_dwParam0,
uint i_dwParam1,
uint i_dwParam2,
uint i_dwParam3,
uint i_dwParam4
)
JScript
public static

DllImportAttribute("ADSDIO.dll", EntryPoint = "TOOL_SetCmdWriteReadRet", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function TOOL_SetCmdWriteReadRet(
handle : int,
i_usSlot : UInt16,
i_wMsgType : UInt16,
i_dwParam0 : UInt32,
i_dwParam1 : UInt32,
i_dwParam2 : UInt32,
i_dwParam3 : UInt32,
i_dwParam4 : UInt32
) : int

Parameters

handle
The driver handle.
i_usSlot
The slot number, based 0.
i_wMsgType
The message type.
i_dwParam0
The 1st parameter input.
i_dwParam1
The 2nd parameter input.
i_dwParam2
The 3rd parameter input.
i_dwParam3
The 4th parameter input.
i_dwParam4
The 5th parameter input.

Return Value

Return 0 if success; otherwise, return error code.

See Also

ApaxAPI Class
Advantech.Common Namespace


Baudrate Enumeration

Baudrate Enumeration
[image]

Baud rate settings. Supported Rates: 110, 300, 600, 1200, 2400, 4800, 9600 14400, 19200, 38400, 56000, 57600, 115200, 128000, 256000

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum Baudrate
C#
public enum Baudrate
C++
public enum class Baudrate
J#
public enum Baudrate
JScript
public enum Baudrate

Members

Member Name | Description
Baud_110 | Baudrate 110
Baud_300 | Baudrate 300
Baud_600 | Baudrate 600
Baud_1200 | Baudrate 1200
Baud_2400 | Baudrate 2400
Baud_4800 | Baudrate 4800
Baud_9600 | Baudrate 9600
Baud_14400 | Baudrate 14400
Baud_19200 | Baudrate 19200
Baud_38400 | Baudrate 38400
Baud_56000 | Baudrate 56000
Baud_57600 | Baudrate 57600
Baud_115200 | Baudrate 115200
Baud_128000 | Baudrate 128000
Baud_256000 | Baudrate 256000

See Also

Advantech.Common Namespace


ComPort Class

ComPort Class
See Also Example Members
[image]

Serial communications base interface class library for Windows CE. This class is provided by Advantech.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class ComPort
C#
public class ComPort
C++
ref class ComPort
J#
public class ComPort
JScript
public class ComPort

Inheritance Hierarchy

System.Object
Advantech.Common.ComPort
Advantech.Adam.AdamCom

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ComPort Members
Advantech.Common Namespace


ComPort Members

ComPort Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Serial communications base interface class library for Windows CE. This class is provided by Advantech.

The following tables list the members exposed by ComPort.

Public Constructors

Name | Description
ComPort | Overloaded.
Top

Public Properties

 | Name | Description
Public property | IsOpen | Get the COM port open status.
Top

Public Methods

 | Name | Description
Public method | CloseComPort | Close the COM port.
Public method | GetComPortEventMask | Get the COM port events monitored
Public method | GetComPortLastError | Get the last error when calling Win API.
Public method | GetComPortState | Read the device control settings to the class DCB structure.
Public method | GetComPortTimeout | Get the COM port timeout.
Public method | GetPortNum | Get the port number for this object.
Public method | OpenComPort | Open the COM port and get the COM port setting from system
Public method | Recv | Overloaded. Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024.
Public method | Send | Overloaded. Send binary data to this COM port.
Public method | SetComPortEventMask | Set the COM port events to be monitored
Public method | SetComPortState | Overloaded. Set the COM port state.
Public method | SetComPortTimeout | Update the COM port timeout.
Public method | SetPurge | Flush the I/O buffers.
Public method | WaitComPortEvent | Wait for an event to occur for the COM port.
Top

Explicit Interface Implementations

Name | Description
ComPort | Overloaded.
Top

See Also

ComPort Class
Advantech.Common Namespace


ComPort Constructor

ComPort Constructor

Overload List

 | Name | Description
Public method | ComPort (Int32) | The ComPort class constructor.
Public method | ComPort (String) | The ComPort class constructor.

See Also

ComPort Class
Advantech.Common Namespace


ComPort Constructor (Int32)

ComPort Constructor (Int32)
See Also Example
[image]

The ComPort class constructor.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_i32Port As Integer _
)
C#
public ComPort(
int i_i32Port
)
C++
public:
ComPort(
int i_i32Port
) sealed
J#
public ComPort(
int i_i32Port
)
JScript
public function ComPort(
i_i32Port : int
)

Parameters

i_i32Port
The port number which is ranged from 1 to 256

See Also

ComPort Class
Advantech.Common Namespace
ComPort Constructor Overload List


ComPort Constructor (String)

ComPort Constructor (String)
See Also Example
[image]

The ComPort class constructor.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_szPort As String _
)
C#
public ComPort(
string i_szPort
)
C++
public:
ComPort(
String i_szPort
) sealed
J#
public ComPort(
string i_szPort
)
JScript
public function ComPort(
i_szPort : String
)

Parameters

i_szPort
The port name

See Also

ComPort Class
Advantech.Common Namespace
ComPort Constructor Overload List


Properties

ComPort Properties
[image]

Public Properties

 | Name | Description
Public property | IsOpen | Get the COM port open status.
Top

See Also

ComPort Class
Advantech.Common Namespace


IsOpen Property

ComPort.IsOpen Property
[image]

Get the COM port open status.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsOpen As Boolean
C#
public bool IsOpen { get; }
C++
public property bool IsOpen sealed {
bool get();
}
J#
/** property */
public bool get_IsOpen();
JScript
public function get IsOpen() : bool

See Also

ComPort Class
Advantech.Common Namespace


Methods

ComPort Methods
[image]

Public Methods

 | Name | Description
Public method | CloseComPort | Close the COM port.
Public method | GetComPortEventMask | Get the COM port events monitored
Public method | GetComPortLastError | Get the last error when calling Win API.
Public method | GetComPortState | Read the device control settings to the class DCB structure.
Public method | GetComPortTimeout | Get the COM port timeout.
Public method | GetPortNum | Get the port number for this object.
Public method | OpenComPort | Open the COM port and get the COM port setting from system
Public method | Recv | Overloaded. Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024.
Public method | Send | Overloaded. Send binary data to this COM port.
Public method | SetComPortEventMask | Set the COM port events to be monitored
Public method | SetComPortState | Overloaded. Set the COM port state.
Public method | SetComPortTimeout | Update the COM port timeout.
Public method | SetPurge | Flush the I/O buffers.
Public method | WaitComPortEvent | Wait for an event to occur for the COM port.
Top

See Also

ComPort Class
Advantech.Common Namespace


CloseComPort Method

ComPort.CloseComPort Method
[image]

Close the COM port.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function CloseComPort() As Boolean
C#
public bool CloseComPort()
C++
public:
bool CloseComPort() sealed
J#
public bool CloseComPort()
JScript
public function CloseComPort() : bool

Return Value

True if executed successfully.

See Also

ComPort Class
Advantech.Common Namespace


GetComPortEventMask Method

ComPort.GetComPortEventMask Method
[image]

Get the COM port events monitored

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function GetComPortEventMask( _
<OutAttribute> ByRef o_i32Event As Integer _
) As Boolean
C#
public bool GetComPortEventMask(
out int o_i32Event
)
C++
public:
bool GetComPortEventMask(
[OutAttribute] int% o_i32Event
) sealed
J#
public bool GetComPortEventMask(
/** @attribute OutAttribute() */ /** @ref */ int o_i32Event
)
JScript
public function GetComPortEventMask(
OutAttribute o_i32Event : int
) : bool

Parameters

o_i32Event
The value could be the combination of Event.BREAK Event.CTS Event.DSR Event.ERR Event.RING Event.RLSD Event.RXCHAR Event.RXFLAG Event.TXEMPTY

Return Value

True if get successful.

See Also

ComPort Class
Advantech.Common Namespace


GetComPortLastError Method

ComPort.GetComPortLastError Method
[image]

Get the last error when calling Win API.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function GetComPortLastError() As Integer
C#
public int GetComPortLastError()
C++
public:
int GetComPortLastError() sealed
J#
public int GetComPortLastError()
JScript
public function GetComPortLastError() : int

Return Value

The error code.

See Also

ComPort Class
Advantech.Common Namespace


GetComPortState Method

ComPort.GetComPortState Method
[image]

Read the device control settings to the class DCB structure.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetComPortState( _
<OutAttribute> ByRef o_i32Baudrate As Baudrate, _
<OutAttribute> ByRef o_btDataBits As Databits, _
<OutAttribute> ByRef o_btParity As Parity, _
<OutAttribute> ByRef o_btStop As Stopbits _
)
C#
public void GetComPortState(
out Baudrate o_i32Baudrate,
out Databits o_btDataBits,
out Parity o_btParity,
out Stopbits o_btStop
)
C++
public:
void GetComPortState(
[OutAttribute] Baudrate% o_i32Baudrate,
[OutAttribute] Databits% o_btDataBits,
[OutAttribute] Parity% o_btParity,
[OutAttribute] Stopbits% o_btStop
) sealed
J#
public void GetComPortState(
/** @attribute OutAttribute() */ /** @ref */ Baudrate o_i32Baudrate,
/** @attribute OutAttribute() */ /** @ref */ Databits o_btDataBits,
/** @attribute OutAttribute() */ /** @ref */ Parity o_btParity,
/** @attribute OutAttribute() */ /** @ref */ Stopbits o_btStop
)
JScript
public function GetComPortState(
OutAttribute o_i32Baudrate : Baudrate,
OutAttribute o_btDataBits : Databits,
OutAttribute o_btParity : Parity,
OutAttribute o_btStop : Stopbits
)

Parameters

o_i32Baudrate
Baud rate at which the communications device operates. Supported Rates: Baudrate.Baud_110, Baudrate.Baud_300, Baudrate.Baud_600, Baudrate.Baud_1200, Baudrate.Baud_2400, Baudrate.Baud_4800, Baudrate.Baud_9600, Baudrate.Baud_14400, Baudrate.Baud_19200, Baudrate.Baud_38400, Baudrate.Baud_56000, Baudrate.Baud_57600, Baudrate.Baud_115200, Baudrate.Baud_128000, Baudrate.Baud_256000
o_btDataBits
Number of bits in the bytes transmitted and received. Supported: Databits.Five, Databits.Six, Databits.Seven, Databits.Eight
o_btParity
Parity scheme using. This member can be one of the following values. Supported: Parity.None, Parity.Odd, Parity.Even, Parity.Mark, Parity.Space
o_btStop
Number of stop bits using. This member can be Supported: Stopbits.One, Stopbits.OneFive, Stopbits.Two.

See Also

ComPort Class
Advantech.Common Namespace


GetComPortTimeout Method

ComPort.GetComPortTimeout Method
[image]

Get the COM port timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetComPortTimeout( _
<OutAttribute> ByRef o_i32ReadInterval As Integer, _
<OutAttribute> ByRef o_i32ReadTotalConstant As Integer, _
<OutAttribute> ByRef o_i32ReadTotalMultiplier As Integer, _
<OutAttribute> ByRef o_i32WriteTotalConstant As Integer, _
<OutAttribute> ByRef o_i32WriteTotalMultiplier As Integer _
)
C#
public void GetComPortTimeout(
out int o_i32ReadInterval,
out int o_i32ReadTotalConstant,
out int o_i32ReadTotalMultiplier,
out int o_i32WriteTotalConstant,
out int o_i32WriteTotalMultiplier
)
C++
public:
void GetComPortTimeout(
[OutAttribute] int% o_i32ReadInterval,
[OutAttribute] int% o_i32ReadTotalConstant,
[OutAttribute] int% o_i32ReadTotalMultiplier,
[OutAttribute] int% o_i32WriteTotalConstant,
[OutAttribute] int% o_i32WriteTotalMultiplier
) sealed
J#
public void GetComPortTimeout(
/** @attribute OutAttribute() */ /** @ref */ int o_i32ReadInterval,
/** @attribute OutAttribute() */ /** @ref */ int o_i32ReadTotalConstant,
/** @attribute OutAttribute() */ /** @ref */ int o_i32ReadTotalMultiplier,
/** @attribute OutAttribute() */ /** @ref */ int o_i32WriteTotalConstant,
/** @attribute OutAttribute() */ /** @ref */ int o_i32WriteTotalMultiplier
)
JScript
public function GetComPortTimeout(
OutAttribute o_i32ReadInterval : int,
OutAttribute o_i32ReadTotalConstant : int,
OutAttribute o_i32ReadTotalMultiplier : int,
OutAttribute o_i32WriteTotalConstant : int,
OutAttribute o_i32WriteTotalMultiplier : int
)

Parameters

o_i32ReadInterval
Read interval timeout in milli-seconds.
o_i32ReadTotalConstant
Read total timeout constant in milli-seconds.
o_i32ReadTotalMultiplier
Read total timeout multiplier in milli-seconds.
o_i32WriteTotalConstant
Write total timeout constant in milli-seconds.
o_i32WriteTotalMultiplier
Write total timeout multiplier in milli-seconds.

See Also

ComPort Class
Advantech.Common Namespace


GetPortNum Method

ComPort.GetPortNum Method
[image]

Get the port number for this object.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPortNum() As Integer
C#
public int GetPortNum()
C++
public:
int GetPortNum() sealed
J#
public int GetPortNum()
JScript
public function GetPortNum() : int

Return Value

The port number.

See Also

ComPort Class
Advantech.Common Namespace


OpenComPort Method

ComPort.OpenComPort Method
[image]

Open the COM port and get the COM port setting from system

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenComPort() As Boolean
C#
public bool OpenComPort()
C++
public:
bool OpenComPort() sealed
J#
public bool OpenComPort()
JScript
public function OpenComPort() : bool

Return Value

True if port opened successfully.

See Also

ComPort Class
Advantech.Common Namespace


Recv Method

ComPort.Recv Method

Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024.

Overload List

 | Name | Description
Public method | Recv (Byte) | Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024.
Public method | Recv (Int32, Byte) | Receive binary data from this COM port.
Public method | Recv (String) | Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024.

See Also

ComPort Class
Advantech.Common Namespace


Recv Method (Byte)

ComPort.Recv Method (Byte)
See Also Example
[image]

Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function Recv( _
<OutAttribute> ByRef o_byData As Byte _
) As Integer
C#
public int Recv(
out byte o_byData
)
C++
public:
int Recv(
[OutAttribute] char% o_byData
) sealed
J#
public int Recv(
/** @attribute OutAttribute() */ /** @ref */ byte o_byData
)
JScript
public function Recv(
OutAttribute o_byData : Byte
) : int

Parameters

o_byData
The receiving byte array.

Return Value

The length of string received.

See Also

ComPort Class
Advantech.Common Namespace
ComPort.Recv Overload List


Recv Method (Int32, Byte)

ComPort.Recv Method (Int32, Byte)
See Also Example
[image]

Receive binary data from this COM port.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function Recv( _
ByVal i_i32Len As Integer, _
ByRef o_btData As Byte _
) As Integer
C#
public int Recv(
int i_i32Len,
ref byte o_btData
)
C++
public:
int Recv(
int i_i32Len,
char% o_btData
) sealed
J#
public int Recv(
int i_i32Len,
byte o_btData
)
JScript
public function Recv(
i_i32Len : int,
o_btData : Byte
) : int

Parameters

i_i32Len
The length of data to read
o_btData
The data buffer which must have enough space

Return Value

The number of bytes received.

See Also

ComPort Class
Advantech.Common Namespace
ComPort.Recv Overload List


Recv Method (String)

ComPort.Recv Method (String)
See Also Example
[image]

Receive string from this COM port. If the carrage return character is received, this function will assume this is the end of the string. The maximum length of string can be received is 1024.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function Recv( _
<OutAttribute> ByRef o_szData As String _
) As Integer
C#
public int Recv(
out string o_szData
)
C++
public:
int Recv(
[OutAttribute] String% o_szData
) sealed
J#
public int Recv(
/** @attribute OutAttribute() */ /** @ref */ string o_szData
)
JScript
public function Recv(
OutAttribute o_szData : String
) : int

Parameters

o_szData
The string

Return Value

The length of string received.

See Also

ComPort Class
Advantech.Common Namespace
ComPort.Recv Overload List


Send Method

ComPort.Send Method

Send binary data to this COM port.

Overload List

 | Name | Description
Public method | Send (Int32, Byte) | Send binary data to this COM port.
Public method | Send (String) | Send a string to this COM port.

See Also

ComPort Class
Advantech.Common Namespace


Send Method (Int32, Byte[])

ComPort.Send Method (Int32, Byte[])
See Also Example
[image]

Send binary data to this COM port.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function Send( _
ByVal i_i32Len As Integer, _
ByVal i_btData As Byte() _
) As Integer
C#
public int Send(
int i_i32Len,
byte[] i_btData
)
C++
public:
int Send(
int i_i32Len,
array<char>^ i_btData
) sealed
J#
public int Send(
int i_i32Len,
byte[] i_btData
)
JScript
public function Send(
i_i32Len : int,
i_btData : Byte[]
) : int

Parameters

i_i32Len
The length of data to write
i_btData
The data buffer

Return Value

The number of bytes sent.

See Also

ComPort Class
Advantech.Common Namespace
ComPort.Send Overload List


Send Method (String)

ComPort.Send Method (String)
See Also Example
[image]

Send a string to this COM port.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function Send( _
ByVal i_szData As String _
) As Integer
C#
public int Send(
string i_szData
)
C++
public:
int Send(
String i_szData
) sealed
J#
public int Send(
string i_szData
)
JScript
public function Send(
i_szData : String
) : int

Parameters

i_szData
The string data

Return Value

The number of bytes sent.

See Also

ComPort Class
Advantech.Common Namespace
ComPort.Send Overload List


SetComPortEventMask Method

ComPort.SetComPortEventMask Method
[image]

Set the COM port events to be monitored

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function SetComPortEventMask( _
ByVal i_i32Event As Integer _
) As Boolean
C#
public bool SetComPortEventMask(
int i_i32Event
)
C++
public:
bool SetComPortEventMask(
int i_i32Event
) sealed
J#
public bool SetComPortEventMask(
int i_i32Event
)
JScript
public function SetComPortEventMask(
i_i32Event : int
) : bool

Parameters

i_i32Event
The value could be the combination of Event.BREAK Event.CTS Event.DSR Event.ERR Event.RING Event.RLSD Event.RXCHAR Event.RXFLAG Event.TXEMPTY

Return Value

True if update successful.

See Also

ComPort Class
Advantech.Common Namespace


SetComPortState Method

ComPort.SetComPortState Method

Set the COM port state.

Overload List

 | Name | Description
Public method | SetComPortState (Baudrate, Databits, Parity, Stopbits) | Set the COM port state.
Public method | SetComPortState (Baudrate, Databits, Parity, Stopbits, FlowControl) | Set the COM port state.

See Also

ComPort Class
Advantech.Common Namespace


SetComPortState Method (Baudrate, Databits, Parity, Stopbits)

ComPort.SetComPortState Method (Baudrate, Databits, Parity, Stopbits)
See Also Example
[image]

Set the COM port state.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function SetComPortState( _
ByVal i_i32Baudrate As Baudrate, _
ByVal i_btDataBits As Databits, _
ByVal i_btParity As Parity, _
ByVal i_btStop As Stopbits _
) As Boolean
C#
public bool SetComPortState(
Baudrate i_i32Baudrate,
Databits i_btDataBits,
Parity i_btParity,
Stopbits i_btStop
)
C++
public:
bool SetComPortState(
Baudrate i_i32Baudrate,
Databits i_btDataBits,
Parity i_btParity,
Stopbits i_btStop
) sealed
J#
public bool SetComPortState(
Baudrate i_i32Baudrate,
Databits i_btDataBits,
Parity i_btParity,
Stopbits i_btStop
)
JScript
public function SetComPortState(
i_i32Baudrate : Baudrate,
i_btDataBits : Databits,
i_btParity : Parity,
i_btStop : Stopbits
) : bool

Parameters

i_i32Baudrate
Baud rate at which the communications device operates. Supported Rates: Baudrate.Baud_110, Baudrate.Baud_300, Baudrate.Baud_600, Baudrate.Baud_1200, Baudrate.Baud_2400, Baudrate.Baud_4800, Baudrate.Baud_9600, Baudrate.Baud_14400, Baudrate.Baud_19200, Baudrate.Baud_38400, Baudrate.Baud_56000, Baudrate.Baud_57600, Baudrate.Baud_115200, Baudrate.Baud_128000, Baudrate.Baud_256000
i_btDataBits
Number of bits in the bytes transmitted and received. Supported: Databits.Five, Databits.Six, Databits.Seven, Databits.Eight
i_btParity
Parity scheme to be used. This member can be one of the following values. Supported: Parity.None, Parity.Odd, Parity.Even, Parity.Mark, Parity.Space
i_btStop
Number of stop bits to be used. This member can be Supported: Stopbits.One, Stopbits.OneFive, Stopbits.Two.

Return Value

True if successful.

See Also

ComPort Class
Advantech.Common Namespace
ComPort.SetComPortState Overload List


SetComPortState Method (Baudrate, Databits, Parity, Stopbits, FlowControl)

ComPort.SetComPortState Method (Baudrate, Databits, Parity, Stopbits, FlowControl)
See Also Example
[image]

Set the COM port state.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function SetComPortState( _
ByVal i_i32Baudrate As Baudrate, _
ByVal i_btDataBits As Databits, _
ByVal i_btParity As Parity, _
ByVal i_btStop As Stopbits, _
ByVal i_btFlowControl As FlowControl _
) As Boolean
C#
public bool SetComPortState(
Baudrate i_i32Baudrate,
Databits i_btDataBits,
Parity i_btParity,
Stopbits i_btStop,
FlowControl i_btFlowControl
)
C++
public:
bool SetComPortState(
Baudrate i_i32Baudrate,
Databits i_btDataBits,
Parity i_btParity,
Stopbits i_btStop,
FlowControl i_btFlowControl
) sealed
J#
public bool SetComPortState(
Baudrate i_i32Baudrate,
Databits i_btDataBits,
Parity i_btParity,
Stopbits i_btStop,
FlowControl i_btFlowControl
)
JScript
public function SetComPortState(
i_i32Baudrate : Baudrate,
i_btDataBits : Databits,
i_btParity : Parity,
i_btStop : Stopbits,
i_btFlowControl : FlowControl
) : bool

Parameters

i_i32Baudrate
Baud rate at which the communications device operates. Supported Rates: Baudrate.Baud_110, Baudrate.Baud_300, Baudrate.Baud_600, Baudrate.Baud_1200, Baudrate.Baud_2400, Baudrate.Baud_4800, Baudrate.Baud_9600, Baudrate.Baud_14400, Baudrate.Baud_19200, Baudrate.Baud_38400, Baudrate.Baud_56000, Baudrate.Baud_57600, Baudrate.Baud_115200, Baudrate.Baud_128000, Baudrate.Baud_256000
i_btDataBits
Number of bits in the bytes transmitted and received. Supported: Databits.Five, Databits.Six, Databits.Seven, Databits.Eight
i_btParity
Parity scheme to be used. This member can be one of the following values. Supported: Parity.None, Parity.Odd, Parity.Even, Parity.Mark, Parity.Space
i_btStop
Number of stop bits to be used. This member can be Supported: Stopbits.One, Stopbits.OneFive, Stopbits.Two.
i_btFlowControl
Flow Control Supported type: Hardware, Xon/Xoff, None.

Return Value

True if successful.

See Also

ComPort Class
Advantech.Common Namespace
ComPort.SetComPortState Overload List


SetComPortTimeout Method

ComPort.SetComPortTimeout Method
[image]

Update the COM port timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function SetComPortTimeout( _
ByVal i_i32ReadInterval As Integer, _
ByVal i_i32ReadTotalConstant As Integer, _
ByVal i_i32ReadTotalMultiplier As Integer, _
ByVal i_i32WriteTotalConstant As Integer, _
ByVal i_i32WriteTotalMultiplier As Integer _
) As Boolean
C#
public bool SetComPortTimeout(
int i_i32ReadInterval,
int i_i32ReadTotalConstant,
int i_i32ReadTotalMultiplier,
int i_i32WriteTotalConstant,
int i_i32WriteTotalMultiplier
)
C++
public:
bool SetComPortTimeout(
int i_i32ReadInterval,
int i_i32ReadTotalConstant,
int i_i32ReadTotalMultiplier,
int i_i32WriteTotalConstant,
int i_i32WriteTotalMultiplier
) sealed
J#
public bool SetComPortTimeout(
int i_i32ReadInterval,
int i_i32ReadTotalConstant,
int i_i32ReadTotalMultiplier,
int i_i32WriteTotalConstant,
int i_i32WriteTotalMultiplier
)
JScript
public function SetComPortTimeout(
i_i32ReadInterval : int,
i_i32ReadTotalConstant : int,
i_i32ReadTotalMultiplier : int,
i_i32WriteTotalConstant : int,
i_i32WriteTotalMultiplier : int
) : bool

Parameters

i_i32ReadInterval
Read interval timeout in milli-seconds.
i_i32ReadTotalConstant
Read total timeout constant in milli-seconds.
i_i32ReadTotalMultiplier
Read total timeout multiplier in milli-seconds.
i_i32WriteTotalConstant
Write total timeout constant in milli-seconds.
i_i32WriteTotalMultiplier
Write total timeout multiplier in milli-seconds.

Return Value

True if update successful.

See Also

ComPort Class
Advantech.Common Namespace


SetPurge Method

ComPort.SetPurge Method
[image]

Flush the I/O buffers.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function SetPurge( _
ByVal i_iFlags As Integer _
) As Boolean
C#
public bool SetPurge(
int i_iFlags
)
C++
public:
bool SetPurge(
int i_iFlags
) sealed
J#
public bool SetPurge(
int i_iFlags
)
JScript
public function SetPurge(
i_iFlags : int
) : bool

Parameters

i_iFlags
The value could be the combination of Purge.TXABORT Purge.RXABORT Purge.TXCLEAR Purge.RXCLEAR

Return Value

True if update successful.

See Also

ComPort Class
Advantech.Common Namespace


WaitComPortEvent Method

ComPort.WaitComPortEvent Method
[image]

Wait for an event to occur for the COM port.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function WaitComPortEvent( _
<OutAttribute> ByRef o_i32Event As Integer _
) As Boolean
C#
public bool WaitComPortEvent(
out int o_i32Event
)
C++
public:
bool WaitComPortEvent(
[OutAttribute] int% o_i32Event
) sealed
J#
public bool WaitComPortEvent(
/** @attribute OutAttribute() */ /** @ref */ int o_i32Event
)
JScript
public function WaitComPortEvent(
OutAttribute o_i32Event : int
) : bool

Parameters

o_i32Event
The event occurs. It could be one of Event.BREAK Event.CTS Event.DSR Event.ERR Event.RING Event.RLSD Event.RXCHAR Event.RXFLAG Event.TXEMPTY

Return Value

True if get successful.

See Also

ComPort Class
Advantech.Common Namespace


ComPort.COMMTIMEOUTS Structure

ComPort.COMMTIMEOUTS Structure
[image]

The COMMTIMEOUTS structure is used in the SetCommTimeouts and GetCommTimeouts functions to set and query the time-out parameters for a communications device. The parameters determine the behavior of ReadFile, WriteFile, ReadFileEx, and WriteFileEx operations on the device.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Protected Structure ComPort.COMMTIMEOUTS
C#
protected struct ComPort.COMMTIMEOUTS
C++
value class ComPort.COMMTIMEOUTS
J#
protected final class ComPort.COMMTIMEOUTS extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Advantech.Common.ComPort.COMMTIMEOUTS

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ComPort.COMMTIMEOUTS Members
Advantech.Common Namespace


Databits Enumeration

Databits Enumeration
[image]

Data bits setting.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum Databits As Byte
C#
public enum Databits : byte
C++
public enum class Databits : char
J#
public enum Databits byte
JScript
public enum Databits :

Members

Member Name | Description
Five | Five bits per data byte.
Six | Six bits per data byte.
Seven | Seven bits per data byte.
Eight | Eight bits per data byte.

See Also

Advantech.Common Namespace


DcbFlagFields Enumeration

DcbFlagFields Enumeration
[image]

The DCB flag structure

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum DcbFlagFields As Byte
C#
public enum DcbFlagFields : byte
C++
public enum class DcbFlagFields : char
J#
public enum DcbFlagFields byte
JScript
public enum DcbFlagFields :

Members

Member Name | Description
fBinary | fBinary
fParity | fParity
fOutxCtsFlow | fOutxCtsFlow
fOutxDsrFlow | fOutxDsrFlow
fDtrControl | fDtrControl
fDsrSensitivity | fDsrSensitivity
fTXContinueOnXoff | fTXContinueOnXoff
fOutX | fOutX
fInX | fInX
fErrorChar | fErrorChar
fNull | fNull
fRtsControl | fRtsControl
fAbortOnError | fAbortOnError
fDummy2 | fDummy2

See Also

Advantech.Common Namespace


ErrorCode Enumeration

ErrorCode Enumeration
[image]

The Advantech error code

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum ErrorCode
C#
public enum ErrorCode
C++
public enum class ErrorCode
J#
public enum ErrorCode
JScript
public enum ErrorCode

Members

Member Name | Description
No_Error | No error
ComPort_Error | ComPort error
ComPort_Open_Fail | ComPort open fail
ComPort_Send_Fail | ComPort send fail
ComPort_Recv_Fail | ComPort receive fail
Socket_Null | Socket is null
Socket_Connect_Fail | Socket connect fail
Socket_Invalid_IP | Invalid IP
Socket_Send_Fail | Socket send fail
Socket_Recv_Fail | Socket send fail
Socket_Unknown | The error cannnot be identified
Adam_Invalid_Head | Adam protocol response header is invalid
Adam_Invalid_End | Adam protocol response header is invalid
Adam_Invalid_Length | Adam protocol response length is invalid
Adam_Invalid_Data | Adam protocol response data is invalid, which causes the convertion failed
Adam_Invalid_Checksum | Adam protocol response checksum is invalid
Adam_Invalid_Param | The parameter is invalid
Adam_Invalid_Password | The password is invalid
Modbus_Invalid_CRC | Received modbus packet CRC is invalid
Modbus_Invalid_Length | Received modbus packet length is invalid
Modbus_Invalid_Serial | Serial number of received modbus packet is different from the sent one
Modbus_Exception | The modbus response with exception, this is the base
Modbus_Exception_IllegalFunction | The modbus response with exception 01
Modbus_Exception_IllegalDataAddress | The modbus response with exception 02
Modbus_Exception_IllegalDataValue | The modbus response with exception 03
Modbus_Exception_SlaveDeviceFailure | The modbus response with exception 04
Modbus_Exception_Acknowledge | The modbus response with exception 05
Modbus_Exception_SlaveDeviceBusy | The modbus response with exception 06
Modbus_Exception_NativeAcknowledge | The modbus response with exception 07
Modbus_Exception_MemoryParityError | The modbus response with exception 08
Command_Nack | Command returning nack
Command_Unknown | Command returning unknown or invalid expected data
API_Parameter_Error | Parameter error
Adam_Null_Error | Internal Null detected

See Also

Advantech.Common Namespace


Event Enumeration

Event Enumeration
[image]

Event settings

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum Event
C#
public enum Event
C++
public enum class Event
J#
public enum Event
JScript
public enum Event

Members

Member Name | Description
Break | A break was detected on input.
Cts | The CTS (clear-to-send) signal changed state.
Dsr | The DSR (data-set-ready) signal changed state.
Err | A line-status error occurred.
Ring | A ring indicator was detected.
Rlsd | The RLSD (receive-line-signal-detect) signal changed state.
RxChar | A character was received and placed in the input buffer.
RxFlag | The event character was received and placed in the input buffer.
TxEmpty | The last character in the output buffer was sent.

See Also

Advantech.Common Namespace


FlagSetting Enumeration

FlagSetting Enumeration
[image]

Flag settings. Supported : Off, On.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum FlagSetting As Byte
C#
public enum FlagSetting : byte
C++
public enum class FlagSetting : char
J#
public enum FlagSetting byte
JScript
public enum FlagSetting :

Members

Member Name | Description
Off | Flag is Off
On | Flag is On

See Also

Advantech.Common Namespace


FlowControl Enumeration

FlowControl Enumeration
[image]

FlowControl settings. Supported type: Hardware, Xon/Xoff, None.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum FlowControl As Byte
C#
public enum FlowControl : byte
C++
public enum class FlowControl : char
J#
public enum FlowControl byte
JScript
public enum FlowControl :

Members

Member Name | Description
None | None
XonXoff | Xon/Xoff
Hardware | Hardware

See Also

Advantech.Common Namespace


ICMP_ECHO_REPLY Class

ICMP_ECHO_REPLY Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class ICMP_ECHO_REPLY
C#
public class ICMP_ECHO_REPLY
C++
ref class ICMP_ECHO_REPLY
J#
public class ICMP_ECHO_REPLY
JScript
public class ICMP_ECHO_REPLY

Inheritance Hierarchy

System.Object
Advantech.Common.ICMP_ECHO_REPLY

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ICMP_ECHO_REPLY Members
Advantech.Common Namespace


ICMP_ECHO_REPLY Members

ICMP_ECHO_REPLY Members
See Also Example Constructors Properties
[image]

The following tables list the members exposed by ICMP_ECHO_REPLY.

Public Constructors

 | Name | Description
Public method | ICMP_ECHO_REPLY |
Top

Public Properties

 | Name | Description
Public property | _Data |
Public property | Address |
Public property | Data |
Public property | DataSize |
Public property | Flags |
Public property | OptionsData |
Public property | OptionsSize |
Public property | RoundTripTime |
Public property | Status |
Public property | Tos |
Public property | Ttl |
Top

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


ICMP_ECHO_REPLY Constructor

ICMP_ECHO_REPLY Constructor
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal size As Integer _
)
C#
public ICMP_ECHO_REPLY(
int size
)
C++
public:
ICMP_ECHO_REPLY(
int size
) sealed
J#
public ICMP_ECHO_REPLY(
int size
)
JScript
public function ICMP_ECHO_REPLY(
size : int
)

Parameters

size

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


Properties

ICMP_ECHO_REPLY Properties
[image]

Public Properties

 | Name | Description
Public property | _Data |
Public property | Address |
Public property | Data |
Public property | DataSize |
Public property | Flags |
Public property | OptionsData |
Public property | OptionsSize |
Public property | RoundTripTime |
Public property | Status |
Public property | Tos |
Public property | Ttl |
Top

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


_Data Property

ICMP_ECHO_REPLY._Data Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property _Data As Byte()
C#
public byte[] _Data { get; }
C++
public property byte[] _Data sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get__Data();
JScript
public function get _Data() : Byte[]

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


Address Property

ICMP_ECHO_REPLY.Address Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Address As Integer
C#
public int Address { get; }
C++
public property int Address sealed {
int get();
}
J#
/** property */
public int get_Address();
JScript
public function get Address() : int

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


Data Property

ICMP_ECHO_REPLY.Data Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Property Data As IntPtr
C#
public IntPtr Data { get; set; }
C++
public property IntPtr Data sealed {
IntPtr get();
void set(IntPtr value);
}
J#
/** property */
public IntPtr get_Data();

/** property */
public void set_Data(IntPtr value);
JScript
public function get Data() : IntPtr

public function set Data(value : IntPtr);

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


DataSize Property

ICMP_ECHO_REPLY.DataSize Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Property DataSize As Short
C#
public short DataSize { get; set; }
C++
public property short DataSize sealed {
short get();
void set(short value);
}
J#
/** property */
public short get_DataSize();

/** property */
public void set_DataSize(short value);
JScript
public function get DataSize() : short

public function set DataSize(value : short);

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


Flags Property

ICMP_ECHO_REPLY.Flags Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flags As Byte
C#
public byte Flags { get; }
C++
public property byte Flags sealed {
char get();
}
J#
/** property */
public byte get_Flags();
JScript
public function get Flags() : Byte

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


OptionsData Property

ICMP_ECHO_REPLY.OptionsData Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Property OptionsData As IntPtr
C#
public IntPtr OptionsData { get; set; }
C++
public property IntPtr OptionsData sealed {
IntPtr get();
void set(IntPtr value);
}
J#
/** property */
public IntPtr get_OptionsData();

/** property */
public void set_OptionsData(IntPtr value);
JScript
public function get OptionsData() : IntPtr

public function set OptionsData(value : IntPtr);

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


OptionsSize Property

ICMP_ECHO_REPLY.OptionsSize Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionsSize As Byte
C#
public byte OptionsSize { get; }
C++
public property byte OptionsSize sealed {
char get();
}
J#
/** property */
public byte get_OptionsSize();
JScript
public function get OptionsSize() : Byte

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


RoundTripTime Property

ICMP_ECHO_REPLY.RoundTripTime Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RoundTripTime As Integer
C#
public int RoundTripTime { get; }
C++
public property int RoundTripTime sealed {
int get();
}
J#
/** property */
public int get_RoundTripTime();
JScript
public function get RoundTripTime() : int

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


Status Property

ICMP_ECHO_REPLY.Status Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As Integer
C#
public int Status { get; }
C++
public property int Status sealed {
int get();
}
J#
/** property */
public int get_Status();
JScript
public function get Status() : int

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


Tos Property

ICMP_ECHO_REPLY.Tos Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tos As Byte
C#
public byte Tos { get; }
C++
public property byte Tos sealed {
char get();
}
J#
/** property */
public byte get_Tos();
JScript
public function get Tos() : Byte

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


Ttl Property

ICMP_ECHO_REPLY.Ttl Property
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ttl As Byte
C#
public byte Ttl { get; }
C++
public property byte Ttl sealed {
char get();
}
J#
/** property */
public byte get_Ttl();
JScript
public function get Ttl() : Byte

See Also

ICMP_ECHO_REPLY Class
Advantech.Common Namespace


ModbusServerAPI Class

ModbusServerAPI Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class ModbusServerAPI
C#
public class ModbusServerAPI
C++
ref class ModbusServerAPI
J#
public class ModbusServerAPI
JScript
public class ModbusServerAPI

Inheritance Hierarchy

System.Object
Advantech.Common.ModbusServerAPI

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ModbusServerAPI Members
Advantech.Common Namespace


ModbusServerAPI Members

ModbusServerAPI Members
See Also Example Constructors Fields Methods
[image]

The following tables list the members exposed by ModbusServerAPI.

Public Constructors

 | Name | Description
Public method | ModbusServerAPI | Initializes a new instance of the ModbusServerAPI class.
Top

Public Fields

Name | Description
MODBUS_FORCEMULTICOIL |
MODBUS_FORCESINGLECOIL |
MODBUS_PRESETMULTIREGS |
MODBUS_PRESETSINGLEREG |
MODBUS_READCOILSTATUS |
MODBUS_READHOLDREG |
MODBUS_READINPUTREG |
MODBUS_READINPUTSTATUS |
MODERR_BASE |
MODERR_CLOSESOCKET_FAILED |
MODERR_CONNECT_FAILED |
MODERR_CREATECLN_FAILED |
MODERR_CREATESOCK_FAILED |
MODERR_CREATESVR_FAILED |
MODERR_MEMALLOC_FAILED |
MODERR_MODEXCEPT_01 |
MODERR_MODEXCEPT_02 |
MODERR_MODEXCEPT_03 |
MODERR_MODEXCEPT_04 |
MODERR_MODEXCEPT_05 |
MODERR_MODEXCEPT_06 |
MODERR_MODEXCEPT_07 |
MODERR_MODEXCEPT_08 |
MODERR_MODEXCEPT_99 |
MODERR_PARAMETER_INVALID |
MODERR_RTUCLIENT_INVALID |
MODERR_RTUCOM_INUSED |
MODERR_RTUCRC_INVALID |
MODERR_SETPRIO_FAILED |
MODERR_SOCKET_CLOSED |
MODERR_SUCCESS |
MODERR_TCPCLIENT_INVALID |
MODERR_TCPRECV_FAILED |
MODERR_TCPSEND_FAILED |
MODERR_THREAD_BUSY |
MODERR_THREAD_RUNNING |
MODERR_THREAD_STOP |
MODERR_WAIT_TIMEOUT |
MODERR_WSACLEAN_FAILED |
MODERR_WSASTART_FAILED |
MODEXCEPT_BASE |
Top

Public Methods

Name | Description
MOD_GetServerCoil | Get the coil status data (0x references) of the MODBUS server. In a process, the library has a single copy of coil status data that can be shared among threads.
MOD_GetServerHoldReg | Get the holding register data (4x references) of the MODBUS server. In a process, the library has a single copy of holding register data that can be shared among threads.
MOD_GetServerInput | Get the input status data (1x references) of the MODBUS server. In a process, the library has a single copy of input status data that can be shared among threads.
MOD_GetServerInputReg | Get the input register data (3x references) of the MODBUS server. In a process, the library has a single copy of input register data that can be shared among threads.
MOD_GetTcpServerClientIdle | Get the client transaction idle timeout.
MOD_GetTcpServerClientIp | Get the acceptable client IP address with indicated index.
MOD_GetVersion | Get the version number of the MODBUS library.
MOD_Initialize | Initialize the MODBUS library resource.
MOD_SetRtuServerComm | Set the MODBUS/RTU server communication parameters.
MOD_SetRtuServerPriority | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
MOD_SetRtuServerTimeout | Set the timeout parameters for all read and write operations on the MODBUS/RTU server.
MOD_SetServerCoil | Set the coil status data (0x references) of the MODBUS server. In a process, the library has a single copy of coil status data that can be shared among threads.
MOD_SetServerCoilChangedEventHandler | Set the coil status data changed event handler of the MODBUS server. Any clients try to write the coil status data to the server will cause the call back function to be called.
MOD_SetServerHoldReg | Set the holding register data (4x references) of the MODBUS server. In a process, the library has a single copy of holding register data that can be shared among threads.
MOD_SetServerHoldRegChangedEventHandler | Set the holding register data changed event handler of the MODBUS server. Any clients try to write the holding register data to the server will cause the call back function to be called.
MOD_SetServerInput | Set the input status data (1x references) of the MODBUS server. In a process, the library has a single copy of input status data that can be shared among threads.
MOD_SetServerInputReg | Set the input register data (3x references) of the MODBUS server. In a process, the library has a single copy of input register data that can be shared among threads.
MOD_SetTcpServerClientConnectEventHandler | Set the MODBUS/TCP client connect to the server event handler. Any clients connect to the server will cause the call back function to be called.
MOD_SetTcpServerClientDisconnectEventHandler | Set the MODBUS/TCP client disconnect from the server event handler. Any clients disconnect from the server will cause the call back function to be called.
MOD_SetTcpServerClientIdle | Set the client transaction idle timeout. If a connected client has been idled for the setting time, the server will disconnect the client from the server. The default value is 30 seconds.
MOD_SetTcpServerClientIp | Set the acceptable client IP address with indicated index.
MOD_SetTcpServerClientIpRestrict | Enable/disable the restriction of remote client connection. If this function sets the restriction to true, then only those clients set by MOD_SetTcpServerClientIp will be acceptable by the server.
MOD_SetTcpServerPriority | Set the priority of the MODBUS/TCP server running thread. Before calling this function, the MODBUS/TCP server has to be successfully started.
MOD_StartRtuServer | Start the MODBUS/RTU server.
MOD_StartTcpServer | Start the MODBUS/TCP server.
MOD_StopRtuServer | Stop the MODBUS/RTU server.
MOD_StopTcpServer | Stop the MODBUS/TCP server.
MOD_Terminate | Terminate the MODBUS library and release resource. Before calling this function, all MODBUS clients and servers have to be stopped.
Top

See Also

ModbusServerAPI Class
Advantech.Common Namespace


ModbusServerAPI Constructor

ModbusServerAPI Constructor
[image]

Initializes a new instance of the ModbusServerAPI class.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ModbusServerAPI()
C++
public:
ModbusServerAPI() sealed
J#
public ModbusServerAPI()
JScript
public function ModbusServerAPI()

See Also

ModbusServerAPI Class
Advantech.Common Namespace


Fields

ModbusServerAPI Fields
[image]

Public Fields

Name | Description
MODBUS_FORCEMULTICOIL |
MODBUS_FORCESINGLECOIL |
MODBUS_PRESETMULTIREGS |
MODBUS_PRESETSINGLEREG |
MODBUS_READCOILSTATUS |
MODBUS_READHOLDREG |
MODBUS_READINPUTREG |
MODBUS_READINPUTSTATUS |
MODERR_BASE |
MODERR_CLOSESOCKET_FAILED |
MODERR_CONNECT_FAILED |
MODERR_CREATECLN_FAILED |
MODERR_CREATESOCK_FAILED |
MODERR_CREATESVR_FAILED |
MODERR_MEMALLOC_FAILED |
MODERR_MODEXCEPT_01 |
MODERR_MODEXCEPT_02 |
MODERR_MODEXCEPT_03 |
MODERR_MODEXCEPT_04 |
MODERR_MODEXCEPT_05 |
MODERR_MODEXCEPT_06 |
MODERR_MODEXCEPT_07 |
MODERR_MODEXCEPT_08 |
MODERR_MODEXCEPT_99 |
MODERR_PARAMETER_INVALID |
MODERR_RTUCLIENT_INVALID |
MODERR_RTUCOM_INUSED |
MODERR_RTUCRC_INVALID |
MODERR_SETPRIO_FAILED |
MODERR_SOCKET_CLOSED |
MODERR_SUCCESS |
MODERR_TCPCLIENT_INVALID |
MODERR_TCPRECV_FAILED |
MODERR_TCPSEND_FAILED |
MODERR_THREAD_BUSY |
MODERR_THREAD_RUNNING |
MODERR_THREAD_STOP |
MODERR_WAIT_TIMEOUT |
MODERR_WSACLEAN_FAILED |
MODERR_WSASTART_FAILED |
MODEXCEPT_BASE |
Top

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_FORCEMULTICOIL Field

ModbusServerAPI.MODBUS_FORCEMULTICOIL Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_FORCEMULTICOIL As Integer
C#
public static readonly int MODBUS_FORCEMULTICOIL;
C++
public:
static const int MODBUS_FORCEMULTICOIL;
J#
public static final int MODBUS_FORCEMULTICOIL
JScript
public static const var MODBUS_FORCEMULTICOIL : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_FORCESINGLECOIL Field

ModbusServerAPI.MODBUS_FORCESINGLECOIL Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_FORCESINGLECOIL As Integer
C#
public static readonly int MODBUS_FORCESINGLECOIL;
C++
public:
static const int MODBUS_FORCESINGLECOIL;
J#
public static final int MODBUS_FORCESINGLECOIL
JScript
public static const var MODBUS_FORCESINGLECOIL : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_PRESETMULTIREGS Field

ModbusServerAPI.MODBUS_PRESETMULTIREGS Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_PRESETMULTIREGS As Integer
C#
public static readonly int MODBUS_PRESETMULTIREGS;
C++
public:
static const int MODBUS_PRESETMULTIREGS;
J#
public static final int MODBUS_PRESETMULTIREGS
JScript
public static const var MODBUS_PRESETMULTIREGS : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_PRESETSINGLEREG Field

ModbusServerAPI.MODBUS_PRESETSINGLEREG Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_PRESETSINGLEREG As Integer
C#
public static readonly int MODBUS_PRESETSINGLEREG;
C++
public:
static const int MODBUS_PRESETSINGLEREG;
J#
public static final int MODBUS_PRESETSINGLEREG
JScript
public static const var MODBUS_PRESETSINGLEREG : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_READCOILSTATUS Field

ModbusServerAPI.MODBUS_READCOILSTATUS Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_READCOILSTATUS As Integer
C#
public static readonly int MODBUS_READCOILSTATUS;
C++
public:
static const int MODBUS_READCOILSTATUS;
J#
public static final int MODBUS_READCOILSTATUS
JScript
public static const var MODBUS_READCOILSTATUS : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_READHOLDREG Field

ModbusServerAPI.MODBUS_READHOLDREG Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_READHOLDREG As Integer
C#
public static readonly int MODBUS_READHOLDREG;
C++
public:
static const int MODBUS_READHOLDREG;
J#
public static final int MODBUS_READHOLDREG
JScript
public static const var MODBUS_READHOLDREG : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_READINPUTREG Field

ModbusServerAPI.MODBUS_READINPUTREG Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_READINPUTREG As Integer
C#
public static readonly int MODBUS_READINPUTREG;
C++
public:
static const int MODBUS_READINPUTREG;
J#
public static final int MODBUS_READINPUTREG
JScript
public static const var MODBUS_READINPUTREG : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODBUS_READINPUTSTATUS Field

ModbusServerAPI.MODBUS_READINPUTSTATUS Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_READINPUTSTATUS As Integer
C#
public static readonly int MODBUS_READINPUTSTATUS;
C++
public:
static const int MODBUS_READINPUTSTATUS;
J#
public static final int MODBUS_READINPUTSTATUS
JScript
public static const var MODBUS_READINPUTSTATUS : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_BASE Field

ModbusServerAPI.MODERR_BASE Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_BASE As Integer
C#
public static readonly int MODERR_BASE;
C++
public:
static const int MODERR_BASE;
J#
public static final int MODERR_BASE
JScript
public static const var MODERR_BASE : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_CLOSESOCKET_FAILED Field

ModbusServerAPI.MODERR_CLOSESOCKET_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CLOSESOCKET_FAILED As Integer
C#
public static readonly int MODERR_CLOSESOCKET_FAILED;
C++
public:
static const int MODERR_CLOSESOCKET_FAILED;
J#
public static final int MODERR_CLOSESOCKET_FAILED
JScript
public static const var MODERR_CLOSESOCKET_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_CONNECT_FAILED Field

ModbusServerAPI.MODERR_CONNECT_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CONNECT_FAILED As Integer
C#
public static readonly int MODERR_CONNECT_FAILED;
C++
public:
static const int MODERR_CONNECT_FAILED;
J#
public static final int MODERR_CONNECT_FAILED
JScript
public static const var MODERR_CONNECT_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_CREATECLN_FAILED Field

ModbusServerAPI.MODERR_CREATECLN_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CREATECLN_FAILED As Integer
C#
public static readonly int MODERR_CREATECLN_FAILED;
C++
public:
static const int MODERR_CREATECLN_FAILED;
J#
public static final int MODERR_CREATECLN_FAILED
JScript
public static const var MODERR_CREATECLN_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_CREATESOCK_FAILED Field

ModbusServerAPI.MODERR_CREATESOCK_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CREATESOCK_FAILED As Integer
C#
public static readonly int MODERR_CREATESOCK_FAILED;
C++
public:
static const int MODERR_CREATESOCK_FAILED;
J#
public static final int MODERR_CREATESOCK_FAILED
JScript
public static const var MODERR_CREATESOCK_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_CREATESVR_FAILED Field

ModbusServerAPI.MODERR_CREATESVR_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CREATESVR_FAILED As Integer
C#
public static readonly int MODERR_CREATESVR_FAILED;
C++
public:
static const int MODERR_CREATESVR_FAILED;
J#
public static final int MODERR_CREATESVR_FAILED
JScript
public static const var MODERR_CREATESVR_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MEMALLOC_FAILED Field

ModbusServerAPI.MODERR_MEMALLOC_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MEMALLOC_FAILED As Integer
C#
public static readonly int MODERR_MEMALLOC_FAILED;
C++
public:
static const int MODERR_MEMALLOC_FAILED;
J#
public static final int MODERR_MEMALLOC_FAILED
JScript
public static const var MODERR_MEMALLOC_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_01 Field

ModbusServerAPI.MODERR_MODEXCEPT_01 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_01 As Integer
C#
public static readonly int MODERR_MODEXCEPT_01;
C++
public:
static const int MODERR_MODEXCEPT_01;
J#
public static final int MODERR_MODEXCEPT_01
JScript
public static const var MODERR_MODEXCEPT_01 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_02 Field

ModbusServerAPI.MODERR_MODEXCEPT_02 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_02 As Integer
C#
public static readonly int MODERR_MODEXCEPT_02;
C++
public:
static const int MODERR_MODEXCEPT_02;
J#
public static final int MODERR_MODEXCEPT_02
JScript
public static const var MODERR_MODEXCEPT_02 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_03 Field

ModbusServerAPI.MODERR_MODEXCEPT_03 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_03 As Integer
C#
public static readonly int MODERR_MODEXCEPT_03;
C++
public:
static const int MODERR_MODEXCEPT_03;
J#
public static final int MODERR_MODEXCEPT_03
JScript
public static const var MODERR_MODEXCEPT_03 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_04 Field

ModbusServerAPI.MODERR_MODEXCEPT_04 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_04 As Integer
C#
public static readonly int MODERR_MODEXCEPT_04;
C++
public:
static const int MODERR_MODEXCEPT_04;
J#
public static final int MODERR_MODEXCEPT_04
JScript
public static const var MODERR_MODEXCEPT_04 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_05 Field

ModbusServerAPI.MODERR_MODEXCEPT_05 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_05 As Integer
C#
public static readonly int MODERR_MODEXCEPT_05;
C++
public:
static const int MODERR_MODEXCEPT_05;
J#
public static final int MODERR_MODEXCEPT_05
JScript
public static const var MODERR_MODEXCEPT_05 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_06 Field

ModbusServerAPI.MODERR_MODEXCEPT_06 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_06 As Integer
C#
public static readonly int MODERR_MODEXCEPT_06;
C++
public:
static const int MODERR_MODEXCEPT_06;
J#
public static final int MODERR_MODEXCEPT_06
JScript
public static const var MODERR_MODEXCEPT_06 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_07 Field

ModbusServerAPI.MODERR_MODEXCEPT_07 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_07 As Integer
C#
public static readonly int MODERR_MODEXCEPT_07;
C++
public:
static const int MODERR_MODEXCEPT_07;
J#
public static final int MODERR_MODEXCEPT_07
JScript
public static const var MODERR_MODEXCEPT_07 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_08 Field

ModbusServerAPI.MODERR_MODEXCEPT_08 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_08 As Integer
C#
public static readonly int MODERR_MODEXCEPT_08;
C++
public:
static const int MODERR_MODEXCEPT_08;
J#
public static final int MODERR_MODEXCEPT_08
JScript
public static const var MODERR_MODEXCEPT_08 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_MODEXCEPT_99 Field

ModbusServerAPI.MODERR_MODEXCEPT_99 Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_99 As Integer
C#
public static readonly int MODERR_MODEXCEPT_99;
C++
public:
static const int MODERR_MODEXCEPT_99;
J#
public static final int MODERR_MODEXCEPT_99
JScript
public static const var MODERR_MODEXCEPT_99 : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_PARAMETER_INVALID Field

ModbusServerAPI.MODERR_PARAMETER_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_PARAMETER_INVALID As Integer
C#
public static readonly int MODERR_PARAMETER_INVALID;
C++
public:
static const int MODERR_PARAMETER_INVALID;
J#
public static final int MODERR_PARAMETER_INVALID
JScript
public static const var MODERR_PARAMETER_INVALID : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_RTUCLIENT_INVALID Field

ModbusServerAPI.MODERR_RTUCLIENT_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_RTUCLIENT_INVALID As Integer
C#
public static readonly int MODERR_RTUCLIENT_INVALID;
C++
public:
static const int MODERR_RTUCLIENT_INVALID;
J#
public static final int MODERR_RTUCLIENT_INVALID
JScript
public static const var MODERR_RTUCLIENT_INVALID : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_RTUCOM_INUSED Field

ModbusServerAPI.MODERR_RTUCOM_INUSED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_RTUCOM_INUSED As Integer
C#
public static readonly int MODERR_RTUCOM_INUSED;
C++
public:
static const int MODERR_RTUCOM_INUSED;
J#
public static final int MODERR_RTUCOM_INUSED
JScript
public static const var MODERR_RTUCOM_INUSED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_RTUCRC_INVALID Field

ModbusServerAPI.MODERR_RTUCRC_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_RTUCRC_INVALID As Integer
C#
public static readonly int MODERR_RTUCRC_INVALID;
C++
public:
static const int MODERR_RTUCRC_INVALID;
J#
public static final int MODERR_RTUCRC_INVALID
JScript
public static const var MODERR_RTUCRC_INVALID : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_SETPRIO_FAILED Field

ModbusServerAPI.MODERR_SETPRIO_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_SETPRIO_FAILED As Integer
C#
public static readonly int MODERR_SETPRIO_FAILED;
C++
public:
static const int MODERR_SETPRIO_FAILED;
J#
public static final int MODERR_SETPRIO_FAILED
JScript
public static const var MODERR_SETPRIO_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_SOCKET_CLOSED Field

ModbusServerAPI.MODERR_SOCKET_CLOSED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_SOCKET_CLOSED As Integer
C#
public static readonly int MODERR_SOCKET_CLOSED;
C++
public:
static const int MODERR_SOCKET_CLOSED;
J#
public static final int MODERR_SOCKET_CLOSED
JScript
public static const var MODERR_SOCKET_CLOSED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_SUCCESS Field

ModbusServerAPI.MODERR_SUCCESS Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_SUCCESS As Integer
C#
public static readonly int MODERR_SUCCESS;
C++
public:
static const int MODERR_SUCCESS;
J#
public static final int MODERR_SUCCESS
JScript
public static const var MODERR_SUCCESS : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_TCPCLIENT_INVALID Field

ModbusServerAPI.MODERR_TCPCLIENT_INVALID Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_TCPCLIENT_INVALID As Integer
C#
public static readonly int MODERR_TCPCLIENT_INVALID;
C++
public:
static const int MODERR_TCPCLIENT_INVALID;
J#
public static final int MODERR_TCPCLIENT_INVALID
JScript
public static const var MODERR_TCPCLIENT_INVALID : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_TCPRECV_FAILED Field

ModbusServerAPI.MODERR_TCPRECV_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_TCPRECV_FAILED As Integer
C#
public static readonly int MODERR_TCPRECV_FAILED;
C++
public:
static const int MODERR_TCPRECV_FAILED;
J#
public static final int MODERR_TCPRECV_FAILED
JScript
public static const var MODERR_TCPRECV_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_TCPSEND_FAILED Field

ModbusServerAPI.MODERR_TCPSEND_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_TCPSEND_FAILED As Integer
C#
public static readonly int MODERR_TCPSEND_FAILED;
C++
public:
static const int MODERR_TCPSEND_FAILED;
J#
public static final int MODERR_TCPSEND_FAILED
JScript
public static const var MODERR_TCPSEND_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_THREAD_BUSY Field

ModbusServerAPI.MODERR_THREAD_BUSY Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_THREAD_BUSY As Integer
C#
public static readonly int MODERR_THREAD_BUSY;
C++
public:
static const int MODERR_THREAD_BUSY;
J#
public static final int MODERR_THREAD_BUSY
JScript
public static const var MODERR_THREAD_BUSY : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_THREAD_RUNNING Field

ModbusServerAPI.MODERR_THREAD_RUNNING Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_THREAD_RUNNING As Integer
C#
public static readonly int MODERR_THREAD_RUNNING;
C++
public:
static const int MODERR_THREAD_RUNNING;
J#
public static final int MODERR_THREAD_RUNNING
JScript
public static const var MODERR_THREAD_RUNNING : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_THREAD_STOP Field

ModbusServerAPI.MODERR_THREAD_STOP Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_THREAD_STOP As Integer
C#
public static readonly int MODERR_THREAD_STOP;
C++
public:
static const int MODERR_THREAD_STOP;
J#
public static final int MODERR_THREAD_STOP
JScript
public static const var MODERR_THREAD_STOP : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_WAIT_TIMEOUT Field

ModbusServerAPI.MODERR_WAIT_TIMEOUT Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_WAIT_TIMEOUT As Integer
C#
public static readonly int MODERR_WAIT_TIMEOUT;
C++
public:
static const int MODERR_WAIT_TIMEOUT;
J#
public static final int MODERR_WAIT_TIMEOUT
JScript
public static const var MODERR_WAIT_TIMEOUT : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_WSACLEAN_FAILED Field

ModbusServerAPI.MODERR_WSACLEAN_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_WSACLEAN_FAILED As Integer
C#
public static readonly int MODERR_WSACLEAN_FAILED;
C++
public:
static const int MODERR_WSACLEAN_FAILED;
J#
public static final int MODERR_WSACLEAN_FAILED
JScript
public static const var MODERR_WSACLEAN_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODERR_WSASTART_FAILED Field

ModbusServerAPI.MODERR_WSASTART_FAILED Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_WSASTART_FAILED As Integer
C#
public static readonly int MODERR_WSASTART_FAILED;
C++
public:
static const int MODERR_WSASTART_FAILED;
J#
public static final int MODERR_WSASTART_FAILED
JScript
public static const var MODERR_WSASTART_FAILED : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MODEXCEPT_BASE Field

ModbusServerAPI.MODEXCEPT_BASE Field
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODEXCEPT_BASE As Integer
C#
public static readonly int MODEXCEPT_BASE;
C++
public:
static const int MODEXCEPT_BASE;
J#
public static final int MODEXCEPT_BASE
JScript
public static const var MODEXCEPT_BASE : int;

See Also

ModbusServerAPI Class
Advantech.Common Namespace


Methods

ModbusServerAPI Methods
[image]

Public Methods

Name | Description
MOD_GetServerCoil | Get the coil status data (0x references) of the MODBUS server. In a process, the library has a single copy of coil status data that can be shared among threads.
MOD_GetServerHoldReg | Get the holding register data (4x references) of the MODBUS server. In a process, the library has a single copy of holding register data that can be shared among threads.
MOD_GetServerInput | Get the input status data (1x references) of the MODBUS server. In a process, the library has a single copy of input status data that can be shared among threads.
MOD_GetServerInputReg | Get the input register data (3x references) of the MODBUS server. In a process, the library has a single copy of input register data that can be shared among threads.
MOD_GetTcpServerClientIdle | Get the client transaction idle timeout.
MOD_GetTcpServerClientIp | Get the acceptable client IP address with indicated index.
MOD_GetVersion | Get the version number of the MODBUS library.
MOD_Initialize | Initialize the MODBUS library resource.
MOD_SetRtuServerComm | Set the MODBUS/RTU server communication parameters.
MOD_SetRtuServerPriority | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
MOD_SetRtuServerTimeout | Set the timeout parameters for all read and write operations on the MODBUS/RTU server.
MOD_SetServerCoil | Set the coil status data (0x references) of the MODBUS server. In a process, the library has a single copy of coil status data that can be shared among threads.
MOD_SetServerCoilChangedEventHandler | Set the coil status data changed event handler of the MODBUS server. Any clients try to write the coil status data to the server will cause the call back function to be called.
MOD_SetServerHoldReg | Set the holding register data (4x references) of the MODBUS server. In a process, the library has a single copy of holding register data that can be shared among threads.
MOD_SetServerHoldRegChangedEventHandler | Set the holding register data changed event handler of the MODBUS server. Any clients try to write the holding register data to the server will cause the call back function to be called.
MOD_SetServerInput | Set the input status data (1x references) of the MODBUS server. In a process, the library has a single copy of input status data that can be shared among threads.
MOD_SetServerInputReg | Set the input register data (3x references) of the MODBUS server. In a process, the library has a single copy of input register data that can be shared among threads.
MOD_SetTcpServerClientConnectEventHandler | Set the MODBUS/TCP client connect to the server event handler. Any clients connect to the server will cause the call back function to be called.
MOD_SetTcpServerClientDisconnectEventHandler | Set the MODBUS/TCP client disconnect from the server event handler. Any clients disconnect from the server will cause the call back function to be called.
MOD_SetTcpServerClientIdle | Set the client transaction idle timeout. If a connected client has been idled for the setting time, the server will disconnect the client from the server. The default value is 30 seconds.
MOD_SetTcpServerClientIp | Set the acceptable client IP address with indicated index.
MOD_SetTcpServerClientIpRestrict | Enable/disable the restriction of remote client connection. If this function sets the restriction to true, then only those clients set by MOD_SetTcpServerClientIp will be acceptable by the server.
MOD_SetTcpServerPriority | Set the priority of the MODBUS/TCP server running thread. Before calling this function, the MODBUS/TCP server has to be successfully started.
MOD_StartRtuServer | Start the MODBUS/RTU server.
MOD_StartTcpServer | Start the MODBUS/TCP server.
MOD_StopRtuServer | Stop the MODBUS/RTU server.
MOD_StopTcpServer | Stop the MODBUS/TCP server.
MOD_Terminate | Terminate the MODBUS library and release resource. Before calling this function, all MODBUS clients and servers have to be stopped.
Top

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_GetServerCoil Method

ModbusServerAPI.MOD_GetServerCoil Method
[image]

Get the coil status data (0x references) of the MODBUS server. In a process, the library has a single copy of coil status data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_GetServerCoil", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_GetServerCoil( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char(), _
<OutAttribute> ByRef o_iRetLen As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerCoil", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_GetServerCoil(
int i_iStart,
int i_iLen,
char[] o_byBuf,
out int o_iRetLen
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_GetServerCoil", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_GetServerCoil(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf,
[OutAttribute] int% o_iRetLen
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerCoil", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_GetServerCoil(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf,
/** @attribute OutAttribute() */ /** @ref */ int o_iRetLen
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerCoil", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_GetServerCoil(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[],
OutAttribute o_iRetLen : int
) : int

Parameters

i_iStart
The start index of the coil status data. The range of this value is from 1 to 65535.
i_iLen
The length of the coil status data to be read. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to store the read coil status data.
o_iRetLen
The length of the returned coil status data in bytes.

Return Value

MODERR_SUCCESS, get the coil status data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the o_byBuf is NULL

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_GetServerHoldReg Method

ModbusServerAPI.MOD_GetServerHoldReg Method
[image]

Get the holding register data (4x references) of the MODBUS server. In a process, the library has a single copy of holding register data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_GetServerHoldReg", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_GetServerHoldReg( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char(), _
<OutAttribute> ByRef o_iRetLen As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerHoldReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_GetServerHoldReg(
int i_iStart,
int i_iLen,
char[] o_byBuf,
out int o_iRetLen
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_GetServerHoldReg", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_GetServerHoldReg(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf,
[OutAttribute] int% o_iRetLen
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerHoldReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_GetServerHoldReg(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf,
/** @attribute OutAttribute() */ /** @ref */ int o_iRetLen
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerHoldReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_GetServerHoldReg(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[],
OutAttribute o_iRetLen : int
) : int

Parameters

i_iStart
The start index of the holding register data. The range of this value is from 1 to 65535.
i_iLen
The length of the holding register data to be read. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to store the read holding register data.
o_iRetLen
The length of the returned holding register data in bytes.

Return Value

MODERR_SUCCESS, get the holding register data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the o_byBuf is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_GetServerInput Method

ModbusServerAPI.MOD_GetServerInput Method
[image]

Get the input status data (1x references) of the MODBUS server. In a process, the library has a single copy of input status data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_GetServerInput", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_GetServerInput( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char(), _
<OutAttribute> ByRef o_iRetLen As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerInput", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_GetServerInput(
int i_iStart,
int i_iLen,
char[] o_byBuf,
out int o_iRetLen
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_GetServerInput", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_GetServerInput(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf,
[OutAttribute] int% o_iRetLen
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerInput", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_GetServerInput(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf,
/** @attribute OutAttribute() */ /** @ref */ int o_iRetLen
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerInput", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_GetServerInput(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[],
OutAttribute o_iRetLen : int
) : int

Parameters

i_iStart
The start index of the input status data. The range of this value is from 1 to 65535.
i_iLen
The length of the input status data to be read. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to store the read input status data.
o_iRetLen
The length of the returned input status data in bytes.

Return Value

MODERR_SUCCESS, get the input status data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the o_byBuf is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_GetServerInputReg Method

ModbusServerAPI.MOD_GetServerInputReg Method
[image]

Get the input register data (3x references) of the MODBUS server. In a process, the library has a single copy of input register data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_GetServerInputReg", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_GetServerInputReg( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char(), _
<OutAttribute> ByRef o_iRetLen As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerInputReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_GetServerInputReg(
int i_iStart,
int i_iLen,
char[] o_byBuf,
out int o_iRetLen
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_GetServerInputReg", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_GetServerInputReg(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf,
[OutAttribute] int% o_iRetLen
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerInputReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_GetServerInputReg(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf,
/** @attribute OutAttribute() */ /** @ref */ int o_iRetLen
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetServerInputReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_GetServerInputReg(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[],
OutAttribute o_iRetLen : int
) : int

Parameters

i_iStart
The start index of the input register data. The range of this value is from 1 to 65535.
i_iLen
The length of the input register data to be read. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to store the read input register data.
o_iRetLen
The length of the returned input register data in bytes.

Return Value

MODERR_SUCCESS, get the input register data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the o_byBuf is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_GetTcpServerClientIdle Method

ModbusServerAPI.MOD_GetTcpServerClientIdle Method
[image]

Get the client transaction idle timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_GetTcpServerClientIdle", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_GetTcpServerClientIdle( _
<OutAttribute> ByRef o_iIdleSec As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetTcpServerClientIdle", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_GetTcpServerClientIdle(
out int o_iIdleSec
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_GetTcpServerClientIdle", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_GetTcpServerClientIdle(
[OutAttribute] int% o_iIdleSec
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetTcpServerClientIdle", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_GetTcpServerClientIdle(
/** @attribute OutAttribute() */ /** @ref */ int o_iIdleSec
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetTcpServerClientIdle", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_GetTcpServerClientIdle(
OutAttribute o_iIdleSec : int
) : int

Parameters

o_iIdleSec
The transaction idle timeout.

Return Value

MODERR_SUCCESS, get the transaction idle timeout succeeded.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_GetTcpServerClientIp Method

ModbusServerAPI.MOD_GetTcpServerClientIp Method
[image]

Get the acceptable client IP address with indicated index.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_GetTcpServerClientIp", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_GetTcpServerClientIp( _
ByVal i_iIndex As Integer, _
ByVal o_szIp As String _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetTcpServerClientIp", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_GetTcpServerClientIp(
int i_iIndex,
string o_szIp
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_GetTcpServerClientIp", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_GetTcpServerClientIp(
int i_iIndex,
String o_szIp
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetTcpServerClientIp", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_GetTcpServerClientIp(
int i_iIndex,
string o_szIp
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetTcpServerClientIp", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_GetTcpServerClientIp(
i_iIndex : int,
o_szIp : String
) : int

Parameters

i_iIndex
The index of the acceptable client. This value is ranged from 0 to 7.
o_szIp
The IP address of the client in the indicated index.

Return Value

MODERR_SUCCESS, get the client IP succeeded. MODERR_PARAMETER_INVALID, indicates the i_iIndex is out of range.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_GetVersion Method

ModbusServerAPI.MOD_GetVersion Method
[image]

Get the version number of the MODBUS library.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_GetVersion", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_GetVersion() As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_GetVersion()
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_GetVersion", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_GetVersion()
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_GetVersion()
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_GetVersion", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_GetVersion() : int

Return Value

The version number. In hex decimal format, for example 0x0101, it means the version is 1.01.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_Initialize Method

ModbusServerAPI.MOD_Initialize Method
[image]

Initialize the MODBUS library resource.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_Initialize", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_Initialize() As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_Initialize", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_Initialize()
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_Initialize", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_Initialize()
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_Initialize", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_Initialize()
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_Initialize", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_Initialize() : int

Return Value

MODERR_SUCCESS initialized MODBUS library succeeded. MODERR_WSASTART_FAILED failed to initialize resource

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetRtuServerComm Method

ModbusServerAPI.MOD_SetRtuServerComm Method
[image]

Set the MODBUS/RTU server communication parameters.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetRtuServerComm", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetRtuServerComm( _
ByVal i_iServerIndex As Integer, _
ByVal i_lBaudrate As Integer, _
ByVal i_iDataBits As Integer, _
ByVal i_iParity As Integer, _
ByVal i_iStop As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerComm", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetRtuServerComm(
int i_iServerIndex,
int i_lBaudrate,
int i_iDataBits,
int i_iParity,
int i_iStop
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetRtuServerComm", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetRtuServerComm(
int i_iServerIndex,
int i_lBaudrate,
int i_iDataBits,
int i_iParity,
int i_iStop
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerComm", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetRtuServerComm(
int i_iServerIndex,
int i_lBaudrate,
int i_iDataBits,
int i_iParity,
int i_iStop
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerComm", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetRtuServerComm(
i_iServerIndex : int,
i_lBaudrate : int,
i_iDataBits : int,
i_iParity : int,
i_iStop : int
) : int

Parameters

i_iServerIndex
The server index. The range of this value is from 0 to 1.
i_lBaudrate
Specifies the baud rate at which the MODBUS/RTU server operates.
i_iDataBits
Specifies the number of bits in the bytes transmitted and received. The range of this value is from 5 to 8.
i_iParity
Specifies the parity scheme to be used.
i_iStop
Specifies the number of stop bits to be used.

Return Value

MODERR_SUCCESS, set the restriction succeeded.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetRtuServerPriority Method

ModbusServerAPI.MOD_SetRtuServerPriority Method
[image]

Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetRtuServerPriority", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetRtuServerPriority( _
ByVal i_iServerIndex As Integer, _
ByVal i_iPriority As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerPriority", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetRtuServerPriority(
int i_iServerIndex,
int i_iPriority
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetRtuServerPriority", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetRtuServerPriority(
int i_iServerIndex,
int i_iPriority
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerPriority", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetRtuServerPriority(
int i_iServerIndex,
int i_iPriority
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerPriority", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetRtuServerPriority(
i_iServerIndex : int,
i_iPriority : int
) : int

Parameters

i_iServerIndex
The server index. The range of this value is from 0 to 1.
i_iPriority
Specifies the priority value for the server thread.

Return Value

MODERR_SUCCESS, set MODBUS/RTU server thread priority succeeded. MODERR_PARAMETER_INVALID, indicates the i_iServerIndex is out of range. MODERR_SETPRIO_FAILED, failed to set the thread priority.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetRtuServerTimeout Method

ModbusServerAPI.MOD_SetRtuServerTimeout Method
[image]

Set the timeout parameters for all read and write operations on the MODBUS/RTU server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetRtuServerTimeout", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetRtuServerTimeout( _
ByVal i_iServerIndex As Integer, _
ByVal i_iReadIntervalTimeout As Integer, _
ByVal i_iReadTotalTimeoutConstant As Integer, _
ByVal i_iReadTotalTimeoutMultiplier As Integer, _
ByVal i_iWriteTotalTimeoutConstant As Integer, _
ByVal i_iWriteTotalTimeoutMultiplier As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerTimeout", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetRtuServerTimeout(
int i_iServerIndex,
int i_iReadIntervalTimeout,
int i_iReadTotalTimeoutConstant,
int i_iReadTotalTimeoutMultiplier,
int i_iWriteTotalTimeoutConstant,
int i_iWriteTotalTimeoutMultiplier
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetRtuServerTimeout", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetRtuServerTimeout(
int i_iServerIndex,
int i_iReadIntervalTimeout,
int i_iReadTotalTimeoutConstant,
int i_iReadTotalTimeoutMultiplier,
int i_iWriteTotalTimeoutConstant,
int i_iWriteTotalTimeoutMultiplier
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerTimeout", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetRtuServerTimeout(
int i_iServerIndex,
int i_iReadIntervalTimeout,
int i_iReadTotalTimeoutConstant,
int i_iReadTotalTimeoutMultiplier,
int i_iWriteTotalTimeoutConstant,
int i_iWriteTotalTimeoutMultiplier
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetRtuServerTimeout", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetRtuServerTimeout(
i_iServerIndex : int,
i_iReadIntervalTimeout : int,
i_iReadTotalTimeoutConstant : int,
i_iReadTotalTimeoutMultiplier : int,
i_iWriteTotalTimeoutConstant : int,
i_iWriteTotalTimeoutMultiplier : int
) : int

Parameters

i_iServerIndex
The server index. The range of this value is from 0 to 1.
i_iReadIntervalTimeout
This parameter sets the Specifies the maximum acceptable time, in milliseconds, to elapse between the arrival of two characters on the communication line.
i_iReadTotalTimeoutConstant
Specifies the constant, in milliseconds, used to calculate the total timeout period for read operations.
i_iReadTotalTimeoutMultiplier
Specifies the multiplier, in milliseconds, used to calculate the total timeout period for read operations.
i_iWriteTotalTimeoutConstant
Specifies the constant, in milliseconds, used to calculate the total timeout period for write operations.
i_iWriteTotalTimeoutMultiplier
Specifies the multiplier, in milliseconds, used to calculate the total timeout period for write operations.

Return Value

MODERR_SUCCESS, set the timeout parameters succeeded. MODERR_PARAMETER_INVALID, indicates the i_iServerIndex is out of range.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetServerCoil Method

ModbusServerAPI.MOD_SetServerCoil Method
[image]

Set the coil status data (0x references) of the MODBUS server. In a process, the library has a single copy of coil status data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetServerCoil", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetServerCoil( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char() _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerCoil", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetServerCoil(
int i_iStart,
int i_iLen,
char[] o_byBuf
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetServerCoil", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetServerCoil(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerCoil", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetServerCoil(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerCoil", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetServerCoil(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[]
) : int

Parameters

i_iStart
The start index of the coil status data. The range of this value is from 1 to 65535.
i_iLen
The length of the coil status data to be set. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to hold the coil status data to be set. For example, if the i_iLen is 40, then the length of this buffer must be 5 bytes long.

Return Value

MODERR_SUCCESS, set the coil status data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the i_byBuf is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetServerCoilChangedEventHandler Method

ModbusServerAPI.MOD_SetServerCoilChangedEventHandler Method
[image]

Set the coil status data changed event handler of the MODBUS server. Any clients try to write the coil status data to the server will cause the call back function to be called.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetServerCoilChangedEventHandler", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetServerCoilChangedEventHandler( _
ByVal i_evtHandle As ModbusServerAPI.EventHandler_OnCoilChangedEvent _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerCoilChangedEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetServerCoilChangedEventHandler(
ModbusServerAPI.EventHandler_OnCoilChangedEvent i_evtHandle
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetServerCoilChangedEventHandler", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetServerCoilChangedEventHandler(
ModbusServerAPI.EventHandler_OnCoilChangedEvent i_evtHandle
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerCoilChangedEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetServerCoilChangedEventHandler(
ModbusServerAPI.EventHandler_OnCoilChangedEvent i_evtHandle
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerCoilChangedEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetServerCoilChangedEventHandler(
i_evtHandle : ModbusServerAPI.EventHandler_OnCoilChangedEvent
) : int

Parameters

i_evtHandle
The handler of the call back function.

Return Value

MODERR_SUCCESS, get the coil status data succeeded. MODERR_PARAMETER_INVALID, indicates the i_evtHandle is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetServerHoldReg Method

ModbusServerAPI.MOD_SetServerHoldReg Method
[image]

Set the holding register data (4x references) of the MODBUS server. In a process, the library has a single copy of holding register data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetServerHoldReg", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetServerHoldReg( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char() _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerHoldReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetServerHoldReg(
int i_iStart,
int i_iLen,
char[] o_byBuf
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetServerHoldReg", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetServerHoldReg(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerHoldReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetServerHoldReg(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerHoldReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetServerHoldReg(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[]
) : int

Parameters

i_iStart
The start index of the holding register data. The range of this value is from 1 to 65535.
i_iLen
The length of the holding register data to be set. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to hold the holding register data to be set. For example, if the i_iLen is 40, then the length of this buffer must be 80 bytes long. (each register is 2 bytes long) The order of the bytes is as follow: [Reg-0 High byte], [Reg-0 Low byte], [Reg-1 High byte], [Reg-1 Low byte]…

Return Value

MODERR_SUCCESS, set the holding register data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the i_byBuf is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetServerHoldRegChangedEventHandler Method

ModbusServerAPI.MOD_SetServerHoldRegChangedEventHandler Method
See Also Example
[image]

Set the holding register data changed event handler of the MODBUS server. Any clients try to write the holding register data to the server will cause the call back function to be called.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetServerHoldRegChangedEventHandler", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetServerHoldRegChangedEventHandler( _
ByVal i_evtHandle As ModbusServerAPI.EventHandler_OnHoldRegChangedEvent _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerHoldRegChangedEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetServerHoldRegChangedEventHandler(
ModbusServerAPI.EventHandler_OnHoldRegChangedEvent i_evtHandle
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetServerHoldRegChangedEventHandler", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetServerHoldRegChangedEventHandler(
ModbusServerAPI.EventHandler_OnHoldRegChangedEvent i_evtHandle
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerHoldRegChangedEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetServerHoldRegChangedEventHandler(
ModbusServerAPI.EventHandler_OnHoldRegChangedEvent i_evtHandle
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerHoldRegChangedEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetServerHoldRegChangedEventHandler(
i_evtHandle : ModbusServerAPI.EventHandler_OnHoldRegChangedEvent
) : int

Parameters

i_evtHandle
The handler of the call back function.

Return Value

MODERR_SUCCESS, get the coil status data succeeded. MODERR_PARAMETER_INVALID, indicates the i_evtHandle is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetServerInput Method

ModbusServerAPI.MOD_SetServerInput Method
[image]

Set the input status data (1x references) of the MODBUS server. In a process, the library has a single copy of input status data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetServerInput", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetServerInput( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char() _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerInput", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetServerInput(
int i_iStart,
int i_iLen,
char[] o_byBuf
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetServerInput", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetServerInput(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerInput", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetServerInput(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerInput", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetServerInput(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[]
) : int

Parameters

i_iStart
The start index of the input status data. The range of this value is from 1 to 65535.
i_iLen
The length of the input status data to be set. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to hold the input status data to be set. For example, if the i_iLen is 40, then the length of this buffer must be 5 bytes long.

Return Value

MODERR_SUCCESS, set the input status data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the i_byBuf is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetServerInputReg Method

ModbusServerAPI.MOD_SetServerInputReg Method
[image]

Set the input register data (3x references) of the MODBUS server. In a process, the library has a single copy of input register data that can be shared among threads.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetServerInputReg", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetServerInputReg( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer, _
<OutAttribute> ByVal o_byBuf As Char() _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerInputReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetServerInputReg(
int i_iStart,
int i_iLen,
char[] o_byBuf
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetServerInputReg", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetServerInputReg(
int i_iStart,
int i_iLen,
[OutAttribute] array<wchar_t>^ o_byBuf
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerInputReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetServerInputReg(
int i_iStart,
int i_iLen,
/** @attribute OutAttribute() */ char[] o_byBuf
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetServerInputReg", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetServerInputReg(
i_iStart : int,
i_iLen : int,
OutAttribute o_byBuf : char[]
) : int

Parameters

i_iStart
The start index of the input register data. The range of this value is from 1 to 65535.
i_iLen
The length of the input register data to be set. The range of this value is from 1 to 65536. The sum of i_iStart and i_iLen must be less than or equal to 65536.
o_byBuf
The buffer pointer where to hold the input register data to be set. For example, if the i_iLen is 40, then the length of this buffer must be 80 bytes long. (each register is 2 bytes long) The order of the bytes is as follow: [Reg-0 High byte], [Reg-0 Low byte], [Reg-1 High byte], [Reg-1 Low byte]…

Return Value

MODERR_SUCCESS, set the input register data succeeded. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range or the i_byBuf is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetTcpServerClientConnectEventHandler Method

ModbusServerAPI.MOD_SetTcpServerClientConnectEventHandler Method
See Also Example
[image]

Set the MODBUS/TCP client connect to the server event handler. Any clients connect to the server will cause the call back function to be called.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetTcpServerClientConnectEventHandler", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetTcpServerClientConnectEventHandler( _
ByVal i_evtHandle As ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientConnectEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetTcpServerClientConnectEventHandler(
ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent i_evtHandle
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetTcpServerClientConnectEventHandler", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetTcpServerClientConnectEventHandler(
ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent i_evtHandle
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientConnectEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetTcpServerClientConnectEventHandler(
ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent i_evtHandle
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientConnectEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetTcpServerClientConnectEventHandler(
i_evtHandle : ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent
) : int

Parameters

i_evtHandle
The handler of the call back function.

Return Value

MODERR_SUCCESS, get the coil status data succeeded. MODERR_PARAMETER_INVALID, indicates the i_evtHandle is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetTcpServerClientDisconnectEventHandler Method

ModbusServerAPI.MOD_SetTcpServerClientDisconnectEventHandler Method
See Also Example
[image]

Set the MODBUS/TCP client disconnect from the server event handler. Any clients disconnect from the server will cause the call back function to be called.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetTcpServerClientDisconnectEventHandler", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetTcpServerClientDisconnectEventHandler( _
ByVal i_evtHandle As ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientDisconnectEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetTcpServerClientDisconnectEventHandler(
ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent i_evtHandle
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetTcpServerClientDisconnectEventHandler", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetTcpServerClientDisconnectEventHandler(
ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent i_evtHandle
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientDisconnectEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetTcpServerClientDisconnectEventHandler(
ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent i_evtHandle
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientDisconnectEventHandler", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetTcpServerClientDisconnectEventHandler(
i_evtHandle : ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent
) : int

Parameters

i_evtHandle
The handler of the call back function.

Return Value

MODERR_SUCCESS, get the coil status data succeeded. MODERR_PARAMETER_INVALID, indicates the i_evtHandle is NULL.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetTcpServerClientIdle Method

ModbusServerAPI.MOD_SetTcpServerClientIdle Method
[image]

Set the client transaction idle timeout. If a connected client has been idled for the setting time, the server will disconnect the client from the server. The default value is 30 seconds.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetTcpServerClientIdle", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetTcpServerClientIdle( _
ByVal i_iIdleSec As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIdle", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetTcpServerClientIdle(
int i_iIdleSec
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetTcpServerClientIdle", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetTcpServerClientIdle(
int i_iIdleSec
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIdle", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetTcpServerClientIdle(
int i_iIdleSec
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIdle", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetTcpServerClientIdle(
i_iIdleSec : int
) : int

Parameters

i_iIdleSec
The transaction idle timeout. The value is ranged from 5 to 600 (seconds).

Return Value

MODERR_SUCCESS, set the transaction idle timeout succeeded. MODERR_PARAMETER_INVALID, indicates the i_iIdleSec is out of range.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetTcpServerClientIp Method

ModbusServerAPI.MOD_SetTcpServerClientIp Method
[image]

Set the acceptable client IP address with indicated index.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetTcpServerClientIp", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetTcpServerClientIp( _
ByVal i_iIndex As Integer, _
ByVal i_szIp As String _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIp", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetTcpServerClientIp(
int i_iIndex,
string i_szIp
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetTcpServerClientIp", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetTcpServerClientIp(
int i_iIndex,
String i_szIp
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIp", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetTcpServerClientIp(
int i_iIndex,
string i_szIp
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIp", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetTcpServerClientIp(
i_iIndex : int,
i_szIp : String
) : int

Parameters

i_iIndex
The index of the acceptable client. This value is ranged from 0 to 7.
i_szIp
The IP address of the client.

Return Value

MODERR_SUCCESS, set the client IP succeeded. MODERR_PARAMETER_INVALID, indicates the i_iIndex is out of range or the IP is invalid.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetTcpServerClientIpRestrict Method

ModbusServerAPI.MOD_SetTcpServerClientIpRestrict Method
[image]

Enable/disable the restriction of remote client connection. If this function sets the restriction to true, then only those clients set by MOD_SetTcpServerClientIp will be acceptable by the server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetTcpServerClientIpRestrict", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetTcpServerClientIpRestrict( _
ByVal i_bRestrict As Boolean _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIpRestrict", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetTcpServerClientIpRestrict(
bool i_bRestrict
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetTcpServerClientIpRestrict", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetTcpServerClientIpRestrict(
bool i_bRestrict
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIpRestrict", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetTcpServerClientIpRestrict(
bool i_bRestrict
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerClientIpRestrict", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetTcpServerClientIpRestrict(
i_bRestrict : bool
) : int

Parameters

i_bRestrict
The Boolean value indicates whether the IP restriction is applied.

Return Value

MODERR_SUCCESS, set the restriction succeeded.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_SetTcpServerPriority Method

ModbusServerAPI.MOD_SetTcpServerPriority Method
[image]

Set the priority of the MODBUS/TCP server running thread. Before calling this function, the MODBUS/TCP server has to be successfully started.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_SetTcpServerPriority", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_SetTcpServerPriority( _
ByVal i_iPriority As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerPriority", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_SetTcpServerPriority(
int i_iPriority
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_SetTcpServerPriority", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_SetTcpServerPriority(
int i_iPriority
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerPriority", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_SetTcpServerPriority(
int i_iPriority
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_SetTcpServerPriority", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_SetTcpServerPriority(
i_iPriority : int
) : int

Parameters

i_iPriority
Specifies the priority value for the server thread.

Return Value

MODERR_SUCCESS, set MODBUS-TCP server thread priority succeeded. MODERR_SETPRIO_FAILED, failed to set the thread priority.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_StartRtuServer Method

ModbusServerAPI.MOD_StartRtuServer Method
[image]

Start the MODBUS/RTU server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_StartRtuServer", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_StartRtuServer( _
ByVal i_iServerIndex As Integer, _
ByVal i_iComIndex As Integer, _
ByVal i_bySlaveAddr As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StartRtuServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_StartRtuServer(
int i_iServerIndex,
int i_iComIndex,
int i_bySlaveAddr
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_StartRtuServer", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_StartRtuServer(
int i_iServerIndex,
int i_iComIndex,
int i_bySlaveAddr
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StartRtuServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_StartRtuServer(
int i_iServerIndex,
int i_iComIndex,
int i_bySlaveAddr
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StartRtuServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_StartRtuServer(
i_iServerIndex : int,
i_iComIndex : int,
i_bySlaveAddr : int
) : int

Parameters

i_iServerIndex
The server index. This library supports two MODBUS/RTU servers can be created at a single process. The range of this value is from 0 to 1.
i_iComIndex
The index of the COM port. The range of this value is from 1 to 255.
i_bySlaveAddr
The slave address of the server. The range of this value is from 1 to 247.

Return Value

MODERR_SUCCESS, started MODBUS/RTU server succeeded. MODERR_THREAD_RUNNING, the server is already started. MODERR_CREATESVR_FAILED, failed to start MODBUS/RTU server. Normally, this caused by the COM port has been used. MODERR_PARAMETER_INVALID, indicates some of the parameters are out of range.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_StartTcpServer Method

ModbusServerAPI.MOD_StartTcpServer Method
[image]

Start the MODBUS/TCP server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_StartTcpServer", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_StartTcpServer() As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StartTcpServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_StartTcpServer()
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_StartTcpServer", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_StartTcpServer()
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StartTcpServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_StartTcpServer()
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StartTcpServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_StartTcpServer() : int

Return Value

MODERR_SUCCESS, started MODBUS/TCP server succeeded. MODERR_THREAD_RUNNING, the server is already started. MODERR_CREATESVR_FAILED, failed to start MODBUS/TCP server. Normally, this caused by the server port (502) has been used.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_StopRtuServer Method

ModbusServerAPI.MOD_StopRtuServer Method
[image]

Stop the MODBUS/RTU server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_StopRtuServer", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_StopRtuServer( _
ByVal i_iServerIndex As Integer _
) As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StopRtuServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_StopRtuServer(
int i_iServerIndex
)
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_StopRtuServer", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_StopRtuServer(
int i_iServerIndex
)
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StopRtuServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_StopRtuServer(
int i_iServerIndex
)
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StopRtuServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_StopRtuServer(
i_iServerIndex : int
) : int

Parameters

i_iServerIndex
The server index. The range of this value is from 0 to 1.

Return Value

MODERR_SUCCESS, stopped MODBUS/RTU server succeeded. MODERR_PARAMETER_INVALID, indicates the i_iServerIndex is out of range.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_StopTcpServer Method

ModbusServerAPI.MOD_StopTcpServer Method
[image]

Stop the MODBUS/TCP server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_StopTcpServer", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_StopTcpServer() As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StopTcpServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_StopTcpServer()
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_StopTcpServer", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_StopTcpServer()
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StopTcpServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_StopTcpServer()
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_StopTcpServer", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_StopTcpServer() : int

Return Value

MODERR_SUCCESS, stopped MODBUS-TCP server succeeded.

See Also

ModbusServerAPI Class
Advantech.Common Namespace


MOD_Terminate Method

ModbusServerAPI.MOD_Terminate Method
[image]

Terminate the MODBUS library and release resource. Before calling this function, all MODBUS clients and servers have to be stopped.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<DllImportAttribute("ADSMOD.dll", EntryPoint := "MOD_Terminate", CharSet := CharSet.None, ExactSpelling := False, SetLastError := True, PreserveSig := True, CallingConvention := CallingConvention.Winapi, BestFitMapping := False, ThrowOnUnmappableChar := False), _
PreserveSigAttribute>
Public Shared Function MOD_Terminate() As Integer
C#
[DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_Terminate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public static int MOD_Terminate()
C++
[DllImportAttribute(L"ADSMOD.dll", EntryPoint = L"MOD_Terminate", CharSet = CharSet::None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention::Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)]
[PreserveSigAttribute]
public:
static int MOD_Terminate()
J#
/** @attribute DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_Terminate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False) */
/** @attribute PreserveSigAttribute() */
public static int MOD_Terminate()
JScript
public static

DllImportAttribute("ADSMOD.dll", EntryPoint = "MOD_Terminate", CharSet = CharSet.None, ExactSpelling = False, SetLastError = True, PreserveSig = True, CallingConvention = CallingConvention.Winapi, BestFitMapping = False, ThrowOnUnmappableChar = False)
PreserveSigAttribute
function MOD_Terminate() : int

Return Value

MODERR_SUCCESS terminated MODBUS library succeeded. MODERR_WSACLEAN_FAILED failed to terminate resource

See Also

ModbusServerAPI Class
Advantech.Common Namespace


ModbusServerAPI.EventHandler_OnCoilChangedEvent Delegate

ModbusServerAPI.EventHandler_OnCoilChangedEvent Delegate
[image]

The prototype of call back function when the coil changed event occurred.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)>
Public Delegate Sub ModbusServerAPI.EventHandler_OnCoilChangedEvent( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer _
)
C#
[UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnCoilChangedEvent(
int i_iStart,
int i_iLen
)
C++
[UnmanagedFunctionPointerAttribute(CallingConvention::Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnCoilChangedEvent(
int i_iStart,
int i_iLen
)
J#
/** delegate */
/** @attribute UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl) */
public delegate void ModbusServerAPI.EventHandler_OnCoilChangedEvent(
int i_iStart,
int i_iLen
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Common Namespace


ModbusServerAPI.EventHandler_OnHoldRegChangedEvent Delegate

ModbusServerAPI.EventHandler_OnHoldRegChangedEvent Delegate
[image]

The prototype of the call back function when the holding register changed event occurred.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)>
Public Delegate Sub ModbusServerAPI.EventHandler_OnHoldRegChangedEvent( _
ByVal i_iStart As Integer, _
ByVal i_iLen As Integer _
)
C#
[UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnHoldRegChangedEvent(
int i_iStart,
int i_iLen
)
C++
[UnmanagedFunctionPointerAttribute(CallingConvention::Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnHoldRegChangedEvent(
int i_iStart,
int i_iLen
)
J#
/** delegate */
/** @attribute UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl) */
public delegate void ModbusServerAPI.EventHandler_OnHoldRegChangedEvent(
int i_iStart,
int i_iLen
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Common Namespace


ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent Delegate

ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent Delegate
See Also Example
[image]

The prototype of the call back function when a remote client connects to the server event occurred.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)>
Public Delegate Sub ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent( _
ByVal i_szIp As String _
)
C#
[UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent(
string i_szIp
)
C++
[UnmanagedFunctionPointerAttribute(CallingConvention::Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent(
String i_szIp
)
J#
/** delegate */
/** @attribute UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl) */
public delegate void ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent(
string i_szIp
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Common Namespace


ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent Delegate

ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent Delegate
See Also Example
[image]

The prototype of the call back function when a remote client disconnects from the server event occurred.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
<UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)>
Public Delegate Sub ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent( _
ByVal i_szIp As String _
)
C#
[UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent(
string i_szIp
)
C++
[UnmanagedFunctionPointerAttribute(CallingConvention::Cdecl)]
public delegate void ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent(
String i_szIp
)
J#
/** delegate */
/** @attribute UnmanagedFunctionPointerAttribute(CallingConvention.Cdecl) */
public delegate void ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent(
string i_szIp
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Common Namespace


Parity Enumeration

Parity Enumeration
[image]

Parity settings

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum Parity As Byte
C#
public enum Parity : byte
C++
public enum class Parity : char
J#
public enum Parity byte
JScript
public enum Parity :

Members

Member Name | Description
None | Characters do not have a parity bit.
Odd | Set if there are an odd number of 1s in the character.
Even | Set if there are an even number of 1s in the character.
Mark | The parity bit is always 1.
Space | The parity bit is always 0.

See Also

Advantech.Common Namespace


Ping Class

Ping Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class Ping
C#
public class Ping
C++
ref class Ping
J#
public class Ping
JScript
public class Ping

Inheritance Hierarchy

System.Object
Advantech.Common.Ping

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Ping Members
Advantech.Common Namespace


Ping Members

Ping Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by Ping.

Public Constructors

 | Name | Description
Public method | Ping | Initializes a new instance of the Ping class.
Top

Public Methods

 | Name | Description
Public method | Initialize |
Public method | LastError |
Public method | PingIP |
Public method | Terminate |
Top

See Also

Ping Class
Advantech.Common Namespace


Ping Constructor

Ping Constructor
[image]

Initializes a new instance of the Ping class.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Ping()
C++
public:
Ping() sealed
J#
public Ping()
JScript
public function Ping()

See Also

Ping Class
Advantech.Common Namespace


Methods

Ping Methods
[image]

Public Methods

 | Name | Description
Public method | Initialize |
Public method | LastError |
Public method | PingIP |
Public method | Terminate |
Top

See Also

Ping Class
Advantech.Common Namespace


Initialize Method

Ping.Initialize Method
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize( _
ByVal i_iTimeout As Integer _
)
C#
public void Initialize(
int i_iTimeout
)
C++
public:
void Initialize(
int i_iTimeout
) sealed
J#
public void Initialize(
int i_iTimeout
)
JScript
public function Initialize(
i_iTimeout : int
)

Parameters

i_iTimeout

See Also

Ping Class
Advantech.Common Namespace


LastError Method

Ping.LastError Method
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function LastError() As Integer
C#
public int LastError()
C++
public:
int LastError() sealed
J#
public int LastError()
JScript
public function LastError() : int

See Also

Ping Class
Advantech.Common Namespace


PingIP Method

Ping.PingIP Method
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub PingIP( _
ByVal i_szIPAddr As String, _
<OutAttribute> ByRef o_szMessage As String _
)
C#
public void PingIP(
string i_szIPAddr,
out string o_szMessage
)
C++
public:
void PingIP(
String i_szIPAddr,
[OutAttribute] String% o_szMessage
) sealed
J#
public void PingIP(
string i_szIPAddr,
/** @attribute OutAttribute() */ /** @ref */ string o_szMessage
)
JScript
public function PingIP(
i_szIPAddr : String,
OutAttribute o_szMessage : String
)

Parameters

i_szIPAddr
o_szMessage

See Also

Ping Class
Advantech.Common Namespace


Terminate Method

Ping.Terminate Method
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub Terminate()
C#
public void Terminate()
C++
public:
void Terminate() sealed
J#
public void Terminate()
JScript
public function Terminate()

See Also

Ping Class
Advantech.Common Namespace


Purge Enumeration

Purge Enumeration
[image]

Purge settings

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum Purge
C#
public enum Purge
C++
public enum class Purge
J#
public enum Purge
JScript
public enum Purge

Members

Member Name | Description
TxAbort | Terminate all write operation
RxAbort | Terminate all read operation
TxClear | Clear output buffer
RxClear | Clear input buffer

See Also

Advantech.Common Namespace


SocketStream Class

SocketStream Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class SocketStream
C#
public class SocketStream
C++
ref class SocketStream
J#
public class SocketStream
JScript
public class SocketStream

Inheritance Hierarchy

System.Object
Advantech.Common.SocketStream

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SocketStream Members
Advantech.Common Namespace


SocketStream Members

SocketStream Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by SocketStream.

Public Constructors

 | Name | Description
Public method | SocketStream | The socket stream class.
Top

Public Methods

 | Name | Description
Public method | DataArrive |
Public method | RecvUDP | To receive UDP datagram.
Public method | SendUDP |
Top

See Also

SocketStream Class
Advantech.Common Namespace


SocketStream Constructor

SocketStream Constructor
[image]

The socket stream class.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByRef i_socket As Socket, _
ByVal i_iSendTimeout As Integer, _
ByVal i_iRecvTimeout As Integer _
)
C#
public SocketStream(
ref Socket i_socket,
int i_iSendTimeout,
int i_iRecvTimeout
)
C++
public:
SocketStream(
Socket% i_socket,
int i_iSendTimeout,
int i_iRecvTimeout
) sealed
J#
public SocketStream(
Socket i_socket,
int i_iSendTimeout,
int i_iRecvTimeout
)
JScript
public function SocketStream(
i_socket : Socket,
i_iSendTimeout : int,
i_iRecvTimeout : int
)

Parameters

i_socket
The socket object.
i_iSendTimeout
i_iRecvTimeout

See Also

SocketStream Class
Advantech.Common Namespace


Methods

SocketStream Methods
[image]

Public Methods

 | Name | Description
Public method | DataArrive |
Public method | RecvUDP | To receive UDP datagram.
Public method | SendUDP |
Top

See Also

SocketStream Class
Advantech.Common Namespace


DataArrive Method

SocketStream.DataArrive Method
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function DataArrive( _
ByVal i_iWaitMilliSecond As Integer _
) As Boolean
C#
public bool DataArrive(
int i_iWaitMilliSecond
)
C++
public:
bool DataArrive(
int i_iWaitMilliSecond
) sealed
J#
public bool DataArrive(
int i_iWaitMilliSecond
)
JScript
public function DataArrive(
i_iWaitMilliSecond : int
) : bool

Parameters

i_iWaitMilliSecond

See Also

SocketStream Class
Advantech.Common Namespace


RecvUDP Method

SocketStream.RecvUDP Method
[image]

To receive UDP datagram.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function RecvUDP( _
<OutAttribute> ByRef o_remoteEP As EndPoint, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_iLen As Integer _
) As Boolean
C#
public bool RecvUDP(
out EndPoint o_remoteEP,
byte[] i_byData,
out int o_iLen
)
C++
public:
bool RecvUDP(
[OutAttribute] EndPoint% o_remoteEP,
array<char>^ i_byData,
[OutAttribute] int% o_iLen
) sealed
J#
public bool RecvUDP(
/** @attribute OutAttribute() */ /** @ref */ EndPoint o_remoteEP,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ int o_iLen
)
JScript
public function RecvUDP(
OutAttribute o_remoteEP : EndPoint,
i_byData : Byte[],
OutAttribute o_iLen : int
) : bool

Parameters

o_remoteEP
i_byData
The data buffer for storing data.
o_iLen
The length of data received.

Return Value

Return true if data received, otherwise return false.

See Also

SocketStream Class
Advantech.Common Namespace


SendUDP Method

SocketStream.SendUDP Method
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function SendUDP( _
ByRef i_remoteEP As EndPoint, _
ByVal i_byData As Byte(), _
ByVal i_iLen As Integer _
) As Boolean
C#
public bool SendUDP(
ref EndPoint i_remoteEP,
byte[] i_byData,
int i_iLen
)
C++
public:
bool SendUDP(
EndPoint% i_remoteEP,
array<char>^ i_byData,
int i_iLen
) sealed
J#
public bool SendUDP(
EndPoint i_remoteEP,
byte[] i_byData,
int i_iLen
)
JScript
public function SendUDP(
i_remoteEP : EndPoint,
i_byData : Byte[],
i_iLen : int
) : bool

Parameters

i_remoteEP
i_byData
i_iLen

See Also

SocketStream Class
Advantech.Common Namespace


Stopbits Enumeration

Stopbits Enumeration
[image]

Stop bit settings

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Enum Stopbits As Byte
C#
public enum Stopbits : byte
C++
public enum class Stopbits : char
J#
public enum Stopbits byte
JScript
public enum Stopbits :

Members

Member Name | Description
One | Line is asserted for 1 bit duration at end of each character
OneAndHalf | Line is asserted for 1.5 bit duration at end of each character
Two | Line is asserted for 2 bit duration at end of each character

See Also

Advantech.Common Namespace


Tool Class

Tool Class
See Also Example Members
[image]

Some tool functions for translating or calculating.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class Tool
C#
public class Tool
C++
ref class Tool
J#
public class Tool
JScript
public class Tool

Inheritance Hierarchy

System.Object
Advantech.Common.Tool

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Tool Members
Advantech.Common Namespace


Tool Members

Tool Members
See Also Example Constructors Methods
[image]

Some tool functions for translating or calculating.

The following tables list the members exposed by Tool.

Public Constructors

 | Name | Description
Public method | Tool | Initializes a new instance of the Tool class.
Top

Public Methods

Name | Description
CRC16 | Calculate the CRC16
FourByteHexStringToInteger | Convert 4 bytes HEX string to integer
HexStringToRTUArray | Convert a HEX string to a RTU array
RTUArrayToHexString | Convert a RTU array to a HEX string
ValidateCRC | Validate the CRC, and remove the CRC data if CRC is valid
Top

See Also

Tool Class
Advantech.Common Namespace


Tool Constructor

Tool Constructor
[image]

Initializes a new instance of the Tool class.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Tool()
C++
public:
Tool() sealed
J#
public Tool()
JScript
public function Tool()

See Also

Tool Class
Advantech.Common Namespace


Methods

Tool Methods
[image]

Public Methods

Name | Description
CRC16 | Calculate the CRC16
FourByteHexStringToInteger | Convert 4 bytes HEX string to integer
HexStringToRTUArray | Convert a HEX string to a RTU array
RTUArrayToHexString | Convert a RTU array to a HEX string
ValidateCRC | Validate the CRC, and remove the CRC data if CRC is valid
Top

See Also

Tool Class
Advantech.Common Namespace


CRC16 Method

Tool.CRC16 Method
[image]

Calculate the CRC16

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CRC16( _
ByVal i_byData As Byte(), _
ByVal i_iLen As Integer, _
<OutAttribute> ByRef o_byCRC16 As Byte _
)
C#
public static void CRC16(
byte[] i_byData,
int i_iLen,
out byte o_byCRC16
)
C++
public:
static void CRC16(
array<char>^ i_byData,
int i_iLen,
[OutAttribute] char% o_byCRC16
)
J#
public static void CRC16(
byte[] i_byData,
int i_iLen,
/** @attribute OutAttribute() */ /** @ref */ byte o_byCRC16
)
JScript
public static function CRC16(
i_byData : Byte[],
i_iLen : int,
OutAttribute o_byCRC16 : Byte
)

Parameters

i_byData
The data for calculating CRC
i_iLen
The data length
o_byCRC16
The two bytes CRC16 data

See Also

Tool Class
Advantech.Common Namespace


FourByteHexStringToInteger Method

Tool.FourByteHexStringToInteger Method
[image]

Convert 4 bytes HEX string to integer

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FourByteHexStringToInteger( _
ByVal i_szHex As String, _
ByRef o_outputValue As Integer _
) As Boolean
C#
public static bool FourByteHexStringToInteger(
string i_szHex,
ref int o_outputValue
)
C++
public:
static bool FourByteHexStringToInteger(
String i_szHex,
int% o_outputValue
)
J#
public static bool FourByteHexStringToInteger(
string i_szHex,
int o_outputValue
)
JScript
public static function FourByteHexStringToInteger(
i_szHex : String,
o_outputValue : int
) : bool

Parameters

i_szHex
The HEX string, length MUST equal 4 bytes.
o_outputValue
Output integer.

Return Value

true if success, otherwise false

See Also

Tool Class
Advantech.Common Namespace


HexStringToRTUArray Method

Tool.HexStringToRTUArray Method
[image]

Convert a HEX string to a RTU array

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HexStringToRTUArray( _
ByVal i_szHex As String, _
<OutAttribute> ByRef o_byRTU As Byte _
)
C#
public static void HexStringToRTUArray(
string i_szHex,
out byte o_byRTU
)
C++
public:
static void HexStringToRTUArray(
String i_szHex,
[OutAttribute] char% o_byRTU
)
J#
public static void HexStringToRTUArray(
string i_szHex,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRTU
)
JScript
public static function HexStringToRTUArray(
i_szHex : String,
OutAttribute o_byRTU : Byte
)

Parameters

i_szHex
The HEX string.
o_byRTU
The RTU array.

See Also

Tool Class
Advantech.Common Namespace


RTUArrayToHexString Method

Tool.RTUArrayToHexString Method
[image]

Convert a RTU array to a HEX string

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub RTUArrayToHexString( _
ByVal i_byRTU As Byte(), _
<OutAttribute> ByRef o_szHex As String _
)
C#
public static void RTUArrayToHexString(
byte[] i_byRTU,
out string o_szHex
)
C++
public:
static void RTUArrayToHexString(
array<char>^ i_byRTU,
[OutAttribute] String% o_szHex
)
J#
public static void RTUArrayToHexString(
byte[] i_byRTU,
/** @attribute OutAttribute() */ /** @ref */ string o_szHex
)
JScript
public static function RTUArrayToHexString(
i_byRTU : Byte[],
OutAttribute o_szHex : String
)

Parameters

i_byRTU
The RTU array.
o_szHex
The HEX string.

See Also

Tool Class
Advantech.Common Namespace


ValidateCRC Method

Tool.ValidateCRC Method
[image]

Validate the CRC, and remove the CRC data if CRC is valid

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateCRC( _
ByRef i_byData As Byte, _
ByRef i_iLen As Integer _
) As Boolean
C#
public static bool ValidateCRC(
ref byte i_byData,
ref int i_iLen
)
C++
public:
static bool ValidateCRC(
char% i_byData,
int% i_iLen
)
J#
public static bool ValidateCRC(
byte i_byData,
int i_iLen
)
JScript
public static function ValidateCRC(
i_byData : Byte,
i_iLen : int
) : bool

Parameters

i_byData
The data for validating CRC
i_iLen
The data length

Return Value

true if CRC is valid, otherwise false

See Also

Tool Class
Advantech.Common Namespace


UDPSocketClient Class

UDPSocketClient Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class UDPSocketClient
C#
public class UDPSocketClient
C++
ref class UDPSocketClient
J#
public class UDPSocketClient
JScript
public class UDPSocketClient

Inheritance Hierarchy

System.Object
Advantech.Common.UDPSocketClient

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UDPSocketClient Members
Advantech.Common Namespace


UDPSocketClient Members

UDPSocketClient Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UDPSocketClient.

Public Constructors

 | Name | Description
Public method | UDPSocketClient | The UDP client class.
Top

Public Properties

 | Name | Description
Public property | ReceiveTimeout | Receive timeout.
Public property | SendTimeout | Send timeout.
Top

Public Methods

 | Name | Description
Public method | ClientSocket | The UDP client socket.
Public method | Create | Create the UDP client.
Public method | Terminate | Terminate the UDP client.
Top

See Also

UDPSocketClient Class
Advantech.Common Namespace


UDPSocketClient Constructor

UDPSocketClient Constructor
[image]

The UDP client class.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UDPSocketClient()
C++
public:
UDPSocketClient() sealed
J#
public UDPSocketClient()
JScript
public function UDPSocketClient()

See Also

UDPSocketClient Class
Advantech.Common Namespace


Properties

UDPSocketClient Properties
[image]

Public Properties

 | Name | Description
Public property | ReceiveTimeout | Receive timeout.
Public property | SendTimeout | Send timeout.
Top

See Also

UDPSocketClient Class
Advantech.Common Namespace


ReceiveTimeout Property

UDPSocketClient.ReceiveTimeout Property
[image]

Receive timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Property ReceiveTimeout As Integer
C#
public int ReceiveTimeout { get; set; }
C++
public property int ReceiveTimeout sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ReceiveTimeout();

/** property */
public void set_ReceiveTimeout(int value);
JScript
public function get ReceiveTimeout() : int

public function set ReceiveTimeout(value : int);

See Also

UDPSocketClient Class
Advantech.Common Namespace


SendTimeout Property

UDPSocketClient.SendTimeout Property
[image]

Send timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Property SendTimeout As Integer
C#
public int SendTimeout { get; set; }
C++
public property int SendTimeout sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_SendTimeout();

/** property */
public void set_SendTimeout(int value);
JScript
public function get SendTimeout() : int

public function set SendTimeout(value : int);

See Also

UDPSocketClient Class
Advantech.Common Namespace


Methods

UDPSocketClient Methods
[image]

Public Methods

 | Name | Description
Public method | ClientSocket | The UDP client socket.
Public method | Create | Create the UDP client.
Public method | Terminate | Terminate the UDP client.
Top

See Also

UDPSocketClient Class
Advantech.Common Namespace


ClientSocket Method

UDPSocketClient.ClientSocket Method
[image]

The UDP client socket.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function ClientSocket() As Socket
C#
public Socket ClientSocket()
C++
public:
Socket ClientSocket() sealed
J#
public Socket ClientSocket()
JScript
public function ClientSocket() : Socket

Return Value

The socket object.

See Also

UDPSocketClient Class
Advantech.Common Namespace


Create Method

UDPSocketClient.Create Method
[image]

Create the UDP client.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub Create()
C#
public void Create()
C++
public:
void Create() sealed
J#
public void Create()
JScript
public function Create()

See Also

UDPSocketClient Class
Advantech.Common Namespace


Terminate Method

UDPSocketClient.Terminate Method
[image]

Terminate the UDP client.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub Terminate()
C#
public void Terminate()
C++
public:
void Terminate() sealed
J#
public void Terminate()
JScript
public function Terminate()

See Also

UDPSocketClient Class
Advantech.Common Namespace


UDPSocketServer Class

UDPSocketServer Class
See Also Example Members
[image]

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Class UDPSocketServer
C#
public class UDPSocketServer
C++
ref class UDPSocketServer
J#
public class UDPSocketServer
JScript
public class UDPSocketServer

Inheritance Hierarchy

System.Object
Advantech.Common.UDPSocketServer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UDPSocketServer Members
Advantech.Common Namespace


UDPSocketServer Members

UDPSocketServer Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UDPSocketServer.

Public Constructors

 | Name | Description
Public method | UDPSocketServer | The UDP server class.
Top

Public Properties

 | Name | Description
Public property | ReceiveTimeout | Receive timeout.
Public property | SendTimeout | Send timeout.
Top

Public Methods

 | Name | Description
Public method | Create | Create the UDP server.
Public method | ServerSocket | The UDP server socket.
Public method | Terminate | Terminate the UDP server.
Top

See Also

UDPSocketServer Class
Advantech.Common Namespace


UDPSocketServer Constructor

UDPSocketServer Constructor
[image]

The UDP server class.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UDPSocketServer()
C++
public:
UDPSocketServer() sealed
J#
public UDPSocketServer()
JScript
public function UDPSocketServer()

See Also

UDPSocketServer Class
Advantech.Common Namespace


Properties

UDPSocketServer Properties
[image]

Public Properties

 | Name | Description
Public property | ReceiveTimeout | Receive timeout.
Public property | SendTimeout | Send timeout.
Top

See Also

UDPSocketServer Class
Advantech.Common Namespace


ReceiveTimeout Property

UDPSocketServer.ReceiveTimeout Property
[image]

Receive timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Property ReceiveTimeout As Integer
C#
public int ReceiveTimeout { get; set; }
C++
public property int ReceiveTimeout sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ReceiveTimeout();

/** property */
public void set_ReceiveTimeout(int value);
JScript
public function get ReceiveTimeout() : int

public function set ReceiveTimeout(value : int);

See Also

UDPSocketServer Class
Advantech.Common Namespace


SendTimeout Property

UDPSocketServer.SendTimeout Property
[image]

Send timeout.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Property SendTimeout As Integer
C#
public int SendTimeout { get; set; }
C++
public property int SendTimeout sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_SendTimeout();

/** property */
public void set_SendTimeout(int value);
JScript
public function get SendTimeout() : int

public function set SendTimeout(value : int);

See Also

UDPSocketServer Class
Advantech.Common Namespace


Methods

UDPSocketServer Methods
[image]

Public Methods

 | Name | Description
Public method | Create | Create the UDP server.
Public method | ServerSocket | The UDP server socket.
Public method | Terminate | Terminate the UDP server.
Top

See Also

UDPSocketServer Class
Advantech.Common Namespace


Create Method

UDPSocketServer.Create Method
[image]

Create the UDP server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub Create( _
ByVal i_iPort As Integer _
)
C#
public void Create(
int i_iPort
)
C++
public:
void Create(
int i_iPort
) sealed
J#
public void Create(
int i_iPort
)
JScript
public function Create(
i_iPort : int
)

Parameters

i_iPort
The port to listen.

See Also

UDPSocketServer Class
Advantech.Common Namespace


ServerSocket Method

UDPSocketServer.ServerSocket Method
[image]

The UDP server socket.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Function ServerSocket() As Socket
C#
public Socket ServerSocket()
C++
public:
Socket ServerSocket() sealed
J#
public Socket ServerSocket()
JScript
public function ServerSocket() : Socket

Return Value

The socket object.

See Also

UDPSocketServer Class
Advantech.Common Namespace


Terminate Method

UDPSocketServer.Terminate Method
[image]

Terminate the UDP server.

Namespace: Advantech.Common
Assembly: Advantech.Common (in Advantech.Common.dll)

Syntax

Visual Basic (Declaration)
Public Sub Terminate()
C#
public void Terminate()
C++
public:
void Terminate() sealed
J#
public void Terminate()
JScript
public function Terminate()

See Also

UDPSocketServer Class
Advantech.Common Namespace


Advantech.Graph

Advantech.Graph Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | AdamBatteryIndicator
Public class | AdamComComponent | AdamComComponent class. The class is based on AdamCom class. The class is very useful for using with Advantech Adam serial devices.
Public class | AdamExternalPower
Public class | AdamIndicator | The AdamIndicator class.
Public class | AdamKnob | The AdamKnob Class.
Public class | AdamLight | AdamLight class is the light control with different shape.
Public class | AdamMeter | The AdamMeter class.
Public class | AdamNumLed | The AdamNumLed class.
Public class | AdamRemote
Public class | AdamRuler | The AdamRuler class.
Public class | AdamSignalIndicator
Public class | AdamSocketComponent
Public class | AdamSwitch | The AdamSwitch class.
Public class | AdamTrend | The AdamTrend class
Public class | AdamWSNNode
Public class | AdvantechLine
Public class | HorLabTag | The horizontal label tag
Public class | LineSegment | The collection of AdvantechLine.
Public class | MiniLZO | MiniLZO native code * ManagedLZO.MiniLZO * * Minimalistic reimplementation of minilzo in C# * * @author Shane Eric Bryldt, Copyright (C) 2006, All Rights Reserved * @note Uses unsafe/fixed pointer contexts internally * @liscence Bound by same liscence as minilzo as below, see file COPYING Based on minilzo.c -- mini subset of the LZO real-time data compression library This file is part of the LZO real-time data compression library. Copyright (C) 2005 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2004 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2003 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2002 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2001 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2000 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1999 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1998 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1997 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1996 Markus Franz Xaver Johannes Oberhumer All Rights Reserved. The LZO library is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License, version 2, as published by the Free Software Foundation. The LZO library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with the LZO library; see the file COPYING. If not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. Markus F.X.J. Oberhumer markus@oberhumer.com http://www.oberhumer.com/opensource/lzo/ * NOTE: * the full LZO package can be found at * http://www.oberhumer.com/opensource/lzo/ This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Delegates

 | Delegate | Description
NestedPublic delegate | AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick | DoubleClick delegate
Public delegate | DelegateDisableButtons | A delegate type for hooking up DisableButtons notifications.
Public delegate | DelegateEnableButtons | A delegate type for hooking up EnableButtons notifications.
Public delegate | DelegateReConnectRemote | A delegate type for hooking up ReConnectRemote notifications.
Public delegate | DelegateUpdateBitmap | A delegate type for hooking up UpdateBitmap notifications.
Public delegate | ValueChangedEventHandler | A delegate type for hooking up ValueChanged notifications.

Enumerations

 | Enumeration | Description
Public enumeration | DrawType | The shape of the control.
Public enumeration | enumHorLabOrientation | Horizontal label orientation enumeration
Public enumeration | enumHorLabType | Horizontal label type enumeration
Public enumeration | enumOrientation | Orientation enumeration
Public enumeration | enumVerLabOrientation | Vertical label orientation enumeration
Public enumeration | LightStyle | The style of the control.
Public enumeration | Shape | The shape of the control.


AdamBatteryIndicator Class

AdamBatteryIndicator Class
See Also Example Members
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamBatteryIndicator), "AdamBatteryIndicator.bmp")>
Public Class AdamBatteryIndicator
Inherits UserControl
C#
[ToolboxBitmapAttribute(typeof(AdamBatteryIndicator), "AdamBatteryIndicator.bmp")]
public class AdamBatteryIndicator : UserControl
C++
[ToolboxBitmapAttribute(typeof(AdamBatteryIndicator), L"AdamBatteryIndicator.bmp")]
ref class AdamBatteryIndicator : UserControl
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamBatteryIndicator), "AdamBatteryIndicator.bmp") */
public class AdamBatteryIndicator extends UserControl
JScript
public
ToolboxBitmapAttribute(typeof(AdamBatteryIndicator), "AdamBatteryIndicator.bmp")
class AdamBatteryIndicator extends UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Advantech.Graph.AdamBatteryIndicator

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamBatteryIndicator Members
Advantech.Graph Namespace


AdamBatteryIndicator Members

AdamBatteryIndicator Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AdamBatteryIndicator.

Public Constructors

 | Name | Description
Public method | AdamBatteryIndicator | The AdamBatteryIndicator constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | IndicatorOffColor | Get/set the color of the indicator when it is Off.
Public property | IndicatorOnColor | Get/set the color of the indicator bar when it is On.
Public property | Maximum | Get/set the maximum value of the indicator.
Public property | Minimum | Get/set the minimum value of the indicator.
Public property | Value | Get/set the value of the indicator.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


AdamBatteryIndicator Constructor

AdamBatteryIndicator Constructor
[image]

The AdamBatteryIndicator constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamBatteryIndicator()
C++
public:
AdamBatteryIndicator() sealed
J#
public AdamBatteryIndicator()
JScript
public function AdamBatteryIndicator()

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


Properties

AdamBatteryIndicator Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | IndicatorOffColor | Get/set the color of the indicator when it is Off.
Public property | IndicatorOnColor | Get/set the color of the indicator bar when it is On.
Public property | Maximum | Get/set the maximum value of the indicator.
Public property | Minimum | Get/set the minimum value of the indicator.
Public property | Value | Get/set the value of the indicator.
Top

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


BackColor Property

AdamBatteryIndicator.BackColor Property
[image]

Get/set the BackColor of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


IndicatorOffColor Property

AdamBatteryIndicator.IndicatorOffColor Property
[image]

Get/set the color of the indicator when it is Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The color of the indicator when it is Off.")>
Public Property IndicatorOffColor As Color
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The color of the indicator when it is Off.")]
public Color IndicatorOffColor { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The color of the indicator when it is Off.")]
public property Color IndicatorOffColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The color of the indicator when it is Off.") */
/** property */
public Color get_IndicatorOffColor();

/** property */
public void set_IndicatorOffColor(Color value);
JScript
public function get IndicatorOffColor() : Color

public function set IndicatorOffColor(value : Color);

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


IndicatorOnColor Property

AdamBatteryIndicator.IndicatorOnColor Property
[image]

Get/set the color of the indicator bar when it is On.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the indicator when it is On."), _
CategoryAttribute("AdamIndicator")>
Public Property IndicatorOnColor As Color
C#
[DescriptionAttribute("The color of the indicator when it is On.")]
[CategoryAttribute("AdamIndicator")]
public Color IndicatorOnColor { get; set; }
C++
[DescriptionAttribute(L"The color of the indicator when it is On.")]
[CategoryAttribute(L"AdamIndicator")]
public property Color IndicatorOnColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the indicator when it is On.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public Color get_IndicatorOnColor();

/** property */
public void set_IndicatorOnColor(Color value);
JScript
public function get IndicatorOnColor() : Color

public function set IndicatorOnColor(value : Color);

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


Maximum Property

AdamBatteryIndicator.Maximum Property
[image]

Get/set the maximum value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The maximum value of the indicator."), _
CategoryAttribute("AdamIndicator")>
Public Property Maximum As Single
C#
[DescriptionAttribute("The maximum value of the indicator.")]
[CategoryAttribute("AdamIndicator")]
public float Maximum { get; set; }
C++
[DescriptionAttribute(L"The maximum value of the indicator.")]
[CategoryAttribute(L"AdamIndicator")]
public property float Maximum sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The maximum value of the indicator.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public float get_Maximum();

/** property */
public void set_Maximum(float value);
JScript
public function get Maximum() : float

public function set Maximum(value : float);

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


Minimum Property

AdamBatteryIndicator.Minimum Property
[image]

Get/set the minimum value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The minimum value of the indicator."), _
CategoryAttribute("AdamIndicator")>
Public Property Minimum As Single
C#
[DescriptionAttribute("The minimum value of the indicator.")]
[CategoryAttribute("AdamIndicator")]
public float Minimum { get; set; }
C++
[DescriptionAttribute(L"The minimum value of the indicator.")]
[CategoryAttribute(L"AdamIndicator")]
public property float Minimum sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The minimum value of the indicator.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public float get_Minimum();

/** property */
public void set_Minimum(float value);
JScript
public function get Minimum() : float

public function set Minimum(value : float);

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


Value Property

AdamBatteryIndicator.Value Property
[image]

Get/set the value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The value of the indicator.")>
Public Property Value As Single
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The value of the indicator.")]
public float Value { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The value of the indicator.")]
public property float Value sealed {
float get();
void set(float value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The value of the indicator.") */
/** property */
public float get_Value();

/** property */
public void set_Value(float value);
JScript
public function get Value() : float

public function set Value(value : float);

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


Methods

AdamBatteryIndicator Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


Dispose Method

AdamBatteryIndicator.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


OnPaint Method

AdamBatteryIndicator.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamBatteryIndicator Class
Advantech.Graph Namespace


AdamComComponent Class

AdamComComponent Class
See Also Example Members
[image]

AdamComComponent class. The class is based on AdamCom class. The class is very useful for using with Advantech Adam serial devices.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamComComponent), "Pictures.AdamComComponent.bmp")>
Public Class AdamComComponent
Inherits Component
C#
[ToolboxBitmapAttribute(typeof(AdamComComponent), "Pictures.AdamComComponent.bmp")]
public class AdamComComponent : Component
C++
[ToolboxBitmapAttribute(typeof(AdamComComponent), L"Pictures.AdamComComponent.bmp")]
ref class AdamComComponent : Component
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamComComponent), "Pictures.AdamComComponent.bmp") */
public class AdamComComponent extends Component
JScript
public
ToolboxBitmapAttribute(typeof(AdamComComponent), "Pictures.AdamComComponent.bmp")
class AdamComComponent extends Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Advantech.Graph.AdamComComponent

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamComComponent Members
Advantech.Graph Namespace


AdamComComponent Members

AdamComComponent Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

AdamComComponent class. The class is based on AdamCom class. The class is very useful for using with Advantech Adam serial devices.

The following tables list the members exposed by AdamComComponent.

Public Constructors

Name | Description
AdamComComponent | Overloaded.
Top

Public Properties

 | Name | Description
Public property | AdamComObject | The AdamCom object. User must check this value is not null before using it.
Public property | Baudrate | Get/set the baudrate of the COM port.
Public property | Checksum | Get/set the checksum enabled status for Advantech ASCII protocol.
Public property | Databits | Get/set the data bits of the COM port.
Public property | IsOpen | The COM port open status.
Public property | LastError | The last error code when function return false.
Public property | Parity | Get/set the parity of the COM port.
Public property | Port | Get/set the COM port number of the component.
Public property | Stopbits | Get/set the stop bits of the COM port.
Public property | Timeout | Get/set the timeout value of the COM port.
Top

Public Methods

 | Name | Description
Public method | AdamTransaction | Send and receive ASCII command for ADAM modules
Public method | Alarm | ADAM-4000 ADAM-5000 Alarm object
Public method | AnalogInput | ADAM-4000 ADAM-5000 AnalogInput object
Public method | AnalogOutput | ADAM-4000 ADAM-5000 AnalogOutput object
Public method | CloseComPort | Close the COM port.
Public method | Configuration | ADAM-4000 ADAM-5000 Configuration object
Public method | Counter | ADAM-4000 ADAM-5000 Counter object
Public method | DigitalInput | ADAM-4000 ADAM-5000 DigitalInput object
Public method | DigitalOutput | ADAM-4000 ADAM-5000 DigitalOutput object
Public method | Modbus | ADAM-4000 Modbus object
Public method | OpenComPort | Open the COM port and get the COM port setting from system
Public method | Pid | ADAM-4000 PID object
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Top

Explicit Interface Implementations

Name | Description
AdamComComponent | Overloaded.
Top

See Also

AdamComComponent Class
Advantech.Graph Namespace


AdamComComponent Constructor

AdamComComponent Constructor

Overload List

 | Name | Description
Public method | AdamComComponent | AdamComComponent class. The class is based on AdamCom class. The class is very useful for using with Advantech Adam serial devices.
Public method | AdamComComponent (IContainer) | AdamComComponent class. The class is based on AdamCom class. The class is very useful for using with Advantech Adam serial devices.

See Also

AdamComComponent Class
Advantech.Graph Namespace


AdamComComponent Constructor ()

AdamComComponent Constructor ()
See Also Example
[image]

AdamComComponent class. The class is based on AdamCom class. The class is very useful for using with Advantech Adam serial devices.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamComComponent()
C++
public:
AdamComComponent() sealed
J#
public AdamComComponent()
JScript
public function AdamComComponent()

See Also

AdamComComponent Class
Advantech.Graph Namespace
AdamComComponent Constructor Overload List


AdamComComponent Constructor (IContainer)

AdamComComponent Constructor (IContainer)
See Also Example
[image]

AdamComComponent class. The class is based on AdamCom class. The class is very useful for using with Advantech Adam serial devices.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal container As IContainer _
)
C#
public AdamComComponent(
IContainer container
)
C++
public:
AdamComComponent(
IContainer container
) sealed
J#
public AdamComComponent(
IContainer container
)
JScript
public function AdamComComponent(
container : IContainer
)

Parameters

container
Container

See Also

AdamComComponent Class
Advantech.Graph Namespace
AdamComComponent Constructor Overload List


Properties

AdamComComponent Properties
[image]

Public Properties

 | Name | Description
Public property | AdamComObject | The AdamCom object. User must check this value is not null before using it.
Public property | Baudrate | Get/set the baudrate of the COM port.
Public property | Checksum | Get/set the checksum enabled status for Advantech ASCII protocol.
Public property | Databits | Get/set the data bits of the COM port.
Public property | IsOpen | The COM port open status.
Public property | LastError | The last error code when function return false.
Public property | Parity | Get/set the parity of the COM port.
Public property | Port | Get/set the COM port number of the component.
Public property | Stopbits | Get/set the stop bits of the COM port.
Public property | Timeout | Get/set the timeout value of the COM port.
Top

See Also

AdamComComponent Class
Advantech.Graph Namespace


AdamComObject Property

AdamComComponent.AdamComObject Property
[image]

The AdamCom object. User must check this value is not null before using it.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdamComObject As AdamCom
C#
public AdamCom AdamComObject { get; }
C++
public property AdamCom AdamComObject sealed {
AdamCom get();
}
J#
/** property */
public AdamCom get_AdamComObject();
JScript
public function get AdamComObject() : AdamCom

See Also

AdamComComponent Class
Advantech.Graph Namespace


Baudrate Property

AdamComComponent.Baudrate Property
[image]

Get/set the baudrate of the COM port.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The baudrate of the COM port."), _
CategoryAttribute("AdamComComponent")>
Public Property Baudrate As Baudrate
C#
[DescriptionAttribute("The baudrate of the COM port.")]
[CategoryAttribute("AdamComComponent")]
public Baudrate Baudrate { get; set; }
C++
[DescriptionAttribute(L"The baudrate of the COM port.")]
[CategoryAttribute(L"AdamComComponent")]
public property Baudrate Baudrate sealed {
Baudrate get();
void set(Baudrate value);
}
J#
/** @attribute DescriptionAttribute("The baudrate of the COM port.") */
/** @attribute CategoryAttribute("AdamComComponent") */
/** property */
public Baudrate get_Baudrate();

/** property */
public void set_Baudrate(Baudrate value);
JScript
public function get Baudrate() : Baudrate

public function set Baudrate(value : Baudrate);

See Also

AdamComComponent Class
Advantech.Graph Namespace


Checksum Property

AdamComComponent.Checksum Property
[image]

Get/set the checksum enabled status for Advantech ASCII protocol.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamComComponent"), _
DescriptionAttribute("The checksum enabled status for Advantech ASCII protocol.")>
Public Property Checksum As Boolean
C#
[CategoryAttribute("AdamComComponent")]
[DescriptionAttribute("The checksum enabled status for Advantech ASCII protocol.")]
public bool Checksum { get; set; }
C++
[CategoryAttribute(L"AdamComComponent")]
[DescriptionAttribute(L"The checksum enabled status for Advantech ASCII protocol.")]
public property bool Checksum sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("AdamComComponent") */
/** @attribute DescriptionAttribute("The checksum enabled status for Advantech ASCII protocol.") */
/** property */
public bool get_Checksum();

/** property */
public void set_Checksum(bool value);
JScript
public function get Checksum() : bool

public function set Checksum(value : bool);

See Also

AdamComComponent Class
Advantech.Graph Namespace


Databits Property

AdamComComponent.Databits Property
[image]

Get/set the data bits of the COM port.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The data bits of the COM port."), _
CategoryAttribute("AdamComComponent")>
Public Property Databits As Databits
C#
[DescriptionAttribute("The data bits of the COM port.")]
[CategoryAttribute("AdamComComponent")]
public Databits Databits { get; set; }
C++
[DescriptionAttribute(L"The data bits of the COM port.")]
[CategoryAttribute(L"AdamComComponent")]
public property Databits Databits sealed {
Databits get();
void set(Databits value);
}
J#
/** @attribute DescriptionAttribute("The data bits of the COM port.") */
/** @attribute CategoryAttribute("AdamComComponent") */
/** property */
public Databits get_Databits();

/** property */
public void set_Databits(Databits value);
JScript
public function get Databits() : Databits

public function set Databits(value : Databits);

See Also

AdamComComponent Class
Advantech.Graph Namespace


IsOpen Property

AdamComComponent.IsOpen Property
[image]

The COM port open status.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsOpen As Boolean
C#
public bool IsOpen { get; }
C++
public property bool IsOpen sealed {
bool get();
}
J#
/** property */
public bool get_IsOpen();
JScript
public function get IsOpen() : bool

See Also

AdamComComponent Class
Advantech.Graph Namespace


LastError Property

AdamComComponent.LastError Property
[image]

The last error code when function return false.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastError As ErrorCode
C#
public ErrorCode LastError { get; }
C++
public property ErrorCode LastError sealed {
ErrorCode get();
}
J#
/** property */
public ErrorCode get_LastError();
JScript
public function get LastError() : ErrorCode

See Also

AdamComComponent Class
Advantech.Graph Namespace


Parity Property

AdamComComponent.Parity Property
[image]

Get/set the parity of the COM port.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamComComponent"), _
DescriptionAttribute("The parity of the COM port.")>
Public Property Parity As Parity
C#
[CategoryAttribute("AdamComComponent")]
[DescriptionAttribute("The parity of the COM port.")]
public Parity Parity { get; set; }
C++
[CategoryAttribute(L"AdamComComponent")]
[DescriptionAttribute(L"The parity of the COM port.")]
public property Parity Parity sealed {
Parity get();
void set(Parity value);
}
J#
/** @attribute CategoryAttribute("AdamComComponent") */
/** @attribute DescriptionAttribute("The parity of the COM port.") */
/** property */
public Parity get_Parity();

/** property */
public void set_Parity(Parity value);
JScript
public function get Parity() : Parity

public function set Parity(value : Parity);

See Also

AdamComComponent Class
Advantech.Graph Namespace


Port Property

AdamComComponent.Port Property
[image]

Get/set the COM port number of the component.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamComComponent"), _
DescriptionAttribute("The COM port number of the component.")>
Public Property Port As Integer
C#
[CategoryAttribute("AdamComComponent")]
[DescriptionAttribute("The COM port number of the component.")]
public int Port { get; set; }
C++
[CategoryAttribute(L"AdamComComponent")]
[DescriptionAttribute(L"The COM port number of the component.")]
public property int Port sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamComComponent") */
/** @attribute DescriptionAttribute("The COM port number of the component.") */
/** property */
public int get_Port();

/** property */
public void set_Port(int value);
JScript
public function get Port() : int

public function set Port(value : int);

See Also

AdamComComponent Class
Advantech.Graph Namespace


Stopbits Property

AdamComComponent.Stopbits Property
[image]

Get/set the stop bits of the COM port.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The stop bits of the COM port."), _
CategoryAttribute("AdamComComponent")>
Public Property Stopbits As Stopbits
C#
[DescriptionAttribute("The stop bits of the COM port.")]
[CategoryAttribute("AdamComComponent")]
public Stopbits Stopbits { get; set; }
C++
[DescriptionAttribute(L"The stop bits of the COM port.")]
[CategoryAttribute(L"AdamComComponent")]
public property Stopbits Stopbits sealed {
Stopbits get();
void set(Stopbits value);
}
J#
/** @attribute DescriptionAttribute("The stop bits of the COM port.") */
/** @attribute CategoryAttribute("AdamComComponent") */
/** property */
public Stopbits get_Stopbits();

/** property */
public void set_Stopbits(Stopbits value);
JScript
public function get Stopbits() : Stopbits

public function set Stopbits(value : Stopbits);

See Also

AdamComComponent Class
Advantech.Graph Namespace


Timeout Property

AdamComComponent.Timeout Property
[image]

Get/set the timeout value of the COM port.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamComComponent"), _
DescriptionAttribute("The timeout value of the COM port.")>
Public Property Timeout As Integer
C#
[CategoryAttribute("AdamComComponent")]
[DescriptionAttribute("The timeout value of the COM port.")]
public int Timeout { get; set; }
C++
[CategoryAttribute(L"AdamComComponent")]
[DescriptionAttribute(L"The timeout value of the COM port.")]
public property int Timeout sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamComComponent") */
/** @attribute DescriptionAttribute("The timeout value of the COM port.") */
/** property */
public int get_Timeout();

/** property */
public void set_Timeout(int value);
JScript
public function get Timeout() : int

public function set Timeout(value : int);

See Also

AdamComComponent Class
Advantech.Graph Namespace


Methods

AdamComComponent Methods
[image]

Public Methods

 | Name | Description
Public method | AdamTransaction | Send and receive ASCII command for ADAM modules
Public method | Alarm | ADAM-4000 ADAM-5000 Alarm object
Public method | AnalogInput | ADAM-4000 ADAM-5000 AnalogInput object
Public method | AnalogOutput | ADAM-4000 ADAM-5000 AnalogOutput object
Public method | CloseComPort | Close the COM port.
Public method | Configuration | ADAM-4000 ADAM-5000 Configuration object
Public method | Counter | ADAM-4000 ADAM-5000 Counter object
Public method | DigitalInput | ADAM-4000 ADAM-5000 DigitalInput object
Public method | DigitalOutput | ADAM-4000 ADAM-5000 DigitalOutput object
Public method | Modbus | ADAM-4000 Modbus object
Public method | OpenComPort | Open the COM port and get the COM port setting from system
Public method | Pid | ADAM-4000 PID object
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Top

See Also

AdamComComponent Class
Advantech.Graph Namespace


AdamTransaction Method

AdamComComponent.AdamTransaction Method
[image]

Send and receive ASCII command for ADAM modules

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function AdamTransaction( _
ByVal i_szSend As String, _
<OutAttribute> ByRef o_szRecv As String _
) As Boolean
C#
public bool AdamTransaction(
string i_szSend,
out string o_szRecv
)
C++
public:
bool AdamTransaction(
String i_szSend,
[OutAttribute] String% o_szRecv
) sealed
J#
public bool AdamTransaction(
string i_szSend,
/** @attribute OutAttribute() */ /** @ref */ string o_szRecv
)
JScript
public function AdamTransaction(
i_szSend : String,
OutAttribute o_szRecv : String
) : bool

Parameters

i_szSend
The command string to send
o_szRecv
The responsed string received

Return Value

True if the transaction success.

See Also

AdamComComponent Class
Advantech.Graph Namespace


Alarm Method

AdamComComponent.Alarm Method
[image]

ADAM-4000 ADAM-5000 Alarm object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Alarm( _
ByVal i_iAddr As Integer _
) As Alarm
C#
public Alarm Alarm(
int i_iAddr
)
C++
public:
Alarm Alarm(
int i_iAddr
) sealed
J#
public Alarm Alarm(
int i_iAddr
)
JScript
public function Alarm(
i_iAddr : int
) : Alarm

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then Alarm object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


AnalogInput Method

AdamComComponent.AnalogInput Method
[image]

ADAM-4000 ADAM-5000 AnalogInput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogInput( _
ByVal i_iAddr As Integer _
) As AnalogInput
C#
public AnalogInput AnalogInput(
int i_iAddr
)
C++
public:
AnalogInput AnalogInput(
int i_iAddr
) sealed
J#
public AnalogInput AnalogInput(
int i_iAddr
)
JScript
public function AnalogInput(
i_iAddr : int
) : AnalogInput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then AnalogInput object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


AnalogOutput Method

AdamComComponent.AnalogOutput Method
[image]

ADAM-4000 ADAM-5000 AnalogOutput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogOutput( _
ByVal i_iAddr As Integer _
) As AnalogOutput
C#
public AnalogOutput AnalogOutput(
int i_iAddr
)
C++
public:
AnalogOutput AnalogOutput(
int i_iAddr
) sealed
J#
public AnalogOutput AnalogOutput(
int i_iAddr
)
JScript
public function AnalogOutput(
i_iAddr : int
) : AnalogOutput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then AnalogOutput object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


CloseComPort Method

AdamComComponent.CloseComPort Method
[image]

Close the COM port.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function CloseComPort() As Boolean
C#
public bool CloseComPort()
C++
public:
bool CloseComPort() sealed
J#
public bool CloseComPort()
JScript
public function CloseComPort() : bool

Return Value

True if executed successfully.

See Also

AdamComComponent Class
Advantech.Graph Namespace


Configuration Method

AdamComComponent.Configuration Method
[image]

ADAM-4000 ADAM-5000 Configuration object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Configuration( _
ByVal i_iAddr As Integer _
) As Configuration
C#
public Configuration Configuration(
int i_iAddr
)
C++
public:
Configuration Configuration(
int i_iAddr
) sealed
J#
public Configuration Configuration(
int i_iAddr
)
JScript
public function Configuration(
i_iAddr : int
) : Configuration

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then AdamConfig object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


Counter Method

AdamComComponent.Counter Method
[image]

ADAM-4000 ADAM-5000 Counter object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Counter( _
ByVal i_iAddr As Integer _
) As Counter
C#
public Counter Counter(
int i_iAddr
)
C++
public:
Counter Counter(
int i_iAddr
) sealed
J#
public Counter Counter(
int i_iAddr
)
JScript
public function Counter(
i_iAddr : int
) : Counter

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then Counter object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


DigitalInput Method

AdamComComponent.DigitalInput Method
[image]

ADAM-4000 ADAM-5000 DigitalInput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalInput( _
ByVal i_iAddr As Integer _
) As DigitalInput
C#
public DigitalInput DigitalInput(
int i_iAddr
)
C++
public:
DigitalInput DigitalInput(
int i_iAddr
) sealed
J#
public DigitalInput DigitalInput(
int i_iAddr
)
JScript
public function DigitalInput(
i_iAddr : int
) : DigitalInput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then DigitalInput object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


DigitalOutput Method

AdamComComponent.DigitalOutput Method
[image]

ADAM-4000 ADAM-5000 DigitalOutput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalOutput( _
ByVal i_iAddr As Integer _
) As DigitalOutput
C#
public DigitalOutput DigitalOutput(
int i_iAddr
)
C++
public:
DigitalOutput DigitalOutput(
int i_iAddr
) sealed
J#
public DigitalOutput DigitalOutput(
int i_iAddr
)
JScript
public function DigitalOutput(
i_iAddr : int
) : DigitalOutput

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then DigitalOutput object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


Dispose Method

AdamComComponent.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamComComponent Class
Advantech.Graph Namespace


Modbus Method

AdamComComponent.Modbus Method
[image]

ADAM-4000 Modbus object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Modbus( _
ByVal i_iAddr As Integer _
) As Modbus
C#
public Modbus Modbus(
int i_iAddr
)
C++
public:
Modbus Modbus(
int i_iAddr
) sealed
J#
public Modbus Modbus(
int i_iAddr
)
JScript
public function Modbus(
i_iAddr : int
) : Modbus

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then Modbus object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


OpenComPort Method

AdamComComponent.OpenComPort Method
[image]

Open the COM port and get the COM port setting from system

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenComPort() As Boolean
C#
public bool OpenComPort()
C++
public:
bool OpenComPort() sealed
J#
public bool OpenComPort()
JScript
public function OpenComPort() : bool

Return Value

True if port opened successfully.

See Also

AdamComComponent Class
Advantech.Graph Namespace


Pid Method

AdamComComponent.Pid Method
[image]

ADAM-4000 PID object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Pid( _
ByVal i_iAddr As Integer _
) As PID
C#
public PID Pid(
int i_iAddr
)
C++
public:
PID Pid(
int i_iAddr
) sealed
J#
public PID Pid(
int i_iAddr
)
JScript
public function Pid(
i_iAddr : int
) : PID

Parameters

i_iAddr
The module address which is ranged from 0 to 255

Return Value

If COM port was opended, then PID object returned. Otherwise, return null.

See Also

AdamComComponent Class
Advantech.Graph Namespace


AdamExternalPower Class

AdamExternalPower Class
See Also Example Members
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Class AdamExternalPower
Inherits UserControl
C#
public class AdamExternalPower : UserControl
C++
ref class AdamExternalPower : UserControl
J#
public class AdamExternalPower extends UserControl
JScript
public class AdamExternalPower extends UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Advantech.Graph.AdamExternalPower

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamExternalPower Members
Advantech.Graph Namespace


AdamExternalPower Members

AdamExternalPower Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by AdamExternalPower.

Public Constructors

 | Name | Description
Public method | AdamExternalPower | The AdamExternalPower constructor.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

See Also

AdamExternalPower Class
Advantech.Graph Namespace


AdamExternalPower Constructor

AdamExternalPower Constructor
[image]

The AdamExternalPower constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamExternalPower()
C++
public:
AdamExternalPower() sealed
J#
public AdamExternalPower()
JScript
public function AdamExternalPower()

See Also

AdamExternalPower Class
Advantech.Graph Namespace


Methods

AdamExternalPower Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

See Also

AdamExternalPower Class
Advantech.Graph Namespace


Dispose Method

AdamExternalPower.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamExternalPower Class
Advantech.Graph Namespace


OnPaint Method

AdamExternalPower.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal e As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs e
)
C++
protected:
virtual void OnPaint(
PaintEventArgs e
) override
J#
protected override void OnPaint(
PaintEventArgs e
)
JScript
protected override function OnPaint(
e : PaintEventArgs
)

Parameters

e

See Also

AdamExternalPower Class
Advantech.Graph Namespace


AdamIndicator Class

AdamIndicator Class
See Also Example Members
[image]

The AdamIndicator class.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamIndicator), "Pictures.AdamIndicator.bmp")>
Public Class AdamIndicator
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamIndicator), "Pictures.AdamIndicator.bmp")]
public class AdamIndicator : Control
C++
[ToolboxBitmapAttribute(typeof(AdamIndicator), L"Pictures.AdamIndicator.bmp")]
ref class AdamIndicator : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamIndicator), "Pictures.AdamIndicator.bmp") */
public class AdamIndicator extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamIndicator), "Pictures.AdamIndicator.bmp")
class AdamIndicator extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamIndicator

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamIndicator Members
Advantech.Graph Namespace


AdamIndicator Members

AdamIndicator Members
See Also Example Constructors Properties Methods
[image]

The AdamIndicator class.

The following tables list the members exposed by AdamIndicator.

Public Constructors

 | Name | Description
Public method | AdamIndicator | The AdamIndicator constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | IndicatorOffColor | Get/set the color of the indicator when it is Off.
Public property | IndicatorOnColor | Get/set the color of the indicator bar when it is On.
Public property | LineWidth | Get/set the width of the indicator lines.
Public property | Maximum | Get/set the maximum value of the indicator.
Public property | Minimum | Get/set the minimum value of the indicator.
Public property | Orientation | Get/set the orientation of the control.
Public property | Registration | Get/set the registration key.
Public property | Shape | Get/set the shape of the indicator.
Public property | Value | Get/set the value of the indicator.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. OnResize event handler.
Top

See Also

AdamIndicator Class
Advantech.Graph Namespace


AdamIndicator Constructor

AdamIndicator Constructor
[image]

The AdamIndicator constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamIndicator()
C++
public:
AdamIndicator() sealed
J#
public AdamIndicator()
JScript
public function AdamIndicator()

See Also

AdamIndicator Class
Advantech.Graph Namespace


Properties

AdamIndicator Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | IndicatorOffColor | Get/set the color of the indicator when it is Off.
Public property | IndicatorOnColor | Get/set the color of the indicator bar when it is On.
Public property | LineWidth | Get/set the width of the indicator lines.
Public property | Maximum | Get/set the maximum value of the indicator.
Public property | Minimum | Get/set the minimum value of the indicator.
Public property | Orientation | Get/set the orientation of the control.
Public property | Registration | Get/set the registration key.
Public property | Shape | Get/set the shape of the indicator.
Public property | Value | Get/set the value of the indicator.
Top

See Also

AdamIndicator Class
Advantech.Graph Namespace


BackColor Property

AdamIndicator.BackColor Property
[image]

Get/set the BackColor of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamIndicator Class
Advantech.Graph Namespace


IndicatorOffColor Property

AdamIndicator.IndicatorOffColor Property
[image]

Get/set the color of the indicator when it is Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The color of the indicator when it is Off.")>
Public Property IndicatorOffColor As Color
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The color of the indicator when it is Off.")]
public Color IndicatorOffColor { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The color of the indicator when it is Off.")]
public property Color IndicatorOffColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The color of the indicator when it is Off.") */
/** property */
public Color get_IndicatorOffColor();

/** property */
public void set_IndicatorOffColor(Color value);
JScript
public function get IndicatorOffColor() : Color

public function set IndicatorOffColor(value : Color);

See Also

AdamIndicator Class
Advantech.Graph Namespace


IndicatorOnColor Property

AdamIndicator.IndicatorOnColor Property
[image]

Get/set the color of the indicator bar when it is On.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The color of the indicator when it is On.")>
Public Property IndicatorOnColor As Color
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The color of the indicator when it is On.")]
public Color IndicatorOnColor { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The color of the indicator when it is On.")]
public property Color IndicatorOnColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The color of the indicator when it is On.") */
/** property */
public Color get_IndicatorOnColor();

/** property */
public void set_IndicatorOnColor(Color value);
JScript
public function get IndicatorOnColor() : Color

public function set IndicatorOnColor(value : Color);

See Also

AdamIndicator Class
Advantech.Graph Namespace


LineWidth Property

AdamIndicator.LineWidth Property
[image]

Get/set the width of the indicator lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The width of the indicator lines."), _
CategoryAttribute("AdamIndicator")>
Public Property LineWidth As Integer
C#
[DescriptionAttribute("The width of the indicator lines.")]
[CategoryAttribute("AdamIndicator")]
public int LineWidth { get; set; }
C++
[DescriptionAttribute(L"The width of the indicator lines.")]
[CategoryAttribute(L"AdamIndicator")]
public property int LineWidth sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The width of the indicator lines.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public int get_LineWidth();

/** property */
public void set_LineWidth(int value);
JScript
public function get LineWidth() : int

public function set LineWidth(value : int);

See Also

AdamIndicator Class
Advantech.Graph Namespace


Maximum Property

AdamIndicator.Maximum Property
[image]

Get/set the maximum value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The maximum value of the indicator.")>
Public Property Maximum As Single
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The maximum value of the indicator.")]
public float Maximum { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The maximum value of the indicator.")]
public property float Maximum sealed {
float get();
void set(float value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The maximum value of the indicator.") */
/** property */
public float get_Maximum();

/** property */
public void set_Maximum(float value);
JScript
public function get Maximum() : float

public function set Maximum(value : float);

See Also

AdamIndicator Class
Advantech.Graph Namespace


Minimum Property

AdamIndicator.Minimum Property
[image]

Get/set the minimum value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The minimum value of the indicator."), _
CategoryAttribute("AdamIndicator")>
Public Property Minimum As Single
C#
[DescriptionAttribute("The minimum value of the indicator.")]
[CategoryAttribute("AdamIndicator")]
public float Minimum { get; set; }
C++
[DescriptionAttribute(L"The minimum value of the indicator.")]
[CategoryAttribute(L"AdamIndicator")]
public property float Minimum sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The minimum value of the indicator.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public float get_Minimum();

/** property */
public void set_Minimum(float value);
JScript
public function get Minimum() : float

public function set Minimum(value : float);

See Also

AdamIndicator Class
Advantech.Graph Namespace


Orientation Property

AdamIndicator.Orientation Property
[image]

Get/set the orientation of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The orientation of the control.")>
Public Property Orientation As Orientation
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The orientation of the control.")]
public Orientation Orientation { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The orientation of the control.")]
public property Orientation Orientation sealed {
Orientation get();
void set(Orientation value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The orientation of the control.") */
/** property */
public Orientation get_Orientation();

/** property */
public void set_Orientation(Orientation value);
JScript
public function get Orientation() : Orientation

public function set Orientation(value : Orientation);

See Also

AdamIndicator Class
Advantech.Graph Namespace


Registration Property

AdamIndicator.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The registration key."), _
CategoryAttribute("AdamIndicator")>
Public Property Registration As String
C#
[DescriptionAttribute("The registration key.")]
[CategoryAttribute("AdamIndicator")]
public string Registration { get; set; }
C++
[DescriptionAttribute(L"The registration key.")]
[CategoryAttribute(L"AdamIndicator")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The registration key.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamIndicator Class
Advantech.Graph Namespace


Shape Property

AdamIndicator.Shape Property
[image]

Get/set the shape of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The shape of the indicator.")>
Public Property Shape As Shape
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The shape of the indicator.")]
public Shape Shape { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The shape of the indicator.")]
public property Shape Shape sealed {
Shape get();
void set(Shape value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The shape of the indicator.") */
/** property */
public Shape get_Shape();

/** property */
public void set_Shape(Shape value);
JScript
public function get Shape() : Shape

public function set Shape(value : Shape);

See Also

AdamIndicator Class
Advantech.Graph Namespace


Value Property

AdamIndicator.Value Property
[image]

Get/set the value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The value of the indicator."), _
CategoryAttribute("AdamIndicator")>
Public Property Value As Single
C#
[DescriptionAttribute("The value of the indicator.")]
[CategoryAttribute("AdamIndicator")]
public float Value { get; set; }
C++
[DescriptionAttribute(L"The value of the indicator.")]
[CategoryAttribute(L"AdamIndicator")]
public property float Value sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The value of the indicator.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public float get_Value();

/** property */
public void set_Value(float value);
JScript
public function get Value() : float

public function set Value(value : float);

See Also

AdamIndicator Class
Advantech.Graph Namespace


Methods

AdamIndicator Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. OnResize event handler.
Top

See Also

AdamIndicator Class
Advantech.Graph Namespace


Dispose Method

AdamIndicator.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamIndicator Class
Advantech.Graph Namespace


OnPaint Method

AdamIndicator.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamIndicator Class
Advantech.Graph Namespace


OnResize Method

AdamIndicator.OnResize Method
[image]

OnResize event handler.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e
The EventArgs.

See Also

AdamIndicator Class
Advantech.Graph Namespace


AdamKnob Class

AdamKnob Class
See Also Example Members
[image]

The AdamKnob Class.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamKnob), "Pictures.AdamKnob.bmp")>
Public Class AdamKnob
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamKnob), "Pictures.AdamKnob.bmp")]
public class AdamKnob : Control
C++
[ToolboxBitmapAttribute(typeof(AdamKnob), L"Pictures.AdamKnob.bmp")]
ref class AdamKnob : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamKnob), "Pictures.AdamKnob.bmp") */
public class AdamKnob extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamKnob), "Pictures.AdamKnob.bmp")
class AdamKnob extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamKnob

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamKnob Members
Advantech.Graph Namespace


AdamKnob Members

AdamKnob Members
See Also Example Constructors Properties Methods Events
[image]

The AdamKnob Class.

The following tables list the members exposed by AdamKnob.

Public Constructors

 | Name | Description
Public method | AdamKnob | The AdamKnob constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | BackDarkColor | Get/set the back dark color of the meter.
Public property | BackLightColor | Get/set the back light color of the meter.
Public property | DisplayAutoCenter | Get/set whether the LED display is autocentered.
Public property | DisplayBackDarkColor | Get/set the LED display back dark color.
Public property | DisplayBackLightColor | Get/set the LED display back light color.
Public property | DisplayDecimalPoint | Get/set the LED display deciaml point.
Public property | DisplayDigitalCount | Get/set the LED display back dark color.
Public property | DisplayLedOffColor | Get/set the LED display off color.
Public property | DisplayLedOnColor | Get/set the LED display on color.
Public property | DisplayLineWidth | Get/set the LED display digit line width.
Public property | DisplayShown | Get/set whether the LED display object should be shown
Public property | DisplaySize | Get/set the LED display digit size.
Public property | MajorTickCount | Get/set the total of the major tick.
Public property | Maximum | Get/set the maximum value of the grid.
Public property | Minimum | Get/set the minimum value of the grid.
Public property | MinorTickCount | Get/set the total of the minor tick.
Public property | NeedleColor | Get/set the color of needle.
Public property | Registration | Get/set the registration key.
Public property | TickColor | Get/set the color of the grid lines.
Public property | Unit | Get/set the unit string.
Public property | Value | Get/set the value of the needle.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | IsInputKey | Overridden. Determines whether the specified key is a regular input key or a special key that requires preprocessing.
Family method | OnKeyDown | Overridden. Fires when the user presses a key.
Family method | OnMouseDown | Overridden. Raises the MouseDown event.
Family method | OnMouseMove | Overridden. Raises the MouseMove event.
Family method | OnMouseUp | Overridden. Raises the MouseUp event.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Family method | OnValueChanged | Invoke the ValueChanged event; called when value is changed
Top

Public Events

 | Name | Description
Public event | ValueChanged | An event that clients can use to be notified whenever the Value is Changed.
Top

See Also

AdamKnob Class
Advantech.Graph Namespace


AdamKnob Constructor

AdamKnob Constructor
[image]

The AdamKnob constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamKnob()
C++
public:
AdamKnob() sealed
J#
public AdamKnob()
JScript
public function AdamKnob()

See Also

AdamKnob Class
Advantech.Graph Namespace


Properties

AdamKnob Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | BackDarkColor | Get/set the back dark color of the meter.
Public property | BackLightColor | Get/set the back light color of the meter.
Public property | DisplayAutoCenter | Get/set whether the LED display is autocentered.
Public property | DisplayBackDarkColor | Get/set the LED display back dark color.
Public property | DisplayBackLightColor | Get/set the LED display back light color.
Public property | DisplayDecimalPoint | Get/set the LED display deciaml point.
Public property | DisplayDigitalCount | Get/set the LED display back dark color.
Public property | DisplayLedOffColor | Get/set the LED display off color.
Public property | DisplayLedOnColor | Get/set the LED display on color.
Public property | DisplayLineWidth | Get/set the LED display digit line width.
Public property | DisplayShown | Get/set whether the LED display object should be shown
Public property | DisplaySize | Get/set the LED display digit size.
Public property | MajorTickCount | Get/set the total of the major tick.
Public property | Maximum | Get/set the maximum value of the grid.
Public property | Minimum | Get/set the minimum value of the grid.
Public property | MinorTickCount | Get/set the total of the minor tick.
Public property | NeedleColor | Get/set the color of needle.
Public property | Registration | Get/set the registration key.
Public property | TickColor | Get/set the color of the grid lines.
Public property | Unit | Get/set the unit string.
Public property | Value | Get/set the value of the needle.
Top

See Also

AdamKnob Class
Advantech.Graph Namespace


BackColor Property

AdamKnob.BackColor Property
[image]

Get/set the background color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


BackDarkColor Property

AdamKnob.BackDarkColor Property
[image]

Get/set the back dark color of the meter.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The back dark color of the knob."), _
CategoryAttribute("AdamKnob")>
Public Property BackDarkColor As Color
C#
[DescriptionAttribute("The back dark color of the knob.")]
[CategoryAttribute("AdamKnob")]
public Color BackDarkColor { get; set; }
C++
[DescriptionAttribute(L"The back dark color of the knob.")]
[CategoryAttribute(L"AdamKnob")]
public property Color BackDarkColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The back dark color of the knob.") */
/** @attribute CategoryAttribute("AdamKnob") */
/** property */
public Color get_BackDarkColor();

/** property */
public void set_BackDarkColor(Color value);
JScript
public function get BackDarkColor() : Color

public function set BackDarkColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


BackLightColor Property

AdamKnob.BackLightColor Property
[image]

Get/set the back light color of the meter.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The back light color of the knob."), _
CategoryAttribute("AdamKnob")>
Public Property BackLightColor As Color
C#
[DescriptionAttribute("The back light color of the knob.")]
[CategoryAttribute("AdamKnob")]
public Color BackLightColor { get; set; }
C++
[DescriptionAttribute(L"The back light color of the knob.")]
[CategoryAttribute(L"AdamKnob")]
public property Color BackLightColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The back light color of the knob.") */
/** @attribute CategoryAttribute("AdamKnob") */
/** property */
public Color get_BackLightColor();

/** property */
public void set_BackLightColor(Color value);
JScript
public function get BackLightColor() : Color

public function set BackLightColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayAutoCenter Property

AdamKnob.DisplayAutoCenter Property
[image]

Get/set whether the LED display is autocentered.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("Indicate whether LED display is autocentered.")>
Public Property DisplayAutoCenter As Boolean
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("Indicate whether LED display is autocentered.")]
public bool DisplayAutoCenter { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"Indicate whether LED display is autocentered.")]
public property bool DisplayAutoCenter sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("Indicate whether LED display is autocentered.") */
/** property */
public bool get_DisplayAutoCenter();

/** property */
public void set_DisplayAutoCenter(bool value);
JScript
public function get DisplayAutoCenter() : bool

public function set DisplayAutoCenter(value : bool);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayBackDarkColor Property

AdamKnob.DisplayBackDarkColor Property
[image]

Get/set the LED display back dark color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The LED display back dark color."), _
CategoryAttribute("LED display")>
Public Property DisplayBackDarkColor As Color
C#
[DescriptionAttribute("The LED display back dark color.")]
[CategoryAttribute("LED display")]
public Color DisplayBackDarkColor { get; set; }
C++
[DescriptionAttribute(L"The LED display back dark color.")]
[CategoryAttribute(L"LED display")]
public property Color DisplayBackDarkColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The LED display back dark color.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public Color get_DisplayBackDarkColor();

/** property */
public void set_DisplayBackDarkColor(Color value);
JScript
public function get DisplayBackDarkColor() : Color

public function set DisplayBackDarkColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayBackLightColor Property

AdamKnob.DisplayBackLightColor Property
[image]

Get/set the LED display back light color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The LED display back light color.")>
Public Property DisplayBackLightColor As Color
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The LED display back light color.")]
public Color DisplayBackLightColor { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The LED display back light color.")]
public property Color DisplayBackLightColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The LED display back light color.") */
/** property */
public Color get_DisplayBackLightColor();

/** property */
public void set_DisplayBackLightColor(Color value);
JScript
public function get DisplayBackLightColor() : Color

public function set DisplayBackLightColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayDecimalPoint Property

AdamKnob.DisplayDecimalPoint Property
[image]

Get/set the LED display deciaml point.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The deciaml point of the LED display.")>
Public Property DisplayDecimalPoint As Integer
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The deciaml point of the LED display.")]
public int DisplayDecimalPoint { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The deciaml point of the LED display.")]
public property int DisplayDecimalPoint sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The deciaml point of the LED display.") */
/** property */
public int get_DisplayDecimalPoint();

/** property */
public void set_DisplayDecimalPoint(int value);
JScript
public function get DisplayDecimalPoint() : int

public function set DisplayDecimalPoint(value : int);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayDigitalCount Property

AdamKnob.DisplayDigitalCount Property
[image]

Get/set the LED display back dark color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The LED display digital count.")>
Public Property DisplayDigitalCount As Integer
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The LED display digital count.")]
public int DisplayDigitalCount { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The LED display digital count.")]
public property int DisplayDigitalCount sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The LED display digital count.") */
/** property */
public int get_DisplayDigitalCount();

/** property */
public void set_DisplayDigitalCount(int value);
JScript
public function get DisplayDigitalCount() : int

public function set DisplayDigitalCount(value : int);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayLedOffColor Property

AdamKnob.DisplayLedOffColor Property
[image]

Get/set the LED display off color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The LED display off color.")>
Public Property DisplayLedOffColor As Color
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The LED display off color.")]
public Color DisplayLedOffColor { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The LED display off color.")]
public property Color DisplayLedOffColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The LED display off color.") */
/** property */
public Color get_DisplayLedOffColor();

/** property */
public void set_DisplayLedOffColor(Color value);
JScript
public function get DisplayLedOffColor() : Color

public function set DisplayLedOffColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayLedOnColor Property

AdamKnob.DisplayLedOnColor Property
[image]

Get/set the LED display on color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The LED display on color."), _
CategoryAttribute("LED display")>
Public Property DisplayLedOnColor As Color
C#
[DescriptionAttribute("The LED display on color.")]
[CategoryAttribute("LED display")]
public Color DisplayLedOnColor { get; set; }
C++
[DescriptionAttribute(L"The LED display on color.")]
[CategoryAttribute(L"LED display")]
public property Color DisplayLedOnColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The LED display on color.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public Color get_DisplayLedOnColor();

/** property */
public void set_DisplayLedOnColor(Color value);
JScript
public function get DisplayLedOnColor() : Color

public function set DisplayLedOnColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayLineWidth Property

AdamKnob.DisplayLineWidth Property
[image]

Get/set the LED display digit line width.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The LED display digit line width."), _
CategoryAttribute("LED display")>
Public Property DisplayLineWidth As Integer
C#
[DescriptionAttribute("The LED display digit line width.")]
[CategoryAttribute("LED display")]
public int DisplayLineWidth { get; set; }
C++
[DescriptionAttribute(L"The LED display digit line width.")]
[CategoryAttribute(L"LED display")]
public property int DisplayLineWidth sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The LED display digit line width.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public int get_DisplayLineWidth();

/** property */
public void set_DisplayLineWidth(int value);
JScript
public function get DisplayLineWidth() : int

public function set DisplayLineWidth(value : int);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplayShown Property

AdamKnob.DisplayShown Property
[image]

Get/set whether the LED display object should be shown

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("Indicate whether the display object should be shown.")>
Public Property DisplayShown As Boolean
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("Indicate whether the display object should be shown.")]
public bool DisplayShown { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"Indicate whether the display object should be shown.")]
public property bool DisplayShown sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("Indicate whether the display object should be shown.") */
/** property */
public bool get_DisplayShown();

/** property */
public void set_DisplayShown(bool value);
JScript
public function get DisplayShown() : bool

public function set DisplayShown(value : bool);

See Also

AdamKnob Class
Advantech.Graph Namespace


DisplaySize Property

AdamKnob.DisplaySize Property
[image]

Get/set the LED display digit size.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The LED display size."), _
CategoryAttribute("LED display")>
Public Property DisplaySize As Size
C#
[DescriptionAttribute("The LED display size.")]
[CategoryAttribute("LED display")]
public Size DisplaySize { get; set; }
C++
[DescriptionAttribute(L"The LED display size.")]
[CategoryAttribute(L"LED display")]
public property Size DisplaySize sealed {
Size get();
void set(Size value);
}
J#
/** @attribute DescriptionAttribute("The LED display size.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public Size get_DisplaySize();

/** property */
public void set_DisplaySize(Size value);
JScript
public function get DisplaySize() : Size

public function set DisplaySize(value : Size);

See Also

AdamKnob Class
Advantech.Graph Namespace


MajorTickCount Property

AdamKnob.MajorTickCount Property
[image]

Get/set the total of the major tick.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamKnob"), _
DescriptionAttribute("The total of the major tick.")>
Public Property MajorTickCount As Integer
C#
[CategoryAttribute("AdamKnob")]
[DescriptionAttribute("The total of the major tick.")]
public int MajorTickCount { get; set; }
C++
[CategoryAttribute(L"AdamKnob")]
[DescriptionAttribute(L"The total of the major tick.")]
public property int MajorTickCount sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamKnob") */
/** @attribute DescriptionAttribute("The total of the major tick.") */
/** property */
public int get_MajorTickCount();

/** property */
public void set_MajorTickCount(int value);
JScript
public function get MajorTickCount() : int

public function set MajorTickCount(value : int);

See Also

AdamKnob Class
Advantech.Graph Namespace


Maximum Property

AdamKnob.Maximum Property
[image]

Get/set the maximum value of the grid.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The maximum value of the tick."), _
CategoryAttribute("AdamKnob")>
Public Property Maximum As Single
C#
[DescriptionAttribute("The maximum value of the tick.")]
[CategoryAttribute("AdamKnob")]
public float Maximum { get; set; }
C++
[DescriptionAttribute(L"The maximum value of the tick.")]
[CategoryAttribute(L"AdamKnob")]
public property float Maximum sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The maximum value of the tick.") */
/** @attribute CategoryAttribute("AdamKnob") */
/** property */
public float get_Maximum();

/** property */
public void set_Maximum(float value);
JScript
public function get Maximum() : float

public function set Maximum(value : float);

See Also

AdamKnob Class
Advantech.Graph Namespace


Minimum Property

AdamKnob.Minimum Property
[image]

Get/set the minimum value of the grid.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamKnob"), _
DescriptionAttribute("The minimum value of the tick.")>
Public Property Minimum As Single
C#
[CategoryAttribute("AdamKnob")]
[DescriptionAttribute("The minimum value of the tick.")]
public float Minimum { get; set; }
C++
[CategoryAttribute(L"AdamKnob")]
[DescriptionAttribute(L"The minimum value of the tick.")]
public property float Minimum sealed {
float get();
void set(float value);
}
J#
/** @attribute CategoryAttribute("AdamKnob") */
/** @attribute DescriptionAttribute("The minimum value of the tick.") */
/** property */
public float get_Minimum();

/** property */
public void set_Minimum(float value);
JScript
public function get Minimum() : float

public function set Minimum(value : float);

See Also

AdamKnob Class
Advantech.Graph Namespace


MinorTickCount Property

AdamKnob.MinorTickCount Property
[image]

Get/set the total of the minor tick.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamKnob"), _
DescriptionAttribute("The total of the minor tick.")>
Public Property MinorTickCount As Integer
C#
[CategoryAttribute("AdamKnob")]
[DescriptionAttribute("The total of the minor tick.")]
public int MinorTickCount { get; set; }
C++
[CategoryAttribute(L"AdamKnob")]
[DescriptionAttribute(L"The total of the minor tick.")]
public property int MinorTickCount sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamKnob") */
/** @attribute DescriptionAttribute("The total of the minor tick.") */
/** property */
public int get_MinorTickCount();

/** property */
public void set_MinorTickCount(int value);
JScript
public function get MinorTickCount() : int

public function set MinorTickCount(value : int);

See Also

AdamKnob Class
Advantech.Graph Namespace


NeedleColor Property

AdamKnob.NeedleColor Property
[image]

Get/set the color of needle.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of needle."), _
CategoryAttribute("AdamKnob")>
Public Property NeedleColor As Color
C#
[DescriptionAttribute("The color of needle.")]
[CategoryAttribute("AdamKnob")]
public Color NeedleColor { get; set; }
C++
[DescriptionAttribute(L"The color of needle.")]
[CategoryAttribute(L"AdamKnob")]
public property Color NeedleColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of needle.") */
/** @attribute CategoryAttribute("AdamKnob") */
/** property */
public Color get_NeedleColor();

/** property */
public void set_NeedleColor(Color value);
JScript
public function get NeedleColor() : Color

public function set NeedleColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


Registration Property

AdamKnob.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamKnob"), _
DescriptionAttribute("The registration key.")>
Public Property Registration As String
C#
[CategoryAttribute("AdamKnob")]
[DescriptionAttribute("The registration key.")]
public string Registration { get; set; }
C++
[CategoryAttribute(L"AdamKnob")]
[DescriptionAttribute(L"The registration key.")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamKnob") */
/** @attribute DescriptionAttribute("The registration key.") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamKnob Class
Advantech.Graph Namespace


TickColor Property

AdamKnob.TickColor Property
[image]

Get/set the color of the grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the ticks."), _
CategoryAttribute("AdamKnob")>
Public Property TickColor As Color
C#
[DescriptionAttribute("The color of the ticks.")]
[CategoryAttribute("AdamKnob")]
public Color TickColor { get; set; }
C++
[DescriptionAttribute(L"The color of the ticks.")]
[CategoryAttribute(L"AdamKnob")]
public property Color TickColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the ticks.") */
/** @attribute CategoryAttribute("AdamKnob") */
/** property */
public Color get_TickColor();

/** property */
public void set_TickColor(Color value);
JScript
public function get TickColor() : Color

public function set TickColor(value : Color);

See Also

AdamKnob Class
Advantech.Graph Namespace


Unit Property

AdamKnob.Unit Property
[image]

Get/set the unit string.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamKnob"), _
DescriptionAttribute("The unit string.")>
Public Property Unit As String
C#
[CategoryAttribute("AdamKnob")]
[DescriptionAttribute("The unit string.")]
public string Unit { get; set; }
C++
[CategoryAttribute(L"AdamKnob")]
[DescriptionAttribute(L"The unit string.")]
public property string Unit sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamKnob") */
/** @attribute DescriptionAttribute("The unit string.") */
/** property */
public string get_Unit();

/** property */
public void set_Unit(string value);
JScript
public function get Unit() : String

public function set Unit(value : String);

See Also

AdamKnob Class
Advantech.Graph Namespace


Value Property

AdamKnob.Value Property
[image]

Get/set the value of the needle.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The value of the needle."), _
CategoryAttribute("AdamKnob")>
Public Property Value As Single
C#
[DescriptionAttribute("The value of the needle.")]
[CategoryAttribute("AdamKnob")]
public float Value { get; set; }
C++
[DescriptionAttribute(L"The value of the needle.")]
[CategoryAttribute(L"AdamKnob")]
public property float Value sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The value of the needle.") */
/** @attribute CategoryAttribute("AdamKnob") */
/** property */
public float get_Value();

/** property */
public void set_Value(float value);
JScript
public function get Value() : float

public function set Value(value : float);

See Also

AdamKnob Class
Advantech.Graph Namespace


Methods

AdamKnob Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | IsInputKey | Overridden. Determines whether the specified key is a regular input key or a special key that requires preprocessing.
Family method | OnKeyDown | Overridden. Fires when the user presses a key.
Family method | OnMouseDown | Overridden. Raises the MouseDown event.
Family method | OnMouseMove | Overridden. Raises the MouseMove event.
Family method | OnMouseUp | Overridden. Raises the MouseUp event.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Family method | OnValueChanged | Invoke the ValueChanged event; called when value is changed
Top

See Also

AdamKnob Class
Advantech.Graph Namespace


Dispose Method

AdamKnob.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamKnob Class
Advantech.Graph Namespace


IsInputKey Method

AdamKnob.IsInputKey Method
[image]

Determines whether the specified key is a regular input key or a special key that requires preprocessing.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsInputKey( _
ByVal key As Keys _
) As Boolean
C#
protected override bool IsInputKey(
Keys key
)
C++
protected:
virtual bool IsInputKey(
Keys key
) override
J#
protected override bool IsInputKey(
Keys key
)
JScript
protected override function IsInputKey(
key : Keys
) : bool

Parameters

key

See Also

AdamKnob Class
Advantech.Graph Namespace


OnKeyDown Method

AdamKnob.OnKeyDown Method
[image]

Fires when the user presses a key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown( _
ByVal e As KeyEventArgs _
)
C#
protected override void OnKeyDown(
KeyEventArgs e
)
C++
protected:
virtual void OnKeyDown(
KeyEventArgs e
) override
J#
protected override void OnKeyDown(
KeyEventArgs e
)
JScript
protected override function OnKeyDown(
e : KeyEventArgs
)

Parameters

e

See Also

AdamKnob Class
Advantech.Graph Namespace


OnMouseDown Method

AdamKnob.OnMouseDown Method
[image]

Raises the MouseDown event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown( _
ByVal e As MouseEventArgs _
)
C#
protected override void OnMouseDown(
MouseEventArgs e
)
C++
protected:
virtual void OnMouseDown(
MouseEventArgs e
) override
J#
protected override void OnMouseDown(
MouseEventArgs e
)
JScript
protected override function OnMouseDown(
e : MouseEventArgs
)

Parameters

e

See Also

AdamKnob Class
Advantech.Graph Namespace


OnMouseMove Method

AdamKnob.OnMouseMove Method
[image]

Raises the MouseMove event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove( _
ByVal e As MouseEventArgs _
)
C#
protected override void OnMouseMove(
MouseEventArgs e
)
C++
protected:
virtual void OnMouseMove(
MouseEventArgs e
) override
J#
protected override void OnMouseMove(
MouseEventArgs e
)
JScript
protected override function OnMouseMove(
e : MouseEventArgs
)

Parameters

e

See Also

AdamKnob Class
Advantech.Graph Namespace


OnMouseUp Method

AdamKnob.OnMouseUp Method
[image]

Raises the MouseUp event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp( _
ByVal e As MouseEventArgs _
)
C#
protected override void OnMouseUp(
MouseEventArgs e
)
C++
protected:
virtual void OnMouseUp(
MouseEventArgs e
) override
J#
protected override void OnMouseUp(
MouseEventArgs e
)
JScript
protected override function OnMouseUp(
e : MouseEventArgs
)

Parameters

e

See Also

AdamKnob Class
Advantech.Graph Namespace


OnPaint Method

AdamKnob.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamKnob Class
Advantech.Graph Namespace


OnResize Method

AdamKnob.OnResize Method
[image]

The OnResize event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e
The EventArgs.

See Also

AdamKnob Class
Advantech.Graph Namespace


OnValueChanged Method

AdamKnob.OnValueChanged Method
[image]

Invoke the ValueChanged event; called when value is changed

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged( _
ByVal sender As Object _
)
C#
protected virtual void OnValueChanged(
object sender
)
C++
protected:
virtual void OnValueChanged(
Object sender
)
J#
protected virtual void OnValueChanged(
object sender
)
JScript
protected virtual function OnValueChanged(
sender : Object
)

Parameters

sender

See Also

AdamKnob Class
Advantech.Graph Namespace


Events

AdamKnob Events
[image]

Public Events

 | Name | Description
Public event | ValueChanged | An event that clients can use to be notified whenever the Value is Changed.
Top

See Also

AdamKnob Class
Advantech.Graph Namespace


ValueChanged Event

AdamKnob.ValueChanged Event
[image]

An event that clients can use to be notified whenever the Value is Changed.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Event ValueChanged As ValueChangedEventHandler
C#
public event ValueChangedEventHandler ValueChanged
C++
public:
virtual event ValueChangedEventHandler ValueChanged {
void add(ValueChangedEventHandler value) sealed ;
void remove(ValueChangedEventHandler value) sealed ;
}
J#
/** event */
public final void add_ValueChanged(ValueChangedEventHandler value);

/** event */
public final void remove_ValueChanged(ValueChangedEventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

AdamKnob Class
Advantech.Graph Namespace


AdamLight Class

AdamLight Class
See Also Example Members
[image]

AdamLight class is the light control with different shape.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamLight), "Pictures.AdamLight.bmp")>
Public Class AdamLight
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamLight), "Pictures.AdamLight.bmp")]
public class AdamLight : Control
C++
[ToolboxBitmapAttribute(typeof(AdamLight), L"Pictures.AdamLight.bmp")]
ref class AdamLight : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamLight), "Pictures.AdamLight.bmp") */
public class AdamLight extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamLight), "Pictures.AdamLight.bmp")
class AdamLight extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamLight

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamLight Members
Advantech.Graph Namespace


AdamLight Members

AdamLight Members
See Also Example Constructors Properties Methods
[image]

AdamLight class is the light control with different shape.

The following tables list the members exposed by AdamLight.

Public Constructors

 | Name | Description
Public method | AdamLight | The AdamLight constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | LightOffColor | Get/set the color of the light when it is Off.
Public property | LightOnColor | Get/set the color of the light when it is On.
Public property | Registration | Get/set the registration key.
Public property | Style | Get/set the light style.
Public property | Value | Get/set the light to be On or Off.
Top

Public Methods

 | Name | Description
Public method | StartBlinking | Start light autoblinking
Public method | StopBlinking | Stop light autoblinking.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamLight Class
Advantech.Graph Namespace


AdamLight Constructor

AdamLight Constructor
[image]

The AdamLight constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamLight()
C++
public:
AdamLight() sealed
J#
public AdamLight()
JScript
public function AdamLight()

See Also

AdamLight Class
Advantech.Graph Namespace


Properties

AdamLight Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | LightOffColor | Get/set the color of the light when it is Off.
Public property | LightOnColor | Get/set the color of the light when it is On.
Public property | Registration | Get/set the registration key.
Public property | Style | Get/set the light style.
Public property | Value | Get/set the light to be On or Off.
Top

See Also

AdamLight Class
Advantech.Graph Namespace


BackColor Property

AdamLight.BackColor Property
[image]

Get/set the BackColor of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamLight Class
Advantech.Graph Namespace


LightOffColor Property

AdamLight.LightOffColor Property
[image]

Get/set the color of the light when it is Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamLight"), _
DescriptionAttribute("The color of the light when it is Off.")>
Public Property LightOffColor As Color
C#
[CategoryAttribute("AdamLight")]
[DescriptionAttribute("The color of the light when it is Off.")]
public Color LightOffColor { get; set; }
C++
[CategoryAttribute(L"AdamLight")]
[DescriptionAttribute(L"The color of the light when it is Off.")]
public property Color LightOffColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamLight") */
/** @attribute DescriptionAttribute("The color of the light when it is Off.") */
/** property */
public Color get_LightOffColor();

/** property */
public void set_LightOffColor(Color value);
JScript
public function get LightOffColor() : Color

public function set LightOffColor(value : Color);

See Also

AdamLight Class
Advantech.Graph Namespace


LightOnColor Property

AdamLight.LightOnColor Property
[image]

Get/set the color of the light when it is On.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamLight"), _
DescriptionAttribute("The color of the light when it is On.")>
Public Property LightOnColor As Color
C#
[CategoryAttribute("AdamLight")]
[DescriptionAttribute("The color of the light when it is On.")]
public Color LightOnColor { get; set; }
C++
[CategoryAttribute(L"AdamLight")]
[DescriptionAttribute(L"The color of the light when it is On.")]
public property Color LightOnColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamLight") */
/** @attribute DescriptionAttribute("The color of the light when it is On.") */
/** property */
public Color get_LightOnColor();

/** property */
public void set_LightOnColor(Color value);
JScript
public function get LightOnColor() : Color

public function set LightOnColor(value : Color);

See Also

AdamLight Class
Advantech.Graph Namespace


Registration Property

AdamLight.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The registration key."), _
CategoryAttribute("AdamLight")>
Public Property Registration As String
C#
[DescriptionAttribute("The registration key.")]
[CategoryAttribute("AdamLight")]
public string Registration { get; set; }
C++
[DescriptionAttribute(L"The registration key.")]
[CategoryAttribute(L"AdamLight")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The registration key.") */
/** @attribute CategoryAttribute("AdamLight") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamLight Class
Advantech.Graph Namespace


Style Property

AdamLight.Style Property
[image]

Get/set the light style.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The light style."), _
CategoryAttribute("AdamLight")>
Public Property Style As LightStyle
C#
[DescriptionAttribute("The light style.")]
[CategoryAttribute("AdamLight")]
public LightStyle Style { get; set; }
C++
[DescriptionAttribute(L"The light style.")]
[CategoryAttribute(L"AdamLight")]
public property LightStyle Style sealed {
LightStyle get();
void set(LightStyle value);
}
J#
/** @attribute DescriptionAttribute("The light style.") */
/** @attribute CategoryAttribute("AdamLight") */
/** property */
public LightStyle get_Style();

/** property */
public void set_Style(LightStyle value);
JScript
public function get Style() : LightStyle

public function set Style(value : LightStyle);

See Also

AdamLight Class
Advantech.Graph Namespace


Value Property

AdamLight.Value Property
[image]

Get/set the light to be On or Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Determines if the light is On or Off."), _
CategoryAttribute("AdamLight")>
Public Property Value As Boolean
C#
[DescriptionAttribute("Determines if the light is On or Off.")]
[CategoryAttribute("AdamLight")]
public bool Value { get; set; }
C++
[DescriptionAttribute(L"Determines if the light is On or Off.")]
[CategoryAttribute(L"AdamLight")]
public property bool Value sealed {
bool get();
void set(bool value);
}
J#
/** @attribute DescriptionAttribute("Determines if the light is On or Off.") */
/** @attribute CategoryAttribute("AdamLight") */
/** property */
public bool get_Value();

/** property */
public void set_Value(bool value);
JScript
public function get Value() : bool

public function set Value(value : bool);

See Also

AdamLight Class
Advantech.Graph Namespace


Methods

AdamLight Methods
[image]

Public Methods

 | Name | Description
Public method | StartBlinking | Start light autoblinking
Public method | StopBlinking | Stop light autoblinking.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamLight Class
Advantech.Graph Namespace


Dispose Method

AdamLight.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamLight Class
Advantech.Graph Namespace


OnPaint Method

AdamLight.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamLight Class
Advantech.Graph Namespace


OnResize Method

AdamLight.OnResize Method
[image]

The OnResize event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e
The EventArgs.

See Also

AdamLight Class
Advantech.Graph Namespace


StartBlinking Method

AdamLight.StartBlinking Method
[image]

Start light autoblinking

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub StartBlinking( _
ByVal i_iInterval As Integer _
)
C#
public void StartBlinking(
int i_iInterval
)
C++
public:
void StartBlinking(
int i_iInterval
) sealed
J#
public void StartBlinking(
int i_iInterval
)
JScript
public function StartBlinking(
i_iInterval : int
)

Parameters

i_iInterval
The blinking interval. The value must be greater than or equal 50. Otherwise, the interval 50 ms is used.

See Also

AdamLight Class
Advantech.Graph Namespace


StopBlinking Method

AdamLight.StopBlinking Method
[image]

Stop light autoblinking.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub StopBlinking( _
ByVal i_bValue As Boolean _
)
C#
public void StopBlinking(
bool i_bValue
)
C++
public:
void StopBlinking(
bool i_bValue
) sealed
J#
public void StopBlinking(
bool i_bValue
)
JScript
public function StopBlinking(
i_bValue : bool
)

Parameters

i_bValue
The light status after the blinking stoped.

See Also

AdamLight Class
Advantech.Graph Namespace


AdamMeter Class

AdamMeter Class
See Also Example Members
[image]

The AdamMeter class.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamMeter), "Pictures.AdamMeter.bmp")>
Public Class AdamMeter
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamMeter), "Pictures.AdamMeter.bmp")]
public class AdamMeter : Control
C++
[ToolboxBitmapAttribute(typeof(AdamMeter), L"Pictures.AdamMeter.bmp")]
ref class AdamMeter : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamMeter), "Pictures.AdamMeter.bmp") */
public class AdamMeter extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamMeter), "Pictures.AdamMeter.bmp")
class AdamMeter extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamMeter

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamMeter Members
Advantech.Graph Namespace


AdamMeter Members

AdamMeter Members
See Also Example Constructors Properties Methods
[image]

The AdamMeter class.

The following tables list the members exposed by AdamMeter.

Public Constructors

 | Name | Description
Public method | AdamMeter | The AdamMeter constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | BackDarkColor | Get/set the back dark color of the meter.
Public property | BackLightColor | Get/set the back light color of the meter.
Public property | CenterColor | Get/set the color of center.
Public property | CenterWidth | Get/set the width of center.
Public property | DisplayAutoCenter | Get/set whether the LED display is autocentered.
Public property | DisplayBackDarkColor | Get/set the LED display back dark color.
Public property | DisplayBackLightColor | Get/set the LED display back light color.
Public property | DisplayDecimalPoint | Get/set the LED display deciaml point.
Public property | DisplayDigitalCount | Get/set the LED display back dark color.
Public property | DisplayLedOffColor | Get/set the LED display off color.
Public property | DisplayLedOnColor | Get/set the LED display on color.
Public property | DisplayLineWidth | Get/set the LED display digit line width.
Public property | DisplayShown | Get/set whether the LED display object should be shown
Public property | DisplaySize | Get/set the LED display digit size.
Public property | MajorTickCount | Get/set the total of the major tick.
Public property | Maximum | Get/set the maximum value of the grid.
Public property | Minimum | Get/set the minimum value of the grid.
Public property | MinorTickCount | Get/set the total of the minor tick.
Public property | NeedleColor | Get/set the color of needle.
Public property | Registration | Get/set the registration key.
Public property | TickColor | Get/set the color of the grid lines.
Public property | Unit | Get/set the unit string.
Public property | Value | Get/set the value of the needle.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamMeter Class
Advantech.Graph Namespace


AdamMeter Constructor

AdamMeter Constructor
[image]

The AdamMeter constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamMeter()
C++
public:
AdamMeter() sealed
J#
public AdamMeter()
JScript
public function AdamMeter()

See Also

AdamMeter Class
Advantech.Graph Namespace


Properties

AdamMeter Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | BackDarkColor | Get/set the back dark color of the meter.
Public property | BackLightColor | Get/set the back light color of the meter.
Public property | CenterColor | Get/set the color of center.
Public property | CenterWidth | Get/set the width of center.
Public property | DisplayAutoCenter | Get/set whether the LED display is autocentered.
Public property | DisplayBackDarkColor | Get/set the LED display back dark color.
Public property | DisplayBackLightColor | Get/set the LED display back light color.
Public property | DisplayDecimalPoint | Get/set the LED display deciaml point.
Public property | DisplayDigitalCount | Get/set the LED display back dark color.
Public property | DisplayLedOffColor | Get/set the LED display off color.
Public property | DisplayLedOnColor | Get/set the LED display on color.
Public property | DisplayLineWidth | Get/set the LED display digit line width.
Public property | DisplayShown | Get/set whether the LED display object should be shown
Public property | DisplaySize | Get/set the LED display digit size.
Public property | MajorTickCount | Get/set the total of the major tick.
Public property | Maximum | Get/set the maximum value of the grid.
Public property | Minimum | Get/set the minimum value of the grid.
Public property | MinorTickCount | Get/set the total of the minor tick.
Public property | NeedleColor | Get/set the color of needle.
Public property | Registration | Get/set the registration key.
Public property | TickColor | Get/set the color of the grid lines.
Public property | Unit | Get/set the unit string.
Public property | Value | Get/set the value of the needle.
Top

See Also

AdamMeter Class
Advantech.Graph Namespace


BackColor Property

AdamMeter.BackColor Property
[image]

Get/set the background color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


BackDarkColor Property

AdamMeter.BackDarkColor Property
[image]

Get/set the back dark color of the meter.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamMeter"), _
DescriptionAttribute("The back dark color of the meter.")>
Public Property BackDarkColor As Color
C#
[CategoryAttribute("AdamMeter")]
[DescriptionAttribute("The back dark color of the meter.")]
public Color BackDarkColor { get; set; }
C++
[CategoryAttribute(L"AdamMeter")]
[DescriptionAttribute(L"The back dark color of the meter.")]
public property Color BackDarkColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamMeter") */
/** @attribute DescriptionAttribute("The back dark color of the meter.") */
/** property */
public Color get_BackDarkColor();

/** property */
public void set_BackDarkColor(Color value);
JScript
public function get BackDarkColor() : Color

public function set BackDarkColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


BackLightColor Property

AdamMeter.BackLightColor Property
[image]

Get/set the back light color of the meter.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The back light color of the meter."), _
CategoryAttribute("AdamMeter")>
Public Property BackLightColor As Color
C#
[DescriptionAttribute("The back light color of the meter.")]
[CategoryAttribute("AdamMeter")]
public Color BackLightColor { get; set; }
C++
[DescriptionAttribute(L"The back light color of the meter.")]
[CategoryAttribute(L"AdamMeter")]
public property Color BackLightColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The back light color of the meter.") */
/** @attribute CategoryAttribute("AdamMeter") */
/** property */
public Color get_BackLightColor();

/** property */
public void set_BackLightColor(Color value);
JScript
public function get BackLightColor() : Color

public function set BackLightColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


CenterColor Property

AdamMeter.CenterColor Property
[image]

Get/set the color of center.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of center."), _
CategoryAttribute("AdamMeter")>
Public Property CenterColor As Color
C#
[DescriptionAttribute("The color of center.")]
[CategoryAttribute("AdamMeter")]
public Color CenterColor { get; set; }
C++
[DescriptionAttribute(L"The color of center.")]
[CategoryAttribute(L"AdamMeter")]
public property Color CenterColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of center.") */
/** @attribute CategoryAttribute("AdamMeter") */
/** property */
public Color get_CenterColor();

/** property */
public void set_CenterColor(Color value);
JScript
public function get CenterColor() : Color

public function set CenterColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


CenterWidth Property

AdamMeter.CenterWidth Property
[image]

Get/set the width of center.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The width of center."), _
CategoryAttribute("AdamMeter")>
Public Property CenterWidth As Single
C#
[DescriptionAttribute("The width of center.")]
[CategoryAttribute("AdamMeter")]
public float CenterWidth { get; set; }
C++
[DescriptionAttribute(L"The width of center.")]
[CategoryAttribute(L"AdamMeter")]
public property float CenterWidth sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The width of center.") */
/** @attribute CategoryAttribute("AdamMeter") */
/** property */
public float get_CenterWidth();

/** property */
public void set_CenterWidth(float value);
JScript
public function get CenterWidth() : float

public function set CenterWidth(value : float);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayAutoCenter Property

AdamMeter.DisplayAutoCenter Property
[image]

Get/set whether the LED display is autocentered.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("Indicate whether LED display is autocentered.")>
Public Property DisplayAutoCenter As Boolean
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("Indicate whether LED display is autocentered.")]
public bool DisplayAutoCenter { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"Indicate whether LED display is autocentered.")]
public property bool DisplayAutoCenter sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("Indicate whether LED display is autocentered.") */
/** property */
public bool get_DisplayAutoCenter();

/** property */
public void set_DisplayAutoCenter(bool value);
JScript
public function get DisplayAutoCenter() : bool

public function set DisplayAutoCenter(value : bool);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayBackDarkColor Property

AdamMeter.DisplayBackDarkColor Property
[image]

Get/set the LED display back dark color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The LED display back dark color.")>
Public Property DisplayBackDarkColor As Color
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The LED display back dark color.")]
public Color DisplayBackDarkColor { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The LED display back dark color.")]
public property Color DisplayBackDarkColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The LED display back dark color.") */
/** property */
public Color get_DisplayBackDarkColor();

/** property */
public void set_DisplayBackDarkColor(Color value);
JScript
public function get DisplayBackDarkColor() : Color

public function set DisplayBackDarkColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayBackLightColor Property

AdamMeter.DisplayBackLightColor Property
[image]

Get/set the LED display back light color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The LED display back light color.")>
Public Property DisplayBackLightColor As Color
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The LED display back light color.")]
public Color DisplayBackLightColor { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The LED display back light color.")]
public property Color DisplayBackLightColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The LED display back light color.") */
/** property */
public Color get_DisplayBackLightColor();

/** property */
public void set_DisplayBackLightColor(Color value);
JScript
public function get DisplayBackLightColor() : Color

public function set DisplayBackLightColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayDecimalPoint Property

AdamMeter.DisplayDecimalPoint Property
[image]

Get/set the LED display deciaml point.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The deciaml point of the LED display."), _
CategoryAttribute("LED display")>
Public Property DisplayDecimalPoint As Integer
C#
[DescriptionAttribute("The deciaml point of the LED display.")]
[CategoryAttribute("LED display")]
public int DisplayDecimalPoint { get; set; }
C++
[DescriptionAttribute(L"The deciaml point of the LED display.")]
[CategoryAttribute(L"LED display")]
public property int DisplayDecimalPoint sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The deciaml point of the LED display.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public int get_DisplayDecimalPoint();

/** property */
public void set_DisplayDecimalPoint(int value);
JScript
public function get DisplayDecimalPoint() : int

public function set DisplayDecimalPoint(value : int);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayDigitalCount Property

AdamMeter.DisplayDigitalCount Property
[image]

Get/set the LED display back dark color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The LED display digital count."), _
CategoryAttribute("LED display")>
Public Property DisplayDigitalCount As Integer
C#
[DescriptionAttribute("The LED display digital count.")]
[CategoryAttribute("LED display")]
public int DisplayDigitalCount { get; set; }
C++
[DescriptionAttribute(L"The LED display digital count.")]
[CategoryAttribute(L"LED display")]
public property int DisplayDigitalCount sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The LED display digital count.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public int get_DisplayDigitalCount();

/** property */
public void set_DisplayDigitalCount(int value);
JScript
public function get DisplayDigitalCount() : int

public function set DisplayDigitalCount(value : int);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayLedOffColor Property

AdamMeter.DisplayLedOffColor Property
[image]

Get/set the LED display off color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The LED display off color."), _
CategoryAttribute("LED display")>
Public Property DisplayLedOffColor As Color
C#
[DescriptionAttribute("The LED display off color.")]
[CategoryAttribute("LED display")]
public Color DisplayLedOffColor { get; set; }
C++
[DescriptionAttribute(L"The LED display off color.")]
[CategoryAttribute(L"LED display")]
public property Color DisplayLedOffColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The LED display off color.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public Color get_DisplayLedOffColor();

/** property */
public void set_DisplayLedOffColor(Color value);
JScript
public function get DisplayLedOffColor() : Color

public function set DisplayLedOffColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayLedOnColor Property

AdamMeter.DisplayLedOnColor Property
[image]

Get/set the LED display on color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The LED display on color."), _
CategoryAttribute("LED display")>
Public Property DisplayLedOnColor As Color
C#
[DescriptionAttribute("The LED display on color.")]
[CategoryAttribute("LED display")]
public Color DisplayLedOnColor { get; set; }
C++
[DescriptionAttribute(L"The LED display on color.")]
[CategoryAttribute(L"LED display")]
public property Color DisplayLedOnColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The LED display on color.") */
/** @attribute CategoryAttribute("LED display") */
/** property */
public Color get_DisplayLedOnColor();

/** property */
public void set_DisplayLedOnColor(Color value);
JScript
public function get DisplayLedOnColor() : Color

public function set DisplayLedOnColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayLineWidth Property

AdamMeter.DisplayLineWidth Property
[image]

Get/set the LED display digit line width.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The LED display digit line width.")>
Public Property DisplayLineWidth As Integer
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The LED display digit line width.")]
public int DisplayLineWidth { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The LED display digit line width.")]
public property int DisplayLineWidth sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The LED display digit line width.") */
/** property */
public int get_DisplayLineWidth();

/** property */
public void set_DisplayLineWidth(int value);
JScript
public function get DisplayLineWidth() : int

public function set DisplayLineWidth(value : int);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplayShown Property

AdamMeter.DisplayShown Property
[image]

Get/set whether the LED display object should be shown

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("Indicate whether the display object should be shown.")>
Public Property DisplayShown As Boolean
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("Indicate whether the display object should be shown.")]
public bool DisplayShown { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"Indicate whether the display object should be shown.")]
public property bool DisplayShown sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("Indicate whether the display object should be shown.") */
/** property */
public bool get_DisplayShown();

/** property */
public void set_DisplayShown(bool value);
JScript
public function get DisplayShown() : bool

public function set DisplayShown(value : bool);

See Also

AdamMeter Class
Advantech.Graph Namespace


DisplaySize Property

AdamMeter.DisplaySize Property
[image]

Get/set the LED display digit size.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("LED display"), _
DescriptionAttribute("The LED display size.")>
Public Property DisplaySize As Size
C#
[CategoryAttribute("LED display")]
[DescriptionAttribute("The LED display size.")]
public Size DisplaySize { get; set; }
C++
[CategoryAttribute(L"LED display")]
[DescriptionAttribute(L"The LED display size.")]
public property Size DisplaySize sealed {
Size get();
void set(Size value);
}
J#
/** @attribute CategoryAttribute("LED display") */
/** @attribute DescriptionAttribute("The LED display size.") */
/** property */
public Size get_DisplaySize();

/** property */
public void set_DisplaySize(Size value);
JScript
public function get DisplaySize() : Size

public function set DisplaySize(value : Size);

See Also

AdamMeter Class
Advantech.Graph Namespace


MajorTickCount Property

AdamMeter.MajorTickCount Property
[image]

Get/set the total of the major tick.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The total of the major tick."), _
CategoryAttribute("AdamMeter")>
Public Property MajorTickCount As Integer
C#
[DescriptionAttribute("The total of the major tick.")]
[CategoryAttribute("AdamMeter")]
public int MajorTickCount { get; set; }
C++
[DescriptionAttribute(L"The total of the major tick.")]
[CategoryAttribute(L"AdamMeter")]
public property int MajorTickCount sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The total of the major tick.") */
/** @attribute CategoryAttribute("AdamMeter") */
/** property */
public int get_MajorTickCount();

/** property */
public void set_MajorTickCount(int value);
JScript
public function get MajorTickCount() : int

public function set MajorTickCount(value : int);

See Also

AdamMeter Class
Advantech.Graph Namespace


Maximum Property

AdamMeter.Maximum Property
[image]

Get/set the maximum value of the grid.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The maximum value of the tick."), _
CategoryAttribute("AdamMeter")>
Public Property Maximum As Single
C#
[DescriptionAttribute("The maximum value of the tick.")]
[CategoryAttribute("AdamMeter")]
public float Maximum { get; set; }
C++
[DescriptionAttribute(L"The maximum value of the tick.")]
[CategoryAttribute(L"AdamMeter")]
public property float Maximum sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The maximum value of the tick.") */
/** @attribute CategoryAttribute("AdamMeter") */
/** property */
public float get_Maximum();

/** property */
public void set_Maximum(float value);
JScript
public function get Maximum() : float

public function set Maximum(value : float);

See Also

AdamMeter Class
Advantech.Graph Namespace


Minimum Property

AdamMeter.Minimum Property
[image]

Get/set the minimum value of the grid.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamMeter"), _
DescriptionAttribute("The minimum value of the tick.")>
Public Property Minimum As Single
C#
[CategoryAttribute("AdamMeter")]
[DescriptionAttribute("The minimum value of the tick.")]
public float Minimum { get; set; }
C++
[CategoryAttribute(L"AdamMeter")]
[DescriptionAttribute(L"The minimum value of the tick.")]
public property float Minimum sealed {
float get();
void set(float value);
}
J#
/** @attribute CategoryAttribute("AdamMeter") */
/** @attribute DescriptionAttribute("The minimum value of the tick.") */
/** property */
public float get_Minimum();

/** property */
public void set_Minimum(float value);
JScript
public function get Minimum() : float

public function set Minimum(value : float);

See Also

AdamMeter Class
Advantech.Graph Namespace


MinorTickCount Property

AdamMeter.MinorTickCount Property
[image]

Get/set the total of the minor tick.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamMeter"), _
DescriptionAttribute("The total of the minor tick.")>
Public Property MinorTickCount As Integer
C#
[CategoryAttribute("AdamMeter")]
[DescriptionAttribute("The total of the minor tick.")]
public int MinorTickCount { get; set; }
C++
[CategoryAttribute(L"AdamMeter")]
[DescriptionAttribute(L"The total of the minor tick.")]
public property int MinorTickCount sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamMeter") */
/** @attribute DescriptionAttribute("The total of the minor tick.") */
/** property */
public int get_MinorTickCount();

/** property */
public void set_MinorTickCount(int value);
JScript
public function get MinorTickCount() : int

public function set MinorTickCount(value : int);

See Also

AdamMeter Class
Advantech.Graph Namespace


NeedleColor Property

AdamMeter.NeedleColor Property
[image]

Get/set the color of needle.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamMeter"), _
DescriptionAttribute("The color of needle.")>
Public Property NeedleColor As Color
C#
[CategoryAttribute("AdamMeter")]
[DescriptionAttribute("The color of needle.")]
public Color NeedleColor { get; set; }
C++
[CategoryAttribute(L"AdamMeter")]
[DescriptionAttribute(L"The color of needle.")]
public property Color NeedleColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamMeter") */
/** @attribute DescriptionAttribute("The color of needle.") */
/** property */
public Color get_NeedleColor();

/** property */
public void set_NeedleColor(Color value);
JScript
public function get NeedleColor() : Color

public function set NeedleColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


Registration Property

AdamMeter.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The registration key."), _
CategoryAttribute("AdamMeter")>
Public Property Registration As String
C#
[DescriptionAttribute("The registration key.")]
[CategoryAttribute("AdamMeter")]
public string Registration { get; set; }
C++
[DescriptionAttribute(L"The registration key.")]
[CategoryAttribute(L"AdamMeter")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The registration key.") */
/** @attribute CategoryAttribute("AdamMeter") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamMeter Class
Advantech.Graph Namespace


TickColor Property

AdamMeter.TickColor Property
[image]

Get/set the color of the grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamMeter"), _
DescriptionAttribute("The color of the ticks.")>
Public Property TickColor As Color
C#
[CategoryAttribute("AdamMeter")]
[DescriptionAttribute("The color of the ticks.")]
public Color TickColor { get; set; }
C++
[CategoryAttribute(L"AdamMeter")]
[DescriptionAttribute(L"The color of the ticks.")]
public property Color TickColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamMeter") */
/** @attribute DescriptionAttribute("The color of the ticks.") */
/** property */
public Color get_TickColor();

/** property */
public void set_TickColor(Color value);
JScript
public function get TickColor() : Color

public function set TickColor(value : Color);

See Also

AdamMeter Class
Advantech.Graph Namespace


Unit Property

AdamMeter.Unit Property
[image]

Get/set the unit string.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The unit string."), _
CategoryAttribute("AdamMeter")>
Public Property Unit As String
C#
[DescriptionAttribute("The unit string.")]
[CategoryAttribute("AdamMeter")]
public string Unit { get; set; }
C++
[DescriptionAttribute(L"The unit string.")]
[CategoryAttribute(L"AdamMeter")]
public property string Unit sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The unit string.") */
/** @attribute CategoryAttribute("AdamMeter") */
/** property */
public string get_Unit();

/** property */
public void set_Unit(string value);
JScript
public function get Unit() : String

public function set Unit(value : String);

See Also

AdamMeter Class
Advantech.Graph Namespace


Value Property

AdamMeter.Value Property
[image]

Get/set the value of the needle.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamMeter"), _
DescriptionAttribute("The value of the needle.")>
Public Property Value As Single
C#
[CategoryAttribute("AdamMeter")]
[DescriptionAttribute("The value of the needle.")]
public float Value { get; set; }
C++
[CategoryAttribute(L"AdamMeter")]
[DescriptionAttribute(L"The value of the needle.")]
public property float Value sealed {
float get();
void set(float value);
}
J#
/** @attribute CategoryAttribute("AdamMeter") */
/** @attribute DescriptionAttribute("The value of the needle.") */
/** property */
public float get_Value();

/** property */
public void set_Value(float value);
JScript
public function get Value() : float

public function set Value(value : float);

See Also

AdamMeter Class
Advantech.Graph Namespace


Methods

AdamMeter Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamMeter Class
Advantech.Graph Namespace


Dispose Method

AdamMeter.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamMeter Class
Advantech.Graph Namespace


OnPaint Method

AdamMeter.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamMeter Class
Advantech.Graph Namespace


OnResize Method

AdamMeter.OnResize Method
[image]

The OnResize event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e
The EventArgs.

See Also

AdamMeter Class
Advantech.Graph Namespace


AdamNumLed Class

AdamNumLed Class
See Also Example Members
[image]

The AdamNumLed class.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamNumLed), "Pictures.AdamNumLed.bmp")>
Public Class AdamNumLed
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamNumLed), "Pictures.AdamNumLed.bmp")]
public class AdamNumLed : Control
C++
[ToolboxBitmapAttribute(typeof(AdamNumLed), L"Pictures.AdamNumLed.bmp")]
ref class AdamNumLed : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamNumLed), "Pictures.AdamNumLed.bmp") */
public class AdamNumLed extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamNumLed), "Pictures.AdamNumLed.bmp")
class AdamNumLed extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamNumLed

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamNumLed Members
Advantech.Graph Namespace


AdamNumLed Members

AdamNumLed Members
See Also Example Constructors Properties Methods
[image]

The AdamNumLed class.

The following tables list the members exposed by AdamNumLed.

Public Constructors

 | Name | Description
Public method | AdamNumLed | The AdamNumLed constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | BackDarkColor | Get/set the dark back color of the control.
Public property | BackLightColor | Get/set the light back color of the control.
Public property | DigitCount | Get/set the number of the LED digit. The number is between 1 and 10.
Public property | LedOffColor | Get/set the color of the LED when it is Off.
Public property | LedOnColor | Get/set the color of the LED when it is On.
Public property | LineWidth | Get/set the size of the LED line. The size is between 1 and 10.
Public property | Registration | Get/set the registration key.
Public property | Value | Get/set the value string to be shown. Only number, dot and colon will be displayed.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamNumLed Class
Advantech.Graph Namespace


AdamNumLed Constructor

AdamNumLed Constructor
[image]

The AdamNumLed constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamNumLed()
C++
public:
AdamNumLed() sealed
J#
public AdamNumLed()
JScript
public function AdamNumLed()

See Also

AdamNumLed Class
Advantech.Graph Namespace


Properties

AdamNumLed Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | BackDarkColor | Get/set the dark back color of the control.
Public property | BackLightColor | Get/set the light back color of the control.
Public property | DigitCount | Get/set the number of the LED digit. The number is between 1 and 10.
Public property | LedOffColor | Get/set the color of the LED when it is Off.
Public property | LedOnColor | Get/set the color of the LED when it is On.
Public property | LineWidth | Get/set the size of the LED line. The size is between 1 and 10.
Public property | Registration | Get/set the registration key.
Public property | Value | Get/set the value string to be shown. Only number, dot and colon will be displayed.
Top

See Also

AdamNumLed Class
Advantech.Graph Namespace


BackColor Property

AdamNumLed.BackColor Property
[image]

Get/set the background color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamNumLed Class
Advantech.Graph Namespace


BackDarkColor Property

AdamNumLed.BackDarkColor Property
[image]

Get/set the dark back color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The back dark color of the control.")>
Public Property BackDarkColor As Color
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The back dark color of the control.")]
public Color BackDarkColor { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The back dark color of the control.")]
public property Color BackDarkColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The back dark color of the control.") */
/** property */
public Color get_BackDarkColor();

/** property */
public void set_BackDarkColor(Color value);
JScript
public function get BackDarkColor() : Color

public function set BackDarkColor(value : Color);

See Also

AdamNumLed Class
Advantech.Graph Namespace


BackLightColor Property

AdamNumLed.BackLightColor Property
[image]

Get/set the light back color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The back light color of the control.")>
Public Property BackLightColor As Color
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The back light color of the control.")]
public Color BackLightColor { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The back light color of the control.")]
public property Color BackLightColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The back light color of the control.") */
/** property */
public Color get_BackLightColor();

/** property */
public void set_BackLightColor(Color value);
JScript
public function get BackLightColor() : Color

public function set BackLightColor(value : Color);

See Also

AdamNumLed Class
Advantech.Graph Namespace


DigitCount Property

AdamNumLed.DigitCount Property
[image]

Get/set the number of the LED digit. The number is between 1 and 10.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The number of the LED digit. The number is between 1 and 10.")>
Public Property DigitCount As Integer
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The number of the LED digit. The number is between 1 and 10.")]
public int DigitCount { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The number of the LED digit. The number is between 1 and 10.")]
public property int DigitCount sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The number of the LED digit. The number is between 1 and 10.") */
/** property */
public int get_DigitCount();

/** property */
public void set_DigitCount(int value);
JScript
public function get DigitCount() : int

public function set DigitCount(value : int);

See Also

AdamNumLed Class
Advantech.Graph Namespace


LedOffColor Property

AdamNumLed.LedOffColor Property
[image]

Get/set the color of the LED when it is Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The color of the LED when it is Off.")>
Public Property LedOffColor As Color
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The color of the LED when it is Off.")]
public Color LedOffColor { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The color of the LED when it is Off.")]
public property Color LedOffColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The color of the LED when it is Off.") */
/** property */
public Color get_LedOffColor();

/** property */
public void set_LedOffColor(Color value);
JScript
public function get LedOffColor() : Color

public function set LedOffColor(value : Color);

See Also

AdamNumLed Class
Advantech.Graph Namespace


LedOnColor Property

AdamNumLed.LedOnColor Property
[image]

Get/set the color of the LED when it is On.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The color of the LED when it is On.")>
Public Property LedOnColor As Color
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The color of the LED when it is On.")]
public Color LedOnColor { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The color of the LED when it is On.")]
public property Color LedOnColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The color of the LED when it is On.") */
/** property */
public Color get_LedOnColor();

/** property */
public void set_LedOnColor(Color value);
JScript
public function get LedOnColor() : Color

public function set LedOnColor(value : Color);

See Also

AdamNumLed Class
Advantech.Graph Namespace


LineWidth Property

AdamNumLed.LineWidth Property
[image]

Get/set the size of the LED line. The size is between 1 and 10.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The width of the LED line. The size is between 1 and 10.")>
Public Property LineWidth As Integer
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The width of the LED line. The size is between 1 and 10.")]
public int LineWidth { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The width of the LED line. The size is between 1 and 10.")]
public property int LineWidth sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The width of the LED line. The size is between 1 and 10.") */
/** property */
public int get_LineWidth();

/** property */
public void set_LineWidth(int value);
JScript
public function get LineWidth() : int

public function set LineWidth(value : int);

See Also

AdamNumLed Class
Advantech.Graph Namespace


Registration Property

AdamNumLed.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The registration key.")>
Public Property Registration As String
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The registration key.")]
public string Registration { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The registration key.")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The registration key.") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamNumLed Class
Advantech.Graph Namespace


Value Property

AdamNumLed.Value Property
[image]

Get/set the value string to be shown. Only number, dot and colon will be displayed.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamNumLed"), _
DescriptionAttribute("The value string to be shown. Only number, dot and colon will be displayed.")>
Public Property Value As String
C#
[CategoryAttribute("AdamNumLed")]
[DescriptionAttribute("The value string to be shown. Only number, dot and colon will be displayed.")]
public string Value { get; set; }
C++
[CategoryAttribute(L"AdamNumLed")]
[DescriptionAttribute(L"The value string to be shown. Only number, dot and colon will be displayed.")]
public property string Value sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamNumLed") */
/** @attribute DescriptionAttribute("The value string to be shown. Only number, dot and colon will be displayed.") */
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

AdamNumLed Class
Advantech.Graph Namespace


Methods

AdamNumLed Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamNumLed Class
Advantech.Graph Namespace


Dispose Method

AdamNumLed.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamNumLed Class
Advantech.Graph Namespace


OnPaint Method

AdamNumLed.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamNumLed Class
Advantech.Graph Namespace


OnResize Method

AdamNumLed.OnResize Method
[image]

The OnResize event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e
The EventArgs.

See Also

AdamNumLed Class
Advantech.Graph Namespace


AdamRemote Class

AdamRemote Class
See Also Example Members
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamRemote), "Pictures.AdamRemote.bmp")>
Public Class AdamRemote
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamRemote), "Pictures.AdamRemote.bmp")]
public class AdamRemote : Control
C++
[ToolboxBitmapAttribute(typeof(AdamRemote), L"Pictures.AdamRemote.bmp")]
ref class AdamRemote : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamRemote), "Pictures.AdamRemote.bmp") */
public class AdamRemote extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamRemote), "Pictures.AdamRemote.bmp")
class AdamRemote extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamRemote

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamRemote Members
Advantech.Graph Namespace


AdamRemote Members

AdamRemote Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AdamRemote.

Public Constructors

 | Name | Description
Public method | AdamRemote | AdamRemote
Top

Public Properties

 | Name | Description
Public property | CanControl | Get/set whether the user can control the remote device.
Public property | ConnectionAlive | Get connection state. If connection is alive, return true, otherwise return false.
Public property | ConnectionTimeout | Get/set the connection timeout in milliseconds. The value must be between 100 and 30000.
Public property | ControlPort | Get/Set the TCP port for control communication.
Public property | DrawHighQuality | Get/set whether the drawing is high quality.
Public property | FtpPort | Get/Set the TCP port for file transfer.
Public property | Registration | Get/set the registration key.
Public property | RemoteIP | Get/set the IP addres of the remote device.
Public property | SendMouseMove | Get/set whether the mouse movement will be sent to the remote device.
Public property | Title | Get/set text of the title.
Public property | UpdateFrameInterval | Get/set update frame interval. The value must be between 1 and 20.
Top

Public Methods

 | Name | Description
Public method | CaptureScreen | Capture screen image.
Public method | CaptureSnapshot | Run the snapshot capture
Public method | RunFileTransfer | Pop up the file transfer dialog
Public method | Start | Start the DiagAnywhere control.
Public method | Stop | Stop the DiagAnywhere control.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | IsInputKey | Overridden.
Family method | OnGotFocus | Overridden.
Family method | OnKeyDown | Overridden.
Family method | OnKeyPress | Overridden.
Family method | OnKeyUp | Overridden.
Family method | OnLostFocus | Overridden.
Family method | OnMouseDown | Overridden. Raises the MouseDown event.
Family method | OnMouseMove | Overridden. Raises the MouseMove event.
Family method | OnMouseUp | Overridden. Raises the MouseUp event.
Family method | OnMouseWheel | Overridden.
Family method | OnPaint | Overridden.
Family method | OnSizeChanged | Overridden.
Top

See Also

AdamRemote Class
Advantech.Graph Namespace


AdamRemote Constructor

AdamRemote Constructor
[image]

AdamRemote

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamRemote()
C++
public:
AdamRemote() sealed
J#
public AdamRemote()
JScript
public function AdamRemote()

See Also

AdamRemote Class
Advantech.Graph Namespace


Properties

AdamRemote Properties
[image]

Public Properties

 | Name | Description
Public property | CanControl | Get/set whether the user can control the remote device.
Public property | ConnectionAlive | Get connection state. If connection is alive, return true, otherwise return false.
Public property | ConnectionTimeout | Get/set the connection timeout in milliseconds. The value must be between 100 and 30000.
Public property | ControlPort | Get/Set the TCP port for control communication.
Public property | DrawHighQuality | Get/set whether the drawing is high quality.
Public property | FtpPort | Get/Set the TCP port for file transfer.
Public property | Registration | Get/set the registration key.
Public property | RemoteIP | Get/set the IP addres of the remote device.
Public property | SendMouseMove | Get/set whether the mouse movement will be sent to the remote device.
Public property | Title | Get/set text of the title.
Public property | UpdateFrameInterval | Get/set update frame interval. The value must be between 1 and 20.
Top

See Also

AdamRemote Class
Advantech.Graph Namespace


CanControl Property

AdamRemote.CanControl Property
[image]

Get/set whether the user can control the remote device.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRemote"), _
DescriptionAttribute("Whether the user can control the remote device.")>
Public Property CanControl As Boolean
C#
[CategoryAttribute("AdamRemote")]
[DescriptionAttribute("Whether the user can control the remote device.")]
public bool CanControl { get; set; }
C++
[CategoryAttribute(L"AdamRemote")]
[DescriptionAttribute(L"Whether the user can control the remote device.")]
public property bool CanControl sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("AdamRemote") */
/** @attribute DescriptionAttribute("Whether the user can control the remote device.") */
/** property */
public bool get_CanControl();

/** property */
public void set_CanControl(bool value);
JScript
public function get CanControl() : bool

public function set CanControl(value : bool);

See Also

AdamRemote Class
Advantech.Graph Namespace


ConnectionAlive Property

AdamRemote.ConnectionAlive Property
[image]

Get connection state. If connection is alive, return true, otherwise return false.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Get the connection alive state."), _
CategoryAttribute("AdamRemote")>
Public ReadOnly Property ConnectionAlive As Boolean
C#
[DescriptionAttribute("Get the connection alive state.")]
[CategoryAttribute("AdamRemote")]
public bool ConnectionAlive { get; }
C++
[DescriptionAttribute(L"Get the connection alive state.")]
[CategoryAttribute(L"AdamRemote")]
public property bool ConnectionAlive sealed {
bool get();
}
J#
/** @attribute DescriptionAttribute("Get the connection alive state.") */
/** @attribute CategoryAttribute("AdamRemote") */
/** property */
public bool get_ConnectionAlive();
JScript
public function get ConnectionAlive() : bool

See Also

AdamRemote Class
Advantech.Graph Namespace


ConnectionTimeout Property

AdamRemote.ConnectionTimeout Property
[image]

Get/set the connection timeout in milliseconds. The value must be between 100 and 30000.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRemote"), _
DescriptionAttribute("The connection timeout in milliseconds.")>
Public Property ConnectionTimeout As Integer
C#
[CategoryAttribute("AdamRemote")]
[DescriptionAttribute("The connection timeout in milliseconds.")]
public int ConnectionTimeout { get; set; }
C++
[CategoryAttribute(L"AdamRemote")]
[DescriptionAttribute(L"The connection timeout in milliseconds.")]
public property int ConnectionTimeout sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamRemote") */
/** @attribute DescriptionAttribute("The connection timeout in milliseconds.") */
/** property */
public int get_ConnectionTimeout();

/** property */
public void set_ConnectionTimeout(int value);
JScript
public function get ConnectionTimeout() : int

public function set ConnectionTimeout(value : int);

See Also

AdamRemote Class
Advantech.Graph Namespace


ControlPort Property

AdamRemote.ControlPort Property
[image]

Get/Set the TCP port for control communication.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRemote"), _
DescriptionAttribute("The TCP port for control communication.")>
Public Property ControlPort As Integer
C#
[CategoryAttribute("AdamRemote")]
[DescriptionAttribute("The TCP port for control communication.")]
public int ControlPort { get; set; }
C++
[CategoryAttribute(L"AdamRemote")]
[DescriptionAttribute(L"The TCP port for control communication.")]
public property int ControlPort sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamRemote") */
/** @attribute DescriptionAttribute("The TCP port for control communication.") */
/** property */
public int get_ControlPort();

/** property */
public void set_ControlPort(int value);
JScript
public function get ControlPort() : int

public function set ControlPort(value : int);

See Also

AdamRemote Class
Advantech.Graph Namespace


DrawHighQuality Property

AdamRemote.DrawHighQuality Property
[image]

Get/set whether the drawing is high quality.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Whether the drawing is high quality."), _
CategoryAttribute("AdamRemote")>
Public Property DrawHighQuality As Boolean
C#
[DescriptionAttribute("Whether the drawing is high quality.")]
[CategoryAttribute("AdamRemote")]
public bool DrawHighQuality { get; set; }
C++
[DescriptionAttribute(L"Whether the drawing is high quality.")]
[CategoryAttribute(L"AdamRemote")]
public property bool DrawHighQuality sealed {
bool get();
void set(bool value);
}
J#
/** @attribute DescriptionAttribute("Whether the drawing is high quality.") */
/** @attribute CategoryAttribute("AdamRemote") */
/** property */
public bool get_DrawHighQuality();

/** property */
public void set_DrawHighQuality(bool value);
JScript
public function get DrawHighQuality() : bool

public function set DrawHighQuality(value : bool);

See Also

AdamRemote Class
Advantech.Graph Namespace


FtpPort Property

AdamRemote.FtpPort Property
[image]

Get/Set the TCP port for file transfer.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRemote"), _
DescriptionAttribute("The TCP port for file transfer.")>
Public Property FtpPort As Integer
C#
[CategoryAttribute("AdamRemote")]
[DescriptionAttribute("The TCP port for file transfer.")]
public int FtpPort { get; set; }
C++
[CategoryAttribute(L"AdamRemote")]
[DescriptionAttribute(L"The TCP port for file transfer.")]
public property int FtpPort sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamRemote") */
/** @attribute DescriptionAttribute("The TCP port for file transfer.") */
/** property */
public int get_FtpPort();

/** property */
public void set_FtpPort(int value);
JScript
public function get FtpPort() : int

public function set FtpPort(value : int);

See Also

AdamRemote Class
Advantech.Graph Namespace


Registration Property

AdamRemote.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The registration key."), _
CategoryAttribute("AdamRemote")>
Public Property Registration As String
C#
[DescriptionAttribute("The registration key.")]
[CategoryAttribute("AdamRemote")]
public string Registration { get; set; }
C++
[DescriptionAttribute(L"The registration key.")]
[CategoryAttribute(L"AdamRemote")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The registration key.") */
/** @attribute CategoryAttribute("AdamRemote") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamRemote Class
Advantech.Graph Namespace


RemoteIP Property

AdamRemote.RemoteIP Property
[image]

Get/set the IP addres of the remote device.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRemote"), _
DescriptionAttribute("The IP address of the remote device.")>
Public Property RemoteIP As String
C#
[CategoryAttribute("AdamRemote")]
[DescriptionAttribute("The IP address of the remote device.")]
public string RemoteIP { get; set; }
C++
[CategoryAttribute(L"AdamRemote")]
[DescriptionAttribute(L"The IP address of the remote device.")]
public property string RemoteIP sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamRemote") */
/** @attribute DescriptionAttribute("The IP address of the remote device.") */
/** property */
public string get_RemoteIP();

/** property */
public void set_RemoteIP(string value);
JScript
public function get RemoteIP() : String

public function set RemoteIP(value : String);

See Also

AdamRemote Class
Advantech.Graph Namespace


SendMouseMove Property

AdamRemote.SendMouseMove Property
[image]

Get/set whether the mouse movement will be sent to the remote device.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Whether the mouse movement will be sent to the remote device."), _
CategoryAttribute("AdamRemote")>
Public Property SendMouseMove As Boolean
C#
[DescriptionAttribute("Whether the mouse movement will be sent to the remote device.")]
[CategoryAttribute("AdamRemote")]
public bool SendMouseMove { get; set; }
C++
[DescriptionAttribute(L"Whether the mouse movement will be sent to the remote device.")]
[CategoryAttribute(L"AdamRemote")]
public property bool SendMouseMove sealed {
bool get();
void set(bool value);
}
J#
/** @attribute DescriptionAttribute("Whether the mouse movement will be sent to the remote device.") */
/** @attribute CategoryAttribute("AdamRemote") */
/** property */
public bool get_SendMouseMove();

/** property */
public void set_SendMouseMove(bool value);
JScript
public function get SendMouseMove() : bool

public function set SendMouseMove(value : bool);

See Also

AdamRemote Class
Advantech.Graph Namespace


Title Property

AdamRemote.Title Property
[image]

Get/set text of the title.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The text of the title."), _
CategoryAttribute("AdamRemote")>
Public Property Title As String
C#
[DescriptionAttribute("The text of the title.")]
[CategoryAttribute("AdamRemote")]
public string Title { get; set; }
C++
[DescriptionAttribute(L"The text of the title.")]
[CategoryAttribute(L"AdamRemote")]
public property string Title sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The text of the title.") */
/** @attribute CategoryAttribute("AdamRemote") */
/** property */
public string get_Title();

/** property */
public void set_Title(string value);
JScript
public function get Title() : String

public function set Title(value : String);

See Also

AdamRemote Class
Advantech.Graph Namespace


UpdateFrameInterval Property

AdamRemote.UpdateFrameInterval Property
[image]

Get/set update frame interval. The value must be between 1 and 20.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRemote"), _
DescriptionAttribute("The update frame interval.")>
Public Property UpdateFrameInterval As Integer
C#
[CategoryAttribute("AdamRemote")]
[DescriptionAttribute("The update frame interval.")]
public int UpdateFrameInterval { get; set; }
C++
[CategoryAttribute(L"AdamRemote")]
[DescriptionAttribute(L"The update frame interval.")]
public property int UpdateFrameInterval sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamRemote") */
/** @attribute DescriptionAttribute("The update frame interval.") */
/** property */
public int get_UpdateFrameInterval();

/** property */
public void set_UpdateFrameInterval(int value);
JScript
public function get UpdateFrameInterval() : int

public function set UpdateFrameInterval(value : int);

See Also

AdamRemote Class
Advantech.Graph Namespace


Methods

AdamRemote Methods
[image]

Public Methods

 | Name | Description
Public method | CaptureScreen | Capture screen image.
Public method | CaptureSnapshot | Run the snapshot capture
Public method | RunFileTransfer | Pop up the file transfer dialog
Public method | Start | Start the DiagAnywhere control.
Public method | Stop | Stop the DiagAnywhere control.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | IsInputKey | Overridden.
Family method | OnGotFocus | Overridden.
Family method | OnKeyDown | Overridden.
Family method | OnKeyPress | Overridden.
Family method | OnKeyUp | Overridden.
Family method | OnLostFocus | Overridden.
Family method | OnMouseDown | Overridden. Raises the MouseDown event.
Family method | OnMouseMove | Overridden. Raises the MouseMove event.
Family method | OnMouseUp | Overridden. Raises the MouseUp event.
Family method | OnMouseWheel | Overridden.
Family method | OnPaint | Overridden.
Family method | OnSizeChanged | Overridden.
Top

See Also

AdamRemote Class
Advantech.Graph Namespace


CaptureScreen Method

AdamRemote.CaptureScreen Method
[image]

Capture screen image.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function CaptureScreen() As Bitmap
C#
public Bitmap CaptureScreen()
C++
public:
Bitmap CaptureScreen() sealed
J#
public Bitmap CaptureScreen()
JScript
public function CaptureScreen() : Bitmap

Return Value

The screen image. If the control has never connect to any device return null.

See Also

AdamRemote Class
Advantech.Graph Namespace


CaptureSnapshot Method

AdamRemote.CaptureSnapshot Method
[image]

Run the snapshot capture

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub CaptureSnapshot()
C#
public void CaptureSnapshot()
C++
public:
void CaptureSnapshot() sealed
J#
public void CaptureSnapshot()
JScript
public function CaptureSnapshot()

See Also

AdamRemote Class
Advantech.Graph Namespace


Dispose Method

AdamRemote.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamRemote Class
Advantech.Graph Namespace


IsInputKey Method

AdamRemote.IsInputKey Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsInputKey( _
ByVal keyData As Keys _
) As Boolean
C#
protected override bool IsInputKey(
Keys keyData
)
C++
protected:
virtual bool IsInputKey(
Keys keyData
) override
J#
protected override bool IsInputKey(
Keys keyData
)
JScript
protected override function IsInputKey(
keyData : Keys
) : bool

Parameters

keyData

See Also

AdamRemote Class
Advantech.Graph Namespace


OnGotFocus Method

AdamRemote.OnGotFocus Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnGotFocus( _
ByVal e As EventArgs _
)
C#
protected override void OnGotFocus(
EventArgs e
)
C++
protected:
virtual void OnGotFocus(
EventArgs e
) override
J#
protected override void OnGotFocus(
EventArgs e
)
JScript
protected override function OnGotFocus(
e : EventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnKeyDown Method

AdamRemote.OnKeyDown Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown( _
ByVal e As KeyEventArgs _
)
C#
protected override void OnKeyDown(
KeyEventArgs e
)
C++
protected:
virtual void OnKeyDown(
KeyEventArgs e
) override
J#
protected override void OnKeyDown(
KeyEventArgs e
)
JScript
protected override function OnKeyDown(
e : KeyEventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnKeyPress Method

AdamRemote.OnKeyPress Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyPress( _
ByVal e As KeyPressEventArgs _
)
C#
protected override void OnKeyPress(
KeyPressEventArgs e
)
C++
protected:
virtual void OnKeyPress(
KeyPressEventArgs e
) override
J#
protected override void OnKeyPress(
KeyPressEventArgs e
)
JScript
protected override function OnKeyPress(
e : KeyPressEventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnKeyUp Method

AdamRemote.OnKeyUp Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyUp( _
ByVal e As KeyEventArgs _
)
C#
protected override void OnKeyUp(
KeyEventArgs e
)
C++
protected:
virtual void OnKeyUp(
KeyEventArgs e
) override
J#
protected override void OnKeyUp(
KeyEventArgs e
)
JScript
protected override function OnKeyUp(
e : KeyEventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnLostFocus Method

AdamRemote.OnLostFocus Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus( _
ByVal e As EventArgs _
)
C#
protected override void OnLostFocus(
EventArgs e
)
C++
protected:
virtual void OnLostFocus(
EventArgs e
) override
J#
protected override void OnLostFocus(
EventArgs e
)
JScript
protected override function OnLostFocus(
e : EventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnMouseDown Method

AdamRemote.OnMouseDown Method
[image]

Raises the MouseDown event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown( _
ByVal e As MouseEventArgs _
)
C#
protected override void OnMouseDown(
MouseEventArgs e
)
C++
protected:
virtual void OnMouseDown(
MouseEventArgs e
) override
J#
protected override void OnMouseDown(
MouseEventArgs e
)
JScript
protected override function OnMouseDown(
e : MouseEventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnMouseMove Method

AdamRemote.OnMouseMove Method
[image]

Raises the MouseMove event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove( _
ByVal e As MouseEventArgs _
)
C#
protected override void OnMouseMove(
MouseEventArgs e
)
C++
protected:
virtual void OnMouseMove(
MouseEventArgs e
) override
J#
protected override void OnMouseMove(
MouseEventArgs e
)
JScript
protected override function OnMouseMove(
e : MouseEventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnMouseUp Method

AdamRemote.OnMouseUp Method
[image]

Raises the MouseUp event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp( _
ByVal e As MouseEventArgs _
)
C#
protected override void OnMouseUp(
MouseEventArgs e
)
C++
protected:
virtual void OnMouseUp(
MouseEventArgs e
) override
J#
protected override void OnMouseUp(
MouseEventArgs e
)
JScript
protected override function OnMouseUp(
e : MouseEventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnMouseWheel Method

AdamRemote.OnMouseWheel Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseWheel( _
ByVal e As MouseEventArgs _
)
C#
protected override void OnMouseWheel(
MouseEventArgs e
)
C++
protected:
virtual void OnMouseWheel(
MouseEventArgs e
) override
J#
protected override void OnMouseWheel(
MouseEventArgs e
)
JScript
protected override function OnMouseWheel(
e : MouseEventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


OnPaint Method

AdamRemote.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamRemote Class
Advantech.Graph Namespace


OnSizeChanged Method

AdamRemote.OnSizeChanged Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnSizeChanged( _
ByVal e As EventArgs _
)
C#
protected override void OnSizeChanged(
EventArgs e
)
C++
protected:
virtual void OnSizeChanged(
EventArgs e
) override
J#
protected override void OnSizeChanged(
EventArgs e
)
JScript
protected override function OnSizeChanged(
e : EventArgs
)

Parameters

e

See Also

AdamRemote Class
Advantech.Graph Namespace


RunFileTransfer Method

AdamRemote.RunFileTransfer Method
[image]

Pop up the file transfer dialog

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub RunFileTransfer()
C#
public void RunFileTransfer()
C++
public:
void RunFileTransfer() sealed
J#
public void RunFileTransfer()
JScript
public function RunFileTransfer()

See Also

AdamRemote Class
Advantech.Graph Namespace


Start Method

AdamRemote.Start Method
[image]

Start the DiagAnywhere control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub Start( _
ByVal szPassword As String _
)
C#
public void Start(
string szPassword
)
C++
public:
void Start(
String szPassword
) sealed
J#
public void Start(
string szPassword
)
JScript
public function Start(
szPassword : String
)

Parameters

szPassword
The remote device Administrator password.

See Also

AdamRemote Class
Advantech.Graph Namespace


Stop Method

AdamRemote.Stop Method
[image]

Stop the DiagAnywhere control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub Stop()
C#
public void Stop()
C++
public:
void Stop() sealed
J#
public void Stop()
JScript
public function Stop()

See Also

AdamRemote Class
Advantech.Graph Namespace


AdamRuler Class

AdamRuler Class
See Also Example Members
[image]

The AdamRuler class.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamRuler), "Pictures.AdamRuler.bmp")>
Public Class AdamRuler
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamRuler), "Pictures.AdamRuler.bmp")]
public class AdamRuler : Control
C++
[ToolboxBitmapAttribute(typeof(AdamRuler), L"Pictures.AdamRuler.bmp")]
ref class AdamRuler : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamRuler), "Pictures.AdamRuler.bmp") */
public class AdamRuler extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamRuler), "Pictures.AdamRuler.bmp")
class AdamRuler extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamRuler

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamRuler Members
Advantech.Graph Namespace


AdamRuler Members

AdamRuler Members
See Also Example Constructors Properties Methods
[image]

The AdamRuler class.

The following tables list the members exposed by AdamRuler.

Public Constructors

 | Name | Description
Public method | AdamRuler | The AdamRuler constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | DeciamlInterval | Get/set the deciaml interval size.
Public property | ForeColor | Overridden. Get/set the ForeColor.
Public property | GridLineSize | Get/set the distance between two grid lines.
Public property | LinearGradientMode | LinearGradientMode
Public property | Orientation | Horizontal or vertical layout
Public property | Registration | Get/set the registration key.
Public property | RulerColor | Set color of Ruler control
Public property | ShowLargeScale | Shows Large Scale marking
Public property | ShowSmallScale | Shows Small Scale marking.
Public property | ShowtickIndex | Shows tick index marking
Public property | StartValue | Current Value of Ruler control
Public property | StepSize | Get/set the X-axis movement steps.
Public property | SurroundColor | Get/set the color of the surrounded line.
Public property | Unit | Get/set the unit string.
Top

Public Methods

 | Name | Description
Public method | ClearGraph | Force to clear the graph.
Public method | UpdateGraph | Force to update the graph.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | DrawGridLines | Draw the grid lines.
Family method | OnPaint | Overridden. The OnPaint event.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamRuler Class
Advantech.Graph Namespace


AdamRuler Constructor

AdamRuler Constructor
[image]

The AdamRuler constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamRuler()
C++
public:
AdamRuler() sealed
J#
public AdamRuler()
JScript
public function AdamRuler()

See Also

AdamRuler Class
Advantech.Graph Namespace


Properties

AdamRuler Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | DeciamlInterval | Get/set the deciaml interval size.
Public property | ForeColor | Overridden. Get/set the ForeColor.
Public property | GridLineSize | Get/set the distance between two grid lines.
Public property | LinearGradientMode | LinearGradientMode
Public property | Orientation | Horizontal or vertical layout
Public property | Registration | Get/set the registration key.
Public property | RulerColor | Set color of Ruler control
Public property | ShowLargeScale | Shows Large Scale marking
Public property | ShowSmallScale | Shows Small Scale marking.
Public property | ShowtickIndex | Shows tick index marking
Public property | StartValue | Current Value of Ruler control
Public property | StepSize | Get/set the X-axis movement steps.
Public property | SurroundColor | Get/set the color of the surrounded line.
Public property | Unit | Get/set the unit string.
Top

See Also

AdamRuler Class
Advantech.Graph Namespace


BackColor Property

AdamRuler.BackColor Property
[image]

Get/set the background color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamRuler Class
Advantech.Graph Namespace


DeciamlInterval Property

AdamRuler.DeciamlInterval Property
[image]

Get/set the deciaml interval size.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The deciaml interval size."), _
DefaultValueAttribute(1), _
CategoryAttribute("AdamRuler")>
Public Property DeciamlInterval As Integer
C#
[DescriptionAttribute("The deciaml interval size.")]
[DefaultValueAttribute(1)]
[CategoryAttribute("AdamRuler")]
public int DeciamlInterval { get; set; }
C++
[DescriptionAttribute(L"The deciaml interval size.")]
[DefaultValueAttribute(1)]
[CategoryAttribute(L"AdamRuler")]
public property int DeciamlInterval sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The deciaml interval size.") */
/** @attribute DefaultValueAttribute(1) */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public int get_DeciamlInterval();

/** property */
public void set_DeciamlInterval(int value);
JScript
public function get DeciamlInterval() : int

public function set DeciamlInterval(value : int);

See Also

AdamRuler Class
Advantech.Graph Namespace


ForeColor Property

AdamRuler.ForeColor Property
[image]

Get/set the ForeColor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property ForeColor As Color
C#
public override Color ForeColor { get; set; }
C++
public override property Color ForeColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_ForeColor();

/** property */
public void set_ForeColor(Color value);
JScript
public function get ForeColor() : Color

public function set ForeColor(value : Color);

See Also

AdamRuler Class
Advantech.Graph Namespace


GridLineSize Property

AdamRuler.GridLineSize Property
[image]

Get/set the distance between two grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRuler"), _
DefaultValueAttribute(10), _
DescriptionAttribute("The distance between two grid lines.")>
Public Property GridLineSize As Integer
C#
[CategoryAttribute("AdamRuler")]
[DefaultValueAttribute(10)]
[DescriptionAttribute("The distance between two grid lines.")]
public int GridLineSize { get; set; }
C++
[CategoryAttribute(L"AdamRuler")]
[DefaultValueAttribute(10)]
[DescriptionAttribute(L"The distance between two grid lines.")]
public property int GridLineSize sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamRuler") */
/** @attribute DefaultValueAttribute(10) */
/** @attribute DescriptionAttribute("The distance between two grid lines.") */
/** property */
public int get_GridLineSize();

/** property */
public void set_GridLineSize(int value);
JScript
public function get GridLineSize() : int

public function set GridLineSize(value : int);

See Also

AdamRuler Class
Advantech.Graph Namespace


LinearGradientMode Property

AdamRuler.LinearGradientMode Property
[image]

LinearGradientMode

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("LinearGradientMode"), _
CategoryAttribute("AdamRuler")>
Public Property LinearGradientMode As LinearGradientMode
C#
[DescriptionAttribute("LinearGradientMode")]
[CategoryAttribute("AdamRuler")]
public LinearGradientMode LinearGradientMode { get; set; }
C++
[DescriptionAttribute(L"LinearGradientMode")]
[CategoryAttribute(L"AdamRuler")]
public property LinearGradientMode LinearGradientMode sealed {
LinearGradientMode get();
void set(LinearGradientMode value);
}
J#
/** @attribute DescriptionAttribute("LinearGradientMode") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public LinearGradientMode get_LinearGradientMode();

/** property */
public void set_LinearGradientMode(LinearGradientMode value);
JScript
public function get LinearGradientMode() : LinearGradientMode

public function set LinearGradientMode(value : LinearGradientMode);

See Also

AdamRuler Class
Advantech.Graph Namespace


Orientation Property

AdamRuler.Orientation Property
[image]

Horizontal or vertical layout

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Horizontal or vertical layout."), _
CategoryAttribute("AdamRuler")>
Public Property Orientation As enumOrientation
C#
[DescriptionAttribute("Horizontal or vertical layout.")]
[CategoryAttribute("AdamRuler")]
public enumOrientation Orientation { get; set; }
C++
[DescriptionAttribute(L"Horizontal or vertical layout.")]
[CategoryAttribute(L"AdamRuler")]
public property enumOrientation Orientation sealed {
enumOrientation get();
void set(enumOrientation value);
}
J#
/** @attribute DescriptionAttribute("Horizontal or vertical layout.") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public enumOrientation get_Orientation();

/** property */
public void set_Orientation(enumOrientation value);
JScript
public function get Orientation() : enumOrientation

public function set Orientation(value : enumOrientation);

See Also

AdamRuler Class
Advantech.Graph Namespace


Registration Property

AdamRuler.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The registration key."), _
CategoryAttribute("AdamRuler")>
Public Property Registration As String
C#
[DescriptionAttribute("The registration key.")]
[CategoryAttribute("AdamRuler")]
public string Registration { get; set; }
C++
[DescriptionAttribute(L"The registration key.")]
[CategoryAttribute(L"AdamRuler")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The registration key.") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamRuler Class
Advantech.Graph Namespace


RulerColor Property

AdamRuler.RulerColor Property
[image]

Set color of Ruler control

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Set color of Ruler control."), _
CategoryAttribute("AdamRuler")>
Public Property RulerColor As Color
C#
[DescriptionAttribute("Set color of Ruler control.")]
[CategoryAttribute("AdamRuler")]
public Color RulerColor { get; set; }
C++
[DescriptionAttribute(L"Set color of Ruler control.")]
[CategoryAttribute(L"AdamRuler")]
public property Color RulerColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("Set color of Ruler control.") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public Color get_RulerColor();

/** property */
public void set_RulerColor(Color value);
JScript
public function get RulerColor() : Color

public function set RulerColor(value : Color);

See Also

AdamRuler Class
Advantech.Graph Namespace


ShowLargeScale Property

AdamRuler.ShowLargeScale Property
[image]

Shows Large Scale marking

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Show large scale."), _
CategoryAttribute("AdamRuler")>
Public Property ShowLargeScale As Boolean
C#
[DescriptionAttribute("Show large scale.")]
[CategoryAttribute("AdamRuler")]
public bool ShowLargeScale { get; set; }
C++
[DescriptionAttribute(L"Show large scale.")]
[CategoryAttribute(L"AdamRuler")]
public property bool ShowLargeScale sealed {
bool get();
void set(bool value);
}
J#
/** @attribute DescriptionAttribute("Show large scale.") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public bool get_ShowLargeScale();

/** property */
public void set_ShowLargeScale(bool value);
JScript
public function get ShowLargeScale() : bool

public function set ShowLargeScale(value : bool);

See Also

AdamRuler Class
Advantech.Graph Namespace


ShowSmallScale Property

AdamRuler.ShowSmallScale Property
[image]

Shows Small Scale marking.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Show small scale."), _
CategoryAttribute("AdamRuler")>
Public Property ShowSmallScale As Boolean
C#
[DescriptionAttribute("Show small scale.")]
[CategoryAttribute("AdamRuler")]
public bool ShowSmallScale { get; set; }
C++
[DescriptionAttribute(L"Show small scale.")]
[CategoryAttribute(L"AdamRuler")]
public property bool ShowSmallScale sealed {
bool get();
void set(bool value);
}
J#
/** @attribute DescriptionAttribute("Show small scale.") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public bool get_ShowSmallScale();

/** property */
public void set_ShowSmallScale(bool value);
JScript
public function get ShowSmallScale() : bool

public function set ShowSmallScale(value : bool);

See Also

AdamRuler Class
Advantech.Graph Namespace


ShowtickIndex Property

AdamRuler.ShowtickIndex Property
[image]

Shows tick index marking

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRuler"), _
DescriptionAttribute("Shows tick index marking.")>
Public Property ShowtickIndex As Boolean
C#
[CategoryAttribute("AdamRuler")]
[DescriptionAttribute("Shows tick index marking.")]
public bool ShowtickIndex { get; set; }
C++
[CategoryAttribute(L"AdamRuler")]
[DescriptionAttribute(L"Shows tick index marking.")]
public property bool ShowtickIndex sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("AdamRuler") */
/** @attribute DescriptionAttribute("Shows tick index marking.") */
/** property */
public bool get_ShowtickIndex();

/** property */
public void set_ShowtickIndex(bool value);
JScript
public function get ShowtickIndex() : bool

public function set ShowtickIndex(value : bool);

See Also

AdamRuler Class
Advantech.Graph Namespace


StartValue Property

AdamRuler.StartValue Property
[image]

Current Value of Ruler control

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The current value of Ruler control."), _
CategoryAttribute("AdamRuler")>
Public Property StartValue As Integer
C#
[DescriptionAttribute("The current value of Ruler control.")]
[CategoryAttribute("AdamRuler")]
public int StartValue { get; set; }
C++
[DescriptionAttribute(L"The current value of Ruler control.")]
[CategoryAttribute(L"AdamRuler")]
public property int StartValue sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The current value of Ruler control.") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public int get_StartValue();

/** property */
public void set_StartValue(int value);
JScript
public function get StartValue() : int

public function set StartValue(value : int);

See Also

AdamRuler Class
Advantech.Graph Namespace


StepSize Property

AdamRuler.StepSize Property
[image]

Get/set the X-axis movement steps.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The X-axis movement steps."), _
DefaultValueAttribute(1), _
CategoryAttribute("AdamRuler")>
Public Property StepSize As Integer
C#
[DescriptionAttribute("The X-axis movement steps.")]
[DefaultValueAttribute(1)]
[CategoryAttribute("AdamRuler")]
public int StepSize { get; set; }
C++
[DescriptionAttribute(L"The X-axis movement steps.")]
[DefaultValueAttribute(1)]
[CategoryAttribute(L"AdamRuler")]
public property int StepSize sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The X-axis movement steps.") */
/** @attribute DefaultValueAttribute(1) */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public int get_StepSize();

/** property */
public void set_StepSize(int value);
JScript
public function get StepSize() : int

public function set StepSize(value : int);

See Also

AdamRuler Class
Advantech.Graph Namespace


SurroundColor Property

AdamRuler.SurroundColor Property
[image]

Get/set the color of the surrounded line.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the surrounded line."), _
CategoryAttribute("AdamRuler")>
Public Property SurroundColor As Color
C#
[DescriptionAttribute("The color of the surrounded line.")]
[CategoryAttribute("AdamRuler")]
public Color SurroundColor { get; set; }
C++
[DescriptionAttribute(L"The color of the surrounded line.")]
[CategoryAttribute(L"AdamRuler")]
public property Color SurroundColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the surrounded line.") */
/** @attribute CategoryAttribute("AdamRuler") */
/** property */
public Color get_SurroundColor();

/** property */
public void set_SurroundColor(Color value);
JScript
public function get SurroundColor() : Color

public function set SurroundColor(value : Color);

See Also

AdamRuler Class
Advantech.Graph Namespace


Unit Property

AdamRuler.Unit Property
[image]

Get/set the unit string.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamRuler"), _
DescriptionAttribute("The unit string.")>
Public Property Unit As String
C#
[CategoryAttribute("AdamRuler")]
[DescriptionAttribute("The unit string.")]
public string Unit { get; set; }
C++
[CategoryAttribute(L"AdamRuler")]
[DescriptionAttribute(L"The unit string.")]
public property string Unit sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamRuler") */
/** @attribute DescriptionAttribute("The unit string.") */
/** property */
public string get_Unit();

/** property */
public void set_Unit(string value);
JScript
public function get Unit() : String

public function set Unit(value : String);

See Also

AdamRuler Class
Advantech.Graph Namespace


Methods

AdamRuler Methods
[image]

Public Methods

 | Name | Description
Public method | ClearGraph | Force to clear the graph.
Public method | UpdateGraph | Force to update the graph.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | DrawGridLines | Draw the grid lines.
Family method | OnPaint | Overridden. The OnPaint event.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamRuler Class
Advantech.Graph Namespace


ClearGraph Method

AdamRuler.ClearGraph Method
[image]

Force to clear the graph.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearGraph()
C#
public void ClearGraph()
C++
public:
void ClearGraph() sealed
J#
public void ClearGraph()
JScript
public function ClearGraph()

See Also

AdamRuler Class
Advantech.Graph Namespace


Dispose Method

AdamRuler.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamRuler Class
Advantech.Graph Namespace


DrawGridLines Method

AdamRuler.DrawGridLines Method
[image]

Draw the grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Sub DrawGridLines( _
ByVal panelGraph As Graphics _
)
C#
protected void DrawGridLines(
Graphics panelGraph
)
C++
protected:
void DrawGridLines(
Graphics panelGraph
) sealed
J#
protected void DrawGridLines(
Graphics panelGraph
)
JScript
protected function DrawGridLines(
panelGraph : Graphics
)

See Also

AdamRuler Class
Advantech.Graph Namespace


OnPaint Method

AdamRuler.OnPaint Method
[image]

The OnPaint event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamRuler Class
Advantech.Graph Namespace


OnResize Method

AdamRuler.OnResize Method
[image]

The OnResize event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e

See Also

AdamRuler Class
Advantech.Graph Namespace


UpdateGraph Method

AdamRuler.UpdateGraph Method
[image]

Force to update the graph.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateGraph()
C#
public void UpdateGraph()
C++
public:
void UpdateGraph() sealed
J#
public void UpdateGraph()
JScript
public function UpdateGraph()

See Also

AdamRuler Class
Advantech.Graph Namespace


AdamSignalIndicator Class

AdamSignalIndicator Class
See Also Example Members
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamSignalIndicator))>
Public Class AdamSignalIndicator
Inherits UserControl
C#
[ToolboxBitmapAttribute(typeof(AdamSignalIndicator))]
public class AdamSignalIndicator : UserControl
C++
[ToolboxBitmapAttribute(typeof(AdamSignalIndicator))]
ref class AdamSignalIndicator : UserControl
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamSignalIndicator)) */
public class AdamSignalIndicator extends UserControl
JScript
public
ToolboxBitmapAttribute(typeof(AdamSignalIndicator))
class AdamSignalIndicator extends UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Advantech.Graph.AdamSignalIndicator

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamSignalIndicator Members
Advantech.Graph Namespace


AdamSignalIndicator Members

AdamSignalIndicator Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AdamSignalIndicator.

Public Constructors

 | Name | Description
Public method | AdamSignalIndicator | The AdamSignalIndicator constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | IndicatorOffColor | Get/set the color of the indicator when it is Off.
Public property | IndicatorOnColor | Get/set the color of the indicator bar when it is On.
Public property | Maximum | Get/set the maximum value of the indicator.
Public property | Minimum | Get/set the minimum value of the indicator.
Public property | Shape | Get/set the shape of the indicator.
Public property | Value | Get/set the value of the indicator.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


AdamSignalIndicator Constructor

AdamSignalIndicator Constructor
[image]

The AdamSignalIndicator constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamSignalIndicator()
C++
public:
AdamSignalIndicator() sealed
J#
public AdamSignalIndicator()
JScript
public function AdamSignalIndicator()

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


Properties

AdamSignalIndicator Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the BackColor of the control.
Public property | IndicatorOffColor | Get/set the color of the indicator when it is Off.
Public property | IndicatorOnColor | Get/set the color of the indicator bar when it is On.
Public property | Maximum | Get/set the maximum value of the indicator.
Public property | Minimum | Get/set the minimum value of the indicator.
Public property | Shape | Get/set the shape of the indicator.
Public property | Value | Get/set the value of the indicator.
Top

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


BackColor Property

AdamSignalIndicator.BackColor Property
[image]

Get/set the BackColor of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


IndicatorOffColor Property

AdamSignalIndicator.IndicatorOffColor Property
[image]

Get/set the color of the indicator when it is Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The color of the indicator when it is Off.")>
Public Property IndicatorOffColor As Color
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The color of the indicator when it is Off.")]
public Color IndicatorOffColor { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The color of the indicator when it is Off.")]
public property Color IndicatorOffColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The color of the indicator when it is Off.") */
/** property */
public Color get_IndicatorOffColor();

/** property */
public void set_IndicatorOffColor(Color value);
JScript
public function get IndicatorOffColor() : Color

public function set IndicatorOffColor(value : Color);

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


IndicatorOnColor Property

AdamSignalIndicator.IndicatorOnColor Property
[image]

Get/set the color of the indicator bar when it is On.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The color of the indicator when it is On.")>
Public Property IndicatorOnColor As Color
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The color of the indicator when it is On.")]
public Color IndicatorOnColor { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The color of the indicator when it is On.")]
public property Color IndicatorOnColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The color of the indicator when it is On.") */
/** property */
public Color get_IndicatorOnColor();

/** property */
public void set_IndicatorOnColor(Color value);
JScript
public function get IndicatorOnColor() : Color

public function set IndicatorOnColor(value : Color);

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


Maximum Property

AdamSignalIndicator.Maximum Property
[image]

Get/set the maximum value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The maximum value of the indicator."), _
CategoryAttribute("AdamIndicator")>
Public Property Maximum As Single
C#
[DescriptionAttribute("The maximum value of the indicator.")]
[CategoryAttribute("AdamIndicator")]
public float Maximum { get; set; }
C++
[DescriptionAttribute(L"The maximum value of the indicator.")]
[CategoryAttribute(L"AdamIndicator")]
public property float Maximum sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The maximum value of the indicator.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public float get_Maximum();

/** property */
public void set_Maximum(float value);
JScript
public function get Maximum() : float

public function set Maximum(value : float);

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


Minimum Property

AdamSignalIndicator.Minimum Property
[image]

Get/set the minimum value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The minimum value of the indicator.")>
Public Property Minimum As Single
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The minimum value of the indicator.")]
public float Minimum { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The minimum value of the indicator.")]
public property float Minimum sealed {
float get();
void set(float value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The minimum value of the indicator.") */
/** property */
public float get_Minimum();

/** property */
public void set_Minimum(float value);
JScript
public function get Minimum() : float

public function set Minimum(value : float);

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


Shape Property

AdamSignalIndicator.Shape Property
[image]

Get/set the shape of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamIndicator"), _
DescriptionAttribute("The shape of the indicator.")>
Public Property Shape As Shape
C#
[CategoryAttribute("AdamIndicator")]
[DescriptionAttribute("The shape of the indicator.")]
public Shape Shape { get; set; }
C++
[CategoryAttribute(L"AdamIndicator")]
[DescriptionAttribute(L"The shape of the indicator.")]
public property Shape Shape sealed {
Shape get();
void set(Shape value);
}
J#
/** @attribute CategoryAttribute("AdamIndicator") */
/** @attribute DescriptionAttribute("The shape of the indicator.") */
/** property */
public Shape get_Shape();

/** property */
public void set_Shape(Shape value);
JScript
public function get Shape() : Shape

public function set Shape(value : Shape);

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


Value Property

AdamSignalIndicator.Value Property
[image]

Get/set the value of the indicator.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The value of the indicator."), _
CategoryAttribute("AdamIndicator")>
Public Property Value As Single
C#
[DescriptionAttribute("The value of the indicator.")]
[CategoryAttribute("AdamIndicator")]
public float Value { get; set; }
C++
[DescriptionAttribute(L"The value of the indicator.")]
[CategoryAttribute(L"AdamIndicator")]
public property float Value sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The value of the indicator.") */
/** @attribute CategoryAttribute("AdamIndicator") */
/** property */
public float get_Value();

/** property */
public void set_Value(float value);
JScript
public function get Value() : float

public function set Value(value : float);

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


Methods

AdamSignalIndicator Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


Dispose Method

AdamSignalIndicator.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


OnPaint Method

AdamSignalIndicator.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamSignalIndicator Class
Advantech.Graph Namespace


AdamSocketComponent Class

AdamSocketComponent Class
See Also Example Members
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamSocketComponent), "Pictures.AdamSocketComponent.bmp")>
Public Class AdamSocketComponent
Inherits Component
C#
[ToolboxBitmapAttribute(typeof(AdamSocketComponent), "Pictures.AdamSocketComponent.bmp")]
public class AdamSocketComponent : Component
C++
[ToolboxBitmapAttribute(typeof(AdamSocketComponent), L"Pictures.AdamSocketComponent.bmp")]
ref class AdamSocketComponent : Component
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamSocketComponent), "Pictures.AdamSocketComponent.bmp") */
public class AdamSocketComponent extends Component
JScript
public
ToolboxBitmapAttribute(typeof(AdamSocketComponent), "Pictures.AdamSocketComponent.bmp")
class AdamSocketComponent extends Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Advantech.Graph.AdamSocketComponent

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamSocketComponent Members
Advantech.Graph Namespace


AdamSocketComponent Members

AdamSocketComponent Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by AdamSocketComponent.

Public Constructors

Name | Description
AdamSocketComponent | Overloaded.
Top

Public Properties

 | Name | Description
Public property | AdamProtocolType | Get/set the protocol type which the component uses.
Public property | AdamSeriesType | Get/set the Adam series type of the connecting module.
Public property | AdamSocketObject | The AdamSocket object.
Public property | Connected | The connection status.
Public property | ConnectTimeout | Get/set the connecting timeout.
Public property | IPAddress | Get/set the IP address which the component connects to.
Public property | LastError | The last error code when function return false.
Public property | RecvTimeout | Get/set the receiving timeout.
Public property | SendTimeout | Get/set the sending timeout.
Top

Public Methods

 | Name | Description
Public method | AdamTransaction | Send and receive ASCII command for ADAM modules
Public method | Alarm | ADAM-5000TCP ADAM-6000 Alarm object
Public method | AnalogInput | ADAM-5000TCP ADAM-6000 AnalogInput object
Public method | AnalogOutput | ADAM-5000TCP ADAM-6000 AnalogOutput object
Public method | Configuration | ADAM-5000TCP ADAM-6000 Configuration object
Public method | Connect | Connect the remote module.
Public method | Counter | ADAM-5000TCP ADAM-6000 Counter object
Public method | DigitalInput | ADAM-5000TCP ADAM-6000 DigitalInput object
Public method | DigitalOutput | ADAM-5000TCP ADAM-6000 DigitalOutput object
Public method | Disconnect | Disconnect the remote module.
Public method | Modbus | ADAM-5000TCP ADAM-6000 Modbus object
Public method | Pid | ADAM-6000 PID object
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Top

Explicit Interface Implementations

Name | Description
AdamSocketComponent | Overloaded.
Top

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AdamSocketComponent Constructor

AdamSocketComponent Constructor

Overload List

 | Name | Description
Public method | AdamSocketComponent | AdamSocketComponent class. The class is based on AdamSocket class. The class is very useful for using with Advantech Adam serial devices.
Public method | AdamSocketComponent (IContainer) | AdamSocketComponent class. The class is based on AdamSocket class. The class is very useful for using with Advantech Adam serial devices.

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AdamSocketComponent Constructor ()

AdamSocketComponent Constructor ()
See Also Example
[image]

AdamSocketComponent class. The class is based on AdamSocket class. The class is very useful for using with Advantech Adam serial devices.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamSocketComponent()
C++
public:
AdamSocketComponent() sealed
J#
public AdamSocketComponent()
JScript
public function AdamSocketComponent()

See Also

AdamSocketComponent Class
Advantech.Graph Namespace
AdamSocketComponent Constructor Overload List


AdamSocketComponent Constructor (IContainer)

AdamSocketComponent Constructor (IContainer)
See Also Example
[image]

AdamSocketComponent class. The class is based on AdamSocket class. The class is very useful for using with Advantech Adam serial devices.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal container As IContainer _
)
C#
public AdamSocketComponent(
IContainer container
)
C++
public:
AdamSocketComponent(
IContainer container
) sealed
J#
public AdamSocketComponent(
IContainer container
)
JScript
public function AdamSocketComponent(
container : IContainer
)

Parameters

container
Container

See Also

AdamSocketComponent Class
Advantech.Graph Namespace
AdamSocketComponent Constructor Overload List


Properties

AdamSocketComponent Properties
[image]

Public Properties

 | Name | Description
Public property | AdamProtocolType | Get/set the protocol type which the component uses.
Public property | AdamSeriesType | Get/set the Adam series type of the connecting module.
Public property | AdamSocketObject | The AdamSocket object.
Public property | Connected | The connection status.
Public property | ConnectTimeout | Get/set the connecting timeout.
Public property | IPAddress | Get/set the IP address which the component connects to.
Public property | LastError | The last error code when function return false.
Public property | RecvTimeout | Get/set the receiving timeout.
Public property | SendTimeout | Get/set the sending timeout.
Top

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AdamProtocolType Property

AdamSocketComponent.AdamProtocolType Property
[image]

Get/set the protocol type which the component uses.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSocketComponent"), _
DescriptionAttribute("The protocol type which the component uses. Only UDP and TCP are acceptable.")>
Public Property AdamProtocolType As ProtocolType
C#
[CategoryAttribute("AdamSocketComponent")]
[DescriptionAttribute("The protocol type which the component uses. Only UDP and TCP are acceptable.")]
public ProtocolType AdamProtocolType { get; set; }
C++
[CategoryAttribute(L"AdamSocketComponent")]
[DescriptionAttribute(L"The protocol type which the component uses. Only UDP and TCP are acceptable.")]
public property ProtocolType AdamProtocolType sealed {
ProtocolType get();
void set(ProtocolType value);
}
J#
/** @attribute CategoryAttribute("AdamSocketComponent") */
/** @attribute DescriptionAttribute("The protocol type which the component uses. Only UDP and TCP are acceptable.") */
/** property */
public ProtocolType get_AdamProtocolType();

/** property */
public void set_AdamProtocolType(ProtocolType value);
JScript
public function get AdamProtocolType() : ProtocolType

public function set AdamProtocolType(value : ProtocolType);

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AdamSeriesType Property

AdamSocketComponent.AdamSeriesType Property
[image]

Get/set the Adam series type of the connecting module.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSocketComponent"), _
DescriptionAttribute("The Adam series type of the connecting module. Only Adam5000Tcp and Adam6000 are acceptable.")>
Public Property AdamSeriesType As AdamType
C#
[CategoryAttribute("AdamSocketComponent")]
[DescriptionAttribute("The Adam series type of the connecting module. Only Adam5000Tcp and Adam6000 are acceptable.")]
public AdamType AdamSeriesType { get; set; }
C++
[CategoryAttribute(L"AdamSocketComponent")]
[DescriptionAttribute(L"The Adam series type of the connecting module. Only Adam5000Tcp and Adam6000 are acceptable.")]
public property AdamType AdamSeriesType sealed {
AdamType get();
void set(AdamType value);
}
J#
/** @attribute CategoryAttribute("AdamSocketComponent") */
/** @attribute DescriptionAttribute("The Adam series type of the connecting module. Only Adam5000Tcp and Adam6000 are acceptable.") */
/** property */
public AdamType get_AdamSeriesType();

/** property */
public void set_AdamSeriesType(AdamType value);
JScript
public function get AdamSeriesType() : AdamType

public function set AdamSeriesType(value : AdamType);

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AdamSocketObject Property

AdamSocketComponent.AdamSocketObject Property
[image]

The AdamSocket object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdamSocketObject As AdamSocket
C#
public AdamSocket AdamSocketObject { get; }
C++
public property AdamSocket AdamSocketObject sealed {
AdamSocket get();
}
J#
/** property */
public AdamSocket get_AdamSocketObject();
JScript
public function get AdamSocketObject() : AdamSocket

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Connected Property

AdamSocketComponent.Connected Property
[image]

The connection status.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Connected As Boolean
C#
public bool Connected { get; }
C++
public property bool Connected sealed {
bool get();
}
J#
/** property */
public bool get_Connected();
JScript
public function get Connected() : bool

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


ConnectTimeout Property

AdamSocketComponent.ConnectTimeout Property
[image]

Get/set the connecting timeout.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSocketComponent"), _
DescriptionAttribute("The connecting timeout. The value must be greater than zero.")>
Public Property ConnectTimeout As Integer
C#
[CategoryAttribute("AdamSocketComponent")]
[DescriptionAttribute("The connecting timeout. The value must be greater than zero.")]
public int ConnectTimeout { get; set; }
C++
[CategoryAttribute(L"AdamSocketComponent")]
[DescriptionAttribute(L"The connecting timeout. The value must be greater than zero.")]
public property int ConnectTimeout sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamSocketComponent") */
/** @attribute DescriptionAttribute("The connecting timeout. The value must be greater than zero.") */
/** property */
public int get_ConnectTimeout();

/** property */
public void set_ConnectTimeout(int value);
JScript
public function get ConnectTimeout() : int

public function set ConnectTimeout(value : int);

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


IPAddress Property

AdamSocketComponent.IPAddress Property
[image]

Get/set the IP address which the component connects to.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The IP address which the component connects to."), _
CategoryAttribute("AdamSocketComponent")>
Public Property IPAddress As String
C#
[DescriptionAttribute("The IP address which the component connects to.")]
[CategoryAttribute("AdamSocketComponent")]
public string IPAddress { get; set; }
C++
[DescriptionAttribute(L"The IP address which the component connects to.")]
[CategoryAttribute(L"AdamSocketComponent")]
public property string IPAddress sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The IP address which the component connects to.") */
/** @attribute CategoryAttribute("AdamSocketComponent") */
/** property */
public string get_IPAddress();

/** property */
public void set_IPAddress(string value);
JScript
public function get IPAddress() : String

public function set IPAddress(value : String);

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


LastError Property

AdamSocketComponent.LastError Property
[image]

The last error code when function return false.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastError As ErrorCode
C#
public ErrorCode LastError { get; }
C++
public property ErrorCode LastError sealed {
ErrorCode get();
}
J#
/** property */
public ErrorCode get_LastError();
JScript
public function get LastError() : ErrorCode

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


RecvTimeout Property

AdamSocketComponent.RecvTimeout Property
[image]

Get/set the receiving timeout.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSocketComponent"), _
DescriptionAttribute("The receiving timeout. The value must be greater than zero.")>
Public Property RecvTimeout As Integer
C#
[CategoryAttribute("AdamSocketComponent")]
[DescriptionAttribute("The receiving timeout. The value must be greater than zero.")]
public int RecvTimeout { get; set; }
C++
[CategoryAttribute(L"AdamSocketComponent")]
[DescriptionAttribute(L"The receiving timeout. The value must be greater than zero.")]
public property int RecvTimeout sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamSocketComponent") */
/** @attribute DescriptionAttribute("The receiving timeout. The value must be greater than zero.") */
/** property */
public int get_RecvTimeout();

/** property */
public void set_RecvTimeout(int value);
JScript
public function get RecvTimeout() : int

public function set RecvTimeout(value : int);

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


SendTimeout Property

AdamSocketComponent.SendTimeout Property
[image]

Get/set the sending timeout.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The sending timeout. The value must be greater than zero."), _
CategoryAttribute("AdamSocketComponent")>
Public Property SendTimeout As Integer
C#
[DescriptionAttribute("The sending timeout. The value must be greater than zero.")]
[CategoryAttribute("AdamSocketComponent")]
public int SendTimeout { get; set; }
C++
[DescriptionAttribute(L"The sending timeout. The value must be greater than zero.")]
[CategoryAttribute(L"AdamSocketComponent")]
public property int SendTimeout sealed {
int get();
void set(int value);
}
J#
/** @attribute DescriptionAttribute("The sending timeout. The value must be greater than zero.") */
/** @attribute CategoryAttribute("AdamSocketComponent") */
/** property */
public int get_SendTimeout();

/** property */
public void set_SendTimeout(int value);
JScript
public function get SendTimeout() : int

public function set SendTimeout(value : int);

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Methods

AdamSocketComponent Methods
[image]

Public Methods

 | Name | Description
Public method | AdamTransaction | Send and receive ASCII command for ADAM modules
Public method | Alarm | ADAM-5000TCP ADAM-6000 Alarm object
Public method | AnalogInput | ADAM-5000TCP ADAM-6000 AnalogInput object
Public method | AnalogOutput | ADAM-5000TCP ADAM-6000 AnalogOutput object
Public method | Configuration | ADAM-5000TCP ADAM-6000 Configuration object
Public method | Connect | Connect the remote module.
Public method | Counter | ADAM-5000TCP ADAM-6000 Counter object
Public method | DigitalInput | ADAM-5000TCP ADAM-6000 DigitalInput object
Public method | DigitalOutput | ADAM-5000TCP ADAM-6000 DigitalOutput object
Public method | Disconnect | Disconnect the remote module.
Public method | Modbus | ADAM-5000TCP ADAM-6000 Modbus object
Public method | Pid | ADAM-6000 PID object
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Top

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AdamTransaction Method

AdamSocketComponent.AdamTransaction Method
[image]

Send and receive ASCII command for ADAM modules

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function AdamTransaction( _
ByVal i_szSend As String, _
<OutAttribute> ByRef o_szRecv As String _
) As Boolean
C#
public bool AdamTransaction(
string i_szSend,
out string o_szRecv
)
C++
public:
bool AdamTransaction(
String i_szSend,
[OutAttribute] String% o_szRecv
) sealed
J#
public bool AdamTransaction(
string i_szSend,
/** @attribute OutAttribute() */ /** @ref */ string o_szRecv
)
JScript
public function AdamTransaction(
i_szSend : String,
OutAttribute o_szRecv : String
) : bool

Parameters

i_szSend
The command string to send
o_szRecv
The responsed string received

Return Value

True if the transaction success.

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Alarm Method

AdamSocketComponent.Alarm Method
[image]

ADAM-5000TCP ADAM-6000 Alarm object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Alarm() As Alarm
C#
public Alarm Alarm()
C++
public:
Alarm Alarm() sealed
J#
public Alarm Alarm()
JScript
public function Alarm() : Alarm

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AnalogInput Method

AdamSocketComponent.AnalogInput Method
[image]

ADAM-5000TCP ADAM-6000 AnalogInput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogInput() As AnalogInput
C#
public AnalogInput AnalogInput()
C++
public:
AnalogInput AnalogInput() sealed
J#
public AnalogInput AnalogInput()
JScript
public function AnalogInput() : AnalogInput

Return Value

The AnalogInput object

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AnalogOutput Method

AdamSocketComponent.AnalogOutput Method
[image]

ADAM-5000TCP ADAM-6000 AnalogOutput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function AnalogOutput() As AnalogOutput
C#
public AnalogOutput AnalogOutput()
C++
public:
AnalogOutput AnalogOutput() sealed
J#
public AnalogOutput AnalogOutput()
JScript
public function AnalogOutput() : AnalogOutput

Return Value

The AnalogOutput object

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Configuration Method

AdamSocketComponent.Configuration Method
[image]

ADAM-5000TCP ADAM-6000 Configuration object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Configuration() As Configuration
C#
public Configuration Configuration()
C++
public:
Configuration Configuration() sealed
J#
public Configuration Configuration()
JScript
public function Configuration() : Configuration

Return Value

The Configuration object

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Connect Method

AdamSocketComponent.Connect Method
[image]

Connect the remote module.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Connect() As Boolean
C#
public bool Connect()
C++
public:
bool Connect() sealed
J#
public bool Connect()
JScript
public function Connect() : bool

Return Value

True, if successed, otherwise false.

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Counter Method

AdamSocketComponent.Counter Method
[image]

ADAM-5000TCP ADAM-6000 Counter object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Counter() As Counter
C#
public Counter Counter()
C++
public:
Counter Counter() sealed
J#
public Counter Counter()
JScript
public function Counter() : Counter

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


DigitalInput Method

AdamSocketComponent.DigitalInput Method
[image]

ADAM-5000TCP ADAM-6000 DigitalInput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalInput() As DigitalInput
C#
public DigitalInput DigitalInput()
C++
public:
DigitalInput DigitalInput() sealed
J#
public DigitalInput DigitalInput()
JScript
public function DigitalInput() : DigitalInput

Return Value

The DigitalInput object

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


DigitalOutput Method

AdamSocketComponent.DigitalOutput Method
[image]

ADAM-5000TCP ADAM-6000 DigitalOutput object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function DigitalOutput() As DigitalOutput
C#
public DigitalOutput DigitalOutput()
C++
public:
DigitalOutput DigitalOutput() sealed
J#
public DigitalOutput DigitalOutput()
JScript
public function DigitalOutput() : DigitalOutput

Return Value

The DigitalOutput object

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Disconnect Method

AdamSocketComponent.Disconnect Method
[image]

Disconnect the remote module.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub Disconnect()
C#
public void Disconnect()
C++
public:
void Disconnect() sealed
J#
public void Disconnect()
JScript
public function Disconnect()

Return Value

True, if successed, otherwise false.

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Dispose Method

AdamSocketComponent.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Modbus Method

AdamSocketComponent.Modbus Method
[image]

ADAM-5000TCP ADAM-6000 Modbus object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Modbus() As Modbus
C#
public Modbus Modbus()
C++
public:
Modbus Modbus() sealed
J#
public Modbus Modbus()
JScript
public function Modbus() : Modbus

Return Value

The Modbus object

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


Pid Method

AdamSocketComponent.Pid Method
[image]

ADAM-6000 PID object

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Function Pid() As PID
C#
public PID Pid()
C++
public:
PID Pid() sealed
J#
public PID Pid()
JScript
public function Pid() : PID

See Also

AdamSocketComponent Class
Advantech.Graph Namespace


AdamSwitch Class

AdamSwitch Class
See Also Example Members
[image]

The AdamSwitch class.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamSwitch), "Pictures.AdamSwitch.bmp")>
Public Class AdamSwitch
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamSwitch), "Pictures.AdamSwitch.bmp")]
public class AdamSwitch : Control
C++
[ToolboxBitmapAttribute(typeof(AdamSwitch), L"Pictures.AdamSwitch.bmp")]
ref class AdamSwitch : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamSwitch), "Pictures.AdamSwitch.bmp") */
public class AdamSwitch extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamSwitch), "Pictures.AdamSwitch.bmp")
class AdamSwitch extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamSwitch

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamSwitch Members
Advantech.Graph Namespace


AdamSwitch Members

AdamSwitch Members
See Also Example Constructors Properties Methods
[image]

The AdamSwitch class.

The following tables list the members exposed by AdamSwitch.

Public Constructors

 | Name | Description
Public method | AdamSwitch | The AdamSwitch constructor.
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | Registration | Get/set the registration key.
Public property | StretchImage | Get/set whether the image should be stretched.
Public property | SwitchOffImage | Get/set the image when the switch Off.
Public property | SwitchOffString | Get/set the string when the switch Off.
Public property | SwitchOnImage | Get/set the image when the switch On.
Public property | SwitchOnString | Get/set the string when the switch On.
Public property | Value | Get/set the swicth to be On or Off.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamSwitch Class
Advantech.Graph Namespace


AdamSwitch Constructor

AdamSwitch Constructor
[image]

The AdamSwitch constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamSwitch()
C++
public:
AdamSwitch() sealed
J#
public AdamSwitch()
JScript
public function AdamSwitch()

See Also

AdamSwitch Class
Advantech.Graph Namespace


Properties

AdamSwitch Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | Registration | Get/set the registration key.
Public property | StretchImage | Get/set whether the image should be stretched.
Public property | SwitchOffImage | Get/set the image when the switch Off.
Public property | SwitchOffString | Get/set the string when the switch Off.
Public property | SwitchOnImage | Get/set the image when the switch On.
Public property | SwitchOnString | Get/set the string when the switch On.
Public property | Value | Get/set the swicth to be On or Off.
Top

See Also

AdamSwitch Class
Advantech.Graph Namespace


BackColor Property

AdamSwitch.BackColor Property
[image]

Get/set the background color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamSwitch Class
Advantech.Graph Namespace


Registration Property

AdamSwitch.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The registration key."), _
CategoryAttribute("AdamSwitch")>
Public Property Registration As String
C#
[DescriptionAttribute("The registration key.")]
[CategoryAttribute("AdamSwitch")]
public string Registration { get; set; }
C++
[DescriptionAttribute(L"The registration key.")]
[CategoryAttribute(L"AdamSwitch")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The registration key.") */
/** @attribute CategoryAttribute("AdamSwitch") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamSwitch Class
Advantech.Graph Namespace


StretchImage Property

AdamSwitch.StretchImage Property
[image]

Get/set whether the image should be stretched.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Determines whether the image should be stretched."), _
CategoryAttribute("AdamSwitch")>
Public Property StretchImage As Boolean
C#
[DescriptionAttribute("Determines whether the image should be stretched.")]
[CategoryAttribute("AdamSwitch")]
public bool StretchImage { get; set; }
C++
[DescriptionAttribute(L"Determines whether the image should be stretched.")]
[CategoryAttribute(L"AdamSwitch")]
public property bool StretchImage sealed {
bool get();
void set(bool value);
}
J#
/** @attribute DescriptionAttribute("Determines whether the image should be stretched.") */
/** @attribute CategoryAttribute("AdamSwitch") */
/** property */
public bool get_StretchImage();

/** property */
public void set_StretchImage(bool value);
JScript
public function get StretchImage() : bool

public function set StretchImage(value : bool);

See Also

AdamSwitch Class
Advantech.Graph Namespace


SwitchOffImage Property

AdamSwitch.SwitchOffImage Property
[image]

Get/set the image when the switch Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSwitch"), _
DescriptionAttribute("The image when the switch Off.")>
Public Property SwitchOffImage As Image
C#
[CategoryAttribute("AdamSwitch")]
[DescriptionAttribute("The image when the switch Off.")]
public Image SwitchOffImage { get; set; }
C++
[CategoryAttribute(L"AdamSwitch")]
[DescriptionAttribute(L"The image when the switch Off.")]
public property Image SwitchOffImage sealed {
Image get();
void set(Image value);
}
J#
/** @attribute CategoryAttribute("AdamSwitch") */
/** @attribute DescriptionAttribute("The image when the switch Off.") */
/** property */
public Image get_SwitchOffImage();

/** property */
public void set_SwitchOffImage(Image value);
JScript
public function get SwitchOffImage() : Image

public function set SwitchOffImage(value : Image);

See Also

AdamSwitch Class
Advantech.Graph Namespace


SwitchOffString Property

AdamSwitch.SwitchOffString Property
[image]

Get/set the string when the switch Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The string when the switch Off."), _
CategoryAttribute("AdamSwitch")>
Public Property SwitchOffString As String
C#
[DescriptionAttribute("The string when the switch Off.")]
[CategoryAttribute("AdamSwitch")]
public string SwitchOffString { get; set; }
C++
[DescriptionAttribute(L"The string when the switch Off.")]
[CategoryAttribute(L"AdamSwitch")]
public property string SwitchOffString sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The string when the switch Off.") */
/** @attribute CategoryAttribute("AdamSwitch") */
/** property */
public string get_SwitchOffString();

/** property */
public void set_SwitchOffString(string value);
JScript
public function get SwitchOffString() : String

public function set SwitchOffString(value : String);

See Also

AdamSwitch Class
Advantech.Graph Namespace


SwitchOnImage Property

AdamSwitch.SwitchOnImage Property
[image]

Get/set the image when the switch On.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSwitch"), _
DescriptionAttribute("The image when the switch On.")>
Public Property SwitchOnImage As Image
C#
[CategoryAttribute("AdamSwitch")]
[DescriptionAttribute("The image when the switch On.")]
public Image SwitchOnImage { get; set; }
C++
[CategoryAttribute(L"AdamSwitch")]
[DescriptionAttribute(L"The image when the switch On.")]
public property Image SwitchOnImage sealed {
Image get();
void set(Image value);
}
J#
/** @attribute CategoryAttribute("AdamSwitch") */
/** @attribute DescriptionAttribute("The image when the switch On.") */
/** property */
public Image get_SwitchOnImage();

/** property */
public void set_SwitchOnImage(Image value);
JScript
public function get SwitchOnImage() : Image

public function set SwitchOnImage(value : Image);

See Also

AdamSwitch Class
Advantech.Graph Namespace


SwitchOnString Property

AdamSwitch.SwitchOnString Property
[image]

Get/set the string when the switch On.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSwitch"), _
DescriptionAttribute("The string when the switch On.")>
Public Property SwitchOnString As String
C#
[CategoryAttribute("AdamSwitch")]
[DescriptionAttribute("The string when the switch On.")]
public string SwitchOnString { get; set; }
C++
[CategoryAttribute(L"AdamSwitch")]
[DescriptionAttribute(L"The string when the switch On.")]
public property string SwitchOnString sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamSwitch") */
/** @attribute DescriptionAttribute("The string when the switch On.") */
/** property */
public string get_SwitchOnString();

/** property */
public void set_SwitchOnString(string value);
JScript
public function get SwitchOnString() : String

public function set SwitchOnString(value : String);

See Also

AdamSwitch Class
Advantech.Graph Namespace


Value Property

AdamSwitch.Value Property
[image]

Get/set the swicth to be On or Off.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamSwitch"), _
DescriptionAttribute("Determines if the swicth is On or Off.")>
Public Property Value As Boolean
C#
[CategoryAttribute("AdamSwitch")]
[DescriptionAttribute("Determines if the swicth is On or Off.")]
public bool Value { get; set; }
C++
[CategoryAttribute(L"AdamSwitch")]
[DescriptionAttribute(L"Determines if the swicth is On or Off.")]
public property bool Value sealed {
bool get();
void set(bool value);
}
J#
/** @attribute CategoryAttribute("AdamSwitch") */
/** @attribute DescriptionAttribute("Determines if the swicth is On or Off.") */
/** property */
public bool get_Value();

/** property */
public void set_Value(bool value);
JScript
public function get Value() : bool

public function set Value(value : bool);

See Also

AdamSwitch Class
Advantech.Graph Namespace


Methods

AdamSwitch Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamSwitch Class
Advantech.Graph Namespace


Dispose Method

AdamSwitch.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamSwitch Class
Advantech.Graph Namespace


OnPaint Method

AdamSwitch.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamSwitch Class
Advantech.Graph Namespace


OnResize Method

AdamSwitch.OnResize Method
[image]

The OnResize event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e
The EventArgs.

See Also

AdamSwitch Class
Advantech.Graph Namespace


AdamTrend Class

AdamTrend Class
See Also Example Members
[image]

The AdamTrend class

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamTrend), "Pictures.AdamTrend.bmp")>
Public Class AdamTrend
Inherits Control
C#
[ToolboxBitmapAttribute(typeof(AdamTrend), "Pictures.AdamTrend.bmp")]
public class AdamTrend : Control
C++
[ToolboxBitmapAttribute(typeof(AdamTrend), L"Pictures.AdamTrend.bmp")]
ref class AdamTrend : Control
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamTrend), "Pictures.AdamTrend.bmp") */
public class AdamTrend extends Control
JScript
public
ToolboxBitmapAttribute(typeof(AdamTrend), "Pictures.AdamTrend.bmp")
class AdamTrend extends Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Advantech.Graph.AdamTrend

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamTrend Members
Advantech.Graph Namespace


AdamTrend Members

AdamTrend Members
See Also Example Constructors Properties Methods
[image]

The AdamTrend class

The following tables list the members exposed by AdamTrend.

Public Constructors

 | Name | Description
Public method | AdamTrend | The AdamTrend constructor
Top

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | DrawType | Get/set the draw type of the lines.
Public property | GridBackColor | Get/set the back color of the grid lines.
Public property | GridColor | Get/set the color of the grid lines.
Public property | GridLineSize | Get/set the distance between two grid lines.
Public property | HorLabOrientation | Get/set the horizontal label layout
Public property | HorLabType | Get/set the horizontal label type.
Public property | MaximumY | Get/set the maximum value of the Y-axis.
Public property | MinimumY | Get/set the minimum value of the Y-axis.
Public property | Pen0Color | Get/set the color of the data line[0].
Public property | Pen1Color | Get/set the color of the data line[1].
Public property | Pen2Color | Get/set the color of the data line[2].
Public property | Pen3Color | Get/set the color of the data line[3].
Public property | Pen4Color | Get/set the color of the data line[4].
Public property | Pen5Color | Get/set the color of the data line[5].
Public property | Pen6Color | Get/set the color of the data line[6].
Public property | Pen7Color | Get/set the color of the data line[7].
Public property | Registration | Get/set the registration key.
Public property | StepSize | Get/set the X-axis movement steps.
Public property | VerLabOrientation | Get/set the vertical label layout
Public property | VerLabUnit | Get/set the vertical label unit string.
Top

Public Methods

 | Name | Description
Public method | ClearGraph | Force to clear the graph.
Public method | CopyGraphSequenceToGraph | Force to copy the sequence graph to graph (for sequence graph connection).
Public method | UpdateGraph | Force to update the graph.
Public method | UpdateGraphSequence | Force to update the sequence graph.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | DrawDataLines | Prepare the image before drawing.
Family method | DrawDataLinesSequence | Prepare the sequence image before drawing.
Family method | DrawGridLines | Draw the grid lines.
Family method | DrawHorLab | Draw horizontal label
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamTrend Class
Advantech.Graph Namespace


AdamTrend Constructor

AdamTrend Constructor
[image]

The AdamTrend constructor

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamTrend()
C++
public:
AdamTrend() sealed
J#
public AdamTrend()
JScript
public function AdamTrend()

See Also

AdamTrend Class
Advantech.Graph Namespace


Properties

AdamTrend Properties
[image]

Public Properties

 | Name | Description
Public property | BackColor | Overridden. Get/set the background color of the control.
Public property | DrawType | Get/set the draw type of the lines.
Public property | GridBackColor | Get/set the back color of the grid lines.
Public property | GridColor | Get/set the color of the grid lines.
Public property | GridLineSize | Get/set the distance between two grid lines.
Public property | HorLabOrientation | Get/set the horizontal label layout
Public property | HorLabType | Get/set the horizontal label type.
Public property | MaximumY | Get/set the maximum value of the Y-axis.
Public property | MinimumY | Get/set the minimum value of the Y-axis.
Public property | Pen0Color | Get/set the color of the data line[0].
Public property | Pen1Color | Get/set the color of the data line[1].
Public property | Pen2Color | Get/set the color of the data line[2].
Public property | Pen3Color | Get/set the color of the data line[3].
Public property | Pen4Color | Get/set the color of the data line[4].
Public property | Pen5Color | Get/set the color of the data line[5].
Public property | Pen6Color | Get/set the color of the data line[6].
Public property | Pen7Color | Get/set the color of the data line[7].
Public property | Registration | Get/set the registration key.
Public property | StepSize | Get/set the X-axis movement steps.
Public property | VerLabOrientation | Get/set the vertical label layout
Public property | VerLabUnit | Get/set the vertical label unit string.
Top

See Also

AdamTrend Class
Advantech.Graph Namespace


BackColor Property

AdamTrend.BackColor Property
[image]

Get/set the background color of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property BackColor As Color
C#
public override Color BackColor { get; set; }
C++
public override property Color BackColor override {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BackColor();

/** property */
public void set_BackColor(Color value);
JScript
public function get BackColor() : Color

public function set BackColor(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


DrawType Property

AdamTrend.DrawType Property
[image]

Get/set the draw type of the lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("The draw type of the lines.")>
Public Property DrawType As DrawType
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("The draw type of the lines.")]
public DrawType DrawType { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"The draw type of the lines.")]
public property DrawType DrawType sealed {
DrawType get();
void set(DrawType value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("The draw type of the lines.") */
/** property */
public DrawType get_DrawType();

/** property */
public void set_DrawType(DrawType value);
JScript
public function get DrawType() : DrawType

public function set DrawType(value : DrawType);

See Also

AdamTrend Class
Advantech.Graph Namespace


GridBackColor Property

AdamTrend.GridBackColor Property
[image]

Get/set the back color of the grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The back color of the grid lines."), _
CategoryAttribute("AdamTrend")>
Public Property GridBackColor As Color
C#
[DescriptionAttribute("The back color of the grid lines.")]
[CategoryAttribute("AdamTrend")]
public Color GridBackColor { get; set; }
C++
[DescriptionAttribute(L"The back color of the grid lines.")]
[CategoryAttribute(L"AdamTrend")]
public property Color GridBackColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The back color of the grid lines.") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public Color get_GridBackColor();

/** property */
public void set_GridBackColor(Color value);
JScript
public function get GridBackColor() : Color

public function set GridBackColor(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


GridColor Property

AdamTrend.GridColor Property
[image]

Get/set the color of the grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("The color of the grid lines.")>
Public Property GridColor As Color
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("The color of the grid lines.")]
public Color GridColor { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"The color of the grid lines.")]
public property Color GridColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("The color of the grid lines.") */
/** property */
public Color get_GridColor();

/** property */
public void set_GridColor(Color value);
JScript
public function get GridColor() : Color

public function set GridColor(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


GridLineSize Property

AdamTrend.GridLineSize Property
[image]

Get/set the distance between two grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DefaultValueAttribute(10), _
DescriptionAttribute("The distance between two grid lines.")>
Public Property GridLineSize As Integer
C#
[CategoryAttribute("AdamTrend")]
[DefaultValueAttribute(10)]
[DescriptionAttribute("The distance between two grid lines.")]
public int GridLineSize { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DefaultValueAttribute(10)]
[DescriptionAttribute(L"The distance between two grid lines.")]
public property int GridLineSize sealed {
int get();
void set(int value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DefaultValueAttribute(10) */
/** @attribute DescriptionAttribute("The distance between two grid lines.") */
/** property */
public int get_GridLineSize();

/** property */
public void set_GridLineSize(int value);
JScript
public function get GridLineSize() : int

public function set GridLineSize(value : int);

See Also

AdamTrend Class
Advantech.Graph Namespace


HorLabOrientation Property

AdamTrend.HorLabOrientation Property
[image]

Get/set the horizontal label layout

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("Horizontal label layout.")>
Public Property HorLabOrientation As enumHorLabOrientation
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("Horizontal label layout.")]
public enumHorLabOrientation HorLabOrientation { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"Horizontal label layout.")]
public property enumHorLabOrientation HorLabOrientation sealed {
enumHorLabOrientation get();
void set(enumHorLabOrientation value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("Horizontal label layout.") */
/** property */
public enumHorLabOrientation get_HorLabOrientation();

/** property */
public void set_HorLabOrientation(enumHorLabOrientation value);
JScript
public function get HorLabOrientation() : enumHorLabOrientation

public function set HorLabOrientation(value : enumHorLabOrientation);

See Also

AdamTrend Class
Advantech.Graph Namespace


HorLabType Property

AdamTrend.HorLabType Property
[image]

Get/set the horizontal label type.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("The horizontal label type.")>
Public Property HorLabType As enumHorLabType
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("The horizontal label type.")]
public enumHorLabType HorLabType { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"The horizontal label type.")]
public property enumHorLabType HorLabType sealed {
enumHorLabType get();
void set(enumHorLabType value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("The horizontal label type.") */
/** property */
public enumHorLabType get_HorLabType();

/** property */
public void set_HorLabType(enumHorLabType value);
JScript
public function get HorLabType() : enumHorLabType

public function set HorLabType(value : enumHorLabType);

See Also

AdamTrend Class
Advantech.Graph Namespace


MaximumY Property

AdamTrend.MaximumY Property
[image]

Get/set the maximum value of the Y-axis.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The maximum value of the Y-axis."), _
CategoryAttribute("AdamTrend"), _
DefaultValueAttribute(100)>
Public Property MaximumY As Single
C#
[DescriptionAttribute("The maximum value of the Y-axis.")]
[CategoryAttribute("AdamTrend")]
[DefaultValueAttribute(100)]
public float MaximumY { get; set; }
C++
[DescriptionAttribute(L"The maximum value of the Y-axis.")]
[CategoryAttribute(L"AdamTrend")]
[DefaultValueAttribute(100)]
public property float MaximumY sealed {
float get();
void set(float value);
}
J#
/** @attribute DescriptionAttribute("The maximum value of the Y-axis.") */
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DefaultValueAttribute(100) */
/** property */
public float get_MaximumY();

/** property */
public void set_MaximumY(float value);
JScript
public function get MaximumY() : float

public function set MaximumY(value : float);

See Also

AdamTrend Class
Advantech.Graph Namespace


MinimumY Property

AdamTrend.MinimumY Property
[image]

Get/set the minimum value of the Y-axis.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(0), _
DescriptionAttribute("The minimum value of the Y-axis."), _
CategoryAttribute("AdamTrend")>
Public Property MinimumY As Single
C#
[DefaultValueAttribute(0)]
[DescriptionAttribute("The minimum value of the Y-axis.")]
[CategoryAttribute("AdamTrend")]
public float MinimumY { get; set; }
C++
[DefaultValueAttribute(0)]
[DescriptionAttribute(L"The minimum value of the Y-axis.")]
[CategoryAttribute(L"AdamTrend")]
public property float MinimumY sealed {
float get();
void set(float value);
}
J#
/** @attribute DefaultValueAttribute(0) */
/** @attribute DescriptionAttribute("The minimum value of the Y-axis.") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public float get_MinimumY();

/** property */
public void set_MinimumY(float value);
JScript
public function get MinimumY() : float

public function set MinimumY(value : float);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen0Color Property

AdamTrend.Pen0Color Property
[image]

Get/set the color of the data line[0].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the data line[0]."), _
CategoryAttribute("AdamTrend")>
Public Property Pen0Color As Color
C#
[DescriptionAttribute("The color of the data line[0].")]
[CategoryAttribute("AdamTrend")]
public Color Pen0Color { get; set; }
C++
[DescriptionAttribute(L"The color of the data line[0].")]
[CategoryAttribute(L"AdamTrend")]
public property Color Pen0Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the data line[0].") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public Color get_Pen0Color();

/** property */
public void set_Pen0Color(Color value);
JScript
public function get Pen0Color() : Color

public function set Pen0Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen1Color Property

AdamTrend.Pen1Color Property
[image]

Get/set the color of the data line[1].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("The color of the data line[1].")>
Public Property Pen1Color As Color
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("The color of the data line[1].")]
public Color Pen1Color { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"The color of the data line[1].")]
public property Color Pen1Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("The color of the data line[1].") */
/** property */
public Color get_Pen1Color();

/** property */
public void set_Pen1Color(Color value);
JScript
public function get Pen1Color() : Color

public function set Pen1Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen2Color Property

AdamTrend.Pen2Color Property
[image]

Get/set the color of the data line[2].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the data line[2]."), _
CategoryAttribute("AdamTrend")>
Public Property Pen2Color As Color
C#
[DescriptionAttribute("The color of the data line[2].")]
[CategoryAttribute("AdamTrend")]
public Color Pen2Color { get; set; }
C++
[DescriptionAttribute(L"The color of the data line[2].")]
[CategoryAttribute(L"AdamTrend")]
public property Color Pen2Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the data line[2].") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public Color get_Pen2Color();

/** property */
public void set_Pen2Color(Color value);
JScript
public function get Pen2Color() : Color

public function set Pen2Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen3Color Property

AdamTrend.Pen3Color Property
[image]

Get/set the color of the data line[3].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("The color of the data line[3].")>
Public Property Pen3Color As Color
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("The color of the data line[3].")]
public Color Pen3Color { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"The color of the data line[3].")]
public property Color Pen3Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("The color of the data line[3].") */
/** property */
public Color get_Pen3Color();

/** property */
public void set_Pen3Color(Color value);
JScript
public function get Pen3Color() : Color

public function set Pen3Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen4Color Property

AdamTrend.Pen4Color Property
[image]

Get/set the color of the data line[4].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the data line[4]."), _
CategoryAttribute("AdamTrend")>
Public Property Pen4Color As Color
C#
[DescriptionAttribute("The color of the data line[4].")]
[CategoryAttribute("AdamTrend")]
public Color Pen4Color { get; set; }
C++
[DescriptionAttribute(L"The color of the data line[4].")]
[CategoryAttribute(L"AdamTrend")]
public property Color Pen4Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the data line[4].") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public Color get_Pen4Color();

/** property */
public void set_Pen4Color(Color value);
JScript
public function get Pen4Color() : Color

public function set Pen4Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen5Color Property

AdamTrend.Pen5Color Property
[image]

Get/set the color of the data line[5].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the data line[5]."), _
CategoryAttribute("AdamTrend")>
Public Property Pen5Color As Color
C#
[DescriptionAttribute("The color of the data line[5].")]
[CategoryAttribute("AdamTrend")]
public Color Pen5Color { get; set; }
C++
[DescriptionAttribute(L"The color of the data line[5].")]
[CategoryAttribute(L"AdamTrend")]
public property Color Pen5Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the data line[5].") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public Color get_Pen5Color();

/** property */
public void set_Pen5Color(Color value);
JScript
public function get Pen5Color() : Color

public function set Pen5Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen6Color Property

AdamTrend.Pen6Color Property
[image]

Get/set the color of the data line[6].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The color of the data line[6]."), _
CategoryAttribute("AdamTrend")>
Public Property Pen6Color As Color
C#
[DescriptionAttribute("The color of the data line[6].")]
[CategoryAttribute("AdamTrend")]
public Color Pen6Color { get; set; }
C++
[DescriptionAttribute(L"The color of the data line[6].")]
[CategoryAttribute(L"AdamTrend")]
public property Color Pen6Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute DescriptionAttribute("The color of the data line[6].") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public Color get_Pen6Color();

/** property */
public void set_Pen6Color(Color value);
JScript
public function get Pen6Color() : Color

public function set Pen6Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Pen7Color Property

AdamTrend.Pen7Color Property
[image]

Get/set the color of the data line[7].

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("The color of the data line[7].")>
Public Property Pen7Color As Color
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("The color of the data line[7].")]
public Color Pen7Color { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"The color of the data line[7].")]
public property Color Pen7Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("The color of the data line[7].") */
/** property */
public Color get_Pen7Color();

/** property */
public void set_Pen7Color(Color value);
JScript
public function get Pen7Color() : Color

public function set Pen7Color(value : Color);

See Also

AdamTrend Class
Advantech.Graph Namespace


Registration Property

AdamTrend.Registration Property
[image]

Get/set the registration key.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("The registration key.")>
Public Property Registration As String
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("The registration key.")]
public string Registration { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"The registration key.")]
public property string Registration sealed {
String get();
void set(String value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("The registration key.") */
/** property */
public string get_Registration();

/** property */
public void set_Registration(string value);
JScript
public function get Registration() : String

public function set Registration(value : String);

See Also

AdamTrend Class
Advantech.Graph Namespace


StepSize Property

AdamTrend.StepSize Property
[image]

Get/set the X-axis movement steps.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(1), _
DescriptionAttribute("The X-axis movement steps."), _
CategoryAttribute("AdamTrend")>
Public Property StepSize As Integer
C#
[DefaultValueAttribute(1)]
[DescriptionAttribute("The X-axis movement steps.")]
[CategoryAttribute("AdamTrend")]
public int StepSize { get; set; }
C++
[DefaultValueAttribute(1)]
[DescriptionAttribute(L"The X-axis movement steps.")]
[CategoryAttribute(L"AdamTrend")]
public property int StepSize sealed {
int get();
void set(int value);
}
J#
/** @attribute DefaultValueAttribute(1) */
/** @attribute DescriptionAttribute("The X-axis movement steps.") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public int get_StepSize();

/** property */
public void set_StepSize(int value);
JScript
public function get StepSize() : int

public function set StepSize(value : int);

See Also

AdamTrend Class
Advantech.Graph Namespace


VerLabOrientation Property

AdamTrend.VerLabOrientation Property
[image]

Get/set the vertical label layout

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<CategoryAttribute("AdamTrend"), _
DescriptionAttribute("Vertical label layout.")>
Public Property VerLabOrientation As enumVerLabOrientation
C#
[CategoryAttribute("AdamTrend")]
[DescriptionAttribute("Vertical label layout.")]
public enumVerLabOrientation VerLabOrientation { get; set; }
C++
[CategoryAttribute(L"AdamTrend")]
[DescriptionAttribute(L"Vertical label layout.")]
public property enumVerLabOrientation VerLabOrientation sealed {
enumVerLabOrientation get();
void set(enumVerLabOrientation value);
}
J#
/** @attribute CategoryAttribute("AdamTrend") */
/** @attribute DescriptionAttribute("Vertical label layout.") */
/** property */
public enumVerLabOrientation get_VerLabOrientation();

/** property */
public void set_VerLabOrientation(enumVerLabOrientation value);
JScript
public function get VerLabOrientation() : enumVerLabOrientation

public function set VerLabOrientation(value : enumVerLabOrientation);

See Also

AdamTrend Class
Advantech.Graph Namespace


VerLabUnit Property

AdamTrend.VerLabUnit Property
[image]

Get/set the vertical label unit string.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The vertical label unit string."), _
CategoryAttribute("AdamTrend")>
Public Property VerLabUnit As String
C#
[DescriptionAttribute("The vertical label unit string.")]
[CategoryAttribute("AdamTrend")]
public string VerLabUnit { get; set; }
C++
[DescriptionAttribute(L"The vertical label unit string.")]
[CategoryAttribute(L"AdamTrend")]
public property string VerLabUnit sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("The vertical label unit string.") */
/** @attribute CategoryAttribute("AdamTrend") */
/** property */
public string get_VerLabUnit();

/** property */
public void set_VerLabUnit(string value);
JScript
public function get VerLabUnit() : String

public function set VerLabUnit(value : String);

See Also

AdamTrend Class
Advantech.Graph Namespace


Methods

AdamTrend Methods
[image]

Public Methods

 | Name | Description
Public method | ClearGraph | Force to clear the graph.
Public method | CopyGraphSequenceToGraph | Force to copy the sequence graph to graph (for sequence graph connection).
Public method | UpdateGraph | Force to update the graph.
Public method | UpdateGraphSequence | Force to update the sequence graph.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | DrawDataLines | Prepare the image before drawing.
Family method | DrawDataLinesSequence | Prepare the sequence image before drawing.
Family method | DrawGridLines | Draw the grid lines.
Family method | DrawHorLab | Draw horizontal label
Family method | OnPaint | Overridden.
Family method | OnResize | Overridden. The OnResize event.
Top

See Also

AdamTrend Class
Advantech.Graph Namespace


ClearGraph Method

AdamTrend.ClearGraph Method
[image]

Force to clear the graph.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearGraph()
C#
public void ClearGraph()
C++
public:
void ClearGraph() sealed
J#
public void ClearGraph()
JScript
public function ClearGraph()

See Also

AdamTrend Class
Advantech.Graph Namespace


CopyGraphSequenceToGraph Method

AdamTrend.CopyGraphSequenceToGraph Method
[image]

Force to copy the sequence graph to graph (for sequence graph connection).

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyGraphSequenceToGraph()
C#
public void CopyGraphSequenceToGraph()
C++
public:
void CopyGraphSequenceToGraph() sealed
J#
public void CopyGraphSequenceToGraph()
JScript
public function CopyGraphSequenceToGraph()

See Also

AdamTrend Class
Advantech.Graph Namespace


Dispose Method

AdamTrend.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamTrend Class
Advantech.Graph Namespace


DrawDataLines Method

AdamTrend.DrawDataLines Method
[image]

Prepare the image before drawing.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Sub DrawDataLines( _
ByVal panelGraph As Graphics, _
ByVal dataValues As Single() _
)
C#
protected void DrawDataLines(
Graphics panelGraph,
float[] dataValues
)
C++
protected:
void DrawDataLines(
Graphics panelGraph,
array<float>^ dataValues
) sealed
J#
protected void DrawDataLines(
Graphics panelGraph,
float[] dataValues
)
JScript
protected function DrawDataLines(
panelGraph : Graphics,
dataValues : float[]
)

See Also

AdamTrend Class
Advantech.Graph Namespace


DrawDataLinesSequence Method

AdamTrend.DrawDataLinesSequence Method
[image]

Prepare the sequence image before drawing.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Sub DrawDataLinesSequence( _
ByVal panelGraph As Graphics, _
ByVal dataValues As Single()(), _
ByVal startIdx As Integer, _
ByVal bEnable As Boolean() _
)
C#
protected void DrawDataLinesSequence(
Graphics panelGraph,
float[][] dataValues,
int startIdx,
bool[] bEnable
)
C++
protected:
void DrawDataLinesSequence(
Graphics panelGraph,
array<array<float>^>^ dataValues,
int startIdx,
array<bool>^ bEnable
) sealed
J#
protected void DrawDataLinesSequence(
Graphics panelGraph,
float[][] dataValues,
int startIdx,
bool[] bEnable
)
JScript
protected function DrawDataLinesSequence(
panelGraph : Graphics,
dataValues : float[][],
startIdx : int,
bEnable : bool[]
)

See Also

AdamTrend Class
Advantech.Graph Namespace


DrawGridLines Method

AdamTrend.DrawGridLines Method
[image]

Draw the grid lines.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Sub DrawGridLines( _
ByVal panelGraph As Graphics _
)
C#
protected void DrawGridLines(
Graphics panelGraph
)
C++
protected:
void DrawGridLines(
Graphics panelGraph
) sealed
J#
protected void DrawGridLines(
Graphics panelGraph
)
JScript
protected function DrawGridLines(
panelGraph : Graphics
)

See Also

AdamTrend Class
Advantech.Graph Namespace


DrawHorLab Method

AdamTrend.DrawHorLab Method
[image]

Draw horizontal label

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Sub DrawHorLab( _
ByVal panelGraph As Graphics, _
ByVal bDrawLabLine As Boolean _
)
C#
protected void DrawHorLab(
Graphics panelGraph,
bool bDrawLabLine
)
C++
protected:
void DrawHorLab(
Graphics panelGraph,
bool bDrawLabLine
) sealed
J#
protected void DrawHorLab(
Graphics panelGraph,
bool bDrawLabLine
)
JScript
protected function DrawHorLab(
panelGraph : Graphics,
bDrawLabLine : bool
)

Parameters

panelGraph
bDrawLabLine

See Also

AdamTrend Class
Advantech.Graph Namespace


OnPaint Method

AdamTrend.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal pe As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs pe
)
C++
protected:
virtual void OnPaint(
PaintEventArgs pe
) override
J#
protected override void OnPaint(
PaintEventArgs pe
)
JScript
protected override function OnPaint(
pe : PaintEventArgs
)

Parameters

pe

See Also

AdamTrend Class
Advantech.Graph Namespace


OnResize Method

AdamTrend.OnResize Method
[image]

The OnResize event.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
ByVal e As EventArgs _
)
C#
protected override void OnResize(
EventArgs e
)
C++
protected:
virtual void OnResize(
EventArgs e
) override
J#
protected override void OnResize(
EventArgs e
)
JScript
protected override function OnResize(
e : EventArgs
)

Parameters

e
The EventArgs.

See Also

AdamTrend Class
Advantech.Graph Namespace


UpdateGraph Method

AdamTrend.UpdateGraph Method
[image]

Force to update the graph.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateGraph( _
ByVal values As Single() _
)
C#
public void UpdateGraph(
float[] values
)
C++
public:
void UpdateGraph(
array<float>^ values
) sealed
J#
public void UpdateGraph(
float[] values
)
JScript
public function UpdateGraph(
values : float[]
)

See Also

AdamTrend Class
Advantech.Graph Namespace


UpdateGraphSequence Method

AdamTrend.UpdateGraphSequence Method
[image]

Force to update the sequence graph.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateGraphSequence( _
ByVal startIdx As Integer, _
ByVal values As Single()(), _
ByVal bEnable As Boolean() _
)
C#
public void UpdateGraphSequence(
int startIdx,
float[][] values,
bool[] bEnable
)
C++
public:
void UpdateGraphSequence(
int startIdx,
array<array<float>^>^ values,
array<bool>^ bEnable
) sealed
J#
public void UpdateGraphSequence(
int startIdx,
float[][] values,
bool[] bEnable
)
JScript
public function UpdateGraphSequence(
startIdx : int,
values : float[][],
bEnable : bool[]
)

See Also

AdamTrend Class
Advantech.Graph Namespace


AdamWSNNode Class

AdamWSNNode Class
See Also Example Members
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute(GetType(AdamWSNNode), "AdamWSNNode.bmp")>
Public Class AdamWSNNode
Inherits UserControl
C#
[ToolboxBitmapAttribute(typeof(AdamWSNNode), "AdamWSNNode.bmp")]
public class AdamWSNNode : UserControl
C++
[ToolboxBitmapAttribute(typeof(AdamWSNNode), L"AdamWSNNode.bmp")]
ref class AdamWSNNode : UserControl
J#
/** @attribute ToolboxBitmapAttribute(typeof(AdamWSNNode), "AdamWSNNode.bmp") */
public class AdamWSNNode extends UserControl
JScript
public
ToolboxBitmapAttribute(typeof(AdamWSNNode), "AdamWSNNode.bmp")
class AdamWSNNode extends UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Advantech.Graph.AdamWSNNode

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdamWSNNode Members
Advantech.Graph Namespace


AdamWSNNode Members

AdamWSNNode Members
See Also Example Properties Methods Events Explicit Inteface Implementations
[image]

The following tables list the members exposed by AdamWSNNode.

Public Constructors

Name | Description
AdamWSNNode | Overloaded. Initializes a new instance of the AdamWSNNode class.
Top

Public Properties

 | Name | Description
Public property | BatteryLevel | Get Battery level object.
Public property | BorderColor | Get/set the border color of WSN node.
Public property | BrushColor | Get/set the brush color.
Public property | CenterPosition | Get/set the center position of WSN node.
Public property | EndingColor | Get/set the Ending color in LinearGradientBrush object.
Public property | NodeType | Node type, must be "c", "r" or "e".
Public property | ShortAddress | Get the Short Address of WSN node.
Public property | SignalStrength | Get signal strength object.
Public property | UseExternalPower | Get/set use external power flag.
Top

Protected Properties

 | Name | Description
Family property | CreateParams | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

Public Events

 | Name | Description
Public event | Adam2kNodeDoubleClick | DoubleClick event
Top

Explicit Interface Implementations

Name | Description
AdamWSNNode | Overloaded. Initializes a new instance of the AdamWSNNode class.
Top

See Also

AdamWSNNode Class
Advantech.Graph Namespace


AdamWSNNode Constructor

AdamWSNNode Constructor

Initializes a new instance of the AdamWSNNode class.

Overload List

 | Name | Description
Public method | AdamWSNNode | The AdamWSNNode constructor.
Public method | AdamWSNNode (String, UInt16, Boolean, Int32, Boolean, UInt16) | The AdamWSNNode constructor.

See Also

AdamWSNNode Class
Advantech.Graph Namespace


AdamWSNNode Constructor ()

AdamWSNNode Constructor ()
See Also Example
[image]

The AdamWSNNode constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdamWSNNode()
C++
public:
AdamWSNNode() sealed
J#
public AdamWSNNode()
JScript
public function AdamWSNNode()

See Also

AdamWSNNode Class
Advantech.Graph Namespace
AdamWSNNode Constructor Overload List


AdamWSNNode Constructor (String, UInt16, Boolean, Int32, Boolean, UInt16)

AdamWSNNode Constructor (String, UInt16, Boolean, Int32, Boolean, UInt16)
See Also Example
[image]

The AdamWSNNode constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal moduleName As String, _
ByVal shortaddr As UInt16, _
ByVal showSignalIndicator As Boolean, _
ByVal signal As Integer, _
ByVal useExternalPower As Boolean, _
ByVal batteryStatus As UInt16 _
)
C#
public AdamWSNNode(
string moduleName,
ushort shortaddr,
bool showSignalIndicator,
int signal,
bool useExternalPower,
ushort batteryStatus
)
C++
public:
AdamWSNNode(
String moduleName,
unsigned short shortaddr,
bool showSignalIndicator,
int signal,
bool useExternalPower,
unsigned short batteryStatus
) sealed
J#
public AdamWSNNode(
string moduleName,
ushort shortaddr,
bool showSignalIndicator,
int signal,
bool useExternalPower,
ushort batteryStatus
)
JScript
public function AdamWSNNode(
moduleName : String,
shortaddr : UInt16,
showSignalIndicator : bool,
signal : int,
useExternalPower : bool,
batteryStatus : UInt16
)

See Also

AdamWSNNode Class
Advantech.Graph Namespace
AdamWSNNode Constructor Overload List


Properties

AdamWSNNode Properties
[image]

Public Properties

 | Name | Description
Public property | BatteryLevel | Get Battery level object.
Public property | BorderColor | Get/set the border color of WSN node.
Public property | BrushColor | Get/set the brush color.
Public property | CenterPosition | Get/set the center position of WSN node.
Public property | EndingColor | Get/set the Ending color in LinearGradientBrush object.
Public property | NodeType | Node type, must be "c", "r" or "e".
Public property | ShortAddress | Get the Short Address of WSN node.
Public property | SignalStrength | Get signal strength object.
Public property | UseExternalPower | Get/set use external power flag.
Top

Protected Properties

 | Name | Description
Family property | CreateParams | Overridden.
Top

See Also

AdamWSNNode Class
Advantech.Graph Namespace


BatteryLevel Property

AdamWSNNode.BatteryLevel Property
[image]

Get Battery level object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The Battery level object.")>
Public ReadOnly Property BatteryLevel As AdamBatteryIndicator
C#
[DescriptionAttribute("The Battery level object.")]
public AdamBatteryIndicator BatteryLevel { get; }
C++
[DescriptionAttribute(L"The Battery level object.")]
public property AdamBatteryIndicator BatteryLevel sealed {
AdamBatteryIndicator get();
}
J#
/** @attribute DescriptionAttribute("The Battery level object.") */
/** property */
public AdamBatteryIndicator get_BatteryLevel();
JScript
public function get BatteryLevel() : AdamBatteryIndicator

See Also

AdamWSNNode Class
Advantech.Graph Namespace


BorderColor Property

AdamWSNNode.BorderColor Property
[image]

Get/set the border color of WSN node.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property BorderColor As Color
C#
public Color BorderColor { get; set; }
C++
public property Color BorderColor sealed {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BorderColor();

/** property */
public void set_BorderColor(Color value);
JScript
public function get BorderColor() : Color

public function set BorderColor(value : Color);

See Also

AdamWSNNode Class
Advantech.Graph Namespace


BrushColor Property

AdamWSNNode.BrushColor Property
[image]

Get/set the brush color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property BrushColor As Color
C#
public Color BrushColor { get; set; }
C++
public property Color BrushColor sealed {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_BrushColor();

/** property */
public void set_BrushColor(Color value);
JScript
public function get BrushColor() : Color

public function set BrushColor(value : Color);

See Also

AdamWSNNode Class
Advantech.Graph Namespace


CenterPosition Property

AdamWSNNode.CenterPosition Property
[image]

Get/set the center position of WSN node.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property CenterPosition As Point
C#
public Point CenterPosition { get; set; }
C++
public property Point CenterPosition sealed {
Point get();
void set(Point value);
}
J#
/** property */
public Point get_CenterPosition();

/** property */
public void set_CenterPosition(Point value);
JScript
public function get CenterPosition() : Point

public function set CenterPosition(value : Point);

See Also

AdamWSNNode Class
Advantech.Graph Namespace


CreateParams Property

AdamWSNNode.CreateParams Property
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property CreateParams As CreateParams
C#
protected override CreateParams CreateParams { get; }
C++
protected override property CreateParams CreateParams override {
CreateParams get();
}
J#
/** property */
protected CreateParams get_CreateParams();
JScript
protected function get CreateParams() : CreateParams

See Also

AdamWSNNode Class
Advantech.Graph Namespace


EndingColor Property

AdamWSNNode.EndingColor Property
[image]

Get/set the Ending color in LinearGradientBrush object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property EndingColor As Color
C#
public Color EndingColor { get; set; }
C++
public property Color EndingColor sealed {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_EndingColor();

/** property */
public void set_EndingColor(Color value);
JScript
public function get EndingColor() : Color

public function set EndingColor(value : Color);

See Also

AdamWSNNode Class
Advantech.Graph Namespace


NodeType Property

AdamWSNNode.NodeType Property
[image]

Node type, must be "c", "r" or "e".

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Node type, must be "c", "r" or "e".")>
Public Property NodeType As String
C#
[DescriptionAttribute("Node type, must be "c", "r" or "e".")]
public string NodeType { get; set; }
C++
[DescriptionAttribute(L"Node type, must be "c", "r" or "e".")]
public property string NodeType sealed {
String get();
void set(String value);
}
J#
/** @attribute DescriptionAttribute("Node type, must be "c", "r" or "e".") */
/** property */
public string get_NodeType();

/** property */
public void set_NodeType(string value);
JScript
public function get NodeType() : String

public function set NodeType(value : String);

See Also

AdamWSNNode Class
Advantech.Graph Namespace


ShortAddress Property

AdamWSNNode.ShortAddress Property
[image]

Get the Short Address of WSN node.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShortAddress As UInt16
C#
public ushort ShortAddress { get; }
C++
public property ushort ShortAddress sealed {
unsigned short get();
}
J#
/** property */
public ushort get_ShortAddress();
JScript
public function get ShortAddress() : UInt16

See Also

AdamWSNNode Class
Advantech.Graph Namespace


SignalStrength Property

AdamWSNNode.SignalStrength Property
[image]

Get signal strength object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The signal strength object.")>
Public ReadOnly Property SignalStrength As AdamSignalIndicator
C#
[DescriptionAttribute("The signal strength object.")]
public AdamSignalIndicator SignalStrength { get; }
C++
[DescriptionAttribute(L"The signal strength object.")]
public property AdamSignalIndicator SignalStrength sealed {
AdamSignalIndicator get();
}
J#
/** @attribute DescriptionAttribute("The signal strength object.") */
/** property */
public AdamSignalIndicator get_SignalStrength();
JScript
public function get SignalStrength() : AdamSignalIndicator

See Also

AdamWSNNode Class
Advantech.Graph Namespace


UseExternalPower Property

AdamWSNNode.UseExternalPower Property
[image]

Get/set use external power flag.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property UseExternalPower As Boolean
C#
public bool UseExternalPower { get; set; }
C++
public property bool UseExternalPower sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseExternalPower();

/** property */
public void set_UseExternalPower(bool value);
JScript
public function get UseExternalPower() : bool

public function set UseExternalPower(value : bool);

See Also

AdamWSNNode Class
Advantech.Graph Namespace


Methods

AdamWSNNode Methods
[image]

Protected Methods

 | Name | Description
Family method | Dispose | Overridden. Clean up any resources being used.
Family method | OnPaint | Overridden.
Top

See Also

AdamWSNNode Class
Advantech.Graph Namespace


Dispose Method

AdamWSNNode.Dispose Method
[image]

Clean up any resources being used.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

AdamWSNNode Class
Advantech.Graph Namespace


OnPaint Method

AdamWSNNode.OnPaint Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPaint( _
ByVal e As PaintEventArgs _
)
C#
protected override void OnPaint(
PaintEventArgs e
)
C++
protected:
virtual void OnPaint(
PaintEventArgs e
) override
J#
protected override void OnPaint(
PaintEventArgs e
)
JScript
protected override function OnPaint(
e : PaintEventArgs
)

Parameters

e

See Also

AdamWSNNode Class
Advantech.Graph Namespace


Events

AdamWSNNode Events
[image]

Public Events

 | Name | Description
Public event | Adam2kNodeDoubleClick | DoubleClick event
Top

See Also

AdamWSNNode Class
Advantech.Graph Namespace


Adam2kNodeDoubleClick Event

AdamWSNNode.Adam2kNodeDoubleClick Event
[image]

DoubleClick event

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Event Adam2kNodeDoubleClick As AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick
C#
public event AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick Adam2kNodeDoubleClick
C++
public:
virtual event AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick Adam2kNodeDoubleClick {
void add(AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick value) sealed ;
void remove(AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick value) sealed ;
}
J#
/** event */
public final void add_Adam2kNodeDoubleClick(AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick value);

/** event */
public final void remove_Adam2kNodeDoubleClick(AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

AdamWSNNode Class
Advantech.Graph Namespace


AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick Delegate

AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick Delegate
[image]

DoubleClick delegate

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick( _
ByVal i_usShortAddr As UInt16, _
ByVal bAlwaysOn As Boolean, _
ByVal byTimes As Byte _
)
C#
public delegate void AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick(
ushort i_usShortAddr,
bool bAlwaysOn,
byte byTimes
)
C++
public delegate void AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick(
unsigned short i_usShortAddr,
bool bAlwaysOn,
char byTimes
)
J#
/** delegate */
public delegate void AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick(
ushort i_usShortAddr,
bool bAlwaysOn,
byte byTimes
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Graph Namespace


AdvantechLine Class

AdvantechLine Class
See Also Example Members
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Class AdvantechLine
C#
public class AdvantechLine
C++
ref class AdvantechLine
J#
public class AdvantechLine
JScript
public class AdvantechLine

Inheritance Hierarchy

System.Object
Advantech.Graph.AdvantechLine

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AdvantechLine Members
Advantech.Graph Namespace


AdvantechLine Members

AdvantechLine Members
See Also Example Constructors Properties
[image]

The following tables list the members exposed by AdvantechLine.

Public Constructors

 | Name | Description
Public method | AdvantechLine | The AdvantechLine constructor.
Top

Public Properties

 | Name | Description
Public property | LineColor | Get/set line color.
Public property | NeedToRedraw | Get/set need to redraw flag.
Public property | PointOne | Get/set Point One position of AdvantechLine object.
Public property | PointTwo | Get/set Point Two position of AdvantechLine object.
Public property | shortAddressPointOne | Get/set short address of Point One of AdvantechLine object.
Public property | shortAddressPointTwo | Get/set short address of Point Two of AdvantechLine object.
Public property | Width | Get/set width of line.
Top

See Also

AdvantechLine Class
Advantech.Graph Namespace


AdvantechLine Constructor

AdvantechLine Constructor
[image]

The AdvantechLine constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AdvantechLine()
C++
public:
AdvantechLine() sealed
J#
public AdvantechLine()
JScript
public function AdvantechLine()

See Also

AdvantechLine Class
Advantech.Graph Namespace


Properties

AdvantechLine Properties
[image]

Public Properties

 | Name | Description
Public property | LineColor | Get/set line color.
Public property | NeedToRedraw | Get/set need to redraw flag.
Public property | PointOne | Get/set Point One position of AdvantechLine object.
Public property | PointTwo | Get/set Point Two position of AdvantechLine object.
Public property | shortAddressPointOne | Get/set short address of Point One of AdvantechLine object.
Public property | shortAddressPointTwo | Get/set short address of Point Two of AdvantechLine object.
Public property | Width | Get/set width of line.
Top

See Also

AdvantechLine Class
Advantech.Graph Namespace


LineColor Property

AdvantechLine.LineColor Property
[image]

Get/set line color.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property LineColor As Color
C#
public Color LineColor { get; set; }
C++
public property Color LineColor sealed {
Color get();
void set(Color value);
}
J#
/** property */
public Color get_LineColor();

/** property */
public void set_LineColor(Color value);
JScript
public function get LineColor() : Color

public function set LineColor(value : Color);

See Also

AdvantechLine Class
Advantech.Graph Namespace


NeedToRedraw Property

AdvantechLine.NeedToRedraw Property
[image]

Get/set need to redraw flag.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property NeedToRedraw As Boolean
C#
public bool NeedToRedraw { get; set; }
C++
public property bool NeedToRedraw sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_NeedToRedraw();

/** property */
public void set_NeedToRedraw(bool value);
JScript
public function get NeedToRedraw() : bool

public function set NeedToRedraw(value : bool);

See Also

AdvantechLine Class
Advantech.Graph Namespace


PointOne Property

AdvantechLine.PointOne Property
[image]

Get/set Point One position of AdvantechLine object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property PointOne As Point
C#
public Point PointOne { get; set; }
C++
public property Point PointOne sealed {
Point get();
void set(Point value);
}
J#
/** property */
public Point get_PointOne();

/** property */
public void set_PointOne(Point value);
JScript
public function get PointOne() : Point

public function set PointOne(value : Point);

See Also

AdvantechLine Class
Advantech.Graph Namespace


PointTwo Property

AdvantechLine.PointTwo Property
[image]

Get/set Point Two position of AdvantechLine object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property PointTwo As Point
C#
public Point PointTwo { get; set; }
C++
public property Point PointTwo sealed {
Point get();
void set(Point value);
}
J#
/** property */
public Point get_PointTwo();

/** property */
public void set_PointTwo(Point value);
JScript
public function get PointTwo() : Point

public function set PointTwo(value : Point);

See Also

AdvantechLine Class
Advantech.Graph Namespace


shortAddressPointOne Property

AdvantechLine.shortAddressPointOne Property
[image]

Get/set short address of Point One of AdvantechLine object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property shortAddressPointOne As UInt16
C#
public ushort shortAddressPointOne { get; set; }
C++
public property ushort shortAddressPointOne sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_shortAddressPointOne();

/** property */
public void set_shortAddressPointOne(ushort value);
JScript
public function get shortAddressPointOne() : UInt16

public function set shortAddressPointOne(value : UInt16);

See Also

AdvantechLine Class
Advantech.Graph Namespace


shortAddressPointTwo Property

AdvantechLine.shortAddressPointTwo Property
[image]

Get/set short address of Point Two of AdvantechLine object.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property shortAddressPointTwo As UInt16
C#
public ushort shortAddressPointTwo { get; set; }
C++
public property ushort shortAddressPointTwo sealed {
unsigned short get();
void set(unsigned short value);
}
J#
/** property */
public ushort get_shortAddressPointTwo();

/** property */
public void set_shortAddressPointTwo(ushort value);
JScript
public function get shortAddressPointTwo() : UInt16

public function set shortAddressPointTwo(value : UInt16);

See Also

AdvantechLine Class
Advantech.Graph Namespace


Width Property

AdvantechLine.Width Property
[image]

Get/set width of line.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width { get; set; }
C++
public property int Width sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Width();

/** property */
public void set_Width(int value);
JScript
public function get Width() : int

public function set Width(value : int);

See Also

AdvantechLine Class
Advantech.Graph Namespace


DelegateDisableButtons Delegate

DelegateDisableButtons Delegate
[image]

A delegate type for hooking up DisableButtons notifications.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub DelegateDisableButtons()
C#
public delegate void DelegateDisableButtons()
C++
public delegate void DelegateDisableButtons()
J#
/** delegate */
public delegate void DelegateDisableButtons()
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Graph Namespace


DelegateEnableButtons Delegate

DelegateEnableButtons Delegate
[image]

A delegate type for hooking up EnableButtons notifications.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub DelegateEnableButtons()
C#
public delegate void DelegateEnableButtons()
C++
public delegate void DelegateEnableButtons()
J#
/** delegate */
public delegate void DelegateEnableButtons()
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Graph Namespace


DelegateReConnectRemote Delegate

DelegateReConnectRemote Delegate
[image]

A delegate type for hooking up ReConnectRemote notifications.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub DelegateReConnectRemote()
C#
public delegate void DelegateReConnectRemote()
C++
public delegate void DelegateReConnectRemote()
J#
/** delegate */
public delegate void DelegateReConnectRemote()
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Graph Namespace


DelegateUpdateBitmap Delegate

DelegateUpdateBitmap Delegate
[image]

A delegate type for hooking up UpdateBitmap notifications.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub DelegateUpdateBitmap()
C#
public delegate void DelegateUpdateBitmap()
C++
public delegate void DelegateUpdateBitmap()
J#
/** delegate */
public delegate void DelegateUpdateBitmap()
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Graph Namespace


DrawType Enumeration

DrawType Enumeration
[image]

The shape of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Enum DrawType
C#
public enum DrawType
C++
public enum class DrawType
J#
public enum DrawType
JScript
public enum DrawType

Members

Member Name | Description
Analog | Analog shape.
Digital | Digital shape.

See Also

Advantech.Graph Namespace


enumHorLabOrientation Enumeration

enumHorLabOrientation Enumeration
[image]

Horizontal label orientation enumeration

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Enum enumHorLabOrientation
C#
public enum enumHorLabOrientation
C++
public enum class enumHorLabOrientation
J#
public enum enumHorLabOrientation
JScript
public enum enumHorLabOrientation

Members

Member Name | Description
Non | Non
Up | Up type
Bottom | Bottom type

See Also

Advantech.Graph Namespace


enumHorLabType Enumeration

enumHorLabType Enumeration
[image]

Horizontal label type enumeration

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Enum enumHorLabType
C#
public enum enumHorLabType
C++
public enum class enumHorLabType
J#
public enum enumHorLabType
JScript
public enum enumHorLabType

Members

Member Name | Description
Time | Time
Span | Span
Step | Step

See Also

Advantech.Graph Namespace


enumOrientation Enumeration

enumOrientation Enumeration
[image]

Orientation enumeration

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Enum enumOrientation
C#
public enum enumOrientation
C++
public enum class enumOrientation
J#
public enum enumOrientation
JScript
public enum enumOrientation

Members

Member Name | Description
HorizontalRight | Horizontal right type
HorizontalLeft | Horizontal left type
VerticalDown | Vertical right type
VerticalUp | Vertical left type

See Also

Advantech.Graph Namespace


enumVerLabOrientation Enumeration

enumVerLabOrientation Enumeration
[image]

Vertical label orientation enumeration

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Enum enumVerLabOrientation
C#
public enum enumVerLabOrientation
C++
public enum class enumVerLabOrientation
J#
public enum enumVerLabOrientation
JScript
public enum enumVerLabOrientation

Members

Member Name | Description
Non | Non
Left | Left type
Right | Right type

See Also

Advantech.Graph Namespace


HorLabTag Class

HorLabTag Class
See Also Example Members
[image]

The horizontal label tag

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Class HorLabTag
C#
public class HorLabTag
C++
ref class HorLabTag
J#
public class HorLabTag
JScript
public class HorLabTag

Inheritance Hierarchy

System.Object
Advantech.Graph.HorLabTag

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

HorLabTag Members
Advantech.Graph Namespace


HorLabTag Members

HorLabTag Members
See Also Example Constructors Fields Properties Methods
[image]

The horizontal label tag

The following tables list the members exposed by HorLabTag.

Public Constructors

 | Name | Description
Public method | HorLabTag | The horizontal label tag constructor
Top

Public Fields

 | Name | Description
Public field | iLocationX | Location X
Public field | szNum | Label string
Top

Public Properties

 | Name | Description
Public property | dataTime | Create dataTime
Top

Public Methods

 | Name | Description
Public method | ShiftLocation | Shift the location
Top

See Also

HorLabTag Class
Advantech.Graph Namespace


HorLabTag Constructor

HorLabTag Constructor
[image]

The horizontal label tag constructor

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public HorLabTag()
C++
public:
HorLabTag() sealed
J#
public HorLabTag()
JScript
public function HorLabTag()

See Also

HorLabTag Class
Advantech.Graph Namespace


Fields

HorLabTag Fields
[image]

Public Fields

 | Name | Description
Public field | iLocationX | Location X
Public field | szNum | Label string
Top

See Also

HorLabTag Class
Advantech.Graph Namespace


iLocationX Field

HorLabTag.iLocationX Field
[image]

Location X

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public iLocationX As Integer
C#
public int iLocationX;
C++
public:
int iLocationX sealed ;
J#
public int iLocationX
JScript
public iLocationX : int;

See Also

HorLabTag Class
Advantech.Graph Namespace


szNum Field

HorLabTag.szNum Field
[image]

Label string

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public szNum As String
C#
public string szNum;
C++
public:
String szNum sealed ;
J#
public string szNum
JScript
public szNum : String;

See Also

HorLabTag Class
Advantech.Graph Namespace


Properties

HorLabTag Properties
[image]

Public Properties

 | Name | Description
Public property | dataTime | Create dataTime
Top

See Also

HorLabTag Class
Advantech.Graph Namespace


dataTime Property

HorLabTag.dataTime Property
[image]

Create dataTime

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property dataTime As Date
C#
public DateTime dataTime { get; }
C++
public property DateTime dataTime sealed {
DateTime get();
}
J#
/** property */
public DateTime get_dataTime();
JScript
public function get dataTime() : DateTime

See Also

HorLabTag Class
Advantech.Graph Namespace


Methods

HorLabTag Methods
[image]

Public Methods

 | Name | Description
Public method | ShiftLocation | Shift the location
Top

See Also

HorLabTag Class
Advantech.Graph Namespace


ShiftLocation Method

HorLabTag.ShiftLocation Method
[image]

Shift the location

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub ShiftLocation( _
ByVal sftX As Integer _
)
C#
public void ShiftLocation(
int sftX
)
C++
public:
void ShiftLocation(
int sftX
) sealed
J#
public void ShiftLocation(
int sftX
)
JScript
public function ShiftLocation(
sftX : int
)

Parameters

sftX

See Also

HorLabTag Class
Advantech.Graph Namespace


LightStyle Enumeration

LightStyle Enumeration
[image]

The style of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Enum LightStyle
C#
public enum LightStyle
C++
public enum class LightStyle
J#
public enum LightStyle
JScript
public enum LightStyle

Members

Member Name | Description
Round | Round style.
Rectangle | Rectangle style.
TriangleUp | Triangle style points up.
TriangleDown | Triangle style points down.
TriangleLeft | Triangle style points left.
TriangleRight | Triangle style points right.

See Also

Advantech.Graph Namespace


LineSegment Class

LineSegment Class
See Also Example Members
[image]

The collection of AdvantechLine.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Class LineSegment
C#
public class LineSegment
C++
ref class LineSegment
J#
public class LineSegment
JScript
public class LineSegment

Inheritance Hierarchy

System.Object
Advantech.Graph.LineSegment

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LineSegment Members
Advantech.Graph Namespace


LineSegment Members

LineSegment Members
See Also Example Constructors Properties
[image]

The collection of AdvantechLine.

The following tables list the members exposed by LineSegment.

Public Constructors

 | Name | Description
Public method | LineSegment | The LineSegment constructor.
Top

Public Properties

 | Name | Description
Public property | LineArray | Get line array.
Top

See Also

LineSegment Class
Advantech.Graph Namespace


LineSegment Constructor

LineSegment Constructor
[image]

The LineSegment constructor.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LineSegment()
C++
public:
LineSegment() sealed
J#
public LineSegment()
JScript
public function LineSegment()

See Also

LineSegment Class
Advantech.Graph Namespace


Properties

LineSegment Properties
[image]

Public Properties

 | Name | Description
Public property | LineArray | Get line array.
Top

See Also

LineSegment Class
Advantech.Graph Namespace


LineArray Property

LineSegment.LineArray Property
[image]

Get line array.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineArray As ArrayList
C#
public ArrayList LineArray { get; }
C++
public property ArrayList LineArray sealed {
ArrayList get();
}
J#
/** property */
public ArrayList get_LineArray();
JScript
public function get LineArray() : ArrayList

See Also

LineSegment Class
Advantech.Graph Namespace


MiniLZO Class

MiniLZO Class
See Also Example Members
[image]

MiniLZO native code * ManagedLZO.MiniLZO * * Minimalistic reimplementation of minilzo in C# * * @author Shane Eric Bryldt, Copyright (C) 2006, All Rights Reserved * @note Uses unsafe/fixed pointer contexts internally * @liscence Bound by same liscence as minilzo as below, see file COPYING Based on minilzo.c -- mini subset of the LZO real-time data compression library This file is part of the LZO real-time data compression library. Copyright (C) 2005 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2004 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2003 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2002 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2001 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2000 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1999 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1998 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1997 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1996 Markus Franz Xaver Johannes Oberhumer All Rights Reserved. The LZO library is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License, version 2, as published by the Free Software Foundation. The LZO library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with the LZO library; see the file COPYING. If not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. Markus F.X.J. Oberhumer markus@oberhumer.com http://www.oberhumer.com/opensource/lzo/ * NOTE: * the full LZO package can be found at * http://www.oberhumer.com/opensource/lzo/ This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Module MiniLZO
C#
public static class MiniLZO
C++
ref class MiniLZO abstract sealed
J#
public final class MiniLZO
JScript
public class MiniLZO

Inheritance Hierarchy

System.Object
Advantech.Graph.MiniLZO

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MiniLZO Members
Advantech.Graph Namespace


MiniLZO Members

MiniLZO Members
See Also Example Methods
[image]

MiniLZO native code * ManagedLZO.MiniLZO * * Minimalistic reimplementation of minilzo in C# * * @author Shane Eric Bryldt, Copyright (C) 2006, All Rights Reserved * @note Uses unsafe/fixed pointer contexts internally * @liscence Bound by same liscence as minilzo as below, see file COPYING Based on minilzo.c -- mini subset of the LZO real-time data compression library This file is part of the LZO real-time data compression library. Copyright (C) 2005 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2004 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2003 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2002 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2001 Markus Franz Xaver Johannes Oberhumer Copyright (C) 2000 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1999 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1998 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1997 Markus Franz Xaver Johannes Oberhumer Copyright (C) 1996 Markus Franz Xaver Johannes Oberhumer All Rights Reserved. The LZO library is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License, version 2, as published by the Free Software Foundation. The LZO library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with the LZO library; see the file COPYING. If not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. Markus F.X.J. Oberhumer markus@oberhumer.com http://www.oberhumer.com/opensource/lzo/ * NOTE: * the full LZO package can be found at * http://www.oberhumer.com/opensource/lzo/ This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by MiniLZO.

Public Methods

Name | Description
Compress |
Decompress |
Top

See Also

MiniLZO Class
Advantech.Graph Namespace


Methods

MiniLZO Methods
[image]

Public Methods

Name | Description
Compress |
Decompress |
Top

See Also

MiniLZO Class
Advantech.Graph Namespace


Compress Method

MiniLZO.Compress Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Compress( _
ByVal src As Byte(), _
<OutAttribute> ByRef dst As Byte _
)
C#
public static void Compress(
byte[] src,
out byte dst
)
C++
public:
static void Compress(
array<char>^ src,
[OutAttribute] char% dst
)
J#
public static void Compress(
byte[] src,
/** @attribute OutAttribute() */ /** @ref */ byte dst
)
JScript
public static function Compress(
src : Byte[],
OutAttribute dst : Byte
)

Parameters

src
dst

See Also

MiniLZO Class
Advantech.Graph Namespace


Decompress Method

MiniLZO.Decompress Method
[image]

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Decompress( _
ByVal src As Byte(), _
ByVal src_len As Integer, _
ByVal dst As Byte(), _
ByRef dst_len As Integer _
)
C#
public static void Decompress(
byte[] src,
int src_len,
byte[] dst,
ref int dst_len
)
C++
public:
static void Decompress(
array<char>^ src,
int src_len,
array<char>^ dst,
int% dst_len
)
J#
public static void Decompress(
byte[] src,
int src_len,
byte[] dst,
int dst_len
)
JScript
public static function Decompress(
src : Byte[],
src_len : int,
dst : Byte[],
dst_len : int
)

Parameters

src
src_len
dst
dst_len

See Also

MiniLZO Class
Advantech.Graph Namespace


Shape Enumeration

Shape Enumeration
[image]

The shape of the control.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Enum Shape
C#
public enum Shape
C++
public enum class Shape
J#
public enum Shape
JScript
public enum Shape

Members

Member Name | Description
Rectangle | Rectangle shape.
Triangle | Triangle shape.

See Also

Advantech.Graph Namespace


ValueChangedEventHandler Delegate

ValueChangedEventHandler Delegate
[image]

A delegate type for hooking up ValueChanged notifications.

Namespace: Advantech.Graph
Assembly: Advantech.Graph (in Advantech.Graph.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ValueChangedEventHandler( _
ByVal Sender As Object _
)
C#
public delegate void ValueChangedEventHandler(
object Sender
)
C++
public delegate void ValueChangedEventHandler(
Object Sender
)
J#
/** delegate */
public delegate void ValueChangedEventHandler(
object Sender
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Graph Namespace


Advantech.Protocol

Advantech.Protocol Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ModbusRTUClient | ModbusRTUClient class is used as a MODBUS packet constructor as well as a MODBUS packet parse for those running on serial communication.
Public class | ModbusRTUServer |
Public class | ModbusServerBase |
Public class | ModbusTCPClient | ModbusTCPClient class is used as a MODBUS/TCP packet constructor as well as a MODBUS/TCP packet parse for those running on ethernet communication.
Public class | ModbusTCPServer |
Public class | TCPSocketListener |

Delegates

 | Delegate | Description
NestedPublic delegate | ModbusServerBase.EventHandler_OnCoilChangedEvent |
NestedPublic delegate | ModbusServerBase.EventHandler_OnHoldRegChangedEvent |
NestedPublic delegate | ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent |
NestedPublic delegate | ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent |
NestedPublic delegate | TCPSocketListener.OnCoilChanged |
NestedPublic delegate | TCPSocketListener.OnRegChanged |

Enumerations

 | Enumeration | Description
Public enumeration | ModbusDataType | The MODBUS data segment type.
Public enumeration | ModbusFunction | Modbus RTU command


ModbusDataType Enumeration

ModbusDataType Enumeration
[image]

The MODBUS data segment type.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Enum ModbusDataType
C#
public enum ModbusDataType
C++
public enum class ModbusDataType
J#
public enum ModbusDataType
JScript
public enum ModbusDataType

Members

Member Name | Description
CoilStatus | MODBUS coil status (0x references)
InputStatus | MODBUS input status (1x references)
InputRegister | MODBUS input register (3x references)
HoldingRegister | MODBUS holding register (4x references)

See Also

Advantech.Protocol Namespace


ModbusFunction Enumeration

ModbusFunction Enumeration
[image]

Modbus RTU command

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Enum ModbusFunction As Byte
C#
public enum ModbusFunction : byte
C++
public enum class ModbusFunction : char
J#
public enum ModbusFunction byte
JScript
public enum ModbusFunction :

Members

Member Name | Description
ReadCoilStatus | Read coil status
ReadInputStatus | Read coil status
ReadHoldingResisters | Read holding registers
ReadInputRegisters | Read input registers
ForceSingleCoil | Force single coil
PresetSingleRegisters | Preset single registers
ForceMutipleCoils | Force multiple coils
PresetMutipleRegisters | Preset multiple registers

See Also

Advantech.Protocol Namespace


ModbusRTUClient Class

ModbusRTUClient Class
See Also Example Members
[image]

ModbusRTUClient class is used as a MODBUS packet constructor as well as a MODBUS packet parse for those running on serial communication.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Class ModbusRTUClient
C#
public class ModbusRTUClient
C++
ref class ModbusRTUClient
J#
public class ModbusRTUClient
JScript
public class ModbusRTUClient

Inheritance Hierarchy

System.Object
Advantech.Protocol.ModbusRTUClient

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ModbusRTUClient Members
Advantech.Protocol Namespace


ModbusRTUClient Members

ModbusRTUClient Members
See Also Example Constructors Properties Methods
[image]

ModbusRTUClient class is used as a MODBUS packet constructor as well as a MODBUS packet parse for those running on serial communication.

The following tables list the members exposed by ModbusRTUClient.

Public Constructors

 | Name | Description
Public method | ModbusRTUClient | Initializes a new instance of the ModbusRTUClient class.
Top

Public Properties

Name | Description
LastError | The last error code
Top

Public Methods

Name | Description
ConstructForceMultiCoils | Construct modbus function 0F sending packet
ConstructForceSingleCoil | Construct modbus function 05 sending packet
ConstructPresetMultiRegs | Construct modbus function 10 sending packet
ConstructPresetSingleReg | Construct modbus function 06 sending packet
ConstructReadAdvantechRegs | Construct modbus function 20 sending packet
ConstructReadCoilStatus | Construct modbus function 01 sending packet
ConstructReadCustomizeRegs | Construct modbus customize function sending packet
ConstructReadHoldingRegs | Construct modbus function 03 sending packet
ConstructReadInputRegs | Construct modbus function 04 sending packet
ConstructReadInputStatus | Construct modbus function 02 sending packet
ConstructWriteAdvantechRegs | Construct modbus function 21 sending packet
ConstructWriteCustomizeRegs | Construct modbus customize function sending packet
VerifyForceMultiCoils | Parse the received packet for modbus function 0F
VerifyForceSingleCoil | Parse the received packet for modbus function 05
VerifyPresetMultiRegs | Parse the received packet for modbus function 10
VerifyPresetSingleReg | Parse the received packet for modbus function 06
VerifyReadAdvantechRegs | Parse the received packet for modbus function 20
VerifyReadCoilStatus | Parse the received packet for modbus function 01
VerifyReadCustomizeRegs | Parse the received packet for modbus function 03
VerifyReadHoldingRegs | Parse the received packet for modbus function 03
VerifyReadInputRegs | Parse the received packet for modbus function 04
VerifyReadInputStatus | Parse the received packet for modbus function 02
VerifyWriteAdvantechRegs | Parse the received packet for modbus function 21
VerifyWriteCustomizeRegs | Parse the received packet for modbus customize function
Top

Protected Methods

Name | Description
ConstructSendPacket | Construct Function 1-4 sending packet
VerifyRecvPacket | Parse Function 1-4 received packet
Top

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ModbusRTUClient Constructor

ModbusRTUClient Constructor
[image]

Initializes a new instance of the ModbusRTUClient class.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ModbusRTUClient()
C++
public:
ModbusRTUClient() sealed
J#
public ModbusRTUClient()
JScript
public function ModbusRTUClient()

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


Properties

ModbusRTUClient Properties
[image]

Public Properties

Name | Description
LastError | The last error code
Top

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


LastError Property

ModbusRTUClient.LastError Property
[image]

The last error code

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property LastError As ErrorCode
C#
public static ErrorCode LastError { get; }
C++
public static property ErrorCode LastError {
ErrorCode get();
}
J#
/** property */
public ErrorCode get_LastError();
JScript
public function get LastError() : ErrorCode

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


Methods

ModbusRTUClient Methods
[image]

Public Methods

Name | Description
ConstructForceMultiCoils | Construct modbus function 0F sending packet
ConstructForceSingleCoil | Construct modbus function 05 sending packet
ConstructPresetMultiRegs | Construct modbus function 10 sending packet
ConstructPresetSingleReg | Construct modbus function 06 sending packet
ConstructReadAdvantechRegs | Construct modbus function 20 sending packet
ConstructReadCoilStatus | Construct modbus function 01 sending packet
ConstructReadCustomizeRegs | Construct modbus customize function sending packet
ConstructReadHoldingRegs | Construct modbus function 03 sending packet
ConstructReadInputRegs | Construct modbus function 04 sending packet
ConstructReadInputStatus | Construct modbus function 02 sending packet
ConstructWriteAdvantechRegs | Construct modbus function 21 sending packet
ConstructWriteCustomizeRegs | Construct modbus customize function sending packet
VerifyForceMultiCoils | Parse the received packet for modbus function 0F
VerifyForceSingleCoil | Parse the received packet for modbus function 05
VerifyPresetMultiRegs | Parse the received packet for modbus function 10
VerifyPresetSingleReg | Parse the received packet for modbus function 06
VerifyReadAdvantechRegs | Parse the received packet for modbus function 20
VerifyReadCoilStatus | Parse the received packet for modbus function 01
VerifyReadCustomizeRegs | Parse the received packet for modbus function 03
VerifyReadHoldingRegs | Parse the received packet for modbus function 03
VerifyReadInputRegs | Parse the received packet for modbus function 04
VerifyReadInputStatus | Parse the received packet for modbus function 02
VerifyWriteAdvantechRegs | Parse the received packet for modbus function 21
VerifyWriteCustomizeRegs | Parse the received packet for modbus customize function
Top

Protected Methods

Name | Description
ConstructSendPacket | Construct Function 1-4 sending packet
VerifyRecvPacket | Parse Function 1-4 received packet
Top

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructForceMultiCoils Method

ModbusRTUClient.ConstructForceMultiCoils Method
[image]

Construct modbus function 0F sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructForceMultiCoils( _
ByVal i_iAddr As Integer, _
ByVal i_iCoilIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructForceMultiCoils(
int i_iAddr,
int i_iCoilIndex,
int i_iTotalPoint,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructForceMultiCoils(
int i_iAddr,
int i_iCoilIndex,
int i_iTotalPoint,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructForceMultiCoils(
int i_iAddr,
int i_iCoilIndex,
int i_iTotalPoint,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructForceMultiCoils(
i_iAddr : int,
i_iCoilIndex : int,
i_iTotalPoint : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address.
i_iCoilIndex
The start coil index for setting.
i_iTotalPoint
The total coil to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructForceSingleCoil Method

ModbusRTUClient.ConstructForceSingleCoil Method
[image]

Construct modbus function 05 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructForceSingleCoil( _
ByVal i_iAddr As Integer, _
ByVal i_iCoilIndex As Integer, _
ByVal i_iData As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructForceSingleCoil(
int i_iAddr,
int i_iCoilIndex,
int i_iData,
out byte o_byPacket
)
C++
public:
static void ConstructForceSingleCoil(
int i_iAddr,
int i_iCoilIndex,
int i_iData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructForceSingleCoil(
int i_iAddr,
int i_iCoilIndex,
int i_iData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructForceSingleCoil(
i_iAddr : int,
i_iCoilIndex : int,
i_iData : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iCoilIndex
The coil index for setting
i_iData
The data to set, 0 for OFF, 1 for ON
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructPresetMultiRegs Method

ModbusRTUClient.ConstructPresetMultiRegs Method
[image]

Construct modbus function 10 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructPresetMultiRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartReg As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructPresetMultiRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructPresetMultiRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructPresetMultiRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructPresetMultiRegs(
i_iAddr : int,
i_iStartReg : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartReg
The start register index for setting.
i_iTotalReg
The total register to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructPresetSingleReg Method

ModbusRTUClient.ConstructPresetSingleReg Method
[image]

Construct modbus function 06 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructPresetSingleReg( _
ByVal i_iAddr As Integer, _
ByVal i_iRegIndex As Integer, _
ByVal i_iData As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructPresetSingleReg(
int i_iAddr,
int i_iRegIndex,
int i_iData,
out byte o_byPacket
)
C++
public:
static void ConstructPresetSingleReg(
int i_iAddr,
int i_iRegIndex,
int i_iData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructPresetSingleReg(
int i_iAddr,
int i_iRegIndex,
int i_iData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructPresetSingleReg(
i_iAddr : int,
i_iRegIndex : int,
i_iData : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address.
i_iRegIndex
The register index for setting.
i_iData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructReadAdvantechRegs Method

ModbusRTUClient.ConstructReadAdvantechRegs Method
[image]

Construct modbus function 20 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadAdvantechRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadAdvantechRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadAdvantechRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadAdvantechRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadAdvantechRegs(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructReadCoilStatus Method

ModbusRTUClient.ConstructReadCoilStatus Method
[image]

Construct modbus function 01 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadCoilStatus( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadCoilStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadCoilStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadCoilStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadCoilStatus(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructReadCustomizeRegs Method

ModbusRTUClient.ConstructReadCustomizeRegs Method
[image]

Construct modbus customize function sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadCustomizeRegs(
i_iCommand : int,
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iCommand
Customize command
i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructReadHoldingRegs Method

ModbusRTUClient.ConstructReadHoldingRegs Method
[image]

Construct modbus function 03 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadHoldingRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadHoldingRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadHoldingRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadHoldingRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadHoldingRegs(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructReadInputRegs Method

ModbusRTUClient.ConstructReadInputRegs Method
[image]

Construct modbus function 04 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadInputRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadInputRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadInputRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadInputRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadInputRegs(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructReadInputStatus Method

ModbusRTUClient.ConstructReadInputStatus Method
[image]

Construct modbus function 02 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadInputStatus( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadInputStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadInputStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadInputStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadInputStatus(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructSendPacket Method

ModbusRTUClient.ConstructSendPacket Method
[image]

Construct Function 1-4 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub ConstructSendPacket( _
ByVal i_iAddr As Integer, _
ByVal i_iFun As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
protected static void ConstructSendPacket(
int i_iAddr,
int i_iFun,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
protected:
static void ConstructSendPacket(
int i_iAddr,
int i_iFun,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
protected static void ConstructSendPacket(
int i_iAddr,
int i_iFun,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
protected static function ConstructSendPacket(
i_iAddr : int,
i_iFun : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
Target address
i_iFun
Function number
i_iStartIndex
Start index
i_iTotalPoint
Total point
o_byPacket
packet data

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructWriteAdvantechRegs Method

ModbusRTUClient.ConstructWriteAdvantechRegs Method
[image]

Construct modbus function 21 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructWriteAdvantechRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartReg As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructWriteAdvantechRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructWriteAdvantechRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructWriteAdvantechRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructWriteAdvantechRegs(
i_iAddr : int,
i_iStartReg : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartReg
The start register index for setting.
i_iTotalReg
The total register to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ConstructWriteCustomizeRegs Method

ModbusRTUClient.ConstructWriteCustomizeRegs Method
[image]

Construct modbus customize function sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructWriteCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iAddr As Integer, _
ByVal i_iStartReg As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructWriteCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructWriteCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructWriteCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructWriteCustomizeRegs(
i_iCommand : int,
i_iAddr : int,
i_iStartReg : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iCommand
Customize command
i_iAddr
The slave address
i_iStartReg
The start register index for setting.
i_iTotalReg
The total register to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyForceMultiCoils Method

ModbusRTUClient.VerifyForceMultiCoils Method
[image]

Parse the received packet for modbus function 0F

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyForceMultiCoils( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyForceMultiCoils(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyForceMultiCoils(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyForceMultiCoils(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyForceMultiCoils(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyForceSingleCoil Method

ModbusRTUClient.VerifyForceSingleCoil Method
[image]

Parse the received packet for modbus function 05

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyForceSingleCoil( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyForceSingleCoil(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyForceSingleCoil(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyForceSingleCoil(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyForceSingleCoil(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyPresetMultiRegs Method

ModbusRTUClient.VerifyPresetMultiRegs Method
[image]

Parse the received packet for modbus function 10

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyPresetMultiRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyPresetMultiRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyPresetMultiRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyPresetMultiRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyPresetMultiRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyPresetSingleReg Method

ModbusRTUClient.VerifyPresetSingleReg Method
[image]

Parse the received packet for modbus function 06

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyPresetSingleReg( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyPresetSingleReg(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyPresetSingleReg(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyPresetSingleReg(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyPresetSingleReg(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyReadAdvantechRegs Method

ModbusRTUClient.VerifyReadAdvantechRegs Method
[image]

Parse the received packet for modbus function 20

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadAdvantechRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadAdvantechRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadAdvantechRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyReadCoilStatus Method

ModbusRTUClient.VerifyReadCoilStatus Method
[image]

Parse the received packet for modbus function 01

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadCoilStatus( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadCoilStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadCoilStatus(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadCoilStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadCoilStatus(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyReadCustomizeRegs Method

ModbusRTUClient.VerifyReadCustomizeRegs Method
[image]

Parse the received packet for modbus function 03

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadCustomizeRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadCustomizeRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadCustomizeRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyReadHoldingRegs Method

ModbusRTUClient.VerifyReadHoldingRegs Method
[image]

Parse the received packet for modbus function 03

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadHoldingRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadHoldingRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadHoldingRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadHoldingRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadHoldingRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyReadInputRegs Method

ModbusRTUClient.VerifyReadInputRegs Method
[image]

Parse the received packet for modbus function 04

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadInputRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadInputRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadInputRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadInputRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadInputRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyReadInputStatus Method

ModbusRTUClient.VerifyReadInputStatus Method
[image]

Parse the received packet for modbus function 02

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadInputStatus( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadInputStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadInputStatus(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadInputStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadInputStatus(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyRecvPacket Method

ModbusRTUClient.VerifyRecvPacket Method
[image]

Parse Function 1-4 received packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function VerifyRecvPacket( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
protected static bool VerifyRecvPacket(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
protected:
static bool VerifyRecvPacket(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
protected static bool VerifyRecvPacket(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
protected static function VerifyRecvPacket(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyWriteAdvantechRegs Method

ModbusRTUClient.VerifyWriteAdvantechRegs Method
[image]

Parse the received packet for modbus function 21

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyWriteAdvantechRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyWriteAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyWriteAdvantechRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyWriteAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyWriteAdvantechRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


VerifyWriteCustomizeRegs Method

ModbusRTUClient.VerifyWriteCustomizeRegs Method
[image]

Parse the received packet for modbus customize function

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyWriteCustomizeRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyWriteCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyWriteCustomizeRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyWriteCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyWriteCustomizeRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusRTUClient Class
Advantech.Protocol Namespace


ModbusRTUServer Class

ModbusRTUServer Class
See Also Example Members
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Class ModbusRTUServer
Inherits ModbusServerBase
C#
public class ModbusRTUServer : ModbusServerBase
C++
ref class ModbusRTUServer : ModbusServerBase
J#
public class ModbusRTUServer extends ModbusServerBase
JScript
public class ModbusRTUServer extends ModbusServerBase

Inheritance Hierarchy

System.Object
Advantech.Protocol.ModbusServerBase
Advantech.Protocol.ModbusRTUServer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ModbusRTUServer Members
Advantech.Protocol Namespace


ModbusRTUServer Members

ModbusRTUServer Members
See Also Example Constructors Fields Methods Events
[image]

The following tables list the members exposed by ModbusRTUServer.

Public Constructors

 | Name | Description
Public method | ModbusRTUServer |
Top

Public Fields

Name | Description
DEFAULT_TIMEOUT |
Top

Public Methods

 | Name | Description
Public method | CalculateCommandRemainByteLength | Calculate the command remainning length in byte.
Public method | SetRtuServerComm | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
Public method | SetRtuServerPriority | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
Public method | SetRtuServerTimeout | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
Public method | Start | Start the MODBUS/RTU server.
Public method | Stop | Stop the MODBUS/RTU server.
Top

Public Events

 | Name | Description
Public event | OnCoilChangedEvent |
Public event | OnHoldRegChangedEvent |
Top

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


ModbusRTUServer Constructor

ModbusRTUServer Constructor
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal i_uiComIndex As UInt32 _
)
C#
public ModbusRTUServer(
uint i_uiComIndex
)
C++
public:
ModbusRTUServer(
unsigned int i_uiComIndex
) sealed
J#
public ModbusRTUServer(
uint i_uiComIndex
)
JScript
public function ModbusRTUServer(
i_uiComIndex : UInt32
)

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


Fields

ModbusRTUServer Fields
[image]

Public Fields

Name | Description
DEFAULT_TIMEOUT |
Top

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


DEFAULT_TIMEOUT Field

ModbusRTUServer.DEFAULT_TIMEOUT Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DEFAULT_TIMEOUT As Integer
C#
public static readonly int DEFAULT_TIMEOUT;
C++
public:
static const int DEFAULT_TIMEOUT;
J#
public static final int DEFAULT_TIMEOUT
JScript
public static const var DEFAULT_TIMEOUT : int;

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


Methods

ModbusRTUServer Methods
[image]

Public Methods

 | Name | Description
Public method | CalculateCommandRemainByteLength | Calculate the command remainning length in byte.
Public method | SetRtuServerComm | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
Public method | SetRtuServerPriority | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
Public method | SetRtuServerTimeout | Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.
Public method | Start | Start the MODBUS/RTU server.
Public method | Stop | Stop the MODBUS/RTU server.
Top

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


CalculateCommandRemainByteLength Method

ModbusRTUServer.CalculateCommandRemainByteLength Method
[image]

Calculate the command remainning length in byte.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function CalculateCommandRemainByteLength( _
ByRef Command As Byte _
) As Integer
C#
public int CalculateCommandRemainByteLength(
ref byte Command
)
C++
public:
int CalculateCommandRemainByteLength(
char% Command
) sealed
J#
public int CalculateCommandRemainByteLength(
byte Command
)
JScript
public function CalculateCommandRemainByteLength(
Command : Byte
) : int

Return Value

Return length of command (Byte).

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


SetRtuServerComm Method

ModbusRTUServer.SetRtuServerComm Method
[image]

Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRtuServerComm( _
ByVal i_lBaudrate As Baudrate, _
ByVal i_iDataBits As Databits, _
ByVal i_iParity As Parity, _
ByVal i_iStop As Stopbits _
) As Integer
C#
public int SetRtuServerComm(
Baudrate i_lBaudrate,
Databits i_iDataBits,
Parity i_iParity,
Stopbits i_iStop
)
C++
public:
int SetRtuServerComm(
Baudrate i_lBaudrate,
Databits i_iDataBits,
Parity i_iParity,
Stopbits i_iStop
) sealed
J#
public int SetRtuServerComm(
Baudrate i_lBaudrate,
Databits i_iDataBits,
Parity i_iParity,
Stopbits i_iStop
)
JScript
public function SetRtuServerComm(
i_lBaudrate : Baudrate,
i_iDataBits : Databits,
i_iParity : Parity,
i_iStop : Stopbits
) : int

Return Value

True if succeed, otherwise false.

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


SetRtuServerPriority Method

ModbusRTUServer.SetRtuServerPriority Method
[image]

Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRtuServerPriority( _
ByVal i_uiPriority As UInt32 _
) As Integer
C#
public int SetRtuServerPriority(
uint i_uiPriority
)
C++
public:
int SetRtuServerPriority(
unsigned int i_uiPriority
) sealed
J#
public int SetRtuServerPriority(
uint i_uiPriority
)
JScript
public function SetRtuServerPriority(
i_uiPriority : UInt32
) : int

Return Value

True if succeed, otherwise false.

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


SetRtuServerTimeout Method

ModbusRTUServer.SetRtuServerTimeout Method
[image]

Set the priority of the MODBUS/RTU server running thread. Before calling this function, the MODBUS/RTU server has to be successfully started.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function SetRtuServerTimeout( _
ByVal i_iReadIntervalTimeout As Integer, _
ByVal i_iReadTotalTimeoutConstant As Integer, _
ByVal i_iReadTotalTimeoutMultiplier As Integer, _
ByVal i_iWriteTotalTimeoutConstant As Integer, _
ByVal i_iWriteTotalTimeoutMultiplier As Integer _
) As Integer
C#
public int SetRtuServerTimeout(
int i_iReadIntervalTimeout,
int i_iReadTotalTimeoutConstant,
int i_iReadTotalTimeoutMultiplier,
int i_iWriteTotalTimeoutConstant,
int i_iWriteTotalTimeoutMultiplier
)
C++
public:
int SetRtuServerTimeout(
int i_iReadIntervalTimeout,
int i_iReadTotalTimeoutConstant,
int i_iReadTotalTimeoutMultiplier,
int i_iWriteTotalTimeoutConstant,
int i_iWriteTotalTimeoutMultiplier
) sealed
J#
public int SetRtuServerTimeout(
int i_iReadIntervalTimeout,
int i_iReadTotalTimeoutConstant,
int i_iReadTotalTimeoutMultiplier,
int i_iWriteTotalTimeoutConstant,
int i_iWriteTotalTimeoutMultiplier
)
JScript
public function SetRtuServerTimeout(
i_iReadIntervalTimeout : int,
i_iReadTotalTimeoutConstant : int,
i_iReadTotalTimeoutMultiplier : int,
i_iWriteTotalTimeoutConstant : int,
i_iWriteTotalTimeoutMultiplier : int
) : int

Return Value

True if succeed, otherwise false.

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


Start Method

ModbusRTUServer.Start Method
[image]

Start the MODBUS/RTU server.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function Start( _
ByVal i_bySlaveAddr As Byte _
) As Integer
C#
public int Start(
byte i_bySlaveAddr
)
C++
public:
int Start(
char i_bySlaveAddr
) sealed
J#
public int Start(
byte i_bySlaveAddr
)
JScript
public function Start(
i_bySlaveAddr : Byte
) : int

Return Value

True if succeed, otherwise false.

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


Stop Method

ModbusRTUServer.Stop Method
[image]

Stop the MODBUS/RTU server.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function Stop() As Integer
C#
public int Stop()
C++
public:
int Stop() sealed
J#
public int Stop()
JScript
public function Stop() : int

Return Value

True if succeed, otherwise false.

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


Events

ModbusRTUServer Events
[image]

Public Events

 | Name | Description
Public event | OnCoilChangedEvent |
Public event | OnHoldRegChangedEvent |
Top

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


OnCoilChangedEvent Event

ModbusRTUServer.OnCoilChangedEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event OnCoilChangedEvent As ModbusServerBase.EventHandler_OnCoilChangedEvent
C#
public event ModbusServerBase.EventHandler_OnCoilChangedEvent OnCoilChangedEvent
C++
public:
virtual event ModbusServerBase.EventHandler_OnCoilChangedEvent OnCoilChangedEvent {
void add(ModbusServerBase.EventHandler_OnCoilChangedEvent value) sealed ;
void remove(ModbusServerBase.EventHandler_OnCoilChangedEvent value) sealed ;
}
J#
/** event */
public final void add_OnCoilChangedEvent(ModbusServerBase.EventHandler_OnCoilChangedEvent value);

/** event */
public final void remove_OnCoilChangedEvent(ModbusServerBase.EventHandler_OnCoilChangedEvent value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


OnHoldRegChangedEvent Event

ModbusRTUServer.OnHoldRegChangedEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event OnHoldRegChangedEvent As ModbusServerBase.EventHandler_OnHoldRegChangedEvent
C#
public event ModbusServerBase.EventHandler_OnHoldRegChangedEvent OnHoldRegChangedEvent
C++
public:
virtual event ModbusServerBase.EventHandler_OnHoldRegChangedEvent OnHoldRegChangedEvent {
void add(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value) sealed ;
void remove(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value) sealed ;
}
J#
/** event */
public final void add_OnHoldRegChangedEvent(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value);

/** event */
public final void remove_OnHoldRegChangedEvent(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ModbusRTUServer Class
Advantech.Protocol Namespace


ModbusServerBase Class

ModbusServerBase Class
See Also Example Members
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Class ModbusServerBase
C#
public class ModbusServerBase
C++
ref class ModbusServerBase
J#
public class ModbusServerBase
JScript
public class ModbusServerBase

Inheritance Hierarchy

System.Object
Advantech.Protocol.ModbusServerBase
Advantech.Protocol.ModbusRTUServer
Advantech.Protocol.ModbusTCPServer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ModbusServerBase Members
Advantech.Protocol Namespace


ModbusServerBase Members

ModbusServerBase Members
See Also Example Constructors Fields Methods
[image]

The following tables list the members exposed by ModbusServerBase.

Public Constructors

 | Name | Description
Public method | ModbusServerBase | Initializes a new instance of the ModbusServerBase class.
Top

Public Fields

Name | Description
DEFAULT_IDLETIMEOUT |
DEFAULT_PORT |
DEFAULT_SERVER |
HiOnMask |
LoOnMask |
MAX_CLIENT |
MaxBytesOfCoil |
MaxBytesOfRegister |
MaxCoilNumber |
MaxRegistersNumber |
MODBUS_EXCEP_01 |
MODBUS_EXCEP_02 |
MODBUS_EXCEP_03 |
MODBUS_EXCEP_04 |
MODBUS_EXCEP_05 |
MODBUS_EXCEP_06 |
MODBUS_EXCEP_07 |
MODBUS_EXCEP_08 |
MODERR_BASE |
MODERR_CLOSESOCKET_FAILED |
MODERR_CONNECT_FAILED |
MODERR_CREATECLN_FAILED |
MODERR_CREATESOCK_FAILED |
MODERR_CREATESVR_FAILED |
MODERR_MEMALLOC_FAILED |
MODERR_MODEXCEPT_01 |
MODERR_MODEXCEPT_02 |
MODERR_MODEXCEPT_03 |
MODERR_MODEXCEPT_04 |
MODERR_MODEXCEPT_05 |
MODERR_MODEXCEPT_06 |
MODERR_MODEXCEPT_07 |
MODERR_MODEXCEPT_08 |
MODERR_MODEXCEPT_99 |
MODERR_PARAMETER_INVALID |
MODERR_RTUCLIENT_INVALID |
MODERR_RTUCOM_INUSED |
MODERR_RTUCRC_INVALID |
MODERR_SETPRIO_FAILED |
MODERR_SOCKET_CLOSED |
MODERR_SUCCESS |
MODERR_TCPCLIENT_INVALID |
MODERR_TCPRECV_FAILED |
MODERR_TCPSEND_FAILED |
MODERR_THREAD_BUSY |
MODERR_THREAD_RUNNING |
MODERR_THREAD_STOP |
MODERR_WAIT_TIMEOUT |
MODERR_WSACLEAN_FAILED |
MODERR_WSASTART_FAILED |
MODEXCEPT_BASE |
Top

Public Methods

Name | Description
ModbusParser |
TOOLGetCoil |
TOOLGetHoldReg |
TOOLGetInput |
TOOLGetInputReg |
TOOLSetCoil |
TOOLSetHoldReg |
TOOLToModbusException |
Top

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


ModbusServerBase Constructor

ModbusServerBase Constructor
[image]

Initializes a new instance of the ModbusServerBase class.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ModbusServerBase()
C++
public:
ModbusServerBase() sealed
J#
public ModbusServerBase()
JScript
public function ModbusServerBase()

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


Fields

ModbusServerBase Fields
[image]

Public Fields

Name | Description
DEFAULT_IDLETIMEOUT |
DEFAULT_PORT |
DEFAULT_SERVER |
HiOnMask |
LoOnMask |
MAX_CLIENT |
MaxBytesOfCoil |
MaxBytesOfRegister |
MaxCoilNumber |
MaxRegistersNumber |
MODBUS_EXCEP_01 |
MODBUS_EXCEP_02 |
MODBUS_EXCEP_03 |
MODBUS_EXCEP_04 |
MODBUS_EXCEP_05 |
MODBUS_EXCEP_06 |
MODBUS_EXCEP_07 |
MODBUS_EXCEP_08 |
MODERR_BASE |
MODERR_CLOSESOCKET_FAILED |
MODERR_CONNECT_FAILED |
MODERR_CREATECLN_FAILED |
MODERR_CREATESOCK_FAILED |
MODERR_CREATESVR_FAILED |
MODERR_MEMALLOC_FAILED |
MODERR_MODEXCEPT_01 |
MODERR_MODEXCEPT_02 |
MODERR_MODEXCEPT_03 |
MODERR_MODEXCEPT_04 |
MODERR_MODEXCEPT_05 |
MODERR_MODEXCEPT_06 |
MODERR_MODEXCEPT_07 |
MODERR_MODEXCEPT_08 |
MODERR_MODEXCEPT_99 |
MODERR_PARAMETER_INVALID |
MODERR_RTUCLIENT_INVALID |
MODERR_RTUCOM_INUSED |
MODERR_RTUCRC_INVALID |
MODERR_SETPRIO_FAILED |
MODERR_SOCKET_CLOSED |
MODERR_SUCCESS |
MODERR_TCPCLIENT_INVALID |
MODERR_TCPRECV_FAILED |
MODERR_TCPSEND_FAILED |
MODERR_THREAD_BUSY |
MODERR_THREAD_RUNNING |
MODERR_THREAD_STOP |
MODERR_WAIT_TIMEOUT |
MODERR_WSACLEAN_FAILED |
MODERR_WSASTART_FAILED |
MODEXCEPT_BASE |
Top

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


DEFAULT_IDLETIMEOUT Field

ModbusServerBase.DEFAULT_IDLETIMEOUT Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DEFAULT_IDLETIMEOUT As Long
C#
public static readonly long DEFAULT_IDLETIMEOUT;
C++
public:
static const __int64 DEFAULT_IDLETIMEOUT;
J#
public static final long DEFAULT_IDLETIMEOUT
JScript
public static const var DEFAULT_IDLETIMEOUT : long;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


DEFAULT_PORT Field

ModbusServerBase.DEFAULT_PORT Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DEFAULT_PORT As Integer
C#
public static readonly int DEFAULT_PORT;
C++
public:
static const int DEFAULT_PORT;
J#
public static final int DEFAULT_PORT
JScript
public static const var DEFAULT_PORT : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


DEFAULT_SERVER Field

ModbusServerBase.DEFAULT_SERVER Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DEFAULT_SERVER As IPAddress
C#
public static readonly IPAddress DEFAULT_SERVER;
C++
public:
static const IPAddress DEFAULT_SERVER;
J#
public static final IPAddress DEFAULT_SERVER
JScript
public static const var DEFAULT_SERVER : IPAddress;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


HiOnMask Field

ModbusServerBase.HiOnMask Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared HiOnMask As Byte()
C#
public static byte[] HiOnMask;
C++
public:
static array<char>^ HiOnMask;
J#
public static byte[] HiOnMask
JScript
public static HiOnMask : Byte[];

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


LoOnMask Field

ModbusServerBase.LoOnMask Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared LoOnMask As Byte()
C#
public static byte[] LoOnMask;
C++
public:
static array<char>^ LoOnMask;
J#
public static byte[] LoOnMask
JScript
public static LoOnMask : Byte[];

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MAX_CLIENT Field

ModbusServerBase.MAX_CLIENT Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MAX_CLIENT As Integer
C#
public static readonly int MAX_CLIENT;
C++
public:
static const int MAX_CLIENT;
J#
public static final int MAX_CLIENT
JScript
public static const var MAX_CLIENT : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MaxBytesOfCoil Field

ModbusServerBase.MaxBytesOfCoil Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxBytesOfCoil As UInt32
C#
public static readonly uint MaxBytesOfCoil;
C++
public:
static const unsigned int MaxBytesOfCoil;
J#
public static final uint MaxBytesOfCoil
JScript
public static const var MaxBytesOfCoil : UInt32;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MaxBytesOfRegister Field

ModbusServerBase.MaxBytesOfRegister Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxBytesOfRegister As UInt32
C#
public static readonly uint MaxBytesOfRegister;
C++
public:
static const unsigned int MaxBytesOfRegister;
J#
public static final uint MaxBytesOfRegister
JScript
public static const var MaxBytesOfRegister : UInt32;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MaxCoilNumber Field

ModbusServerBase.MaxCoilNumber Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxCoilNumber As UInt32
C#
public static readonly uint MaxCoilNumber;
C++
public:
static const unsigned int MaxCoilNumber;
J#
public static final uint MaxCoilNumber
JScript
public static const var MaxCoilNumber : UInt32;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MaxRegistersNumber Field

ModbusServerBase.MaxRegistersNumber Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxRegistersNumber As UInt32
C#
public static readonly uint MaxRegistersNumber;
C++
public:
static const unsigned int MaxRegistersNumber;
J#
public static final uint MaxRegistersNumber
JScript
public static const var MaxRegistersNumber : UInt32;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_01 Field

ModbusServerBase.MODBUS_EXCEP_01 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_01 As Byte
C#
public static readonly byte MODBUS_EXCEP_01;
C++
public:
static const char MODBUS_EXCEP_01;
J#
public static final byte MODBUS_EXCEP_01
JScript
public static const var MODBUS_EXCEP_01 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_02 Field

ModbusServerBase.MODBUS_EXCEP_02 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_02 As Byte
C#
public static readonly byte MODBUS_EXCEP_02;
C++
public:
static const char MODBUS_EXCEP_02;
J#
public static final byte MODBUS_EXCEP_02
JScript
public static const var MODBUS_EXCEP_02 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_03 Field

ModbusServerBase.MODBUS_EXCEP_03 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_03 As Byte
C#
public static readonly byte MODBUS_EXCEP_03;
C++
public:
static const char MODBUS_EXCEP_03;
J#
public static final byte MODBUS_EXCEP_03
JScript
public static const var MODBUS_EXCEP_03 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_04 Field

ModbusServerBase.MODBUS_EXCEP_04 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_04 As Byte
C#
public static readonly byte MODBUS_EXCEP_04;
C++
public:
static const char MODBUS_EXCEP_04;
J#
public static final byte MODBUS_EXCEP_04
JScript
public static const var MODBUS_EXCEP_04 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_05 Field

ModbusServerBase.MODBUS_EXCEP_05 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_05 As Byte
C#
public static readonly byte MODBUS_EXCEP_05;
C++
public:
static const char MODBUS_EXCEP_05;
J#
public static final byte MODBUS_EXCEP_05
JScript
public static const var MODBUS_EXCEP_05 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_06 Field

ModbusServerBase.MODBUS_EXCEP_06 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_06 As Byte
C#
public static readonly byte MODBUS_EXCEP_06;
C++
public:
static const char MODBUS_EXCEP_06;
J#
public static final byte MODBUS_EXCEP_06
JScript
public static const var MODBUS_EXCEP_06 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_07 Field

ModbusServerBase.MODBUS_EXCEP_07 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_07 As Byte
C#
public static readonly byte MODBUS_EXCEP_07;
C++
public:
static const char MODBUS_EXCEP_07;
J#
public static final byte MODBUS_EXCEP_07
JScript
public static const var MODBUS_EXCEP_07 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODBUS_EXCEP_08 Field

ModbusServerBase.MODBUS_EXCEP_08 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODBUS_EXCEP_08 As Byte
C#
public static readonly byte MODBUS_EXCEP_08;
C++
public:
static const char MODBUS_EXCEP_08;
J#
public static final byte MODBUS_EXCEP_08
JScript
public static const var MODBUS_EXCEP_08 : Byte;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_BASE Field

ModbusServerBase.MODERR_BASE Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_BASE As Integer
C#
public static readonly int MODERR_BASE;
C++
public:
static const int MODERR_BASE;
J#
public static final int MODERR_BASE
JScript
public static const var MODERR_BASE : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_CLOSESOCKET_FAILED Field

ModbusServerBase.MODERR_CLOSESOCKET_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CLOSESOCKET_FAILED As Integer
C#
public static readonly int MODERR_CLOSESOCKET_FAILED;
C++
public:
static const int MODERR_CLOSESOCKET_FAILED;
J#
public static final int MODERR_CLOSESOCKET_FAILED
JScript
public static const var MODERR_CLOSESOCKET_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_CONNECT_FAILED Field

ModbusServerBase.MODERR_CONNECT_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CONNECT_FAILED As Integer
C#
public static readonly int MODERR_CONNECT_FAILED;
C++
public:
static const int MODERR_CONNECT_FAILED;
J#
public static final int MODERR_CONNECT_FAILED
JScript
public static const var MODERR_CONNECT_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_CREATECLN_FAILED Field

ModbusServerBase.MODERR_CREATECLN_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CREATECLN_FAILED As Integer
C#
public static readonly int MODERR_CREATECLN_FAILED;
C++
public:
static const int MODERR_CREATECLN_FAILED;
J#
public static final int MODERR_CREATECLN_FAILED
JScript
public static const var MODERR_CREATECLN_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_CREATESOCK_FAILED Field

ModbusServerBase.MODERR_CREATESOCK_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CREATESOCK_FAILED As Integer
C#
public static readonly int MODERR_CREATESOCK_FAILED;
C++
public:
static const int MODERR_CREATESOCK_FAILED;
J#
public static final int MODERR_CREATESOCK_FAILED
JScript
public static const var MODERR_CREATESOCK_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_CREATESVR_FAILED Field

ModbusServerBase.MODERR_CREATESVR_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_CREATESVR_FAILED As Integer
C#
public static readonly int MODERR_CREATESVR_FAILED;
C++
public:
static const int MODERR_CREATESVR_FAILED;
J#
public static final int MODERR_CREATESVR_FAILED
JScript
public static const var MODERR_CREATESVR_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MEMALLOC_FAILED Field

ModbusServerBase.MODERR_MEMALLOC_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MEMALLOC_FAILED As Integer
C#
public static readonly int MODERR_MEMALLOC_FAILED;
C++
public:
static const int MODERR_MEMALLOC_FAILED;
J#
public static final int MODERR_MEMALLOC_FAILED
JScript
public static const var MODERR_MEMALLOC_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_01 Field

ModbusServerBase.MODERR_MODEXCEPT_01 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_01 As Integer
C#
public static readonly int MODERR_MODEXCEPT_01;
C++
public:
static const int MODERR_MODEXCEPT_01;
J#
public static final int MODERR_MODEXCEPT_01
JScript
public static const var MODERR_MODEXCEPT_01 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_02 Field

ModbusServerBase.MODERR_MODEXCEPT_02 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_02 As Integer
C#
public static readonly int MODERR_MODEXCEPT_02;
C++
public:
static const int MODERR_MODEXCEPT_02;
J#
public static final int MODERR_MODEXCEPT_02
JScript
public static const var MODERR_MODEXCEPT_02 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_03 Field

ModbusServerBase.MODERR_MODEXCEPT_03 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_03 As Integer
C#
public static readonly int MODERR_MODEXCEPT_03;
C++
public:
static const int MODERR_MODEXCEPT_03;
J#
public static final int MODERR_MODEXCEPT_03
JScript
public static const var MODERR_MODEXCEPT_03 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_04 Field

ModbusServerBase.MODERR_MODEXCEPT_04 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_04 As Integer
C#
public static readonly int MODERR_MODEXCEPT_04;
C++
public:
static const int MODERR_MODEXCEPT_04;
J#
public static final int MODERR_MODEXCEPT_04
JScript
public static const var MODERR_MODEXCEPT_04 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_05 Field

ModbusServerBase.MODERR_MODEXCEPT_05 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_05 As Integer
C#
public static readonly int MODERR_MODEXCEPT_05;
C++
public:
static const int MODERR_MODEXCEPT_05;
J#
public static final int MODERR_MODEXCEPT_05
JScript
public static const var MODERR_MODEXCEPT_05 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_06 Field

ModbusServerBase.MODERR_MODEXCEPT_06 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_06 As Integer
C#
public static readonly int MODERR_MODEXCEPT_06;
C++
public:
static const int MODERR_MODEXCEPT_06;
J#
public static final int MODERR_MODEXCEPT_06
JScript
public static const var MODERR_MODEXCEPT_06 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_07 Field

ModbusServerBase.MODERR_MODEXCEPT_07 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_07 As Integer
C#
public static readonly int MODERR_MODEXCEPT_07;
C++
public:
static const int MODERR_MODEXCEPT_07;
J#
public static final int MODERR_MODEXCEPT_07
JScript
public static const var MODERR_MODEXCEPT_07 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_08 Field

ModbusServerBase.MODERR_MODEXCEPT_08 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_08 As Integer
C#
public static readonly int MODERR_MODEXCEPT_08;
C++
public:
static const int MODERR_MODEXCEPT_08;
J#
public static final int MODERR_MODEXCEPT_08
JScript
public static const var MODERR_MODEXCEPT_08 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_MODEXCEPT_99 Field

ModbusServerBase.MODERR_MODEXCEPT_99 Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_MODEXCEPT_99 As Integer
C#
public static readonly int MODERR_MODEXCEPT_99;
C++
public:
static const int MODERR_MODEXCEPT_99;
J#
public static final int MODERR_MODEXCEPT_99
JScript
public static const var MODERR_MODEXCEPT_99 : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_PARAMETER_INVALID Field

ModbusServerBase.MODERR_PARAMETER_INVALID Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_PARAMETER_INVALID As Integer
C#
public static readonly int MODERR_PARAMETER_INVALID;
C++
public:
static const int MODERR_PARAMETER_INVALID;
J#
public static final int MODERR_PARAMETER_INVALID
JScript
public static const var MODERR_PARAMETER_INVALID : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_RTUCLIENT_INVALID Field

ModbusServerBase.MODERR_RTUCLIENT_INVALID Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_RTUCLIENT_INVALID As Integer
C#
public static readonly int MODERR_RTUCLIENT_INVALID;
C++
public:
static const int MODERR_RTUCLIENT_INVALID;
J#
public static final int MODERR_RTUCLIENT_INVALID
JScript
public static const var MODERR_RTUCLIENT_INVALID : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_RTUCOM_INUSED Field

ModbusServerBase.MODERR_RTUCOM_INUSED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_RTUCOM_INUSED As Integer
C#
public static readonly int MODERR_RTUCOM_INUSED;
C++
public:
static const int MODERR_RTUCOM_INUSED;
J#
public static final int MODERR_RTUCOM_INUSED
JScript
public static const var MODERR_RTUCOM_INUSED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_RTUCRC_INVALID Field

ModbusServerBase.MODERR_RTUCRC_INVALID Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_RTUCRC_INVALID As Integer
C#
public static readonly int MODERR_RTUCRC_INVALID;
C++
public:
static const int MODERR_RTUCRC_INVALID;
J#
public static final int MODERR_RTUCRC_INVALID
JScript
public static const var MODERR_RTUCRC_INVALID : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_SETPRIO_FAILED Field

ModbusServerBase.MODERR_SETPRIO_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_SETPRIO_FAILED As Integer
C#
public static readonly int MODERR_SETPRIO_FAILED;
C++
public:
static const int MODERR_SETPRIO_FAILED;
J#
public static final int MODERR_SETPRIO_FAILED
JScript
public static const var MODERR_SETPRIO_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_SOCKET_CLOSED Field

ModbusServerBase.MODERR_SOCKET_CLOSED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_SOCKET_CLOSED As Integer
C#
public static readonly int MODERR_SOCKET_CLOSED;
C++
public:
static const int MODERR_SOCKET_CLOSED;
J#
public static final int MODERR_SOCKET_CLOSED
JScript
public static const var MODERR_SOCKET_CLOSED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_SUCCESS Field

ModbusServerBase.MODERR_SUCCESS Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_SUCCESS As Integer
C#
public static readonly int MODERR_SUCCESS;
C++
public:
static const int MODERR_SUCCESS;
J#
public static final int MODERR_SUCCESS
JScript
public static const var MODERR_SUCCESS : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_TCPCLIENT_INVALID Field

ModbusServerBase.MODERR_TCPCLIENT_INVALID Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_TCPCLIENT_INVALID As Integer
C#
public static readonly int MODERR_TCPCLIENT_INVALID;
C++
public:
static const int MODERR_TCPCLIENT_INVALID;
J#
public static final int MODERR_TCPCLIENT_INVALID
JScript
public static const var MODERR_TCPCLIENT_INVALID : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_TCPRECV_FAILED Field

ModbusServerBase.MODERR_TCPRECV_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_TCPRECV_FAILED As Integer
C#
public static readonly int MODERR_TCPRECV_FAILED;
C++
public:
static const int MODERR_TCPRECV_FAILED;
J#
public static final int MODERR_TCPRECV_FAILED
JScript
public static const var MODERR_TCPRECV_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_TCPSEND_FAILED Field

ModbusServerBase.MODERR_TCPSEND_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_TCPSEND_FAILED As Integer
C#
public static readonly int MODERR_TCPSEND_FAILED;
C++
public:
static const int MODERR_TCPSEND_FAILED;
J#
public static final int MODERR_TCPSEND_FAILED
JScript
public static const var MODERR_TCPSEND_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_THREAD_BUSY Field

ModbusServerBase.MODERR_THREAD_BUSY Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_THREAD_BUSY As Integer
C#
public static readonly int MODERR_THREAD_BUSY;
C++
public:
static const int MODERR_THREAD_BUSY;
J#
public static final int MODERR_THREAD_BUSY
JScript
public static const var MODERR_THREAD_BUSY : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_THREAD_RUNNING Field

ModbusServerBase.MODERR_THREAD_RUNNING Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_THREAD_RUNNING As Integer
C#
public static readonly int MODERR_THREAD_RUNNING;
C++
public:
static const int MODERR_THREAD_RUNNING;
J#
public static final int MODERR_THREAD_RUNNING
JScript
public static const var MODERR_THREAD_RUNNING : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_THREAD_STOP Field

ModbusServerBase.MODERR_THREAD_STOP Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_THREAD_STOP As Integer
C#
public static readonly int MODERR_THREAD_STOP;
C++
public:
static const int MODERR_THREAD_STOP;
J#
public static final int MODERR_THREAD_STOP
JScript
public static const var MODERR_THREAD_STOP : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_WAIT_TIMEOUT Field

ModbusServerBase.MODERR_WAIT_TIMEOUT Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_WAIT_TIMEOUT As Integer
C#
public static readonly int MODERR_WAIT_TIMEOUT;
C++
public:
static const int MODERR_WAIT_TIMEOUT;
J#
public static final int MODERR_WAIT_TIMEOUT
JScript
public static const var MODERR_WAIT_TIMEOUT : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_WSACLEAN_FAILED Field

ModbusServerBase.MODERR_WSACLEAN_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_WSACLEAN_FAILED As Integer
C#
public static readonly int MODERR_WSACLEAN_FAILED;
C++
public:
static const int MODERR_WSACLEAN_FAILED;
J#
public static final int MODERR_WSACLEAN_FAILED
JScript
public static const var MODERR_WSACLEAN_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODERR_WSASTART_FAILED Field

ModbusServerBase.MODERR_WSASTART_FAILED Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODERR_WSASTART_FAILED As Integer
C#
public static readonly int MODERR_WSASTART_FAILED;
C++
public:
static const int MODERR_WSASTART_FAILED;
J#
public static final int MODERR_WSASTART_FAILED
JScript
public static const var MODERR_WSASTART_FAILED : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


MODEXCEPT_BASE Field

ModbusServerBase.MODEXCEPT_BASE Field
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MODEXCEPT_BASE As Integer
C#
public static readonly int MODEXCEPT_BASE;
C++
public:
static const int MODEXCEPT_BASE;
J#
public static final int MODEXCEPT_BASE
JScript
public static const var MODEXCEPT_BASE : int;

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


Methods

ModbusServerBase Methods
[image]

Public Methods

Name | Description
ModbusParser |
TOOLGetCoil |
TOOLGetHoldReg |
TOOLGetInput |
TOOLGetInputReg |
TOOLSetCoil |
TOOLSetHoldReg |
TOOLToModbusException |
Top

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


ModbusParser Method

ModbusServerBase.ModbusParser Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ModbusParser( _
ByRef ModbusCommandArray As Byte, _
ByVal LengthOfCommand As UInt32, _
<OutAttribute> ByRef o_Result As Byte, _
<OutAttribute> ByRef o_ReturnLength As UInt32, _
<OutAttribute> ByRef o_byEvtCmd As Byte, _
<OutAttribute> ByRef o_EvtStartAddress As UInt32, _
<OutAttribute> ByRef o_EvtLength As UInt32 _
)
C#
public static void ModbusParser(
ref byte ModbusCommandArray,
uint LengthOfCommand,
out byte o_Result,
out uint o_ReturnLength,
out byte o_byEvtCmd,
out uint o_EvtStartAddress,
out uint o_EvtLength
)
C++
public:
static void ModbusParser(
char% ModbusCommandArray,
unsigned int LengthOfCommand,
[OutAttribute] char% o_Result,
[OutAttribute] unsigned int% o_ReturnLength,
[OutAttribute] char% o_byEvtCmd,
[OutAttribute] unsigned int% o_EvtStartAddress,
[OutAttribute] unsigned int% o_EvtLength
)
J#
public static void ModbusParser(
byte ModbusCommandArray,
uint LengthOfCommand,
/** @attribute OutAttribute() */ /** @ref */ byte o_Result,
/** @attribute OutAttribute() */ /** @ref */ uint o_ReturnLength,
/** @attribute OutAttribute() */ /** @ref */ byte o_byEvtCmd,
/** @attribute OutAttribute() */ /** @ref */ uint o_EvtStartAddress,
/** @attribute OutAttribute() */ /** @ref */ uint o_EvtLength
)
JScript
public static function ModbusParser(
ModbusCommandArray : Byte,
LengthOfCommand : UInt32,
OutAttribute o_Result : Byte,
OutAttribute o_ReturnLength : UInt32,
OutAttribute o_byEvtCmd : Byte,
OutAttribute o_EvtStartAddress : UInt32,
OutAttribute o_EvtLength : UInt32
)

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


TOOLGetCoil Method

ModbusServerBase.TOOLGetCoil Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TOOLGetCoil( _
ByVal i_uiStart As UInt32, _
ByVal i_uiLen As UInt32, _
<OutAttribute> ByRef i_byBuf As Byte, _
<OutAttribute> ByRef o_ReturnLength As UInt32 _
) As Boolean
C#
public static bool TOOLGetCoil(
uint i_uiStart,
uint i_uiLen,
out byte i_byBuf,
out uint o_ReturnLength
)
C++
public:
static bool TOOLGetCoil(
unsigned int i_uiStart,
unsigned int i_uiLen,
[OutAttribute] char% i_byBuf,
[OutAttribute] unsigned int% o_ReturnLength
)
J#
public static bool TOOLGetCoil(
uint i_uiStart,
uint i_uiLen,
/** @attribute OutAttribute() */ /** @ref */ byte i_byBuf,
/** @attribute OutAttribute() */ /** @ref */ uint o_ReturnLength
)
JScript
public static function TOOLGetCoil(
i_uiStart : UInt32,
i_uiLen : UInt32,
OutAttribute i_byBuf : Byte,
OutAttribute o_ReturnLength : UInt32
) : bool

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


TOOLGetHoldReg Method

ModbusServerBase.TOOLGetHoldReg Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TOOLGetHoldReg( _
ByVal i_uiStart As UInt32, _
ByVal i_uiLen As UInt32, _
<OutAttribute> ByRef i_byBuf As Byte, _
<OutAttribute> ByRef o_ReturnLength As UInt32 _
) As Boolean
C#
public static bool TOOLGetHoldReg(
uint i_uiStart,
uint i_uiLen,
out byte i_byBuf,
out uint o_ReturnLength
)
C++
public:
static bool TOOLGetHoldReg(
unsigned int i_uiStart,
unsigned int i_uiLen,
[OutAttribute] char% i_byBuf,
[OutAttribute] unsigned int% o_ReturnLength
)
J#
public static bool TOOLGetHoldReg(
uint i_uiStart,
uint i_uiLen,
/** @attribute OutAttribute() */ /** @ref */ byte i_byBuf,
/** @attribute OutAttribute() */ /** @ref */ uint o_ReturnLength
)
JScript
public static function TOOLGetHoldReg(
i_uiStart : UInt32,
i_uiLen : UInt32,
OutAttribute i_byBuf : Byte,
OutAttribute o_ReturnLength : UInt32
) : bool

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


TOOLGetInput Method

ModbusServerBase.TOOLGetInput Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TOOLGetInput( _
ByVal i_uiStart As UInt32, _
ByVal i_uiLen As UInt32, _
<OutAttribute> ByRef i_byBuf As Byte, _
<OutAttribute> ByRef o_ReturnLength As UInt32 _
) As Boolean
C#
public static bool TOOLGetInput(
uint i_uiStart,
uint i_uiLen,
out byte i_byBuf,
out uint o_ReturnLength
)
C++
public:
static bool TOOLGetInput(
unsigned int i_uiStart,
unsigned int i_uiLen,
[OutAttribute] char% i_byBuf,
[OutAttribute] unsigned int% o_ReturnLength
)
J#
public static bool TOOLGetInput(
uint i_uiStart,
uint i_uiLen,
/** @attribute OutAttribute() */ /** @ref */ byte i_byBuf,
/** @attribute OutAttribute() */ /** @ref */ uint o_ReturnLength
)
JScript
public static function TOOLGetInput(
i_uiStart : UInt32,
i_uiLen : UInt32,
OutAttribute i_byBuf : Byte,
OutAttribute o_ReturnLength : UInt32
) : bool

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


TOOLGetInputReg Method

ModbusServerBase.TOOLGetInputReg Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TOOLGetInputReg( _
ByVal i_uiStart As UInt32, _
ByVal i_uiLen As UInt32, _
<OutAttribute> ByRef i_byBuf As Byte, _
<OutAttribute> ByRef o_ReturnLength As UInt32 _
) As Boolean
C#
public static bool TOOLGetInputReg(
uint i_uiStart,
uint i_uiLen,
out byte i_byBuf,
out uint o_ReturnLength
)
C++
public:
static bool TOOLGetInputReg(
unsigned int i_uiStart,
unsigned int i_uiLen,
[OutAttribute] char% i_byBuf,
[OutAttribute] unsigned int% o_ReturnLength
)
J#
public static bool TOOLGetInputReg(
uint i_uiStart,
uint i_uiLen,
/** @attribute OutAttribute() */ /** @ref */ byte i_byBuf,
/** @attribute OutAttribute() */ /** @ref */ uint o_ReturnLength
)
JScript
public static function TOOLGetInputReg(
i_uiStart : UInt32,
i_uiLen : UInt32,
OutAttribute i_byBuf : Byte,
OutAttribute o_ReturnLength : UInt32
) : bool

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


TOOLSetCoil Method

ModbusServerBase.TOOLSetCoil Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TOOLSetCoil( _
ByVal i_uiStart As UInt32, _
ByVal i_uiLen As UInt32, _
ByRef i_byBuf As Byte _
) As Boolean
C#
public static bool TOOLSetCoil(
uint i_uiStart,
uint i_uiLen,
ref byte i_byBuf
)
C++
public:
static bool TOOLSetCoil(
unsigned int i_uiStart,
unsigned int i_uiLen,
char% i_byBuf
)
J#
public static bool TOOLSetCoil(
uint i_uiStart,
uint i_uiLen,
byte i_byBuf
)
JScript
public static function TOOLSetCoil(
i_uiStart : UInt32,
i_uiLen : UInt32,
i_byBuf : Byte
) : bool

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


TOOLSetHoldReg Method

ModbusServerBase.TOOLSetHoldReg Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TOOLSetHoldReg( _
ByVal i_uiStart As UInt32, _
ByVal i_uiLen As UInt32, _
ByRef i_byBuf As Byte _
) As Boolean
C#
public static bool TOOLSetHoldReg(
uint i_uiStart,
uint i_uiLen,
ref byte i_byBuf
)
C++
public:
static bool TOOLSetHoldReg(
unsigned int i_uiStart,
unsigned int i_uiLen,
char% i_byBuf
)
J#
public static bool TOOLSetHoldReg(
uint i_uiStart,
uint i_uiLen,
byte i_byBuf
)
JScript
public static function TOOLSetHoldReg(
i_uiStart : UInt32,
i_uiLen : UInt32,
i_byBuf : Byte
) : bool

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


TOOLToModbusException Method

ModbusServerBase.TOOLToModbusException Method
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub TOOLToModbusException( _
ByRef ModbusCommandArray As Byte, _
ByVal i_byExceptCode As Byte, _
<OutAttribute> ByRef o_Result As Byte, _
<OutAttribute> ByRef o_ReturnLength As UInt32 _
)
C#
public static void TOOLToModbusException(
ref byte ModbusCommandArray,
byte i_byExceptCode,
out byte o_Result,
out uint o_ReturnLength
)
C++
public:
static void TOOLToModbusException(
char% ModbusCommandArray,
char i_byExceptCode,
[OutAttribute] char% o_Result,
[OutAttribute] unsigned int% o_ReturnLength
)
J#
public static void TOOLToModbusException(
byte ModbusCommandArray,
byte i_byExceptCode,
/** @attribute OutAttribute() */ /** @ref */ byte o_Result,
/** @attribute OutAttribute() */ /** @ref */ uint o_ReturnLength
)
JScript
public static function TOOLToModbusException(
ModbusCommandArray : Byte,
i_byExceptCode : Byte,
OutAttribute o_Result : Byte,
OutAttribute o_ReturnLength : UInt32
)

See Also

ModbusServerBase Class
Advantech.Protocol Namespace


ModbusServerBase.EventHandler_OnCoilChangedEvent Delegate

ModbusServerBase.EventHandler_OnCoilChangedEvent Delegate
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ModbusServerBase.EventHandler_OnCoilChangedEvent( _
ByVal i_iStart As UInt32, _
ByVal i_iLen As UInt32 _
)
C#
public delegate void ModbusServerBase.EventHandler_OnCoilChangedEvent(
uint i_iStart,
uint i_iLen
)
C++
public delegate void ModbusServerBase.EventHandler_OnCoilChangedEvent(
unsigned int i_iStart,
unsigned int i_iLen
)
J#
/** delegate */
public delegate void ModbusServerBase.EventHandler_OnCoilChangedEvent(
uint i_iStart,
uint i_iLen
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Protocol Namespace


ModbusServerBase.EventHandler_OnHoldRegChangedEvent Delegate

ModbusServerBase.EventHandler_OnHoldRegChangedEvent Delegate
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ModbusServerBase.EventHandler_OnHoldRegChangedEvent( _
ByVal i_iStart As UInt32, _
ByVal i_iLen As UInt32 _
)
C#
public delegate void ModbusServerBase.EventHandler_OnHoldRegChangedEvent(
uint i_iStart,
uint i_iLen
)
C++
public delegate void ModbusServerBase.EventHandler_OnHoldRegChangedEvent(
unsigned int i_iStart,
unsigned int i_iLen
)
J#
/** delegate */
public delegate void ModbusServerBase.EventHandler_OnHoldRegChangedEvent(
uint i_iStart,
uint i_iLen
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Protocol Namespace


ModbusTCPClient Class

ModbusTCPClient Class
See Also Example Members
[image]

ModbusTCPClient class is used as a MODBUS/TCP packet constructor as well as a MODBUS/TCP packet parse for those running on ethernet communication.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Class ModbusTCPClient
C#
public class ModbusTCPClient
C++
ref class ModbusTCPClient
J#
public class ModbusTCPClient
JScript
public class ModbusTCPClient

Inheritance Hierarchy

System.Object
Advantech.Protocol.ModbusTCPClient

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ModbusTCPClient Members
Advantech.Protocol Namespace


ModbusTCPClient Members

ModbusTCPClient Members
See Also Example Constructors Properties Methods
[image]

ModbusTCPClient class is used as a MODBUS/TCP packet constructor as well as a MODBUS/TCP packet parse for those running on ethernet communication.

The following tables list the members exposed by ModbusTCPClient.

Public Constructors

 | Name | Description
Public method | ModbusTCPClient | Initializes a new instance of the ModbusTCPClient class.
Top

Public Properties

Name | Description
LastError | The last error code
Top

Public Methods

Name | Description
ConstructForceMultiCoils | Construct modbus function 0F sending packet
ConstructForceSingleCoil | Construct modbus function 05 sending packet
ConstructPresetMultiRegs | Construct modbus function 10 sending packet
ConstructPresetSingleReg | Construct modbus function 06 sending packet
ConstructReadAdvantechRegs | Construct modbus function 20 sending packet
ConstructReadCoilStatus | Construct modbus function 01 sending packet
ConstructReadCustomizeRegs | Construct modbus customize function sending packet
ConstructReadHoldingRegs | Construct modbus function 03 sending packet
ConstructReadInputRegs | Construct modbus function 04 sending packet
ConstructReadInputStatus | Construct modbus function 02 sending packet
ConstructWriteAdvantechRegs | Construct modbus function 21 sending packet
ConstructWriteCustomizeRegs | Construct modbus customize function sending packet
VerifyForceMultiCoils | Parse the received packet for modbus function 0F
VerifyForceSingleCoil | Parse the received packet for modbus function 05
VerifyPresetMultiRegs | Parse the received packet for modbus function 10
VerifyPresetSingleReg | Parse the received packet for modbus function 06
VerifyReadAdvantechRegs | Parse the received packet for modbus function 20
VerifyReadCoilStatus | Parse the received packet for modbus function 01
VerifyReadCustomizeRegs | Parse the received packet for modbus function 20
VerifyReadHoldingRegs | Parse the received packet for modbus function 03
VerifyReadInputRegs | Parse the received packet for modbus function 04
VerifyReadInputStatus | Parse the received packet for modbus function 02
VerifyWriteAdvantechRegs | Parse the received packet for modbus function 21
VerifyWriteCustomizeRegs | Parse the received packet for modbus function 21
Top

Protected Methods

Name | Description
ConstructSendPacket | Construct Function 1-4 sending packet
VerifyRecvPacket | Parse Function 1-4 received packet
Top

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ModbusTCPClient Constructor

ModbusTCPClient Constructor
[image]

Initializes a new instance of the ModbusTCPClient class.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ModbusTCPClient()
C++
public:
ModbusTCPClient() sealed
J#
public ModbusTCPClient()
JScript
public function ModbusTCPClient()

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


Properties

ModbusTCPClient Properties
[image]

Public Properties

Name | Description
LastError | The last error code
Top

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


LastError Property

ModbusTCPClient.LastError Property
[image]

The last error code

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property LastError As ErrorCode
C#
public static ErrorCode LastError { get; }
C++
public static property ErrorCode LastError {
ErrorCode get();
}
J#
/** property */
public ErrorCode get_LastError();
JScript
public function get LastError() : ErrorCode

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


Methods

ModbusTCPClient Methods
[image]

Public Methods

Name | Description
ConstructForceMultiCoils | Construct modbus function 0F sending packet
ConstructForceSingleCoil | Construct modbus function 05 sending packet
ConstructPresetMultiRegs | Construct modbus function 10 sending packet
ConstructPresetSingleReg | Construct modbus function 06 sending packet
ConstructReadAdvantechRegs | Construct modbus function 20 sending packet
ConstructReadCoilStatus | Construct modbus function 01 sending packet
ConstructReadCustomizeRegs | Construct modbus customize function sending packet
ConstructReadHoldingRegs | Construct modbus function 03 sending packet
ConstructReadInputRegs | Construct modbus function 04 sending packet
ConstructReadInputStatus | Construct modbus function 02 sending packet
ConstructWriteAdvantechRegs | Construct modbus function 21 sending packet
ConstructWriteCustomizeRegs | Construct modbus customize function sending packet
VerifyForceMultiCoils | Parse the received packet for modbus function 0F
VerifyForceSingleCoil | Parse the received packet for modbus function 05
VerifyPresetMultiRegs | Parse the received packet for modbus function 10
VerifyPresetSingleReg | Parse the received packet for modbus function 06
VerifyReadAdvantechRegs | Parse the received packet for modbus function 20
VerifyReadCoilStatus | Parse the received packet for modbus function 01
VerifyReadCustomizeRegs | Parse the received packet for modbus function 20
VerifyReadHoldingRegs | Parse the received packet for modbus function 03
VerifyReadInputRegs | Parse the received packet for modbus function 04
VerifyReadInputStatus | Parse the received packet for modbus function 02
VerifyWriteAdvantechRegs | Parse the received packet for modbus function 21
VerifyWriteCustomizeRegs | Parse the received packet for modbus function 21
Top

Protected Methods

Name | Description
ConstructSendPacket | Construct Function 1-4 sending packet
VerifyRecvPacket | Parse Function 1-4 received packet
Top

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructForceMultiCoils Method

ModbusTCPClient.ConstructForceMultiCoils Method
[image]

Construct modbus function 0F sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructForceMultiCoils( _
ByVal i_iAddr As Integer, _
ByVal i_iCoilIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructForceMultiCoils(
int i_iAddr,
int i_iCoilIndex,
int i_iTotalPoint,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructForceMultiCoils(
int i_iAddr,
int i_iCoilIndex,
int i_iTotalPoint,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructForceMultiCoils(
int i_iAddr,
int i_iCoilIndex,
int i_iTotalPoint,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructForceMultiCoils(
i_iAddr : int,
i_iCoilIndex : int,
i_iTotalPoint : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address.
i_iCoilIndex
The start coil index for setting.
i_iTotalPoint
The total coil to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructForceSingleCoil Method

ModbusTCPClient.ConstructForceSingleCoil Method
[image]

Construct modbus function 05 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructForceSingleCoil( _
ByVal i_iAddr As Integer, _
ByVal i_iCoilIndex As Integer, _
ByVal i_iData As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructForceSingleCoil(
int i_iAddr,
int i_iCoilIndex,
int i_iData,
out byte o_byPacket
)
C++
public:
static void ConstructForceSingleCoil(
int i_iAddr,
int i_iCoilIndex,
int i_iData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructForceSingleCoil(
int i_iAddr,
int i_iCoilIndex,
int i_iData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructForceSingleCoil(
i_iAddr : int,
i_iCoilIndex : int,
i_iData : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iCoilIndex
The coil index for setting
i_iData
The data to set, 0 for OFF, 1 for ON
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructPresetMultiRegs Method

ModbusTCPClient.ConstructPresetMultiRegs Method
[image]

Construct modbus function 10 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructPresetMultiRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartReg As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructPresetMultiRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructPresetMultiRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructPresetMultiRegs(
int i_iAddr,
int i_iStartReg,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructPresetMultiRegs(
i_iAddr : int,
i_iStartReg : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartReg
The start register index for setting.
i_iTotalReg
The total register to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructPresetSingleReg Method

ModbusTCPClient.ConstructPresetSingleReg Method
[image]

Construct modbus function 06 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructPresetSingleReg( _
ByVal i_iAddr As Integer, _
ByVal i_iRegIndex As Integer, _
ByVal i_iData As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructPresetSingleReg(
int i_iAddr,
int i_iRegIndex,
int i_iData,
out byte o_byPacket
)
C++
public:
static void ConstructPresetSingleReg(
int i_iAddr,
int i_iRegIndex,
int i_iData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructPresetSingleReg(
int i_iAddr,
int i_iRegIndex,
int i_iData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructPresetSingleReg(
i_iAddr : int,
i_iRegIndex : int,
i_iData : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address.
i_iRegIndex
The register index for setting.
i_iData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructReadAdvantechRegs Method

ModbusTCPClient.ConstructReadAdvantechRegs Method
[image]

Construct modbus function 20 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadAdvantechRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadAdvantechRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadAdvantechRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadAdvantechRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadAdvantechRegs(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructReadCoilStatus Method

ModbusTCPClient.ConstructReadCoilStatus Method
[image]

Construct modbus function 01 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadCoilStatus( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadCoilStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadCoilStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadCoilStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadCoilStatus(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructReadCustomizeRegs Method

ModbusTCPClient.ConstructReadCustomizeRegs Method
[image]

Construct modbus customize function sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadCustomizeRegs(
i_iCommand : int,
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iCommand
Customize command
i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructReadHoldingRegs Method

ModbusTCPClient.ConstructReadHoldingRegs Method
[image]

Construct modbus function 03 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadHoldingRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadHoldingRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadHoldingRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadHoldingRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadHoldingRegs(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructReadInputRegs Method

ModbusTCPClient.ConstructReadInputRegs Method
[image]

Construct modbus function 04 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadInputRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadInputRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadInputRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadInputRegs(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadInputRegs(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructReadInputStatus Method

ModbusTCPClient.ConstructReadInputStatus Method
[image]

Construct modbus function 02 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructReadInputStatus( _
ByVal i_iAddr As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructReadInputStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
public:
static void ConstructReadInputStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructReadInputStatus(
int i_iAddr,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructReadInputStatus(
i_iAddr : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartIndex
The starting index for reading.
i_iTotalPoint
The total point for reading.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructSendPacket Method

ModbusTCPClient.ConstructSendPacket Method
[image]

Construct Function 1-4 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub ConstructSendPacket( _
ByVal i_iAddr As Integer, _
ByVal i_iFun As Integer, _
ByVal i_iStartIndex As Integer, _
ByVal i_iTotalPoint As Integer, _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
protected static void ConstructSendPacket(
int i_iAddr,
int i_iFun,
int i_iStartIndex,
int i_iTotalPoint,
out byte o_byPacket
)
C++
protected:
static void ConstructSendPacket(
int i_iAddr,
int i_iFun,
int i_iStartIndex,
int i_iTotalPoint,
[OutAttribute] char% o_byPacket
)
J#
protected static void ConstructSendPacket(
int i_iAddr,
int i_iFun,
int i_iStartIndex,
int i_iTotalPoint,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
protected static function ConstructSendPacket(
i_iAddr : int,
i_iFun : int,
i_iStartIndex : int,
i_iTotalPoint : int,
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
Target address
i_iFun
Function number
i_iStartIndex
Start index
i_iTotalPoint
Total point
o_byPacket
packet data

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructWriteAdvantechRegs Method

ModbusTCPClient.ConstructWriteAdvantechRegs Method
[image]

Construct modbus function 21 sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructWriteAdvantechRegs( _
ByVal i_iAddr As Integer, _
ByVal i_iStartAddr As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructWriteAdvantechRegs(
int i_iAddr,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructWriteAdvantechRegs(
int i_iAddr,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructWriteAdvantechRegs(
int i_iAddr,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructWriteAdvantechRegs(
i_iAddr : int,
i_iStartAddr : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iAddr
The slave address
i_iStartAddr
The start register index for setting.
i_iTotalReg
The total register to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ConstructWriteCustomizeRegs Method

ModbusTCPClient.ConstructWriteCustomizeRegs Method
[image]

Construct modbus customize function sending packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConstructWriteCustomizeRegs( _
ByVal i_iCommand As Integer, _
ByVal i_iAddr As Integer, _
ByVal i_iStartAddr As Integer, _
ByVal i_iTotalReg As Integer, _
ByVal i_iTotalByte As Integer, _
ByVal i_byData As Byte(), _
<OutAttribute> ByRef o_byPacket As Byte _
)
C#
public static void ConstructWriteCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
out byte o_byPacket
)
C++
public:
static void ConstructWriteCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
array<char>^ i_byData,
[OutAttribute] char% o_byPacket
)
J#
public static void ConstructWriteCustomizeRegs(
int i_iCommand,
int i_iAddr,
int i_iStartAddr,
int i_iTotalReg,
int i_iTotalByte,
byte[] i_byData,
/** @attribute OutAttribute() */ /** @ref */ byte o_byPacket
)
JScript
public static function ConstructWriteCustomizeRegs(
i_iCommand : int,
i_iAddr : int,
i_iStartAddr : int,
i_iTotalReg : int,
i_iTotalByte : int,
i_byData : Byte[],
OutAttribute o_byPacket : Byte
)

Parameters

i_iCommand
Customize command
i_iAddr
The slave address
i_iStartAddr
The start register index for setting.
i_iTotalReg
The total register to set.
i_iTotalByte
The total byte of data.
i_byData
The data to set.
o_byPacket
The packet to send.

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyForceMultiCoils Method

ModbusTCPClient.VerifyForceMultiCoils Method
[image]

Parse the received packet for modbus function 0F

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyForceMultiCoils( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyForceMultiCoils(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyForceMultiCoils(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyForceMultiCoils(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyForceMultiCoils(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyForceSingleCoil Method

ModbusTCPClient.VerifyForceSingleCoil Method
[image]

Parse the received packet for modbus function 05

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyForceSingleCoil( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyForceSingleCoil(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyForceSingleCoil(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyForceSingleCoil(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyForceSingleCoil(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyPresetMultiRegs Method

ModbusTCPClient.VerifyPresetMultiRegs Method
[image]

Parse the received packet for modbus function 10

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyPresetMultiRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyPresetMultiRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyPresetMultiRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyPresetMultiRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyPresetMultiRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyPresetSingleReg Method

ModbusTCPClient.VerifyPresetSingleReg Method
[image]

Parse the received packet for modbus function 06

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyPresetSingleReg( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyPresetSingleReg(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyPresetSingleReg(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyPresetSingleReg(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyPresetSingleReg(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyReadAdvantechRegs Method

ModbusTCPClient.VerifyReadAdvantechRegs Method
[image]

Parse the received packet for modbus function 20

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadAdvantechRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadAdvantechRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadAdvantechRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyReadCoilStatus Method

ModbusTCPClient.VerifyReadCoilStatus Method
[image]

Parse the received packet for modbus function 01

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadCoilStatus( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadCoilStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadCoilStatus(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadCoilStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadCoilStatus(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyReadCustomizeRegs Method

ModbusTCPClient.VerifyReadCustomizeRegs Method
[image]

Parse the received packet for modbus function 20

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadCustomizeRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadCustomizeRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadCustomizeRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyReadHoldingRegs Method

ModbusTCPClient.VerifyReadHoldingRegs Method
[image]

Parse the received packet for modbus function 03

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadHoldingRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadHoldingRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadHoldingRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadHoldingRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadHoldingRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyReadInputRegs Method

ModbusTCPClient.VerifyReadInputRegs Method
[image]

Parse the received packet for modbus function 04

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadInputRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadInputRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadInputRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadInputRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadInputRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyReadInputStatus Method

ModbusTCPClient.VerifyReadInputStatus Method
[image]

Parse the received packet for modbus function 02

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyReadInputStatus( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
public static bool VerifyReadInputStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
public:
static bool VerifyReadInputStatus(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
public static bool VerifyReadInputStatus(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
public static function VerifyReadInputStatus(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyRecvPacket Method

ModbusTCPClient.VerifyRecvPacket Method
[image]

Parse Function 1-4 received packet

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function VerifyRecvPacket( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte(), _
<OutAttribute> ByRef o_byRecvData As Byte _
) As Boolean
C#
protected static bool VerifyRecvPacket(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
out byte o_byRecvData
)
C++
protected:
static bool VerifyRecvPacket(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket,
[OutAttribute] char% o_byRecvData
)
J#
protected static bool VerifyRecvPacket(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket,
/** @attribute OutAttribute() */ /** @ref */ byte o_byRecvData
)
JScript
protected static function VerifyRecvPacket(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[],
OutAttribute o_byRecvData : Byte
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.
o_byRecvData
The data read.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyWriteAdvantechRegs Method

ModbusTCPClient.VerifyWriteAdvantechRegs Method
[image]

Parse the received packet for modbus function 21

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyWriteAdvantechRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyWriteAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyWriteAdvantechRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyWriteAdvantechRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyWriteAdvantechRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


VerifyWriteCustomizeRegs Method

ModbusTCPClient.VerifyWriteCustomizeRegs Method
[image]

Parse the received packet for modbus function 21

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function VerifyWriteCustomizeRegs( _
ByVal i_iSendLen As Integer, _
ByVal i_bySendPacket As Byte(), _
ByVal i_iRecvLen As Integer, _
ByVal i_byRecvPacket As Byte() _
) As Boolean
C#
public static bool VerifyWriteCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
C++
public:
static bool VerifyWriteCustomizeRegs(
int i_iSendLen,
array<char>^ i_bySendPacket,
int i_iRecvLen,
array<char>^ i_byRecvPacket
)
J#
public static bool VerifyWriteCustomizeRegs(
int i_iSendLen,
byte[] i_bySendPacket,
int i_iRecvLen,
byte[] i_byRecvPacket
)
JScript
public static function VerifyWriteCustomizeRegs(
i_iSendLen : int,
i_bySendPacket : Byte[],
i_iRecvLen : int,
i_byRecvPacket : Byte[]
) : bool

Parameters

i_iSendLen
The length of sent packet.
i_bySendPacket
The sent packet.
i_iRecvLen
The length of received packet.
i_byRecvPacket
The received packet.

Return Value

True if succeed, otherwise false

See Also

ModbusTCPClient Class
Advantech.Protocol Namespace


ModbusTCPServer Class

ModbusTCPServer Class
See Also Example Members
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Class ModbusTCPServer
Inherits ModbusServerBase
C#
public class ModbusTCPServer : ModbusServerBase
C++
ref class ModbusTCPServer : ModbusServerBase
J#
public class ModbusTCPServer extends ModbusServerBase
JScript
public class ModbusTCPServer extends ModbusServerBase

Inheritance Hierarchy

System.Object
Advantech.Protocol.ModbusServerBase
Advantech.Protocol.ModbusTCPServer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ModbusTCPServer Members
Advantech.Protocol Namespace


ModbusTCPServer Members

ModbusTCPServer Members
See Also Example Constructors Methods Events
[image]

The following tables list the members exposed by ModbusTCPServer.

Public Constructors

 | Name | Description
Public method | ModbusTCPServer | Initializes a new instance of the ModbusTCPServer class.
Top

Public Methods

 | Name | Description
Public method | GetTcpServerClientIdle | Get the client transaction idle timeout.
Public method | GetTcpServerClientIp | Get the acceptable client IP address with indicated index.
Public method | SetTcpServerClientIdle | Set the client transaction idle timeout. If a connected client has been idled for the setting time, the server will disconnect the client from the server. The default value is 30 seconds.
Public method | SetTcpServerClientIp | Set the acceptable client IP address with indicated index.
Public method | SetTcpServerClientIpRestrict | Enable/disable the restriction of remote client connection. If this function sets the restriction to true, then only those clients set by MOD_SetTcpServerClientIp will be acceptable by the server.
Public method | SetTcpServerPriority | Set the priority of the MODBUS/TCP server running thread. Before calling this function, the MODBUS/TCP server has to be successfully started.
Public method | Start | Start the MODBUS/TCP server.
Public method | Stop | Stop the MODBUS/TCP server.
Top

Public Events

 | Name | Description
Public event | OnCoilChangedEvent |
Public event | OnHoldRegChangedEvent |
Public event | OnRemoteTcpClientConnectEvent |
Public event | OnRemoteTcpClientDisconnectEvent |
Top

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


ModbusTCPServer Constructor

ModbusTCPServer Constructor
[image]

Initializes a new instance of the ModbusTCPServer class.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ModbusTCPServer()
C++
public:
ModbusTCPServer() sealed
J#
public ModbusTCPServer()
JScript
public function ModbusTCPServer()

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


Methods

ModbusTCPServer Methods
[image]

Public Methods

 | Name | Description
Public method | GetTcpServerClientIdle | Get the client transaction idle timeout.
Public method | GetTcpServerClientIp | Get the acceptable client IP address with indicated index.
Public method | SetTcpServerClientIdle | Set the client transaction idle timeout. If a connected client has been idled for the setting time, the server will disconnect the client from the server. The default value is 30 seconds.
Public method | SetTcpServerClientIp | Set the acceptable client IP address with indicated index.
Public method | SetTcpServerClientIpRestrict | Enable/disable the restriction of remote client connection. If this function sets the restriction to true, then only those clients set by MOD_SetTcpServerClientIp will be acceptable by the server.
Public method | SetTcpServerPriority | Set the priority of the MODBUS/TCP server running thread. Before calling this function, the MODBUS/TCP server has to be successfully started.
Public method | Start | Start the MODBUS/TCP server.
Public method | Stop | Stop the MODBUS/TCP server.
Top

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


GetTcpServerClientIdle Method

ModbusTCPServer.GetTcpServerClientIdle Method
[image]

Get the client transaction idle timeout.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTcpServerClientIdle( _
<OutAttribute> ByRef o_iIdleSec As UInt32 _
) As Integer
C#
public int GetTcpServerClientIdle(
out uint o_iIdleSec
)
C++
public:
int GetTcpServerClientIdle(
[OutAttribute] unsigned int% o_iIdleSec
) sealed
J#
public int GetTcpServerClientIdle(
/** @attribute OutAttribute() */ /** @ref */ uint o_iIdleSec
)
JScript
public function GetTcpServerClientIdle(
OutAttribute o_iIdleSec : UInt32
) : int

Parameters

o_iIdleSec
The transaction idle timeout.

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


GetTcpServerClientIp Method

ModbusTCPServer.GetTcpServerClientIp Method
[image]

Get the acceptable client IP address with indicated index.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTcpServerClientIp( _
<OutAttribute> ByRef o_szIp As String _
) As Integer
C#
public int GetTcpServerClientIp(
out string o_szIp
)
C++
public:
int GetTcpServerClientIp(
[OutAttribute] String% o_szIp
) sealed
J#
public int GetTcpServerClientIp(
/** @attribute OutAttribute() */ /** @ref */ string o_szIp
)
JScript
public function GetTcpServerClientIp(
OutAttribute o_szIp : String
) : int

Parameters

o_szIp
The IP address array of the restricted clients.

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


SetTcpServerClientIdle Method

ModbusTCPServer.SetTcpServerClientIdle Method
[image]

Set the client transaction idle timeout. If a connected client has been idled for the setting time, the server will disconnect the client from the server. The default value is 30 seconds.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function SetTcpServerClientIdle( _
ByVal i_iIdleSec As UInt32 _
) As Integer
C#
public int SetTcpServerClientIdle(
uint i_iIdleSec
)
C++
public:
int SetTcpServerClientIdle(
unsigned int i_iIdleSec
) sealed
J#
public int SetTcpServerClientIdle(
uint i_iIdleSec
)
JScript
public function SetTcpServerClientIdle(
i_iIdleSec : UInt32
) : int

Parameters

i_iIdleSec
The transaction idle timeout. The value is ranged from 5 to 600 (seconds).

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


SetTcpServerClientIp Method

ModbusTCPServer.SetTcpServerClientIp Method
[image]

Set the acceptable client IP address with indicated index.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function SetTcpServerClientIp( _
ByVal i_iIndex As Integer, _
ByVal i_szIp As String _
) As Integer
C#
public int SetTcpServerClientIp(
int i_iIndex,
string i_szIp
)
C++
public:
int SetTcpServerClientIp(
int i_iIndex,
String i_szIp
) sealed
J#
public int SetTcpServerClientIp(
int i_iIndex,
string i_szIp
)
JScript
public function SetTcpServerClientIp(
i_iIndex : int,
i_szIp : String
) : int

Parameters

i_iIndex
The index of the acceptable client. This value is ranged from 0 to 7.
i_szIp
The IP address of the restricted client.

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


SetTcpServerClientIpRestrict Method

ModbusTCPServer.SetTcpServerClientIpRestrict Method
[image]

Enable/disable the restriction of remote client connection. If this function sets the restriction to true, then only those clients set by MOD_SetTcpServerClientIp will be acceptable by the server.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function SetTcpServerClientIpRestrict( _
ByVal i_bRestrict As Boolean _
) As Integer
C#
public int SetTcpServerClientIpRestrict(
bool i_bRestrict
)
C++
public:
int SetTcpServerClientIpRestrict(
bool i_bRestrict
) sealed
J#
public int SetTcpServerClientIpRestrict(
bool i_bRestrict
)
JScript
public function SetTcpServerClientIpRestrict(
i_bRestrict : bool
) : int

Parameters

i_bRestrict
Specifies the priority value for the server thread.

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


SetTcpServerPriority Method

ModbusTCPServer.SetTcpServerPriority Method
[image]

Set the priority of the MODBUS/TCP server running thread. Before calling this function, the MODBUS/TCP server has to be successfully started.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function SetTcpServerPriority( _
ByVal i_uiPriority As UInt32 _
) As Integer
C#
public int SetTcpServerPriority(
uint i_uiPriority
)
C++
public:
int SetTcpServerPriority(
unsigned int i_uiPriority
) sealed
J#
public int SetTcpServerPriority(
uint i_uiPriority
)
JScript
public function SetTcpServerPriority(
i_uiPriority : UInt32
) : int

Parameters

i_uiPriority
Specifies the priority value for the server thread from 1 ~ 5.

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


Start Method

ModbusTCPServer.Start Method
[image]

Start the MODBUS/TCP server.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function Start() As Integer
C#
public int Start()
C++
public:
int Start() sealed
J#
public int Start()
JScript
public function Start() : int

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


Stop Method

ModbusTCPServer.Stop Method
[image]

Stop the MODBUS/TCP server.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function Stop() As Integer
C#
public int Stop()
C++
public:
int Stop() sealed
J#
public int Stop()
JScript
public function Stop() : int

Return Value

True if succeed, otherwise false.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


Events

ModbusTCPServer Events
[image]

Public Events

 | Name | Description
Public event | OnCoilChangedEvent |
Public event | OnHoldRegChangedEvent |
Public event | OnRemoteTcpClientConnectEvent |
Public event | OnRemoteTcpClientDisconnectEvent |
Top

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


OnCoilChangedEvent Event

ModbusTCPServer.OnCoilChangedEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event OnCoilChangedEvent As ModbusServerBase.EventHandler_OnCoilChangedEvent
C#
public event ModbusServerBase.EventHandler_OnCoilChangedEvent OnCoilChangedEvent
C++
public:
virtual event ModbusServerBase.EventHandler_OnCoilChangedEvent OnCoilChangedEvent {
void add(ModbusServerBase.EventHandler_OnCoilChangedEvent value) sealed ;
void remove(ModbusServerBase.EventHandler_OnCoilChangedEvent value) sealed ;
}
J#
/** event */
public final void add_OnCoilChangedEvent(ModbusServerBase.EventHandler_OnCoilChangedEvent value);

/** event */
public final void remove_OnCoilChangedEvent(ModbusServerBase.EventHandler_OnCoilChangedEvent value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


OnHoldRegChangedEvent Event

ModbusTCPServer.OnHoldRegChangedEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event OnHoldRegChangedEvent As ModbusServerBase.EventHandler_OnHoldRegChangedEvent
C#
public event ModbusServerBase.EventHandler_OnHoldRegChangedEvent OnHoldRegChangedEvent
C++
public:
virtual event ModbusServerBase.EventHandler_OnHoldRegChangedEvent OnHoldRegChangedEvent {
void add(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value) sealed ;
void remove(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value) sealed ;
}
J#
/** event */
public final void add_OnHoldRegChangedEvent(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value);

/** event */
public final void remove_OnHoldRegChangedEvent(ModbusServerBase.EventHandler_OnHoldRegChangedEvent value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


OnRemoteTcpClientConnectEvent Event

ModbusTCPServer.OnRemoteTcpClientConnectEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event OnRemoteTcpClientConnectEvent As ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent
C#
public event ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent OnRemoteTcpClientConnectEvent
C++
public:
virtual event ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent OnRemoteTcpClientConnectEvent {
void add(ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent value) sealed ;
void remove(ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent value) sealed ;
}
J#
/** event */
public final void add_OnRemoteTcpClientConnectEvent(ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent value);

/** event */
public final void remove_OnRemoteTcpClientConnectEvent(ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


OnRemoteTcpClientDisconnectEvent Event

ModbusTCPServer.OnRemoteTcpClientDisconnectEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event OnRemoteTcpClientDisconnectEvent As ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent
C#
public event ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent OnRemoteTcpClientDisconnectEvent
C++
public:
virtual event ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent OnRemoteTcpClientDisconnectEvent {
void add(ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent value) sealed ;
void remove(ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent value) sealed ;
}
J#
/** event */
public final void add_OnRemoteTcpClientDisconnectEvent(ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent value);

/** event */
public final void remove_OnRemoteTcpClientDisconnectEvent(ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ModbusTCPServer Class
Advantech.Protocol Namespace


ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent Delegate

ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent Delegate
See Also Example
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent( _
ByVal i_szIp As String _
)
C#
public delegate void ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent(
string i_szIp
)
C++
public delegate void ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent(
String i_szIp
)
J#
/** delegate */
public delegate void ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent(
string i_szIp
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Protocol Namespace


ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent Delegate

ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent Delegate
See Also Example
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent( _
ByVal i_szIp As String _
)
C#
public delegate void ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent(
string i_szIp
)
C++
public delegate void ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent(
String i_szIp
)
J#
/** delegate */
public delegate void ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent(
string i_szIp
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Protocol Namespace


TCPSocketListener Class

TCPSocketListener Class
See Also Example Members
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Class TCPSocketListener
C#
public class TCPSocketListener
C++
ref class TCPSocketListener
J#
public class TCPSocketListener
JScript
public class TCPSocketListener

Inheritance Hierarchy

System.Object
Advantech.Protocol.TCPSocketListener

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TCPSocketListener Members
Advantech.Protocol Namespace


TCPSocketListener Members

TCPSocketListener Members
See Also Example Constructors Properties Methods Events
[image]

The following tables list the members exposed by TCPSocketListener.

Public Constructors

 | Name | Description
Public method | TCPSocketListener | Client Socket Listener Constructor.
Top

Public Properties

 | Name | Description
Public property | ClientSocket | Client Socket.
Top

Public Methods

 | Name | Description
Public method | IsMarkedForDeletion | Method that returns the state of this object i.e. whether this object is marked for deletion or not.
Public method | SetIdleTimeout | Method that set communication idle timeout.
Public method | StartSocketListener | Method that starts SocketListener Thread.
Public method | StopSocketListener | Method that stops Client SocketListening Thread.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Overridden. Client SocketListener Destructor.
Top

Public Events

 | Name | Description
Public event | CoilChangedEvent |
Public event | RegChangedEvent |
Top

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


TCPSocketListener Constructor

TCPSocketListener Constructor
[image]

Client Socket Listener Constructor.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal clientSocket As Socket _
)
C#
public TCPSocketListener(
Socket clientSocket
)
C++
public:
TCPSocketListener(
Socket clientSocket
) sealed
J#
public TCPSocketListener(
Socket clientSocket
)
JScript
public function TCPSocketListener(
clientSocket : Socket
)

Parameters

clientSocket

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


Properties

TCPSocketListener Properties
[image]

Public Properties

 | Name | Description
Public property | ClientSocket | Client Socket.
Top

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


ClientSocket Property

TCPSocketListener.ClientSocket Property
[image]

Client Socket.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientSocket As Socket
C#
public Socket ClientSocket { get; }
C++
public property Socket ClientSocket sealed {
Socket get();
}
J#
/** property */
public Socket get_ClientSocket();
JScript
public function get ClientSocket() : Socket

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


Methods

TCPSocketListener Methods
[image]

Public Methods

 | Name | Description
Public method | IsMarkedForDeletion | Method that returns the state of this object i.e. whether this object is marked for deletion or not.
Public method | SetIdleTimeout | Method that set communication idle timeout.
Public method | StartSocketListener | Method that starts SocketListener Thread.
Public method | StopSocketListener | Method that stops Client SocketListening Thread.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Overridden. Client SocketListener Destructor.
Top

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


Finalize Method

TCPSocketListener.Finalize Method
[image]

Client SocketListener Destructor.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize()
C#
~TCPSocketListener();
C++
~TCPSocketListener();
J#
protected override void Finalize()
JScript
protected override function Finalize()

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


IsMarkedForDeletion Method

TCPSocketListener.IsMarkedForDeletion Method
[image]

Method that returns the state of this object i.e. whether this object is marked for deletion or not.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Function IsMarkedForDeletion() As Boolean
C#
public bool IsMarkedForDeletion()
C++
public:
bool IsMarkedForDeletion() sealed
J#
public bool IsMarkedForDeletion()
JScript
public function IsMarkedForDeletion() : bool

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


SetIdleTimeout Method

TCPSocketListener.SetIdleTimeout Method
[image]

Method that set communication idle timeout.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetIdleTimeout( _
ByVal i_lTimeout As Long _
)
C#
public void SetIdleTimeout(
long i_lTimeout
)
C++
public:
void SetIdleTimeout(
__int64 i_lTimeout
) sealed
J#
public void SetIdleTimeout(
long i_lTimeout
)
JScript
public function SetIdleTimeout(
i_lTimeout : long
)

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


StartSocketListener Method

TCPSocketListener.StartSocketListener Method
[image]

Method that starts SocketListener Thread.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub StartSocketListener()
C#
public void StartSocketListener()
C++
public:
void StartSocketListener() sealed
J#
public void StartSocketListener()
JScript
public function StartSocketListener()

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


StopSocketListener Method

TCPSocketListener.StopSocketListener Method
[image]

Method that stops Client SocketListening Thread.

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Sub StopSocketListener()
C#
public void StopSocketListener()
C++
public:
void StopSocketListener() sealed
J#
public void StopSocketListener()
JScript
public function StopSocketListener()

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


Events

TCPSocketListener Events
[image]

Public Events

 | Name | Description
Public event | CoilChangedEvent |
Public event | RegChangedEvent |
Top

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


CoilChangedEvent Event

TCPSocketListener.CoilChangedEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event CoilChangedEvent As TCPSocketListener.OnCoilChanged
C#
public event TCPSocketListener.OnCoilChanged CoilChangedEvent
C++
public:
virtual event TCPSocketListener.OnCoilChanged CoilChangedEvent {
void add(TCPSocketListener.OnCoilChanged value) sealed ;
void remove(TCPSocketListener.OnCoilChanged value) sealed ;
}
J#
/** event */
public final void add_CoilChangedEvent(TCPSocketListener.OnCoilChanged value);

/** event */
public final void remove_CoilChangedEvent(TCPSocketListener.OnCoilChanged value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


RegChangedEvent Event

TCPSocketListener.RegChangedEvent Event
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Event RegChangedEvent As TCPSocketListener.OnRegChanged
C#
public event TCPSocketListener.OnRegChanged RegChangedEvent
C++
public:
virtual event TCPSocketListener.OnRegChanged RegChangedEvent {
void add(TCPSocketListener.OnRegChanged value) sealed ;
void remove(TCPSocketListener.OnRegChanged value) sealed ;
}
J#
/** event */
public final void add_RegChangedEvent(TCPSocketListener.OnRegChanged value);

/** event */
public final void remove_RegChangedEvent(TCPSocketListener.OnRegChanged value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

TCPSocketListener Class
Advantech.Protocol Namespace


TCPSocketListener.OnCoilChanged Delegate

TCPSocketListener.OnCoilChanged Delegate
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub TCPSocketListener.OnCoilChanged( _
ByVal i_iStart As UInt32, _
ByVal i_iLen As UInt32 _
)
C#
public delegate void TCPSocketListener.OnCoilChanged(
uint i_iStart,
uint i_iLen
)
C++
public delegate void TCPSocketListener.OnCoilChanged(
unsigned int i_iStart,
unsigned int i_iLen
)
J#
/** delegate */
public delegate void TCPSocketListener.OnCoilChanged(
uint i_iStart,
uint i_iLen
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Protocol Namespace


TCPSocketListener.OnRegChanged Delegate

TCPSocketListener.OnRegChanged Delegate
[image]

Namespace: Advantech.Protocol
Assembly: Advantech.Protocol (in Advantech.Protocol.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub TCPSocketListener.OnRegChanged( _
ByVal i_iStart As UInt32, _
ByVal i_iLen As UInt32 _
)
C#
public delegate void TCPSocketListener.OnRegChanged(
uint i_iStart,
uint i_iLen
)
C++
public delegate void TCPSocketListener.OnRegChanged(
unsigned int i_iStart,
unsigned int i_iLen
)
J#
/** delegate */
public delegate void TCPSocketListener.OnRegChanged(
uint i_iStart,
uint i_iLen
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Advantech.Protocol Namespace


Advantech.Adam Hierarchy

Advantech.Adam Hierarchy
System.Object
Advantech.Adam.Adam4000Config
Advantech.Adam.Adam5000Config
Advantech.Adam.AdamBase
Advantech.Adam.Adam2000
Advantech.Adam.Alarm
Advantech.Adam.AnalogInput
Advantech.Adam.AnalogOutput
Advantech.Adam.Configuration
Advantech.Adam.Counter
Advantech.Adam.DigitalInput
Advantech.Adam.DigitalOutput
Advantech.Adam.Modbus
Advantech.Adam.PID
Advantech.Adam.AdamCOMConfig
Advantech.Adam.AdamControl
Advantech.Adam.AdamEvent
Advantech.Adam.AdamEventServerThread
Advantech.Adam.AdamGCL_IOMsg
Advantech.Adam.AdamInformation
Advantech.Adam.AdamMacComparer ---- System.Collections.IComparer
Advantech.Adam.AdamP2P
Advantech.Adam.AdamSocket
Advantech.Adam.AdamStreamRec
Advantech.Adam.AdamStreamRecList
Advantech.Adam.AdamWirelessAP
Advantech.Adam.GCL_IOMsg_Config
Advantech.Adam.P2P_Config
Advantech.Adam.SelfMarshalledStruct
Advantech.Adam.Adam2000Config
Advantech.Adam.Apax5000Config
Advantech.Common.ComPort
Advantech.Adam.AdamCom
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Advantech.Adam.GetDataCallback
Advantech.Adam.GetP2PDataCallback
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Advantech.Adam._AlarmReason
Advantech.Adam._CurrentDeviceState
Advantech.Adam._DeviceType
Advantech.Adam._FunctionType
Advantech.Adam._HardwareIOType
Advantech.Adam._SlaveGeneralRespCode
Advantech.Adam._SlotStatus
Advantech.Adam.Adam_AIAlarmMode
Advantech.Adam.Adam_AiStatus_HighAddress
Advantech.Adam.Adam_AiStatus_LowAddress
Advantech.Adam.Adam_AoStatus_HighAddress
Advantech.Adam.Adam_AoStatus_LowAddress
Advantech.Adam.Adam_Baudrate
Advantech.Adam.Adam_Checksum
Advantech.Adam.Adam_DIMode
Advantech.Adam.Adam_DOMode
Advantech.Adam.ADAM_EVENT
Advantech.Adam.Adam_EventType
Advantech.Adam.Adam_LocalAlarmType
Advantech.Adam.Adam_Protocol
Advantech.Adam.Adam_SlewRate
Advantech.Adam.Adam_Temperature
Advantech.Adam.Adam2000.CC2530DownloadMode
Advantech.Adam.Adam2000.ChannelStatus
Advantech.Adam.Adam2000.CmdCode
Advantech.Adam.Adam2000.MessageType
Advantech.Adam.Adam2000.SerialPortCfg
Advantech.Adam.Adam2000_Integration
Advantech.Adam.Adam2000Type
Advantech.Adam.Adam2kChannelType
Advantech.Adam.Adam4000_ChannelStatus
Advantech.Adam.Adam4000_CounterAlarmMode
Advantech.Adam.Adam4000_DataFormat
Advantech.Adam.Adam4000_FreqGateTime
Advantech.Adam.Adam4000_Integration
Advantech.Adam.Adam4000Type
Advantech.Adam.Adam4011_InputRange
Advantech.Adam.Adam4012_InputRange
Advantech.Adam.Adam4013_InputRange
Advantech.Adam.Adam4015_InputRange
Advantech.Adam.Adam4015T_InputRange
Advantech.Adam.Adam4016_InputRange
Advantech.Adam.Adam4017_InputRange
Advantech.Adam.Adam4017P_InputRange
Advantech.Adam.Adam4018_InputRange
Advantech.Adam.Adam4018M_InputRange
Advantech.Adam.Adam4018P_InputRange
Advantech.Adam.Adam4019_InputRange
Advantech.Adam.Adam4019P_InputRange
Advantech.Adam.Adam4021_OutputRange
Advantech.Adam.Adam4022T_InputRange
Advantech.Adam.Adam4022T_OutputRange
Advantech.Adam.Adam4024_OutputRange
Advantech.Adam.Adam4080_CounterMode
Advantech.Adam.Adam4080_GateMode
Advantech.Adam.Adam4080_InputSignalMode
Advantech.Adam.Adam4080_Level
Advantech.Adam.Adam4080D_LedSource
Advantech.Adam.Adam4100_BurnoutMap
Advantech.Adam.Adam4100_HighSpeed
Advantech.Adam.Adam4100_Integration
Advantech.Adam.Adam4117_InputRange
Advantech.Adam.Adam4118_InputRange
Advantech.Adam.Adam5000_ChannelStatus
Advantech.Adam.Adam5000_CounterAlarmMode
Advantech.Adam.Adam5000_DataFormat
Advantech.Adam.Adam5000_Integration
Advantech.Adam.Adam5000TCP_Integration
Advantech.Adam.Adam5000Type
Advantech.Adam.Adam5013_InputRange
Advantech.Adam.Adam5017_InputRange
Advantech.Adam.Adam5017H_InputRange
Advantech.Adam.Adam5017P_InputRange
Advantech.Adam.Adam5017S_InputRange
Advantech.Adam.Adam5017UH_BurnoutMap
Advantech.Adam.Adam5017UH_InputRange
Advantech.Adam.Adam5018_InputRange
Advantech.Adam.Adam5018P_InputRange
Advantech.Adam.Adam5024_OutputRange
Advantech.Adam.Adam5080_CounterMode
Advantech.Adam.Adam5081_CounterMode
Advantech.Adam.Adam6000_Integration
Advantech.Adam.Adam6000_RangeFormat
Advantech.Adam.Adam6000_SlewRate
Advantech.Adam.Adam6000Type
Advantech.Adam.Adam6015_InputRange
Advantech.Adam.Adam6017_InputRange
Advantech.Adam.Adam6018_InputRange
Advantech.Adam.Adam6022_InputRange
Advantech.Adam.Adam6022_OutputRange
Advantech.Adam.Adam6024_InputRange
Advantech.Adam.Adam6024_OutputRange
Advantech.Adam.Adam6051_CounterMode
Advantech.Adam.AdamInfoModuleStatus
Advantech.Adam.AdamInfoType
Advantech.Adam.AdamType
Advantech.Adam.AdamUnknown_DataFormat
Advantech.Adam.AdamUnknown_InputRange
Advantech.Adam.Apax_Integration
Advantech.Adam.Apax5000_ChannelStatus
Advantech.Adam.Apax5000Type
Advantech.Adam.Apax5080_CounterMode
Advantech.Adam.ApaxUnknown_InputRange
Advantech.Adam.DeviceConnectionStatus
Advantech.Adam.DI_OperationMode
Advantech.Adam.EVENT_STATUS
Advantech.Adam.EVENT_TYPE
Advantech.Adam.ModuleControlCmdType
Advantech.Adam.P2P_FunctionCode
Advantech.Adam.P2P_InfoIdx
Advantech.Adam.P2P_Mode
Advantech.Adam.PID_Addr
Advantech.Adam.PID_Loop

See Also

Advantech.Adam Namespace


Advantech.Common Hierarchy

Advantech.Common Hierarchy
System.Object
Advantech.Common.AdsdioAPI
Advantech.Common.ApaxAPI
Advantech.Common.ComPort
Advantech.Common.ICMP_ECHO_REPLY
Advantech.Common.ModbusServerAPI
Advantech.Common.Ping
Advantech.Common.SocketStream
Advantech.Common.Tool
Advantech.Common.UDPSocketClient
Advantech.Common.UDPSocketServer
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Advantech.Common.ModbusServerAPI.EventHandler_OnCoilChangedEvent
Advantech.Common.ModbusServerAPI.EventHandler_OnHoldRegChangedEvent
Advantech.Common.ModbusServerAPI.EventHandler_OnRemoteTcpClientConnectEvent
Advantech.Common.ModbusServerAPI.EventHandler_OnRemoteTcpClientDisconnectEvent
System.ValueType
Advantech.Common.ComPort.COMMTIMEOUTS
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Advantech.Common.Baudrate
Advantech.Common.Databits
Advantech.Common.DcbFlagFields
Advantech.Common.ErrorCode
Advantech.Common.Event
Advantech.Common.FlagSetting
Advantech.Common.FlowControl
Advantech.Common.Parity
Advantech.Common.Purge
Advantech.Common.Stopbits

See Also

Advantech.Common Namespace


Advantech.Graph Hierarchy

Advantech.Graph Hierarchy
System.Object
Advantech.Graph.AdvantechLine
Advantech.Graph.HorLabTag
Advantech.Graph.LineSegment
Advantech.Graph.MiniLZO
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Advantech.Graph.AdamWSNNode.EventHandler_AdamWSNNodeDoubleClick
Advantech.Graph.DelegateDisableButtons
Advantech.Graph.DelegateEnableButtons
Advantech.Graph.DelegateReConnectRemote
Advantech.Graph.DelegateUpdateBitmap
Advantech.Graph.ValueChangedEventHandler
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
Advantech.Graph.AdamComComponent
Advantech.Graph.AdamSocketComponent
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
Advantech.Graph.AdamIndicator
Advantech.Graph.AdamKnob
Advantech.Graph.AdamLight
Advantech.Graph.AdamMeter
Advantech.Graph.AdamNumLed
Advantech.Graph.AdamRemote
Advantech.Graph.AdamRuler
Advantech.Graph.AdamSwitch
Advantech.Graph.AdamTrend
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.UserControl
Advantech.Graph.AdamBatteryIndicator
Advantech.Graph.AdamExternalPower
Advantech.Graph.AdamSignalIndicator
Advantech.Graph.AdamWSNNode
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Advantech.Graph.DrawType
Advantech.Graph.enumHorLabOrientation
Advantech.Graph.enumHorLabType
Advantech.Graph.enumOrientation
Advantech.Graph.enumVerLabOrientation
Advantech.Graph.LightStyle
Advantech.Graph.Shape

See Also

Advantech.Graph Namespace


Advantech.Protocol Hierarchy

Advantech.Protocol Hierarchy
System.Object
Advantech.Protocol.ModbusRTUClient
Advantech.Protocol.ModbusServerBase
Advantech.Protocol.ModbusRTUServer
Advantech.Protocol.ModbusTCPServer
Advantech.Protocol.ModbusTCPClient
Advantech.Protocol.TCPSocketListener
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Advantech.Protocol.ModbusServerBase.EventHandler_OnCoilChangedEvent
Advantech.Protocol.ModbusServerBase.EventHandler_OnHoldRegChangedEvent
Advantech.Protocol.ModbusTCPServer.EventHandler_OnRemoteTcpClientConnectEvent
Advantech.Protocol.ModbusTCPServer.EventHandler_OnRemoteTcpClientDisconnectEvent
Advantech.Protocol.TCPSocketListener.OnCoilChanged
Advantech.Protocol.TCPSocketListener.OnRegChanged
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Advantech.Protocol.ModbusDataType
Advantech.Protocol.ModbusFunction

See Also

Advantech.Protocol Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace


AdamBase Class Hierarchy

AdamBase Hierarchy

The following table lists the types derived from AdamBase .

Derived Types

Type | Description
Adam2000 |
Alarm |
AnalogInput | AnalogInput class for ADAM series.
AnalogOutput |
Configuration | Configuration class for ADAM series running on ASCII command.
Counter |
DigitalInput | DigitalInput class for ADAM series.
DigitalOutput | DigitalOutput class for ADAM series.
Modbus | MODBUS class library.
PID |

See Also

AdamBase Class
Advantech.Adam Namespace