welcome

Advantech DAQNavi LabVIEW Driver User Manual

Homepage: http://www.advantech.com.cn

E-mail: info@advantech.com

Copyright© 1983-2014, Advantech (China) Co., Ltd. All Rights Reserved


About the user manual

About This Manual

Thank you for choosing Advantech DAQNavi LabVIEW driver. The user manual will show you how to use Advantech DAQNavi LabVIEW driver. Advantech DAQNavi LabVIEW driver is for DAQNavi Assistant and DAQNavi Polymorphic VI. With DAQNavi, users can easily operate Advantech DAQ Device in LabVIEW. It allows users to create their own tasks just by selecting scenarios, choosing devices, configuring parameters according to the instructions of the Wizard without programming. DAQNavi Polymorphic is a VI library under LabVIEW. In LabVIEW 8.6 or above versions, users can use Advantech I/O card to develop data acquisition, control and simulation via the VI library.

The user manual further provides a variety of example programs for users to modify according to their own needs. The user manual will not teach users to solve all the problems during modifying these examples. For the purpose of getting the most out of the manual, users have to master Windows operating system and at least one supported programming environment. If you have any questions, please contact Advantech product application engineers.

Service hotlines:

800-810-8389

86-010-82782066


Conventions

Symbols

Note: | The information, tips or explanations helpful for you to further understand the driver.
Warning: | The important information needing your attentions.
Italics: | Reserve content or the description information of the content.


Reading

Recommended Content

Here we list the recommended content and the orders to read them according to the users’ comprehension of data acquisition card, professional knowledge and the objects of using the user manual.

It is the first time that you use data acquisition card, and you are not familiar with signal processing and industrial automation.

It is recommended that you read ”Advantech DAQ tutorial” first, and then read the “DAQNavi Core Concept” to understand the important concepts of DAQNavi SDK, the common but important hardware knowledge of the data acquisition card and the design concept of DAQNavi. “Scenarios” is an important concept of DAQNavi, so it is advisable that you can read DAQNavi scenarios in the end to learn the related information about how to use DAQNavi\\DAQNavi scenarios, such as scenario function, signal connections, examples and SDK interface, etc. After you understand the above content, you can begin to read “How to DAQNavi LabVIEW Driver”.

Recommended reading steps: Advantech DAQ tutorial---> DAQNavi Core Concept ---> How to use DAQNavi\\DAQNavi scenarios ---> How to use DAQNavi LabVIEW Driver

You have used data acquisition card before.

It is recommended that you read “How to use DAQNavi\\DAQNavi scenarios” to understand the related information about scenarios, such as scenario function, signal connections, examples and SDK interface, etc. Next, it is advisable that you read “DAQNavi Core Concept” and some important concepts of SDK. After you understand the above content, you can begin to read “How to use DAQNavi LabVIEW Driver”.

Recommended reading steps: How to use DAQNavi\\DAQNavi scenarios ---> DAQNavi Core Concept ---> How to use DAQNavi LabVIEW Driver

You have used Advantech DAQ equipment for a long time, but you know nothing about DAQNavi.

It is recommended that you read “DAQNavi Core Concept” to understand the design intention of DAQNavi, which helps you use DAQNaviSDK interface more easily. Then, please read “How to use DAQNavi” to understand the content of DAQNavi, including programming process, the interfaces of DAQNavi and the classes, methods, and properties of DAQNavi SDK.

Recommended reading steps: DAQNavi Core Concept ---> How to use DAQNavi ---> How to use DAQNavi LabVIEW Driver


Organization of This Manual

Table of Content

The user manual includes the following chapters:

  • DAQNavi Summary of DAQNavi LabVIEW driver
  • Hardware and Software requirements
  • Supported hardware
  • The installation of DAQNavi LabVIEW driver
  • Usage references of DAQNavi LabVIEW driver
  • Example programs
  • Q&A

Summary of DAQNavi LabVIEW driver

The chapter provides a short introduction about DAQNavi LabVIEW driver and briefly introduces DAQNavi Assistant and DAQNavi Polymorphic VI.

Hardware and Software requirements

The chapter introduces the hardware, software and operating system requirements of DAQNavi LabVIEW driver.

Supported hardware

The chapter introduces the devices supported by Advantech DAQNavi SDK, the scenarios supported by Advantech data acquisition card and the installations of Adventech hardware and their drivers.

Installation of DAQNavi LabVIEW driver

The chapter introduces the installation process of DAQNavi LabVIEW driver.

Usage references of DAQNavi LabVIEW driver

The chapter introduces the process of driving DAQNavi Assistant and DAQNavi Polymorphic VI by DAQNavi LabVIEW driver.

Example programs

The chapter provides some example programs for DAQNavi LabVIEW driver.

Q&A

The chapter provides the solutions for the most frequent asked questions.


DAQNavi Assistant Introduction

Summary of DAQNavi LabVIEW

DAQNavi LabVIEW driver includes two portions, as shown in the following figure.

Assistant

  • Guided development
  • Quick solution production

Polymorphic VI

  • Sub-function development
  • Simple but powerful functions


Reading

Hardware and Software Requirements

Hardware Requirements

  • Supported hardware based on PCI, PCIE, USB and ISA.

Please configure your data acquisition card before open NI LabVIEW environment.

Please refer to Supported Hardware for the specific data acquisition tasks supported by the hardware.

Software Requirements

  • NI LabVIEW 8.6 or above versions

Operating System

  • Windows XP; Windows7-32bit; Windows7-64bit; Windows Server 2003-64bit


Driver Installation1

Installation of DAQNavi LabVIEW Driver

We provide two methods to install the driver:

  • Installation
  • Preinstallation
  • Uninstallation

Installation

First, you can check whether labview8.6 or above version has been installed; if it has yet to been installed, please install it before installing DAQNavi SDK package.

You can insert the corresponding card to the corresponding slot in the computer.

  1. Please insert the attached DVD into the system. If the automatic playback function is enabled in the system, then the installation program will be automatically activated and run.
  2. Please click “CONTINUE” to go to the next step.
  3. Please select “Installation”.
  4. Please select “DAQNavi SDK” to install LabVIEW Driver, as shown in the following figure.

    5. Figure1-1: Installshield wizard

  5. After the installation of DAQNavi SDK package is successful, please activate LabVIEW to create VI. Please click Check >> Function selection board >> measurement I/O In the block diagram. Then you can see “DAQNavi-Data Acquisition” icon; please click it, and then you will see DAQNavi Assistant and all DAQNavi Polymorphic VI, as shown in the Figure 1-2.

Figure1-2: Data Acquisition

Preinstallation

You can insert the corresponding card to the corresponding slot in the computer, or install DAQNavi SDK package first.

  1. Please insert the attached DVD into the system. If the automatic playback function is enabled in the system, then the installation program will be automatically activated and run.
  2. Please click “CONTINUE” to go to the next step.
  3. Please select “Installation”.
  4. Please select “DAQNavi SDK” to install DAQNavi SDK package, then you will see the interface shown in the following Figure1-1.
  5. Please select and then click “Nest” until it finishes.
  6. Please select “Start>>All Programs>>Advantech Automation>>DAQNavi>>Installation LabVIEW Driver”. Select Installation LabVIEW Driver can make the system automatically installs LabVIEW. After the installation is completed, please activate LabVIEW to create VI. In the block diagram, please click Check >> Function selection board >>I/O measurement. Then you can see “DAQNavi-Data Acquisition” icon; please click it, and then you will see DAQNavi Assistant and DAQNavi Polymorphic VI, as shown in the Figure 1-2.

Uninstallation

  1. Shut down the device in use.
  2. Run DAQNavi SDK package and then select “Remove” to uninstall LabVIEW Driver.


DAQNavi LabVIEW Driver Operaion

DAQNavi LabVIEW Driver Usage Reference

DAQNavi LabVIEW Driver is composed of two parts-Assistant and Polymorphic VI. Please refer to the following links for the information about the usages of Assistant and Polymorphic VI:

  • DAQNavi Assistant Usage
  • Polymorphic VI Usage
  • DAQNavi Assistant Reference
  • Polymorphic VI Reference

    •


DAQNavi Assistant Operation

Usage of DAQNavi Assistant

Usage of DAQNavi Assistant

DAQNavi Assistant includes two parts-input lead and output lead. Please refer to DAQNavi Assistant reference for more information.

The following takes Instant AI as an example to show the usage process of DAQNavi Assistant.

  1. In order to operate Advantech DAQ Device in LabVIEW, you need to open LabVIEW first, and then select “create VI” to create a new VI.

  2. Select DAQNavi Assistant from the Functions panel to add an Express VI, as shown in the following figure:

  3. After the Express VI is added, a DAQNavi Wizard will be brought out automatically, as shown in the following figure. You can select the scenarios which you want to run and configure them step by step according to the instructions of the Wizard.

  4. Take AI as an example, select Analog Input function and click “Next>>” to go to the next page.

  5. The Wizard will automatically list the scenarios related to the function which you selected. Please select the scenario which you want to run (take Instant AI as an example) and click “Next>>” to go to the next page.

  6. The Wizard will automatically list your system’s DAQ devices which support the scenario, so you just need to select the device which you want to use to run the scenario in the device list and then click “Next>>” to go to the next page to configure the related parameters relevant to the scenario, as shown in the following figure:

    7. You can check the Overview page to determine whether the configuration is appropriate; if it isn’t, you can click “<<Previous” to go to the previous page to modify it.

  7. After the parameter configuration is finished, please select “Finish” to automatically save and record the parameters that you just set. Please right click DDT (Dynamic Data Type) to bring out a dialog box and select “Create/Numeric Indicator” in the dialog box to show the acquired data, as shown in the following figure:

    8. Please click the white arrow above the panel to run the VI and then the Instant AI function of the device that you selected can work normally.

    Matters needing attention in using of DAQNavi Assistant

    • Except for some special designs, if you put DAQ Assistant in a loop, make sure that loop’s end condition is connected to the stop terminal.

    • For Static AO, the size of 1D array should be equal to channel count.

    • For Buffered AO’s 2D array data [m] [n], m should be equal to channel count; n should be equal to the samples value configured in the scenario.


DAQNavi Polymorphic VI的使用

Usage of DAQNavi Polymorphic VI

DAQNavi Polymorphic VI includes the following VIs:

  • DAQNavi Create Channel VI
  • DAQNavi Read
  • DAQNavi Write
  • DAQNavi Timing
  • DAQNavi Trigger
  • DAQNavi Start Task
  • DAQNavi Stop Task
  • DAQNavi Clear Task
  • DAQNavi Is Task Done
  • DAQNavi Wait Task Until Done
  • DAQNavi Get Property
  • DAQNavi Set Property
  • DAQNavi Feature Assistant
  • DAQNavi Property Assistant

DAQNavi Polymorphic VI is on program panel >> Function selection board >> measurement I/O, as shown in the following figure. When you move the cursor to a VI, the description corresponding to the VI will be shown on the screen.

Figure1-1: MeasurementI/O

These Vis are Polymorphic Vis. They can accept or return different data types, such as waveform, array and scalar value. The instance you selected is particularly used to perform the operation you executed. Please refer to Polymorphic VI for more information.

Polymorphic VI performs data acquisition task

When an application executes data acquisition, a task expresses a measurement or output operation. A task may include a channel set comprising one or more channels having timing, trigger and other properties, and each task is relevant to a hardware device.

A single task is created to execute each data acquisition operation, such like analog input, digital output, etc. All channel of a task have to be the same I/O type. The DAQNavi I/O types are as follows:

Analog input/output, digital input/output and counter input/output.

A DAQNavi Task can only operate a device, and the channel range is continuous. Counter-type task can have only one Counter Channel.

The general steps for Polymorphic VI to execute data acquisition are as follows:

  1. Add a DAQNavi Create Channel VI to create one or more virtual channels, and use the VI to designate I/O channel types, number or device number to execute tasks.
  2. Add a DAQNavi Read VI or DAQNavi Write VI to read, display or transmit data from a task.
  3. Run a task to acquire or generate data samples.
  4. Use DAQNavi Clear Task to give up the current execution and then release the resources occupied by it.

In addition to the above steps, you can optionally use DAQNavi Timing VI or DAQNavi Trigger to configure timing or trigger properties.

Note: some tasks definitely require starting them. Please refer to DAQNavi Start Task for more information.

The general steps for Polymorphic VI to execute data acquisition are as the above description. The following takes AI_OneBufferedAI_DelayToStart.vi as an example to show you the specific steps.

  1. In order to operate Advantech DAQ Device in LabVIEW, you have to open LabVIEW first and then select create VI to create a new VI, as shown in the following figure:

    2. Figure1-1: Create VI

  2. Please drag DAQNavi Create Channel.vi to the block diagram and configure its Physical channels and Value range, and then drag DAQNavi Property Assistant.vi to the block diagram, where one is configured as physical channel and the other is configured as value range. Next, right click the corresponding icon to select “property” and then configure the pop-up dialog box, as shown in the following figure. Afterward, choose two constants to express the device name for data acquisition, channel number and require voltage range.

    Figure2-1: Create Channel

    Figure 2-2: Physical Channels Property

    Figure 2-3: Value Range Property

  3. Then drag DAQNavi Timing.vi in and then configure its samples per channel and convert clock rate.

    4. Figure 3-1: Configure Convert Clock

  4. Drag DAQ Trigger.vi in to configure its trigger source and trigger action, and then drag DAQNavi Property Assistant.vi in, where one serves as trigger source and the other serves as trigger action. The corresponding configuration is as following dialog box. Then, choose constants to express delay count and level.

    5. Figure 4-1: Configure Trigger

    Figure 4-2: Tigger Source Property

    Figure 4-3: Trigger Source Property

  5. Drag DAQNavi Read.vi in to configure the number of samples per channel to read, and display the read data by waveform graph.

    6. Figure 5-1: Read Configuration

  6. Finally, drag DAQNavi Clear Task.vi in to release the resource currently occupied by the task and then configure a simple error handler for Clear Task. The final block diagram is as follows:

Figure 6-1: Final Block Diagram

Press ctrl+E to switch the corresponding block diagram to the front panel and after the configuration is done, please click to run the front panel to execute data acquisition, as shown in the following figure:


Polymorphic VI reference

DAQNavi Assistant References

The appearance of DAQNavi Assistant’s terminals will vary with different task functions. Some terminals are not always available for each kind of task. The following list the meanings of the supported terminals.

  • Input
  • Output
  • Wires for each task

DAQNavi Assistant’s leads are as follows:

Input

error in (no error): Errors occurred before task starts.

stop (true): Determine value of stopping a task and release resources after the task is finished. The default value is true. If DAQNavi Assistant is in a loop, make sure the wire of the loop’s end condition connect to the stop terminal of Express VI.

conversion rate: Conversion clock rate per channel for buffered AI/O. The default value is from the DAQNavi Wizard.

samples: Sample count per channel for buffered AI/O. The default value is from the DAQNavi Wizard.

time out: Specify the timeout threshold of the task. The default value is 10 seconds.

data in (DDT): It is the sample number of AO output. For Static AO, its required data type is 1D array, each element of the AO channel is a sample. For Buffered AO, its required data type is 2D array and each row corresponds to one AO channel. Users need to convert 1D array or 2D array to dynamic data type before connecting to the Express VI.

dataIn (U8Array): Samples outputted from DO.

frequency: Frequency value for pulse output and timer interrupt. The default value is from the DAQNavi Wizard.

delay count: Delay count outputted from delay pulse output. The default value is from the DAQNavi Wizard.

high period: High level outputted form PWM output. The default value is from the DAQNavi Wizard.

low period: Low level outputted form PWM output. The default value is from the DAQNavi Wizard.

compare table (I32 Array): Array comparison value for UpDown counter to execute comparison function.

snap event sources (I32 Array): Monitoring event triggers UpDown counter to grasp the current value.

reset updown count?: reset the updown count value stored by the updown counter to 0.

Output

error out: Output errors when task is finished or stopped duo to error.

data out (DDT): Samples read by task. The data type is dynamic data type.

stopped: The value determines whether task is finished or not.

dataOut (U8Array): Read samples from DI task. For DI interrupt, DI pattern matching interrupt and DI status changing interrupt, the sample is a snapshot data when DI interrupt takes place.

Interrupt source: Interrupt source (DI port or Di channel) is DI interrupt. DI pattern matching interrupts or DI status changing interrupts.

event count: Real-time counting value read by the task event counting function.

frequency value: Frequency value read by the frequency measurement function.

interrupt?: The value determines whether pulse output delay occurs in cntr event

pulse width: Pulse width measurement.

updown count: UpDown counter reads UpDown counting value.

continue compare data: Continue compare data have three members, which includes ContinueCompare task data mode matching, the Boolean data means whether there is data matching in the compare table; mode matching number, the integer means how much data matching is in the compare table; mode matching end, the Bollean value means whether the matching of the data in the compare table is finished.

snap counter data: Snap counters have two members. One is the snap event source of Snap counter task, which means the event has occurred; the other is data (I32 Array), the snapped data of the UpDown counter.

Wires for each task

AI

AI_InstantAI: error in, stop?, error out, data out (DDT)

AI_OneBufferedAI: error in, stop?, samples, rate, time out, error out, data out (DDT)

AI_StreamingAI: error in, stop?, rate, samples, time out, error out, data out (DDT)

AO

AO_StaticAO: error in, stop?, data in (DDT), error out

AO_OneBufferedAO: error in, stop?, dataIn (U8Array), error out

AO_StreamingAO: error in, stop?, data in (DDT), rate, samples, time out, error out, stopped

DIO

DI_StaticDI: error in, stop?, error out, dataOut (U8Array)

DO_StaticDO: error in, stop?, dataIn (U8Array), error out

DI_DIInterrupt: error in, stop?, time out, error out, interrupt source, dataOut (U8Array)

DI_DIPatternMatchInterrupt: error in, stop?, time out, error out, interrupt source, dataOut (U8Array)

DI_DIStatusChangeInterrupt: error in, stop?, time out, error out, interrupt source, dataOut (U8Array)

Counter

Counter_EventCounter: error in, stop?, error out, event count

Counter_FrequencyMeasurement: error in, stop?, error out, frequency value

Counte_DelayedPulseGeneration: error in, stop?, delay count, error out, interrupt?

Counter_PulseWidthMeasurement: error in, stop?, error out, pulse width

Counter_PWMOutput: error in, stop?, high period, low period, error out

Counter_UpDownCounter: error in, stop?, reset updown count?, error out, updown count

Counter_SnapCounter: error in, stop?, time out (10s), snap event sources, error out, snap counter data

Counter_ContinueCompare: error in, stop?, time out (10s), compare table (I32 Array), error out, continue compare data

Counter_BufferedEventCounter: error in, stop?, time out, samples,stopped, error out, data

Counter_BufferedPulseWidthMeasurement:error in, stop?, time out , samples,stopped, error out, data

Counter_BufferedPWMOutput:error in, stop?, time out , samples,stopped, error out, data

Counter_BufferedUpdownCounter:error in, stop?, time out , samples,stopped, error out, data


Polymorphic VI reference

Polymorphic VI References

The usages of the VIs provided by DAQNavi Polymorphic VI are as follows:

  • DAQNavi Create Channel VI

Create a channel and add it to the current Task. Each example of the VIs of DAQNavi Create Channel designates its I/O type and corresponding signal type. Please refer to DAQNavi Create Channel for more information.

  • DAQNavi Read

Read sampling point data from the designated Task. Each example of DAQNavi designates the I/O Type, data format, the number of sampling points read at one time and determine to read sampling point data from one channel or multiple channels. Please refer to DAQNavi Read for more information.

  • DAQNavi Write

Write sampling point data in the designated Task. Each example of DAQNavi designates the I/O Type, data format, the number of sampling points read at one time and determine to read sampling point data from one channel or multiple channels. Please refer to DAQNavi Write for more information.

  • DAQNavi Timing

Timing parameters with high-speed AI/O function are provided. Please refer to DAQNavi Timing for more information.

  • DAQNavi Trigger

Trigger parameters with high-speed AI/O function are provided. Please refer to DAQNavi Trigger for more information.

  • DAQNavi Start Task

Start a task. It will switch the status of a task to Running so as to acquire or output data. The VI is necessary for some applications, but optional in most cases. Please refer to DAQNavi Start for more information.

  • DAQNavi Stop Task

Stop a task. It will switch the status of a task to Ready. Please refer to DAQNavi Stop for more information.

  • DAQNavi Clear Task

Clear a Task. DAQNavi Clear Task will abandon the currently executed Task to release the resources occupied by it. After the task is cleared, you cannot use it again unless you recreate a new task.

  • DAQNavi Is Task Done

In some occasions, you can use DAQNavi Is Task Done to aperiodically check the execution status of a task by calling the VI; therefore, you can know the whether the execution of the task is over, or there is any error occurred during the execution.

Usually, if you don’t to read or write out data during high-speed infinite acquisition or output, you can aperiodically check the execution status through the VI. Please refer to DAQNavi Is Task Done for more information.

  • DAQNavi Wait Task Until Done

When you call DAQNavi Stop VI to step a Task or call DAQNavi Clear VI to clear a Task, you may use DAQNavi Wait Until Done VI to confirm whether the designated operation is completed.

The most common example is high-speed finite output function. If you activate a Task to execute a high-speed AO finite output and then stop the Task right away, the designated samples may not be completely outputted. Please refer to DAQNavi Wait Until Done for more information.

  • DAQNavi Get Property

Export the properties which can be configured in each control for users to check. Here the Features of each control are not exported for now. The reasons are as follows:

The programming of LabVIEW is based on data. Users care more about data and data flow. Our DAQNavi Driver Features puts more emphasis on the parameter verification in the programming to perform complicated parameter verification. Please refer to DAQNavi Get Property for more information.

  • DAQNavi Set Property

Regarding general parameter configuration, users can configure them in channel, timing, trigger; however, more properties can be configured in SCSCL.

Regarding other properties, users can configure them in DAQNavi Set Property VI. Please refer to DAQNavi Set Property for more information.

  • DAQNavi Feature Assistant

The feature assistant helps user to select device feature to read.

  • DAQNavi Property Assistant

Select the assistant for the property of DAQNavi customized data type of the device of the system.


DAQNavi Create Channel

Create a channel and add it to the current task. Each example of DAQNavi Create Channel polymorphic VI designates the I/O type and corresponding signal type.

Please use DAQNavi Clear VI to clear VI by DAQNavi Clear VI after using the task so as to prevent the memory from being allocated repeatedly.

Physical Channels Format

  • Physical Channels Name

Physical Channels name includes device label, module index number (optional) and channel part. For example, if physical channels string is DemoDevice, BID#000/ai0, then the device label is DemoDevice, BID#000, the channel label is ai0. The description of a device is to explain the device, which can be modified by users in the configuration interface of the device.

Channel identification columns corresponding to different I/O type are as follows:

Analog Input: ai, Analog Output : ao, Digital Input/Output: port, Counter Input/Output: cntr.

Module index number’s default value is 0, and there is no need or users to provide the number except for PCI-1780. The device has two modules for counter. If you want to use the function of module 1, then you should specify the index number, such as:

PCI-1780,BID#0/module1/cntr0

Channel part is composed of channel label and physical channel number, such as ai0, cntr1, port0.

  • physical channels Range

Two channel numbers are divided by ':' in order to specify the physical channel range, such as: DemoDevice, BID#000/ai0:3, DemoDevice, BID#000/ai0, DemoDevice, BID#000/ai1.

  • Physical channels List

Physical channel name and physical channel range are divided by ',', such as: DemoDevice, BID#000/ai0, DemoDevice, BID#000ai1.

AI Voltage ,Current , Temperature

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

signal type: Signal connection type. If the terminal is not wired, the default value is Single-Ended. Users can check the available options supported by the device via the Individual driver user Interface manual.

value range: Value range. If the terminal is not wired, the default value of AI Voltage is +/-5V, the default value of AI Current is 0~20mA, the default value of AI Temperature is T/C J type0~760degree C. Users can check the available options supported by the device via the Individual driver user Interface manual.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

AO Voltage ,Current

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

signal type: Signal connection type. If it is not wired, the default value is Single-Ended. Users can check the available options supported by the device via the Individual driver user Interface manual.

value range: Value range. If there is no connection to the terminal, the default value of AI Voltage is +/-5V, the default value of AI Current is 0~20mA, the default value of AI Temperature is T/C J type0~760degree C. Users can check the options supported by the device via the Individual driver user Interface manual.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital Input

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital Output

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Counter Input Count Value, Pulse Width

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Counter Input Frequency

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

frequency measurement method: If it is not wired, the default value is AutoAdaptive. Users can check the available options supported by the device via the Individual driver user Interface manual.

collection period: If it is not wired, the default value is 0. Users can check the range supported by the device via the Individual driver user Interface manual.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Counter Input UpDown Count Value

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

signal counting type: If it is not wired, the default value is PulseDirection. Users can check the available options supported by the device via the Individual driver user Interface manual.

error in: Describe the errors occurred before the execution of the VI. If there is no connection to the terminal, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Counter Output Frequency

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

frequency: If there is no connection to the terminal, the default value is 100. Users can check the range supported by the device via the Individual driver user Interface manual.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Counter Output Delayed Pulse

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

delay count: If there is no connection to the terminal, the default value is 100. Users can check the range supported by the device via the Individual driver user Interface manual.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Counter Output Pulse Width

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

high period: If there is no connection to the terminal, the default value is 0.08. Users can check the range supported by the device via the Individual driver user Interface manual.

low period: If there is no connection to the terminal, the default value is 0.02. Users can check the range supported by the device via the Individual driver user Interface manual.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Buffered Counter Input Count Value

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Buffered Counter Input Pulse Width

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Buffered Counter Input UpDown Count Value

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

signal counting type: If it is not wired, the default value is PulseDirection. Users can check the available options supported by the device via the Individual driver user Interface manual.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Buffered Counter Output Pulse Width

The selection method is as follows:

task in: Specify the task where the channel created by the VI is added. If the terminal is not wired, DAQNavi Polymorphic will create a task, and add the channel to the task.

physical channels: Specify the device and channel range. Please refer to “physical channels format” for the information about the format.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNavi Read

DAQNavi Read is to read the data from designated sample points of the designated task. Respectively select Single Channel or Multiple Channel instances to read the data from the sample points according to whether the channel number of the task is 1 or more than 1. Users can obtain the channel number of the current task by the Channel Count of DAQNavi Get Property. Please note that when designating channel from DAQNavi CreateChannel, you can only designate physical channels. Regarding AI, DAQNavi will calculate selected logic channels and the number according to the signal type configured by users.

Regarding unscaled, keep 2D U16, 2D U32 because the driver read data from mixed channels. The result that one row represents one channel can be acquired by detaching. When the read version selected by users is not consistent with the data size of the current device, the data may not be incorrect.

Added 1D U16, 1D U32 versions can help the users who want to directly save data save more time.

Analog DBL 1Chan 1Samp

Read sample points whose data type is double from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Analog Wfm 1Chan 1Samp

Read sample points whose data type is WaveForm from a task consisting of one channel.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Analog 1D DBL 1Chan NSamp

Read sample points whose amount of data numbers of samples per channel is and data type is 1D double from a task consisting of one channel.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

markBuf: An array of data mark that receives the data mark information about the data.

Analog Wfm 1Chan NSamp

Read sample points whose amount of data is number of samples per channel and data type is WaveForm from a task consisting of one channel.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

markBuf: An array of data mark that receives the data mark information about the data.

Analog 1D DBL NChan 1Samp

Read sample points whose amount of data is 1 and data type is 1D from a task consisting of one or more or more than one channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each of the data is corresponding to one channel.

Analog 1D Wfm NChan 1Samp

Read sample points whose amount of data is 1 and data type is 1D WaveForm from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each WaveForm is corresponding to one channel and include one data sample point.

Analog 2D DBL NChan NSamp

Read sample points whose amount of data is number of samples per channel and the data type is 2D double from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each row is corresponding to one channel and the number of columns is the number of data sample points read from each channel.

markBuf: An array of data mark that receives the data mark information about the data.

Analog 1D Wfm NChan NSamp

Read sample points whose amount of data is number of samples per channel and data type is 1D Wfm from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each WaveForm is corresponding to one channel and the data which one WaveForm includes are the data sample points read from each channel.

markBuf: An array of data mark that receives the data mark information about the data.

Analog 2D U16 NChan NSamp

Read sample points whose amount of data is number of samples per channel and data type is 2D U16 raw data from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each row is corresponding to one channel and the number of columns is the number of data sample points read from each channel.

markBuf: An array of data mark that receives the data mark information about the data.

Analog 2D U32 NChan NSamp

Read sample points whose amount of data is number of samples per channel and data type is 2D U32 raw data from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each row is corresponding to one channel and the number of columns is the number of data sample points read from each channel.

markBuf: An array of data mark that receives the data mark information about the data.

Analog 1D U16 NChan NSamp

Read sample points whose amount of data is number of samples per channel and data type is 1D U16 raw data from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where the data are mixed channels. (e.g. a task has three channels 0, 1, 2 and the data distribution is 0 1 2 0 1 2 0 1 2..)

markBuf: An array of data mark that receives the data mark information about the data.

Analog 1D U32 NChan NSamp

Read sample points whose amount of data is number of samples per channel and data type is 1D U32 raw data from a task consisting of one or more channels.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where the data are mixed channels. (e.g. a task has three channels 0, 1, 2 and the data distribution is 0 1 2 0 1 2 0 1 2..)

markBuf: An array of data mark that receives the data mark information about the data.

Digital U8 1Chan 1Samp

Read sample points whose data type is U8 from a task consisting of one port.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Digital Wfm 1Chan 1Samp

Read sample points whose data type is WaveForm from a task consisting of one port.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Analog 1D DBL 1Chan NSamp

Read sample points whose amount of data is number of samples per channel and data type is 1D double from a task consisting of one channel.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Digital Wfm 1Chan 1Samp

Read a sample point whose data type is WaveForm from a task consisting of one port.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Digital 1D U8 1Chan NSamp

Read sample points whose amount of data is number of samples per channel and data type is 1D U8 from a task consisting of one port.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

numbers of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Digital Wfm 1Chan NSamp

Read sample points whose amount of data is number of samples per channel and data type is WaveForm from a task consisting of one port.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Digital 1D U8 NChan 1Samp

Read sample points whose amount of data is 1 and data type is 1D U8 from a task consisting of one or more ports.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each of the data is corresponding to one port.

Digital 1D Wfm NChan 1Samp

Read sample points whose amount of data is 1 and data type is 1D WaveForm from a task consisting of one or more ports.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each WaveForm is corresponding to one port and each WaveForm includes one data sample point.

Digital 2D U8 NChan NSamp

Read sample points whose amount of data is numbers of samples per channel and data type is 2D U8 from a task consisting of one or more ports.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each row is corresponding to one port and the number of columns is the number of data sample points read from each port.

Digital 1D Wfm NChan NSamp

Read sample points whose amount of data is numbers of samples per channel and data type is 1D Wfm from a task consisting of one or more ports.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 1000.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where each line is corresponding to one port and the data which one WaveForm includes is the number of data sample points read from each port.

Counter Count Value 1Chan 1Samp

Read one count value of the Event Counter from a task.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Counter Pulse Width 1Chan 1Samp

Read one value of the Pulse Width Measurement from a task.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where a cluster includes the high period and low period of a Pulse.

Counter Frequency 1Chan 1Samp

Read one value of the Frequency Measurement from a task.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out:: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Counter 1D Count Value 1Chan NSamp

Read multiple count values of the Event Counter from a task.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 10.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Counter 1D Pulse Width 1Chan NSamp

Read one value of the Pulse Width Measurement from a task.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 10.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read, where a cluster includes the high period and low period of a Pulse.

Counter 1D Frequency 1Chan NSamp

Read multiple values of the Frequency Measurement from a task.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 10.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Buffered Counter 2D Count Value

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 10.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.

Buffered Counter 2D Pulse Width

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

number of samples per channel: Specify the amount of data to be read, the default value is 10.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

data: Data read.


DAQNavi Write

Output sample point data to the designated task. Select the Single Channel or Multiple Channel of Write to output sample point data according to whether the number of the channel of the task is one or more.

Regarding unscaled, keep 2D U16, 2D U32, one row represents the data of one channel. When the Write version selected by users is not consistent with the data size of the current device, the data may not be all correct.

Analog DBL 1Chan 1Samp

The task has one channel and the output data type is double.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog Wfm 1Chan 1Samp

The task has one channel and the output data type is Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog 1D DBL 1Chan NSamp

The task has one channel and the data type is 1D double.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog Wfm 1Chan NSamp

The task has one channel and the data type is Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog 1D DBL NChan 1Samp

The task has one or more channels and the output data type is 1D double.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

dataContain the data to write to the task, and each element of the array is corresponding to each channel.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog 1D Wfm 1Chan NSamp

The task has one or more channels and the output data type is Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task, including channel count waveform and each waveform include one datum.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog 2D DBL NChan NSamp

The task has one or more channels and the output data type is 2D double.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task, and each row represents the data of one channel and the number of columns represents the amount of data to be outputted from each of the channels.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog 1D Wfm NChan NSamp

The task has one or more channels and the output data type is 1D Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task., including channel count waveform.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog 2D U16 NChan NSamp

The task has one or more channels and the output data type is 2D U16.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task. Each row represents the data of one channel, and the number of columns represents the data to be outputted from each of the channels.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Analog 2D U32 NChan NSamp

The task has one or more channels and the output data type is 2D U32.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task. Each row represents the data of one channel, and the number of columns represents the data to be outputted from each of the channels.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital U8 1Chan 1Samp

The task has one port and the output data type is U8.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital Wfm 1Chan 1Samp

The task has one port and the output data type is Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital 1D U8 1Chan NSamp

The task has one port and the output data type is 1D U8.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital Wfm 1Chan NSamp

The task has one port and the output data type is Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital 1D U8 NChan 1Samp

The task has one port and the output data type is 1D U8.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task. Each element corresponds to each port.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital 1D Wfm 1Chan NSamp

The task has one or more port and the output data type is Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: The data to write to the task. The number of waveform is equal to the port count and each waveform includes one datum.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital 2D U8 NChan NSamp

The task has one port and the output data type is 2D U8.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task, each row represents the data of one port, and the number of columns represents the amount of data to be outputted from each port.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Digital 1D Wfm NChan NSamp

The task has one port and the output data type is 1D Wfm.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: The data to write to the task, including waveforms, and the number of waveform is equal to the port count.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Counter 2D Pulse Width

The output data type is 2D Pulse Width.

The selection method is as follows:

task in: Specify the task where the operation applies.

time out: Specify the amount of time in seconds to wait for the data to become available. If the terminal is not wired, the default value is 10 seconds. If the time elapses, but the required amount of data is not available, the VI returns ErrorCode: ErrorDevicelo TimeOut as well as any of the available data before the timeout occurs.

data: Contain the data to write to the task. Each row represents the data of one channel, and the number of columns represents the data to be outputted from each of the channels.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

number of samples written per channel: The amount of data already outputted to the device.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNavi Timing

Timing parameter with high-speed AI/O function.

ConvertClock(Analog)

Configure the convert clock source, rate, sample mode and samples.

task in: Specify the task where the operation applies.

clock source: If it is not wired, the default value is Internal clock. Users can check the available options supported by the device via the Individual driver user Interface manual.

rate: If it is not wired, the default is 1000. Users can check the available options supported by the device via the Individual driver user Interface manual.

sample mode: Specify to execute finite or infinite data acquisition or output. If it is not wired, the default value is Finite.

samples:

For task whose I/O type is Analog Input:

If the samples mode is Finite, the samples specify the number of the data sample points acquired by each channel.

If the samples mode is Infinite, DAQNavi Polymorphic confirms the properties of the samples and interval count of the Scan Channels of the controls of Buffered AI in CSCL.

For task whose I/O type is Analog Output:

For the samples value here, the adjusted samples value will be used to confirm the properties of the samples and interval count of the Scan Channels of the controls of Buffered AI in CSCL when the task call DAQNavi Write VI for the first time.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Scan Clock (Analog Input)

Configure the clock source, rate and scan count of scan clock.

task in: Specify the task where the operation applies.

clock source: If it is not wired, the default value is None. Users can check the available options supported by the device via the Individual driver user Interface manual.

rate: If it is not wired, the default value is 100. Users can check the available options supported by the device via the Individual driver user Interface manual.

scan count: If it is not wired, the default value is 10. Users can check the available options supported by the device via the Individual driver user Interface manual.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Use WaveForm (Analog Output)

Configure the clock source and WaveForm of convert clock.

task in: Specify the task where the operation applies.

clock source: If it is not wired, the default value is Internal clock. Users can check the available options supported by the device via the Individual driver user Interface manual.

WaveForm : Use the dt parameter, the time interval between two sample points, to confirm the convert clock rate and determine samples parameters according to the number of the data sample points which the WaveForm includes. Users should ensure the WaveForm here and the WaveForm connected to is DAQNavi Write VI the same one.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Sample Clock (Buffered Counter Input)

Configure the clock source and WaveForm of convert clock.

task in: Specify the task where the operation applies.

sample clock source: If it is not wired, the default value is None or ExternDigtalClock. Users can check the available options supported by the device via the Individual driver user Interface manual.

secion length:If it is not wired, the default value is 1024. Section length sets how many samples of each counter should be acquired before sending the dataready event.

section count:If it is not wired, the default value is 0.A non-zero value of the property indicates a finite acquisition, and a zero value of the property indicates an infinite acquisition.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.

Sample Clock (Buffered Counter Output)

Configure the clock source and WaveForm of convert clock.

task in: Specify the task where the operation applies.

clock source: If it is not wired, the default value is None. Users can check the available options supported by the device via the Individual driver user Interface manual.

sample mode: Specify to execute finite or infinite data acquisition or output. If it is not wired, the default value is Finite.

samples per channel:the adjusted samples value will be used to confirm the properties of the samples and interval count of the Scan Channels of the controls of Buffered Counter in CSCL when the task call DAQNavi Write VI for the first time.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNavi Trigger

Configure Trigger parameters.

task in: Specify the task where the operation applies.

trigger source: If it is not wired, the default value is None. Users can check the available options supported by the device via the Individual driver user Interface manual.

edge: If it is not wired, the default value is Rising. Users can check the available options supported by the device via the Individual driver user Interface manual.

level: If it is not wired, the default value is 5. Users can check the available options supported by the device via the Individual driver user Interface manual.

action: If it is not wired, the default value is DelayToStart. Users can check the available options supported by the device via the Individual driver user Interface manual.

delay count: If it is not wired, the default value is 0. Users can check the available options supported by the device via the Individual driver user Interface manual.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNavi Start

Start to execute a task to switch the status of the task to running and then proceed to acquire data or output.

If the task is Idle when calling DAQNavi Read/Write VI, the prepare action will be performed first to configure the device and automatically calling start action to switch the status of the task to running.

task in: Specify the task where the operation applies.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNavi Stop

Stop the task to switch the status of the task to Ready.

For finite high-speed output, DAQNavi Wait Until Done VI should be called before calling stop in order to make sure the output complete.

task in: Specify the task where the operation applies.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNai Is Task Done

DAQNavi Is Task Done

In some occasions, users can aperiodically check the execution status of a task. Users can know whether the execution of the task is done or there is any error occurred during the execution by calling the VI.

task in: Specify the task where the operation applies.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

isTaskDone: Go back to check whether the execution of the current task is done. If it is, return true; if it isn’t, return false.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNavi Wait Until Done

When calling DAQNavi Stop VI to stop a task or calling DAQNavi Clear VI to clear a task, you may need to confirm whether the designated operation is done through DAQNavi Wait Until Done VI.

task in: Specify the task where the operation applies.

time ToWait: Specify the amount of time in seconds to wait for the current task to run completely, the default value is 10. If the time elapses, but the task still fails to run completely, the error out will output ErrorDevicelo TimeOut.

error in: Describe the errors that occurred before the VI runs. If the terminal is not wired, the default value is no error occurred.

task out: Take out the reference of the task.

error out: If there is an error in error in, the VI will directly transmit error in to error out. If there is no error in error in, the VI will run its function. If there is an error occurred during the execution, the VI will transmit the error out via error out.


DAQNavi Get Property

Export the properties which defined by CSCL and can be configured in each control for users to check.

The following are descriptions for the special properties peculiar to LabVIEW.

Digital Input/Counter Input/Output Event Refnum

A labview event reference can be obtained via the property. The event reference can be connected to Event Dynamic Registration terminal to monitor various events, such as DI Interrupt, DI Pattern Match, DI Status Change, Timer Pulse, OneShot and UpDown Counter.


DAQNavi Set Property

1. AO regen mode

AO regen mode is a property of Streaming AO, which determines whether to output new data provided by DAQNavi Write VI. If the terminal is not wired, the default value is NonRegeneration, which needs users to repeatedly output new data by Write VI.

If the terminal is wired to Regeneration, then the Function Generator will be created, which means if DAQNavi Write VI is used to provide the output data for the first time, the same data will be outputted repeatedly.

Under the mode, if the samples are not adjusted, the Driver will report Error after about 30 minutes.

Memorandum: in LabVIEW, Write provides data slowly (the things done in each iteration waste a lot of time, the below output too fast (the convert clock rate is set too high), which will cause under run. Which is a limitation, users need to reduce the time waste in iteration and lower the convert clock rate to improve the problem.

2. UpDownCounter Events To Snap

UpDownCounter Events To Snap is a property of the Snap Counter function of UpDown Counter. It provides the event sources needing to be tested by Snap Counter function. If it is not wired, the Snap Counter will not test any event by default. When inputting, please divide the RefNum string corresponding to the test time by “l”, and input them together.

3. UpDownCounter Compare Table

UpDownCounter Compare Table is a property of the Continue Compare function of UpDown Counter, which provides the count value needed to be matched for the Continue Compare function. If it is not wired, the default value is that the Continue Compare will not perform any matching. When inputting, input in the count value needed to be matched by I32 array.


Using Example Programs

Example Programs

Open the example programs of DAQNavi LabVIEW Driver

DAQNavi LabVIEW Driver library provides some example programs to show users how to use DAQNavi LabVIEW Driver to operate Advantech DAS card under LabVIEW. Users can develop specific applications according to these example programs.

These example programs are installed under the \Advantech\DAQNavi\Examples inventory, all example programs are under LabVIEW_DAQNavi_Assistant and LabVIEW_DAQNavi_Polymorphic_VI.

Note: among the Vis supported by DAQNavi LabVIEW Driver, Device_GetSupportedDevices.vi can search all VI examples supported by Assistant and the search range thereof.

The example programs of include the following two parts:

  • Assistant Example Programs
  • Polymorphic VI Example Programs


Assistant Example Programs

The following table lists the example programs of DAQNavi under Assistant.

Please refer to for the information about how to open the example programs.

DAQNavi Assistant Example Programs

VI example name | Description
AI_InstantAI.vi | Acquire the data inputted from several AI channels via the static method.
AI_OneBuffered.vi | Repeatedly acquire finite pieces of data inputted from several AI channels via the asynchronous batch method.
AI_OneBuffered_double_trigger.vi | Repeatedly acquire finite pieces of data inputted from several AI channels via the asynchronous batch method with double trigger control.
AI_StreamingAI.vi | Repeatedly acquire infinite pieces of data inputted from several AI channels via the asynchronous batch method.
AI_StreamingAI_double_trigger.vi | Repeatedly acquire infinite pieces of data inputted from several AI channels via the asynchronous batch method with double trigger control.
AO_OneWaveformAO.vi | Via the batch method, finite pieces of data are analogized as a complete sinusoid signal to be outputted to the AO channel.
AO_StaticAO.vi | Use software method to let signals pass but output data to AO channels.
AO_StreamingAO.vi | Via the asynchronous batch method, infinite pieces of data are analogized as a complete sinusoid signal to be outputted to the AO channel.
DI_DIInterrupt.vi | Select a DI port with the interrupt function via an interrupt event and start the snapshot function of the DI port.
DI_DIPatternMatchInterrupt.vi | Select a DI port with status change interrupt function via status change event and start the snapshot function of the DI port.
DI_StatusChangeInterrupt.vi | Select a DI port with pattern matching interrupt function via pattern matching interrupt event and start the snapshot function of the DI port.
DI_StaticDI.vi | Digital static input repeatedly reads all DI ports via the instant method and shows the results.
DO_StaticDO.vi | Output the digital value to the DO port during calling a static output.
Counter_ContinueCompare.vi | Set a compare value to start the up-down counter. When the count value matches the compare value, send an event.
Counter_DelayedPulseGeneration.vi | Wait for an outer signal. When the outer signal reaches, start to count immediately. When the count value is reached, the OUT pin sends a signal; meanwhile, the Demo waits for an outer signal again.
Counter_EventCounter.vi | Count the number of the impulses generated from outer digital signals.
Counter_FrequencyMeasurement.vi | Measure the frequency of an input signal.
Counter_PulseOutputwithTimerInterrupt.vi | Send an interrupt or impulse at regular intervals.
Counter_PulseWidthMeasurement.vi | Measure the high level period and low level period of an input signal.
Counter_PWMOutput.vi | Send a signal defined by high level period and low level signal.
Counter_SnapCounter.vi | Select a snapshot event ID to start the snapshot function of the counter. When a designated event occurred, immediately read data from the channel memory of the designated counter and return to the buffer.
Counter_UpDownCount.vi | Select 4 times AB phase encoder counter to count the time for generating pulses from an outer signal.
Counter_BufferedEventCounter.vi | Count the pulse number of external signal according to sample clock rate.
Counter_BufferedPulseWidthMeasurement.vi | Measure the high level period and low level period of the input pulse signal according to sample clock rate.
Counter_BufferedPWMOutput.vi | Output the pulse wave according to preset parameters.
Counter_BufferedUpdownCounter.vi | Indicate the shaft position according to sample clock rate.


Polymorphic VI Example Programs

The following table lists the example programs in Polymorphic VI for DAQNavi.

Please refer to Opening DAQNavi Example Programs for the information about how to open example programs.

DAQNavi Polymorphic VI Example Programs

VI example name | Description
AI_InstantAI_MultipleChannels.vi | Acquire the data inputted from several AI channels via the multiple-channel instant method.
AI_InstantAI_SingleChannel.vi | Acquire the data inputted from one AI channel via the single-channel instant method.
AI_OneBufferedAI_MultipleChannels.vi | Repeatedly acquire finite pieces of data inputted from several AI channels via the multiple-channel batch method.
AI_OneBufferedAI_SingleChannel.vi | Repeatedly acquire limited pieces of data inputted from one AI channel via the single-channel batch method.
AI_OneBufferedAI_Trigger_DelayToStart.vi | The example show users the analog quantity single batch sampling with trigger control and the trigger action is DelayToStar. Which means the driver begins the data acquisition process but fails to store the data in the buffer. Once the trigger occurs, the driver will wait for sampling (the sampling number is configured via DealyCount) and then save the data in the data buffer.
AI_OneBufferedAI_Trigger_DelayToStop.vi | The example show users the analog quantity single batch sampling with trigger control and the trigger action is DelayToStop. Which means the driver starts the data acquisition process and save the data in the data buffer. Once the trigger occurs, the driver will wait for sampling (the sampling number is configured via DealyCount) and then stop to save the data in the data buffer.
AI_OneBufferedAI_Trigger_DoubleTrigger.vi | The example show users the analog quantity single batch sampling with trigger control and one trigger action is DelayToStart and the other trigger action is DelayToStop.
AI_StreamingAI_MultipleChannels.vi | Repeatedly acquire infinite pieces of data inputted from several AI channels via the multiple-channel asynchronous batch method.
AI_StreamingAI_SingleChannel.vi | Repeatedly acquire infinite pieces of data inputted from several AI channels via the single-channel asynchronous batch method.
AI_StreamingAI_Trigger_DelayToStart.vi | The example shows users how to the analog quantity continuously sampling with trigger control and the trigger action is DelayToStart.
AI_StreamingAI_Trigger_DelayToStop.vi | The example shows users how to the analog quantity continuously sampling with trigger control and the trigger action is DelayToStop.
AI_StreamingAI_Trigger_DoubleTrigger.vi | The example shows users how to the analog quantity continuously sampling with trigger control and one trigger action is DelayToStart and the other trigger action is DelayToStop.
AI_StreamingAI_MultipleChannels_DataMark.vi | Repeatedly acquire infinite pieces of data inputted from several AI channels and data marks within the specified time-out interval via the multiple-channel asynchronous batch method.
AO_OneWaveformAO_MultipleChannels.vi | Via the multiple-channel batch method, finite pieces of data are analogized as multiple complete sinusoid signals to be outputted to the AO channel.
AO_OneWaveformAO_SingleChannek.vi | Via the single-channel batch method, finite pieces of data are analogized as a complete sinusoid signal to be outputted to the AO channel.
AO_OneWaveformAO_UseWaveForm.vi | Via the UseWaveForm batch method, finite pieces of data are analogized as a complete sinusoid signal to be outputted to the AO channel.
AO_StaticAO_MultipleChannels.vi | Use software method to output signals to the AO channel via multiple channels single data.
AO_StaticAO_SingleChannel.vi | Use software method to output signals to the AO channel via single channels single data.
AO_StaticAO_RawData.vi | Use software method to output signals to the AO channel via the original data.
AO_StreamingAO_MultipleChannels.vi | Via the multiple-channel asynchronous batch method, infinite pieces of data are analogized as multiple complete sinusoid signals to be outputted to the AO channel.
AO_StreamingAO_SingleChannel.vi | Via the single-channel asynchronous batch method, infinite pieces of data are analogized as a complete sinusoid signal to be outputted to the AO channel.
AO_StreamingAO_Regeneration.vi | Via the AO regen mode asynchronous batch method, infinite pieces of data are analogized as a complete sinusoid signal to be outputted to the AO channel.
DI_DIInterrupt.vi | Select a DI channel with the interrupt function via the interrupt event and start the snapshot function of the DI port.
DI_DIPatternMatch.vi | Select a DI port with the status change interrupt function via status change event and start the snapshot function of the DI por.
DI_StaticDI_MultipleChannel.vi | Repeatedly read the input from a DI port via the multiple-channel instant method and display the result.
DI_StaticDI_SingleBit.vi | Repeatedly read the inputs from specific bit of a channel via the single-sample of the single-channel instant method and display the result.
DI_StaticDI_SingleChannel.vi | Repeatedly read the inputs from all DI ports via the single-channel instant method and display the result.
DI_DIStatusChange.vi | Select a DI port with pattern matching interrupt function via pattern matching interrupt event, and start the snapshot function of the DI port.
DO_StaticDO_MultipleChannel.vi | Via the multiple-channel instant method, write in an output status value of a DO part by hexadecimal.
DO_StaticDO_SingleChannel.vi | Via the single-channel instant method, write in an output status value of a DO part by hexadecimal.
DO_StaticDO_SingleBit.vi | Via the single-channel instant method, write in an output status value of a DO port's bit by a hexadecimal.
Counter_ContinueCompare.vi | Set a compare value to start the up-down counter. When the count value match the compare value, send an event.
Counter_DelayedPulseGeneration.vi | Wait for an outer signal. When the outer signal reaches, start to count immediately. When the count value is reached, the out pin sends a signal; meanwhile, the Demo waits for an outer signal again.
Counter_EventCounter.vi | Count the number of pulses generated from outer digital signal.
Counter_EventCounter_MultipleCounters.vi | Count the number of pulses generated from outer digital signal of multi-channels at a time.
Counter_FrequencyMeasurement.vi | Measure the frequency of an input signal.
Counter_PulseOutputwithTimerInterrupt.vi | Send an interruption or pulse at regular intervals.
Counter_PulseWidthMeasurement.vi | Measure the high level period and low level period of an input signal.
Counter_PWMOutput.vi | Send a signal defined by the level period and low level period.
Counter_SnapCounter.vi | Select a snapshot event ID to start the snapshot function of the counter. When a designated event occurred, immediately read data from the channel memory of the designated counter and return to the buffer.
Counter_UpDownCount.vi | Select 4 times AB phase encoder counter to count the time for generating pulses from an outer signal.
Counter_BufferedEventCounter.vi | Count the pulse number of external signal according to sample clock rate.
Counter_BufferedPulseWidthMeasurement.vi | Measure the high level period and low level period of the input pulse signal according to sample clock rate.
Counter_BufferedPWMOutput.vi | Output the pulse wave according to preset parameters.
Counter_BufferedUpDownCounter.vi | Indicate the shaft position according to sample clock rate.
Device_GetAIFeatures.vi | Use the GetFeatures VI to show how to get the AI releated features such as resoluation,value range and so on.
Device_GetSupportedDevices | Acquire the devices supporting Instant AI and Buffered AI from the current device.


Known Issues

Q&A

  • In example programs, can the sub-functions under the same scenario be used at the same time?
  • Invalid physical channel format.
  • Regarding reading and outputting sample point data, how to make sure the data are correct.
  • The logic channels and number are configured by users.

Can the sub-functions under the same scenario be used at the same time?

The sub-functions under the same scenario cannot be used at the same time, or the system will bring a dialog box to tell you the function is busy. Please close the sub-functions in other scenarios and reopen the corresponding function in the example program, and then you will find it can work normally.

Invalid physical channel format

If the physical channel format is invalid, it means the string format where the physical channel is connected is wrong. Please search the physical channel format (DemoDevice, BID#000/ai0), and modify the physical channel format according to the corresponding device.

How to make sure the data are correct when reading and outputting sample point data.

No matter reading or outputting sample point data, keep 2D U16, 2D U32 to unscaled. As the DAQNavi LabVIEW driver reads or outputs data from mixed channels, the result that one row represents one channel can be acquired by detaching. Also, make sure the read version is consistent with the data size of the current device, or the data read may be incorrect.

The logic channels and number of AI are configured by users

When reading sample point data, users can acquire the channel number of the current task by the Channel Count of DAQNavi Get Property. However, all designated channels of DAQNavi Create Channel are physical channels. For AI, DAQNavi Polymorphic will count the selected logic channels and the number according to the signal type configured by users.

Note: DAQNavi Create Channel VI specifies devices and channel ranges via physical channel terminals and the connection to the physical channel terminals can only be realized via strings. Therefore, please pay more attention to the grammar formant of the physical channel, the specific format is as follows:

  • physical channels name

The name of physical channels includes device tab, module index number (optional) and channel. For instance, if the string of physical channels is DemoDevice BID#/ai0, the device tab is DemoDevice，BID#000, the channel is ai0. The description of the device is the device expression, and users can modify it in the configuration interface of the device.

The channel identification columns are as follows:

Analog Input: ai, Analog Output: ao, Digital Input/Output: port, Counter Input/Output: cntr.

Default module index number is 0. Users don’t have to provide it except for PCI-1780. For counter, the device has two modules. If users want to use the function of the module 1, then its index number needs to be specified, such as PCI-1780,BID#0/module1/cntr0.

The channel consists of channel expression and physical channel number, such as ai0,cntr1,port0.

  • physical channels range

So as to specify the physical channels and range, two channel numbers need to be divided by ':', such as DemoDevice,BID#000/ai0:3, DemoDevice,BID#000/ai0:1.

  • physical channels list

Please use ',' to divide the physical channels name from physical channels list, such as DemoDevice,BID#000/ai0,DemoDevice,BID#000/ai1.

The physical channel control lists all devices in the machine, and lists the channels according to the I/O types for users to use conveniently.


Device Support

DAQNavi LabVIEW Driver is applicable to the equipment supported by DAQNavi SDK to perform the data acquisition task via Advantech data acquisition card.

Device Type | Analog Input | Analog Output | Digital Input/Output | Counter
PCI-1706U | √ | √ | √ | √
PCI-1710 | √ | √ | √ | √
PCI-1710HG | √ | √ | √ | √
PCI-1710HGL | √ |  | √ | √
PCI-1710L | √ |  | √ | √
PCI-1711 | √ | √ | √ | √
PCI-1711L | √ |  | √ | √
PCI-1712 | √ | √ | √ | √
PCI-1712L | √ |  | √ | √
PCI-1713 | √ |  |  |
PCI-1714 | √ |  |  |
PCI-1715U | √ |  |  |
PCI-1716 | √ | √ | √ | √
PCI-1718 | √ | √ | √ | √
PCI-1720 |  | √ |  |
PCI-1721 |  | √ | √ | √
PCI-1723 |  | √ | √ |
PCI-1724U |  | √ |  |
PCI-1727U |  | √ | √ |
PCI-1730U |  |  | √ |
PCI-1733 |  |  | √ |
PCI-1734 |  |  | √ |
PCI-1735U |  |  | √ | √
PCI-1737U |  |  | √ |
PCI-1739U |  |  | √ |
PCI-1741U | √ | √ | √ | √
PCI-1742U | √ | √ | √ | √
PCI-1747U | √ |  |  |
PCI-1750/SO |  |  | √ | √
PCI-1751 |  |  | √ | √
PCI-1752/USO |  |  | √ |
PCI-1753 |  |  | √ |
PCI-1754 |  |  | √ |
PCI-1756 |  |  | √ |
PCI-1757UP |  |  | √ |
PCI-1758UDI |  |  | √ |
PCI-1758UDO |  |  | √ |
PCI-1758UDIO |  |  | √ |
PCI-1760 |  |  | √ | √
PCI-1761 |  |  | √ |
PCI-1762 |  |  | √ |
PCI-1780U |  |  | √ | √
PCI-1784 |  |  | √ | √
USB-4702 | √ | √ | √ | √
USB-4704 | √ | √ | √ | √
USB-4711A | √ | √ | √ | √
USB-4716 | √ | √ | √ | √
USB-4718 | √ |  | √ |
USB-4750 |  |  | √ | √
USB-4751 |  |  | √ | √
USB-4751L |  |  | √ | √
USB-4761 |  |  | √ |
PCM-3718H | √ |  | √ |
PCM-3718HG | √ |  | √ |
PCM-3718HO | √ | √ | √ | √
PCM-3724 |  |  | √ |
PCM-3725 |  |  | √ |
PCM-3730 |  |  | √ |
PCM-3730I |  |  | √ |
PCM-3753I |  |  | √ |
PCM-3761I |  |  | √ |
PCM-3810I | √ | √ | √ | √
PCM-3813I | √ |  |  |
PCL-818HD | √ | √ | √ | √
PCL-818HG | √ | √ | √ | √
PCL-818L | √ |  | √ | √
PCIE-1730 |  |  | √ |
PCIE-1744 | √ |  |  |
PCIE-1751 |  |  | √ | √
PCIE-1752 |  |  | √ |
PCIE-1753 |  |  | √ |
PCIE-1754 |  |  | √ |
PCIE-1756 |  |  | √ |
PCIE-1760 |  |  | √ | √
PCI-1710_ECU | √ | √ | √ | √
PCI-1720_ECU |  | √ |  |
ECU-P1706 | √ |  |  | √
PCIE-1810 | √ | √ | √ | √
PCIE-1816 | √ | √ | √ | √
PCIE-1816H | √ | √ | √ | √
PCIE-1802 | √ |  | √ |
PCIE-1802L | √ |  | √ |
PCIE-1840 | √ |  |  |
PCM-27D24DI |  |  | √ | √
MIC-3714 | √ |  |  |
MIC-3716 | √ | √ | √ | √
MIC-3720 |  | √ |  |
MIC-3723 |  | √ | √ |
MIC-3753 |  |  | √ |
MIC-3756 |  |  | √ | √
MIC-3761 |  |  | √ |
MIC-3780 |  |  | √ | √
MIOe-3810 | √ | √ | √ | √


DAQNavi Assistant Introduction

DAQNavi Assistant简介

DAQNavi Assistant简介

DAQNavi Assistant 是LabVIEW的一个Express VI。通过它，可以在LabVIEW中很容易地操作Advantech DAQ Device。

它可以让用户不需要编程，通过在向导中选择场景，选择设备，配置参数，就可以定制出自己的任务。

DAQNavi Assistant特性

1.配置永久化。所选择场景，设备以及所做的配置会永久化在VI中。并随着程式的执行应用到实体设备上，按照既定的方式完成场景任务。

2.DAQNavi Assistant Express VI的端子根据用户选择场景动态变化。一旦为Express VI实例选择了场景类型，就不能再变更。


DAQNavi Polymophic VI Introduction

DAQNavi Polymorphic VI简介

DAQNavi Polymorphic VI

它是NI LabVIEW下的一个VI库。在Labview 8.6和以后的版本,通过这组VI, 可以操作研华的I/O 板卡开发采集，控制和仿真应用。

DAQNavi Polymorphic VI是基于Task的，Task是一个或多个带有定时、触发以及其他属性的通道集合。从概念上讲，任务表示执行一次测量或产生一次信号。

支持的操作系统

Windows XP；Windows7-32bit；Windows7-64bit；Windows Server 2003-64bit

支持的硬件I/O设备

列在DAQNavi Navigator的 Supported Device的设备。

DAQNavi Polymorphic VI是基于Task的，Task是一个或多个带有定时、触发以及其他属性的通道集合。从概念上讲，任务表示执行一次测量或产生一次信号。例如：用户可以在任务中指明是要测量一次采样、测量N次采样和连续测量。

Task中的每个通道必须具有相同的I/O类型，也就是说，你可以建立包含多个通道的AD采集任务或者DA输出任务，但是不能建立同时包括AD和DA的任务，因为它们的I/O类型是完全不同的。

DAQNavi I/O 类型列表如下：

  • Analog Input

  • Analog Output

  • Digital Input

  • Digital Output

  • Counter Input

  • Counter Output

DAQNavi Task中包含一个device, 也就是说一个Task中只能操作一个设备。并且要求通道范围是连续的。需要特殊注意的是，Counter类型Task中只能包含一个Counter Channel.

Task实质上是一个运行描述文件，用来描述设备如何完成task指定的功能。

下图展示了DAQNavi Polymorphic VI 的DAQNavi Task State Model。

Figure1-1：DAQNavi Task State Model

一、Idle

通过Create Channel VI新创建出的Task的初始状态都是Idle, 在这一状态用户可以设置Channel, Timing, trigger和DAQNavi Set Property相关的参数。

二、Ready

n 通过调用DAQNavi Control Task, 动作传为Prepare, 可将用户参数设置到设备上。

n 用户需要用DAQNavi Get Property获取某一属性值，以获得当前device状态。内部将用户先前的配置先设置到设备上，并将Task状态转换为Ready, 然后取得设备当前状态。

n 通过调用DAQNavi Control Task, 动作传为Release , 将状态切回到Idle。

n 通过DAQNavi Set Property设置属性值时，将状态转换为Idle。

三、Running

n 通过调start,将状态转换为Running。

n 通过调stop,将状态转换为Ready。

DAQNavi Control Task VI, Task action包括Prepare, Release动作.先不提供给用户使用，作为内部状态转换用。

DAQNavi Polymorphic VI包含的VI如下：

  • DAQNavi Create Channel

  • DAQNavi Read

  • DAQNavi Write

  • DAQNavi Timing

  • DAQNavi Trigger

  • DAQNavi Start Task

  • DAQNavi Stop Task

  • DAQNavi Clear Task

  • DAQNavi Is Task Done

  • DAQNavi Get Property

  • DAQNavi Set Property

  • DAQNavi Wait Until Done

  • DAQNavi Property Assistant